QSK19G Generator Set Control System K

Last Modified: 30 October 2018

Copyright © 2018
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Shutdown SRT: | Electronic Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the ECM related to memory hardware failures or internal ECM voltage supply circuits. | The engine will shut down.
CM558 or CM700 (CM700 shown)

Circuit Description

The CM558 and CM700 are electronic control modules that are responsible for engine control, diagnostics, and user features.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal CM558 or CM700 problem.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 21-Jul-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Warning SRT: | Engine Magnetic Crankshaft Speed/Position Lost One or Two Signals - Abnormal Rate of Change. The ECM has lost one of the two speed/position signals. | The engine will continue to run. Engine performance can be affected.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual coil circuit that provides the engine speed signal to the CM700 through the engine harness.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

If the problem occurs only at a certain engine temperature, be sure to check the engine speed sensor circuit while the engine is at that particular temperature.

Check for the correct air gap between the engine speed sensor and the flywheel.

Refer to Troubleshooting Fault Code t05-121


Operator Interface Mode Transition to Emergency Stop (due to Remote E-Stop) - Condition Exists

FAULT CODE 1434

Operator Interface Mode Transition to Emergency Stop (due to Remote E-Stop) - Condition Exists

Printable Version Printable Version

Overview

Operator Interface Mode Transition to Emergency Stop (due to Remote E-Stop) - Condition Exists

CODE | REASON | EFFECT
Fault Code: 1434 PID: S151 SPN: 611 FMI: 11/31 LAMP: Stop/Shutdown SRT: | Operator Interface Mode Transition to Emergency Stop (due to Remote E-Stop) - Condition Exists. Operator interface mode transition to emergency stop (due to remote E-Stop). | Engine will shut down and will not restart until the remote emergency stop switch has been reset.
Emergency Stop Circuit

Circuit Description

The remote emergency stop switches are used by the operator to initiate an Emergency Stop if an emergency condition exists.

Component Location

Refer to Procedure 100-002 in Section E.

NOTE: The location of some remote emergency stop switches will be site specific. Operators and service technicians must locate these switches before commencing work or operating the generator set.

Refer to Troubleshooting Fault Code t05-1434


Alternator Short Circuit (on GenSet) - Condition Exists

FAULT CODE 1445

Alternator Short Circuit (on GenSet) - Condition Exists

Printable Version Printable Version

Overview

Alternator Short Circuit (on GenSet) - Condition Exists

CODE | REASON | EFFECT
Fault Code: 1445 PID: SPN: 2448 FMI: 11/31 LAMP: Stop/Shutdown SRT: | Alternator Short Circuit (on GenSet) - Condition Exists. A short circuit exists within the alternator or on its associated circuits. | The generator set will shut down.
Alternator Circuit
PCS/CM700 Comms Circuit

Circuit Description

The alternator converts the mechanical energy produced by the engine into electrical energy. The PowerCommand® Supervisor (PSC) monitors the performance and operation of the alternator. The threshold for short circuit condition is 175 percent of rated.

The PCS transmits this data to the CM700 via a RS485 Profibus Data Link. The generator control system will inform the operator that a short circuit condition exists in the generator set alternator output circuit by displaying a fault code (322) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1445).

The fault codes must be cleared on both control systems before the generator set can be restarted.

Component Location

Use the customer/facility/installation documentation for diagrams on the generator set/electric bus setup. For the location of the generator components, use the following procedure. Refer to Procedure 100-002 in Section E.

Shop Talk

Check the load and load lead connections. The electronic service tool required for the diagnostic checks is InPower™ (for PCS) and INSITE™ electronic service tool (for ECM).

Refer to Troubleshooting Fault Code t05-1445


Generator AC Output Voltage - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 1446

Generator AC Output Voltage - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Generator AC Output Voltage - Data Valid but Above Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 1446 PID: SPN: 2444 FMI: 1 LAMP: Stop/Shutdown SRT: | Generator AC Output Voltage - Data Valid but Above Normal Operational Range - Most Severe Level. Generator AC output voltage is high. | Generator set will shut down.
Generator Circuit
PCS/CM700 Comms Circuit

Circuit Description

The generator set produces electrical power. This power is in the form of three-phase AC. The PowerCommand® Supervisor (PCS) monitors the performance and operation of the generator set. The threshold for a high AC output voltage condition is that one or more of the phase voltages has exceeded 130 percent of nominal or has exceeded 110 percent of nominal for at least 10 seconds. The PCS generates a fault code (301) to inform the operator when the generator set AC output voltage is high.

The PCS transmits this data to the CM700 via a Profibus Data Link. The Generator control system will inform the operator that a high AC voltage output condition exists in the generator set alternator output circuit by displaying a fault code (301) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1446).

The fault codes must be cleared on both control systems before the generator set can be restarted.

Component Location

Use the customer/facility/installation documentation for diagrams on the generator set/electric bus setup. For the location of the generator components use the following procedure. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault can be caused by a failed voltage regulator, PT/CT (A36) board, open circuit, or short circuit in one of the harnesses.

If the voltages at the output leads of the alternator do not correspond to the voltages read by the electronic service tool, the problem can be in the voltage sensing circuits.

At idle, if the electronic service tool shows greater than residual voltages from the alternator, the problem can be with either the PMG, field wiring, or voltage regulator (A37). If connector 10 and the AC output voltage drops to residual, the problem is with the voltage regulator (A37). If the voltage does not drop, the problem is with the PMG or field wiring.

The electronic service tool required for the diagnostic checks is InPower™ (for PCS) and INSITE™ electronic service tool (for ECM).

Refer to Troubleshooting Fault Code t05-1446


Generator AC Output Voltage - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 1447

Generator AC Output Voltage - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Generator AC Output Voltage - Data Valid but Below Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 1447 PID: SPN: 2444 FMI: 1 LAMP: Stop/Shutdown SRT: | Generator AC Output Voltage - Data Valid but Below Normal Operational Range - Most Severe Level. Generator AC output voltage is low. | Generator set will shut down.
Generator Circuit
PCS/CM700 Comms Circuit

Circuit Description

The generator set produces electric power. This power is in the form of three-phase AC. The PowerCommand® Supervisor (PCS) monitors the performance and operation of the generator set. The threshold for a low AC output voltage condition is that one or more of the phase voltages has dropped below 85 percent of nominal for at least 10 seconds.

The PCS uses this fault code to tell the operator when he generator set AC output voltage is low.

The PCS transmits this data to the CM700 via a Profibus data link. Therefore, the generator control system will inform the operator that a low AC voltage condition exists in the generator set alternator output circuit by displaying a fault code (303) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1447).

The fault codes must be cleared on both control systems before the generator set can be restarted.

Component Location

For diagrams on the generator set/electrical bus setup, use the customer/facility/installation documentation. For the location of the generator components use the following procedure. Refer to Procedure 100-002 in Section E.

Shop Talk

If output voltage is low, the control can not drive the output voltage high enough. This fault can be caused by a damaged voltage regulator (A34), PT/CT (A36) board, bad PMG on field wirings, or an open or short circuit in one of the harnesses.

If the voltages at the output leads of the alternator are significantly higher than the voltages read by the electronic service tool, the problem can be in the voltage sensing circuits.

If the voltage regulator (A37) is getting B positive (+). but the isolated supply LED is not illuminated, the problem is with the voltage regulator (A37).

Refer to Troubleshooting Fault Code t05-1447


Generator AC Output Frequency - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 1448

Generator AC Output Frequency - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Generator AC Output Frequency - Data Valid but Below Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 1448 PID: SPN: 2436 FMI: 1 LAMP: Stop/Shutdown SRT: | Generator AC Output Frequency - Data Valid but Below Normal Operational Range - Most Severe Level. Generator AC output frequency is low. | Generator set will shut down.
Generator Set

Circuit Description

The generator set produces electrical power. This power is in the form of three-phase AC. The PowerCommand® Supervisor (PCS) monitors the performance and operation of the generator set.

The threshold for a low AC output frequency condition is that the engine speed has dropped below 90 percent of nominal for at least 10 seconds.

The PCS generates a fault code (313) to inform the operator when the generator set AC output frequency output is low.

The PCS transmits generator set data to the CM700 via a Profibus data link. The generator control system will inform the operator that a low AC output frequency condition exists in the generator set output circuit by displaying a fault code (313) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1448).

The fault codes must be cleared on both control systems before the generator set can be restarted.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Check the fuel supply, intake air supply and generator set load (overload).

The electronic service tools required for diagnostic checks are InPower™ (for PCS) and INSITE™ electronic service tool (for engine/ECM).

Refer to Troubleshooting Fault Code t05-1448


Generator Circuit Breaker Status Failed to Close - Condition Exists

FAULT CODE 1452

Generator Circuit Breaker Status Failed to Close - Condition Exists

Printable Version Printable Version

Overview

Generator Circuit Breaker Status Failed to Close - Condition Exists

CODE | REASON | EFFECT
Fault Code: 1452 PID: SPN: 3545 FMI: 11/31 LAMP: Stop/Shutdown SRT: | Generator Circuit Breaker Status Failed to Close - Condition Exists. Generator circuit breaker failed to close. | Generator set will shut down.
Generator Set Circuit Breaker Circuit (Customer Wiring Harness)

Circuit Description

The generator set circuit breaker is the switch for the generator set's connection to the bus. The circuit breaker opens when events have occurred, which forces the generator set to disconnect from the bus. The circuit breaker closes when the generator set is to be connected to the system bus.

The PowerCommand® Supervisor (PCS) transmits generator set data to the CM700 via a Profibus data link. The generator control system will inform the operator that the generator set circuit breaker has failed to close by displaying a fault code (226) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1452).

The fault codes must be cleared on both control systems before the generator set can be restarted.

Component Location

For the location of the generator set circuit breakers, use the customer/facility/installation documentation.

For the generator set component locations, Refer to Procedure 100-002 in Section E.

Shop Talk

Verify that the charging mechanism of the paralleling breaker is functioning correctly.

Check the closed signal to the breaker.

Verify that the auxiliary contact signals from the breaker to PCS are operational.

The electronic service tools required for diagnostic checks are InPower™(for PCS) and INSITE™ electronic service tool (for engine/ECM).

Refer to Troubleshooting Fault Code t05-1452


Generator Synchronizing to Electric Bus Failed - Condition Exists

FAULT CODE 1457

Generator Synchronizing to Electric Bus Failed - Condition Exists

Printable Version Printable Version

Overview

Generator Synchronizing to Electric Bus Failed - Condition Exists

CODE | REASON | EFFECT
Fault Code: 1457 PID: SPN: 2529 FMI: 11/31 LAMP: Warning SRT: | Generator Synchronizing to Electric Bus Failed - Condition Exists. Generator synchronizing to electric bus failed. | Generator set will continue to run, but will not pick up load.
Generator Circuit
PCS/CM700 Comms Circuit

Circuit Description

The generator set picks up the electrical load from the system bus. For the generator set to connect to a bus (other than a dead bus), it must match, with a threshold, the voltage and frequency of the bus. The generator set can not connect to the bus while voltage and frequency are outside the threshold; otherwise, damage can occur to the generator set.

The PowerCommand® Supervisor (PCS) transmits this data to the CM700 via a Profibus data link. The generator set control system will inform the operator that the generator set has failed to synchronize by displaying a fault code (224) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1457).

The fault codes must be cleared on both control systems before the generating set can be restarted.

Component Location

For the location of the generator set circuit breakers, use the customer/facility/installation documentation.

For the generator set component locations, Refer to Procedure 100-002 in Section E.

Shop Talk

Check the PCS for correct setup.

Check the synchronizing parameters for correct setup.

Check the fuel system for problems that can cause instability.

The electronic service tools required for diagnostic checks are InPower™(for PCS) and INSITE™ electronic service tool (for engine/ECM).

Refer to Troubleshooting Fault Code t05-1457


Generator and Electric Bus Phase Sequences Differ - Condition Exists

FAULT CODE 1458

Generator and Electric Bus Phase Sequences Differ - Condition Exists

Printable Version Printable Version

Overview

Generator and Electric Bus Phase Sequences Differ - Condition Exists

CODE | REASON | EFFECT
Fault Code: 1458 PID: SPN: 2516 FMI: 11/31 LAMP: Warning SRT: | Generator and Electric Bus Phase Sequences Differ - Condition Exists. The generator set and system electric bus phase sequences differ. | The generator set will continue to run, but will not synchronize and pick up load.
Generator Circuit
PCS/CM700 Comms Circuit

Circuit Description

The generator set picks up the electrical load from the bus. For the generator to connect to a bus (other than a dead bus), it must match, in phase sequences as well as with a threshold, the voltage and frequency of the bus. The generator set can not connect to the bus while voltage and frequency are outside the threshold, or the phase sequences of the generator set do not match the electric bus; otherwise, damage can occur to the generator set.

The PowerCommand® Supervisor (PCS) transmits this data to the CM700 via a Profibus data link. The generator set control system will inform the operator that the generator set has failed to synchronize by displaying a fault code (270) phase rotation on the PCS alpha numeric display, as well as the CM700 generating a fault code (1458).

The fault codes must be cleared on both control systems before the generating set can be restarted.

The alarm condition of this fault is configured with the PCS front panel, or by connecting the PCS electronic service tool - InPower™. The operator can set this fault code to either WARNING, in which case the generator set will continue to run but will not take load, or SHUTDOWN, in which case the generator set will shut down. The factory default for this fault code is set to WARNING.

Component Location

Use the following procedure for location of the ECM card cage. Refer to Procedure 100-002 in Section E.

Go to customer/facility/installation documentation for the location of the generator set circuit breaker and interface with the electric bus.

Shop Talk

Check the bus feedback wires to the bus PT.

Verify phase rotation of generator and the system bus.

The electronic service tools required for the diagnostic checks is InPower™ (for PCS) and INSITE™ electronic service tool (for ECM).

Refer to Troubleshooting Fault Code t05-1458


Generator is Absorbing Power from the Electric Bus - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 1459

Generator is Absorbing Power from the Electric Bus - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Generator is Absorbing Power from the Electric Bus - Data Valid but Below Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 1459 PID: SPN: 4252 FMI: 1 LAMP: Stop/Shutdown SRT: | Generator is Absorbing Power from the Electric Bus - Data Valid but Below Normal Operational Range - Most Severe Level. Reverse kW detected (generator is absorbing voltage from the electric bus). | The generator set will shut down.
Generator Circuit
PCS/CM700 Comms Circuit

Circuit Description

Under normal operating conditions, the generator set connects to the system electric bus and produces electrical power. This power is in the form of three phase AC. When the generator set is connected to the system electric bus, power is added (exported) to the main electric bus. When some events occur, a condition can occur when the generator set is no longer producing power for the electric bus, but is instead drawing/absorbing power from the electric bus. The condition is call reverse kW or reverse power. The PowerCommand® Supervisor (PCS) monitors the performance and operation of the generator set. When reverse kW/power is detected, the PCS generates a fault code (335) to inform the operator that the generator set is absorbing power from the electric bus.

The PCS transmits this data to the CM700 via a Profibus data link. The generator set control system will inform the operator that the generator set is absorbing power from the system bus by displaying a fault code (335) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1459).

The fault codes must be cleared on both control systems before the generator set can be restarted.

Component Location

Use the following procedure for location of the ECM card cage. Refer to Procedure 100-002 in Section E.

Go to customer/facility/installation documentation for the location of the generator set circuit breaker and interface with the electric bus.

Shop Talk

The system (electric bus) is driving the engine using the alternator as a motor.

If the problem occurs at initial start-up, verify proper connection of the generator's current transformers.

Verify correct connection of load-sharing lines.

Verify that the generator is operating at the correct frequency and voltage.

Verify that there are no new fuel system problems that are causing the engine not to be able to pick up the load.

The electronic service tool required for the diagnostic checks is InPower™ (for PCS) and INSITE™ electronic service tool (for ECM).

Refer to Troubleshooting Fault Code t05-1459


AC Output Current - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1471

AC Output Current - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

AC Output Current - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 1471 PID: SPN: 2448 FMI: 16 LAMP: Warning SRT: | AC Output Current - Data Valid But Above Normal Operating Range - Moderately Severe Level. AC output current has exceeded the WARNING threshold for high current | The Generator Set will continue to run.
Generator Circuit
PCS/CM700 Comms Circuit

Circuit Description

Under normal operating conditions, the generator set connects to the system electric bus and produces electrical power. This power is in the form of three-phase AC. The PowerCommand® Supervisor (PCS) monitors the performance and operation of the generator set. When high AC current has exceeded 110 percent of rated for at least 60 seconds, the PCS generates a fault code (320) to inform the operator that the generator set is producing high AC current and has passed the WARNING threshold.

The PCS transmits this data to the CM700 via a Profibus data link. The generator set control system will inform the operator that the generator set is absorbing power from the system bus by displaying a fault code (320) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1471).

The fault codes must be cleared on both control systems before the generator set can be restarted.

Component Location

Refer to Procedure 100-002 in Section E.

Go to customer/facility/installation documentation for diagrams on the generator set and electric bus setup.

Shop Talk

The alternator is beginning to become overloaded. The AC output current has passed the calibrated threshold for a WARNING level.

Verify correct connection of load-sharing lines.

Verify that the generator set is operating at the correct frequency and voltage.

The electronic service tool required for the diagnostic checks is InPower™ (for PCS) and INSITE™ electronic service tool (for ECM).

Refer to Troubleshooting Fault Code t05-1471


AC Output Current - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1472

AC Output Current - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

AC Output Current - Data Valid But Above Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 1472 PID: SPN: 2448 FMI: 0 LAMP: Stop/Shutdown SRT: | AC Output Current - Data Valid But Above Normal Operating Range - Most Severe Level. AC output current has exceeded the SHUTDOWN threshold for high current | The Generator Set will shutdown.
Generator Circuit
PCS/CM700 Comms Circuit

Circuit Description

Under normal operating conditions, the generator set connects to the system electric bus and produces electrical power. This power is in the form of three-phase AC. The PowerCommand® Supervisor (PCS) monitors the performance and operation of the generator set. When high AC current has exceeded 110 percent of rated for at least 120 seconds, the PCS generates a fault code (321) to inform the operator that the generator set is producing high AC current and has passed the SHUTDOWN threshold.

The PCS transmits this data to the CM700 via a Profibus data link. The generator set control system will inform the operator that the generator set is absorbing power from the system bus by displaying a fault code (321) on the PCS alpha numeric display, as well as the CM700 generating a fault code (1472).

The fault codes must be cleared on both control systems before the generator set can be restarted.

Component Location

Refer to Procedure 100-002 in Section E.

Go to customer/facility/installation documentation for diagrams on the generator set and electric bus setup.

Shop Talk

The alternator is beginning to become overloaded. The AC output current has passed the calibrated threshold for a SHUTDOWN level.

Verify correct connection of load-sharing lines.

Verify that the generator set is operating at the correct frequency and voltage.

The electronic service tool required for the diagnostic checks is InPower™ (for PCS) and INSITE™ electronic service tool (for ECM).

Refer to Troubleshooting Fault Code t05-1472


Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists

FAULT CODE 1474

Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists

Printable Version Printable Version

Overview

Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists

CODE | REASON | EFFECT
Fault Code: 1474 PID: SPN: 520211 FMI: 31 LAMP: Shutdown SRT: | Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists. The ECM has detected a software version conflict on one or more modules. | The engine will not be allowed to start.
Electronic Service Tool

Circuit Description

The CM700 and CM558 each require software, often referred to as calibrations, to perform control functions and provide engine protection.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The ECM function and control can change with software versions. The electric service tool and ECM perform automatic checks to make certain the CM700 and CM558 software versions are compatible. If the ECM automatic check identifies incompatible software, Fault Code 1474 will be activated.

Refer to Troubleshooting Fault Code t05-1474


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Warning SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | No engine protection for the intake manifold air temperature. Possible reduced engine performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the CM558 to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the CM558 for engine protection, timing, and fueling control.

If the voltage is high, the CM558 will log Fault Code 153. High voltage can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Use the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-153


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Warning SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage at intake manifold temperature circuit. | No engine protection for the intake air manifold temperature. Possible reduced engine performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the CM558 to monitor the temperature of the air intake manifold downstream of the aftercooler element. The intake manifold temperature is used by the CM558 for engine protection, timing, and fuel control.

If the voltage is low the CM558 will log Fault Code 154. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded, damaged sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Use the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-154


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Stop/Shutdown SRT: | Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. The intake manifold temperature has exceeded the high critical threshold. | The engine will shut down.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is used by the CM558 to monitor the temperature of the air in the intake manifold after the aftercooler. The intake manifold temperature sensor is used by the CM558 for engine protection, timing, and fueling control.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold temperature has exceeded the critical threshold.

Refer to Troubleshooting Fault Code t05-155


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 175

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 175 PID: SPN: 3464 FMI: 3 LAMP: Stop/Shutdown SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal, or Shorted to High Source. High frequency detected on the throttle actuator return pin on the main harness CM558 connector. | No effect on engine performance.
Throttle Actuator Position Circuit

Circuit Description

The throttle actuator circuit consists of the throttle driver and the CM558. The throttle driver receives a 24-VDC pulse-width modulated commanded position signal from the CM558.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the throttle driver are tight. The connections are made on the terminal strips inside the throttle driver box. To access them, it is necessary to remove the cover on the throttle driver.

Refer to Troubleshooting Fault Code t05-175


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 176

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 176 PID: SPN: 3464 FMI: 4 LAMP: Stop/Shutdown SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal, or Shorted to Low Source. Low frequency detected on the throttle actuator return pin on the main harness CM558 connector. | No effect on engine performance.
Throttle Actuator Position Circuit

Circuit Description

The throttle actuator circuit consists of the throttle driver and the CM558. The throttle driver receives a 24-VDC pulse-width modulated commanded position signal from the CM558.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the throttle driver are tight. The connections are made on the terminal strips inside the throttle driver box. To access them, it is necessary to remove the cover on the throttle driver.

Refer to Troubleshooting Fault Code t05-176


Engine Electronic Fuel Valve 1 Position - Data Erratic, Intermittent or Incorrect

FAULT CODE 1761

Engine Electronic Fuel Valve 1 Position - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

Engine Electronic Fuel Valve 1 Position - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 1761 PID: S018 SPN: 1442 FMI: 2 LAMP: Shutdown SRT: | Engine Electronic Fuel Valve 1 Position - Data Erratic, Intermittent or Incorrect. The fuel control valve position feedback is not responding to commands from the ECM. The valve is stuck. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The fuel control valve position circuit consists of the commanded position signal from the CM558 and feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve command position signal is supplied by the CM558. The position signal is a 24-VDC pulse-width modulated signal and the feedback is a 0 to 5-VDC signal.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel control valve commanded signal and the feedback signal can be monitored using the electronic service tool. The fuel control valve is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to make sure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the fault code for the mechanically stuck valve will be set.

Refer to Troubleshooting Fault Code t05-1761


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

CODE | REASON | EFFECT
Fault Code: 177 PID: P051 SPN: 3464 FMI: 7 LAMP: Stop/Shutdown SRT: | Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment. The Throttle Plate position feedback is not responding to commands from the ECM. The actuator or butterfly plate is stuck. | The engine will shutdown.
Throttle Plate Circuit

Circuit Description

The Throttle Actuator Circuit consists of the Throttle Driver and the CM558. The throttle driver receives a 24-VDC pulse-width modulated commanded position signal from the CM558. The position feedback signal from the throttle driver is also a 0 to 5-VDC signal.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The throttle plate commanded signal and the feedback signal can be monitored using the electronic service tool. The throttle plate is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the throttle actuator fault will be set.

Always verify that the cable connections on the throttle driver are tight.

The connections at the throttle driver are terminal strips located inside the driver. The cover must be remove to access them.

Refer to Troubleshooting Fault Code t05-177


Engine Gas Control Valve Inlet Pressure - Voltage Above Normal, or Shorted to High Source

FAULT CODE 1827

Engine Gas Control Valve Inlet Pressure - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Engine Gas Control Valve Inlet Pressure - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 1827 PID: SPN: 1390 FMI: 3 LAMP: Warning SRT: | Engine Gas Control Valve Inlet Pressure - Voltage Above Normal, or Shorted to High Source. High voltage detected on the fuel delivery pressure sensor signal pin of the main harness CM558 connector A. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit for Option FM4701 on Generator Set Model GFBA
Fuel Delivery Pressure Sensor Circuit for Option FM4704 on Generator Set Model GFBE

Circuit Description

The fuel delivery pressure sensor monitors the engine gas pressure before it enters the fuel control valve. This pressure is monitored by the left bank CM558. High voltage will cause Fault Code 1827 and can be caused by shorts in the supply, signal or return wires, an open in the return wire, or a damaged sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure is the regulated input gas pressure to the engine. It is typically regulated to approximately 150 mBar [2.2 psi].

Fuel delivery pressure will be 0 mBar [0 psi] while the engine is cranking during the purge cycle. Fuel delivery pressure must rise as soon as the fuel shutoff valve opens.

Refer to Troubleshooting Fault Code t05-1827


Engine Gas Control Valve Inlet Pressure - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1828

Engine Gas Control Valve Inlet Pressure - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Engine Gas Control Valve Inlet Pressure - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 1828 PID: SPN: 1390 FMI: 4 LAMP: Warning SRT: | Engine Gas Control Valve Inlet Pressure - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the fuel delivery pressure sensor signal pin of the main harness CM558 connector A. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit for Option FM4701 on Generator Set Model GFBA
Fuel Delivery Pressure Sensor Circuit for Option FM4704 on Generator Set Model GFBE

Circuit Description

The fuel delivery pressure sensor monitors the engine gas pressure before it enters the fuel control valve. This pressure is monitored by the CM558. Low voltage will cause Fault Code 1828 and can be caused by shorts in the supply, signal or return wires, an open in the return wire, or a damaged sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure is the regulated input gas pressure to the engine. It is typically regulated to approximately 150 mBar [2.2 psi].

Fuel delivery pressure will be 0 mBar [0 psi] while the engine is cranking during the purge cycle. Fuel delivery pressure must rise as soon as the fuel shutoff valve opens.

Refer to Troubleshooting Fault Code t05-1828


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent or Incorrect

FAULT CODE 1837

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 1837 PID: S064 SPN: 723 FMI: 2 LAMP: Stop/Shutdown SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent or Incorrect. Invalid engine speed signal detected on the Engine Speed/Position Sensor signal pins of the main harness CM558 connector. | Engine will shut down, or if not running, the engine will not start.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine speed/position sensor monitors the engine speed by reading a pattern of raised ribs on the back of the camshaft gear.

There are six evenly spaced ribs, one for each cylinder, and a seventh that indicates the start of the firing sequence.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Check the air gap of the sensor over the camshaft gear. Make sure to set the gap over one of the raised ribs.

Refer to Troubleshooting Fault Code t05-1837


Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 187 PID: SPN: 3510 FMI: 4 LAMP: Warning SRT: | Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source. Sensor supply 2 circuit signal is shorted low. | Possible reduced engine performance or shutdown. Pressure sensor shorted low faults likely.
Sensor Supply 2 Circuit

Circuit Description

Sensor supply 2 circuit from the ECM supplies multiple engine pressure sensors with a positive (+) 5-VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Use the engine wiring diagram to find sensors that share a common electrical supply or return. A damaged pressure sensor can cause multiple fault codes. A damaged pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-187


Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2188

Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2188 PID: S151 SPN: 724 FMI: 7 LAMP: Warning SRT: | Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected at the oxygen sensor signal pin of the main harness CM558 connector. | Possible reduced performance. Return to open-loop running.
Heated Oxygen Sensor Circuit

Circuit Description

The CM558 uses this sensor to determine the amount of oxygen in the exhaust gas, and then, adjusts the commanded air-fuel ratio.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The heated oxygen sensor heater must be functional for the sensor to work properly. It has a 12-VDC supply, which is separate from the engine control 24-VDC supply.

The engine will run in open-loop when the heated oxygen sensor fault is set. If rough running results, INSITE™ electronic service tool can be used to adjust the open-loop set points.

Refer to Troubleshooting Fault Code t05-2188


Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2192

Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 2192 PID: P151 SPN: 724 FMI: 4 LAMP: Warning SRT: | Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the heated oxygen sensor signal pin of the CM558 harness. | Possible reduced performance. Return to open loop running.
Heated Oxygen Sensor Circuit

Circuit Description

The CM558 uses this sensor to determine the amount of oxygen in the exhaust gas, and then, adjusts the commanded air-fuel ratio.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The heated oxygen sensor heater must be functional for the sensor to work properly. It has a 12-VDC supply, which is separate from the engine control 24-VDC supply.

The engine will run in open-loop when the heated oxygen sensor fault is set. If rough running results, the electronic service tool can be used to adjust the open-loop set points.

Refer to Troubleshooting Fault Code t05-2192


Engine Speed Crank Sync - Abnormal Rate of Change

FAULT CODE 2199

Engine Speed Crank Sync - Abnormal Rate of Change

Printable Version Printable Version

Overview

Engine Speed Crank Sync - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2199 PID: P190 SPN: 190 FMI: 10 LAMP: None SRT: | Engine Speed Crank Sync - Abnormal Rate of Change. Invalid engine speed signal detected on the engine speed sensor signal pins of the main harness CM558 connector. | Engine will shut down, or if not running, the engine will not start.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor monitors the engine speed by reading the teeth on the starter ring gear that is mounted on the flywheel.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Check the air gap of the sensor over the flywheel. Make sure to set the gap over one of the ring gear teeth.

Refer to Troubleshooting Fault Code t05-2199


Fuel Delivery Pressure 1 - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2228

Fuel Delivery Pressure 1 - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Fuel Delivery Pressure 1 - Data Valid but Above Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 2228 PID: P135 SPN: 135 FMI: 0 LAMP: Stop/Shutdown SRT: | Fuel Delivery Pressure 1 - Data Valid but Above Normal Operational Range - Most Severe Level. The fuel delivery pressure has exceeded the high critical threshold. | Engine will shut down.
Fuel Delivery Pressure Sensor Circuit for Option FM4701 on Generator Set Model GFBA
Fuel Delivery Pressure Sensor Circuit for Option FM4704 on Generator Set Model GFBE

Circuit Description

The fuel delivery pressure sensor monitors the engine gas pressure before it enters the fuel control valve. This pressure is monitored by the CM558. Low voltage will cause Fault Code 547 or Fault Code 1828 and can be caused by shorts in the supply, signal or return wires, an open in the return wire, or a damaged sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure is the regulated input gas pressure to the engine. It is typically regulated to approximately 150 mBar [2.2 psi].

Fuel delivery pressure will be 0 mBar [0 psi] while the engine is cranking during the purge cycle. Fuel delivery pressure must rise as soon as the fuel shutoff valve opens.

Refer to Troubleshooting Fault Code t05-2228


Engine Cylinder 5 (A3) Knock Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2235

Engine Cylinder 5 (A3) Knock Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Engine Cylinder 5 (A3) Knock Sensor Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2235 PID: S094 SPN: 1356 FMI: 3 LAMP: Warning SRT: | Engine Cylinder 5 (A3) Knock Sensor Circuit - Voltage Above Normal, or Shorted to High Source. Cylinder number 5 has exceeded the knock threshold. | The engine will shut down.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor the engine for excessive knock or detonation.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Cylinder 5 and cylinder 6 are fitted with a knock sensors. The CM558 monitors all of the knock sensors.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-2235


Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2236

Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 2236 PID: S095 SPN: 1357 FMI: 3 LAMP: Warning SRT: | Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. Cylinder number 6 has exceeded the knock threshold. | The engine will shut down.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor the engine for excessive knock or detonation.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Cylinder 5 and cylinder 6 are fitted with a knock sensors. The CM558 monitors all of the knock sensors.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-2236


Sensor Supply 2 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Sensor Supply 2 Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3 LAMP: Warning SRT: | Sensor Supply 2 Circuit - Voltage Above Normal, or Shorted to High Source. Sensor supply 2 circuit signal is shorted high. | Possible reduced engine performance or shutdown. Pressure sensor shorted high faults likely.
Sensor Supply 2 Circuit

Circuit Description

Sensor supply 2 circuit from the ECM supplies multiple engine pressure sensors with a positive (+) 5-VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires may cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Use the engine wiring diagram to find sensors that share a common electrical supply or return. A damaged pressure sensor can cause multiple fault codes. A damaged pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-227


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

Electronic Fuel Injection Control Valve Circuit - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2311 PID: S018 SPN: 633 FMI: 31 LAMP: Warning SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. Abnormal voltage detected on the fuel control valve signal return pin of the main harness CM558 connector. | Engine performance can be affected.
Fuel Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24-VDC pulse-width modulated signal. An abnormal voltage in the harness or at the fuel control valve connector will cause Fault Code 2311 to be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 must always read an alternating 24-VDC and 0-VDC.

Refer to Troubleshooting Fault Code t05-2311


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0 LAMP: Stop/Shutdown SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level. Engine speed signals indicate an engine speed greater than shutdown threshold. | Engine will shut down. Fuel shutoff valves are de-energized (valves closed).
Engine Speed Sensor Circuit

Circuit Description

The engine/speed position sensor(s) monitor the engine position and the engine speed. They then pass this information to the CM558 and CM700 through the engine harness.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include reverse powering (motoring) of the engine, damaged engine speed/position sensors and sudden decreases in generator load.

Inspect the engine speed/position sensor for damage and check the air gap of the installed sensors.

Refer to Troubleshooting Fault Code t05-234


Sensor Supply 3 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Sensor Supply 3 Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4 LAMP: Warning SRT: | Sensor Supply 3 Circuit - Voltage Below Normal, or Shorted to Low Source. Sensor supply number 3 supply signal is shorted low. | Possible reduced engine performance or shutdown. Gas mass flow sensor shorted low fault likely.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

Sensor supply circuit number 3 from the CM558 module supplies the gas mass flow sensor with a positive (+) 14-VDC supply. A fault on either of these wires can cause multiple sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Use to the circuit art or engine wiring diagram to find sensors that share a common electrical supply or return. A damaged sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-238


Sensor Supply 3 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Sensor Supply 3 Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3 LAMP: Warning SRT: | Sensor Supply 3 Circuit - Voltage Above Normal, or Shorted to High Source. Sensor supply number 3 supply signal is shorted high. | Possible reduced engine performance or shutdown. Gas mass flow sensor shorted high fault likely.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

Sensor supply circuit number 3 from the CM558 module supplies the gas mass flow sensor with a positive (+) 14-VDC supply. A fault on either of these wires may cause multiple sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Use the circuit diagram or engine wiring diagram to find sensors that share a common electrical supply or return. A malfunctioning sensor can cause multiple fault codes. A malfunctioning sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-239


Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2427

Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2427 PID: S305 SPN: 2980 FMI: 3 LAMP: Warning SRT: | Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected on the Fuel Outlet Pressure Sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Fuel Outlet Pressure Sensor Circuit for Option FM4701 on Generator Set Model GFBA
Fuel Outlet Pressure Sensor Circuit for Option FM4704 on Generator Set Model GFBE

Circuit Description

The fuel outlet pressure sensor monitors the gas pressure as it exits the fuel control assembly. The pressure is monitored by the CM558 modules. High voltage will cause Fault Code 2427 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a damaged sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel outlet pressure is the gas pressure after the gas flow has been metered by the fuel control valve. This gas is introduced into the air/fuel mixer to mix with the intake air.

Refer to Troubleshooting Fault Code t05-2427


Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2428

Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 2428 PID: S305 SPN: 2980 FMI: 4 LAMP: Warning SRT: | Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the Fuel Outlet Pressure Sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Fuel Outlet Pressure Sensor Circuit for Option FM4701 on Generator Set Model GFBA
Fuel Outlet Pressure Sensor Circuit for Option FM4704 on Generator Set Model GFBE

Circuit Description

The fuel outlet pressure sensor monitors the gas pressure as it exits the fuel control assembly. The pressure is monitored by the CM558 modules. Low voltage will cause Fault Code 2428 and can be caused by shorts in the supply, signal or return wires, an open in the return wire, or a damaged sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel outlet pressure is the gas pressure after the gas flow has been metered by the fuel control valve. This gas is introduced into the air/fuel mixer to mix with the intake air.

Refer to Troubleshooting Fault Code t05-2428


Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2435

Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

CODE | REASON | EFFECT
Fault Code: 2435 PID: S094 SPN: 1356 FMI: 0/15 LAMP: Warning SRT: | Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level. The engine cylinder 5 knock sensor has detected a knock above normal operating range, least severe level. | The engine will continue to run.
Detonation (Knock) Sensor Circuit

Circuit Description

The electronic control module (ECM) CM558, uses this sensor to monitor the engine for excessive knock or detonation, so it can protect the engine.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Cylinder 5 and cylinder 6 are fitted with a knock sensors. The CM558 monitors all of the knock sensors.

Cylinder 6 ignition timing is set so that it is 2 degrees in advance of cylinders 1 to 5. This is to make sure that, should knock occur, it will occur on this cylinder first.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will continue to run.

Refer to Troubleshooting Fault Code t05-2435


Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2436

Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

CODE | REASON | EFFECT
Fault Code: 2436 PID: S094 SPN: 1357 FMI: 0/15 LAMP: Warning SRT: | Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level. The engine cylinder 6 knock sensor has detected a knock above normal operating range, least severe level. | The engine will continue to run.
Detonation (Knock) Sensor Circuit

Circuit Description

The electronic control module (ECM) CM558, uses this sensor to monitor the engine for excessive knock or detonation, so it can protect the engine.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Cylinder 5 and cylinder 6 are fitted with a knock sensors. The CM558 monitors all of the knock sensors.

Cylinder 6 ignition timing is set so that it is 2 degrees in advance of cylinders 1 to 5. This is to make sure that, should knock occur, it will occur on this cylinder first.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will continue to run.

Refer to Troubleshooting Fault Code t05-2436


Proprietary Data Link - Master Message Lost

FAULT CODE 2444

Proprietary Data Link - Master Message Lost

Printable Version Printable Version

Overview

Proprietary Data Link - Master Message Lost

CODE | REASON | EFFECT
Fault Code: 2444 PID: TBD SPN: TBD FMI: 2 LAMP: Stop/Shutdown SRT: | Proprietary Data Link - Master Message Lost. Erratic, intermittent, or incorrect data was received by the CM558 over the proprietary data link. | Engine will shut down.
Proprietary Data Link Circuit

Circuit Description

The proprietary data link is a high speed data link that carries critical engine operating data.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The proprietary data link can not be interrogated by service tools.

Refer to Troubleshooting Fault Code t05-2444


External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

FAULT CODE 2455

External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

CODE | REASON | EFFECT
Fault Code: 2455 PID: S151 SPN: 3938 FMI: 5 LAMP: Warning SRT: | External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit. Low frequency detected on the speed bias pin of the CM700. | The engine will shut down.
Speed Bias Circuit

Circuit Description

The speed bias input to the CM700 is a 5-VDC pulse-width modulated signal. An open in the speed bias signal or a short to ground will cause Fault Code 2455.

Component Location

Not applicable.

Shop Talk

The pulse-width modulated signal that is sent to the CM700 from the PowerCommand® Supervisor (PCS) must always read a frequency of 3 kHz.

Refer to Troubleshooting Fault Code t05-2455


Engine Starter Mode Before Ready Status - Condition Exists

FAULT CODE 2482

Engine Starter Mode Before Ready Status - Condition Exists

Printable Version Printable Version

Overview

Engine Starter Mode Before Ready Status - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2482 PID: SPN: 1675 FMI: 11/31 LAMP: Shutdown SRT: | Engine Starter Mode Before Ready Status - Condition Exists. A start attempt has been made while a start block condition was active. | The engine will not start.
Start Block Condition

Circuit Description

The starter motor is commanded to run by the CM700. If an attempt is made to start the engine while a start block condition is active, the engine will not start and the start block condition fault will be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Common start block conditions are having the barring gear engaged or attempting to start the engine too quickly after a keyswitch reset.

Refer to Troubleshooting Fault Code t05-2482


Engine Starter Mode Engagement - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2483

Engine Starter Mode Engagement - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

Engine Starter Mode Engagement - Mechanical System Not Responding or Out of Adjustment

CODE | REASON | EFFECT
Fault Code: 2483 PID: SPN: 1675 FMI: 7 LAMP: Stop/Shutdown SRT: | Engine Starter Mode Engagement - Mechanical System Not Responding or Out of Adjustment. The starter motor has been commanded to run and is not running. | The engine will not start.
Continuous Starter Failure

Circuit Description

The starter motor is commanded to run by the CM700. If the CM700 commands the starter to run three times and does not see engine speed during any attempt, the Continuous Starter Failure fault is set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Check the starter connections and batteries to be sure that the connections are tight and that the starting batteries are charged.

Refer to Troubleshooting Fault Code t05-2483


Throttle Position Sensor - Data Erratic, Intermittent or Incorrect

FAULT CODE 2519

Throttle Position Sensor - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

Throttle Position Sensor - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 2519 PID: P051 SPN: 51 FMI: 2 LAMP: Stop/Shutdown SRT: | Throttle Position Sensor - Data Erratic, Intermittent or Incorrect. The throttle plate position feedback is not responding to commands from the ECM. The actuator or butterfly plate is stuck. | The engine will shutdown.
Throttle Plate Circuit

Circuit Description

The throttle actuator circuit consists of the throttle driver and the CM558. The throttle driver receives a 24-VDC pulse-width modulated commanded position signal from the CM558. The position feedback signal from the throttle driver is also a 0 to 5-VDC signal.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The throttle plate commanded signal and the feedback signal can be monitored using the electronic service tool. The throttle plate is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the throttle actuator fault will be set.

Always verify that the cable connections on the throttle driver are tight.

The connections at the throttle driver are terminal strips located inside the driver. The cover must be remove to access them.

Refer to Troubleshooting Fault Code t05-2519


Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2526

Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2526 PID: S094 SPN: 1356 FMI: 16 LAMP: Stop/Shutdown SRT: | Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 5 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Cylinder Number 5 Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an electronic service tool.

The continuous light detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the continuous light detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2526


Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2527

Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2527 PID: S095 SPN: 1357 FMI: 16 LAMP: Stop/Shutdown SRT: | Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 6 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Cylinder Number 6 Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an electronic service tool.

The continuous light detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the continuous light detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2527


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4 LAMP: Stop/Shutdown SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the signal return pin of the fuel control valve. | The engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection. The logic of the vent valve is the opposite of the main fuel shutoff solenoids. When power is provided to open the solenoids, the vent valve is closed (if fitted).

The fuel shutoff valve is often connected as part of the OEM wiring. Be certain to check terminal connections at the valve and also on the engine interface terminal block, TB-31.

Refer to Troubleshooting Fault Code t05-254


Engine ECU Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2544

Engine ECU Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Engine ECU Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 2544 PID: P021 SPN: 1136 FMI: 0 LAMP: Red SRT: | Engine ECU Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. The ECM internal temperature has exceeded the high shutdown threshold. | The engine will shut down.
Electronic Control Module (ECM)

Circuit Description

The CM700 and CM558 each contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the ECM in the event of excessive temperature.

Refer to Troubleshooting Fault Code t05-2544


CAN Slave Msg 2 Lost Error - Data Erratic, Intermittent or Incorrect

FAULT CODE 2548

CAN Slave Msg 2 Lost Error - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CAN Slave Msg 2 Lost Error - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 2548 PID: TBD SPN: TBD FMI: 2 LAMP: Stop/Shutdown SRT: | CAN Slave Msg 2 Lost Error - Data Erratic, Intermittent or Incorrect. Data was received by the CM558 from the other CM558 over the proprietary data link. | Engine will shut down.
Proprietary Data Link Circuit

Circuit Description

The proprietary data link is a high speed datalink that carries critical engine operating data.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The proprietary data link can not be interrogated by the electronic service tools.

Refer to Troubleshooting Fault Code t05-2548


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 255 PID: S017 SPN: 632 FMI: 3 LAMP: Warning SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected at the signal return pin of the fuel control valve. | The engine will continue running.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection. The logic of the vent valve is the opposite of the main fuel shutoff solenoids. When power is provided to open the solenoids, the vent valve is closed (if fitted).

The fuel shutoff valve is often connected as part of the OEM wiring. Be sure to check terminal connections at the valve and also on the engine interface terminal block, TB-31.

Refer to Troubleshooting Fault Code t05-255


Engine Network Master Slave Communication - Data Erratic, Intermittent or Incorrect

FAULT CODE 2768

Engine Network Master Slave Communication - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

Engine Network Master Slave Communication - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 2768 PID: SPN: 520334 FMI: 2 LAMP: Shutdown SRT: | Engine Network Master Slave Communication - Data Erratic, Intermittent or Incorrect. Erratic, intermittent, or incorrect data was received by the CM558 over the proprietary data link. | Engine will shut down.
Proprietary Data Link Circuit

Circuit Description

The proprietary data link is a high speed data link that carries critical engine operating data.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The proprietary data link can not be interrogated by service tools.

Refer to Troubleshooting Fault Code t05-2768


Engine Network Slave Message - Data Erratic, Intermittent or Incorrect

FAULT CODE 2769

Engine Network Slave Message - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

Engine Network Slave Message - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 2769 PID: SPN: 520335 FMI: 2 LAMP: Shutdown SRT: | Engine Network Slave Message - Data Erratic, Intermittent or Incorrect. Erratic, intermittent, or incorrect data was received by the CM558 from the other CM558 over the proprietary data link. | Engine will shut down.
Proprietary Data Link Circuit

Circuit Description

The proprietary data link is a high speed data link that carries critical engine operating data.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The proprietary data link can not be interrogated by service tools.

Refer to Troubleshooting Fault Code t05-2769


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2864

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2864 PID: SPN: 632 FMI: 3 LAMP: Stop/Shutdown SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected at the signal return pin of the fuel control valve. | The engine will continue running.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by the CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection. The logic of the vent valve is the opposite of the main fuel shutoff solenoids. When power is provided to open the solenoids, the vent valve is closed (if fitted).

The fuel shutoff valve is often connected as part of the OEM wiring. Be sure to check terminal connections at the valve and also on the engine interface terminal block, TB-31.

Refer to Troubleshooting Fault Code t05-2864


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2867

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 2867 PID: SPN: 1442 FMI: 4 LAMP: Warning SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the fuel control valve signal return pin of the main harness CM558 connector. | Engine can suffer from reduced performance and might not be able to achieve full load operation.
Fuel Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24-VDC pulse-width modulated signal. An open circuit in the harness or at the fuel control valve connector will cause Fault Code 2867 to be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 must always read an alternating 24-VDC and 0-VDC.

Refer to Troubleshooting Fault Code t05-2867


Engine Control Module Internal Failure - Special Instructions

FAULT CODE 2994

Engine Control Module Internal Failure - Special Instructions

Printable Version Printable Version

Overview

Engine Control Module Internal Failure - Special Instructions

CODE | REASON | EFFECT
Fault Code: 2994 PID: SPN: 629 FMI: 14 LAMP: Warning SRT: | Engine Control Module Internal Failure - Special Instructions. Error internal to the CM558 or CM700. | No effect on engine performance.
CM558 or CM700 (CM700 shown)

Circuit Description

The CM558 and CM700 are electronic control modules that are responsible for engine control, diagnostics, and user features.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal CM558 or CM700 problem.

Refer to Troubleshooting Fault Code t05-2994


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12 LAMP: Warning SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. Error internal to the CM558. | No effect on engine performance.
CM558 and CM700 (CM700 shown)

Circuit Description

The CM558 and CM700 are electronic control modules that are responsible for engine control, diagnostics, and user features.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal CM558 and CM700 problem.

Refer to Troubleshooting Fault Code t05-346


Sensor Supply 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Sensor Supply 1 Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4 LAMP: Warning SRT: | Sensor Supply 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Sensor supply number 1 supply signal is shorted high. | Possible reduced engine performance or shutdown. Gas mass flow sensor shorted low fault likely.
Sensor Supply Circuit Number 1

Circuit Description

Sensor supply circuit number 1 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5-VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Perform these checks on all interconnecting harness connectors in the circuit. Use the following to find sensors that share a common electrical supply or return. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358. A damaged pressure sensor can cause multiple fault codes. A damaged pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-352


Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 354

Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 354 PID: SPN: 3563 FMI: 3 LAMP: Warning SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High voltage has been detected in the intake manifold pressure 1 sensor circuit. | The engine will shutdown.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors the absolute pressure of the air-to-fuel mixture in the intake manifold. This pressure is monitored by the CM558. High voltage will cause Fault Code 354 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold pressure is required for engine control. The engine will shutdown if the sensor fails.

Refer to Troubleshooting Fault Code t05-354


Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 355

Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: 3563 FMI: 4 LAMP: Warning SRT: | Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the intake manifold pressure sensor signal pin of the main harness CM558 connector. | The engine will shutdown.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors the absolute pressure of the air-to-fuel mixture in the intake manifold. This pressure is monitored by the CM558. Low voltage will cause Fault Code 355 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold pressure is required for engine control. The engine will shutdown if the sensor fails.

Refer to Troubleshooting Fault Code t05-355


Engine Failed Automatic Start - Condition Exists

FAULT CODE 359

Engine Failed Automatic Start - Condition Exists

Printable Version Printable Version

Overview

Engine Failed Automatic Start - Condition Exists

CODE | REASON | EFFECT
Fault Code: 359 PID: S124 SPN: 1664 FMI: 11/31 LAMP: Stop/Shutdown SRT: | Engine Failed Automatic Start - Condition Exists. The engine has not started after a complete starting cycle. | The engine will shut down.
Engine Failed to Start.

Circuit Description

The starter is commanded to run by the CM700. If the engine performs a complete start cycle of cranking and purge attempts without starting, the failed start fault will be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The failed to start fault will cause the start cycle to stop and a shutdown fault will occur. However, as soon as the engine speed reaches zero, after the final purge cycle, the fault will reset and the engine will be ready for another starting cycle.

Refer to Troubleshooting Fault Code t05-359


Sensor Supply 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Sensor Supply 1 Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3 LAMP: Warning SRT: | Sensor Supply 1 Circuit - Voltage Above Normal, or Shorted to High Source. Sensor supply number 1 supply signal is shorted high. | Possible reduced engine performance or shutdown.
Sensor Supply Circuit Number 1

Circuit Description

Sensor supply circuit number 1 from the ECM supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to find sensors that share a common electrical supply or return. A damaged pressure sensor can cause multiple fault codes. A damaged pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-386


SAEJ1587/J1922 Datalink - Data Erratic, Intermittent or Incorrect

FAULT CODE 412

SAEJ1587/J1922 Datalink - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

SAEJ1587/J1922 Datalink - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 SPN: 608 FMI: 2 LAMP: None SRT: | SAEJ1587/J1922 Datalink - Data Erratic, Intermittent or Incorrect. Erratic, intermittent, or incorrect data detected on the SAE J1587/1922 data link | No effect on engine performance.
SAE J1587/1922 Datalink Circuit

Circuit Description

The SAE J1587/1922 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

A selector switch in installed in the generator set control panel that allows for the selection of the module data that will be available on the data link. Be certain that the selector switch is in the appropriate position for the electronic tool configuration.

Refer to Troubleshooting Fault Code t05-412


SAE J1587/1922 Datalink - Abnormal Update Rate

FAULT CODE 414

SAE J1587/1922 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

SAE J1587/1922 Datalink - Abnormal Update Rate

CODE | REASON | EFFECT
Fault Code: 414 PID: S250 SPN: 608 FMI: 9 LAMP: None SRT: | SAE J1587/1922 Datalink - Abnormal Update Rate. An abnormal update rate has been detected on the SAE J1587/1922 data link. | No effect on engine performance.
SAE J1587/1922 Data Link Circuit

Circuit Description

The SAE J1587/1922 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

A selector switch is installed in the generator set control panel that allows for the selection of the module data that will be available on the data link. Be certain the selector switch is in the appropriate position for the electronic tool configuration.

Refer to Troubleshooting Fault Code t05-414


J1939 Network Number 1 - Data Erratic, Intermittent or Incorrect

FAULT CODE 426

J1939 Network Number 1 - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

J1939 Network Number 1 - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | J1939 Network Number 1 - Data Erratic, Intermittent or Incorrect. Erratic, intermittent, or incorrect data detected on the SAE J1939 data link. | No effect on engine performance.
SAE J1939 Data Link Circuit

Circuit Description

The SAE J1939 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The SAE J1939 data link is a network data link on which each ECM is attached via a network stub connection. Be certain that the electronic service tool is set up for J1939 communications (if applicable) when using this data link.

Refer to Troubleshooting Fault Code t05-426


SAE J1939 Data Link - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Data Link - Abnormal Update Rate

Printable Version Printable Version

Overview

SAE J1939 Data Link - Abnormal Update Rate

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9 LAMP: None SRT: | SAE J1939 Data Link - Abnormal Update Rate. An abnormal update rate has been detected on the SAE J1939 data link. | No effect on engine performance.
SAE J1939 Data Link Circuit

Circuit Description

The SAE J1939 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The SAE J1939 data link is a network data link on which each ECM is attached via a network stub connection. Be certain that the electronic service tool is set up for J1939 communications (if applicable) when using this data link.

Refer to Troubleshooting Fault Code t05-427


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Warning SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low voltage has been detected on the battery supply. | ECM voltage supply approaching a level at which unpredictable operation will occur.
Battery Supply Circuit

Circuit Description

The 24-VDC battery circuit provides operating power to the CM558 module. This supply is provided by a 20A DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

This fault is usually caused by loose or corroded connections, a blown fuse or a tripped circuit breaker.

Refer to Troubleshooting Fault Code t05-441


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Warning SRT: | Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. High voltage has been detected on the battery supply. | ECM damage will occur.
Battery Supply Circuit

Circuit Description

The 24-VDC battery circuit provides operating power to the CM558 module. This supply is provided by a 20A DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-442


Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 453

Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 453 PID: P149 SPN: 1241 FMI: 3 LAMP: Warning SRT: | Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected at the gas mass flow sensor pin of the main harness CM558 connector. | Possible reduced engine performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The supply from the CM558 to the gas mass flow sensor is 14-VDC. A short to battery voltage in the harness or at the gas mass flow sensor connector will cause Fault Code 453 to be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The gas mass flow sensor is supplied with 14-VDC from the CM558. The sensor is a hot wire sensor with two wire elements that protrude into the gas flow. The two wires are kept at equal temperatures and the signal, 0 to 5-VDC, indicates the gas flow to the CM558. The 0 to 5-VDC signal corresponds to the voltage necessary to maintain the temperature of the wires due to the cooling affect as the gas flows.

Refer to Troubleshooting Fault Code t05-453


Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 454

Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 454 PID: P149 SPN: 1241 FMI: 4 LAMP: Warning SRT: | Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the gas mass flow sensor pin of the main harness CM558 connector. | Possible reduced engine performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The supply from the CM558 to the gas mass flow sensor is 14 VDC. A short to ground in the harness or at the gas mass flow sensor connector will cause Fault Code 454 to be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The gas mass flow sensor is supplied with 14-VDC from the CM558. The sensor is a hot wire sensor with two wire elements that protrude into the gas flow. The two wires are kept at equal temperatures and the signal, 0 to 5-VDC, indicates the gas flow to the CM558. The 0 to 5-VDC signal corresponds to the voltage necessary to maintain the temperature of the wires due to the cooling affect as the gas flows.

Refer to Troubleshooting Fault Code t05-454


Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 455

Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 455 PID: S018 SPN: 633 FMI: 3 LAMP: Stop/Shutdown SRT: | Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected on the fuel control valve signal return pin of the main harness CM558 connector. | The engine will shutdown.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24-VDC pulse-width modulated signal. A short to battery voltage in the harness or at the fuel control valve connector will cause Fault Code 455 to be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 must always read an alternating 24-VDC and 0-VDC.

Refer to Troubleshooting Fault Code t05-455


Ignition Timing Signal Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 458

Ignition Timing Signal Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 458 PID: S067 SPN: 726 FMI: 3 LAMP: Stop/Shutdown SRT: | Ignition Timing Signal Circuit - Voltage Above Normal, or Shorted to High Source. The ignition timing signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | The engine will shut down.
Ignition Timing Signal Circuit

Circuit Description

The ignition timing signal is a 5 VDC signal. The CM558 drives the ignition timing signal to 0-VDC to create an ignition timing pulse for each cylinder.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Cummins® Ignition Module (CIM) to start the firing sequence. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-458


Ignition Timing Signal Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 459

Ignition Timing Signal Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 459 PID: S067 SPN: 726 FMI: 4 LAMP: Stop/Shutdown SRT: | Ignition Timing Signal Circuit - Voltage Below Normal, or Shorted to Low Source. The ignition timing signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | The engine will shut down.
Ignition Timing Signal Circuit

Circuit Description

The ignition timing signal is a 5-VDC signal. The CM558 drives the ignition timing signal to 0-VDC to create an ignition timing pulse for each cylinder.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Cummins® Ignition Module (CIM) to start the firing sequence. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-459


Ignition Control Signal Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 461

Ignition Control Signal Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Ignition Control Signal Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 461 PID: S066 SPN: 725 FMI: 4 LAMP: Stop/Shutdown SRT: | Ignition Control Signal Circuit - Voltage Above Normal, or Shorted to High Source. The ignition reference signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | Engine will shut down.
Ignition Timing and Reference Signal Circuit

Circuit Description

The ignition reference signal is a 5-VDC signal. The CM558 drives the ignition reference signal to 0-VDC to create pulse to initiate the firing order.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Cummins® Ignition Module (CIM) to start the firing sequence. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-461


Ignition Control Signal Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 462

Ignition Control Signal Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Ignition Control Signal Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 462 PID: S066 SPN: 725 FMI: 4 LAMP: Stop/Shutdown SRT: | Ignition Control Signal Circuit - Voltage Below Normal, or Shorted to Low Source. The ignition reference signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | Engine will shut down.
Ignition timing and Reference Signal Circuit

Circuit Description

The ignition reference signal is a 5-VDC signal. The CM558 drives the ignition reference signal to 0-VDC to create pulse to initiate the firing order.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Cummins® Ignition Module (CIM) to start the firing sequence. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-462


Engine Heated Oxygen Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 463

Engine Heated Oxygen Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Engine Heated Oxygen Sensor Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 463 PID: S065 SPN: 724 FMI: 3 LAMP: None SRT: | Engine Heated Oxygen Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected at the oxygen sensor signal pin of the main harness CM558 connector. | Possible reduced performance. Return to open-loop running.
Heated Oxygen Sensor Circuit

Circuit Description

The CM558 uses this sensor to determine the amount of oxygen in the exhaust gas and then, adjusts the commanded air-fuel ratio.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The oxygen sensor heater must be functional for the sensor to work properly. It has a 12-VDC supply, which is separate from the engine control 24-VDC supply.

The engine will run in open-loop when the oxygen sensor fault is set. If rough running results, the electronic service tool can be used to adjust the open-loop set points.

Refer to Troubleshooting Fault Code t05-463


Engine Heated Oxygen Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 464

Engine Heated Oxygen Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Engine Heated Oxygen Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 464 PID: S065 SPN: 724 FMI: 4 LAMP: None SRT: | Engine Heated Oxygen Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the oxygen sensor signal pin of the main harness CM558. | Possible reduced performance. Return to open loop running.
Heated Oxygen Sensor Circuit

Circuit Description

The CM558 uses this sensor to determine the amount of oxygen in the exhaust gas and then, adjusts the commanded air-fuel ratio.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The oxygen sensor heater must be functional for the sensor to work properly. It has a 12-VDC supply, which is separate from the engine control 24-VDC supply.

The engine will run in open-loop when the oxygen sensor fault is set. If rough running results, the electronic service tool can be used to adjust the open-loop set points.

Refer to Troubleshooting Fault Code t05-464


Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 477 PID: P444 SPN: 444 FMI: 1/18 LAMP: Warning SRT: | Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low voltage has been detected on the isolated battery supply. | ECM voltage supply approaching a level at which unpredictable operation will occur.
Battery 2 Voltage Circuit

Circuit Description

The 24-VDC isolated battery circuit provides operating power to the CM558. This supply is used by the CM558 to provide power to the sensors and actuators connected to it.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

This fault is usually caused by loose or corroded connections, a blown fuse or a tripped circuit breaker.

Refer to Troubleshooting Fault Code t05-477


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 478 PID: P444 SPN: 444 FMI: 0/16 LAMP: Warning SRT: | Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. High voltage has been detected on the isolated battery supply. | ECM damage will occur.
Battery 2 Voltage Circuit

Circuit Description

The 24-VDC isolated battery circuit provides operating power to the CM558. This supply is used by the CM558 to provide power to the sensors and actuators connected to it.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-478


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Warning SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine intake manifold temperature has exceeded the warning threshold. | Possible reduced engine performance.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is used by the CM558 to monitor the temperature of the air-fuel mixture in the intake manifold after the aftercooler. The intake manifold 1 temperature sensor is used by the CM558 for engine protection, timing, and fueling control.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Use the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-488


Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 511

Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 511 PID: S018 SPN: 633 FMI: 4 LAMP: Stop/Shutdown SRT: | Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the fuel control valve signal return pin of the main harness CM558 connector. | The engine will shutdown.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24-VDC pulse-width modulated signal. An open circuit in the harness or at the electronic fuel injection control valve connector will cause Fault Code 511 to be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the electronic fuel injection control valve from the CM558 must always read an alternating 24-VDC and 0-VDC.

Refer to Troubleshooting Fault Code t05-511


Throttle Position 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 512

Throttle Position 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Throttle Position 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 512 PID: P051 SPN: 51 FMI: 3 LAMP: Warning SRT: | Throttle Position 1 Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Position 1 Sensor Circuit

Circuit Description

The throttle plate position 1 sensor circuit consists of the throttle driver and the CM558. The throttle driver has internal circuitry that provides a 0 to 5-VDC throttle position reference to the CM558.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the throttle driver are tight. The connections at the throttle driver are terminal strips located inside the driver. The cover must be removed to access them.

Refer to Troubleshooting Fault Code t05-512


Throttle Position 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 513

Throttle Position 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Throttle Position 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 513 PID: P051 SPN: 51 FMI: 4 LAMP: Warning SRT: | Throttle Position 1 Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Position 1 Sensor Circuit

Circuit Description

The throttle plate position circuit consists of the throttle driver and the CM558. The throttle driver has internal circuitry that provides a 0 to 5-VDC throttle position reference to the CM558.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the throttle driver are tight. The connections at the throttle driver are terminal strips located inside the driver. The cover must be removed to access them.

Refer to Troubleshooting Fault Code t05-513


Electronic Fuel Injection Control Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 514

Electronic Fuel Injection Control Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

Electronic Fuel Injection Control Valve - Mechanical System Not Responding or Out of Adjustment

CODE | REASON | EFFECT
Fault Code: 514 PID: S018 SPN: 633 FMI: 7 LAMP: Stop/Shutdown SRT: | Electronic Fuel Injection Control Valve - Mechanical System Not Responding or Out of Adjustment. The fuel control valve position feedback is not responding to commands from the ECM. The valve is stuck. | The engine will shutdown.
Electronic Fuel Injection Control Valve

Circuit Description

The fuel control valve position circuit consists of the commanded position signal from the CM558 and feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve command position signal is supplied by the CM558. The position signal is a 24-VDC pulse-width modulated signal and the feedback is a 0 to 5-VDC signal.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel control valve commanded signal and the feedback signal can be monitored using the electronic service tool. The fuel control valve is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the fault for the mechanically stuck valve will be set.

Refer to Troubleshooting Fault Code t05-514


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 546 PID: P094 SPN: 94 FMI: 3 LAMP: Warning SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High voltage detected on the fuel delivery pressure sensor signal pin of the main harness CM558 connector A. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit for Option FM4701 on Generator Set Model GFBA
Fuel Delivery Pressure Sensor Circuit for Option FM4704 on Generator Set Model GFBE

Circuit Description

The fuel delivery pressure sensor monitors the engine gas pressure before it enters the fuel control valve. This pressure is monitored by the left bank CM558. High voltage will cause Fault Code 546 and can be caused by shorts in the supply, signal or return wires, an open in the return wire, or a damaged sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure is the regulated input gas pressure to the engine. It is typically regulated to approximately 150 mBar [2.2 psi].

Fuel delivery pressure will be 0 mBar [0 psi] while the engine is cranking during the purge cycle. Fuel delivery pressure must rise as soon as the fuel shutoff valve opens.

Refer to Troubleshooting Fault Code t05-546


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 547 PID: P094 SPN: 94 FMI: 4 LAMP: Warning SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the fuel delivery pressure sensor signal pin of the main harness CM558 connector A. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit for Option FM4701 on Generator Set Model GFBA
Fuel Delivery Pressure Sensor Circuit for Option FM4704 on Generator Set Model GFBE

Circuit Description

The fuel delivery pressure sensor monitors the engine gas pressure before it enters the fuel control valve. This pressure is monitored by the CM558. Low voltage will cause Fault Code 547 and can be caused by shorts in the supply, signal or return wires, an open in the return wire, or a damaged sensor.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure is the regulated input gas pressure to the engine. It is typically regulated to approximately 150 mBar [2.2 psi].

Fuel delivery pressure will be 0 mBar [0 psi] while the engine is cranking during the purge cycle. Fuel delivery pressure must rise as soon as the fuel shutoff valve opens.

Refer to Troubleshooting Fault Code t05-547


Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 565

Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 565 PID: S094 SPN: 1356 FMI: 0 LAMP: Stop/Shutdown SRT: | Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. Cylinder number 5 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor the engine for excessive knock or detonation.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Cylinder 5 and cylinder 6 are fitted with a knock sensors. The CM558 monitors all the knock sensors.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-565


Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 566

Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 566 PID: S095 SPN: 1357 FMI: 0 LAMP: Stop/Shutdown SRT: | Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operational Range - Most Severe Level. Cylinder number 6 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor the engine for excessive knock or detonation.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Cylinder 5 and cylinder 6 are fitted with a knock sensors. The CM558 monitors all the knock sensors.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-566


Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 584 PID: S039 SPN: 677 FMI: 3 LAMP: Warning SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the CM700 through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is taken directly to ground. The harness is internal wiring located within the DC panel or Generator Interface Box, depending upon the Genset Model ID.

Component Location

Generator Set Model ID GFBA: The starter lockout relay is located within the DC panel.

Generator Set Model ID GFBE: The starter lockout relay is located within the Generator Interface Box (GIB).

Shop Talk

The CM700 monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded “OFF”, it records this fault code.

This fault can be caused by:

  • Open circuit in the starter lockout relay, its harness, or connectors
  • Short circuit to a voltage source, either in the relay or harness.
Refer to Troubleshooting Fault Code t05-584


Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 585 PID: S039 SPN: 677 FMI: 4 LAMP: Warning SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
Starter Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the CM700 through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is taken directly to ground. The harness is internal wiring located within the DC panel or Generator Interface Box, depending upon the Generator Set Model ID.

Component Location

Generator Set Model ID GFBA: The starter lockout relay is located within the DC Panel.

Generator Set Model ID GFBE: The starter lockout relay is located within the Generator Interface Box (GIB).

Conditions for Running the Diagnostics

The diagnostic runs when the PowerCommand™ Supervisor keyswitch is in the “ON”, position and when the PWM device is being energized or de-energized.

Conditions for Setting the Fault Codes

The starter lockout relay circuit PWM is detected to be greater than 0-VDC when the PWM signal is turned off.

Action Taken When the Fault Code is Active

  • The ECM drives a PowerCommand™ Supervisor “261” Warning alarm.
  • The starter lockout feature will be disabled.

Conditions for Clearing the Fault Code

The ECM will receive the PowerCommand™ Supervisor “261” Warning alarm driver signal and the fault code state will become inactive immediately after the diagnostic runs and passes. The PowerCommand™ Supervisor alarm state will need to be Reset by pressing the Reset button located on the PowerCommand™ Supervisor front panel. The ECM fault code can be cleared using the electronic service tool.

Shop Talk

The CM700 monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded “ON”, it records this fault code.

This fault can be caused by:

  • Short circuit to ground in the starter lockout relay harness, or connectors.
Refer to Troubleshooting Fault Code t05-585


Exhaust Back Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 591

Exhaust Back Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Exhaust Back Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 591 PID: S034 SPN: 648 FMI: 3 LAMP: Warning SRT: | Exhaust Back Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the engine exhaust back pressure sensor signal pin of the CM558. | Possible reduced engine performance.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The exhaust back pressure sensor monitors exhaust back pressure and passes information to the CM558. The CM558 monitors voltage on the exhaust back pressure signal pin and expects to see a voltage vary between 0.46 and 4.56-VDC during normal operation.

The CM558 uses this input to determine the pressure of the exhaust gas, which affects the measured oxygen level and therefore the fueling of the engine.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust back pressure sensor tube is vulnerable to collection of condensation and sludge. Periodic maintenance of this tube must be performed. The sensor is located such that it is protected from extreme heat. Do not relocate this sensor from its on-engine position.

Refer to Troubleshooting Fault Code t05-591


Exhaust Back Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 592

Exhaust Back Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Back Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 592 PID: S034 SPN: 648 FMI: 4 LAMP: Warning SRT: | Exhaust Back Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the engine exhaust back pressure sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The exhaust back pressure sensor monitors exhaust back pressure and passes information to the CM558. The CM558 monitors voltage on the exhaust back pressure signal pin and expects to see a voltage vary between 0.46 and 4.56-VDC during normal operation.

The CM558 uses this input to determine the pressure of the exhaust gas, which affects the measured oxygen level and therefore the fueling of the engine.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust back pressure sensor tube is vulnerable to collection of condensation and sludge. Periodic maintenance of this tube must be performed. The sensor is located such that it is protected from extreme heat. Do not relocate this sensor from its on-engine position.

Refer to Troubleshooting Fault Code t05-592


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor

Circuit Description

The ECM provides a 5-VDC supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies depending on the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects a loss of the crankshaft speed/position sensor while the engine is running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The camshaft speed sensor is used to provide engine speed and position information to the ECM.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it operate for 1 minute.
  • The fault code status displayed by the INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code:

  • Open or short circuit of the +5-VDC SUPPLY, SIGNAL, or RETURN wire in the engine harness.
  • Damaged or malfunctioning engine speed sensor.
Refer to Troubleshooting Fault Code 689.

Last Modified: 03-Sep-2014


Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 697 PID: P021 SPN: 1136 FMI: 3 LAMP: Warning SRT: | Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. The internal signal for the ECM temperature is reading an abnormally high voltage. | No effect on engine performance.
CM558

Circuit Description

The CM558 and CM700 contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside of the ECM.

Shop Talk

The ECM temperature is monitored to protect the ECM in the event of excessive temperature.

Refer to Troubleshooting Fault Code t05-697


Engine ECU Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

Engine ECU Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 698 PID: P021 SPN: 1136 FMI: 4 LAMP: Warning SRT: | Engine ECU Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. The internal signal for the ECM temperature is reading an abnormally low voltage. | No effect on engine performance.
CM558

Circuit Description

The CM558 and CM700 contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside of the ECM.

Shop Talk

The ECM temperature is monitored to protect the ECM in the event of excessive temperature.

Refer to Troubleshooting Fault Code t05-698


Gas Mass Flow 1 Sensor - Data Erratic, Intermittent or Incorrect

FAULT CODE 751

Gas Mass Flow 1 Sensor - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

Gas Mass Flow 1 Sensor - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 751 PID: P149 SPN: 1241 FMI: 2 LAMP: Warning SRT: | Gas Mass Flow 1 Sensor - Data Erratic, Intermittent or Incorrect. A signal that is outside of the normal operating limits was detected on the gas mass flow sensor signal pin of the main harness CM558 connector. | Engine performance may be affected.
Invalid Signal Detected at Gas Mass Flow Sensor

Circuit Description

The signal from the CM558 to the gas mass flow sensor is 14 VDC. The feedback signal from the sensor to the CM558 is 0 to 5 VDC. A signal outside of the normal operating limits will cause Fault Code 751 to be set.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The gas mass flow sensor is supplied with 14-VDC from the CM558. The sensor is a hot wire sensor with two wire elements that protrude into the gas flow. The two wires are kept at equal temperatures and the signal, 0 to 5-VDC, indicates the gas flow to the CM558. The 0 to 5-VDC signal corresponds to the voltage necessary to maintain the temperature of the wires due to the cooling affect as the gas flows.

An invalid signal on the gas mass flow sensor can be caused by fuel system problems. The invalid signal is an indication that the gas mass flow sensor is either faulty, or it can not correct the fuel flow to the desired value. The gas mass flow sensor corrects the fuel flow by adjusting the position of the fuel control valve.

Refer to Troubleshooting Fault Code t05-751


Heated Oxygen Sensor - Data Erratic, Intermittent or Incorrect

FAULT CODE 752

Heated Oxygen Sensor - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

Heated Oxygen Sensor - Data Erratic, Intermittent or Incorrect

CODE | REASON | EFFECT
Fault Code: 752 PID: S065 SPN: 724 FMI: 2 LAMP: Warning SRT: | Heated Oxygen Sensor - Data Erratic, Intermittent or Incorrect. The sensed air/fuel ration is at least five air/fuel ratios greater than the commanded air/fuel ratio. | Possible reduced performance.
Heated Oxygen Sensor Circuit

Circuit Description

The heated oxygen sensor is used by the CM558 to measure the air to fuel ratio at which the engine is operating.

Component Location

The heated oxygen sensor is located in the turbocharger exhaust outlet.

Shop Talk

  • The sensor offset valve in the CM558 has to agree with the tag on the sensor for this sensor to function properly.
  • Any grease in the electrical connectors can cause the sensor to fail.
  • Only use Cummins Inc. approved anti-seize and lubricating compound on the sensor mounting threads.
  • Reference air flows through the heated oxygen sensor wires - the engine will not perform well if the supply of air is obstructed.
  • Check the 10A heated oxygen sensor/gas mass flow sensor fuse.
Refer to Troubleshooting Fault Code t05-752


Engine Camshaft Speed/Position Sensor - Abnormal Rate of Change

FAULT CODE 753

Engine Camshaft Speed/Position Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

Engine Camshaft Speed/Position Sensor - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 753 PID: S064 SPN: 723 FMI: 10 LAMP: None SRT: | Engine Camshaft Speed/Position Sensor - Abnormal Rate of Change. Invalid engine speed signal detected on the engine camshaft speed/position sensor signal pins of the main harness CM558 connector. | Engine will shutdown, or if not running, the engine will not start.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine camshaft speed/position sensor monitors the engine speed by reading a pattern of raised ribs on the back of the camshaft gear.

There are six evenly spaced ribs, one for each cylinder, a seventh that indicates the start of the firing sequence.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Check the air gap of the sensor over the camshaft gear. Make sure to set the gap over one of the raised ribs.

Refer to Troubleshooting Fault Code t05-753


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Sep-2017


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to verify that the Fault Code 111 is inactive.

Fault Code 111 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Engine speed sensor fault code active?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine speed sensor. | Damaged engine speed sensor?
 | STEP 2C. Check for an open circuit. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2E. Check for a short circuit between coils. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 2k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto Switch in the Stop mode.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Engine speed sensor fault code active?
YES NO
No Repair

Use INSITE™ electronic service tool to clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check the Engine Speed Sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine speed sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine speed sensor
  • Remove the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.

Damaged engine speed sensor?
YES NO

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit in the sensor.

  • Measure the resistance from the engine speed sensor signal pin to the engine speed sensor return pin.

NOTE: While testing the sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially cracked wires under the insulation.

Less than 2k ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance between the engine speed sensor signal pin to the engine block ground.

NOTE: While testing the sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially cracked wires under the insulation.

More than 100k ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit between coils.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor signal pin of one coil and the engine speed sensor signal pin of the other coil.
  • Measure the resistance between the engine speed sensor return pin to the engine speed sensor return pin.

NOTE: While testing the sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially cracked wires under the insulation.

More than 100k ohms?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor signal pin to the speed sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Less than 2k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor signal pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit pin to pin.

  • Measure the resistance between the engine speed sensor signal pin and all other pins of the engine harness connector.
  • Measure the resistance between the engine speed sensor return pin and all other pins of the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 2A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-Oct-2014


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 153 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 153 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the intake manifold temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the Intake Manifold Temperature Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the intake manifold temperature sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 5A

2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the intake manifold temperature signal pin and the intake manifold temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the intake manifold temperature sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the intake manifold temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the intake manifold temperature sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the intake manifold temperature sensor harness connector to the sensor signal pin on the CM558 harness connector.
  • Measure the resistance from the return pin on the intake manifold temperature sensor harness connector to the return signal pin on the CM558 harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch is Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate CM558 response.

  • Place a jumper wire between the intake manifold temperature signal pin and the intake manifold temperature return pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 154 will become active upon installing the jumper.

Fault Code 153 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 153 is inactive.

Fault Code 153 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active?
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 154 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 154 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the intake manifold temperature sensor.

Other fault codes are active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the intake manifold temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the intake manifold temperature signal pin and the intake manifold temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the intake manifold temperature sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the intake manifold temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the intake manifold temperature sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the intake manifold temperature sensor harness connector to the sensor signal pin on the CM558 harness connector.
  • Measure the resistance from the return pin on the intake manifold temperature sensor harness connector to the return pin on the CM558 harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 153 will become active upon disconnecting the sensor.

Fault Code 154 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 154 is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 153 or 154 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 153 or 154 active?
YES NO
No Repair

Refer to the Intake Manifold Temperature Above Specification symptom tree in the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit for pin to pin. | More than 100k ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check the throttle driver commanded position and feedback position signal. | More than 20 mA?
 | STEP 4B. Check for the appropriate CM558 response. | Fault Code 175 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault code 175 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver supply voltage.

Remove the throttle driver cover and measure the supply voltage with a multimeter.

24-VDC?
YES NO
No Repair

Check the power supply connections and the fuses in the harness. Use the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the CM558.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit for pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Preform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check the throttle driver commanded position and feedback position signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver commanded position signal and the feedback position signal.

  • Connect INSITE™ electronic service tool
  • Use a jumper wire to connect the return connection
  • Monitor the commanded position signal and the feedback signal.

Is the difference in the signals less than 20 degrees?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the throttle commanded position signal wire
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the commanded position signal wire and the position signal return wire
  • Fault Code 176 will become active upon installation of the jumper wire.

Fault Code 175 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™electronic service tool to verify Fault Code 175 is inactive.

Fault Code 175 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit for pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check the throttle driver commanded position and feedback position signal. | Less than 4 mA?
 | STEP 4B. Check for the appropriate CM558 response. | Fault Code 176 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault code 176 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver supply voltage.

Remove the throttle driver cover and measure the supply voltage with a multimeter.

24-VDC?
YES NO
No Repair

Check the power supply connections and the fuses in the harness. Use the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver and the CM558.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit for pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Preform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver commanded position return pin on the engine harness connector to the throttle driver commanded position return pin on the throttle driver commanded position connector.
  • Measure the resistance from the throttle driver commanded position signal pin on the engine harness connector to the throttle driver commanded position signal pin on the throttle driver commanded position connector.
  • Preform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check the throttle driver commanded position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver commanded position signal and the feedback position signal.

  • Connect INSITE™ electronic service tool
  • Use a jumper wire to connect the return connection
  • Monitor the commanded position signal and the feedback signal.

Is the difference in the signals less than 20 degrees?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the throttle driver position signal wires
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the commanded position signal wire and the position signal return wire
  • Fault Code 175 will become active upon installation of the jumper wire.

Fault Code 176 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 176 is inactive.

Fault Code 176 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 175, 176, 512, or 513 active?
STEP 2. | Check the throttle driver and actuator. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver position signal voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 177 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 177 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 175, 176, 512, or 513 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver and actuator.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver and actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver and actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. 019-219 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.
  • Repair or replace the throttle driver. Refer to 019-429 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver position signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Remove the cover from the throttle driver
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver position signal voltage.

  • Measure the signal voltage using a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24-VDC and 0-VDC.

24-VDC?
YES NO

Inspect the throttle actuator coupling for damage. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, for component location.

Check the power supply connections and fuses in the power supply wires to the CM558. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the throttle driver and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the throttle driver position feedback pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, for the appropriate circuit.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the throttle driver position feedback pin on the engine harness connector to the throttle driver position feedback pin on the engine harness sensor connector.
  • Measure the resistance from the throttle driver return pin on the engine harness connector to the throttle driver return pin on the engine harness sensor connector.
  • Measure the resistance from the throttle driver position signal pin on the engine harness connector to the throttle driver position signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, for the appropriate circuit.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 177 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 117 is inactive.

Fault Code 177 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 187 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 187 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply 2 circuit.

Fault Code 187 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.
  • Refer to the Procedure 019-360 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 2 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply 2 circuit .

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor supply pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 187 is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 227 is active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply 2 circuit.

Fault Code 227 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

019-361 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.
  • Refer to the Procedure 019-360 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply 2 circuit.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply 2 circuit positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 is active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 227 is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 2650 rpm, the engine must be shut off immediately. To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Load transient?
 | STEP 1B. Check the engine rpm with the monitor mode. | Correct rpm reading?
 | STEP 1C. Check for an active fault code at idle or rated speed. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify that the fault code is inactive. | Verify the fault code is inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode.

Action

Check for proper operating conditions.

  • Verify that the fault did not occur after the load transient.

Load transient?
YES NO
No Repair

Check the engine for damage.

  • Electronics are functional
  • Check the base engine for damage because of overspeed condition.

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with the monitor mode.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with the monitor mode.

  • Use INSITE™ electronic service tool to monitor the engine rpm.

Correct rpm reading?
YES NO
No Repair

Check the engine position sensor as outlined for Fault Code 121.

Go to 1C

Go to the troubleshooting chart for Fault Code 121.

Guided Step 1C - Check for an active fault at idle or rated speed.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes at idle or rated speed.

  • Use INSITE™ electronic service tool to check for active Fault Code 234 when the engine is not running above the engine overspeed shutdown threshold.

Fault Code 234 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 2A

Repair complete.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 238 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the circuit art or the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 3.

Fault Code 238 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure Refer to the Procedure 019-360 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 3.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 3 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 3.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor supply pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 238 is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 239 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing Sensor Supply Circuit Number 3.

Fault Code 239 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.
  • Use the following procedure for general resistance measurement techniques. Refer to the Procedure 019-360 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 3.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 3 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 239 is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the valve supply voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 254 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 254 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Use the Troubleshooting and Repair Manual, QSK19G Generator Set, Bulletin 4021372, for the following procedure. Refer to Procedure 005-044 in Section 5.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

NOTE: Be sure the engine is not performing a purge cycle when making this measurement.

24-VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the engine harness connector from the fuel shutoff valve
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358 for the appropriate circuit.
  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 255 will become active.

Fault Code 254 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 255 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the valve supply voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 255 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 255 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. The following procedure can be found in the Troubleshooting and Repair Manual, QSK19G Generator Set, Bulletin 4021372. Refer to Procedure 005-044 in Section 5.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

NOTE: Make sure that the engine is not performing a purge cycle when making this measurement.

24-VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the engine harness connector from the fuel shutoff valve
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 response.

  • Remove the fuel shutoff valve relays and crank the engine. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358 for the appropriate circuit.
  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 255 will become active.

Fault Code 255 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 255 is inactive.

Fault Code 255 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 346 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 346. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to verify that the Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 346.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Check the inactive counts of Fault Code 346.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 346.

Less than three counts?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 352 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 352 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply 1 circuit.

Fault Code 352 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.
  • Use the following procedure for general resistance measurement techniques. Refer to the Procedure 019-360 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 1 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor supply pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 352 is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 354 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 354 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the intake manifold pressure sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 386

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the intake manifold pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the intake manifold pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold pressure sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to the intake manifold pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to the intake manifold pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to the intake manifold pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the intake manifold pressure sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds
  • Using the electronic service tool, read the fault codes.

NOTE: Fault Code 355 will become active upon disconnecting the sensor.

Fault Code 354 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the intake manifold pressure signal pin on the CM558 to the CM558 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 354 is inactive.

Fault Code 354 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 355 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 355 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the circuit art or engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the intake manifold pressure sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 352

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the intake manifold pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the intake manifold pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the intake manifold pressure sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to the intake manifold pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to the intake manifold pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to the intake manifold pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the intake manifold pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the intake manifold pressure supply pin and the intake pressure signal pin of the sensor connector.
  • Check for the appropriate CM558 response after thirty seconds.
  • Read the fault codes using the electronic service tool.

NOTE: Fault Code 354 will become active upon installing the jumper.

Fault Code 355 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the intake manifold pressure signal pin on the CM558 to the CM558 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 355 is inactive.

Fault Code 355 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Refer to the Engine Performance Troubleshooting Tree t02-1001 in Section TT.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 386 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 1.

Fault Code 386 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share Sensor Supply Circuit Number 1.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Sensor Supply Circuit Number 1 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to the Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. 019-204 and 019-208 in Section 19.
  • Replace the engine harness. 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 386 is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Refer to Procedure 019-166 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Refer to Procedure 019-165 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120-VAC supplied to DC power supply. (if applicable) | 120-VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 441 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Use the Power Supply Manual for cleaning and connection instructions.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply or batteries.

17.3 to 34.7-VDC (24-VDC system)?
YES NO
No Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120 VAC supplied to DC power supply ( if applicable)

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120-VAC input to the DC power supply.

Use a multimeter to check the AC power supply for 120-VAC.

120-VAC?
YES NO

Repair or replace the DC power supply.

Make certain the input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair the battery ground connection. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the battery supply circuit to see if any fuse is blown.

  • Use the following procedure to identify all fuses in the circuit.Refer to Procedure 100-002 in Section E.

Fuse OK?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness or the intake manifold pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the power supply or battery harness and extension harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify the connectors and pins.

More than 100 ohms?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 441 is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120-VAC supplied to DC power supply (if applicable). | 120-VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | Damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 442 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Refer to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply or batteries.

17.3 to 34.7-VDC (24-VDC system)?
YES NO
No Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120-VAC supplied to DC power supply (if applicable).

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120-VAC input to the DC power supply.

Use a multimeter to check the AC power supply for 120-VAC.

120-VDC?
YES NO

Repair or replace the AC power supply.

Make certain the input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the battery supply circuit to see if any fuse is blown.

  • Use the following procedure to identify all fuses in the circuit.Refer to Procedure 100-002 in Section E.

Fuse OK?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed).

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the power supply or battery harness and extension harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify the connectors and pins.

More than 100 ohms?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 442 is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 239 active?
STEP 2. | Check the gas mass flow sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check the sensor supply voltage. | 8 to 15-VDC?
 | STEP 3E. Check the gas mass flow sensor signal voltage. | Greater than 1 pound per hour?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 453 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 453 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to sensor supply 3 circuit - voltage above normal, or shorted to high source, Fault Code 239

Go to 2A

Guided Step 2 - Check the Gas Mass Flow Sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the gas mass flow sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the gas mass flow sensor, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the gas mass flow sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the gas mass flow sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the gas mass flow sensor supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify the connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the gas mass flow sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the gas mass flow sensor return pin on the engine harness connector to the gas mass flow sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the gas mass flow sensor
  • Connect INSITE™ electronic service tool.

Action

Check the gas mass fow sensor supply voltage.

  • Measure the sensor supply voltage.

8 to 15-VDC?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 3E

Repair Complete

Guided Step 3E - Check the gas mass flow sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the CM558
  • Connect INSITE™ electronic service tool.

Action

Check the gas mass flow sensor signal.

  • Use INSITE™ electronic service tool to monitor the gas mass flow sensor signal.

Greater than 1 pound per hour?
YES NO
No Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the gas mass flow sensor
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check the CM558 for an appropriate response after 30 seconds
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 454 will become active upon disconnecting the sensor.

Fault Code 453 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 453 is inactive.

Fault Code 453 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Merti-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Merti-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 238 active?
STEP 2. | Check the gas mass flow sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check the sensor supply voltage. | 8 to 15-VDC?
 | STEP 3E. Check the gas mas flow sensor signal voltage. | Greater than one pound per hour?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 454 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 454 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to sensor supply 3 circuit - voltage below normal, or shorted to low source, Fault Code 238

Go to 2A

Guided Step 2 - Check the gas mass flow sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the gas mass flow sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the gas mass flow sensor, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the gas mass flow sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the gas mass flow sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the gas mass flow sensor supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify the connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the gas mass flow sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the gas mass flow sensor return pin on the engine harness connector to the gas mass flow sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the gas mass flow sensor
  • Connect INSITE™ electronic service tool.

Action

Check the gas mass fow sensor supply voltage.

  • Measure the sensor supply voltage.

8 to 15-VDC?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 3E

Repair Complete

Guided Step 3E - Check the gas mass flow sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the CM558
  • Connect INSITE™ electronic service tool.

Action

Check the gas mass flow sensor signal.

  • Use INSITE™ electronic service tool to monitor the gas mass flow sensor signal.

Greater than 1 pound per hour?
YES NO
No Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the gas mass flow sensor
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check the CM558 for an appropriate response after 30 seconds
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 453 will become active upon disconnecting the sensor.

Fault Code 454 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 454 is inactive.

Fault Code 454 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator supply voltage. | 24-VDC?
 | STEP 2C. Check the actuator signal Voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 455 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 455 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442 or 477, 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and the harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Repair or replace the engine harness or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check actuator supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel fontrol valve actuator supply voltage.

  • Measure the supply voltage with a multimeter.

24-VDC?
YES NO
No Repair

Use the following procedure to check the power supply connections and the fuses. Refer to Procedure 100-002 in Section E.

Go to 2C

Go to 3A

Guided Step 2C - Check actuator signal voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator signal voltage.

  • Measure the signal voltage with a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24-VDC and 0-VDC.

24-VDC?
YES NO

Use the following procedure to replace the fuel control valve. It can be found in the Troubleshooting and Repair Manual Generator Set QSK19G Series Engine, Bulletin Number 4021372. Refer to Procedure 006-049 in Section 6.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the fuel control valve actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve actuator signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel control valve actuator supply pin on the engine harness connector to the fuel control valve actuator supply pin on the engine harness connector.
  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to the fuel control valve actuator return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the fuel control valve actuator connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds
  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 511 will become active upon disconnecting the actuator.

Fault Code 455 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 455 is inactive.

Fault Code 455 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact the nearest Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit on the Cummins® Ignition Module connector. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the Cummins® Ignition Module. |
 | STEP 3A. Check the ignition timing signal. | 5 VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 458 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 458 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the pins of the CM558 connectors and the Cummins® Ignition Module connector for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt or debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit on the Cummins® Ignition Module connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the 24-VDC supply pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the 24-VDC return pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the ignition timing signal pin to all other pins on the CM558 connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply, and power return lines.

  • Measure the resistance from the ignition timing signal pin on the Cummins® Ignition Module wiring harness connector to the ignition timing signal pin on the CM558 connector.
  • Measure the resistance from the 24-VDC supply pin on the Cummins® Ignition Module wiring harness connector to the 24-VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24-VDC return pin on the Cummins® Ignition Module wiring harness connector to the 24-VDC return on the power supply.
  • Measure the resistance from the 24-VDC supply pin on the CM558 wiring harness connector to the 24-VDC supply on the power supply.
  • Measure the resistance from the 24-VDC return pin on the CM558 wiring harness connector to the 24-VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the Cummins® Ignition Module.

Guided Step 3A - Check the ignition timing signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connectors from the right bank CM558.

Action

Check the voltage on the ignition timing signal pin of the CM558 main harness connector.

  • Install a jumper across the contacts of the Cummins® Ignition Module power supply relay. Make certain that 24-VDC is applied to the circuit.
  • Use a multimeter to measure the ignition timing signal voltage.

5-VDC?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Connect all components
  • Run/Stop/Auto switch in Run mode and running for at least 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Codes 458 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 458 is inactive.

Fault Code 458 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact the nearest Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to pin short circuit on the Cummins® Ignition Module connector. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the Cummins® Ignition Module. |
 | STEP 3A. Check the ignition timing signal. | 5 VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 459 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 459 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the pins of the CM558 connectors and the Cummins® Ignition Module connector for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt or debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the Cummins® Ignition Module connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the 24-VDC supply pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the 24-VDC return pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the ignition timing signal pin to all other pins on the CM558 connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin on the Cummins® Ignition Module wiring harness connector to engine block ground.
  • Measure the resistance from the 24-VDC supply pin on the Cummins® Ignition Module harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply, and power return lines.

  • Measure the resistance from the ignition timing signal pin on the Cummins® Ignition Module wiring harness connector to the ignition timing signal pin on the CM558 connector.
  • Measure the resistance from the 24-VDC supply pin on the Cummins® Ignition Module wiring harness connector to the 24-VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24-VDC return pin on the Cummins® Ignition Module wiring harness connector to the 24-VDC return on the power supply.
  • Measure the resistance from the 24-VDC supply pin on the CM558 wiring harness connector to the 24-VDC supply on the power supply.
  • Measure the resistance from the 24-VDC return pin on the CM558 wiring harness connector to the 24-VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the Cummins® Ignition Module.

Guided Step 3A - Check the ignition timing signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connectors from the right bank CM558.

Action

Check the voltage on the ignition timing signal pin of the CM558 main harness connector.

Install a jumper across the contacts of the Cummins® Ignition Module power supply relay. Ensure that 24-VDC is applied to the circuit.

  • Use a multimeter to measure the ignition timing signal voltage.

5-VDC?
YES NO
No Repair

Contact at Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Connect all components
  • Run/Stop/Auto switch in Run mode and running for at least 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Codes 459 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 459 is inactive.

Fault Code 459 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement.Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin on the Cummins® Ignition Module connector. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | More than 100k ohms?
STEP 3. | Check the Cummins® Ignition Module. |
 | STEP 3A. Check the ignition reference signal. | 5 VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 459 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 459 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the engine harnes and ECM connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pin. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the Cummins® Ignition Module connector.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition reference signal pin to all others on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the 24-VDC supply pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the 24-VDC return pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the ignition reference signal pin to all others on the CM558 connectors.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply and power return lines.

  • Measure the resistance from the ignition reference signal pin on the Cummins® Ignition Module wiring harness connector to the ignition reference signal pin on the CM558 connector.
  • Measure the resistance from the 24-VDC supply pin on the Cummins® Ignition Module wiring harness connector to the 24-VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24-VDC return pin on the Cummins® Ignition Module wiring harness connector to the 24-VDC return on the power supply.
  • Measure the resistance from the 24-VDC supply pin on the CM558 wiring harness connector to the 24-VDC supply on the power supply.
  • Measure the resistance from the 24-VDC return pin on the CM558 wiring harness connector to the 24-VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the Cummins® Ignition Module.

Guided Step 3A - Check the ignition reference signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main harness connectors from the right bank CM558.

Action

Check the voltage on the ignition reference signal pin on the CM558 main harness connector.

  • Install a jumper across the contacts of the Cummins® Ignition Module power supply relay. Ensure that 24-VDC is applied to the circuit.
  • Measure the ignition reference signal voltage using a multimeter.

5-VDC?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • All components connected
  • Run/Stop/Auto switch in the Run mode and running for at least 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 461 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 461 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement.Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin on the Cummins® Ignition Module connector. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the Cummins® Ignition Module. |
 | STEP 3A. Check the ignition reference signal. | 5-VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 462 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 462 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the engine harnes and CM558 connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the Cummins® Ignition Module connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition reference signal pin to all others on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the 24-VDC supply pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the 24-VDC return pin to all other pins on the Cummins® Ignition Module wiring harness connector.
  • Measure the resistance from the ignition reference signal pin to all others on the CM558 connectors.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Go to 2C

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the ignition reference signal pin on the Cummins® Ignition Module wiring harness connector to engine block ground.
  • Measure the resistance from the 24-VDC supply pin the Cummins® Ignition Module wiring harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Cummins® Ignition Module
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal power supply and power return lines.

  • Measure the resistance from the ignition reference signal pin on the Cummins® Ignition Module wiring harness connector to the Ignition Reference Signal pin on the CM558 connector.
  • Measure the resistance from the 24-VDC supply pin on the Cummins® Ignition Module wiring harness connector to the 24-VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24-VDC return pin on the Cummins® Ignition Module wiring harness connector to the 24-DC return on the power supply.
  • Measure the resistance from the 24-VDC supply pin on the CM558 wiring harness connector to the 24-VDC supply on the power supply.
  • Measure the resistance from the 24-VDC return pin on the CM558 wiring harness connector to the 24-VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the Cummins® Ignition Module.

Guided Step 3A - Check the ignition reference signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main harness connectors from the right bank CM558.

Action

Check the voltage on the ignition reference signal pin on the CM558 main harness connector.

  • Install a jumper across the contacts of the Cummins® Ignition Module power supply relay. Ensure that 24-VDC is applied to the circuit.
  • Measure the ignition reference signal voltage using a multimeter.

5-VDC?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for a CM558 response.

Conditions

  • Keyswitch circuit energized
  • All components connected
  • Run/Stop/Auto switch in the Run mode and running for at least 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after 30 seconds
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 462 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 462 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.


FAULT CODE 463 - Engine Heated Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperatures and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 441, 442, 477, or 478 are not active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage. | 11.0 to 14.0-VDC?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 463 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 are not active?

YES NO

Troubleshoot any active fault codes before proceeding.

 No Repair

Appropriate Troubleshooting Chart

Go to 2A

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect engine harness connectors from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect engine harness connectors from the CM558.

Action

Inspect the engine harness and CM558 connector pins for the following.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Run mode and running
  • Disconnect engine harness from the NGK inline module power connector.

Action

Check the supply voltage.

  • Measure the supply voltage from the heated oxygen heater positive (+) to the heated oxygen heater negative (-) pin in the engine harness sensor connector.

11.0 to 14.0-VDC?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect the engine harness connector from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check the supply voltage.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to the heated oxygen reference signal pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference return pin in the engine harness CM558 connector to the heated oxygen reference return pin in the engine harness sensor connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect the engine harness connector from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to all other pins in the connector.
  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to all other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Connect all components
  • Place run/stop/auto switch in the Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 463 is inactive.

Fault Code 463 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Mar-2012


FAULT CODE 464 - Engine Heated Oxygen Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 441, 442, 477, or 478 are not active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage. | 11.0 to 14.0-VDC?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 464 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 are not active?

YES NO

Troubleshoot any active fault codes before proceeding.

 No Repair

Appropriate Troubleshooting Chart

Go to 2A

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect engine harness connectors from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect engine harness connectors from the CM558.

Action

Inspect the engine harness and CM558 connector pins for the following.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Run mode and running
  • Disconnect engine harness from the NGK inline module power connector.

Action

Check the supply voltage.

  • Measure the supply voltage from the heated oxygen heater positive (+) pin to the heated oxygen heater negative (-) pin in the engine harness sensor connector.

11.0 to 14.0-VDC?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect the engine harness connector from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for an open circuit.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to the heated oxygen reference signal pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference return pin in the engine harness CM558 connector to the heated oxygen reference return pin in the engine harness sensor connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect the engine harness connector from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to all other pins in the connector.
  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to all other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Connect all components
  • Place run/stop/auto switch in the Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 464 is inactive.

Fault Code 464 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120-VAC supplied to DC power supply (if applicable). | 120-VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 477 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Go to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply or batteries.

17.3 to 34.7-VDC (24-VDC system)?
YES NO
No Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120-VAC supplied to DC power supply (if applicable).

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120-VAC input to the DC power supply.

Use a multimeter to check the DC power supply for 120-VAC.

120-VAC?
YES NO

Repair or replace the AC power supply.

Make certain the input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Isolated Battery Supply Circuit to see if any fuse is blown.

  • Use the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the power supply or battery harness and extension harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify the connectors and pins.

More than 100 ohms?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 477 is inactive.

Fault Code 477 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120-VAC supplied to DC power supply (if applicable). | 120-VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | Damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 478 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Go to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply or battery.

17.3 to 34.7-VDC (24-VDC system)?
YES NO
No Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120-VAC supplied to DC power supply (if applicable).

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120-AC input to the DC power supply.

Using a multimeter, check the DC power supply for 120-VAC.

120-VAC?
YES NO

Repair or replace the AC power supply.

Make certain the input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the isolated battery supply circuit to see if any fuse is blown.

  • Use the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed).

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the power supply or battery and extension harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify the connectors and pins.

More than 100 ohms?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 478 is inactive.

Fault Code 478 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 153 and 154 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 153 and 154 active?
YES NO
No Repair

Refer to the Intake Manifold Air Temperature Above Specification symptom tree in the QSK19G Series Engine Generator Set Troubleshooting and Repair Manual, Bulletin 4021372.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop position
  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 — female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator supply voltage. | 24-VDC?
 | STEP 2C. Check the actuator signal Voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 511 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 511 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442 or 477, 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and the harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Repair or replace the engine harness or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check actuator supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator supply voltage.

  • Measure the supply voltage with a multimeter.

24-VDC?
YES NO
No Repair

Check the power supply connections and the fuses. Use the circuit diagram or wiring diagram to identify the connectors and pins.

Go to 2C

Go to 5A

Guided Step 2C - Check actuator signal voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator signal voltage.

  • Measure the signal voltage with a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24-VDC and 0-VDC.

24-VDC?
YES NO

Replace the fuel control valve. Go to the QSK19G Series Engine Generator Set Troubleshooting and Repair Manual, Bulletin Number 4021372 for the following procedure. Refer to Procedure 006-049 in Section 6.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Fuel Control Valve Actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve actuator signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel control valve actuator supply pin on the engine harness connector to the fuel control valve actuator supply pin on the engine harness connector.
  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to the fuel control valve actuator return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the fuel control valve actuator connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the fuel control valve actuator supply pin and the fuel control valve actuator signal pin of the sensor connector.
  • Check for the appropriate CM558 response after thirty seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 455 will become active upon installing the jumper.

Fault Code 511 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 511 is inactive.

Fault Code 511 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Electronic Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the Throttle Driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24-VDC?
 | STEP 2C. Check the throttle driver position signal circuit. | 0.5 to 4.5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 512 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 512 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 441, 442, 447, or 448 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running
  • Remove the cover on the throttle driver
  • Connect INSITE™ electronic service tool.

Action

Check throttle driver supply voltage.

  • Use a multimeter to check the throttle driver supply voltage
  • Measure the voltage at the terminals inside the throttle driver.

24-VDC?
YES NO
No Repair

Check the power supply connections and the fuses in the harness. Use the circuit diagram or wiring diagram to identify the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the throttle driver position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running
  • Remove the cover from the throttle driver
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver position signal voltage.

  • Use a multimeter to measure the throttle position feedback signal voltage at the terminal strip in the throttle driver.

0.5 to 4.5-VDC?
YES NO
No Repair

  • Replace the throttle driver. Refer to Procedure 019-429 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver and the CM558.

Action

Inspect the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Inspect the engine harness connector pins for the following:

  • Measure the resistance from the throttle driver position feedback return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver position feedback position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for 1 minute
  • Disconnect the throttle driver actuator position feedback connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes
  • Disconnect the throttle driver position feedback wires.

NOTE: Fault Code 513 will become active upon disconnecting the throttle driver position feedback connections.

Fault Code 512 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 512 is inactive.

Fault Code 512 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Electronic Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24-VDC?
 | STEP 2C. Check the throttle driver position signal circuit. | Less than 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | More than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 513 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 513 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 441, 442 or 447, 448 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running
  • Remove the cover from the throttle driver
  • Connect INSITE™ electronic service tool.

Action

Check throttle driver supply voltage.

  • Use a multimeter to check the throttle driver supply voltage
  • Measure the voltage at the terminal strip inside the throttle driver.

24-VDC?
YES NO
No Repair

Check the power supply connections and the fuses in the harness. Use the circuit diagram or wiring diagram to identify the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the throttle driver position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running
  • Remove the cover from the throttle driver
  • Connect INSITE™ electronic service tool.

Action

Check the ProAct™ driver position signal voltage.

  • Use a multimeter to measure the throttle position feedback signal voltage at the terminal strip in the throttle driver.

Less than 0 to 5-VDC?
YES NO
No Repair

  • Replace the throttle driver. Refer to Procedure 019-429 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver and the CM558.

Action

Inspect the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Inspect the engine harness connector pins for the following:

  • Measure the resistance from the throttle driver position or feedback return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver position or feedback position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver position feedback connector.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the throttle driver position or feedback return pin on the engine harness connector to the throttle driver position or feedback return pin on the engine harness sensor connector.
  • Measure the resistance from the throttle driver position feedback signal pin on the engine harness connector to the throttle driver position feedback signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 513 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 513 is inactive.

Fault Code 513 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 455 or 511 active?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator position signal voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for open circuit. | Less than 10 ohms?
 | STEP 3D. Check the position feedback signal voltage. | 0 to 5-VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 514 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 514 inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 455 or 511 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel control valve actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Repair or replace the engine harness or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the actuator position signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator position signal voltage.

  • Measure the signal voltage using a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24-VDC and 0-VDC.

24-VDC?
YES NO
No Repair

Check the power supply connections and fuses in the power supply wires to the CM558. Use the circuit diagram or wiring harness diagram to identify the appropriate circuit.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel control valve actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the fuel control valve actuator position feedback pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve actuator position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel control valve actuator position feedback pin on the engine harness connector to the fuel control valve actuator position feedback pin on the engine harness sensor connector.
  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to the fuel control valve actuator return pin on the engine harness sensor connector.
  • Measure the resistance from the fuel control valve actuator position signal pin on the engine harness connector to the fuel control valve actuator position signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the position feedback signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the Fuel Control Valve Actuator position feedback signal.

  • Use INSITE™ electronic service tool top monitor the fuel control valve feedback position.

2 - 90 percent?
YES NO
No Repair

Replace the fuel control valve. Go to the QSK19G Series Engine Generator Set Troubleshooting and Repair Manual, Bulletin Number 4021372 for the following procedure. Refer to Procedure 006-049 in Section 6.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 514 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 514 is inactive.

Fault Code 514 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-Oct-2014


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the fuel delivery pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.53-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 546 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 546 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel delivery pressure sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to Sensor Supply 1 Circuit - Voltage above normal, or shorted to high source, Fault Code 386.

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel delivery pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel delivery pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel delivery pressure sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the fuel delivery pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ the electronic service tool.

Action

Check the fuel delivery pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the fuel delivery pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel delivery pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel delivery pressure sensor and the CM558.

Action

Inspect the wiring harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel delivery pressure sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel delivery pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel delivery pressure sensor.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the fuel delivery pressure sensor connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 547 or Fault Code 1828 will become active upon disconnecting the sensor.

Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check CM558 signal pin resistance.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel delivery pressure signal pin on the CM558 to the CM558 supply circuit number one return pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault codes is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electrical service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and idle for 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 546 is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable.Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the fuel delivery pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.53-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 547 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 547 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel delivery pressure sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to Sensor Supply 2 Circuit - Voltage above normal, or shorted to high source, Fault Code 227.

Go to 2A

Guided Step 2 - Check the Fuel Delivery Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness connector from the fuel delivery pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel delivery pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Install the fuel delivery pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel delivery pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Install the fuel delivery pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel delivery pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the fuel delivery pressure sensor and the CM558.

Action

Inspect the wiring harness and extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel delivery pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel delivery pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness

Go to 3C

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.
Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel delivery pressure sensor.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the fuel delivery pressure sensor connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the fuel delivery pressure sensor supply pin and the fuel delivery pressure sensor signal pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 546 or Fault Code 1827 will become active upon installing the jumper wire.

Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check CM558 signal pin resistance.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel delivery pressure signal pin on the CM558 to the CM558 sensor supply circuit number one return pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault codes is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electrical service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run position and idle for 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 547 is inactive.

Fault Code 547 inactive?

Operation mode switch in Auto position.
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Refer to the Engine Noise - Combustion Knocks symptom tree in the QSK19G Series Engine Generator Set Troubleshooting and Repair Manual, Bulletin Number 4021372.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Use the Engine Noise - Combustion Knocks symptom tree in the QSK19G Series Engine Generator Set Troubleshooting and Repair Manual, Bulletin Number 4021372.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


FAULT CODE 584 - Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect ECM and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 584 inactive?
 | STEP 4B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Energize keyswitch circuit
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

No Repair

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness.

Action

Inspect the starter lockout relay and connector pins.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Repair the damaged harness, connector or pins if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.

Repair the damaged harness, connector, or pins if possible. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL wire pin and the starter lockout relay RETURN wire pin.

Use the circuit diagram or wiring diagram for starter lockout relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

  • Replace the starter lockout relay. Contact a Cummins® Authorized Repair Location.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the OEM harness
  • Disconnect the harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN wire pin at the starter lockout relay connector to ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Use the generator set wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the harness. Contact a Cummins® Authorized Repair Location.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection. Contact a Cummins® Authorized Repair Location.

Clean, repair or replace the harness as necessary.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect ECM and harness connector pins.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the harness from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair the damaged harness, connector, or pins if possible. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness
  • Disconnect the harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL wire pin at the harness ECM connector plug C.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay SIGNAL line has been detected in the harness.

Use the circuit diagram or generator set wiring diagram for the RETURN wire configuration.

Repair or replace the harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness
  • Disconnect the harness from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout relay SIGNAL wire pin in the ECM connector plug C and all other pins in the ECM connector plug C.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the harness.

Use the circuit diagram or the generator set wiring diagram for SIGNAL wire configuration.

Repair or replace the harness. Contact a Cummins® Authorized Repair Location.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None.

The removal and installation of the connector corrected the fault code.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Place run/stop/auto switch in Stop mode. The engine will start and allow it to run at rated speed, no load for 1 minute.
  • Use the electronic service tool to verify that the fault code is inactive.

Fault Code 584 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Place run/stop/auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Reset the engine. Press the Reset button located on the generator control front panel.
  • Use the electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Mar-2012


FAULT CODE 585 - Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, supply line, and return circuit. | Greater than 3.75-VDC?
STEP 3. | Check the starter lockout relay harness. |
 | STEP 3A. Inspect ECM and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 585 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Enerigize keyswitch circuit
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Guided Step 2 - Check starter lockout relay circuit.

Guided Step 2A - Inspect starter lockout relay and connector pins.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness.

Action

Inspect the starter lockout relay and connector pins.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Repair the damaged harness, connector or pins if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.

Repair the damaged harness, connector, or pins if possible. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness.

Action

Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

  • Measure the resistance between the starter lockout relay SIGNAL wire pin and the starter lockout relay RETURN wire pin.

Use the circuit diagram or wiring diagram for starter lockout relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

  • Replace the starter lockout relay. Contact a Cummins® Authorized Repair Location.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness.

Action

Check for a pin-to-ground short circuit in the starter lockout relay.

Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL wire pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay. Contact a Cummins® Authorized Repair Location.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL wire pin and the starter lockout relay RETURN wire pin at the starter lockout relay connector of the harness.

Use the circuit art or generator set wiring diagram to identify the connectors and pins.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect ECM and wiring harness connector pins.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the harness from the ECM (CM700).

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair the damaged harness, connector, or pins if possible. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the harness.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit to ground in the starter lockout relay harness.

  • Measure the resistance between the starter lockout relay SIGNAL wire pin in the harness ECM connector plug C and ground.

Use the circuit art or generator set wiring diagram to identify the connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground on the starter lockout relay SIGNAL wire has been detected in the harness.

Use the circuit diagram or the generator set wiring diagram for starter lockout relay wiring configuration.

Repair or replace the harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Place run/stop/auto switch in Stop mode
  • Disconnect the starter lockout relay from the harness.
  • Disconnect the harness from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout relay SIGNAL wire pin in the ECM connector plug C and all other pins in the ECM connector plug C.

Use the circuit diagram or generator set wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the harness.

Use the circuit diagram or the generator set wiring diagram for starter lockout relay wiring configuration.

Repair or replace the harness. Contact a Cummins® Authorized Repair Location.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Enerigize keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector correct the fault.

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Place run/stop/auto switch in the RUN mode. The engine will start and allow it to run at rated speed, no load for 1 minute.
  • Use the electronic service tool to verify that the fault code is inactive.

Fault Code 585 inactive?
YES NO
No Repair

Return to the troubleshooting steps or a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Place run/stop/auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Reset the engine. Press the Reset button located on the generator control front panel.
  • Use the electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following breakout tool when taking a measurement:Part Number 3824774 - pressure sensor breakout cable

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 592 active?
STEP 2. | Check the exhaust back pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit form pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 592 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive | Fault Code 592 inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.
  • Use the circuit diagram or engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the exhaust back pressure sensor.

Fault Code 592 active?
YES | NO
No Repair | No Repair

Fault Code 239.

Go to 2A

Guided Step 2 - Check the Exhaust Back Pressure Sensor .

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness connector from the exhaust back pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the exhaust back pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the exhaust back pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the exhaust back pressure sensor breakout cable between the sensor and the harness connector
  • Connect the electronic service tool.

Action

Check the exhaust back pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the stop mode
  • Disconnect the engine harness from the exhaust back pressure sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the exhaust back pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the exhaust back pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the exhaust back pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the exhaust back pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the exhaust back pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the exhaust back pressure return pin on the engine harness connector to the exhaust back pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the exhaust back pressure signal pin on the engine harness connector to the exhaust back pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the exhaust back pressure supply pin on the engine harness connector to the exhaust back pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust back pressure sensor connector.

Action

Check for the appropriate CM558 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 592 will become active upon disconnecting the sensor.

Fault Code 592 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto pin in Stop mode
  • Disconnect the 50 pin A Deutsch™ connector from the CM558.
  • Disconnect the 50 pin B Deutsch™ connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the exhaust back pressure signal pin on the CM558 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 592 is inactive.

Fault Code 592 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto/switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following breakout tool when taking a measurement:Part Number 3824774 - pressure sensor breakout cable

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 591 active?
STEP 2. | Check the exhaust back pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit form pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 591 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive | Fault Code 591 inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.
  • Use the circuit diagram or wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the exhaust back pressure sensor.

Fault Code 591 active?
YES | NO
No Repair | No Repair

Fault Code 238.

Go to 2A

Guided Step 2 - Check the exhaust back pressure sensor .

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness connector from the exhaust back pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the exhaust back pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the exhaust back pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the exhaust back pressure sensor breakout cable between the sensor and the harness connector
  • Connect the electronic service tool.

Action

Check the exhaust back pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the stop mode
  • Disconnect the engine harness from the exhaust back pressure sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the exhaust back pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the exhaust back pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the exhaust back pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the exhaust back pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the exhaust back pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the exhaust back pressure return pin on the engine harness connector to the exhaust back pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the exhaust back pressure signal pin on the engine harness connector to the exhaust back pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the exhaust back pressure supply pin on the engine harness connector to the exhaust back pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust back pressure sensor connector.

Action

Check for the appropriate CM558 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 591 will become active upon disconnecting the sensor.

Fault Code 591 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto pin in Stop mode
  • Disconnect the 50 pin A Deutsch connector from the CM558.
  • Disconnect the 50 pin B Deutsch connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the exhaust back pressure signal pin on the CM558 to the CM558 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Contact Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 592 is inactive.

Fault Code 591 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto/switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 698 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 698 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active Fault Codes. | Fault Codes 453 or 454 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active Fault Codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than 1 minute.

Action

Check the Electronic Control Module (ECM).

  • Use the electronic service tool to read the active fault codes.

Fault Codes 453 or 454 active?
YES NO
No Repair

Go to the Engine Performance Troubleshooting Tree in Section TT.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault code.

Conditions

  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault code.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


FAULT CODE 752 - Heated Oxygen Sensor - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

Wait until the heated oxygen sensor has cooled before touching the sensor. The heated oxygen sensor operates at high temperatures and can cause personal injury.
CAUTION

Do not use any grease in the heated oxygen sensor connector. The heated oxygen sensor will not perform correctly with grease in the connector. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822917 - female AMP™/Cannon™ test lead Part Number 3822758 - male AMP™/Cannon™ test lead. To reduce the possibility of damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

Do not use any grease in the heated oxygen sensor connector. The heated oxygen sensor will not perform correctly with grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 453, 454, 455, 511, 514, and 751 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Check the offset value. | Offset value agrees?
 | STEP 2B. Inspect the harness and the sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage. | 11.0 to 14.0-VDC?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 752 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Check the fault codes.

  • Start the engine and let it idle for 1 minute
  • Use the electronic service tool to read the fault codes.

Fault Codes 453, 454, 455, 511, and/or 751 are not active?

YES NO
No Repair

Troubleshoot any active fault codes before proceeding.

Go to 2A

Active fault code(S)

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Check the offset value.

Conditions

  • Energize keyswitch circuit
  • Connect the electronic service tool.

Action

Check the offset value.

  • Use the electronic service tool to read the offset value in the ECM and compare it with the tag on the sensor.

Offset value agrees?
YES NO
No Repair

Use the electronic service tool to change offset value to match the number on the sensor tag. For information on performing this procedure, use the Electronic Service Tool Users Manual.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the harness and the sensor connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-100 in Section 19.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 31 pin connector.

Action

Inspect the engine harness and ECM connector pins for the following.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the heated oxygen sensor heater connector.
  • Turn keyswitch ON.

Action

Check supply voltage.

  • Measure the supply voltage from the heated oxygen heater positive (+) to the heated oxygen heater negative (-) pin in the engine harness sensor connector.

11.0 to 14.0-VDC?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for an open circuit.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness ECM connector to the heated oxygen reference signal pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference return pin in the engine harness ECM connector to the heated oxygen reference return pin in the engine harness sensor connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect engine harness connector 1 and 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the heated oxygen reference signal pin in the engine harness ECM connector 2 to all pins in engine harness connector 1.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use the electronic service tool to verify that Fault Code 752 is inactive.

Fault Code 752 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Mar-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 753 active?
STEP 2. | Check the engine speed/position sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor for damage. | Damaged engine camshaft speed/position sensor?
 | STEP 2C. Check the resistance of the sensor. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2E. Check for short circuit between coils. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 2k ohms?
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 753 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Connect the electronic service tool.

Action

Read the fault codes.

Use the electronic service tool to read the fault codes.

Fault Code 753 active?
YES NO
No Repair

Use the electronic service tool to clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check the engine camshaft speed/position sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine camshaft speed/position sensor.

Action

Inspect the engine harness and engine camshaft speed/position sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed/position sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine camshaft speed/position sensor.

Action

Inspect the Engine Speed/Position Sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Damaged engine camshaft speed/position sensor?
YES NO

Repair or replace the engine camshaft speed/position sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine camshaft speed/position sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine camshaft speed/position sensor signal positive (+) pin to the engine speed/position sensor return negative (-) pin in the engine camshaft speed/position sensor connector.
  • Measure the resistance from the engine camshaft speed/position sensor backup signal positive (+) pin to the engine camshaft speed/position sensor backup return negative (-) pin in the engine camshaft speed/position sensor connector.

NOTE: While testing the sensor, electrical leads must be gently flexed to check for damage or partially broken wires under the insulation.

Less than 2k ohms?
YES NO
No Repair

  • Repair or replace the engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine camshaft speed/position sensor
  • Engine speed/position sensor installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the signal pin in the engine camshaft speed/position sensor to the engine block ground.

NOTE: While testing the sensor, electrical leads must be gently flexed to check for damage or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine camshaft speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit between coils.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine camshaft speed/position sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine camshaft speed/position sensor signal pin of one coil and the engine camshaft speed/position sensor signal pin of the other coil.
  • Measure the resistance between the engine camshaft speed/position sensor return pin to the engine camshaft speed/position sensor return pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine camshaft speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine camshaft speed/position sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Connect the engine harness to the engine camshaft speed/position sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine camshaft speed/position sensor signal pin on the engine harness connector to the speed/position sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 2k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the engine camshaft speed/position sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine camshaft speed/position sensor signal pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the engine camshaft speed/position sensor.

Action

Check for a short circuit pin to pin.

  • Measure the resistance between the engine camshaft speed/position sensor signal pin and all other pins of the engine harness connector.
  • Measure the resistance between the engine camshaft speed/position sensor return pin and all other pins of the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 753 is inactive.

Fault Code 753 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. | Fault Code 1434 cleared?

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

  • Interview the operator to determine the reason for the remote emergency stop button being pressed
  • Connect the electronic service tool
  • Reset the engine - press the Reset button located on the generator control front panel.

Action

Take any actions based on the operator's comments and then reset the remote emergency stop button. Use the electronic service tool to clear the fault code after resetting the remote emergency stop.

NOTE: Generator Set Model ID GFBE: Check the 1A remote emergency fuse F11 located in the Generator Interface Box (GIB).

Generator Set Model ID GFBA: Check the 6A remote emergency stop fuse F34 located in the DC panel.

  • Use the electronic service tool to clear the fault code.

Fault Code 1434 cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of damaging a new ECM board, all other active fault codes must be investigated prior to replacing the ECM board.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new PCS PCB, all other active fault codes must be investigated prior to replacing the PCS PCB.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the kW accuracy. |
 | STEP 1A. Verify the kW output is not above the threshold for alternator short circuit. | kW output below threshold?
STEP 2. | Check the output leads. |
 | STEP 2A. Inspect the alternator output leads and harness cables. | No damaged/corroded posts or lead terminals?
 | STEP 2B. Check for a short circuit from post to post. | Greater than 100k ohms?
STEP 3. | Check the current transformers. |
 | STEP 3A. Inspect the current transformers and current transformer connections. | Current transformers and current transformer connections correct?
 | STEP 3B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from post to post. | Greater than 100k ohms?
STEP 4. | Check the PT/CT (A36) board. |
 | STEP 4A. Check the PT/CT (A36) board 3 ohm resistors. | 3 ohm resistors are good?
 | STEP 4B. Inspect the PT/CT (A36) board and the generator control harness connector pins. | Dirty or damaged pins?
STEP 5. | Check the generator control harness. |
 | STEP 5A. Inspect the generator control harness and the PowerCommand® Supervisor (PCS) connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 5C. Check for a short circuit from post to post. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 1445 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the kW accuracy.

Guided Step 1A - Verify the kW output is not above the threshold for alternator short circuit.

Conditions

  • Connect InPower™ electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Verify kW output is not above threshold for alternator for short circuit.

  • Use InPower™ electronic service tool to verify the kW output is not above the threshold for alternator short circuit.

kW output is below threshold?
YES NO
No Repair

kW output is above the threshold for alternator short circuit. Check generator set model option, selected in PowerCommand® Supervisor is correct.

Use the customer/facility/installation documentation.

Go to 2A

Go to 6A

Guided Step 2 - Check the output leads.

Guided Step 2A - Inspect the alternator output leads and harness cables.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the load harnesses from the alternator output cables.

Action

Verify kW output is not above threshold for alternator for short circuit.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged posts.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Use the site installation documentation for the following procedures.

  • Repair the load harness cables.
  • Replace the alternator output leads.

Go to 2B

Go to 6A

Guided Step 2B - Check for a short circuit from post to post.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the load harness cables from the alternator output leads.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the alternator output leads.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Use the site installation documentation for the following procedures.

  • Repair or replace the alternator.

Go to 3A

Go to 6A

Guided Step 3 - Check the current transformers.

Guided Step 3A - Inspect the current transformers and current transformer connections.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the current transformers and current transformer connections.

Verify that current transformers are connected properly.

Current transformer connections correct?
YES NO
No Repair

Use the site installation documentation for the following procedures.

  • Correctly connect the current transformer connections.

Go to 3B

Go to 6A

Guided Step 3B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the AC harness from the PT/CT (A36) board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT connector P9 to generator set ground.
  • Repeat previous step for all other current transformer pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair and replace the AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from post to post.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the AC harness from the PT/CT (A36) board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit from post to post.

  • Measure the resistance from the current transformers' pins on the AC harness connector P9 to all other pins on the AC harness connector P9.
  • Repeat previous step for all other current transformer pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohm?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair and replace the AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the PT/CT (A36) board.

Guided Step 4A - Check the PT/CT (A36) board 3 ohm resistors.

Conditions

  • Run/Stop/Auto switch in Stop Mode
  • Disconnect the AC harness from the PT/CT (A36) board (P9)
  • Disconnect the generator control harness from the PT/CT (A36) board (P8).

Action

Check the 3-ohm resistors from PT/CT board connector P8.

  • Measure the resistance between CT21 pin on connector P8 and CT21 COM wire on connector P8.
  • Measure the resistance between CT22 pin on connector P8 and CT22 COM wire on connector P8.
  • Measure the resistance between CT23 pin on connector P8 and CT23 COM wire on connector P8.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

3-ohm resistors good?
YES NO
No Repair

Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 6A

Guided Step 4B - Inspect the PT/CT (A36) board and the generator control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PT/CT (A36) board (P8).

Action

Inspect the PT/CT board and the generator control harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203, Refer to Procedure 019-205 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the PT/CT (A36) board. Refer to Procedure 019-318.

Go to 5A

Go to 6A

Guided Step 5 - Check the generator control harness.

Guided Step 5A - Inspect the generator control harness and the PowerCommand® Supervisor (PCS) connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS (P3).

Action

Inspect the generator control harness and the PCS connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Use the PCS internal wiring diagram to identify the appropriate board in the PCS.

  • Replace the appropriate PCS board.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS (P3).
  • Disconnect the generator control harness from the PT/CT (A36) board (P8).

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector pin on the generator control harness PCS connector P3 to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 6A

Guided Step 5C - Check for a short circuit from post to post.

Conditions

  • Run/Stop switch in Stop mode
  • Disconnect the generator control harness from the PCS (P3)
  • Disconnect the generator control harness from the PT/CT (A36) board (P8).

Action

Check for a short circuit from post to post.

  • Measure the resistance of each PT/CT pin on the generator control harness PCS connector P3 to all other pins on the generator control harness PCS connector P3.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and run the generator set at rated rpm, no longer than 1 minute.

Action

Disable the fault code.

  • Press the Reset button located on the PCS control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 1445 is inactive.

Fault code 1445 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Inactive fault codes cleared?
YES NO

All fault codes cleared.

Run/Stop/Auto switch in Auto position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Oct-2014


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of damaging a new PCS PCB, all other active fault codes must be investigated prior to replacing the PCS PCB.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the voltage accuracy. |
 | STEP 1A. Verify the AC voltage at the alternator matches the AC voltage seen by the PCS control panel. | AC voltages are consistent?
STEP 2. | Check the AC harness. |
 | STEP 2A. Inspect the generator AC harness and voltage regulator connections. | Dirty or damaged connections?
 | STEP 2B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the voltage regulator and generator control harness. |
 | STEP 3A. Check the voltage regulator for proper operation. | AC voltage is greater than residual and LED is on?
 | STEP 3B. Inspect the voltage regulator and generator control harness connector pins. | Dirty or damaged pins?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the load cables. |
 | STEP 4A. Inspect the load cables and generator AC harness connections. | No damaged connections?
STEP 5. | Check the Generator AC harness. |
 | STEP 5A. Inspect the generator AC harness and PT/CT (A36) board connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 5C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5D. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the PT/CT (A36) board. |
 | STEP 6A. Inspect the PT/CT (A36) board and the generator control harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Check PT/CT (A36) board primary PTs. | 1k to 2.5k ohms?
 | STEP 6C. Check PT/CT (A36) board secondary PTs. | 140 to 225 ohms?
STEP 7. | Check the generator control harness. |
 | STEP 7A. Inspect the generator control harness and PCS connector pins. | Dirty or damaged pins?
 | STEP 7B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 7C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 7D. Check for an open circuit. | Less than 10 ohms?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 1446 inactive?
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the voltage accuracy.

Guided Step 1A - Verify the AC voltage at the alternator matches the AC voltage seen by the PCS control panel.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Attach digital multimeter leads to the alternator output leads.

Action

Verify that the voltages displayed on the PCS control panel are correct.

  • Via the PCS alpha numeric display, read the L1 - L2, L2 - L3, and L3 - L1 voltages and verify that they are consistent with the voltages of the alternator output leads using the multimeter.

AC voltages are consistent?
YES NO
No Repair

Problem is in the voltage sensing.

Go to 2A

Go to 4A

Guided Step 2 - Check the AC harness.

Guided Step 2A - Inspect the AC harness and voltage regulator connections.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness connector (P10) from the voltage regulator (A37).

Action

Inspect the alternator AC harness and voltage regulator (A37) connections for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connections?
YES NO
No Repair

Repair the damaged connections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.
  • Replace the voltage regulator (A37). Refer to Procedure 019-317 in Section 19.

Go to 2B

Go to 8A

Guided Step 2B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness connectors from the PMG
  • Disconnect the generator AC harness connectors from the alternator
  • Disconnect the generator AC harness connector from the voltage regulator (A37).

Action

Check for a short circuit to generator set ground.

  • Measure the resistance from each pin in the generator AC voltage regulator connector P10 to the generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 2C

Go to 8A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness connectors from the PMG
  • Disconnect the generator AC harness connectors from the alternator
  • Disconnect the generator AC harness connector from the voltage regulator (A37).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each pin in the generator AC harness voltage regulator connector P10 to all other pins in the connector P10.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 2D

Go to 8A

Guided Step 2D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness connector from the PMG
  • Disconnect the generator AC harness connector from the alternator
  • Disconnect the generator AC harness connector from the voltage regulator (A37).

Action

Check for an open circuit in the generator AC harness.

  • Measure the resistance of the P2 wire on the generator AC harness voltage regulator connection P10 to the generator AC harness P2 wire connection to the PMG.
  • Measure the resistance of the P3 wire on the generator AC harness voltage regulator connection P10 to the AC generator harness P3 wire connection to the PMG.
  • Measure the resistance of the P4 wire on the generator AC harness voltage regulator connection P10 to the AC generator harness P4 wire connection to the PMG.
  • Measure the resistance of the F1 wire on the generator AC harness voltage regulator connection P10 to the AC generator harness F1 wire connection to the alternator.
  • Measure the resistance of the F2 wire on the generator AC harness voltage regulator connection P10 to the AC generator harness F2 wire connection to the alternator.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 8A

Guided Step 3 - Check the voltage regulator (A37) and generator control harness.

Guided Step 3A - Check the voltage regulator (A37) for proper operation.

Conditions

  • Run/Stop/Auto switch in Run mode, no load (breaker open).

Action

Check the voltage regulator (A37).

  • Use the PCS analog voltmeter to verify that the AC voltage is greater than residual.
  • If AC voltage output is residual, check to see if the Output Duty Cycle green LED on the voltage regulator (A37) is on.

AC voltage is greater than residual and LED is on?
YES NO
No Repair

  • Replace the voltage regulator (A37). Refer to Procedure 019-317 in Section 19.

Go to 3B

Go to 8A

Guided Step 3B - Inspect the voltage regulator (A37) and generator control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the voltage regulator (A37).

Action

Inspect the generator control harness and voltage regulator (A37) connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the voltage regulator (A37). Refer to Procedure 019-317 in Section 19.

Go to 3C

Go to 8A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the voltage regulator (A37)
  • Disconnect the generator control harness from the PCS.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each pin on the generator control harness voltage regulator connector P4 to all other pins in the generator control harness connector P4.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair and replace the generator control harness. Refer to Procedure 019-213 in Section 19.

Go to 3D

Go to 8A

Guided Step 3D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the voltage regulator (A37).
  • Disconnect the generator control harness from the PCS.

Action

Check for a open circuit in the generator control harness.

  • Measure the resistance of the voltage regulator PWM positive (+) pin on the generator control harness voltage regulator connector P7 to the voltage regulator PWM positive (+) pin on the generator control harness on the PCS connector P4.
  • Measure the resistance of the voltage regulator PWM negative (-) pin on the generator control harness voltage regulator connector P7 to the voltage regulator PWM negative (-) pin on the generator control harness on the PCS connector P4.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less that 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 8A

Guided Step 4 - Check the load cables.

Guided Step 4A - Inspect the load cables and generator AC harness connections

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness from the load cables.

Action

Inspect the load cables and generator AC harness connections for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 8A

Guided Step 5 - Check the Generator AC harness.

Guided Step 5A - Inspect the generator AC harness and PT/CT (A36) board connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the AC harness from the PT/CT (A36) board.

Action

Inspect the AC harness and the PT/CT (A36) board connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.
  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 8A

Guided Step 5B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector pin on the generator control harness PCS connector P3 to the generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from pin-to-pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness from the current transformers
  • Disconnect the generator AC harness from the load cables
  • Disconnect the generator AC harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each pin on the generator AC harness PT/CT (A36) board connector P8 to all other pins on the generator in the connector P8.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 5D

Go to 8A

Guided Step 5D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness from the current transformers
  • Disconnect the generator AC harness from the load cables
  • Disconnect the generator AC harness from the PT/CT (A36) board.

Action

Check for an open circuit in the generator AC harness.

  • Measure the resistance of the GEN L3 wire on the generator AC harness PT/CT board connector 09 to the GEN L3 connection on the generator AC harness to load cable W (harness ID 6).
  • Measure the resistance of the GEN L2 wire on the generator AC harness PT/CT board connector 09 to the GEN L2 connection on the generator AC harness to load cable V (harness ID 7).
  • Measure the resistance of the GEN L1 wire on the generator AC harness PT/CT board connector 09 to the GEN L1 connection on the generator AC harness to load cable U (harness ID 8).
  • Measure the resistance of the COMMON wire on the generator AC harness PT/CT board connector 09 to the COMMON connection on the generator AC harness to load cable N (harness ID 283).

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 8A

Guided Step 6 - Check the PT/CT (A36) board.

Guided Step 6A - Inspect the PT/CT (A36) board and the generator control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Inspect the PT/CT (A36) board and the generator control harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203, Refer to Procedure 019-205 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the PT/CT (A36) board. Refer to Procedure 019-318.

Go to 6B

Go to 8A

Guided Step 6B - Check PT/CT (A36) board primary PTs.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PT/CT (A36) board
  • Disconnect the generator AC harness from the PT/CT (A36) board.

Action

Verify resistance of primary PT's from PT/CT (A36) board connector P9.

  • Measure the resistance of the GEN L1 wire to the COMMON wire on connector P9.
  • Measure the resistance of the GEN L2 wire to the COMMON wire on connector P9.
  • Measure the resistance of the GEN L3 wire to the COMMON wire on connector P9.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

1k to 2.5k-ohms?
YES NO
No Repair

  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 6C

Go to 8A

Guided Step 6C - Check PT/CT board secondary PTs.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PT/CT (A36) board
  • Disconnect the generator AC harness from the PT/CT (A36) board.

Action

Verify resistance of secondary PT's from PT/CT (A36) board connector P8.

  • Measure the resistance of the GEN L1 wire to the GEN L1 COM wire on connector P8.
  • Measure the resistance of the GEN L2 wire to the GEN L2 COM wire on connector P8.
  • Measure the resistance of the GEN L3 wire to the GEN L3 COM wire on connector P8.

140 to 225 ohms?
YES NO
No Repair

  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the generator control harness.

Guided Step 7A - Inspect the generator control harness and the ECM connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS.

Action

Inspect the generator control harness and the PCS connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the appropriate PCS board. Use the PCS internal wiring diagram to identify the appropriate board.

Go to 7B

Go to 8A

Guided Step 7B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS connector plug P3
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector pin on the generator control harness PCS connector to the generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 7C

Go to 8A

Guided Step 7C - Check for a short circuit from pin-to-pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS connector plug P3
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each pin on the generator control harness PCS connector P3 to all other pins on the generator control harness PCS connector P3.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 7D

Go to 8A

Guided Step 7D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS connector plug P3
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance of the GEN L1 wire on the Generator control harness PT/CT board connector P8 to GEN L1 connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L1 COM wire on the Generator control harness PT/CT board connector P8 to GEN L1 COM connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L2 wire on the Generator control harness PT/CT board connector P8 to GEN L2 connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L2 COM wire on the Generator control harness PT/CT board connector P8 to GEN L2 COM connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L3 wire on the Generator control harness PT/CT board connector P8 to GEN L3 connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L3 COM wire on the Generator control harness PT/CT board connector P8 to GEN L3 COM connection on the Generator control harness PCS connector P3.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and run the generator set at rated speed, no load for 1 minute.

Action

Disable the fault code.

  • Press the Reset button located on the PCS control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 1446 is inactive.

Fault Code 1446 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Inactive fault codes cleared?
YES NO

All fault codes cleared.

Run/Stop/Auto switch in Auto position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Oct-2014


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of damaging a new ECM board, all other active fault codes must be investigated prior to replacing the ECM board.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the voltage accuracy. |
 | STEP 1A. Verify the AC voltage at the alternator matches the AC voltage seen by the control. | AC voltages are consistent?
STEP 2. | Check the AC harness. |
 | STEP 2A. Check the AC harness and voltage regulator connections. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the voltage regulator and generator control harness. |
 | STEP 3A. Inspect the voltage regulator and generator control harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage regulator DC power supply. | B positive (+) OK?
 | STEP 3C. Check the voltage regulator for proper operation. | LED on?
 | STEP 3D. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the load cables. |
 | STEP 4A. Inspect the load cables and AC harness connections. | Dirty or damaged pins?
STEP 5. | Check the generator AC harness. |
 | STEP 5A. Inspect the generator AC harness and PT/CT (A36) board connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 5C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5D. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the PT/CT (A36) board. |
 | STEP 6A. Inspect the PT/CT (A36) board and the generator control harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Check the PT/CT (A36) board primary PTs. | 1k to 2.5k ohms?
 | STEP 6C. Check the PT/CT (A36) board secondary PTs. | 140 to 225 ohms?
STEP 7. | Check the generator control harness. |
 | STEP 7A. Inspect the generator control harness and the PCS connector pins. | Dirty or damaged pins?
 | STEP 7B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 7C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 7D. Check for an open circuit. | Less than 10 ohms?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 1447 inactive?
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the voltage accuracy.

Guided Step 1A - Verify the AC voltage at the alternator matches the AC voltage seen by the PSC control panel.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Attach digital multimeter leads to the alternator output leads.

Action

Verify that the voltages displayed on the PCS control panel are correct.

  • Use the PCS alpha numeric display. Read the L1-L2, L2-L3, and L3-L1 voltages and verify that they are consistent with the voltages of the alternator output leads using the multimeter.

AC voltages are constant?
YES NO

Problem is in the voltage sensing. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the AC harness.

Guided Step 2A - Inspect the AC harness and voltage regulator (A37) connections.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness from the voltage regulator (A37).

Action

Inspect the generator AC harness and voltage regulator (A37) connections for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged connections.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.
  • Replace the voltage regulator (A37). Refer to Procedure 019-317 in Section 19.

Go to 2B

Go to 8A

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness connectors from the PMG
  • Disconnect the generator AC harness connectors from the alternator
  • Disconnect the generator AC harness connector from the voltage regulator (A37).

Action

Check for a short circuit to generator set ground.

  • Measure the resistance from each pin in the generator AC harness voltage regulator connector P10 to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 2C

Go to 8A

Guided Step 2C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness connector from the PMG
  • Disconnect the generator AC harness connector from the alternator
  • Disconnect the generator AC harness connector from the voltage regulator (A37).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each pin in the generator AC harness voltage regulator connector P10 to all other pins in connector P10.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 2D

Go to 8A

Guided Step 2D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness connectors from the PMG
  • Disconnect the generator AC harness connectors from the alternator
  • Disconnect the generator AC harness connectors from the voltage regulator (A37).

Action

Check for a open circuit in the generator AC harness.

  • Measure the resistance of the P2 pin on the generator AC harness voltage regulator connector P10 to the generator AC harness P2 connection to the PMG.
  • Measure the resistance of the P3 pin on the generator AC harness voltage regulator connector P10 to the AC harness P3 connection to the PMG.
  • Measure the resistance of the P4 pin on the generator AC harness voltage regulator connector P10 to the AC harness P4 connection to the PMG.
  • Measure the resistance of the F1 pin on the generator AC harness voltage regulator connector P10 to the AC harness F1 connection to the alternator.
  • Measure the resistance of the F2 pin on the generator AC harness voltage regulator connector P10 to the AC harness F2 connection to the alternator.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 8A

Guided Step 3 - Check the voltage regulator (A37) and generator control harness.

Guided Step 3A - Inspect the voltage regulator (A37) and generator control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the voltage regulator (A37).

Action

Inspect the generator control harness and voltage regulator (A37) connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 3B

Go to 8A

Guided Step 3B - Check the voltage regulator (A37) DC power supply.

Conditions

  • Run/Stop/Auto switch in Run mode, no load (breaker open)
  • Disconnect the generator control harness from the voltage regulator (A37) connector 07.

Action

Check the voltage regulator (A37) DC power supply.

  • Use a multimeter to test for B positive (+) into the voltage regulator, and check the voltage on the DC power supply pin of the generator control harness.

AC voltage is greater than residual and LED is on?
YES NO
No Repair

Check for a short circuit to generator ground.

Go to 3C

Go to 3D

Guided Step 3C - Check the voltage regulator (A37) for proper operation.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Connect the generator control harness to the voltage regulator.

Action

Check the voltage regulator (A37) for correct operation.

  • Check to see that the isolated supply green LED on the voltage regulator (A37) is illuminated.

Isolated Supply green LED is on?
YES NO
No Repair

Replace the voltage regulator. Refer to Procedure 019-317 in Section 19.

Go to 3D

Go to 8A

Guided Step 3D - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the voltage regulator (A37)
  • Disconnect the generator control harness from the PCS.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each pin on the generator control harness voltage regulator connector P7 to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 3E

Go to 8A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the voltage regulator (A37)
  • Disconnect the generator control harness from the PCS.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each pin on the generator control harness voltage regulator connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 3F

Go to 8A

Guided Step 3F - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the voltage regulator (A37)
  • Disconnect the generator control harness from the PCS.

Action

Check for a open circuit in the generator control harness.

  • Measure the resistance of the voltage regulator PWM positive (+) pin on the generator control harness voltage regulator connector P7 to the voltage regulator PWM positive (+) pin on the generator control harness on the PCS connector P4.
  • Measure the resistance of the voltage regulator PWM negative (-) pin on the generator control harness voltage regulator connector P7 to the voltage regulator PWM negative (-) pin on the generator control harness on the PCS connector P4.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 8A

Guided Step 4 - Check the load cables.

Guided Step 4A - Inspect the load cables and generator AC harness connections.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator AC harness from the load cables.

Action

Inspect the load cables and generator AC harness connections for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.
  • Replace the load cables. Refer to Procedure 019-197 in Section 19.

Go to 5A

Go to 8A

Guided Step 5 - Check the AC harness.

Guided Step 5A - Inspect the AC harness and PT/CT (A36) board connector pins.

Conditions

  • Run/Stop/Auto switch in Stop position.
  • Disconnect the AC harness from the PT/CT (A36) board.

Action

Inspect the generator AC harness and the PT/CT (A36) board connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator AC harness. Refer to Procedure 019-213 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 8A

Guided Step 5B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector wire on the generator control harness PCS connector P3 to Generator Set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit from pin-to-pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Generator AC from the current transformers
  • Disconnect the Generator AC harness from the load cables
  • Disconnect the Generator AC harness from the PT/CT (A36) board

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each wire on the generator AC harness PT/CT (A36) board connector P8 to all other wires on the generator AC harness in the connector P8.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator AC harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator AC harness. Contact a Cummins® Authorized Repair Location.

Go to 5D

Go to 8A

Guided Step 5D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Generator AC from the current transformers
  • Disconnect the Generator AC harness from the load cables
  • Disconnect the Generator AC harness from the PT/CT (A36) board

Action

Check for a open circuit in the generator AC harness.

  • Measure the resistance of the GEN L3 wire on the Generator AC harness PT/CT board connector P9 to GEN L3 connection on the Generator AC harness to load cable W (harness ID 6).
  • Measure the resistance of the GEN L2 wire on the Generator AC harness PT/CT board connector P9 to GEN L2 connection on the Generator AC harness to load cable V (harness ID 7).
  • Measure the resistance of the GEN L1 wire on the Generator AC harness PT/CT board connector P9 to GEN L1 connection on the Generator AC harness to load cable U (harness ID 8).
  • Measure the resistance of the GEN COMMON wire on the Generator AC harness PT/CT board connector P9 to GEN COMMON connection on the Generator AC harness to load cable N (harness ID 283).

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator AC harness. Refer to Procedure 019-203 or Refer to Procedure 019-197 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 8A

Guided Step 6 - Check the PT/CT (A36) board.

Guided Step 6A - Inspect the PT/CT (A36) board and the generator control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Inspect the PT/CT (A36) board and the generator control harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203, Refer to Procedure 019-205, or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the PT/CT board. Refer to Procedure 019-318 in Section 19.

Go to 6B

Go to 8A

Guided Step 6B - Check PT/CT (A36) board primary PTs.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PT/CT (A36) board.
  • Disconnect the AC harness from the PT/CT (A36) board.

Action

Verify resistance of primary PTs from PT/CT board (A36) connector 09.

  • Measure the resistance of the GEN L1 pin to the COMMON pin on connector P9.
  • Measure the resistance of the GEN L2 pin to the COMMON pin on connector P9.
  • Measure the resistance of the GEN L3 pin to the COMMON pin on connector P9.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1k to 2.5k ohms?
YES NO
No Repair

  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 6C

Go to 8A

Guided Step 6C - Check PT/CT (A36) board secondary PTs.

Conditions

  • Run/Stop/Auto switch in Stop position.
  • Disconnect the generator control harness from the PT/CT (A36) board.
  • Disconnect the AC harness from the PT/CT (A36) board.

Action

Verify resistance of secondary PTs from PT/CT board connector 08.

  • Measure the resistance of the GEN L1 pin to the GEN L1 COM pin on connector P8.
  • Measure the resistance of the GEN L2 pin to the GEN L2 COM pin on connector P8.
  • Measure the resistance of the GEN L3 pin to the GEN L3 COM pin on connector P8.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

140 to 225 ohms?
YES NO
No Repair

  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the generator control harness.

Guided Step 7A - Inspect the generator control harness and the PCS connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS.

Action

Inspect the generator control harness and the PCS connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the appropriate PCS board. Use the PCS internal wiring diagram for to identify the appropriate board.

Go to 7B

Go to 8A

Guided Step 7B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS connector plug P3
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector wire on the generator control harness PCS connector P3 to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 7C

Go to 8A

Guided Step 7C - Check for a short circuit from pin-to-pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS connector plug P3
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each wire on the generator control harness PCS connector P3 to all other wires on the generator control harness PCS connector P3.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 7D

Go to 8A

Guided Step 7D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Generator control harness from the PCS connector plug P3
  • Disconnect the Generator control harness from the PT/CT (A36) board.

Action

Check for a open circuit in the generator AC harness.

  • Measure the resistance of the GEN L1 wire on the Generator control harness PT/CT board connector P8 to GEN L1 connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L1 COM wire on the Generator control harness PT/CT board connector P8 to GEN L1 COM connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L2 wire on the Generator control harness PT/CT board connector P8 to GEN L2 connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L2 COM wire on the Generator control harness PT/CT board connector P8 to GEN L2 COM connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L3 wire on the Generator control harness PT/CT board connector P8 to GEN L3 connection on the Generator control harness PCS connector P3.
  • Measure the resistance of the GEN L3 COM wire on the Generator control harness PT/CT board connector P8 to GEN L3 COM connection on the Generator control harness PCS connector P3.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 8A

Guided Step 8 - Clear the inactive fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and run the generator set at rated speed, no load for 1 minute

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1447 is inactive.

Fault Code 1447 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Inactive fault codes cleared?
YES NO

All fault codes cleared?

Run/Stop/Auto switch in Auto position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the PowerCommand® Supervisor (PCS). |
 | STEP 1A. Check for multiple fault codes. | No other active fault codes?
 | STEP 1B. Verify correct calibration is loaded/generator set model selected in PCS. | Correct calibration loaded?
 | STEP 1C. Verify that the initial setup of the generator set was installed correctly. | Initial setup is correct?
 | STEP 1D. Check for overload. | No overload conditions or faults?
STEP 2. | Check the engine ECM. |
 | STEP 2A. Check for multiple fault codes. | No other fault codes active?
 | STEP 2B. Verify that the correct ECM calibration is loaded. | Correct calibration loaded?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1448 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the PowerCommand® Supervisor (PCS).

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Run/Stop/Auto switch on PCS front panel in Stop mode.

Action

Check the PCS for multiple fault codes.

  • Use the PSC front panel to read the fault codes.

No other active fault codes?
YES NO
No Repair

Other fault codes are active.

  • Troubleshoot all other fault codes before proceeding to Step 3A.

Go to 1B

Appropriate troubleshooting steps

Guided Step 1B - Verify correct calibration is loaded/generator set model selected in PCS.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Connect all components.

Action

Verify the correct calibration is loaded and generator set model selected in the PCS.

  • Use the PCS front panel to verify the calibration and generator set model selection is correct.

Correct calibration loaded?
YES NO
No Repair

Use the PCS service manual to verification of the correct the PCS calibration or model selection.

  • Use InPower™ to install the correct PCS calibration.
  • Use the PCS front panel to select the correct generator set model from the options listed.

Go to 1C

Go to 3A

Guided Step 1C - Verify that the initial setup of the generator set was installed correctly.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Connect all components.

Action

Verify that the initial setup of the generator set was installed correctly in PCS.

  • Use the PCS front panel to verify that the initial setup of the generator set is correctly installed.

Initial setup is correct?
YES NO
No Repair

Use the PCS service manual to verify the correct initial setup of the generator set within PCS.

  • Use InPower™ to install the correct initial setup for the generator set.

Go to 1D

Go to 3A

Guided Step 1D - Check for overload.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Connect the electronic service tool.

Action

Check for overload.

  • Use InPower™ to verify that the load present on the system is acceptable and does not exceed the generator set specification.

No overload conditions?
YES NO
No Repair

The generator set is being overloaded

  • Use site documentation to correctly install initial setup and correct any overload.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine ECM.

Guided Step 2A - Check for multiple fault codes.

Conditions

  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for multiple fault codes.

  • Connect INSITE™ electronic service tool and check the ECM for multiple active fault codes.

No other fault codes active?
YES NO
No Repair

Troubleshoot all other fault codes before proceeding to Step 3A.

Go to 2B

Appropriate troubleshooting steps.

Guided Step 2B - Verify that the correct ECM calibration is loaded.

Conditions

  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for correct calibration.

  • Connect INSITE™ electronic service tool and check that the correct calibration is loaded into the ECM.

Correct calibration loaded?
YES NO
No Repair

Correct the calibration within the ECM.

  • Connect INSITE™ and install the correct ECM calibration from the INCAL™ calibration DVD.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Run/Stop/Auto switch on the PCS front panel in Run position and idle engine for 1 minute
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Use the RESET button located on the PCS front panel to acknowledge all fault codes. (PCS fault code 313 Reset?)
  • Use INSITE™ electronic service tool to verify that Fault Code 1448 is inactive.

Fault Code 1448 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact your nearest authorized repair location if all steps have been completed and checked again.

Go to 3B

Appropriate troubleshooting steps

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Generator Circuit Breaker Status Failed to Close - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of damaging a new ECM or PowerCommand™ Supervisor (PCS) PCB, all other fault codes must be investigated prior to replacing the ECM or PCS PCB.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator set circuit breaker. |
 | STEP 1A. Inspect the generator set circuit breaker connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the generator set circuit breaker for damage. | No visible damage?
 | STEP 1C. Check the generator set circuit breaker for proper charge. | Circuit breaker properly charged?
STEP 2. | Check the customer circuit breaker harness. |
 | STEP 2A. Inspect the customer circuit breaker harness and the Generator Interface Box (GIB) TB1 connections. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to generator set ground. | Greater than 100k ohms”
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1452 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the generator set circuit breaker.

Guided Step 1A - Inspect the generator set circuit breaker connector pins.

Conditions

  • Run/Stop/Auto switch on PCS front panel in Stop mode.
  • Disconnect the customer circuit breaker harness from the circuit breaker connector.

Action

Inspect the generator control harness and the circuit breaker connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Use site documentation to repair the customer circuit breaker harness.
  • Use site documentation to replace the customer circuit breaker harness.
  • Use site documentation to repair the circuit breaker connector.
  • Use site documentation to replace the circuit breaker connector.

Go to 1B

Go to 3A

Guided Step 1B - Check the generator set circuit breaker for damage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch on PCS front panel in Stop mode.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Inspect the circuit breaker.

  • Inspect the generator set circuit breaker for any visual damage.

No visible damage?
YES NO
No Repair

Use the site installation documentation to replace the generator set circuit breaker.

Go to 1C

Go to 3A

Guided Step 1C - Check the generator set circuit breaker for proper charge.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch on PCS front panel in Stop mode.

Action

Check the generator set circuit breaker for proper charge.

Check the generator set circuit breaker for proper charge.

Circuit breaker properly charged?
YES NO
No Repair

Use the site installation documentation to repair the generator set circuit breaker.

Go to 2A

Go to 3A

Guided Step 2 - Check the customer circuit breaker harness.

Guided Step 2A - Inspect the customer circuit breaker harness and the Generator Interface Box (GIB) TB1 connections.

Conditions

  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Inspect the harness and GIB TB1 connections for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Use the site documentation to repair the customer circuit breaker harness.
  • Use the site documentation to replace the customer circuit breaker harness.
  • Replace the genset board.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch on PCS front panel in Stop mode.
  • Disconnect the customer circuit breaker harness from the BIB TB1.
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance from the generator set circuit breaker on the customer circuit breaker harness GIB TB1 connections to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the customer circuit breaker harness.

  • Use the site documentation to repair the customer circuit breaker harness.
  • Use the site documentation to replace the customer circuit breaker harness.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Disconnect the customer circuit breaker harness from the GIB TB1
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for an open circuit in the generator set circuit breaker control harness.

  • Measure the resistance from the Generator Set circuit breaker wires on the customer circuit breaker harness board connector to the customer circuit breaker harness GIB TB1 wire connections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the customer circuit breaker harness.

  • Use the site documentation to repair the customer circuit breaker harness.
  • Use the site documentation to replace the customer circuit breaker harness.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Disconnect the customer circuit breaker harness from the GIB TB1
  • Disconnect the customer circuit breaker harness from the generator set circuit breaker.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the generator set circuit breaker wire on the customer circuit breaker harness to all other wires on the customer circuit breaker harness GIB TB1 connections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the customer circuit breaker harness.

  • Use the site documentation to repair the customer circuit breaker harness.
  • Use the site documentation to replace the customer circuit breaker harness.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Run/Stop/Auto switch on PCS front panel in Run mode for 1 minute
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use the RESET button located on the PCS front panel, acknowledge all PCS fault codes.
  • Use INSITE™ electronic service tool to verify that Fault Code 1452 is inactive.

Fault code 1452 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Appropriate troubleshooting steps

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Run/Stop/Auto switch on PCS front panel in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Inactive fault codes cleared?
YES NO

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Oct-2014


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of damaging a new ECM or PowerCommand® Supervisor (PCS) PCB, all other fault codes must be investigated prior to replacing the ECM or PCS PCB.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the PowerCommand® Supervisor (PCS) and ECM for multiple fault codes. |
 | STEP 1A. Read the PCS fault codes. | No other PCS fault codes active?
 | STEP 1B. Read the ECM fault codes. | No other ECM fault codes active?
STEP 2. | Check the PowerCommand® Supervisor (PCS). |
 | STEP 2A. Check the PCS calibration is correct and the correct generator set model is selected. | PCS calibration and generator set model selection correct?
 | STEP 2B. Verify that the initial setup of the generator set was installed correctly. | Initial setup of the generator set installed correctly?
 | STEP 2C. Verify that the PCS synchronizer is correct. | PCS synchronizer setup correct?
STEP 3. | Check the engine ECM. |
 | STEP 3A. Verify that the ECM calibration is correct. | Engine ECM calibration correct?
STEP 4. | Check the fuel system. |
 | STEP 4A. Verify that the fuel system is not running with instability. | Fuel system is functioning normally?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1457 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the PowerCommand® Supervisor (PCS).

Guided Step 1A - Read the PCS fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool

Action

Verify that there are no other active PCS fault codes.

  • Use the PCS alpha numeric display to check that no other PCS fault codes are active.

No other PCS fault codes active?
YES NO
No Repair

Other PCS fault codes are active.

  • Use to the appropriate PCS service manual to troubleshoot all other fault codes before proceeding to 5A.

Go to 1B

Go to 5A

Guided Step 1B - Read the ECM fault codes.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Connect INSITE™ electronic service tool.

Action

Read the ECM fault codes.

  • Use INSITE™ electronic service tool to read the ECM fault codes.

No other ECM fault codes active?
YES NO
No Repair

Other ECM fault codes are active.

  • Go to Section TF and appropriate troubleshooting steps to troubleshoot all other fault codes before proceeding to 5A.

Go to 2A

Go to 5A

Guided Step 2 - Check the PowerCommand® Supervisor (PCS).

Guided Step 2A - Verify that the PCS calibration is correct and the correct Generator Set model is selected.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Verify that the PCS calibration is correct and the correct generator set model is selected.

  • Via the PCS front panel, verify that the PCS calibration is correct and that the Generator Set model selection is correct for application.

PCS calibration and generator set model selection correct?
YES NO
No Repair

Correct the PCS calibration and model selection. (Use to the appropriate PCS service manual.)

  • Use InPower™ to install the correct PCS calibration.
  • Use the PCS front panel to select the correct generator set model from the options listed (to match application).

Go to 2B

Go to 5A

Guided Step 2B - Verify that the initial setup of the generator set was installed correctly.

Conditions

  • Keyswitch energized
  • Run/Stop/Auto switch in Stop mode

Action

Verify that the initial setup of the generator set was installed correctly in the PCS.

Initial setup of the generator set installed correctly?
YES NO
No Repair

Use the appropriate PCS service manual to correct the initial setup of the generator set within PCS.

  • Use the front panel to install the correct initial setup for the generator set.
  • Use InPower™ to install the correct initial setup for the generator set.

Go to 2C

Go to 5A

Guided Step 2C - Verify that the PCS synchronizer is correctly setup.

Conditions

  • Keyswitch energized
  • Run/Stop/Auto switch in Stop mode

Action

Check the setup of the PCS synchroniser.

  • Use the PCS front panel to check that the synchronizer is correct.

PCS synchronizer setup correct?
YES NO
No Repair

Correct the PCS synchronizer setup.

  • Use the PCS front panel to reset the synchronizer setup to approved limits.
  • Use InPower™ to reset the synchronizer setup to approved limits.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine ECM.

Guided Step 3A - Verify that the engine ECM calibration is correct.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check the engine ECM for correct calibration.

  • Connect INSITE™ electronic service tool and check that the correct calibration is loaded into the ECM.

Correct calibration is loaded into the engine ECM?
YES NO
No Repair

Correct the calibration within the ECM.

  • Connect INSITE™ electronic service tool yand install the correct ECM calibration from the INCAL™ calibration DVD.

Go to 4A

Go to 5A

Guided Step 4 - Check the fuel system.

Guided Step 4A - Check that the fuel system is not running instability.

Conditions

  • Run/Stop/Auto switch in Run mode, no load
  • Connect INSITE™ electronic service tool

Action

Verify that the fuel system is not causing the engine to run with instability at no load conditions.

  • Use INSITE™ electronic service tool to check that no fuel system related fault codes are active.
  • Check that the engine is stable with no load applied.

No fuel system related fault codes active or engine instability?
YES NO
No Repair

Fuel system related fault codes active and engine instability observed.

  • Use appropriate troubleshooting steps to troubleshoot fuel system fault codes.
  • Clear the fuel system related fault codes.
  • Go to Section TS to troubleshoot the engine instability.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and run the generator set at rated speed with no load for 1 minute.

Action

Disable the fault code.

  • Press the Reset button located on the PCS control front panel.
  • Use INSITE™ electronic service tool to verify that the Fault Code 1457 is inactive.

Fault code 1457 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Inactive fault codes cleared?
YES NO

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the system bus voltage. |
 | STEP 1A. Verify that the system bus voltage is correct and is not single phase. | System bus voltage is correct?
STEP 2. | Check the power output feeders. |
 | STEP 2A. Verify that the power output feeders are correctly connected. | Power output feeders correctly connected?
STEP 3. | Check the generator set control harness. |
 | STEP 3A. Inspect the generator set control harness and the PowerCommand® Supervisor (PCS) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to generator set ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1458 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the system bus voltage.

Guided Step 1A - Verify that the system bus voltage is correct and is not single phase.

Conditions

  • Run/Stop/Auto switch in Stop mode

Action

Verify that the system bus voltage is correct and is not single phase.

  • Use a digital multimeter or power analyzer to verify that the system bus voltage is correct and is not single phase.

System bus voltage is correct?
YES NO
No Repair

System bus voltage is not correct / is single phase.

  • Use the site system documentation for repairs.

Go to 2A

Go to 4A

Guided Step 2 - Check the power output feeders.

Guided Step 2A - Verify that the power output feeders are correctly connected.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode

Action

Verify that the system bus voltage is correct and is not single phase.

  • Energize the system bus and start the generator set in the Run mode, but do not close the paralleling circuit breaker. Connect each voltmeter from the line to load side of a single phase of the paralleling breaker. If the generator set and the system bus have the same phase rotation, the voltmeter will rise and fall in voltage at the same time. If they are not in phase, one will rise while the other falls.

Power output feeders correctly connected?
YES NO
No Repair

Use the site documentation to verify the power output feeders are correctly connected.

Go to 3A

Go to 4A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator set control harness and the PowerCommand® Supervisor (PCS) connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS.
  • Disconnect the generator set control harness from the BUS/PT board (A39).

Action

Inspect the generator set control harness and PCS connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the BUS/PT board (A39). Refer to Procedure 019-319 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the BUS/PT board (A39).

Action

Check for an open circuit in the generator set control harness.

  • Measure the resistance from each of the BUS/PT board (A39) wires on the generator set control harness board connector to the aligned generator set control harness PCS connector wire.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the BUS/PT board (A39).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each BUS/PT (A39) board wires on the generator set control harness PCS connector to all other wires on the generator set control harness PCS connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to generator ground.

Conditions

  • Run/Stop/Auto switch on the PCS front panel in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the BUS/PT board (A39).

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each BUS/PT (A39) board generator set control harness PCS connector wires to the generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and operate the generator set at rated rpm at no load for 1 minute.

Action

Disable the fault code.

  • Press the Reset button located on the PCS control front panel.
  • Use INSITE™ electronic service tool to verify that the Fault Code 1458 is inactive.

Fault code 1458 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Inactive fault codes cleared?
YES NO

All fault codes cleared. Run/Stop/Auto switch in Auto position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the PowerCommand® Supervisor (PCS). |
 | STEP 1A. Check the PCS for multiple active fault codes. | No other PCS fault codes active?
 | STEP 1B. Check the PCS calibration is correct and generator set model selection are correct. | PCS calibration and model selection correct?
 | STEP 1C. Verify that the initial setup of the PCS is correct. | Initial PCS setup correct?
STEP 2. | Check the engine ECM. |
 | STEP 2A. Check for active or inactive counts of fuel system or air intake system faults. | No active or inactive fuel system or air intake system faults?
 | STEP 2B. Verify that the ECM calibration is correct. | Engine ECM calibration correct?
STEP 3. | Check the alternator output leads. |
 | STEP 3A. Inspect the alternator and the output leads. | No damaged, corroded posts or loose connections?
 | STEP 3B. Check for a short circuit from post to post. | Greater than 100k ohms?
STEP 4. | Check the current transformers. |
 | STEP 4A. Inspect the current transformers and current transformer connections. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 5. | Check the PT/CT board (A36). |
 | STEP 5A. Check the PT/CT (A36) board and the generator set control harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the PT/CT board and 3 ohm resistors. | 3 ohm resistors good?
 | STEP 5C. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 5D. Check for an open circuit. | Less than 10 ohms?
 | STEP 5E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 6. | Check the BUS/PT (A39) board. |
 | STEP 6A. Check the BUS/PT (A39) board and the generator set control harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 6C. Check for an open circuit. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 7. | Check the generator system. |
 | STEP 7A. Verify that the transient responses for the generators in the system are matched/similar. | Generator set transient responses similar?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 1459 inactive?
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the PowerCommand® Supervisor (PCS).

Guided Step 1A - Check the PCS for multiple active fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that there are no other active PCS fault codes.

  • Use the PCS alpha numeric display to check the PCS for multiple active fault codes.

No other PCS fault codes active?
YES NO
No Repair

Other PCS fault codes are active. Troubleshoot all other fault codes before proceeding to Step 8A.

Go to 1B

Appropriate troubleshooting steps

Guided Step 1B - Check the PCS calibration and model selection are correct.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that the PCS calibration is correct and the correct generator set model option is selected.

  • Use the PCS front panel, verify that the PCS calibration is correct and that the generator set model selection is correct for application.

PCS calibration and generator set model selection correct?
YES NO
No Repair

Use the appropriate PCS service manual to correct the PCS calibration and model selection.

  • Use InPower™ to install the correct PCS calibration.
  • Use the PCS front panel to select the correct generator set model from the options listed (to match application).

Go to 1C

Go to 8A

Guided Step 1C - Verify that the initial setup of the PCS is correct.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that the Initial Setup of the PCS is Correct.

  • Verify that the initial setup of the generator set was installed correctly in PCS (for generator set model selected).

Initial PCS setup correct?
YES NO
No Repair

Use the appropriate PCS service manual to correct the initial setup of the generator set within PCS.

  • Use InPower™ to install the correct PCS calibration.
  • Use the PCS front panel to install the correct initial setup for the generator set.

Go to 2A

Go to 8A

Guided Step 2 - Check the engine ECM.

Guided Step 2A - Check for active or inactive counts of fuel system or air intake system faults.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive counts of fuel system or air intake system faults.

  • Use INSITE™ electronic service tool to read the ECM fault codes.

No active or inactive fuel system or air intake system faults?
YES NO
No Repair

Other ECM active or inactive fuel system or air intake system fault codes are present. Troubleshoot all other fault codes before proceeding to 8A.

Go to 2B

Go to 8A

Guided Step 2B - Verify that the engine ECM calibration is correct.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Keyswitch energized
  • Connect INSITE™ electronic service tool.

Action

Check the engine ECM for correct calibration.

  • Connect INSITE™ electronic service tool and verify that the correct ECM calibration has been installed.

Engine ECM calibration correct?
YES NO
No Repair

Correct the calibration within the ECM.

  • Connect INSITE™ electronic service tool and install the correct ECM calibration from the INCAL™ calibration DVD.

Go to 3A

Go to 8A

Guided Step 3 - Check the alternator output leads.

Guided Step 3A - Inspect the alternator and the output leads.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the load cables from the alternator.

Action

Check the engine ECM for correct calibration.

  • Corroded posts
  • Loose connections.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged, corroded posts or loose connections?
YES NO
No Repair

Use the site documentation to repair the damaged and/or corroded posts or loose connections.

Go to 3B

Go to 8A

Guided Step 3B - Check for a short circuit from post to post.

Conditions

  • Run/Stop switch in Stop position.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the output leads.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Use the site installation documentation to repair or replace the alternator.

Go to 4A

Go to 8A

Guided Step 4 - Check the current transformers.

Guided Step 4A - Inspect the current transformers and current transformer connections.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Flush the dirt, debris, or moisture from the connector pin. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator set AC harness. Refer to Procedure 019-203 in Section 19, and Refer to Procedure 019-197 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.
  • Use the site installation documentation to replace the damaged current transformer.

Go to 4B

Go to 8A

Guided Step 4B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness connectors from the PT/CT (A36) board
  • Disconnect the generator set AC harness connectors from the current transformers.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each current transformer wire on the generator set AC harness PCS connector to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Repair the generator set AC harness. Refer to Procedure 019-203 in Section 19, and Refer to Procedure 019-197 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 4C

Go to 8A

Guided Step 4C - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness from the PT/CT board (A36).
  • Disconnect the generator set AC harness from the current transformers.

Action

Check for an open circuit.

  • Measure the resistance of each current transformer wire on the generator set AC harness connector to the aligning wire on the generator set AC harness PCS connector.
  • Repeat the resistance check for all other current transformer wires in the generator set AC harness connector to aligning wires on the generator set AC harness PCS connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201, Refer to Procedure 019-207 or Refer to Procedure 019-205 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 4D

Go to 8A

Guided Step 4D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness connectors from the PT/CT (A36) board
  • Disconnect the generator set AC harness connectors from the current transformers.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each current transformers wire on the generator set AC harness connector to all other wires on the generator set AC harness connector.
  • Repeat the resistance checks for all other current transformer wires on the generator set AC harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Repair the generator set AC harness. Refer to Procedure 019-203 and Refer to Procedure 019-197 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 8A

Guided Step 5 - Check the PT/CT (A36) board.

Guided Step 5A - Inspect the PT/CT (A36) board and the generator set control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin to pin.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203, Refer to Procedure 019-205, and Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 8A

Guided Step 5B - Check the PT/CT (A36) board 3-ohm resistors.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PT/CT (A36) board 3 ohm resistors
  • Disconnect the generator set AC harness from the PT/CT (A36) board.

Action

Check the 3-ohm resistors from the PT/CT (A36) connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

3-ohm resistors good?
YES NO
No Repair

The 3-ohm resistors damaged.

  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 5C

Go to 8C

Guided Step 5C - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector wire on the generator set control harness PCS connector to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 5D

Go to 8A

Guided Step 5D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Generator control harness from the PCS
  • Disconnect the Generator control harness from the PT/CT (A36) board.

Action

Check for an open circuit in the generator set control harness.

  • Measure the resistance of the GEN L1 wire on the generator set control harness PT/CT board connector 08 to GEN L1 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L1 COM wire on the generator set control harness PT/CT board connector 08 to GEN L1 COM connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L2 wire on the generator set control harness PT/CT board connector 08 to GEN L2 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L2 COM wire on the generator set control harness PT/CT board connector 08 to GEN L2 COM connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L3 wire on the generator set control harness PT/CT board connector 08 to GEN L3 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L3 COM wire on the generator set control harness PT/CT board connector 08 to GEN L3 COM connection on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 5E

Go to 8A

Guided Step 5E - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Generator control harness from the PCS
  • Disconnect the Generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each PT/CT wire on the generator set control harness PCS connector to all other wires on the generator set control harness PCS connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 8A

Guided Step 6 - Check the BUS/PT (A39) board.

Guided Step 6A - Inspect the BUS/PT (A39) board and the generator control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Generator control harness from the BUS PT (A39) board.

Action

Inspect the BUS/PT (A39) board and the generator set control harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the BUS/PT (A39) board. Refer to Procedure 019-319 in Section 19.

Go to 6B

Go to 8A

Guided Step 6B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the BUS/PT (A39) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each BUS PT (A39) board connector wire on the generator set control harness PCS connector to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6C

Go to 8A

Guided Step 6C - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the BUS PT (A39) board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the BUS PT (A39) board connector wires on the generator set control harness board connector to the aligned connection wire on the generator set control harness PCS connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6D

Go to 8A

Guided Step 6D - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the BUS PT (A39) board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each BUS PT wire on the generator set control harness PCS connector to all other wires on the generator set control harness PCS connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 8A

Guided Step 7 - Check the generator system.

Guided Step 7A - Verify that the transient responses for the generator sets in the system are not greatly dissimilar.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Connect the electronic service tool.

Action

Verify the transient responses of each generator set on the system are not greatly dissimilar.

  • Use INSITE™ electronic service tool and InPower™ to verify the transient responses for the generator sets in the system are not greatly dissimilar.

Generator set transient responses similar?
YES NO
No Repair

Transient responses are greatly dissimilar. Use INSITE™ electronic service tool and InPower™ to check and adjust the necessary parameters within the PCS and engine ECM so the transient responses are similar between all generator sets in the system. All PCS settings must be set identically.

Go to 8A

Go to 8A

Guided Step 8A - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and run the generator set at rated rpm, no load for 1 minute.

Action

Disable the fault code.

  • Press the Reset button located on the PCS control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 1459 is inactive.

Fault code 1459 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the PowerCommand® Supervisor (PCS). |
 | STEP 1A. Check the PCS for multiple active fault codes. | No other fault codes active?
 | STEP 1B. Check the PCS calibration and generator set model selection are correct. | PCS calibration and generator set model selection correct?
 | STEP 1C. Verify that the initial setup of the PCS is correct. | Initial PCS setup correct?
STEP 2. | Check the alternator output current accuracy. |
 | STEP 2A. Verify the AC current at the alternator matches the AC current seen by the PowerCommand® Supervisor (PCS) control. | Current sensing OK?
 | STEP 2B. Check the load. | No overload condition exists?
STEP 3. | Check the output leads. |
 | STEP 3A. Inspect the alternator output leads. | No damaged, corroded posts or loose connections?
 | STEP 3B. Check for a short circuit from post to post. | Greater than 100k ohms?
STEP 4. | Check the generator set AC harness. |
 | STEP 4A. Check the generator set AC harness and PT/CT (A36) board connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the PT/CT (A36) board. |
 | STEP 5A. Check the PT/CT (A36) board and the generator set control harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Inspect the PT/CT (A36) board and 3 ohm resistors. | 3 ohm resistors are good?
 | STEP 5C. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 5D. Check for an open circuit. | Less than 10 ohms?
 | STEP 5E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 6. | Check the generator set control harness. |
 | STEP 6A. Inspect the generator set control harness and the PowerCommand® Supervisor (PCS) connector pins. | Dirty or damaged pins?
 | STEP 6B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 6C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 6D. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 1471 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the PowerCommand® Supervisor (PCS).

Guided Step 1A - Check the PCS for multiple active fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that there are no other active PCS fault codes.

  • Use the PCS alpha numeric display to check the PCS for multiple active fault codes.

No other PCS fault codes active?
YES NO
No Repair

Other PCS fault codes are active. Troubleshoot all other fault codes before proceeding to 7A.

Go to 1B

Appropriate troubleshooting steps

Guided Step 1B - Check the PCS calibration and generator set model selection are correct.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that the PCS calibration is correct and the correct generator set model option is selected.

  • Use the PCS front panel, verify that the PCS calibration is correct and that the generator set model selection is correct for application.

PCS calibration and generator set model selection correct?
YES NO
No Repair

Use the appropriate PCS service manual to correct the PCS calibration and model selection.

  • Use InPower™ to install the correct PCS calibration.
  • Use the PCS front panel to select the correct generator set model from the options listed (to match application).

Go to 1C

Go to 7A

Guided Step 1C - Verify that the initial setup of the PCS is correct.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that the initial setup of the generator set was installed correctly in PCS (for generator set model selected).

  • Use the PCS front panel to verify that the initial setup of the generator set is correctly installed.

Initial PCS setup correct?
YES NO
No Repair

Use the appropriate PCS service manual to correct the initial setup of the generator set within PCS.

  • Use InPower™ to install the correct PCS calibration.
  • Use the PCS front panel to install the correct initial setup for the generator set.

Go to 2A

Go to 7A

Guided Step 2 - Check the AC output current accuracy.

Guided Step 2A - Verify the AC current at the alternator matches the AC current seen by the PowerCommand® Supervisor (PCS) control.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Attach a suitable digital multimeter or power analyzer to the alternator output leads.

Action

Verify that the AC current displayed on PCS is correct.

  • Use a digital multimeter or power analyses to measure the L1, L2, and L3 AC current and verify that they are consistent with the current displayed on PCS.

Current sensing OK?
YES NO
No Repair

Problem with the AC current sensing.

  • Use the PCS service manual for calibration procedure to calibrate the PCS sensed current.

Go to 2B

Go to 7A

Guided Step 2B - Check the load.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Keyswitch energized
  • Connect the electronic service tool.

Action

Check the load.

  • Connect InPower™ and verify that the load is within the generator sets operating range.

No overload condition exists?
YES NO
No Repair

Correct the calibration within the ECM.

  • Check for overload on the electrical system.
  • Check the load cables.
  • Use the PCS service manual for calibration procedure to calibrate the PCS sensed AC voltage and current.

Go to 3A

Go to 7A

Guided Step 3 - Check the alternator output leads.

Guided Step 3A - Inspect the alternator and the output leads.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the load cables from the alternator.

Action

Check the load.

  • Corroded posts
  • Loose connections.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged, corroded posts or loose connections?
YES NO
No Repair

Use the site documentation to repair the damaged, corroded posts, or loose connections.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from post to post.

Conditions

  • Run/Stop switch in Stop position.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the output leads.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Use the site installation documentation or OEM service manual to repair or replace the alternator.

Go to 4A

Go to 7A

Guided Step 4 - Check the AC Harness.

Guided Step 4A - Check the AC harness and PT/CT (A36) board connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the AC harness connector, current transformers and the current transformer connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Flush the dirt, debris, or moisture from the connector pin. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator set AC harness. Refer to Procedure 019-203 and Refer to Procedure 019-197 in Section 19.
  • Replace the Generator AC harness. Contact a Cummins® Authorized Repair Location.
  • Replace the damaged PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness connectors from the PT/CT (A36) board
  • Disconnect the generator set AC harness connectors from the current transformers.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each current transformer wire on the generator set AC harness PCS connector 09 to generator set ground.
  • Repeat the resistance checks for all other current transformer terminals.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Repair the generator set AC harness. Refer to Procedure 019-201, Refer to Procedure 019-205 and Refer to Procedure 019-207 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness connectors from the PT/CT (A36) board
  • Disconnect the generator set AC harness connectors from the current transformers.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each current transformers wire on the generator set AC harness connector 09 to all other wires on the generator set AC harness connector 09.
  • Repeat the resistance checks for all other current transformer wires on the generator set AC harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Repair the generator set AC harness. Refer to Procedure 019-203 in Section 19, and Refer to Procedure 019-197 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness from the PT/CT board (A36).
  • Disconnect the generator set AC harness from the current transformers.

Action

Check for an open circuit. in the AC harness

  • Measure the resistance of each current transformer wire on the generator set AC harness connector P08 to the corresponding wire on the generator set AC harness PCS connector P03.
  • Repeat the resistance check for all other current transformer wires in the generator set AC harness connector P08 to corresponding wires on the generator set AC harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Repair the generator set AC harness. Refer to Procedure 019-201, Refer to Procedure 019-207 or Refer to Procedure 019-205 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 7A

Guided Step 5 - Check the PT/CT (A36) board.

Guided Step 5A - Inspect the PT/CT (A36) board and the generator set control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for an open circuit. in the AC harness

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203, Refer to Procedure 019-205, and Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check the PT/CT (A36) board 3-ohm resistors.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PT/CT (A36) board 3 ohm resistors
  • Disconnect the generator set AC harness from the PT/CT (A36) board.

Action

Check the 3-ohm resistors from the PT/CT (A36) connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

3-ohm resistors good?
YES NO
No Repair

The 3-ohm resistors are damaged.

  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector wire on the generator set control harness PCS connector to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 5D

Go to 7A

Guided Step 5D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for an open circuit in the generator set control harness.

  • Measure the resistance of the GEN L1 wire on the generator set control harness PT/CT board connector 08 to GEN L1 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L1 COM wire on the generator set control harness PT/CT board connector 08 to GEN L1 COM connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L2 wire on the generator set control harness PT/CT board connector 08 to GEN L2 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L2 COM wire on the generator set control harness PT/CT board connector 08 to GEN L2 COM connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L3 wire on the generator set control harness PT/CT board connector 08 to GEN L3 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L3 COM wire on the generator set control harness PT/CT board connector 08 to GEN L3 COM connection on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 5E

Go to 7A

Guided Step 5E - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each PT/CT wire on the generator set control harness PCS connector P03 to all other wires on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 7A

Guided Step 6 - Check the generator control harness.

Guided Step 6A - Inspect the generator set control harness and the PowerCommand® Supervisor (PCS) connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Inspect the generator set control harness and PCS connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the BUS/PT (A39) board. Refer to Procedure 019-319 in Section 19.

Go to 6B

Go to 7A

Guided Step 6B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector wire on the generator set control harness PCS connector to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6C

Go to 7A

Guided Step 6C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each PT/CT (A36) board wire on the generator set control harness PCS connector P03 to all other wires on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6D

Go to 7A

Guided Step 6D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the PT/CT (A36) board connector wires on the generator set control harness board connector P08 to the aligned connection wire on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 7A

Guided Step 7A - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and run the generator set at rated rpm, no load for 1 minute.

Action

Disable the fault code.

  • Press the Reset button located on the PCS control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 1471 is inactive.

Fault Code 1471 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the PowerCommand® Supervisor (PCS). |
 | STEP 1A. Check the PCS for multiple active fault codes. | No other PCS fault codes active?
 | STEP 1B. Check the PCS calibration and generator set model selection are correct. | PCS calibration and generator set model selection correct?
 | STEP 1C. Verify that the initial setup of the PCS is correct. | Initial PCS setup correct?
STEP 2. | Check the alternator output current accuracy. |
 | STEP 2A. Verify the AC current at the alternator matches the AC current seen by the PowerCommand® Supervisor (PCS) control. | Current sensing OK?
 | STEP 2B. Check the load. | No overload condition exists?
STEP 3. | Check the output leads. |
 | STEP 3A. Inspect the alternator output leads. | No damaged, corroded posts or loose connections?
 | STEP 3B. Check for a short circuit from post to post. | Greater than 100k ohms?
STEP 4. | Check the generator set AC harness. |
 | STEP 4A. Check the generator set AC harness and PT/CT (A36) board connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the PT/CT (A36) board. |
 | STEP 5A. Inspect the PT/CT (A36) board and the generator set control harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the PT/CT (A36) board and 3 ohm resistors. | 3 ohm resistors are good?
 | STEP 5C. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 5D. Check for an open circuit. | Less than 10 ohms?
 | STEP 5E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 6. | Check the generator set control harness. |
 | STEP 6A. Inspect the generator set control harness and the PowerCommand® Supervisor (PCS) connector pins. | Dirty or damaged pins?
 | STEP 6B. Check for a short circuit to generator set ground. | Greater than 100k ohms?
 | STEP 6C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6D. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 1472 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the PowerCommand® Supervisor (PCS).

Guided Step 1A - Check the PCS for multiple active fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that there are no other active PCS fault codes.

  • Use the PCS alpha numeric display to check the PCS for multiple active fault codes.

No other PCS fault codes active?
YES NO
No Repair

Other PCS fault codes are active. Troubleshoot all other fault codes before proceeding to 7A.

Go to 1B

Appropriate troubleshooting steps

Guided Step 1B - Check the PCS calibration and model selection are correct.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that the PCS calibration is correct and the correct generator set model option is selected.

  • Use the PCS front panel, verify that the PCS calibration is correct and that the generator set model selection is correct for application.

PCS calibration and generator set model selection correct?
YES NO
No Repair

Use the appropriate PCS service manual to correct the PCS calibration and model selection.

  • Use InPower™ to install the correct PCS calibration.
  • Use the PCS front panel to select the correct generator set model from the options listed (to match application).

Go to 1C

Go to 7A

Guided Step 1C - Verify that the initial setup of the PCS is correct.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Verify that the initial setup of the generator set was installed correctly in PCS (for generator set model selected).

  • Use the PCS front panel to verify that the initial setup of the generator set is correctly installed.

Initial PCS setup correct?
YES NO
No Repair

Use the appropriate PCS service manual to correct the initial setup of the generator set within PCS.

  • Use InPower™ to install the correct PCS calibration.
  • Use the PCS front panel to install the correct initial setup for the generator set.

Go to 2A

Go to 7A

Guided Step 2 - Check the AC output current accuracy.

Guided Step 2A - Verify the AC current at the alternator matches the AC current seen by the PowerCommand® Supervisor (PCS) control.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Attach a suitable digital multimeter or power analyzer to the alternator output leads.

Action

Verify that the AC current displayed on PCS is correct.

  • Use a digital multimeter or power analyses to measure the L1, L2, and L3 AC current and verify that they are consistent with the current displayed on PCS.

Current sensing OK?
YES NO
No Repair

Problem with the AC current sensing.

  • Use the PCS service manual for calibration procedure to calibrate the PCS sensed current.

Go to 2B

Go to 7A

Guided Step 2B - Check the load.

Conditions

  • Run/Stop/Auto switch in Run mode
  • Keyswitch energized
  • Connect the electronic service tool

Action

Check the load.

  • Connect InPower™ and verify that the load is within the generator sets operating range.

No overload condition exists?
YES NO
No Repair

Correct the calibration within the ECM.

  • Check for overload on the electrical system.
  • Check the load cables.
  • Use the PCS service manual for calibration procedure to calibrate the PCS sensed AC voltage and current.

Go to 3A

Go to 7A

Guided Step 3 - Check the alternator output leads.

Guided Step 3A - Inspect the alternator and the output leads.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the load cables from the alternator.

Action

Check the load.

  • Corroded posts
  • Loose connections.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged, corroded posts or loose connections?
YES NO
No Repair

Use the site documentation to repair the damaged, corroded posts, or loose connections.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from post to post.

Conditions

  • Run/Stop switch in Stop position.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the output leads.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Use the site installation documentation or OEM service manual to repair or replace the alternator.

Go to 4A

Go to 7A

Guided Step 4 - Check the AC Harness.

Guided Step 4A - Check the AC harness and PT/CT (A36) board connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the AC harness connector, current transformers and the current transformer connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Flush the dirt, debris, or moisture from the connector pin. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator set AC harness. Refer to Procedure 019-203 and Refer to Procedure 019-197 in Section 19.
  • Replace the Generator AC harness. Contact a Cummins® Authorized Repair Location.
  • Replace the damaged PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness connectors from the PT/CT (A36) board
  • Disconnect the generator set AC harness connectors from the current transformers.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each current transformer wire on the generator set AC harness PCS connector P09 to generator set ground.
  • Repeat the resistance checks for all other current transformer terminals.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Repair the generator set AC harness. Refer to Procedure 019-201, Refer to Procedure 019-205 and Refer to Procedure 019-207 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness connectors from the PT/CT (A36) board
  • Disconnect the generator set AC harness connectors from the current transformers.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from each current transformers wire on the generator set AC harness connector P09 to all other wires on the generator set AC harness connector P09.
  • Repeat the resistance checks for all other current transformer wires on the generator set AC harness connector P09.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Repair the generator set AC harness. Refer to Procedure 019-203 in Section 19, and Refer to Procedure 019-197 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set AC harness from the PT/CT board (A36)
  • Disconnect the generator set AC harness from the current transformers.

Action

Check for an open circuit. in the AC harness

  • Measure the resistance of each current transformer wire on the generator set AC harness connector P08 to the corresponding wire on the generator set AC harness PCS connector P03.
  • Repeat the resistance check for all other current transformer wires in the generator set AC harness connector P08 to corresponding wires on the generator set AC harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set AC harness.

  • Repair the generator set AC harness. Refer to Procedure 019-201, Refer to Procedure 019-207 or Refer to Procedure 019-205 in Section 19.
  • Replace the generator set AC harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 7A

Guided Step 5 - Check the PT/CT (A36) board.

Guided Step 5A - Inspect the PT/CT (A36) board and the generator set control harness connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for an open circuit. in the AC harness

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203, Refer to Procedure 019-205, and Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check the PT/CT (A36) board 3-ohm resistors.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PT/CT (A36) board 3 ohm resistors
  • Disconnect the generator set AC harness from the PT/CT (A36) board.

Action

Check the 3-ohm resistors from the PT/CT (A36) connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

3-ohm resistors good?
YES NO
No Repair

The 3-ohm resistors is damaged.

  • Replace the PT/CT (A36) board. Refer to Procedure 019-318 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector wire on the generator set control harness PCS connector P03 to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 5D

Go to 7A

Guided Step 5D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for an open circuit in the generator set control harness.

  • Measure the resistance of the GEN L1 wire on the generator set control harness PT/CT board connector 08 to GEN L1 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L1 COM wire on the generator set control harness PT/CT board connector 08 to GEN L1 COM connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L2 wire on the generator set control harness PT/CT board connector 08 to GEN L2 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L2 COM wire on the generator set control harness PT/CT board connector 08 to GEN L2 COM connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L3 wire on the generator set control harness PT/CT board connector 08 to GEN L3 connection on the generator set control harness PCS connector P03.
  • Measure the resistance of the GEN L3 COM wire on the generator set control harness PT/CT board connector 08 to GEN L3 COM connection on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 5E

Go to 7A

Guided Step 5E - Check for a short circuit from pin to pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the PCS
  • Disconnect the generator control harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each PT/CT wire on the generator set control harness PCS connector P03 to all other wires on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 7A

Guided Step 6 - Check the generator control harness.

Guided Step 6A - Inspect the generator set control harness and the PowerCommand® Supervisor (PCS) connector pins.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Inspect the generator set control harness and PCS connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Contact a Cummins® Authorized Repair Location.
  • Replace the BUS/PT (A39) board. Refer to Procedure 019-319 in Section 19.

Go to 6B

Go to 7A

Guided Step 6B - Check for a short circuit to generator set ground.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for a short circuit to generator set ground.

  • Measure the resistance of each PT/CT (A36) board connector wire on the generator set control harness PCS connector P03 to generator set ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6C

Go to 7A

Guided Step 6C - Check for a short circuit from pin-to-pin.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each PT/CT (A36) board wire on the generator set control harness PCS connector P03 to all other wires on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 6D

Go to 7A

Guided Step 6D - Check for an open circuit.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator set control harness from the PCS
  • Disconnect the generator set control harness from the PT/CT (A36) board.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the PT/CT (A36) board connector wires on the generator set control harness board connector P08 to the aligned connection wire on the generator set control harness PCS connector P03.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator set control harness.

  • Repair the generator set control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control harness. Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 7A

Guided Step 7A - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and run the generator set at rated rpm, no load for 1 minute.

Action

Disable the fault code.

  • Press the Reset button located on the PCS control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 1472 is inactive.

Fault Code 1472 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Software Compatibility |
 | STEP 1A. Check for Software Compatibility | Is Fault Code 1474 Active?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for Software Compatibility

Guided Step 1A - Check for Software Compatibility

Conditions

  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch on the PowerCommand® Supervisor front panel is in Stop mode.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the software version of the ECM.

Is Fault Code 1474 active?
YES NO

Use INSITE™ electronic service tool to load compatible software into the ECM.

 No Repair

Repair complete.

Repair complete.

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch on the PowerCommand® Supervisor front panel is in Stop mode.
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 455, 511, 2311, or 2867 active?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator position signal voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for open circuit. | Less than 10 ohms?
 | STEP 3D. Check the position feedback signal voltage. | 0 to 5-VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 1761 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 1761 inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 455, 511, 2311, or 2867 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel control valve actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the actuator position signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator position signal voltage.

  • Use a multimeter to measure the signal voltage. The pulse-width modulated signal must be alternating between positive (+) 24-VDC and 0-VDC.

24-VDC?
YES NO
No Repair

Check the power supply connections and fuses in the power supply wires to the CM558. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, for the appropriate circuit.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel control valve actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the fuel control valve actuator position feedback pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve actuator position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the fuel control valve actuator position feedback pin on the engine harness connector to the fuel control valve actuator position feedback pin on the engine harness sensor connector.
  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to the fuel control valve actuator return pin on the engine harness sensor connector.
  • Measure the resistance from the fuel control valve actuator position signal pin on the engine harness connector to the fuel control valve actuator position signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the position feedback signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator position feedback signal.

  • Use INSITE™ electronic service tool to monitor the fuel control valve feedback position.

0 to 5-VDC?
YES NO
No Repair

Replace the fuel control valve. Use the Troubleshooting and Repair Manual, QSK19G Generator Set, Bulletin 4021372 for the following procedure. Refer to Procedure 006-049 in Section 6

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 1761 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™electronic service tool to verify that Fault Code 1761 is inactive.

Fault Code 1761 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the fuel delivery pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.53-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 1827 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 1827 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel delivery pressure sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to Sensor Supply 1 Circuit - Voltage above normal, or shorted to high source, Fault Code 386.

Go to 2A

Guided Step 2 - Check the Fuel Delivery Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel delivery pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel delivery pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the fuel delivery pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ the electronic service tool.

Action

Check the fuel delivery pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the fuel delivery pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the Fuel Delivery Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel delivery pressure sensor and the CM558.

Action

Inspect the wiring harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel delivery pressure sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel delivery pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel delivery pressure sensor.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the fuel delivery pressure sensor connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 547 or Fault Code 1828 will become active upon disconnecting the sensor.

Fault Code 1827 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check CM558 signal pin resistance.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel delivery pressure sensor signal pin on the CM558 to the CM558 supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electrical service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and idle for 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1827 is inactive.

Fault Code 1827 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable.Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the fuel delivery pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.53-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 1828 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 1828 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel delivery pressure sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply 2 Circuit - Voltage above normal, or shorted to high source, Fault Code 227.

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness connector from the fuel delivery pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel delivery pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Install the fuel delivery pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel delivery pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Install the fuel delivery pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel delivery pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the fuel delivery pressure sensor and the CM558.

Action

Inspect the wiring harness and extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel delivery pressure sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel delivery pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Go to 3C

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.
Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the fuel delivery pressure sensor.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the fuel delivery pressure sensor connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the fuel delivery pressure sensor supply pin and the fuel delivery pressure sensor signal pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 546 or Fault Code 1827 will become active upon installing the jumper wire.

Fault Code 1828 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check CM558 signal pin resistance.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel delivery pressure sensor signal pin on the CM558 to the CM558 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault codes is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electrical service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run position and idle for 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1828 is inactive.

Fault Code 1828 inactive?

Operation mode switch in Auto position.
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1837 active?
STEP 2. | Check the engine speed/position sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor for damage. | Damaged engine speed/position sensor?
 | STEP 2C. Check the resistance of the sensor. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2E. Check for a short circuit between coils. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 2k ohms?
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1837 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Connect the electronic service tool.

Action

Read the fault codes.

Use the electronic service tool to read the fault codes.

Fault Code 1837 active?
YES NO
No Repair

Use the electronic service tool to clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check the engine speed/position sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine speed/position sensor.

Action

Inspect the engine harness and engine speed/position sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed/position sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine speed/position sensor.

Action

Inspect the engine speed/position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Damaged engine camshaft speed/position sensor?
YES NO

  • Repair or replace the engine camshaft speed/position sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine speed/position sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine speed/position sensor signal positive (+) pin to the engine speed/position sensor return negative (-) pin in the engine speed/position sensor connector.
  • Measure the resistance from the engine speed/position sensor backup signal positive (+) pin to the engine speed/position sensor backup return negative (-) pin in the engine speed/position sensor connector.

Note: While testing the sensor, electrical leads must be gently flexed to check for damage or partially cracked wires under the insulation.

Less than 2k ohms?
YES NO
No Repair

  • Repair or replace the engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine speed/position sensor
  • Engine speed/position sensor installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the signal pin in the engine speed/position sensor to the engine block ground.

Note: While testing the sensor, electrical leads must be gently flexed to check for damage or partially cracked wires under the insulation.

More than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit between coils.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine speed/position sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed/position sensor signal pin of one coil and the engine speed/position sensor signal pin of the other coil.
  • Measure the resistance between the engine speed/position sensor return pin to the engine speed/position sensor return pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially cracked wires under the insulation.

More than 100k ohms?
YES NO
No Repair

  • Repair or replace the engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Connect the engine harness to the engine speed/position sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed/position sensor signal pin on the engine harness connector to the speed/position sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 2k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the engine speed/position sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine speed/position sensor signal pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the engine speed/position sensor.

Action

Check for a short circuit pin to pin.

  • Measure the resistance between the engine speed/position sensor signal pin and all other pins of the engine harness connector.
  • Measure the resistance between the engine speed/position sensor return pin and all other pins of the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 1837 is inactive.

Fault Code 1837 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


FAULT CODE 2188 - Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperatures and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 441, 442, 477, or 478 are not active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage. | 11.0 to 14.0-VDC?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2188 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Keyswitch circuit energized
  • Place run/stop/auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Codes 441, 442, 477, or 478 are not active?

YES NO

Troubleshoot any active fault codes before proceeding.

 No Repair

Appropriate Troubleshooting Chart

Go to 2A

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in the Stop mode
  • Disconnect engine harness connectors from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in the Stop mode
  • Disconnect engine harness connectors from the CM558.

Action

Inspect the engine harness and CM558 connector pins for the following.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage.

Conditions

  • Keyswitch circuit energized
  • Place run/stop/auto switch in the Run mode and running
  • Disconnect engine harness from the NGK inline module power connector.

Action

Check the supply voltage.

  • Measure the supply voltage from the heated oxygen heater positive (+) to the heated oxygen heater negative (-) pin in the engine harness sensor connector.

11.0 to 14.0-VDC?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in the Stop mode
  • Disconnect the engine harness connector from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check the supply voltage.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to the heated oxygen reference signal pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference return pin in the engine harness CM558 connector to the heated oxygen reference return pin in the engine harness sensor connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in the Stop mode
  • Disconnect the engine harness connector from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to all other pins in the connector.
  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to all other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Connect all components
  • Place run/stop/auto switch in the Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2188 is inactive.

Fault Code 2188 is inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Place run/stop/auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Mar-2012


FAULT CODE 2192 - Heated Oxygen Sensor Heater Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 441, 442, 477, or 478 are not active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage. | 11.0 to 14.0-VDC?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2192 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 are not active?

YES NO

Troubleshoot any active fault codes before proceeding.

 No Repair

Appropriate Troubleshooting Chart

Go to 2A

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect engine harness connectors from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 and Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect engine harness connectors from the CM558.

Action

Inspect the engine harness and CM558 connector pins for the following.

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Run mode and running
  • Disconnect engine harness from the NGK inline module power connector.

Action

Check the supply voltage.

  • Measure the supply voltage from the heated oxygen heater positive (+) pin to the heated oxygen heater negative (-) pin in the engine harness sensor connector.

11.0 to 14.0-VDC?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect the engine harness connector from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for an open circuit.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to the heated oxygen reference signal pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference return pin in the engine harness CM558 connector to the heated oxygen reference return pin in the engine harness sensor connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Disconnect the engine harness connector from the CM558
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to all other pins in the connector.
  • Measure the resistance from the heated oxygen reference signal pin in the engine harness CM558 connector to all other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Connect all components
  • Place run/stop/auto switch in the Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2192 is inactive.

Fault Code 2192 is inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Mar-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2199 active?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor for damage. | Damaged engine speed sensor?
 | STEP 2C. Check the resistance of the sensor. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit between coils. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 2k ohms?
 | STEP 3C. Check for short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2199 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2199 active?
YES NO
No Repair

Use the electronic service tool to clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Inspect the engine harness and engine speed sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Engine Speed Sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in the sensing end of the sensor.

Damaged engine speed sensor?
YES NO

Repair or replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine speed sensor signal positive (+) pin to the engine speed sensor return negative (-) pin in the engine speed sensor connector.

NOTE: While testing the sensor, electrical leads must be gently flexed to check for damage or partially broken wires under the insulation.

Less than 2k ohms?
YES NO
No Repair

Repair or replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the engine speed sensor
  • Engine speed sensor installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the signal pin in the engine speed sensor to the engine block ground.

NOTE: While testing the sensor, electrical leads must be gently flexed to check for damage or partially broken wires under the insulation.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit between coils.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor signal pin of one coil and the engine speed sensor signal pin of the other coil.
  • Measure the resistance between the engine speed sensor return pin to the engine speed sensor return pin of the other coil.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 Refer to Procedure and 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor signal pin of the engine harness connector to the engine speed sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 2k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 Refer to Procedure and 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor signal pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 Refer to Procedure and 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit pin to pin.

  • Measure the resistance between the engine speed sensor signal pin and all other pins of the engine harness connector.
  • Measure the resistance between the engine speed sensor return pin and all other pins of the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 Refer to Procedure and 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2199 is inactive.

Fault Code 2199 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-Oct-2014


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 546, 1827, 547, or 1828 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 546, 1827, 547, or 1828 active?
YES NO
No Repair

Check the pressure regulator setting. Verify that the installation guidelines have been followed.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Acknowledge the fault code. | Fault Code 2235 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Use the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372, to troubleshoot combustion knocks. Use the following symptom tree. Engine Noise - Combustion Knocks.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Acknowledge the fault codes.

Conditions

  • Connect all components
  • Run/Stop/Auto switch in Run Mode
  • Connect INSITE™ electronic service tool
  • Reset the engine - press the Reset button, located on the generator control front panel.

Action

Clear the fault codes.

  • Start the generator set in Run mode and allow it to run at rated speed, no load for 1 minute.
  • Press the Reset button located on the generator control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 2235 is inactive.

Fault Code 2235 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Acknowledge the fault code. | Fault Code 2236 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Use the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372, to troubleshoot combustion knocks. Use the following symptom tree. Engine Noise - Combustion Knocks.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Acknowledge the fault codes.

Conditions

  • Connect all components
  • Run/Stop/Auto switch in Run Mode
  • Connect INSITE™ electronic service tool
  • Reset the engine - press the Reset button, located on the generator control front panel.

Action

Clear the fault codes.

  • Start the generator set in Run mode and allow it to run at rated speed, no load for 1 minute.
  • Press the Reset button located on the generator control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 2236 is inactive.

Fault Code 2236 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator supply voltage. | 24-VDC?
 | STEP 2C. Check the actuator signal Voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2311 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2311 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Fuel Control Valve Actuator.

Guided Step 2A - Inspect the actuator and the harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Repair or replace the engine harness or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check actuator supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator supply voltage.

  • Measure the supply voltage with a multimeter.

24-VDC?
YES NO
No Repair

Check the power supply connections and the fuses. Use the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check actuator signal voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator signal voltage.

  • Measure the signal voltage with a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24-VDC and 0-VDC.

24-VDC?
YES NO

Replace the fuel control valve. Use the Troubleshooting and Repair Manual QSK19G Generator Set, Bulletin 4021372 for the following procedure. Refer to Procedure 006-049 in Section 6.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the fuel control valve actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

A damaged connection has been detected in the ECM connector or fuel control valve actuator connector.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve actuator signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel control valve actuator supply pin on the engine harness connector to the fuel control valve actuator supply pin on the engine harness connector.
  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to the fuel control valve actuator return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the fuel control valve actuator connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 511 will become active upon disconnecting the actuator.

Fault Code 2311 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2311 is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the fuel outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2427 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2427 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel outlet pressure sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to the Sensor Supply 1 Circuit - Voltage above normal, or shorted to high source, Fault Code 386.

Go to 2A

Guided Step 2 - Check the Fuel Outlet Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the fuel outlet pressure sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the engine harness or the fuel outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel outlet pressure sensor supply voltage.

  • Measure the supply voltage by the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the signal voltage by the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the fuel outlet pressure sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the engine harness or the fuel outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel outlet pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Fuel Outlet Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to fuel outlet pressure return pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to fuel outlet pressure signal pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to fuel outlet pressure supply pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the fuel outlet pressure sensor connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 2428 will become active upon disconnecting the sensor.

Fault Code 2427 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel outlet pressure signal pin on the CM558 to the CM558 sensor supply circuit number 1 pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2427 is inactive.

Fault Code 2427 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the fuel outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2428 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2428 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel outlet pressure sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to the Sensor Supply 1 Circuit - Voltage below normal, or shorted to low source, Fault Code 352.

Go to 2A

Guided Step 2 - Check the fuel outlet pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the fuel outlet pressure sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel outlet pressure sensor supply voltage.

  • Measure the supply voltage by the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the signal voltage by the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Fuel Outlet Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel outlet pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to fuel outlet pressure return pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to fuel outlet pressure signal pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to fuel outlet pressure supply pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the QSK19G CM558 Generator Drive (GD) Wiring Diagram, Bulletin 4021358, to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the fuel outlet pressure sensor connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes
  • Install a jumper wire between the fuel outlet pressure supply pin and the fuel outlet pressure signal pin of the sensor connector.

NOTE: Fault Code 2427 will become active upon installing the jumper.

Fault Code 2428 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel outlet pressure signal pin on the CM558 to the CM558 sensor supply circuit number 1 pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2428 is inactive.

Fault Code 2428 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2435 active?
 | STEP 1B. Check the knock sensor. | Any knock sensor damage?
 | STEP 1C. Check the overhead adjustment. | Valve adjustment within specification?
 | STEP 1D. Check for in-cylinder damage. | Evidence of damage?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Acknowledge the fault code. | Fault Code 2435 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2435 active?
YES NO

Use the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372, to troubleshoot combustion knocks, use the following symptom tree. Engine Noise - Combustion Knocks.

No Repair

Go to 1B

Go to 2B

Guided Step 1B - Check the knock sensor.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the harness from cylinder 5 knock sensor.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face
  • Damage to the mounting stud or bolt
  • Poor installation, such as sensor loose on mounting
  • Poor harness connection, loose connector or corroded contact pins
  • Use the following procedure to make sure the knock sensor is correctly tightened. Refer to Procedure 019-346 in Section 19.

Any knock sensor damage?
YES NO

Repair or replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the overhead adjustment.

Conditions

  • Carry out the necessary generator set isolation and lock-out procedures
  • Run/Stop/Auto switch in STOP mode.

Action

Check the overhead adjustment.

  • Use the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372, for the following procedure to set the overhead. Refer to Procedure 003-004 in Section 3.

Valve adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Use the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372, for the following procedure to set the overhead. Refer to Procedure 003-004 in Section 3.

Go to 1D

Go to 2A

Guided Step 1D - Check for in-cylinder damage.

Conditions

  • Carry out the necessary generator set isolation and lock-out procedures
  • Run/Stop/Auto switch in STOP mode.

Action

Check the following possible in-cylinder damage.

  • Evidence of detonation/knocking
  • Compression too low (power cylinder damage)
  • Compression too high (in-cylinder deposits)
  • Valve leakage
  • Spark plug damage, such as metal flakes, molten aluminium, and missing spark plug ground electrodes
  • Fuel quality (low methane index number, contaminants, etc).

Evidence of damage?
YES NO

Replace the affected components.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Acknowledge the fault codes.

Conditions

  • Connect all components
  • Run/Stop/Auto switch in Run Mode
  • Connect INSITE™ electronic service tool
  • Reset the engine - press the Reset button, located on the generator control front panel.

Action

Clear the fault codes.

  • Start the generator set in Run mode and allow it to run at rated speed, no load for 1 minute.
  • Press the Reset button located on the generator control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 2435 is inactive.

Fault Code 2435 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Reset the engine - press the Reset button located on the generator control front panel

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2436 active?
 | STEP 1B. Check the knock sensor. | Any knock sensor damage?
 | STEP 1C. Check the overhead adjustment. | Valve adjustment within specification?
 | STEP 1D. Check for in-cylinder damage. | Evidence of damage?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Acknowledge the fault code. | Fault Code 2436 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2436 active?
YES NO

Use the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372, to troubleshoot combustion knocks, use the following symptom tree. Engine Noise - Combustion Knocks.

No Repair

Go to 1B

Go to 2B

Guided Step 1B - Check the knock sensor.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the harness from cylinder 6 knock sensor.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face
  • Damage to the mounting stud or bolt
  • Poor installation, such as sensor loose on mounting
  • Poor harness connection, loose connector or corroded contact pins
  • Use the following procedure to make sure the knock sensor is correctly tightened. Refer to Procedure 019-346 in Section 19.

Any knock sensor damage?
YES NO

Repair or replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the overhead adjustment.

Conditions

  • Carry out the necessary generator set isolation and lock-out procedures
  • Run/Stop/Auto switch in STOP mode.

Action

Check the overhead adjustment.

  • Use the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372, for the following procedure to set the overhead. Refer to Procedure 003-004 in Section 3.

Valve adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Use the QSK19G Generator Set Troubleshooting and Repair Manual, Bulletin 4021372, for the following procedure to set the overhead. Refer to Procedure 003-004 in Section 3.

Go to 1D

Go to 2A

Guided Step 1D - Check for in-cylinder damage.

Conditions

  • Carry out the necessary generator set isolation and lock-out procedures
  • Run/Stop/Auto switch in STOP mode.

Action

Check the following possible in-cylinder damage.

  • Evidence of detonation/knocking
  • Compression too low (power cylinder damage)
  • Compression too high (in-cylinder deposits)
  • Valve leakage
  • Spark plug damage, such as metal flakes, molten aluminium, and missing spark plug ground electrodes
  • Fuel quality (low methane index number, contaminants, etc).

Evidence of damage?
YES NO

Replace the affected components.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Acknowledge the fault codes.

Conditions

  • Connect all components
  • Run/Stop/Auto switch in Run Mode
  • Connect INSITE™ electronic service tool
  • Reset the engine - press the Reset button, located on the generator control front panel.

Action

Clear the fault codes.

  • Start the generator set in Run mode and allow it to run at rated speed, no load for 1 minute.
  • Press the Reset button located on the generator control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 2436 is inactive.

Fault Code 2436 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Reset the engine - press the Reset button located on the generator control front panel

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2444 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Troubleshoot the proprietary data link circuit. Refer to Procedure 019-417 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and run the generator set at rated rpm, no load for 1 minute.

Action

Disable the fault code.

  • Press the Reset button located on the PCS control front panel.
  • Use INSITE™ electronic service tool to verify that Fault Code 2444 is inactive.

Fault Code 2444 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the CM700.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wiring harness. |
 | STEP 1A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1C. Check for an open circuit. | Less than 10 ohms?
STEP 2. | Check the speed bias signal. |
 | STEP 2A. Inspect the speed bias termination. | Dirty or damaged pins?
 | STEP 2B. Check the speed bias signal frequency at terminal strip TB31. | Between 2.5 kHz and 3.5 kHz?
STEP 3. | Check for a CM700 response. |
 | STEP 3A. Check for the appropriate CM700 response. | Fault Code 2455 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 2455 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the wiring harness.

Guided Step 1A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the CM700 main harness connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the CM700 main harness connector.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance from the speed bias signal pin on the CM700 harness connector to all other pins in the CM700 harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pin. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 4A

Guided Step 1C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the CM700 main harness connector.

Action

Check for an open circuit in the speed bias signal wire.

  • Measure the resistance from the pin on the harness connector to the speed bias signal pin on terminal strip TB31.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pin. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the speed bias signal.

Guided Step 2A - Inspect the speed bias signal terminations.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode.

Action

Inspect the terminations on treminal strip TB31.

  • Corroded contacts
  • Moisture
  • Missing or damaged terminations
  • Dirt or debris in or on the terminations.

Damaged terminations?
YES NO

Repair the damaged terminations.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the speed bias signal frequency at terminal strip TB31.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running.

Action

Check the speed bias signal frequency.

  • Measure the speed bias signal frequency with a multimeter.

Between 2.5 and 3.5 kHz?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 4A

Guided Step 3 - Check for a CM700 response.

Guided Step 3A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2455 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2455 is inactive.

Fault Code 2455 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Go to the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2482 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2482 active?
YES NO
No Repair

Go to the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 175, 176, 512, or 513 active?
STEP 2. | Check the throttle driver and actuator. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver position signal voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 2519 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 2519 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 175, 176, 512, or 513 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver and actuator.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver and actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the Throttle Driver and Actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the throttle driver. Refer to Procedure 019-429 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver position signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Remove the cover from the throttle driver
  • Connect the electronic service tool.

Action

Check the throttle driver position signal voltage.

  • Measure the signal voltage using a multimeter. The pulse-width modulated signal should be alternating between positive (+) 24-VDC and 0-VDC.

24-VDC?
YES NO

Inspect the throttle actuator coupling for damage. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Check the power supply connections and fuses in the power supply wires to the CM558. Use the circuit diagram or engine wiring harness diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the throttle driver and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the throttle driver position feedback pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the throttle driver position feedback pin on the engine harness connector to the throttle driver position feedback pin on the engine harness sensor connector.
  • Measure the resistance from the throttle driver return pin on the engine harness connector to the throttle driver return pin on the engine harness sensor connector.
  • Measure the resistance from the throttle driver position signal pin on the engine harness connector to the throttle driver position signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for 1 minute
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use the electronic service tool to verify the fault codes.

Fault Code 2519 is inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 2519 is inactive.

Fault Code 2519 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Go to the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


FAULT CODE 2544 - Engine ECU Temperature - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2544 active?
YES NO

Allow the ECM to cool and then restart the generator set. If the fault reoccurs, check for correct air flow over the generator set (ventilation fans running, air inlet vents or grills are clear of debris, no obstructions to air flow, etc.). If the fault persists, replace the ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Place run/stop/auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Use the following procedure for proprietary data link circuit troubleshooting procedures. Refer to Procedure 019-417 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Refer to Procedure 019-417 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the valve supply voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2864 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2864 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Use the Troubleshooting and Repair Manual, QSK19G Generator Set, Bulletin 4021372 for the following procedure. Refer to Procedure 005-044 in Section 5.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

NOTE: Make Certain the engine is not performing a purge cycle when making this measurement.

24-VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the engine harness connector from the fuel shutoff valve
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 response.

  • Remove the fuel shutoff valve relays and crank the engine. Use the circuit diagram or the wiring diagram to identify connectors and pins.
  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 2864 will become active.

Fault Code 2864 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2864 is inactive.

Fault Code 2864 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the Fuel Control Valve Actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator supply voltage. | 24-VDC?
 | STEP 2C. Check the actuator signal voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2867 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2867 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Fuel Control Valve Actuator.

Guided Step 2A - Inspect the actuator and the harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins

Repair or replace the engine harness or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check actuator supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator supply voltage.

  • Measure the supply voltage with a multimeter.

24-VDC?
YES NO
No Repair

Check the power supply connections and the fuses. Use the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 5A

Guided Step 2C - Check actuator signal voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the fuel control valve actuator
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve actuator signal voltage.

  • Measure the signal voltage with a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24-VDC and 0-VDC.

24-VDC?
YES NO

Replace the fuel control valve. Use the Troubleshooting and Repair Manual, QSK19G Generator Set, Bulletin 4021372 for the following procedure. Refer to Procedure 006-049 in Section 6 in Section 6.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the fuel control valve actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve actuator signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel control valve actuator

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel control valve actuator supply pin on the engine harness connector to the fuel control valve actuator supply pin on the engine harness connector.
  • Measure the resistance from the fuel control valve actuator return pin on the engine harness connector to the fuel control valve actuator return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram in to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the fuel control valve actuator connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the fuel control valve actuator supply pin and the fuel control valve actuator signal pin of the sensor connector.
  • Check for the appropriate CM558 response after thirty seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 2867 will become active upon installing the jumper.

Fault Code 2867 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2867 is inactive.

Fault Code 2867 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 2994 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 2994. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to verify that the Fault Code 2994 is inactive.

Fault Code 2994 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 2994.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Check the inactive counts of Fault Code 2994.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 2994.

Less than three counts?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart


INDEX
58-fc111.htm

58-t05-111.htm

58-fc121.htm

58-t05-121.htm

58-fc153.htm

58-t05-153.htm

58-fc154.htm

58-t05-154.htm

58-fc155.htm

58-t05-155.htm

58-fc175.htm

58-t05-175.htm

58-fc176.htm

58-t05-176.htm

58-fc177.htm

58-t05-177.htm

58-fc187.htm

58-t05-187.htm

58-fc227.htm

58-t05-227.htm

58-fc234.htm

58-t05-234.htm

58-fc238.htm

58-t05-238.htm

58-fc239.htm

58-t05-239.htm

58-fc254.htm

58-t05-254.htm

58-fc255.htm

58-t05-255.htm

58-fc346.htm

58-t05-346.htm

58-fc352.htm

58-t05-352.htm

58-fc354.htm

58-t05-354.htm

58-fc355.htm

58-t05-355.htm

58-fc359.htm

58-t05-359.htm

58-fc386.htm

58-t05-386.htm

58-fc412.htm

58-t05-412.htm

58-fc414.htm

58-t05-414.htm

58-fc426.htm

58-t05-426.htm

58-fc427.htm

58-t05-427.htm

58-fc441.htm

58-t05-441.htm

58-fc442.htm

58-t05-442.htm

58-fc453.htm

58-t05-453.htm

58-fc454.htm

58-t05-454.htm

58-fc455.htm

58-t05-455.htm

58-fc458.htm

58-t05-458.htm

58-fc459.htm

58-t05-459.htm

58-fc461.htm

58-t05-461.htm

58-fc462.htm

58-t05-462.htm

58-fc463.htm

58-t05-463.htm

58-fc464.htm

58-t05-464.htm

58-fc477.htm

58-t05-477.htm

58-fc478.htm

58-t05-478.htm

58-fc488.htm

58-t05-488.htm

58-fc511.htm

58-t05-511.htm

58-fc512.htm

58-t05-512.htm

58-fc513.htm

58-t05-513.htm

58-fc514.htm

58-t05-514.htm

58-fc546.htm

58-t05-546.htm

58-fc547.htm

58-t05-547.htm

58-fc565.htm

58-t05-565.htm

58-fc566.htm

58-t05-566.htm

58-fc584.htm

58-t05-584.htm

58-fc585.htm

58-t05-585.htm

58-fc591.htm

58-t05-591.htm

58-fc592.htm

58-t05-592.htm

58-fc689.htm

00-t05-689.htm

58-fc697.htm

58-t05-697.htm

58-fc698.htm

58-t05-698.htm

58-fc751.htm

58-t05-751.htm

58-fc752.htm

58-t05-752.htm

58-fc753.htm

58-t05-753.htm

58-fc1434.htm

58-t05-1434.htm

58-fc1445.htm

58-t05-1445.htm

58-fc1446.htm

58-t05-1446.htm

58-fc1447.htm

58-t05-1447.htm

58-fc1448.htm

58-t05-1448.htm

58-fc1452.htm

58-t05-1452.htm

58-fc1457.htm

58-t05-1457.htm

58-fc1458.htm

58-t05-1458.htm

58-fc1459.htm

58-t05-1459.htm

58-fc1471.htm

58-t05-1471.htm

58-fc1472.htm

58-t05-1472.htm

58-fc1474.htm

58-t05-1474.htm

58-fc1761.htm

58-t05-1761.htm

58-fc1827.htm

58-t05-1827.htm

58-fc1828.htm

58-t05-1828.htm

58-fc1837.htm

58-t05-1837.htm

58-fc2188.htm

58-t05-2188.htm

58-fc2192.htm

58-t05-2192.htm

58-fc2199.htm

58-t05-2199.htm

58-fc2228.htm

58-t05-2228.htm

58-fc2235.htm

58-t05-2235.htm

58-fc2236.htm

58-t05-2236.htm

58-fc2311.htm

58-t05-2311.htm

58-fc2427.htm

58-t05-2427.htm

58-fc2428.htm

58-t05-2428.htm

58-fc2435.htm

58-t05-2435.htm

58-fc2436.htm

58-t05-2436.htm

58-fc2444.htm

58-t05-2444.htm

58-fc2455.htm

58-t05-2455.htm

58-fc2482.htm

58-t05-2482.htm

58-fc2483.htm

58-t05-2483.htm

58-fc2519.htm

58-t05-2519.htm

58-fc2526.htm

58-t05-2526.htm

58-fc2527.htm

58-t05-2527.htm

58-fc2544.htm

58-t05-2544.htm

58-fc2548.htm

58-t05-2548.htm

58-fc2768.htm

58-t05-2768.htm

58-fc2769.htm

58-t05-2769.htm

58-fc2864.htm

58-t05-2864.htm

58-fc2867.htm

58-t05-2867.htm

58-fc2994.htm

58-t05-2994.htm