Signature/ISX - CM870

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module (ECM) Microprocessor

FAULT CODE 111

Electronic Control Module (ECM) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the ECM related to memory hardware failures or internal ECM voltage supply circuits. | Engine may not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the intake side of the engine between the air horn and the front of the engine. Use Section E for a detailed component location view.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 02-Sep-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - shorted high. High signal voltage detected at the intake manifold pressure circuit. | Engine power derate
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Use Section E for a detailed component location view.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-122

Last Modified: 02-Sep-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - shorted low. Low signal voltage detected at intake manifold pressure circuit. | Derate in power output of the engine.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If intake manifold pressure becomes too low, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and Shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123 check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground, in the engine harness or sensor.
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-123

Last Modified: 02-Sep-2010


Accelerator Pedal Position Sensor Circuit

FAULT CODE 131

Accelerator Pedal Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal Position Sensor Circuit - shorted high. High signal voltage detected at accelerator pedal position circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator pedal position sensor is attached to the accelerator pedal. The accelerator pedal position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal is depressed and released. The accelerator pedal position circuit contains three wires: Accelerator Pedal Position +5 Volt Supply, Accelerator Pedal Position Return, and Accelerator Pedal Position Signal.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The accelerator pedal position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal circuit shorted to battery or +5 volt supply.
  • Open accelerator pedal return circuit in the harness or connections.
Refer to Troubleshooting Fault Code t05-131

Last Modified: 01-Sep-2010


Accelerator Pedal Position Sensor Circuit

FAULT CODE 132

Accelerator Pedal Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 091 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal Position Sensor Circuit - shorted low. Low voltage detected at accelerator pedal position signal circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator pedal position sensor is attached to the accelerator pedal. The accelerator pedal position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal is depressed and released. The accelerator pedal position circuit contains three wires: Accelerator Pedal Position Supply, Accelerator Pedal Position Return, and Accelerator Pedal Position Signal.

Component Location

The accelerator pedal position sensor is mounted to the accelerator pedal assembly.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The accelerator pedal position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor.
  • Failed accelerator pedal position sensor.
Refer to Troubleshooting Fault Code t05-132

Last Modified: 01-Sep-2010


Remote Accelerator Pedal or Lever Position Sensor Circuit

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 974 FMI: 3/3 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor Circuit - shorted high. High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator pedal or lever will not operate. Remote accelerator pedal or lever position will be set to zero percent.
Remote Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The remote accelerator pedal or lever provides the operators accelerator command to the electronic control module (ECM) through the OEM harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal or lever location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

Possible causes of this fault include:

  • Remote accelerator position sensor signal shorted to battery or 5 VDC supply.
  • Open remote accelerator pedal or lever position sensor return circuit in the OEM harness, connectors.
  • Failed remote accelerator pedal or lever position sensor.
Refer to Troubleshooting Fault Code t05-133

Last Modified: 01-Sep-2010


Remote Accelerator Pedal or Lever Position Sensor Circuit

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor Circuit - shorted low. Low signal voltage detected at remote accelerator pedal or lever position signal circuit. | Remote accelerator pedal or lever will not operate. Remote accelerator pedal or lever position will be set to zero percent.
Remote Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The remote accelerator pedal or lever provides the operators accelerator command to the electronic control module (ECM) through the OEM harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal or lever location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal circuit shorted to engine ground, return wires in the OEM harness, or sensor.
  • Open remote accelerator pedal or lever position signal circuit in the OEM harness or connectors.
  • Failed remote accelerator pedal or lever position sensor.
Refer to Troubleshooting Fault Code t05-134

Last Modified: 01-Sep-2010


Engine Oil Pressure Sensor Circuit

FAULT CODE 135

Engine Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Pressure Sensor Circuit - shorted high. High signal voltage detected at the engine oil pressure circuit. | No engine protection for engine oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil pressure sensor is located on the intake side of the engine block, below and to the rear of the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

The engine oil pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting fault code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return in the harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135

Last Modified: 01-Sep-2010


Engine Oil Pressure Sensor Circuit

FAULT CODE 141

Engine Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Pressure Sensor Circuit - Shorted Low. Low signal voltage detected at engine oil pressure circuit. | No engine protection for engine oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The engine oil pressure sensor is located on the intake side of the engine block, below and to the rear of the integrated fuel system module (IFSM).

Shop Talk

The engine oil pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Open signal wire in the harness, connectors, or sensor
  • Signal wire shorted to ground.
Refer to Troubleshooting Fault Code t05-141

Last Modified: 01-Sep-2010


Engine Oil Pressure Low - Warning

FAULT CODE 143

Engine Oil Pressure Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Pressure Low - Warning. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Oil Pressure

Circuit Description

The engine oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM) through the engine harness. If the oil pressure becomes too low based on engine speed, it will cause a derate condition.

Component Location

The engine oil pressure sensor is located on the left side of the engine block, below and to the rear of the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

The engine oil pressure sensor measures the pressure of the oil in the oil rifle on the left-hand side of the engine block.

Possible causes of this fault code include:

  • Mechanical failures such as lubricating oil pump, lubricating oil high pressure relief valve, loose lubricating oil filter
  • Breakdown or contamination of the lubricating oil
  • Plugged lubricating oil filter.
Refer to Troubleshooting Fault Code t05-143

Last Modified: 01-Sep-2010


Coolant Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Coolant Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Coolant Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for engine coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin, and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated form the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, sensor, or ECM
  • Open signal circuit or shorted to a voltage source.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-144

Last Modified: 02-Sep-2010


Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for engine coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Use Section E for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated form the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • signal shorted to ground in the harness or ECM
  • signal shorted to return or ground in the sensor.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-145

Last Modified: 02-Sep-2010


Engine Coolant Temperature High - Critical

FAULT CODE 151

Engine Coolant Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature High - Critical. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive engine speed increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Engine Coolant Temperature

Circuit Description

The engine coolant temperature sensor monitors coolant temperature and passes information to the electronic control module (ECM) through the engine harness. If the coolant temperature becomes too high, it will cause a derate condition. If the engine protection shutdown is enabled, the engine will shut down 30 seconds after the red stop lamp starts flashing.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine in the thermostat housing. Refer to Section E for a detailed component location view.

Shop Talk

The engine coolant temperature sensor measures the temperature of the engine coolant as it passes through the thermostat housing. This fault code is activated if the engine coolant temperature is above 116°C [241°F].

Possible causes of this fault code include:

  • Obstructed radiator
  • Plugged vent lines
  • Aerated coolant
  • Other cooling system failure.
Refer to Troubleshooting Fault Code t05-151

Last Modified: 01-Sep-2010


Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for intake manifold air temperature.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the ECM through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold air temperature sensor is located in the air intake connection. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness, Part Number 3682854, see the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, see the Separate Pressure/Temperature Sensor Return Circuit above.

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 153, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, sensor, or ECM
  • Open signal circuit or shorted to voltage source.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code t05-153

Last Modified: 02-Sep-2010


Intake Manifold Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for intake manifold air temperature.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold air temperature sensor is located in the air intake connection. Refer to Section E for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 154 check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness or ECM
  • Signal circuit shorted to return or ground in the sensor.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 29k to 36k
25 | 77 | 9k to 11k
40 | 104 | 4.9k to 5.8k
100 | 212 | 600 to 700
Refer to Troubleshooting Fault Code t05-154

Last Modified: 01-Sep-2010


Intake Manifold Air Temperature High - Critical

FAULT CODE 155

Intake Manifold Air Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold Air Temperature High - Critical. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive engine speed derate increasing in severity from time of alert. Engine will shut down 30 seconds after red stop lamp starts flashing if engine protection shutdown is enabled.
Intake Manifold Air Temperature High

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition. If engine protection shutdown is enabled, the engine will shut down 30 seconds after the red stop lamp starts flashing.

Component Location

The intake manifold air temperature sensor is located in the air intake horn. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge air (fresh air compressed by the turbocharger, cooled by the charge air cooler, and mixed with EGR) as it passes through the intake manifold. This fault code is activated if the intake manifold air temperature is above 132°C [270°F].

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault code include:

  • Plugged charge air cooler fins
  • Restricted airflow through the charge air cooler
  • Failed EGR differential pressure sensor, or leaks in sensor tubes
  • Undersized charge air cooler
  • High turbocharger compressor outlet temperature
  • Fouled EGR cooler
  • Stuck EGR valve.
Refer to Troubleshooting Fault Code t05-155

Last Modified: 02-Sep-2010


Sensor Supply Voltage Number 2 Circuit

FAULT CODE 187

Sensor Supply Voltage Number 2 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply Voltage Number 2 Circuit - shorted low. Low voltage detected at the sensor supply Number 2 circuit. | Engine will run derated. No engine protection for intake manifold air temperature.
Sensor Supply Voltage Number 2 Circuit

Circuit Description

The Sensor Supply Number 2 pin of the ECM provides (+) 5 VDC for the camshaft position sensor, exhaust gas pressure sensor, rail fuel pressure sensor, intake manifold pressure sensor, EGR valve position sensor, and EGR differential pressure sensor.

Component Location

Sensor Supply Number 2 is located in the ECM.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a failed sensor, or a failed ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time, unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code t05-187

Last Modified: 01-Sep-2010


Fault Code Path Selection

FAULT CODE 70-fc195
Fault Code Path Selection

View Related Topic

Is the coolant level sensor a 2-wire sensor? | Go to 70-fc195-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 70-fc195-3wire

Last Modified: 23-Mar-2010


Fault Code Path Selection

FAULT CODE 70-fc196
Fault Code Path Selection

View Related Topic

Is the coolant level sensor a 2-wire sensor? | Go to 70-fc196-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 70-fc196-3wire

Last Modified: 23-Mar-2010


Engine Coolant Level Low - Warning

FAULT CODE 197

Engine Coolant Level Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Engine Coolant Level Low - Warning. Low engine coolant level detected. | None on performance.
Engine Coolant Level

Circuit Description

The coolant level sensor is used to measure the level of the engine coolant in the radiator top tank. The electronic control module (ECM) supplies 5 volts to the coolant level sensor. The resistance of the engine coolant level sensor changes, based on the coolant level. The sensor resistance is between 4.5k ohms and 34k ohms when the sensor is submersed in coolant. The sensor resistance is between 333k ohms and 880k ohms when the sensor is not submersed in coolant. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for the location.

Refer to Troubleshooting Fault Code t05-197

Last Modified: 01-Sep-2010


Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine oil temperature circuit. | No engine protection for engine oil temperature.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is used by the electronic control module (ECM) to monitor the engine oil temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine oil temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine oil temperature sensor is located on the intake side of the engine near the EGR connection tube below the integrated fuel system module (IFSM). Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, see the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, see the Separate Pressure/Temperature Sensor Return Circuit above.

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 212, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, sensor, or ECM
  • Open signal circuit or shorted to a voltage source.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-212

Last Modified: 02-Sep-2010


Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine oil temperature circuit. | No engine protection for engine oil temperature.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is used by the electronic control module (ECM) to monitor the engine oil temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine oil temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine oil temperature sensor is located on the intake side of the engine near the EGR connection tube below the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The engine oil temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 213, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness or ECM
  • Signal shorted to return or ground in the sensor.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-213

Last Modified: 01-Sep-2010


Engine Oil Temperature High - Critical

FAULT CODE 214

Engine Oil Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature High - Critical. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Engine Oil Temperature

Circuit Description

The engine oil temperature sensor monitors engine oil temperature and passes information to the electronic control module (ECM) through the engine harness. If the engine oil temperature becomes too high, it will cause a derate condition. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red stop lamp starts flashing.

Component Location

The engine oil temperature sensor is located on the intake side of the engine near the EGR crossover tube below the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

The engine oil temperature sensor measures the temperature of the oil in the oil rifle on the left hand side of the engine block. This fault code is activated if the engine oil temperature is above 122°C [252°F].

Possible causes of this fault code include:

  • Low oil level
  • High coolant temperature
  • Failed lubricating oil thermostat
  • Failed lubricating oil cooler
  • Failed engine oil temperature sensor.
Refer to Troubleshooting Fault Code t05-214

Last Modified: 01-Sep-2010


Centinel™ Oil Tank Level Low - Warning

FAULT CODE 219

Centinel™ Oil Tank Level Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 219 PID: P017 SPN: 1380 FMI: 1/17 LAMP: Amber with Maintenance Flashout SRT: | Engine Oil Level Number 2 (Remote) Low - Maintenance. Low oil level detected in the Centinel™ makeup oil tank. | None on performance. Centinel™ oil system deactivated.
Centinel™ Oil System

Circuit Description

The Centinel™ oil burn level switch monitors the oil level in the makeup tank and reports to the electronic control module (ECM) when the oil drops below the specified level.

Component Location

The Centinel™ oil burn level switch is located on the lower portion of the front of the Centinel makeup oil tank.

Shop Talk

Verify that the makeup tank has the appropriate oil level.

Refer to Troubleshooting Fault Code t05-219

Last Modified: 01-Sep-2010


Barometric Pressure Sensor Circuit

FAULT CODE 221

Barometric Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor - shorted high. High signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the electronic control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Section E for a detailed component location view.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-221

Last Modified: 01-Sep-2010


Barometric Pressure Sensor Circuit

FAULT CODE 222

Barometric Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - shorted low. Low signal voltage detected at barometric pressure circuit. | Engine power derate
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the electronic control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Section E for a detailed component location view.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness may cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-222

Last Modified: 01-Sep-2010


Centinel™ Oil Control Valve Circuit - Shorted Low

FAULT CODE 223

Centinel™ Oil Control Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S085 SPN: 1265 FMI: 4/4 LAMP: Amber SRT: | Centinel™ oil control valve circuit - shorted low. Low signal voltage detected at Centinel™ oil control valve circuit. | None on performance. Centinel™ system deactivated.
Centinel™ Oil Control Valve Circuit

Circuit Description

The Centinel™ oil control valve is controlled by the ECM. The ECM sends a voltage signal to the valve which diverts a preset amount of engine oil into the fuel system to be burned.

Component Location

Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault is logged when the ECM commands the Centinel™ oil control valve ON and detects a lower signal voltage than expected at the output.

Possible causes for this fault include:

  • Short circuit to ground in the oil control valve or engine harness.
  • Faulty ECM circuit
  • Low internal resistance of Centinel™ oil control valve.
Refer to Troubleshooting Fault Code t05-223

Last Modified: 07-Oct-2010


Centinel™ Oil Control Valve Circuit - Shorted High

FAULT CODE 224

Centinel™ Oil Control Valve Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 224 PID: S085 SPN: 1265 FMI: 3/3 LAMP: Amber SRT: | Centinel™ oil control valve circuit - shorted high. Open circuit or high signal voltage detected at Centinel™ oil control valve circuit. | None on performance. Centinel™ system deactivated.
Centinel™ Oil Control Valve Circuit

Circuit Description

The Centinel™ oil control valve is controlled by the ECM. The ECM sends a voltage signal to the valve which diverts a preset amount of engine oil into the fuel system to be burned.

Component Location

The Centinel™ oil control valve is mounted on the intake side of the engine below and towards the rear of the air compressor. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The Centinel™ oil control valve, turbocharger control valve, and turbocharger control shutoff valve share the same return wire in the engine harness. If Fault Codes 224, 2355, and 2277 are all active, check the return ground terminal for a faulty ground connection.

Possible causes for this fault include:

  • Open circuit in the engine harness, connectors, or Centinel™ oil control valve.
  • Signal circuit shorted to a voltage source in the engine harness.
Refer to Troubleshooting Fault Code t05-224

Last Modified: 07-Oct-2010


Sensor Supply Voltage Number 2 Circuit

FAULT CODE 227

Sensor Supply Voltage Number 2 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 620 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply Voltage Number 2 Circuit - shorted high. High voltage detected at sensor supply Number 2 circuit. | Engine will run derated. No engine protection for intake manifold air temperature.
Sensor Supply Voltage Number 2 Circuit

Circuit Description

The sensor supply Number 2 of the ECM provides (+) 5 volt supply for the camshaft position sensor, exhaust gas pressure sensor, rail fuel pressure sensor, intake manifold pressure sensor, EGR valve position sensor, and EGR differential pressure sensor.

Component Location

The sensor supply Number 2 is located in the ECM. The supply voltage is spliced off in the engine harness to each sensor it supports.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or failed ECM.

Refer to Troubleshooting Fault Code t05-227

Last Modified: 01-Sep-2010


Engine Overspeed

FAULT CODE 234

Engine Overspeed

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Speed High - Critical.Engine speed signal indicates engine speed above engine protection limit. | Fuel shutoff valve closed until engine speed falls below the engine protection limit.
Engine Overspeed Circuit

Circuit Description

The engine speed sensor and the camshaft position sensor provide engine speed and position information to the electronic control module (ECM) through the engine harness.

Component Location

The engine speed sensor is located in the front gear housing on the intake side of the engine. The camshaft position sensor is located on the intake side of the cylinder head near the engine brake pass-through connector. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes of this fault code include external fuel sources drawn into the intake air passage, reverse powering (motoring) of the engine, and tampering of the engine speed sensor or camshaft position sensor.Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks.

Refer to Troubleshooting Fault Code t05-234

Last Modified: 01-Sep-2010


Vehicle Speed Sensor Circuit

FAULT CODE 241

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Vehicle Speed Sensor Circuit - data incorrect. The ECM lost the vehicle speed signal. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise control, gear-down protection, and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine ECM and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM troubleshooting and repair manual.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Refer to your OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a vehicle speed signal greater than zero.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not catch all failures of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, please refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-241

Last Modified: 01-Sep-2010


Vehicle Speed Sensor Circuit

FAULT CODE 242

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Vehicle Speed Sensor Circuit - tampering has been detected. Invalid or inappropriate vehicle speed signal detected. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to maximum engine speed without vehicle speed sensor parameter value. Cruise control progressive shifting, gear-down protection, and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine ECM and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for your specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is on for 30 seconds and the ECM senses zero vehicle and engine speed.

Refer to Troubleshooting Fault Code t05-242

Last Modified: 01-Sep-2010


Fan Control Circuit

FAULT CODE 245

Fan Control Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - shorted low. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can possibly stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The ECM provides a signal to the fan control solenoid to turn the engine fan on and off. There are two types of fans supported by this signal; variable speed and ON/OFF. The INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by OEM. Certain OEM's may use a solenoid return that is wired to the ECM or may use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Shop Talk

The fan control logic can be adjusted with the INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24 volts to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24 volts. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service literature for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code t05-245

Last Modified: 01-Sep-2010


Ambient Air Temperature Sensor Circuit

FAULT CODE 249

Ambient Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | Ambient Air Temperature Sensor Circuit - Shorted High. High signal voltage detected at ambient air temperature circuit. | None on performance. The idle shutdown ambient air temperature override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is used by the ECM to monitor ambient air temperature. This could be used to sense the temperature inside the cab of a vehicle or the air temperature outside the vehicle. The ambient air temperature signal is used by the ECM for the idle shutdown ambient air temperature override feature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM troubleshooting and repair manual.

Shop Talk

Possible causes of this fault code include:

  • Open return in the harness, connectors, or sensor.
  • Open signal or signal shorted to a voltage source.
Temperature (°F) | Temperature (°C) | Resistance (ohms)
25 | −4 | 39k to 44k
44 | 7 | 22k to 25k
64 | 18 | 13k to 15k
84 | 29 | 8k to 9k
104 | 40 | 5k to 6k
Refer to Troubleshooting Fault Code t05-249

Last Modified: 01-Sep-2010


Fuel Shutoff Valve Circuit

FAULT CODE 254

Fuel Shutoff Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S017 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Fuel Shutoff Valve Circuit - Shorted Low. Low voltage detected at fuel shutoff valve circuit. | Fuel shutoff valve will close. Engine will shutdown.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the electronic control module (ECM) to control the engine fuel supply. The ECM can shut down the engine by cutting off the power to the fuel shutoff valve.

Component Location

The fuel shutoff valve is located on the fuel delivery housing above the fuel filter. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

Inspect the fuel shutoff supply circuit for external wires that can be spliced in to power another device. Remove any extra wires that are found in the circuit. If there is an external shutdown system on the vehicle that uses the fuel shutoff valve for engine shutdown, make sure it has not failed and pulled down the voltage on the fuel shutoff circuit. Inspect the engine-to-chassis ground wire to make sure it is securely fastened to a clean, dry, conductive surface.

Possible causes for this fault include:

  • Short circuit to ground in the engine harness, connectors, or fuel shutoff valve.
Refer to Troubleshooting Fault Code t05-254

Last Modified: 02-Sep-2010


Engine Fuel Shutoff Valve Drive Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Drive Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S017 SPN: 632 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Drive Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or short to voltage source detected at fuel shutoff valve circuit. | Fuel shutoff valve may not open when keyswitch is in ON position, or may not close when keyswitch is OFF position.
Engine Fuel Shutoff Valve Drive Circuit

Circuit Description

The electronic control module (ECM) supplies voltage for the fuel shutoff valve to open. If voltage is externally supplied to the fuel shutoff valve, it will stay open.

Component Location

The fuel shutoff valve solenoid is located on the fuel delivery housing. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E .

Shop Talk

If there is an external shutdown system on the vehicle, make sure it is not miswired and feeding voltage into the fuel shutoff supply circuit.

Possible causes of this fault include:

  • Open circuit in the engine harness, connectors, or shutoff valve.
  • Fuel shutoff valve signal wire shorted to a voltage source in the harness.
Refer to Troubleshooting Fault Code t05-255

Last Modified: 02-Sep-2010


Ambient Air Temperature Sensor Circuit

FAULT CODE 256

Ambient Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Ambient Air Temperature Sensor Circuit - Shorted Low. Low voltage detected at ambient air temperature circuit. | None on performance. The idle shutdown ambient air temperature override feature will use the intake manifold air temperature sensor value to determine idle shutdown and availability of override.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is used by the ECM to monitor ambient air temperature. This could be used to sense the temperature inside the cab of a vehicle or the air temperature outside the vehicle. The ambient air temperature signal is used by the ECM for the idle shutdown ambient air temperature override feature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM troubleshooting and repair manual.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness.
  • Signal circuit shorted to return or ground in the sensor.
Temperature (°F) | Temperature (°C) | Resistance (ohms)
25 | -4 | 39k to 44k
44 | 7 | 22k to 25k
64 | 18 | 13k to 15k
84 | 29 | 8k to 9k
104 | 40 | 5k to 6k
Refer to Troubleshooting Fault Code t05-256

Last Modified: 01-Sep-2010


Fuel Shutoff Valve

FAULT CODE 259

Fuel Shutoff Valve

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 259 PID: S017 SPN: 632 FMI: 7/7 LAMP: Yellow SRT: | The ECM detected that the fuel shutoff valve is stuck open mechanically or leaking. | Engine will have a torque derate.
Fuel Shutoff Valve

Circuit Description

Voltage is supplied to the fuel shutoff valve by the ECM while the engine keyswitch is ON. When the keyswitch is OFF, the voltage to the fuel shutoff valve is turned off by the ECM. The fuel shutoff valve closes and stops fuel from flowing to the fueling and timing actuators.

Component Location

The fuel shutoff valve is located on the fuel delivery housing, below the air inlet horn.

Shop Talk

Upon turning the keyswitch off, the ECM turns off the voltage supplied to keep the fuel shutoff open. The ECM continues to fire the fueling and timing actuators as the engine spins down. The ECM monitors fuel pressure using the fuel pressure sensor during this time. If the fuel pressure does not drop after the fuel shutoff valve is turned off, the ECM activates this fault.

Refer to Troubleshooting Fault Code t05-259

Last Modified: 01-Sep-2010


Engine Fuel Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine fuel temperature circuit. | May have white smoke and low power when engine is cold.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is used by the electronic control module (ECM) to monitor the engine fuel temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine fuel temperature value is used by the ECM to adjust fuel delivery to the injectors.

Component Location

The engine fuel temperature sensor is located on the lower rear of the integrated fuel system module (IFSM). Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The engine fuel temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 263, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, sensor, or ECM
  • Open signal circuit or shorted to a voltage source.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-263

Last Modified: 02-Sep-2010


Engine Fuel Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine fuel temperature circuit. | May have white smoke and low power when engine is cold.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is used by the electronic control module (ECM) to monitor the engine fuel temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine fuel temperature value is used by the ECM to adjust fuel delivery to the injectors.

Component Location

The engine fuel temperature sensor is located on the lower rear of the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The engine fuel temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 265, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness or ECM
  • Signal shorted to return or ground in the sensor.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-265

Last Modified: 01-Sep-2010


Engine Speed Sensor Supply Voltage Circuit

FAULT CODE 284

Engine Speed Sensor Supply Voltage Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 284 PID: S221 SPN: 1043 FMI: 4/4 LAMP: Amber SRT: | Engine Speed Sensor Supply Voltage Circuit - shorted low. Incorrect voltage detected on the ECM voltage supply line to the engine speed sensor. | Possible hard starting and rough running.
Engine Speed Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies the engine speed sensor with +5 VDC.

Component Location

The engine speed sensor is located in the lower portion of the front cover on the intake side of the engine. Refer to Section E for a detailed component location view.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If voltage falls below a calibratible limit then this fault is recorded.

Possible causes of this fault code are a short circuit to ground in the engine harness, sensor, or ECM.

Refer to Troubleshooting Fault Code t05-284

Last Modified: 01-Sep-2010


SAE J1939 Data Link Multiplexing

FAULT CODE 285

SAE J1939 Data Link Multiplexing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9 (J1587), 9(J1939) LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough, or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Multiplexing Circuit

Circuit Description

Inputs, such as accelerator pedals, switches, and sensors can be communicated to the ECM over the SAE J1939 data link. Messages sent from the vehicle electronic control units are received by the ECM and used for controlling the engine. Both the ECM and vehicle electronic control units must be properly configured so that each device's information is transmitted by the vehicle electronic control unit and received by the ECM.

Component Location

The ECM is bolted to the intake side of the engine between the air horn and the front of the engine. Refer to Procedure For component location information 100-002 (Engine Diagrams) in Section E.

Shop Talk

This fault occurs when the ECM is set up to receive information about a multiplexed device from a vehicle electronic control unit over the SAE J1939 data link and does not receive a message with that information. This fault can also be caused if the ECM does not receive the information fast enough to control the engine properly. This condition can be caused by the SAE J1939 data link having an electrical problem, a lack of terminating plugs on the SAE J1939 data link backbone, the ECM not being set up to receive information, a multiplexed device that truly is not multiplexed, or a vehicle electronic control unit not being correctly set up to transmit information on one of its multiplexed devices.

Refer to Troubleshooting Fault Code t05-285

Last Modified: 02-Sep-2010


SAE J1939 Data Link Multiplexing

FAULT CODE 286

SAE J1939 Data Link Multiplexing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13 (J1587),13 (J1939) LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Data Link Multiplexing Circuit

Circuit Description

Inputs such as throttle pedals, switches, and sensors can be communicated to the ECM over the SAE J1939 data link. Messages sent from the vehicle electronic control units are received by the ECM and used for controlling the engine. Both the ECM and vehicle electronic control unit (VECU) must be properly configured so that each device's information is transmitted by the vehicle electronic control unit and received by the ECM.

Component Location

The ECM is bolted to the intake side of the engine between the air horn and the front of the engine. Refer to Section E for a detailed component location view. The SAE J1939 data link wiring and vehicle electronic control unit(s) vary by OEM options.

Shop Talk

This fault occurs when the ECM is set up to receive information from several multiplexed switches from vehicle electronic control unit(s) and only receives some of the switches. It indicates the ECM is set up to receive too many switches or the vehicle electronic control unit(s) is setup to transmit too few switches.

Refer to Troubleshooting Fault Code t05-286

Last Modified: 01-Sep-2010


SAE J1939 Data Link Multiplexing Accelerator Pedal Sensor

FAULT CODE 287

SAE J1939 Data Link Multiplexing Accelerator Pedal Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P091 SPN: 19 FMI: 19 LAMP: Red SRT: | SAE J1939 Multiplexing Accelerator Pedal Sensor Error. The OEM vehicle electronic control unit (VECU) detected a fault with its accelerator pedal. | The engine will only idle.
SAE J1939 Data Link Multiplexing Circuit

Circuit Description

Inputs, such as accelerator pedals, switches, and sensors can be communicated to the ECM over the SAE J1939 data link. Messages sent from the vehicle electronic control units are received by the ECM and used for controlling the engine. Both the ECM and vehicle electronic control units must be properly configured so that each device's information is transmitted by the vehicle electronic control unit and received by the ECM.

Component Location

The ECM is bolted to the intake side of the engine between the air horn and the front of the engine. Refer to Section E for a detailed component location view.

Shop Talk

If the OEM vehicle electronic control unit detects an error with the accelerator pedal sensor, it transmits an error message to the ECM. This fault code is set active when the ECM receives an accelerator pedal sensor error message from the vehicle electronic control unit over the SAE J1939 data link.

Refer to Troubleshooting Fault Code t05-287

Last Modified: 01-Sep-2010


SAE J1939 Data Link Multiplexing Remote Accelerator

FAULT CODE 288

SAE J1939 Data Link Multiplexing Remote Accelerator

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P029 SPN: 19 FMI: 19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Throttle Data Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | The engine will not respond to the remote accelerator.
SAE J1939 Data Link Multiplexing Circuit

Circuit Description

Inputs, such as accelerator pedals, switches, and sensors can be communicated to the ECM over the SAE J1939 data link. Messages sent from the vehicle electronic control units are received by the ECM and used for controlling the engine. Both the ECM and vehicle electronic control units must be properly configured so that each device's information is transmitted by the vehicle electronic control unit and received by the ECM.

Component Location

The ECM is bolted to the intake side of the engine between the air horn and the front of the engine. Refer to Section E for a detailed component location view.

Shop Talk

If the OEM vehicle electronic control unit detects an error with the remote accelerator, it transmits an error message to the ECM. This fault code is set active when the ECM receives a remote accelerator error message from the vehicle electronic control unit over the SAE J1939 data link.

Refer to Troubleshooting Fault Code t05-288

Last Modified: 01-Sep-2010


Barometric Pressure Sensor Circuit - Data Incorrect

FAULT CODE 295

Barometric Pressure Sensor Circuit - Data Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Data Incorrect. An error in the barometric pressure sensor signal was detected by the ECM. | Engine will run derated.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the electronic control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted to the main branch of the engine harness near the ECM. Refer to Section E for a detailed component location view.

Shop Talk

At key-on, before the engine starts, the sensor readings for intake manifold pressure, exhaust gas pressure, and engine oil pressure are compared with the barometric pressure. This fault code occurs if the barometric pressure sensor reading is different from any two of the other three. This check is only done once after the keyswitch is turned on and before the engine is started. The engine oil temperature must also be at least 7°C [45°F] for this check to run.

Shop exhaust fans can cause this fault code to come active. Turn exhaust fans off when troubleshooting this fault code.

Refer to Troubleshooting Fault Code t05-295

Last Modified: 01-Sep-2010


Real-Time Clock Power Circuit

FAULT CODE 319

Real-Time Clock Power Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Amber (Maintenance) SRT: | Real Time Clock - Power Interrupt. Real-time clock lost power. | None on performance. Data in the ECM will not have accurate time and date information.
Real-Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the ECM is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real-time clock battery is secured to the engine harness near the ECM. Refer to Section E for a detailed component location view.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or failed real-time clock battery, failed wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code t05-319

Last Modified: 01-Sep-2010


Idle Shutdown Vehicle Accessories Relay Circuit

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S087 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Circuit - shorted high. Open circuit or short to voltage source detected at the idle shutdown vehicle accessory/ignition bus relay circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Circuit

Circuit Description

The ECM idle shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by OEM. The return circuit may be returned to the ECM through pin 42 or connected directly to ground. Refer to the OEM service literature to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded OFF, it records this fault code. This fault code can be caused by:

  • ECM idle shutdown feature setup incorrectly
  • Open circuit in the idle shutdown relay, OEM harness or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code t05-338

Last Modified: 01-Sep-2010


Idle Shutdown Vehicle Accessories Relay Circuit

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S087 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Circuit - shorted low. Low voltage detected at the idle shutdown vehicle accessory or ignition bus relay circuit when commanded on. | Vehicle accessories controlled by the idle shutdown vehicle accessory relay will not power down.
Idle Shutdown Vehicle Accessories Relay Circuit

Circuit Description

The ECM idle shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to 'Installed', the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by OEM. The return circuit may be returned to the ECM through pin 42 or connected directly to ground. Refer to the OEM service literature to determine the grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Shop Talk

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded on. This fault code can be caused by a short circuit to ground in the idle shutdown relay, OEM harness or connectors.

Refer to Troubleshooting Fault Code t05-339

Last Modified: 01-Sep-2010


Unswitched Battery Supply Circuit

FAULT CODE 341

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 341 PID: S253 SPN: 630 FMI: 2/2 LAMP: Amber SRT: | Engine control module (ECM) data lost. | Possibly no noticeable performance effects, engine dying, or difficulty in starting the engine. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives constant voltage at the 4-pin power connector from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire, in the 50-pin OEM ECM connector, when the vehicle keyswitch is turned on. Pins 2 and 3 are optional circuits the OEM may not use. Refer to the OEM wiring diagram for detailed information on these circuits.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-341

Last Modified: 01-Sep-2010


Electronic Control Module (ECM)

FAULT CODE 343

Electronic Control Module (ECM)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module - Warning internal hardware failure. Internal ECM error. | Possibly none on performance, or severe derate.
Electronic Control Module

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is bolted to the intake side of the cylinder head between the air inlet horn and the front of the engine. Refer to Section E for a detailed component location view.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-343

Last Modified: 01-Sep-2010


Sensor Supply Voltage Number 1 Circuit

FAULT CODE 352

Sensor Supply Voltage Number 1 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 1079 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply Voltage Number 1 Circuit - shorted low. Low voltage detected at sensor supply Number 1 circuit. | Engine will run derated.
Sensor Supply Voltage Number 1 Circuit

Circuit Description

The sensor supply voltage Number 1 of the electronic control module (ECM) provides (+) 5 volt supply for the barometric pressure sensor, engine oil pressure sensor, and fuel pump pressure sensor on the engine harness. This +5 volt supply also powers two optional OEM devices. The two devices are digital vehicle speed sensor and remote accelerator sensor.

Component Location

The sensor supply Number 1 is located in the ECM. The supply voltage is spliced off in the engine and OEM harness to each sensor it supports.

Shop Talk

Low voltage on the (+) 5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-352

Last Modified: 01-Sep-2010


Sensor Supply Voltage Number 1 Circuit

FAULT CODE 386

Sensor Supply Voltage Number 1 Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 1079 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply Voltage Number 1 Circuit - shorted high. High voltage detected at sensor supply Number 1 circuit. | Engine will run derated.
Sensor Supply Voltage Number 1 Circuit

Circuit Description

The sensor supply voltage Number 1 of the ECM provides (+) 5 VDC for the barometric pressure sensor and engine oil pressure sensor on the engine harness. This +5 volt supply also powers two optional OEM devices. The two devices are digital vehicle speed sensor and remote accelerator sensor.

Component Location

The sensor supply Number 1 is located in the ECM. The supply voltage is spliced off in the engine and OEM harness to each sensor it supports.

Shop Talk

High voltage on the sensor supply line can be caused by an individual sensor supply wire in the harness shorted to battery voltage or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-386

Last Modified: 01-Sep-2010


Accelerator Pedal Position Sensor Supply Voltage Circuit

FAULT CODE 387

Accelerator Pedal Position Sensor Supply Voltage Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 387 PID: S221 SPN: 1043 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal Position Sensor Supply Voltage Circuit - shorted high. High voltage detected at sensor supply circuit for the accelerator pedal position sensor. | Engine will only idle.
Accelerator Pedal Position Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies the accelerator pedal position sensor with +5 VDC.

Component Location

The accelerator pedal assembly is located in the cab.

Shop Talk

This fault is logged when the ECM senses more than 5.25 volts on the accelerator pedal position +5 volt supply line. This can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than +5 VDC.

Refer to Troubleshooting Fault Code t05-387

Last Modified: 01-Sep-2010


Engine Oil Pressure Low - Critical

FAULT CODE 415

Engine Oil Pressure Low - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Pressure Low - Critical. Engine oil pressure signal indicates engine oil pressure below the engine protection critical limit. | Progressive engine speed derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red Stop lamp starts flashing.
Engine Oil Pressure

Circuit Description

The engine oil pressure sensor monitors oil pressure and passes information to the electronic control module (ECM) through the engine harness. If the oil pressure becomes too low, based on engine speed, it will cause a derate condition. If the engine protection shutdown is enabled, the engine will shut down 30 seconds after the red stop lamp starts flashing.

Component Location

The engine oil pressure sensor is located on the left side of the engine block, below and to the rear of the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

The engine oil pressure sensor measures the pressure of the oil in the oil rifle on the left-hand side of the engine block.

Possible causes of this fault code include:

  • Mechanical failures such as lubricating oil pump, lubricating oil high pressure relief valve, loose lubricating oil filter
  • Breakdown or contamination of lubricating oil
  • Plugged lubricating oil filter.
Refer to Troubleshooting Fault Code t05-415

Last Modified: 01-Sep-2010


Water-in-Fuel Indicator High - Maintenance

FAULT CODE 418

Water-in-Fuel Indicator High - Maintenance

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Amber (Maintenance Flashout) SRT: | Water-in-Fuel Indicator High - Maintenance. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
Water-in-Fuel Sensor

Circuit Description

The water-in-fuel sensor is attached to the suction-side fuel filter supplied by the Original Equipment Manufacturer (OEM). The water-in-fuel sensor sends a signal to the electronic control module when a set volume of water has accumulated in the fuel filter. The water-in-fuel sensor circuit contains two wires: a return and a signal wire.

Component Location

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

The water-in-fuel sensor will be located on the suction-side fuel filter that is mounted by the OEM. Locations will vary depending on chassis.

Refer to Troubleshooting Fault Code t05-418

Last Modified: 12-Oct-2011


SAE J1939 Data Link Communication

FAULT CODE 426

SAE J1939 Data Link Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | Communication between the electronic control module (ECM) and another device on the SAE J1939 data link has been lost. | None on performance. SAE J1939 devices possibly do not operate.
SAE J1939 Data Link Circuit

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and VECUs can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The ECM is located on the intake side of the engine, near the front. The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the SAE J1939 data link and then can no longer transmit on the data link. Possible causes of this fault include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages.
Refer to Troubleshooting Fault Code t05-426

Last Modified: 01-Sep-2010


Water-In-Fuel Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water-In-Fuel Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water-in-Fuel Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
Water-In-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the suction-side fuel filter. The water-in-fuel sensor sends a signal to the Electronic Control Module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires: a return and a signal wire.

Component Location

The water-in-fuel sensor is integrated into the bottom of the Original Equipment Manufacturer (OEM) supplied fuel filter. Refer to the OEM troubleshooting and repair manual for location.

Shop Talk

Beginning with Engine Serial Number (ESN)14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The water-in-fuel sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 428, check for multiple fault codes.

Possible causes for this fault code include:

  • Open return or signal circuit in the harness, connectors, sensor, or ECM.
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-428

Last Modified: 01-Sep-2010


Water-In-Fuel Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water-In-Fuel Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
Water-In-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the suction-side fuel filter. The water-in-fuel sensor sends a signal to the Electronic Control Module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires: a return and a signal wire.

Component Location

The water-in-fuel sensor is integrated into the bottom of the Original Equipment Manufacturer (OEM) supplied fuel filter. Refer to the OEM troubleshooting and repair manual for location.

Shop Talk

Beginning with Engine Serial Number (ESN) 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The water-in-fuel sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 429, check for multiple fault codes.

Possible causes for this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, connector or ECM
Refer to Troubleshooting Fault Code t05-429

Last Modified: 01-Sep-2010


Fault Code Path Selection

FAULT CODE 431
Fault Code Path Selection

Do you have an NISS throttle pedal? | Go to 70-fc431niss
Do you have an ISS throttle pedal? | Go to 70-fc431iss
Do you have an SSS throttle pedal? | Go to 70-fc431sss

Last Modified: 06-Jun-2003


Accelerator Pedal Idle Validation Circuit

FAULT CODE 432

Accelerator Pedal Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13/13 LAMP: Red SRT: | Accelerator Pedal Idle Validation Circuit - out of calibration. Voltage at idle validation on-idle and off-idle circuit does not match accelerator pedal position. | Engine will only idle.
Accelerator Pedal Idle Validation Circuit

Circuit Description

The accelerator pedal position sensor is attached to the accelerator pedal. The accelerator pedal position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal is depressed and released. The accelerator pedal position circuit contains three wires: accelerator pedal position supply, accelerator pedal position return, and accelerator pedal position signal. The switch return circuit for the on-idle and off-idle validation circuit is a shared return with other OEM switches.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

This fault is logged when both the on idle and off idle validation switches disagree with the accelerator pedal position signal. Turning the keyswitch ON while partially depressing the accelerator pedal can cause this fault code to go active. This fault will stay active until the pedal is cycled through its full travel.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 01-Sep-2010


Intake Manifold Pressure Sensor Circuit - Data Incorrect

FAULT CODE 433

Intake Manifold Pressure Sensor Circuit - Data Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 433 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Data Incorrect. An error in the intake manifold pressure signal was detected by the ECM. | Derate in power output of the engine. The ECM will estimate the Intake Manifold Pressure.
Intake Manifold Pressure Sensor Circuit - Data Incorrect

Circuit Description

The intake manifold pressure sensor is used by the electronic control module (ECM) to monitor the intake manifold pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The intake manifold pressure sensor is located on the intake side of the engine in the inlet air horn. Refer to Section E for a detailed component location view.

Shop Talk

At key-on, before the engine starts, the sensor readings for barometric pressure, exhaust gas pressure, and engine oil pressure are compared with the intake manifold pressure. This fault code occurs if the intake manifold pressure sensor reading is different from any two of the other three. This check is only done once after the keyswitch is turned on and before the engine is started. The engine oil temperature must also be at least 7°C [45°F] for the check to run.

Shop exhaust fans can cause his fault code to come active. Turn exhaust fans off when troubleshooting this fault code.

Refer to Troubleshooting Fault Code t05-433

Last Modified: 01-Sep-2010


Unswitched Battery Supply Circuit

FAULT CODE 434

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 434 PID: S251 SPN: 627 FMI: 2/2 LAMP: Amber SRT: | Power Lost Without Ignition OFF. Supply voltage to the ECM fell below 6.2 volts momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the OEM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Shop Talk

This fault is set active if the ECM battery supply voltage drops below 6.2 volts while the keyswitch is in the ON position.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 434 active.

Refer to Troubleshooting Fault Code t05-434

Last Modified: 01-Sep-2010


Engine Oil Pressure Sensor Circuit - Data Incorrect

FAULT CODE 435

Engine Oil Pressure Sensor Circuit - Data Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Pressure Sensor Circuit - data incorrect. An error in the engine oil pressure sensor signal was detected by the ECM. | None on performance. No engine protection for engine oil pressure.
Engine Oil Pressure Sensor Circuit - Data Incorrect

Circuit Description

The engine oil pressure is used by the electronic control module (ECM) to monitor the engine oil pressure. This value is used by the engine protection feature.

Component Location

The engine oil pressure sensor is located on the intake side of the engine block, below and to the rear of the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

At key-on, before the engine is started, the sensor readings for barometric pressure, exhaust gas pressure, and intake manifold pressure are compared with engine oil pressure. This fault code occurs if the engine oil pressure sensor reading is different from any two of the other three. This check is only done once after the keyswitch is turned on and before the engine is started. The engine oil temperature must also be at least 7°C [45°F] for this check to run.

Shop exhaust fans can cause this fault code to come active. Turn exhaust fans off when troubleshooting this fault code.

Refer to Troubleshooting Fault Code t05-435

Last Modified: 01-Sep-2010


Accelerator Pedal Position Sensor Supply Voltage Circuit

FAULT CODE 443

Accelerator Pedal Position Sensor Supply Voltage Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443 PID: S221 SPN: 1043 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal Position Sensor Supply Voltage Circuit - shorted low. Low voltage detected at sensor supply circuit to the accelerator pedal position sensor. | Engine will only die.
Accelerator Pedal Position Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies the accelerator with +5 VDC. If the supply circuit to the accelerator is damaged, the accelerator will not work correctly.

Component Location

The accelerator pedal is located in the cab.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and return circuit, a failed accelerator, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-443

Last Modified: 01-Sep-2010


High Fuel Pressure

FAULT CODE 449

High Fuel Pressure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P094 SPN: 94 FMI: 0/16 LAMP: Amber SRT: | Fuel Pressure High - Warning. High fuel pressure was detected at the fuel rail in the IFSM. | The engine may produce black smoke and may be derated.
Hydraulic Fuel System Circuit

Circuit Description

The gear pump draws fuel from the fuel tank through the suction side fuel filter. The gear pump develops 1724 to 2620 kPa [250 to 380 psi] of fuel pressure. The fuel flows through the pressure fuel filter and fuel shutoff valve to the fueling and timing actuators and the rail fuel pressure sensor. The 1724 kPa [250 psi] regulator controls the fuel pressure in the fuel rail, which supplies fuel to the actuators.

Component Location

Refer to Section E for a detailed component location view.

Shop Talk

The fuel pressure is monitored by the ECM. If the rail fuel pressure is higher than an acceptable range for engine operating conditions, the fault code is logged.

Refer to Troubleshooting Fault Code t05-449

Last Modified: 01-Sep-2010


Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level.

FAULT CODE 482

Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 482 PID: P094 SPN: 94 FMI: 1/18 LAMP: Amber SRT: | Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level. | Engine may not start, emit white smoke, run rough, or lose power.
Fuel System Circuit

Circuit Description

The gear pump draws fuel from the fuel tank through a suction fuel filter and an anti-drainback valve. The gear pump develops between 1724 and 2620 kPa [250 and 380 psi] of fuel pressure. The fuel flows through a pressure fuel filter and fuel shutoff valve to the fueling and timing actuators and rail fuel pressure sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel pressure is monitored by the ECM. If the rail fuel pressure is lower than an acceptable level for a given set of engine operating conditions, the fault code is logged.

NOTE: One possible cause of this fault code is a damaged or sticking drain-back valve located in the fuel supply circuit in the integrated fuel system module (IFSM). The IFSM is located directly above the fuel lift pump.

Refer to Troubleshooting Fault Code t05-482.

Last Modified: 17-Jan-2011


Fuel System Underfueling

FAULT CODE 486

Fuel System Underfueling

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 486 PID: P129 SPN: 1349 FMI: 1/18 LAMP: Amber SRT: | Injector Metering Rail Number 2 Fueling Low - WarningAn unexpectedly low fuel delivery was detected on the rear three cylinders. | Low power or rough idle.
Hydraulic Fuel System

Circuit Description

The electronic control module (ECM) supplies voltage to open the rear fueling actuator for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects the fuel into the cylinder for combustion.

Component Location

The rear fuel metering actuator is located on the fuel control housing. It is the first actuator from the rear of the engine. The fuel control housing is located on the intake side of the engine below the exhaust gas mixer. Refer to Section E for a detailed component location view.

Shop Talk

The ECM estimates the amount of fuel delivered to each bank by monitoring the crankshaft acceleration pattern as it rotates. This fault is set active if the ECM estimates that the rear bank is receiving insufficient fuel flow.

Refer to Troubleshooting Fault Code t05-486

Last Modified: 01-Sep-2010


Rail Fuel Pressure Sensor Circuit

FAULT CODE 546

Rail Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: P094 SPN: 94 FMI: 3/3 LAMP: Amber SRT: | Rail Fuel Pressure Sensor Circuit - shorted high. High signal voltage detected at the rail fuel pressure circuit. | Engine may crank longer than usual before starting, may have low power, white smoke, or run rough.
Rail Fuel Pressure Sensor Circuit

Circuit Description

The rail fuel pressure sensor is used by the electronic control module (ECM) to monitor fuel pressure.

Component Location

The rail fuel pressure sensor is located on the bottom front corner of the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

The rail fuel pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting fault code 546, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-546

Last Modified: 01-Sep-2010


Rail Fuel Pressure Sensor Circuit

FAULT CODE 547

Rail Fuel Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: P094 SPN: 94 FMI: 4/4 LAMP: Amber SRT: | Rail Fuel Pressure Sensor Circuit - shorted low. Low signal voltage detected at rail fuel pressure circuit. | Engine may not start, may have low power, white smoke, or run rough.
Rail Fuel Pressure Sensor Circuit

Circuit Description

The rail fuel pressure sensor is used by the electronic control module (ECM) to monitor fuel pressure.

Component Location

The rail fuel pressure sensor is located on the bottom front corner of the integrated fuel system module (IFSM). Refer to Section E for a detailed component location view.

Shop Talk

The rail fuel pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 547, check for multiple faults.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to ground in the engine harness, connector, or sensor.
  • Failed sensor.
Refer to Troubleshooting Fault Code t05-547

Last Modified: 01-Sep-2010


Fault Code Path Selection

FAULT CODE 551
Fault Code Path Selection

Do you have an NISS throttle pedal? | Go to 70-fc551niss
Do you have an ISS throttle pedal? | Go to 70-fc551iss
Do you have an SSS throttle pedal? | Go to 70-fc551sss

Last Modified: 04-May-2004


Fuel System Underfueling

FAULT CODE 559

Fuel System Underfueling

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | Injector Metering Rail Number 1 Fueling Low - WarningAn unexpectedly low fuel delivery was detected on the front three cylinders. | Low power or rough idle.
Hydraulic Fuel System

Circuit Description

The electronic control module (ECM) supplies voltage to open the front fueling actuator for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects the fuel into the cylinder for combustion.

Component Location

The front fueling actuator is located on the fuel control housing. It is the first actuator from the front of the engine. The fuel control housing is located on the intake side of the engine below the exhaust gas mixer. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The ECM estimates the amount of fuel delivered to each bank by monitoring the crankshaft acceleration pattern as it rotates. This fault is set active if the ECM estimates that the front bank is receiving insufficient fuel flow.

Refer to Troubleshooting Fault Code t05-559

Last Modified: 02-Sep-2010


Starter Relay Circuit

FAULT CODE 584

Starter Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter Relay Circuit - shorted high. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the ECM through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for exact location.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code.This fault can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code t05-584

Last Modified: 01-Sep-2010


Starter Relay Circuit

FAULT CODE 585

Starter Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter Relay Circuit - shorted low. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the ECM through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to OEM service manual for exact location.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded on, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Refer to Troubleshooting Fault Code t05-585

Last Modified: 01-Sep-2010


Turbocharger Number 1 Speed High Circuit

FAULT CODE 595

Turbocharger Number 1 Speed High Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Amber SRT: | Turbocharger Number 1 Speed High - warning level. High turbocharger speed has been detected. | Engine power derate. The ECM uses an estimated turbocharger speed.
Turbocharger Number 1 Speed High Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The ECM provides power to the sensor and the sensor generates a signal as the turbocharger shaft spins. The target on the turbocharger shaft is a ground flat in the center of the shaft.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

NOTE: This fault code may become active if the protective shipping sticker is not removed from the port located on the end opposite of the connector. When installing a new turbocharger control valve, make sure the adhesive cover is removed.

This fault can come active any time the key is on and the ECM detects turbocharger speed greater than a calibration limit. This fault can be caused by malfunctions in the following components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM power supply or grounds
  • Electronic vehicle accessories which emit excessive electromagnetic interference.

This fault becomes inactive any time the ECM detects a valid turbocharger speed.

If the fault occurs intermittently:

  • Look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).
  • Look for sources of electronic noise such as poorly installed vehicle electronic components.
  • Make sure the vehicle chassis grounds are in good condition.
  • Make sure the ECM power supply and ground circuits are in good condition and that this power supply is not shared with other vehicle electronics.
Refer to Troubleshooting Fault Code t05-595

Last Modified: 02-Sep-2010


Battery Voltage Monitor - High Voltage

FAULT CODE 596

Battery Voltage Monitor - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | Electrical Charging System Voltage High - warning level. High battery voltage detected by the battery voltage monitor feature. | Amber warning lamp illuminated until high battery voltage condition is corrected.
Battery Voltage Monitor Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for the battery location.

Shop Talk

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Overcharged batteries caused by a faulty alternator or regulator.
Refer to Troubleshooting Fault Code t05-596

Last Modified: 01-Sep-2010


Voltage Monitor - Low Voltage

FAULT CODE 597

Voltage Monitor - Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Electrical Charging System Voltage Low - Warning Level. Low battery voltage detected by the battery voltage monitor feature. | Amber lamp will light until low battery voltage condition is corrected. The electronic control module (ECM) can increase idle speed and deactivate idle decrement switch if idle speedup is enabled.
Voltage Monitor Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault:

  • Undercharged batteries caused by a faulty alternator or regulator.
  • High-current devices on the vehicle such as refrigerators, citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code t05-597

Last Modified: 01-Sep-2010


Battery Voltage Monitor - Very Low Voltage

FAULT CODE 598

Battery Voltage Monitor - Very Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Electrical Charging System Voltage Low - critical level. Very low battery voltage detected by the battery voltage monitor feature. | Red lamp illuminated until very low battery voltage condition is corrected. The electronic control module (ECM) can increase idle speed and deactivate idle decrement switch if idle speedup is enabled.
Battery Voltage Monitor Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM manual for the battery location.

Shop Talk

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Undercharged batteries caused by a faulty alternator or regulator.
Refer to Troubleshooting Fault Code t05-598

Last Modified: 01-Sep-2010


Engine Requires Lubricating Oil and Filter Change - Maintenance

FAULT CODE 649

Engine Requires Lubricating Oil and Filter Change - Maintenance

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S153 SPN: 1378 FMI: 11/31 LAMP: Amber (Maintenance Flashout) SRT: | Change Lubricating Oil and Filter. Maintenance Monitor feature indicates the engine is due for a lubricating oil and filter change. | None on performance, maintenance reminder only. If the engine is equipped with Centinel™, the Centinel™ oil control system will not operate.
Engine Maintenance

Circuit Description

The electronic control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubricating oil drain limits.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enable in INSITE™ electronic service tool. Make sure all faults have been cleared, and make sure the oil and filter are changed before clearing the fault.

Refer to Troubleshooting Fault Code t05-649

Last Modified: 01-Sep-2010


Turbocharger Speed Low - Warning Level

FAULT CODE 687

Turbocharger Speed Low - Warning Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Turbocharger Speed Low - Warning Level. Low turbocharger speed detected by the ECM. | Engine power derate. The ECM uses an estimated turbocharger speed.
Turbocharger Speed Low Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. A signal is generated as the turbocharger shaft spins. The target on the turbocharger shaft is a ground flat in the center of the shaft.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Shop Talk

This fault may come active if the electronic control module (ECM) senses boost pressure and engine speed while at the same time a turbocharger speed signal is not present.

Items that can generate this fault code include:

  • Turbocharger speed sensor
  • Turbocharger speed sensor o-ring
  • Engine harness
  • Barometric pressure sensor
  • Intake manifold pressure sensor
  • ECM.

This fault becomes inactive any time the speed signal from the turbocharger speed sensor returns.

If the calibration software phase is less than 5.0.0.0 and this fault code is active at key-on with the engine not running, the intake manifold pressure signal or barometric pressure sensor signal is inaccurate. Use INSITE™ electronic service tool, Data Logger/Monitor to view the calibration software phase.

Make sure only one turbocharger speed sensor o-ring is present. If the old turbocharger speed sensor o-ring remained when the new turbocharger speed sensor and turbocharger speed sensor o-ring were installed, this will create excessive clearance and the turbocharger sensor will not read the turbocharger speed, causing the fault.

Refer to Troubleshooting Fault Code t05-687

Last Modified: 01-Sep-2010


Engine Speed Sensor Circuit

FAULT CODE 689

Engine Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Primary Engine Speed Sensor Error. The ECM has detected an error in the engine speed signal. | Engine power derate.
Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor monitors engine speed and position then passes this information to the electronic control module (ECM) through the engine harness.

Component Location

The engine speed sensor is located on the side of the front gear housing on the intake side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault is logged when the ECM does not receive a valid engine speed signal. Causes of this fault include:

  • Open or short circuit of the +5 volt supply, signal, or return wire in the engine harness
  • Damaged or malfinctioning engine speed sensor.
Refer to Troubleshooting Fault Code t05-689

Last Modified: 02-Sep-2010


Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: S151 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor inlet air temperature circuit. | Engine will run derated.
Turbocharger Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor inlet air temperature sensor is used by the electronic control module (ECM) to monitor the turbocharger compressor inlet air temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The turbocharger compressor inlet air temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The turbocharger compressor inlet air temperature sensor is located on the turbocharger compressor inlet. Refer to Procedure 100-002.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, see the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, see the Separate Pressure/Temperature Sensor Return Circuit above.

The turbocharger compressor inlet air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, sensor, or ECM
  • Open signal circuit or shorted to a voltage source.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
-10 | 14 | 49k to 62k
0 | 32 | 29k to 36k
20 | 68 | 11.3k to 13.7k
40 | 104 | 4.9k to 5.8k
70 | 158 | 1.6k to 1.9k
100 | 212 | 640 to 720
Refer to Troubleshooting Fault Code t05-691

Last Modified: 22-Oct-2010


Turbocharger Number 1 Compressor Inlet Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger Number 1 Compressor Inlet Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: S151 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Turbocharger Number 1 Compressor Inlet Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Shorted to Low Source. Low signal voltage detected at the turbocharger compressor inlet air temperature circuit. | Engine will run derated.
Turbocharger Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor inlet air temperature sensor is used by the electronic control module (ECM) to monitor the turbocharger compressor inlet air temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The turbocharger compressor inlet air temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The turbocharger compressor inlet air temperature sensor is located on the turbocharger compressor inlet. Refer to Section E for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

The turbocharger compressor inlet air temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 692, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness or ECM
  • Signal shorted to return or ground in the sensor.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
-10 | 14 | 49k to 62k
0 | 23 | 29k to 36k
20 | 68 | 11.3k to 13.7k
40 | 104 | 4.9k to 5.8k
70 | 158 | 1.6k to 1.9k
100 | 212 | 640 to 720
Refer to Troubleshooting Fault Code t05-692

Last Modified: 01-Sep-2010


Engine Speed Sensor and Camshaft Position Sensor - Mechanical Misalignment Between Camshaft and Crankshaft Sensors

FAULT CODE 731

Engine Speed Sensor and Camshaft Position Sensor - Mechanical Misalignment Between Camshaft and Crankshaft Sensors

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed Sensor and Camshaft Position Sensor - Mechanical Misalignment Between Camshaft and Crankshaft Sensors. Engine position signal from the engine speed sensor and camshaft position sensor do not match. | Engine will run derated. Excessive smoke, hard start, and rough idle possible.
Engine Speed Sensor and Camshaft Position Sensor Circuit - Mechanical Misalignment Between Camshaft and Crankshaft Sensors

Circuit Description

The engine speed sensor and camshaft position sensor provide an engine speed and position signal to the engine control module (ECM) through the engine harness.

Component Location

Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Possible causes for this fault code include:

  • Loose, missing, or corroded grounds
  • Damaged tone wheel teeth
  • Loose crankshaft tone wheel
  • Static timing misset
  • Front gear train slippage
  • Misoriented engine speed or camshaft position sensor
  • Electrical noise.
Refer to Troubleshooting Fault Code t05-731

Last Modified: 18-Sep-2012


Camshaft Position Sensor Circuit

FAULT CODE 778

Camshaft Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | Camshaft Position Sensor Error. The ECM has detected an error in the camshaft position sensor signal. | Engine power derate.
Camshaft Position Sensor Circuit

Circuit Description

The camshaft position sensor monitors camshaft position then passes this information to the electronic control module (ECM) through the engine harness.

Component Location

The camshaft position sensor is located on the intake side of the engine in the cylinder head to the right of the ECM. Refer to Section E for a detailed component location view.

Shop Talk

This fault is logged when the ECM does not receive a valid camshaft position signal.

Causes of this fault include:

  • Open or short circuit of the +5 volt supply, signal, or return wire in the engine harness
  • Damaged or failed camshaft position sensor.
Refer to Troubleshooting Fault Code t05-778

Last Modified: 01-Sep-2010


Adaptive Cruise Control Circuit

FAULT CODE 784

Adaptive Cruise Control Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: SPN: 1590 FMI: 2 LAMP: Amber SRT: | Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
Adaptive Cruise Control Circuit

Circuit Description

The adaptive cruise control unit communicates with the electronic control module (ECM) sending and receiving vehicle speed control messages through the SAE J1939 data link.

Component Location

The location of the adaptive cruise control unit will vary by OEM. Refer to the OEM service manual for specific location.

Shop Talk

This fault is set active if the ECM does not receive the Heartbeat message from the adaptive cruise control unit on the SAE J1939 data link.

Refer to Troubleshooting Fault Code t05-784

Last Modified: 01-Sep-2010


Cylinder Power Imbalance

FAULT CODE 951

Cylinder Power Imbalance

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 951 PID: P166 SPN: 166 FMI: 2/2 LAMP: None SRT: | A power imbalance between cylinders was detected by the electronic control module (ECM). | Engine can have rough idle or misfire.
Cylinder Power Imbalance

Circuit Description

The ECM calculates the power output of each cylinder at engine idle speeds.

Component Location

The ECM is located on the intake side of the engine between the intake air horn and the front of the engine.

Shop Talk

At engine idle speeds, the ECM measures the instantaneous acceleration of each cylinder as it fires to determine the cylinder's power. The ECM adjusts fueling to individual cylinders if the imbalance is within pre-defined limits. If the imbalance is greater than the pre-defined limits, Fault Code 951 will be set active.

Refer to Troubleshooting Fault Code t05-951

Last Modified: 01-Sep-2010


Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1119

Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1119 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level. Engine coolant temperature signal indicates coolant temperature is above the engine coolant temperature engine protection warning limit. | EGR valve will be closed.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine, near the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

  • Beginning with engine serial number (ESN) first 14039654, the temperature sensor RETURN circuit was separated from the pressure sensor RETURN circuit. For engine serial numbers (ESNs) prior to this and with engine wiring harness Part Number 3682854, see the common pressure/temperature sensor RETURN circuit above. For this engine serial number (ESN) and greater or for any other engine wiring harness part number, see the separate pressure/temperature sensor RETURN circuit above.

This fault code can be caused by high coolant temperatures.

Refer to Troubleshooting Fault Code t05-1119

Last Modified: 02-Sep-2010


EGR Valve Position Sensor Circuit

FAULT CODE 1228

Printable Version Printable Version

Overview

EGR Valve Position Sensor Circuit

CODE | REASON | EFFECT
Fault Code: 1228 PID: P27 SPN: 27 FMI: 2/2 LAMP: Amber SRT: | EGR valve position sensor circuit - data erratic, intermittent, or incorrect. | Possible low power. EGR valve will be closed.
EGR Valve Position Sensor Circuit

Circuit Description

The EGR valve position sensor outputs a voltage signal to the ECM. The ECM converts this signal into a percentage value, 0 to 100 percent, indicating EGR valve position. A fully open valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is located on the EGR valve assembly. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is caused by an internal failure of the EGR valve position sensor. This failure causes erratic readings of EGR valve position.

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Refer to Troubleshooting Fault Code t05-1228

Last Modified: 02-Sep-2010


Ambient Air Density - Data Valid But Below Normal Operational Range - Least Severe Level

FAULT CODE 1943

Ambient Air Density - Data Valid But Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1943 PID: SPN: 3555 FMI: 1/17 LAMP: None SRT: | Low ambient air density has been calculated by the electronic control module. | Fuel is limited in an attempt to protect the engine.
Low Ambient Air Density

Circuit Description

The ambient air density is calculated by the electronic control module (ECM). Ambient air density is derived by the ECM, based on ambient air pressure and ambient air temperature.

Component Location

There is not a physical ambient air density sensor in the system. The ambient air density is a calculation based on the ambient air pressure and temperature.

Shop Talk

The most common cause of this fault code is high altitude. The fault code can also be caused by extreme ambient air temperatures. This derate can be viewed in the INSITE™ electronic service tool, User Fueling State, as Air Density Limit State.

NOTE: The engine must be loaded to trip this fault code in the shop. The engine must be under the same operating conditions (altitude and temperature) at the time that it had originally logged.

Refer to Troubleshooting Fault Code t05-1943

Last Modified: 01-Sep-2010


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2215

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: P094 SPN: 94 FMI: 1/18 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low fuel pressure has been detected by the ECM. | Engine may not start, emitt white smoke, run rough, or lose power.
ISX - Fuel System Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel manifold of the integrated fuel system module (IFSM). The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

The electronic control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel manifold. The ECM will detect a low signal voltage at operating conditions, such as during an idle or a deceleration. The ECM will detect a high signal voltage during high engine load operating conditions.

The gear pump draws fuel from the fuel tank through a suction fuel filter and an anti-drainback valve. The gear pump develops between 1724 and 2620 kPa [250 and 380 psi] of fuel pressure. The fuel flows through a pressure fuel filter and fuel shutoff valve to the fueling and timing actuators and rail fuel pressure sensor.

Component Location

The rail fuel pressure sensor is located on the bottom front corner of the IFSM. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the fuel delivery pressure is lower than the minimum pressure level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The engine may not start, or the performance output of the engine could be limited, due to the low fuel pressure condition.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Use the following procedure in the appropriate Troubleshooting and Repair Manual for the engine being serviced. Refer to Procedure 019-032 in Section 19.

It is possible to swap the connections between the aftertreatment fuel pressure sensor and the fuel delivery pressure sensor. If this occurs, Fault Code 2215 will intermittently go active and the engine will run rough and will surge at low idle. If these symptoms are present, make sure the fuel pressure connections are connected properly.

The fuel pressure is monitored by the electronic control module (ECM). If the rail fuel pressure is lower than an acceptable level for given engine operating conditions, the fault code is logged.

NOTE: One possible cause for this fault code is a damaged or sticking drain-back valve located in the fuel supply circuit in the integrated fuel system module (IFSM) which is located directly above the fuel lift pump.

Refer to Troubleshooting Fault Code t05-2215.

Last Modified: 17-Jan-2011


EGR Valve Position Sensor Circuit

FAULT CODE 2271

EGR Valve Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2271 PID: P27 SPN: 27 FMI: 3/3 LAMP: Amber SRT: | EGR Valve Position Sensor Circuit - Shorted High. High signal voltage detected at EGR valve position sensor circuit. | Possible low power. Power will be removed from EGR valve motor.
EGR Valve Position Sensor Circuit

Circuit Description

The EGR valve position sensor outputs a voltage signal to the ECM. The ECM converts this signal into a percentage value from 0 to 100 indicating valve position. A fully open valve is equivalent to 100 percent. The engine harness is connected to the EGR valve by an EGR valve extension harness. This extension harness contains five wires, three for the EGR valve position sensor and two for the EGR valve motor.

Component Location

The EGR valve position sensor is located on the EGR valve assembly. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view of each sensor.

Shop Talk

The EGR valve position sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness may cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Failed EGR valve position sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code t05-2271

Last Modified: 02-Sep-2010


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P27 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) Valve Position Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at EGR valve position sensor circuit. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Position Sensor Circuit

Circuit Description

The EGR valve position sensor outputs a voltage signal to the electronic control module (ECM). The ECM converts this signal into a percentage value, from 0 to 100 percent, indicating valve position. A fully open valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is located on the EGR valve assembly. Refer to Procedure 100-002 in Section E.

Shop Talk

The EGR valve position sensor shares supply and return wires in the engine harness with other sensors. Open circuits and shorts circuits in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground
  • Supply circuit open or shorted to ground
  • Sensor shorted to ground
  • Damaged EGR valve.
Refer to Troubleshooting Fault Code t05-2272

Last Modified: 02-Sep-2010


EGR Valve Differential Pressure Sensor Circuit

FAULT CODE 2273

EGR Valve Differential Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | EGR Valve Differential Pressure Sensor Circuit - shorted high. High signal voltage detected at EGR differential pressure sensor circuit. | EGR valve will be closed.
EGR Differential Pressure Sensor Circuit for Original Sensor with Side Connector
EGR Differential Pressure Sensor Circuit for Updated Sensor with Rear Connector

Circuit Description

The EGR differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The ECM uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

Component Location

The EGR differential pressure sensor is mounted to the air intake manifold between cylinders three and four. Refer to Procedure 100-002 for a detailed component location view.

Note: The original sensor is connected to the engine harness through a short pigtail harness. The pigtail harness is permanently affixed to the original sensor. Do not try to remove the connector that is attached to the origninal sensor body or damage to the sensor will result.

Shop Talk

The EGR differential pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-2273

Last Modified: 02-Sep-2010


EGR Differential Pressure Sensor Circuit

FAULT CODE 2274

EGR Differential Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | EGR Differential Pressure Sensor Circuit - shorted low. Low signal voltage detected at EGR differential pressure sensor circuit. | EGR valve will be closed.
EGR Differential Pressure Sensor Circuit for Original Sensor with Side Connector
EGR Differential Pressure Sensor Circuit for Updated Sensor with Rear Connector

Circuit Description

The EGR differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The ECM uses this pressure difference to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.

Component Location

The EGR differential pressure sensor is mounted to the air intake manifold between cylinders three and four. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Note: The original sensor is connected to the engine harness through a short pigtail harness. The pigtail harness is permanently affixed to the original sensor. Do not try to remove the connector that is attached to the original sensor body. Damage to the sensor will result.

Shop Talk

The EGR differential pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 2274, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open in the engine harness, connectors, or sensor
  • Supply circuit open or shorted to ground
  • Leaks in the sensor EGR differential pressure tubes
  • Sensor shorted to ground.
Refer to Troubleshooting Fault Code t05-2274

Last Modified: 02-Sep-2010


Variable Geometry Turbocharger Output Device Driver - Shorted High

FAULT CODE 2277

Variable Geometry Turbocharger Output Device Driver - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2277 PID: S27 SPN: 641 FMI: 3/3 LAMP: Amber SRT: | Variable Geometry Turbocharger Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at turbocharger control valve circuit. | The variable geometry actuator will go to either the fully open or fully closed position.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the control valve through the turbocharger control valve signal of the ECM engine harness. The turbocharger control valve is grounded to the engine block through the turbocharger control valve return wire, not back to the ECM. The turbocharger control valve, Centinel™ oil control valve, and turbocharger control shutoff valve share the same return wire in the engine harness.

Component Location

The turbocharger control valve is mounted on top of the alternator/refrigerant compressor mounting bracket. Refer to Section E for a detailed component location view.

Shop Talk

Turbocharger Control Valve Command can be monitored with the INSITE™ electronic service tool. This parameter represents the ECM command to the turbocharger control valve which in turn controls the variable geometry actuator position.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or turbocharger control valve.
  • Signal circuit short to voltage source in the engine harness.
Refer to Troubleshooting Fault Code t05-2277

Last Modified: 01-Sep-2010


Turbocharger Control Valve Circuit

FAULT CODE 2278

Turbocharger Control Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2278 PID: S27 SPN: 641 FMI: 4/4 LAMP: Amber SRT: | Turbocharger Control Valve Circuit - shorted low. Low voltage detected at turbocharger control valve circuit. | The variable geometry actuator will go to the fully open position.
Turbocharger Control Valve Circuit

Circuit Description

The ECM controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the turbocharger control valve through the turbocharger control valve signal of the ECM engine harness. The turbocharger control valve is grounded to the engine block through the turbocharger control valve return wire, not back to the ECM. The turbocharger control valve, Centinel™ oil control valve, and turbocharger control shutoff valve share the same return wire in the engine harness.

Component Location

The turbocharger control valve is mounted on top of the alternator/refrigerant compressor mounting bracket. Refer to Section E for a detailed component location view.

Shop Talk

Turbocharger Control Valve Command can be monitored with the INSITE™ electronic service tool. This parameter represents the ECM command to the turbocharger control valve which in turn controls the variable geometry actuator position.

Possible causes for this fault code include:

  • Signal circuit short circuit to ground in the engine harness, connectors, or turbocharger control valve.
Refer to Troubleshooting Fault Code t05-2278

Last Modified: 01-Sep-2010


Front Fueling Actuator Circuit

FAULT CODE 2311

Front Fueling Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S18 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Fueling Actuator Number 1 Circuit Error. Error detected on the front fueling actuator circuit. | Cylinders in front bank will not receive fuel. Engine will run rough with low power.
Front Fueling Actuator Circuit

Circuit Description

The fueling actuators are commanded by the ECM to control fuel metering. Each fueling actuator is connected to the ECM by a fueling actuator (+) and fueling actuator (-) wire. An electrical signal is sent to the fueling actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front fueling actuator is located on the fuel control housing. It is the first actuator from the front of the engine. The fuel control housing is located on the intake side of the engine below the EGR mixer. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes of this fault are:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or actuator
  • Short circuit to voltage source in the engine harness
  • Low or high resistance in the actuator.
Refer to Troubleshooting Fault Code t05-2311

Last Modified: 01-Sep-2010


Front Timing Actuator Circuit

FAULT CODE 2312

Front Timing Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2312 PID: S20 SPN: 635 FMI: 11/31 LAMP: Amber SRT: | Timing Actuator Number 1 Circuit Error. Error detected on the front timing actuator circuit. | Cylinders in front bank will not receive fuel. Engine will run rough with low power.
Front Timing Actuator Circuit

Circuit Description

The timing actuators are commanded by the ECM to control fuel timing. Each timing actuator is connected to the ECM by a timing actuator (+) and timing actuator (-) wire. An electrical signal is sent to the timing actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The front timing actuator is located on the fuel control housing. It is the second actuator from the front of the engine. The fuel control housing is located on the intake side of the engine below the EGR mixer. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes of this fault are:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or actuator
  • Short circuit to voltage source in the engine harness
  • Low or high resistance in the actuator.
Refer to Troubleshooting Fault Code t05-2312

Last Modified: 01-Sep-2010


Rear Fueling Actuator Circuit

FAULT CODE 2313

Rear Fueling Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2313 PID: S83 SPN: 1244 FMI: 11/31 LAMP: Amber SRT: | Fueling Actuator Number 2 Circuit Error. Error detected on the rear fueling actuator circuit. | Cylinders in rear bank will not receive fuel. Engine will run rough with low power.
Rear Fueling Actuator Circuit

Circuit Description

The fueling actuators are commanded by the ECM to control fuel metering. Each fueling actuator is connected to the ECM by a fueling actuator (+) and fueling actuator (-) wire. An electrical signal is sent to the fueling actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear fueling actuator is located on the fuel control housing. It is the first actuator from the rear of the engine. The fuel control housing is located on the intake side of the engine below the EGR mixer. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes of this fault are:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or actuator
  • Short circuit to voltage source in the engine harness
  • Low or high resistance in the actuator.
Refer to Troubleshooting Fault Code t05-2313

Last Modified: 01-Sep-2010


Rear Timing Actuator Circuit

FAULT CODE 2314

Rear Timing Actuator Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2314 PID: S84 SPN: 1245 FMI: 11/31 LAMP: Amber SRT: | Timing Actuator Number 2 Circuit Error. Error detected on the rear timing actuator circuit. | Cylinders in rear bank will not receive fuel. Engine will run rough with low power.
Rear Timing Actuator Circuit

Circuit Description

The timing actuators are commanded by the ECM to control fuel timing. Each timing actuator is connected to the ECM by a timing actuator (+) and timing actuator (-) wire. An electrical signal is sent to the timing actuator from the ECM on the (+) wire and is returned to the ECM on the (-) wire. Each actuator is normally closed, and it is only opened by an electrical pulse from the ECM during metering.

Component Location

The rear timing actuator is located on the fuel control housing. It is the second actuator from the rear of the engine. The fuel control housing is located on the intake side of the engine below the EGR mixer. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes of this fault are:

  • Open circuit in the engine harness, connectors, or actuator
  • Short circuit to ground in the engine harness or actuator
  • Short circuit to voltage source in the engine harness
  • Low or high resistance in the actuator.
Refer to Troubleshooting Fault Code t05-2314

Last Modified: 01-Sep-2010


Engine Speed/Position Sensor Number 1 - Engine Speed/Position Glitch Detect

FAULT CODE 2321

Engine Speed/Position Sensor Number 1 - Engine Speed/Position Glitch Detect

Printable Version Printable Version

Overview

Engine Speed/Position Sensor Number 1 - Engine Speed/Position Glitch Detect

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2 LAMP: None SRT: | Engine speed/position sensor number 1 - engine speed/position glitch detect (crankshaft sensor). | Engine may exhibit misfire as control switches from the primary to the backup speed sensor.
Engine Speed/Position Sensor Number 1 Circuit

Circuit Description

The engine speed sensor provides engine speed information to the ECM. The sensor is powered by +5 VDC. The sensor generates the signal by sensing the movement of target teeth machined into the tone wheel that is pressed onto the crankshaft.

Component Location

The engine speed sensor is located on the side of the front gear housing on the intake side of the engine. Refer to Section E for a detailed component location view.

Shop Talk

The CM870 controls are able to function almost normally on a single speed sensor. In the event that there is a signal glitch on the engine speed sensor, the system controls transfer to the camshaft position sensor. After awhile, the camshaft position sensor will transfer controls back to the engine speed sensor. When the controls transfer from one sensor to the next, a few actuator pulses may be skipped. This transition between sensors may be seen as a glitch, dropout, or miss. Fault Code 2321 serves as a tool to identify the source of those glitches in the event that a customer has a complaint regarding glitches, dropouts, or misses.

This fault becomes inactive at each key ON or if the ECM does not detect a loss of the engine speed sensor signal for at least 20 minutes.

Failures that can cause this fault:

  • Loose, damaged, or corroded ECM or sensor connection
  • Engine harness insulation damage
  • Pushed back or bent ECM, sensor, or harness pins.

Actions to take if fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit. Refer to Procedure 019-362.
Refer to Troubleshooting Fault Code t05-2321

Last Modified: 02-Sep-2010


Turbocharger Turbine Inlet Temperature (Calculated) - Data Above Normal Operational Range - Least Severe Level.

FAULT CODE 2346

Turbocharger Turbine Inlet Temperature (Calculated) - Data Above Normal Operational Range - Least Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger Turbine Inlet Temperature (Calculated) - Data Above Normal Operational Range - Least Severe Level. | Fuel is limited in an attempt to decrease the calculated exhaust gas temperature.
High Exhaust Gas Temperature (Calculated)

Circuit Description

The exhaust gas temperature is calculated by the electronic control module (ECM). Exhaust gas temperature is derived by the electronic control module, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger and is also known as turbine inlet temperature.

NOTE: Some OEMs have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet temperature or (the temperature of the exhaust gas leaving the turbocharger) and will not equal the value monitored with the exhaust gas temperature parameter in INSITE™ electronic service tool.

Shop Talk

The most common cause of this fault code is low boost. Low boost can be caused by several factors: leaking charge air cooler, loose charge air cooler clamps, malfunctioning components, (including charge air cooler piping or hoses), intake manifold pressure sensor, variable geometry turbocharger, turbocharger control valve, or turbocharger control shutoff valve.

NOTE: Prior to running INSITE™ electronic service tool EGR valve and EGR valve/turbocharger operational test, the ECM Calibration software phase could possibly need to be updated to the latest software phase. The ECM calibration phase software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the software phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the software phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require software phase 06050402.

ISX engines with CM870 (engines built before January 2004) require software phase 05050000.

This is a warrantable calibration change.

This fault code can also be caused be a Turbocharger Fuel Control (TFC) derate which can be viewed in INSITE™ electronic service tool, under the User Fueling State. TFC derates can be caused by several factors: high exhaust temperatures, high turbocharger compressor inlet temperatures, and high turbocharger compressor outlet temperatures.

NOTE: The engine must be loaded to trip this fault code and to determine if the problem has been found and fixed. It is possible to cause the fault code to log when the engine is placed on a dynamometer. The fault code will trip because of the stationary nature and high temperatures encountered on the dynamometer.

Refer to Troubleshooting Fault Code t05-2346

Last Modified: 01-Sep-2010


Turbocharger Compressor Outlet Air Temperature (Calculated) - Data Valid but Above Normal Range

FAULT CODE 2347

Turbocharger Compressor Outlet Air Temperature (Calculated) - Data Valid but Above Normal Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: S309 SPN: 2790 FMI: 0/15 LAMP: None SRT: | Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level. High turbocharger compressor outlet air temperature has been calculated by the electronic control module (ECM). | Fuel is limited in an attempt to decrease the calculated turbocharger compressor outlet air temperature.
Turbocharger Compressor Outlet Air Temperature

Circuit Description

The turbocharger compressor outlet air temperature is calculated by the ECM. Turbocharger compressor outlet air temperature is calculated by the ECM, based on engine operating conditions such as turbocharger compressor inlet air temperature, barometric pressure, turbocharger speed, engine speed, intake manifold air temperature, and intake manifold pressure.

Component Location

There is not a physical turbocharger compressor outlet air temperature sensor in the system. The turbocharger compressor outlet air temperature is a calculation of the temperature of the air after it is compressed by the turbocharger compressor, but before exhaust gas from the EGR connection tube is mixed into the system, and before it enters the charge air cooler.

Shop Talk

Note: This fault code may become active if the protective shipping sticker is not removed from the port located on the end opposite of the connector. When installing a new turbocharger control valve, make sure the adhesive cover is removed.

Note: Before performing the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, be sure the ECM Calibration Software Phase is updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below, or later, do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault code include:

  • Air intake leaks allowing hot under hood air to enter the intake system
  • Faulty intake manifold pressure readings
  • High turbocharger speed readings
  • Faulty barometric pressure readings
  • Stuck turbocharger control valve
  • Stuck variable geometry turbocharger.

Note: Unless the malfunction is a damaged barometric pressure sensor or intake manifold pressure sensor, this fault code will not become active without a load in the shop. The engine will need to be loaded to trip this fault code and to determine if the failure has been found and fixed.

Refer to Troubleshooting Fault Code t05-2347

Last Modified: 01-Sep-2010


EGR Valve Self Calibration

FAULT CODE 2348

EGR Valve Self Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2348 PID: 27 SPN: 27 FMI: 13/13 LAMP: Amber SRT: | EGR Valve Self Calibration. EGR valve failed automatic self calibration procedure. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Self Calibration Circuit

Circuit Description

The electronic control module (ECM) periodically checks and adjusts the zero position of the EGR valve position sensor when the EGR valve is closed. This self calibrating feature adjusts for wear and unit to unit variation of position sensors and valve assemblies. This fault is logged if the position sensor reading is outside the self calibration limits.

Component Location

The EGR valve position sensor is mounted on the EGR valve assembly. Refer to Procedure 100-002 (Engine View) in Section E for a detailed component location view.

Shop Talk

A possible cause of this fault is an EGR valve assembly internal malfunction that is causing the EGR valve not to close fully.

Another possible cause of this fault code is high resistance in the EGR valve connectors or the EGR valve position +5 volt SUPPLY. A short circuit between the EGR valve position SIGNAL and other pins could also trigger Fault Code 2348.

Refer to Troubleshooting Fault Code t05-2348

Last Modified: 02-Sep-2010


Exhaust Gas Recirculation (EGR) Valve Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 2349

Exhaust Gas Recirculation (EGR) Valve Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5/5 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) Valve Control Circuit - current below normal or open circuit. | Possible low power. Power removed from the EGR valve motor.
Exhaust Gas Recirculation (EGR) Valve Control Circuit

Circuit Description

The Electronic Control Module (ECM) controls the EGR valve, opening and closing it based on various engine operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor SIGNAL (+) and EGR valve motor SIGNAL (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor SIGNAL (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor SIGNAL (-) circuit.

Component Location

The EGR valve and motor assembly is located on the exhaust side of the engine. It is mounted near the accessory bracket towards the front of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The ECM monitors the voltage level of this circuit and logs a fault code if the voltage level indicates an open circuit or short to voltage source.

This fault is always set inactive when the keyswitch is turned ON. If the fault condition reoccurs while the keyswitch is in the ON position, the fault code will be set active. Since active faults are set inactive at key ON, this troubleshooting tree should be used to troubleshoot active and inactive faults.

Possible causes of this fault include:

  • An open circuit in the engine harness, connectors, motor, or ECM
  • EGR valve motor SIGNAL (+) or (-) leads shorted to a voltage source in the engine harness or ECM.

Do not supply voltage of any kind to the EGR valve motor. This circuit uses a pulse-width-modulated signal and direct voltage can permanently damage the motor.

Refer to Troubleshooting Fault Code t05-2349

Last Modified: 02-Sep-2010


Exhaust Gas Recirculation (EGR) Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2351

Exhaust Gas Recirculation (EGR) Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2351 PID: S146 SPN: 2791 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the EGR valve motor circuit. | Possible low power. Power removed from the EGR valve motor.
EGR Valve Control Circuit

Circuit Description

The electronic control module (ECM) controls the EGR valve, opening and closing it based on various engine operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor SIGNAL (+) and EGR valve motor SIGNAL (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor SIGNAL (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor SIGNAL (-) circuit.

Component Location

The EGR valve and motor assembly is located on the exhaust side of the engine. It is mounted near the accessory bracket towards the front of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault are EGR valve motor (+) or (-) leads shorted to ground in the harness, EGR valve motor, or ECM. The ECM monitors the voltage level of this circuit and logs a fault code if the voltage level indicates that a short to ground is present. This fault is always set inactive when the keyswitch is turned ON. If the fault condition reoccurs while the keyswitch is turned ON, the fault code will be set active. Because active faults are set inactive at keyswitch ON, this troubleshooting tree must be used to troubleshoot active and inactive faults.

This also means the only sufficient way to make certain the repair is complete is to run the INSITE™ electronic service tool EGR valve test. Operating the engine is not adequate to verify the correct component was repaired or replace.

Refer to Troubleshooting Fault Code t05-2351

Last Modified: 02-Sep-2010


Exhaust Gas Recirculation (EGR) Valve Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2352

Exhaust Gas Recirculation (EGR) Valve Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2352 PID: S146 SPN: 2791 FMI: 3/3 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the EGR valve motor circuit. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Control Circuit

Circuit Description

The electronic control module (ECM) controls the EGR valve, opening and closing it based on various engine operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor SIGNAL (+) and EGR valve motor SIGNAL (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor SIGNAL (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor SIGNAL (-) circuit.

Component Location

The EGR valve and motor assembly is located on the exhaust side of the engine. It is mounted near the accessory bracket towards the front of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault are EGR valve motor (+) or (-) leads shorted to a voltage source in the harness or ECM. The ECM monitors the voltage level of this circuit and logs a fault code if the voltage level indicates a short to voltage source is present. This fault is always set inactive when the keyswitch is turned ON. If the fault condition reoccurs while the keyswitch is turned ON, the fault code will be set active. Because active fault codes are set inactive at keyswitch ON, this troubleshooting tree must be used to troubleshoot active and inactive faults.

This also means the only sufficient way to make certain the repair is complete is to run the INSITE™ electronic service tool EGR valve test. Operating the engine is not adequate to verify the correct component was repair or replaced.

Refer to Troubleshooting Fault Code t05-2352

Last Modified: 02-Sep-2010


Exhaust Gas Recirculation (EGR) Valve Control Circuit - Excessive Current Detected

FAULT CODE 2353

Exhaust Gas Recirculation (EGR) Valve Control Circuit - Excessive Current Detected

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2353 PID: S146 SPN: 2791 FMI: 6/6 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) Valve Control Circuit - excessive current detected. Excessive current detected at the EGR valve motor output circuit. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Motor Output Circuit

Circuit Description

The ECM controls the EGR valve, opening and closing it based on various engine operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor (+) and EGR valve motor (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor (-) circuit.

Component Location

The EGR valve and motor assembly is located on the exhaust side of the engine. It is mounted near the accessory bracket towards the front of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The ECM monitors the current draw of this circuit. If the ECM detects excessive current, it sets the Fault Code 2353 active.

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault include:

  • EGR valve motor (+) or (-) leads shorted together in the engine harness, EGR valve extension harness, EGR valve motor or ECM
  • Low EGR valve motor internal resistance.
Refer to Troubleshooting Fault Code t05-2353

Last Modified: 02-Sep-2010


Turbocharger Control Shutoff Valve Circuit

FAULT CODE 2355

Turbocharger Control Shutoff Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2355 PID: SPN: 2792 FMI: 3/3 LAMP: Amber SRT: | VGT Air Control Shutoff Valve Circuit - shorted high. Open circuit or high signal voltage detected at the turbocharger control shutoff valve circuit. | Turbocharger control shutoff valve will either remain open or closed. If open, vehicle air will bleed off through turbocharger control valve over time with engine shut off. If closed, no air will be delivered to turbocharger control valve.
Turbocharger Control Shutoff Valve Circuit

Circuit Description

The turbocharger control shutoff valve controls the flow of vehicle brake air to the turbocharger control valve. When the keyswitch is in the ON position, the ECM commands the turbocharger control shutoff valve open, allowing vehicle air to pass through to the turbocharger control valve. When the keyswitch is in the OFF position, the ECM commands the turbocharger control shutoff valve closed shutting off the flow of vehicle air to the turbocharger control valve. This also prevents vehicle brake air from bleeding down through the turbocharger control valve while the vehicle is not in use.

Component Location

The turbocharger control shutoff valve is located on the intake side of the engine below the air compressor. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness signal circuit, connectors, or shutoff valve
  • Signal circuit short to voltage source in the engine harness.
Refer to Troubleshooting Fault Code t05-2355

Last Modified: 01-Sep-2010


Turbocharger Control Shutoff Valve Circuit

FAULT CODE 2356

Turbocharger Control Shutoff Valve Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2356 PID: SPN: 2792 FMI: 4/4 LAMP: Amber SRT: | Turbocharger Control Shutoff Valve - shorted high. Low voltage detected at turbocharger control shutoff valve circuit. | Turbocharger control shutoff valve will remain closed. No air delivered to turbocharger control valve.
Turbocharger Control Shutoff Valve Circuit

Circuit Description

The turbocharger control shutoff valve controls the flow of vehicle brake air to the turbocharger control valve. When the keyswitch is in the ON position, the ECM commands the shutoff valve open, allowing vehicle air to pass through to the turbocharger control valve. When the keyswitch is in the OFF position, the ECM commands the shutoff valve closed, shutting off the flow of vehicle air to the turbocharger control valve. This also prevents vehicle brake air from bleeding down through the turbocharger control valve while the vehicle is not in use.

Component Location

The turbocharger control shutoff valve is located on the intake side of the engine, below the air compressor. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes for this fault include:

  • Short circuit to ground in the engine harness, connectors, or control valve.
Refer to Troubleshooting Fault Code t05-2356

Last Modified: 01-Sep-2010


Exhaust Gas Recirculation (EGR) Valve Control - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2357

Exhaust Gas Recirculation (EGR) Valve Control - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2357 PID: S146 SPN: 2791 FMI: 7/7 LAMP: Amber SRT: | EGR Valve Control - Mechanical System not Responding Properly or Out of Adjustment. EGR valve not responding or slow to respond. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Motor Circuit

Circuit Description

The electronic control module (ECM) controls the EGR valve, opening and closing it based on various engine operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor SIGNAL (+) and EGR valve motor SIGNAL (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor SIGNAL (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor SIGNAL (-) circuit.

Component Location

The EGR valve and motor assembly is located on the exhaust side of the engine. It is mounted near the accessory bracket towards the front of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault include:

  • Damaged EGR valve position sensor, mechanical or electrical damage.
  • EGR valve assembly damage requiring a high current to operate the valve, such as a stuck or sticking valve.

The ECM monitors the response of the EGR valve and logs a fault code if the valve fails to respond as commanded. When the ECM stops commanding the valve, the fault code will go inactive; therefore, this fault code tree must be used to troubleshoot active and inactive faults.

This also means the only sufficient way to make certain the repair is complete is to run the INSITE™ electronic service tool EGR valve test. Operating the engine is not adequate to verify the correct component was repaired or replaced.

Refer to Troubleshooting Fault Code t05-2357

Last Modified: 02-Sep-2010


EGR Differential Pressure Sensor - Data Valid But Above Normal Operating Range-Moderately Severe Level

FAULT CODE 2359

EGR Differential Pressure Sensor - Data Valid But Above Normal Operating Range-Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Recirclation (EGR) Differential Pressure Sensor - Data Valid But Above Normal Operating Range-Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2359 PID: P411 SPN: 411 FMI: 0/16 LAMP: Amber SRT: | EGR Differential Pressure Sensor - data valid but above normal operating range-moderately severe level. EGR differential pressure sensor failed automatic calibration procedure or EGR differential pressure reading not valid for engine operating conditions. | EGR valve will be closed.
ISM02 (CM870/CM570) and ISX (CM870) EGR Differential Pressure Sensor Circuit for Original Sensor with Side Connector
ISM04 (CM875) EGR Differential Pressure Sensor Circuit for Original Sensor with Side Connector
ISM04 (CM875) EGR Differential Pressure Sensor Circuit for Updated Sensor with Rear Connector

Circuit Description

The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

ISM02 (CM870 and CM570) and ISM04 (CM875) engines: The sensor is located on the air intake manifold.

ISX (CM870) engines: The sensor is located near the fuel inlet to the integrated fuel system module (IFSM).

A High EGR differential pressure tube and a Reference EGR differential pressure tube extend from the EGR differential pressure orifice and connect to the EGR differential pressure sensor. Reference the respective procedure below for a detailed component view:

ISM CM870 and CM570 Electronic Control System, Troubleshooting and Repair Manual, Bulletin 4021381. Refer to Procedure 100-002 in Section E.

ISM CM875 Electronic Control System, Troubleshooting and Repair Manual, Bulletin 4021477. Refer to Procedure 100-002 in Section E.

Signature™ and ISX CM870 Electronic Control System, Troubleshooting and Repair Manual, Bulletin 4021334. Refer to Procedure 100-002 in Section E.

The original sensor is connected to the engine harness through a short pigtail harness. The pigtail harness is permanently affixed to the original sensor. Do not try to remove the connector attached to the original sensor body. Damage to the sensor will result.

Shop Talk

The ECM Calibration Software Phase can be checked in INSITE™ electronic service tool, under Features and Parameters. There have been changes in the calibrations that reduce false occurrences of the fault code and also affect the tolerable sensor range.

  • Expand the selection for System ID and Dataplate, then go to Calibration Information.
  • ISX Engines with CM870 built during and after January 2004 require software phase 06050402 or greater from the February 2007 INCAL™ DVD or newer.
  • ISX Engines with CM870 built before January 2004 require software phase 05050000 or greater from the April 2007 INCAL™ DVD or newer.

The ECM Calibration Revision History can be found at: http://insite.cummins.com/insite/tools/incal/index.html.

This is a warrantable calibration change.

Possible causes of this fault code include:

  • A plugged or leaking low or high EGR differential pressure tube
  • A damaged EGR differential pressure sensor
  • A stuck open or closed EGR valve
  • A damaged EGR connection tube hose
  • A leak in the EGR connection tube hoses or tubes
  • A damaged variable geometry turbocharger
  • A damaged variable geometry actuator
  • A damaged turbocharger control valve
  • A damaged turbocharger control shutoff valve
  • A plugged turbocharger control shutoff valve filter
  • A leak in the air line supplying air pressure to the turbocharger control shutoff valve, turbocharger control valve, or variable geometry actuator
  • Incorrectly installed EGR differential pressure tubes
  • Incorrectly installed EGR differential pressure sensor
  • Expanded exhaust gasses trapped in differential pressure tube.
  • A damaged EGR cooler that allows coolant into the crossover tube and EGR differential pressure sensor tubes.

Note: If Fault Code 2359 is active after a key-cycle and the engine is not running, it will be set inactive only if the following conditions are met:

  • Engine coolant temperature is greater than 67°C [154°F]
  • Intake manifold air temperature is greater than 7°C [45°F]
  • Keyswitch transitions from ON to OFF for 30 seconds.
  • EGR differential pressure sensor reading is within a set calibration threshold near zero.

ISM02 and ISM04 VGT Actuator Travel Specifications
CPL | Minimum Acturator Travel | Maximum Acturator Travel
8427, 8559, 8560, 8603, 8706 | 8 mm [0.315 in] | 10 mm [0.394 in]
8271, 8272, 8273, 8274, 8503, 8504, 8505, 8506, 8556, 8557, 8561, 8562 | 7 mm [0.276 in] | 9 mm [0.354 in]
8377, 8558, 8563, 8572 | 10 mm [0.394 in] | 12 mm [0.472 in]
Refer to Troubleshooting Fault Code t05-2359

Last Modified: 06-Sep-2016


Engine Brake Solenoid 1 Signal Circuit

FAULT CODE 2362

Engine Brake Solenoid 1 Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2362 PID: S28 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Circuit Number 1 - shorted low. Low voltage detected at the engine brake solenoid Number 1 signal circuit. | Engine brake on cylinder Number 1 can not be activated.
Engine Brake Solenoid 1 Signal Circuit

Circuit Description

The ECM controls the engine brakes on cylinder Number 1 by sending a signal on engine brake solenoid 1 signal circuit. The ECM will only command the brakes on under certain operating conditions.

Component Location

The engine brake solenoids are located under the valve cover. The 8-pin engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.

Shop Talk

Possible causes for this fault include:

  • Short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-2362

Last Modified: 01-Sep-2010


Engine Brake Solenoid 2 Signal Circuit

FAULT CODE 2363

Engine Brake Solenoid 2 Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S29 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Circuit Number 2 - shorted low. Low voltage detected at the engine brake solenoid Number 2 signal circuit. | Engine brake on cylinders Number 2 and 3 can not be activated.
Engine Brake Solenoid 2 Signal Circuit

Circuit Description

The ECM controls the engine brakes on cylinders Number 2 and 3 by sending a signal on engine brake signal Number 2 circuit. The ECM will only command the brakes on under certain operating conditions.

Component Location

The engine brake solenoids are located under the valve cover. The 8-pin engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.

Shop Talk

Possible causes for this fault include:

  • Short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-2363

Last Modified: 01-Sep-2010


Engine Brake Solenoid 3 Signal Circuit

FAULT CODE 2365

Engine Brake Solenoid 3 Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2365 PID: S82 SPN: 1112 FMI: 4/4 LAMP: Amber SRT: | Engine Brake Actuator Circuit Number 3 - shorted low. Low voltage detected at the engine brake solenoid Number 3 signal circuit. | Engine brake on cylinders Number 4, 5, and 6 can not be activated.
Engine Brake Solenoid 3 Signal Circuit

Circuit Description

The ECM controls the engine brakes on cylinders Number 4, 5, and 6 by sending a signal on engine brake solenoid 3 signal circuit. The ECM will only command the brakes on under certain operating conditions.

Component Location

The engine brake solenoids are located under the valve cover. The 8-pin engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes for this fault include:

  • Short circuit to ground in the engine harness, connectors, or engine brake solenoids
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-2365

Last Modified: 01-Sep-2010


Fault Code Path Selection

FAULT CODE 2366
Fault Code Path Selection

Does the engine have software older than 05040408? | Go to 70-fc2366v1
Does the engine have 05040408 software or newer? | Go to 70-fc2366v2

Last Modified: 06-Aug-2009


Fault Code Path Selection

FAULT CODE 2367
Fault Code Path Selection

Does the engine have software older than 05040408? | Go to 70-fc2367v1
Does the engine have 05040408 software or newer? | Go to 70-fc2367v2

Last Modified: 06-Aug-2009


Engine Brake Solenoid Number 3 Signal Circuit

FAULT CODE 2368

Engine Brake Solenoid Number 3 Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2368 PID: S82 SPN: 1112 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Circuit Number 3 - shorted high. Open circuit or high voltage detected at the engine brake solenoid Number 3 signal circuit. | Engine brake on cylinders Number 4, 5, and 6 may be on all the time, or can not be activated.
Engine Brake Solenoid Number 3 Signal Circuit

Circuit Description

The ECM controls the engine brakes on cylinders Number 4, 5, and 6 by sending a signal on engine brake solenoid Number 3 signal circuit. The ECM will only command the brakes on under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.

Shop Talk

Possible causes of this fault include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Damaged ECM
  • Loose connection at the engine brake solenoid.
Refer to Troubleshooting Fault Code t05-2368

Last Modified: 01-Sep-2010


Fuel Filter Restriction Moderately High - Warning

FAULT CODE 2372

Fuel Filter Restriction Moderately High - Warning

Printable Version Printable Version

Overview

Fuel Filter Restriction Moderately High - Warning

CODE | REASON | EFFECT
Fault Code: 2372 PID: P95 SPN: 95 FMI: 0/16 LAMP: Amber - Maintenance Flashout SRT: | Fuel filter restriction moderately high - warning. Fuel filter is plugged or fuel inlet restriction is high. | The engine can respond poorly after motoring and/or the engine can have low power at high engine speeds.
Integrated Fuel System Module (IFSM)

Circuit Description

This fault code activates if low fuel pressure is detected by the Electronic Control Module (ECM) during high engine rpm or motoring conditions.

Component Location

There are two fuel filters and several OEM supplied components that can attribute to this fault code. The pressure-side fuel filter is located on the Integrated Fuel System Module (IFSM). The suction-side fuel filters and other OEM supplied components are OEM specific. The OEM is required to supply a suction-side filter with 25 to 150 micron filtration. The suction-side filter is typically frame-mounted near the IFSM. However, exact location is OEM dependent. Refer to the OEM for component location.

Shop Talk

Low fuel pressure during high engine speeds or motoring conditions indicates a fuel inlet restriction or a plugged pressure-side fuel filter. Items that can cause this fault code to activate are:

  • Plugged pressure or suction side fuel filter
  • Collapsed fuel inlet lines
  • Obstructed suction tube in fuel tank.

For engines with phase 4 or phase 5 software, in order to disable this fault code, the engine must be run above 1800 rpm under no load or a very light load for approximately 15 seconds.

If the engine speed is limited due to Maximum Engine Speed without vehicle speed sensor (VSS), one of the following methods can be used to clear this fault code:

  • Adjust the Maximum Engine Speed without VSS to a value above 1800 rpm and clear the fault code as stated above.
  • Start the Setup for Dynamometer Test in INSITE™ and clear the fault code as stated above.
  • Run the unit in first gear with no load at wide open throttle for 15 seconds. NOTE: This method will not work if load based speed control is set to values less than 1800 rpm. For engines with phase 6 or greater software, the fault code will go inactive after ten seconds of idling. Therefore, the fault can be inactive even though the problem has not been found and fixed. Due to this interaction with phase 6 or greater software, this fault code must be followed for an inactive fault code.
Refer to Troubleshooting Fault Code t05-2372

Last Modified: 01-Sep-2010


Exhaust Gas Pressure Sensor Circuit

FAULT CODE 2373

Exhaust Gas Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P95 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - shorted high. High signal voltage detected at exhaust gas pressure circuit. | Engine power derate.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the ECM to control emissions and EGR valve operation.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold between the number 1 and number 2 cylinders. Refer to Section E for a detailed component location view.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-2373

Last Modified: 01-Sep-2010


Exhaust Gas Pressure Sensor Circuit

FAULT CODE 2374

Exhaust Gas Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P95 SPN: 1029 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - shorted low. Low signal voltage detected at exhaust gas pressure circuit. | Engine power derate.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the ECM to control emissions and EGR valve operation.

Component Location

The exhaust gas pressure sensor is located above the front section of exhaust manifold and is plumbed into the exhaust manifold between the number 1 and number 2 cylinders. Refer to Section E for a detailed component location view.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness may cause multiple fault codes to be active. Before troubleshooting, check for multiple faults.

Possible causes for this fault code include:

  • Signal circuit open or shorted to ground, in the engine harness or sensor.
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-2374

Last Modified: 01-Sep-2010


Recirculated Exhaust Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Recirculated Exhaust Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | Recirculated Exhaust Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at EGR temperature circuit. | EGR valve will be closed.
EGR Temperature Sensor Circuit

Circuit Description

The EGR temperature sensor is used to measure the temperature of the exhaust gas that exits the EGR cooler. The ECM uses this temperature to control emissions levels of the engine

Component Location

The EGR temperature sensor is located on the front EGR connection tube between the EGR cooler and the EGR mixer. Refer to Section E.

Shop Talk

Beginning with engine serial number (ESN) 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness, Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

This fault code is set active if the sensor signal voltage is above the normal operating range for the sensor and the ECM has commanded the EGR valve open. This fault code will not be set active if the ECM has commanded the EGR valve closed. However, once the fault code is set, it will remain active independent of whether the EGR valve is open or closed.

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 2375, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, sensor, or ECM
  • Open signal circuit or shorted to a voltage source.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 256k to 423k
20 | 68 | 99k to 154k
40 | 104 | 42k to 63k
100 | 212 | 5.5k to 7.1k
140 | 284 | 1.9k to 2.3k
200 | 392 | 520 to 580
Refer to Troubleshooting Fault Code t05-2375

Last Modified: 01-Sep-2010


Recirculated Exhaust Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Recirculated Exhaust Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Recirculated Exhaust Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at EGR temperature circuit. | EGR valve will be closed.
EGR Temperature Sensor Circuit

Circuit Description

The EGR temperature sensor is used to measure the temperature of the exhaust gas that exits the EGR cooler. The ECM uses this temperature to control emissions levels of the engine

Component Location

The EGR temperature sensor is located on the front EGR connection tube between the EGR cooler and the EGR mixer. Refer to Section E for a detailed component location view.

Shop Talk

Beginning with ESN 14039654, the temperature sensor return circuit was separated from the pressure sensor return circuit. For ESNs prior to this and with engine wiring harness Part Number 3682854, refer to the Common Pressure/Temperature Sensor Return Circuit above. For this ESN and greater or for any other engine wiring harness part number, refer to the Separate Pressure/Temperature Sensor Return Circuit above.

This fault code is set active if the sensor signal voltage is below the normal operating range for the sensor and the ECM has commanded the EGR valve open. This fault code will not be set active if the ECM has commanded the EGR valve closed. However, once the fault code is set, it will remain active independent of whether the EGR valve is open or closed.

The EGR temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 2376, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness or ECM
  • Signal shorted to return or ground in the sensor.
Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 256k to 423k
20 | 68 | 99k to 154k
40 | 104 | 42k to 63k
100 | 212 | 5.5k to 7.1k
140 | 284 | 1.9k to 2.3k
200 | 392 | 520 to 580
Refer to Troubleshooting Fault Code t05-2376

Last Modified: 01-Sep-2010


Fan Control Circuit - Shorted High

FAULT CODE 2377

Fan Control Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Fan Control Circuit - shorted high. Open circuit or high voltage detected at the fan control circuit. | The fan may stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The electronic control module (ECM) provides a signal to the fan control solenoid to turn the engine fan on and off. There are two types of fans supported by this signal, variable speed, and ON/OFF. The INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by OEM. Certain OEM's may use a solenoid return that is wired to the ECM or may use a return that goes to engine block or chassis ground.

Component Location

The fan clutch solenoid location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the fan signal low, it expects the voltage level to be approximately 0 volts. If it detects a higher voltage, this fault is recorded. This usually indicates an open circuit or short circuit to a voltage source in the harness.

Once the fault code becomes active, the fan must be cycled to clear the code. This can be done by cycling the manual fan switch, if equipped, or by operating the engine and satisfying the fan engagement requirements.

If Fault Code 2377 is still active after completing the following troubleshooting steps, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Refer to Troubleshooting Fault Code t05-2377

Last Modified: 01-Sep-2010


Variable Geometry Turbocharger Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2384

Variable Geometry Turbocharger Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2384 PID: S027 SPN: 641 FMI: 4 LAMP: Amber SRT: | Variable geometry turbocharger actuator driver circuit - voltage below normal or shorted to low source. Low voltage detected at turbocharger control valve circuit. | Variable geometry turbocharger will go to the open position.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the control valve through the turbocharger control valve signal of the ECM engine harness.

Component Location

The Herion and Norgren air control valves are in different locations on the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

Turbocharger control valve command can be monitored with INSITE™ electronic service tool. This parameter represents the ECM command to the turbocharger control valve, which in turn controls the variable geometry actuator position.

Possible causes of this fault code include:

  • Signal short circuit to ground
  • Short circuit to ground in the turbocharger control valve.
Refer to Troubleshooting Fault Code t05-2384

Last Modified: 02-Sep-2010


Variable Geometry Turbocharger Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2385

Variable Geometry Turbocharger Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2385 PID: S027 SPN: 641 FMI: 3 LAMP: Amber SRT: | Variable geometry turbocharger actuator driver circuit - voltage above normal or shorted to high source. Open circuit or high voltage detected at turbocharger control valve circuit. | Variable geometry turbocharger may be in either the open or closed position.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the control valve through the turbocharger control valve signal of the ECM engine harness.

Component Location

The Herion and Norgren air control valves are in different locations on the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The turbocharger control valve command can be monitored with INSITE™ electronic service tool. This parameter represents the ECM command to the turbocharger control valve, which in turn controls the variable geometry actuator position.

Possible causes of this fault code include:

  • Open circuit in the engine harness or connectors
  • Open circuit in the turbocharger control valve
  • Signal circuit short to voltage source in the engine harness
  • Loose ground connection through the engine wiring harness to the engine block ground terminal. Engine test experience has proven that a loose nut on the engine block stud which results in a poor ground connection at the engine harness ring terminal will cause intermittent Fault Code 2385.
Refer to Troubleshooting Fault Code t05-2385

Last Modified: 02-Sep-2010


Fuel System Overfueling

FAULT CODE 2551

Fuel System Overfueling

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2551 PID: P129 SPN: 1349 FMI: 0/16 LAMP: Red SRT: | Rear Fueling Actuator Pressure High - Warning. Unexpected high fueling detected on the rear bank. | Engine will return to idle speed and possibly surge. The engine can be shutdown using the keyswitch.
Rear Fueling Actuator Circuit

Circuit Description

The electronic control module (ECM) supplies voltage to open the rear fueling actuator for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects the fuel into the cylinder for combustion.

Component Location

The rear fueling actuator is located on the fuel control housing. It is the first actuator from the rear of the engine. The fuel control housing is located on the intake side of the engine below the exhaust gas mixer. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The ECM estimates the amount of fuel injected into the front and rear banks of the engine by analyzing the acceleration of the crankshaft. This fault is set active when the estimate of fueling on the rear bank is higher than expected.

Refer to Troubleshooting Fault Code t05-2551

Last Modified: 02-Sep-2010


Fuel System Overfueling

FAULT CODE 2552

Fuel System Overfueling

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2552 PID: P157 SPN: 157 FMI: 0/16 LAMP: Red SRT: | Front Fueling Actuator Pressure High - Warning. Unexpected high fueling detected on the front bank. | Engine will return to idle speed and possibly surge. The engine can be shutdown using the keyswitch.
Front Fueling Actuator Circuit

Circuit Description

The electronic control module (ECM) supplies voltage to open the front fueling actuator for a short length of time. This allows a short pulse of fuel to flow to the injector. The injector then injects the fuel into the cylinder for combustion.

Component Location

The front fueling actuator is located on the fuel control housing. It is the first actuator from the front of the engine. The fuel control housing is located on the intake side of the engine below the exhaust gas mixer. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The ECM estimates the amount of fuel injected into the front and rear banks of the engine by analyzing the acceleration of the crankshaft. This fault is set active when the estimate of fueling on the front bank is higher than expected.

Refer to Troubleshooting Fault Code 2552.

Last Modified: 08-Sep-2010


Exhaust Gas Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P95 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect. An error in the exhaust gas pressure sensor signal was detected by the ECM. | Engine power derate. The ECM will estimate the exhaust gas pressure.
Exhaust Gas Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Circuit Description

The exhaust gas pressure sensor is used by the electronic control module (ECM) to monitor the engine exhaust gas pressure. This value is used by the ECM for engine emissions control.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold between the Number 1 and Number 2 cylinders. The exhaust gas pressure sensor is mounted to an exhaust gas pressure sensor adapter that is secured to the engine above the exhaust manifold. An exhaust gas pressure tube is mounted between the exhaust gas pressure sensor adapter and the exhaust manifold to separate the exhaust gas pressure sensor from the heat of the exhaust manifold. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

At key-on, before the engine starts, the sensor readings for barometric pressure, engine oil pressure, and intake manifold pressure are compared with exhaust gas pressure. This fault code occurs if the exhaust gas pressure sensor reading is different from any two of the other three. This check is only done once after the keyswitch is turned on and before the engine is started. The engine oil temperature must also be at least 7°C [45°F] for this check to run.

Shop exhaust fans can cause this fault code to come active. Turn exhaust fans off when troubleshooting this fault code.

In some cases, a plugged exhaust gas pressure sensor tube can also cause this fault code.

Refer to Troubleshooting Fault Code t05-2554

Last Modified: 02-Sep-2010


EGR Temperature - Data Valid But Above Normal Operating Range

FAULT CODE 2961

EGR Temperature - Data Valid But Above Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | EGR Temperature - data valid but above normal operating range least severe level. | Slight fueling derate to bring EGR temperature under the maximum limit.
EGR Temperature - Data Valid But Above Normal Operating Range

Circuit Description

The EGR temperature sensor measures the temperature of the exhaust gas exiting the EGR cooler. This temperature is monitored to protect the engine against the extremely high temperatures associated with EGR.

Component Location

The EGR temperature sensor is located in the EGR connection tube, downstream of the EGR differential pressure connection tube and below the integrated fuel system module (IFSM). Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

NOTE: This fault code may become active if the protective shipping sticker is not removed from the port located on the end opposite of the connector. When installing a new turbocharger control valve, make sure the adhesive cover is removed.

NOTE: Before performing the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, be sure the ECM Calibration Software Phase is updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault code include:

  • Fouled EGR cooler
  • Intake manifold, charge air cooler, or EGR leaks
  • Failed EGR differential pressure tubes
  • Failed EGR valve
  • Stuck open turbocharger control valve
  • EGR differential pressure sensor reading low
  • EGR valve position sensor reading low
  • High exhaust temperatures
  • Stuck closed variable geometry turbocharger.

NOTE: This fault code will not become active without a load in the shop. The engine must be loaded to trip this fault code and to determine if the failure has been found and fixed.

Refer to Troubleshooting Fault Code t05-2961

Last Modified: 02-Sep-2010


EGR Temperature - Data Valid But Above Normal Operating Range

FAULT CODE 2962

EGR Temperature - Data Valid But Above Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | EGR Temperature - Data Valid But Above Normal Operating Range. | Severe fueling derate to bring EGR temperature under the maximum limit.
EGR Temperature Sensor

Circuit Description

The EGR temperature sensor measures the temperature of the exhaust gas exiting the EGR cooler. This temperature is monitored to protect the engine against the extremely high temperatures associated with EGR.

Component Location

The EGR temperature sensor is located in the EGR connection tube, downstream of the EGR differential pressure connection tube and below the integrated fuel system module (IFSM). Refer to Procedure 100-002 in Section E.

Shop Talk

NOTE: This fault code may become active if the protective shipping sticker is not removed from the port located on the end opposite of the connector. When installing a new turbocharger control valve, make sure the adhesive cover is removed.

NOTE: Before performing INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, be sure the ECM Calibration Software Phase is updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault code include:

  • Fouled EGR cooler
  • Intake manifold, charge-air cooler, or EGR leaks
  • Damaged EGR differential pressure tubes
  • Damaged EGR valve
  • Stuck open turbocharger control valve
  • EGR differential pressure sensor reading low
  • EGR valve position sensor reading low
  • High exhaust temperatures
  • Stuck closed variable geometry turbocharger.

NOTE: This fault code will not become active without a load in the shop. The engine must be loaded to trip this fault code and to determine if the malfunction has been found and repaired.

Refer to Troubleshooting Fault Code t05-2962

Last Modified: 02-Sep-2010


Engine Coolant Temperature High - Warning

FAULT CODE 2963

Engine Coolant Temperature High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/16 LAMP: None SRT: | Engine Coolant Temperature High - Warning. Engine coolant temperature signal indicates engine coolant temperature above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature

Circuit Description

The engine coolant temperature sensor monitors coolant temperature and passes information to the electronic control module (ECM) through the engine harness. If the coolant temperature becomes too high, it will cause a derate condition.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine in the thermostat housing. Refer to Section E for a detailed component location view.

Shop Talk

The engine coolant temperature sensor measures the temperature of the engine coolant as it passes through the thermostat housing. This fault code is activated if the engine coolant temperature is above 107°C [225°F] for at least five seconds.

Possible causes of this fault code include:

  • Obstructed radiator
  • Plugged vent lines
  • Aerated coolant
  • Other cooling system failure.
Refer to Troubleshooting Fault Code t05-2963

Last Modified: 01-Sep-2010


Intake Manifold Air Temperature High - Warning

FAULT CODE 2964

Intake Manifold Air Temperature High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/16 LAMP: None SRT: | Intake Manifold Air Temperature High - Warning. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Intake Manifold Air Temperature

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold air temperature sensor is located in the air intake horn. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge air (fresh air compressed by the turbocharger, cooled by the charge air cooler, and mixed with EGR) as it passes through the intake manifold. This fault code is activated if the intake manifold air temperature is above 121°C [250° F] for five seconds.

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate and go to 'Calibration Information'. If the Software Phase is earlier than shown below, calibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a calibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

Possible causes of this fault code include:

  • Plugged charge air cooler fins
  • Restricted airflow through the charge air cooler
  • Damaged EGR differential pressure sensor, or leaks in sensor tubes
  • Undersized charge air cooler
  • High turbocharger compressor outlet temperature
  • Fouled EGR cooler
  • Stuck EGR valve
  • Sensor malfunction.
Refer to Troubleshooting Fault Code t05-2964

Last Modified: 02-Sep-2010


Intake Manifold Pressure

FAULT CODE 2973

Intake Manifold Pressure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold Pressure - data incorrect. The ECM has detected an intake manifold pressure signal that is too high or low for current engine operating conditions. | Engine power derate.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the ECM through the engine harness. If the intake manifold pressure becomes too low or high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Refer to Section E for a detailed component location view.

Shop Talk

The intake manifold pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too high or low for the current engine operating conditions. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault are:

  • Failed intake manifold pressure sensor
  • Failed barometric pressure sensor
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Restriction in the charge air cooler
  • Failed turbocharger speed sensor.
Refer to Troubleshooting Fault Code t05-2973

Last Modified: 01-Sep-2010


EGR Valve Actuator Over Temperature (Calculated) - Data Above Normal Range

FAULT CODE 9121

EGR Valve Actuator Over Temperature (Calculated) - Data Above Normal Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 9121 PID: S146 SPN: 2791 FMI: 0/15 LAMP: None SRT: | EGR Valve Actuator Over Temperature (Calculated) - Data Above Normal Range - least severe level. | EGR valve will be closed.
INSITE™

Circuit Description

The electronic control module (ECM) controls the exhaust gas recirculation (EGR) valve, opening and closing it based on various engine operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor signal (+) and EGR valve motor signal (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor signal (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor signal (-) circuit.

Component Location

The EGR vale motor is located on the exhaust side of the engine and is attached to the EGR valve assembly, which is mounted to the exhaust manifold. Refer to Section E for a detailed component view.

Shop Talk

The ECM calculates the temperature of the EGR valve motor. If the ECM detects excessive temperatures for a calibrated period of time this fault is recorded and the valve is commanded closed. This action is for protection of the valve only; this fault code is not indicative of any component failure. Once the ECM detects normal EGR valve temperatures, the fault code will go inactive and the EGR valve operation will resume.

NOTE: During this event, there will be no noticeable symptoms. This troubleshooting tree should not be considered if there is a performance complaint.

A combination of frequent valve movement and elevated coolant temperatures can lead to this fault code.

Refer to Troubleshooting Fault Code t05-9121

Last Modified: 01-Sep-2010


Engine Coolant Level Sensor Circuit

FAULT CODE 195

Engine Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Level Sensor Circuit - Shorted High. High signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The engine coolant level sensor monitors the engine coolant level within the coolant system and passes information to the electronic control module (ECM) through the OEM harness.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Shop Talk

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-195-2wire

Last Modified: 01-Sep-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
ISX and ISM - Engine Coolant Level Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195-3wire

Last Modified: 01-Sep-2010


Engine Coolant Level Sensor Circuit

FAULT CODE 196

Engine Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Level Sensor Circuit - shorted low. Low signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The engine coolant level sensor monitors the engine coolant level within the coolant system and passes information to the electronic control module (ECM) through the OEM harness.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground or return in the harness, sensor or connectors.
Refer to Troubleshooting Fault Code t05-196-2wire

Last Modified: 01-Sep-2010


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
ISX and ISM - Coolant Level Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than 0.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor.
  • Signal circuit shorted to ground in the engine harness, connector, or sensor.
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196-3wire.

Last Modified: 14-Jan-2011


Engine Brake Solenoid Number 1 Signal Circuit

FAULT CODE 2366

Engine Brake Solenoid Number 1 Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2366 PID: S28 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Circuit Number 1 - shorted high. Open circuit or high voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinder number 1 can be on all the time, or can not be activated.
Engine Brake Solenoid Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinder number 1 by sending a signal on engine brake solenoid number 1 signal circuit. The ECM will only command the brakes ON under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.

Shop Talk

Possible causes of this fault include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Signal circuit shorted to voltage source in the engine harness
  • Incorrect ECM calibration code in the ECM
  • Failed ECM
  • Loose connection at the engine brake solenoid.
Refer to Troubleshooting Fault Code t05-2366v1

Last Modified: 01-Sep-2010


Engine Brake Solenoid Number 1 Signal Circuit

FAULT CODE 2366

Engine Brake Solenoid Number 1 Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2366 PID: S28 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Actuator Circuit Number 1 - shorted high. Open circuit or high voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinder number 1 can be on all the time, or can not be activated.
Engine Brake Solenoid Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinder number 1 by sending a signal on engine brake solenoid number 1 signal circuit. The ECM will only command the brakes ON under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.

Shop Talk

Possible causes of this fault include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Signal circuit shorted to voltage source in the engine harness
  • Incorrect ECM calibration code in the ECM
  • Damaged ECM
  • Loose connection at the engine brake solenoid.
Refer to Troubleshooting Fault Code t05-2366v2

Last Modified: 01-Sep-2010


Engine Brake Solenoid Number 2 Signal Circuit

FAULT CODE 2367

Engine Brake Solenoid Number 2 Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S28 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Solenoid Number 2 Signal Circuit. Open circuit or high voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders number 2 and 3 can be on all the time, or can not be activated.
Engine Brake Solenoid Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders 2 and 3 by sending a signal on engine brake solenoid Number 2 signal circuit. The ECM will only command the brakes on under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.

Shop Talk

Use INSITE™ electronic service tool to determine the ECM calibration software phase. Navigate to “Features and Parameters”, “System ID and Dataplate”, and go to “Calibration Information”.

Possible causes of this fault include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Damaged ECM
  • Loose connection at the engine brake solenoid.
Refer to Troubleshooting Fault Code t05-2367v1

Last Modified: 01-Sep-2010


Engine Brake Solenoid Number 2 Signal Circuit

FAULT CODE 2367

Engine Brake Solenoid Number 2 Signal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S28 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | Engine Brake Solenoid Number 2 Signal Circuit. Open circuit or high voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders number 2 and 3 can be on all the time, or can not be activated.
Engine Brake Solenoid Signal Circuit

Circuit Description

The electronic control module (ECM) controls the engine brakes on cylinders 2 and 3 by sending a signal on engine brake solenoid Number 2 signal circuit. The ECM will only command the brakes on under certain operating conditions.

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake connector is located on the intake side of the cylinder head above and forward of the air inlet horn.

Shop Talk

Use INSITE™ electronic service tool to determine the ECM calibration software phase. Navigate to “Features and Parameters”, “System ID and Dataplate”, and go to “Calibration Information”.

Possible causes of this fault include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Damaged ECM
  • Loose connection at the engine brake solenoid.
Refer to Troubleshooting Fault Code t05-2367v2

Last Modified: 01-Sep-2010


Accelerator Pedal Idle Validation Circuit

FAULT CODE 431 (ISS)

Accelerator Pedal Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal Idle Validation Circuit - data incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | No effect on performance.
Accelerator Pedal Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The switch return is a shared return with other OEM cab switches.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuit, a loose connection, uncalibrated accelerator pedal assembly, or miswired idle validation switch.
  • The integrated sensor switch (ISS) has a different internal resistance specification (125 ohms) than the nonintegrated sensor switch (NISS).
  • When installing a new accelerator pedal assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-431iss

Last Modified: 01-Aug-2013


Accelerator Pedal Idle Validation Circuit

FAULT CODE 431 (NISS)

Accelerator Pedal Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal Idle Validation Circuit - data incorrect. Voltage detected simultaneously on both idle validation and idle validation off-idle validation switches. | No effect on performance.
Accelerator Pedal Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The nonintegrated sensor switch (NISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuits, a loose connection, uncalibrated accelerator pedal assembly, or miswired idle validation switch.
  • The nonintegrated sensor switch has a different internal resistance specification (10 ohms) than the integrated sensor switch (ISS).
  • When installing a new accelerator pedal assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-431niss

Last Modified: 01-Sep-2010


Accelerator Pedal Idle Validation Circuit

FAULT CODE 431 (SSS)

Accelerator Pedal Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal Idle Validation Circuit - data incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | No effect on performance.
Accelerator Pedal Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The solid state sensor switch (SSS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuits, a loose connection, uncalibrated accelerator pedal assembly, or miswired idle validation switch.
  • Since the solid state sensor switch (SSS) uses an integrated circuit to output idle and off-idle SIGNALs, the internal resistance can not be checked with a multimeter as it is for the integrated sensor switch and nonintegrated sensor switch.
  • When installing a new accelerator pedal assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-431sss

Last Modified: 01-Sep-2010


Accelerator Pedal Idle Validation Circuit

FAULT CODE 551 (ISS)

Accelerator Pedal Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal Idle Validation Circuit - data incorrect. No voltage detected simultaneously on both idle validation and off-idle validation switches. | Engine will only idle.
Accelerator Pedal Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by a short circuit to ground in the harness, uncalibrated accelerator pedal assembly, or miswired idle validation switch.
  • When installing a new accelerator pedal assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-551iss

Last Modified: 01-Sep-2010


Accelerator Pedal Idle Validation Circuit

FAULT CODE 551 (NISS)

Accelerator Pedal Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal Idle Validation Circuit - data incorrect. No voltage detected simultaneously on both idle validation and off-idle validation switches. | Engine will only idle.
Accelerator Pedal Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The nonintegrated sensor switch (NISS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code is usually caused by a short circuit to ground in the harness, uncalibrated accelerator pedal assembly, or miswired idle validation switch.
  • When installing a new accelerator pedal assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-551niss

Last Modified: 01-Sep-2010


Accelerator Pedal Idle Validation Circuit

FAULT CODE 551

Accelerator Pedal Idle Validation Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal Idle Validation Circuit - data incorrect. No voltage detected simultaneously on both idle validation and off-idle validation switches. | Engine will only idle.
Accelerator Pedal Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The solid state sensor switch (SSS) is located on the accelerator pedal assembly.

Shop Talk

  • This fault code can be caused by a short circuit to ground in the harness, uncalibrated accelerator pedal assembly, or miswired idle validation switch.
  • When installing a new accelerator pedal assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-551sss

Last Modified: 01-Sep-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Electronic Control Module (ECM) Microprocessor

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM |
 | STEP 1A. Check the ECM | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111 | Less than 3 counts?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 111 inactive?
 | STEP 2B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components

Action

Check the ECM.

  • Turn keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Is Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Are there less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Repair complete

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 111 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 122 active?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 123 active and Fault Code 122 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM port.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 2 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 123 active?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Fault Code 122 active and Fault Code 123 inactive?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 122 active and Fault Code 123 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362.

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the sensor connector of the engine harness.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 122 active and Fault Code 123 inactive?
YES NO

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes .

Refer to the wiring diagram for connector pin identification.

Fault Code 122 active and Fault Code 123 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and intake manifold pressure SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes .

Refer to the wiring diagram for connector pin identification.

Fault Code 122 active and Fault Code 123 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 131 - Accelerator Pedal Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather-Pack test lead Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 387 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 387 active?
YES | NO
No Repair | No Repair

Fault Code 387

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 18.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position sensor +5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES NO

Replace the accelerator pedal position sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

Measure the resistance of the following pin between the OEM harness ECM connector and the OEM harness accelerator pedal position sensor connector:

  • Accelerator pedal position sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the OEM harness ECM connector:

  • Accelerator pedal position sensor +5 volt SUPPLY pin
  • Accelerator pedal position sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 131 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Dec-2016


FAULT CODE 132 - Accelerator Pedal Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 443 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 active?
YES | NO
No Repair | No Repair

Fault Code 443

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or Intermittent Fault Code. Refer to Procedure 019-362 Section 19.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position +5 volt SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the accelerator pedal position +5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 131 active and Fault Code 132 inactive?
YES NO

Replace the accelerator pedal position sensor.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Harness connector to connector continuity pin-to-pin continuity check:

Measure the resistance of the following pins between the OEM harness ECM connector and the OEM harness accelerator pedal position sensor connector:

  • Accelerator pedal position sensor +5 volt SUPPLY pin
  • Accelerator pedal position sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the OEM harness ECM connector:

  • Accelerator pedal position sensor +5 volt SUPPLY pin
  • Accelerator pedal position sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and ground:

  • Accelerator pedal position sensor +5 volt SUPPLY pin
  • Accelerator pedal position sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 019.

Go to 4A

Go to 4A

Guided Step 2 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 132 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack test lead, Part Number 3823996 - female Weather-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 133 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the remote accelerator pedal or lever position +5 volt SUPPLY pin to the remote accelerator pedal or lever position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES NO

Replace the remote accelerator pedal or lever position sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell brokenWire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Harness connector to connector continuity pin-to-pin continuity check:

Measure the resistance of the following pin between the OEM harness ECM connector and the OEM harness remote accelerator pedal or lever position sensor connector:

  • Remote accelerator pedal or lever position sensor RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever from the OEM harness.
  • Disconnect the digital vehicle speed sensor (if equipped).

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the OEM harness ECM connector:

  • Remote accelerator pedal or lever position sensor +5 volt SUPPLY pin
  • Remote accelerator pedal or lever position sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 133 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 134 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the remote accelerator pedal position +5 volt SUPPLY pin to the remote accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Rever to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the remote accelerator pedal position +5 volt SUPPLY pin and the remote accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 133 active and Fault Code 134 inactive?
YES NO

Replace the remote accelerator pedal or lever position sensor.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell brokenWire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

Measure the resistance of the following pins between the OEM harness ECM connector and the OEM harness remote accelerator pedal or lever position sensor connector:

  • Remote accelerator pedal position sensor +5 volt SUPPLY pin
  • Remote accelerator pedal or lever position sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Disconnect the digital vehicle speed sensor (if equipped).

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the OEM harness ECM connector:

  • Remote accelerator pedal position sensor SUPPLY pin
  • Remote accelerator pedal or lever position sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and ground:

  • Remote accelerator pedal position sensor +5 volt SUPPLY pin
  • Remote accelerator pedal or lever position sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedufre for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 134 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 135 - Engine Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 135 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Engine oil pressure sensor signal voltage is less than or equal to 0.5 volts?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Engine oil pressure sensor signal voltage is less than or equal to 0.5 volts?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 135 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 Section 19.

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the Data Monitor/Logger in INSITE™ electronic service tool to monitor the engine oil pressure sensor signal voltage.

Engine oil pressure sensor signal voltage is less than or equal to 0.5 volts?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the engine oil pressure +5 volt SUPPLY pin to the engine oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the engine oil pressure +5 volt SUPPLY pin to the engine oil pressure RETURN pin at the ECM port.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the Data Monitor/Logger in INSITE™ electronic service tool to monitor the engine oil pressure sensor signal voltage.

Engine oil pressure sensor signal voltage is less than or equal to 0.5 volts?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Jul-2012


FAULT CODE 141 - Engine Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 141 active?
STEP 2. | Check the engine oil pressure sensor and circuit. |
 | STEP 2A. Inspect the engine oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Engine oil pressure sensor signal voltage is 4.5-VDC or greater?
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Engine oil pressure sensor signal voltage is 4.5-VDC or greater?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Engine oil pressure sensor signal voltage is 4.5-VDC or greater?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil pressure sensor and circuit.

Guided Step 2A - Inspect the engine oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine oil pressure +5 volt SUPPLY pin to the engine oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine oil pressure SIGNAL pin and the engine oil pressure +5 volt SUPPLY pin at the sensor connector of the engine harness.
  • Check for the appropriate ECM response after 30 seconds.
  • Use the Data Monitor/Logger in INSITE™ electronic service tool to monitor the engine oil pressure sensor signal voltage.

Refer to the wiring diagram for connector pin identification.

Engine oil pressure sensor signal voltage is 4.5-VDC or greater?
YES NO

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine oil pressure +5 volt SUPPLY pin and the engine oil pressure SIGNAL pin at the ECM port.
  • Check for the appropriate ECM response after 30 seconds.
  • Use the Data Monitor/Logger in INSITE™electronic service tool to monitor the engine oil pressure sensor signal voltage.

Refer to the wiring diagram for connector pin identification.

Engine oil pressure sensor signal voltage is 4.5-VDC or greater?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine oil pressure +5 volt SUPPLY pin and engine oil pressure SIGNAL pin at the ECM port.
  • Check for the appropriate ECM response after 30 seconds.
  • Use the Data Monitor/Logger in INSITE™electronic service tool to monitor the engine oil pressure sensor signal voltage.

Refer to the wiring diagram for connector pin identifications.

Engine oil pressure sensor signal voltage is 4.5-VDC or greater?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 143 - Engine Oil Pressure Low - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ to read the fault codes.

Active or inactive counts of Fault Code 143?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS..

Repair complete

Last Modified: 20-Feb-2012


FAULT CODE 145 - Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging the pin and harness, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164269 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor signal pin and engine coolant temperature sensor return pin at the engine coolant temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement technique. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor.

Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor return pin and the engine harness engine coolant temperature sensor connector return pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor signal pin and the engine harness engine coolant temperature sensor connector signal pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor signal pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2012


FAULT CODE 145 - Coolant Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging the pin and harness, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A defective sensor has been detected.

Replace the engine coolant temperature sensor.

Refer to Procedure 019-019 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check fore the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor signal pin in the engine harness engine ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor signal pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a pin-to-ground short.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes .

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 151 - Engine Coolant Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 151. | Active or inactive counts of Fault Code 151?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 151.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 151?
YES | NO
No Repair | No Repair

Refer to the Engine Coolant Temperature Above Normal - Gradual Overheat or Sudden Overheat symptom tree in Section TS.

Repair complete

Last Modified: 13-Feb-2012


FAULT CODE 153 - Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack test lead, Part Number 3164266 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 600 ohms to 36k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the intake manifold air temperature sensor.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

600 ohms to 36k ohms?
YES NO
No Repair

Replace the intake manifold air temperature sensor.

Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode will be detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 154 - Intake Manifold Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Is Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Is Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged wire or engine harness insulation
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A defective sensor has been detected.

Replace the intake manifold air temperature sensor.

Refer to Procedure 019-059 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged wire or engine harness insulation
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short in the engine harness.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Is Fault Code 154 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Is Fault Code 154 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 155 - Intake Manifold Air Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for other fault codes. | Active counts or high inactive counts of Fault Code 245, 2346, 2347, 2348, 2349, 2351, 2352, 2353, 2355, 2357, 2377, 2961, or 2962?
STEP 2. | Check the charge air cooler for external restriction. |
 | STEP 2A. Inspect the charge air cooler for plugged or bent fins. | Charge air cooler has plugged or bent fins?
 | STEP 2B. Check the charge air cooler for internal restriction. | Charge air cooler plugged?
 | STEP 2C. Check for properly sized charge air cooler. | Correct charge air cooler?
STEP 3. | Check the EGR differential pressure tubes. |
 | STEP 3A. Check the EGR differential pressure tubes for cracks, restrictions, or leaks. | Are cracks, restrictions, or leaks present?
STEP 4. | Check the EGR cooler. |
 | STEP 4A. Check the EGR cooler for fouling. | Is the EGR Cooler Efficiency parameter greater than 50 percent after 4 minutes?
 | STEP 4B. Pressure test the EGR Cooler. | Does the EGR Cooler pass the pressure test?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 155 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for other fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active counts or high inactive counts of Fault Code 245, 2346, 2347, 2348, 2349, 2351, 2352, 2353, 2355, 2357, 2377, 2961, or 2962?

YES | NO
No Repair | No Repair

Refer to Fault Code 245, 2346, 2347, 2348, 2349, 2351, 2352, 2353, 2355, 2357, 2377, 2961, or 2962 troubleshooting tree

Go to 2A

Guided Step 2 - Check the charge air cooler for external restriction.

Guided Step 2A - Inspect the charge air cooler for plugged or bent fins.

Conditions

  • Inspect the charge air cooler in chassis.

Action

Inspect the charge air cooler for plugged or bent fins.

Charge air cooler has plugged or bent fins?
YES NO

Clean or repair the charge air cooler.

Replace if necessary.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the charge air cooler for internal restriction.

Action

Inspect the charge air cooler for internal restriction.

Refer to Procedure 010-027 in Section 10.

Is charge air cooler plugged?
YES NO

Clean or replace the charge air cooler.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for properly sized charge air cooler.

Action

Check the charge air cooler.

Refer to the OEM specifications for proper sized charge air cooler.

Correct charge air cooler?
YES NO
No Repair

Replace the charge air cooler with the correct size unit.

Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the EGR differential pressure tubes and adapter.

Guided Step 3A - Check the EGR differential pressure tubes and adapter for cracks, restrictions, or leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure tubes and adapter for cracks, restrictions, or leaks.

  • Soot streaks can indicate the line is loose or cracked.

Are cracks, restrictions, or leaks present?
YES NO

Clean, tighten, or replace the EGR differential pressure tubes.

Clean or replace the EGR differential pressure sensor adapter.

Refer to Procedure 011-026 in Section 11. Refer to Procedure 011-028 in Section 11.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the EGR cooler.

Guided Step 4A - Check the EGR cooler for fouling.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Coolant temperature above 79°C [175°F].
  • Turn manual fan switch OFF.
  • Turn manual air conditioning switch OFF.

Action

If the effectiveness of the cooler is degraded, the cooler will not effectively cool the exhaust gas and will cause the EGR temperature and intake manifold air temperature to rise.

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Start the engine and set the PTO speed to 1300 rpm.
  • Perform the EGR Valve Test in INSITE™ electronic service tool and command the EGR valve 100 percent open.
  • Start the INSITE™ electronic servicet tool monitor screen and monitor EGR Cooler Efficiency.
  • Run the engine at this condition for 4 minutes.
  • After 4 minutes, record the value of EGR Cooler Efficiency.

Is the EGR Cooler Efficiency parameter greater than 50 percent after 4 minutes?
YES NO

Repair or replace the intake manifold air temperature sensor.

Refer to Procedure 019-059 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Pressure test the EGR Cooler.

Action

Remove and pressure test the EGR Cooler.

Refer to Procedure 011-019 in Section 11.

Does the EGR Cooler pass the pressure test?
YES NO

Determine the cause of the fouled cooler. Refer to the Smoke, Black - Excessive symptom in the TT Tree.

Replace the EGR Cooler.

Refer to Procedure 011-019 in Section 11.

Refer to Smoke, Black - Excessive symptom in the TT tree.

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 155 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2012


FAULT CODE 187 - Sensor Supply Voltage Number 2 Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor Number 2 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 187 active?
 | STEP 2C. Inspect the intake manifold pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the EGR valve position sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the EGR differential pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. Inspect the rail fuel pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
 | STEP 2G. Inspect the exhaust gas pressure sensor and circuit connected to the sensor Number 2 supply and return. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the sensors and circuits connected to the sensor Number 2 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the intake manifold pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the EGR valve position sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the EGR valve position sensor.

Refer to Procedure 019-372 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the EGR differential pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Inspect the rail fuel pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 is active?
YES NO
No Repair

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 in Section 19.

Go to 2G

Go to 4A

Guided Step 2G - Inspect the exhaust gas pressure sensor and circuit connected to the sensor Number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 2G-1

Guided Step 2G-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 is active?
YES NO
No Repair

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-204 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 195 - Engine Coolant Level Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code | Fault Code 195 active?
STEP 2. | Check the OEM harness |
 | STEP 2A. Inspect the ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM harness | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the OEM harness | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM power harness | Greater than 100k ohms?
STEP 3. | Check the engine coolant level sensor and circuit |
 | STEP 3A. Inspect the engine coolant level sensor and connector pins | Dirty or damaged pins?
 | STEP 3B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM harness

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

  • Measure the resistance of the engine coolant level SIGNAL wire between the OEM harness ECM connector and the OEM harness engine coolant level sensor connector.
  • Measure the resistance of the engine coolant level RETURN wire between the OEM harness ECM connector and the OEM harness engine coolant level sensor connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM.

Action

Short circuit on two connectors - pin-to-pin check:

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and the ECM battery SUPPLY (+) pins of the OEM power harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine coolant level sensor and circuit

Guided Step 3A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Connect the OEM power harness to the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine coolant level SIGNAL pin at the sensor connector of the OEM harness and engine block ground.

  • Check for the appropriate ECM response after 1 minute.
  • Read the fault codes, use INSITE™ electronic service tool.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Fault Code 196 active and Fault Code 195 inactive?
YES NO

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return the appropriate fault code troubleshooting steps.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 195 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the wiring diagram or circuit diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be checked again from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2012


FAULT CODE 196 - Engine Coolant Level Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP . Check for an active fault code | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
STEP 3. | Check the OEM Harness |
 | STEP 3A. Inspect the ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground in the OEM harness | Greater than 100k ohms?
 | STEP 3D. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault code | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the engine coolant level sensor and circuit

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES NO

Replace the engine coolant level sensor.

  • Refer to Procedure 019-017 in Sectiion 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Short circuit on one connector pin-to-ground check:

  • Measure the resistance and check for a short circuit between the engine coolant level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19. .

Greater than 100k ohms?
YES NO
No Repair

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Return the appropriate fault code troubleshooting steps.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active faul codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-May-2012


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive for Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or Wiring Diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be checked again from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 17-Feb-2012


FAULT CODE 197 - Engine Coolant Level Low - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for Fault Code 197 | Active or inactive counts of Fault Code 197?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES | NO
No Repair | No Repair

Refer to Coolant Loss symptom troubleshooting tree in Section TS.

Repair complete

Last Modified: 14-Feb-2012


FAULT CODE 212 - Oil Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3164269 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180k ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Codes 212 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged wire or engine harness insulation
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180k ohms to 160k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor.

Refer to Procedure 019-067 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged wire or engine harness insulation
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine oil temperature sensor SIGNAL pin and engine oil temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 212 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 213 - Oil Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged wire or engine harness insulation
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A defective sensor has been detected.

Replace the engine oil temperature sensor.

Refer to Procedure 019-067 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged wire or engine harness insulation
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the engine oil temperature sensor signal pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature sensor signal pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 214 - Engine Oil Temperature High - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Active or inactive counts of Fault Code 214?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ to read the fault codes.

Active or inactive counts of Fault Code 214?
YES | NO
No Repair | No Repair

Refer to the Lubricating Oil Temperature Above Specification symptom troubleshooting tree in the TS Section.

Repair complete

Last Modified: 14-Feb-2012


FAULT CODE 219 - Centinel™ Oil Tank Level Low - Warning

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for Fault Code 219 | Fault Code 219 inactive?
STEP 2. | Check the Centinel™ oil burn level switch |
 | STEP 2A. Inspect the Centinel™ oil burn level switch and OEM harness connector | Dirty or damaged pins?
 | STEP 2B. Check the Centinel™ oil burn level switch for an open. | Less than 100 ohms?
STEP 3. | Check the OEM harness |
 | STEP 3A. Inspect the OEM harness and ECM connector | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin to pin | More than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 219 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 219.

Conditions

  • Fill the makeup oil tank.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Using INSITE™ electronic service tool to read the fault codes.

Fault Code 219 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the Centinel™ oil burn level switch.

Guided Step 2A - Inspect the Centinel™ oil burn level switch and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the Centinel oil burn level switch.

Action

Inspect the Centinel™ oil burn level switch and the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the Centinel™ oil burn level switch for an open.

Conditions

  • Fill the makeup oil tank.
  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil burn level switch from the OEM harness.

Action

Check the Centinel™ oil burn level switch for an open.

  • Measure the resistance from the Centinel™ oil burn level switch SIGNAL pin to RETURN pin of the switch while the switch is covered with oil.

Refer to the wiring diagram for connector pin identification.

Use the following for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

Replace the Centinel™ oil burn level switch.

Refer to the Master Repair Manual, Centinel™, Bulletin 3666231, Section G.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness

Guided Step 3A - Inspect the OEM harness and ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

Loose connector

Corroded pins

Bent or broken pins

Pushed back or expanded pins

Moisture in or on the connector

Missing or damaged connector seals

Dirt or debris in or on the connector pins

Connector shell broken

Wire insulation damage

Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect Centinel™ oil burn level switch from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open in the Centinel™ oil burn level switch circuit.

  • Measure the resistance from the Centinel™ oil burn level switch SIGNAL pin of the OEM harness ECM connector to the Centinel™ oil burn level switch SIGNAL pin of the OEM harness switch connector.
  • Measure the resistance from the Centinel™ oil burn level switch RETURN pin of the OEM harness ECM connector to the Centinel™ oil burn level switch RETURN pin of the OEM harness switch connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the Centinel™ oil burn level switch.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Centinel™ oil burn level switch SIGNAL pin of the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components.
  • Start the engine and let it idle for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 219 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2012


FAULT CODE 221 - Barometric Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 221 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 222 active and Fault Code 221 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 221 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM port.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 222 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Fault Code 221 active and Fault Code 222 inactive?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 221 active and Fault Code 222 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the sensor connector of the engine harness.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 221 active and Fault Code 222 inactive?
YES NO

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 221 active and Fault Code 222 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and barometric pressure SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 221 active and Fault Code 222 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • UseINSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 223 - Centinel™ Oil Control Valve Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 223 active?
STEP 2. | Check the Centinel™ oil control valve and circuit. |
 | STEP 2A. Inspect the Centinel™ oil control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to ground short circuit in the Centinel™ oil control valve. | Greater than 100k ohms?
 | STEP 2C. Check for an internal short in the Centinel™ oil control valve. | Greater than 3 ohms?
 | STEP 2D. Check the Centinel™ oil control valve diagnostic supply voltage and supply line. | Greater than 5.0 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM Centinel™ oil control valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 223 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 223 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Centinel™ oil control valve and circuit.

Guided Step 2A - Inspect the Centinel™ oil control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Damaged locking tab connectors
  • Wire insulation damage
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin to ground short circuit in the Centinel™ oil control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following Centinel™ oil control valve connector pin and ground:

  • Centinel™ oil control valve SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the Centinel™ oil control valve.

Refer to Procedure 007-078 in Section 7.

Go to 2C

Go to 4A

Guided Step 2C - Check for an internal short in the Centinel™ oil control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil control valve from the OEM harness.

Action

Check for low internal resistance of the Centinel™ oil control valve.

  • Using a multimeter, measure the resistance between the SIGNAL and RETURN pin of the Centinel™ oil control valve connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3 ohms?
YES NO
No Repair

Replace the Centinel™ oil control valve.

Refer to Procedure 007-078 in Section 7.

Go to 2D

Go to 4A

Guided Step 2D - Check the Centinel™ oil control valve diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil control valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the Centinel™ oil control valve SIGNAL pin and the Centinel™ oil control valve RETURN pin at the engine harness connector.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Damaged locking tab connectors
  • Wire insulation damage
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM Centinel™ oil control valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage between the Centinel™ oil control valve SIGNAL pin of the ECM port to ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and ground:

  • Centinel™ oil control valve SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Short circuit on one connector pin-to-pin check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and all other pins in the engine harness ECM connector:

  • Centinel™ oil control valve SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 223 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 224 - Centinel™ Oil Control Valve Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 224 active?
STEP 2. | Check the Centinel™ oil control valve and circuit. |
 | STEP 2A. Inspect the Centinel™ oil control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the Centinel™ oil control valve. | Less than 100 ohms?
 | STEP 2C. Check the Centinel™ oil control valve diagnostic supply voltage, supply line and return circuit. | Greater than 5.0 VDC?
 | STEP 2D. Check for an open circuit in the Centinel™ oil control valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM Centinel™ oil control valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 224 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Centinel™ oil control valve and circuit.

Guided Step 2A - Inspect the Centinel™ oil control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the Centinel™ oil control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Actuator continuity - pin-to-pin continuity check:

  • Measure the resistance and check for an open circuit between the Centinel oil control valve SIGNAL pin and the Centinel™ oil control valve RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

Replace the Centinel™ oil control valve. Refer to Procedure 007-078 in Section 7.

Go to 2C

Go to 4A

Guided Step 2C - Check the Centinel™ oil control valve diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil control valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the Centinel™ oil control valve actuator SIGNAL pin and the Centinel oil control valve actuator RETURN pin at the engine harness actuator connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the Centinel™ oil control valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Harness connector to connector continuity - pin-to-ground continuity check:

  • Measure the resistance between the engine harness Centinel™ oil control valve RETURN pin and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

There is an open RETURN circuit between the Centinel™ oil control valve engine harness connector and engine block ground.

Clean and tighten the engine block ground connection if necessary.

Repair or replace the engine harness, connector, or pins if possible.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM Centinel™ oil control valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage between the Centinel™ oil control valve SIGNAL pin at the ECM port and ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

Measure the resistance of the following pin between the engine harness ECM connector and the engine harness Centinel™ oil control valve connector:

  • Centinel™ oil control valve SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the Centinel™ oil control valve from the engine harness.

Action

Short circuit on one connector pin-to-pin check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and all other pins in the engine harness ECM connector:

  • Centinel™ oil control valve SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 224 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummin®s Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 227 - Sensor Supply Voltage Number 2 Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Cection 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

There is a short circuit to a voltage source in the engine harness sensor supply Number 2 line.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 234 - Engine Overspeed

Associated Procedures

Cautions and Warnings

WARNING

To avoid personal injury and property damage, the engine must be shut off immediately if the engine speed stays above 2650 rpm.
CAUTION

To avoid damaging the new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed |
 | STEP 1A. Check for proper operating conditions | Engine motoring downhill?
 | STEP 1B. Check for an alternate fuel source | Alternate fuel source?
 | STEP 1C. Check the engine rpm using INSITE™ | Correct rpm reading?
 | STEP 1D. Check the injector overhead settings | Correct injector overhead settings?
 | STEP 1E. Check for an active fault at low engine rpm | Fault Code 234 inactive at low rpm?
 | STEP 1F. Test the vehicle | Fault Code 234 inactive?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Identify the reason for the overspeed

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Engine motoring downhill?
YES NO

Check the engine for damage due to overspeed condition.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 2650 rpm, followed by moderate deceleration to 2000 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, cracked cylinder head from the fuel passageways to the intake manifold, etc.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm using INSITE™ electronic service tool

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Use INSITE™ electronic service tool to check the engine speed with the data monitor/logger mode.

  • Verify engine rpm with a digital optical tachometer, Part Number 3377462.

Correct rpm reading?
YES NO
No Repair

Inspect the engine speed sensor and camshaft position sensor as outlined for Fault Codes 689 and 778.

Go to 1D

Refer to the troubleshooting trees for Fault Codes 689 and 778.

Guided Step 1D - Check the injector overhead settings.

Conditions

  • Turn keyswitch OFF.

Action

Check for correct injector overhead settings.

  • Refer to Procedure 003-004 in Section 3.

Correct injector overhead settings?
YES NO
No Repair

Reset the overhead. Refer to Procedure 003-004 in Section 3.

Go to 1E

Go to 2A

Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active Fault Code 234 when the engine is running below 2650 rpm.

Fault Code 234 inactive at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test.

  • Check if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and check again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Using INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 241 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle speed sensor setting in INSITE™ electronic service tool |
 | STEP 1A. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match | The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
STEP 2. | Check the OEM harness |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the ECM | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness | More than 100k ohms?
 | STEP 2E. Check for a pin to pin short circuit in the OEM harness | More than 100k ohms?
STEP 3. | Check for additional OEM devices |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft | Gear or tone wheel damaged or slips?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 241 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the vehicle speed sensor setting in INSITE™ electronic service tool.

Guided Step 1A - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to go to the Vehicle Speed Source feature under Adjustments, Features, and Parameters.

  • Verify that the vehicle speed sensor type parameter in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

Loose connector

Corroded pins

Bent or broken pins

Pushed back or expanded pins

Moisture in or on the connector

Missing or damaged connector seals

Dirt or debris in or on the connector pins

Connector shell broken

Wire insulation damage

Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Using a multimeter, check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

Extra devices?
YES NO

Remove the device or contact an OEM representative.

 No Repair

Go to 4A

Go to 4B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor remove.

Action

Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

Gear or tone wheel damaged or slips?
YES NO

Refer to the OEM troubleshooting and repair manual to repair or replace the gear or tone wheel.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 241 is inactive.

Fault Code 241 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location or OEM dealer if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 241 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are correct |
 | STEP 1A. Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled | Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
 | STEP 1B. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match | The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
 | STEP 1C. Verify that the Anti-Tampering Sensitivity Level is set correctly for the application | Sensitivity Level is set correctly?
STEP 2. | Look for signs or evidence of tampering |
 | STEP 2A. Inspect the vehicle speed sensor | Tampering, installed incorrectly or external device present?
 | STEP 2B. Check for open circuit in the OEM harness | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness | More than 100k ohms?
 | STEP 2D. Check for a pin to pin short circuit in the OEM harness | More than 100k ohms?
STEP 3. | Check the vehicle speed reporting |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal | INSITE™ electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed | Vehicle speed is accurate?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault codes | Fault Code 242 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Verify that the feature settings are correct

Guided Step 1A - Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled.

Action

Verify that the customer wants Vehicle Speed Sensor Anti-Tampering feature enabled.

Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Vehicle Speed Sensor Anti-Tampering feature.

Go to 1B

Go to 4A

Guided Step 1B - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool go to the Vehicle Speed Source feature under Adjustments, Features, and Parameters.

  • Verify that the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1C

Go to 4A

Guided Step 1C - Verify that the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool and go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level is set correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 2A

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering, installed incorrectly, or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the ECM connector to engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting

Guided Step 3A - Use INSITE™ to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is 0 when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Use INSITE™ electronic service tool to compare the vehicle speed read by to the speedometer on the dash.

Compare INSITE™ electronic service tool readout with the vehicle speedometer match?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correct in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Vehicle moving.

Action

Verify that the speed reported by INSITE™ electronic service tool is accurate or reasonable for the current gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data)

Vehicle speed is accurate?
YES NO
No Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correct in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 242 is inactive.

Fault Code 242 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location or OEM dealer if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-ground short circuit in the fan control solenoid. | Greater than 100k ohms?
 | STEP 2C. Check for an internal short in the fan control solenoid. | Within the OEM resistance specification?
 | STEP 2D. Check the fan control solenoid diagnostic supply voltage and supply line. | Greater than +5 VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit in the OEM harness ECM battery (-) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 245 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following fan control solenoid connector pin and ground:

  • Fan control SIGNAL connector pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control solenoid.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to the OEM service manual for resistance specifications.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Replace the fan control solenoid.

Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Check the fan control solenoid diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Refer to the wiring diagram for connector pin identification.

Greater than +5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Short circuit on one connector - pin-to-ground check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the OEM harness ECM battery (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM.

Action

Measure the resistance between the fan control SIGNAL pin in the OEM harness ECM connector and the ECM battery (-) pins in the ECM power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Repair Complete

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 245 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault code.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps

Last Modified: 14-May-2012


FAULT CODE 249 - Ambient Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823255 - female Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 249 active?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Less than 78k ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 249 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Using a multimeter measure the resistance between the ambient air temperature SIGNAL pin and ambient air temperature RETURN pin of the sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 78k ohms?
YES NO
No Repair

Replace the ambient air temperature sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Harness connector to connector continuity - pin to pin continuity check:

Measure the resistance of the following pins between the OEM harness ECM connector and the OEM harness ambient air temperature sensor connector:

  • Ambient air temperature RETURN pin
  • Ambient air temperature SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and all other pins in the OEM harness ECM connector:

  • Ambient air temperature SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 254 - Fuel Shutoff Valve Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 254 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for extra wires connected to the fuel shutoff valve | Extra wires connected to valve?
 | STEP 2C. Check for a pin to ground short circuit in the fuel shutoff valve. | Is resistance 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
 | STEP 2D. Check the fuel shutoff valve diagnostic supply voltage and supply line. | Greater than 5.0 VDC?
 | STEP 2E. Check the fuel shutoff valve solenoid resistance. | Is resistance 1 to 5 ohms for 6-VDC solenoids, 6 to 15 ohms for 12-VDC solenoids, 24 to 50 ohms for 24-VDC solenoids, 42 to 80 ohms for 32-VDC solenoids, 46 to 87 ohms for 36-VDC solenoids, 92 to 145 ohms for 48-VDC solenoids, 315 to 375 ohms for 74-VDC solenoids, 645 to 735 ohms for 115-VAC solenoids?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 254 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 active?
YES NO
No Repair

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Repair complete

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for extra wires connected to the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Extra wires connected to the fuel shutoff valve powering devices on the vehicle can cause this fault to be active.

  • Visually inspect the fuel shutoff valve terminal for extra wires.

Extra wires connected to valve?
YES NO

Remove extra wires.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for a pin to ground short circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Short circuit on one connector - pin-to-ground check.

  • Measure the resistance between the fuel shutoff valve terminal stud and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance:

  • 1 to 5 ohms for 6-VDC solenoids
  • 6 to 15 ohms for 12-VDC solenoids
  • 24 to 50 ohms for 24-VDC solenoids
  • 42 to 80 ohms for 32-VDC solenoids
  • 46 to 87 ohms for 36-VDC solenoids
  • 92 to 145 ohms for 48-VDC solenoids
  • 315 to 375 ohms for 74-VDC solenoids
  • 645 to 735 ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve.

Refer to Procedure 019-050 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fuel shutoff valve diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the fuel shutoff valve SIGNAL wire and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2E

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 2E - Check the fuel shutoff valve solenoid resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the fuel shutoff valve solenoid.

Action

Check the fuel shutoff valve solenoid resistance.

  • Measure the resistance from the fuel shutoff valve solenoid to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance:

  • 1 to 5 ohms for 6-VDC solenoids
  • 6 to 15 ohms for 12-VDC solenoids
  • 24 to 50 ohms for 24-VDC solenoids
  • 42 to 80 ohms for 32-VDC solenoids
  • 46 to 87 ohms for 36-VDC solenoids
  • 92 to 145 ohms for 48-VDC solenoids
  • 315 to 375 ohms for 74-VDC solenoids
  • 645 to 735 ohms for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve solenoid.

Refer to Procedure 019-050 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the diagnostic supply voltage.

  • Using a multimeter, measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Short circuit on one connector pin-to-ground check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and ground:

  • Fuel shutoff valve SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and all other pins in the engine harness ECM connector:

  • Fuel shutoff valve SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 254 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 255 - Engine Fuel Shutoff Valve Drive Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 255 active?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | Is resistance 1 to 5 Ω for 6-VDC solenoids, 6 to 15 Ω for 12-VDC solenoids, 24 to 50 Ω for 24-VDC solenoids, 42 to 80 Ω for 32-VDC solenoids, 46 to 87 Ω for 36-VDC solenoids, 92 to 145 Ω for 48-VDC solenoids, 315 to 375 Ω for 74-VDC solenoids, 645 to 735 Ω for 115-VAC solenoids?
 | STEP 2C. Check the fuel shutoff valve diagnostic supply voltage and signal circuit. | Greater than 5.0 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel shutoff valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 255 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES NO
No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and ring terminal connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Use a multimeter to measure the resistance between the fuel shutoff valve ring terminal stud and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Is the resistance:

  • 1 to 5 Ω for 6-VDC solenoids
  • 6 to 15 Ω for 12-VDC solenoids
  • 24 to 50 Ω for 24-VDC solenoids
  • 42 to 80 Ω for 32-VDC solenoids
  • 46 to 87 Ω for 36-VDC solenoids
  • 92 to 145 Ω for 48-VDC solenoids
  • 315 to 375 Ω for 74-VDC solenoids
  • 645 to 735 Ω for 115-VAC solenoids?
YES NO
No Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve diagnostic supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the fuel shutoff valve diagnostic supply voltage.

  • Measure the voltage from the actuator harness fuel shutoff valve SIGNAL ring terminal to engine block ground.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve supply voltage.

  • Measure the voltage from the fuel shutoff valve SIGNAL pin at the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the actuator harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for circuit continuity.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness fuel shutoff valve connector and the fuel shutoff valve SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure and a wiring diagram for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 255 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 256 - Ambient Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 256 active?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 170 ohms?
 | STEP 2C. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Using a multimeter, measure the resistance between the ambient air temperature SIGNAL pin and ambient air temperature RETURN pin of the ambient air temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 170 ohms?
YES NO
No Repair

Replace the ambient air temperature sensor.

Go to 2C

Go to 4A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and all other pins in the OEM harness ECM connector:

  • Ambient air temperature sensor SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Short circuit on one connector - pin to ground check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and ground:

  • Ambient air temperature sensor SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 256 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 259 - Fuel Shutoff Valve

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault status. |
 | STEP 1A. Check for active Fault Code 255 or high inactive counts. | Fault Code 255 not active.
STEP 2. | Check for extra wires. |
 | STEP 2A. Check for extra wires attached to the fuel shutoff valve solenoid. | No extra wires.
STEP 3. | Check the fuel pressure sensor accuracy. |
 | STEP 3A. Check the fuel pressure sensor accuracy with the keyswitch ON. | Fuel pressure greater than 69 kPa [10 psi].
 | STEP 3B. Check the fuel pressure sensor accuracy with at idle. | Fuel pressure difference not greater than 69 kPa [10 psi].
STEP 4. | Check for proper fuel shutoff valve circuit operation. |
 | STEP 4A. Check for proper fuel shutoff valve circuit operation. | Voltage available at the fuel shutoff valve is greater than 11-VDC with the keyswitch ON and less than 0.5-VDC with the keyswitch OFF.
STEP 5. | Check the fuel shutoff valve actuator disc. |
 | STEP 5A. Check the fuel shutoff valve actuator disc. | No debris or damage found on the valve disc, valve seat, or actuator disc.
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 259 inactive.
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault status.

Guided Step 1A - Check for active Fault Code 255 or high inactive counts.

Conditions

  • All the components connected.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 255 not active.

Fault Code 255 active.

Go to 2A

Reference Fault Code 255

Guided Step 2 - Check for extra wires.

Guided Step 2A - Check for extra wires attached to the fuel shutoff valve solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires.

  • Check for extra wires attached to the fuel shutoff valve solenoid.
OK NOT OK

No extra wires.

Remove extra wires attached to the fuel shutoff valve solenoid.

Go to 3A

Go to 6A

Guided Step 3 - Check the fuel pressure sensor accuracy.

Guided Step 3A - Check the fuel pressure sensor accuracy with the keyswitch ON.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pressure gauge on the Compuchek™ fitting on the IFSM.
  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check fuel pressure sensor accuracy with keyswitch ON.

  • Use INSITE™ electronic service tool to verify the fuel pressure on the gauge and both are less than 69 kPa [10 psi].
OK NOT OK

Fuel pressure less than 69 kPa [10 psi].

Fuel pressure greater than 69 kPa [10 psi].

Go to 4A

Go to 3B

Guided Step 3B - Check the fuel pressure sensor accuracy with at idle.

Conditions

  • Turn keyswitch ON.
  • Fuel pressure gauge connected on the Compuchek™ fitting on the IFSM.
  • All components connected.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel pressure sensor accuracy with the engine running.

  • Start the engine.
  • Allow the idle to stabilize.
  • Verify the fuel pump pressure meets specification.
  • Fuel pump pressure greater than 1448 kPa [210 psi] at idle.
  • Use INSITE™ electronic service tool to verify that the fuel pressure on the gauge are no greater than 69 kPa [10 psi] different.
OK NOT OK

Fuel pressure difference not greater than 69 kPa [10 psi].

Replace the fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the fuel shutoff valve circuit operation.

Guided Step 4A - Check the fuel shutoff valve circuit operation.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve circuit operation.

  • Verify the voltage available at the fuel shutoff valve is greater than 11-VDC.
  • Turn keyswitch OFF.
  • Verify the voltage available at the fuel shutoff valve is less than 0.5-VDC.
OK NOT OK

Voltage available at the fuel shutoff valve is greater than 11-VDC with the keyswitch ON and less than 0.5-VDC with the keyswitch OFF.

Troubleshoot the fuel shutoff valve electrical circuit.

Reference Step 3A in the Engine Performance Troubleshooting Tree (16-t02-1001a) in Section TT of the Signature™, ISX and QSX15 Service Manual, Bulletin 3666239 to diagnose the fuel shutoff valve circuit.

Go to 5A

Go to 6A

Guided Step 5 - Check the fuel shutoff valve actuator disc.

Guided Step 5A - Check the fuel shutoff valve actuator disc.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check the fuel shutoff valve actuator disc.

  • Check the housing, valve disc, valve seat, and actuator disc for dirt, debris, metal parts, bonding separation, corrosion, cracks, or wear.
OK NOT OK

No debris or damage found on the valve disc, valve seat, or actuator disc.

Assemble the fuel shutoff valve.

Replace the damaged fuel shutoff valve component. Refer to Procedure 019-050 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 259 is inactive.
OK NOT OK

Fault Code 259 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.
OK NOT OK

All fault codes cleared.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Feb-2012


FAULT CODE 263 - Engine Fuel Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch/™AMP™/Metri-Pack™ test lead, Part Number 3822917 - Deutsch/™AMP™/Metri-Pack™ test lead, Part Number 3164269 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 30k ohms to 3.8k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 263 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for inactive fault code. | Fault Code 263 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 263 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or Damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine fuel temperature sensor signal pin and engine fuel temperature sensor return pin at the engine fuel temperature sensor.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

30k ohms to 3.8k ohms?
YES NO
No Repair

  • Replace the engine fuel temperature sensor.
  • Refer to Procedure 019-119 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor to the engine harness.
  • Turn the keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine fuel temperature sensor SIGNAL pin and the engine fuel temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Fault Code 265 active and Fault Code 263 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Place a jumper wire between the engine fuel temperature sensor SIGNAL pin and the engine fuel temperature sensor RETURN pin at the ECM connector.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor return pin and the engine harness engine fuel temperature sensor connector return pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor signal pin and the engine harness engine fuel temperature sensor connector signal pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for pin-to-pin short.

  • Measure the resistance between the engine fuel temperature sensor signal pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 263 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 265 - Engine Fuel Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging pin and harness, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 265 inactive?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 265 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for inactive fault code. | Fault Code 265 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Use the following procedures for Inactive or intermittent Fault Code Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor to the engine harness.
  • Turn the keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

A defective sensor has been detected.

Replace the engine fuel temperature sensor.

Refer to Procedure 019-119 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for the appropriate ECM response after 30 seconds.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 265 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 284 - Engine Speed Sensor Supply Voltage Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 284 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine speed sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 284 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 284 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 284 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 284 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine speed sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 284 active?
YES NO
No Repair

Replace the engine speed sensor.

Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 284 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 284 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to cler the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 285 - SAE J1939 Data Link Multiplexing

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for proper multiplexing configuration |
 | STEP 1A. Determine which vehicle inputs (accelerator, switches, lamps, sensors) are multiplexed over the SAE J1939 data link | Do devices in Step 1A match devices in Step 1B?
 | STEP 1B. Use INSITE™ electronic service tool to verify that the proper devices are set to be multiplexed in the ECM. | INSITE™ electronic service tool readout matches ECM settings for devices (devices in Step 1B must match devices in Step 1A).
STEP 2. | Inspect the SAE J1939 connectors on the backbone harness and OEM harness connectors |
 | STEP 2A. Inspect the ECM, OEM harness, and 3-pin connectors | Dirty or damaged pins?
 | STEP 2B. Inspect the vehicle electronic control unit 3-pin and associated connectors | Dirty or damaged pins?
STEP 3. | Inspect the OEM harness |
 | STEP 3A. Check for an open circuit in the OEM harness | Less than 10 ohms?
 | STEP 3B. Check the resistance value in the SAE J1939 harness | 55 to 65 ohms?
 | STEP 3C. Check for a pin short circuit to power in the OEM harness | Less than +1.5-VDC?
 | STEP 3D. Check for a pin short circuit to ground in the OEM harness | More than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness | More than 100k ohms?
STEP 4. | Inspect the SAE J1939 backbone harness |
 | STEP 4A. Check for an open circuit in the SAE J1939 backbone | Less than 10 ohms?
 | STEP 4B. Check for a pin short circuit to power in the SAE J1939 backbone | Less than +1.5-VDC?
 | STEP 4C. Check for a pin short circuit to ground in the SAE J1939 backbone | More than 100k ohms?
STEP 5. | Inspect the OEM wiring. |
 | STEP 5A. Check for an open circuit | Less than 10 ohms?
 | STEP 5B. Check for a pin short circuit to power | Less than +1.5-VDC?
 | STEP 5C. Check for pin short circuit to ground | More than 100k ohms?
STEP 6. | Check for proper communication with the SAE J1939 devices |
 | STEP 6A. Check communication with the vehicle electronic control unit(s) | Proper communication between multiplexing devices and vehicle electronic control unit(s)?
STEP 7. | Clear the fault codes |
 | STEP 7A. Disable the fault code | Fault Code 285 inactive?
 | STEP 7B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the ECM for proper mulitplexing configuration

Guided Step 1A - Determine which vehicle inputs (accelerator, switches, lamps, sensors) are multiplexed overthe SAE J1939 data link.

Conditions

  • Connect the OEM service tool to the vehicle electronic control unit.
  • Turn keyswitch ON.

Action

Check which vehicle inputs are multiplexed over the SAE J1939 data link in the VECU.

  • Read the devices that are sending input information with the OEM service tool

Do devices in Step 1A match devices in Step 1B?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Use INSITE™ electronic service tool to verify that the proper devices are set to be multiplexed in the ECM.

Conditions

  • Connect the INLINE 2™ electronic service tool data link adapter.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check if ECM settings match devices installed on vehicle.

  • Use INSITE™ electronic service tool to read the ECM settings for devices.

Does INSITE™ electronic service tool readout match ECM settings for devices?

Devices in Step 1B must match devices in Step 1A.

YES | NO
No Repair | No Repair

Go to 2A

Go to 7A

Guided Step 2 - Inspect the SAE J1939 connectors on the backbone and OEM harness connectors

Guided Step 2A - Inspect the ECM, OEM harness, and 3-pin connectors.

Conditions

  • Disconnect the OEM harness from the ECM.
  • Disconnect the multiplexed devices.

Action

Inspect the ECM, OEM harness, SAE J1939 connectors, and multiplexed devices for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the ECM, OEM harness, SAE J1939 3-pin connector, or multiplexed devices, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the 3-pin connectors.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Inspect the vehicle electronic control unit 3-pin and associated connectors.

Conditions

  • Disconnect the vehicle electronic control unit(s) from the SAE J1939 backbone harness.
  • Disconnect the multiplexed devices from the vehicle electronic control unit(s).

Action

Inspect the vehicle electronic control unit(s), 3-pin, and multiplexed devices connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the vehicle electronic control unit(s), 3-pin connector, or multiplexed devices, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the vehicle electronic control units(s). Refer to the OEM service manual.
  • Repair the 3-pin connector.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Inspect the OEM harness

Guided Step 3A - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the SAE J1939 backbone connector from the OEM harness.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

Measure the resistance of the following pins between the OEM harness ECM connector, and the SAE J1939 data link connector:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin
  • SAE J1939 data link SHIELD pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 7A

Guided Step 3B - Check the resistance value in the SAE J1939 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SAE J1939 harness connector form the vehicle electronic control unit(s).
  • Disconnect the SAE J1939 harness connector from the OEM harness.

Action

Check the SAE J1939 harness resistance.

  • Use a multimeter to measure the resistance between the SAE® J1939 data link (+) connector pin and SAE J1939 data link (-) connector pin, OEM side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

55 to 65 ohms?
YES NO
No Repair

The SAE J1939 backbone termination resistors are missing or damaged.

Replace the termination resistors.

Go to 3C

Go to 7A

Guided Step 3C - Check for a pin short circuit to power in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SAE J1939 backbone harness from the OEM harness.
  • Turn keyswitch ON.

Action

Short circuit on one connector - pin-to-power check:

Measure the voltage and check for a short circuit between the following OEM harness ECM connector pins and ground:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin

Less than +1.5-VDC?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SAE J1939 backbone harness from the OEM harness.

Action

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and ground:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin
  • SAE J1939 data link SHIELD pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 7A

Guided Step 3E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SAE J1939 backbone harness from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the OEM harness ECM connector:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin
  • SAE J1939 data link SHIELD pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Inspect the SAE J1939 backbone harness

Guided Step 4A - Check for an open circuit in the SAE® J1939 backbone.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the SAE J1939 backbone.
  • Disconnect the vehicle electronic control unit(s) connector from the SAE J1939 backbone.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

Measure the resistance of the following pins between the OEM harness connector and the vehicle electronic control unit(s) connector:

  • SAE® J1939 data link (+) pin
  • SAE® J1939 data link (-) pin
  • SAE® J1939 data link SHIELD pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following prcedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the SAE J1939 backbone.

Refer to the OEM troubleshooting and repair manual.

Go to 4B

Go to 7A

Guided Step 4B - Check for a pin short circuit to power in the SAE J1939 backbone.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the SAE J1939 backbone.
  • Disconnect the vehicle electronic control unit(s) connector from the SAE J1939 backbone.
  • Turn keyswitch ON.

Action

Short circuit on one connector - pin-to-power check:

Measure the voltage and check for a short circuit between the following SAE J1939 backbone connector pins, OEM harness side, and ground:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than +1.5-VDC?
YES NO
No Repair

Repair or replace the SAE J1939 backbone.

Refer to the OEM troubleshooting and repair manual.

Go to 4C

Go to 7A

Guided Step 4C - Check for a pin short circuit to ground in the SAE J1939 backbone.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the SAE J1939 backbone.
  • Disconnect the vehicle electronic control unit(s) connector from the SAE J1939 backbone.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following SAE J1939 backbone connector pins and ground:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin
  • SAE J1939 data link SHIELD pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the SAE J1939 backbone.

Refer to the OEM service manual.

Go to 5A

Go to 7A

Guided Step 5 - Inspect the OEM wiring

Guided Step 5A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle electronic control unit(s) connector from the SAE J1939 backbone.
  • Disconnect the vehicle electronic control unit(s) connector from the vehicle electronic control unit(s).

Action

Harness connector to connector continuity - pin-to-pin continuity check:

Measure the resistance of the following pins between the SAE J1939 backbone connector and the vehicle electronic control unit(s) connector:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin
  • SAE J1939 data link SHIELD pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM wiring.

Refer to the OEM troubleshooting and repair manual.

Go to 5B

Go to 7A

Guided Step 5B - Check for a pin short circuit to power.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle electronic control unit(s) connector from the SAE J1939 backbone.
  • Disconnect the vehicle electronic control unit(s) connector from the vehicle electronic control unit(s).
  • Turn keyswitch ON.

Action

Short circuit on one connector - pin-to-power check:

Measure the voltage and check for a short circuit between the following SAE J1939 backbone connector pins, OEM side, and engine block ground:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than +1.5-VDC?
YES NO
No Repair

Repair or replace the OEM wiring.

Refer to the OEM service manual.

Go to 5C

Go to 7A

Guided Step 5C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle electronic control unit(s) connector from the SAE J1939 backbone.
  • Disconnect the vehicle electronic control unit(s) connector from the vehicle electronic control unit(s).

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following SAE J1939 backbone connector pins, OEM side, and engine block ground:

  • SAE J1939 data link (+) pin
  • SAE J1939 data link (-) pin
  • SAE J1939 data link SHIELD pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM wiring.

Refer to the OEM service manual.

Go to 6A

Go to 7A

Guided Step 6 - Check for proper communication with the SAE J1939 devices

Guided Step 6A - Check communication with the vehicle electronic control unit(s).

Conditions

  • Install the OEM service tool software.
  • Turn keyswitch ON.

Action

Check communication with the vehicle electronic control unit(s).

  • Use the OEM service tool software and/or INSITE™ electronic service tool to confirm communication between vehicle electronic control unit(s) and multiplexing devices.

Proper communication between multiplexing devices and vehicle electronic control unit(s)?
YES NO
No Repair

Refer to the OEM service manual for additional repair procedures.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 285 is inactive.

Fault Code 285 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 286 - SAE J1939 Data Link Multiplexing

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the vehicle electronic control unit(s) and ECM have matching settings. |
 | STEP 1A. Consult OEM information and/or use OEM service tool to verify which input parameters are wired to vehicle electronic control unit(s). | Physical input devices to vehicle electronic control unit match vehicle electronic control unit configuration?
 | STEP 1B. Determine which parameters are set to be received over the SAE J1939 data link. Check settings in Adjustments - Features and Parameters - SAE J1939 Multiplexing. | INSITE™ readout matches ECM settings for devices (devices in Step 1B match Step 1A)?
STEP 2. | Change the settings. |
 | STEP 2A. ECM is set up to receive parameters that the vehicle electronic control unit(s) is not transmitting. | ECM setting now matches vehicle electronic control unit configuration?
 | STEP 2B. The vehicle electronic control unit(s) is not set up to transmit all of the information from all of the multiplex devices. | Vehicle electronic control unit(s) parameters match all input devices that are wired to vehicle electronic control unit(s)?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify that the vehicle electronic control unit(s) and ECM have matching settings

Guided Step 1A - Consult OEM information and/or use OEM service tool to verify which input parameters are wired to vehicle electronic control unit(s)

Conditions

  • Turn keyswitch ON.
  • Connect to the vehicle electronic control unit with the OEM service tool.

Action

Check that the vehicle inputs are multiplexed.

  • Determine which input devices (throttle, cruise switches, clutch switch, and so forth) are wired to the vehicle's vehicle electronic control unit(s).
  • Use OEM service tool to verify the vehicle electronic control unit is configured properly.

Physical input devices to vehicle electronic control unit match vehicle electronic control unit configuration?
YES NO
No Repair

Change multiplex settings.

Go to 1B

Go to 2B

Guided Step 1B - Determine which parameters are set to be received over the SAE J1939 data link. Check settings in Adjustments — Features and Parameters — SAE J1939 Multiplexing.

Conditions

  • Connect the INLINE™ II data link adapter to the engine and PC.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start INSITE™ electronic service tool job.

Action

Check that ECM settings match devices installed on vehicle.

  • Use INSITE™ electronic service tool to read the ECM setting for devices.
  • Information for setting in menu: Adjustments - Features and Parameters — SAE J1939 Multiplexing.

INSITE™ electronic service tool readout matches ECM settings for devices (devices in Step 1B match Step 1A)?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Change the settings.

Guided Step 2A - ECM is set up to receive parameters that the vehicle electronic control unit(s) is not transmitting.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Chenage ECM setting to match vehicle electronic control unit configuration.

  • If the ECM is set up to receive any of the parameters the vehicle electronic control unit(s) is not transmitting over the data link, turn off multiplexing for those parameters in the ECM, use INSITE™ electronic service tool.

ECM setting now matches vehicle electronic control unit configuration?
YES NO
No Repair

Check the OEM multiplex settings.

Go to 3A

Go to 1A

Guided Step 2B - The vehicle electronic control unit(s) is not set up to transmit all of the information from all of the multiplex devices.

Conditions

  • Install OEM service tool.
  • Turn keyswitch ON.

Action

Change the setting of the vehicle electronic control unit(s) to transmit all information.

  • Vehicle electronic control unit(s) is not set up to transmit information from all of the devices connected to it. Change the setting in the vehicle electronic control unit(s). Refer to the OEM service manual for instruction.

Vehicle electronic control unit(s) parameters match all input devices that are wired to vehicle electronic control unit(s)?
YES NO
No Repair

Check OEM multiplex settings.

Go to 3A

Go to 1A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ to verify Fault Code 286 is inactive.

Fault Code 286 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 287 - SAE J1939 Data Link Multiplexing Accelerator Pedal Sensor

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for Fault Code 287 | Active or inactive counts of Fault Code 287?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 287.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Active or inactive counts of Fault Code 287?
YES | NO
No Repair | No Repair

Refer to the OEM Service Manual. Troubleshoot the accelerator pedal circuit connected to the OEM vehicle control unit.

Repair complete

Last Modified: 23-Feb-2012


FAULT CODE 288 - SAE J1939 Data Link Multiplexing Remote Accelerator

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for Fault Code 288 | Active or inactive counts of Fault Code 288?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 288.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Using INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 288?
YES | NO
No Repair | No Repair

Refer to the OEM Service Manual. Troubleshoot the remote accelerator circuit connected to the OEM vehicle control unit.

Repair complete

Last Modified: 15-Feb-2012


FAULT CODE 295 - Barometric Pressure Sensor Circuit - Data Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine speed and camshaft position fault codes. |
 | STEP 1A. Check for Fault Codes 689 or 778. | Fault Codes 689 or 778 active?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for an active 295 Fault Code. | Fault Code 295 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 295 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for engine speed and camshaft position fault codes.

Guided Step 1A - Check for fault codes 689 or 778.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Using INSITE™ electronic service tool to read the fault codes.

Fault Codes 689 or 778 active?
YES | NO
No Repair | No Repair

Go to Fault Code 689 or 778 troubleshooting trees

Go to 2A

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for an active 295 fault code.

Conditions

  • Engine oil temperature is 7°C [45°F] or higher.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn shop exhaust fans off (if applicable).

Action

Check for an active fault code.

  • Wait 30 seconds.
  • Turn the keyswitch ON, wait 15 seconds.

Fault Code 295 inactive?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 295 is inactive.

Fault Code 295 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location, if all the steps have been completed or rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 319 - Real-Time Clock Power Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery and connections |
 | STEP 1A. Inspect the ECM and engine harness connector pins | Dirty or damaged pins?
 | STEP 1B. Check the real-time clock battery voltage at the ECM harness connector | Between 3.3 and 3.6 VDC?
 | STEP 1B-1. Inspect the real-time clock battery and engine wire harness connector pins |
 | STEP 1B-2. Check the real-time clock battery voltage at the battery module connector |
STEP 2. | Check the battery module harness |
 | STEP 2A. Check for an open circuit in the engine harness | Less than 10 ohms?
 | STEP 2B. Check for a short circuit in the engine harness | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground | More than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 319 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the real-time clock battery and connections

Guided Step 1A - Inspect the ECM and engine harness connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged pins harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the real-time clock battery voltage at the ECM harness connector

Conditions

  • Engine equipped with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Between 3.3 and 3.6 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the real-time clock battery and engine wire harness connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the real-time clock battery or engine harness.

Refer to Procedure 019-311 in Section 19. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B-2

Guided Step 1B-2 - Check the real-time clock battery voltage at the battery module connector

Conditions

  • Engine equipped with optional real-time clock battery.
  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Refer to the wiring diagram for connector pin identification.

Between 3.3 and 3.6 VDC?
YES NO
No Repair

Replace the real-time clock battery.

Refer to Procedure 019-311 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness

Guided Step 2A - Check for an open circuit in the engine harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the real-time clock battery from the engine harness.

Action

Using a multimeter, measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the real-time clock battery from the engine harness.

Action

Using a multimeter, measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to set real-time clock to the correct date and time.
  • Verify Fault Code 319 is inactive.

Fault Code 319 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 338 - Idle Shutdown Vehicle Accessories Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code | Fault Code 338 active?
STEP 2. | Check the idle shutdown ECM setup |
 | STEP 2A. Check the ECM setup for idle shutdown accessory relay | INSITE™ electronic service tool idle shutdown feature set up correctly?
STEP 3. | Check idle shutdown relay and circuit |
 | STEP 3A. Check the idle shutdown relay for an open circuit | Refer to OEM service manual for relay specifications.
 | STEP 3B. Determine return circuit location | Return circuit is wired to ECM?
 | STEP 3B-1. Check for an open circuit in the relay return circuit |
 | STEP 3C. Inspect the ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 3D. Check for an open circuit in the relay return circuit | Less than 10 ohms?
 | STEP 3E. Check for an open circuit in the relay signal circuit | Less than 10 ohms?
 | STEP 3F. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
 | STEP 3G. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 338 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the idle shutdown ECM setup

Guided Step 2A - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the idle shutdown feature setup.

  • If the vehicle has an idle shutdown relay installed, INSITE™ parameter shutdown accessory relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter shutdown accessory relay must be set to “Not Installed”.

INSITE™ electronic service tool idle shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the idle shutdown feature setup.

Go to 3A

Go to 4A

Guided Step 3 - Check the idle shutdown relay and circuit

Guided Step 3A - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Relay continuity pin-to-pin continuity check:

  • Measure the resistance of the relay coil and check for an open circuit between the idle shutdown SIGNAL pin and the relay RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification..

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to the OEM service manual for relay specifications.

Resistance within specifications?
YES NO
No Repair

Replace the idle shutdown relay.

Go to 3B

Go to 4A

Guided Step 3B - Determine return circuit location.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Determine if the relay return circuit is wired to the ECM or to block or chassis ground.

Refer to the OEM wiring diagram.

Return circuit is wired to ECM?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check for an open circuit in the relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Harness connector to ground continuity pin to ground continuity check:

Measure the resistance of the following pins between the idle shutdown relay connector and ground:

  • Idle shutdown relay RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

There is an open circuit between the relay connector and ground.

Repair the open return circuit. Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3C - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for an open circuit in the relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

Measure the resistance of the following pins between the OEM harness ECM connector and the OEM harness idle shutdown relay connector:

  • Idle shutdown relay RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

There is an open circuit in the idle shutdown relay return circuit between the OEM harness ECM connector and the OEM harness relay connector.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an open circuit in the relay signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Harness connector to connector continuity pin-to-pin continuity check:

Measure the resistance of the following pins between the OEM harness ECM connector and the OEM harness idle shutdown relay connector:

  • Idle shutdown SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Short Circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the OEM harness ECM connector:

  • Idle shutdown relay SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM power harness from the ECM.

Action

Measure the resistance between the idle shutdown relay SIGNAL pin of the OEM harness ECM connector and the ECM battery supply (+) pins of the OEM power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 338 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troublehoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 339 - Idle Shutdown Vehicle Accessories Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code | Fault Code 339 active?
STEP 2. | Check the idle shutdown relay and circuit |
 | STEP 2A. Check the idle shutdown relay resistance | Greater than 6.0 ohms?
 | STEP 2B. Check for a pin to ground short circuit in the idle shutdown relay | Greater than 100k ohms?
STEP 3. | Check the OEM harness |
 | STEP 3A. Inspect the ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 339 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the idle shutdown relay and circuit

Guided Step 2A - Check the idle shutdown relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Relay continuity - pin-to-pin continuity check:

  • Measure the resistance of the relay coil and check for low resistance between the idle shutdown SIGNAL pin and the relay RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 6.0 ohms?
YES NO
No Repair

Replace the idle shutdown relay.

Go to 2B

Go to 4A

Guided Step 2B - Check for a pin to ground short circuit in the idle shutdown relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Short circuit on one connector - pin to ground check:

Measure the resistance and check for a short circuit between the following idle shutdown relay pin and ground:

  • Idle shutdown relay SIGNAL connector pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Replace the idle shutdown relay.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness form the ECM.

Action

Short circuit on one connector - pin to ground check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and ground:

  • Idle shutdown relay SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-362 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and all other pins in the OEM harness ECM connector:

  • Idle shutdown relay SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-362 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM power harness from the ECM.

Action

Measure the resistance between the idle shutdown relay SIGNAL pin of the OEM harness ECM connector and the ECM battery supply (-) pins of the OEM power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-362 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 339 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electroni service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 341 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code | Are other fault codes active?
STEP 2. | Check the batteries and the power harness connector |
 | STEP 2A. Check the resistance of the battery supply circuit | Less than 10 ohms?
 | STEP 2B. Check the battery voltage | Normal conditions: At least (+) 12 VDC?During cranking: At least (+) 6.2 VDC?
 | STEP 2C. Check the battery connections | Connections are tight and corrosion-free?
STEP 3. | Check the OEM fuses |
 | STEP 3A. Verify that the OEM fuses are installed correctly | Fuses installed correctly?
 | STEP 3B. Verify that the OEM fuses are not blown | Fuses not blown?
STEP 4. | Check the power connector |
 | STEP 4A. Check the add-on or the accessory wiring at the positive (+) terminal of the battery | No damaged wires?
STEP 5. | Calibrate the ECM |
 | STEP 5A. Calibrate the ECM | Fault Code 341 inactive?
STEP 6. | Clear the fault codes |
 | STEP 6A. Disable the fault code | Fault Code 341 inactive?
 | STEP 6B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Are other fault codes active?
YES NO

Troubleshoot the active fault codes.

 No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the batteries and the power connector

Guided Step 2A - Check the resistance of the battery supply circuit

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.

Action

Check the resistance of the battery supply circuit.

  • Using a multimeter, measure the resistance between the ECM battery supply (+) pins of the power harness ECM connector and the positive (+) battery terminal.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the battery voltage

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Is the battery voltage at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Inspect the battery terminal connections.

Are connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 3 - Check the OEM fuses

Guided Step 3A - Verify that the OEM fuses are installed correctly

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuses for correct installation.

Are fuses installed correctly?
YES NO
No Repair

Install the fuses correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Verify the OEM fuses are not blown

Conditions

  • Turn keyswitch OFF.

Action

Verify the OEM fuses are not blown.

Are any fuses blown?
YES NO

Replace the fuses.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check the power connector

Guided Step 4A - Check the add-on or the accessory wiring at positive (+) terminal of the battery

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Are any wires damaged?
YES NO

Repair or replace the damaged wiring.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Calibrate the ECM

Guided Step 5A - Calibrate the ECM

Conditions

  • Connect all components.

Action

Recalibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECM.

Is Fault Code 341 inactive?
YES | NO
No Repair | No Repair

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes

Guided Step 6A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait 30 seconds.
  • Use INSITE™ electronic service tool to verify Fault Code 341 is inactive.

Fault Code 341 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 343 - Electronic Control Module (ECM)

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM |
 | STEP 1A. Check the ECM | Fault Code 343 inactive
 | STEP 1B. Check the inactive counts of Fault Code 343 | Less than 3 counts
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 343 inactive
 | STEP 2B. Clear the inactive fault codes | All faults cleared

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components

Action

Check the ECM.

  • Turn keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Is Fault Code 343 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 343

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 343.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 343.

Are there less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 352 - Sensor Supply Voltage Number 1 Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor Number 1 supply and return. |
 | STEP 2A. Inspect the barometric pressure sensor and circuit connected to the sensor Number 1 supply and return | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the engine oil pressure sensor and circuit connected to the sensor Number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the digital vehicle speed sensor and circuit connected to the sensor Number 1 supply and return | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response |
 | STEP 2D. Inspect the remote accelerator position sensor and circuit connected to the sensor Number 1 supply and return | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
 | STEP 3C. Inspect the vehicle for optional OEM devices | OEM devices installed?
 | STEP 3D. Inspect the ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 3E. Check the OEM harness for short circuit to ground | Greater than 100k ohms?
 | STEP 3F. Check the OEM harness for short circuit pin to pin | Greater than 100k ohms?
 | STEP 3G. Check for a short circuit in the OEM harness ECM battery (-) circuit | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Repair complete

Guided Step 2 - Check the sensors and circuits connected to the sensor Number 1 supply and return.

Guided Step 2A - Inspect the barometric pressure sensor and circuit connected to the sensor Number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine oil pressure sensor and circuit connected to the sensor Number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the digital vehicle speed sensor and circuit connected to the sensor Number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the digital vehicle speed sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the digital vehicle speed sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the digital vehicle speed sensor.

Refer to the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the remote accelerator position sensor and circuit connected to the sensor Number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the remote accelerator position sensor.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

There is a short in the engine harness pulling the sensor supply voltage down.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the vehicle for optional OEM devices.

Conditions

  • Turn keyswitch OFF.

Action

OEM devices, digital vehicle speed sensor and remote accelerator position sensor share a +5 volt SUPPLY with sensors on the engine harness.

  • Check the vehicle for a digital vehicle speed sensor or remote accelerator position sensor.

OEM devices installed?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19

Go to 3D

Repair complete

Guided Step 3D - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the OEM harness for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check the OEM harness for a short circuit to ground.

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the OEM harness for short circuit pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check the OEM harness for a short circuit - pin-to-pin.

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for a short circuit in the OEM harness ECM battery (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM power harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check for a short circuit.

  • Measure the resistance between the OEM +5 volt SUPPLY pin in the OEM harness ECM connector and the ECM battery (-) pins in the ECM power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Repair complete

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-May-2012


FAULT CODE 386 - Sensor Supply Voltage Number 1 Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check the OEM +5 volt supply |
 | STEP 3A. Inspect the vehicle for optional OEM devices | Digital vehicle speed sensor or remote accelerator sensor installed?
 | STEP 3B. Inspect ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 3C. Check the OEM harness for a short circuit pin to pin | Greater than 100k ohms?
 | STEP 3D. Check the OEM harness for a short circuit to ECM battery (+) | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • UseINSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO
No Repair

There is a short in the engine harness causing the sensor +5 volt supply line to have too high a voltage.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM +5 volt supply

Guided Step 3A - Inspect the vehicle for optional OEM devices.

Conditions

  • Turn keyswitch OFF.

Action

OEM devices, digital vehicle speed sensor and remote accelerator position sensor share a +5 volt SUPPLY with sensors on the engine harness.

  • Check the vehicle for a digital vehicle speed sensor or remote accelerator position sensor.

Digital vehicle speed sensor or remote accelerator sensor installed?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Repair complete

Guided Step 3B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the OEM harness for short circuit pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check the OEM harness for a short circuit - pin-to-pin.

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the OEM harness for short circuit to ECM battery (+).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM power harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).

Action

Check for a short circuit to ECM battery (+) in the OEM harness.

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to the ECM battery (+) pins at the OEM harness power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 386 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 387 - Accelerator Pedal Position Sensor Supply Voltage Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 387 active?
STEP 2. | Check the ECM and OEM harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2B-1. Check for an unswitched battery supply OEM connector. |
 | STEP 2B-2. Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 387 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 387 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the connector:

  • Accelerator pedal position +5 volt SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an unswitched battery supply OEM connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM for the following type of connector:

  • Dedicated unswitched battery supply OEM connector.

This dedicated connector provides unswitched battery voltage to the ECM and will be in addition to the primary OEM connector.

Dedicated unswitched battery supply OEM connector?
YES | NO
No Repair | No Repair

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Disconnect the OEM power harness from the ECM.

Action

Short circuit on two connectors - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and the ECM battery SUPPLY (+) pins in the OEM power harness connector:

  • Accelerator pedal position +5 volt SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 387 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 415 - Engine Oil Pressure Low - Critical

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 415. | Active or inactive counts of Fault Code 415?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 415.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ to read the fault codes.

Active or inactive counts of Fault Code 415?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Pressure Low symptom troubleshooting tree in Troubleshooting and Repair Manual, Signature/ISX/QSX Engines, Bulletin 3666239.

Repair complete

Last Modified: 20-Feb-2012


FAULT CODE 418 - Water-in-Fuel Indicator High - Maintenance

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 418 active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 418 active?
YES NO

Drain the water from the fuel filter.

 No Repair

Repair complete

Repair complete

Last Modified: 20-Feb-2012


FAULT CODE 426 - SAE J1939 Data Link Communication

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3163151 - ECM bench calibration harness, Part Number 3164185 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool | Does INSITE™ communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with ECM?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 426 inactive?
 | STEP 2B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check SAE J1939 communication

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool .

Conditions

  • Turn keyswitch ON.
  • Connect INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Attempt to communicate with the ECM with INSITE™ electronic service tool .

  • Start INSITE™ electronic service tool and connect to the ECM with an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM service manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Attempt to communicate with the ECM using INSITE™.

  • Start INSITE™ electronic service tool and connect to the ECM with an INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM troubleshooting and repair manual.

Refer to the Communication Error - Electronic Service Tool or Control Device Symptom troubleshooting tree.

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™electronic service tool to verify the fault code is inactive.

Is Fault Code 426 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes

Conditions

  • Connect all the components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 428 - Water-In-Fuel Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - 16 AWG male Deutsch™ test lead, Part Number 3823994 - 16 AWG female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 100k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 428 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Clear the fault codes: |
 | STEP 4A. Disable the fault code. | Fault Code 428 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the sensor extension harness.

Action

Inspect the sensor extension harness and water-in-fuel connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the sensor extension harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO

Replace the water-in-fuel sensor.

Refer to Procedure 019-127.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the sensor extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for the appropriate circuit response after 30 seconds.

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 429 active and Fault Code 428 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the water-in-fuel sensor from the sensor extension harness.

Action

Check for the appropriate circuit response after 30 seconds.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor RETURN pin and the extension harness water-in-fuel sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness or sensor extension harness.

Repair or replace the engine harness or sensor extension harness.

Refer to Procedure 019-043.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the water-in-fuel sensor from the sensor extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor SIGNAL pin and the extension harness water-in-fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness or sensor extension harness.

Repair or replace the engine harness or sensor extension harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the water-in-fuel sensor from the sensor extension harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness or sensor extension harness.

Repair or replace the engine harness or sensor extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 428 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 429 - Water-In-Fuel Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 429 inactive?
STEP 2. | Check the water-in-fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100 ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 429 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the sensor extension harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or extension harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the sensor extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 second.

  • Use INSITE™ to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the sensor extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 429 active?
YES NO

A defective sensor has been detected.

Replace the water-in-fuel sensor.

Refer to Procedure 019-127 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for the appropriate circuit response after 30 seconds.

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor extension harness from the water-in-fuel sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for the appropriate circuit response after 30 seconds.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Refer to the circuit diagram or the wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness or sensor extension harness.

Repair or replace the engine harness or sensor extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the water-in-fuel sensor from the sensor extension harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness or sensor extension harness.

Repair or replace the engine harness or sensor extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 429 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummin®s Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 431 - Accelerator Pedal Idle Validation Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ISS |
 | STEP 1A. Verify the ISS is connected to the OEM harness | ISS is connected to the OEM harness?
 | STEP 1B. Inspect the ISS and connector pins | Dirty or damaged pins?
 | STEP 1C. Check the ISS for an open circuit | Less than 125 ohms?
 | STEP 1D. Check the ISS for a short circuit from pin to pin | More than 100k ohms?
STEP 2. | Check the OEM harness |
 | STEP 2A. Check the OEM harness for an open circuit | Greater than 4.0 VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit | Less than 10 ohms?
 | STEP 2E. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery (+) circuit | Greater than 100k ohms?
STEP 3. | Clear the fault code |
 | STEP 3A. Disable the fault code | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the ISS

Guided Step 1A - Verify the ISS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the ISS is connected to the OEM harness.

ISS is connected to the OEM harness?
YES NO
No Repair

Connect the ISS to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the ISS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Inspect the OEM harness and ISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector of pins if possible.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the ISS for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and switch RETURN pin of the ISS connector with the pedal released.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and switch RETURN pin of the ISS connector with the pedal depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 125 ohms?
YES NO
No Repair

Replace the ISS.

Go to 1D

Go to 3A

Guided Step 1D - Check the ISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the ISS connector with the pedal released and depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the ISS.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins if possible.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the ISS connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the ISS connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Refer to the circuit diagram or the wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the ECM connector and the ISS connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open switch return circuit.

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the connector:

  • Idle validation on-idle SIGNAL pin
  • Idle validation off-idle SIGNAL pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM.

Action

Short circuit on two connectors - pin-to-pin check.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Repair complete

Go to 3A

Guided Step 3 - Clear the fault code

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Using INSITE™ electronic service tool to verify Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 431 - Accelerator Pedal Idle Validation Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the NISS |
 | STEP 1A. Verify the NISS is connected to the OEM harness | NISS is connected to the OEM harness?
 | STEP 1B. Inspect the NISS and connector pins | Dirty or damaged pins?
 | STEP 1C. Check the NISS for an open circuit | Less than 10 ohms?
 | STEP 1D. Check the NISS for a short circuit from pin to pin | More than 100k ohms?
STEP 2. | Check the OEM harness |
 | STEP 2A. Check the OEM harness for an open circuit | Greater than 4.0 VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit | Less than 10 ohms?
 | STEP 2E. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery (+) circuit | Greater than 100k ohms?
STEP 3. | Clear the fault code |
 | STEP 3A. Disable the fault code | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the NISS

Guided Step 1A - Verify the NISS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the NISS is connected to the OEM harness.

NISS is connected to the OEM harness?
YES NO
No Repair

Connect the NISS to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the NISS and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Inspect the OEM harness and NISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the NISS for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and switch RETURN pin of the NISS connector with the pedal released.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and switch RETURN pin of the NISS connector with the pedal depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the NISS.

Go to 1D

Repair Complete

Guided Step 1D - Check the NISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the NISS connector with the pedal released and depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification..

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the NISS.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness and connector pins, if possible.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the NISS connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the NISS connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the OEM harness switch RETURN wire in the OEM harness between the ECM connector and the NISS connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Short circuit on one connector - pin to pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the connector:

  • Idle validation on-idle SIGNAL pin
  • Idle validation off-idle SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM.

Action

Short circuit on two connectors - pin-to-pin check:

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Repair complete

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SSS |
 | STEP 1A. Verify the SSS is connected to the OEM harness | SSS is connected to the OEM harness?
STEP 2. | Check the OEM harness |
 | STEP 2A. Check the OEM harness for an open circuit | Greater than 4.0 VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit | Less than 10 ohms?
 | STEP 2E. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery (+) circuit | Greater than 100k ohms?
STEP 3. | Clear the fault code |
 | STEP 3A. Disable the fault code | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the SSS

Guided Step 1A - Verify the SSS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the SSS is connected to the OEM harness.

SSS is connected to the OEM harness?
YES NO
No Repair

Connect the SSS to the OEM harness. Refer to the OEM service manual

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins if possible.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the SSS connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the SSS connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the ECM connector and the SSS connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Short circuit on one connector - pin to pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the connector:

  • Idle validation on-idle SIGNAL pin
  • Idle validation off-idle SIGNAL pin

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM.

Action

Short circuit on two connectors - pin-to-pin check:

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM ECM connector and the ECM battery (+) pins in the ECM power connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM ECM connector and the ECM battery (+) pins in the ECM power connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the SSS.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 432 active?
STEP 2. | Check the fault codes. |
 | STEP 2A. Perform the fault code disable procedure. | Fault Code 432 active?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the accelerator pedal position sensor resistance. | 1500 to 3000 Ohms (released)250 to 1500 Ohms (depressed)?
 | STEP 3B-1. Check the resistance of the accelerator pedal position sensor. |
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 432 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fault codes.

Guided Step 2A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal to the full fuel position and release it completely three times.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES NO
No Repair

Replace the accelerator pedal assembly.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the accelerator pedal position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Measure the resistance between the accelerator pedal position SIGNAL pin and accelerator pedal position +5 volt SUPPLY pin at the ECM connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 Ohms (released)250 to 1500 Ohms (depressed)?

Released value must be at least 1000 ohms greater than depressed value.

YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the resistance of the accelerator pedal position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Measure the resistance between the accelerator pedal position SIGNAL pin and accelerator pedal position +5 volt SUPPLY pin at the accelerator pedal position sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 Ohms (released)250 to 1500 Ohms (depressed)?

Released value must be at least 1000 ohms greater than depressed value.

YES NO

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Replace the accelerator pedal assembly.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the OEM harness ECM connector:

  • Accelerator pedal position +5 volt SUPPLY pin
  • Accelerator pedal position SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 432 is inactive.

Fault Code 432 inactive?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 433 - Intake Manifold Pressure Sensor Circuit - Data Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine speed and camshaft position fault codes |
 | STEP 1A. Check for fault codes 689 or 778 | Fault Codes 689 or 778 active?
STEP 2. | Check for a valid fault code |
 | STEP 2A. Check for an active Fault Code 433 | Fault Code 433 inactive?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 433 inactive?
 | STEP 3B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the engine speed and camshaft position fault codes

Guided Step 1A - Check for Fault Codes 689 or 778.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Using INSITE™ electronic service tool to read the fault codes.

Fault Codes 689 or 778 active?
YES | NO
No Repair | No Repair

Go to Fault Code 689 or 778 troubleshooting trees

Go to 2A

Guided Step 2 - Check for valid fault code

Guided Step 2A - Check for active Fault Code 433.

Conditions

  • Engine oil temperature is 7°C [45°F] or higher.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn shop exhaust fans off (if applicable).

Action

Check for an active fault code.

  • Wait 30 seconds
  • Turn the keyswitch ON and wait 15 seconds.

Fault Code 433 inactive?
YES NO
No Repair

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 433 is inactive.

Fault Code 433 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the local Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 434 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To avoid pin and harness damage, use the following test lead when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part No. 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the batteries and the power connector |
 | STEP 1A. Check the battery connections | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage | Normal conditions:At least (+) 12 VDC?During cranking:At least (+) 6.2 VDC?
STEP 2. | Check the OEM power harness |
 | STEP 2A. Inspect the harness and the ECM connector pins | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the battery power circuits | (+) 10 to 15 VDC?
 | STEP 2B-1. Verify that the OEM fuse is installed correctly |
 | STEP 2B-2. Check if the OEM fuse is blown |
 | STEP 2C. Check the resistance of the battery supply circuit | Less than 1.0 ohms?
 | STEP 2D. Check for a short circuit | More than 100K ohms?
 | STEP 2E. Check the add-on or the accessory wiring at (+) terminal of the battery | Any damaged wires?
 | STEP 2F. Check all fuel metering and timing actuator connectors | Loose connections or evidence of arcing?
 | STEP 2G. Check the keyswitch input-to-ECM wire | Keyswitch input wire interrupted?
 | STEP 2H. Check the keyswitch input circuit | Less than 5 ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 434 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the batteries and the power connector

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: at least (+) 12 VDC?During cranking: at least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM power harness

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the battery power circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM

Action

Check for an open circuit in the battery power circuits.

  • Using a multimeter, measure the voltage from the ECM battery SUPPLY (+) at the OEM power harness connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

(+) 10 to 15 VDC?
YES NO
No Repair

Repair or replace the OEM power harness.

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Is fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Is fuse blown?
YES NO

Locate the short circuit.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s).

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power harness connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin and the negative battery connector.

Refer to the wiring diagram for connector pin identification.

NOTE: Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM
  • Disconnect both positive (+) and negative (-) terminals from the battery

Action

Check for a short circuit.

Measure the resistance between the following OEM power harness ECM connector pins and all other pins in the OEM power harness connector:

  • ECM battery SUPPLY (+) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or the accessory wiring at (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

 No Repair

Go to 3A

Go to 2F

Guided Step 2F - Check all fuel metering and timing actuator connectors.

Conditions

  • Turn keyswitch OFF.

Action

Check all fuel metering and timing connectors for the following:

  • Loose connections
  • Arcing.

Loose connections or evidence of arcing?
YES NO

Clean and tighten the connectors.

 No Repair

Go to 3A

Go to 2G

Guided Step 2G - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire interrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 3A

Go to 2H

Guided Step 2H - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 434 is inactive.

Fault Code 434 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 435 - Engine Oil Pressure Sensor Circuit - Data Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine speed and camshaft position fault codes. |
 | STEP 1A. Check for Fault Codes 689 or 778. | Fault Codes 689 or 778 active?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for an active 435 fault code. | Fault Code 435 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 435 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for engine speed and camshaft position fault codes.

Guided Step 1A - Check for Fault Codes 689 or 778.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Using INSITE™, read the fault codes.

Fault Codes 689 or 778 active?
YES | NO
No Repair | No Repair

Go to Fault Code 689 or 778 troubleshooting trees.

Go to 2A

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for an active 435 fault code.

Conditions

  • Engine oil temperature is 7°C [45°F] or higher.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn shop exhaust fans off (if applicable).

Action

Check for an active fault code.

  • Wait 30 seconds.
  • Turn the keyswitch ON, wait 15 seconds.

Fault Code 435 inactive?
YES NO
No Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 435 is inactive.

Fault Code 435 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 443 - Accelerator Pedal Position Sensor Supply Voltage Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 443 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 443 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground in the OEM harness. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 443 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Short circuit on one connector - pin to pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and all other pins in the connector:

  • Accelerator pedal/lever position +5 volt SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Short circuit on one connector - pin to ground check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and ground:

  • Accelerator pedal/lever position +5 volt SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 443 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 449 - High Fuel Pressure

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fuel restriction |
 | STEP 1A. Check for fuel restriction in the fuel drain line | Restriction below 229 mm Hg [9 in Hg]?
STEP 2. | Check rail fuel pressure sensor |
 | STEP 2A. Verify accuracy with a mechanical gauge | Gauge and INSITE™ electronic service tool readings are within 69 kPa [10 psi]?
STEP 3. | Replace the fuel regulator |
 | STEP 3A. Replace the 1724 kPa [250 psi] fuel regulator | Fault Code 449 inactive?
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code | Fault Code 449 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check for fuel restriction

Guided Step 1A - Check for fuel restriction in the fuel drain line

Conditions

  • Engine running.

Action

Check for fuel restriction in the fuel drain line.

  • Install restriction gauge in fuel drain line.
  • Start the engine and run at high idle.
  • Check the restriction gauge.

Restriction below 229 mm Hg [9 in Hg]?
YES NO
No Repair

Correct drain line restriction.

Reference the Troubleshooting and Repair Manual, Signature/ISX/QSX Engines, Bulletin No. 3666239.

Go to 2A

Go to 4A

Guided Step 2 - Check rail fuel pressure sensor

Guided Step 2A - Verify accuracy with a mechanical gauge

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the sensor accuracy.

  • Connect a mechanical fuel pressure gauge to the pressure side Compuchek™ fitting.
  • Setup INSITE™ electronic service tool to monitor mode to display rail fuel pressure.
  • Start the engine and compare the rail fuel pressure reading on INSITE™ electronic service tool to the reading on the mechanical fuel pressure gauge.

Gauge and INSITE™ electronic service tool readings within 69 kPa [10 psi]?
YES NO
No Repair

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Replace the fuel regulator

Guided Step 3A - Replace the 1724 kPa [250 psi] regulator

Conditions

  • Keyswitch "OFF"

Action

Replace the 1724 kPa [250 psi] regulator.

Fault Code 449 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 449 is inactive.

Fault Code 449 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A.

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 482 - Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the fuel supply. |
 | STEP 2A. Check the vehicle fuel tanks for fuel. | Fuel in the fuel tanks?
 | STEP 2B. Verify the fuel system has been primed. | Fuel system been properly primed?
 | STEP 2C. Check for fuel leaks. | Any fuel leaks in the tanks or the fuel supply lines?
 | STEP 2D. Check for fuel inlet restriction. | Fuel inlet restriction less than the specifications listed?
STEP 3. | Check the engine operation. |
 | STEP 3A. Crank the engine to see if it starts. | Does the engine start?
STEP 4. | Check fuel shutoff valve operation. |
 | STEP 4A. Check the fuel lift pump for activation at keyswitch ON. | Fuel lift pump operate when the keyswitch is turned ON?
 | STEP 4B. Check the fuel lift pump pressure. | Positive fuel pressure greater than 64 kPa [10 psi] present when the lift pump is operating?
STEP 5. | Check the fuel shutoff valve operation. |
 | STEP 5A. Check the fuel shutoff valve electrical operation. | Fuel shutoff valve operates and 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
 | STEP 5B. Check the fuel shutoff valve mechanical operation. | Pressure difference greater than 69kPa [10 psi]?
 | STEP 5C. Check for a mechanical restriction of the fuel shutoff valve. | Debris present in the fuel shutoff valve or are there signs the fuel shutoff valve is restricting flow?
STEP 6. | Check the 1724 kPa [250 psi] fuel pressure regulator. |
 | STEP 6A. Inspect the 1724 kPa [250 psi] fuel pressure regulator. | Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?
STEP 7. | Check the 2620 kPa [380 psi] pressure regulator. |
 | STEP 7A. Inspect the 2620 kPa [380 psi] pressure regulator. | More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?
STEP 8. | Check the fuel pump (gear pump) pressure. |
 | STEP 8A. Measure the fuel pump (gear pump) pressure while cranking. | Fuel pump (gear pump) pressure less than 2413 kPa [350 psi] cranking at 130 rpm for 15 seconds?
STEP 9. | Check the fuel pressure. |
 | STEP 9A. Measure the rail fuel pressure. | Rail fuel pressure at least 1448 kPa [210 psi] at idle?
 | STEP 9B. Measure the fuel pump (gear pump) pressure, engine operating. | Fuel pump (gear pump) pressure a minimum of 1931 kPa [280 psi] at 2000 rpm?
STEP 10. | Check for air in the pressure-side fuel. |
 | STEP 10A. Check for air in the pressure-side fuel. | Air present in the pressure-side fuel?
STEP 11. | Check the fuel inlet restriction. |
 | STEP 11A. Measure the fuel inlet restriction. | Fuel inlet restriction less than the specification?
STEP 12. | Check the fuel shutoff valve. |
 | STEP 12A. Check for a mechanical restriction of the fuel shutoff valve. | Debris present in the fuel shutoff valve or are there signs the fuel shutoff valve is restricting flow?
STEP 13. | Check the pressure fuel filter. |
 | STEP 13A. Measure the pressure drop across the pressure fuel filter. | Pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
STEP 14. | Check the 1724 kPa [250 psi] fuel pressure regulator. |
 | STEP 14A. Inspect the 1724 kPa [250 psi] fuel pressure regulator. | Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?
STEP 15. | Check the 2620 kPa [380 psi] pressure regulator. |
 | STEP 15A. Inspect the 2620 kPa [380 psi] pressure regulator. | More that 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?
STEP 16. | Check the fuel pressure sensor for accuracy. |
 | STEP 16A. Verify the fuel pressure sensor for accuracy. | INSITE™ electronic service tool reading and pressure gauge reading match within 138 kPa [20 psi]?
STEP 17. | Clear the fault codes. |
 | STEP 17A. Disable the fault code. | Fault Code 482 inactive?
 | STEP 17B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: If Fault Code 482 is active or inactive, attempt to clear fault. If fault remains active or inactive, continue through tree.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227

Go to 2A

Guided Step 2 - Check the fuel supply.

Guided Step 2A - Check the vehicle fuel tanks for fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle fuel tanks for fuel.

Fuel in the fuel tanks?
YES NO
No Repair

Fill the fuel tanks.

Go to 2B

Go to 17A

Guided Step 2B - Verify the fuel system has been primed.

Conditions

  • Turn keyswitch OFF.

Action

If entering this tree after a component has been replaced in the fuel system, or after the engine was emptied of fuel, verify the fuel system has been properly primed before proceeding.

  • Verify the fuel system has been properly primed.
  • Use the following procedure for fuel system priming information found in the Signature™, ISX, and QSX15, Service Manual, Bulletin 3666239. Refer to Procedure 006-015 in Section 6.

Fuel system been properly primed?
YES NO
No Repair

Prime the fuel system.

  • Refer to Procedure 006-015 in Section 6.

Go to 2C

Go to 17A

Guided Step 2C - Check for fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel tanks, lines, and related components for leaks.

  • Inspect for fuel leaks.

Any fuel leaks in the tanks or the fuel supply lines?
YES NO

Locate and repair the source of the fuel leak by checking all the engine and OEM supply lines, fittings, suction-side fuel filter head, fuel tank stand pipes, ECM cooling plate, and ECM cooling plate fuel supply and return lines.

No Repair

Go to 17A

Go to 2D

Guided Step 2D - Check for fuel inlet restriction.

Conditions

  • Connect the vacuum gauge to the suction side Compuchek™ fitting.
  • Turn keyswitch ON.
  • Opereate engine at high idle (engine cranking if troubleshooting No-Start).

Action

Wait until the priming pump has turned off or unplug the priming pump and observe the reading on the vacuum gauge.

  • Check the fuel inlet restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specifications listed?
YES NO

Fuel filter condition:

Dirty: 305 mm-Hg [12 in-Hg]: New: 203 mm-Hg [8 in-Hg]

Locate the cause of high fuel inlet restriction.

Check the suction-side fuel filter and fuel supply lines.

Note: For QSX only, check the 300 micron inlet filter screen for debris.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

Go to 3A

Repair complete

Guided Step 3 - Check the engine operation.

Guided Step 3A - Crank the engine to see if it starts.

Conditions

  • Turn keyswitch ON.

Action

Crank the engine to see if it starts.

  • Start the engine.

Engine start?
YES | NO
No Repair | No Repair

Go to 9A

Go to 4A

Guided Step 4 - Check the fuel lift pump operation.

Guided Step 4A - Check the fuel lift pump for activation at keyswitch ON.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel lift pump for activation at keyswitch ON.

  • Verify the fuel lift pump operates when the vehicle keyswitch is turned ON.

Fuel lift pump operate when the keyswitch is turned ON?
YES NO
No Repair

Use the following procedure to check the fuel lift pump. Refer to Procedure 019-397 in Section 19.

Go to 4B

Go to 17A

Guided Step 4B - Check the fuel lift pump pressure.

Conditions

  • Turn keyswitch ON.
  • Connect a pressure gauge on the gear pump inlet Compuchek™ fitting.

Action

Check the fuel lift pump pressure.

  • Verify there is a positive fuel pressure greater than 64 kPa [10 psi] when the fuel lift pump is operating.

Note: Erratic fuel lift pump pressure can indicate air in the fuel.

Positive fuel pressure greater than 64 kPa [10 psi] present when the lift pump is operating?
YES NO
No Repair

Repair or replace the fuel lift pump. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-045 in Section 5.

Go to 5A

Go to 17A

Guided Step 5 - Check the fuel shutoff valve.

Guided Step 5A - Check the fuel shutoff valve electrical operation.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel shutoff valve for activation at keyswitch ON.

  • Verify the fuel shutoff operates and there is 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON.

Fuel shutoff valve operates and 12-VDC present at the terminal of the fuel shutoff valve when the keyswitch is turned ON?
YES NO
No Repair

  • Use the following procedure to check the fuel shutoff valve. Refer to Procedure 019-049 in Section 19.

Go to 5B

Go to 17A

Guided Step 5B - Check the fuel shutoff valve mechanical operation.

Conditions

  • Connect pressure gauge, Part Number 3375932, on the rail fuel pressure Compuchek™ fitting.
  • Connect pressure gauge, Part Number 3375932, on the gear pump output pressure Compuchek™ fitting.
  • Turn keyswitch ON.

Action

Monitor the fuel pressure on both gauges with the lift pump operating.

NOTE: A restricted pressure side fuel filter will cause erroneous fuel pressure drop readings during this test. Address any fuel filter issues before proceeding.

Pressure difference greater than than 69 kPa [10 psi]?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Check for a mechanical restriction of the fuel shutoff valve.

  • Remove and inspect the fuel shutoff valve for a mechanical restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Debris present in the fuel shutoff valve or are there signs the fuel shutoff valve is restricting flow?
YES NO

  • Repair or replace the fuel shutoff valve.
  • Refer to Procedure 019-050 in Section 19.

No Repair

Go to 17A

Go to 6A

Guided Step 6 - Check the 1724 kPa [250 psi] pressure regulator.

Guided Step 6A - Inspect the 1724 kPa [250 psi] pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 1724 kPa [250 psi] pressure regulator.

  • Disconnect the wiring harness from the fueling and timing actuators.
  • Remove the fuel line that connects the pressure fuel filter head on the IFSM to the ECM cooling plate at the cooling plate.
  • Install a cap onto the fitting into the cooling plate to make sure no air is brought into the fuel system.
  • Place the fuel line into a bucket and crank the engine. If there is a measurable amount of fuel coming out of the line during cranking, then fuel is bypassing the 1724 kPa [250 psi] regulator.

Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 1724 kPa [250 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

Replace the 1724 kPa [250 psi] regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 7A

Guided Step 7 - Check the 2620 kPa [380 psi] pressure regulator.

Guided Step 7A - Inspect the 2620 kPa [380 psi] pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 2620 kPa [380 psi] pressure regulator.

  • Disconnect the OEM drain line connection at the IFSM.
  • Install a short piece of hose and place the end of the hose into a bucket.
  • Disconnect the wiring harness from the fueling and timing actuators.
  • Turn keyswitch ON and wait until the lift pump stops operating.
  • Crank the engine for 15 seconds and measure the fuel from the IFSM drain.

More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 2620 kPa [380 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.

Replace the regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 8A

Guided Step 8 - Check the fuel pump (Gear Pump) pressure.

Guided Step 8A - Measure the fuel pump (gear pump) pressure while cranking.

Conditions

  • Connect a pressure gauge to the Compuchek™ fitting on the back of the fuel pump (gear pump).
  • Turn keyswitch ON.
  • Disconnect the wire at the fuel shutoff valve.

Action

Measure the fuel pump (gear pump) pressure while cranking.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after the keyswitch is turned ON or disconnect the 2-pin power supply from the lift pump.

Note: The engine wiring harness must be disconnected from the fuel shutoff valve during this step.

  • Measure the fuel pump (gear pump) pressure while cranking the engine.

NOTE: Do not crank the engine for 30 seconds continuously. Crank the engine in 15 second intervals with a 15 second pause between intervals. This reduces the possibility of overheating the starting motor.

Fuel pump (gear pump) pressure less than 2413 kPa [350 psi] cranking at 130 rpm for 15 seconds?
YES NO

Use the following procedure to repair or replace the fuel pump (gear pump), in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-016 in Section 5.

No Repair

Go to 17A

Go to 9A

Guided Step 9 - Check the fuel pressure.

Guided Step 9A - Measure the fuel pump (gear pump) pressure at idle.

Conditions

  • Connect all components.
  • Connect pressure gauge, Part Number 3375932, or equivalent, onto the Compuchek™ fitting (as shown).
  • Operate engine at idle.

Action

Measure the fuel pump (gear pump) pressure at idle.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.

Measure the fuel pump (gear pump) pressure.

  • With the engine operating at idle, use a pressure gauge attached to the rail pressure Compuchek™ fitting on the IFSM to measure the fuel pump (gear pump) pressure.

Fuel pump (gear pump) pressure at least 1448 kPa [210 psi] at idle?
YES | NO
No Repair | No Repair

Go to 9B

Go to 12A

Guided Step 9B - Measure the fuel pump (gear pump) pressure at high idle.

Conditions

  • Connect all components.
  • Connect pressure gauge, Part Number 3375932, or equivalent, onto the Compuchek™ fitting (as shown).
  • Turn keyswitch ON.
  • Operate engine at high idle.

Action

Measure the fuel pump (gear pump) pressure at high idle.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.
  • Measure the fuel pump (gear pump) pressure with the engine operating at high idle and no load.
  • With the engine operating at high idle, use a pressure gauge attached to the rail pressure Compuchek™ fitting on the IFSM to measure the fuel pump (gear pump) pressure.

Fuel pump (gear pump) pressure a minimum of 1931 kPa [280 psi] at 2000 rpm?
YES | NO
No Repair | No Repair

Go to 16A

Go to 10A

Guided Step 10 - Check the air in the pressure-side fuel.

Guided Step 10A - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Note: Possible sources of air in the pressure-side fuel are leaks in:

  • OEM supply lines
  • Fittings
  • Suction-side fuel filter head
  • Fuel tank stand pipes
  • ECM cooling plate
  • ECM cooling plate fuel supply and return lines.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-003 in Section 6.

Air present in the pressure-side fuel?
YES NO

Locate and repair the source of the air leak by checking all the OEM supply lines and fittings, suction-side fuel filter head, fuel tank stand pipes, ECM cooling plate, and ECM cooling plate fuel supply and return lines.

No Repair

Go to 17A

Go to 11A

Guided Step 11 - Check the fuel inlet restriction.

Guided Step 11A - Measure the fuel inlet restriction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start the engine.

Action

Measure the fuel inlet restriction.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.
  • Check the fuel inlet restriction.
  • Maximum clean filter: 203 mm Hg [8 in-Hg]
  • Maximum dirty filter: 305 mm Hg [12 in-Hg]

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction less than the specification?
YES NO
No Repair

Replace the suction-side fuel filter or repair the cause of high inlet restriction.

Go to 12A

Go to 17A

Guided Step 12 - Check the fuel shutoff valve.

Guided Step 12A - Check for a mechanical restriction of the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check for a mechanical restriction of the fuel shutoff valve.

  • Remove and inspect the fuel shutoff valve for a mechanical restriction.
  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-043 in Section 5.

Debris present in the fuel shutoff valve or are there signs the fuel shutoff valve is restricting flow?
YES NO

Repair or replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 17A

Go to 13A

Guided Step 13 - Check the pressure-side fuel filter.

Guided Step 13A - Measure pressure drop across the pressure-side fuel filter.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine at high idle.

Action

Measure the pressure drop across the pressure-side fuel filter.

  • The fuel lift pump must not be operating during this check. Wait 2 minutes after keyswitch ON or disconnect the 2-pin power supply from the fuel lift pump.

NOTE: The fuel temperature must be a minimum of 38°C [100°F].

  • Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load.
  • Use the Compuchek™ fitting on the back of the fuel pump (gear pump) to measure the pressure out of the fuel pump (gear pump). This will be the high pressure reading.
  • Use the Compuchek™ fitting on the underside of the IFSM to measure the pressure of the fuel rail. This will be the low pressure reading.
  • Subtract the low reading from the high reading to obtain the pressure drop across the pressure-side fuel filter.

Pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
YES NO
No Repair

Replace the pressure fuel filter.

Go to 14A

Go to 17A

Guided Step 14 - Check the 1724 kPa [250 psi] fuel pressure regulator.

Guided Step 14A - Inspect the 1724 kPa [250 psi] fuel pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 1724 kPa [250 psi] fuel pressure regulator.

  • Disconnect the engine wiring harness from the fueling and timing actuators.
  • Remove the fuel line that connects the pressure fuel filter head on the IFSM to the ECM cooling plate at the cooling plate.
  • Install a cap onto the fitting into the cooling plate to make sure no air is brought into the fuel system.
  • Place the fuel line into a bucket and crank the engine. If there is a measurable amount of fuel coming out of the line during cranking, then fuel is bypassing the 1724 kPa [250 psi] regulator.

Any amount of fuel coming from the ECM cooling plate supply line while the engine is cranking and the fueling and timing actuators are disconnected from the engine harness?

YES NO

Remove and inspect the 1724 kPa [250 psi] regulator for debris that can stick the regulator open and for cut or missing o-rings.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 15A

Guided Step 15 - Check the 2620 kPa [380 psi] fuel pressure regulator.

Guided Step 15A - Inspect the 2620 kPa [380 psi] fuel pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine wiring harness to the fuel shutoff valve.

Action

Inspect the 2620 kPa [380 psi] fuel pressure regulator.

  • Disconnect the OEM drain line connection at the IFSM.
  • Install a short piece of hose and place the end of the hose into a bucket.
  • Disconnect the wiring harness from the fueling and timing actuators.
  • Turn the keyswitch ON and wait until the lift pump stops operating.
  • Crank the engine for 15 seconds and measure the fuel from the IFSM.

More than 237 ml [8 oz] of fuel coming from the drain line while the engine is cranking for 15 seconds and the fueling and timing actuators are disconnected from the engine harness?

YES NO

  • Remove and inspect the 2620 kPa [380 psi] pressure regulator for debris that can stick the regulator open and for cut or missing o-rings.
  • Replace the regulator. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-073 in Section 5.

No Repair

Go to 17A

Go to 16A

Guided Step 16 - Check the fuel pressure sensor for accuracy.

Guided Step 16A - Verify the accuracy of the rail fuel pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Install a pressure gauge on the rail fuel pressure Compuchek™ fitting.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the pressure gauge and INSITE™ electronic service tool reading for the rail fuel pressure sensor agree.

INSITE™ electronic service tool reading and pressure gauge reading match within 138 kPa [20 psi]?
YES NO

Repair or replace the fuel pump (gear pump). Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 005-016 in Section 5.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 17A

Go to 17A

Guided Step 17 - Clear the fault codes.

Guided Step 17A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 482 is inactive.

Fault Code 482 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 17B

Go to 1A

Guided Step 17B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshooting any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-Mar-2014


FAULT CODE 486 - Fuel System Underfueling

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Inspect for active or high inactive counts of Fault Code 482 or 2313. | Fault Codes 482 or 2313 are active or have high inactive counts?
STEP 2. | Check for air in the pressure-side fuel. |
 | STEP 2A. Inspect for air in the pressure-side fuel. | Air in fuel?
STEP 3. | Check the rear fueling actuator. |
 | STEP 3A. Inspect the rear fueling actuator. | Fault Code 486 inactive?
STEP 4. | Check the injector o-rings. |
 | STEP 4A. Inspect the bottom two injector o-rings of all six injectors. | O-rings damaged?
STEP 5. | Check the fuel passages in the head. |
 | STEP 5A. Inspect the fuel passages in the rear of the head. | Leaks to the drain passages, crankcase, cylinders, or coolant system?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 486 inactive?
 | STEP 6B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Inspect for active or high inactive counts of Fault Code 482 or 2313.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check for active or high counts of inactive fault codes.

Fault Codes 482 or 2313 are active or have high inactive counts?
YES | NO
No Repair | No Repair

Troubleshooting trees for Fault Codes 2313 and 482.

Go to 2A

Guided Step 2 - Check for air in the pressure-side fuel

Guided Step 2A - Inspect for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Refer to Procedure 006-003 in Section 19.

Air in fuel?
YES NO

Refer to Procedure 006-003 in Section 6.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the rear fueling actuator

Guided Step 3A - Inspect the rear fueling actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect the INSITE™ electronic service tool.

Action

Replace the rear fueling actuator.

  • Refer to Procedure 019-110 in Section 19.
  • Use INSITE™ electronic service tool to verify Fault Code 486 is inactive.

Fault Code 486 inactive?
YES NO
No Repair

Install the original rear fueling actuator. Refer to Procedure 019-110 in Section 19.

Go to 6A

Go to 4A

Guided Step 4 - Check the injector o-rings

Guided Step 4A - Inspect the bottom two injector o-rings of all six injectors.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for nicks or tears on the bottom two o-rings of all six injectors.

  • Refer to Procedure 006-026 in Section 19.
  • Check that o-rings are in good condition.

O-rings damaged?
YES NO

Replace the o-rings. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the fuel passages in the head

Guided Step 5A - Inspect the fuel passages in the rear of the head.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel drillings in the rear of the cylinder head for leaks or obstructions.

Leaks to the drain passages, crankcase, cylinders, or coolant system?
YES NO

Correct the problem. Reference the Troubleshooting and Repair Manual, Signature™/ISX/QSX15 Engines, Bulletin 3666239.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes

Guided Step 6A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 486 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Are all faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 06-Aug-2015


FAULT CODE 546 - Rail Fuel Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 546 active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 547 active and Fault Code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 547 active and Fault Code 546 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 546 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM port.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-May-2012


FAULT CODE 547 - Rail Fuel Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 547 active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 546 active and Fault Code 547 inactive?
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Fault Code 546 active and Fault Code 547 inactive?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 546 active and Fault Code 547 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 547 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure +5 volt SUPPLY pin and the rail fuel pressure SIGNAL pin at the sensor connector of the engine harness.

  • Check for the appropriate ECM response after 30 seconds.
  • Read the fault codes using INSITE™.

Refer to the wiring diagram for connector pin identification.

Fault Code 546 active and Fault Code 547 inactive?
YES NO

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure +5 volt SUPPLY pin and the rail fuel pressure SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response after 30 seconds.
  • Read the fault codes using INSITE™.

Refer to the wiring diagram for connector pin identification.

Fault Code 546 active and Fault Code 547 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure +5 volt SUPPLY pin and rail fuel pressure SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response after 30 seconds.
  • Read the fault codes using INSITE™.

Refer to the wiring diagram for connector pin identification.

Fault Code 546 active and Fault Code 547 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 551 (ISS) - Accelerator Pedal Idle Validation Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ISS |
 | STEP 1A. Inspect the ISS and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the ISS for a short circuit from pin to pin. | More than 100k ohms?
STEP 2. | Check the OEM harness |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than 4.0 VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2A-4. Check for a pin to pin short circuit in the OEM harness. |
 | STEP 2A-5. Check the ECM voltage. |
 | STEP 2B. Check for a pin to pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Clear the fault code |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the ISS

Guided Step 1A - Inspect the ISS from the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Inspect the OEM harness and ISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the ISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the ISS connector with the pedal released and depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the ISS.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the RETURN pin in the ISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector of pins, if possible.

 No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit to return.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and RETURN pin at the ISS connector of the OEM harness.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and RETURN pin at the ISS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ISS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ISS connector of the OEM harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the ISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin the ISS connector of the OEM harness to the RETURN pin in the ISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES NO

Replace the ISS.

Go to 3A

Repair complete

Guided Step 2B - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Replace the ISS.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 551NISS - Accelerator Pedal Idle Validation Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the NISS |
 | STEP 1A. Inspect the NISS and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the NISS for a short circuit from pin to pin. | More than 100k ohms?
STEP 2. | Check the OEM harness |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than 4.0 VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2A-4. Check for a pin to pin short circuit in the OEM harness |
 | STEP 2A-5. Check the ECM voltage |
 | STEP 2B. Check for a pin to pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Clear the fault code |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the NISS

Guided Step 1A - Inspect the NISS and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Inspect the OEM harness and NISS from the OEM harness.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the NISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the NISS connector with the pedal released and depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the NISS.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the RETURN pin in the NISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the RETURN pin in the NISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit to return.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and RETURN pin at the NISS connector of the OEM harness.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and RETURN pin at the NISS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the NISS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the NISS connector of the OEM harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the NISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the RETURN pin in the NISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the RETURN pin in the NISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES NO

Replace the NISS.

Go to 3A

Repair Complete

Guided Step 2B - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Replace the NISS.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 551 - Accelerator Pedal Idle Validation Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SSS |
 | STEP 1A. Inspect the SSS and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the SSS for a short circuit from pin to pin. | More than 100k ohms?
STEP 2. | Check the OEM harness |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than 4.0 VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2B. Check for a pin to pin short circuit in the OEM harness. | More than 100k ohms.
STEP 3. | Clear the fault code |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault code. | All faults cleared?

Guided Step 1 - Check the SSS

Guided Step 1A - Inspect the SSS and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.

Action

Inspect the OEM harness and SSS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the SSS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the SSS connector with the pedal released and depressed.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the SSS.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the RETURN pin in the SSS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the RETURN pin in the SSS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit to return.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and RETURN pin at the SSS connector of the OEM harness.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and RETURN pin at the SSS connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and RETURN pin at the SSS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and RETURN pin at the SSS connector of the OEM harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Replace the SSS.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the SSS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the RETURN pin in the SSS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the RETURN pin in the SSS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES NO

Replace the SSS.

Go to 3A

Repair Complete

Guided Step 2B - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Replace the SSS.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair Complete.

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 559 - Fuel System Underfueling

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes |
 | STEP 1A. Inspect for active or high inactive counts of Fault Code 482 or 2311 | Fault Code 482 or 2311 are active or have high inactive counts?
STEP 2. | Check for air in the pressure-side fuel |
 | STEP 2A. Inspect for air in the pressure-side fuel | Air in fuel?
STEP 3. | Check the front fueling actuator |
 | STEP 3A. Inspect the front fueling actuator | Fault Code 559 goes inactive?
STEP 4. | Check the injector o-rings |
 | STEP 4A. Inspect the bottom two injector o-rings on the rear bank of injectors | The o-rings are OK?
STEP 5. | Check the fuel passages in the head |
 | STEP 5A. Inspect the fuel passages in the front of the head | No leaks to the drain passage, crankcase, cylinders, or coolant system?
STEP 6. | Clear the fault codes |
 | STEP 6A. Disable the fault code | Fault Code 559 inactive?
 | STEP 6B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Inspect for active or high inactive counts of Fault Code 482 or 2311.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault codes or high inactive counts.

  • Use INSITE™ electronic service tool to check for active or high counts of inactive fault codes.

Fault Code 482 or 2311 are active or have high inactive counts?
YES | NO
No Repair | No Repair

Go to troubleshooting trees for Fault Code 482 or 2311.

Go to 2A

Guided Step 2 - Check for air in the pressure-side fuel

Guided Step 2A - Inspect for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the pressure-side fuel.

Refer to Procedure 006-003 in Section 6.

Air in fuel?
YES NO

Refer to Procedure 006-003 in Section 6.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the front fueling actuator

Guided Step 3A - Inspect the front fueling actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect the INSITE™ electronic service tool.

Action

Replace the front fueling actuator.

  • Refer to Procedure 019-110 in Section 19.
  • Use INSITE™ electronic service tool check that Fault Code 559 goes inactive.

Fault Code 559 inactive?
YES NO
No Repair

Install the original front fueling actuator. Refer to Procedure 019-110 in Section 19.

Go to 6A

Go to 4A

Guided Step 4 - Check the injector o-rings

Guided Step 4A - Inspect the bottom two injector o-rings on the rear bank of injectors.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for nicks or tears on the bottom two o-rings of the rear bank of injectors.

Refer to Procedure 006-026 Section 6.

  • Check that o-rings are in good condition.

Are o-rings damaged?
YES NO

Replace the o-rings. Refer to Procedure 006-026 Section 6.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the fuel passages in the head

Guided Step 5A - Inspect the fuel passages in the front of the head.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel drillings in the front of the cylinder head for leaks or obstructions.

Are there leaks to the drain passages, crankcase, cylinders, or coolant system?
YES NO

Correct the problem. Reference the Troubleshooting and Repair Manual, Signature&trade;/ISX/QSX15 Engines, Bulletin 3666239.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes

Guided Step 6A - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 559 is inactive.

Fault Code 559 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 584 - Starter Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code | Fault Code 584 active?
STEP 2. | Check the starter lockout relay and circuit |
 | STEP 2A. Check the starter lockout relay for an open circuit | Less than 10k ohms?
 | STEP 2B. Inspect ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the starter lockout relay signal circuit | Less than 10 ohms?
 | STEP 2D. Determine return circuit location | Return circuit wired to ECM?
 | STEP 2D-1. Check for an open circuit in the relay return circuit |
 | STEP 2E. Inspect the OEM harness ECM connector pins. | Dirty or damaged pins?
 | STEP 2F. Check for an open circuit in the relay return circuit | Less than 10 ohms?
 | STEP 2G. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
 | STEP 2H. Check for a pin to pin short circuit in the OEM power harness | Greater than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 584 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check starter lockout relay and circuit

Guided Step 2A - Check the starter lockout relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Relay continuity pin-to-pin continuity check:

  • Measure the resistance of the relay coil and check for an open circuit between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10k ohms?
YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the starter lockout relay signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Measure the resistance of the starter lockout relay SIGNAL wire between the OEM harness ECM connector and the OEM harness starter lockout relay connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Determine return circuit location.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Determine if the relay return circuit is wired to the ECM, or to block or chassis ground.

Refer to the OEM wiring diagram.

Return circuit wired to ECM?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check for an open circuit in the relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance of the starter lockout relay RETURN circuit between the relay connector and ground.

Refer to the wiring diagram for connector pin identification.

Refer to the circuit diagram or the wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the source of the failed ground connection.

Go to 2G

Go to 3A

Guided Step 2E - Inspect the OEM harness ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 2F

Guided Step 2F - Check for an open circuit in the relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

  • Measure the resistance of the starter lockout relay RETURN wire between the OEM harness ECM connector and the OEM harness starter lockout relay connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2H

Go to 3A

Guided Step 2H - Check for a pin-to-pin short circuit in the OEM power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM power harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a short circuit between the OEM harness and the OEM power harness.

  • Check for a short circuit between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM power harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 584 inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authrizd Repair Location if all the steps have been completed and checked again.

Return to the troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 585 - Starter Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit |
 | STEP 2A. Check the starter lockout relay resistance | Greater than 6 ohms?
 | STEP 2B. Check for a pin to ground short circuit in the starter lockout relay | Greater than 100k ohms?
STEP 3. | Check the OEM harness |
 | STEP 3A. Inspect ECM and OEM harness connector pins | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness | Greater than 100k ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 585 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Codes, Refer to Procedure 019-062 in Section 19..

Guided Step 2 - Check starter lockout relay and circuit

Guided Step 2A - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check for a pin to ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19..

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-360 in Section 19..

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 585 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Feb-2012


FAULT CODE 595 - Turbocharger Number 1 Speed High Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead, Part Number 3822917 female Deutsch/AMP/Cannon/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for intermittent fault condition. |
 | STEP 1A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 595 come active during engine operation?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 595 come active during engine operation?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 595 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for intermittent fault condition.

Guided Step 1A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Connect INSITE™ electronic service tool and clear inactive fault codes.
  • Start the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Use the accelerator pedal, to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

Does Fault Code 595 come active during engine operation?
YES NO
No Repair

An intermittent fault condition exists. The problem may be with the turbocharger speed sensor circuit; however, the intermittent fault condition may be due to electrical noise that is caused by other devices or faulty grounds.

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for a damaged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the connector or pigtail harness damaged?
YES NO

Repair or replace the damaged connector or turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Refer to the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor connector from the engine harness connector.

Action

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: Inspect very carefully for a pin that may not be locked into the engine harness ECM connector.

Dirty or damaged pins or connector?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM.

Action

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

NOTE: The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Refer to the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Resistance within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

Repair or replace the engine harness or connector(s).

Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM.

Action

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Refer to the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor connector to the engine harness connector.
  • Disconnect the engine harness connector from the ECM.

Action

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

Refer to the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle.

  • Use the accelerator pedal, to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

NOTE: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Does Fault Code 595 come active during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

An intermittent fault condition exists. The problem may exist in the turbocharger speed sensor circuit or it may exist with other vehicle electronic components. The problem may have been corrected when the harness connections were re-engaged.

Make sure that the ECM and chassis grounds are in good condition.

Go to 5A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 595 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 596 - Battery Voltage Monitor - High Voltage

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system |
 | STEP 1A. Inspect the battery cable and alternator cable connections | Damaged connections?
 | STEP 1B. Check the battery voltage | Normal conditions: At least (+) 12 VDC?During cranking: At least (+) 6.2 VDC?
STEP 2. | Check the charging system |
 | STEP 2A. Inspect the alternator | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 596 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the equipment battery system

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged connections?
YES NO

Repair the damaged connections.Tighten the battery connections and clean the battery terminals. Refer to the OEM service manual.

 No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.

Are the voltages at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 596 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Feb-2012


FAULT CODE 597 - Voltage Monitor - Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system |
 | STEP 1A. Inspect the battery cable and alternator connections | Any damaged connections?
 | STEP 1B. Check the battery voltage | Normal conditions: At least (+) 12 VDCDuring cranking: At least (+) 6.2 VDC?
STEP 2. | Check the alternator and power harness |
 | STEP 2A. Inspect the alternator | Alternator charging within OEM specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit | Less than 10 ohms?
 | STEP 2C. Check for a short circuit | More than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery | No damaged wires?
 | STEP 2E. Check for a short circuit | More than 100k ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 597 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the equipment battery system

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Any damaged connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Is the battery voltage at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Check the alternator and power harness

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Using a multimeter, measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness.

Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Using a multimeter, measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause a short circuit in the supply wire to the engine block.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM
  • Disconnect the positive (+) battery cable from the battery.

Action

Using a multimeter, measure the resistance between the ECM Battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 597 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Feb-2012


FAULT CODE 598 - Battery Voltage Monitor - Very Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system |
 | STEP 1A. Inspect the battery cable and alternator connections | Damaged connections?
 | STEP 1B. Check the battery voltage | Normal conditions: At least (+) 12 VDC?During cranking: At least (+) 6.2 VDC?
STEP 2. | Check the alternator and OEM harness |
 | STEP 2A. Inspect the alternator | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit | Less than 10 ohms?
 | STEP 2D. Check for a short circuit | More than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery | Damaged wires?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 598 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the equipment battery system

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.

Are the voltages at least (+) 12 VDC during normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Check the alternator and OEM harness

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the battery power connector.

Refer to the OEM troubleshooting and repair manual for location and procedure.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Measure the resistance and check for a short circuit between the ECM battery supply (+) pins and all other pins of the power harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause a short circuit at supply wire to the engine block ground.

Damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 598 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Feb-2012


FAULT CODE 649 - Engine Requires Lubricating Oil and Filter Change - Maintenance

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for Fault Code 649 | Active or inactive counts of Fault Code 649?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 649 inactive?
 | STEP 2B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 649?
YES NO

Change the lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor feature.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 649 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Feb-2012


FAULT CODE 687 - Turbocharger Speed Low - Warning Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with the INSITE™ electronic service tool. | Fault Codes 122, 123, 221, or 222 active?
STEP 2. | Check for intermittent fault condition. |
 | STEP 2A. Operate the engine and confirm that the turbocharger speed fault comes active. | Did Fault Code 687 come active during engine operation?
STEP 3. | Check for a damaged turbocharger speed sensor. |
 | STEP 3A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 3B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 3C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Is the engine harness connector damaged?
 | STEP 4B. Check the turbocharger speed signal (+) for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check the turbocharger speed signal (-) for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4E. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 5. | Check the ECM. |
 | STEP 5A. Connect all components and determine if the fault code reoccurs. | Did Fault Code 687 come active during engine operation?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 687 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with the INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check for intermittent fault condition.

Guided Step 2A - Operate the engine and confirm that the turbocharger speed fault comes active.

Conditions

  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use the accelerator pedal, to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: This step is valid even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Did Fault Code 687 come active during engine operation?
YES NO
No Repair

An intermittent fault condition exists.

Go to 3A

Refer to Procedure 019-362 in Section 19

Guided Step 3 - Check for a damaged turbocharger speed sensor.

Guided Step 3A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the connector pigtail harness damaged?
YES NO

Repair or replace the damaged connector or turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the engine harness connector damaged?
YES NO

Repair or replace the engine harness connector.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the turbocharger speed signal (+) for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the turbocharger speed SIGNAL (+) pin at the ECM connector of the engine harness and the turbocharger speed SIGNAL (+) pin at the turbocharger speed sensor connector of the engine harness.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check the turbocharger speed signal (-) for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the turbocharger speed SIGNAL (-) pin at the ECM connector of the engine harness and the turbocharger speed SIGNAL (-) pin at the turbocharger speed sensor connector of the engine harness.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short to ground in the engine harness.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed SIGNAL (-) pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM

Guided Step 5A - Connect all components and determine if the fault code reoccurs.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM.
  • Turn keyswitch ON.
  • Start the engine.

Action

Operate the engine at idle.

  • Use the accelerator pedal, to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle speed.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Did Fault Code 687 come active during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

The removal and installation of the connector corrected the fault.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive

Fault Code 687 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Troubleshoot any remaining active fault codes.

Last Modified: 05-Mar-2012


FAULT CODE 689 - Engine Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 284 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine speed sensor and circuit. |
 | STEP 2A. Inspect the engine speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Engine speed sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the engine speed sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate engine speed sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor engine speed sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™electronic service tool to read the fault codes.

Fault Code 284 active?
YES | NO
No Repair | No Repair

Fault Code 284

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine operating.

Action

With the engine running, check for an active fault code.

  • Use INSITE™electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine speed sensor and circuit.

Guided Step 2A - Inspect the engine speed sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the engine speed +5 volt SUPPLY pin to the engine speed RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool monitor mode to read the engine speed sensor.

Engine speed sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine speed +5 volt SUPPLY pin and the engine speed SIGNAL pin at the sensor connector of the engine harness.

  • Check for the appropriate ECM response.
  • Use INSITE™ electronic service tool monitor mode to read the engine speed sensor state.

Refer to the wiring diagram for connector pin identification.

Engine speed sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine.

Action

Inspect the engine speed sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

Replace the engine speed sensor.

Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine speed sensor from the engine.
  • Make sure the engine speed sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Using the ratchet drive side of the socket tool that was used to remove the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

  • Check for the appropriate ECM response
  • Use INSITE™ electronic service tool monitor mode to read the engine speed sensor state.

Engine speed sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Replace the engine speed sensor.

Refer to Procedure 019-042 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate engine speed sensor air gap.

Conditions

  • Install the engine speed sensor in the engine
  • Turn keyswitch ON.
  • Connect the engine speed sensor to the engine harness
  • Connect INSITE™ electronic service tool.

Action

Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary. Monitor the engine speed sensor state of the engine speed sensor for the following:

  • Change of state from high to low, or low to high, or the state shows triggered.

Engine speed sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Inspect the crankshaft tone wheel/gear teeth for damage or spinning. Refer to the service manual for the repair or replacement.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ elecronic control module monitor mode to read the engine speed sensor state.

Engine speed sensor state equals low?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine speed +5 volt SUPPLY pin and the engine speed SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response.
  • Use INSITE™ electronic service tool monitor mode to read the engine speed sensor state.

Refer to the wiring diagram for connector pin identification.

Engine speed sensor state equals high?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the engine speed +5 volt SUPPLY pin to the engine speed RETURN pin at the ECM port.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 691 - Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging the pin and harness, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164269 - 2-way Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 2. | Check the turbocharger compressor inlet air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor inlet air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 691 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or intermittent Fault Code Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor inlet air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor inlet air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharge compressor inlet air temperature sensor from the sensor extension harness.

Action

Inspect the sensor extension harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the sensor extension harness.

Action

Check the sensor resistance.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin and the turbocharger compressor inlet air temperature sensor RETURN pin at the turbocharger compressor inlet air temperature sensor.

Refer to the wiring diagram or circuit diagram for connector pin identification..

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the turbocharger compressor inlet air temperature sensor.

Refer to Procedure 019-395 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor inlet air temperature sensor to the sensor extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger compressor inlet air temperature sensor SIGNAL pin and the turbocharger compressor inlet air temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

See the wiring diagram or circuit diagram for connector pin identification.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the sensor extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor inlet air temperature sensor RETURN pin and the sensor extension harness temperature turbocharger compressor inlet air sensor connector RETURN pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness or sensor extension harness.

Repair or replace the engine harness or sensor extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the sensor extension harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor inlet air temperature sensor SIGNAL pin and the sensor extension harness turbocharger compressor inlet air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness or sensor extension harness.

Repair or replace the engine harness or the sensor extension harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the sensor extension harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 691 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been competed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase inactive fault codes

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 692 - Turbocharger Number 1 Compressor Inlet Air Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of damaging the pin and harness, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 2. | Check the turbocharger compressor inlet air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor inlet air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 692 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or intermittent Fault Code Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the turbocharger compressor inlet air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor inlet air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the sensor extension harness.

Action

Inspect the sensor extension harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the sensor extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor inlet air temperature sensor to the sensor extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

A defective sensor has been detected.

Replace the turbocharger compressor inlet air temperature sensor.

Refer to Procedure 019-395 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the sensor extension harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness or sensor extension harness.

Repair or replace the engine harness or sensor extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the sensor extension harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness or the sensor extension harness.

Repair or replace the engine harness or the sensor extension harness.

Refer to Procedure 019-043.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 692 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify fault code is inactive

Fault Code 692 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been competed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 731 - Engine Speed Sensor and Camshaft Position Sensor - Mechanical Misalignment Between Camshaft and Crankshaft Sensors

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and speed/position sensors. |
 | STEP 1A. Inspect the engine speed and position sensors for damage. | Any damage present?
 | STEP 1B. Inspect the tone wheels for any damage. | Damage found or crankshaft tone wheel loose?
STEP 2. | Inspect the engine and vehicle grounding. |
 | STEP 2A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 3. | Check for correct engine static timing. |
 | STEP 3A. Check static timing. | Does the proper wedge fit easily between the flat on the injector camshaft and the groove in the cylinder head?
 | STEP 3B. Inspect the gear train. | Any damage present?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 4B. Clear the fault codes. | All faults cleared?

Guided Step 1 - Inspect the tone wheels and speed/position sensors.

Guided Step 1A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and position sensors for damage.

If either sensor has physical damage, do not replace the sensor until the source of the damage is identified.

The locking tab on the sensor must point towards the capscrew hole on the engine brackets.

Any damage present?
YES NO

Repair or replace the speed or position sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for damage.

  • Use a screwdriver to gently pry on the crankshaft tone wheel.
  • Verify the tone wheel is not loose.

Damage found or crankshaft tone wheel loose?
YES NO

Replace the crankshaft or injector camshaft, whichever has malfunctioned. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 002-025 in Section 2.

No Repair

Go to 4A

Go to 2A

Guided Step 2 - Inspect the engine and vehicle grounding.

Guided Step 2A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 3A

Go to 4A

Guided Step 3 - Check for correct engine static timing.

Guided Step 3A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Rotate the engine to the insert pin mark on the damper.
  • Install the injector camshaft timing wedge.

Action

Inspect the engine static timing.

Does the proper wedge fit easily between the flat on the injector camshaft and the groove in the cylinder head?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the upper and lower front gear covers.

Remove the upper gear cover. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 001-079 in Section 1.

Remove the lower gear cover. Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 001-080 in Section 1.

  • Inspect the gear train for damage that would lead to slippage.

Any damage present?
YES NO

Reference the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239, for repair procedure.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify fault code is inactive

Fault Code 731 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 27-Feb-2012


FAULT CODE 778 - Camshaft Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 778 active?
STEP 2. | Check the camshaft position sensor and circuit. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | +4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Camshaft position sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the camshaft position sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate camshaft position sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor Engine speed sensor state/camshaft position sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | +4.75 to 5.25 VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 778 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Using INSITE™, read the fault codes.

Fault Code 187 or 227 active?
YES | NO
No Repair | No Repair

Fault Code 187 or 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running.

Action

With the engine running, check for an active fault code.

  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the camshaft position sensor and circuit.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the camshaft position +5 volt SUPPLY pin to the camshaft position RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

+4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Read the camshaft position sensor state using the INSITE™ electronic service tool monitor mode.

Camshaft position sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the camshaft position +5 volt SUPPLY pin and the camshaft position SIGNAL pin at the sensor connector of the engine harness.

  • Check for the appropriate ECM response.
  • Read the camshaft position sensor state using the INSITE™ monitor mode.

Refer to the wiring diagram for connector pin identification.

Camshaft position sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the camshaft position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine.

Action

Inspect the camshaft position sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

Replace the camshaft position sensor. Refer to Procedure 019-363 in Section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the camshaft position sensor from the engine.
  • Ensure the camshaft position sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Using the ratchet drive side of the socket tool that was used to remove the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Inspect for the following:

  • Check for the appropriate ECM response
  • Read the camshaft position sensor state using the INSITE™ electronic service tool monitor mode.

Camshaft position sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Replace the camshaft position sensor. Refer to Procedure 019-363 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Install the camshaft position sensor in the engine.
  • Connect the camshaft position sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary. Monitor the camshaft position sensor state of the camshaft position sensor for the following:

  • Change of state from high to low, or low to high, or the state shows triggered.

Camshaft position sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Inspect the camshaft tone wheel/gear teeth for damage or spinning.

Refer to the Troubleshooting and Repair Manual, Signature™/ISX/QSX Engines, Bulletin 3666239.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Read the camshaft position sensor state using the INSITE™ electronic service tool monitor mode.

Camshaft position sensor state equals low?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the camshaft position +5 volt SUPPLY pin and the camshaft position SIGNAL pin at the ECM port.
  • Read the camshaft position sensor state using the INSITE™ monitor mode.

Refer to the wiring diagram for connector pin identification.

Camshaft position sensor state equals high?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the camshaft position +5 volt SUPPLY pin to the camshaft position RETURN pin at the ECM port.

Refer to the wiring diagram for connector pin identification.

+4.75 to 5.25 VDC?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive

Fault Code 778 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 778 - Camshaft Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the adaptive cruise control hardware |
 | STEP 1A. Check for installed adaptive cruise control hardware | Adaptive cruise control hardware installed on vehicle?
STEP 2. | Check SAE J1939 communication |
 | STEP 2A. Check for ECM communication with INSITE™ | Does INSITE™ communicate with ECM?
 | STEP 2B. Inspect the OEM harness and ECM connector pins | Dirty or damaged pins?
 | STEP 2C. Check ECM communication with the ECM bench calibration harness | INSITE™ communicates with ECM?
STEP 3. | Clear the fault code |
 | STEP 3A. Disable the fault code | Fault Code 784 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the adaptive cruise control hardware

Guided Step 1A - Check for install adaptive cruise control hardware.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle for installed adaptive cruise control hardware.

Adaptive cruise control hardware installed on vehicle?
YES NO
No Repair

Use INSITE™ electronic service tool to disable the Adaptive Cruise feature.

Go to 2A

Go to 3A

Guided Step 2 - Check SAE J1939 communications

Guided Step 2A - Check for ECM communication with INSITE™

Conditions

  • Turn keyswitch ON.
  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool, attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool.
  • Select INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

Refer to the OEM service manual for information on troubleshooting the adaptive cruise control unit and the vehicle SAE J1939 network.

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damage harness connector or pins if possible.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter to the ECM bench calibration harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Using INSITE™, attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM with an INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM SAE J1939 data link circuit is functioning properly.

No Repair

Refer to the OEM service manual for troubleshooting the vehicle SAE J1939 circuit and devices.

Refer to the Communication Error - Electronic Service Tool or Control Device Symptom Troubleshooting Tree

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify fault code is inactive

Fault Code 784 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Return to the troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 28-Feb-2012


FAULT CODE 951 - Cylinder Power Imbalance

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for Fault Code 951 | Active or inactive counts of Fault Code 951?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for Fault Code 951.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 951?
YES NO

Check fuel quality. Check for air being ingested into the fuel. It is normal to have an inactive Fault Code 951 after a service procedure introduced air into the fuel system, such as a filter change. Perform the Cylinder Performance Test outlined in guided step 5B in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Reference the Engine Performance Troubleshooting Tree in the Signature™, ISX, and QSX15 Service Maual, Bulletin 3666239.

No Repair

Repair complete

Repair complete

Last Modified: 16-Oct-2012


FAULT CODE 1119 - Engine Coolant Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for Fault Code 1119. | Active or inactive counts of Fault Code 1119?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for Fault Code 1119.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1119.

Use INSITE™ electronic service tool to read the fault code.

Active or inactive counts of Fault Code 1119?
YES | NO
No Repair | No Repair

Reference the Engine Coolant Temperature Above Normal - Gradual Overheat and Sudden Overheat symptom trees in the Signature, ISX, and QSX15 Service Manual, Bulletin 3666239.

Repair complete

Last Modified: 28-Feb-2012


FAULT CODE 1228 - EGR Valve Position Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Other active or inactive fault codes?
 | STEP 1B. Check for Fault Code 1228. | Active or inactive counts of Fault Code 1228?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Code 1228 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Other active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other fault codes

Go to 1B

Guided Step 1B - Check for Fault Code 1228.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1228?
YES NO

Replace the EGR position sensor. Refer to Procedure 019-372 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1228 is inactive.

Fault Code 1228 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 1943 - Ambient Air Density - Data Valid But Below Normal Operational Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 221 or 249 inactive?
 | STEP 1C. Check ECM calibration software phase. |
 | STEP 1D. Check the barometric pressure sensor reading. | Is the barometric pressure reading ± 25 mm-Hg [1.0 in-Hg] from the value in the table?
 | STEP 1E. Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 1943 snapshot data. | Are the values for the turbocharger compressor inlet temperature greater than 14° C [25° F] above the ambient air temperature or turbocharger compressor outlet temperature (calculated) above 227° C [440° F]?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1943 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 221 or 249 inactive?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 221 and/or 249.

Go to 1C

Guided Step 1C - Check ECM Calibration Software Phase.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check ECM Calibration Software Phase

  • Check the calibration software phase.
  • Use INSITE™ electronic service tool to read the calibration software phase under the “Calibration Information” section of the “System ID and Dataplate” “Features and Parameters”.
  • ISX Engines with CM870 built in and after January 2004 require software phase 06050402 or greater from the February 2007 INCAL™ DVD or newer.
  • ISX Engines with CM870 built before January 2004 require software phase 05050000 or greater from the April 2007 INCAL™ DVD or newer.

Does the ECM have the proper calibration software phase?
YES NO
No Repair

Calibrate the ECM, use the INCAL™ DVD with the proper calibration software phase. Refer to Procedure 019-132.

Go to 1D

Go to 2A

Guided Step 1D - Check the barometric pressure sensor reading.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool, to read value for the barometric pressure.

Refer to Procedure For the barometric pressure at altitude specifications, 018-028.

Is the barometric pressure reading ± 25 mm-Hg [1.0 in-Hg] from the value in the table?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004.

Go to 1E

Go to 2A

Guided Step 1E - Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 1943 snapshot data.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Expand and read the last occurrence of Fault Code 1943 snapshot data

  • Use INSITE™ electronic service tool to read the fault codes snapshot data.
  • Check the values for the parameters: turbocharger compressor inlet temperature and turbocharger compressor outlet temperature.

Are the values for the turbocharger compressor inlet temperature greater than 14° C [25° F] above the ambient air temperature or turbocharger compressor outlet temperature (calculated) above 227° C [440° F]?

YES NO

No Repair - All engine causes have been eliminated.

 No Repair

Contact the OEM to review the cooling/air handling package.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1943 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location, if all steps have been completed and checked a second time.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 2271 - EGR Valve Position Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2271 active?
STEP 2. | Check the EGR valve position sensor and circuit. |
 | STEP 2A. Inspect the EGR valve position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2272 active and Fault Code 2271 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Check sensor supply voltage and return circuit at EGR valve extension harness. |
 | STEP 2C-2. Check sensor supply voltage and return circuit at engine control module. |
STEP 3. | Check the EGR valve extension harness. |
 | STEP 3A. Inspect EGR valve extension harness and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the system response at the EGR valve extension harness. | Fault Code 2272 active and Fault Code 2271 inactive?
 | STEP 3C. Check the engine control module response. | Fault Code 2272 active and Fault Code 2271 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code | Fault Code 2271 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshooting tree for Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve position sensor and circuit

Guided Step 2A - Inspect the EGR valve position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the EGR valve extension harness.

Action

Inspect the EGR valve extension harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness.
  • Replace the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the EGR valve extension harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active and Fault Code 2271 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the EGR valve extension harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the EGR valve position +5 volt SUPPLY pin to the EGR valve position RETURN pin at the sensor connector of the EGR valve extension harness.

Use the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

Replace the EGR valve assembly.

Refer to Procedure 019-372 in Section 19.

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check sensor supply voltage and return circuit at EGR valve extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the EGR valve position +5 volt SUPPLY pin to the EGR valve position RETURN pin at the EGR valve extension harness connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-359 in Section 19.

tion.

4.75 to 5.25-VDC?
YES NO

Repair or replace the EGR valve extension harness.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check sensor supply voltage and return circuit at engine control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module.
  • Turn keyswitch ON.

Action

Measure the voltage from the EGR valve position +5 volt SUPPLY pin to the EGR valve position RETURN pin at the engine control module port.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the EGR valve extension harness

Guided Step 3A - Inspect EGR valve extension harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.

Action

Inspect the EGR valve extension harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the engine control module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness.
  • Repalce the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the system response at the EGR valve extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active and Fault Code 2271 inactive?
YES NO

Repair or replace the EGR valve extension harness.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate engine control module response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes .

Fault Code 2272 active and Fault Code 2271 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2271 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Return to troubleshooting steps.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-May-2012


FAULT CODE 2272 - Exhaust Gas Recirculation (EGR) Valve Position Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2272 active?
 | STEP 1C. Check for related fault codes. | Fault Codes 2348, 2349, 2351, 2352, 2353, or 2357 active or inactive?
STEP 2. | Check the EGR valve position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR valve position sensor supply and return circuit at the engine harness. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2272 inactive and Fault Code 2271 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2272 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Troubleshoot Fault Code 187.

 No Repair

See troubleshooting tree for Fault Code 187

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES | NO
No Repair | No Repair

Go to 1C

Use the following procedure for troubleshooting an Inactive or Intermittent Fault Code.
Refer to Procedure 019-362 in Section 19.

Guided Step 1C - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2348, 2349, 2351, 2352, 2353, or 2357 active or inactive?
YES NO

Replace the EGR valve assembly.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the EGR valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the EGR valve position sensor supply and return circuit at the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply and return circuit at the engine harness.

  • Measure the voltage between the EGR valve position +5-VDC SUPPLY pin and the EGR valve position RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the EGR valve position +5-VDC SUPPLY pin and the EGR valve position SIGNAL pin at the sensor connector of the engine harness.
  • Use INSITE™ electronic service tool, to read the fault code to make sure the fault code goes inactive.

Use the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-359 in Section 19.

Fault Code 2272 inactive and Fault Code 2271 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve position sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

A damaged sensor has been detected.

Replace the EGR valve assembly.

Refer to Procedure 019-372 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM (ECM) and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the EGR position +5-VDC SUPPLY pin and the EGR position RETURN pin at the ECM port.

Refer to the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine or EGR valve extension harness.

Repair or replace the appropriate harness.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the EGR valve position +5-VDC SUPPLY pin and the EGR valve position SIGNAL pin at the ECM port.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool, to read the fault code.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 2272 inactive and Fault Code 2271 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine or EGR valve extension harness.

Repair or replace the appropriate harness.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Oct-2012


FAULT CODE 2273 - EGR Valve Differential Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2273 active?
STEP 2. | Check the EGR differential pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR differential pressure tubes for leaks. | Exhaust leaks at pressure tubes?
 | STEP 2B. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the circuit response. | Fault Code 2274 active and Fault Code 2273 inactive?
 | STEP 2D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2E. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2274 active and Fault Code 2273 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2273 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 2273 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362

Guided Step 2 - Check the EGR differential pressure sensor and circuit

Guided Step 2A - Inspect the EGR differential pressure tubes for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for signs of exhaust leaks at the EGR differential pressure tubes.

Exhaust leaks at pressure tubes?
YES NO

Repair the exhaust leaks at the pressure tubes.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the EGR differential pressure +5 volt SUPPLY pin to the EGR differential pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the EGR differential pressure +5 volt SUPPLY pin to the EGR differential pressure RETURN pin at the ECM port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2273 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3164597 - female Framatome™ test lead, Part Number 3822917 - female Deutsch™ /AMP™ /Metri-Pack™.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2274 active?
STEP 2. | Check the EGR differential pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR differential pressure tubes for leaks. | Exhaust leaks at pressure tubes?
 | STEP 2B. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the circuit response. | Fault Code 2273 active and Fault Code 2274 inactive?
 | STEP 2E. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2F. Check the ECM response. | Fault Code 2273 active and Fault Code 2274 inactive?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2273 active and Fault Code 2274 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2274 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR differential pressure sensor and circuit.

Guided Step 2A - Inspect the EGR differential pressure tubes for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for signs of exhaust leaks at the EGR differential pressure tubes.

Exhaust leaks at pressure tubes?
YES NO

Repair the exhaust leaks at the pressure tubes.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM, harness, or replace the EGR differential pressure sensor, whichever has the damaged pin.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure Repair the engine harness. 019-220 in Section 19.
  • Refer to Procedure Replace the engine harness. 019-043 in Section 19.

Replace the EGR differential pressure sensor.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the EGR differential pressure +5 volt SUPPLY pin to the EGR differential pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR differential pressure +5 volt SUPPLY pin and the EGR differential pressure SIGNAL pin at the sensor connector of the engine harness.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 2273 active and Fault Code 2274 inactive?
YES NO

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, OEM, harness, or replace the ECM, whichever has the damaged pin.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure Replace the engine harness. 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 2F

Guided Step 2F - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR differential pressure +5 volt SUPPLY pin and the EGR differential pressure SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 2273 active and Fault Code 2274 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, OEM, harness, or replace the ECM, whichever has the damaged pin.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure Replace the engine harness. 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR differential pressure +5 volt supply pin and EGR differential pressure SIGNAL pin at the ECM port.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 2273 active and Fault Code 2274 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™electronic service tool to verify the fault code is inactive.

Fault Code 2274 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 2277 - Variable Geometry Turbocharger Output Device Driver - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2277 active?
STEP 2. | Check the turbocharger control valve and circuit. |
 | STEP 2A. Inspect the turbocharger control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the turbocharger control valve. | Less than 10 ohms?
 | STEP 2C. Check the turbocharger control valve diagnostic supply voltage, supply line and return circuit. | Greater than 5.0 VDC?
 | STEP 2D. Check for an open circuit in the turbocharger control valve return circuit. | Less than 10 ohms?
 | STEP 2E. Check the fault codes and verify valve condition. | Fault Code 2277 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM turbocharger control valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2277 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2277 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger control valve and circuit.

Guided Step 2A - Inspect the turbocharger control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Inspect the engine harness and turbocharger control valve connector pins for the following:

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the turbocharger control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for pin-to-pin actuator continuity.

  • Measure the resistance and check for an open circuit between the turbocharger control valve SIGNAL pin and the turbocharger control valve RETURN pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the turbocharger control valve diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the turbocharger control valve SIGNAL pin and the turbocharger control valve RETURN pin at the engine harness turbocharger control valve connector.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the turbocharger control valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for pin-to-pin connector continuity in the harness connector.

  • Measure the resistance between the engine harness turbocharger control valve RETURN pin and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

There is an open circuit between the turbocharger control valve engine harness connector and the engine block ground stud.

Check the engine block ground stud connection. Clean and tighten, if necessary.

Clean the connector and pins.

Repair or replace the engine harness, connector, or pins if necessary.

Go to 2E

Go to 4A

Guided Step 2E - Check the fault codes and verify valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger control valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2277 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM turbocharger control valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage between the turbocharger control valve SIGNAL pin at the ECM port to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5.0 VDC?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for pin-to-pin connector continuity in the harness connector.

  • Measure the resistance of the turbocharger control valve SIGNAL pin and the engine harness turbocharger control valve connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for a pin-to-pin short circuit in the connector.

  • Measure the resistance and check for a short circuit between the turbocharger control valve SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2277 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Mar-2012


FAULT CODE 2278 - Turbocharger Control Valve Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2278 active?
STEP 2. | Check the turbocharger control valve and circuit. |
 | STEP 2A. Inspect the turbocharger control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to ground short circuit in the turbocharger control valve. | Greater than 100k ohms?
 | STEP 2C. Check for an internal short in the turbocharger control valve. | Greater than 3 ohms?
 | STEP 2D. Check the turbocharger control valve diagnostic supply voltage and supply line. | Greater than 5.0 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM turbocharger control valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2278 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2278 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger control valve and circuit.

Guided Step 2A - Inspect the turbocharger control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Inspect the engine harness and turbocharger control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin to ground short circuit in the turbocharger control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following turbocharger control valve connector pin and ground:

  • Turbocharger control valve SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an internal short in the turbocharger control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for low internal resistance of the turbocharger control valve.

  • Using a multimeter, measure the resistance between the SIGNAL and RETURN pin of the turbocharger control valve connector.

Refer to the wiring diagram or circuit diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3 ohms?
YES NO
No Repair

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the turbocharger control valve diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the turbocharger control valve SIGNAL pin and the turbocharger control valve RETURN pin at the engine harness turbocharger control valve connector.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM turbocharger control valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage between the turbocharger control valve SIGNAL pin at the ECM port to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and ground:

  • Turbocharger control valve SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and all other pins in the engine harness ECM connector:

  • Turbocharger control valve SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive

Fault Code 2278 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Mar-2012


FAULT CODE 2311 - Front Fueling Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator |
 | STEP 1A. Inspect the fueling actuator and connector pins | Dirty or damaged pins?
 | STEP 1B. Check the fault codes | Fault Code 2311 inactive?
 | STEP 1C. Check the fueling actuator resistance | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground | More than 100k ohms?
STEP 2. | Check the engine harness |
 | STEP 2A. Inspect the ECM and engine harness connector pins | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness | More than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes | Fault Code 2311 inactive?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 2311 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fueling actuator

Guided Step 1A - Inspect the fueling actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Inspect the engine harness and fueling actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the fueling actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the fueling actuator.

  • Measure the resistance between the front fueling actuator (+) pin and the front fueling actuator (-) pin of the front fueling actuator.

NOTE: Since the actuator resistance is normally very low, it's necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the fueling actuator.

Refer to Procedure 019-110 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Check for a short to ground in the fueling actuator.

Measure the resistance between the following front fueling actuator pins and engine block ground:

  • Front fueling actuator (+) pin
  • Front fueling actuator (-) pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the fueling actuator.

Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the fueling actuator.
  • Disconnect the engine harness from the ECM.

Action

Measure the resistance between the front fueling actuator (+) pin and the front fueling actuator (-) pin at the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Front fueling actuator (+) pin
  • Front fueling actuator (-) pin

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Front fueling actuator (+) pin
  • Front fueling actuator (-) pin.

Refer to the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive

Fault Code 2311 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Return to troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Mar-2012


FAULT CODE 2312 - Front Timing Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator |
 | STEP 1A. Inspect the timing actuator and connector pins | Dirty or damaged pins?
 | STEP 1B. Check the fault codes | Fault Code 2312 inactive?
 | STEP 1C. Check the timing actuator resistance | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground | More than 100k ohms?
STEP 2. | Check the engine harness |
 | STEP 2A. Inspect the ECM and engine harness connector pins | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness | More than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes | Fault Code 2312 inactive?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 2312 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the timing actuator

Guided Step 1A - Inspect the timing actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Inspect the engine harness and timing actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2312 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the timing actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the timing actuator.

  • Measure the resistance between the front timing actuator (+) pin and the front timing actuator (-) pin of the front timing actuator.

NOTE: Since the actuator resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the timing actuator.

Refer to Procedure 019-111 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Check for a short to ground in the timing actuator.

Measure the resistance between the following front timing actuator pins and engine block ground:

  • Front timing actuator (+) pin
  • Front timing actuator (-) pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the timing actuator.

Refer to Procedure 019-111 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the timing actuator.
  • Disconnect the engine harness from the ECM.

Action

Measure the resistance between the front timing actuator (+) pin and the front timing actuator (-) pin at the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Front timing actuator (+) pin
  • Front timing actuator (-) pin

Use the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Front timing actuator (+) pin
  • Front timing actuator (-) pin.

Refer to the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2312 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Repair complete

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2312 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Return to troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Mar-2012


FAULT CODE 2313 - Rear Fueling Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator |
 | STEP 1A. Inspect the fueling actuator and connector pins | Dirty or damaged pins?
 | STEP 1B. Check the fault codes | Fault Code 2313 inactive?
 | STEP 1C. Check the fueling actuator resistance | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground | More than 100k ohms?
STEP 2. | Check the engine harness |
 | STEP 2A. Inspect the ECM and engine harness connector pins | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness | More than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes | Fault Code 2313 inactive?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 2313 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fueling actuator

Guided Step 1A - Inspect the fueling actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Inspect the engine harness and fueling actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2313 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the fueling actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the fueling actuator.

  • Measure the resistance between the rear fueling actuator (+) pin and the rear fueling actuator (-) pin of the rear fueling actuator.

NOTE: Since the actuator resistance is normally very low, it's necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the fueling actuator.

Refer to Procedure 019-110 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Check for a short to ground in the fueling actuator.

Measure the resistance between the following rear fueling actuator pins and engine block ground:

  • Rear fueling actuator (+) pin
  • Rear fueling actuator (-) pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the fueling actuator.

Refer to Procedure 019-110 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the fueling actuator.
  • Disconnect the engine harness from the ECM.

Action

Measure the resistance between the rear fueling actuator (+) pin and the rear fueling actuator (-) pin at the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Rear fueling actuator (+) pin
  • Rear fueling actuator (-) pin

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Rear fueling actuator (+) pin
  • Rear fueling actuator (-) pin.

Refer to the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2313 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Repair complete

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2313 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2314 - Rear Timing Actuator Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing actuator |
 | STEP 1A. Inspect the timing actuator and connector pins | Dirty or damaged pins?
 | STEP 1B. Check the fault codes | Fault Code 2314 inactive?
 | STEP 1C. Check the timing actuator resistance | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground | More than 100k ohms?
STEP 2. | Check the engine harness |
 | STEP 2A. Inspect the ECM and engine harness connector pins | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness | More than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes | Fault Code 2314 inactive?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 2314 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the timing actuator

Guided Step 1A - Inspect the timing actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Inspect the engine harness and timing actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2314 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the timing actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the timing actuator.

  • Measure the resistance between the rear timing actuator (+) pin and the rear timing actuator (-) pin of the rear timing actuator.

NOTE: Since the actuator resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the timing actuator.

Refer to Procedure 019-111 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.

Action

Check for a short to ground in the timing actuator.

Measure the resistance between the following rear timing actuator pins and engine block ground:

  • Rear timing actuator (+) pin
  • Rear timing actuator (-) pin.

Refer to the wiring diagram or circuit diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the timing actuator.

Refer to Procedure 019-111 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the timing actuator.
  • Disconnect the engine harness from the ECM.

Action

Measure the resistance between the rear timing actuator (+) pin and the rear timing actuator (-) pin at the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Rear timing actuator (+) pin
  • Rear timing actuator (-) pin

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage in the engine harness.

Conditions

  • Disconnect the engine harness from the timing actuator.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Rear timing actuator (+) pin
  • Rear timing actuator (-) pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2314 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Repair Complete

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2314 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Return to troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2321 - Engine Speed/Position Sensor Number 1 - Engine Speed/Position Glitch Detect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 is active or has high number of inactive counts?
STEP 2. | Check the engine speed sensor circuit. |
 | STEP 2A. Inspect the engine speed sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the engine speed sensor circuit at the ECM engine harness connector. | Loose, dirty, or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Road test the vehicle. |
 | STEP 3A. Road test the vehicle to determine if the fault condition exists. | Does Fault Code 2321 become active during engine operation?
 | STEP 3B. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 2321 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ to read the fault codes.

NOTE: If Fault Code 689 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the engine speed sensor.

Fault Code 689 is active or has high number of inactive counts?
YES | NO
No Repair | No Repair

Refer to Fault Code 689 troubleshooting steps

Go to 2A

Guided Step 2 - Check the engine speed sensor circuit.

Guided Step 2A - Inspect the engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Closely inspect the engine harness near the engine speed sensor.

  • Look for damage on the wiring harness insulation allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the engine speed sensor circuit at the ECM engine harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Loose, dirty, or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for damage on the wiring harness insulation allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Road test the vehicle.

Guided Step 3A - Road test the vehicle to determine if the fault condition exists.

Conditions

  • Reconnect all components.
  • Connect the INSITE™ electronic service tool.
  • Engine running.

Action

Accelerate the engine several times.

  • Road test the vehicle.
  • Use INSITE™ to read the fault codes.

Does Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2321 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins™ Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2346 - Turbocharger Turbine Inlet Temperature (Calculated) - Data Above Normal Operational Range - Least Severe Level.

Associated Procedures

Cautions and Warnings

CAUTION

If the engine is equipped only with a turbocharger air control valve mounted under the air compressor do not install a Compuchek™ fitting directly into the valve body. Damage to the air control valve will result.
CAUTION

If the engine is equipped only with a Turbocharger air control valve mounted under the air compressor, do not install a Compuchek™ fitting directly into the valve body. Damage to the air control valve will result.
CAUTION

If the engine is equipped only with a turbocharger air control valve mounted under the air compressor do not install a Compuchek™ fitting directly into the valve body. Damage to the air control valve will result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 2973 inactive?
 | STEP 1C. Check ECM calibration software phase. |
 | STEP 1D. Check the User Fueling State values in the Fault Code 2346 snapshot data. | Is the value for the User Fueling State set to Turbocharger Fuel Control State in the last occurrence of the fault code?
 | STEP 1D-1. Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 2346 snapshot data. |
 | STEP 1D-2. Check the Exhaust Temperature (Calculated) in the Fault Code 2346 snapshot data. |
 | STEP 1D-3. Check the Turbocharger Control Valve Command, Turbocharger Speed, and Exhaust Manifold Pressure values in the Fault Code 2346 snapshot data. |
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the charge air cooler, clamps, hoses, and piping. (Turbocharger Fuel Control state Not present) | Air leak present or clamps loose?
 | STEP 2B. Inspect turbocharger compressor and turbine blades. | Damage or wear found on turbocharger blades?
 | STEP 2C. Check the variable geometry actuator rod for correct travel. | Does the turbocharger actuator rod extend between 10 and 12 mm [0.394 and 0.472 in]?
 | STEP 2C-1. Check for air leaks and inspect air lines. |
 | STEP 2C-2. Check for air pressure at the turbocharger control valve. |
 | STEP 2C-3. Check for correct turbocharger actuator travel. |
 | STEP 2C-4. Check for air pressure at the turbocharger control shutoff valve outlet. |
 | STEP 2C-5. Check for air pressure at the turbocharger control shutoff valve inlet. |
 | STEP 2C-6. Check for a plugged turbocharger control shutoff valve filter. |
 | STEP 2D. Perform INSITE™ electronic service tool Turbocharger Operational Test. | Does the Turbocharger Operation Test pass?
 | STEP 2E. Check the charge air cooler, clamps, hoses, and piping. (Turbocharger Fuel Control state present). | Air leak present or clamps loose?
 | STEP 2F. Check the air intake system sealing surface between the air filter and the hood air plenum. | Excessive wear or ineffective sealing?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2346 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2973 inactive?
YES | NO
No Repair | No Repair

Fault Code 2973

Go to 1C

Guided Step 1C - Check ECM Calibration Software Phase.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check ECM Calibration Software Phase

  • Check the calibration software phase.
  • Use INSITE™ electronic service tool to read the calibration software phase under the Calibration Information section of the System ID and Dataplate Features and Parameters.
  • ISX Engines with CM870 built in and after January 2004 require software phase 06050402 or greater from the February 2007 INCAL™ Calibration DVD-ROM or newer.
  • ISX Engines with CM870 built before January 2004 require software phase 05050000 or greater from the April 2007 INCAL™ Calibration DVD-ROM or newer.

Does the ECM have the proper calibration software phase?
YES NO
No Repair

Use the INCAL™ Calibration DVD-ROM with the proper calibration software phase to calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check the User Fuel State values in the Fault Code 2346 snapshot data.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Expand and read Fault Code 2346 Snapshot Data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data for the last occurrence of the fault code.
  • Check the values for the User Fueling State parameter.

Is the value for the User Fueling State set to Turbocharger Fuel Control State in the last occurrence of the fault code?
YES | NO
No Repair | No Repair

Go to 1D-1

Go to 1D-3

Guided Step 1D-1 - Check the turbocharger compressor inlet and turbocharger compressor outlet temperature in the Fault Code 2346 snapshot data.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Expand and read Fault Code 2346 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data
  • Check the values for the parameters: Turbocharger Compressor Inlet Temperature and Turbocharger Compressor Outlet Temperature.

Are the values for the Turbocharger Compressor Inlet Temperature greater than 14°C [25°F] above the Ambient Air Temperature or Turbocharger Compressor Outlet Temperature (Calculated) above 227°C [440°F]?

YES NO

No Repair. All engine causes have been eliminated.

 No Repair

Go to 2F

Go to 1D-2

Guided Step 1D-2 - Check the Exhaust Temperature (Calculated) in the Fault Code 2346 snapshot data.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Expand and read Fault Code 2346 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.
  • Check the values for the parameter: Exhaust Temperature (Calculated).

Is the value for Exhaust Temperature (Calculated) above 746°C [1375°F]?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 1D-3 - Check the Turbocharger Control Valve Command, Turbocharger Speed, and Exhaust Manifold Pressure values in the Fault Code 2346 snapshot data.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Expand and read Fault Code 2346 snapshot data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.
  • Check the values for the parameters: Turbocharger control Valve Command, Turbocharger Speed, Exhaust Manifold Pressure.

Are the values for Turbocharger Control Valve Command greater than 65 percent, Turbocharger Speed less than 60,000 rpm, and Exhaust Manifold Pressure less than 1651 mm-Hg [65 in-Hg]?

YES | NO
No Repair | No Repair

Go to 2C

Go to 2A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the charge air cooler, clamps, hoses, and piping. (Turbocharger Fuel Control State Not Present)

Conditions

  • Turn keyswitch OFF.

Action

Check the charge air cooler, hoses, and piping for leaks.

Check the clamps for correct torque.

Air leak present or clamps loose?
YES NO

Repair air leak.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect turbocharger compressor and turbine blades.

Conditions

  • Engine OFF.
  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

For Signature™, ISX, and QSX15 engines, use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3A

Go to 2C

CAUTION

If the engine is equipped only with a Turbocharger air control valve mounted under the air compressor, do not install a Compuchek™ fitting directly into the valve body. Damage to the air control valve will result.
CAUTION

If the engine is equipped only with a turbocharger air control valve mounted under the air compressor do not install a Compuchek™ fitting directly into the valve body. Damage to the air control valve will result.
Guided Step 2C - Check the variable geometry actuator rod for correct travel.

Conditions

  • Engine at operating temperature.
  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to start the Turbocharger Actuator Test.

  • Adjust the delay timer in the Turbocharger Actuator Test so that the rod movement can be observed.
  • Select the Retract Actuator position with INSITE™ electronic service tool.
  • Mark or scribe the VG actuator rod at the base of the actuator.
  • Select the Extend Actuator position with INSITE™ electronic service tool.
  • Measure the rod travel by measuring the distance from the base of the turbocharger actuator to the scribe mark.
  • Use a straight edge steel ruler.
  • Retract and extend the turbocharger actuator at least 10 times.

Note: The turbocharger actuator moves quickly and crisply. If the actuator rod movement is slow, there could be a problem with the air supply or mechanical problems with the variable geometry turbocharger assembly.

Does the turbocharger actuator rod extend between 10 and 12 mm [0.394 and 0.472 in]?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for air leaks and inspect air lines.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position. Listen for air leaks at the following components:

  • Turbocharger control valve
  • Turbocharger control shutoff valve inlet connection
  • Turbocharger control shutoff valve outlet connection
  • Turbocharger control valve inlet connection
  • Turbocharger control valve outlet connection
  • Turbocharger actuator inlet connection
  • Turbocharger actuator
  • All air lines including OEM supply line to turbocharger control shutoff valve, turbocharger control shutoff valve to turbocharger control valve, and turbocharger control valve to turbocharger actuator.

Air leaks found in the system?
YES NO

Repair air leaks.

 No Repair

Go to 3A

Go to 2C-2

CAUTION

If the engine is equipped only with a turbocharger air control valve mounted under the air compressor do not install a Compuchek™ fitting directly into the valve body. Damage to the air control valve will result.
Guided Step 2C-2 - Check for air pressure at the turbocharger control valve.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Remove the air line connection at the outlet of the turbocharger air control valve.

  • If the engine is equipped with a turbocharger air control valve and turbocharger air shutoff valve, remove the air line connection at the outlet of the turbocharger air control valve. Install an M12 Compuchek™ fitting at the outlet of the turbocharger control valve. Install an air pressure gauge that is capable of reading at least 1034 kPa [150 psi].
  • If the engine is equipped with a turbocharger air control valve only, install a pressure gauge at the end of the turbocharger actuator air hose. Use INSITE™ electronic service tool, to perform the Turbocharger Actuator Test. Select the Extend Actuator position.

Is vehicle air tank pressure present at the turbocharger control valve outlet?
YES | NO
No Repair | No Repair

Go to 2C-3

Go to 2C-4

Guided Step 2C-3 - Check for correct turbocharger actuator travel.

Conditions

  • Engine OFF.
  • Remove the variable geometry actuator rod from the turbocharger.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Extend Actuator position.

Does the turbocharger actuator rod travel at least 12 mm [0.472 in]?
YES NO

Replace the turbocharger assembly.

For Signature, ISX, and QSX15 engines, use the following procedure in Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Replace the turbocharger actuator.

For Signature, ISX, and QSX15 engines, use the following procedure in Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-113 in Section 10.

Go to 3A

Go to 3A

Guided Step 2C-4 - Check for air pressure at the turbocharger control shutoff valve outlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Verify vehicle air tanks are fully charged.

Action

Loosen the air line connection at the turbocharger control shutoff valve outlet.

Can air be heard escaping from the turbocharger control shutoff valve outlet?
YES NO

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Section 19.

No Repair

Go to 3A

Go to 2C-5

Guided Step 2C-5 - Check for air pressure at the turbocharger control shutoff valve inlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Verify vehicle air tanks are fully charged.

Action

Verify the OEM air supply line is connected to the correct port on the turbocharger control shutoff valve.

  • Loosen the air line connection at the turbocharger control shutoff valve inlet.

Can air be heard escaping from the turbocharger control shutoff valve inlet?
YES NO
No Repair

Repair the air supply from the OEM air tanks.

Go to 2C-6

Go to 3A

Guided Step 2C-6 - Check for plugged turbocharger control shutoff valve filter.

Conditions

  • Remove the turbocharger control shutoff valve filter.
  • Turn keyswitch ON.
  • Verify vehicle air tanks are fully charged.

Action

Listen for an air leak at the turbocharger control shutoff valve filter head.

Is an air leak present at the turbocharger control shutoff valve filter head?
YES NO

Replace the turbocharger control shutoff valve filter.

For Signature™, ISX, and QSX15 engines, use the following procedure in Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-114 in Section 10.

Replace the turbocharger control shutoff valve.

Refer to Procedure 019-386 in Section 19.

Go to 3A

Go to 3A

Guided Step 2D - Perform INSITE™ electronic service tool Turbocharger Operational Test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Use the INSITE™ electronic service tool to select the EGR/VGT Operational Test.

NOTE: Prior to running INSITE™ electronic service tool EGR valve and EGR valve/turbocharger operational test, the ECM calibration software phase could possibly need to be updated to the latest software phase. The ECM calibration phase software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the software phase is earlier than shown below, recalibrate the ECM, use the January 2006 INCAL™ Calibration DVD-ROM, or later. Engines with the software phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require software phase 06050402.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Run the Turbocharger Operational Test.

Does the Turbocharger Operational Test pass?
YES NO
No Repair

Replace the variable geometry turbocharger.

For Signature, ISX, and QSX15 engines, use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239.Refer to Procedure 010-033 in Section 10.

Go to 3A

Go to 3A

Guided Step 2E - Check the charge air cooler, clamps, hoses, and piping. (Turbocharger Fuel Control State Present).

Conditions

  • Turn Keyswitch OFF.

Action

Check the charge air cooler, hoses, and piping for leaks.

  • Check the clamps for correct torque.

Air leak present or clamps loose?
YES NO

Repair air leak.

No Repair - All engine causes have been eliminated.

Go to 3A

Contact the OEM to review the cooling/air handling package.

Guided Step 2F - Check the air intake system sealing surface between the air filter and the hood air plenum.

Conditions

  • Turn Keyswitch OFF.

Action

Check the air intake system sealing surface between the air filter and the hood air plenum.

  • Visually inspect the surface between the air filter and the hood air plenum.
  • Check for excessive wear, ineffective sealing, and proper fit.

Excessive wear or ineffective sealing?
YES NO

Repair sealing surface(s).

No Repair - All engine causes have been eliminated.

Go to 3A

Contact the OEM to review the cooling/air handling package.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2346 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2347 - Turbocharger Compressor Outlet Air Temperature (Calculated) - Data Valid but Above Normal Range

Associated Procedures

Cautions and Warnings

CAUTION

Damage to the turbocharger can result if the proper removal procedure is not followed.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Code 123, 295, 433, 595, 2277, 2355, or 2973 inactive?
 | STEP 1C. Expand and read Fault Code 2347 snapshot data. | Turbocharger Control Valve Command less than 30 percent, Turbocharger Speed greater than 95,000 rpm, or Exhaust Manifold Pressure greater than 2794 mm-hg [110 in-hg].
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the intake restriction to the turbocharger inlet. | Air intake restriction greater than 635 mm H²O [25 in H²O] for a used air filter or 254 mm H²O [10 in H²O] for a new filter?
 | STEP 2B. Check the air intake piping under the hood. | Damage found on turbocharger air intake piping?
 | STEP 2C. Check the charge air cooler, clamps, hoses, and piping. | Loose charge air-cooler connection or damaged charge air cooler?
 | STEP 2D. Check the variable geometry actuator rod for correct travel. | Turbocharger actuator rod extend between 10 and 12 mm [0.394 and 0.472 in]?
 | STEP 2D-1. Check the engine and vehicle grounds. |
 | STEP 2D-2. Check for air pressure at the turbocharger control valve outlet. |
 | STEP 2D-3. Inspect the EGR differential tubes for restrictions, cracks, or leaks. |
 | STEP 2D-4. Check for correct turbocharger actuator travel. |
 | STEP 2E. Perform the INSITE™ EGR Valve/Turbocharger Operational Test. | Turbocharger Operational Test pass?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2347 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123, 295, 433, 595, 2277, 2355, or 2973 inactive?
YES | NO
No Repair | No Repair

Troubleshoot inactive fault codes starting with the fault code containing the highest number of counts

Go to 1C

Guided Step 1C - Expand and read Fault Code 2347 snapshot data.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Expand and read Fault Code 2347 Snapshot Data.

  • Use INSITE™ electronic service tool to read the fault code snapshot data.
  • Check the values for the parameters: Turbocharger Control Valve Command, Turbocharger Speed, and Exhaust Manifold Pressure.

Turbocharger Control Valve Command less than 30 percent, Turbocharger Speed greater than 95,000 rpm, or Exhaust Manifold Pressure greater than 2794 mm-hg [110 in-hg].

YES | NO
No Repair | No Repair

Go to 2D

Go to 2A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the intake restriction to the turbocharger inlet.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at the advertised horsepower and rpm.

Action

Check the intake system restriction by installing a vacuum gauge into the air system.

Refer to Procedure 010-031 in Section 10.

Air intake restriction greater than 635 mm H²O [25 in H²O] for a used air filter or 254 mm H²O [10 in H²O] for a new filter?

YES NO

Correct the cause of high intake air restriction. Check for a plugged air filter or restricted air intake piping.

 No Repair

Repair complete

Go to 2B

Guided Step 2B - Check the air intake piping under the hood.

Conditions

  • Turn engine OFF.
  • Turn keyswitch OFF.

Action

Inspect the turbocharger air inlet piping for damage.

Inspect the turbocharger air inlet piping for damage or holes that allow hot underhood air to enter the turbocharger intake.

  • Reference the Signature™ and ISX Engines, Operation and Maintenance Manual, Bulletin 3666251.
  • Refer to Procedure 010-024 in Section 10.

Damage found on the turbocharger air intake piping?
YES NO

Repair the air intake piping.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the charge-air cooler, clamps, hoses, and piping.

Conditions

  • Turn engine OFF.
  • Turn keyswitch OFF.

Action

Check the charge-air cooler clamps, hoses, and pipes for signs of leaks.

Pressure check the charge air cooler.

Loose charge air-cooler connection or damaged charge air cooler?
YES NO

Repair the charge air-cooler connections or charge-air cooler.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the variable geometry actuator rod for correct travel.

Conditions

  • Operate engine at operating temperature.
  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Start the turbocharger actuator test, use INSITE™ electronic service tool.

  • Adjust the delay timer in the Turbocharger Actuator Test so the rod movement can be observed.
  • Select the retract actuator position with INSITE™ electronic service tool.
  • Mark or scribe the VG actuator rod at the base of the actuator.
  • Select the extend actuator position with INSITE™ electronic service tool.
  • Measure the rod travel by measuring the distance from the base of the turbocharger actuator to the scribe mark.
  • Use a straight edge steel ruler.
  • Retract and extend the turbocharger actuator at least 10 times.

Note: The turbocharger actuator should move quickly and crisply. If the actuator rod movement is slow, there could be a problem with the air supply, a faulty ground connection on the engine or chassis, or mechanical problems with the variable geometry turbocharger assembly.

Turbocharger actuator rod extend between 10 and 12 mm [0.394 and 0.472 in]?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the engine and vehicle grounds.

Conditions

  • Turn keyswitch OFF.

Action

Check for a loose or corroded engine, chassis, or battery ground connection.

  • Check the engine ground connection
  • Check the chassis ground connections
  • Check the battery terminal connections.

Connections tight and corrosion - free?
YES NO
No Repair

Tighten the loose connections and/or clean the terminals.

Go to 2D-2

Go to 3A

Guided Step 2D-2 - Check for air pressure at the turbocharger control valve outlet.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the retract actuator position.
  • Remove the air line connection at the outlet of the turbocharger control valve.

Can air be heard escaping from the turbocharger control valve outlet?
YES NO

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Section 19.

No Repair

Go to 3A

Go to 2D-3

Guided Step 2D-3 - Inspect the EGR differential tubes for restrictions, cracks, or leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential tubes for restrictions, cracks, or leaks.

Soot streaks can indicate that the tube is loose or cracked.

Restrictions, cracks, or leaks present?
YES NO

Clean or replace the EGR differential pressure sensor tubes.

 No Repair

Go to 3A

Go to 2D-4

Guided Step 2D-4 - Check for correct turbocharger actuator travel.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Remove the variable geometry actuator from the turbocharger.

Refer to Procedure 010-113 in Section 10.

Note: Damage to the turbocharger can result if the proper removal procedure is not followed.

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the extend actuator position.

Turbocharger actuator rod travel at least 12 mm [0.472 in]?
YES NO

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Refer to Procedure 010-145 in Section 10.

Replace the turbocharger actuator.

Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Refer to Procedure 010-113 in Section 10.

Go to 3A

Go to 3A

Guided Step 2E - Perform the INSITE™ EGR Valve/Turbocharger Operational Test.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Select the EGR/VGT Operational Test, use INSITE™ electronic service tool.

Note: Before performing the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, be sure the ECM Calibration Software Phase is updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below, or later, do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Run the Turbocharger Operational Test.

Turbocharger Operational Test pass?
YES NO

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Section 19.

Replace the variable geometry turbocharger.

Refer to Procedure 010-033 in Section 1.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2347 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2348 - EGR Valve Self Calibration

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 2352, 2353, 2351, 2349, 2271, 2367, or 2368 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2348 inactive?
 | STEP 2B. Disable the fault code. | Fault Code 2348 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2352, 2353, 2351, 2349, 2271, 2367, or 2368 active?
YES NO

Troubleshoot respective fault code(s).

Replace the EGR valve assembly.

Use the following procedure in the Signature™, ISX, QSX15, Service Manual, Bulletin 3666239. Refer to Procedure 011-022 in Section 11 of

See troubleshooting tree for respective fault code

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2348 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Turn Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2348 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2349 - Exhaust Gas Recirculation (EGR) Valve Control Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994- female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

Do not attempt to free the EGR valve motor by striking the motor body. Damage to the EGR valve will result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EGR valve motor and circuit. |
 | STEP 1A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit in the EGR valve motor. | Less than 15 ohms?
STEP 2. | Check the engine harness and EGR valve extension harness. |
 | STEP 2A. Inspect the engine harness and EGR valve extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the EGR valve extension harness. | Less than 10 ohms?
 | STEP 2C. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2E-1. Check for a short circuit in the EGR valve extension harness. |
 | STEP 2F. Check for a short circuit to voltage source in the engine harness. | Less than 1.5 VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2349 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the EGR valve motor and circuit.

Guided Step 1A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.

Action

Inspect the EGR valve extension harness and EGR valve motor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

For general inspection techniques Refer to Procedure 019-361 in Section 19. .

Dirty or damaged pins?
YES NO

A defective connection has been detected in the EGR valve extension harness or the EGR valve motor connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

Repair or replace the EGR valve assembly.

Use the following procedure in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Section 19

No Repair

Go to 3A

Go to 1B

CAUTION

Do not attempt to free the EGR valve motor by striking the motor body. Damage to the EGR valve will result.
Guided Step 1B - Check for an open circuit in the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.

Action

Use a multimeter to measure the resistance between the EGR valve motor signal (+) pin and the EGR valve motor signal (-) pin at the EGR valve motor connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

Replace the EGR valve assembly.

Use the following procedure in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness and EGR valve extension harness.

Guided Step 2A - Inspect the engine harness and EGR valve extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the EGR valve extension harness.

Action

Inspect the engine harness and EGR valve extension harness pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the EGR valve extension harness engine harness connector or the engine harness EGR valve extension harness connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the EGR valve extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the EGR valve extension harness.
  • Disconnect the EGR valve motor from the EGR valve extension harness.

Action

Check the resistance of the EGR valve extension harness.

  • Use a multimeter to measure the resistance of the EGR valve motor SIGNAL (+) wire in the EGR valve extension harness between the engine harness connector and the EGR valve motor connector.
  • Use a multimeter to measure the resistance of the EGR valve motor SIGNAL (-) wire in the EGR valve extension harness between the engine harness connector and the EGR valve motor connector.

Flex the EGR valve extension harness while checking the resistance to help find intermittent opens or short circuits.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the EGR valve extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broken.
  • Damaged connector locking tab
  • Damaged wire or engine harness insulation.

For general inspection techniques. Refer to Procedure 019-361 in Section 19. .

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR valve extension harness from the engine harness.

Action

Check the resistance of the engine harness.

  • Use a multimeter to measure the resistance of the EGR valve motor SIGNAL (+) wire in the engine harness between the EGR valve extension harness connector and the ECM connector.
  • Use a multimeter to measure the resistance of the EGR valve motor SIGNAL (-) wire in the engine harness between the EGR valve extension harness connector and the ECM connector.

Flex the engine harness while checking the resistance to help find intermittent opens or short circuits.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.
  • Connect the EGR valve extension harness to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Short circuit on one connector - pin-to-pin check:

  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (+) pin and all other pins in the engine harness ECM connector.
  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (-) pin and all other pins in the engine harness ECM connector.

Flex the engine harness while checking the resistance to help find intermittent opens or short circuits.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 2F

Go to 2E-1

Guided Step 2E-1 - Check for a short circuit in the EGR valve extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.
  • Disconnect the EGR valve extension harness from the engine harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (+) pin and all other pins in the EGR valve extension harness engine harness connector.
  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (-) pin and all other pins in the EGR valve extension harness engine harness connector.

Flex the EGR valve extension harness while checking the resistance to help find intermittent opens or short circuits.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Repair or replace the EGR valve extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 2F - Check for a short circuit to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve motor to the EGR valve extension harness
  • Connect the EGR valve extension harness to the engine harness.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source in the engine harness.

  • Use a multimeter to check the voltage from the EGR valve motor SIGNAL (+) pin in the engine harness ECM connector to engine block ground.
  • Use a multimeter to check the voltage from the EGR valve motor SIGNAL (-) pin in the engine harness ECM connector to engine block ground.

See the wiring diagram for connector pin identification.

Less than 1.5 VDC?
YES NO

No repair.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ to verify the fault code is inactive.

Fault Code 2349 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2351 - Exhaust Gas Recirculation (EGR) Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.
CAUTION

Do not attempt to free the EGR valve motor by striking the motor body. Damage to the EGR valve will result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EGR valve motor and circuit. |
 | STEP 1A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground in the EGR valve motor. | More than 100k ohms?
STEP 2. | Check the engine harness and EGR valve extension harness. |
 | STEP 2A. Inspect the engine harness and EGR valve extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the EGR valve extension harness. | More than 100k ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the EGR valve extension harness. | More than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | More than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2351 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the EGR valve motor and circuit.

CAUTION

Do not attempt to free the EGR valve motor by striking the motor body. Damage to the EGR valve will result.
Guided Step 1A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.

Action

Inspect the EGR valve extension harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection was detected in the EGR valve extension harness or the EGR valve motor connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

Repair or replace the EGR valve assembly.

Use the following procedure in the Troubleshooting and Repair Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground in the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.

Action

Check for a short circuit to ground in the EGR valve motor.

  • Use a multimeter to measure the resistance from the EGR valve motor SIGNAL (+) pin to engine block ground.
  • Use a multimeter to measure the resistance from the EGR valve motor SIGNAL (-) pin to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the EGR valve assembly.

Use the following procedure in the Troubleshooting and Repair Manual, Signature/ISX/QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Section 11..

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness and EGR valve extension harness.

Guided Step 2A - Inspect the engine harness and EGR valve extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.

Action

Inspect the EGR valve extension harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection was detected in the EGR valve extension harness engine harness connector or the engine harness EGR valve extension harness connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the EGR valve extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.
  • Connect the EGR valve motor to the EGR valve extension harness.

Action

Check for a short circuit to ground in the EGR valve extension harness.

  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (+) pin at the engine harness connector of the EGR valve extension harness to engine block ground.
  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (-) pin at the engine harness connector of the EGR valve extension harness to engine block ground.

NOTE: Flex the harness and connectors while performing this step to isolate possible intermittent failures.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit to ground was detected in the EGR valve extension harness.

Repair or replace the EGR valve extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the EGR valve extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.
  • Disconnect the EGR valve motor from the EGR valve extension harness.

Action

Check for a pin-to-pin short circuit in the EGR valve extension harness.

  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (+) pin at the engine harness connector of the EGR valve extension harness to all other pins in the connector.
  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (-) pin at the engine harness connector of the EGR valve extension harness to all other pins in the connector.

NOTE: Flex the harness and connectors while performing this step to isolate possible intermittent failures.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit was found in the EGR valve extension harness.

Repair or replace the EGR valve extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground in the engine harness.

  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness to engine block ground.
  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness to engine block ground.

NOTE: Flex the harness and connectors while performing this step to isolate possible intermittent failures.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit to ground was detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (+) pin to all other pins at the ECM connector of the engine harness.
  • Use a multimeter to measure the resistance between the EGR valve motor SIGNAL (-) pin to all other pins at the ECM connector of the engine harness.

NOTE: Flex the harness and connectors while performing this step to isolate possible intermittent failures.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit was detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Engine coolant temperature above 82° C [180° F].
  • Engine not running.

Action

Disable the fault code.

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Perform the INSITE™ EGR valve test.
  • Command the valve open and closed.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

NOTE: Operating the engine to verify the repair was effective is not sufficient. The EGR valve test must be run to verify the correct component was repaired or replaced.

Fault Code 2351 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again..

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2352 - Exhaust Gas Recirculation (EGR) Valve Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

Do not attempt to free the EGR valve motor by striking the motor body. Damage to the EGR valve will result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to voltage source. | Less than 1.5 VDC?
 | STEP 1C. Check for a short circuit in the engine harness. | More than 100k ohms?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 2352 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

CAUTION

Do not attempt to free the EGR valve motor by striking the motor body. Damage to the EGR valve will result.
Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection was detected in the engine harness ECM connector.

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for a short circuit to voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine harness for a short circuit to battery or other voltage source.

  • Use a multimeter to measure the voltage from the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness to engine block ground.
  • Use a multimeter to measure the voltage from the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-359 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

A short to a voltage source was detected in the engine harness or EGR valve extension harness.

Repair or replace the engine harness or the EGR valve extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

  • Use a multimeter to measure the resistance from the EGR valve motor SIGNAL (+) pin to all other pins at the ECM connector of the engine harness.
  • Use a multimeter to measure the resistance from the EGR valve motor SIGNAL (-) pin to all other pins at the ECM connector of the engine harness.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit was found in the engine harness or EGR valve extension harness.

Repair or replace the engine harness or the EGR valve extension harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Engine coolant temperature above 82°C [180°F].
  • Engine not running.

Action

Disable the fault code.

Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase.

The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Perform the INSITE™ electronic service tool EGR valve test.
  • Command the valve open and closed.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Operating the engine to verify the repair was effective is not sufficient. The EGR valve test must be run to verify the correct component was repaired or replaced.

Fault Code 2352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2353 - Exhaust Gas Recirculation (EGR) Valve Control Circuit - Excessive Current Detected

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

Do not attempt to free the EGR valve motor by striking the motor body. Damage to the EGR valve will result.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EGR valve motor and circuit. |
 | STEP 1A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the EGR valve motor. | More than 0.5 ohms?
STEP 2. | Check the engine harness and EGR valve extension harness. |
 | STEP 2A. Inspect the engine harness and EGR valve extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the EGR valve extension harness. | More than 100k ohms?
 | STEP 2C. Check for a short circuit in the engine harness. | More than 100k ohms?
STEP 3. | Check the EGR valve assembly. |
 | STEP 3A. Perform the INSITE™ EGR Valve Test. | Is EGR valve position 100 percent when open?
 | STEP 3B. Perform the INSITE™ EGR Valve Test. | Is EGR valve position less than 10 percent when closed?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 2353 inactive?
 | STEP 4B. Clear the inactive fault code. | All faults cleared?

Guided Step 1 - Check the EGR valve motor and circuit.

CAUTION

Do not attempt to free the EGR valve motor by striking the motor body. Damage to the EGR valve will result.
Guided Step 1A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.

Action

Inspect the EGR valve extension harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the resistance of the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for low resistance in the EGR valve motor.

  • Using a multimeter, measure the resistance from the EGR valve motor SIGNAL (+) pin to the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector.

NOTE: Since the EGR valve motor resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 0.5 ohms?
YES NO
No Repair

Replace the EGR valve assembly.

Use the following procedure in Troubleshooting and Repair Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness and EGR valve extension harness.

Guided Step 2A - Inspect the engine harness and EGR valve extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.

Action

Inspect the EGR valve extension harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness connector or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the EGR valve extension harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the EGR valve extension harness.
  • Disconnect the EGR valve extension harness from the engine harness.

Action

Check for a short circuit in the EGR valve extension harness.

  • Using a multimeter, measure the resistance from the EGR valve motor SIGNAL(+) pin to the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector of the EGR valve extension harness.

NOTE: Flex the EGR valve extension harness while checking the resistance to help find intermittent opens or short circuits.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the EGR valve extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve extension harness from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

  • Using a multimeter, measure the resistance from the EGR valve motor SIGNAL (+) pin to the EGR valve motor SIGNAL (-) pin at the engine harness EGR valve extension harness connector.

NOTE: Flex the engine harness while checking the resistance to help find intermittent opens or short circuits.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the EGR valve assembly.

Guided Step 3A - Perform the INSITE™ EGR Valve Test.

Conditions

  • Connect all components.
  • Engine coolant temperature at least 82°C [180°F].
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ EGR Valve Test.

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Open the EGR valve.

Is EGR valve position 100 percent when open?
YES NO
No Repair

Replace the EGR valve assembly.

Use the following procedure in Troubleshooting and Repair Manual, Signature, ISX, QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Sedtion 11.

Go to 3B

Go to 4A

Guided Step 3B - Perform the INSITE™ EGR Valve Test.

Conditions

  • Connect all components.
  • Engine coolant temperature at least 82°C [180°F].
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool EGR Valve Test.

  • Close the EGR valve.

Is EGR valve position less than 10 percent when closed?
YES NO
No Repair

Replace the EGR valve assembly.

Use the following procedure in Troubleshooting and Repair Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2353 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2355 - Turbocharger Control Shutoff Valve Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3164597 - female Framatome™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2355 active?
STEP 2. | Check the turbocharger control shutoff valve and circuit. |
 | STEP 2A. Inspect the turbocharger control shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the turbocharger control shutoff valve. | Less than 15 ohms?
 | STEP 2C. Check the turbocharger control shutoff valve diagnostic supply voltage, supply line and return circuit. | Greater than 5.0 VDC?
 | STEP 2D. Check for an open circuit in the turbocharger control shutoff valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM turbocharger control shutoff valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2355 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2355 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger control shutoff valve and circuit.

Guided Step 2A - Inspect the turbocharger control shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Inspect the engine harness and shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the turbocharger control shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Actuator continuity - pin-to-pin continuity check:

  • Measure the resistance and check for an open circuit between the turbocharger control shutoff valve SIGNAL pin and the turbocharger control shutoff valve RETURN pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

Replace the turbocharger control shutoff valve.

Refer to Procedure 019-386 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the turbocharger control shutoff valve diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the turbocharger control shutoff valve SIGNAL pin and the turbocharger control shutoff valve RETURN pin at the engine harness connector.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the turbocharger control shutoff valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Harness connector to connector continuity - pin-to-ground continuity check:

  • Measure the resistance between the engine harness turbocharger control shutoff valve RETURN pin and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Clean the connector and pins and engine block ground stud connection.

Repair or replace the engine harness, connector, or pins if necessary.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM turbocharger control shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Using a multimeter, measure the voltage from the turbocharger control shutoff valve SIGNAL pin at the ECM port to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM.

Call for authorization.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Harness connector to connector continuity - pin-to-pin continuity check:

Measure the resistance of the following pin between the engine harness ECM connector and the engine harness turbocharger control shutoff valve connector:

  • Turbocharger control shutoff valve SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and all other pins in the engine harness ECM connector:

  • Turbocharger control shutoff valve SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO

Replace the ECM.

Call for authorization.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2355 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2356 - Turbocharger Control Shutoff Valve Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2356 active?
STEP 2. | Check the turbocharger control shutoff valve and circuit. |
 | STEP 2A. Inspect the turbocharger control shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to ground short circuit in the turbocharger control shutoff valve. | Greater than 100k ohms?
 | STEP 2C. Check for an internal short in the turbocharger control valve | More than 3 ohms?
 | STEP 2D. Check the turbocharger control shutoff valve diagnostic supply voltage and supply line. | Greater than 5.0 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM turbocharger control shutoff valve diagnostic supply voltage. | Greater than 5.0 VDC?
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2356 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2356 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger control shutoff valve and circuit.

Guided Step 2A - Inspect the turbocharger control shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Inspect the engine harness and shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin to ground short circuit in the turbocharger control shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following turbocharger control shutoff valve connector pin and ground:

  • Turbocharger control shutoff valve SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the turbocharger control shutoff valve.

Refer to Procedure 019-386 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an internal short in the turbocharger control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control shutoff valve from the engine harness.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for low internal resistance of the turbocharger control shutoff valve.

  • Using a multimeter, measure the resistance between the SIGNAL and RETURN pin at the turbocharger control shutoff valve connector.

NOTE: Since the turbocharger control shutoff valve resistance is normally very low, it's necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More then 3 ohms?
YES NO
No Repair

Replace the turbocharger control shutoff valve.

Refer to Procedure 019-386 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the turbocharger control shutoff valve diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the turbocharger control shutoff valve SIGNAL pin and the turbocharger control shutoff valve RETURN pin at the engine harness connector.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM turbocharger control shutoff valve diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the turbocharger control shutoff valve SIGNAL pin at the ECM port to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Short circuit on one connector - pin-to-ground check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and ground:

  • Turbocharger control shutoff valve SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control shutoff valve from the engine harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and all other pins in the connector:

  • Turbocharger control shutoff valve SIGNAL pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2356 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Mar-2012


FAULT CODE 2357 - Exhaust Gas Recirculation (EGR) Valve Control - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for a short circuit from pin-to-pin. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the EGR valve position sensor SIGNAL for a short circuit. | More than 100k ohms?
STEP 2. | Check the ECM. |
 | STEP 2A. Check the EGR valve position sensor SIGNAL voltage. | Less than 0.1-VDC?
 | STEP 2B. Check the ECM's EGR valve circuit. | 85.5k to 105.5k ohms?
 | STEP 2C. Verify the circuit resistances. | Are BOTH measurements between 85.5k to 105.5k ohms?
STEP 3. | Check the EGR valve assembly. |
 | STEP 3A. Perform INSITE™ electronic service tool EGR valve test. | Is the EGR valve position 100 percent when open?
 | STEP 3B. Perform INSITE™ electronic service tool EGR valve test. | Is the EGR valve position less than 10 percent when closed?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2357 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for a short circuit from pin-to-pin.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the EGR valve position sensor SIGNAL for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR valve position sensor from the EGR valve extension harness.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the EGR valve position sensor SIGNAL pin at the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit from was found in the engine harness or EGR valve extension harness.

Repair or replace the engine harness or the EGR valve extension harness.

Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

Guided Step 2A - Check the EGR valve position sensor SIGNAL voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool data logger/monitor to check the EGR valve position sensor SIGNAL voltage.

Less than 0.1-VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the ECM's EGR valve circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the power harness from th ECM.

Action

Check the resistance between the EGR valve motor SIGNAL pins at the ECM.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the ECM port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

85.5k to 105.5k ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Verify the Circuit Resistances.

Conditions

  • Remove the ECM from the engine.
  • Perform the following ECM testing on a non-metallic surface.

Action

Compare the resistances between the EGR valve ECM circuit pins and two specific REFERENCE pins at the ECM.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the ECM port WITH THE ECM REMOVED FROM THE ENGINE.
  • Measure the resistance between pins 9 and 10 at the ECM engine harness port.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Are BOTH measurements between 85.5k to 105.5k ohms?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

  • Replace the EGR valve assembly.Use the following procedure in the Troubleshooting and Repair Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

Go to 3A

Go to 4A

Guided Step 3 - Check the EGR valve assembly.

Guided Step 3A - Perform INSITE™ electronic service tool EGR valve test.

Conditions

  • Connect all components.
  • Engine coolant temperature above 82°C [180°F].
  • Turn keyswitch ON.
  • Engine not running.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool EGR valve test.

Note: Prior to running INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Software Phase can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Open the EGR valve.

Is the EGR valve position 100 percent when open?
YES NO
No Repair

Replace the EGR valve assembly.

Use the following procedure in the Troubleshooting and Repair Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

Go to 3B

Go to 4A

Guided Step 3B - Perform INSITE™ electronic service tool EGR valve test.

Conditions

  • Connect all components.
  • Engine coolant temperature above 82°C [180°F].
  • Turn keyswitch ON.
  • Engine not running.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool EGR valve test.

  • Close the EGR valve.

Is the EGR valve position less than 10 percent when closed?
YES NO
No Repair

Replace the EGR valve assembly.

Use the following procedure in the Troubleshooting and Repair Manual, Signature™, ISX, and QSX15 Engine, Bulletin 3666239. Refer to Procedure 011-022 in Section 11.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Perform INSITE™ electronic service tool EGR valve test.
  • Command the valve open and closed.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Note: Operating the engine to verify the repair was effective is not sufficient. The EGR valve test must be run to verify the correct component was repaired or replaced.

Fault Code 2357 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 2359 - EGR Differential Pressure Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for additional fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Codes 2271, 2272, 2273, 2274, 2277, 2278, 2346, 2347, 2348, 2349, 2351, 2352, 2353, 2355, 2356, or 2357 active or inactive with high counts?
STEP 2. | Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging. |
 | STEP 2A. Check the EGR differential pressure tubes, adapter, and exhaust system for leaks. | Leaks detected at either the low or high EGR differential pressure tubes, adapter, or exhaust system?
 | STEP 2B. Check for proper installation of the EGR differential pressure tubes. | Are the EGR differential pressure tubes installed correctly?
 | STEP 2C. Check for proper installation of the EGR differential pressure sensor. | Is the EGR differential pressure sensor installed correctly?
STEP 3. | Perform the EGR differential pressure tube diagnostic test. |
 | STEP 3A. Verify the engine coolant temperature. | Is the coolant temperature within 5.6°C [10°F] of the ambient temperature?
 | STEP 3B. Release the excess pressure in the EGR differential pressure tubes. | Are the differential pressure tube fittings tightened?
 | STEP 3C. Diagnostic test for High side EGR differential pressure tube. | Is differential pressure sensor signal voltage less than or equal to 0.5 VDC?
 | STEP 3D. Diagnostic test for Reference side EGR differential pressure tube. | Is differential pressure sensor signal voltage greater than or equal to 1.44 VDC?
STEP 4. | Check the EGR differential pressure. |
 | STEP 4A. Verify the EGR differential pressure at key ON. | Fault Code 2359 active?
STEP 5. | Check the air handling system. |
 | STEP 5A. Inspect the air handling system for intake manifold, charge air cooler, or EGR leaks. | Are any leaks detected?
 | STEP 5B. Check the variable geometry actuator rod for correct travel. | Does the turbocharger actuator rod extend between 10 and 12 mm [0.394 and 0.472 in]?
 | STEP 5B-1. Check for air leaks and inspect air lines. |
 | STEP 5B-2. Check the engine and vehicle grounds. |
 | STEP 5B-3. Check for air pressure at the turbocharger control valve outlet. |
 | STEP 5B-4. Check for air pressure at the turbocharger control valve outlet. |
 | STEP 5B-5. Check for correct turbocharger actuator travel. |
 | STEP 5B-6. Check for air pressure at the turbocharger control shutoff valve outlet. |
 | STEP 5B-7. Check for air pressure at the turbocharger control shutoff valve inlet. |
 | STEP 5B-8. Check for plugged turbocharger control shutoff valve filter. |
 | STEP 5C. Perform the INSITE™ electronic service tool EGR Valve/Turbocharger Operational Test. | Do both the EGR valve and the turbocharger pass the operational test?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2359 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for additional fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active or high counts of inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2271, 2272, 2273, 2274, 2277, 2278, 2346, 2347, 2348, 2349, 2351, 2352, 2353, 2355, 2356, or 2357 active or inactive with high counts?

YES NO

Troubleshoot fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the EGR differential pressure tubes and mounting surfaces for leaks or debris plugging.

Guided Step 2A - Check the EGR differential pressure tubes, adapter, and exhaust system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR differential pressure tubes, adapter, and exhaust system for visible leaks.

  • Leaks should be easily noted by traces of soot; however, the sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the adapter for proper sealing.
  • Refer to Procedure 019-370 in Section 19.

Leaks detected at either the low or high EGR differential pressure tubes, adapter, or exhaust system?
YES NO

Tighten the fittings, replace the EGR differential pressure tube and the adapter, or correct the exhaust leaks.

Use the following procedure in the Signature, ISX, and QSX15 Engine, Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for proper installation of the EGR differential pressure tubes.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR differential pressure tubes for proper installation.

Use the following procedure in the Signature, ISX, and QSX15 Engine, Service Manual, Bulletin 3666239. Refer to Procedure 011-028 in Section 11.

Note: Cross-connecting the EGR differential pressure tubes will cause this fault code to become active.

Are the EGR differential pressure tubes installed correctly?
YES NO
No Repair

Properly install the EGR differential pressure tubes.

Use the following procedure in the Signature, ISX, and QSX15 Engine, Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Go to 2C

Go to 6A

Guided Step 2C - Check for proper installation of the EGR differential pressure sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR differential pressure sensor for proper installation.

Refer to Procedure 019-370 in Section 19.

Note: Installing the EGR differential pressure sensor backwards will cause this fault code to become active.

Is the EGR differential pressure sensor installed correctly?
YES NO
No Repair

Properly install the EGR differential pressure sensor.

Refer to Procedure 019-370 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Perform the EGR differential pressure tube diagnostic test.

Guided Step 3A - Verify the engine coolant temperature.

Conditions

  • Keyswitch ON.

Action

Monitor the engine coolant temperature.

  • Use INSITE™ electronic service tool to verify coolant temperature is within 5.6°C [10°F] of ambient temperature.

Note: This procedure will help determine if the tubes are plugged without removing them.

Is the coolant temperature within 5.6°C [10°F] of the ambient temperature?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B

Guided Step 3B - Release the excess pressure in the EGR differential pressure tubes.

Conditions

  • Keyswitch ON.

Action

Release the excess pressure in the EGR differential pressure tubes.

  • Bleed the lines by loosening and tightening the Adapter side fittings on both the Low and High side tubes.
  • Use the following procedure in the Signature, ISX, and QSX15 Engines Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

NOTE: This procedure will release gas that has expanded due to hot temperatures.

Are the differential pressure tube fittings tightened?
YES NO
No Repair

Tighten the differential pressure tube fittings.

Use the following procedure for standard torque specifications in the Signature, ISX, and QSX15 Engines Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

Go to 3C

Go to 3C

Guided Step 3C - Diagnostic test for High side EGR differential pressure tubes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Transmission in neutral.
  • Service brakes ON.
  • Trailer brakes ON.
  • Start engine and run at idle.

Note: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool under ”Features and Parameters”. Expand the selection for ”System ID and Dataplate” and go to ”Calibration Information”. If the Software Phase is earlier than shown below, calibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require calibration.

Action

Use INSITE™ electronic service tool to monitor the following parameters:

  • EGR differential pressure sensor signal voltage
  • EGR valve position (percent open)
  • Intake manifold pressure.

Open the INSITE™ electronic service tool ECM Diagnostics Test and choose the EGR Valve Test. OPEN and CLOSE the EGR valve to ensure the valve can transition between less than 4 percent OPEN to greater than 90 percent OPEN.

Set the EGR valve position to close condition. Use INSITE™ electronic service tool command ”Close EGR valve".

  • Wait for the valve to close and verify the EGR valve position is less than 4 percent.
  • Engage PTO and raise engine speed to 1400 ± 50 rpm.
  • Monitor the EGR differential pressure sensor signal voltage.

Verify the EGR differential pressure sensor signal voltage is less than or equal to 0.5 VDC.

Is differential pressure sensor signal voltage less than or equal to 0.5 VDC?
YES NO

Replace the High side EGR differential pressure tube.

Use the following procedure for standard torque specifications in the Signature, ISX, and QSX15 Engines Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 6A

Go to 3D

Guided Step 3D - Diagnostic test for Reference side EGR differential pressure tube.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Transmission in neutral.
  • Service brakes ON.
  • Trailer brakes ON.
  • Start engine and run at idle.

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool under ”Features and Parameters”. Expand the selection for ”System ID and Dataplate” and go to ”Calibration Information”. If the Software Phase is earlier than shown below, calibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require calibration.

Action

Use INSITE™ electronic service tool to monitor the following parameters:

  • EGR differential pressure sensor signal voltage
  • EGR valve position (percent open)
  • Intake manifold pressure.

Open the INSITE™ electronic service tool ECM Diagnostics Test and choose the EGR Valve Test. OPEN and CLOSE the EGR valve to ensure the valve can transition between less than 4 percent OPEN to greater than 90 percent OPEN.

Set the EGR valve position to close condition. Use the INSITE™ electronic service tool command ”Close EGR valve".

  • Wait for the valve to close and verify the EGR valve position is less than 4 percent.
  • Engage PTO and raise engine speed to 1400 ± 50 rpm.
  • Monitor the EGR differential pressure sensor signal voltage.

Verify the EGR differential pressure sensor signal voltage is greater than or equal to 1.44 VDC.

  • Command the EGR valve position to open using the INSITE™ electronic service tool command ”Open Valve”.

Once the EGR valve position is greater than 90 percent:

  • Verify the EGR differential pressure is greater than or equal to 51 mmHg [2 inHg].

Is differential pressure sensor signal voltage greater than or equal to 1.44 VDC?
YES NO

Replace the Reference side EGR differential pressure tubes.

Use the following procedure for standard torque specifications in the Signature, ISX, and QSX15 Engines Service Manual, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the EGR differential pressure.

Guided Step 4A - Verify the EGR differential pressure at key ON.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine not running.
  • Exhaust fans disconnected or turned off.

Action

Verify engine coolant temperature is greater than 67°C [154°F] and intake manifold air temperature is greater than 7°C [45°F].

  • Turn keyswitch OFF for 30 seconds.

Note: The engine must not be running before the keyswitch is turned OFF. If the engine is running, turn the keyswitch OFF for 30 seconds, key ON for 30 seconds, then back OFF again.

  • Turn keyswitch ON and wait 30 seconds.
  • Use INSITE™ electronic service tool, to check the fault codes.

Fault Code 2359 active?
YES NO

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 in Section 19.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the air handling system.

Guided Step 5A - Inspect the air handling system for intake manifold, charge air cooler, or EGR leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air handling system for intake manifold, charger air cooler, or EGR leaks.

Inspect the following for leaks:

  • Charge air cooler - Use the following procedure in the Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-027
  • Air intake and exhaust - Use the following procedure in the Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-024 in Section 10.
  • EGR connection tubes and hoses.

Are any leaks detected?
YES NO

Repair leaks.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the variable geometry actuator rod for correct travel.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool, to start the Turbocharger Actuator Test.

  • Adjust the delay timer in the Turbocharger Actuator Test so the rod movement can be observed.
  • Select the Retract Actuator position with INSITE™ electronic service tool.
  • Mark or scribe the variable geometry actuator rod at the base of the actuator.
  • Select the Extend Actuator position with INSITE™ electronic service tool.
  • Use a straight edge steel ruler.
  • Measure the rod travel by measuring the distance from the base of the variable geometry actuator to the scribe mark.

Note: The turbocharger actuator should move quickly and crisply. If the actuator rod movement is slow, there could be a problem with the air supply, a faulty ground connection on the engine or chassis, or mechanical problems with the variable geometry turbocharger assembly.

Does the turbocharger actuator rod travel between 10 and 12 mm [0.394 and 0.472 in]?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5B-1

Guided Step 5B-1 - Check for air leaks and inspect air lines.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position. Listen for air leaks at the following components:

  • Turbocharger control valve
  • Turbocharger control shutoff valve inlet connection
  • Turbocharger control shutoff valve outlet connection
  • Turbocharger control valve inlet connection
  • Turbocharger control valve outlet connection
  • Turbocharger actuator inlet connection
  • Turbocharger actuator
  • All air lines including the OEM supply line to the turbocharger control shutoff valve, turbocharger control shutoff valve to turbocharger control valve, and turbocharger control valve to turbocharger actuator.

Note: A small amount of air could possibly be heard escaping from the turbocharger control valve during the turbocharger actuator test. This is a normal condition for the valve to achieve output regulation pressure. Do not replace the turbocharger control valve for this condition.

Air leaks found in the system?
YES NO

Repair air leaks.

 No Repair

Go to 6A

Go to 5B-2

Guided Step 5B-2 - Check the engine and vehicle grounds.

Conditions

  • Turn keyswitch OFF.

Action

Check for a loose or corroded engine, chassis, or battery ground connection.

  • Check the engine ground connection
  • Check the chassis ground connections
  • Check the battery terminal connections
  • Check the turbocharger control valve ground connection through the engine wiring harness to the engine block grounding stud.

Are connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals.

Refer to the OEM troubleshooting and repair manual.

Go to 5B-3

Go to 6A

Guided Step 5B-3 - Check for air pressure at the turbocharger control valve outlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Retract Actuator position.
  • Remove the air line connection at the outlet of the turbocharger control valve.
  • Install an M12 Compuchek® fitting, Part Number 3824843, at the outlet of the turbocharger control valve.
  • Install an air pressure gauge that is capable of reading at least 1034 kPa [150 psi].
  • Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test. Select the Extend Actuator position.

Is vehicle air tank pressure present at the turbocharger control valve outlet?
YES | NO
No Repair | No Repair

Go to 5B-4

Go to 5B-6

Guided Step 5B-4 - Check for air pressure at the turbocharger control valve outlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Retract Actuator position.
  • Remove the air line connection at the outlet of the turbocharger control valve.
  • Install an M12 Compuchek® fitting, Part Number 3824843, at the outlet of the turbocharger control valve.
  • Install an air pressure gauge that is capable of reading at least 1034 kPa [150 psi].

Does the pressure gauge read more than 103 kPa [15 psi] after 5 minutes?
YES NO

Replace the turbocharger control valve.

Refer to Procedure 019-388.

No Repair

Go to 6A

Go to 5B-5

Guided Step 5B-5 - Check for correct turbocharger actuator travel.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Damage to the turbocharger can result if the proper removal procedure is not followed.

Remove the variable geometry actuator from the turbocharger.

Use the following procedure in the Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-113 in Section 10.

Perform the Turbocharger Actuator Test, use INSITE™ electronic service tool.

  • Select the Extend Actuator position.

Does the turbocharger actuator rod travel at least 12 mm [0.472 in]?
YES NO

Replace the turbocharger assembly.

Use the following procedure in the Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Replace the turbocharger actuator.

Use the following procedure in the Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239.Refer to Procedure 010-113 in Section 10

Go to 6A

Go to 6A

Guided Step 5B-6 - Check for air pressure at the turbocharger control shutoff valve outlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Extend Actuator position.
  • Loosen the air line connection at the turbocharger control shutoff valve outlet.

Can air be heard escaping from the turbocharger control shutoff valve outlet?
YES NO

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Secetion 19..

No Repair

Go to 6A

Go to 5B-7

Guided Step 5B-7 - Check for air pressure at the turbocharger control shutoff valve inlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Verify vehicle air tanks are fully charged.

Action

Verify the OEM air supply line is connected to the correct port on the turbocharger control shutoff valve.

  • Loosen the air line connection at the turbocharger control shutoff valve inlet.

Can air be heard escaping from the turbocharger control shutoff valve inlet?
YES NO
No Repair

Repair the air supply from the OEM air tanks.

Go to 5B-8

Go to 6A

Guided Step 5B-8 - Check for plugged turbocharger control shutoff valve filter.

Conditions

  • Remove the turbocharger control shutoff valve filter.
  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Extend Actuator position.
  • Listen for an air leak at the turbocharger control shutoff valve filter head.

Is an air leak present at the turbocharger control shutoff valve filter head?
YES NO

Replace the turbocharger control shutoff valve filter.

Use the following procedure in the Service Manual, Signature, ISX, QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-114 in Section 10.

Replace the turbocharger control shutoff valve.

Refer to Procedure 019-386 in Section 19.

Go to 6A

Go to 6A

Guided Step 5C - Perform the INSITE™ electronic service tool, EGR Valve/Turbocharger Operational Test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Use the INSITE™ electronic service tool, to select the EGR Valve/Turbocharger Operational Test.

NOTE: Prior to running the INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, the ECM Calibration Software Phase could possibly need to be updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, calibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require calibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Choose the Turbocharger Actuator option under Test Choices.

Do both the EGR valve and the turbocharger pass the operational test?
YES NO
No Repair

Replace the component that did not pass the test.

Use the following procedures in the Service Manual, Signature, ISX, QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Refer to Procedure 011-022 in Section 11.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine coolant temperature is greater than 67°C [153°F].
  • Intake manifold air temperature is greater than 7°C [45°F].
  • Engine not running.

Action

Use INSITE™ electronic service tool to verify the engine coolant temperature is greater than 67°C [154°F] and the intake manifold air temperature is greater than 7° [45°F].

  • Turn keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Check the fault codes

Fault Code 2359 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 2362 - Engine Brake Solenoid 1 Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake solenoid 1 signal circuit |
 | STEP 1A. Check for a signal short to ground | Greater than 5.0 VDC?
 | STEP 1A-1. Check the engine harness and ECM connector pins |
 | STEP 1A-2. Check for a signal short to ground at the ECM |
STEP 2. | Check the engine brake wiring harness and solenoids |
 | STEP 2A. Check the engine brake wiring harness for a short to ground | More than 100k ohms?
 | STEP 2B. Check the brake solenoids for a short to ground | 5 ohms or greater?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 2362 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the engine brake solenoid 1 signal circuit

Guided Step 1A - Check for a signal short to ground

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 1 SIGNAL pin of the engine harness to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Check the engine harness and ECM connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 1A-2

Guided Step 1A-2 - Check for a signal short to ground at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 1 SIGNAL pin of the ECM port to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the engine brake wiring harness and solenoids

Guided Step 2A - Check the engine brake wiring harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from solenoid Number 1.

Action

Check for a pinched or an abraded harness, or the areas that may be shorted to ground.

  • Using a multimeter, measure the resistance from the engine brake solenoid Number 1 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

More than 100k ohms?
YES NO
No Repair

Replace the engine brake wiring harness.

Refer to Procedure 019-136 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the brake solenoids for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from solenoid Number 1.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the solenoid terminal pin to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Activate the engine brakes.
  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2362 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Return to the troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jun-2012


FAULT CODE 2363 - Engine Brake Solenoid 2 Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake solenoid 2 signal circuit. |
 | STEP 1A. Check for a signal short to ground. | Greater than 5.0 VDC?
 | STEP 1A-1. Check the engine harness and ECM connector pins. |
 | STEP 1A-2. Check for a signal short to ground at the ECM. |
STEP 2. | Check the engine brake wiring harness and solenoids. |
 | STEP 2A. Check the engine brake wiring harness for a short to ground. | More than 100k ohms?
 | STEP 2B. Check the brake solenoids for a short to ground. | 5 ohms or greater?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2363 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the engine brake solenoid 2 signal circuit.

Guided Step 1A - Check for a signal short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin of the engine harness to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 1A-2

Guided Step 1A-2 - Check for a signal short to ground at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin of the ECM port to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the engine brake wiring harness and solenoids

Guided Step 2A - Check the engine brake wiring harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from solenoid Number 2.

Action

Check for a pinched or an abraded harness, or areas that may be shorted to ground.

  • Use a multimeter to measure the resistance from the engine brake solenoid Number 2 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the engine brake wiring harness.

Refer to Procedure 019-136.

Go to 2B

Go to 3A

Guided Step 2B - Check the brake solenoids for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from solenoid Number 2.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the solenoid terminal pin to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid.

Reference the Signature™, ISX, and QSX Engines, Service Manual, Bulletin 3666239.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Activate the engine brakes.
  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2363 inactive?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Return to the troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Jun-2012


FAULT CODE 2365 - Engine Brake Solenoid 3 Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake solenoid 3 signal circuit. |
 | STEP 1A. Check for a signal short to ground. | Greater than 5.0 VDC?
 | STEP 1A-1. Check the engine harness and ECM connector pins. |
 | STEP 1A-2. Check for a signal short to ground at the ECM. |
STEP 2. | Check the engine brake wiring harness and solenoids. |
 | STEP 2A. Check the engine brake wiring harness for a short to ground. | More than 100k ohms?
 | STEP 2B. Check the brake solenoids for a short to ground. | 5 ohms or greater?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 2365 inactive?
 | STEP 3B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the engine brake solenoid 3 signal circuit

Guided Step 1A - Check for a signal short to ground

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin of the engine harness to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1A-1

Guided Step 1A-1 - Check the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 3A

Go to 1A-2

Guided Step 1A-2 - Check for a signal short to ground at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin of the ECM port to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 2 - Check the engine brake wiring harness and solenoids

Guided Step 2A - Check the engine brake wiring harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from solenoid Number 3.

Action

Check for a pinched or abraded harness, or areas that may be shorted to ground.

  • Using a multimeter, measure the resistance from the engine brake solenoid Number 3 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the engine brake wiring harness.

Refer to Procedure 019-136 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the brake solenoids for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from solenoid Number 3.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the solenoid terminal pin to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Replace the engine brake solenoid.

Reference the Signature/ISX/QSX Engines, Service Manual, Bulletin 3666239.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Activate the engine brakes.
  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2365 inactive?
YES NO

Return to the troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Jun-2012


FAULT CODE 2366 - Engine Brake Solenoid Number 1 Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake harness, ECM calibration code, and solenoids. |
 | STEP 1A. Check the ECM code and number of brake solenoid connector pins. | ECM code compatible with the number of brake solenoids?
 | STEP 1A-1. Inspect the connector pins. |
 | STEP 1B. Check the engine brake harness and solenoid for an open circuit. | Between 5 and 20 ohms?
 | STEP 1B-1. Inspect the solenoid and engine brake harness connection. |
 | STEP 1B-2. Check the engine brake harness for an open circuit. |
 | STEP 1B-3. Check the engine brake solenoid for an open circuit. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for an open circuit. | Greater than 5.0 VDC?
 | STEP 2A-1. Inspect the ECM and engine harness connector pins. |
 | STEP 2A-2. Check the diagnostic voltage at the ECM, |
 | STEP 2A-3. Check for an open circuit in the engine harness. |
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2B-1. Check for a short circuit to a voltage source. |
 | STEP 2B-2. Inspect the solenoid and engine brake harness connection. |
 | STEP 2B-3. Check for an open circuit in the ECM. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2366 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine brake harness, ECM calibration code, and solenoids.

Guided Step 1A - Check the ECM code compatibility with the number of brake solenoid connector pins.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool to the service tool datalink.

Action

Check for active fault codes.

Review the SC Option information for the current ECM code in the ECM to verify that the ECM code is compatible with the number of brake solenoids available on the engine.

ECM code is compatible with the number of brake solenoids available on the engine?
YES NO
No Repair

Select the correct ECM code and transfer the code to the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 1A-1

Go to 3A

Guided Step 1A-1 - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Inspect the engine harness and engine brake connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins
  • Count the number of connector pins in the engine brake connector.

NOTE: Two pins correspond to two brake solenoid control and three pins correspond to three brake solenoid control.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the engine brake harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 1 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.

Action

Inspect the engine brake harness and engine brake solenoid Number 1 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Clean and reconnect the terminal.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Replace the engine brake harness, if necessary. Refer to Procedure 019-136 in Section 19.

No Repair

Go to 2A

Go to 1B-2

Guided Step 1B-2 - Check the engine brake harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the valve cover.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 1.

Action

Check the resistance of the engine brake harness.

  • Use a multimeter to measure the resistance from the engine brake harness, from the engine brake solenoid number 1 SIGNAL pin of the engine brake connector to the solenoid connector pin.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine brake harness.

Refer to Procedure 019-136 in Section 19.

Go to 1B-3

Go to 3A

Guided Step 1B-3 - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the terminal to the body of the solenoid.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Use the following procedure in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239. Refer to Procedure 020-012 in Section 20.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the engine harness for an open circuit.

  • Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin in the engine brake connector of the engine harness to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 1 SIGNAL pin of the ECM port to engine block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 5.0 VDC?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance of the engine brake solenoid Number 1 SIGNAL wire between the ECM connector and the engine brake connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 1 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin of the engine harness to engine block ground.

Refer to the wiring diagram for connector pin identification.

Less than 1 VDC?
YES NO
No Repair

There is a short to a voltage source.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Inspect the solenoid and engine brake harness connection.

Conditions

  • If you have done Step 1B-1, skip this step and go to Step 2B-3.
  • Turn keyswitch OFF.
  • Remove valve cover.

Action

Inspect the engine brake harness and engine brake solenoid number 1 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-136 in Section 19.

Clean and reconnect the terminal.

 No Repair

Go to 2B-3

Go to 2B-3

Guided Step 2B-3 - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.
  • Disconnect the engine brake harness from solenoids 2 and 3.
  • Replace the valve cover.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Be sure the Engine Brake Control feature is enabled and that Engine Brake Minimum Vehicle Speed for the Engine Brake Control feature is set to 0.
  • Select 100% braking with the manual dash-switch.
  • Monitor all Engine Brake Output Circuits and Engine Brake Switch Level with the INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle then release the throttle completely.

  • Actuate the engine brakes while monitoring the Engine Brake Output Circuits, Engine Brake Switch Level and Fault Codes.
  • Be sure that all conditions are met for the engine brakes to operate, for example; for example: clutch not depressed and 0% throttle.

Did engine brake number 1 operate?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031.

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Reset all engine brake settings and features to their original settings using the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify the fault code is inactive using the INSITE™ electronic service tool.

Fault Code 2366 inactive?
YES NO
No Repair

Return to troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Apr-2012


FAULT CODE 2366 - Engine Brake Solenoid Number 1 Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake harness, ECM calibration code, and solenoids. |
 | STEP 1A. Check the ECM code and number of brake solenoid connector pins. | ECM code compatible with the number of brake solenoids?
 | STEP 1A-1. Inspect the connector pins. |
 | STEP 1B. Check the engine brake harness and solenoid for an open circuit. | Between 5 and 20 ohms?
 | STEP 1B-1. Inspect the solenoid and engine brake harness connection. |
 | STEP 1B-2. Check the engine brake harness for an open circuit. |
 | STEP 1B-3. Check the engine brake solenoid for an open circuit. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for an open circuit. | Greater than 5.0-VDC?
 | STEP 2A-1. Inspect the ECM and engine harness connector pins. |
 | STEP 2A-2. Check the diagnostic voltage at the ECM, |
 | STEP 2A-3. Check for an open circuit in the engine harness. |
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2B-1. Check for a short circuit to a voltage source. |
 | STEP 2B-2. Inspect the solenoid and engine brake harness connection. |
 | STEP 2B-3. Check for an open circuit in the ECM. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2366 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine brake harness, ECM calibration code, and solenoids.

Guided Step 1A - Check the ECM code compatibility with the number of brake solenoid connector pins.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to the service tool datalink.

Action

Check for active fault codes.

Review the SC Option information for the current ECM code in the ECM to verify that the ECM code is compatible with the number of brake solenoids available on the engine.

ECM code is compatible with the number of brake solenoids available on the engine?
YES NO
No Repair

Select the correct ECM code and transfer the code to the ECM. Refer to Procedure 019-032 in Section 19.

Go to 1A-1

Go to 3A

Guided Step 1A-1 - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Inspect the engine harness and engine brake connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Count the number of connector pins in the engine brake connector.

Two pins correspond to two brake solenoid control and three pins correspond to three brake solenoid control.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the engine brake harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 1 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement and multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.

Action

Inspect the engine brake harness and engine brake solenoid Number 1 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Clean and reconnect the terminal.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the engine brake harness, if necessary. Refer to Procedure 019-136 in Section 19.

No Repair

Go to 2A

Go to 1B-2

Guided Step 1B-2 - Check the engine brake harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the valve cover.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 1.

Action

Check the resistance of the engine brake harness.

  • Use a multimeter to measure the resistance of the engine brake harness, from the engine brake solenoid number 1 SIGNAL pin of the engine brake connector to the solenoid connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement and multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine brake harness. Refer to Procedure 019-136 in Section 19.

Go to 1B-3

Go to 3A

Guided Step 1B-3 - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the terminal to the body of the solenoid.

Use the following procedure for general resistance measurement and multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

  • Use the following procedure in the Troubleshooting and Repair Manual, Signature, ISX and QSX15 Engines, Bulletin 3666239. Refer to Procedure 020-012 in Section 20.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the engine harness for an open circuit.

  • Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin in the engine brake connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance of the engine brake solenoid Number 1 SIGNAL wire between the ECM connector and the engine brake connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement and multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 1 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement and multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid number 1 SIGNAL pin of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 1-VDC?
YES NO
No Repair

There is a short to a voltage source.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Inspect the solenoid and engine brake harness connection.

Conditions

  • If you have done Step 1B-1, skip this step and go to Step 2B-3.
  • Turn keyswitch OFF.
  • Remove valve cover.

Action

Inspect the engine brake harness and engine brake solenoid number 1 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-136 in Section 19.

Clean and connect the terminal.

 No Repair

Go to 2B-3

Go to 2B-3

Guided Step 2B-3 - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.
  • Disconnect the engine brake harness from solenoid 3.
  • Attach a test lead to solenoid number 1 that is long enough to reach outside the valve cover.
  • Replace the valve cover.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Be sure the Engine Brake Control feature is enabled and that Engine Brake Minimum Vehicle Speed for the Engine Brake Control feature is set to zero.
  • Select 100% braking with the manual dash-switch.
  • Monitor all Engine Brake Output Circuits and Engine Brake Switch Level with INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle, then release the throttle completely.

  • Actuate the engine brakes.
  • Using a multimeter, measure the voltage between solenoid number 1 and ground when the engine brakes are actuating.
  • Make sure that all conditions are met for the engine brakes to operate, for example: clutch not depressed and 0% throttle.
  • When repeating the test, the keyswitch must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Did the voltage rise during engine brake activation?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Refer to Procedure 019-362 in Section 19.

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Use INSITE™ electronic service tool to set all engine brake settings and features to their original settings.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2366 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use the INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


FAULT CODE 2367 - Engine Brake Solenoid Number 2 Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake harness and solenoids. |
 | STEP 1A. Inspect the connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the engine brake harness and solenoid for an open circuit. | Between 5 and 20 ohms?
 | STEP 1B-1. Inspect the solenoid and engine brake harness connection. |
 | STEP 1B-2. Check the engine brake harness for an open circuit. |
 | STEP 1B-3. Check the engine brake solenoid for an open circuit. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for an open circuit. | Greater than 5.0-VDC?
 | STEP 2A-1. Inspect the ECM and engine harness connector pins. |
 | STEP 2A-2. Check the diagnostic voltage at the ECM. |
 | STEP 2A-3. Check for an open circuit in the engine harness. |
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2B-1. Check for a short circuit to a voltage source. |
 | STEP 2B-2. Inspect the solenoid and engine brake harness connection. |
 | STEP 2B-3. Check for an open circuit in the ECM. |
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 2367 inactive?
 | STEP 3B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the engine brake harness and solenoids.

Guided Step 1A - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Inspect the engine harness and engine brake connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the engine brake harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 2 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.

Action

Inspect the engine brake harness and engine brake solenoid Number 2 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Clean and connect the terminal.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Replace the engine brake harness, if necessary. Refer to Procedure 019-136 in Section 19.

No Repair

Go to 2A

Go to 1B-2

Guided Step 1B-2 - Check the engine brake harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from engine brake solenoid number 2.

Action

Use a multimeter to measure the resistance of the engine brake harness from the engine brake solenoid Number 2 SIGNAL pin of the engine brake connector to the solenoid connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine brake harness.

Refer to Procedure 019-136 in Section 19.

Go to 1B-3

Go to 3A

Guided Step 1B-3 - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the terminal to the body of the solenoid.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Use the following procedure in the Troubleshooting and Repair Manual, Signature&trade;, ISX and QSX15 Engines, Bulletin 3666239 Refer to Procedure 020-012 in Section 20.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the engine harness for an open circuit.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin in the internal actuator harness connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance of the engine brake solenoid Number 2 SIGNAL wire between the ECM connector and the engine brake connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 2 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 1-VDC?
YES NO
No Repair

There is a short to a voltage source.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Inspect the solenoid and engine brake harness connection.

Conditions

  • If you have done Step 1B-1, skip this step and go to Step 2B-3.
  • Turn keyswitch OFF.
  • Remove the engine valve cover.

Action

Inspect the engine brake harness and engine brake solenoid number 2 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Clean and connect the terminal.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-136 in Section 19.

No Repair

Go to 2B-3

Go to 2B-3

Guided Step 2B-3 - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.
  • Disconnect the engine brake harness from solenoids 1 and 3.
  • Replace the valve cover.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Be sure that the Engine Brake Control feature is enabled and that Engine Brake Minimum Vehicle Speed for the Engine Brake Control feature is set to zero.
  • Select 100 percent braking with the manual dash switch.
  • Use the INSITE™ electronic service tool to monitor all Engine Brake Output Circuits and Engine Brake Switch Level.

Action

Start the engine and accelerate to high idle then release the throttle completely.

  • Actuate the engine brakes while monitoring the Engine Brake Output Circuits, Engine Brake Switch Level and Fault Codes.
  • Be sure all conditions are met for the engine brakes to operate, for example: clutch not depressed and 0 percent throttle.

Did engine brake number 2 operate?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Refer to Procedure 019-362 in Section 19.

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Use INSITE™ electronic service tool to set all engine brake settings and features to their original settings.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use the INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2367 inactive?
YES NO
No Repair

Return to troubleshooting steps.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 11-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake harness and solenoids. |
 | STEP 1A. Inspect the connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the engine brake harness and solenoid for an open circuit. | Between 5 and 20 ohms?
 | STEP 1B-1. Inspect the solenoid and engine brake harness connection. |
 | STEP 1B-2. Check the engine brake harness and solenoid for an open circuit. |
 | STEP 1B-3. Check the engine brake harness for an open circuit. |
 | STEP 1B-4. Check the engine brake solenoid for an open circuit. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for an open circuit. | Greater than 5.0-VDC?
 | STEP 2A-1. Inspect the ECM and engine harness connector pins. |
 | STEP 2A-2. Check the diagnostic voltage at the ECM. |
 | STEP 2A-3. Check for an open circuit in the engine harness. |
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2B-1. Check for a short circuit to a voltage source. |
 | STEP 2B-2. Inspect the solenoid and engine brake harness connection. |
 | STEP 2B-3. Check for an open circuit in the ECM. |
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code | Fault Code 2367 inactive?
 | STEP 3B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the engine brake harness and solenoids.

Guided Step 1A - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Inspect the engine harness and engine brake connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the engine brake harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 2 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.

Action

Inspect the engine brake harness and engine brake solenoid Number 2 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Clean and connect the terminal.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the engine brake harness, if necessary. Refer to Procedure 019-136 in Section 19.

No Repair

Go to 1B-2

Go to 1B-3

Guided Step 1B-2 - Check the engine brake harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 2 SIGNAL pin of the engine brake connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B-3

Guided Step 1B-3 - Check the engine brake harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 2.

Action

Use a multimeter to measure the resistance of the engine brake harness from the engine brake solenoid Number 2 SIGNAL pin of the engine brake connector to the solenoid connector pin..

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine brake harness.

Refer to Procedure 019-136 in Section 19.

Go to 1B-4

Go to 3A

Guided Step 1B-4 - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from the engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the terminal to the body of the solenoid.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Use the following procedure in the Troubleshooting and Repair Manual, Signature™, ISX and QSX15 Engines, Bulletin 3666239. Refer to Procedure 020-012 in Section 20.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the engine harness for an open circuit.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin in the internal actuator harness connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance of the engine brake solenoid Number 2 SIGNAL wire between the ECM connector and the engine brake connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 2 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 2 SIGNAL pin of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 1-VDC?
YES NO
No Repair

There is a short to a voltage source.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Inspect the solenoid and engine brake harness connection.

Conditions

  • If you have done Step 1B-1, skip this step and go to Step 2B-3.
  • Turn keyswitch OFF.
  • Remove the engine valve cover.

Action

Inspect the engine brake harness and engine brake solenoid number 2 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Clean and connect the terminal.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-136 in Section 19.

No Repair

Go to 2B-3

Go to 2B-3

Guided Step 2B-3 - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.
  • Disconnect the engine brake harness from solenoid 3.
  • Attach a test lead to solenoid number 2 that is long enough to reach outside the valve cover.
  • Replace the valve cover.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Be sure that the Engine Brake Control feature is enabled and that Engine Brake Minimum Vehicle Speed for the Engine Brake Control feature is set to zero.
  • Select 100 percent braking with the manual dash switch.
  • Monitor all Engine Brake Output Circuits and Engine Brake Switch Level with INSITE™ electronic service tool.

Action

Start the engine and accelerate to high idle then release the throttle completely.

  • Actuate the engine brakes.
  • Use a multimeter to measure the voltage between solenoid number 2 and ground when the engine brakes are actuating.
  • Be sure all conditions are met for the engine brakes to operate, for example: clutch not depressed and 0 percent throttle.
  • When repeating the test, the keyswitch must be turned off for at least 30 seconds. This allows the ECM to power down completely.

Did the voltage rise during engine brake activation?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Use the following procedure for Inactive or Intermittent Fault Code Refer to Procedure 019-362 in Section 19.

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Use INSITE™ electronic service tool to reset all engine brake settings and features to their original settings.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use the INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2367 inactive?
YES NO
No Repair

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Apr-2012


FAULT CODE 2368 - Engine Brake Solenoid Number 3 Signal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possiblity of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine brake harness and solenoids. |
 | STEP 1A. Inspect the connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the engine brake harness and solenoid for an open circuit. | Between 5 and 20 ohms?
 | STEP 1B-1. Inspect the solenoid and engine brake harness connection. |
 | STEP 1B-2. Check the engine brake harness for an open circuit. |
 | STEP 1B-3. Check the engine brake solenoid for an open circuit. |
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for an open circuit. | Greater than 5.0-VDC?
 | STEP 2A-1. Inspect the ECM and engine harness connector pins. |
 | STEP 2A-2. Check the diagnostic voltage at the ECM |
 | STEP 2A-3. Check for an open circuit in the engine harness. |
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2B-1. Check for a short circuit to a voltage source. |
 | STEP 2B-2. Inspect the solenoid and engine brake harness connection. |
 | STEP 2B-3. Check for an open circuit in the ECM. |
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine brake harness and solenoids.

Guided Step 1A - Inspect the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the engine brake connector.

Action

Inspect the engine harness and engine brake connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the engine brake harness and solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 3 SIGNAL pin of the engine brake connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B-1

Guided Step 1B-1 - Inspect the solenoid and engine brake harness connection.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.

Action

Inspect the engine brake harness and engine brake solenoid Number 3 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Clean and connect the terminal.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the engine brake harness, if necessary. Refer to Procedure 019-136 in Section 19.

No Repair

Go to 3A

Go to 1B-2

Guided Step 1B-2 - Check the engine brake harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from engine brake solenoid Number 3.

Action

Use a multimeter to measure the resistance of the engine brake harness from the engine brake solenoid Number 3 SIGNAL pin of the engine brake connector to the solenoid connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine brake harness.

Refer to Procedure 019-136 in Section 19.

Go to 1B-3

Go to 3A

Guided Step 1B-3 - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from the engine brake solenoid Number 3.

Action

Check the resistance of the solenoid.

  • Use a multimeter to measure the resistance from the terminal to the body of the solenoid.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 20 ohms?
YES NO
No Repair

Replace the engine brake solenoid.

Consult the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check the engine harness for an open circuit.

  • Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin in the engine brake connector of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the diagnostic voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin of the ECM port to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 5.0-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance of the engine brake solenoid Number 3 SIGNAL wire between the ECM connector and the engine brake connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.

Action

Use a multimeter to measure the resistance from the engine brake solenoid Number 3 SIGNAL pin in the ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Use a multimeter to measure the voltage from the engine brake solenoid Number 3 SIGNAL pin of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 1-VDC?
YES NO
No Repair

There is a short to a voltage source.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Inspect the solenoid and engine brake harness connection.

Conditions

  • If you have done Step 1B-1, skip this step and go to Step 2B-3.
  • Turn keyswitch OFF.
  • Remove the engine valve cover.

Action

Inspect the engine brake harness and engine brake solenoid Number 3 connection for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

If there is no visible damage, gently wiggle the connection to determine if the connection is tight. If the solenoid connector can easily be rocked from side to side, the engine brake wiring harness terminal must be crimped to be sure of proper contact.

Clean and connect the terminal.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-136 in Section 19.

No Repair

Go to 2B-3

Go to 2B-3

Guided Step 2B-3 - Check for an open circuit in the ECM.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve cover.
  • Disconnect the engine brake harness from solenoids 1 and 2.
  • Replace the valve cover.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Be sure that the Engine Brake Control feature is enabled and that Engine Brake Minimum Vehicle Speed for the Engine Brake Control feature is set to 0.
  • Select 100 percent braking with the manual dash switch.
  • Use INSITE™ electronic service tool to monitor all Engine Brake Output Circuits and Engine Brake Switch Level.

Action

Start the engine and accelerate to high idle, then release the throttle completely.

  • Actuate the engine brakes while monitoring the Engine Brake Output Circuits, Engine Brake Switch Level and Fault Codes.
  • Be sure all conditions are met for the engine brakes to operate, for example, clutch not depressed and 0 percent throttle.

Did engine brake Number 3 operate?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Refer to Procedure 019-362 in Section 19.

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the ECM code and revision number. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - INSITE™ electronic service tool

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-May-2012


FAULT CODE 2372 - Fuel Filter Restriction Moderately High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Other active or inactive fault codes?
STEP 2. | Check the pressure-side fuel filter. |
 | STEP 2A. Measure the pressure drop across the pressure fuel filter. | Is the pressure drop across the pressure fuel filter less than 517 kPa [75 psi]?
 | STEP 2B. Measure the pressure drop across the pressure fuel filter after filter replacement. | Is the pressure drop across the pressure fuel filter less than 517 kPa [75psi]?
 | STEP 2C. Check the fuel shutoff valve actuator disc. | Debris or damage found on the valve disc, valve seat, or actuator disc?
STEP 3. | Check the fuel inlet restriction. |
 | STEP 3A. Measure the fuel inlet restriction. | Does the fuel inlet restriction exceed 203 mm Hg [8 in Hg] for a clean (new) filter or 305 mm Hg [12 in Hg] for a dirty (old) filter?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2372 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Other active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other fault codes.

Go to 2A

Guided Step 2 - Check the pressure-side fuel filter.

Guided Step 2A - Measure the pressure drop across the pressure-side fuel filter.

Conditions

  • Turn keyswitch ON.
  • Operate engine at high idle.
  • Fuel temperature must be a minimum of 38°C [100°F].

Action

The fuel lift pump must not be running during this check. Wait 2 minutes after keyswitch is ON or disconnect the two-pin power supply from the fuel lift pump.

  • Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load.
  • Measure the pressure out of the fuel pump by using the Compuchek® fitting on the back of the fuel pump. This will be the high pressure reading.
  • Measure the pressure of the fuel rail by using the Compuchek® fitting on the underside of the IFSM. This will be the low pressure reading.
  • Subtract the low reading from the high reading to obtain the pressure drop across the pressure-side fuel filter.

Is the pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
YES NO
No Repair

Replace the pressure-side fuel filter.

Use the following procedure in the Signature™, ISX, QSX15 Engines Troubleshooting and Repair Manual Bulletin 3666239. Refer to Procedure 006-015 in Section 6.

Go to 3A

Go to 2B

Guided Step 2B - Measure the pressure drop across the pressure-side fuel filter after filter replacement.

Conditions

  • Turn keyswitch ON.
  • Fuel lift pump must not be running during this check. Wait 2 minutes after keyswitch is ON or disconnect the two-pin power supply from the fuel lift pump.
  • Operate engine at high idle.
  • Fuel temperature must be a minimum of 38°C [100°F].

Action

Measure the pressure drop across the pressure-side fuel filter while the engine is operating at high idle and no load.

  • Measure the pressure out of the fuel pump. Use the Compuchek™ fitting on the back of the fuel pump. This will be the high pressure reading.
  • Measure the pressure of the fuel rail. Use the Compuchek™ fitting on the underside of the integrated fuel system module. This will be the low pressure reading.

Subtract the low reading from the high reading to obtain the pressure drop across the pressure-side fuel filter.

Is the pressure drop across the pressure-side fuel filter less than 517 kPa [75 psi]?
YES NO
No Repair

Check the fuel shutoff valve components.

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel shutoff valve actuator disc.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel shutoff valve actuator disc.

  • Remove the fuel shutoff solenoid, valve disc, valve seat, and actuator disc. Refer to Procedure 019-050 in Section 19.
  • Inspect the housing, valve disc, valve seat, and actuator disc for dirt, debris, metal parts, bonding separation, corrosion, cracks, or other wear.

Debris or damage found on the valve disc, valve seat, or actuator disc?
YES NO

Clean or replace the damaged fuel shutoff valve component. Refer to Procedure 019-050 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel inlet restriction.

Guided Step 3A - Measure the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

The fuel lift pump must not be running during this check. Wait 2 minutes after keyswitch ON or disconnect the two-pin power supply from the fuel lift pump.

  • Check the fuel inlet restriction.
  • Maximum clean filter: 203 mm Hg [8 in Hg]
  • Maximum dirty filter: 305 mm Hg [12 in Hg]

Use the following procedure in the Signature™, ISX, QSX15 Engines Troubleshooting and Repair Manual, Bulletin 3666239. Refer to Procedure 006-020 in Section 6.

Is fuel inlet restriction less than the specification?
YES NO
No Repair

Replace the suction-side fuel filter or repair the line restriction. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the Calibration Software Phase.

For engines with phase 4 or phase 5 software:

  • Operate the engine above 1800 rpm for 15 seconds with no load.

Note: For engines with phase 4 or phase 5 software, the engine must be run above 1800 rpm with no load in order for this fault code to be disabled.

  • Use INSITE™ electronic service tool to read the fault codes.

If the engine speed is limited due to maximum engine speed without VSS, use one of the following methods to clear this fault code:

  • Start the Setup for Dynamometer Test in INSITE™ electronic service tool and clear the fault code as stated above.
  • Adjust the maximum engine speed without VSS to a value above 1800 rpm and clear the fault code as stated above.
  • Run the unit in first gear with no load at wide open throttle for approximately 15 seconds. NOTE: This method will not work if the load based speed control is set to values less than 1800 rpm.

For engines with phase 6 or greater software:

  • Operate the engine at idle for 10 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location is all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Apr-2012


FAULT CODE 2373 - Exhaust Gas Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2373 active?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2274 active and Fault Code 2273 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2374 active and Fault Code 2373 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2373 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19..

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the exhaust gas pressure SUPPLY pin to the exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the exhaust gas pressure SUPPLY pin to the exhaust gas pressure RETURN pin at the ECM port.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2374 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 2374 active?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active and Fault Code 2374 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2374 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. |
 | STEP 4B. Disable the fault code. | Fault Code 2374 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 2374 active?
YES NO

A defective sensor has been detected.

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 in Section 19.

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

  • Measure the voltage from the exhaust gas pressure sensor SUPPLY pin to the exhaust gas pressure sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES NO

None. The removal and installation of the connector corrected the problem.

A open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2374 inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 21-Mar-2017


FAULT CODE 2375 - Recirculated Exhaust Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758- Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3164596 - male Framatome™ test lead, Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 2. | Check the EGR temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 200 ohms to 2.4M ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2375 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2376 active and Fault Code 2375 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2375 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the EGR temperature sensor signal pin and the EGR temperature sensor return pin at the EGR temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

200 ohms to 2.4M ohms?
YES NO
No Repair

Replace the EGR temperature sensor.

Refer to Procedure 019-378 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR temperature sensor signal pin and EGR temperature sensor return pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 2376 active and Fault Code 2375 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor return pin and the engine harness EGR temperature sensor connector return pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor return pin and the engine harness EGR temperature sensor connector return pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the EGR temperature sensor signal pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2375 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2376 - Recirculated Exhaust Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 2. | Check the EGR temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2376 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2376 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault Code Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 2376 active?
YES NO

A defective sensor has been detected.

Replace the EGR temperature sensor.

Refer to Procedure 019-378 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damage connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the EGR temperature sensor signal pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the EGR temperature sensor signal pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 18.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 2376 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 2376 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to clear inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Apr-2012


FAULT CODE 2377 - Fan Control Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2377 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10k ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply line and return circuit. | Greater than 5.0 VDC?
 | STEP 2D. Determine return circuit location. | Return circuit wired to ECM?
 | STEP 2D-1. Check for an open circuit in the fan control solenoid actuator return circuit. |
 | STEP 2E. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2F. Check for an open fan control return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM power harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 2377 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2377 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 2377 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Measure the resistance and check for an open circuit between the fan control SIGNAL pin and the fan control RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Replace the fan control solenoid.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin on the actuator connector of the OEM harness.

Greater than 5.0 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Determine the return circuit location.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Determine if the relay return circuit is wired to the ECM, or to engine block or chassis ground.

Refer to the OEM wiring harness.

Return circuit wired to ECM?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check for an open circuit in the fan control solenoid actuator return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Harness connector to connector continuity - pin-to-ground continuity check:

  • Measure the resistance between the OEM harness fan control RETURN pin and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

There is an open return circuit in the OEM wiring.

Locate the source of the open return circuit in the OEM wiring. Refer to the OEM wiring diagram.

Go to 3A

Go to 4A

Guided Step 2E - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2F

Guided Step 2F - Check for an open fan control return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Measure the resistance of the fan control RETURN wire between the OEM harness ECM connector and the fan control solenoid connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit in the fan control SIGNAL circuit.

  • Measure the resistance of the fan control SIGNAL wire between the OEM harness ECM connector and the fan control solenoid connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM power harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a short circuit between the OEM harness and the OEM power harness.

  • Check for a short circuit between the fan control SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM power harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 2377 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

There was a loose connection in fan circuit that has been corrected.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Cycle the fan with a manual switch, or by unplugging the Intake Manifold Temperature Sensor, and/or the Coolant Temperature Sensor.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 2377 inactive?
YES NO

Return to the troubleshooting steps or contact a Cummis® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2384 - Variable Geometry Turbocharger Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2384 active?
STEP 2. | Check the turbocharger control valve circuit. |
 | STEP 2A. Inspect the turbocharger control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2385 is active and Fault Code 2384 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2384 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2385 active and Fault Code 2384 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2384 is inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2384 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the turbocharger control valve circuit.

Guided Step 2A - Inspect the turbocharger control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Inspect the engine harness and turbocharger control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the turbocharger control valve connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 is active and Fault Code 2384 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger control valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 is active?
YES NO

A damaged turbocharger control valve has been detected.

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and turbocharger control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the turbocharger control valve connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 active and Fault Code 2384 inactive?
YES NO
No Repair

Repace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger control valve SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger control valve SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2384 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Apr-2012


FAULT CODE 2385 - Variable Geometry Turbocharger Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2385 active?
STEP 2. | Check the turbocharger control valve and circuit. |
 | STEP 2A. Inspect the turbocharger control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger control valve diagnostic signal voltage and return circuit. | Greater than 4.5-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2384 active and fault code 2385 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2385 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the diagnostic signal voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2385 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger control valve and circuit.

Guided Step 2A - Inspect the turbocharger control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Inspect the engine harness turbocharger control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the turbocharger control valve diagnostic signal voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the turbocharger control valve diagnostic voltage and return circuit.

  • Measure the diagnostic voltage between the turbocharger control valve SIGNAL pin and the turbocharger control valve RETURN pin at the turbocharger control valve connector of the engine harness.
  • Check the connection of the turbocharger control valve ground terminal from the engine harness to the engine block ground. Connection must be clean and tight.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger control valve SIGNAL pin at the turbocharger control valve connector of the engine harness and engine block ground.

  • Check for the appropriate circuit response after 15 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 active and Fault Code 2385 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 is active?
YES NO

A damaged turbocharger control valve has been detected

Replace the turbocharger control valve.

Refer to Procedure 019-388 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the diagnostic signal voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the turbocharger control valve diagnostic signal voltage.

  • Measure the voltage between the turbocharger control valve SIGNAL pin and the engine block ground at the ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Greater than 4.5-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the fault.

An open RETURN circuit has been detected in the engine harness.

Check the connection of the turbocharger control valve ground terminal from the engine harness to the engine block ground.

If the connection is clean and tight, repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger control valve SIGNAL pin and engine block ground at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 active and Fault Code 2385 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2385 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2551 - Fuel System Overfueling

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes |
 | STEP 1A. Inspect for active or high inactive counts of Fault Code 449. | Fault Code 449 active?
 | STEP 1B. Check for air in the pressure-side fuel. | Air in fuel?
 | STEP 1C. Measure for drain line restriction. | Less than 229 mm Hg [9.0 in Hg]?
STEP 2. | Check the rear fueling actuator performance. |
 | STEP 2A. Inspect the rear fueling actuator | Fault Code 2552 inactive?
STEP 3. | Check the rear timing actuator performance. |
 | STEP 3A. Inspect the rear timing actuator. | Fault Code 2552 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 2551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Inspect for active or high inactive counts of Fault Code 449.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active?
YES | NO
No Repair | No Repair

Fault Code 449 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for air in the pressure-side fuel.

  • Use the following procedure in Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-003 in Section 6.

Air in fuel?
YES NO

Use the following procedure in Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-003 in Section 6.

No Repair

Go to 4A

Go to 1C

Guided Step 1C - Measure for drain line restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the drain line.

  • Measure the drain line restriction.

Use the following procedure in Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-012 in Section 6.

Less than 229 mm Hg [9.0 in Hg]?
YES NO
No Repair

Use the following procedure in Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-012 in Section 6.

Go to 2A

Go to 4A

Guided Step 2 - Check the rear fueling actuator performance.

Guided Step 2A - Inspect the rear fueling actuator

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the front and rear fueling actuators. Inspect the actuators for damage or debris.

Refer to Procedure 019-110 in Section 19..

  • Start the engine and operate above 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2551 is inactive.

Fault Code 2552 active?
YES NO

Return the front and rear fueling actuators to their original positions.

Refer to Procedure 019-110 in Section 19..

Replace the rear fueling actuator.

Return the front and rear fueling actuators to their original positions. Refer to Procedure 019-110 in Section 19.

Go to 4A

Go to 3A

Guided Step 3 - Check the rear timing actuator performance.

Guided Step 3A - Inspect the rear timing actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the front and rear timing actuators. Inspect the actuators for damage or debris.

Start the engine and run above 1000 rpm for 1 minute.

Use INSITE™ electronic service tool to verify Fault Code 2552 is active.

Fault Code 2552 inactive?
YES NO

Return the front and rear fueling actuators to their original positions.

Replace the rear timing actuator.

Refer to Procedure 019-111 in Section 19.

Return the front and rear timing actuators to their original positions.

Refer to Procedure 019-111 in Section 19.

Go to 3B

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and run above 1000 rpm for 1 minute.
  • Use INSITE electronic service tool to verify that Fault Code 2551 is inactive.

Fault Code 2551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2552 - Fuel System Overfueling

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes |
 | STEP 1A. Inspect for active or high inactive counts of Fault Code 449. | Fault Code 449 active?
 | STEP 1B. Check for air in the pressure-side fuel. | Air in fuel?
 | STEP 1C. Measure for drain line restriction. | Less than 229 mm Hg [9.0 in Hg]?
STEP 2. | Check the rear fueling actuator performance. |
 | STEP 2A. Inspect the rear fueling actuator | Fault Code 2551 inactive?
STEP 3. | Check the rear timing actuator performance. |
 | STEP 3A. Inspect the rear timing actuator. | Fault Code 2551 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 2551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Inspect for active or high inactive counts of Fault Code 449.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active?
YES | NO
No Repair | No Repair

Fault Code 449 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air in the pressure-side fuel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for air in the pressure-side fuel.

  • Use the following procedure in Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-003 in Section 6.

Air in fuel?
YES NO

Use the following procedure in Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-003 in Section 6.

No Repair

Go to 4A

Go to 1C

Guided Step 1C - Measure for drain line restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the drain line.

  • Measure the drain line restriction.

Use the following procedure in Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-012 in Section 6.

Less than 229 mm Hg [9.0 in Hg]?
YES NO
No Repair

Use the following procedure in Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 006-012 in Section 6.

Go to 2A

Go to 4A

Guided Step 2 - Check the rear fueling actuator performance.

Guided Step 2A - Inspect the rear fueling actuator

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the front and rear fueling actuators. Inspect the actuators for damage or debris.

Refer to Procedure 019-110 in Section 19..

  • Start the engine and operate above 1000 rpm for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2551 is inactive.

Fault Code 2551 active?
YES NO

Replace the rear fueling actuator (return the front actuator to its original position).

Refer to Procedure 019-110 in Section 19..

Return the front and rear fueling actuators to their original positions. Refer to Procedure 019-110 in Section 19.

Go to 4A

Go to 3A

Guided Step 3 - Check the rear timing actuator performance.

Guided Step 3A - Inspect the rear timing actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Swap the front and rear timing actuators. Inspect the actuators for damage or debris.

Refer to Procedure 019-111 in Section 19.

Start the engine and run above 1000 rpm for 1 minute.

Use INSITE™ electronic service tool to verify Fault Code 2552 is active.

Fault Code 2551 inactive?
YES NO

Return the front and rear fueling actuators to their original positions.

Replace the rear timing actuator.

Refer to Procedure 019-111 in Section 19.

Return the front and rear timing actuators to their original positions.

Refer to Procedure 019-111 in Section 19.

Go to 3B

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and run above 1000 rpm for 1 minute.
  • Use INSITE electronic service tool to verify that Fault Code 2551 is inactive.

Fault Code 2551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2554 - Exhaust Gas Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine speed and camshaft position fault codes. |
 | STEP 1A. Check for Fault Code 689 or 778. | Fault Code 689 or 778 active?
STEP 2. | Check for valid fault codes. |
 | STEP 2A. Check for an active Fault Code 2554. | Fault Code 2554 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2554 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for engine speed and camshaft position fault codes.

Guided Step 1A - Check for Fault Code 689 or 778.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 or 778 active?
YES | NO
No Repair | No Repair

Go to Fault Code 689 or 778 troubleshooting tree

Go to 2A

Guided Step 2 - Check for valid fault codes.

Guided Step 2A - Check for an active Fault Code 2554.

Conditions

  • Engine oil temperature is 7°C [45°F] or higher.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn shop exhaust fans off (if applicable).

Action

Check for an active fault code.

  • Wait 30 seconds
  • Turn the keyswitch ON and wait 15 seconds.

Fault Code 2554 inactive?
YES NO
No Repair

Replace the exhaust gas pressure sensor.

Refer to Procedure 019-376 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault code

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Engine oil temperature is 7°C [45°F] or higher.
  • Turn shop exhaust fans off (if applicable).

Action

Disable the fault code.

  • Turn the keyswitch ON and wait 15 seconds.
  • Use INSITE™ electronic service tool to verify that Fault Code 2554 is inactive.

Fault Code 2554 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2961 - EGR Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 2277, 2348, 2357, or 2359 inactive?
STEP 2. | Check the air handling system. |
 | STEP 2A. Inspect the air handling system for intake manifold, charge air cooler, or EGR leaks. | Any leaks detected?
 | STEP 2B. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on turbocharger blades?
 | STEP 2C. Check the variable geometry actuator rod for correct travel. | Turbocharger actuator rod extend between 10 and 12 mm [0.394 and 0.472 in]?
 | STEP 2C-1. Check for air leaks and inspect air lines. |
 | STEP 2C-2. Check for air pressure at the turbocharger control valve. |
 | STEP 2C-3. Check for air pressure at the turbocharger control valve outlet. |
 | STEP 2C-4. Check for correct turbocharger actuator travel. |
 | STEP 2C-5. Check for air pressure at the turbocharger control shutoff valve outlet. |
 | STEP 2C-6. Check for air pressure at the turbocharger control shutoff valve inlet. |
 | STEP 2C-7. Check for plugged turbocharger control shutoff valve filter. |
 | STEP 2D. Perform INSITE™ Turbocharger Operational Test. | Turbocharger Operational Test passes?
STEP 3. | Check the EGR differential pressure tubes. |
 | STEP 3A. Check the EGR differential pressure tubes for cracks, restrictions, or leaks. | Cracks, restrictions, or leaks present?
STEP 4. | Check the EGR cooler. |
 | STEP 4A. Check the EGR cooler for fouling. | EGR cooler efficiency parameter greater than 50 percent after 4 minutes?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2961 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES NO

Troubleshoot the active fault codes.

 No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2277, 2348, 2357, or 2359 inactive?
YES NO

Troubleshoot inactive fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Inspect the air handling system for intake manifold, charge-air cooler, or EGR leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air handling system for intake manifold, charge air cooler, or EGR leaks.

Inspect the following for leaks:

  • Charge-air cooler - Use the following procedure in Service Manual, Signature™, ISX, and QSX15, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.
  • Air intake and exhaust - Use the following procedure in Service Manual, Signature™, ISX, and QSX15, Bulletin 3666239. Refer to Procedure 010-024 in Section 10.
  • EGR transfer tubes and hoses.

Any leaks detected?
YES NO

Repair Leaks

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the turbcharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

Damage or wear found on the turbocharger blades?
YES NO

Replace the turbocharger.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the variable geometry actuator rod for correct travel

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to start the Turbocharger Actuator Test.

  • Adjust the delay timer in the Turbocharger Actuator Test so that the rod movement can be observed.
  • Select the Retract Actuator position with INSITE™ electronic service tool.
  • Mark or scribe the variable geometry actuator rod at the base of the actuator.
  • Select the Extend Actuator position with INSITE™ electronic service tool.
  • Measure the rod travel by measuring the distance from the base of the variable geometry actuator to the scribe mark.
  • Use a straight edge steel ruler.

The turbocharger actuator should move quickly and crisply. If the actuator rod movement is slow, there could be a problem with the air supply or mechanical problems with the variable geometry turbocharger assembly.

Turbocharger actuator rod extend between 10 and 12 mm [0.394 and 0.472 in]?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for air leaks and inspect air lines.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position. Listen for air leaks at the following components:

  • Turbocharger control valve
  • Turbocharger control shutoff valve inlet connection
  • Turbocharger control shutoff valve outlet connection
  • Turbocharger control valve inlet connection
  • Turbocharger control valve outlet connection
  • Turbocharger actuator inlet connection
  • Turbocharger actuator
  • All air lines including OEM supply line to turbocharger control shutoff valve, turbocharger control shutoff valve to turbocharger control valve, and turbocharger control valve to turbocharger actuator.

Air leaks found in the system?
YES NO

Repair air leaks.

 No Repair

Go to 5A

Go to 2C-2

Guided Step 2C-2 - Check for air pressure at the turbocharger control valve.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Remove the air line connection at the outlet of the turbocharger control valve.

Install an M12 Compuchek® fitting at the outlet of the turbocharger control valve.

Install an air pressure gauge that is capable of reading at least 1034 kPa [150 psi].

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Vehicle air tank pressure present at the turbocharger control valve outlet?
YES | NO
No Repair | No Repair

Go to 2C-3

Go to 2C-5

Guided Step 2C-3 - Check for air pressure at the turbocharger control valve outlet.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Retract Actuator position.
  • Remove the air line connection at the outlet of the turbocharger control valve.

Air heard escaping from the turbocharger control valve outlet?
YES NO

Replace the turbocharger control valve.

  • Refer to Procedure 019-388 in Section 19.

No Repair

Go to 5A

Go to 2C-4

Guided Step 2C-4 - Check for correct turbocharger actuator travel.

Conditions

  • Turn engine OFF.
  • Disconnect the variable geometry actuator rod from the turbocharger cross-shaft.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use the INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position.

Turbocharger actuator rod travel at least 12 mm [0.472 in]?
YES NO

Replace the turbocharger assembly.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Replace the turbocharger actuator.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-113 in Section 10.

Go to 5A

Go to 5A

Guided Step 2C-5 - Check for air pressure at the turbocharger control shutoff valve outlet.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Loosen the air line connection at the turbocharger control shutoff valve outlet.

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position.

Air heard escaping from the turbocharger control shutoff valve outlet?
YES NO

Replace the turbocharger control valve.

  • Refer to Procedure 019-388 in Section 19.

No Repair

Go to 5A

Go to 2C-6

Guided Step 2C-6 - Check for air pressure at the turbocharger control shutoff valve inlet.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Verify vehicle air tanks are fully charged.

Action

Verify the OEM air supply line is connected to the correct port on the turbocharger control shutoff valve.

  • Loosen the air line connection at the turbocharger control shutoff valve inlet.

Air heard escaping from the turbocharger control shutoff valve inlet?
YES NO
No Repair

Repair the air supply from the OEM air tanks.

Go to 2C-7

Go to 5A

Guided Step 2C-7 - Check for a plugged turbocharger control shutoff valve filter.

Conditions

  • Remove the turbocharger control shutoff valve filter.
  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position.

Listen for an air leak at the turbocharger control shutoff valve filter head.

Air leak present at the turbocharger control shutoff valve filter head?
YES NO

Replace the turbocharger control shutoff valve filter.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-114 in Section 10.

Replace the turbocharger control shutoff valve.

  • Refer to Procedure 019-386 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Perform INSITE™ electronic service tool Turbocharger Operational Test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run it at low idle.

Action

Use INSITE™ electronic service tool to select the EGR/VGT Operational Test.

Before performing INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, be sure the ECM Calibration Software Phase is updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Run the Turbocharger Operational Test.

Turbocharger Operational Test passes?
YES NO
No Repair

Replace the variable geometry turbocharger.

  • Use the following procedure in Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Go to 3A

Go to 5A

Guided Step 3 - Check the EGR differential pressure tubes.

Guided Step 3A - Check the EGR differential pressure tubes for cracks, restrictions, or leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure tubes for cracks, restrictions, or leaks.

  • Soot streaks can indicate the line is loose or cracked.

Cracks, restrictions, or leaks present?
YES NO

Tighten or replace the EGR differential pressure tubes.

  • Use the following procedure in Service Manual, Signature, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the EGR cooler

Guided Step 4A - Check the EGR cooler for fouling.

Conditions

  • Turn fan control switch in OFF position.
  • Turn air conditioning OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Make sure coolant temperature is above 79°C [175°F].

Action

If the effectiveness of the cooler is degraded, the cooler will not effectively cool the exhaust gas and will cause the EGR temperature to rise.

  • Start the engine and set the PTO speed to 1300 rpm.
  • Perform the EGR Valve Test in INSITE™ electronic service tool and command the EGR valve 100 percent open.
  • Start INSITE™ electronic service tool monitor screen and monitor EGR cooler efficiency.
  • Run the engine at this condition for 4 minutes.
  • After 4 minutes, record the value of EGR cooler efficiency.

If the engine fan activates during this test, the test must be started over from the beginning.

EGR cooler efficiency parameter greater than 50 percent after 4 minutes?
YES NO
No Repair

Clean or replace the EGR cooler.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-019

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: This fault code will not become active without a load in the shop. The engine must be loaded to trip this fault code, and to determine if the failure has been found and repaired.

Fault Code 2961 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2962 - EGR Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 245, 2277, 2348, 2357, or 2359 inactive?
STEP 2. | Check the air handling system. |
 | STEP 2A. Inspect the air handling system for intake manifold, charge-air cooler, or EGR leaks. | Any leaks detected?
 | STEP 2B. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on turbocharger blades?
 | STEP 2C. Check the variable geometry actuator rod for correct travel. | Turbocharger actuator rod extends between 10 and 12 mm [0.394 and 0.472 in]?
 | STEP 2C-1. Check for air leaks and inspect air lines. |
 | STEP 2C-2. Check for air pressure at the turbocharger control valve. |
 | STEP 2C-3. Check for air pressure at the turbocharger control valve outlet. |
 | STEP 2C-4. Check for correct turbocharger actuator travel. |
 | STEP 2C-5. Check for air pressure at the turbocharger control shutoff valve outlet. |
 | STEP 2C-6. Check for air pressure at the turbocharger control shutoff valve inlet. |
 | STEP 2C-7. Check for plugged turbocharger control shutoff valve filter. |
 | STEP 2D. Perform INSITE™ electronic service tool Turbocharger Operational Test. | Turbocharger Operational Test passes?
STEP 3. | Check the EGR differential pressure tubes. |
 | STEP 3A. Check the EGR differential pressure tubes for cracks, restrictions, or leaks. | Cracks, restrictions, or leaks present?
STEP 4. | Check the EGR cooler. |
 | STEP 4A. Check the EGR cooler for fouling. | EGR cooler efficiency parameter greater than 50 percent after 4 minutes?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2962 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES NO

Troubleshoot the active fault codes.

 No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2277, 2348, 2357, or 2359 inactive?
YES NO

Troubleshoot inactive fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Inspect the air handling system for intake manifold, charge air cooler, or EGR leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air handling system for intake manifold, charge air cooler, or EGR leaks.

Inspect the following for leaks:

  • Charge-air cooler - Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.
  • Air intake and exhaust - Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-024 in Section 10.
  • EGR transfer tubes and hoses.

Any leaks detected?
YES NO

Repair leaks

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the variable geometry actuator rod for correct travel.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to start the Turbocharger Actuator Test.

  • Adjust the delay timer in the Turbocharger Actuator Test so that the rod movement can be observed.
  • Select the Retract Actuator position with INSITE™ electronic service tool.
  • Mark or scribe the variable geometry actuator rod at the base of the actuator.
  • Select the Extend Actuator position with INSITE™ electronic service tool.
  • Measure the rod travel by measuring the distance from the base of the variable geometry actuator to the scribe mark.
  • Use a straight edge steel ruler.

The turbocharger actuator should move quickly and crisply. If the actuator rod movement is slow, there could be a problem with the air supply or mechanical problems with the variable geometry turbocharger assembly.

Turbocharger actuator rod extend between 10 and 12 mm [0.394 and 0.472 in]?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for air leaks and inspect air lines.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position. Listen for air leaks at the following components:

  • Turbocharger control valve
  • Turbocharger control shutoff valve inlet connection
  • Turbocharger control shutoff valve outlet connection
  • Turbocharger control valve inlet connection
  • Turbocharger control valve outlet connection
  • Turbocharger actuator inlet connection
  • Turbocharger actuator
  • All air lines including OEM supply line to turbocharger control shutoff valve, turbocharger control shutoff valve to turbocharger control valve, and turbocharger control valve to turbocharger actuator.

Air leaks found in the system?
YES NO

Repair air leaks.

 No Repair

Go to 5A

Go to 2C-2

Guided Step 2C-2 - Check for air pressure at the turbocharger control valve.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Remove the air line connection at the outlet of the turbocharger control valve.

Install an M12 Compuchek® fitting at the outlet of the turbocharger control valve.

Install an air pressure gauge that is capable of reading at least 1034 kPa [150 psi].

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position.

Vehicle air tank pressure present at the turbocharger control valve outlet?
YES | NO
No Repair | No Repair

Go to 2C-3

Go to 2C-5

Guided Step 2C-3 - Check for air pressure at the turbocharger control valve outlet.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Retract Actuator position.
  • Remove the air line connection at the outlet of the turbocharger control valve.

Air heard escaping from the turbocharger control valve outlet?
YES NO

Replace the turbocharger control valve.

  • Refer to Procedure 019-388 in Section 19.

No Repair

Go to 5A

Go to 2C-4

Guided Step 2C-4 - Check for correct turbocharger actuator travel.

Conditions

  • Turn engine OFF.
  • Disconnect the variable geometry actuator rod from the turbocharger cross-shaft.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position.

Turbocharger actuator rod travel at least 12 mm [0.472 in]?
YES NO

Replace the turbocharger assembly.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Replace the turbocharger actuator.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-113 in Section 10.

Go to 5A

Go to 5A

Guided Step 2C-5 - Check for air pressure at the turbocharger control shutoff valve outlet.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Loosen the air line connection at the turbocharger control shutoff valve outlet.

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position.

Air heard escaping from the turbocharger control shutoff valve outlet?
YES NO

Replace the turbocharger control valve.

  • Refer to Procedure 019-388 in Section 19.

No Repair

Go to 5A

Go to 2C-6

Guided Step 2C-6 - Check for air pressure at the turbocharger control shutoff valve inlet.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Verify vehicle air tanks are fully charged.

Action

Verify the OEM air supply line is connected to the correct port on the turbocharger control shutoff valve.

  • Loosen the air line connection at the turbocharger control shutoff valve inlet.

Air be heard escaping from the turbocharger control shutoff valve inlet?
YES NO
No Repair

Repair the air supply from the OEM air tanks.

Go to 2C-7

Go to 5A

Guided Step 2C-7 - Check for plugged turbocharger control shutoff valve filter.

Conditions

  • Remove the turbocharger control shutoff valve filter.
  • Turn engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position.

Listen for an air leak at the turbocharger control shutoff valve filter head.

Air leak present at the turbocharger control shutoff valve filter head?
YES NO

Replace the turbocharger control shutoff valve filter.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-114 in Section 10.

Replace the turbocharger control shutoff valve.

  • Refer to Procedure 019-386 in Section 19.

Go to 5A

Go to 5A

Guided Step 2D - Perform INSITE™ electronic service tool turbocharger operational test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run it at low idle.

Action

Use INSITE™ electronic service tool to select the EGR/VGT Operational Test.

Before performing INSITE™ electronic service tool EGR Valve and EGR Valve/Turbocharger Operational Test, be sure the ECM Calibration Software Phase is updated to the latest Software Phase. The ECM Calibration Phase Software can be checked in INSITE™ electronic service tool, under 'Features and Parameters'. Expand the selection for 'System ID and Dataplate' and go to 'Calibration Information'. If the Software Phase is earlier than shown below, recalibrate the ECM using the January 2006 INCAL™ CD-ROM, or later. Engines with the Software Phase listed below or later do not require a recalibration.

ISX engines with CM870 (engines built after January 2004) require Software Phase 06050302.

ISX engines with CM870 (engines built before January 2004) require no changes at this time.

This is a warrantable calibration change.

  • Run the Turbocharger Operational Test.

Turbocharger Operational Test passes?
YES NO
No Repair

Replace the variable geometry turbocharger.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Go to 3A

Go to 5A

Guided Step 3 - Check the EGR differential pressure tubes.

Guided Step 3A - Check the EGR differential pressure tubes for cracks, restrictions, or leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure tubes for cracks, restrictions, or leaks.

  • Soot streaks can indicate the line is loose or cracked.

Cracks, restrictions, or leaks present?
YES NO

Tighten or replace the EGR differential pressure tubes.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-026 in Section 11.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the EGR cooler.

Guided Step 4A - Check the EGR cooler for fouling.

Conditions

  • Turn fan control switch in OFF position.
  • Turn air conditioning OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Make sure coolant temperature is above 79°C [175°F].

Action

If the effectiveness of the cooler is degraded, the cooler will not effectively cool the exhaust gas and will cause the EGR temperature to rise.

  • Start the engine and set the PTO speed to 1300 rpm.
  • Use INSITE™ electronic service tool to perform the EGR Valve Test and command the EGR valve 100 percent open.
  • Start INSITE™ electronic service tool monitor screen and monitor EGR cooler efficiency.
  • Operate the engine at this condition for 4 minutes.
  • After 4 minutes, record the value of EGR cooler efficiency.

If the engine fan activates during this test, the test must be started over from the beginning.

If the EGR cooler efficiency parameter is displayed as "Not Available" in INSITE™ electronic service tool, monitor Exhaust Gas Temperature (Calculated), EGR Temperature and Engine Coolant Temperature and record the values after 4 minutes.

  • Use the formula (Exhaust Gas Temperature (Calculated) MINUS EGR Temperature) DIVIDED BY (Exhaust Gas Temperature (Calculated) MINUS Engine Coolant Temperature) MULTIPLED BY 100 to obtain EGR cooler efficiency.

EGR cooler efficiency parameter greater than 50 percent after 4 minutes?
YES NO
No Repair

Clean or replace the EGR cooler.

  • Use the following procedure in Service Manual, Signature™, ISX, and QSX15 Engines, Bulletin 3666239. Refer to Procedure 011-019 in Section 11.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

This fault code will not become active without a load in the shop. The engine must be loaded to trip this fault code and to determine if the failure has been found and repaired.

Fault Code 2962 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


FAULT CODE 2963 - Engine Coolant Temperature High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2963. | Active or inactive counts of Fault Code 2963?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2963.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ to read the fault codes.

Active or inactive counts of Fault Code 2963?
YES | NO
No Repair | No Repair

Reference the Engine Coolant Temperature Above Normal - Gradual Overheat or Sudden Overheat symptom tree in the Troubleshooting and Repair Manual, Signature™/ISX/QSX Engines, Bulletin 3666239.

Repair complete

Last Modified: 16-Apr-2012


FAULT CODE 2964 - Intake Manifold Air Temperature High - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active counts or high inactive counts of Fault Code 245, 2346, 2347, 2348,2349, 2351, 2352, 2353, 2355, 2357, 2377, 2961, or 2962?
STEP 2. | Check for sensor accuracy. |
 | STEP 2A. Check for accuracy of temperature sensors. | Is intake manifold temperature within 5.5°C [10°F] of ambient air temperature?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active counts or high inactive counts of Fault Code 245, 2346, 2347, 2348, 2349, 2351, 2352, 2353, 2355, 2357, 2377, 2961, or 2962?

YES | NO
No Repair | No Repair

See Fault Code 245, 2346, 2347, 2348,2349, 2351, 2352, 2353, 2355, 2357, 2377, 2961, or 2962.

Go to 2A

Guided Step 2 - Check for sensor accuracy.

Guided Step 2A - Check for accuracy of temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service too to monitor the intake manifold temperature against ambient air temperature.

Is intake manifold temperature within 5.5°C [10°F] of ambient air temperature?
YES NO

See the Intake Manifold Air Temperature Above Specification symptom tree in the Signature™, ISX and QSX15 Service Manual, Bullet 3666239.

Replace the intake manifold temperature sensor. Refer to Procedure 019-059.

Appropriate troubleshooting tree

Repair complete

Last Modified: 15-Apr-2012


FAULT CODE 2973 - Intake Manifold Pressure - Data Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or high inactive counts of Fault Codes 122, 123, 221, 222, 295, 595, 687, or 2345?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge-air cooler for leaks. | Air leak present?
 | STEP 2B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 2C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 2D. Check for a restricted charge-air cooler. | Charge-air cooler within specifications?
STEP 3. | Check the turbocharger speed sensor. |
 | STEP 3A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 3B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
STEP 4. | Check the intake manifold pressure sensor. |
 | STEP 4A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
STEP 5. | Check the barometric pressure sensor. |
 | STEP 5A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 102 mm Hg [4 in Hg] of local barometric pressure?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2973 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Codes 122, 123, 221, 222, 295, 595, 687, or 2345?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air cooler for leaks.

Conditions

  • Operate engine.

Action

Check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Operate engine.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 2C

Guided Step 2C - Inspect turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Use the following procedure in the Signature™, ISX, and QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-033 in Section 10.

Damage or wear found on turbocharger blades?
YES NO

Replace the turbocharger.

No Repair

Go to 6A

Go to 2D

Guided Step 2D - Check for a restricted charge-air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge-air cooler.

  • Use the following procedure in the Signature™/ISX/QSX15 Service Manual, Bulletin 3666239. Refer to Procedure 010-027 in Section 10.

Charge-air cooler within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, if necessary.

Go to 3A

Go to 6A

Guided Step 3 - Check the turbocharger speed sensor.

Guided Step 3A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

Clean, repair, or replace the damaged connector, pins, or turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the intake manifold pressure sensor.

Guided Step 4A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine at high idle.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm Hg [5 in Hg] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 10.

Go to 5A

Go to 6A

Guided Step 5 - Check the barometric pressure sensor.

Guided Step 5A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for barometric pressure to the local barometric pressure.

Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading is within 102 mm Hg [4 in Hg] of local barometric pressure?
YES NO
No Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Raise engine speed to 1500 rpm and hold for 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2973 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Clear the inactive fault codes using INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 19-Aug-2013


FAULT CODE 9121 - EGR Valve Actuator Over Temperature (Calculated) - Data Above Normal Range

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes |
 | STEP 1A. Check for fault codes | Active or inactive fault codes?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault codes | Fault Code 9121 inactive?
 | STEP 2B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Read the fault codes

Guided Step 1A - Check for fault codes

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other active fault codes

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 9121 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Apr-2012


INDEX
70-fc111.htm

70-t05-111.htm

70-fc122.htm

70-t05-122.htm

70-fc123.htm

70-t05-123.htm

70-fc131.htm

70-t05-131.htm

70-fc132.htm

70-t05-132.htm

70-fc133.htm

70-t05-133.htm

70-fc134.htm

70-t05-134.htm

70-fc135.htm

70-t05-135.htm

70-fc141.htm

70-t05-141.htm

70-fc143.htm

70-t05-143.htm

70-fc144.htm

70-t05-144.htm

70-fc145.htm

70-t05-145.htm

70-fc151.htm

70-t05-151.htm

70-fc153.htm

70-t05-153.htm

70-fc154.htm

70-t05-154.htm

70-fc155.htm

70-t05-155.htm

70-fc187.htm

70-t05-187.htm

70-fc195.htm

70-fc195-2wire.htm

70-t05-195-2wire.htm

70-fc195-3wire.htm

70-t05-195-3wire.htm

70-fc196.htm

70-fc196-2wire.htm

70-t05-196-2wire.htm

70-fc196-3wire.htm

70-t05-196-3wire.htm

70-fc197.htm

70-t05-197.htm

70-fc212.htm

70-t05-212.htm

70-fc213.htm

70-t05-213.htm

70-fc214.htm

70-t05-214.htm

70-fc219.htm

70-t05-219.htm

70-fc221.htm

70-t05-221.htm

70-fc222.htm

70-t05-222.htm

70-fc223.htm

70-t05-223.htm

70-fc224.htm

70-t05-224.htm

70-fc227.htm

70-t05-227.htm

70-fc234.htm

70-t05-234.htm

70-fc241.htm

70-t05-241.htm

70-fc242.htm

70-t05-242.htm

70-fc245.htm

70-t05-245.htm

70-fc249.htm

70-t05-249.htm

70-fc254.htm

70-t05-254.htm

70-fc255.htm

70-t05-255.htm

70-fc256.htm

70-t05-256.htm

70-fc259.htm

70-t05-259.htm

70-fc263.htm

70-t05-263.htm

70-fc265.htm

70-t05-265.htm

70-fc284.htm

70-t05-284.htm

70-fc285.htm

70-t05-285.htm

70-fc286.htm

70-t05-286.htm

70-fc287.htm

70-t05-287.htm

70-fc288.htm

70-t05-288.htm

70-fc295.htm

70-t05-295.htm

70-fc319.htm

70-t05-319.htm

70-fc338.htm

70-t05-338.htm

70-fc339.htm

70-t05-339.htm

70-fc341.htm

70-t05-341.htm

70-fc343.htm

70-t05-343.htm

70-fc352.htm

70-t05-352.htm

70-fc386.htm

70-t05-386.htm

70-fc387.htm

70-t05-387.htm

70-fc415.htm

70-t05-415.htm

70-fc418.htm

70-t05-418.htm

70-fc426.htm

70-t05-426.htm

70-fc428.htm

70-t05-428.htm

70-fc429.htm

70-t05-429.htm

70-fc431.htm

70-fc431iss.htm

70-t05-431iss.htm

70-fc431niss.htm

70-t05-431niss.htm

70-fc431sss.htm

70-t05-431sss.htm

70-fc432.htm

70-t05-432.htm

70-fc433.htm

70-t05-433.htm

70-fc434.htm

70-t05-434.htm

70-fc435.htm

70-t05-435.htm

70-fc443.htm

70-t05-443.htm

70-fc449.htm

70-t05-449.htm

70-fc482.htm

70-t05-482.htm

70-fc486.htm

70-t05-486.htm

70-fc546.htm

70-t05-546.htm

70-fc547.htm

70-t05-547.htm

70-fc551.htm

70-fc551iss.htm

70-t05-551iss.htm

70-fc551niss.htm

70-t05-551niss.htm

70-fc551sss.htm

70-t05-551sss.htm

70-fc559.htm

70-t05-559.htm

70-fc584.htm

70-t05-584.htm

70-fc585.htm

70-t05-585.htm

70-fc595.htm

70-t05-595.htm

70-fc596.htm

70-t05-596.htm

70-fc597.htm

70-t05-597.htm

70-fc598.htm

70-t05-598.htm

70-fc649.htm

70-t05-649.htm

70-fc687.htm

70-t05-687.htm

70-fc689.htm

70-t05-689.htm

70-fc691.htm

70-t05-691.htm

70-fc692.htm

70-t05-692.htm

70-fc731.htm

70-t05-731.htm

70-fc778.htm

70-t05-778.htm

70-fc784.htm

70-t05-784.htm

70-fc951.htm

70-t05-951.htm

70-fc1119.htm

70-t05-1119.htm

70-fc1228.htm

70-t05-1228.htm

70-fc1943.htm

70-t05-1943.htm

70-fc2215.htm

70-fc2271.htm

70-t05-2271.htm

70-fc2272.htm

70-t05-2272.htm

70-fc2273.htm

70-t05-2273.htm

70-fc2274.htm

70-t05-2274.htm

70-fc2277.htm

70-t05-2277.htm

70-fc2278.htm

70-t05-2278.htm

70-fc2311.htm

70-t05-2311.htm

70-fc2312.htm

70-t05-2312.htm

70-fc2313.htm

70-t05-2313.htm

70-fc2314.htm

70-t05-2314.htm

70-fc2321.htm

70-t05-2321.htm

70-fc2346.htm

70-t05-2346.htm

70-fc2347.htm

70-t05-2347.htm

70-fc2348.htm

70-t05-2348.htm

70-fc2349.htm

70-t05-2349.htm

70-fc2351.htm

70-t05-2351.htm

70-fc2352.htm

70-t05-2352.htm

70-fc2353.htm

70-t05-2353.htm

70-fc2355.htm

70-t05-2355.htm

70-fc2356.htm

70-t05-2356.htm

70-fc2357.htm

70-t05-2357.htm

70-fc2359.htm

70-t05-2359.htm

70-fc2362.htm

70-t05-2362.htm

70-fc2363.htm

70-t05-2363.htm

70-fc2365.htm

70-t05-2365.htm

70-fc2366.htm

70-fc2366v1.htm

70-t05-2366v1.htm

70-fc2366v2.htm

70-t05-2366v2.htm

70-fc2367.htm

70-fc2367v1.htm

70-t05-2367v1.htm

70-fc2367v2.htm

70-t05-2367v2.htm

70-fc2368.htm

70-t05-2368.htm

70-fc2372.htm

70-t05-2372.htm

70-fc2373.htm

70-t05-2373.htm

70-fc2374.htm

70-t05-2374.htm

70-fc2375.htm

70-t05-2375.htm

70-fc2376.htm

70-t05-2376.htm

70-fc2377.htm

70-t05-2377.htm

70-fc2384.htm

70-t05-2384.htm

70-fc2385.htm

70-t05-2385.htm

70-fc2551.htm

70-t05-2551.htm

70-fc2552.htm

70-t05-2552.htm

70-fc2554.htm

70-t05-2554.htm

70-fc2961.htm

70-t05-2961.htm

70-fc2962.htm

70-t05-2962.htm

70-fc2963.htm

70-t05-2963.htm

70-fc2964.htm

70-t05-2964.htm

70-fc2973.htm

70-t05-2973.htm

70-fc9121.htm

70-t05-9121.htm