L Gas Plus, C Gas Plus/B Gas Plus,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Internal ECM Failure

FAULT CODE 111

Internal ECM Failure

Printable Version Printable Version

Overview

Internal ECM Failure

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Red SRT: | Engine control module critical internal failure - bad intelligent device or component. Error internal to the ECM related memory hardware failures or internal ECM voltage supply circuits. | Engine possibly will not start or run.
Internal ECM Failure

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-111.

Last Modified: 25-Oct-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Fault Code Path Selection

FAULT CODE 115
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc115bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc115lgp

Last Modified: 01-Oct-2004


Fuel Pressure Sensor Circuit, Primary - Shorted High

FAULT CODE 118

Fuel Pressure Sensor Circuit, Primary - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 118 PID: P135 SPN: 135 FMI: 3 LAMP: Yellow SRT: | Fuel pressure sensor, primary, shorted high. | None.
Fuel Pressure Sensor Circuit

Circuit Description

The ECM uses this sensor to monitor the primary fuel pressure into the engine.

Component Location

The fuel pressure sensor is located in the low-pressure regulator housing.

Shop Talk

The fuel pressure sensor is used to detect the high-pressure fuel supplied to the engine from the OEM pressure regulator. The sensor is diagnostic only and does not affect fueling calculations to the engine. Disconnect the sensor before carrying out any wiring checks.

Refer to Troubleshooting Fault Code t05-118.

Last Modified: 25-Oct-2010


Fuel Pressure Sensor Circuit, Primary - Shorted Low

FAULT CODE 119

Fuel Pressure Sensor Circuit, Primary - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 119 PID: P135 SPN: 135 FMI: 4 LAMP: Yellow SRT: | Fuel pressure sensor, primary, shorted low. | None.
Fuel Pressure Sensor Circuit

Circuit Description

The ECM uses this sensor to monitor the primary fuel pressure into the engine.

Component Location

The fuel pressure sensor is located in the low-pressure regulator housing.

Shop Talk

The fuel pressure sensor is used to detect the high-pressure fuel supplied to the engine from the OEM pressure regulator. The sensor is diagnostic only and does not affect fueling calculations to the engine. Disconnect the sensor before carrying out any wiring checks.

Refer to Troubleshooting Fault Code t05-119.

Last Modified: 25-Oct-2010


Engine Position Sensor Circuit - Primary or Backup Signal Lost

FAULT CODE 121

Engine Position Sensor Circuit - Primary or Backup Signal Lost

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Yellow SRT: | Invalid engine speed signal detected on the engine position sensor signal pins at the ECM connector. | Engine can die. Engine will not start.
Engine Position Sensor Circuit

Circuit Description

The engine position sensor monitors the engine position and speed, then passes this information to the ECM through the engine harness.

Component Location

The engine position sensor is located in the gear housing, above the air compressor.

Shop Talk

The engine position sensor is a magnetic sensor and senses the raised material on the back of the camshaft gear to determine engine position and speed.

Refer to Troubleshooting Fault Code t05-121.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 122
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc122bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc122lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 123
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc123bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc123lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 124
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc124bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc124lgp

Last Modified: 01-Oct-2004


Accelerator Pedal Position Sensor Circuit - Shorted High

FAULT CODE 131

Accelerator Pedal Position Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 091 FMI: 3 LAMP: Red SRT: | The acceleration pedal position sensor circuit - shorted high. High voltage detected on the accelerator pedal position signal at the ECM. | Engine idles when the idle validation switch indicates idle and ramps up to a default set speed when the idle validation switch indicates off idle.
Accelerator Pedal Position Sensor and Idle Validation Circuit

Circuit Description

The accelerator pedal position sensor sends a signal to the electronic control module (ECM), when the driver depresses the accelerator pedal, to determine the accelerator pedal position.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

This signal is a 0- to 5.0-VDC signal from the foot pedal potentiometer to the ECM. At a foot pedal position of 100 percent closed, a 5.0-VDC signal will be output from the pedal. The wiring between the accelerator pedal and the OEM connector will be a twisted pair.

Refer to Troubleshooting Fault Code t05-131.

Last Modified: 25-Oct-2010


Accelerator Pedal Position Sensor Circuit - Shorted Low

FAULT CODE 132

Accelerator Pedal Position Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 091 FMI: 4 LAMP: Red SRT: | The acceleration pedal position sensor circuit - shorted low. Low voltage detected on the accelerator pedal position signal pin at the ECM. | Engine idles when the idle validation switch indicates idle and ramps up to a default set speed when the idle validation switch indicates off idle.
Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator pedal position sensor sends a signal to the electronic control module (ECM), when the driver depresses the accelerator pedal, to determine the accelerator pedal position.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

This signal is a 0- to 5.0-VDC signal from the foot pedal potentiometer to the ECM. At a foot pedal position of 100 percent closed, a 5.0-VDC signal will be output from the pedal. The wiring between the accelerator pedal and the OEM connector will be a twisted pair.

Refer to Troubleshooting Fault Code t05-132.

Last Modified: 25-Oct-2010


Remote Accelerator Pedal Position Sensor Circuit - Shorted High

FAULT CODE 133

Remote Accelerator Pedal Position Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Remote Accelerator Pedal Position Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 974 FMI: 3 LAMP: Red SRT: | Remote Accelerator Pedal Position Sensor Circuit - Shorted High. High voltage detected on the sensor SIGNAL pin at the ECM. | Engine will only idle if the remote accelerator is enabled.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the remote accelerator pedal position input to determine the remote accelerator pedal position.

Component Location

The remote accelerator pedal position sensor is located on the remote accelerator pedal.

Shop Talk

The remote accelerator pedal position sensor functions similarly to the accelerator pedal position sensor.

  • Make sure there are no external circuits hooked into the remote accelerator pedal position sensor circuit and that there are no signs of tampering in the circuit.
  • If all the wiring and sensor checks are okay, replace the remote accelerator pedal position sensor wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the vehicle with the test wires in place. If the fault code goes away, replace the OEM harness.
  • Verify that the remote accelerator pedal position sensor wires are twisted together.
Refer to Troubleshooting Fault Code t05-133.

Last Modified: 28-Feb-2012


Remote Accelerator Pedal Position Sensor Circuit - Shorted Low

FAULT CODE 134

Remote Accelerator Pedal Position Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Remote Accelerator Pedal Position Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 974 FMI: 4 LAMP: Red SRT: | Remote Accelerator Pedal Position Sensor Circuit - Shorted Low. Low voltage detected on the sensor SIGNAL pin at the ECM. | Engine will only idle if the remote accelerator is enabled.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the remote accelerator pedal position input to determine the remote accelerator pedal position.

Component Location

The remote accelerator pedal position sensor is located on the remote accelerator pedal.

Shop Talk

The remote accelerator pedal position sensor functions similarly to the accelerator pedal position sensor.

  • Make sure there are no external circuits hooked into the remote accelerator pedal position sensor circuit and that there are no signs of tampering in the circuit.
  • If all the wiring and sensor checks are okay, replace the remote accelerator pedal position sensor wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the vehicle with the test wires in place. If the fault code goes away, replace the OEM harness.
  • Verify that the remote accelerator pedal position sensor wires are twisted together.
Refer to Troubleshooting Fault Code t05-134.

Last Modified: 28-Feb-2012


Fault Code Path Selection

FAULT CODE 135
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc135bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc135lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 141
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc141bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc141lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 142
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc142bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc142lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 143
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc143bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc143lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 144
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc144bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc144lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 145
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc145bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc145lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 146
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc146bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc146lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 151
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc151bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc151lgp

Last Modified: 01-Oct-2004


Intake Manifold Temperature Sensor Circuit - Shorted High

FAULT CODE 153

Intake Manifold Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Intake Manifold Temperature Sensor Circuit - Shorted High. High signal voltage detected at the intake manifold air temperature sensor pin at the ECM. | Possible reduced performance. Fan will stay ON if controlled by the ECM. No engine protection for intake manifold air temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 25-Oct-2010


Intake Manifold Temperature Sensor Circuit - Shorted Low

FAULT CODE 154

Intake Manifold Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Amber SRT: | Intake Manifold Temperature Sensor Circuit - Shorted Low. | Possible reduced performance. Fan will stay ON if controlled by ECM. No engine protection for intake manifold air temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature of the air mixture entering the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 25-Oct-2010


Intake Manifold Temperature Sensor Circuit - Critical Temperature Reached

FAULT CODE 155

Intake Manifold Temperature Sensor Circuit - Critical Temperature Reached

Printable Version Printable Version

Overview

Intake Manifold Temperature Sensor Circuit - Critical Temperature Reached

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake manifold air temperature high - critical. Intake manifold air temperature signal indicates intake manifold temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If engine protection shutdown feature is enabled, engine will shutdown 30 seconds after the red stop lamp starts flashing.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the Intake Manifold Pressure/Temperature Sensor input to determine the temperature of the fuel mixture.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with absolute pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

This sensor can control the engine fan if the OEM utilizes this feature within the ECM. The engine protection shutdown feature is customer-enabled and will require enabling at the customer's request.

Refer to Troubleshooting Fault Code t05-155.

Last Modified: 25-Oct-2010


Electronic Throttle Control Actuator Circuit - Shorted High

FAULT CODE 175

Electronic Throttle Control Actuator Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 175 PID: S58 SPN: 698 FMI: 3 LAMP: Red SRT: | Electronic Throttle Control Actuator Circuit - Shorted High. High voltage detected on the throttle actuator signal pin at the ECM. | The throttle plate will close, causing the engine to die.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle control actuator; it is both an input and output device.

Component Location

The electronic throttle control actuator is located after the fuel housing and before the intake manifold inlet.

Shop Talk

The electronic throttle control actuator is a pulse-width modulated component on Gas Plus technology. Within the actuator is the throttle position sensor circuit. This is a non repairable sensor and requires replacement of the actuator upon failure.

Refer to Troubleshooting Fault Code t05-175.

Last Modified: 25-Oct-2010


Electronic Throttle Control Actuator Circuit - Shorted Low

FAULT CODE 176

Electronic Throttle Control Actuator Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 176 PID: S58 SPN: 698 FMI: 4 LAMP: Red SRT: | Electronic Throttle Control Actuator Circuit - Shorted Low. Low voltage detected on the throttle actuator signal pin at the ECM. | Possible reduced performance. Engine can die or not start.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle control actuator; it is both an input and output device.

Component Location

The electronic throttle control actuator is located after the fuel housing and before the intake manifold inlet.

Shop Talk

The electronic throttle control actuator is a pulse-width modulated component on Gas Plus technology. Within the actuator is the throttle position sensor circuit. This is a non repairable sensor and requires replacement of the actuator upon failure.

Refer to Troubleshooting Fault Code t05-176.

Last Modified: 25-Oct-2010


Electronic Throttle Control Actuator - Stuck Open

FAULT CODE 177

Electronic Throttle Control Actuator - Stuck Open

Printable Version Printable Version

Overview

Electronic Throttle Control Actuator - Stuck Open

CODE | REASON | EFFECT
Fault Code: 177 PID: S58 SPN: 698 FMI: 7 LAMP: Red SRT: | Electronic Throttle Control Actuator - stuck open. The throttle plate has moved unexpectedly. | Engine will shut down.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle control actuator; it is both an input and output device.

Component Location

The electronic throttle control actuator is located after the fuel housing and before the intake manifold inlet.

Shop Talk

The Electronic Throttle Control Actuator is a pulse-width modulated component. Within the actuator is the throttle position sensor circuit. This is a non-repairable sensor and requires replacement of the actuator upon failure.

Refer to Troubleshooting Fault Code t05-177.

Last Modified: 25-Oct-2010


Electronic Throttle Control Actuator - Stuck Closed

FAULT CODE 178

Electronic Throttle Control Actuator - Stuck Closed

Printable Version Printable Version

Overview

Electronic Throttle Control Actuator - Stuck Closed

CODE | REASON | EFFECT
Fault Code: 178 PID: S58 SPN: 698 FMI: 7 LAMP: Red SRT: | Electronic Throttle Control Actuator - stuck closed. The throttle plate has moved unexpectedly. | Possible reduced performance. Engine may die or not start.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle control actuator; it is both an input and output device.

Component Location

The electronic throttle control actuator is located after the fuel housing and before the intake manifold inlet.

Shop Talk

The Electronic Throttle Control Actuator is a pulse-width modulated component. Within the actuator is the throttle position sensor circuit. This is a non-repairable sensor and requires replacement of the actuator upon failure.

Refer to Troubleshooting Fault Code t05-178.

Last Modified: 25-Oct-2010


Sensor Supply Voltage 5 Volt (2) Circuit - Shorted Low

FAULT CODE 187

Sensor Supply Voltage 5 Volt (2) Circuit - Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Voltage 5 Volt (2) Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4 LAMP: Yellow SRT: | Sensor Supply Voltage (2) Circuit - Shorted Low. | Possible reduced performance.
Sensor Supply Voltage 5 Volt (2) Circuit

Circuit Description

This circuit is the voltage supply for the remote accelerator pedal position sensor, mixer inlet pressure sensor, coolant level sensor and coolant pressure/temperature sensor.

Component Location

The sensor supply voltage 5 Volt (2) circuit is contained in the wiring harness.

Shop Talk

The voltage supplies on the B and C Plus engines are broken up into 1, 2, 3, and 4. On the L Gas Plus engine, voltage supplies are broken up into 1, 2 and 4.

Refer to Troubleshooting Fault Code t05-187.

Last Modified: 25-Oct-2010


ECM Diagnostic Lamp Circuit - Shorted Low

FAULT CODE 198

ECM Diagnostic Lamp Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 198 PID: S122 SPN: 612 FMI: 4 LAMP: Yellow SRT: | ECM Diagnostic Lamp Circuit - Shorted Low. Open circuit detected on diagnostic lamp pins in the engine harness ECM connector 2. | No effect on performance. Loss of diagnostic lamp.
ECM Diagnostic Lamp Circuit

Circuit Description

These are the three malfunction-indicator lamps for the electronic control module (ECM).

Component Location

The three malfunction-indicator lamps are installed on the dashboard by the OEM.

Shop Talk

Each of the three malfunction-indicator lamps will be a different color. The stop engine lamp is red. The check engine lamp is yellow. The low fuel pressure lamp is green. For exact circuitry information, use the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-198.

Last Modified: 25-Oct-2010


ECM Diagnostic Lamp Circuit - Shorted High

FAULT CODE 199

ECM Diagnostic Lamp Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 199 PID: S238 SPN: 623 FMI: 3 LAMP: Yellow SRT: | ECM Diagnostic Lamp Circuit - Shorted High. Short circuit to ground detected on diagnostic lamp pins in the engine harness ECM connector 2. | No effect on performance. Loss of diagnostic lamp.
ECM Diagnostic Lamp Circuit

Circuit Description

These are the three malfunction-indicator lamps for the electronic control module (ECM).

Component Location

The three malfunction-indicator lamps are installed on the dashboard by the OEM.

Shop Talk

Each of the three malfunction-indicator lamps will be a different color. The stop engine lamp is red. The check engine lamp is yellow. The low fuel pressure lamp is green. For exact circuitry information, use the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-199.

Last Modified: 25-Oct-2010


Oil Temperature Sensor Circuit - Shorted High

FAULT CODE 212

Oil Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3 LAMP: Amber SRT: | Oil Temperature Sensor Circuit - Shorted High. High signal voltage detected on the oil temperature signal pin at the ECM. | None on performance. No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block on the fuel system side of the engine.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-212.

Last Modified: 25-Oct-2010


Oil Temperature Sensor Circuit - Shorted Low

FAULT CODE 213

Oil Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4 LAMP: Amber SRT: | Oil Temperature Sensor Circuit - Shorted Low. Low signal voltage detected on the oil temperature signal pin at the ECM. | None on performance. No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block on the fuel system side of the engine.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-213.

Last Modified: 25-Oct-2010


Engine Oil Temperature - High Critical

FAULT CODE 214

Engine Oil Temperature - High Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0 LAMP: Red SRT: | High Oil Temperature - Over Temperature. | Progressive power derate increasing in severity from the time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block, on the fuel system side of the engine.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 214 | 600 to 675

The engine protection shutdown for oil temperature is a customer feature and will only be enabled at the customer's request. This feature will deactivate or disable the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-214.

Last Modified: 25-Oct-2010


Compressor Inlet Pressure Sensor Circuit - Shorted High

FAULT CODE 221

Compressor Inlet Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Compressor Inlet Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3 LAMP: Amber SRT: | Compressor Inlet Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected on the compressor inlet pressure circuit at the ECM. | None
Compressor Inlet Pressure Sensor Circuit

Circuit Description

The compressor inlet pressure sensor measures the inlet pressure to the turbocharger.

Component Location

The compressor inlet pressure sensor is located just prior to the inlet to the turbocharger.

Shop Talk

This sensor is also considered an inlet restriction sensor and measures pressure in absolute pressure.

Refer to Troubleshooting Fault Code t05-221.

Last Modified: 25-Oct-2010


Compressor Inlet Pressure Sensor Circuit - Shorted Low

FAULT CODE 222

Compressor Inlet Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Compressor Inlet Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4 LAMP: Amber SRT: | Compressor Inlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected on the compressor inlet pressure circuit at the ECM. | None
Compressor Inlet Pressure Sensor Circuit

Circuit Description

The compressor inlet pressure sensor measures the inlet pressure to the turbocharger.

Component Location

The compressor inlet pressure sensor is located just prior to the inlet to the turbocharger.

Shop Talk

This sensor is also considered an inlet restriction sensor and measures pressure in absolute pressure.

Refer to Troubleshooting Fault Code t05-222.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 227
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? High? | Go to 85-fc227bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc227lgp

Last Modified: 01-Oct-2004


Coolant Pressure - Engine Protection

FAULT CODE 228

Coolant Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 228 PID: P109 SPN: 109 FMI: 1 LAMP: Red SRT: | Engine Coolant Pressure Low - Critical | Progressive power derate increasing in severity from time of alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the electronic control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The coolant pressure value is used by the ECM for engine protection.

Component Location

The coolant pressure sensor is located on the engine block, below the water outlet location.

Shop Talk

The engine protection shutdown for coolant is a customer feature and will only be enabled at the customer's request. This feature will deactivate or disable the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-228.

Last Modified: 25-Oct-2010


Engine Coolant Pressure Sensor Circuit - Shorted High

FAULT CODE 231

Engine Coolant Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: P109 SPN: 109 FMI: 3 LAMP: Amber SRT: | Engine Coolant Pressure Sensor Circuit - Shorted High | None on performance. No engine protection for coolant pressure.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine coolant pressure/temperature sensor is used by the electronic control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The coolant pressure value is used by the ECM for the engine protection system.

Component Location

The coolant pressure/temperature sensor is located in the block, below the water outlet location.

Refer to Troubleshooting Fault Code t05-231.

Last Modified: 25-Oct-2010


Engine Coolant Pressure Sensor Circuit - Shorted Low

FAULT CODE 232

Engine Coolant Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: P109 SPN: 109 FMI: 4 LAMP: Amber SRT: | Engine Coolant Pressure Sensor Circuit - Shorted Low | None on performance. No engine protection for coolant pressure.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine coolant pressure/temperature sensor is used by the electronic control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The coolant pressure value is used by the ECM for the engine protection system.

Component Location

The coolant pressure/temperature sensor is located in the block, below the water outlet location.

Refer to Troubleshooting Fault Code t05-232.

Last Modified: 25-Oct-2010


Engine Coolant Pressure Low Warning

FAULT CODE 233

Engine Coolant Pressure Low Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 233 PID: P109 SPN: 109 FMI: 1 LAMP: Amber SRT: | Engine Coolant Pressure Low - Warning | Progressive power derate increasing in severity from time of alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Coolant Pressure Sensor Circuit

Circuit Description

The coolant pressure sensor is used by the electronic control module (ECM) to monitor the coolant pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The coolant pressure value is used by the ECM for engine protection.

Component Location

The coolant pressure sensor is located on the engine block, below the water outlet location.

Shop Talk

The engine protection shutdown for coolant is a customer feature and will only be enabled at the customer's request. This feature will deactivate or disable the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-233.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 234
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc234bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc234lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 235
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc235bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc235lgp

Last Modified: 01-Oct-2004


Sensor Supply Voltage Number 3 Circuit - Shorted Low

FAULT CODE 238

Sensor Supply Voltage Number 3 Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: 232 SPN: 620 FMI: 4 LAMP: Amber SRT: | Sensor Supply Voltage Number 3 Circuit - Shorted Low. Low voltage detected on sensor supply voltage 12 VDC (3). | Possible reduced performance.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

This is the voltage supply for the gas mass flow sensor.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness.

Shop Talk

When testing the resistance of the wires, make sure that the ECM and OEM connectors are disconnected.

Refer to Troubleshooting Fault Code t05-238.

Last Modified: 25-Oct-2010


Sensor Supply Voltage Number 3 Circuit - Shorted High

FAULT CODE 239

Sensor Supply Voltage Number 3 Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S239 SPN: 620 FMI: 3 LAMP: Amber SRT: | Sensor Supply Voltage Number 3 Circuit - Shorted High. High voltage detected at sensor supply number 3 circuit. | Possible reduced performance.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

This is the voltage supply for the gas mass flow sensor.

Component Location

The sensor supply circuit number 3 circuit is contained in the engine wiring harness.

Shop Talk

When testing the resistance of the wires, make sure that the ECM and OEM connectors are disconnected.

Refer to Troubleshooting Fault Code t05-239.

Last Modified: 25-Oct-2010


Vehicle Speed Sensor Circuit - Input Signal Lost

FAULT CODE 241

Vehicle Speed Sensor Circuit - Input Signal Lost

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2 LAMP: Amber SRT: | Vehicle Speed Sensor Circuit - data erratic, intermittent, or incorrect. The ECM lost the vehicle speed signal. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise Control, gear-down protection, and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor is an OEM-supplied sensor but can provide an input to the electronic control module (ECM) for added features such as road speed governing and cruise control.

Component Location

Use the OEM manual for location of this sensor. Usually, this sensor is installed in the tail shaft of the transmission.

Shop Talk

  • Disconnect the vehicle speed sensor connector that connects to the OEM speedometer, or trip recorder, and move the vehicle. If the fault goes inactive, there is probably electrical noise being fed into the vehicle speed sensor circuit from the OEM device.
  • Verify the vehicle speed sensor wires in the OEM harness are twisted pairs.
  • This sensor usually has one coil but can have two. Only one is used.
  • Vehicle speed can also be transmitted via the data link if the vehicle is utilizing the J1939. If no sensor is found but vehicle speed is being read, then it is likely being transmitted; so no vehicle speed sensor is used.
Refer to Troubleshooting Fault Code t05-241.

Last Modified: 25-Oct-2010


Vehicle Speed Sensor Circuit - Tampering Has Been Detected

FAULT CODE 242

Vehicle Speed Sensor Circuit - Tampering Has Been Detected

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P84 SPN: 84 FMI: 10 LAMP: Amber SRT: | Invalid vehicle speed signal detected; signal tampered. | Maximum engine speed is limited to the value set for maximum engine speed without the vehicle speed sensor. Cruise controller and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor is an OEM-supplied sensor but can provide an input to the electronic control module (ECM) for added features such as road speed governing and cruise control.

Component Location

Use the OEM manual for location of this sensor. Usually, this sensor is installed in the tailshaft of the transmission.

Shop Talk

  • Disconnect the vehicle speed sensor connector that connects to the OEM speedometer, or trip recorder, and move the vehicle. If the fault goes inactive, there is probably electrical noise being fed into the vehicle speed sensor circuit from the OEM device.
  • Verify the vehicle speed sensor wires in the OEM harness are twisted pairs.
  • This sensor usually has one coil but can have two. Only one is used for engine control.
Refer to Troubleshooting Fault Code t05-242.

Last Modified: 25-Oct-2010


Compressor Inlet Temperature Sensor Circuit - Shorted High

FAULT CODE 249

Compressor Inlet Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Compressor Inlet Temperature Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 249 PID: P105 SPN: 105 FMI: 3 LAMP: Amber SRT: | Compressor Inlet Temperature Sensor Circuit - Shorted High. | Possible reduced performance.
Compressor Inlet Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the compressor inlet temperature sensor input to determine the temperature of the air entering the turbocharger.

Component Location

The compressor inlet temperature sensor is located in the intake piping to the turbocharger (combination sensor with humidity).

Shop Talk

  • The compressor inlet temperature sensor is a combination sensor with the humidity sensor.

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-249.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 254
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc254gp
Do you have a L Gas Plus Engine? | Go to 85-fc254blpg

Last Modified: 22-Nov-2004


Fault Code Path Selection

FAULT CODE 255
Fault Code Path Selection

Do you have a B LPG Engine? | Go to 85-fc255blpg
Do you have a B Gas Plus, C Gas Plus or L Gas Plus Engine? | Go to 85-fc255gp

Last Modified: 01-Oct-2004


Compressor Inlet Temperature Sensor Circuit - Shorted Low

FAULT CODE 256

Compressor Inlet Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Compressor Inlet Temperature Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4 LAMP: Amber SRT: | Compressor Inlet Temperature Sensor Circuit - Voltage below normal, or Shorted to low source. Low signal voltage detected on the compressor inlet circuit at the ECM. | Possible reduced engine performance. Fan will stay ON if controlled by ECM. No engine protection for compressor inlet temperature.
Compressor Inlet Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the compressor inlet temperature sensor input to determine the temperature of the air entering the turbocharger.

Component Location

The compressor inlet temperature sensor is located in the intake piping to the turbocharger (combination sensor with humidity).

Shop Talk

  • The compressor inlet temperature sensor is a combination sensor with the humidity sensor.

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-256.

Last Modified: 25-Oct-2010


Fuel Temperature Sensor Circuit - Shorted High

FAULT CODE 263

Fuel Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3 LAMP: Amber SRT: | Fuel Temperature Sensor Circuit - Shorted High. Open circuit detected on the signal pin of the ECM. | Possible reduced performance.
Fuel Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the fuel pressure/temperature sensor (combination sensor) to measure the fuel temperature.

Component Location

The fuel pressure/temperature sensor is located in the fuel housing.

Shop Talk

The fuel pressure/temperature sensor measures secondary fuel pressure and temperature at the mixer housing after the low-pressure regulator.

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault code can log in extremely cold weather.
Refer to Troubleshooting Fault Code t05-263.

Last Modified: 25-Oct-2010


Fuel Temperature Sensor Circuit - Shorted Low

FAULT CODE 265

Fuel Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4 LAMP: Amber SRT: | Fuel Temperature Sensor Circuit - Shorted Low. Low voltage (short to ground) detected at the ECM. | Possible reduced performance.
Fuel Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the fuel pressure/temperature sensor (combination sensor) to measure the fuel temperature, as well as the secondary pressure.

Component Location

The fuel pressure/temperature sensor is located in the fuel housing.

Shop Talk

The fuel pressure/temperature sensor measures secondary fuel pressure and temperature at the mixer housing after the low-pressure regulator.

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-265.

Last Modified: 25-Oct-2010


Idle Speed Control Valve Circuit - Shorted High

FAULT CODE 336

Idle Speed Control Valve Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 336 PID: S19 SPN: 634 FMI: 3 LAMP: Amber SRT: | Idle Speed Control Valve Circuit - Shorted High | Short to 12-VDC causes surging. Engine will die and not start on a short to 5-VDC.
Idle Speed Control Valve Circuit - Shorted High

Circuit Description

The idle speed control valve is a bypass valve that is used to control idle speed under certain load conditions by the electronic control module(ECM). The ECM uses this valve to regulate the air-fuel mixture flow at idle condition.

Component Location

The idle speed control valve is located on the side of the throttle body.

Shop Talk

The idle speed control valve only operates at idle conditions.

Refer to Troubleshooting Fault Code t05-336.

Last Modified: 25-Oct-2010


Idle Speed Control Valve Circuit - Shorted Low

FAULT CODE 337

Idle Speed Control Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 337 PID: S19 SPN: 634 FMI: 4 LAMP: Amber SRT: | Idle Speed Control Valve Circuit - Shorted Low | Low idle speed will be lower than normal. Engine can possibly die.
Idle Speed Control Valve Circuit - Shorted Low

Circuit Description

The idle speed control valve is a bypass valve that is used to control idle speed under certain load conditions by the electronic control module(ECM). The ECM uses this valve to regulate the air or fuel mixture flow at idle condition.

Component Location

The idle speed control valve is located on the side of the throttle body.

Shop Talk

The idle speed control valve only operates at idle conditions.

Refer to Troubleshooting Fault Code t05-337.

Last Modified: 25-Oct-2010


ECM - Warning Internal Hardware Failure

FAULT CODE 343

ECM - Warning Internal Hardware Failure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: 254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | Internal ECM error. | Engine possibly will not start or run.
ECM

Circuit Description

The electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-343.

Last Modified: 25-Oct-2010


ECM Software Error

FAULT CODE 346

ECM Software Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: 253 SPN: 630 FMI: 12 LAMP: Yellow SRT: | ECM software error. | None.
ECM Power-down Error

Circuit Description

The electronic control module (ECM) is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM).

Shop Talk

This fault code can be caused by an internal ECM problem. This can also be caused if battery power is disconnected before power-down sequence is completed. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-346.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 352
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc352bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc352lgp

Last Modified: 01-Oct-2004


Intake Manifold Pressure Sensor Circuit - Shorted High

FAULT CODE 354

Intake Manifold Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: P106 SPN: 106 FMI: 3 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Shorted High . High voltage detected on the sensor signal pin at the ECM. | Possible reduced performance.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature).

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the Plus engines are absolute sensors.

Refer to Troubleshooting Fault Code t05-354.

Last Modified: 25-Oct-2010


Intake Manifold Pressure Sensor Circuit - Shorted Low

FAULT CODE 355

Intake Manifold Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Intake Manifold Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: 106 FMI: 4 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Shorted Low . Low voltage (short to ground) detected on the sensor signal pin at the ECM. | Possible reduced performance.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the pressure of the air mixture entering the engine. This sensor is used to determine the fueling calculation into the engine.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with temperature).

Shop Talk

This sensor detects the pressure and temperature of the air/fuel mixture entering the engine. All pressure sensors on the Plus engines are absolute sensors.

Refer to Troubleshooting Fault Code t05-355.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 386
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc386bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc386lgp

Last Modified: 01-Oct-2004


Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Shorted High

FAULT CODE 387

Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 387 PID: S221 SPN: 1043 FMI: 3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Above Normal, or shorted to high source. High voltage detected at sensor supply circuit for the accelerator pedal position sensor. | Engine idles when the idle validation switch indicates idle and ramps up to a default set speed when the idle validation switch indicates off idle.
Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit

Circuit Description

The accelerator pedal position sensor sends a signal to the electronic control module (ECM) to indicate to the ECM the rate at which the driver wants to accelerate the vehicle.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

  • Make sure there are no external circuits hooked into the accelerator pedal position sensor circuit and that there are no signs of tampering in the circuit.
  • If all the wiring and sensor checks are okay, replace the accelerator pedal position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the vehicle with the test wires in place. If the fault code goes away, replace the OEM harness.
  • Verify that the accelerator pedal position sensor wires are twisted together.
Refer to Troubleshooting Fault Code t05-387.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 415
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc415bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc415lgp

Last Modified: 01-Oct-2004


Engine Oil Temperature High - Over Temperature Warning

FAULT CODE 421

Engine Oil Temperature High - Over Temperature Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | High oil temperature - over temperature warning. | Progressive power derate increasing in severity from time of alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this combination pressure/temperature sensor for engine protection purposes.

Component Location

The engine oil pressure/temperature sensor is located in the block, underneath the ECM.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 421 | 600 to 675

The engine protection shutdown for oil temperature is a customer feature and will only be enabled at the customer's request. This sensor will deactivate or disable the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-421.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 422
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc422bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc422lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 431
Fault Code Path Selection

Does your accelerator pedal or lever have a Solid-State Sensor Switch? | Go to 85-fc431sss
Does your accelerator pedal or lever have a Integrated Sensor Switch? | Go to 85-fc431iss
Does your accelerator pedal or lever have a Nonintegrated Sensor Switch? | Go to 85-fc431niss

Last Modified: 01-Oct-2004


Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

FAULT CODE 432

Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13/13 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration. Voltage at idle validation on-idle and off-idle circuit does not match accelerator pedal position. | Engine will only idle.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal or lever. The accelerator pedal or lever position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal or lever is depressed or released. The accelerator pedal or lever position circuit contains three wires: accelerator pedal or lever position supply, accelerator pedal or lever position return, accelerator pedal or lever position signal. The switch return circuit for the on-idle and off-idle validation circuit is a shared return with other OEM switches.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever.

Shop Talk

This fault is logged when both the on- idle and off-idle validation switches disagree with the accelerator pedal or lever position signal. Turning the keyswitch ON while partially depressing the accelerator pedal or lever can cause this fault code to go active. This fault will stay active until the pedal or lever is cycled through its full travel.

Refer to Troubleshooting Fault Code t05-432.

Last Modified: 25-Oct-2010


Battery Number 1 Voltage Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441

Battery Number 1 Voltage Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery Number 1 Voltage Low - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Possible reduced performance.
Unswitched Battery Supply Circuit

Circuit Description

There are four battery inputs into the OEM connectors that are unswitched battery supply to the electronic control module (ECM).

Component Location

The battery voltage circuit is located in the wiring harness.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning.

Refer to Troubleshooting Fault Code t05-441.

Last Modified: 25-Oct-2010


Battery Number 1 Voltage High - Data Valid but Below Above Operational Range - Moderately Severe Level

FAULT CODE 442

Battery Number 1 Voltage High - Data Valid but Below Above Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 1/16 LAMP: Amber SRT: | Battery Number 1 Voltage High - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the minimum system voltage level. | Possible electrical damage to all electrical components.
Unswitched Battery Supply Circuit

Circuit Description

There are four battery inputs into the OEM connectors that are unswitched battery supply to the electronic control module (ECM).

Component Location

The battery voltage circuit is located in the wiring harness.

Shop Talk

The engine will not communicate or start if the battery circuit is malfunctioning.

Refer to Troubleshooting Fault Code t05-442.

Last Modified: 25-Oct-2010


Accelerator Pedal Position Sensor Supply Voltage - Shorted Low

FAULT CODE 443

Accelerator Pedal Position Sensor Supply Voltage - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443 PID: S221 SPN: 1043 FMI: 4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the accelerator pedal position sensor. | Engine idles when the idle validation switch indicates idle and ramps up to a default set speed when the idle validation switch indicates off idle.
Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit

Circuit Description

The accelerator pedal position sensor sends a signal to the electronic control module (ECM), when the driver depresses the accelerator pedal, to determine the accelerator pedal position.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal.

Shop Talk

  • Make sure there are no external circuits hooked into the accelerator pedal position sensor circuit and that there are no signs of tampering in the circuit.
  • If all the wiring and sensor checks are okay, replace the accelerator pedal position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the wires through or around the bulkhead without using the bulkhead connector. Test the vehicle with the test wires in place. If the fault code goes away, replace the OEM harness.
  • Verify that the accelerator pedal position sensor wires are twisted together.
Refer to Troubleshooting Fault Code t05-443.

Last Modified: 25-Oct-2010


Fuel Pressure High - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 449

Fuel Pressure High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P94 SPN: 94 FMI: 0/16 LAMP: Amber SRT: | Fuel Pressure High - Data Valid But Above Normal Operating Range - Moderately Severe Level. Fuel pressure signal indicates that fuel pressure has exceeded the maximum limit for the given engine condition. | Possible erratic engine performance.
Fuel Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the secondary fuel pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the intake of the engine fuel control valve. The electronic control module (ECM) provides a 5 volt supply to the secondary fuel pressure/temperature sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The secondary fuel pressure/temperature sensor provides a signal to the ECM on the secondary fuel pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the intake of the fuel control valve. The sensor is also used to measure the temperature of the fuel entering the intake of the engine fuel control valve.

Component Location

The secondary fuel pressure/temperature sensor is located in the fuel housing near the fuel control valve.

Shop Talk

The secondary fuel pressure/temperature sensor measures the secondary fuel pressure to the engine. This is after the low-pressure regulator. The secondary fuel pressure/temperature sensor is an absolute sensor.

The Compuchek™ fitting located on the low pressure regulator housing is used to measure the secondary fuel pressure.

Possible causes of this fault code include:

  • High primary fuel pressure
  • Damaged engine low pressure regulator or evaporator
  • Damaged secondary fuel pressure/temperature sensor
Refer to Troubleshooting Fault Code t05-449.

Last Modified: 09-Nov-2010


Fault Code Path Selection

FAULT CODE 453
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc453bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc453lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 454
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine without optional Sensor Supply Voltage Converter? | Go to 85-fc454bcgp
Do you have a L Gas Plus or C Gas Plus Engine with optional Sensor Supply Voltage Converter? | Go to 85-fc454lcgp

Last Modified: 29-Feb-2008


Fuel Control Valve Circuit - Shorted High

FAULT CODE 455

Fuel Control Valve Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: S18 SPN: 633 FMI: 3 LAMP: Red SRT: | Fuel Control Valve Circuit - Shorted High. High voltage detected on the sensor signal pin at the ECM. | Engine will die or not start.
Fuel Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses this valve to meter the fuel into the fuel housing.

Component Location

The fuel control valve is located in the fuel housing next to the gas sensor.

Shop Talk

This valve is normally closed when no power is applied. The valve is pulse-width modulated.

Refer to Troubleshooting Fault Code t05-455.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 458
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc458bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc458lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 459
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc459bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc459lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 461
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc461bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc461lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 462
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc462bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc462lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 465
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc465bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc465lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 466
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc466bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc466lgp

Last Modified: 01-Oct-2004


Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 482

Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 482 PID: P94 SPN: 94 FMI: 1/18 LAMP: Amber SRT: | Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level. Pressure below the engine protection limit. | Engine power derate.
Fuel Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the secondary fuel pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the intake of the engine fuel control valve. The electronic control module (ECM) provides a 5 volt supply to the secondary fuel pressure/temperature sensor on the sensor supply 1 circuit. The ECM also provides a ground on the sensor return circuit. The secondary fuel pressure/temperature sensor provides a signal to the ECM on the secondary fuel pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the intake of the fuel control valve. The sensor is also used to measure the temperature of the fuel entering the intake of the engine fuel control valve.

Component Location

The secondary fuel pressure/temperature sensor is located in the fuel housing near the fuel control valve.

Shop Talk

The secondary fuel pressure/temperature sensor measures the secondary fuel pressure to the engine. This is after the low-pressure regulator. The fuel pressure/temperature sensor, secondary, is an absolute sensor. The Compuchek™ fitting located on the low pressure regulator housing is used to measure the secondary fuel pressure.

Possible causes are:

  • Low primary fuel pressure
  • Damaged low pressure fuel regulator
  • Damaged secondary fuel pressure/temperature sensor
  • Oil contamination in the fuel system
  • Restricted fuel lines
  • Fuel leaks.
Refer to Troubleshooting Fault Code 482.

Last Modified: 09-Nov-2010


Intake Manifold Temperature High - Over Temperature Warning

FAULT CODE 488

Intake Manifold Temperature High - Over Temperature Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold Temperature High - Over Temperature Warning. High intake manifold temperature warning. | Progressive power derate increasing in severity from time of alert. If engine protection shutdown feature is enabled, engine will shut down 30 seconds after red stop light starts flashing.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the intake manifold pressure/temperature sensor input to determine the temperature of the intake manifold.

Component Location

The intake manifold pressure/temperature sensor is located in the intake manifold housing (combination sensor with absolute pressure).

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • The engine protection shutdown for the intake manifold temperature is a customer feature and will only be enabled at the customer's request. This feature will deactivate the fuel control valve if this feature is utilized by the OEM.
Refer to Troubleshooting Fault Code t05-488.

Last Modified: 25-Oct-2010


Fuel Control Valve Circuit - Shorted Low

FAULT CODE 511

Fuel Control Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 511 PID: S18 SPN: 633 FMI: 4 LAMP: Red SRT: | Fuel Control Valve Circuit - Shorted Low. Low voltage detected at the ECM. | Engine will die or not start.
Fuel Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses this valve to meter the fuel into the fuel housing.

Component Location

The fuel control valve is located in the fuel housing next to the gas mass flow sensor.

Shop Talk

This valve is normally closed when no power is applied. The valve is pulse-width modulated.

Refer to Troubleshooting Fault Code t05-511.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 512
Fault Code Path Selection

Do you have a B Gas Plus Engine? | Go to 85-fc512gp
Do you have a B Gas International engine? | Go to 85-fc512bgi

Last Modified: 08-Dec-2004


Fault Code Path Selection

FAULT CODE 513
Fault Code Path Selection

Do you have a B Gas Plus Engine? | Go to 85-fc513gp
Do you have a B Gas International Engine? | Go to 85-fc513bgi

Last Modified: 08-Dec-2004


Fault Code Path Selection

FAULT CODE 545
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc545bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc545lgp

Last Modified: 01-Oct-2004


Fuel Pressure Sensor Circuit, Secondary- Shorted High

FAULT CODE 546

Fuel Pressure Sensor Circuit, Secondary- Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: P94 SPN: 94 FMI: 3 LAMP: Amber SRT: | Fuel Pressure Sensor Circuit, Secondary- Shorted High. High voltage detected at the ECM. | Possible reduced performance.
Fuel Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the fuel pressure/temperature sensor to measure the secondary fuel pressure to the engine.

Component Location

The fuel pressure/temperature sensor, secondary, is located in the fuel housing.

Shop Talk

The fuel pressure/temperature sensor measures the secondary fuel pressure to the engine. This is after the low-pressure regulator. The fuel pressure/temperature sensor, secondary, is an absolute sensor.

Refer to Troubleshooting Fault Code t05-546.

Last Modified: 25-Oct-2010


Fuel Pressure Sensor Circuit, Secondary- Shorted Low

FAULT CODE 547

Fuel Pressure Sensor Circuit, Secondary- Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: P94 SPN: 94 FMI: 4 LAMP: Amber SRT: | Fuel Pressure Sensor Circuit, Secondary- Shorted Low. Low voltage (short to ground) detected at the ECM. | Possible effect on performance.
Fuel Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the fuel pressure/temperature sensor to measure the secondary fuel pressure to the engine. This is a combination sensor with the temperature sensor.

Component Location

The fuel pressure/temperature sensor, secondary, is located in the fuel housing.

Shop Talk

The fuel pressure/temperature sensor measures the secondary fuel pressure to the engine. This is after the low pressure regulator. The fuel pressure/temperature sensor, secondary, is an absolute sensor.

Refer to Troubleshooting Fault Code t05-547.

Last Modified: 25-Oct-2010


Idle Validation Switch Circuit - Both Switches Low

FAULT CODE 551

Idle Validation Switch Circuit - Both Switches Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: P91 SPN: 91 FMI: 4 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal, or shorted to a low source. No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Engine will only idle.
Idle Validation Switch Circuit

Circuit Description

The electronic control module (ECM) uses this signal to determine the position of the accelerator pedal.

Component Location

The idle validation switches are located in the accelerator pedal.

Shop Talk

The idle validation switch does not require twisted pair wiring.

Refer to Troubleshooting Fault Code t05-551.

Last Modified: 25-Oct-2010


Engine Cylinder Number 1 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 561

Engine Cylinder Number 1 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 561 PID: S090 SPN: 1352 FMI: 0 LAMP: Red SRT: | Engine Cylinder Number 1 Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. This may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration or during a stall test on an automatic transmission. As such, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-561.

Last Modified: 25-Oct-2010


Engine Cylinder Number 2 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 562

Engine Cylinder Number 2 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 562 PID: S091 SPN: 1353 FMI: 0 LAMP: Red SRT: | Engine Cylinder Number 2 Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. This may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration or during a stall test on an automatic transmission. As such, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-562.

Last Modified: 25-Oct-2010


Engine Cylinder Number 3 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 563

Engine Cylinder Number 3 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 563 PID: S092 SPN: 1354 FMI: 0 LAMP: Red SRT: | Engine Cylinder Number 3 Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. This may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration or during a stall test on an automatic transmission. As such, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-563.

Last Modified: 25-Oct-2010


Engine Cylinder Number 4 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 564

Engine Cylinder Number 4 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 564 PID: S093 SPN: 1355 FMI: 0 LAMP: Red SRT: | Engine Cylinder Number 4 Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. This may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration or during a stall test on an automatic transmission. As such, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-564.

Last Modified: 25-Oct-2010


Engine Cylinder Number 5 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 565

Engine Cylinder Number 5 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 565 PID: S094 SPN: 1356 FMI: 0 LAMP: Red SRT: | Engine Cylinder Number 5 Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. This may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration or during a stall test on an automatic transmission. As such, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-565.

Last Modified: 25-Oct-2010


Engine Cylinder Number 6 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 566

Engine Cylinder Number 6 Knock - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 566 PID: S095 SPN: 1357 FMI: 0 LAMP: Red SRT: | Engine Cylinder Number 6 Knock - Data Valid but Above Normal Operational Range - Most Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. This may include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power such as during wide open throttle acceleration or during a stall test on an automatic transmission. As such, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-566.

Last Modified: 25-Oct-2010


Knock Sensor Circuit - Shorted Low, Front Sensor

FAULT CODE 572

Knock Sensor Circuit - Shorted Low, Front Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 572 PID: S91 SPN: 1353 FMI: 4 LAMP: Amber SRT: | Knock Sensor Circuit - Shorted Low, Front Sensor. Knock sensor circuit shorted low. | Knock control will be disabled.
Knock Sensor 1 and 2 Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine if the engine is knocking so it can protect the engine.

Component Location

The knock sensor 1 is located on the side of the engine, on the block, above the air compressor on the C and L Gas Plus engines. The B series engine has Knock Sensor 1 located on the cylinder head intake cover capscrew.

Knock Sensor 2 is located on the top of the engine, on the cylinder head, beside cylinder number 6 on the C and L Gas Plus engines. On B series engine, Knock Sensor 2 is located on the left side of the block near the ECM.

Refer to Troubleshooting Fault Code t05-572.

Last Modified: 25-Oct-2010


Starter Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S039 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter relay circuit - Voltage above normal or shorted to high source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the Electronic Control Module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on Original Equipment Manufacturer (OEM) wiring. It is wired to chassis or block ground. Consult the OEM wiring diagram for return circuit details.

Component Location

The starter lockout relay is installed by the vehicle OEM. See the OEM service manual for exact location.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code t05-584.

Last Modified: 25-Oct-2010


Starter Relay Circuit - Shorted Low

FAULT CODE 585

Starter Relay Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S039 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter relay circuit - Shorted low. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the Electronic Control Module(ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on Original Equipment Manufacturer (OEM) wiring. It is wired to chassis or block ground. Consult the OEM wiring diagram for return circuit details.

Component Location

The starter lockout relay is installed by the vehicle OEM. Consult the OEM service manual for exact location.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded on, it records this fault code. This fault can be caused by:

  • A short circuit to ground in the starter lockout relay, OEM harness, or connectors.
Refer to Troubleshooting Fault Code t05-585.

Last Modified: 25-Oct-2010


Exhaust Back Pressure Sensor Circuit - Shorted High

FAULT CODE 591

Exhaust Back Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 591 PID: S034 SPN: 648 FMI: 3 LAMP: Amber SRT: | Exhaust Back Pressure Sensor Circuit - Shorted High. High voltage detected at the exhaust back pressure pin of the ECM connector. | Possible reduced performance.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor's input to determine the pressure of the exhaust gas, which affects the fueling of the engine.

Component Location

The exhaust back pressure sensor is located above the rocker housing and is connected to the closed-crankcase ventilation filter bracket. The sensor utilizes a tube that is fitted into the exhaust outlet connection. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The exhaust back pressure sensor tube is vulnerable to the collection of condensation and sludge. Periodic maintenance of this tube should be performed. This sensor is located such that it is protected from extreme heat. Do not relocate this sensor from its on-engine position.

On the L Gas Plus engine an OEM tube from the exhaust connects to an accumulator on the exhaust side of the engine. A tube then connects the accumulator to the exhaust back pressure sensor.

Refer to Troubleshooting Fault Code t05-591.

Last Modified: 25-Oct-2010


Exhaust Back Pressure Sensor Circuit - Shorted Low

FAULT CODE 592

Exhaust Back Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 592 PID: S034 SPN: 648 FMI: 4 LAMP: Amber SRT: | Exhaust Back Pressure Sensor Circuit - Shorted Low. Low voltage (short to ground) detected at the ECM connector. | Possible reduced performance.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor's input to determine the pressure of the exhaust gas, which affects the fueling of the engine.

Component Location

The exhaust back pressure sensor is located above the rocker housing and is connected to the closed-crankcase ventilation filter bracket. The sensor utilizes a tube that is fitted into the exhaust outlet connection. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The exhaust back pressure sensor tube is vulnerable to the collection of condensation and sludge. Periodic maintenance of this tube should be performed. This sensor is located such that it is protected from extreme heat. Do not relocate this sensor from its on-engine position.

On the L Gas Plus an OEM tube from the exhaust connects to an accumulator on the exhaust side of the engine. A tube then connects the accumulator to the exhaust back pressure sensor.

Refer to Troubleshooting Fault Code t05-592.

Last Modified: 25-Oct-2010


Engine Misfire for Multiple Cylinders - Data Valid But Below Normal Operational Level - Most Severe Level

FAULT CODE 613

Engine Misfire for Multiple Cylinders - Data Valid But Below Normal Operational Level - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 613 PID: None SPN: 1322 FMI: 11/31 LAMP: Red SRT: | Engine Misfire for Multiple Cylinders - Data Valid But Below Normal Operational Level - Most Severe Level | Progressive power derate increasing in severity from time of alert. Fault will only clear after key off event.
Ignition System Circuit

Circuit Description

The ignition system is a coil on plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the ECM. The ECM commands the ICM to energize the ignition coil for the proper cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary return wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) signal lines.

Component Location

The ICM is located next to the ECM on the intake side of the engine near the flywheel housing. The ignition coils are located above the corresponding cylinder on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects the engine misfire percentage for all cylinders is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM logs this fault immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.

  • The ECM will turn the fault inactive immediately after the ECM detects the misfire percentage for all cylinders has dropped below a calibrated value.
  • This fault code can also be cleared with INSITE™ electronic service tool.

Shop Talk

If the ECM does not receive a signal on the secondary return wire after a cylinder has been commanded to fire, the ECM will log this as a misfire. In addition to the three misfire faults for each cylinder, misfire percentages are also calculated over all six cylinders. There are three levels of severity for misfire on multiple cylinders.

Possible causes for the Fault Code 613 include:

  • Spark plugs past maintenance intervals
  • Damaged spark plugs or boots
  • Malfunctioning coils
  • Shorted or open ignition harness

In addition, misfires on multiple cylinders may be caused by low fuel pressure, EGR, voltage supply, fuel system, or oxygen sensor issues. Any fault codes for these systems should be resolved prior to troubleshooting the misfire compliant.

Misfires may not occur under all operating conditions. Be sure to operate the engine under the conditions in which the misfire occurs when troubleshooting.

All secondary return wires in the ignition harness are tied together. This way there will be continuity through each secondary return pin of each coil to the main secondary return wire at the ignition harness connector 2. If one of the secondary return wires is found to be open, the ICM will determine that the engine is misfiring when it is not.

Physical damage to the tip of the spark plug and/or traces of aluminum can indicate a damaged piston.

Refer to Troubleshooting Fault Code t05-613.

Last Modified: 25-Oct-2010


Primary Engine Speed Sensor Error

FAULT CODE 689

Primary Engine Speed Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2 LAMP: Amber SRT: | Primary Engine Speed Sensor (Crankshaft) Error - Data Erratic, Intermittent, or Incorrect. Loss of signal from crankshaft sensor. | Engine will possibly die or not start.
Engine Speed/Position Sensor Circuit

Circuit Description

The crankshaft engine speed/position sensor provides engine speed information to the electronic control module (ECM). The sensor is powered by 5 volts. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The engine speed/position sensor is located on the intake side of the engine between number 5 and number 6 cylinders at the crankshaft level. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is recorded when the ECM does not receive a signal from the crankshaft engine speed sensor, or the signal it receives is degraded.

Possible causes of this fault code include: open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM.

Short circuits to ground or return circuits in the sensor, engine harness, or ECM.

Short circuits to a voltage source in the sensor, engine harness, or ECM.

Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-689.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 751
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc751bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc751lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 752
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc752bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc752lgp

Last Modified: 01-Oct-2004


Fault Code Path Selection

FAULT CODE 753
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc753bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc753lgp

Last Modified: 01-Oct-2004


Secondary Engine Speed Sensor Error

FAULT CODE 778

Secondary Engine Speed Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S064 SPN: 723 FMI: 2 LAMP: Amber SRT: | Secondary Engine Speed Sensor (Camshaft) Error - Data Erratic, Intermittent, or Incorrect. Loss of signal from camshaft sensor. | Engine will possibly die or not start.
Engine Position Sensor Circuit

Circuit Description

The camshaft engine speed/position sensor provides engine speed information to the electronic control module (ECM). The sensor is powered by 5 volts. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the camshaft.

Component Location

The camshaft speed/position sensor is located on the intake side of the engine above the accessory drive. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is recorded when the ECM does not receive a signal from the camshaft engine speed sensor, or the signal it receives is degraded.

Possible causes of this fault code include: open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM.

Short circuits to ground or return circuits in the sensor, engine harness, or ECM.

Short circuits to a voltage source in the sensor, engine harness, or ECM.

Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-778.

Last Modified: 25-Oct-2010


Fault Code Path Selection

FAULT CODE 1128
Fault Code Path Selection

Do you have a B Gas Plus or a C Gas Plus Engine? | Go to 85-fc1128bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc1128lgp

Last Modified: 14-May-2014


Fault Code Path Selection

FAULT CODE 1129
Fault Code Path Selection

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc1129bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc1129lgp

Last Modified: 01-Oct-2004


Engine Misfire for Multiple Cylinders - Data Valid but Below Normal Operational Level - Most Severe Level

FAULT CODE 1271

Engine Misfire for Multiple Cylinders - Data Valid but Below Normal Operational Level - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1271 PID: None SPN: 1322 FMI: 1 LAMP: Red SRT: | Engine Misfire for Multiple Cylinders - Data Valid but Below Normal Operational Level - Most Severe Level | Progressive power derate increasing in severity from time of alert.
Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information. The ICM is capable of misfire and spark voltage detection.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

For the ICM to operate correctly, all components must be clean and tight. Fault Codes 1482 will always be active if this fault is active.

Refer to Troubleshooting Fault Code t05-1271.

Last Modified: 25-Oct-2010


Engine Misfire For Multiple Cylinders - Data Valid But Below Normal Operating Level - Least Severe Level

FAULT CODE 1482

Engine Misfire For Multiple Cylinders - Data Valid But Below Normal Operating Level - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1482 PID: None SPN: 1322 FMI: None LAMP: None SRT: | Engine Misfire For Multiple Cylinders - Data Valid But Below Normal Operating Level - Least Severe Level | None - information for misfire.
Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information. The ICM is capable of misfire and spark voltage detection.

Component Location

The ICM is located next to the ECM on the side of the engine.

Refer to Troubleshooting Fault Code t05-1482.

Last Modified: 21-Feb-2012


Engine Cylinder 1 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1643

Engine Cylinder 1 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1643 PID: S90 SPN: 1352 FMI: 0 LAMP: Amber SRT: | Engine Cylinder Number 1 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if it is operated at excessive temperature. Other sources of high frequency vibration can cause knock faults to be logged. Examples include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically occur when operated at full power such as during wide open throttle acceleration or during a stall test with an automatic transmission. Because of this, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-1643.

Last Modified: 22-Feb-2012


Engine Cylinder 2 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1644

Engine Cylinder 2 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1644 PID: S91 SPN: 1353 FMI: 0 LAMP: Amber SRT: | Engine Cylinder Number 2 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if it is operated at excessive temperature. Other sources of high frequency vibration can cause knock faults to be logged. Examples include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically occur when operated at full power such as during wide open throttle acceleration or during a stall test with an automatic transmission. Because of this, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-1644.

Last Modified: 22-Feb-2012


Engine Cylinder 3 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1645

Engine Cylinder 3 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1645 PID: S92 SPN: 1354 FMI: 0 LAMP: Amber SRT: | Engine Cylinder Number 3 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the side of the engine, on the block, above the air compressor on C and L engines. The B series engine has the knock sensor located on the cylinder head intake cover capscrew. The front knock sensor mounting surface on the C and L engine block has two identically sized holes. The knock sensor is mounted on the lower hole and the top hole is used on some products for p-clip mounting.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if it is operated at excessive temperature. Other sources of high frequency vibration can cause knock faults to be logged. Examples include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically occur when operated at full power such as during wide open throttle acceleration or during a stall test with an automatic transmission. Because of this, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-1645.

Last Modified: 22-Feb-2012


Engine Cylinder 4 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1646

Engine Cylinder 4 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1646 PID: S93 SPN: 1355 FMI: 0 LAMP: Amber SRT: | Engine Cylinder Number 4 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 2 is located on the top of the engine, on the cylinder head, near cylinder number 6 on C and L engines. On the B series engine, knock sensor 2 is located on the side of the block near the ECM.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if it is operated at excessive temperature. Other sources of high frequency vibration can cause knock faults to be logged. Examples include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically occur when operated at full power such as during wide open throttle acceleration or during a stall test with an automatic transmission. Because of this, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-1646.

Last Modified: 22-Feb-2012


Engine Cylinder 5 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1647

Engine Cylinder 5 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1647 PID: S94 SPN: 1356 FMI: 0 LAMP: Amber SRT: | Engine Cylinder Number 5 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 2 is located on the top of the engine, on the cylinder head, near cylinder number 6 on C and L engines. On the B series engine, knock sensor 2 is located on the side of the block near the ECM.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if it is operated at excessive temperature. Other sources of high frequency vibration can cause knock faults to be logged. Examples include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically occur when operated at full power such as during wide open throttle acceleration or during a stall test with an automatic transmission. Because of this, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-1647.

Last Modified: 23-Feb-2012


Engine Cylinder 6 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1648

Engine Cylinder 6 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1648 PID: S95 SPN: 1357 FMI: 0 LAMP: Amber SRT: | Engine Cylinder Number 6 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer which measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. In this way, one sensor can be used for multiple cylinders.

Component Location

Knock sensor 2 is located on the top of the engine, on the cylinder head, near cylinder number 6 on C and L engines. On the B series engine, knock sensor 2 is located on the side of the block near the ECM.

Shop Talk

The knock sensors are located on the cylinder block and cylinder head. There are two sensors. Knock sensor 1 monitors cylinders 1, 2, and 3; and knock sensor 2 monitors cylinders 4, 5, and 6. The vehicle keyswitch must be cycled before full power will be restored after a knock induced derate.

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock can occur if the engine is supplied low quality fuel or if it is operated at excessive temperature. Other sources of high frequency vibration can cause knock faults to be logged. Examples include gear driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically occur when operated at full power such as during wide open throttle acceleration or during a stall test with an automatic transmission. Because of this, faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code t05-1648.

Last Modified: 23-Feb-2012


Spark Voltage on Multiple Cylinders - Data Valid But Below Normal Operating Range

FAULT CODE 1649

Spark Voltage on Multiple Cylinders - Data Valid But Below Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1649 PID: None SPN: None FMI: 1/17 LAMP: None SRT: | Spark Voltage on Multiple Cylinders - Data Valid But Below Normal Operating Range | None - information for misfire.
Ignition Timing Signal Circuit

Circuit Description

The ICM is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The ECM controls the ICM by providing ignition timing information. The ICM is capable of misfire and spark voltage detection.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the vehicle is in normal service or for misfire complaints. The most probable cause for this fault code to occur will be from an ignition coil or incorrectly gapped spark plug.

Refer to Troubleshooting Fault Code t05-1649.

Last Modified: 23-Feb-2012


Spark Voltage on Multiple Cylinders - Data Valid But Above Normal Operating Range

FAULT CODE 1651

Spark Voltage on Multiple Cylinders - Data Valid But Above Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1651 PID: None SPN: None FMI: 0/15 LAMP: None SRT: | Spark Voltage on Multiple Cylinders - Data Valid But Above Normal Operating Range | None - information for misfire.
Ignition Timing Signal Circuit

Circuit Description

The ICM is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The ECM controls the ICM by providing ignition timing information. The ICM is capable of misfire and spark voltage detection.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness or ICM exists when the vehicle is in normal service or for misfire complaints. The most probable cause for this fault code to occur will be from an ignition coil or incorrectly gapped spark plug.

Refer to Troubleshooting Fault Code t05-1651.

Last Modified: 23-Feb-2012


Spark Voltage on Multiple Cylinders - Data Erratic, Intermittent or Incorrect

FAULT CODE 1652

Spark Voltage on Multiple Cylinders - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1652 PID: None SPN: None FMI: 2 LAMP: Amber SRT: | Spark Voltage on Multiple Cylinders - Data Erratic, Intermittent or Incorrect. | None - information for short or open circuit in the ignition harness spark signal lines.
Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information. The ICM is capable of misfire and spark voltage detection.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

This fault code is designed to inform the technician a potential problem with the ignition harness or ICM. The most probable cause for this fault code to occur will be from an ignition harness short or open.

Refer to Troubleshooting Fault Code t05-1652.

Last Modified: 23-Feb-2012


Fault Code Path Selection

FAULT CODE 1919
Fault Code Path Selection

View Related Topic

Do you have a B Gas Plus or C Gas Plus Engine? | Go to 85-fc1919bcgp
Do you have a L Gas Plus Engine? | Go to 85-fc1919lgp

Last Modified: 28-Nov-2006


Fuel Delivery Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2118

Fuel Delivery Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2118 PID: P135 SPN: 135 FMI: 0/16 LAMP: Amber SRT: | Fuel Delivery Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. Pressure is above the engine protection limit. | Progressive power derate increasing in severity from time of alert.
Fuel Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the primary fuel pressure sensor on the sensor supply 4 circuit. The ECM also provides a ground on the sensor return circuit. The primary fuel pressure sensor provides a signal to the ECM on the primary fuel pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the engine (low pressure) regulator.

Component Location

On the B Gas Plus, C Gas Plus, and L Gas Plus the primary fuel pressure sensor is located in the low pressure regulator housing. On the B LPG Plus the primary fuel pressure sensor is located in the evaporator.

Shop Talk

The primary fuel pressure sensor is used to detect high or low fuel pressure conditions from the OEM fuel system.

Possible causes of this fault code include:

  • Over pressurized fuel tanks
  • Damaged OEM high pressure fuel regulator
  • Damaged primary fuel pressure sensor.
Refer to Troubleshooting Fault Code 2118.

Last Modified: 24-Feb-2012


Fuel Delivery Pressure 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2119

Fuel Delivery Pressure 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2119 PID: P135 SPN: 135 FMI: 1/18 LAMP: Amber SRT: | Fuel Delivery Pressure 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level | Engine power derate.
Fuel Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the primary fuel pressure sensor on the sensor supply 4 circuit. The ECM also provides a ground on the sensor return circuit. The primary fuel pressure sensor provides a signal to the ECM on the primary fuel pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the engine (low pressure) regulator.

Component Location

On the B Gas Plus, C Gas Plus, and L Gas Plus the primary fuel pressure sensor is located in the low pressure regulator housing. On the B LPG Plus the primary fuel pressure sensor is located in the evaporator.

Shop Talk

The primary fuel pressure sensor is used to detect high or low fuel pressure conditions from the OEM fuel system.

Possible cause of this fault code include:

  • Low fuel level or pressure
  • Restrictions in the fuel lines or fuel filter
  • Damaged OEM high pressure regulator
  • Damaged primary fuel pressure sensor.
Refer to Troubleshooting Fault Code 2119.

Last Modified: 23-Nov-2010


Fuel Control Valve Hysteresis

FAULT CODE 2184

Fuel Control Valve Hysteresis

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2184 PID: S018 SPN: 633 FMI: 11 LAMP: Amber SRT: | Fuel Control Valve Hysteresis. | Possible reduced performance.
Fuel Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses this valve to meter the fuel flow into the fuel housing.

Component Location

The fuel control valve is located in the fuel housing next to the gas mass flow sensor.

Shop Talk

This valve is normally closed when no power is applied. The valve is pulse-width modulated. Oil and debris can cause the valve to operate incorrectly. Drain the fuel filter and check the system for oil contamination.

Refer to Troubleshooting Fault Code t05-2184.

Last Modified: 24-Feb-2012


Sensor Supply Voltage (4) Circuit - Shorted High

FAULT CODE 2185

Sensor Supply Voltage (4) Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 620 FMI: 3 LAMP: Amber SRT: | Sensor Supply Voltage (4) Circuit - Shorted High . High voltage detected on sensor supply voltage (4) circuit. | Possible reduced performance.
Sensor Supply Voltage (4) Circuit

Circuit Description

This circuit is the voltage supply for the primary fuel pressure sensor and exhaust back pressure sensor.

Component Location

The sensor supply voltage (4) circuit is contained in the wiring harness.

Shop Talk

The voltage supplies on the B and C Gas Plus engines are broken up into 1, 2, 3, and 4. On the L Gas Plus engine, voltage supplies are broken up into 1, 2, and 4.

Refer to Troubleshooting Fault Code t05-2185.

Last Modified: 25-Oct-2010


Sensor Supply Voltage (4) Circuit - Shorted Low

FAULT CODE 2186

Sensor Supply Voltage (4) Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 620 FMI: 4 LAMP: Amber SRT: | Sensor Supply Voltage (4) Circuit - Shorted Low. Low voltage detected on sensor supply voltage (4) . | Possible reduced performance.
Sensor Supply Voltage (4) Circuit

Circuit Description

This circuit is the voltage supply for the primary fuel pressure sensor and exhaust back pressure sensor.

Component Location

The sensor supply voltage (4) circuit is contained in the wiring harness.

Shop Talk

The voltage supplies on the B and C Gas Plus engines are broken up into 1, 2, 3, and 4. On the L Gas Plus engines, voltage supplies are broken up into 1, 2, and 4.

Refer to Troubleshooting Fault Code t05-2186.

Last Modified: 25-Oct-2010


Exhaust Back Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2187

Exhaust Back Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2187 PID: S34 SPN: 648 FMI: 0/16 LAMP: Amber SRT: | Exhaust Back Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Pressure is above the engine protection limit. | Progressive speed and power derate.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor's input to determine the pressure of the exhaust gas, which affects the fueling of the engine.

Component Location

The exhaust back pressure sensor is located above the rocker housing and is attached to the closed-crankcase ventilation filter bracket.

Shop Talk

The arrangement of this sensor allows some condensation/sludge buildup within the tube arrangement. Before replacing the sensor, make sure this tube is free from blockage.

On the L Gas Plus, an original equipment manufacturer (OEM) tube from the exhaust connects to a boiler box on the exhaust side of the engine. A tube then connects the box to the exhaust back pressure sensor.

Refer to Troubleshooting Fault Code t05-2187.

Last Modified: 27-Feb-2012


Heated Oxygen Sensor Circuit - Heater Shorted High

FAULT CODE 2188

Heated Oxygen Sensor Circuit - Heater Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2188 PID: S151 SPN: 611 FMI: 4 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Heater Shorted High. Open circuit detected on the heater return pin at the ECM or no heater supply voltage. | Possible reduced performance. No closed loop operation.
Heated Oxygen Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling when operating in closed loop.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The oxygen sensor is used to correct the fuel composition that is used by the engine. The sensor only affects the closed-loop operation of the engine.

If the fault code remains active after all troubleshooting steps have been followed, the sensor can possibly have a voltage supply issue. Remove pin 26 from the OEM side of the 31-pin connector and connect a 12-VDC supply from the vehicle battery to the heated oxygen sensor heater positive pin 26. If the fault code goes inactive, there is a voltage drop in the OEM supply circuit to pin 26.

Refer to Troubleshooting Fault Code t05-2188.

Last Modified: 25-Oct-2010


Leaking Throttle Plate

FAULT CODE 2189

Leaking Throttle Plate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2189 PID: S58 SPN: 698 FMI: 7 LAMP: Amber SRT: | Leaking Throttle Plate. Throttle actuator leaking. | The engine will idle above 900 rpm.
Throttle Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the throttle actuator; it is both an input and output device.

Component Location

The throttle actuator is located after the fuel housing and before the intake manifold cover.

Shop Talk

The throttle actuator used for the Gas Plus engines is pulse-width modulated. Leaks, especially missing pipe and cap plugs, after the throttle actuator can also cause this fault. Excessive backfire can cause a bent throttle plate.

Refer to Troubleshooting Fault Code t05-2189.

Last Modified: 27-Feb-2012


Mixer Inlet Pressure, Intake Manifold Pressure, and Exhaust Back Pressure Do Not Agree

FAULT CODE 2191

Mixer Inlet Pressure, Intake Manifold Pressure, and Exhaust Back Pressure Do Not Agree

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2191 PID: P102 SPN: 102 FMI: 11/31 LAMP: Amber SRT: | Mixer Inlet Pressure, Intake Manifold Pressure, and Exhaust Back Pressure Do Not Agree. Manifold Absolute Pressure Sensor disagrees with the Mixer Inlet Pressure Sensor or the Exhaust Back Pressure Sensor. | Possible reduced performance.
Atmospheric Pressure Sensors

Circuit Description

The electronic control module (ECM) uses these three sensors to validate the atmospheric pressure.

Component Location

The mixer inlet pressure sensor is located in the air inlet elbow, the intake manifold pressure/temperature sensor is located in the intake manifold, and the exhaust back pressure sensor is connected to the exhaust.

Shop Talk

Atmospheric pressure is used to calculate base fueling to the engine.

Refer to Troubleshooting Fault Code t05-2191.

Last Modified: 27-Feb-2012


Heated Oxygen Sensor Circuit - Heater Shorted Low

FAULT CODE 2192

Heated Oxygen Sensor Circuit - Heater Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2192 PID: S151 SPN: 611 FMI: 3 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Heater Shorted Low. Heater voltage to heated oxygen sensor low. | Possible reduced performance.
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, and then to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (λ). The air/fuel ratio (stoichiometric) is 1λ :17. The approximate lean-burn condition for the engine is 1.4.

Refer to Troubleshooting Fault Code t05-2192.

Last Modified: 23-Aug-2011


L Gas Plus - Engine Speed/Position Sensor Error

FAULT CODE 2199

L Gas Plus - Engine Speed/Position Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2199 PID: P190 SPN: 190 FMI: 2 LAMP: Amber SRT: | L Gas Plus - Engine Speed/Position - Sensor Error. | Engine will possibly die or not start.
Engine Position Sensor Circuit

Circuit Description

The crankshaft engine speed/position sensor provides engine speed information to the electronic control module (ECM). The sensor is powered by 5 volts. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The engine speed/position sensor is located on the intake side of the engine between number 5 and number 6 cylinders at the crankshaft level. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is recorded when the ECM does not receive a signal from the crankshaft engine speed sensor, or the signal it receives is degraded.

Possible causes of this fault code include: open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM.

Short circuits to ground or return circuits in the sensor, engine harness, or ECM.

Short circuits to a voltage source in the sensor, engine harness, or ECM.

Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-2199.

Last Modified: 27-Feb-2012


Heated Oxygen Sensor Circuit - Failed In-Range High

FAULT CODE 2219

Heated Oxygen Sensor Circuit - Failed In-Range High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2219 PID: S65 SPN: 724 FMI: 0/16 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Failed In-Range High. The measured air-to-fuel ratio is greater than the desired calculated air-to-fuel ratio. | Possible reduced performance. No closed loop operation.
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas, and then to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (λ). The air-to-fuel ratio (stoichiometric) is 1λ :16.5. The approximate lean-burn condition for the engine is 1.4.

The ECM will read an in-range high fault code if the engine is running lean or the heated oxygen sensor or heated oxygen sensor circuit has malfunctioned. An exhaust leak can cause this fault code by not providing enough back pressure to the heated oxygen sensor. If there are any intake leaks after the throttle actuator, the engine can also run lean due to low fuel pressure problems which can cause this fault code to activate. If this troubleshooting tree does not fix the problem, the ECM can be the fault.

Refer to Troubleshooting Fault Code t05-2219.

Last Modified: 23-Aug-2011


Heated Oxygen Sensor Circuit - Failed In-Range Low

FAULT CODE 2221

Heated Oxygen Sensor Circuit - Failed In-Range Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2221 PID: S65 SPN: 724 FMI: 0/18 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Failed In-Range Low. The measured air-to-fuel ratio is lower than the desired calculated air-to-fuel ratio. | Possible reduced performance. No closed loop operation.
Heated Oxygen Sensor Circuit

Circuit Description

The ECM uses this sensor to determine the composition of the exhaust gas and then to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (λ). The air-to-fuel ratio (stoichiometric) is 1λ :16.5. The approximate lean-burn condition for the engine is 1.4.

The ECM will read an in-range low fault if the engine is running rich or the heated oxygen sensor or heated oxygen sensor circuit has failed. Excessive exhaust back pressure can cause this fault by creating a lower partial pressure of oxygen to form at the heated oxygen sensor. If the fuel control valve is stuck open the engine will not burn all the gas that is ingested causing it to run rich. If the heated oxygen sensor heater supply has shorted to ground or has an open circuit, then the sensor will read a lower than normal exhaust oxygen value.

Refer to Troubleshooting Fault Code t05-2221.

Last Modified: 23-Aug-2011


Intake Manifold Pressure Leak

FAULT CODE 2227

Intake Manifold Pressure Leak

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2227 PID: P102 SPN: 102 FMI: 7 LAMP: Amber SRT: | Intake Manifold Pressure Leak. Intake manifold pressure leak is due to actuator leaking. | The engine will idle above 900 rpm.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the electronic throttle control actuator; it is both an input and output device.

Component Location

The electronic throttle control actuator is located after the fuel housing and before the intake manifold inlet.

Shop Talk

The electronic throttle control actuator used for the Plus technology is pulse-width modulated and is compatible with only the Gas Plus engines.

Refer to Troubleshooting Fault Code t05-2227.

Last Modified: 28-Feb-2012


Fuel Delivery Pressure (Absolute) High - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2228

Fuel Delivery Pressure (Absolute) High - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2228 PID: P135 SPN: 135 FMI: 0/16 LAMP: Red SRT: | Fuel Delivery Pressure (Absolute) High - Data Valid But Above Normal Operating Range - Most Severe Level. Pressure is above the engine protection limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown is enabled, the engine will shut down 30 seconds after red stop lamp starts flashing.
Fuel Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the primary fuel pressure sensor on the sensor supply 4 circuit. The ECM also provides a ground on the sensor return circuit. The primary fuel pressure sensor provides a signal to the ECM on the primary fuel pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel entering the engine (low pressure) regulator.

Component Location

On the B Gas Plus, C Gas Plus, and L Gas Plus the primary fuel pressure sensor is located in the low pressure regulator housing.On the B LPG Plus the primary fuel pressure sensor is located in the evaporator.

Shop Talk

The primary fuel pressure sensor is used to detect high or low fuel pressure conditions from the OEM fuel system. The engine protection shutdown for fuel pressure is a customer feature and will only be enabled at the customer's request. This sensor will deactivate or disable the fuel control valve if this feature is utilized by the OEM.

Possible causes of this fault code include:

  • Over pressurized fuel tanks
  • Damaged OEM high pressure fuel regulator
  • Damaged primary fuel pressure sensor
Refer to Troubleshooting Fault Code t05-2228.

Last Modified: 28-Feb-2012


Heated Oxygen Sensor Circuit - Long Term Drift

FAULT CODE 2229

Heated Oxygen Sensor Circuit - Long Term Drift

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2229 PID: S55 SPN: 724 FMI: 13 LAMP: Amber SRT: | Heated Oxygen Sensor Circuit - Long Term Drift. Heated oxygen sensor failed long-term drift. | Possible reduced performance. No closed loop operation.
Heated Oxygen Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas, and then to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

The heated oxygen sensor measures the partial pressure of oxygen present in the exhaust gas. It measures this oxygen presence in lambda (λ). The air/fuel ratio (stoichiometric) is 1λ. The approximate lean-burn condition for the engine is 1.4.

This fault code will become active if there is not enough oxygen being pumped through the exhaust while motoring. Any presence of hydrocarbons can cause the heated oxygen sensor to misread the air oxygen content in the exhaust. Oil, fuel, or air contaminants that can pass by the heated oxygen sensor can cause the sensor to misread and light the fault lamp. Keep in mind this will occur only in a motoring situation. The ECM uses data from motoring instances to recalibrate fuel tables and maintain optimum fuel operation for the engine.

Refer to Troubleshooting Fault Code t05-2229.

Last Modified: 23-Aug-2011


Exhaust Back Pressure Low Warning - Under Pressure

FAULT CODE 2319

Exhaust Back Pressure Low Warning - Under Pressure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2319 PID: S34 SPN: 648 FMI: 1/18 LAMP: Amber SRT: | Exhaust Back Pressure Low Warning - Under Pressure. Low exhaust back pressure or the sensor signal line has been broken. | Possible reduced performance.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor's input to determine the pressure of the exhaust gas, which affects the fueling of the engine.

Component Location

The exhaust back pressure sensor is located above the rocker housing and attached to the closed-crankcase ventilation filter bracket.

Shop Talk

The arrangement of this sensor allows some condensation/sludge buildup within the tube arrangement. Before replacing the sensor, make sure this tube is free from blockage.

On the L Gas Plus, an OEM tube from the exhaust connects to a boiler box on the exhaust side of the engine. A tube then connects the box to the exhaust back pressure sensor.

A broken or disconnected exhaust back pressure tube will cause this fault to be active.

Refer to Troubleshooting Fault Code t05-2319.

Last Modified: 28-Feb-2012


Humidity Sensor - Voltage Above Normal

FAULT CODE 1128

Humidity Sensor - Voltage Above Normal

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1128 PID: 370 SPN: 2946 FMI: 3 LAMP: Amber SRT: | Humidity Sensor - Voltage above normal or shorted to a high source. High signal voltage detected at the humidity sensor signal circuit at the ECM. | Possible reduced performance.
Humidity Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the humidity sensor to measure relative humidity. The humidity sensor is connected to sensor supply number 1.

Component Location

The humidity sensor is located in the mixer inlet elbow near the fuel housing.

Shop Talk

Relative humidity is calculated using the intake manifold temperature sensor, intake manifold pressure sensor, and humidity sensor. The units are displayed in grains/pound mass of dry air. The humidity sensor can only provide a valid reading under certain engine operating conditions. The value displayed for specific humidity is the last value updated by the sensor. A value of 75 grains is the default and will be displayed until the engine operating conditions are met for an update.

Refer to Troubleshooting Fault Code t05-1128bcgp.

Last Modified: 25-Oct-2010


Humidity Sensor - Voltage Above Normal

FAULT CODE 1128

Humidity Sensor - Voltage Above Normal

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1128 PID: 370 SPN: 2946 FMI: 3 LAMP: Amber SRT: | Humidity Sensor - Voltage above normal or shorted to a high source. High signal voltage detected at the humidity sensor signal circuit at the ECM. | Possible reduced performance.
Humidity Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the humidity sensor to measure relative humidity. The humidity sensor is connected to sensor supply number 1.

Component Location

The humidity sensor is located in the turbocharger compressor inlet elbow.

Shop Talk

Relative humidity is calculated using the turbocharger compressor temperature sensor, turbocharger compressor pressure sensor, and humidity sensor. The units are displayed in grains/pound mass of dry air. The humidity sensor can only provide a valid reading under certain engine operating conditions. The value displayed for specific humidity is the last value updated by the sensor. A value of 75 grains is the default and will be displayed until the engine operating conditions are met for an update.

Refer to Troubleshooting Fault Code t05-1128lgp.

Last Modified: 25-Oct-2010


Humidity Sensor - Voltage Below Normal

FAULT CODE 1129

Humidity Sensor - Voltage Below Normal

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1129 PID: 370 SPN: 2946 FMI: 4 LAMP: Amber SRT: | Humidity Sensor - Voltage below normal or shorted to a low source. Low signal voltage detected at the humidity sensor signal circuit at the ECM. | Possible reduced performance.
Humidity Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the humidity sensor to measure relative humidity. The humidity sensor is connected to sensor supply number 1.

Component Location

The humidity sensor is located in the mixer inlet elbow near the fuel housing.

Shop Talk

Relative humidity is calculated using the intake manifold temperature sensor, intake manifold pressure sensor, and humidity sensor. The units are displayed in grains/pound mass of dry air. The humidity sensor can only provide a valid reading under certain engine operating conditions. The value displayed for specific humidity is the last value updated by the sensor. A value of 75 grains is the default and will be displayed until the engine operating conditions are met for an update.

Refer to Troubleshooting Fault Code t05-1129bcgp.

Last Modified: 25-Oct-2010


Humidity Sensor - Voltage Below Normal

FAULT CODE 1129

Humidity Sensor - Voltage Below Normal

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1129 PID: 370 SPN: 2946 FMI: 4 LAMP: Amber SRT: | Humidity Sensor - Voltage below normal or shorted to a low source. Low signal voltage detected at the humidity sensor signal circuit at the ECM. | Possible reduced performance.
Humidity Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the humidity sensor to measure relative humidity. The humidity sensor is connected to sensor supply number 1.

Component Location

The humidity sensor is located in the turbocharger compressor inlet elbow.

Shop Talk

Relative humidity is calculated using the turbocharger compressor temperature sensor, turbocharger compressor pressure sensor, and humidity sensor. The units are displayed in grains/pound mass of dry air. The humidity sensor can only provide a valid reading under certain engine operating conditions. The value displayed for specific humidity is the last value updated by the sensor. A value of 75 grains is the default and will be displayed until the engine operating conditions are met for an update.

Refer to Troubleshooting Fault Code t05-1129lgp.

Last Modified: 25-Oct-2010


Engine Position Sensor Circuit - Both Signals Lost

FAULT CODE 115

Engine Position Sensor Circuit - Both Signals Lost

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Red SRT: | Engine position sensor circuit - both signals lost. | Engine can possibly die or will not start.
Engine Position Sensor Circuit

Circuit Description

The engine position sensor is a magnetic sensor that provides engine speed and position to the electronic control module. This sensor generates a signal from the movement of target teeth machined into the rear side of the camshaft gear.

Component Location

The engine position sensor is located in the gear housing behind the air compressor. Refer to Procedure 100-002 in Section E for a detailed component location.

Shop Talk

During normal engine operation, the intake manifold is under a vacuum (less than atmospheric pressure). When the intake manifold pressure indicates a vacuum, the engine will be running. Fault Code 115 can become active with the keyswitch on and the engine RPM at zero, if the intake manifold pressure indicates a pressure that is different than expected. INSITE™ electronic service tool can be used to compare the intake manifold pressure sensor to the mixer inlet pressure sensor. These two sensors must both be equal and read atmospheric pressure (101.3 kPa [14.7 psia] at sea level) with the keyswitch on and the engine not running. If these are not equal, it possibly indicates an in-range failure of the intake manifold pressure sensor. The engine will possibly not start if this condition exists.

Check the engine position sensor for engine oil contamination. Engine oil will wick through the wires into the connector. Also check the tip of the sensor for damage, the tip can extrude out of the sensor body and contact the camshaft gear, damaging the sensor.

Refer to Troubleshooting Fault Code t05-115bcgp.

Last Modified: 15-Feb-2012


Engine Speed/Position Sensor Circuit - Both Signals Lost

FAULT CODE 115

Engine Speed/Position Sensor Circuit - Both Signals Lost

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Red SRT: | Engine speed/position sensor circuit - both signals lost. | Engine can possibly die or will not start.
Engine Position Sensor Circuit

Circuit Description

The crankshaft and camshaft engine speed/position sensors provides engine speed and position information to the electronic control module (ECM). The sensor is powered by 5 volts. The sensor generates the signal by sensing movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The crankshaft speed/position sensor is located on the intake side of the engine between number 5 and number 6 cylinders at the crankshaft level. The camshaft speed/position sensor in located on the intake side of the engine above the accessory drive. Refer to Procedure 100-002 for a detailed component location.

Shop Talk

When the intake manifold pressure indicates a vacuum, the engine will be running. Fault Code 115 can become active with the keyswitch on and the engine RPM is zero if the intake manifold pressure indicates a pressure that is different than expected. INSITE™ electronic service tool can be used to compare the intake manifold pressure sensor to the mixer inlet pressure sensor. These two sensors must both be equal and read atmospheric pressure (101.3 kPa [14.7 psia] at sea level) with the keyswitch on and the engine is not running. If these are not equal, it possibly indicates an in-range failure of the intake manifold pressure sensor. The engine will possibly not start if this condition exists.

This fault code is recorded when the ECM does not receive a signal from the crankshaft and camshaft speed sensor, or the signal it receives is degraded.

Possible causes of this fault code include: open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM.

Short circuits to ground or return circuits in the sensor, engine harness, or ECM.

Short circuits to a voltage source in the sensor, engine harness, or ECM.

Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-115lgp.

Last Modified: 25-Oct-2010


Mixer Inlet Pressure Sensor Circuit - Shorted High

FAULT CODE 122

Mixer Inlet Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Mixer Inlet Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Amber SRT: | Mixer Inlet Pressure Sensor Circuit - Voltage above normal, or shorted to high source. High signal voltage detected on the mixer inlet pressure signal pin at the ECM. | Engine power derate.
Mixer Inlet Pressure Sensor Circuit

Circuit Description

The Mixer Inlet Pressure Sensor measures the inlet air pressure entering the fuel housing.

Component Location

The Mixer Inlet Pressure Sensor is located in the air inlet elbow.

Shop Talk

If the Mixer Inlet Pressure Sensor is disconnected, the engine can continue operating by using the accelerator plate position and the manifold pressure to estimate the mixer inlet pressure. Before performing any wiring checks, disconnect the sensor from the engine harness.

Refer to Troubleshooting Fault Code t05-122bcgp.

Last Modified: 25-Oct-2010


Mixer Inlet Pressure Sensor Circuit - Shorted High

FAULT CODE 122

Mixer Inlet Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Mixer Inlet Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Amber SRT: | Mixer Inlet Pressure Sensor Circuit - Voltage above normal, or shorted to high source. High signal voltage detected on the mixer inlet pressure signal pin at the ECM. | Engine power derate.
Mixer Inlet Pressure Sensor Circuit

Circuit Description

The Mixer Inlet Pressure Sensor measures the inlet air pressure entering the fuel housing.

Component Location

The Mixer Inlet Pressure Sensor is located in the air inlet elbow.

Shop Talk

If the Mixer Inlet Pressure Sensor is disconnected, the engine can continue operating by using the accelerator plate position and the manifold pressure to estimate the mixer inlet pressure. Before performing any wiring checks, disconnect the sensor from the engine harness.

Refer to Troubleshooting Fault Code t05-122lgp.

Last Modified: 25-Oct-2010


Mixer Inlet Pressure Sensor Circuit - Shorted Low

FAULT CODE 123

Mixer Inlet Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Mixer Inlet Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Amber SRT: | Mixer Inlet Pressure Sensor Circuit - voltage below normal or shorted to low source. Low signal voltage detected on the mixer inlet pressure signal pin at the ECM. | Engine power derate.
Mixer Inlet Pressure Sensor Circuit

Circuit Description

The Mixer Inlet Pressure Sensor measures the inlet air pressure entering the fuel housing.

Component Location

The Mixer Inlet Pressure Sensor is located in the air inlet elbow.

Shop Talk

If the Mixer Inlet Pressure Sensor is disconnected, the engine can continue operating by using the accelerator plate position and the manifold pressure to estimate the mixer inlet pressure. Before performing any wiring checks, disconnect the sensor from the engine harness.

Refer to Troubleshooting Fault Code t05-123bcgp.

Last Modified: 25-Oct-2010


Mixer Inlet Pressure Sensor Circuit - Shorted Low

FAULT CODE 123

Mixer Inlet Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Mixer Inlet Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Amber SRT: | Mixer Inlet Pressure Sensor Circuit - voltage below normal or shorted to low source. Low signal voltage detected on the mixer inlet pressure signal pin at the ECM. | Engine power derate.
Mixer Inlet Pressure Sensor Circuit

Circuit Description

The Mixer Inlet Pressure Sensor measures the inlet air pressure entering the fuel housing.

Component Location

The Mixer Inlet Pressure Sensor is located in the air inlet elbow.

Shop Talk

If the Mixer Inlet Pressure Sensor is disconnected, the engine can continue operating by using the accelerator plate position and the manifold pressure to estimate the mixer inlet pressure. Before performing any wiring checks, disconnect the sensor from the engine harness.

Refer to Troubleshooting Fault Code t05-123lgp.

Last Modified: 25-Oct-2010


High Mixer Inlet Pressure - Overboost

FAULT CODE 124

High Mixer Inlet Pressure - Overboost

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 0/16 LAMP: Amber SRT: | High mixer inlet pressure - Overboost. Pressure is above the engine protection limit. | Engine power derate.
Mixer Inlet Pressure Sensor Circuit

Circuit Description

The Mixer Inlet Pressure Sensor measures the inlet air pressure entering the fuel housing.

Component Location

The Mixer Inlet Pressure Sensor is located in the air inlet elbow.

Shop Talk

The Mixer Inlet Pressure Sensor detects the pressure of the air entering the mixer housing. This is sometimes referred to as the boost pressure sensor or compressor outlet pressure sensor. If the Mixer Inlet Pressure Sensor is disconnected, the engine can continue operating by using the accelerator plate position and the manifold absolute pressure to estimate the mixer inlet pressure. Before performing any wiring checks, disconnect the sensor from the engine harness.

Refer to Troubleshooting Fault Code t05-124bcgp.

Last Modified: 25-Oct-2010


High Mixer Inlet Pressure - Overboost

FAULT CODE 124

High Mixer Inlet Pressure - Overboost

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 0/16 LAMP: Amber SRT: | High Mixer Inlet Pressure - Overboost. Pressure is above the engine protection limit. | Engine power derate.
Mixer Inlet Pressure Sensor Circuit

Circuit Description

The mixer inlet pressure sensor measures the inlet air pressure entering the fuel housing.

Component Location

The mixer inlet pressure sensor is located in the air inlet elbow.

Shop Talk

The mixer inlet pressure sensor detects the pressure of the air entering the mixer housing. This is sometimes referred to as the boost pressure sensor or compressor outlet pressure sensor. If the mixer inlet pressure sensor is disconnected, the engine can continue operating by using the accelerator plate position and the manifold absolute pressure to estimate the mixer inlet pressure. Before performing any wiring checks, disconnect the sensor from the engine harness.

Refer to Troubleshooting Fault Code t05-124lgp.

Last Modified: 25-Oct-2010


Engine Oil Pressure Sensor Circuit - Shorted High

FAULT CODE 135

Engine Oil Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected on the engine oil pressure sensor pin at the ECM. | None on performance. No engine protection for oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located in the block, beneath the ECM.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.
  • Engine operating in altitudes above 5000 feet with auxiliary oil filtering devices can experience low oil pressure faults at idle conditions.
Refer to Troubleshooting Fault Code t05-135bcgp.

Last Modified: 25-Oct-2010


Engine Oil Pressure Sensor Circuit - Shorted High

FAULT CODE 135

Engine Oil Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Engine Oil Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 4 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected on the engine oil pressure sensor pin at the ECM. | None on performance. No engine protection for oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located in the block, beneath the ECM.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.
  • Engine operating in altitudes above 5000 feet with auxiliary oil filtering devices can experience low oil pressure faults at idle conditions.
Refer to Troubleshooting Fault Code t05-135lgp.

Last Modified: 25-Oct-2010


Engine Oil Pressure Sensor Circuit - Shorted Low

FAULT CODE 141

Engine Oil Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected on the engine oil pressure sensor pin at the ECM. | None on performance. No engine protection for oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located in the block, beneath the ECM.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.
  • Engine operating in altitudes above 5000 feet with auxiliary oil filtering devices can experience low oil pressure faults at idle conditions.
Refer to Troubleshooting Fault Code t05-141bcgp.

Last Modified: 25-Oct-2010


Engine Oil Pressure Sensor Circuit - Shorted Low

FAULT CODE 141

Engine Oil Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected on the engine oil pressure sensor pin at the ECM. | None on performance. No engine protection for oil pressure.
Engine Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located in the block, beneath the ECM.

Shop Talk

  • Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.
  • Engine operating in altitudes above 5000 feet with auxiliary oil filtering devices can experience low oil pressure faults at idle conditions.
Refer to Troubleshooting Fault Code t05-141lgp.

Last Modified: 25-Oct-2010


High Engine Oil Pressure - Over Pressure

FAULT CODE 142

High Engine Oil Pressure - Over Pressure

Printable Version Printable Version

Overview

High Engine Oil Pressure - Over Pressure

CODE | REASON | EFFECT
Fault Code: 142 PID: P100 SPN: 100 FMI: 16 LAMP: Amber SRT: | Engine Oil Pressure High — Warning. Pressure is above the engine protection limit. | None on performance.
Engine Oil Pressure Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located in the engine block, on the fuel system side.

Shop Talk

Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.

The L Gas Plus uses only a pressure sensor.

Refer to Troubleshooting Fault Code t05-142bcgp.

Last Modified: 25-Oct-2010


High Engine Oil Pressure - Over Pressure

FAULT CODE 142

High Engine Oil Pressure - Over Pressure

Printable Version Printable Version

Overview

High Engine Oil Pressure - Over Pressure

CODE | REASON | EFFECT
Fault Code: 142 PID: P100 SPN: 100 FMI: 16 LAMP: Amber SRT: | Engine Oil Pressure High — Warning. Pressure is above the engine protection limit. | None on performance.
Engine Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located in the engine block, on the fuel system side.

Shop Talk

Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.

The L Gas Plus uses only a pressure sensor.

Refer to Troubleshooting Fault Code t05-142lgp.

Last Modified: 25-Oct-2010


Engine Oil Pressure Low Warning

FAULT CODE 143

Engine Oil Pressure Low Warning

Printable Version Printable Version

Overview

Engine Oil Pressure Low Warning

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Yellow SRT: | Engine Oil Pressure Low - Warning. Engine oil pressure signal indicates engine oil pressure below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert. If engine protection shutdown is enabled, the engine will shutdown after 30 seconds of the red lamp flashing.
Engine Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, on the fuel system side.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.

The B Gas Plus, B LPG Plus and the C Gas Plus use a combination sensor.

Refer to Troubleshooting Fault Code t05-143bcgp.

Last Modified: 25-Oct-2010


Engine Oil Pressure Low - Warning

FAULT CODE 143

Engine Oil Pressure Low - Warning

Printable Version Printable Version

Overview

Engine Oil Pressure Low - Warning

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Yellow SRT: | Engine Oil Pressure Low - Warning. Engine oil pressure signal indicates engine oil pressure below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert. If engine protection shutdown is enabled, the engine will shutdown after 30 seconds of the red lamp flashing.
Engine Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, on the fuel system side.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.

The L Gas Plus uses only a pressure sensor.

Refer to Troubleshooting Fault Code t05-143lgp.

Last Modified: 25-Oct-2010


Engine Coolant Temperature Sensor Circuit - Shorted High

FAULT CODE 144

Engine Coolant Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Amber SRT: | Engine Coolant Temperature Sensor Circuit - Shorted High. High signal voltage detected at the engine coolant temperature sensor pin at the ECM. | None on performance. No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the left side of the block, behind the ECM.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault code can log in extremely cold weather.
Refer to Troubleshooting Fault Code t05-144bcgp.

Last Modified: 25-Oct-2010


Engine Coolant Temperature Sensor Circuit - Shorted High

FAULT CODE 144

Engine Coolant Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature Sensor Circuit - Shorted High. High signal voltage detected at the engine coolant temperature sensor pin at the ECM. | None on performance. No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the left side of the block, behind the ECM.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe will compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
  • This fault code can log in extremely cold weather.
Refer to Troubleshooting Fault Code t05-144lgp.

Last Modified: 25-Oct-2010


Engine Coolant Temperature Sensor Circuit - Shorted Low

FAULT CODE 145

Engine Coolant Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature Sensor Circuit - Shorted Low | None on performance. No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the left side of the block, behind the ECM.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145bcgp.

Last Modified: 25-Oct-2010


Engine Coolant Temperature Sensor Circuit - Shorted Low

FAULT CODE 145

Engine Coolant Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Amber SRT: | Engine Coolant Temperature Sensor Circuit - Shorted Low | None on performance. No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located on the right side of the block near the oil cooler.

Shop Talk

The L Gas Plus engine uses a combination sensor for coolant pressure and temperature.

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading observed must compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-145lgp.

Last Modified: 25-Oct-2010


Engine Coolant Temperature Sensor Circuit - Temperature Warning

FAULT CODE 146

Engine Coolant Temperature Sensor Circuit - Temperature Warning

Printable Version Printable Version

Overview

Engine Coolant Temperature Sensor Circuit - Temperature Warning

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature Sensor Circuit - Temperature Warning. High coolant temperature warning. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit (B Gas Plus, B LPG Plus and C Gas Plus)

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located near the water outlet connection.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-146bcgp.

Last Modified: 25-Oct-2010


Engine Coolant Temperature Sensor Circuit - Temperature Warning

FAULT CODE 146

Engine Coolant Temperature Sensor Circuit - Temperature Warning

Printable Version Printable Version

Overview

Engine Coolant Temperature Sensor Circuit - Temperature Warning

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature Sensor Circuit - Temperature Warning. High coolant temperature warning. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit (L Gas Plus)

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located near the water outlet connection.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-146lgp.

Last Modified: 25-Oct-2010


Engine Coolant Temperature High - Critical

FAULT CODE 151

Engine Coolant Temperature High - Critical

Printable Version Printable Version

Overview

Engine Coolant Temperature High - Critical

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature High - Critical. High coolant temperature critical. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, the engine will shutdown 30 seconds after the Red Stop Lamp starts flashing.
Engine Coolant Temperature Sensor Circuit (B Gas Plus, B LPG Plus and C Gas Plus)

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located near the water outlet connection.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

The engine protection shutdown for the coolant temperature is a customer feature and will only be enabled at the customer's request. This sensor will deactivate the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-151bcgp.

Last Modified: 25-Oct-2010


Engine Coolant Temperature High - Critical

FAULT CODE 151

Engine Coolant Temperature High - Critical

Printable Version Printable Version

Overview

Engine Coolant Temperature High - Critical

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine Coolant Temperature High - Critical. High coolant temperature critical. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, the engine will shutdown 30 seconds after the Red Stop Lamp starts flashing.
Engine Coolant Temperature Sensor Circuit (L Gas Plus)

Circuit Description

The electronic control module (ECM) uses the coolant temperature sensor for engine protection purposes.

Component Location

The coolant temperature sensor is located near the water outlet connection.

Shop Talk

All temperature sensors:

  • The resistance of the sensor varies with temperature. The reading you observe should compare to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675

The engine protection shutdown for the coolant temperature is a customer feature and will only be enabled at the customer's request. This sensor will deactivate the fuel control valve if this feature is utilized by the OEM.

Refer to Troubleshooting Fault Code t05-151lgp.

Last Modified: 25-Oct-2010


Humidity Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1919

Humidity Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1919 PID: SPN: 2946 FMI: 2 LAMP: Amber SRT: | Humidity Sensor - Data erratic, intermittent, or incorrect. | Possible reduced performance.
Humidity Sensor Circuit

Circuit Description

The ECM uses the humidity sensor to measure relative humidity. The humidity sensor is connected to sensor supply number 1.

Component Location

The humidity sensor is located in the mixer inlet elbow near the fuel housing.

Shop Talk

Relative humidity is calculated using the intake manifold temperature sensor, intake manifold pressure sensor, and humidity sensor. The units are displayed in grains/pound mass of dry air. The humidity sensor can only provide a valid reading under certain engine operating conditions. The value displayed for specific humidity is the last value updated by the sensor. A value of 75 grains is the default and will be displayed until the engine operating conditions are met for an update.

Refer to Troubleshooting Fault Code t05-1919bcgp.

Last Modified: 25-Oct-2010


Humidity Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1919

Humidity Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1919 PID: SPN: 2946 FMI: 2 LAMP: Amber SRT: | Humidity Sensor - Data erratic, intermittent, or incorrect. | Possible reduced performance.
Humidity Sensor Circuit

Circuit Description

The ECM uses the humidity sensor to measure relative humidity. The humidity sensor is connected to sensor supply number 1.

Component Location

The humidity sensor is located in the turbocharger compressor inlet elbow.

Shop Talk

Relative humidity is calculated using the turbocharger compressor temperature sensor, turbocharger compressor pressure sensor, and humidity sensor. The units are displayed in grains/pound mass of dry air. The humidity sensor can only provide a valid reading under certain engine operating conditions. The value displayed for specific humidity is the last value updated by the sensor. A value of 75 grains is the default and will be displayed until the engine operating conditions are met for an update.

Refer to Troubleshooting Fault Code t05-1919lgp.

Last Modified: 25-Oct-2010


Sensor Supply Voltage 5 Volt (2) - Shorted High

FAULT CODE 227 - B and C Gas Plus

Sensor Supply Voltage 5 Volt (2) - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Voltage 5 Volt (2) - Shorted High

CODE | REASON | EFFECT
Fault Code: 227 PID: 232 SPN: 1080 FMI: 3 LAMP: Amber SRT: | Sensor Supply Voltage 5 Volt (2) - Shorted High. High voltage detected on sensor supply number 2 circuit. | Possible reduced performance.
Sensor Supply Voltage 5 Volt (2)

Circuit Description

This circuit is the voltage supply for the remote accelerator pedal position sensor, mixer inlet pressure sensor, and coolant level sensor.

Component Location

The sensor supply voltage 5 Volt (2) circuit is contained in the wiring harness.

Shop Talk

The voltage supplies on the B and C Gas Plus engines are broken up into 1, 2, 3, and 4.

Refer to Troubleshooting Fault Code t05-227bcgp.

Last Modified: 25-Oct-2010


Sensor Supply Voltage 5 Volt (2) - Shorted High

FAULT CODE 227 - L Gas Plus

Sensor Supply Voltage 5 Volt (2) - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Voltage 5 Volt (2) - Shorted High

CODE | REASON | EFFECT
Fault Code: 227 PID: 232 SPN: 1080 FMI: 3 LAMP: Amber SRT: | Sensor Supply Voltage 5 Volt (2) - Shorted High. High voltage detected on sensor supply number 2 circuit. | Possible reduced performance.
Sensor Supply Voltage 5 Volt (2)

Circuit Description

This circuit is the voltage supply for the remote accelerator pedal position sensor, mixer inlet pressure sensor, coolant level sensor, and coolant pressure/temperature sensor.

Component Location

The sensor supply voltage 5 Volt (2) circuit is contained in the wiring harness.

Shop Talk

The voltage supplies on the L Gas Plus engine voltage supplies are broken up into 1, 2, and 4.

Refer to Troubleshooting Fault Code t05-227lgp.

Last Modified: 25-Oct-2010


Engine Speed High - Critical

FAULT CODE 234

Engine Speed High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0 LAMP: Red SRT: | Engine Speed High - Data Valid but Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit, | Spark and fuel disabled until engine speed falls below the overspeed limit.
Engine Position Sensor Circuit

Circuit Description

The engine position sensor monitors the engine speed and position, then passes this information to the electronic control module (ECM) through the sensor harness.

Component Location

The engine position sensor is located in the gear housing, above the air compressor.

Shop Talk

The engine position sensor is a magnetic sensor and senses the raised material on the back of the camshaft gear to determine engine position and speed. Make sure the correct operation conditions are followed when operating the engine as described in the operation and maintenance manual. To check for valid overspeed, check the fault code snapshot information for the speed reached. This fault will activate at 2800 rpm on the C Gas Plus and 3200 rpm on the B Gas Plus engines.

Refer to Troubleshooting Fault Code t05-234bcgp.

Last Modified: 25-Oct-2010


Engine Speed High - Critical

FAULT CODE 234

Engine Speed High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Speed High - Critical. Engine Speed High - Data Valid but Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit, | Spark and fuel disabled until engine speed falls below the overspeed limit.
Camshaft and Crankshaft Speed and Position Sensors Circuit

Circuit Description

The crankshaft (primary) engine speed/position sensor and the camshaft (back-up) engine speed/position sensor provide engine speed and position information to the electronic control module (ECM) through the engine harness.

Component Location

The crankshaft speed sensor is located on the intake side of the engine near the number 6 cylinder at the crankshaft centerline. The camshaft speed/position sensor is located in the gear housing, above the air compressor.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Make sure the correct operation conditions are followed when operating the engine as described in the operation and maintenance manual. To check for valid overspeed, check the fault code snapshot information for the speed reached. This fault will activate at 2800 rpm on the L Gas Plus engine.

Refer to Troubleshooting Fault Code t05-234lgp.

Last Modified: 25-Oct-2010


Engine Coolant Level Low - Critical

FAULT CODE 235 B and C Gas Plus

Engine Coolant Level Low - Critical

Printable Version Printable Version

Overview

Engine Coolant Level Low - Critical

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1 LAMP: Red SRT: | Coolant level low - data valid but below normal operating range - most severe level. Low engine coolant level detected. | Progressive power and speed derate; if engine protection shutdown is enabled, engine will shut down after 30 seconds of the lamp flashing.
Engine Coolant Level Circuit (B Gas, B LPG Plus and C Gas Plus)

Circuit Description

There are two coolant signal level wires, one for high coolant level and one for low coolant level. The sensor is OEM-supplied.

Component Location

The coolant level sensor is usually located in the coolant supply tank. Use the OEM manual for the component location.

Shop Talk

The engine protection for coolant level is a customer feature and will only be enabled at the customer's request. This sensor must deactivate or disable the fuel control valve if this feature is utilized by the OEM.

A coolant level sensor or shorting plug is required on all Gas Plus engines.

Refer to Troubleshooting Fault Code t05-235bcgp.

Last Modified: 25-Oct-2010


Engine Coolant Level Low - Critical

FAULT CODE 235 L Gas Plus

Engine Coolant Level Low - Critical

Printable Version Printable Version

Overview

Engine Coolant Level Low - Critical

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1 LAMP: Red SRT: | Coolant level low - data valid but below normal operating range - most severe level. Low engine coolant level detected. | Progressive power and speed derate; if engine protection shutdown is enabled, engine will shut down after 30 seconds of the lamp flashing.
Engine Coolant Level Circuit (L Gas Plus)

Circuit Description

There are two coolant signal level wires, one for high coolant level and one for low coolant level. The sensor is OEM-supplied.

Component Location

The coolant level sensor is usually located in the coolant supply tank. Use the OEM manual for the component location.

Shop Talk

The engine protection for coolant level is a customer feature and will only be enabled at the customer's request. This sensor must deactivate or disable the fuel control valve if this feature is utilized by the OEM.

A coolant level sensor or shorting plug is required on all Gas Plus engines.

Refer to Troubleshooting Fault Code t05-235lgp.

Last Modified: 25-Oct-2010


Fuel Shutoff Valve Command Circuit - Shorted Low

FAULT CODE 254 - B LPG

Fuel Shutoff Valve Command Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4 LAMP: Red SRT: | Fuel Shutoff Valve Command Circuit - Shorted Low. Low voltage (short to ground) detected at the ECM | Fuel shutoff valve closes. Engine will die or will not start.
Fuel Shutoff Valve Command Circuit

Circuit Description

The fuel shutoff valve is a solenoid that is used to shut off the flow of gas to the engine. The electronic control module (ECM) controls the fuel shutoff valve.

Component Location

The fuel shutoff valve is located in the fuel housing at the fuel entry point for natural gas engines.

Shop Talk

The ECM will only open the fuel shutoff valve when it detects engine speed. The valve is normally closed when no power is supplied.

Refer to Troubleshooting Fault Code t05-254blpg.

Last Modified: 25-Oct-2010


Fuel Shutoff Valve Command Circuit - Shorted Low

FAULT CODE 254 - Gas Plus

Fuel Shutoff Valve Command Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4 LAMP: Red SRT: | Fuel Shutoff Valve Command Circuit - Shorted Low. Low voltage (short to ground) detected at the ECM | Fuel shutoff valve closes. Engine will die or will not start.
Fuel Shutoff Valve Command Circuit

Circuit Description

The fuel shutoff valve is a solenoid that is used to shut off the flow of gas to the engine. The electronic control module (ECM) controls the fuel shutoff valve.

Component Location

The fuel shutoff valve is located in the fuel housing at the fuel entry point for natural gas engines.

Shop Talk

The ECM will only open the fuel shutoff valve when it detects engine speed. The valve is normally closed when no power is supplied.

Refer to Troubleshooting Fault Code t05-254gp.

Last Modified: 20-Feb-2012


Fuel Shutoff Valve Command Circuit - Shorted High

FAULT CODE 255 - BLPG

Fuel Shutoff Valve Command Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S17 SPN: 632 FMI: 3 LAMP: Amber SRT: | Fuel Shutoff Valve Command Circuit - Shorted High . Open circuit detected at the ECM | Fuel shutoff valve closes. Engine will die or will not start.
Fuel Shutoff Valve Command Circuit

Circuit Description

The fuel shutoff valve is a solenoid that is used to shut off the flow of gas to the engine. The electronic control module (ECM) controls the fuel shutoff valve.

Component Location

The fuel shutoff valve is located in the fuel evaporator at the fuel entry point for liquid propane engines.

Shop Talk

The electronic control module (ECM) will only open the fuel shutoff valve when it detects engine speed. The valve is normally closed when no power is supplied. The ECM detects engine speed using the engine position sensor.

Refer to Troubleshooting Fault Code t05-255blpg.

Last Modified: 24-Feb-2012


Fuel Shutoff Valve Command Circuit - Shorted High

FAULT CODE 255 - Gas Plus

Fuel Shutoff Valve Command Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 - Gas Plus PID: S17 SPN: 632 FMI: 3 LAMP: Amber SRT: | Fuel Shutoff Valve Command Circuit - Shorted High . Open circuit detected at the ECM | Fuel shutoff valve closes. Engine will die or will not start.
Fuel Shutoff Valve Command Circuit

Circuit Description

The fuel shutoff valve is a solenoid that is used to shut off the flow of gas to the engine. The electronic control module (ECM) controls the fuel shutoff valve.

Component Location

The fuel shutoff valve is located in the fuel housing at the fuel entry point for natural gas engines.

Shop Talk

The electronic control module (ECM) will only open the fuel shutoff valve when it detects engine speed. The valve is normally closed when no power is supplied. The ECM detects engine speed using the engine position sensor.

Refer to Troubleshooting Fault Code t05-255gp.

Last Modified: 25-Oct-2010


Sensor Supply Voltage Number 1 Circuit - Shorted Low

FAULT CODE 352

Sensor Supply Voltage Number 1 Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 1079 FMI: 4 LAMP: Amber SRT: | Sensor Supply Voltage Number 1 Circuit - Shorted Low. Low voltage detected on sensor supply number 1 circuit. | Possible reduced performance.
Sensor Supply Voltage Number 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold pressure/temperature sensor; the secondary fuel pressure/temperature sensor, the humidity sensor, and the oil pressure/temperature sensor.

Component Location

The sensor supply voltage 5 Volt (1) circuit is contained in the wiring harness.

Shop Talk

The voltage supplies for the B and C Gas Plus engines are broken up into 1, 2, 3, and 4.

Refer to Troubleshooting Fault Code t05-352bcgp.

Last Modified: 25-Oct-2010


Sensor Supply Voltage Number 1 Circuit - Shorted Low

FAULT CODE 352

Sensor Supply Voltage Number 1 Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: 232 SPN: 1079 FMI: 4 LAMP: Amber SRT: | Sensor Supply Voltage Number 1 Circuit - Shorted Low. Low voltage detected on sensor supply number 1 circuit. | Possible reduced performance.
Sensor Supply Voltage Number 1 Circuit

Circuit Description

This circuit is the voltage supply for the intake manifold pressure/temperature sensor; the secondary fuel pressure/temperature sensor, the humidity sensor, air inlet restriction sensor, the camshaft position sensor, the crankshaft position sensor and the oil pressure sensor.

Component Location

The sensor supply voltage 5 Volt (1) circuit is contained in the wiring harness.

Shop Talk

The voltage supplies for the L Gas Plus engines are broken up into 1, 2, and 4.

Refer to Troubleshooting Fault Code t05-352lgp.

Last Modified: 25-Oct-2010


Sensor Supply Voltage 5 Volt (1) - Shorted High

FAULT CODE 386

Sensor Supply Voltage 5 Volt (1) - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 1079 FMI: 3 LAMP: Amber SRT: | Sensor Supply Voltage 5 Volt (1) - Shorted High. High voltage detected on sensor supply number 1 circuit. | Possible reduced performance.
Sensor Supply Voltage 5 Volt (1)

Circuit Description

This circuit is the voltage supply for the intake manifold pressure/temperature sensor; the secondary fuel pressure/temperature sensor, the humidity sensor and oil pressure/temperature sensor.

Component Location

The sensor supply voltage 5 Volt (1) circuit is contained in the engine wiring harness.

Shop Talk

The voltage supplies for the B and C Gas Plus engines are broken up into 1, 2, 3, and 4.

Refer to Troubleshooting Fault Code t05-386bcgp.

Last Modified: 25-Oct-2010


Sensor Supply Voltage 5 Volt (1) - Shorted High

FAULT CODE 386

Sensor Supply Voltage 5 Volt (1) - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 1079 FMI: 3 LAMP: Amber SRT: | Sensor Supply Voltage 5 Volt (1) - Shorted High. High voltage detected on sensor supply number 1 circuit. | Possible reduced performance.
Sensor Supply Voltage 5 Volt (1)

Circuit Description

This circuit is the voltage supply for the intake manifold pressure/temperature sensor; the secondary fuel pressure/temperature sensor, the humidity sensor, the air inlet restriction pressure sensor, the camshaft position sensor, the crankshaft position sensor, and the oil pressure sensor.

Component Location

The sensor supply voltage 5 Volt (1) circuit is contained in the engine wiring harness.

Shop Talk

The voltage supplies for the L Gas Plus engines are broken up into 1, 2, and 4 and are shown as such on the wiring diagram.

Refer to Troubleshooting Fault Code t05-386lgp.

Last Modified: 25-Oct-2010


Oil Pressure - Engine Protection

FAULT CODE 415

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

Oil Pressure - Engine Protection

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Red SRT: | Oil Pressure Low - Data Valid but Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates engine oil pressure below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown is enabled, the engine will shutdown after 30 seconds of the red lamp flashing.
Engine Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, on the fuel system side.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.

The B Gas Plus, B LPG Plus and the C Gas Plus use a combination sensor.

Refer to Troubleshooting Fault Code t05-415bcgp.

Last Modified: 25-Oct-2010


Oil Pressure Low- Engine Protection

FAULT CODE 415

Oil Pressure Low- Engine Protection

Printable Version Printable Version

Overview

Oil Pressure Low- Engine Protection

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Red SRT: | Oil Pressure Low - Data Valid, but below normal operational range - most severe level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate increasing in severity from time of alert. If engine protection shut down feature is enabled, engine will shut down 30 seconds after red stop lamp starts flashing.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, on the fuel system side.

Shop Talk

Verify with the driver the engine speed at which the fault occurs. If the engine is being operated at too low of a speed, the oil pressure can drop below the engine protection limits.

Possible causes:

  • Low oil level
  • Low operation speeds
  • Oil dilution
  • Oil filter needs to be changed.

The L Gas Plus uses only a pressure sensor.

Refer to Troubleshooting Fault Code t05-415lgp.

Last Modified: 25-Oct-2010


Engine Coolant Level Sensor Circuit - Data Not Correct

FAULT CODE 422

Engine Coolant Level Sensor Circuit - Data Not Correct

Printable Version Printable Version

Overview

Engine Coolant Level Sensor Circuit - Data Not Correct

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2 LAMP: Amber SRT: | Engine Coolant Level Sensor Circuit - Data Incorrect. Both signals are open or shorted to ground. | None on performance. No engine protection for coolant level.
Engine Coolant Level Circuit (B Gas, B LPG Plus and C Gas Plus)

Circuit Description

There are two coolant signal level wires, one for high coolant level and one for low coolant level. The sensor is OEM-supplied.

Component Location

The coolant level sensor is usually located in the coolant supply tank. Use the OEM manual for the component location.

Shop Talk

The engine protection for coolant level is a customer feature and will only be enabled at the customer's request. This sensor must deactivate or disable the fuel control valve if this feature is utilized by the OEM.

A coolant level sensor or shorting plug is required on all Gas Plus engines.

Refer to Troubleshooting Fault Code t05-422bcgp.

Last Modified: 25-Oct-2010


Engine Coolant Level Sensor Circuit - Data Not Correct

FAULT CODE 422

Engine Coolant Level Sensor Circuit - Data Not Correct

Printable Version Printable Version

Overview

Engine Coolant Level Sensor Circuit - Data Not Correct

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2 LAMP: Amber SRT: | Engine Coolant Level Sensor Circuit - Data Incorrect. Both signals are open or shorted to ground. | None on performance. No engine protection for coolant level.
Engine Coolant Level Circuit (L Gas Plus)

Circuit Description

There are two coolant signal level wires, one for high coolant level and one for low coolant level. The sensor is OEM-supplied.

Component Location

The coolant level sensor is usually located in the coolant supply tank. Use the OEM manual for the component location.

Shop Talk

The engine protection for coolant level is a customer feature and will only be enabled at the customer's request. This sensor must deactivate or disable the fuel control valve if this feature is utilized by the OEM.

A coolant level sensor or shorting plug is required on all Gas Plus engines.

Refer to Troubleshooting Fault Code t05-422lgp.

Last Modified: 25-Oct-2010


Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect.

FAULT CODE 431 - Integrated Sensor Switch

Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | None.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle or depressed (off-idle). The switch is adjusted during the pedal manufacturing process to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other OEM cab switches.

Component Location

The integrated sensor switch is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuits, a loose connection, uncalibrated accelerator pedal or lever assembly, or mis-wired idle validation switch.
  • The integrated sensor switch has a different internal resistance specification (125 ohms) than the nonintegrated sensor switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-431iss.

Last Modified: 25-Oct-2010


Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect.

FAULT CODE 431 - Nonintegrated sensor switch

Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | None.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle or depressed (off-idle). The switch is adjusted during the pedal manufacturing process to switch from on-idle to off-idle at the correct accelerator pedal or lever position.

Component Location

The nonintegrated sensor switch is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuits, a loose connection, uncalibrated accelerator pedal or lever assembly, or mis-wired idle validation switch.
  • The nonintegrated sensor switch has a different internal resistance specification (10 ohms) than the integrated sensor switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-431niss.

Last Modified: 25-Oct-2010


Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect.

FAULT CODE 431 - Solid-State Sensor Switch

Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | None.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle or depressed (off-idle). The switch is adjusted during the pedal manufacturing process to switch from on-idle to off-idle at the correct accelerator pedal or lever position.

Component Location

The solid-state sensor switch is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuits, a loose connection, uncalibrated accelerator pedal or lever assembly, or mis-wired idle validation switch.
  • Since the solid-state sensor switch uses an integrated circuit to output idle and off-idle signals, the internal resistance can not be checked with a multimeter as it is for the integrated sensor switch and non-integrated sensor switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-431sss.

Last Modified: 25-Oct-2010


Gas Mass Flow Sensor Circuit - Shorted High

FAULT CODE 453

Gas Mass Flow Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 453 PID: P183 SPN: 183 FMI: 3 LAMP: Amber SRT: | Gas Mass Flow Sensor Circuit - Shorted High. High voltage detected on the sensor signal pin at the ECM. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Shop Talk

Make sure that the screen located in the fuel housing is free from debris and oil.

The voltage supply for the C series engine must be maintained at or above 13.5 VDC for proper sensor operation. On the B series engine the voltage must be maintained above 12 VDC for proper sensor operation. This can be monitored in the INSITE™ electronic service tool with parameter sensor supply 3.

Refer to Troubleshooting Fault Code t05-453bcgp.

Last Modified: 25-Oct-2010


Gas Mass Flow Sensor Circuit - Shorted High

FAULT CODE 453

Gas Mass Flow Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 453 PID: P183 SPN: 183 FMI: 3 LAMP: Amber SRT: | Gas Mass Flow Sensor Circuit - Shorted High. High voltage detected on the sensor signal pin at the ECM. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Shop Talk

Make sure that the screen located in the fuel housing is free from debris and oil.

The voltage supply to the gas mass flow sensor passes through a voltage converter which maintains a minimum value of 14 VDC to the sensor. The power for this converter is supplied from a switched battery source on the OEM 31 pin connector and must be maintained above 12 VDC.

Refer to Troubleshooting Fault Code t05-453lgp.

Last Modified: 25-Oct-2010


Gas Mass Flow Sensor Circuit - Shorted Low.

FAULT CODE 454 - B Gas Plus, and C Gas Plus engines without optional Sensor Supply Voltage Converter

Gas Mass Flow Sensor Circuit - Shorted Low.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 454 PID: P183 SPN: 183 FMI: 4 LAMP: Amber SRT: | Gas Mass Flow Sensor Circuit - Shorted Low. Open circuit or short to ground detected on the sensor signal pin at the ECM. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel entering the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Shop Talk

Make sure the screen located in the fuel housing is free from debris and oil.

When connecting and disconnecting electronic components, be sure the keyswitch is OFF unless otherwise specified in the procedure.

The voltage supply for the C Gas Plus engine must be maintained at or above +13.5-VDC for proper sensor operation. On the B Gas Plus and B LPG engines the voltage must be maintained above +12.0-VDC for proper sensor operation. This can be monitored in the INSITE™ electronic service tool use the 14 Volt Sensor Supply parameter (3).

Refer to Troubleshooting Fault Code t05-454bcgp.

Last Modified: 25-Oct-2010


Gas Mass Flow Sensor Circuit - Shorted Low.

FAULT CODE 454 - L Gas Plus and C Gas Plus engines with optional Sensor Supply Voltage Converter

Gas Mass Flow Sensor Circuit - Shorted Low.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 454 PID: P183 SPN: 183 FMI: 4 LAMP: Amber SRT: | Gas Mass Flow Sensor Circuit - Shorted Low. Open circuit or short to ground detected on the sensor signal pin at the ECM. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel entering the engine and adjusts the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing. The sensor supply voltage converter is located between the engine harness and the gas mass flow sensor.

Shop Talk

Make sure that the screen located in the fuel housing is free from debris and oil.

When connecting and disconnecting electronic components, ensure that the keyswitch is OFF unless otherwise specified in the procedure.

The voltage supply to the gas mass flow sensor passes through a voltage converter which maintains a minimum of +13.5-VDC to the sensor. The power for this converter is supplied by a switched battery source on the OEM 31 pin connector. This supply voltage must be maintained above +8.0-VDC.

Refer to Troubleshooting Fault Code t05-454lcgp.

Last Modified: 25-Oct-2010


Ignition Timing Signal Circuit - Shorted High

FAULT CODE 458

Ignition Timing Signal Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 458 PID: S67 SPN: 726 FMI: 3 LAMP: Red SRT: | Ignition Timing Signal Circuit - Shorted High. High voltage detected at the ECM. | Engine will die or not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

The ICM can not detect whether there is a misfire or a bad spark plug. For the ICM to operate correctly, all connectors must be clean and tight. Cylinders 3 and 4 are especially critical to the proper operation of the ICM. A poor connection in either of these areas will cause the engine not to start.

Refer to Troubleshooting Fault Code t05-458bcgp.

Last Modified: 25-Oct-2010


Ignition Timing Signal Circuit - Shorted High

FAULT CODE 458

Ignition Timing Signal Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 458 PID: S67 SPN: 726 FMI: 3 LAMP: Red SRT: | Ignition Timing Signal Circuit - Shorted High. High voltage detected at the ECM. | Engine will die or not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

For the ICM to operate correctly, all connectors must be clean and tight.

Refer to Troubleshooting Fault Code t05-458lgp.

Last Modified: 25-Oct-2010


Ignition Timing Signal Circuit - Shorted Low

FAULT CODE 459

Ignition Timing Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 459 PID: S67 SPN: 726 FMI: 4 LAMP: Red SRT: | Ignition Timing Signal Circuit - Shorted Low. Low voltage detected at the ECM. | Engine will die or not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

The ICM can not detect whether there is a misfire or a bad spark plug. For the ICM to operate correctly, all connectors must be clean and tight. Cylinders 3 and 4 are especially critical to the proper operation of the ICM. A poor connection in either of these areas will cause the engine not to start.

Refer to Troubleshooting Fault Code t05-459bcgp.

Last Modified: 25-Oct-2010


Ignition Timing Signal Circuit - Shorted Low

FAULT CODE 459

Ignition Timing Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 459 PID: S67 SPN: 726 FMI: 4 LAMP: Red SRT: | Ignition Timing Signal Circuit - Shorted Low. Low voltage detected at the ECM. | Engine will die or not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

The ICM can not detect whether there is a misfire or a malfunctioning spark plug. For the ICM to operate correctly, all connectors must be clean and tight. Cylinders 3 and 4 are especially critical to the proper operation of the ICM. A poor connection in either of these areas will cause the engine not to start.

Refer to Troubleshooting Fault Code t05-459lgp.

Last Modified: 25-Oct-2010


Ignition Reference Signal Circuit - Shorted High

FAULT CODE 461

Ignition Reference Signal Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 461 PID: S66 SPN: 725 FMI: 3 LAMP: Red SRT: | Ignition Control Module (Reference) Signal Circuit - Shorted High. High voltage detected at the ECM. | Engine will die or not start.
Ignition Reference Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

The ICM can not detect whether there is a misfire or a bad spark plug. For the ICM to operate correctly, all connections must be clean and tight. Cylinders 3 and 4 are especially critical to the proper operation of the ICM. A poor connection in either of these areas will cause the engine not to start.

Refer to Troubleshooting Fault Code t05-461bcgp.

Last Modified: 25-Oct-2010


Ignition Reference Signal Circuit - Shorted High

FAULT CODE 461

Ignition Reference Signal Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 461 PID: S66 SPN: 725 FMI: 3 LAMP: Red SRT: | Ignition Control Mode (Reference) Signal Circuit - Shorted High. High voltage detected at the ECM. | Engine will die or not start.
Ignition Reference Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

For the ICM to operate correctly, all connectors must be clean and tight.

Refer to Troubleshooting Fault Code t05-461lgp.

Last Modified: 25-Oct-2010


Ignition Control Module Reference Signal Circuit - Shorted Low

FAULT CODE 462

Ignition Control Module Reference Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 462 PID: S66 SPN: 725 FMI: 4 LAMP: Red SRT: | Ignition Control Module Reference Signal Circuit - Shorted Low. Low voltage detected at the ECM. | Engine will die or not start.
Ignition Reference Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information. The ICM for the C8.3G Plus engine is multispark, disengage-capable during idle conditions to smooth out idle operation.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

The ICM can not detect whether there is a misfire or a bad spark plug. For the ICM to operate correctly, all connectors must be clean and tight. Cylinders 3 and 4 are especially critical to the proper operation of the ICM. A poor connection in either of these areas will cause the engine not to start.

Refer to Troubleshooting Fault Code t05-462bcgp.

Last Modified: 25-Oct-2010


Ignition Control Module Reference Signal Circuit - Shorted Low

FAULT CODE 462

Ignition Control Module Reference Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 462 PID: S66 SPN: 725 FMI: 4 LAMP: Red SRT: | Ignition Control Module Reference Signal Circuit - Shorted Low. Low voltage detected at the ECM. | Engine will stall or not start.
Ignition Reference Signal Circuit

Circuit Description

The ignition control module (ICM) is a distributorless ignition module that provides a signal to the coils and delivers high voltage to the spark plugs. The electronic control module (ECM) controls the ICM by providing ignition timing information.

Component Location

The ICM is located next to the ECM on the side of the engine.

Shop Talk

The ICM can not detect whether there is a misfire or a malfunctioning spark plug. For the ICM to operate correctly, all connectors must be clean and tight. Cylinders 3 and 4 are especially critical to the proper operation of the ICM. A poor connection in either of these areas will cause the engine not to start.

Refer to Troubleshooting Fault Code t05-462lgp.

Last Modified: 25-Oct-2010


Turbocharger Control Valve Circuit - Shorted High

FAULT CODE 465

Turbocharger Control Valve Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 465 PID: S32 SPN: 118 FMI: 3 LAMP: Amber SRT: | Turbocharger Control Valve Circuit - Shorted High. High voltage detected at the ECM. | Possible reduced performance.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses this valve to control the position of the turbocharger actuator.

Component Location

The turbocharger control valve is located on the fuel housing and connected by a tube to the turbocharger actuator.

Shop Talk

This fault code is caused by an electrical problem. A mechanical issue will not cause this fault to log.

Possible causes of this fault code include:

  • Open circuit in the engine harness or connectors
  • Open circuit in the turbocharger control valve
  • Signal circuit short to voltage source in the engine harness.
Refer to Troubleshooting Fault Code t05-465bcgp.

Last Modified: 25-Oct-2010


Turbocharger Control Valve Circuit - Shorted High

FAULT CODE 465

Turbocharger Control Valve Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 465 PID: S32 SPN: 118 FMI: 3 LAMP: Amber SRT: | Turbocharger Control Valve Circuit - Shorted High. High voltage detected at the ECM. | Variable geometry turbocharger may be in either the open or closed position.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the control valve through the turbocharger control valve signal of the ECM engine harness.

Component Location

The turbocharger actuator control valve is located near the fuel housing and connected by a tube to the turbocharger actuator.

Shop Talk

This fault code is caused by an electrical problem. A mechanical issue will not cause this fault to log.

Possible causes of this fault code include:

  • Open circuit in the engine harness or connectors
  • Open circuit in the turbocharger control valve
  • Signal circuit short to voltage source in the engine harness.
Refer to Troubleshooting Fault Code t05-465lgp.

Last Modified: 25-Oct-2010


Turbocharger Control Valve Circuit - Shorted Low

FAULT CODE 466

Turbocharger Control Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 466 PID: S32 SPN: 1188 FMI: 4 LAMP: Amber SRT: | Turbocharger Control Valve Circuit - Shorted Low. Low voltage (short to ground) detected at the ECM. | Possible reduced performance.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses this valve to control the position of the turbocharger actuator.

Component Location

The turbocharger actuator control valve is located on the fuel housing and connected by a tube to the turbocharger actuator.

Shop Talk

This fault code is caused by an electrical problem. A mechanical issue will not cause this fault to log.

Possible causes of this fault code include:

  • Signal short circuit to ground
  • Short circuit to ground in the turbocharger control valve.
Refer to Troubleshooting Fault Code t05-466bcgp.

Last Modified: 25-Oct-2010


Turbocharger Control Valve Circuit - Shorted Low

FAULT CODE 466

Turbocharger Control Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 466 PID: S32 SPN: 1188 FMI: 4 LAMP: Amber SRT: | Turbocharger Control Valve Circuit - Shorted Low. Low voltage (short to ground) detected at the ECM. | Variable geometry turbocharger will go to the open position.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the control valve through the turbocharger control valve signal of the ECM engine harness.

Component Location

The turbocharger actuator control valve is located near the fuel housing and connected by a tube to the turbocharger actuator.

Shop Talk

This fault code is caused by an electrical problem. A mechanical issue will not cause this fault to log.

Possible causes of this fault code include:

  • Signal short circuit to ground
  • Short circuit to ground in the turbocharger control valve.
Refer to Troubleshooting Fault Code t05-466lgp.

Last Modified: 25-Oct-2010


Throttle Plate Position Sensor Circuit - Shorted High

FAULT CODE 512bgi

Throttle Plate Position Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3 LAMP: Amber SRT: | Throttle Plate Position Sensor Circuit - Shorted High. High voltage detected at the Electronic Control Module (ECM). | Possible reduced performance.
Throttle Plate Position Sensor Circuit

Circuit Description

The throttle plate position sensor is used by the electronic control module (ECM) to measure the percentage of throttle plate opening.

Component Location

The throttle plate position sensor is installed on top of the throttle body.

Shop Talk

Check to make sure that throttle linkage moves smoothly and freely.

Refer to Troubleshooting Fault Code t05-512bgi.

Last Modified: 25-Oct-2010


Throttle Plate Position Sensor Circuit - Shorted High

FAULT CODE 512gp

Throttle Plate Position Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3 LAMP: Amber SRT: | Throttle Plate Position Sensor Circuit - Shorted High. High voltage detected at the ECM. | Possible reduced performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the throttle actuator, which is both an input and output device.

Component Location

The throttle actuator is located after the fuel housing and before the intake manifold inlet.

Shop Talk

The fault will light if the throttle actuator shorts to a high source on either the positive (+) throttle command or throttle position signal circuits.

Refer to Troubleshooting Fault Code t05-512gp.

Last Modified: 25-Oct-2010


Throttle Plate Position Sensor Circuit - Shorted Low

FAULT CODE 513bgi

Throttle Plate Position Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 SPN: 51 FMI: 4 LAMP: Amber SRT: | Throttle Plate Position Sensor Circuit - Shorted Low. Low voltage (short to ground detected at the Electronic Control Module (ECM)). | Possible reduced performance.
Throttle Plate Position Sensor Circuit

Circuit Description

The throttle plate position sensor is used by the electronic control module (ECM) to measure the percentage of throttle plate opening.

Component Location

The throttle plate position sensor is installed on top of the throttle body.

Shop Talk

Check to make sure that throttle linkage moves smoothly and freely.

Refer to Troubleshooting Fault Code t05-513bgi.

Last Modified: 25-Oct-2010


Throttle Plate Position Sensor Circuit - Shorted Low

FAULT CODE 513gp

Throttle Plate Position Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 SPN: 51 FMI: 4 LAMP: Amber SRT: | Throttle Plate Position Sensor Circuit - Shorted Low. Low voltage (shorted to ground) detected at the ECM. | Possible reduced performance.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the throttle actuator, which is both an input and output device.

Component Location

The throttle actuator is located after the fuel housing and before the intake manifold inlet.

Shop Talk

The fault will light if the throttle actuator has low voltage on the switched battery and this is detected by the ECM.

Refer to Troubleshooting Fault Code t05-513gp.

Last Modified: 25-Oct-2010


Wastegate Control Valve Stuck Open

FAULT CODE 545

Wastegate Control Valve Stuck Open

Printable Version Printable Version

Overview

Wastegate Control Valve Stuck Open

CODE | REASON | EFFECT
Fault Code: 545 PID: S32 SPN: 1188 FMI: 7 LAMP: Yellow SRT: | Turbocharger Control Valve stuck open. | Possible turbocharger overspeed.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses this valve to control the position of the turbocharger actuator.

Component Location

The turbocharger control valve is located on the fuel housing and connected by tube to the turbocharger actuator.

Shop Talk

This fault is usually caused by a mechanical problem. The mechanical problem is caused by actual mixer inlet pressure being higher than the pressure requested by the ECM and control system of the engine.

Refer to Troubleshooting Fault Code t05-545bcgp.

Last Modified: 25-Oct-2010


Wastegate Control Valve Stuck Open

FAULT CODE 545

Wastegate Control Valve Stuck Open

Printable Version Printable Version

Overview

Wastegate Control Valve Stuck Open

CODE | REASON | EFFECT
Fault Code: 545 PID: S32 SPN: 1188 FMI: 7 LAMP: Yellow SRT: | Turbocharger control valve stuck open. | Possible turbocharger overspeed.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control valve (ECM) controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the control valve through the turbocharger control valve signal of the ECM engine harness.

Component Location

The turbocharger control valve is located on the fuel housing.

Shop Talk

Turbocharger control valve command can be monitored with INSITE™ electronic service tool. This parameter represents the ECM command to the turbocharger control valve which in turn controls the variable geometry actuator position.

Possible causes of this fault code include:

  • Signal short circuit to ground
  • Short circuit to ground in the turbocharger control valve.
Refer to Troubleshooting Fault Code t05-545lgp.

Last Modified: 25-Oct-2010


Gas Mass Flow Sensor Error

FAULT CODE 751

Gas Mass Flow Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 751 PID: P183 SPN: 183 FMI: 2 LAMP: Amber SRT: | Gas Mass Flow Sensor Error. The sensed gas flow does not match the desired gas flow. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement. The gas mass flow sensor is powered by battery voltage.

Component Location

The gas mass flow sensor is located on the fuel housing and is unique to the C Series gas engines. On the B and B Gas Plus engines the gas mass flow sensor is located on the fuel control housing.

Shop Talk

The voltage supply for the C Gas Plus engine must be maintained at or above 13.5 VDC for proper sensor operation. On the B and B Gas Plus engines, the voltage must be maintained above 12 VDC for proper sensor operation. This can be monitored in INSITE™ monitoring sensor supply number 3. The possible fail modes are the following: Improper fuel pressure or out of fuel, a stuck or sticking fuel control valve not correcting gas flow according to gas mass flow sensor, restriction due to deposits in the laminar flow screen and oil contamination in the mixer housing and gas flow sensor.

Refer to Troubleshooting Fault Code t05-751bcgp.

Last Modified: 25-Oct-2010


Gas Mass Flow Sensor Error

FAULT CODE 751

Gas Mass Flow Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 751 PID: P183 SPN: 183 FMI: 2 LAMP: Amber SRT: | Gas Mass Flow Sensor Error. The sensed gas flow does not match the desired gas flow. | Possible reduced performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement. The gas mass flow sensor is powered by battery voltage.

Component Location

The gas mass flow sensor is located on the air/fuel mixer housing on L Gas Plus engines.

Shop Talk

The L series uses a supply voltage converter in series with the voltage supply to the gas mass flow sensor to provide the needed 15.5 VDC to operate correctly. The possible fail modes are the following: Improper fuel pressure or out of fuel, a stuck or sticking fuel control valve not correcting gas flow according to gas mass flow sensor, restriction due to deposits in the laminar flow screen and oil contamination in the mixer housing and gas flow sensor.

Refer to Troubleshooting Fault Code t05-751lgp.

Last Modified: 25-Oct-2010


Heated Oxygen Sensor Error

FAULT CODE 752

Heated Oxygen Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 752 PID: S065 SPN: 723 FMI: 2 LAMP: Amber SRT: | Heated Oxygen Sensor Error. The sensed air fuel ratio does not match the desired air fuel ratio. | Possible reduced performance. No closed-loop operation.
Heated Oxygen Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

This fault is not typically caused by a failed heated oxygen sensor, but is a result of the engine running very lean or very rich. To determine if the engine is rich or lean, monitor the heated oxygen sensor compensation in INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-752bcgp.

Last Modified: 25-Oct-2010


Heated Oxygen Sensor Error

FAULT CODE 752

Heated Oxygen Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 752 PID: S065 SPN: 723 FMI: 2 LAMP: Amber SRT: | Heated Oxygen Sensor Error. The sensed air fuel ratio does not match the desired air fuel ratio. | Possible reduced performance. No closed-loop operation.
Heated Oxygen Sensor Circuit

Circuit Description

The electronic control module (ECM) uses this sensor to determine the composition of the exhaust gas and then, to adjust fueling.

Component Location

The heated oxygen sensor is located in the exhaust outlet connection, after the turbocharger.

Shop Talk

This fault is not typically caused by a failed heated oxygen sensor, but is a result of the engine running very lean or very rich. To determine if the engine is rich or lean, monitor the heated oxygen sensor compensation in INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-752lgp.

Last Modified: 25-Oct-2010


Engine Position Sensor Synchronization Error

FAULT CODE 753

Engine Position Sensor Synchronization Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 753 PID: 21 SPN: 636 FMI: 2 LAMP: Amber SRT: | Engine Speed/Position - Camshaft Synchronization Error. Invalid engine speed signal detected on the engine position sensor signal pins in the ECM. | Engine can possibly die or will not start.
Engine Position Sensor Circuit

Circuit Description

The engine position sensor monitors the engine speed and position, then passes this information to the electronic control module (ECM) through the sensor harness.

Component Location

The engine position sensor is located in the gear housing, above the air compressor.

Shop Talk

The engine position sensor is a magnetic sensor and senses the raised material on the back of the camshaft gear to determine engine position and speed. There are seven raised material pieces on the back of the camshaft gear, one for each cylinder and one for timing.

Refer to Troubleshooting Fault Code t05-753bcgp.

Last Modified: 25-Oct-2010


Engine Speed/Position Camshaft Synchronization Error

FAULT CODE 753

Engine Speed/Position Camshaft Synchronization Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 753 PID: S064 SPN: 723 FMI: 2 LAMP: Amber SRT: | Engine Speed/Position Camshaft Synchronization Error. Invalid engine speed signal detected on the engine position sensor signal pins in the ECM connector. | Engine can die or will not start.
Engine Position Sensor Circuit

Circuit Description

The camshaft engine speed/position sensor provides engine speed information to the electronic control module (ECM). The sensor is powered by 5 volts. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the camshaft.

Component Location

The camshaft speed/position sensor is located on the intake side of the engine above the accessory drive. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is recorded when the ECM does not receive a signal from the camshaft engine speed sensor, or the signal it receives is degrading.

Possible causes of this fault code include: open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM.

Short circuits to ground or return circuits in the sensor, engine harness, or ECM.

Short circuits to a voltage source in the sensor, engine harness, or ECM.

Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-753lgp.

Last Modified: 25-Oct-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Internal ECM Failure

Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | No active fault codes?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Calibrate the ECM. | ECM calibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait five seconds. Start the engine and let idle for 1 minute.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Is there a constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 31 pin OEM connector.

Refer to the OEM service manual.

Go to 1C

Go to 2A

Guided Step 1C - Calibrate the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Did the ECM calibrate correctly?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Repair complete

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 111 is inactive.

Is Fault Code 111 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Repair complete

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaing fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 115 - B and C Plus - Engine Position Sensor Circuit - Both Signals Lost

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 115 active?
STEP 2. | Check the engine position sensor. |
 | STEP 2A. Inspect the engine harness and engine position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 1000 to 2000 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Inspect the sensor for damage. | Damaged sensor?
 | STEP 2E. Read the fault codes. | Fault Code 115 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine position sensor.

Guided Step 2A - Inspect the engine harness and engine position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the engine position sensor.

Action

Inspect the engine harness and engine position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine position sensor SIGNAL pin to the engine position sensor RETURN pin in the engine position sensor connector.
  • Measure the resistance from the engine position backup SIGNAL pin to the engine position backup RETURN pin in the engine position sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1000 to 2000 ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-038 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Engine position sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the SIGNAL pin in the engine position sensor connector, sensor side, to the engine block ground.
  • Measure the resistance from the backup SIGNAL pin in the engine position sensor connector, sensor side, to the engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-038 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Remove the engine position sensor from the gear housing.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of sensor, caused by the engine gear
  • Oil leakage or insulation problems, such as swelling
  • Damaged electrical potting in the sensing end of sensor.

Damaged sensor?
YES NO

Replace the sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Disconnect engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the engine position sensor SUPPLY pin in the engine harness sensor connector to the engine position sensor SUPPLY pin in the engine harness ECM connector.
  • Measure the resistance from the engine position sensor backup SUPPLY pin in the engine harness sensor connector to the engine position sensor backup SUPPLY pin in the engine harness ECM connector.
  • Measure the resistance from the engine position sensor RETURN pin in the engine harness sensor connector to the engine position sensor RETURN pin in the engine harness ECM connector.
  • Measure the resistance from the engine position sensor backup RETURN pin in the engine harness sensor connector to the engine position sensor backup RETURN pin in the engine harness ECM connector.
  • See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Disconnect engine harness connector 1 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine position sensor SUPPLY pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the engine position sensor backup SUPPLY pin in the engine harness ECM connector to engine block ground.
  • See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine position sensor SUPPLY pin in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the engine position sensor SUPPLY pin in engine harness ECM connector 1 to all pins in engine harness ECM connector 2.
  • Measure the resistance from the engine position sensor backup SUPPLY pin in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the engine position sensor backup SUPPLY pin in engine harness ECM connector 1 to all pins in engine harness ECM connector 2.
  • See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 115 is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 115 - L Gas Plus - Engine Speed/Position Sensor Circuit - Both Signals Lost

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 115 inactive?
STEP 2. | Check the crankshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Inspect the crankshaft speed/position sensor. | Damaged sensor tip?
 | STEP 2E. Verify adequate crankshaft speed/position sensor air gap. | Distance is between 41.36 mm [1.36 in] and 42.65 mm [1.68 in]?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 2119 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3G. Check for an inactive fault code. | Fault Code 115 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 or 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the crankshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect crankshaft speed/position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-365 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect camshaft speed/position sensor from the engine harness.

Action

Inspect the engine harness and camshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-365 in Section 19.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect crankshaft speed/position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the crankshaft speed/position SUPPLY pin and the crankshaft speed/position RETURN pin at the crankshaft speed/position sensor connector of the engine harness.

See the circuit diagram or wiring diagram for component pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Inspect the crankshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the crankshaft speed/position sensor from the engine.

Action

Inspect the crankshaft speed/position sensor for the following:

  • Damage sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A damaged sensor has been detected.

Replace the crankshaft speed/position sensor. Refer to Procedure 019-365 in Section 19.

Inspect the crankshaft tone wheel/gear teeth for damage or spinning. Sensor clearance is between 41.36 mm [1.36 in] and 42.65 mm [1.68 in].

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Verify adequate crankshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove crankshaft speed/position sensor from the engine.

Action

Verify adequate crankshaft speed/position sensor air gap.

  • Measure the distance between the sensor mounting surface and the edge of the tone wheel.

Distance is between 41.36 mm [1.36 in] and 42.65 mm [1.68 in]?
YES NO
No Repair

Inspect the crankshaft tone wheel/gear teeth for damage or spinning.

  • Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206, Bulletin 3666206. Refer to Procedure 001-071 in Section 1.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

 No Repair

Go to 4B

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.
  • Disconnect the crankshaft speed/position sensor from the engine harness.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the ECM connector 1 RETURN pin and the crankshaft speed/position sensor connector RETURN pin.
  • Measure the resistance between the ECM connector 1 SUPPLY pin and the crankshaft speed/position sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 SIGNAL pin and the crankshaft speed/position sensor connector SIGNAL pin.
  • Measure the resistance between the ECM connector 1 RETURN pin and the camshaft speed/position sensor connector RETURN pin.
  • Measure the resistance between the ECM connector 1 SUPPLY pin and the camshaft speed/position sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 SIGNAL pin and the camshaft speed/position sensor connector SIGNAL pin.

Shake and wiggle the harness to determine an intermittent connection.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return current has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 2.
  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the crankshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the crankshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the camshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the camshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness ECM connector 1 and ground.
  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 115 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 118 - Fuel Pressure Sensor Circuit, Primary - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for inactive fault codes. | Fault Code 118 inactive?
STEP 2. | Check the fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 119 active and Fault Code 118 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor conditions. | Fault Code 118 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 1000 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 118 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 118 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 118 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel pressure sensor and circuit.

Guided Step 2A - Inspect the fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the damaged engine harness, connector, or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 119 active and Fault Code 118 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn the keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the +5-VDC SUPPLY pin and the fuel pressure RETURN pin at the fuel pressure sensor connector of the engine harness.

Use the wiring diagram for connection pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 118 active?
YES NO

Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

None, the removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect fuel pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the fuel pressure sensor connector RETURN pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel pressure SIGNAL pin in the engine harness and all the other pins in the engine harness connector 1.
  • Measure the resistance between the fuel pressure SIGNAL pin in the engine harness connector 1 and all the other pins in the engine connector 2.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness, connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel pressure +5-VDC SUPPLY pin in the engine harness connector 1 and all the other pins in the engine harness connector 1.
  • Measure the resistance between the fuel pressure +5-VDC SUPPLY pin in the engine harness connector 1 and all the other pins in the engine connector 2.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 1000 ohms?
YES NO
No Repair

Repair or replace the engine harness, connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 118 inactive?
YES NO

None, the removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 118 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 119 - Fuel Pressure Sensor Circuit, Primary - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for inactive fault codes. | Fault Code 119 inactive?
STEP 2. | Check the fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 118 active and Fault Code 119 inactive?
 | STEP 2D. Check the fault codes and verify sensor conditions. | Fault Code 119 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 1000 ohms?
 | STEP 3E. Check for a pin-to-pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 119 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 119 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 119 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel pressure sensor and circuit.

Guided Step 2A - Inspect the fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the damaged engine harness, connector, or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the +5-VDC SUPPLY pin and the fuel pressure RETURN pin at the fuel pressure sensor connector of the engine harness.

Use the wiring diagram for connection pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the fuel pressure SUPPLY pin and the fuel pressure SIGNAL pin at the fuel pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 118 active and Fault Code 119 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 119 active?
YES NO

Replace the fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

None, the removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect fuel pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the engine harness fuel pressure sensor connector SUPPLY pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin and the engine harness fuel pressure sensor connector SIGNAL pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness, connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel pressure SIGNAL pin in the engine harness ECM connector 1 and all the other pins in the connector 1.
  • Measure the resistance between the fuel pressure SIGNAL pin in the engine harness ECM connector 1 and all the other pins in the connector 2.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 1000 ohms?
YES NO
No Repair

Repair or replace the engine harness, connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the fuel pressure SIGNAL pin in the engine harness ECM connector 1 and ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness, connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 119 inactive?
YES NO

None, the removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 119 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 121 - Engine Position Sensor Circuit - Primary or Backup Signal Lost

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 121 active?
STEP 2. | Check the engine position sensor. |
 | STEP 2A. Inspect the engine harness and engine position sensor connector pins. | Damaged or dirty pins?
 | STEP 2B. Inspect the sensor for damage. | Damage found?
 | STEP 2C. Read the fault codes. | Fault Code 121 active?
 | STEP 2D. Check the resistance of the sensor. | 1000 to 2000 ohms?
 | STEP 2E. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 3B. Read the fault codes. | Fault Code 121 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the engine position sensor.

Guided Step 2A - Inspect the engine harness and engine position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Inspect the engine harness and engine position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-038 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Inspect the engine position sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damage found?
YES NO

Replace the sensor. Refer to Procedure 019-038 in Section 19.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4B

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine position sensor positive pin to the engine position sensor negative pin in the engine position sensor connector.
  • Measure the resistance from the engine position sensor backup positive pin to the engine position sensor backup negative pin in the engine position sensor connector.

1000 to 2000 ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-038 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Make sure the sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine position sensor positive pin in the engine position sensor connector, sensor side, to engine block ground.
  • Measure the resistance from the engine position sensor backup positive pin in the engine position sensor connector, sensor side, to engine block ground.

More than 100k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-038 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 121 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Disconnect engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the engine position sensor positive pin in the engine harness sensor connector to the engine position sensor positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine position sensor backup positive pin in the engine harness sensor connector to the engine position sensor backup positive pin in the engine harness ECM connector.
  • Measure the resistance from the engine position sensor negative pin in the engine harness sensor connector to the engine position sensor negative pin in the engine harness ECM connector.
  • Measure the resistance from the engine position sensor backup negative pin in the engine harness sensor connector to the engine position sensor backup negative pin in the engine harness ECM connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine position sensor positive pin in the engine harness ECM connector to the engine block ground.
  • Measure the resistance from the engine position sensor backup positive pin in the engine harness ECM connector to the engine block ground.
  • See the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine position sensor positive pin in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the engine position sensor positive pin in the engine harness ECM connector 1 to all the pins in engine harness connector 2.
  • Measure the resistance from the engine position sensor backup positive pin in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the engine position sensor backup positive pin in the engine harness ECM connector 1 to all the pins in engine harness connector 2.
  • See the circuit diagram or wiring diagram for connector pin identification.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 122 - B and C Gas Plus - Mixer Inlet Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the mixer inlet pressure sensor and circuit. |
 | STEP 2A. Inspect the mixer inlet pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check the sensor supply fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the mixer inlet pressure sensor and circuit.

Guided Step 2A - Inspect the mixer inlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and mixer inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the SUPPLY pin and the mixer inlet pressure RETURN pin at the mixer inlet pressure sensor connector of the engine harness.

Use the wiring diagram for connector pin identification.

4.5 VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

Replace the mixer inlet pressure sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the mixer inlet pressure sensor connector RETURN pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the mixer inlet pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in engine harness connector 1.
  • Measure the resistance between the mixer inlet pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in engine harness connector 2.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

More than 100K ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the mixer inlet pressure sensor SUPPLY pin in engine harness ECM connector 2 and all other pins in engine harness ECM connector 2.
  • Measure the resistance between the mixer inlet pressure sensor SUPPLY pin in engine harness ECM connector 2 and all other pins in engine harness ECM connector 1.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Apr-2012


FAULT CODE 122 - L Gas Plus - Mixer Inlet Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the mixer inlet pressure sensor and circuit. |
 | STEP 2A. Inspect the mixer inlet pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check the sensor supply fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the mixer inlet pressure sensor and circuit.

Guided Step 2A - Inspect the mixer inlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and mixer inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the SUPPLY pin and the mixer inlet pressure RETURN pin at the mixer inlet pressure sensor connector of the engine harness.

Use the wiring diagram for connector pin identification.

4.5 VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

Replace the mixer inlet pressure sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the mixer inlet pressure sensor connector RETURN pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the mixer inlet pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in engine harness connector 1.
  • Measure the resistance between the mixer inlet pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in engine harness connector 2.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

More than 100K ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the mixer inlet pressure sensor SUPPLY pin in engine harness ECM connector 2 and all other pins in engine harness ECM connector 2.
  • Measure the resistance between the mixer inlet pressure sensor SUPPLY pin in engine harness ECM connector 2 and all other pins in engine harness ECM connector 1.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 122 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Apr-2012


FAULT CODE 123 - B and C Gas Plus - Mixer Inlet Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the mixer inlet pressure sensor and circuit. |
 | STEP 2A. Inspect the mixer inlet pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for a pin short to ground. | More than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 123 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check the sensor supply fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187.

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the mixer inlet pressure sensor and circuit.

Guided Step 2A - Inspect the mixer inlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and mixer inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the SUPPLY pin and the mixer inlet pressure RETURN pin at the mixer inlet pressure sensor connector of the engine harness.

Use the wiring diagram for connector pin identification.

4.5 VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

Replace the mixer inlet pressure sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector SUPPLY pin and the engine harness mixer inlet pressure sensor connector SUPPLY pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between engine harness ECM connector SIGNAL pin and engine harness mixer inlet pressure sensor connector SIGNAL pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the mixer inlet pressure SIGNAL pin in engine harness ECM connector 2 and all other pins in engine harness ECM connector 2.
  • Measure the resistance between the mixer inlet pressure SIGNAL pin in engine harness ECM connector 2 and all other pins in engine harness ECM connector 1.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the mixer inlet pressure sensor SIGNAL pin in engine harness ECM connector and ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Apr-2012


FAULT CODE 123 - L Gas Plus - Mixer Inlet Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the mixer inlet pressure sensor and circuit. |
 | STEP 2A. Inspect the mixer inlet pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | More than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 123 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check the sensor supply fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187.

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the mixer inlet pressure sensor and circuit.

Guided Step 2A - Inspect the mixer inlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and mixer inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the SUPPLY pin and the mixer inlet pressure RETURN pin at the mixer inlet pressure sensor connector of the engine harness.

Use the wiring diagram for connector pin identification.

4.5 VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the mixer inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

Replace the mixer inlet pressure sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector SUPPLY pin and the engine harness mixer inlet pressure sensor connector SUPPLY pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between engine harness ECM connector SIGNAL pin and engine harness mixer inlet pressure sensor connector SIGNAL pin.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the mixer inlet pressure SIGNAL pin in engine harness ECM connector 2 and all other pins in engine harness ECM connector 2.
  • Measure the resistance between the mixer inlet pressure SIGNAL pin in engine harness ECM connector 2 and all other pins in engine harness ECM connector 1.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the mixer inlet pressure sensor SIGNAL pin in engine harness ECM connector and ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 123 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 124 - B and C Gas Plus - High Mixer Inlet Pressure - Overboost

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122 or 123 active?
STEP 2. | Check the mixer inlet pressure sensor. |
 | STEP 2A. Inspect the engine harness and mixer inlet pressure sensor connector pins. | No damaged pins
 | STEP 2B. Verify the mixer inlet pressure. | Mixer inlet and manifold absolute pressure values the same at atmospheric pressure?
 | STEP 2C. Read the fault codes. | Fault Code 124 active?
STEP 3. | Check the mechanical components. |
 | STEP 3A. Check the turbocharger. | Turbocharger is correct and is operating properly?
 | STEP 3B. Check the air intake restriction. | Is restriction within specification?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 124 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 122 or 123 active?

YES NO

Troubleshoot Fault Codes 122 or 123.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the mixer inlet pressure sensor.

Guided Step 2A - Inspect the engine harness and mixer inlet pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the mixer inlet pressure sensor.

Action

Inspect the engine harness and mixer inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-098 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify the mixer inlet pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the mixer inlet pressure with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to compare the mixer inlet pressure and manifold absolute pressure.

Mixer inlet and manifold absolute pressure values the same at atmospheric pressure?
YES NO
No Repair

Replace the mixer inlet pressure sensor. Refer to Procedure 019-098 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 124 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the mechanical components.

Guided Step 3A - Check the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger.

Confirm the turbocharger is the correct for the engine. Check the turbocharger and wastegate plumbing for mechanical problems.

  • Use the following procedure in the Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.6 Engines, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Turbocharger is correct and is operating properly?
YES NO
No Repair

Repair or replace the turbocharger wastegate.

  • Use the following procedure in theTroubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.6 Engines, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Go to 3B

Go to 4A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake restriction of the engine.

  • Use the following procedure in the Troubleshooting and Repair Manual B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 010-031 in Section 10.

Is restriction within specification?
YES NO
No Repair

Correct the restriction. Remove the restriction or replace the air cleaner element.

  • Use the following procedure in the Troubleshooting and Repair Manual B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 010-031 in Section 10.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Verify that Fault Code 124 is inactive.

Fault Code 124 active?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 124 - L Gas Plus - High Mixer Inlet Pressure - Overboost

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 122 or 123 active?
STEP 2. | Check the mixer inlet pressure sensor. |
 | STEP 2A. Inspect the engine harness and mixer inlet pressure sensor connector pins. | No damaged pins
 | STEP 2B. Verify the mixer inlet pressure. | Mixer inlet and manifold absolute pressure values the same at atmospheric pressure?
STEP 3. | Check the mechanical components. |
 | STEP 3A. Check the turbocharger. | Turbocharger is correct and is operating properly?
 | STEP 3B. Check the air intake restriction. | Is restriction within specification?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 124 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 122 or 123 active?

YES NO

Troubleshoot Fault Codes 122 or 123.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the mixer inlet pressure sensor.

Guided Step 2A - Inspect the engine harness and mixer inlet pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the mixer inlet pressure sensor.

Action

Inspect the engine harness and mixer inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-098 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify the mixer inlet pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the mixer inlet pressure with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to compare the mixer inlet pressure and manifold absolute pressure.

Mixer inlet and manifold absolute pressure values the same at atmospheric pressure?
YES NO
No Repair

Replace the mixer inlet pressure sensor. Refer to Procedure 019-098 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the mechanical components.

Guided Step 3A - Check the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger.

  • Confirm that the turbocharger is the correct for the engine application.
  • Check the turbocharger and wastegate plumbing for mechanical problems. Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 010-113 in Section 10.

Turbocharger is correct and is operating correctly?
YES NO
No Repair

Repair or replace the turbocharger variable geometry actuator.

  • Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 010-113 in Section 10.

Go to 3B

Go to 4A

Guided Step 3B - Check the air intake restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake restriction of the engine.

  • Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 010-031 in section 10.

Is restriction within specification?
YES NO
No Repair

Correct the restriction. Remove the restriction or replace the air cleaner element.

  • Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 010-031 in section 10.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 111 is inactive.

Fault Code 124 active?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 131 - Accelerator Pedal Position Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault code. | Fault Code 387 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 2. | Check the accelerator pedal and circuit. |
 | STEP 2A. Inspect the accelerator pedal and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 132 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness and OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the engine harness and OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 387 active?
YES | NO
No Repair | No Repair

Fault Code 387

Go to 1B

Guided Step 1B - Check for inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the accelerator pedal and circuit.

Guided Step 2A - Inspect the accelerator pedal and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-201in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage and return circuit.

  • Measure the voltage between the accelerator pedal SUPPLY pin and the accelerator pedal RETURN pin at accelerator pedal connector of the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes .

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. Use the OEM service manual.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the engine ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector RETURN pin and the OEM harness accelerator pedal connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or the OEM harness.

Troubleshoot each harness connected is series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness or the OEM harness.

Troubleshoot each harness connected is series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 131 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 132 - Accelerator Pedal Position Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault code. | Fault Code 443 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 2. | Check the accelerator pedal and circuit. |
 | STEP 2A. Inspect the accelerator pedal and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 132 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness and OEM harness. |
 | STEP 3A-2. Check for an open circuit in the engine harness and OEM harness. |
 | STEP 3A-3. Check for a pin-to-pin short circuit in the engine harness and OEM harness. |
 | STEP 3A-4. Check for a pin short circuit to ground. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 active?
YES | NO
No Repair | No Repair

Fault Code 443

Go to 1B

Guided Step 1B - Check for inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the accelerator pedal and circuit.

Guided Step 2A - Inspect the accelerator pedal and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the accelerator pedal SUPPLY pin and the accelerator pedal RETURN pin at accelerator pedal connector of the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the accelerator pedal SUPPLY pin and the accelerator pedal SIGNAL pin at the accelrator pedal connector of the OEM harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes .

Fault Code 132 active?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. Use the OEM service manual.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the engine ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM or harness connector.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 SUPPLY pin and the OEM harness accelerator pedal connector SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or the OEM harness.

Troubleshoot each harness connected is series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or the OEM harness.

Troubleshoot each harness connected is series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a pin-to-pin short circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line has been detected in the engine harness or the OEM harness.

Troubleshoot each harness connected is series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector 2 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness or the OEM harness.

Troubleshoot each harness connected is series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 132 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 133 - Remote Accelerator Pedal Position Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 2. | Check the remote accelerator pedal/lever and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal/lever and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal/lever supply voltage and signal circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal/lever condition. | Fault Code 133 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness and OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the engine harness and OEM harness. |
 | STEP 3A-3. Check for a pin short circuit to ground. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the remote accelerator pedal/lever and circuit.

Guided Step 2A - Inspect the remote accelerator pedal/lever and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Inspect the OEM harness and remote accelerator pedal/lever connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal/lever supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage between the accelerator pedal voltage SUPPLY pin and the SIGNAL pin at the remote accelerator pedal/lever connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn keyswitch ON.
  • Turn remote accelerator switch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let idle for 30 seconds.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal/lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal/lever to the OEM harness.
  • Turn keyswitch ON.
  • Turn the remote accelerator switch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check for the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES NO

A damaged remote accelerator pedal/lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

  • Replace the remote accelerator/lever. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ECM and OEM harness connector 2.

Action

Inspect the engine harness and the OEM connector 2 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector 2.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 2.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 SIGNAL pin and the OEM harness accelerator pedal/lever connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1 and connector 2.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for a pin-to-pin short circuit

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the engine harness ECM connector 2 and all other pins in the connector 2.
  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the engine harness ECM connector 2 and all other pins in the connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness and engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Use the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3A-3 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1 and connector 2.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for a short circuit.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the OEM harness ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-ground circuit has been detected in the OEM harness and ECM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-201 in Sectio 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-4

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check for the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 133 is inactive.

Fault Code 133 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Turn the remote accelerator switch to ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Feb-2012


FAULT CODE 134 - Remote Accelerator Pedal Position Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test lead when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 2. | Check the remote accelerator pedal/lever and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal/lever and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal/lever supply voltage and signal circuit. | 4.5 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal/lever condition. | Fault Code 134 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness and OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the engine harness and OEM harness. |
 | STEP 3A-3. Check for a pin short circuit to ground. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Turn remote accelerator switch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the remote accelerator pedal/lever and circuit.

Guided Step 2A - Inspect the remote accelerator pedal/lever and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Inspect the OEM harness and remote accelerator pedal/lever connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal/lever supply voltage and signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply and signal circuit.

  • Measure the voltage between the accelerator pedal voltage SUPPLY pin and the SIGNAL pin at the remote accelerator pedal/lever connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.
  • Turn keyswitch ON.
  • Turn remote accelerator switch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 30 seconds.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active and Fault Code 134 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal/lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal/lever to the OEM harness
  • Turn keyswitch ON.
  • Turn remote accelerator switch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO

A damaged remote accelerator pedal/lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

  • Replace the remote accelerator/lever. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ECM and OEM harness connector 2.

Action

Inspect the engine harness and the OEM connector 2 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector 2.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 2.
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 SIGNAL pin and the OEM harness accelerator pedal/lever connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1 and connector 2
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for a short circuit.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the engine harness ECM connector 2 and all other pins in connector 2.
  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the engine harness ECM connector 2 and all other pins in connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit has been detected in the OEM harness and engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 2
  • Disconnect the remote accelerator pedal/lever from the OEM harness.

Action

Check for a short circuit.

  • Measure the resistance between the remote accelerator pedal/lever SIGNAL pin in the OEM harness ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-ground short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the engine harness or OEM harness.

  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Turn remote accelerator switch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Turn remote accelerator switch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code134 is inactive.

Fault Code 134 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Turn remote accelerator switch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Feb-2012


FAULT CODE 135 - B and C Gas Plus - Engine Oil Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the oil pressure RETURN pin on the oil pressure sensor connector of the engine harness.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

  • Refer to Procedure 019-155 in Section 19.
  • Refer to Procedure 019-066 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ecm connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the oil pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure 5 Volt SUPPLY pin in engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the oil pressure 5 Volt SUPPLY pin in engine harness connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-May-2012


FAULT CODE 135 - L Gas Plus - Engine Oil Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the oil pressure RETURN pin on the oil pressure sensor connector of the engine harness.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

  • Refer to Procedure 019-155 in Section 19
  • Refer to Procedure 019-066 in Section 19

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ecm connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 1.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the oil pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 1.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 1.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure 5 Volt SUPPLY pin in engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the oil pressure 5 Volt SUPPLY pin in engine harness connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 141 - B and C Gas Plus - Engine Oil Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the oil pressure RETURN pin on the oil pressure sensor connector of the engine harness.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil pressure SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

  • Refer to Procedure 019-155 in Section 19.
  • Refer to Procedure 019-066 in Section 19

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the engine harness oil pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin and the engine harness oil pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in connector 1.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector 1 and ground.

Refer tothe circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 08-May-2012


FAULT CODE 141 - L Gas Plus - Engine Oil Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate breakout cable when taking a measurement.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3162898 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the 5 Volt SUPPLY pin and the oil pressure RETURN pin on the oil pressure sensor connector of the engine harness.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the oil pressure SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

  • Refer to Procedure 019-155 in Section 19.
  • Refer to Procedure 019-066 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the engine harness oil pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin and the engine harness oil pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in connector 1.
  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the oil pressure SIGNAL pin in engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 08-May-2012


FAULT CODE 142 - B and C Gas Plus - High Engine Oil Pressure - Over Pressure

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1. Read the fault codes. | Fault Code 142 active?
STEP 2. | Check the oil pressure sensor accuracy. |
 | STEP 2A. Check the sensor accuracy. | Sensor reading is correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 142 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 142 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the oil pressure sensor accuracy.

Guided Step 2A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.

If necessary, increase the engine rpm's to make it easier to see differences in the readings.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 142 is inactive.

If the fault was at a particular speed, operate the engine at that speed to verify the problem is corrected.

Fault Code 142 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If the fault code remains active, Lubricating Oil Temperature Above Specifications troubleshooting symptom chart in Section TS in the Troubleshooting and Repair Manual B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 142 - L Gas Plus - High Engine Oil Pressure - Over Pressure

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1. Read the fault codes. | Fault Code 142 active?
STEP 2. | Check the oil pressure sensor accuracy. |
 | STEP 2A. Check the sensor accuracy. | Sensor reading is correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 142 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 142 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the oil pressure sensor accuracy.

Guided Step 2A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.

If necessary, increase the engine rpm's to make it easier to see differences in the readings.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading.

  • Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 142 is inactive.

If the fault was at a particular speed, operate the engine at that speed to verify the problem is corrected.

Fault Code 142 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If the fault code remains active, Lubricating Oil Temperature Above Specifications troubleshooting symptom chart in Section TS of the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 143 - B and C Gas Plus - Engine Oil Pressure Low Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading is correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading.

  • Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical oil pressure gauge
  • Connect INSITE™ electronic service tool
  • Engine operating at idle speed.

Action

Check the engine oil pressure.

  • Use the following procedure in the Troubleshooting and Repair Manual B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 007-052 in Section 7.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Lubricating Oil Pressure Low troubleshooting symptom tree.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 143 is inactive.

If the fault was at a particular speed, operate the engine at that speed to verify the problem is corrected.

Fault Code 143 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If fault code remains active, go to the Low Oil Pressure symptom tree in Section TS.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 143 - L Gas Plus - Engine Oil Pressure Low - Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading is correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute. Add atmospheric pressure to gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if INSITE™ electronic service tool reading differs from mechanical gauge reading.

  • Refer to Procedure 019-066 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical oil pressure gauge.
  • Connect INSITE™ electronic service tool.
  • Engine operating at idle speed.

Action

Check the engine oil pressure.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 007-052 in Section 7.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 143 is inactive.

If the fault was at a particular speed, operate the engine at that speed to verify the problem is corrected.

Fault Code 143 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If fault code remains active, reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 11-May-2012


FAULT CODE 144 - B and C Gas Plus - Engine Coolant Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 144 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 175 ohms to 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor and circuit.

Guided Step 2A - Inspect the coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the coolant temperature sensor connector.

175 ohms to 274k ohms?
YES NO
No Repair

Replace the coolant temperature sensor.

  • Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ecm connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature RETURN pin and the ECM connector 1 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness to all other pins in the engine ECM connector 1.
  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness and all pins in engine ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL pin has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 144 - L Gas Plus - Engine Coolant Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 144 inactive?
STEP 2. | Check the coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 175 ohms to 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor and circuit.

Guided Step 2A - Inspect the coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the coolant temperature sensor connector.

175 ohms to 274k ohms?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-157 in Section 19

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Dirt or debris in or on the connector pins.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature RETURN pin and the ECM connector 2 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the coolant temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness to all other pins in the engine ECM connector 1.
  • Measure the resistance between the coolant temperature SIGNAL pin in engine harness and all pins in engine ECM connector 2.

Use the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL pin has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 145 - B and C Gas Plus - Engine Coolant Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine coolant temperature sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Mar-2012


Fault Code 146 - L Gas Plus - Engine Coolant Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine coolant temperature sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 n Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the engine coolant temperature SIGNAL pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Mar-2012


FAULT CODE 146 - B and C Gas Plus - Engine Coolant Temperature Sensor Circuit - Temperature Warning

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 146 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Temperature differ more than 3°C or 5°F?
STEP 3. | Check the Coolant Temperature Sensor. |
 | STEP 3A. Inspect the Coolant Temperature Sensor and Engine Harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 146 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 146 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool, to the reading from the temperature probe.

If no temperature measuring device is available, answer “NO” to this step.

Temperature differ more than 3°C or 5°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-157.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Coolant Temperature Sensor.

Guided Step 3A - Inspect the Coolant Temperature Sensor and Engine Harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Harness from the Coolant Temperature Sensor.

Action

Inspect the Coolant Temperature Sensor and Engine Harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the Engine Harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the Engine Harness. Refer to Procedure 019-202 in Section 19.
  • Replace the Engine Harness. Refer to Procedure 019-043 in Section 19.
  • Replace the Coolant Temperature Sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it run for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES NO

Coolant Temperature Above Normal troubleshooting symptom chart in Section TS of the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206, and in the Troubleshooting and Repair Manual B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 146 is inactive.

Fault Code 146 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 03-Apr-2012


FAULT CODE 146 - L Gas Plus - Engine Coolant Temperature Sensor Circuit - Temperature Warning

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 146 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Temperature differ more than 3°C or 5°F?
STEP 3. | Check the Coolant Temperature Sensor. |
 | STEP 3A. Inspect the Coolant Temperature Sensor and Engine Harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 146 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 146 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Turn keyswitch ON.

Action

Verify the sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool, to the reading from the temperature probe.

If no temperature measuring device is available, answer “NO” to this step.

Temperature differ more than 3°C or 5°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Coolant Temperature Sensor.

Guided Step 3A - Inspect the Coolant Temperature Sensor and Engine Harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Harness from the Coolant Temperature Sensor.

Action

Inspect the Coolant Temperature Sensor and Engine Harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the Engine Harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the Engine Harness. Refer to Procedure 019-202 in Section 19.
  • Replace the Engine Harness. Refer to Procedure 019-043 in Section 19.
  • Replace the Coolant Temperature Sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES NO

Coolant Temperature Above Normal troubleshooting symptom chart in Section TS of the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool verify Fault Code 146 is inactive.

Fault Code 146 inactive?
YES NO
No Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 04-Apr-2012


FAULT CODE 151 - B and C Gas Plus - Engine Coolant Temperature High - Critical

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 151 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ more than 3°C or 5°F?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 151 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the sensor accuracy.

  • Compare the coolant temperature reading on the INSITE™ electronic service tool, to the reading from the temperature probe.

If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C or 5°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector. Using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206, or the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 151 is inactive.

Fault Code 151 active?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 151 - L Gas Plus - Engine Coolant Temperature High - Critical

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 151 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Does the temperature differ more than 3°C or 5°F?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the coolant temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 151 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the sensor accuracy.

  • Compare the coolant temperature reading on the INSITE™ electronic service tool to the reading from the temperature probe.

If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C or 5°F?
YES NO

Replace the coolant sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the Engine Harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it run for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES NO

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 151 is inactive.

Fault Code 151 active?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 153 - Intake Manifold Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance | Between 175 ohms and 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the engine harness and intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the intake manifold temperature sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Between 175 ohms and 274 ohms?
YES NO

Go to the table in Shop Talk for specifications.

Replace the intake manifold temperature sensor. Refer to Procedure 019-354 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the temperature RETURN pin and the ECM connector 1 RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine intake manifold temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the intake manifold temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 154 - Intake Manifold Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 active?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the intake manifold air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold air temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-354 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the intake manifold air temperature SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the intake manifold air temperature SIGNAL pin in engine harness ECM connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 155 - Intake Manifold Temperature Sensor Circuit - Critical Temperature Reached

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 155 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Does the temperature differ more than 3°C or 5°F?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 155 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 155 active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect the INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Verify the sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

If no temperature measuring device is available, answer “NO” to this step.

Does the temperature differ more than 3°C or 5°F?
YES NO

Replace the intake manifold intake pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the intake manifold pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-099 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 155 active?
YES NO

Reference the Intake Manifold Air Temperature Above Normal troubleshooting symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206 or the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 155 is inactive.

Fault Code 155 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

 No Repair

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 175 - Electronic Throttle Control Actuator Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 175 active?
STEP 2. | Check the electronic throttle control actuator. |
 | STEP 2A. Inspect the electronic throttle control actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 175 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 175 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 175 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electronic throttle control actuator.

Guided Step 2A - Inspect the electronic throttle control actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.

Action

Inspect the electronic throttle control actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-097 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 175 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the throttle actuator positive (+) pin in the engine harness connector to the throttle actuator positive (+) pin in the engine harness actuator connector.
  • Measure the resistance between the throttle actuator negative (-) pin in the engine harness connector to the throttle actuator negative (-) pin in the engine harness actuator connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance between the throttle actuator positive (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance between the throttle actuator negative (-) pin in the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit.

  • Measure the resistance between the throttle actuator positive (+) pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the throttle actuator negative (-) pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the throttle actuator positive (+) pin in the engine harness ECM connector 1 to all pins in the engine harness ECM connector 2.
  • Measure the resistance between the throttle actuator negative (-) pin in the engine harness ECM connector 1 to all pins in the engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check the appropriate circuit response for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 175 is inactive.

Fault Code 175 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Feb-2012


FAULT CODE 176 - Electronic Throttle Control Actuator Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 176 active?
STEP 2. | Check the electronic throttle control actuator. |
 | STEP 2A. Inspect the electronic throttle control actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 175 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 176 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 176 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electronic throttle control actuator.

Guided Step 2A - Inspect the electronic throttle control actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.

Action

Inspect the electronic throttle control actuator and engine harness connector pins in the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-097 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 176 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins in the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the throttle actuator positive (+) pin in the engine harness connector to the throttle actuator positive (+) pin in the engine harness actuator connector.
  • Measure the resistance between the throttle actuator negative (-) pin in the engine harness connector to the throttle actuator (-) pin in the engine harness actuator connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the electronic throttle control actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit.

  • Measure the resistance between the throttle actuator positive (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance between the throttle actuator negative (-) pin in the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit.

  • Measure the resistance between the throttle actuator positive (+) pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the throttle actuator negative (-) pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the throttle actuator positive (+) pin in engine harness ECM connector 1 to all pins in engine harness ECM connector 2.
  • Measure the resistance between the throttle actuator negative (-) pin in engine harness ECM connector 1 to all pins in engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Check the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 176 is inactive.

Fault Code 176 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 28-Feb-2012


FAULT CODE 177 - Electronic Throttle Control Actuator - Stuck Open

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test leads when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 177 active?
STEP 2. | Check the electronic throttle control actuator. |
 | STEP 2A. Inspect the electronic throttle control actuator and engine harness connector pins. | Damaged or dirty pins?
 | STEP 2B. Read the fault codes. | Fault Code 177 active?
STEP 3. | Verify the throttle operation. |
 | STEP 3A. Verify the throttle operation. | Did the gas throttle control pass the test?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Damaged or dirty pins?
 | STEP 4B. Read the fault codes. | Fault Code 177 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 4E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4F. Check the throttle actuator for an obstruction or damage. | Obstruction or damage?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 177 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the electronic throttle control actuator.

Guided Step 2A - Inspect the electronic throttle control actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic throttle control actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-052 in Section 5.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-052 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 5B

Guided Step 3 - Verify the throttle operation.

Guided Step 3A - Verify the throttle operation.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Verify proper throttle operation.

  • Use INSITE™ electronic service tool to activate the gas throttle control test.

Did the gas throttle control pass the test?
YES NO
No Repair

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-052 in Section 5.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-052 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 177 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the throttle actuator
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the throttle position (+) pin in the engine harness connector to the throttle position (+) pin in the engine harness actuator connector.
  • Measure the resistance from the throttle actuator (+) pin in the engine harness connector to the throttle actuator (+) pin in the engine harness actuator connector.
  • Measure the resistance from the throttle actuator (-) pin in the engine harness connector to the throttle actuator (-) pin in the engine harness actuator connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the throttle position (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle actuator (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle actuator (-) pin in the engine harness ECM connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the OEM harness at the 23 pin and 31 pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the throttle position (+) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.
  • Measure the resistance from the throttle actuator (+) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.
  • Measure the resistance from the throttle actuator (-) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check the throttle actuator for an obstruction or damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the throttle actuator for an obstruction or damage.

  • Check the throttle plate for straightness. If the plate is bent, replace the throttle actuator.

Obstruction or damage?
YES NO

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-052 in Section 5.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-052 in Section 19.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 177 is inactive.

Fault Code 177 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a local Cummins® authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 28-Feb-2012


FAULT CODE 178 - Electronic Throttle Control Actuator - Stuck Closed

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the appropriate test leads when taking a measurement.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 178 active?
STEP 2. | Check the throttle actuator. |
 | STEP 2A. Inspect the throttle actuator and engine harness connector pins. | Damaged or dirty pins?
 | STEP 2B. Read the fault codes. | Fault Code 178 active?
STEP 3. | Verify the throttle operation. |
 | STEP 3A. Verify the throttle operation. | Did the gas throttle control pass the test?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 178 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 4E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4F. Check the throttle actuator for an obstruction or damage. | Obstruction or damage?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 178 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Read the fault codes.

Fault Code 178 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5B

Guided Step 2 - Check the throttle actuator.

Guided Step 2A - Inspect the throttle actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the throttle actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the actuator. Refer to Procedure 019-097 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 178 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 5B

Guided Step 3 - Verify the throttle operation.

Guided Step 3A - Verify the throttle operation.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Verify proper throttle operation.

  • Use INSITE™ electronic service tool to activate the gas throttle control test.

Did the gas throttle control pass the test?
YES NO
No Repair

Replace the throttle actuator.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-052 in Section 5.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-052 in Section 5.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 178 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the throttle position (+) pin in the engine harness connector to the throttle position (+) pin in the engine harness actuator connector.
  • Measure the resistance from the throttle actuator (+) pin in the engine harness connector to the throttle actuator (+) pin in the engine harness actuator connector.
  • Measure the resistance from the throttle actuator (-) pin in the engine harness connector to the throttle actuator (-) pin in the engine harness actuator connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the throttle position (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle actuator (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance from the throttle actuator (-) pin in the engine harness ECM connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the throttle actuator.
  • Disconnect the engine harness from the OEM harness at the 23 pin and 31 pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the throttle position (+) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.
  • Measure the resistance from the throttle actuator (+) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.
  • Measure the resistance from the throttle actuator (-) pin in engine harness connector 1 and all pins in engine harness ECM connector 2.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check the throttle actuator for an obstruction or damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the throttle actuator for an obstruction or damage.

  • Check the throttle plate for straightness. If the plate is bent, replace the throttle actuator.

Obstruction or damage?
YES NO

Replace the throttle actuator.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-052 in Section 5.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE electronic service tool to verify that Fault Code 178 is inactive.

Fault Code 178 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a local Cummins® authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 28-Feb-2012


FAULT CODE 187 - Sensor Supply Voltage 5 Volt (2) Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Codes 187 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the remote accelerator pedal position sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response |
 | STEP 2B. Inspect the mixer inlet pressure sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response |
 | STEP 2C. Inspect the coolant level sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response |
 | STEP 2D. Inspect the coolant pressure/temperature sensor and connector pins connected to sensor supply number 2. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3B-1. Check for a pin short to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

n/a

Use INSITE™ electronic service tool to read the fault codes.

Dirty or damaged pins?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the remote accelerator pedal position sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.

Action

Inspect the remote accelerator pedal position sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the remote accelerator pedal position sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the remote accelerator pedal position sensor. Refer to Procedure 019-085 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the mixer inlet pressure sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the mixer inlet pressure sensor from the engine harness.

Action

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the mixer inlet pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ciruit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the mixer inlet pressure sensor. Refer to Procedure 019-098 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the coolant level sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor from the OEM harness.

Action

Inspect the coolant level sensor harness and OEM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the coolant level sensor. Use the OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the coolant pressure/temperature sensor and connector pins connected to sensor supply number 2.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure/temperature sensor from the engine harness.

Action

Inspect the coolant pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure/temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the coolant pressure/temperature sensor. Refer to Procedure 019-157 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the coolant pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 2 from the ECM
  • Disconnect the remote accelerator pedal position sensor, mixer inlet pressure sensor, coolant level sensor and coolant pressure/temperature sensor from the engine harness.
  • Make sure all components connected to sensor supply number 2 are disconnected.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply line number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 2 from the ECM
  • Disconnect the remote accelerator pedal position sensor, mixer inlet pressure sensor, coolant level sensor and coolant pressure/temperature sensor from the engine harness.
  • Make sure all components connected to sensor supply number 2 are disconnected.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor supply line number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 187 inactive.

Fault Code 187 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 198 - ECM Diagnostic Lamp Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 198 active?
STEP 2. | Check the ECM diagnostic lamp circuit. |
 | STEP 2A. Inspect the OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 198 active?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 198 active?
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 198 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 198 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the ECM diagnostic lamp circuit.

Guided Step 2A - Inspect the OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 31-pin OEM connector.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the OEM harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 198 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 31-pin OEM connector
  • Disconnect the stop engine lamp, check engine lamp, maintenance lamp, and low fuel pressure lamp from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the stop engine lamp output pin in the 31-pin OEM connector, OEM side, to engine block ground.
  • Measure the resistance from the check engine lamp output pin in the 31-pin OEM connector, OEM side, to engine block ground.
  • Measure the resistance from the low fuel pressure lamp output pin in the 31-pin OEM connector, OEM side, to engine block ground.

More than 100k ohms?
YES NO
No Repair

  • Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 198 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 31-pin OEM connector
  • Disconnect engine harness connector 2 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the stop engine lamp output pin in engine harness ECM connector 2 to engine block ground.
  • Measure the resistance from the check engine lamp output pin in engine harness ECM connector 2 to engine block ground.
  • Measure the resistance from the low fuel pressure lamp output pin in engine harness ECM connector 2 to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 23-pin and 31-pin OEM connectors
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the stop engine lamp output pin in harness ECM connector 2 to all other pins in the connector, and to all pins in engine harness ECM connector 1.
  • Measure the resistance from the check engine lamp output pin in harness ECM connector 2 to all other pins in the connector, and to all pins in engine harness ECM connector 1.
  • Measure the resistance from the low fuel pressure lamp output pin in harness ECM connector 2 to all other pins in the connector, and to all pins in engine harness ECM connector 1.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool verify that Fault Code 198 is inactive.

Fault Code 198 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 199 - ECM Diagnostic Lamp Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 199 active?
STEP 2. | Check the ECM diagnostic lamp circuit. |
 | STEP 2A. Inspect the OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 199 active?
 | STEP 2C. Check the ECM response | Fault Code 199 active and Fault Code 198 active?
 | STEP 2D. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 199 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 199 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 199 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4B

Guided Step 2 - Check the ECM diagnostic lamp circuit.

Guided Step 2A - Inspect the OEM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 31-pin OEM connector.

Action

Inspect the OEM harness and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the OEM harness or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Refer to the OEM service manual.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 199 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4B

Guided Step 2C - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the lamps from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 199 active and Fault Code 198 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 31-pin OEM connector
  • Disconnect the stop engine lamp, check engine lamp, maintenance lamp, and low fuel pressure lamp from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from the stop engine lamp output pin in the 31-pin OEM connector, OEM side, to engine block ground.
  • Measure the resistance from the check engine lamp output pin in the 31-pin OEM connector, OEM side, to engine block ground.
  • Measure the resistance from the low fuel pressure lamp output pin in the 31-pin OEM connector, OEM side, to engine block ground.

More than 100k ohms?
YES NO
No Repair

  • Repair or replace the OEM harness. Use the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 199 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 31-pin OEM connector
  • Disconnect the engine harness connector 2 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the stop engine lamp output pin in the engine harness ECM connector 2 to the stop engine lamp output pin in the 31-pin OEM connector, engine harness side.
  • Measure the resistance from the check engine lamp output pin in the engine harness ECM connector 2 to the check engine lamp output pin in the 31-pin OEM connector, engine harness side.
  • Measure the resistance from the low fuel pressure lamp output pin in the engine harness ECM connector 2 to the low fuel pressure lamp output pin in the 31-pin OEM connector, engine harness side.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 31-pin OEM connector
  • Disconnect engine harness connector 2 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the stop engine lamp output pin in engine harness ECM connector 2 to engine block ground.
  • Measure the resistance from the check engine lamp output pin in engine harness ECM connector 2 to engine block ground.
  • Measure the resistance from the low fuel pressure lamp output pin in engine harness ECM connector 2 to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the engine harness at the 23-pin and 31-pin OEM connectors
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the stop engine lamp output pin in harness ECM connector 2 to all other pins in the connector, and to all pins in engine harness ECM connector 1.
  • Measure the resistance from the check engine lamp output pin in harness ECM connector 2 to all other pins in the connector, and to all pins in engine harness ECM connector 1.
  • Measure the resistance from the low fuel pressure lamp output pin in harness ECM connector 2 to all other pins in the connector, and to all pins in engine harness ECM connector 1.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool verify that Fault Code 199 is inactive.

Fault Code 199 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 212 - Oil Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 175 ohms and 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil temperature sensor and circuit.

Guided Step 2A - Inspect the oil pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the oil temperature sensor from the engine harness.

Action

Inspect the engine harness and oil pressure/temperature sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the oil temperature sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 175 and 274k ohms?
YES NO

Reference the table in the Shop Talk section for specifications.

Replace the engine oil temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the oil temperature RETURN pin and the ECM connector 1 RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.
  • Disconnect the oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the oil temperature SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the oil temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Feb-2012


FAULT CODE 213 - Oil Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine oil temperature sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine oil temperature sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine oil temperature sensor. Refer to Procedure 019-155 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature SIGNAL pin in engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the engine oil temperature SIGNAL pin in engine harness ECM connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine oil temperature SIGNAL pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to ground short circuit has been detected in the engine harness.

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Feb-2012


FAULT CODE 214 - Engine Oil Temperature - High Critical

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 214 active?
STEP 2. | Check the engine oil pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and engine oil pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 214 active?
 | STEP 2C. Verify engine oil temperature sensor. | Does temperature differ more than 5 degrees?
 | STEP 2D. Check the resistance of the sensor. | Between 300 and 90k ohms?
 | STEP 2E. Read the fault codes. | Fault Code 214 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 214 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and engine oil pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine oil pressure/temperature sensor.

Action

Inspect the engine harness and engine oil pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Verify engine oil temperature sensor.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify the engine oil temperature sensor accuracy

  • Verify the engine oil temperature measurement by comparing the INSITE™ electronic service tool reading to the mechanical gauge measurement.

Does temperature differ more than five degrees?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the resistance of the sensor.

Conditions

  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.

Action

Check the resistance of the sensor.

  • Measure the resistance from the oil temperature SIGNAL pin to the oil pressure/temperature RETURN pin in the engine oil pressure/temperature sensor.

Between 300 and 90k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-155 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active?
YES NO

Reference the Oil Temperature Above Normal troubleshooting symptom tree in Section TS in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206, or in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Reference the Oil Temperature Above Normal troubleshooting symptom tree in Section TS.

Go to 3B

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 214 is inactive.

Fault Code 214 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 17-Feb-2012


FAULT CODE 221 - Compressor Inlet Pressure Sensor Circuit - Shorted High

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for 386 fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the compressor inlet pressure sensor and circuit. |
 | STEP 2A. Inspect the compressor inlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.5 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for 386 fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 386.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the compressor inlet pressure sensor and circuit.

Guided Step 2A - Inspect the compressor inlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the compressor inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and compressor inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the compressor inlet pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the compressor inlet pressure sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the compressor inlet pressure RETURN pin at the compressor inlet pressure sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the compressor inlet pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes and verify sensor condition.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected,

Replace the compressor inlet pressure sensor. Refer to Procedure 019-433 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the compressor inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the compressor inlet pressure sensor connector RETURN pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the compressor inlet pressure sensor from the harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the compressor inlet pressure SIGNAL pin in the engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the compressor inlet pressure SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 1.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the compressor inlet pressure sensor from the harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the compressor inlet pressure sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the engine ECM connector 1.
  • Measure the resistance between the compressor inlet pressure sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the engine ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Feb-2012


FAULT CODE 222 - Compressor Inlet Pressure Sensor Circuit - Shorted Low

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the compressor inlet pressure sensor and circuit. |
 | STEP 2A. Inspect the compressor inlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.5 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the compressor inlet pressure sensor and circuit.

Guided Step 2A - Inspect the compressor inlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the compressor inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and compressor inlet presssure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the compressor inlet pressure sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the compressor inlet pressure RETURN pin at the compressor inlet pressure sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the compressor inlet pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the compressor inlet pressure supply pin and the compressor inlet pressure signal pin at the compressor inlet pressure sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the compressor inlet pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected,

Replace the compressor inlet pressure sensor. Refer to Procedure 019-433 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ecm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the compressor inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector SUPPLY pin and the engine harness compressor inlet pressure sensor connector SUPPLY pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the compressor inlet pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector SIGNAL pin and the engine harness compressor inlet pressure sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the compressor inlet pressure sensor from the harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the compressor inlet pressure SIGNAL pin in the engine harness ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the compressor inlet pressure SIGNAL pin in the engine harness ECM connector 1 and all other pins in the ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the compressor inlet pressure sensor from the harness.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the compressor inlet pressure SIGNAL pin in the engine harness ECM connector and ground.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 24-Feb-2012


FAULT CODE 227 - B and C Gas Plus - Sensor Supply Voltage 5 Volt (2) - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 227 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch ON
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the remote accelerator pedal position sensor, mixer inlet pressure sensor, and coolant level sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive?

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Feb-2012


FAULT CODE 227 - L Gas Plus - Sensor Supply Voltage 5 Volt (2) - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 227 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 227 inactive?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch ON
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the remote accelerator pedal position sensor, mixer inlet pressure sensor, Coolant pressure/temperature sensor, and coolant level sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 2.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the sensor SUPPLY number 2 pin in the engine harness ECM connector 2 and all other pins in the engine connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY number 2 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive?

Fault Code 227 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Feb-2012


FAULT CODE 228 - Coolant Pressure - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check fault codes. | Active or inactive counts of Fault Code 228?
STEP 2. | Check engine coolant pressure. |
 | STEP 2A. Check engine coolant pressure with a mechanical gauge. | Coolant pressure greater than the specified value?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 228 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 228?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check engine coolant pressure.

Guided Step 2A - Check engine coolant pressure with a mechanical gauge.

Conditions

  • Remove the coolant pressure/temperature sensor
  • Turn keyswitch ON
  • Connect a mechanical pressure gauge
  • Start engine and warm engine to above 82°C [180°F].

Action

Check the engine coolant pressure at idle speed and 2300 rpm.

Minimum coolant pressure specification with thermostat open:

  • Idle: 13.7 kPa [2 psi]
  • 2300 rpm: 172 kPa [25 psi]

Coolant pressure greater than the specified value?
YES | NO
No Repair | No Repair

Go to 3A

Reference the Coolant Pressure Low troubleshooting symptom tree in Section TS.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 228 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON or Run/Stop switch to the RUN position
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Feb-2012


FAULT CODE 231 - Engine Coolant Pressure Sensor Circuit - Shorted High

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for 227 fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 231 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 232 active and Fault Code 231 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.5 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 231 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 231 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 231 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 227.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 227.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and coolant pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the coolant pressure RETURN pin at the coolant pressure sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the coolant pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active?
YES NO

A damaged sensor has been detected,

Replace the coolant pressure sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM connector 2
  • Disconnect the coolant pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 RETURN pin and the coolant pressure sensor connector RETURN pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the coolant pressure sensor from the harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the coolant pressure SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the coolant pressure SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the coolant pressure sensor from the harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the coolant pressure 5 Volt SUPPLY pin in the engine harness connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the coolant pressure 5 Volt SUPPLY pin in the engine harness connector 2 and all other pins in the engine connector 1.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 28-Feb-2012


FAULT CODE 232 - Engine Coolant Pressure Sensor Circuit - Shorted Low

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 232 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.5 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 232 active and Fault Code 231 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 231 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 231 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 232 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 352.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and coolant pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the coolant pressure RETURN pin at the coolant pressure sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Between 4.5 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the coolant pressure supply pin and the coolant pressure signal pin at the coolant pressure sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the coolant pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

A damaged sensor has been detected,

Replace the coolant pressure sensor. Refer to Procedure 019-157 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the coolant pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 SUPPLY pin and the coolant pressure sensor connector SUPPLY pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the coolant pressure sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin and the coolant pressure sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the coolant pressure SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the coolant pressure SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the signal line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the coolant pressure sensor from the harness.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the coolant pressure SIGNAL pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to ground short circuit on the signal line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 28-Feb-2012


FAULT CODE 233 - Engine Coolant Pressure Low Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine coolant pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading within 34.5 kPa [5 psia]?
STEP 2. | Check engine coolant pressure. |
 | STEP 2A. Check engine coolant pressure with a mechanical gauge. | Coolant pressure greater than the specified value?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 233 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine coolant pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical pressure gauge
  • Connect INSITE™ electronic service tool to the vehicle datalink.

Action

Check the sensor accuracy.

  • Start the engine and compare the coolant pressure reading on the service tool monitor screen in INSITE™ electronic service tool to the reading on the mechanical coolant pressure gauge. Pressure sensor displays in absolute, add atmosphere pressure to gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if INSITE™ electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-157 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine coolant pressure.

Guided Step 2A - Check engine coolant pressure with a mechanical gauge.

Conditions

  • Remove the coolant pressure/temperature sensor
  • Turn keyswitch ON
  • Connect a mechanical pressure gauge
  • Start engine and warm engine to above 82°C [180°F].

Action

Check the engine coolant pressure at idle and 2300 rpm.

Minimum coolant pressure specification with thermostat open:

  • Idle: 13.7 kPa [2 psi]
  • 2300 rpm: 172 kPa [25 psi]

Coolant pressure greater than the specified value?
YES | NO
No Repair | No Repair

Go to 3A

Reference the Coolant Pressure Low troubleshooting symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code 233 is inactive.

Fault Code 233 inactive?
YES NO
No Repair

Repeat the troubleshooting steps. If fault code remains active, reference the Coolant Pressure Low troubleshooting symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON or Run/Stop switch to the RUN position
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 28-Feb-2012


FAULT CODE 234 - B and C Gas Plus - Engine Speed High - Critical

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage will occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for an alternate fuel source | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault code at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1F. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO

Check for engine damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated without accelerator pedal being depressed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Engine is running
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with INSITE™ electronic service tool.

  • Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault code 115 and Fault Code 121.

Go to 1D

Fault Codes 689 and 778

Guided Step 1D - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensors.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged connector pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code at low engine rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Test the vehicle.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Test the vehicle.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 2B

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

/Disable the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 28-Feb-2012


FAULT CODE 234 - L Gas Plus - Engine Speed High - Critical

Associated Procedures

Cautions and Warnings

CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage will occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for an alternate fuel source | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault code at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1F. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO

Check for engine damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated without accelerator pedal being depressed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON
  • Engine is running
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with INSITE™ electronic service tool.

  • Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault code 115 and Fault Code 121.

Go to 1D

Fault Codes 689 and 778

Guided Step 1D - Inspect the engine harness and engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine speed sensors.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged connector pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an inactive fault code at low engine rpm.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code at low engine rpm.

  • Use INSITE™ electronic service tool to read the fault codes.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Test the vehicle.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Test the vehicle.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 2B

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 28-Feb-2012


FAULT CODE 235 - B and C Gas Plus - Engine Coolant Level Low - Critical

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number - 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 235 active?
STEP 2. | Check the coolant level. |
 | STEP 2A. Verify the coolant level. | Coolant level normal?
STEP 3. | Check the coolant level sensor and harness. |
 | STEP 3A. Inspect the engine harness and coolant level sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 235 active?
STEP 4. | Check the ECM and harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 235 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Verify the coolant level. |
 | STEP 5A. Verify the coolant level with INSITE™ electronic service tool. | INSITE™ electronic service tool reading of coolant level correct?
 | STEP 5B. Check the sensor supply voltage. | Between 4.5 and 5.5-VDC?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 235 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6B

Guided Step 2 - Check the coolant level.

Guided Step 2A - Verify the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Remove the radiator cap or top tank reservoir and inspect the coolant level.

Coolant level normal?
YES NO
No Repair

Add coolant to the system. Cummins® Coolant Requirements and Maintenance, Bulletin 3666132.

Check for coolant leaks. Reference the Coolant Loss troubleshooting symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206 or the B5.9G, 5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164.

Go to 2B

Go to 6A

Guided Step 3 - Check the coolant level sensor and harness.

Guided Step 3A - Inspect the engine harness and coolant level sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor from the engine harness.

Action

Inspect the engine harness and coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damage connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 6B

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damage connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 6B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the engine harness connector 1 and 2 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to the SIGNAL pins in the OEM harness sensor connector.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to the coolant level RETURN pin in the OEM harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

Repair the engine harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the OEM harness. Refer to the OEM service manual.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the engine harness connector 2.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the coolant level RETURN pins in the engine harness ECM connector 2 to all other pins in the engine harness connector 1.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Verify the coolant level.

Guided Step 5A - Verify the coolant level with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch OFF
  • Install the shorting plug into the coolant level sensor connector
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to verify the coolant level.

Verify the Engine Coolant Level Sensor high reading is “ON” with INSITE™ electronic service tool and the Engine Coolant Level Sensor low reading is “OFF”.

INSITE™ electronic service tool reading of coolant level correct?
YES NO
No Repair

Replace the sensor. Refer to the OEM service manual.

Go to 5B

Go to 6A

Guided Step 5B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor from the harness
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from the coolant level SUPPLY pin in the sensor connector to engine block ground.

Between 4.5 and 5.5-VDC?
YES NO

  • Repair or replace the coolant level sensor. OEM service manual.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 235 is inactive.

Fault Code 235 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 29-Feb-2012


FAULT CODE 235 - L Gas Plus - Engine Coolant Level Low - Critical

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number - 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 235 active?
STEP 2. | Check the coolant level. |
 | STEP 2A. Verify the coolant level. | Coolant level normal?
STEP 3. | Check the coolant level sensor and harness. |
 | STEP 3A. Inspect the engine harness and coolant level sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 235 active?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 235 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Verify the coolant level. |
 | STEP 5A. Verify the coolant level with INSITE™ electronic service tool. | INSITE™ electronic service tool reading of coolant level correct?
 | STEP 5B. Check the sensor supply voltage. | Between 4.5 and 5.5-VDC?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 235 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6B

Guided Step 2 - Check the coolant level.

Guided Step 2A - Verify the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Remove the radiator cap or top tank reservoir and inspect the coolant level.

Coolant level normal?
YES NO
No Repair

Add coolant to the system. Cummins® Coolant Requirements and Maintenance, Bulletin 3666132.

Check for coolant leaks. Reference the Coolant Loss troubleshooting symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 2B

Go to 6A

Guided Step 3 - Check the coolant level sensor and harness.

Guided Step 3A - Inspect the engine harness and coolant level sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor from the engine harness.

Action

Inspect the engine harness and coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damage connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 6B

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damage connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 6B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the engine harness connector 1 and 2 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to the SIGNAL pins in the OEM harness sensor connector.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to the coolant level RETURN pin in the OEM harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

Repair the engine harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the OEM harness from the coolant level sensor
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the engine harness connector 2.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the coolant level RETURN pins in the engine harness ECM connector 2 to all other pins in the engine harness connector 1.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Verify the coolant level.

Guided Step 5A - Verify the coolant level with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch OFF
  • Install the shorting plug into the coolant level sensor connector
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to verify the coolant level.

Verify the Engine Coolant Level Sensor high reading is “ON” with INSITE™ electronic service tool and the Engine Coolant Level Sensor low reading is “OFF”.

INSITE™ electronic service tool reading of coolant level correct?
YES NO
No Repair

Replace the sensor. Refer to the OEM service manual.

Go to 5B

Go to 6A

Guided Step 5B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the coolant level sensor from the harness
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from the coolant level SUPPLY pin in the sensor connector to engine block ground.

Between 4.5 and 5.5-VDC?
YES NO

  • Repair or replace the coolant level sensor. Refer to the OEM service manual.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 235 is inactive.

Fault Code 235 inactive?
YES NO
No Repair

Troubleshooting procedures need to be completed again from the beginning.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 29-Feb-2012


FAULT CODE 238 - Sensor Supply Voltage Number 3 Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the gas mass flow sensor and connector pins connected to sensor supply number 3. | Dirty or damaged pins?
 | STEP 2A-1. Check for circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 238 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the gas mass flow sensor and connector pins connected to sensor supply number 3.

Conditions

  • Turn keyswitch OFF
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Inspect the gas mass flow sensor and connector pins to sensor supply number 3 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the gas mass floe sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the gas mass flow sensor. Refer to Procedure 019-085 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the gas mass flow sensor from the engine harness
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector 1 to all other pins in the engine connector 2.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the gas mass flow sensor from the engine harness
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for a pin to ground short circuit.

  • Measure the resistance between the sensor SUPPLY voltage number 3 pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor supply number 3 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 29-Feb-2012


FAULT CODE 239 - Sensor Supply Voltage Number 3 Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 239 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engien harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the gas mass flow sensor from the engine harness
  • Make sure all components connected to sensor supply number 3 circuit are disconnected.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 3 pin in engine harness ECM connector 1 to all other pins in the engine connector 2.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 3 circuit line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 239 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 29-Feb-2012


FAULT CODE 241 - Vehicle Speed Sensor Circuit - Input Signal Lost

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 241 active?
STEP 2. | Check the vehicle speed sensor. |
 | STEP 2A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 241 active?
 | STEP 2C. Check the vehicle speed sensor for proper adjustment. | Adjustment 1/2 to 3/4 of a turn out from the gear?
 | STEP 2D. Check the vehicle speed sensor resistance. | Between 750 and 1500 ohms?
 | STEP 2E. Check the vehicle speed sensor for a short circuit to ground. | More than 100k ohms?
 | STEP 2F. Check the vehicle speed sensor for a short circuit between coils. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 241 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 241 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the vehicle speed sensor.

Guided Step 2A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the sensor. Refer to Procedure 019-090 in Section 19. Refer to Procedure 019-091 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 241 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4B

Guided Step 2C - Check the vehicle speed sensor for proper adjustment.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for proper adjustment.

Verify that the correct number of tailshaft teeth is entered in INSITE™ electronic service tool.

Adjustment ½ to ¾ of a turn out from the gear?
YES NO
No Repair

Adjust the sensor. Refer to Procedure 019-091 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the vehicle speed sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the sensor resistance.

  • Measure the resistance from the vehicle speed sensor (+) pin to the vehicle speed sensor (-) pin in the vehicle speed sensor connector, sensor side.
  • Repeat the resistance check in the second coil (if applicable).

Between 750 and 1500 ohms?
YES NO
No Repair

Replace the sensor.

  • Refer to Procedure 019-090 in Section 19.
  • Refer to Procedure 019-091 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check the vehicle speed sensor for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the vehicle speed sensor
  • Make sure the sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the vehicle speed sensor (+) pin in the vehicle speed sensor connector, sensor side, to engine block ground.
  • Repeat the short-circuit-to-ground check in the second coil (if applicable).

More than 100k ohms?
YES NO
No Repair

Replace the sensor.

  • Refer to Procedure 019-090 in Section 19.
  • Refer to Procedure 019-091 in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Check the vehicle speed sensor for a short circuit between coils.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance from the vehicle speed sensor (+) pin in the vehicle speed sensor connector to the vehicle speed sensor (+) pin in the second vehicle speed sensor connector, sensor side.

More than 100k ohms?
YES NO
No Repair

Replace the sensor.

  • Refer to Procedure 019-090 in Section 19.
  • Refer to Procedure 019-091 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 241 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the vehicle speed sensor
  • Disconnect engine harness connector 2 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the vehicle speed sensor (+) pin in the engine harness ECM connector to the vehicle speed sensor (+) pin in the sensor harness connector.
  • Measure the resistance from the vehicle speed sensor (-) pin in the engine harness ECM connector to the vehicle speed sensor (-) pin in the sensor harness connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness

Repair the engine harness.

  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the vehicle speed sensor (+) pin in the engine harness ECM connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the vehicle speed sensor (+) pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the vehicle speed sensor (-) pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the vehicle speed sensor (+) pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.
  • Measure the resistance from the vehicle speed sensor (-) pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 241 is inactive.

Fault Code 241 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode will possibly have been detected.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 29-Feb-2012


FAULT CODE 242 - Vehicle Speed Sensor Circuit - Tampering Has Been Detected

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify vehicle speed settings. |
 | STEP 1A. Check vehicle speed settings with INSITE™. | Trim sets correct?
STEP 2. | Check the vehicle speed sensor. |
 | STEP 2A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 242 active?
 | STEP 2C. Check the vehicle speed sensor for proper adjustment. | 1/2 to 3/4 of a turn out from the gear?
 | STEP 2D. Check the vehicle speed sensor resistance. | 750 to 1500 ohms?
 | STEP 2E. Check the vehicle speed sensor for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check the vehicle speed sensor for a short circuit between coils. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 242 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 242 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 4E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 242 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify vehicle speed settings.

Guided Step 1A - Check vehicle speed settings with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check vehicle speed settings with INSITE™electronic service tool.

  • Check that the vehicle speed settings are correct.
  • Compare the vehicle speed on the bus is in relationship to the INSITE™ electronic service tool reading for vehicle speed.

Trim sets correct?
YES NO
No Repair

Adjust settings to vehicle specification. Refer to the OEM service manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the vehicle speed sensor.

Guided Step 2A - Inspect the OEM harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.
  • Replace the sensor. Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 242 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 5B

Guided Step 2C - Check the vehicle speed sensor for proper adjustment.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for proper adjustment.

  • Verify that the vehicle speed sensor is adjusted properly.

1/2 to 3/4 of a turn out from the gear?
YES NO
No Repair

Adjust the sensor. Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check the vehicle speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the (+) pin to the (-) pin in the vehicle speed sensor connector.
  • Repeat the resistance check in the second coil, if applicable.

750 to 1500 ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 2E

Go to 5A

Guided Step 2E - Check the vehicle speed sensor for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the (+) pin in the vehicle speed sensor connector and to engine block ground.
  • Repeat the short-circuit-to-ground check in the second coil, if applicable.

Greater than 100k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 2F

Go to 5A

Guided Step 2F - Check the vehicle speed sensor for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance from the (+) pin in the vehicle speed sensor connector to the (+) pin in the second vehicle speed sensor connector.

Greater than 100k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-090 or Refer to Procedure 019-091 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin OEM connector.

Action

Inspect the OEM harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM service manual.
  • Replace the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 242 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin OEM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the vehicle speed sensor (+) pin in the OEM harness sensor connector to the vehicle speed sensor (+) pin in the 31-pin OEM connector.
  • Measure the resistance from the vehicle speed sensor (-) pin in the OEM harness sensor connector to the vehicle speed sensor (-) pin in the 31-pin OEM connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin OEM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the vehicle speed sensor (+) pin in the 31-pin OEM connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31-pin OEM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the vehicle speed sensor (+) pin in the 31-pin OEM connector to all other pins in the connector.
  • Measure the resistance from the vehicle speed sensor (-) pin in the 31-pin OEM connector to all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 242 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 31-pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance from the vehicle speed sensor (+) pin in the engine harness ECM connector to the vehicle speed sensor (+) pin in the 31-pin OEM connector.
  • Measure the resistance from the vehicle speed sensor (-) pin in the engine harness ECM connector to the vehicle speed sensor (-) pin in the 31-pin OEM connector.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM
  • Disconnect the engine harness from the OEM harness at the 31-pin OEM connector.

Action

n/a

  • Measure the resistance from the vehicle speed sensor (+) pin in the engine harness ECM connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the vehicle speed sensor (+) pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the vehicle speed sensor (-) pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the vehicle speed sensor (+) pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.
  • Measure the resistance from the vehicle speed sensor (-) pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE electronic service tool to set speed and verify speed while driving the vehicle.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 242 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 249 - Compressor Inlet Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 2. | Check the compressor inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the compressor inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 175 ohms to 274 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 249 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the compressor inlet temperature sensor and circuit.

Guided Step 2A - Inspect the compressor inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor inlet temperature sensor from the engine harness.

Action

Inspect the engine harness and compressor inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor inlet temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the compressor inlet temperature sensor connector.

175 ohms to 274 ohms?
YES NO

Reference the Shop Talk section for specifications.

Replace the humidity/temperature sensor. Refer to Procedure 019-356 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the compressor inlet temperature sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the compressor inlet temperature RETURN pin and the ECM connector 1 RETURN pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the compressor inlet temperature sensor from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the compressor inlet temperature sensor SIGNAL pin and the ECM connector 1 SIGNAL pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the compressor inlet temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the compressor inlet temperature SIGNAL pin in the engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the compressor inlet temperature SIGNAL pin in the engine harness and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 249 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 254 - B LPG - Fuel Shutoff Valve Command Circuit - Shorted Low

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 254 inactive?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | 12 to 20 ohms?
 | STEP 2B-1. Check for a short to ground in the fuel shutoff valve. |
 | STEP 2C. Check the fuel shutoff valve supply voltage, supply line, and return circuit. | Greater than 5-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 254 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 254 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive and intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the fuel shutoff valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check ffuel shutoff valve resistance.

  • Measure the resistance between the fuel shutoff valve OUTPUT pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

12 to 20 ohms?
YES NO
No Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

Go to 2C

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a fuel shutoff valve output short to ground.

  • Measure the resistance between the fuel shutoff valve SUPPLY pin and ground at the fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve supply voltage and return circuit.

  • Measure the voltage between the fuel shutoff valve OUTPUT pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a pin ground short.

  • Measure the resistance between the fuel shutoff valve OUTPUT pin in engine harness ECM connector 1 and engine block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the fuel shutoff valve output line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel shutoff valve from engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel shutoff valve SUPPLY pin in engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the fuel shutoff valve SUPPLY pin in engine harness ECM connector 1 to all other pins in engine connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fuel shutoff valve supply line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 254 - Gas Plus - Fuel Shutoff Valve Command Circuit - Shorted Low

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 254 inactive?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | Between 12 and 20 ohms?
 | STEP 2B-1. Check for a short to ground in the fuel shutoff valve. |
 | STEP 2C. Check the fuel shutoff valve supply voltage, supply line, and return circuit. | Greater than 10-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 254 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 254 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check the fuel shutoff valve and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the fuel shutoff valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit in the fuel shutoff valve.

  • Measure the resistance between the fuel shutoff valve output pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 12 and 20 ohms?
YES NO
No Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

Go to 2C

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a short to ground in the fuel shutoff valve.

  • Measure the resistance between the fuel shutoff valve SUPPLY pin and ground at the fuel shutoff valve connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel shutoff valve from the engine harness
  • Turn keyswitch ON.

Action

Check the fuel shutoff valve supply voltage, supply line and return circuit.

  • Measure the voltage between the fuel shutoff valve output pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector of the engine harness.

Greater than 10-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check the ECM and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the fuel shutoff valve output pin in engine harness ECM connector 1 and engine block ground.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the fuel shutoff valve output line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM
  • Disconnect the fuel shutoff valve from engine harness.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the fuel shutoff valve SUPPLY pin in engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the fuel shutoff valve SUPPLY pin in engine harness ECM connector 1 to all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fuel shutoff valve supply line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 254 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 20-Feb-2012


FAULT CODE 255 - B LPG - Fuel Shutoff Valve Command Circuit - Shorted High

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 255 inactive?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | 12 to 20 ohms?
 | STEP 2C. Check the fuel shutoff valve supply voltage, supply line and return circuit. | Greater than 12-VDC?
 | STEP 2D. Check for an open circuit in the fuel shutoff valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 255 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 255 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the fuel shutoff valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check fuel shutoff vlave resistance.

  • Measure the resistance between the fuel shutoff valve output pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

12 to 20 ohms?
YES NO
No Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.
  • Engage starter and crank the engine.

Action

Check the fuel shutoff valve supply voltage and return circuit.

  • Measure the voltage between the fuel shutoff valve SUPPLY pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 12-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel shutoff valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel shutoff valve RETURN pin and the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open pin to ground circuit on the return line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the fuel shutoff valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 fuel shutoff valve SUPPLY pin and the engine harness fuel shutoff valve connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fuel shutoff valve supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel shutoff valve from engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel shutoff valve SUPPLY pin in engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the fuel shutoff valve SUPPLY pin in engine harness ECM connector 1 to all other pins in engine connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fuel shutoff valve supply line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 255 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 255 - Gas Plus - Fuel Shutoff Valve Command Circuit - Shorted High

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 255 inactive?
STEP 2. | Check the fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel shutoff valve. | 12 to 20 ohms?
 | STEP 2C. Check the fuel shutoff valve supply voltage, supply line and return circuit. | Greater than 12 VDC?
 | STEP 2D. Check for an open circuit in the fuel shutoff valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 255 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 255 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve and circuit.

Guided Step 2A - Inspect the fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Inspect the enigne harness and fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the fuel shutoff valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check fuel shutoff valve resistance.

  • Measure the resistance between the fuel shutoff valve output pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

12 to 20 ohms?
YES NO
No Repair

Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel shutoff valve supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.
  • Turn keyswitch ON.
  • Engage starter and crank the engine.

Action

Check the fuel shutoff valve supply voltage and return circuit.

  • Measure the voltage between the fuel shutoff valve SUPPLY pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 12 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel shutoff valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel shutoff valve RETURN pin and the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open pin to ground circuit on the return line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, or replace the fuel shutoff valve solenoid, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM

Action

Inspect the engine harness and ECM connector 1 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 fuel shutoff valve SUPPLY pin and the engine harness fuel shutoff valve connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fuel shutoff valve supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel shutoff valve from engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel shutoff valve SUPPLY pin in engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the fuel shutoff valve SUPPLY pin in engine harness ECM connector 1 to all other pins in engine connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fuel shutoff valve supply line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit responseafter 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 255 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 256 - Compressor Inlet Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 2. | Check the compressor inlet temperature sensor and circuit. |
 | STEP 2A. Inspect the compressor inlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 2C. Check for circuit response | Fault Code 256 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 249 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the compressor inlet temperature sensor and circuit.

Guided Step 2A - Inspect the compressor inlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor inlet temperature sensor from the engine harness.

Action

Inspect the engine harness and compressor inlet temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor inlet temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor inlet temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

A damaged sensor has been detected.

Replace the humidity/temperature sensor. Refer to Procedure 019-356 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the compressor inlet temperature sensor from the harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the compressor inlet temperature SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the compressor inlet temperature SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the compressor inlet temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the compressor inlet temperature SIGNAL pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 256 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Feb-2012


FAULT CODE 263 - Fuel Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 2. | Check the fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 175 ohms to 274k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 263 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 263 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel temperature sensor and circuit.

Guided Step 2A - Inspect the fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the engine harness and fuel temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurment techniques. Refer to Procedure 019-360 in Section 19.

175k ohms to 274k ohms?
YES NO
No Repair

Replace the fuel temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector 1 and connector 2 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel temperature sensor from engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel temperature RETURN pin in the ECM connector 1 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel temperature sensor from engine harness.

Action

Check for an open circuit.

  • Measure the resistance from the fuel temperature SIGNAL pin in the ECM connector 2 SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the fuel temperature sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel temperature SIGNAL pin in engine harness and all other pins in the ECM connector 2.
  • Measure the resistance from the fuel temperature SIGNAL pin in engine harness and all other pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit responseafter 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 263 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 263 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 265 - Fuel Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 265 inactive?
STEP 2. | Check the fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 265 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 265 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 265 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel temperature sensor and circuit.

Guided Step 2A - Inspect the fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel temperature sensor from the engine harness.

Action

Inspect the engine harness and fuel temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Read the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

A damaged sensor has been detected.

Replace the fuel temperature sensor. Refer to Procedure 019-153 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ecmengine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connectors.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance from the fuel temperature SIGNAL pin in engine harness ECM connector 2 to all other pins in the engine connector 2.
  • Measure the resistance from the fuel temperature SIGNAL pin in engine harness ECM connector 2 to all other pins in the engine connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the fuel temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the fuel temperature SIGNAL pin in engine harness ECM connector 2 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit responseafter 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 265 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 265 is inactive.

Fault Code 265 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 336 - Idle Speed Control Valve Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 336 inactive?
STEP 2. | Check the idle speed control valve and circuit. |
 | STEP 2A. Inspect the idle speed control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the idle speed control valve. | 16 to 14 ohms?
 | STEP 2C. Check the idle speed control valve supply voltage, supply line, and return circuit. | Greater than 3-VDC?
 | STEP 2D. Check for an open circuit in the idle speed control valve return circuit. | Less than 10 ohms?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 336 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 336 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 336 inactive?
YES NO

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the idle speed control valve and circuit.

Guided Step 2A - Inspect the idle speed control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle speed control valve from the engine harness.

Action

Inspect the engine harness and idle speed control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness connector, or pins, if possible.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-104 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the idle speed control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle speed control valve from the engine harness.

Action

Check the idle speed control valve resistance.

  • Measure the resistance between the idle speed control valve SUPPLY pin and the idle speed control valve RETURN pin at idle speed control valve connector.

Refer to the circuit description or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

6 to 14 ohms?
YES NO
No Repair

Replace the idle speed control valve. Refer to Procedure 019-104 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the idle speed control valve supply voltage, supply line. and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle speed control valve from the engine harness.
  • Turn keyswitch ON.
  • Engage the starter and crank the engine.

Action

Check the idle speed control valve supply voltage and return circuit.

  • Measure the voltage between the idle speed control valve output pin and the idle speed control valve RETURN pin at the idle speed control valve connector of the engine harness.

Refer to the circuit description or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the idle speed control valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle speed control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle speed control valve RETURN pin in the engine harness and the engine block ground.

Refer to the circuit description or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pin to ground circuit on the RETURN line has been detected in the engine harness.

Clean, repair, or replace the engine harness, if possible.

Refer to Procedure 019-204 in Sectio 19.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 from the engine control module.

Action

Inspect the engine harness and engine control module connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pin?
YES NO

A damaged connection has been detected in the engine control module connector 1 or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 from the engine control module.
  • Disconnect the idle speed control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness engine control module engine connector 1 idle speed control valve SUPPLY pin and the engine harness idle speed control valve connector SUPPLY pin.

Refer to the circuit description or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open idle speed control valve SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 and connector 2 from the engine control module.
  • Disconnect the idle speed control valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the idle speed control valve SUPPLY pin in the engine harness engine control module engine connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the idle speed control valve SUPPLY pin in the engine harness engine control module engine connector 1 and all other pins in the engine connector 2.

Refer to the circuit description or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the idle speed control valve SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 336 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear thee fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 336 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inacrive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 20-Feb-2012


FAULT CODE 337 - Idle Speed Control Valve Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 337 inactive?
STEP 2. | Check the idle speed control valve and circuit. |
 | STEP 2A. Inspect the idle speed control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the idle speed control valve. | 6 to 14 ohms?
 | STEP 2B-1. Check for a short to ground in the idle speed control valve. |
 | STEP 2C. Check the idle speed control valve supply voltage, supply line and return circuit. | Greater than 3-VDC?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 337 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 337 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 337 inactive?
YES NO

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the idle speed control valve and circuit.

Guided Step 2A - Inspect the idle speed control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle speed control valve from the engine harness.

Action

Inspect the engine harness and idle speed control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-104 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the idle speed control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle speed control valve from the engine harness.

Action

Check the idle speed control valve resistance.

  • Measure the resistance between the idle speed control valve SUPPLY pin and the idle speed control valve RETURN pin at idle speed control valve connector.

Use the circuit description or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

6 to 14 ohms?
YES NO
No Repair

Replace the idle speed control valve. Refer to Procedure 019-104 in Section 19.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the idle speed control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle speed control valve from the engine harness.

Action

Check for a idle speed control valve output short to ground.

  • Measure the resistance between the idle speed control valve SUPPLY pin and ground at the idle speed control valve connector.

Refer to the circuit description or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Replace the idle speed control valve. Refer to Procedure 019-104 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the idle speed control valve supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle speed control valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the idle speed control valve supply voltage and return circuit.

  • Measure the voltage between the idle speed control valve output pin and the idle speed control valve RETURN pin at the idle speed control valve connector of the engine harness.

Refer to the circuit description or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 from the engine control module.

Action

Inspect the engine harness and engine control module connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pin?
YES NO

A damaged connection has been detected in the engine control module connector 1 or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 from the engine control module.
  • Disconnect the idle speed control valve from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine idle speed control valve output pin in the engine harness engine control module engine connector 1 and ground.

Refer to the circuit description or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100K ohms?
YES NO
No Repair

A pin to ground short circuit on the idle speed control valve output line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 and connector 2 from the engine control module.
  • Disconnect the idle speed control valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the idle speed control valve SUPPLY pin in the engine harness engine control module engine connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the idle speed control valve SUPPLY pin in the engine harness engine control module engine connector 1 and all other pins in the engine connector 2.

Refer to the circuit description or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the idle speed control valve SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 337 inactive?
YES NO

None. The removal reinstallation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 337 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inacrive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 343 - ECM - Warning Internal Hardware Failure

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active?
 | STEP 1B. Check the power supply. | Constant +12 volt power supply to the ECM?
 | STEP 1C. Check ECM for a short circuit to ground. | More than 100k ohms?
 | STEP 1D. Calibrate the ECM. | ECM recalibrated successfully?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Recycle the power to the ECM using the keyswitch.

Fault Code 343 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the OEM connector as a possible source of an intermittent power supply.

Constant +12 volt power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 31-pin OEM connector. Refer to the OEM service manual.

Go to 1C

Go to 2A

Guided Step 1C - Check ECM for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

Refer to the circuit description or wiring diagram for pin identification.

Use the following procedure for general reisistance measurment techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

ECM recalibrated successfully?
YES NO
No Repair

Active fault codes present.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 343 is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 346 - ECM Software Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 346 active?
 | STEP 1B. Check the power supply. | Constant +12-VDC power supply to the ECM?
 | STEP 1C. Check the ECM ground. | More than 100k ohms?
 | STEP 1D. Calibrate the ECM. | Fault Code 346 active after recalibration?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 346 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electroninc service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2B

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM
  • Check the OEM connector as a possible source of an intermittent power supply.
  • Make certain the power supply to the ECM is constant and not intermittent.

Constant +12-VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to the 31-pin OEM connector. Refer to the OEM service manual.

Go to 1C

Go to 2A

Guided Step 1C - Check the ECM ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Verify short circuit to ground.

  • Measure the resistance from engine block ground to all pins in the ECM connector ports.
  • Measure the resistance from battery (-) post to all pins in the ECM connector ports.

Refer to the circuit description or wiring diagram for pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Calibrate the ECM.

  • Refer to Procedure 019-032 in Section 19.

Fault Code 346 active after recalibration?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO

.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

n/a

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 352 - B and C Gas Plus - Sensor Supply Voltage Number 1 Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 352 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the fuel pressure/temperature sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine oil pressure/temperature sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the humidity sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

Go to 2B

Go to 4B

Guided Step 2B - Inspect the fuel pressure/temperature sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure/temperature sensor from the engine harness.

Action

inspect the fuel pressure/temperaturesensor harness and engine sensorconnector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit responseafter 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the fuel pressure/temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 2C

Go to 4B

Guided Step 2C - Inspect the engine oil pressure/temperature sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.

Action

inspect the engine oilpressure/temperature sensor harness andengine sensor connector pins for thefollowing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the engine oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2D

Go to 4B

Guided Step 2D - Inspect the humidity sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the humidity sensor harness andengine sensor connector pins for thefollowing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the humidity sensor. Refer to Procedure 019-356 in Section 19.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel pressure/temperature sensor, engine oil pressure/temperature sensor, intake manifold pressure/temperature sensor, and humidity sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 to all pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the fuel pressure/temperature sensor, engine oil pressure/temperature sensor, intake manifold pressure/temperature sensor, humidity sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor supply number 1 pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the apprporiate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Codes 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 352 - L Gas Plus - Sensor Supply Voltage Number 1 Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the fuel pressure/temperature sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine oil pressure/temperature sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the humidity sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the air inlet restriction pressure sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. Inspect the camshaft position sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
 | STEP 2G. Inspect the crankshaft position sensor and connector pins connected to sensor supply number 1. | Dirty or damaged pins?
 | STEP 2G-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 352 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-099 in Section 19.

Go to 2B

Go to 4B

Guided Step 2B - Inspect the fuel pressure/temperature sensor and connector pins connected to sensor SUPPLY number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure/temperature sensor from the engine harness.

Action

Inspect the fuel pressure/temperature sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the fuel pressure/temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 2C

Go to 4B

Guided Step 2C - Inspect the engine oil pressure sensor and connector pins connected to sensor SUPPLY number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine oil pressure sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2D

Go to 4B

Guided Step 2D - Inspect the humidity sensor and connector pins connected to sensor supply number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the humidity sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the humidity sensor. Refer to Procedure 019-356 in Section 19.

Go to 2E

Go to 4B

Guided Step 2E - Inspect the air inlet restriction pressure sensor and connector pins connected to sensor SUPPLY number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the air inlet restriction pressure sensor from the engine harness.

Action

Inspect the air inlet restriction pressure sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the air inlet restriction pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the air inlet restriction pressure sensor. Refer to Procedure 019-433 in Section 19.

Go to 2F

Go to 4B

Guided Step 2F - Inspect the camshaft position sensor and connector pins connected to sensor SUPPLY number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the camshaft position sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in Section 19.

Go to 2G

Go to 4B

Guided Step 2G - Inspect the crankshaft position sensor and connector pins connected to sensor SUPPLY number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the crankshaft position sensor harness and engine sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2G-1

Guided Step 2G-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in Section 19.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness connectors and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel pressure/temperature sensor, engine oil pressure sensor, intake manifold pressure/temperature sensor, humidity sensor air inlet restriction sensor, camshaft position sensor, and crankshaft position sensor from the engine harness.
  • Disconnect all components connected to sensor SUPPLY number 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 to all pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor SUPPLY number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the fuel pressure/temperature sensor, engine oil pressure sensor, intake manifold pressure/temperature sensor, humidity sensor, air inlet restriction sensor, camshaft position sensor, and crankshaft position sensor from the engine harness.
  • Disconnect all components connected to sensor SUPPLY number 1.

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 and ground.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor SUPPLY number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the apprporiate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Codes 352 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 14-May-2012


FAULT CODE 354 - Intake Manifold Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 355 active and Fault Code 354 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 354 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 354 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 354 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 355 active and Fault Code 354 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 active?
YES NO

A damaged sensor has been detected

Replace the intake manifold pressure sensor. Refer to Procedure 019-354 in Section 19.

 No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

  • .

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the intake manifold pressure sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness to all other pins in the engine connector 1.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness connector 1 to all pins in engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure sensor 5 Volt SUPPLY pin in engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the intake manifold pressure 5 Volt SUPPLY pin in engine harness connector 1 and all pins in engine harness ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 354 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 355 - Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 355 active?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 354 active and Fault Code 355 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 355 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 355 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 355 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the harness, replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 5 volt SUPPLY pin and the intake manifold pressure RETURN pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.5 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake pressure SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 354 active and Fault Code 355 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES NO

A damaged sensor has been detected

Replace the intake manifold pressure sensor. Refer to Procedure 019-354 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins.

Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the intake manifold pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin and the intake manifold pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in engine harness.

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector 1 and all other pins in the connector 1.
  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector 1 and all pins in connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal circuit has been detected in the engine harness.

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the intake manifold pressure SIGNAL pin in engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin to ground short circuit on the signal circuit has been detected in the engine harness.

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 inactive?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 355 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Mar-2016


FAULT CODE 386 - B and C Gas Plus - Sensor Supply Voltage 5 Volt (1) - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel pressure/temperature sensor, the engine oil pressure/temperature sensor, the intake manifold pressure/temperature sensor and humidity sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 386 - L Gas Plus - Sensor Supply Voltage 5 Volt (1) - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel pressure/temperature sensor, the engine oil pressure sensor, the intake manifold pressure/temperature sensor, the humidity sensor, the compressor inlet sensor, the camshaft position sensor, and crankshaft position sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 1.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the sensor SUPPLY number 1 pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 386 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 387 - Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 387 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 387 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 387 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 387 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.
  • Make sure all components connected to the accelerator pedal supply are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance from the accelerator pedal SUPPLY pin in engine harness ECM connector 2 to all other pins in the ECM connector 2.
  • Measure the resistance from the accelerator pedal SUPPLY pin in engine harness ECM connector 2 to all pins in the ECM connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A pin-to-pin short circuit on the accelerator pedal supply line has been detected in the engine harness.

Repair the damaged pins.

Repair or replace the engine harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to the OEM service manual.

 No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 387 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Codes 387 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 415 - B and C Gas Plus - Oil Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading is correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute, add atmospheric pressure to gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical oil pressure gauge.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Use the following procedure in the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 007-052 in Section 7.
  • Use the following procedure in the Troubleshooting and Repair Manual B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 007-052 in Section 7.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 415 is inactive.

If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 415 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

If fault code remains active, go to the Low Oil Pressure troubleshooting symptom tree in Section TS.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 415 - L Gas Plus - Oil Pressure Low - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Sensor reading correct?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. The pressure sensor displays in absolute. Add atmospheric pressure to gauge reading.

Sensor reading is correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-066 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check the engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical oil pressure gauge.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Use the following procedure in the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 007-052 in Section 7.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 415 is inactive.

If the fault was at a particular speed, run the engine at that speed to verify the problem is corrected.

Fault Code 415 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

If fault code remains active, go to the Low Oil Pressure troubleshooting symptom tree in Section TS.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 22-May-2012


FAULT CODE 421 - Engine Oil Temperature High - Over Temperature Warning

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 421 active?
 | STEP 1B. Verify engine oil temperature is high. | Engine oil temperature high?
STEP 2. | Check the engine oil pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and engine oil pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 421 active?
 | STEP 2C. Check the resistance of the sensor. | 300 to 90k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 421 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 421 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3B

Guided Step 1B - Verify engine oil temperature is high.

Conditions

  • Turn keyswitch ON.

Action

Verify engine oil temperature is high.

  • Verify engine oil temperature by using the mechanical gauge.

Engine oil temperature high?
YES NO

Reference the Lubricating Oil Temperature Above Specifications troubleshooting symptom chart in Section TS of the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206 or the Troubleshooting and Repair Manual B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine oil pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and engine oil pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the engine harness from the engine oil pressure/temperature sensor.

Action

Inspect the engine harness and oil pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-155 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 421 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the engine oil pressure/temperature sensor from the engine harness.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine oil temperature SIGNAL pin to the engine oil pressure/temperature RETURN pin in the engine oil pressure/temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

300 to 90k ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 421 is inactive.

Fault Code 421 inactive
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Feb-2012


FAULT CODE 422 - B and C Gas Plus - Engine Coolant Level Sensor Circuit - Data Not Correct

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number - 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 422 active?
STEP 2. | Check the coolant level. |
 | STEP 2A. Verify the coolant level. | Coolant level normal?
STEP 3. | Check the coolant level sensor and harness. |
 | STEP 3A. Inspect the engine harness and coolant level sensor connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 422 active?
STEP 4. | Check the ECM and harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 422 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Verify the coolant level. |
 | STEP 5A. Verify the coolant level with INSITE™ electronic service tool. | Is the INSITE™ electronic service tool reading of coolant level correct?
 | STEP 5B. Check the sensor supply voltage. | 4.5 to 5.5-VDC?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 422 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6B

Guided Step 2 - Check the coolant level.

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
Guided Step 2A - Verify the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Remove the radiator cap or top tank reservoir and inspect the coolant level.

Coolant level normal?
YES NO
No Repair

Add coolant to the system. Refer to the Cummins Coolant Requirements and Maintenance, Bulletin 3666132.

Go to 2B

Go to 6A

Guided Step 3 - Check the coolant level sensor and harness.

Guided Step 3A - Inspect the engine harness and coolant level sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the engine harness.

Action

Inspect the engine harness and coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 6B

Guided Step 4 - Check the ECM and Harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM . Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4B

Go to 6A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 6B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness connector 1 and 2 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to the SIGNAL pins in the OEM harness sensor connector.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to the coolant level RETURN pin in the OEM harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-202 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the engine harness connector 2.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the coolant level RETURN pins in the engine harness ECM connector 2 to all other pins in the engine harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 - Verfiy the coolant level.

Guided Step 5A - Verify the coolant level with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch OFF.
  • Install the shorting plug into the coolant level sensor connector.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to verify the coolant level.

Verify the engine coolant level sensor high reading is ON with INSITE™ electronic service tool and the engine coolant level sensor low reading is OFF.

Is the INSITE™ electronic service tool reading of coolant level correct?
YES NO
No Repair

Replace the sensor. Refer to the OEM service manual.

Go to 5B

Go to 6A

Guided Step 5B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from the coolant level SUPPLY pin in the sensor connector to engine block ground.

4.5 to 5.5-VDC?
YES NO

  • Repair or replace the coolant level sensor. Refer to the OEM service manual.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 422 is inactive.

Fault Code 422 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 422 - L Gas Plus - Engine Coolant Level Sensor Circuit - Data Not Correct

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number - 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 422 active?
STEP 2. | Check the coolant level. |
 | STEP 2A. Verify the coolant level. | Coolant level normal?
STEP 3. | Check the coolant level sensor and harness. |
 | STEP 3A. Inspect the engine harness and coolant level sensor connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 422 active?
STEP 4. | Check the ECM and harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 422 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Verify the coolant level. |
 | STEP 5A. Verify the coolant level with INSITE™ electronic service tool. | Is the INSITE™ electronic service tool reading of coolant level correct?
 | STEP 5B. Check the sensor supply voltage. | 4.5 to 5.5-VDC?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 422 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 6B

Guided Step 2 - Check the coolant level.

Guided Step 2A - Verify the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant level.

  • Remove the radiator cap or top tank reservoir and inspect the coolant level.

Coolant level normal?
YES NO
No Repair

Add coolant to the system. Refer to the Cummins Coolant Requirements and Maintenance, Bulletin 3666132.

Go to 2B

Go to 6A

Guided Step 3 - Check the coolant level sensor and harness.

Guided Step 3A - Inspect the engine harness and coolant level sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the engine harness.

Action

Inspect the engine harness and coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 6B

Guided Step 4 - Check the ECM and harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ecmconnector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM . Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4B

Go to 6A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 422 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 6B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness connector 1 and 2 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to the SIGNAL pins in the OEM harness sensor connector.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to the coolant level RETURN pin in the OEM harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-202 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the OEM harness. Refer to the OEM service manual..

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance from the coolant level SIGNAL pins in the engine harness ECM connector 1 to all other pins in the engine harness connector 2.
  • Measure the resistance from the coolant level RETURN pin in the engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the coolant level RETURN pins in the engine harness ECM connector 2 to all other pins in the engine harness connector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or OEM harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 5A

Go to 6A

Guided Step 5 -

Guided Step 5A - Verify the coolant level with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch OFF.
  • Install the shorting plug into the coolant level sensor connector.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to verify the coolant level.

Verify the engine coolant level sensor high reading is ON with INSITE™ electronic service tool and the engine coolant level sensor low reading is OFF.

Is the INSITE™ electronic service tool reading of coolant level correct?
YES NO
No Repair

Replace the sensor. Refer to the OEM service manual.

Go to 5B

Go to 6A

Guided Step 5B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage from the coolant level SUPPLY pin in the sensor connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.5 to 5.5-VDC?
YES NO

  • Repair or replace the coolant level sensor. Refer to the OEM service manual.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 422 is inactive.

Fault Code 422 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 431 - Integrated Sensor Switch - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

On automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the integrated sensor switch. |
 | STEP 1A. Verify the integrated sensor switch is connected to the OEM harness. | Integrated sensor switch is connected to the OEM harness?
 | STEP 1B. Inspect the integrated sensor switch connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the integrated sensor switch for an open circuit. | Less than 125 ohms?
 | STEP 1D. Check the integrated sensor switch for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 2. | Check the wiring harnesses. |
 | STEP 2A. Check the wiring harnesses for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the harnesses for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the integrated sensor switch.

Guided Step 1A - Verify the integrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the integrated sensor switch is connected to the harness.

  • Verify the integrated sensor switch is connected to the OEM harness.

Integrated sensor switch is connected to the OEM harness?
YES NO
No Repair

Connect the integrated sensor switch to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the integrated sensor switch connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Inspect the oem harness and integrated sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the harness, connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the integrated sensor switch for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation switch on-idle SIGNAL pin and switch RETURN pin in the integrated sensor switch connector with the pedal or lever released.
  • Measure the resistance between the idle validation switch off-idle SIGNAL pin and switch RETURN pin in the integrated sensor switch connector with the pedal or lever depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 125 ohms?
YES NO
No Repair

Refer to the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check the integrated sensor switch for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation switch on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the integrated sensor switch connector with the pedal or lever released and depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the wiring harnesses.

Guided Step 2A - Inspect the wiring harnesses for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation switch on-idle SIGNAL pin on the integrated sensor switch connector of the OEM harness to the switch RETURN pin in the integrated sensor switch connector of the OEM harness.
  • Measure the voltage from the idle validation switch off-idle SIGNAL pin on the integrated sensor switch connector of the OEM harness to the switch RETURN pin in the integrated sensor switch connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 2.

Action

Inspect the engine harness and ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the harness, connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the harnesses for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 2.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the wiring harnesses between the ECM connector and the integrated sensor switch connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the wiring harnesses between the ECM connector and the integrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the chassis ground and the integrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 2.
  • Disconnect the integrated sensor switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation switch on-idle SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the idle validation switch on-idle SIGNAL pin in engine harness and all other pins in the ECM connector 2.
  • Measure the resistance between the idle validation switch off-idle SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the idle validation switch off-idle SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 431 - Non-Integrated Sensor Switch - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

On automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the non-integrated sensor switch. |
 | STEP 1A. Verify the non-integrated sensor switch is connected to the OEM harness. | Non-integrated sensor switch is connected to the OEM harness?
 | STEP 1B. Inspect the non-integrated sensor switch and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the non-integrated sensor switch for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check the non-integrated sensor switch for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery positive (+) circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the non-integrated sensor switch.

Guided Step 1A - Verify the non-integrated sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the non-integrated sensor switch is connected to the harness.

  • Verify the non-integrated sensor switch is connected to the OEM harness.

Non-integrated sensor switch is connected to the OEM harness?
YES NO
No Repair

Connect the non-integrated sensor switch to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the non-integrated sensor switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the non-integrated sensor switch from the OEM harness.

Action

Inspect the OEM harness and non-integrated sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or non-integrated sensor switch connector.

Repair the damaged pins. Repair or replace the harness, connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the non-integrated sensor switch for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the non-integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation switch on-idle SIGNAL pin and switch RETURN pin in the non-integrated sensor switch connector with the pedal or lever released.
  • Measure the resistance between the idle validation switch off-idle SIGNAL pin and switch RETURN pin in the non-integrated sensor switch connector with the pedal or lever depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Refer to the OEM service manual.

Go to 1D

Repair complete

Guided Step 1D - Check the non-integrated sensor switch for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the non-integrated sensor switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation switch on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the non-integrated sensor switch connector with the pedal or lever released and depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the wiring harnesses.

Guided Step 2A - Inspect the wiring harnesses for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the non-integrated sensor switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation switch on-idle SIGNAL pin on the non-integrated sensor switch connector of the OEM harness to the switch RETURN pin in the non-integrated sensor switch connector of the OEM harness.
  • Measure the voltage from the idle validation switch off-idle SIGNAL pin on the non-integrated sensor switch connector of the OEM harness to the switch RETURN pin in the non-integrated sensor switch connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 2.

Action

Inspect the engine harness and ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector 2.

Repair the damaged pins. Repair or replace the harness, connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the wiring harnesses for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector 2.
  • Disconnect the non-integrated sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the wiring harnesses between the ECM connector and the non-integrated sensor switch connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the wiring harnesses between the ECM connector and the non-integrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness or engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the non-integrated sensor switch from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the OEM harness switch RETURN wire in the OEM harness between the chassis ground and the non-integrated sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 2.
  • Disconnect the non-integrated sensor switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation switch on-idle SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the idle validation switch on-idle SIGNAL pin in engine harness and all other pins in the ECM connector 2.
  • Measure the resistance between the idle validation switch off-idle SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the idle validation switch off-idle SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness or engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 431 - Solid-State Sensor Switch - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

On automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the solid-state sensor switch. |
 | STEP 1A. Verify the solid-state sensor switch is connected to the OEM harness. | Solid-state sensor switch is connected to the OEM harness?
 | STEP 1B. Inspect the solid-state sensor switch connector pins. | Dirty or damaged pins?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the OEM harness for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the wiring harnesses for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the solid-state sensor switch.

Guided Step 1A - Verify the solid-state sensor switch is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the solid-state sensor switch isconnected to the harness.

  • Verify the solid-state sensor switch is connected to the OEM harness.

Solid-state sensor switch is connected to the OEM harness?
YES NO
No Repair

Connect the solid-state sensor switch to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the solid-state sensor switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the solid-state sensor switch from the OEM harness.

Action

Inspect the OEM harness and solid-state sensor switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the harness, connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the wiring harnesses.

Guided Step 2A - Inspect the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the solid-state sensor switch from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation switch on-idle SIGNAL pin on the solid-state sensor switch connector of the OEM harness to the switch RETURN pin in the solid-state sensor switch connector of the OEM harness.
  • Measure the voltage from the idle validation switch off-idle SIGNAL pin on the solid-state sensor switch connector of the OEM harness to the switch RETURN pin in the solid-state sensor switch connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the OEM harness and ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the harness, connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the wiring harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector 2 from the ECM.
  • Disconnect the solid-state sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the wiring harnesses between the ECM connector 2 and the solid-state sensor switch connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the wiring harnesses between the ECM connector 2 and the solid-state sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness or engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM or engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the solid-state sensor switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the chassis ground and the solid-state sensor switch connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the solid-state sensor switch from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation switch on-idle SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the idle validation switch on-idle SIGNAL pin in engine harness and all other pins in the ECM connector 2.
  • Measure the resistance between the idle validation switch off-idle SIGNAL pin in engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the idle validation switch off-idle SIGNAL pin in engine harness and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 432 - Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

Associated Procedures

Cautions and Warnings

WARNING

On automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 432 active?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position sensor resistance. | 1500 to 3000 ohms (released), 250 to 1500 ohms (depressed)?
 | STEP 3B-1. Check the resistance of the accelerator pedal or lever position sensor. |
 | STEP 2C. Check for a pin-to-pin short. | Greater than 100k ohms?
STEP 3. | Check the fault codes. |
 | STEP 3A. Perform the fault code disable procedure | Fault Code 432 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 423 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 2.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM connector 2.

Action

Check the sensor resistance.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position 5 volt SUPPLY pin at the ECM connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms released, 250 to 1500 ohms depressed?

Released value must be at least 1000 ohms greater than depressed value.

YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the resistance of the accelerator pedal or lever position sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check the sensor resistance.

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position 5 volt SUPPLY pin at the accelerator pedal or lever position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms released, 250 to 1500 ohms depressed?

Released value must be at least 1000 ohms greater than depressed value.

YES NO

Repair the damaged pins.

Repair or replace the OEM or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the accelerator pedal. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 2C - Check for a pin to pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 2.

Action

Short circuit on one connector pin-to-pin check.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness and all other pins in the ECM connector 2.
  • Measure the resistance between the accelerator pedal position 5 volt SUPPLY pin in the engine harness and all other pins in the ECM connector 1.
  • Measure the resistance between the accelerator pedal position 5 volt SUPPLY pin in the engine harness and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the OEM or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the fault codes.

Guided Step 3A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch ON.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal or lever to the full throttle position and release it completely three times.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES NO
No Repair

Replace the accelerator pedal or lever assembly. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 432 is inactive.

Fault Code 432 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 441 - Battery Number 1 Voltage Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 2. | Check for a damaged voltage source. |
 | STEP 2A. Determine if vehicle has a voltage regulator. | Voltage regulator installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5 and 15.0-VDC?
 | STEP 2C. Determine voltage on the 12-VDC side of the OEM voltage regulator. | Voltage between 11.5 and 15.0-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and connector pin. | Dirty or damaged pins?
 | STEP 3B. Check the voltage at the 23 pin OEM connector. | Voltage between 11.5 and 15.0-VDC?
 | STEP 3C. Check for an open circuit in the unswitched battery supplies in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the voltage at the ECM. | Voltage between 11.5 and 15.0-VDC?
 | STEP 4C. Check for an open circuit in the unswitched battery supplies in the engine harness. | Less than 10 ohms?
 | STEP 4D. Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 441 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electrical service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check for a damaged voltage regulator.

Guided Step 2A - Determine if vehicle has a voltage regulator.

Conditions

  • Turn keyswitch OFF.

Action

Check for the presence of a voltage regulator.

  • Inspect the vehicle for a possible voltage regulator or OEM repair manual to determine if the vehicle has a voltage regulator installed.

If the vehicle has a 24-VDC or 36-VDC system, then it must have a voltage regulator to supply 12-VDC power to the unswitched battery pin in the ECM.

Voltage regulator installed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between 11.5-VDC and 15.0-VDC?
YES NO
No Repair

A damaged battery has been detected.

Replace the damaged battery or batteries. OEM service manual.

Go to 3A

Go to 5A

Guided Step 2C - Determine the voltage on the 12-VDC side of the OEM voltage regulator.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage on the 12-VDC side of the voltage regulator across the positive (+) and negative (-) terminals.

  • Use a multimeter to read the voltage across the voltage regulator.

Voltage between 11.5-VDC and 15.0-VDC?
YES NO
No Repair

A damaged battery, battery circuit or voltage regulator has been detected.

OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Inspect the OEM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the 23-pin OEM connector.

Repair the damaged pins. Repair or replace the OEM or engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Repair the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Refer to Procedure 019-071.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the voltage at the 23 pin OEM connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 23 pin OEM connector.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the 23 pin OEM connector unswitched battery SUPPLY pins and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 VDC and 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 3E

Go to 3C

Guided Step 3C - Check the battery voltage.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM harness at the 23-pin connector
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery pins of the 23 pin OEM connector and the positive (+) battery terminal.

Check for blown or corroded fuses that are in series with the unswitched battery supplies.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Repair the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the unswitched battery supplies in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM harness at the 23 pin and 31 pin OEM connectors.
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in the 23 pin OEM connector and all other pins in the 23 pin OEM connector.
  • Measure the resistance between the unswitched battery SUPPLY pins in the 23 pin OEM connector and all other pins in the 31 pin OEM connector.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Repair the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 3E

Go to 5A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the ECM and engine harness connectors for the following:

  • Inspect the engine harness connector pins for the following:
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the voltage at the ECM.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the engine harness ECM connector 1 unswitched battery SUPPLY pins and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5-VDC and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 4E

Go to 4C

Guided Step 4C - Check for an open circuit in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for an open circuit.

  • Measure the resistance between the unswitched battery SUPPLY pins in the engine connector 1 and the 23-pin OEM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the battery cables from the battery.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the unswitched battery SUPPLY pins in engine harness connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the efollowing procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 inactive?
YES NO
No Repair

Replace the ECM. Call for pre-authorization.

Refer to Procedure 019-031.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Feb-2012


FAULT CODE 442 - Battery Number 1 Voltage High - Data Valid But Above Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823993 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 2. | Check for a malfunctioning voltage source. |
 | STEP 2A. Determine if vehicle has a voltage regulator. | Voltage regulator installed?
 | STEP 2B. Determine battery voltage. | Battery voltage between 11.5 and 15.0-VDC?
 | STEP 2C. Determine voltage on the 12-VDC side of the OEM voltage regulator. | Voltage between 11.5 and 15.0-VDC?
STEP 3. | Check the charging system. |
 | STEP 3A. Inspect the alternator for correct charging voltage. | Charging system performing properly and voltage between 11.5-VDC and 15.0-VDC?
STEP 4. | Check the OEM a harness. |
 | STEP 4A. Inspect the OEM harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the voltage at the 23 pin OEM connector. | Voltage between 11.5-VDC and 15.0-VDC?
 | STEP 4C. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check for a damaged voltage regulator.

Guided Step 2A - Determine if vehicle has a voltage regulator.

Conditions

  • Turn keyswitch OFF.

Action

Check for the presence of a vlotage regulator.

  • Inspect the vehicle for a possible voltage regulator or OEM repair manual to determine if the vehicle has a voltage regulator installed.

If the vehicle has a 24-VDC or 36-VDC system, then it must have a voltage regulator to supply 12-VDC power to the unswitched battery pin in the ECM.

Voltage regulator installed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

  • Use a multimeter to read the battery voltage.

Battery voltage between 11.5 VDC and 15.0 VDC?
YES NO
No Repair

A malfunctioning battery has been detected.

Replace the malfunctioning battery or batteries. Use the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 2C - Determine the voltage on the 12 VDC side of the OEM voltage regulator.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage on the 12-VDC side of the voltage regulator across the positive (+) and negative (-) terminals.

  • Use a multimeter to read the voltage across the voltage regulator.

Voltage between 11.5-VDC and 15.0-VDC?
YES NO
No Repair

A malfunctioning battery, battery circuit or voltage regulator has been detected.

Use the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the charging system.

Guided Step 3A - Check the alternator for correct charging voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle's charging systen.

  • Use the following procedure in the C8.3g (Natural Gas) Engines Troubleshooting and Repair manual, Bulletin 3666206. Refer to Procedure 013-0013 in Section 13. Also use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-001 in Section 13.

Charging system performing properly and voltage between 11.5-VDC and 15.0 VDC?
YES NO
No Repair

A malfunctioning charging system has been detected.

Repair the charging system.

  • Use the following procedure in the C8.3g (Natural Gas) Engines Troubleshooting and Repair manual, Bulletin 3666206. Refer to Procedure 013-001 in Section 13. Also use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-001 in Section 13.

Refer to Procedure 013-001 in Section 13.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the 23-pin OEM harness connector.

Action

Inspect the OEM and engine harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the 23 pin OEM connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the voltage at the 23-pin OEM connector.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the OEM harness at the 23-pin connector.

Action

Check the voltage of the unswitched battery supplies.

  • Check the voltage between the 23-pin OEM connector unswitched battery SUPPLY pins and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Voltage between 11.5 VDC and 15.0-VDC?
YES NO
No Repair

A high voltage source in the OEM harness has shorted to one of the unswitched battery supplies.

Repair or replace the OEM wiring harness.

Use the OEM service manual.

Go to 4C

Go to 5A

Guided Step 4C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to cleaar the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Feb-2012


FAULT CODE 443 - Accelerator Pedal Position Sensor Supply Voltage - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check multiple fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 443 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine and OEM harnesses. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 443 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 443 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check multiple fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Use the OEM service manual.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 active?
YES NO
No Repair

A damaged sensor has been detected.

Replace the accelerator pedal position sensor. Use the OEM service manual.

Go to 3A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for connector pin identification.Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine and OEM harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Make sure all components to accelerator pedal position sensor supply are disconnected.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin in engine harness ECM connector 2 to all other pins in the engine connector 2.
  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin in engine harness ECM connector 2 to all other pins in engine connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the accelerator pedal position sensor SUPPLY wire has been detected in the engine or OEM harnesses.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector two from the ECM
  • Disconnect the accelerator pedal position sensor from the OEM harness
  • Make sure all components to accelerator pedal position sensor supply are disconnected.

Action

Check for a pin short to ground.

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin in the engine harness ECM connector 2 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply number 1 wire has been detected in the engine or OEM harnesses.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the OEM or engine harnesses.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 443 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Feb-2012


FAULT CODE 449 - Fuel Pressure High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 118, 119, 2118, 2119, and/or 2228 active?
 | STEP 1B. Check for an active fault code. | Fault Code 449 active?
STEP 2. | Check the secondary fuel pressure/temperature sensor reading. |
 | STEP 2A. Verify the secondary fuel pressure/temperature sensor reading. | Fuel pressure measurement within 5 percent?
 | STEP 2B. Check the primary fuel pressure. | Pressure greater than maximum value for the engine family?
 | STEP 2C. Verify the primary fuel pressure sensor reading. | Fuel pressure measurement within 5 percent
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 449 active?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multipe fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 118, 119, 2118, 2119, and/or 2228 active?
YES NO

Troubleshoot the active fault codes. If all fault codes are active, start by troubleshooting Fault Code 2228.

 No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Operate the engine in the condition in which the fault occured.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the secondary fuel pressure/temperature sensor.

Guided Step 2A - Verify the secondary fuel pressure/temperature sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical gauge to the Compuchek™ electronic service tool.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure.

  • Verify the secondary fuel pressure measurement with a mechanical gauge connected to the Compuchek™ fitting on the low pressure regulator housing against the secondary fuel pressure measurement displayed in INSITE™ electronic service tool.

See the circuit diagram or wiring diagram for component pin identification.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool. On B LPG Plus engines it may be necessary to install a Compuchek™ fitting after the evaporator outlet.

Fuel pressure measurement within 5 percent?
YES NO
No Repair

Replace the secondary fuel pressure/temperature sensor. Refer to Procedure 019-153 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the primary fuel pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the primary fuel pressure.

  • Use INSITE™ electronic service tool to read the fuel pressure.
  • Use the following procedure found in the B5.9G, B5.9LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-061 in Section 5.
  • Use the following procedure found in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-061 in Section 5.

Pressure greater than maximum value for the engine family?
YES NO
No Repair

A damaged low pressure regulator has been detected.

Repair or replace the missing or damaged components or replace the regulator.

  • Use the following procedure found in the B5.9G, B5.9LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-047 in Section 5.
  • Use the following procedure found in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-047 in Section 5.

Go to 2C

Go to 3A

Guided Step 2C - Verify the primary fuel pressure sensor reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge to the Compuchek™ electronic service tool.
  • Use the following procedure found in the B5.9G, B5.9LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-061 in Section 5.
  • Use the following procedure found in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-061 in Section 5.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the primary fuel pressure.

  • Use INSITE™ electronic service tool to read the fuel pressure.
  • Use the following procedure found in the B5.9G, B5.9LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-061 in Section 5.
  • Use the following procedure found in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-061 in Section 5.

Note: Fuel pressure is displayed in absolute in INSITE™. The Compuchek™ fitting located on the fuel housing is used to measure engine (low pressure) regulator outlet pressure

Fuel pressure measurement within 5 percent?
YES NO

The OEM fuel system supply pressure to the engine (low pressure) regulator is too high.

Troubleshoot the OEM fuel system. Refer to the OEM service manual

A damaged primary fuel pressure sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 449 is inactive.

Fault Code 449 active?
YES | NO
No Repair | No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Nov-2010


FAULT CODE 453 - B and C Gas Plus - Gas Mass Flow Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 453 active?
STEP 2. | Check the sensor. |
 | STEP 2A. Inspect the engine harness and gas mass flow sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit response. | Fault Code 454 active and Fault Code 453 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage to specifications?
 | STEP 2D. Read the fault codes. | Fault Code 453 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, OEM harness, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C-1. Check for a pin-to-pin short circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Read the fault codes. | Fault Code 453 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 453 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 453 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensor.

Guided Step 2 - Inspect the engine harness and gas mass flow sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Inspect the engine harness and gas mass flow sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the sensor. Refer to Procedure 019-101 in Section 19..

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 454 active and Fault Code 453 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the 12-VDC SUPPLY pin and the gas mass flow RETURN pin at the gas mass flow sensor connector of the engine harness.

See the circuit diagram or wiring diagram for component pin identification.

Voltage range on B Series engines is 12 to 15-VDC.

Voltage range on C Series engines is 13.5 to 15-VDC.

Voltage to specifications?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 453 active?
YES NO

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19..

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, OEM harness, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector number 1 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 31-pin OEM connector.

Action

Inspect the engine harness, oem harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM , whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 n Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the gas mass flow sensor form the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the gas mass flow sensor connector RETURN pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Check for a pin-to pin-short circuit.
  • Measure the resistance between the gas mass flow sensor SIGNAL pin in engine harness connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Sectione 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the gas mas flow sensor 12-VDC SUPPLY pin in engine harness and all other pins in the engine harness connector 1.
  • Measure the resistance between the gas mas flow sensor 12-VDC SUPPLY pin in engine harness connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 453 active?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Disable the fault code.
  • Use INSITE™ electronic service tool to verify that Fault Code 453 is inactive?

Fault Code 453 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair completed

Appropriate troubleshooting charts.

Last Modified: 04-Mar-2012


FAULT CODE 453 - L Gas Plus - Gas Mass Flow Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 453 active?
STEP 2. | Check the sensor. |
 | STEP 2A. Inspect the engine harness and gas mass flow sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit response. | Fault Code 454 active and Fault Code 453 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Voltage to specifications?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, OEM harness, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 453 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 453 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensor.

Guided Step 2 - Inspect the engine harness and gas mass flow sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the sensor supply voltage converter.

Action

Inspect the engine harness and gas mass flow sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-101 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the sensor supply voltage converter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 454 active and Fault Code 453 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the voltage converter harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Refer to Procedure 019-439 in Section 19.

Voltage output greater than 15.7-VDC?
YES NO

Replace the voltage converter. Refer to Procedure 019-439 in Section 19.

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, OEM harness, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 31-pin and 23 pin OEM connectors.
  • Disconnect the sensor supply voltage converter from the engine harness.

Action

Inspect the engine harness, OEM harness, sensor supply voltage converter and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the gas mass flow sensor from the sensor supply voltage converter.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector RETURN pin and the gas mass flow sensor connector RETURN pins.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the sensor voltage converter. Refer to Procedure 019-439 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM
  • Disconnect the gas mass flow sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the gas mass flow sensor SIGNAL pin in engine harness and all other pins in the engine harness connector 1.
  • Measure the resistance between the gas mass flow sensor SIGNAL pin in engine harness connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness, connector, or pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the sensor voltage converter. Refer to Procedure 019-439 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 453 is inactive?

Fault Code 453 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Cear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 454 - B Gas Plus and C Gas Plus - Engines Without Optional Sensor Supply Voltage Converter Gas Mass Flow Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes and verify engine options. |
 | STEP 1A. Read the fault codes. | Fault Code 454 active?
 | STEP 1B. Check for sensor supply voltage converter. | Voltage converter present?
STEP 2. | Check the sensor. |
 | STEP 2A. Check system voltage. | Voltage between +13.5 and +15.0-VDC?
 | STEP 2B. Check sensor supply voltage. | Voltage between +13.5 and +15.0-VDC?
 | STEP 2C. Check the circuit response. | Fault code 454 inactive and fault code 453 active?
 | STEP 2D. Read the fault codes and verify sensor condition. | Fault code 454 active?
STEP 3. | Check the harnesses. |
 | STEP 3A. Inspect the engine harness and gas mass flow sensor connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine harness, OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 Ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k Ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k Ohms?
 | STEP 3F. Check for an inactive fault code. | Fault code 454 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 454 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes and verify engine options.

Guided Step 1A - Read the fault codes.

Conditions

  • INSITE™ electronic service tool connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool .

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 454 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19.

Guided Step 1B - Check for sensor supply voltage converter.

Conditions

  • None

Action

Check for the presence of a sensor supply voltage converter.

  • Inspect the engine to confirm that it is not an L Gas Plus or C Gas Plus with a sensor supply voltage converter.

Voltage converter present?
YES | NO
No Repair | No Repair

Use the appropriate fault code for application.

Go to 2A

Guided Step 2 - Check the sensor.

Guided Step 2A - Check system voltage.

Conditions

  • Operate engine.
  • INSITE™ electronic service tool connected.

Action

Check system voltage.

  • Use INSITE™ electronic service tool to read the battery voltage parameter.

Voltage range is +13.5 to +15.0-VDC.

Voltage to specifications?
YES NO
No Repair

Troubleshoot the vehicle's charging system.

  • Use Troubleshooting Symptoms Procedure T013 (Alternator Not Charging or Insufficient Charging) in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206, or Troubleshooting Symptoms Procedure T013 (Alternator Not Charging or Insufficient Charging) in the B.59G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International and G5.9 Base Engine Troubleshooting and Repair Manual, Bulletin 3666164, and the OEM Service Manual.

Go to 2B

Go to 4A

Guided Step 2B - Check sensor supply voltage.

Conditions

  • Engine operating.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor supply voltage.

  • Use INSITE™ electronic service tool to read the 14 Volt Sensor Supply (3) parameter.

Voltage should be between +13.5 and +15.0-VDC.

Voltage to specifications?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Gas mass flow sensor disconnected from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool .

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the gas mass flow SUPPLY pin and the gas mass flow SIGNAL pin at the gas mass flow sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 453 active and Fault Code 454 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Read the fault codes and verify sensor condition.

Conditions

  • Gas mass flow sensor connected to the engine harness.
  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 454 active?
YES NO

Replace the gas mass flow sensor. Refer to Procedure 019-101 (Gas Mass Flow Sensor) in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and gas mass flow sensor connector pins.

Conditions

  • Keyswitch OFF
  • Gas mass flow sensor disconnected from the engine harness.

Action

Inspect the engine harness and gas mass flow sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

  • Wire insulation damaged

See the circuit diagram or wiring diagram for component pin identification.

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM , whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-101 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the engine harness OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector 1 disconnected from the ECM.
  • Engine harness disconnected from the OEM harness at the 23-pin and the 31-pin OEM connectors.

Action

Inspect the engine harness, OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Refer to Procedure 019-361 in Section 19.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness.Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Use the OEM service manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Engine harness disconnected from the ECM.
  • Gas mass flow sensor disconnected from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the engine harness gas mass flow sensor connector SUPPLY pin.
  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin and the engine harness gas mass flow sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Engine harness disconnected from the ECM.
  • Engine harness disconnected from the OEM harness at the 23-pin and the 31-pin OEM connectors.
  • Gas mass flow sensor disconnected from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the gas mass flow SIGNAL pin in the engine harness ECM connector 1 and all other pins in connector 1.
  • Measure the resistance between the gas mass flow sensor SIGNAL pin in engine harness connector 1 and all other pins in connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques, Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Engine harness disconnected from the ECM.
  • Gas mass flow sensor disconnected from the engine harness.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the gas mass flow sensor SIGNAL pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k Ohms?
YES NO
No Repair

Repair or replace the engine harness connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 454 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all componens.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool .

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 454 is inactive.

Fault Code 454 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts.

Last Modified: 04-Mar-2012


FAULT CODE 454 - L Gas Plus and C Gas Plus - Engines With Optional Sensor Supply Voltage Converter Gas Mass Flow Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes and verify engine options. |
 | STEP 1A. Read the fault codes. | Fault Code 454 active?
 | STEP 1B. Check for sensor supply voltage converter. | Voltage converter present?
STEP 2. | Check the sensor and sensor supply voltage converter. |
 | STEP 2A. Check system voltage. | Voltage to specifications?
 | STEP 2B. Inspect engine harness and sensor supply voltage converter harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the sensor supply voltage converter supply voltage. | Voltage between +8.0 and +15.0-VDC?
 | STEP 2D. Check for a failed sensor supply voltage converter 2 ampere fuse. | Less than 10 Ohms?
 | STEP 2E. Inspect the sensor supply voltage converter harness and gas mass flow sensor connector pins. | Dirty or damaged pins?
 | STEP 2F. Check the sensor supply voltage converter output voltage. | Voltage between +14.73 and +15.73-VDC?
 | STEP 2G. Check for an open circuit in the sensor supply voltage converter harness. | Less than 10 Ohms?
 | STEP 2H. Check the circuit response. | Fault code 453 active and fault code 454 inactive?
 | STEP 2I. Read the fault codes and verify sensor condition. | Fault code 454 active?
STEP 3. | Check the harnesses. |
 | STEP 3A. Inspect the engine harness and OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check OEM 5 Ampere fuse. | Less than 10 Ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 Ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k Ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k Ohms?
 | STEP 3F. Check for an inactive fault code. | Fault code 454 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 454 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes and verify engine options.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 454 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for sensor supply voltage converter.

Conditions

  • None

Action

Check for the presence of a sensor supply voltage converter.

  • Inspect the engine to confirm that it is an L Gas Plus or C Gas Plus with a sensor supply voltage converter.

Voltage converter present?
YES | NO
No Repair | No Repair

Go to 2A

Use the appropriate fault code for application.

Guided Step 2 - Check the sensor and sensor supply voltage converter.

Guided Step 2A - Check system voltage.

Conditions

  • Engine operating.
  • Connect INSITE™ electronic service tool .

Action

Check the supply voltage.

  • Use INSITE™ electronic service tool to read the battery voltage parameter.

Voltage range is +13.5 to +15.0-VDC.

Voltage to specifications?
YES NO
No Repair

Troubleshoot the vehicle's charging system.

  • Use Troubleshooting Symptoms Procedure T013 in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206, or Troubleshooting Symptoms Procedure T013 in the B.59G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International and G5.9 Base Engine Troubleshooting and Repair Manual, Bulletin 3666164, and the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Inspect engine harness and sensor supply voltage converter connector pins.

Conditions

  • Turn keyswitch OFF.
  • Sensor supply voltage converter disconnected from the engine harness.

Action

Inspect the engine harness and sensor supply voltage converter pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor supply voltage converter or harness connector.

Repair the damaged pins. If unable, replace the engine harness, or replace the sensor supply voltage converter, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor supply voltage converter. Refer to Procedure 019-439 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check sensor supply voltage converter supply voltage

Conditions

  • Sensor supply voltage converter disconnected from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the +12.0-VDC SUPPLY (Pin 1) and the sensor supply voltage converter GROUND (Pin 2) at the sensor supply voltage converter connector of the engine harness.

See the circuit diagram or wiring diagram for component pin identification.

Voltage between +8.0 and +15.0-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check for a failed sensor supply voltage converter 2 Ampere fuse.

Conditions

  • Keyswitch OFF.
  • 2 Ampere fuse removed from sensor supply voltage converter harness.

Action

Check for a failed fuse.

  • Remove the 2 Ampere fuse from the inline fuse holder installed in the +12.0 VOLT supply line of the sensor supply voltage converter.
  • Use a multimeter to test the continuity of the 2 Ampere fuse.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO

Replace the sensor supply voltage converter. Refer to Procedure 019-439 in Section 19.

A failed fuse has been detected in the sensor supply voltage converter harness. Replace the fuse.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the sensor supply voltage converter harness and gas mass flow sensor connector pins.

Conditions

  • Keyswitch OFF.
  • Sensor supply voltage converter connected to the engine harness.
  • Gas mass flow sensor disconnected from the sensor supply voltage converter harness.

Action

Check for a failed fuse.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Refer to Procedure For general inspection techniques, 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor supply voltage converter harness or gas mass flow sensor connector.

Repair the damaged pins. If unable, replace the sensor supply voltage converter or the gas mass flow sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the sensor supply voltage converter. Refer to Procedure 019-439 in Section 19.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

 No Repair

Go to 4A

Go to 2F

Guided Step 2F - Check sensor supply voltage converter output voltage.

Conditions

  • Sensor supply voltage converter connected to the engine harness.
  • Sensor supply voltage converter disconnected from the gas mass flow sensor.
  • A 40 Ohm, 10 Watt resistor inserted across the gas mass flow sensor connector SUPPLYand RETURN pins.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the gas mass flow sensor +12.0 VOLT SUPPLY (Pin 1) and the gas mass flow sensor GROUND (Pin 2) at the gas mass flow sensor connector of the sensor supply voltage converter harness.
  • Refer to Procedure 019-439 in Section 19.

Voltage between +14.73 and +15.73-VDC?
YES NO
No Repair

Repair or replace the sensor supply voltage converter.

Refer to Procedure 019-439 in Section 19.

Go to 2G

Go to 4A

Guided Step 2G - Check for an open circuit in the sensor supply voltage converter harness.

Conditions

  • Turn keyswitch OFF
  • Engine harness disconnected from the sensor supply voltage converter
  • Gas mass flow sensor disconnected from the sensor supply voltage converter.

Action

Check for an open circuit.

  • Measure the resistance between the sensor supply voltage converter Gas Mass Flow Sensor connector SIGNAL pin and the sensor supply voltage converter Engine Harness connector SIGNAL pin.
  • Measure the resistance between the sensor supply voltage converter Gas Mass Flow Sensor connector RETURN pin and the sensor supply voltage converter Engine Harness connector RETURN pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

An open circuit has been detected in the sensor supply voltage converter.

  • Repair or replace the sensor voltage converter. Refer to Procedure 019-439 in Section 19.

Go to 2H

Go to 4A

Guided Step 2H - Check the circuit response.

Conditions

  • Gas mass flow sensor disconnected from the sensor supply voltage converter harness.
  • Keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the gas mass flow SUPPLY pin and the gas mass flow SIGNAL pin at the gas mass flow sensor connector of the sensor supply voltage converter harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 453 active and fault code 454 inactive?
YES NO
No Repair

An open circuit has been detected in the sensor supply voltage converter.

  • Repair or replace the sensor voltage converter. Refer to Procedure 019-439 in Section 19.

Go to 2I

Go to 3A

Guided Step 2I - Read fault codes and verify sensor condition.

Conditions

  • Gas mass flow sensor connected to the engine harness.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 454 active?
YES NO

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the harnesses.

Guided Step 3A - Inspect the engine harness, OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Engine harness connector 1 disconnected from the ECM.
  • Engine harness disconnected from the OEM harness at the 23-pin and the 31-pin OEM connectors.

Action

Inspect the engine hanress, OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-220 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a failed OEM 5 Ampere fuse.

Conditions

  • Keyswitch OFF
  • OEM 5 Ampere fuse removed.

Action

Check for a failed fuse.

  • Remove the 5 Ampere fuse installed in the +12.0 Volt Supply between OEM connector Pin 31 and the +12.0 Volt switched battery source.
  • Use a multimeter to test the continuity of the 5 Ampere fuse.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

A malfunctioning fuse has been detected. Replace the fuse.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Engine harness disconnected from the ECM.
  • Sensor supply voltage converter disconnected from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the engine harness sensor supply voltage converter connector SUPPLY pin.
  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin and the engine harness sensor supply voltage converter connector SIGNAL pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 Ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness.Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Keyswitch OFF.
  • Engine harness disconnected from the ECM.
  • Gas mass flow sensor disconnected from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the gas mass flow SIGNAL pin in the engine harness ECM connector 1 and all other pins in connector 1.
  • Measure the resistance between the gas mass flow sensor SIGNAL pin in the engine harness connector 1 and all other pins in connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the OEM harness.Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Engine harness disconnected from the ECM.

Action

Check for a pin short circuit to ground.

  • Measure the resistance between the gas mass flow sensor SIGNAL pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques, Refer to Procedure 019-360 in Section 19.

Greater than 100k Ohms?
YES NO
No Repair

Repair or replace the engine harness connector or pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 454 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • All components connected.
  • Keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 454 is inactive.

Fault Code 454 inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all componens.
  • Keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts.

Last Modified: 05-Mar-2012


FAULT CODE 455 - Fuel Control Valve Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 455 inactive?
STEP 2. | Check the fuel control valve and circuit. |
 | STEP 2A. Inspect the fuel control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel control valve. | 2 ohms to 5 ohms?
 | STEP 2C. Check the fuel control valve supply voltage, supply line and return circuit. | Greater than 5-VDC?
 | STEP 2D. Check for an open circuit in the fuel control valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B. Check for an inactive fault code. | Fault Code 455 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 455 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 455 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the fuel control valve and circuit.

Guided Step 2A - Inspect the fuel control valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel control valve from the engine harness.

Action

Inspect the engine harness and fuel control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the valve. Refer to Procedure 019-102.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel control valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel control valve from the engine harness.

Action

Check the fuel control valve resistance.

  • Measure the resistance between the fuel control valve output pin and the fuel control valve RETURN pin at the fuel control valve connector.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

2 ohms to 5 ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel control valve supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel control valve from the engine harness
  • Turn keyswitch ON
  • Engage the starter and crank the engine.

Action

Check the fuel control vlave supply voltage and return circuit.

  • Measure the voltage between the fuel control valve output pin and the fuel control valve RETURN pin of the fuel control valve connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel control valve return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel control valve RETURN pin in the engine harness and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pin-to-ground circuit on the return line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:Inspect the ?????? connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the fuel control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 fuel supply valve SUPPLY pin in the engine harness fuel control valve connector SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fuel control valve supply circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel control valve SUPPLY pin in engine harness ECM engine connector 1 to all other pins in the engine connector 1.
  • Measure the resistance from the fuel control valve SUPPLY pin in engine harness ECM engine connector 1 to all pins in engine connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short on the fuel control valve supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204.
  • Replace the harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 455 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 455 is inactive.

Fault Code 455 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Feb-2012


FAULT CODE 458 - B and C Gas Plus - Ignition Timing Signal Circuit - Shorted High

Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 458 active?
STEP 2. | Check the ignition control module. |
 | STEP 2A. Inspect the ICM (Ignition Control Module) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 458 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 458 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

n/a

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 458 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition control module (ICM).

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM.

Action

Inspect the module and engine harness connector pins for the following: Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 458 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.

Action

Inspect the engine harness, OEM 23-pin, oem 31-pin and ECM connector pins for the following:Inspect the ?????? connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ICM timing pin in the engine harness ECM connector to the ICM timing pin in the engine harness ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness, OEM 23-pin, OEM 31-pin and ECM connector pins for the following:

  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19..

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait five seconds.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 458 is inactive.

Fault Code 458 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 458 - L Gas Plus - Ignition Timing Signal Circuit - Shorted High

Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995- male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 458 active?
STEP 2. | Check the ignition control module (ICM). |
 | STEP 2A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 458 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 458 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 458 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362

Guided Step 2 - Check the ignition control module (ICM).

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.

Action

Inspect the module and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 458 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.

Action

Inspect the engine harness, OEM 23-pin, OEM 31-pin and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ICM timing pin in the engine harness ECM connector to the ICM timing pin in the engine harness ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait five seconds
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 458 is inactive.

Fault Code 458 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 459 - B and C Gas Plus - Ignition Timing Signal Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823995 - male Weather Pack™ test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 459 active?
STEP 2. | Check the ignition control module (ICM). |
 | STEP 2A. Check the system voltage. | Less than 12-VDC?
 | STEP 2B. Check the ICM supply voltage. | Less than 12-VDC?
 | STEP 2C. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the ICM supply voltage. | Less than 12-VDC?
 | STEP 2E. Check for a damaged ICM 15 ampere fuse. | Less than 10 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 459 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check the ECM for active fault codes. | Fault Code 459 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 459 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition control module (ICM).

Guided Step 2A - Check the system voltage.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the system voltage.

  • Use INSITE™ electronic service tool to read the Battery Voltage parameter.

Less than 12-VDC?
YES NO

Recharge or replace the vehicle battery. Refer to Procedure 013-007 in Section 13.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ICM supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect engine harness from ICM connector.

Action

Check the Switched Battery (+) voltage.

  • Measure the voltage at pin A at the ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

Less than 12-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM and the 31-pin OEM connector.

Action

Inspect the module, engine harness, and OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-105 in Section 19.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the ICM supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check the Switched Battery (+) voltage.

  • Measure the voltage at pins 27 and 30 at the OEM connector.

See the circuit diagram or wiring diagram for component pin identification.

Less than 12-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a damaged ICM 15 ampere fuse.

Conditions

  • Turn keyswitch OFF.
  • Remove the 15 ampere ICM fuse.

Action

Check for a damaged fuse.

  • Remove the 15 ampere ICM fuse.
  • Use a multimeter to test the continuity of the fuse.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A damaged fuse has been detected. Replace the fuse.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.

Action

Inspect the engine harness, OEM 23-pin, OEM 31-pin and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ICM timing pin in the engine harness ECM connector to the ICM timing pin in the engine harness ICM connector.
  • Measure the resistance between the ICM SIGNAL reference pin in the engine harness ECM connector to the ICM SIGNAL reference pin in the engine harness ICM connector.
  • Measure the resistance between the ICM SIGNAL negative (-) pin in the engine harness ECM connector to the ICM SIGNAL negative (-) pin in the engine harness ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ICM timing pin in the engine harness ECM connector 1 to engine block ground.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 to all other pins in the connector, and to all pins in engine harness ECM connector 2.
  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in the connector, and to all pins in engine harness ECM connector 2.
  • Measure the resistance between the ICM SIGNAL negative (-) pin in engine harness ECM connector 1 to all other pins in the connector , and to all pins in engine harness ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 inactive?
YES NO
No Repair

Replace the ICM. Refer to Procedure 019-105 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 459 is inactive.

Fault Code 459 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 459 - L Gas Plus - Ignition Timing Signal Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 459 active?
STEP 2. | Check the ignition control module (ICM). |
 | STEP 2A. Check the system voltage. | Less than 12-VDC?
 | STEP 2B. Check the ICM supply voltage. | Less than 12-VDC?
 | STEP 2C. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the ICM supply voltage. | Less than 12-VDC?
 | STEP 2E. Check for a damaged ICM 15 ampere fuse. | Less than 10 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 459 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check the ECM for active fault codes. | Fault Code 459 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 459 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition control module (ICM).

Guided Step 2A - Check the system voltage.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the system voltage.

  • Use INSITE™ electronic service tool to read the Battery Voltage parameter.

Less than 12-VDC?
YES NO

Recharge or replace the vehicle battery. Refer to Procedure 013-007 in Section 13.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ICM supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect engine harness from ICM connector.

Action

Check the Switched Battery (+) voltage.

  • Measure the voltage at pin A at the ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

Less than 12-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM connector.

Action

Inspect the module, engine harness, and OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-105 in Section 19.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the ICM supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check the Switched Battery (+) voltage.

  • Measure the voltage at pins 27 and 30 at the OEM connector.

See the circuit diagram or wiring diagram for component pin identification.

Less than 12-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a damaged ICM 15 ampere fuse.

Conditions

  • Turn keyswitch OFF.
  • Remove the 15 ampere ICM fuse.

Action

Check for a damaged fuse.

  • Remove the 15 ampere ICM fuse.
  • Use a multimeter to test the continuity of the fuse.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A damaged fuse has been detected. Replace the fuse.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.

Action

Inspect the engine harness, OEM 23-pin, OEM 31-pin and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ICM timing pin in the engine harness ECM connector to the ICM timing pin in the engine harness ICM connector.
  • Measure the resistance between the ICM SIGNAL reference pin in the engine harness ECM connector to the ICM SIGNAL reference pin in the engine harness ICM connector.
  • Measure the resistance between the ICM SIGNAL negative (-) pin in the engine harness ECM connector to the ICM SIGNAL negative (-) pin in the engine harness ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect the engine harness connector 1 and connector 3 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ICM timing pin in engine harness ECM connector 1 to engine block ground.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM timing pin in engine harness ECM connector 1 to all other pins in the connector, and to all pins in engine harness ECM connector 2.
  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in the connector, and to all pins in engine harness ECM connector 2.
  • Measure the resistance between the ICM SIGNAL negative (-) pin in engine harness ECM connector 1 to all other pins in the connector , and to all pins in engine harness ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459 inactive?
YES NO
No Repair

Replace the ICM. Refer to Procedure 019-105 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 459 is inactive.

Fault Code 459 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 461 - B and C Gas Plus - Ignition Reference Signal Circuit - Shorted High

Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 461 active?
STEP 2. | Check the ignition control module (ICM) and wiring harnesses. |
 | STEP 2A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2F. Inspect the OEM connector pins. | Dirty or damaged pins?
 | STEP 2G. Check for voltage supply to the ICM. | 8 to 15-VDC on pin 27 or 30?
 | STEP 2H. Check the 15-amp OEM fuse. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 461 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 461 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the ignition control module and wiring harnesses.

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnected the engine harness from the ignition control module.

Action

Inspect the ignition control module and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ignition control module. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the engine harness from the OEM harness at the 23 pin and 31 pin OEM connectors.

Action

Inspect the engine harness, OEM 23-pin, OEM 31-pin, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ICM SIGNAL reference pin in the engine harness ECM connector to the ICM SIGNAL reference pin in the engine harness ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from connector 1 at the ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from pin 11 of the ECM connector to engine block ground.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 2F

Guided Step 2F - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Inspect the OEM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 3A

Go to 2G

Guided Step 2G - Check the voltage supply to the ICM.

Conditions

  • Turn keyswitch OFF.
  • The engine harness disconnected from the 31-pin OEM connector.

Action

Check the voltage supplied to the ICM as follows:

  • Measure the voltage from pin 30 to ground on the vehicle side of the OEM connector.
  • Measure the voltage from pin 27 to ground on the vehicle side of the OEM connector.

See the circuit diagram or wiring diagram for component pin identification.

8 to 15-VDC on pin 27 or 30?
YES NO
No Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-208 in Section 19.
  • Replace the OEM harness. Use the OEM troubleshooting and repair manual.

Go to 2H

Go to 3A

Guided Step 2H - Check the 15-amp OEM fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check the 15-amp fuse.

  • Measure the resistance across the 15-amp OEM fuse.

See the circuit diagram or wiring diagram for component pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Replace the ignition control module. Refer to Procedure 019-105 in Section 19.

Replace the 15-amp fuse.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 461 is inactive.

Fault Code 461 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 461 - L Gas Plus - Ignition Reference Signal Circuit - Shorted High

Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 461 active?
STEP 2. | Check the ignition control module (ICM). |
 | STEP 2A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 461 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 461 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 461 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the ignition control module.

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ignition control module.

Action

Inspect the module and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the sensor. Refer to Procedure 019-105.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 461 active?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the engine harness from the OEM harness at the 23 pin and 31 pin OEM connectors.

Action

Inspect the engine harness, OEM 23-pin, OEM 31-pin and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Call for pre-authorization. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ICM SIGNAL reference pin in the engine harness ECM connector to the ICM SIGNAL reference pin in the engine harness ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 461 is inactive.

Fault Code 461 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 462 - B and C Gas Plus - Ignition Control Module (ICM) Reference Signal Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 462 active?
STEP 2. | Check the ignition control module. |
 | STEP 2A. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 462 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3E. Check the ECM for active fault codes. | Fault Code 462 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 462 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition control module (ICM).

Guided Step 2A - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ignition control module.

Action

Inspect the module and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23 pin and 31 pin OEM connectors.

Action

Inspect the engine harness, OEM 23-pin, OEM 31-pin and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ICM SIGNAL reference pin in the engine harness ECM connector to the ICM SIGNAL reference pin in the engine harness ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 .

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to engine block ground.

See the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use eletrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 inactive?
YES NO
No Repair

Replace the ICM. Refer to Procedure 019-105 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait 5 seconds
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 462 is inactive.

Fault Code 462 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins®Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 462 - L Gas Plus - Ignition Control Module Reference Signal Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 462 active?
STEP 2. | Check the ignition control module. |
 | STEP 2A. Check the system voltage. | Less than 12-VDC?
 | STEP 2B. Check the ICM supply voltage. | Less than 12-VDC?
 | STEP 2C. Inspect the ICM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the ICM supply voltage. | Less than 12-VDC?
 | STEP 2E. Check for a damaged ICM 15 ampere fuse. | Less than 10 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 462 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3E. Check the ECM for active fault codes. | Fault Code 462 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 462 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition control module.

Guided Step 2A - Check the system voltage.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the system voltage.

  • Use INSITE™ electronic service tool to read the Battery Voltage parameter.

Less than 12-VDC?
YES NO

Recharge or replace the vehicle battery. Refer to Procedure 013-007 in Section 13.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ICM supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect engine harness from ICM connector

Action

Check the Switched Battery (+) voltage.

  • Measure the voltage at pin A at the ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

Less than 12-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the ICM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM and the 31-pin OEM connector.

Action

Inspect the module, engine harness, and OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ICM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-105 in Section 19.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check the ICM supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check the Switched Battery (+) voltage.

  • Measure the voltage at pins 27 and 30 at the OEM connector.

See the circuit diagram or wiring diagram for component pin identification.

Less than 12-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a damaged ICM 15 ampere fuse.

Conditions

  • Turn keyswitch OFF.
  • Remove the 15 ampere ICM fuse.

Action

Check for a damaged fuse.

  • Remove the 15 ampere ICM fuse.
  • Use a multimeter to test the continuity of the fuse.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A damaged fuse has been detected. Replace the fuse.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.

Action

Inspect the engine harness, OEM 23-pin, OEM 31-pin, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ICM SIGNAL reference pin in the engine harness ECM connector to the ICM SIGNAL reference pin in the engine harness ICM connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to engine block ground.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ICM.
  • Disconnect the engine harness from the OEM harness at the 23-pin and 31-pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in the connector.
  • Measure the resistance between the ICM SIGNAL reference pin in engine harness ECM connector 1 to all other pins in engine harness ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 462 inactive?
YES NO
No Repair

Replace the ICM. Refer to Procedure 019-105 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 462 is inactive.

Fault Code 462 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 465 - B and C Gas Plus - Turbocharger Control Valve Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 465 inactive?
STEP 2. | Check the wastegate control valve and circuit. |
 | STEP 2A. Inspect the wastegate control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the wastegate control valve. | 2 ohms to 6 ohms?
 | STEP 2C. Check the wastegate control valve voltage, SUPPLY wire and return circuit. | Greater than 5-VDC?
 | STEP 2D. Check for an open circuit in the wastegate control valve return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness(es). | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 465 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 465 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the wastegate control valve and circuit.

Guided Step 2A - Inspect the wastegate control valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate control valve from the engine harness.

Action

Inspect the engine harness and wastegate control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the wastegate control valve. Refer to Procedure 019-103 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the wastegate control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine harness.

Action

Check the wastegate control valve resistance.

  • Measure the resistance between the wastegate control valve OUTPUT pin and the wastegate control valve RETURN pin at the wastegate control valve connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

2 ohms to 6 ohms?
YES NO
No Repair

Replace the wastegate control valve. Refer to Procedure 019-103 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the wastegate control valve voltage, supply wire and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate control valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the wastegate control valve voltage and return circuit

  • Measure the voltage between the wastegate control valve OUTPUT pin and the wastegate control valve RETURN pin at the wastegate control valve connector of the engine harness.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the wastegate control valve return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the wastegate control valve RETURN pin in the engine harness and ground.

See the circuit diagram or wiring diagram for component pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

A open pin-to-ground short circuit on the RETURN wire has been detected in the engine harness(es).

Troubleshoot each harness connected in series to determine which contains the open circuit to ground.

Repair or replace the engine harness(es).

  • Flush the dirt, debris, or moisture from the connector pins . Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Call for pre-authorization. Refer to Procedure 019-031 in Section 19..

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness(es).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the wastegate control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector wastegate control valve SUPPLY pin in the engine harness wastegate control valve connector SUPPLY pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pin 8 wastegate control valve supply circuit has been detected in the engine harness(es).

Troubleshoot each harness connected in series to determine which contains the open supply circuit.

Repair or replace the engine harness(es).

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness(es).

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the wastegate control valve from engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the wastegate control valve SUPPLY pin in engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance between the wastegate control valve SUPPLY pin in engine harness ECM connector 1 to all other pins in ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the wastegate control valve supply line has been detected in the engine harness(es).

Troubleshoot each harness connected in series to determine which contains the open supply circuit.

Repair or replace the engine harness(es).

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 465 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 465 - L Gas Plus - Turbocharger Control Valve Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead and Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 465 inactive?
STEP 2. | Check the variable geometry turbocharger actuator control valve and circuit. |
 | STEP 2A. Inspect the variable geometry turbocharger actuator control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the variable geometry turbocharger control valve voltage, SUPPLY wire and return circuit. | Greater than 5-VDC?
 | STEP 2C. Check for circuit response. | Fault Code 466 active and Fault Code 465 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 465 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness(es). | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 465 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 465 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON or Run/Stop switch to the RUN position.
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the variable geometry turbocharger actuator control valve and circuit.

Guided Step 2A - Inspect the variable geometry turbocharger actuator control valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the variable geometry turbocharger actuator control valve from the engine harness.

Action

Inspect the engine harness and variable geometry turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the wastegate control valve. Refer to Procedure 019-388 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the variable geometry turbocharger actuator voltage, SUPPLY wire and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator control valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the variable geometry turbocharger actuator control valve voltage and return circuit.

  • Measure the voltage between the variable geometry turbocharger actuator control valve output pin and the variable geometry turbocharger actuator control valve RETURN pin at the variable geometry turbocharger actuator control valve connector of the engine harness.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2C - Check for circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the variable geometry turbocharger actuator control valve from the engine harness
  • Install a jumper wire
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 15 seconds.

  • Place a jumper wire between the turbocharger control valve SIGNAL pin at the turbocharger control valve connector of the engine harness and engine block ground.
  • Use INSITE™ electronic service tool to read the fault codes.

See the circuit diagram or wiring diagram for component pin identification.

Fault Code 466 active and Fault Code 465 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the turbocharger control valve to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 active?
YES NO

A damaged connection has been detected in the turbocharger control valve.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

Replace the turbocharger control valve.

  • Replace the wastegate control valve. Refer to Procedure 019-388 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

See the circuit diagram or wiring diagram for component pin identification.

For general inspection techniques. Refer to Procedure 019-361 in Section 19..in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the ECM. Call for pre-authorization. Refer to Procedure 019-031 in Section 19. .

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness(es).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the variable geometry turbocharger actuator control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector variable geometry turbocharger actuator control valve SUPPLY pin in the engine harness variable geometry turbocharger actuator control valve connector SUPPLY pin.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open variable geometry turbocharger actuator control valve supply circuit has been detected in the engine harness(es).

Troubleshoot each harness connected in series to determine which contains the open supply circuit.

Repair or replace the engine harness(es).

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness(es).

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM
  • Disconnect the variable geometry turbocharger actuator control valve from engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the variable geometry turbocharger actuator control valve SUPPLY pin in engine harness ECM connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance between the variable geometry turbocharger actuator control valve SUPPLY pin in engine harness ECM connector 1 to all other pins in ECM connector 2.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the variable geometry turbocharger actuator control valve SUPPLY wire has been detected in the engine harness(es).

Troubleshoot each harness connected in series to determine which contains the open supply circuit.

Repair or replace the engine harness(es).

Replace the ECM.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Call for pre-authorization. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 465 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 466 - B and C Gas Plus Turbocharger Control Valve Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 466 inactive?
STEP 2. | Check the wastegate control valve and circuit. |
 | STEP 2A. Inspect the wastegate control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the wastegate control valve coil. | 2 ohms to 6 ohms?
 | STEP 2B-1. Check for a short to ground in the wastegate control valve. |
 | STEP 2C. Check the wastegate control valve diagnostic supply voltage, supply line and return circuit. | Greater than 5-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness(es). | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 466 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 466 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 466 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362

Go to 2A

Guided Step 2 - Check the wastegate control valve and circuit.

Guided Step 2A - Inspect the wastegate control valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate control valve from the engine harness.

Action

Inspect the engine harness and wastegate control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the valve. Refer to Procedure 019-102 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the wastegate control valve coil.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate control valve from the engine harness.

Action

Check the wastegate control valve resistance.

  • Measure the resistance between the wastegate control valve SUPPLY pin and the wastegate control valve RETURN pin ground at the wastegate control valve connector.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

2 ohms to 6 ohms?
YES NO
No Repair

Replace the wastegate control valve. Refer to Procedure 019-103 in Section 19.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short circuit to ground in the wastegate control valve.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate control valve from the engine harness.

Action

Check for a wastegate control valve output short to ground.

  • Measure the resistance between the wastegate control valve SUPPLY pin and ground at the wastegate control valve connector.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Replace the wastegate control valve. Refer to Procedure 019-103 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the wastegate control valve diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wastegate control valve from the engine harness
  • Turn keyswitch ON.

Action

Check the wastegate control vlave supply voltage and return circuit.

  • Measure the voltage between the wastegate control valve SUPPLY pin and the wastegate control valve RETURN pin of the wastegate control valve connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the wastegate control valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the wastegate control valve SUPPLY pin in the ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the wastegate control valve supply line has been detected in the engine harness(es).

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness(es).

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the wastegate control valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between t.he wastegate control valve SUPPLY pin in the engine harness ECM engine connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance from the wastegate control valve SUPPLY pin in the engine harness ECM engine connector 1 to all pins in the ECM connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to pin-short on the wastegate control valve supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 466 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 466 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Apr-2012


FAULT CODE 466 - L Gas Plus - Turbocharger Control Valve Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 466 inactive?
STEP 2. | Check the variable geometry actuator and circuit. |
 | STEP 2A. Inspect the variable geometry turbocharger actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit response. | Fault Code 465 active and Fault Code 466 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 466 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness(es). | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 466 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 466 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 466 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362in Section 19.

Go to 2A

Guided Step 2 - Check the variable geometry turbocharger actuator and circuit.

Guided Step 2A - Inspect the variable geometry turbocharger actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.

Action

Inspect the engine harness and variable geometry turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the valve. Refer to Procedure 019-388 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 465 active and Fault Code 466 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 466 active?
YES NO

A damaged turbocharger control valve has been detected.

  • Replace the turbocharger control valve. Refer to Procedure 019-388 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:Inspect the ?????? connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the variable geometry turbocharger actuator SUPPLY pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin to ground short circuit on the variable geometry turbocharger actuator supply line has been detected in the engine harness(es).

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness(es).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the variable geometry turbocharger actuator from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the variable geometry turbocharger actuator SUPPLY pin in the engine harness ECM engine connector 1 to all other pins in the ECM connector 1.
  • Measure the resistance from the variable geometry turbocharger actuator SUPPLY pin in the engine harness ECM engine connector 1 to all pins in the ECM connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short on the variable geometry turbocharger actuator supply line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair the damaged pins. Repair or replace the harness(es), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 466 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

faFault Code 466 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2012


FAULT CODE 482 - Fuel Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fuel tank pressure or level. | Fuel tank pressure or level low?
 | STEP 1B. Check the vehicle fueling history. | Low fuel pressure faults only after refueling?
 | STEP 1C. Check for multiple fault codes. | Fault Codes 118, 119, and/or 2119 active?
 | STEP 1D. Check for an active fault code. | Fault Code 482 active?
STEP 2. | Check the primary fuel pressure sensor. |
 | STEP 2A. Check the primary fuel pressure. | Pressure measurement greater than minimum value for the engine family?
 | STEP 2B. Verify the primary fuel pressure sensor reading. | Fuel pressure measurement within 5 percent?
STEP 3. | Check the secondary fuel pressure. |
 | STEP 3A. Inspect the low pressure regulator boost reference line. | Boost reference line damaged?
 | STEP 3B. Verify the secondary fuel pressure/temperature sensor reading. | Fuel pressure measurement within 5 percent?
 | STEP 3C. Check the fuel system for leaks. | Fuel leaks?
 | STEP 3D. Check the gas mass flow sensor for oil carryover. | Deposites or evidence of oil?
 | STEP 3E. Inspect the engine fuel shutoff valve. | Damaged fuel shut off valve or hardware?
 | STEP 3F. Inspect the fuel transfer hoses. | Fuel transfer hoses kinked, restricted, or damaged?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 482 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the OEM gauge to check the pressure or level.

Fuel tank pressure or level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check the vehicle fueling history.

Conditions

  • Turn keyswitch OFF.

Action

Check the history to see if the vehicle’s low fuel pressure complaints occur only after refueling.

Low fuel pressure faults only after refueling?
YES NO

A fuel fill issue has been detected. Refer to the OEM service manual or fuel system supplier to review fuel fill procedures.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 118, 119, and/or 2119 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes.

Go to 1D

Guided Step 1D - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Operate the engine in the condition in which the fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 482 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the primary fuel pressure sensor.

Guided Step 2A - Check the primary fuel pressure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine in the condition in which the fault occurs.

  • Use INSITE™ electronic service tool to read the primary fuel pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, B5.9G B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 005-047 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, C Gas , C Gas Plus and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-047 in Section 5.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool.

Pressure measurement greater than minimum value for the engine family?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Verify the primary fuel pressure sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical gauge.

Use the following procedure in the Troubleshooting and Repair Manual, B5.9G B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 005-061 in section 5.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas , C Gas Plus and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-061 in Section 5.

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the primary fuel pressure.

  • Verify the primary fuel pressure measurement with a mechanical gauge against the primary fuel pressure measurement value displayed in INSITE™ electronic service tool.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool.

The Compuchek™ fitting located on the fuel housing is used to measure secondary fuel pressure out of the engine (low pressure) fuel regulator.

Fuel pressure measurement within 5 percent?
YES NO

The OEM fuel system is not supplying sufficient fuel pressure or flow.

Troubleshoot the OEM fuel system. Refer to the OEM service manual

A damged primary fuel pressure sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the secondary fuel pressure.

Guided Step 3A - Inspect the low pressure regulator boost reference line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the boost reference line (L Gas Plus only)

  • Check the boost reference line connected to the low pressure regulator for signs of damage.

NOTE: The boost reference line connects to the low pressure regulator housing rear cover. If the engine is not equipped with a boost reference line, answer NO to this step.

Boost reference line damaged?
YES NO

A damaged boost reference line has been detected. Replace the boost reference line.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Verify the secondary fuel pressure/temperature sensor reading.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical gauge to the Compuchek™ fitting.
  • Connect INSITE™ electronic service tool.

Action

Verify the fuel pressure while operating the engine in the condition in which the fault occurs.

  • Verifythe secondary fuel pressure measurement with a mechanical gauge connected to the Compuchek™ fitting on the low pressure regulator housing against the secondary fuel pressure measurement displayed in INSITE™ electronic service tool.

NOTE: Fuel pressure is displayed in absolute in INSITE™electronic service tool. On B LPG Plus engines it may be necessary to install a Compuchek™ fitting after the evaporator outlet.

Fuel pressure measurement within 5 percent?
YES NO

A damaged low pressure regulator has been detected. Repair or replace the missing or damaged components or replace the regulator.

  • Use the following procedure in the Troubleshooting and Repair Manual, B5.9G B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 005-047 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, C Gas , C Gas Plus and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-047 in Section 5.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the fuel system for leaks.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for leaks in the fuel system.

  • Use the combustible gas detector service tool to check the fuel lines, fuel connections, and fuel filters for leaks.

NOTE: Unlike natural gas, liquefied petroleum gas is heavier than air and will sink to the ground. It is best to check below the connector. Another sign of fuel leakage is frosting around the connection.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Repair or replace the leaking component.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the gas mass flow sensor for oil carryover.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil in the fuel system.

  • Remove the gas mass flow sensor. Refer to Procedure 019-101 in section 19

NOTE: Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check the gas compression station for oil carry over.

NOTE: On C Gas Plus and L Gas Plus engines verify that the screen pack before the gas mass flow sensor is properly seated and is free of oil deposits.

Deposits or evidence of oil
YES NO

Replace the gas mass flow sensor and clean the fuel system of deposits and oil.

  • Use the following procedure in the Troubleshooting and Repair Manual, B5.9G B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 005-047 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual, C Gas , C Gas Plus and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-047 in Section 5.

No Repair

Go to 4A

Go to 3E

Guided Step 3E - Inspect the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

Action

Inspect the engine fuel shutoff valve for restrictions, damage, or missing o-rings.

  • Refer to Procedure 019-050 in Section 19.

Damaged engine fuel shutoff valve or hardware?
YES NO

Replace the engine fuel shutoff valve.

  • Refer to Procedure 019-050 in Section 19.

 No Repair

Go to 4A

Go to 3F

Guided Step 3F - Inspect the engine fuel transfer hoses.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel transfer hoses after the low pressure regulator for kinks, restrictions, damage, or loose connections.

Fuel transfer hoses kinked, restricted, or damaged?
YES NO

A damaged fuel transfer hose or loose connection has been detected. Tighten the connection or replace the fuel transfer hose.

A damaged sensor secondary fuel pressure/temperature sensor has been detected. Replace the secondary fuel pressure/temperature sensor.

  • Refer to Procedure 019-364 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and operate it in the condition in which the fault occurs.
  • Use INSITE™ electronic service tool to verify Fault Code 482 is inactive.

Fault Code 482 active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot and remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Nov-2010


FAULT CODE 488 - Intake Manifold Temperature High - Over Temperature Warning

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 488 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar probe. | Temperature within five degrees?
STEP 3. | Check the intake manifold pressure/temperature sensor. |
 | STEP 3A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 488 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 488 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar probe.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify sensor accuracy.

  • Compare the intake manifold temperature reading on INSITE™ electronic service tool to the reading from the probe.

If no temperature measuring device is available, answer Yes to this step.

Temperature within five degrees?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-099 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the intake manifold pressure/temperature sensor.

Guided Step 3A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-205 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ICM. Refer to Procedure 019-099 in Section 19.

 No Repair

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 488 active?
YES NO

Intake Manifold Temperature Above Normal troubleshooting tree in the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206.

No Repair

Go to 4A

Go to 4B

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 488 is inactive.

Fault Code 488 inactive?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Mar-2012


FAULT CODE 511- Fuel Control Valve Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823994 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 511 inactive?
STEP 2. | Check the fuel control valve and circuit. |
 | STEP 2A. Inspect the fuel control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel control valve. | 2 ohms to 5 ohms?
 | STEP 2B-1. Check for a short to ground in the fuel control valve. |
 | STEP 2C. Check the fuel control valve supply voltage, supply line, and return circuit. | Greater than 5-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 511 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 511 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 511 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel control valve and circuit.

Guided Step 2A - Inspect the fuel control valve and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the fuel control from the valve engine harness.

Action

Inspect the engine harness and fuel control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the harness, or replace the valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the valve. Refer to Procedure 019-102 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine harness.

Action

Check fuel control valve resistance.

  • Measure the resistance between the fuel control valve output pin and the fuel control valve RETURN pin at the fuel control valve connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

2 ohms to 5 ohms?
YES NO
No Repair

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the fuel control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a fuel control valve output short to ground.

  • Measure the resistance between the fuel control valve (+) pin and ground to the body of the fuel control valve.

Note: Remove any paint, grease, or foreign material which might compromise the measurement.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel control valve supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel control valve supply voltage and return circuit.

  • Measure the voltage between the fuel control valve output pin to the fuel control valve RETURN pin at the fuel control valve connector of the engine harness.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the ECM and engine harness connector pins connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness connector.

Repair the damaged pins. Repair or replace the harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a pin-to-ground short

  • Measure the resistance between the fuel control valve output pin in the engine harness ECM engine connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the fuel control valve output line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel control valve SUPPLY pin in the engine harness ECM connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the fuel control valve SUPPLY pin in the engine harness ECM connector to all other pins in the engine connector 2.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fuel control valve supply line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 511 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 511 is inactive.

Fault Code 511 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting charts

Last Modified: 13-Nov-2014


FAULT CODE 512 - B Gas International - Throttle Plate Position Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 512 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator. Refer to Procedure 019-121 in Section 19.
  • Use the following procedure in the Troubleshooting and Repair Manual C8.3G, C Gas Plus and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-052 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual B5.9G, B5.9 LPG, B Gas Plus and B LPG Engines, Bulletin 3666164. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 30 seconds.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module connector 1 or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ICM.
  • Disconnect the throttle plate position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command (+) line for position signal line has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Start the engine and let it idle for 30 seconds.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 512 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Mar-2012


FAULT CODE 512 - Gas Plus - Throttle Plate Position Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 512 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 512 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the harness, or replace the throttle actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator. Refer to Procedure 019-097 in Section 19.
  • Use the following procedure in the Troubleshooting and Repair Manual C8.3G, C Gas Plus and L Gas Plus Engines, Bulletin 3666206 for replacing the throttle body assembly. Refer to Procedure 005-052 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual B5.9G, B5.9 LPG, B Gas Plus and B LPG Plus Engines, Bulletin 3666164 for replacing the throttle body assembly. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 30 seconds.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ICM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle actuator SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Start the engine and let it idle for 30 seconds.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 512 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Mar-2012


FAULT CODE 513 - B Gas International - Throttle Plate Position Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 2. | Check the throttle plate position sensor and circuit. |
 | STEP 2A. Inspect the throttle plate position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short to ground. | Greater than 100K ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 513 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO

Inactive or intermittent fault code.

Refer to Procedure 019-362 in Section 19 in Section 19.

 No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle plate position sensor and circuit.

Guided Step 2A - Inspect the throttle plate position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle plate position sensor from the engine harness.

Action

Inspect the engine harness and throttle posiition sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector or pins if possible.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator. Refer to Procedure 019-121 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short to ground in the throttle plate position sensor.

Conditions

  • Keyswitch in OFF position.
  • Disconnect the throttle plate position sensor from the engine harness.

Action

Check for a throttle plate position sensor (+) short to ground.

  • Measure the resistance between the throttle plate position sensor supply pin and ground at the throttle plate position sensor connector.

Use the circuit description or circuit diagram for connector pin identification.

Greater than 100K ohms?
YES NO
No Repair

Replace the throttle plate position sensor. Refer to Procedure 019-121 in Section 19.

Go to 2C

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and 2 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the throttle plate position sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness control module engine connector 1 throttle plate position sensor SIGNAL pin and the throttle plate position sensor connector SIGNAL pin for the engine harness.
  • Measure the resistance between the engine harness ECM engine connector 2 throttle plate position sensor 5-VDC SUPPLY pin and the throttle plate position sensor connector 5-VDC SUPPLY pin of the engine harness.

Use the circuit description or circuit diagram for connector pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the throttle plate position sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the throttle plate position sensor 5-VDC SUPPLY pin in the engine harness ECM engine connector 2 and ground.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM engine connector 1 and ground.

Use the circuit description or circuit diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a Pin-to-Pin Short Circuit in the Engine Harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the throttle plate position sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the throttle plate position sensor 5-VDC SUPPLY pin in the engine harness ECM engine connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the throttle position sensor 5-VDC SUPPLY pin in the engine harness ECM engine connector 2 and ground and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine connector 2.

Use the circuit art for connector pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle plate position sensor command 5-VDC SUPPLY wire or position SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO

None. The removal and reinstallation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 513 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2012


FAULT CODE 513 - B and C Gas Plus - Throttle Plate Position Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 2. | Check the throttle actuator and circuit. |
 | STEP 2A. Inspect the throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle actuator battery voltage and ground. | 12-VDC?
 | STEP 2C. Check the resistance in the switched battery and ground. | 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 513 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 513 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO

Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 4B

Go to 2A

Guided Step 2 - Check the throttle actuator and circuit.

Guided Step 2A - Inspect the throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or engine harness connector.

Repair the damaged pins. Repair or replace the throttle actuator, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator. Refer to Procedure 005-052 in the Troubleshooting and Repair Manual C8.3G, C Gas Plus and L Gas Plus Engines, Bulletin 3666206.
  • Replace the throttle actuator. Refer to Procedure 005-052 in the Troubleshooting and Repair Manual B5.9G, B5.9 LPG, B Gas Plus and B LPG Plus Engines, Bulletin 3666164.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the throttle actuator battery voltage and ground.

Conditions

  • Turn keyswitch OFF.
  • Using a break-out harness or piercing probes so a load is on the voltage supply
  • Turn keyswitch ON.

Action

Check the throttle actuator battery voltage.

  • Check switched battery voltage on pins A and B for battery voltage (bad fuse or voltage drop will be shown by being hooked to actuator).

Use the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

12-VDC?
YES NO
No Repair

Determine the root cause for no or insufficient switched battery voltage.

Go to 3B-1

Go to 2C

Guided Step 2C - Check the resistance in the throttle actuator battery voltage and ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the throttle actuator battery voltage to ground.

  • Measure the resistance between the throttle actuator battery voltage pin and ground at the throttle actuator connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the throttle actuator.

Refer to Procedure 005-052 in Section 5 in the Troubleshooting and Repair Manual, C8.3G, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-052 in Section 5 in the Troubleshooting and Repair Manual, B5.9G, B5.9 LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19..
  • Replace the harness. Refer to Procedure 019-043 in Section 19..

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 from the ECM
  • Disconnect the throttle actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 throttle actuator switched battery (+) pin and the throttle actuator connector switched battery (+) pin in the engine harness.
  • Measure the resistance between the engine harness ECM connector 1 throttle actuator RETURN pin and the throttle actuator connector RETURN pin of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 throttle position (+) pin and the throttle position (+) pin of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open supply circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the throttle actuator switched battery (+) pin in the engine harness ECM connector 1 and ground.
  • Measure the resistance between the throttle position (+) pin in the engine harness ECM connector 1 and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the followin procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the throttle actuator supply or the throttle position signal lines has been detected in the engine harness.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 1 and connector 2 from the ICM.
  • Disconnect the throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the throttle actuator switched battery (+) pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle actuator switched battery (+) pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.
  • Measure the resistance between the throttle position (+) pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the throttle position (+) pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Use the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the throttle actuator command supply line or position signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 513 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Mar-2012


FAULT CODE 545 - B and C Gas Plus - Wastegate Control Valve Stuck Open

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for overboost Fault Code 124. | Fault Code 124 inactive?
STEP 2. | Check the wastegate control valve. |
 | STEP 2A. Inspect the wastegate control valve. | Does the air flow go into the intake?
 | STEP 2B. Inspect wastegate control valve vent to atmosphere. | Does the air flow go to the atmosphere when +12-VDC are applied?
STEP 3. | Check the wastegate. |
 | STEP 3A. Check for blockage in the wastegate actuator pipe work. | Blockage in pipe work?
 | STEP 3B. Inspect wastegate actuator rod for travel. | Does the wastegate actuator rod move?
 | STEP 3B-1. Inspect the wastegate actuator rod for travel. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 545 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for overboost Fault Code 124.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 124 inactive?
YES | NO
No Repair | No Repair

Fault Code 124

Go to 2A

Guided Step 2 - Check the wastegate control valve.

Guided Step 2A - Inspect the wastegate control valve.

Conditions

  • Turn keyswitch OFF
  • Remove the wastegate control hose or line.

Action

Apply regulated shop air to the wastegate control valve.

  • Apply a regulated air supply of 138 kPa [20 psi] to the wastegate control line connection on the wastegate control valve block.

Does the air flow go into the intake?
YES NO
No Repair

Replace the wastegate control valve. Refer to Procedure 019-103 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wastegate control valve vent to atmosphere.

Conditions

  • Turn keyswitch OFF.
  • Remove wastegate control hose or line.
  • Remove wastegate control valve electrical connector.

Action

Check the wastegate control valve for proper operation.

  • Connect test leads to the pins on the wastegate control valve supply (+) to a +12 VDC supply (+) and the wastegate control valve supply (-) to a 12-VDC supply (-).
  • Apply a regulated air supply of 138 kPa [20 psi] to the wastegate control wire connection on the wastegate control valve block.

Circuit art or wiring diagram for connector pin identification.

Does the air flow go to the atmosphere when +12-VDC are applied?
YES NO
No Repair

Replace the wastegate control valve. Refer to Procedure 019-103 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the wastegate.

Guided Step 3A - Check for blockages in the wastegate actuator pipe work.

Conditions

  • Turn keyswitch OFF.

Action

Check for blockages in the actuator pipe work.

  • Verify that the wastegate control valve hose is connected to the actuator. Refer to Procedure 010-050 in Section 19 in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206 or Refer to Procedure 010-050 in Section 19 in the Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

Blockage in pipe work?
YES NO

Repair or replace the wastegate actuator pipe work. Refer to Procedure 010-050 in Section 19 in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206 or Refer to Procedure 010-050 in Section 19 in the Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the wastegate actuator rod for travel.

Conditions

  • Turn keyswitch OFF.
  • Remove the line from the wastegate actuator.

Action

Apply a regulated air supply to the wastegate actuator.

  • Apply a regulated air supply of 138 kPa [20 psi] to the wastegate actuator and check for actuator rod movement.

Does the wastegate actuator rod move?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Inspect the wastegate actuator rod for travel.

Conditions

  • Turn keyswitch OFF
  • Remove the e-clip from the wastegate pin and disconnect the actuator rod.

Action

Apply a regulated air supply to the wastegate actuator.

  • Apply a regulated air supply of 138 kPa [20 psi] to the wastegate actuator and check for actuator rod movement.

Does the wastegate actuator rod move?
YES NO
No Repair

Replace the wastegate actuator. Refer to Procedure 010-050 in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206 or Refer to Procedure 010-050 in Section 10 in the Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify that Fault Code 545 is inactive.

Fault Code 545 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Mar-2012


FAULT CODE 545 - L Gas Plus - Wastegate Control Valve Stuck Open

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for overboost Fault Code 124. | Fault Code 124 active?
STEP 2. | Check the turbocharger. |
 | STEP 2A. Check variable geometry actuator rod for correct travel. | Does the turbocharger actuator rod extend between 10.8 mm and 11.8 mm [0.42 and 0.46 in]?
 | STEP 2A-1. Check for air leaks and inspect air lines. |
 | STEP 2A-2. Check for air pressure at the turbocharger control valve outlet. |
 | STEP 2A-3. Check for air pressure at turbocharger control valve outlet. |
 | STEP 2A-4. Check for vehicle air tank pressure at turbocharger control valve inlet. |
 | STEP 2A-5. Check for correct turbocharger actuator travel. |
 | STEP 2B. Check for broken shaft inside the turbocharger. | Does the sliding nozzle move correctly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 545 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for overboost Fault Code 124.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 124 active?
YES | NO
No Repair | No Repair

Fault Code 124

Go to 2A

Guided Step 2 - Check the turbocharger.

Guided Step 2A - Check variable geometry actuator rod for correct travel.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged (greater than 100 psi).

Action

Apply regulated shop air to the wastegate control valve.

  • Adjust the delay timer in the Turbocharger Actuator Test so that the rod movement can be observed.
  • Select the “Retract Actuator” position with INSITE™ electronic service tool.
  • Mark or scribe the variable geometry actuator rod at the base of the actuator.
  • Select the “Extend Actuator” position with INSITE™ electronic service tool.
  • Measure the rod travel by measuring the distance from the base of the variable geometry actuator to the scribe mark.

The variable geometry actuator must move quickly and crisply. If the actuator rod movement is slow. there can possibly be a problem with the variable geometry turbocharger.

Does the turbocharger actuator rod extend between 10.8 mm and 11.8 mm [0.42 and 0.46 in]?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Check for air leaks and inspect air lines.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged (greater than 100 psi).

Action

Use INSITE™ electronic service tool to start the turbocharger actuator test.

Select the “Extended Actuator” position.

Listen for air leaks in the following components:

  • Turbocharger control valve
  • Turbocharger control valve inlet connection
  • Turbocharger control valve outlet connection
  • Turbocharger actuator inlet connection
  • Turbocharger actuator
  • Apply air lines including OEM supply line to turbocharger control valve and between the turbocharger control valve and the variable geometry turbocharger.

A small amount of air will be heard escaping from the turbocharger control valve. This is a normal condition. Do not replace the turbocharger control valve for this condition.

Air leaks found in the system or damaged air lines?
YES NO

Repair air leaks or replace damaged air lines.

 No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check for air pressure at the turbocharger control valve outlet.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Verify vehicle air tanks are fully charged (greater than 100 psi).

Action

Check for air pressure at the turbocharger control valve outlet.

  • Remove the air line connection at the outlet of the turbocharger control valve.
  • Install a Compucheck® fitting in the turbocharger control valve outlet.
  • Install an air pressure gauge that is capable of reading at least 1034 kPa [150 psi].
  • Use INSITE™ electronic service tool to perform the “Turbocharger Actuator Test”. Select the “Extend” position.

Is vehicle tank air pressure present at the turbocharger control valve outlet?
YES | NO
No Repair | No Repair

Go to 2A-3

Go to 2A-5

Guided Step 2A-3 - Check for air pressure at turbocharger control valve outlet.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged (greater than 100 psi).

Action

Check for air pressure at turbocharger control valve outlet.

  • Remove the air line connection at the outlet of the turbocharger control valve.
  • Use INSITE™ electronic service tool to perform the “Turbocharger Actuator Test”. Select the “Retract” position.

Can air be heard escaping from the turbocharger control valve outlet?
YES NO

The turbocharger control valve is stuck open. It must not be allowing air to escape when in the “Retract” position. Replace the turbocharger control valve. Refer to Procedure 019-388 in Section 19.

No Repair

Go to 3A

Go to 2A-4

Guided Step 2A-4 - Check for vehicle air tank pressure at turbocharger control valve inlet.

Conditions

  • Turn keyswitch ON.
  • Verify vehicle air tanks are fully charged (greater than 100 psi).

Action

Disconnect the air inlet connection to the turbocharger control valve inlet.

  • Verify vehicle air tank pressure is available at the turbocharger control valve inlet.

Vehicle air tank pressure available at the turbocharger control valve inlet?
YES NO
No Repair

No air pressure available at the turbocharger control valve inlet. Troubleshoot the OEM air plumbing and determine why air pressure is not present.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check for correct turbocharger actuator travel.

Conditions

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Remove the variable geometry actuator from the turbocharger assembly. Refer to Procedure 010-113 in Section 10.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged (greater than 100 psi).

Action

Use INSITE™ electronic service tool to perform the turbocharger actuator test.

  • Select the “Extended Actuator” position.

Does the variable geometry actuator rod travel at least 12 mm [0.472 in]?
YES NO

The variable geometry actuator has correct air pressure and correct travel. The variable geometry mechanism in the turbocharger is seized. Replace the turbocharger assembly. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-033 in Section 10.

Variable geometry actuator has correct air pressure but variable geometry actuator rod is not extending. Replace the turbocharger actuator. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Remove the variable geometry actuator from the turbocharger assembly. Refer to Procedure 010-113 in Section 10.

Go to 3A

Go to 3A

Guided Step 2B - Check for broken shaft inside the turbocharger.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Remove the variable geometry actuator from the turbocharger assembly. Refer to Procedure 010-113 in Section 10.

Action

Check for a broken shaft inside the turbocharger.

  • Check for a broken linkage inside the turbocharger by moving the variable geometry actuator on the turbocharger up and down.

The actuator lever must move evenly and crisp as it is moved.

Does the sliding nozzle move correctly?
YES NO
No Repair

The variable geometry turbocharger has a mechanical failure inside the turbocharger. The actuator moves properly, but the linkage attaching the actuator to the nozzle is broken. Replace the turbocharger assembly. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus, Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-033 in Section 10.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 545 is inactive.

Fault Code 545 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Apr-2012


FAULT CODE 546 - Fuel Pressure Sensor Circuit, Secondary- Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 386. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 386 inactive?
STEP 2. | Check the fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 547 active and Fault Code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 546 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 546 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 546 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 386.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel pressure sensor and connector pins.

Guided Step 2A - Inspect the fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damage connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel pressure sensor SUPPLY pin and the fuel pressure RETURN pin at the fuel pressure sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

A damage sensor has been detected.

Replace the fuel pressure sensor. Refer to Procedure 019-153 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ecm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damage connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pressure sensor RETURN pin in the engine harness connector 1 and the engine harness fuel pressure sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

n/a

  • Measure the resistance between the fuel pressure SIGNAL pin in engine harness connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the fuel pressure SIGNAL pin in engine harness connector 1 to all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pressure SUPPLY pin in engine harness connector 1 to all other pins in the engine connector 1.
  • Measure the resistance between the fuel pressure SUPPLY pin in engine harness connector 1 to all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 547 - Fuel Pressure Sensor Circuit, Secondary - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 547 inactive?
STEP 2. | Check the fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 546 active and Fault Code 547 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 547 inactive?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 547 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 547 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel pressure sensor and connector pins.

Guided Step 2A - Inspect the fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-153 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OF
  • Disconnect the secondary fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel pressure sensor SUPPLY pin and the fuel pressure RETURN pin at the fuel pressure sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel pressure SUPPLY pin and the fuel pressure SIGNAL pin at the fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO

A damaged sensor has been detected.

Replace the fuel pressure sensor. Refer to Procedure 019-153 in Section 19.

 No Repair

Go to 4B

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ecm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the engine harness fuel pressure sensor connector SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SIGNAL pin in the engine harness fuel pressure sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pressure SIGNAL pin in engine harness ECM connector 1 to all other pins in the connector 1.
  • Measure the resistance between the fuel pressure SIGNAL pin in engine harness ECM connector 1 to all other pins in the connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Check for a pin ground short.

  • Measure the resistance between the fuel pressure SIGNAL pin in engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 22-Feb-2012


FAULT CODE 551 - Idle Validation Switch Circuit - Both Switches Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 551 active?
STEP 2. | Check the idle validation switch. |
 | STEP 2A. Inspect the idle validation switch and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 551 active?
 | STEP 2C. Check the resistance of the idle validation switch. | On-idle resistance less than 125 ohms and Off-idle switch is more than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Both measurements greater than 100k ohms?
 | STEP 3B-1. Check for a short circuit to ground. |
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3C-1. Check for a short circuit from pin to pin. |
 | STEP 3D. Check for an inactive fault code. | Fault Code 551 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 551 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the idle validation switch.

Guided Step 2A - Inspect the idle validation switch and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the harness, or replace the switch, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the idle validation switch. Refer to Procedure 019-054 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Depress and release the accelerator pedal three times.

Fault Code 551 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the idle validation switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.
  • Make certain accelerator pedal is in the released position before measuring resistance.

Action

Check the resistance of the switch.

  • Measure the resistance between the idle validation on-idle SIGNAL pin to the RETURN pin in the idle validation OEM harness sensor connector.
  • Measure the resistance from the idle validation off-idle SIGNAL pin to the RETURN pin in the idle validation OEM harness sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

On-idle resistance less than 125 ohms and Off-idle switch is more than 100k ohms?
YES NO
No Repair

Replace the idle validation switch. Refer to Procedure 019-054 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the engine harness ECM connector to engine block ground.

Both measure greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 31 pin OEM connector.
  • Disconnect engine harness connector 2 from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the engine harness ECM connector to engine block ground.

Greater than 100k ohms?
YES NO

Repair or replace the OEM harnesses. OEM service manual.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance between the idle validation on-idle SIGNAL pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C-1

Guided Step 3C-1 - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the engine harness at the 23 pin and 31 pin OEM connectors.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance between the idle validation on-idle SIGNAL pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.

Greater than 100k ohms?
YES NO

Repair or replace the OEM harnesses. OEM service manual.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3D - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 551 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch ON
  • Depress and release the accelerator pedal three times
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Feb-2012


FAULT CODE 561 - Engine Cylinder Number 1 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 561 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor and sensor connector. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the turbocharger wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check to see if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 561 inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Reference Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 561 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face
  • Damage to the mounting stud or bolt
  • Poor installation, such as incorrect torque
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem:

  • Reference the Ignition System troubleshooting procedures in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

Repair or replace the damaged components.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-016 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-016 in Section 13.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

Set the air compressor timing.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Cylinder 1 spark plug removed.

Action

Inspect for cylinder damage.

  • Use a borescope to inspect cylinder 1 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Reference the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206.
  • Reference the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 561 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 562 - Engine Cylinder Number 2 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 562 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor and sensor connector. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the turbocharger wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check to see if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 562 inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Reference Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 562 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face
  • Damage to the mounting stud or bolt
  • Poor installation, such as incorrect torque
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem:

  • Reference the Ignition System troubleshooting procedures in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

Repair or replace the damaged components.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-016 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-016 in Section 13.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 Section 3.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

Set the air compressor timing.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Cylinder 2 spark plug removed.

Action

Inspect for cylinder damage.

  • Use a borescope to inspect cylinder 2 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Reference the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206.
  • Reference the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 562 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 563 - Engine Cylinder Number 3 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 563 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor and sensor connector. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the turbocharger wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check to see if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 563 inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Reference Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 563 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face
  • Damage to the mounting stud or bolt
  • Poor installation, such as incorrect torque
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem:

  • Reference the Ignition System troubleshooting procedures in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

Repair or replace the damaged components.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-016 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-016 in Section 13.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

Set the air compressor timing.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Cylinder 3 spark plug removed.

Action

Inspect for cylinder damage.

  • Use a borescope to inspect cylinder 3 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Reference the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206
  • Reference the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 563 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 564 - Engine Cylinder Number 4 Knock - Data Valid but Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 564 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor and sensor connector. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the turbocharger wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check to see if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 564 inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Reference Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 564 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face
  • Damage to the mounting stud or bolt
  • Poor installation, such as incorrect torque
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem:

  • Reference the Ignition System troubleshooting procedures in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

Repair or replace the damaged components.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-016 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-016 in Section 13.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

Set the air compressor timing.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Cylinder 4 spark plug removed.

Action

Inspect for cylinder damage.

  • Use a borescope to inspect cylinder 4 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Reference the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206.
  • Reference the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 564 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 565 - Engine Cylinder Number 5 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 565 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor and sensor connector. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the turbocharger wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for cylinder damage. | Evidence of damage?
STEP 3. | Check engine engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check to see if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 565 inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Reference Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 565 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face
  • Damage to the mounting stud or bolt
  • Poor installation, such as incorrect torque
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem:

  • Reference the Ignition System troubleshooting procedures in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

Repair or replace the damaged components.

  • Use the following procedures in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 or Refer to Procedure 013-016 in Section 13.
  • Use the following procedures in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 or Refer to Procedure 013-016 in Section 13.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

Set the air compressor timing.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Cylinder 5 spark plug removed.

Action

Inspect for cylinder damage.

  • Use a borescope to inspect cylinder 5 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Reference the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206.
  • Reference the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 565 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Dec-2012


FAULT CODE 566 - Engine Cylinder Number 6 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 572 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 566 active?
STEP 2. | Check the knock sensor and related components. |
 | STEP 2A. Inspect the knock sensor and sensor connector. | Any knock sensor damage?
 | STEP 2B. Check for an ignition related problem. | Ignition system operating properly?
 | STEP 2C. Check the turbocharger wastegate. | Is the turbocharger wastegate functioning properly?
 | STEP 2D. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 2E. Check the air compressor timing. | Air compressor timed correctly?
 | STEP 2F. Check for cylinder damage. | Evidence of damage?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check to see if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 566 inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Reference Fault Code 572

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 566 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor and related components.

Guided Step 2A - Inspect the knock sensor and sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face
  • Damage to the mounting stud or bolt
  • Poor installation, such as incorrect torque
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check for an ignition related problem.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem:

  • Reference the Ignition System troubleshooting procedures in the Engine Performance Troubleshooting Tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

An ignition related problem has been detected.

Repair or replace the damaged components.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-016 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13.

Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-016 in Section 13.

Go to 2C

Go to 2F

Guided Step 2C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-050 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-050 in Section 10.

Go to 2D

Go to 2F

Guided Step 2D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 2E

Go to 3A

Guided Step 2E - Check the air compressor timing.

Conditions

  • Turn keyswitch OFF.

Action

Check the air compressor timing:

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Air compressor timed correctly?
YES NO
No Repair

An incorrectly timed air compressor has been detected.

Set the air compressor timing.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 012-014 in Section 12.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 012-014 in Section 12.

Go to 3A

Go to 3A

Guided Step 2F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Cylinder 6 spark plug removed.

Action

Inspect for cylinder damage.

  • Use a borescope to inspect cylinder 6 for knock damage.

Evidence of damage?
YES NO

Replace the damaged components.

  • Reference the C8.3G, C Gas Plus, and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206.
  • Reference the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Engines Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 566 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 572 - Knock Sensor Circuit - Shorted Low, Front Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 572 active?
STEP 2. | Check the knock sensor. |
 | STEP 2A. Inspect the engine harness and knock sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 572 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 572 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 572 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 572 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362

Guided Step 2 - Check the knock sensor.

Guided Step 2A - Inspect the engine harness and knock sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensors 1 and 2.

Action

Inspect the engine harness and knock sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ecm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Read the fault codes using INSITE™.

Fault Code 572 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the engine harness from knock sensors 1 and 2.

Action

Check for an open circuit.

  • Measure the resistance between the knock 1 positive (+) pin in the engine harness ECM connector to the knock 1 positive (+) pin in the sensor harness connector.
  • Measure the resistance between the knock 1 negative (-) pin in the engine harness ECM connector to the knock 1 negative (-) pin in the sensor harness connector.
  • Measure the resistance between the knock 2 positive (+) pin in the engine harness ECM connector to the knock 2 positive (+) pin in the sensor harness connector.
  • Measure the resistance between the knock 2 negative (-) pin in the engine harness ECM connector to the knock 2 negative (-) pin in the sensor harness connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-214 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the engine harness from knock sensors 1 and 2.

Action

Check for a short circuit to ground.

  • Measure the resistance between the knock 1 positive (+) pin in the engine harness ECM connector to engine block ground.
  • Measure the resistance between the knock 2 positive (+) pin in the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from knock sensors 1 and 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the knock 1 positive (+) pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the knock 1 positive (+) pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.
  • Measure the resistance between the knock 2 positive (+) pin in engine harness ECM connector 2 to all other pins in the connector.
  • Measure the resistance from the knock 2 positive (+) pin in engine harness ECM connector 2 to all pins in engine harness ECM connector 1.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 572 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 572 is inactive.

Fault Code 572 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 584 - Starter Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 584 inactive?
STEP 2. | Check the starter lockout relay and circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Check engine control module and engine harness |
 | STEP 4A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the starter lockout supply in the engine harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-pin short in the unswitched battery supplies in the engine harness. | Less than 100K ohms?
 | STEP 4D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault codes. | Fault code 584 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

Inactive or intermittent fault code.

Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 5B

Go to 2A

Guided Step 2 - Check the starter lockout relay and circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Inspect the OEM harness and starter lockout relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Repair the damaged harness, connector, or pins if possible.

See the OEM Wiring Harness. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance and check for an open circuit between the starter lockout relay signal pin and the starter lockout relay RETURN pin.

Use the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10K ohms?
YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance of the starter lockout relay connector to ground.

Use the circuit description or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. See the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the malfunctioning connection.

Clean, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31 pin OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31 pin OEM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM engine harness connector.

Use the circuit description or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31 pin OEM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM connector and all other pins in the OEM connector.

Use the circuit description or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check engine control module and engine harness.

Guided Step 4A - Inspect engine control module and engine harness connector pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the engine control module.

Action

Inspect the engine harness and engine control module connectors pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine control module connectors or engine harness connectors.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Repair the damaged harness, connector, or pins, if possible.

Repair the harness. Refer to Procedure 019-204 in Section 19.

Replace the harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the starter lockout supply in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector 2 from the engine control module.
  • Disconnect 31 Pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout SUPPLY pin in the engine connector 2 and 31 pin OEM connector.

Use the circuit description or circuit diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

Repair the damaged harness, connector, or pins, if possible.

Repair the harness. Refer to Procedure 019-204 in Section 19.

Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short in the unswitched battery supplies in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the engine control module.
  • Disconnect 31 Pin OEM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout SUPPLY pin in the engine connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the starter lockout SUPPLY pin in the engine connector 2 and all other pins in the engine connector 1.

Use the circuit description or circuit diagram for connector pin identification.

Less than 100K ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness.

Repair the damaged harness, connector, or pins, if possible.

Repair the harness. Refer to Procedure 019-204 in Section 19.

Replace the harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 584 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code inactive

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 585 - Starter Relay Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check the starter lockout relay and circuit. |
 | STEP 2A. Check the starter lockout relay resistance. | Greater than 6 ohms?
 | STEP 2B. Check for a pin-to-ground short circuit in the starter lockout relay. | Greater than a 100K ohms
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM and engine harness |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit in the engine and OEM harness. | Greater than 100K ohms?
 | STEP 4C. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 4D. Check for an inactive fault code. | Fault Code 585 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault codes. | Fault code 585 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES NO
No Repair

Inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5B

Guided Step 2 - Check the starter lockout relay and circuit.

Guided Step 2A - Check starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 2B

Go to 5A

Guided Step 2B - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance and check for a short circuit between the starter lockout relay signal pin and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?

YES NO
No Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31 pin OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the 31 pin OEM connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin n the OEM harness ECM connector and ground.

Use the circuit description or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin-to-in short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 31 Pin OEM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pns in the OEM harness ECM connector.

See the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Go to 4A

Go to 5A

Guided Step 4 - Check ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.

Action

Inspect the engine harness and engine control module connectors pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connectors or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the harness. Refer to Procedure 019-204 in Section 19.

Replace the harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to-pin short in the engine and OEM harness.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect 31 Pin OEM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout SUPPLY pin in the engine harness ECM engine connector 2 and all other pins in the engine connector 2.
  • Measure the resistance between the starter lockout sensor SUPPLY pin in the engine harness ECM engine connector 2 and all other pins in the connector 1.

Use the circuit description or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the starter lockout supply line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect 31 Pin OEM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout SUPPLY pin in the engine harness ECM engine connector 2 and ground.

Use the circuit description or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the sensor supply number 1 line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 585 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 591 - Exhaust Back Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2185. | Fault Code 2185 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 591 inactive?
STEP 2. | Check the exhaust back pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust back pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 592 active and Fault Code 591 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 591 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit from in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit from in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 591 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 591 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2185.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Fault Code 2185

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 591 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust back pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust back pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust back pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 592 active and Fault Code 591 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the supply voltage between 5 Volt SUPPLY pin and the exhaust back pressure RETURN pin at the exhaust back pressure sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust back pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 591 active?
YES NO

A damaged sensor has been detected.

  • Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the exhaust back pressure sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust back pressure SIGNAL pin in engine harness connector 2 and all other pins in engine connector 2.
  • Measure the resistance from the exhaust back pressure SIGNAL pin in engine harness connector 2 to all pins in engine connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust back pressure sensor 5 Volt SUPPLY pin in engine harness connector 1 and all other pins in ECM connector 1.
  • Measure the resistance from the exhaust back pressure sensor 5 Volt SUPPLY pin in engine harness connector 1 and all pins in ECM connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 591 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 591 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 592 - Exhaust Back Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3824775 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2186 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 592 inactive?
STEP 2. | Check the exhaust back pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust back pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 592 active and Fault Code 591 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 591 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit from in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 592 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 592 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2186.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Fault Code 2186

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 592 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust back pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust back pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust back pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the supply voltage between 5 Volt SUPPLY pin and the exhaust back pressure RETURN pin at the exhaust back pressure sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust back pressure SUPPLY pin and the exhaust back pressure SIGNAL pin at the exhaust back pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 591 active and Fault Code 592 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust back pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 592 active?
YES NO

A damaged sensor has been detected.

  • Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in Section 19.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 SUPPLY pin and the engine harness exhaust back pressure connector sensor SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 SIGNAL pin and the engine harness exhaust back pressure sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust back pressure SIGNAL pin in engine harness ECM connector 2 and all other pins in the connector 2.
  • Measure the resistance from the exhaust back pressure SIGNAL pin in engine harness ECM connector 2 to all pins in the connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the exhaust back pressure SIGNAL pin in engine harness ECM connector 2 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 592 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 592 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 613 - Engine Misfire For Multiple Cylinders - Data Valid But Below Normal Operating Level - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury, do not touch any ignition wires or components while the engine is operating, unless using suitably insulated tools.
WARNING

The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Any non-ignition related fault codes?
 | STEP 1B. Check for an active fault code. | Fault Code 613 active?
STEP 2. | Check the ignition coils and spark plugs. |
 | STEP 2A. Inspect the ignition coil connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the coils. | Steady spark observed?
 | STEP 2C. Check the spark plugs. | Spark plug damage or wear?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Inspect the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin short circuit to ground in the ignition harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check for voltage at the coils. | Steady spark observed?
 | STEP 3F. Check for voltage at the coils. | Steady spark observed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Start the engine.

Action

Operate the engine under the conditions in which the misfire occured.

  • Use INSITE™ electronic service tool to read the fault codes.

Any non-ignition related fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the non-ignition related fault codes.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Start the engine.

Action

Operate the engine under the conditions in which the misfire occured.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 613 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coils and spark plugs.

Guided Step 2A - Inspect the ignition coil connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ICM connector C1 from the ICM.
  • Disconnect ignition harness from all of the ignition coils.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-037 in Section 13.
  • Replace the ignition coil. Replace the harness. Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

No Repair

Go to 4B

Go to 2B

Guided Step 2B - Check for voltage at the coils.

Conditions

  • Turn keyswitch ON.

Action

Check the ignition coils of the misfiring cylinders.

  • Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.
  • Test the misfiring cylinders to determine if the plugs are receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

The coils must be tested in the vertical position or damage to the coils can result.

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the spark plugs.

Conditions

  • Turn keyswitch OFF.
  • Remove all of the spark plugs.

Action

Inspect the spark plugs for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Worn or missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-016 in Section 13.

Spark plug damage or wear?
YES NO

  • Correct the spark plug gap. Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 4B

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Inspect the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the Iignition harness and ICM connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM or ignition harness connector.

Repair the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

No Repair

Go to 4B

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ICM connector 2.
  • Disconnect the ignition harness from all of the coils.

Action

Check for an open circuit in the ignition harness.

  • Measure the resistance between the ignition harness ICM connector C2 primary RETURN pins and the ignition harness coil connector primary RETURN pins.
  • Measure the resistance between the ignition harness ICM connector C2 charge voltage pin and the ignition harness coil connector charge voltage pins.
  • Measure the resistance between the ignition harness ICM connector C2 secondary RETURN pin and the ignition harness coil connector secondary RETURN pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ignition harness. Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-037 in Section 13.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the ignition harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from all of the coils.

Action

Check for an open circuit in the ignition harness.

  • Measure the resistance between the charge voltage pins at the coil connectors and engine block ground.
  • Measure the resistance between the secondary return pin at the coil connectors and engine block ground.
  • Measure the resistance between the primary return pin at the coil connectors and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the ignition harness.

Repair or replace the ignition harness, with the damaged pins.

  • Repair the ignition harness. Refer to Procedure 019-203 in Section 19.
  • Repair the ignition harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ignition harness. Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-037 in Section 13.

Go to 3D

Go to 4B

Guided Step 3D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from the ignition coils.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between the secondary RETURN pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance the primary RETURN pins in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin-to-pin short circuit has been identified in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Repair the ignition harness. Refer to Procedure 019-203 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Replace the ignition harness. Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-037 in Section 13.

Go to 3E

Go to 4A

Guided Step 3E - Check for voltage at the coils.

Conditions

  • Turn keyswitch ON.

Action

Check the ignition coils of the misfiring cylinders.

  • Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.
  • Test the misfiring cylinders to determine if the plugs are receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

The coils must be tested in the vertical position or damage to the coils can result.

Steady spark observed?
YES NO
No Repair

  • Replace the ignition coil. Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Go to 4A

Go to 3F

Guided Step 3F - Check for voltage at the coils.

Conditions

  • Turn keyswitch ON.

Action

Check the ignition coils of the misfiring cylinders.

  • Use the following procedure found in the C8.3G C Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.
  • Test the misfiring cylinders to determine if the plugs are receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

The coils must be tested in the vertical position or damage to the coils can result.

Steady spark observed?
YES NO
No Repair

  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 613 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 689 - Primary Engine Speed Sensor Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 689 inactive?
STEP 2. | Check the crankshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the crankshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the crankshaft speed/position sensor. | Damage sensor tip?
 | STEP 2D. Verify adequate crankshaft speed/position senor air gap. | Distance is between 41.36 mm [1.63 in] and 42.65 mm [1.68 in]?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 689 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3G. Check for an inactive fault code. | Fault Code 689 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 or 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the crankshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect crankshaft speed/position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-365 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect crankshaft speed/position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the crankshaft speed/position SUPPLY pin and the crankshaft speed/position RETURN pin at the crankshaft speed/position sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for component pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the crankshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the crankshaft speed/position sensor from the engine.

Action

Inspect the camshaft speed/position sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A damaged sensor has been detected.

Replace the crankshaft speed/position sensor. Refer to Procedure 019-365 in Section 19.

Inspect the crankshaft tone wheel/gear teeth for damage or spinning. Sensor clearance is between 41.36 mm [1.63 in] and 42.65 mm [1.68 in]. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 001-013 in Section 1.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Verify adequate crankshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove crankshaft speed/position sensor from the engine.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the edge of the tone wheel.

Distance is between 41.36 mm [1.63 in] and 42.65 mm [1.68 in]?
YES NO
No Repair

Inspect the crankshaft tone wheel/gear teeth for damage or spinning. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 001-013 in Section 1.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.

Action

Inspect the engine harness and ecm connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

 No Repair

Go to 4B

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.
  • Disconnect the crankshaft speed/position sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the crankshaft speed/position sensor connector RETURN pin.
  • Measure the resistance between the ECM connector 1 SUPPLY pin and the crankshaft speed/position sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 SIGNAL pin and the crankshaft speed/position sensor connector SIGNAL pin.

Shake and wiggle the harness to determine an intermittent connection.

Shake and wiggle the harness to determine an intermittent connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return current has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the crankshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the crankshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

 No Repair

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON or Run/Stop switch to the RUN position.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON or Run/Stop switch to the RUN position.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-May-2012


FAULT CODE 751 - B and C Gas Plus - Gas Mass Flow Sensor Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active Fault Codes 455 and 511. | Fault Codes 455 and 511 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 751 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check the fuel supply | Fuel supply sufficient?
 | STEP 2B. Check the primary fuel inlet pressure. | Fuel pressure between 517 to 1138 kPa [75 to 165 psia]?
 | STEP 2C. Check the secondary fuel inlet pressure. | Pressure correct for the engine family?
 | STEP 2D. Check for a stuck open or sticking fuel control valve. | Secondary fuel pressure drop within 50 seconds of key ON?
 | STEP 2E. Check the laminar flow screen. | Deposits or evidence of oil?
 | STEP 2F. Check for oil in the air fuel mixer housing. | Evidence of oil?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 751 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active Fault Codes 455 and 511.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active 455 and 511 fault code.

  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Codes 455 and 511 active?
YES | NO
No Repair | No Repair

Fault Code 455 or 511

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 751 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check the fuel supply.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle's fuel supply.

  • Verify that there is sufficient fuel in the vehicle's gas tank. There will be an original equipment manufacturer (OEM) pressure gauge to view the tank pressure.

Fuel supply sufficient?
YES NO
No Repair

Refuel the vehicle.

Go to 2B

Go to 3A

Guided Step 2B - Check the primary fuel inlet pressure.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the primary fuel pressure.

  • Use INSITE™ electronic service tool to monitor the fuel pressure.

All pressure sensors on the C8.3G Plus engine are absolute pressure sensors.

Fuel pressure between 517 to 1138 kPa [75 to 165 psi]?
YES NO
No Repair

Replace the primary regulator. Use the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check the secondary fuel inlet pressure.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Use INSITE™ electronic service tool to monitor the fuel pressure.
  • Maximum secondary fuel pressures are different depending on engine platform. See below:

B Gas Plus - 414 kPa [60 psi]

B LPG Plus - 220 kPa [32 psi]

C Gas Plus - 517 kPa [75 psia]

All pressure sensors on the Gas Plus engines are absolute pressure sensors.

Pressure correct for the engine family?
YES NO
No Repair

Replace the secondary regulator.

  • Use the following procedure in the B5.9g, B5.9 LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-047 in Section 5.
  • Use the following procedure in the C8.3g, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-047 in Section 5.

Go to 2D

Go to 3A

Guided Step 2D - Check for a stuck or sticking fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the secondary fuel pressure while keyswitch is ON.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the gas mass flow sensor to read more fuel than is commanded by the ECM. This will allow Fault Code 751 to occur, but the fuel control valve is actually the root cause.

Secondary fuel pressure drop within 50 seconds of keyswitch ON?
YES NO

A malfunctioning fuel control valve has been detected.

  • Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.
  • Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the laminar flow screen.

Conditions

  • Turn keyswitch OFF.

Action

Check for deposits on the laminar flow screen.

  • Remove the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.
  • Inspect the laminar flow screen for deposits, damage, and oil contamination.

Deposits or evidence of oil?
YES NO

Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

 No Repair

Go to 3A

Go to 2F

Guided Step 2F - Check for oil in the air fuel mixer housing.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil in the air fuel mixer housing and on the sensor components.

  • Remove the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.
  • Check for compressor station oil contaminating in the gas mass flow sensor.

Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check his gas compression station for oil carry over.

Evidence of oil?
YES NO

  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Clean the fuel system.

Use the following procedures in the B5.9g, B5.9 LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

  • Refer to Procedure 005-009 in Section 5.
  • Refer to Procedure 005-047 in Section 5.

Use the following procedures in the C8.3g, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

  • Refer to Procedure 005-009 in Section 5.
  • Refer to Procedure 005-047 in Section 5.
  • Use INSITE™ electronic service tool, to reset the fuel tables.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 751 is inactive.

Fault Code 751 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-May-2013


FAULT CODE 751 - L Gas Plus - Gas Mass Flow Sensor Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active Fault Codes 455 and 511. | Fault Codes 455 and 511 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 751 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check the fuel supply | Fuel supply sufficient?
 | STEP 2B. Check the primary fuel inlet pressure. | Fuel pressure between 517 to 1138 kPa [75 to 165 psia]?
 | STEP 2C. Check the secondary fuel inlet pressure. | Is pressure above 75 psia?
 | STEP 2D. Check for a stuck open or sticking fuel control valve. | Secondary fuel pressure drop within 50 seconds of key ON?
 | STEP 2E. Check the laminar flow screen. | Deposits or evidence of oil?
 | STEP 2F. Check for oil in the air fuel mixer housing. | Evidence of oil?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 751 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Codes 455 and 511 for being active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active Fault Code 455 and 511.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 455 or 511 active?
YES | NO
No Repair | No Repair

Fault Codes 455 or 511

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 751 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check the fuel supply.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle's fuel supply.

  • Verify that there is sufficient fuel in the vehicle's gas tank. There will be an OEM pressure gauge to view the tank pressure.

Fuel supply sufficient?
YES NO
No Repair

Refuel the vehicle.

Go to 2B

Go to 3A

Guided Step 2B - Check the primary fuel inlet pressure.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the primary fuel pressure.

  • Use INSITE™ electronic service tool to monitor the fuel pressure.

All pressure sensors on Gas Plus engine are absolute pressure sensors.

Fuel pressure between 517 to 1138 kPa [75 to 165 psia]?
YES NO
No Repair

Replace the primary regulator. Use the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check the secondary fuel inlet pressure.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Use INSITE™ electronic service tool to monitor the fuel pressure.

All pressure sensors on Gas Plus engine are absolute pressure sensors.

Is pressure above 517 kPa [75 psia]?
YES NO
No Repair

Replace the secondary regulator.

  • Use the following procedure in the C8.3G, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-047 in Section 5.

Go to 2D

Go to 3A

Guided Step 2D - Check for a stuck or sticking fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the secondary fuel pressure while keyswitch is ON.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the gas mas flow sensor to read more fuel than is commanded by the ECM. This will allow Fault Code 751 to occur, but the fuel control valve is actually the root cause.

Secondary fuel pressure drop within 50 seconds of keyswitch ON?
YES NO

A malfunctioning fuel control valve has been detected.

Replace the fuel control valve.

  • Refer to Procedure 019-102 in Section 19.
  • Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the laminar flow screen.

Conditions

  • Turn keyswitch OFF.

Action

Check for deposits on the laminar flow screen.

  • Remove the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.
  • Inspect the laminar flow screen for deposits, damage, and oil contamination.

Deposits or evidence of oil?
YES NO

  • Replace the fuel shutoff valve. Refer to Procedure 019-050 in Section 19.

 No Repair

Go to 3A

Go to 2F

Guided Step 2F - Check for oil in the air fuel mixer housing.

Conditions

  • Turn keyswitch OFF.

Action

Check for oil in the air fuel mixer housing and on the sensor components.

  • Remove the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.
  • Check for compressor station oil contaminating in the gas mass flow sensor.

Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter than there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil?
YES NO

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Clean the fuel system. Use the following procedures in the C8.3G, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

  • Refer to Procedure 005-009 in Section 5.
  • Refer to Procedure 005-047 in Section 5.
  • Other objects in the fuel mixer housing and fuel system will possibly need to be changed if there is significant evidence of oil contamination.
  • Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 751 is inactive.

Fault Code 751 inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Apr-2012


FAULT CODE 752 - B and C Gas Plus - Heated Oxygen Sensor Error

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 453, 454, 455, 511, and/or 751 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 752 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 2B. Check for a stuck open or sticking fuel control valve. | Secondary fuel pressure drop within 50 seconds of key ON?
 | STEP 2C. Gas Mass Flow Compensation correct. | Is the gas flow compensation a positive 25 or higher?
STEP 3. | Check Base engine components. |
 | STEP 3A. Check for an exhaust leak. | Any exhaust leaks?
STEP 4. | Check the engine harness and heated oxygen sensor. |
 | STEP 4A. Check the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
 | STEP 4C. Check the heated oxygen sensor heater supply voltage. | Voltage greater than 12-VDC?
 | STEP 4C-1. Check for an open circuit in the engine harness. |
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4G. Verify oxygen sensor operation. | Did the sensor pass the test?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 752 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool..

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 453, 454, 455, 511, and/or 751 active?
YES NO

Troubleshoot any remaining fault codes before proceeding.

 No Repair

Fault Codes 453, 454, 455, 511, or 751 first.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Fuel System.

Guided Step 2A - Verify secondary fuel pressure.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Use INSITE™ electronic service tool to monitor the fuel pressure.
  • Secondary fuel pressures are different depending on engine platform. See below:

B Gas Plus - 60 psia Minimum

B LPG Plus - 40 psia Minimum

C Gas Plus - 75 psia Minimum

All pressure sensors on the gas plus engines are absolute pressure sensors.

It might be necessary to perform a stall test to monitor dynamic secondary fuel pressure. If fuel pressure is not adequate, then the engine will surge under load, possibly causing this fault to occur. Engine Performance Troubleshooting Tree in Section TT.

Is pressure correct for the engine family?
YES NO
No Repair

Engine Performance Troubleshooting Tree in Section TT.

Go to 2B

Go to 5A

Guided Step 2B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the secondary fuel pressure while keyswitch is ON.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Secondary fuel pressure drop within 50 seconds of keyswitch ON?
YES NO

A defective fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Gas Mass Flow Compensation incorrect.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine at stall conditions.

Action

Monitor the gas mass flow compensation.

  • Use INSITE™ electronic service tool to monitor the gas mass flow compensation.

Oil contamination of the gas mass flow sensor will cause a low flow reading and over-compensate for fuel flow. If the engine is running rich and a Fault Code 752 is active, the gas mass flow sensor must be inspected. Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Is the gas flow compensation a positive 25 or higher?
YES NO

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check base engine components.

Guided Step 3A - Check an exhaust leak.

Conditions

  • Turn keyswitch OFF.

Action

Check for an exhaust leak between the exhaust manifold and the heated oxygen sensor.

  • Check all gaskets
  • Check all castings
  • Check all pipe plugs.

Any exhaust leaks?
YES NO

An exhaust leak has been detected.

Repair or replace any exhaust component.

  • Use the following procedure in the B5.9G, B5.9 LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164Refer to Procedure 011-007 in Section 11.
  • Use the following procedure in the C8.3G, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 011-007 in Section 11.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the engine harness and heated oxygen sensor.

Guided Step 4A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness connector 2 and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check heated oxygen sensor resistance.

  • Measure the resistance between the heated oxygen sensor heater SUPPLY pin and the heated oxygen sensor heater RETURN pin at the heated oxygen sensor connector.
  • Make sure to check the resistance at room temperature (23°C [73°F] ± 5 degrees).

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 4C

Go to 5A

Guided Step 4C - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES | NO
No Repair | No Repair

Go to 4D

Go to 4C-1

Guided Step 4C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 heated oxygen heater RETURN pin and the engine harness heated oxygen sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line in the OEM harness.

Check for an open circuit in the OEM switched battery supply to the heated oxygen sensor supply.

Repair the damaged pins. Replace the engine harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the 10 Ampere heater supply fuse. Refer to Procedure 019-198 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and the engine harness heated oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and the engine harness heated oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor reference RETURN pin and the engine harness heated oxygen sensor connector reference RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current signal or reference return circuit has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and the engine block ground.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and the engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19,

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the heated oxygen sensor test using the INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to activate the heated oxygen sensor test. Follow the directions given by the INSITE™ electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 752 is inactive.

Fault Code 752 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Apr-2012


FAULT CODE 752 - L Gas Plus - Heated Oxygen Sensor Error

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 453, 454, 455, 511, and/or 751 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 752 inactive?
STEP 2. | Check the fuel system. |
 | STEP 2A. Verify secondary fuel pressure. | Is pressure correct for the engine family?
 | STEP 2B. Check for a stuck open fuel control valve. | Secondary fuel pressure drop within 50 seconds of key ON?
 | STEP 2C. Gas mass flow compensation correct. | Is the gas flow compensation a positive 25 or higher?
STEP 3. | Check Base engine components. |
 | STEP 3A. Check for an exhaust leak. | Any exhaust leaks?
 | STEP 3B. Check heated oxygen sensor location. | Is sensor between 203.2 to 457.2 cm [8 to 18 inches] from the turbocharger outlet?
STEP 4. | Check the engine harness and heated oxygen sensor. |
 | STEP 4A. Check the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
 | STEP 4C. Check the heated oxygen sensor heater supply voltage. | Voltage greater than 12-VDC?
 | STEP 4C-1. Check for an open circuit in the engine harness. |
 | STEP 4D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4E. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 4F. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4G. Verify oxygen sensor operation. | Did the sensor passs the test?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 752 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 453, 454, 455, 511, and/or 751 active?
YES NO

Troubleshoot any remaining fault codes before proceeding.

 No Repair

Fault Codes 453, 454, 455, 511, or 751 first.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Fuel System.

Guided Step 2A - Verify secondary fuel pressure.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Use INSITE™ electronic service tool to monitor the fuel pressure.
  • Secondary fuel pressures are different depending on engine platform. See below:

B Gas Plus - 60 psia Minimum

B LPG Plus - 40 psia Minimum

C and L Gas Plus - 75 psia Minimum

All pressure sensors on the Gas Plus engines are absolute pressure sensors.

It might be necessary to perform a stall test to monitor dynamic secondary fuel pressure. If fuel pressure is not adequate, then the engine will surge under load, possibly causing this fault to occur. Reference the Engine Performance Troubleshooting Tree in Section TT.

Is pressure correct for the engine family?
YES NO
No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT.

Go to 2B

Go to 5A

Guided Step 2B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the secondary fuel pressure while keyswitch is ON.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Secondary fuel pressure drop within 50 seconds of keyswitch ON?
YES NO

A malfunctioning fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Gas mass flow compensation incorrect.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run engine at stall conditions.

Action

Monitor the gas mass flow compensation.

  • Use INSITE™ electronic service tool to monitor the gas mass flow compensation.

Oil contamination of the gas mass flow sensor will cause a low flow reading and over-compensate for fuel flow. If the engine is running rich and a Fault Code 752 is active, the gas mass flow sensor must be inspected. Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Is the gas flow compensation a positive 25 or higher?
YES NO

  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.
  • Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check base engine components.

Guided Step 3A - Check an exhaust leak.

Conditions

  • Turn keyswitch OFF.

Action

Check for an exhaust leak between the exhaust manifold and the heated oxygen sensor.

  • Check all gaskets
  • Check all castings
  • Check all pipe plugs.

Any exhaust leaks?
YES NO

An exhaust leak has been detected.

  • Repair or replace any exhaust component. Use the following procedure in the C8.3G, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 011-007 in Section 11.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the heated oxygen sensor location.

Conditions

Turn keyswitch OFF.

Action

Check heated oxygen sensor location.

  • Measure the distance from the turbocharger outlet to the location of the heated oxygen sensor.

Is sensor between 203.2 to 457.2 cm [8 to 18 inches] from the turbocharger outlet?
YES NO
No Repair

The OEM has installed the heated oxygen sensor in the wrong location. Return the vehicle to the OEM for proper installation.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness and heated oxygen sensor.

Guided Step 4A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness connector 2 and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check heated oxygen sensor resistance.

  • Measure the resistance between the heated oxygen sensor heater SUPPLY pin and the heated oxygen sensor heater RETURN pin at the heated oxygen sensor connector.
  • Make sure to check the resistance at room temperature (23°C [73°F] ± 5 degrees).

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12-VDC?
YES | NO
No Repair | No Repair

Go to 4D

Go to 4C-1

Guided Step 4C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 1 heated oxygen heater RETURN pin and the engine harness heated oxygen sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line in the OEM harness.

Check for an open circuit in the OEM switched battery supply to the heated oxygen sensor supply.

Repair the damaged pins. Replace the engine harness or OEM harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the 10 Ampere heater supply fuse. Refer to Procedure 019-198 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and the engine harness heated oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and the engine harness heated oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor reference RETURN pin and the engine harness heated oxygen sensor connector reference RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current signal or reference return circuit has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and the engine block ground.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and the engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 2.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the engine harness connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the heated oxygen sensor test.

  • Use INSITE™ electronic service tool to activate the heated oxygen sensor test. Follow the directions given by the INSITE™ electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.
  • Use INSITE™ electronic service tool to reset the fuel tables.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 752 is inactive.

Fault Code 752 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Apr-2012


FAULT CODE 753 - B and C Gas Plus - Engine Position Sensor Synchronization Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 753 active?
STEP 2. | Check the engine position sensor. |
 | STEP 2A. Inspect the engine harness and engine position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the sensor for damage. | Damage found?
 | STEP 2C. Check the resistance of the sensor. | 1000 to 2000 ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2E. Read the fault codes. | Fault Code 753 active?
 | STEP 2F. Verify adequate camshaft speed/position sensor air gap. | Distance is between 33.81 mm [1.33 in] and 34.06 mm [1.34 in]?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 753 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 753 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the engine position sensor.

Guided Step 2A - Inspect the engine harness and engine position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and engine position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-038 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Inspect the engine position sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damage found?
YES NO

Replace the sensor. Refer to Procedure 019-038 in Section 19.

Inspect the camshaft tone wheel/gear teeth for damage or spinning.

  • For B Series engines, use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 001-013 in Section 1.
  • For C Series engines, use the following procedure in the C8.3G, C Gas Plus and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 001-013 in Section 1.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the engine position sensor SIGNAL pin to the engine position sensor RETURN pin in the engine position sensor connector.
  • Measure the resistance from the engine position backup SIGNAL pin to the engine position backup RETURN pin in the engine position sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1000 to 2000 ohms?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-038 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position sensor.
  • Engine position sensor is installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the SIGNAL pin in the engine position sensor connector, sensor side, to the engine block ground.
  • Measure the resistance from the backup SIGNAL pin in the engine position sensor connector, sensor side, to the engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the sensor.

  • Repair the sensor. Refer to Procedure 019-201 in Section 19.
  • Replace the sensor. Refer to Procedure 019-038 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 753 active?
YES NO
No Repair

The removal and installation of the connector corrected the malfunction.

Go to 2F

Go to 3B

Guided Step 2F - Verify adequate camshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove camshaft speed/position sensor from the engine.

Action

Verify adequate air gap.

  • Measure the distance between the sensor o-ring sealing surface and the edge of the tone wheel.

Distance is between 33.81 mm [1.33 in] and 34.06 mm [1.34 in]?
YES NO
No Repair

Inspect the camshaft tone wheel/gear teeth for damage or spinning.

  • For B Series engines, use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 001-013 in Section 1.
  • For C Series engines, use the following procedure in the C8.3G, C Gas Plus and L Gas Plus Engines Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 001-013 in Section 1.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 753 is inactive.

Fault Code 753 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Mar-2015


FAULT CODE 753 - L Gas Plus - Engine Speed/Position Camshaft Synchronization Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 753 inactive?
STEP 2. | Check the camshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the camshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the camshaft speed/position sensor. | Damaged sensor tip?
 | STEP 2D. Verify adequate camshaft speed/position senor air gap. | Distance is between 30.16 mm [1.19 in] and 31.27 mm [1.23 in]?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 753 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3G. Check for an inactive fault code. | Fault Code 753 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 753 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 or 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 753 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the camshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the camshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect camshaft speed/position sensor from the engine harness.

Action

Inspect the engine harness and engine position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-365 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect camshaft speed/position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the camshaft speed/position SUPPLY pin and the camshaft speed/position RETURN pin at the camshaft speed/position sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for component pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the camshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the camshaft speed/position sensor from the engine.

Action

Inspect the camshaft speed/position sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A damaged sensor has been detected.

Replace the camshaft speed/position sensor. Refer to Procedure 019-365 in Section 19.

Inspect the camshaft tone wheel/gear teeth for damage or spinning. Sensor clearance is between 30.16 mm [1.19 in] and 31.27 mm [1.23 in]. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 001-013 in Section 1.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Verify adequate camshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove camshaft speed/position sensor from the engine.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the edge of the tone wheel.

Distance is between 30.16 mm [1.19 in] and 31.27 mm [1.23 in]?
YES NO
No Repair

Inspect the camshaft tone wheel/gear teeth for damage or spinning. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 001-013 in Section 1.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following: Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 753 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the camshaft speed/position sensor connector RETURN pin.
  • Measure the resistance between the ECM connector 1 SUPPLY pin and the camshaft speed/position sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 SIGNAL pin and the camshaft speed/position sensor connector SIGNAL pin.

Shake and wiggle the harness to determine an intermittent connection.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return current has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the camshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the camshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for pin-to-ground short.

  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 753 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON or Run/Stop switch to the RUN position
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 753 is inactive.

Fault Code 753 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON or run/stop switch to the RUN position.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-May-2012


FAULT CODE 778 - Secondary Engine Speed Sensor Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 778 inactive?
STEP 2. | Check the camshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the camshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the camshaft speed/position sensor. | Damage sensor tip?
 | STEP 2D. Verify adequate camshaft speed/position senor air gap. | Distance is between 30.16 mm [1.19 in] and 31.27 mm [1.23 in]?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 778 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3G. Check for an inactive fault code. | Fault Code 778 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 753 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 or 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the camshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the camshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect camshaft speed/position sensor from the engine harness.

Action

Inspect the engine harness and engine position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-365 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect camshaft speed/position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the camshaft speed/position SUPPLY pin and the camshaft speed/position RETURN pin at the camshaft speed/position sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for component pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the camshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the camshaft speed/position sensor from the engine.

Action

Inspect the camshaft speed/position sensor for the following:

  • Damage sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A damaged sensor has been detected.

  • Replace the camshaft speed/position sensor. Refer to Procedure 019-365 in Section 19.

Inspect the camshaft tone wheel/gear teeth for damage or spinning. Sensor clearance is between 30.16 mm [1.19 in] and 31.27 mm [1.23 in].

  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 001-013 in Section 1.
  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 001-013 in Section 1.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Verify adequate camshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove camshaft speed/position sensor from the engine.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the edge of the tone wheel.

Distance is between 30.16 mm [1.19 in] and 31.27 mm [1.23 in]?
YES NO
No Repair

Inspect the camshaft tone wheel/gear teeth for damage or spinning.

  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 001-013 in Section 1.
  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 001-013 in Section 1.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness from the ECM connector 1.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the camshaft speed/position sensor connector RETURN pin.
  • Measure the resistance between the ECM connector 1 SUPPLY pin and the camshaft speed/position sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 SIGNAL pin and the camshaft speed/position sensor connector SIGNAL pin.

Shake and wiggle the harness to determine an intermittent connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return current has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the camshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the camshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the camshaft speed/position sensor from the engine harness.

Action

Check for pin-to-ground short.

  • Measure the resistance between the camshaft speed/position SIGNAL pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON or run/stop switch to the RUN position.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 778 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON or run/stop switch to the RUN position.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-May-2012


FAULT CODE 1128 - B and C Gas Plus Humidity Sensor - Voltage Above Normal

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Read the fault codes. | Fault Code 1128 active?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1129 active and Fault Code 1128 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.3-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1128 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1128 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1128 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 or 386.

Go to 2A

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-361 in Section 19.

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-356 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1129 active and Fault Code 1128 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the humidity SUPPLY pin and the humidity RETURN pin at the humidity sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.3-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active?
YES NO

A damaged sensor has been detected.

Replace the humidity sensor.

  • Refer to Procedure 019-356 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM number 1 connector.

Action

Inspect the engine harness and ecm number 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM number 1 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM number 1 connector.
  • Disconnect the humidity sensor from the engine harness.

Action

n/a

  • Measure the resistance between the engine harness ECM engine connector 1 humidity RETURN pin and the engine harness humidity sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM number 1 and 2 connectors.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM number 1 connector.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SUPPLY pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SUPPLY pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1128 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Apr-2012


FAULT CODE 1128 - L Gas Plus - Humidity Sensor - Voltage Above Normal

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Read the fault codes. | Fault Code 1128 active?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1129 active and Fault Code 1128 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.5 to 5.3-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1128 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1128 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1128 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 and/or 386

Go to 2A

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-361 in Section 19.

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-356 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1129 active and Fault Code 1128 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the humidity SUPPLY pin and the humidity RETURN pin at the humidity sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.3-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active?
YES NO

A damaged sensor has been detected.

Replace the humidity sensor.

Refer to Procedure 019-356 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM number 1 connector.

Action

Inspect the engine harness and ecm number 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM number 1 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM number 1 connector.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity RETURN pin and the engine harness humidity sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM number 1 and 2 connectors.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM number 1 connector.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SUPPLY pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SUPPLY pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1128 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Apr-2012


FAULT CODE 1129 - B and C Gas Plus - Humidity Sensor - Voltage Below Normal

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Read the fault codes. | Fault Code 1129 active?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.3-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1128 active and Fault Code 1129 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1129 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1129 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1129 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 and/or 386

Go to 2A

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1129 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-361 in Section 19.

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-356 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the humidity SUPPLY pin and the humidity RETURN pin at the humidity sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.3-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the humidity SUPPLY pin and the humidity SIGNAL pin at the humidity sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active and Fault Code 1129 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1129 active?
YES NO

A damaged sensor has been detected.

Replace the humidity sensor.

  • Refer to Procedure 019-356 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

inspect the engine harness and ecm engine harness connector 1 pins for the following: Inspect the ?????? connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity SUPPLY pin and the engine harness humidity sensor connector SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity SIGNAL pin and the engine harness humidity sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 and 2 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1129 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1129 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Apr-2012


FAULT CODE 1129 - L Gas Plus - Humidity Sensor - Voltage Below Normal

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Read the fault codes. | Fault Code 1129 active?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.3-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1128 active and Fault Code 1129 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1129 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1129 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1129 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 or 386

Go to 2A

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1129 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-361 in Section 19.

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
  • Refer to Procedure 019-356 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the humidity SUPPLY pin and the humidity RETURN pin at the humidity sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.3-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the humidity SUPPLY pin and the humidity SIGNAL pin at the humidity sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active and Fault Code 1129 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1129 active?
YES NO

A damaged sensor has been detected.

Replace the humidity sensor.

  • Refer to Procedure 019-356 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ecm engine harness connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-204 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity SUPPLY pin and the engine harness humidity sensor connector SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity SIGNAL pin and the engine harness humidity sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 and 2 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and engine block ground

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1129 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1129 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Apr-2012


FAULT CODE 1271 - Engine Misfire for Multiple Cylinders - Data Valid But Below Normal Operating Level - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the status of misfire. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 1271 inactive?
 | STEP 1B. Check for spark plug voltage fault codes. | Fault Codes 613, 1649, 1651, or 1652 active?
 | STEP 1B-1. Check for multiple fuel system fault codes. |
 | STEP 1C. Check the life of spark plug. | Spark plugs life is between 50 and 1400 hours?
STEP 2. | Check the ignition coils and spark plugs. |
 | STEP 2A. Inspect the ignition coils and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the coils. | Steady spark observed?
 | STEP 2C. Check the spark plugs | Spark plug damaged or wear?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Inspect ICM, ignition coils and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the ignition harness. |
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check the ICM. | ICM to specification?
 | STEP 3F. Verify that ignition coils and ignition circuit are good. | Steady spark observed?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1271 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check status of misfire.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Operate the vehicle in the condition in which the misfire occurred.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1271 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for spark plug voltage fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 613, 1649, 1651, or 1652 active?
YES | NO
No Repair | No Repair

Fault Codes 613, 1649, 1651, or 1652 before proceeding

Go to 1B-1

Guided Step 1B-1 - Check for multiple fuel system fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2184, 2219, 751, or 752 active?
YES NO

Troubleshoot any remaining fault codes before proceeding.

Note: If any of these fault coders are present, then the misfire can be due to a system error. Such as, engine running lean or gas mass flow sensor or heated oxygen sensor can not compensate correctly.

No Repair

Fault Codes 2184, 2219, 751, or 752 before proceeding

Go to 1C

Guided Step 1C - Check the life of spark plugs.

Conditions

  • Use the following procedure to reference the maintenance schedule in the C8.3G, C Gas Plus and L Gas Plus Owners Manual, Bulletin 4021387. Refer to Procedure 102-002 in Section 2.

Action

Confirm how many hour are on the spark plugs.

  • Use the following procedure to reference the maintenance schedule for the last time the spark plugs where changed in the C8.3G, C Gas Plus and L Gas Plus Owners Manual, Bulletin 4021387. Refer to Procedure 102-002 in Section 2.

Spark plugs life is between 50 and 1400 hours?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2 - Check the ignition coils and spark plugs.

Guided Step 2A - Inspect ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ignition coil.

Action

Inspect the ignition harness and ignition coil connector pins of the cylinders that were misfiring for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

Repair the harness.

  • Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage at the coils.

Conditions

  • Turn keyswitch ON.
  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Action

Check the ignition coils of the misfiring cylinders.

  • Test each coil one at a time to determine if the coils are receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the spark plugs.

Conditions

  • Turn keyswitch OFF.
  • Remove the spark plug from the misfiring cylinders.

Action

Inspect the spark plugs for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Worn or missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Gap between 0.30 to 0.38 mm [0.012 to 0.015 inch].

Spark plug damage or wear?
YES NO

Replace each damaged spark plug. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Inspect the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the ignition harness and icm connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM, ignition coils, or ignition harness connector.

Repair the damaged pins. Repair the harness, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector 2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit for each cylinder that is misfiring.

  • Measure the resistance between the ignition harness ICM connector 2 coil SIGNAL pin and the ignition harness coil connector SIGNAL pin.
  • Measure the resistance between the ignition harness ICM connector 2 CD voltage pin and the ignition harness coil connector CD voltage pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-037 in Section 13.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector 2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit for each cylinder that is misfiring.

  • Measure the resistance between the ignition harness ICM connector 2 coil RETURN SIGNAL pin and the ignition harness coil connector RETURN SIGNAL pins.

All spark RETURN SIGNAL wires in the ignition harness are tied together. This way there will be continuity through each spark SIGNAL pin of each coil to the main spark RETURN SIGNAL wire at the ignition harness connector 2. If one of the spark signal circuits is found to be open, then the ICM will think that the engine is misfiring when it is not.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-037 in Section 13.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector 2 from the ICM.
  • Disconnect the ignition harness from all coils.

Action

Check for a pin-to-ground short for each cylinder this is misfiring.

  • Measure the resistance between the CD voltage pin at the coil connector and engine block ground.
  • Measure the resistance between the coil SIGNAL pin at the coil connector and engine block ground.
  • Measure the resistance between the spark SIGNAL pin at the coil connector and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-037 in Section 13.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector 2 from the ICM.
  • Disconnect ignition harness from the ignition coils.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the CD voltage pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between the spark RETURN SIGNAL pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between each coil SIGNAL pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-037 in Section 13.

Go to 3E

Go to 4A

Guided Step 3E - Check the ICM.

Conditions

  • Test the ICM. Refer to Procedure 019-105 in Section 19.

Action

Check the icm for internal shorts or open circuits.

  • Test the ICM. Refer to Procedure 019-105 in Section 19.

ICM to specification?
YES NO
No Repair

  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Verify that ignition coils and ignition circuit are good.

Conditions

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Action

Check the ignition coils of the misfiring cylinders.

  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

  • Replace the ignition coil. Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1271 inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

n/a

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Apr-2012


FAULT CODE 1482 - Engine Misfire For Multiple Cylinders - Data Valid But Below Normal Operating Level - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the status of misfire. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1482 inactive?
 | STEP 1B. Check for spark plug voltage fault codes. | Fault Code 613, 1649, 1651, or 1652 active?
 | STEP 1B-1. Check for multiple fuel system fault codes. |
 | STEP 1C. Check the life of spark plug. | Spark plug life between 50 and 1400 hours?
STEP 2. | Check the ignition coils and spark plugs. |
 | STEP 2A. Inspect the ignition coils and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for voltage at the coils. | Steady spark observed?
 | STEP 2C. Check the spark plugs. | Spark plug damaged or wear?
STEP 3. | Check the ICM and ignition harness. |
 | STEP 3A. Inspect ICM, ignition coils and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the ignition harness. |
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check the ICM. | ICM to specification?
 | STEP 3F. Verify that ignition coils and ignition circuit are good. | Steady spark observed?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1482 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check status of misfire.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Run the vehicle in the condition in which the misfire occurred.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1482 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for spark plug voltage fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 613, 1649, 1651, or 1652 active?
YES | NO
No Repair | No Repair

Fault Code 613, 1649, 1651, or 1652 before proceeding.

Go to 1B-1

Guided Step 1B-1 - Check for multiple fuel system fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2184, 2219, 751, or 752 active?
YES NO

Troubleshoot any remaining fault codes before proceeding.

Note: If any of these fault codes are present, the misfire can be due to a system error, such as, engine running lean or gas mass flow sensor or heated oxygen sensor can not compensate correctly.

No Repair

Fault Code 2184, 2219, 751, or 752 before proceeding.

Go to 1C

Guided Step 1C - Check the life of spark plugs.

Conditions

  • Refer to Procedure 102-002 in Section 2 in the C8.3G, C Gas Plus, and L Gas Plus Owners Manual, Bulletin 4021387.

Action

Confirm how many hours are on the spark plugs.

  • Refer to Procedure 102-002 in Section 2 in the C8.3G, C Gas Plus, and L Gas Plus Owners Manual, Bulletin 4021387 for the last time the spark plugs where changed.

Spark plug life is between 50 and 1400 hours?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2 - Check the ignition coils and spark plugs.

Guided Step 2A - Inspect ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness from the ignition coil.

Action

Inspect the ignition harness and ignition coil connector pins of the cylinders that were misfiring for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ignition coil or ignition harness connectors.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage at the coils.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-012 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Action

Check the ignition coils of the misfiring cylinders.

  • Test each coil one at a time to determine if the coils are receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Steady spark observed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the spark plugs.

Conditions

  • Turn keyswitch OFF.
  • Remove the spark plug from the misfiring cylinders.

Action

Inspect the spark plugs for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Worn or missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Gap between 0.30 to 0.38 mm [0.012 to 0.015 inch].

Spark plug damage or wear?
YES NO

Replace each damaged spark plug. Refer to Procedure 013-016 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM and ignition harness.

Guided Step 3A - Inspect the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the ignition harness and ICM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ICM, ignition coils or ignition harness connector.

Repair the damaged pins. Repair the harness, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector 2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit for each cylinder that is misfiring.

  • Measure the resistance between the ignition harness ICM connector 2 coil SIGNAL pin and the ignition harness coil connector SIGNAL pin.
  • Measure the resistance between the ignition harness ICM connector 2 CD voltage pin and the ignition harness coil connector CD voltage pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C Gas, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector 2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit for each cylinder that is misfiring.

  • Measure the resistance between the ignition harness ICM connector 2 coil RETURN SIGNAL pin and the ignition harness coil connector RETURN SIGNAL pins.

All spark return signal wires in the ignition harness are tied together. This way there will be continuity through each spark signal pin of each coil to the main spark return signal wire at the ignition harness connector 2. If one of the spark signal circuits is found to be open, the ICM will think the engine is misfiring when it is not.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C Gas, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector 2 from the ICM.
  • Disconnect the ignition harness from all coils.

Action

Check for a pin short to ground for each cylinder that is misfiring.

  • Measure the resistance between the CD voltage pin at the coil connector and engine block ground.
  • Measure the resistance between the coil SIGNAL pin at the coil connector and engine block ground.
  • Measure the resistance between the spark SIGNAL pin at the coil connector and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C Gas, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector 2 from the ICM.
  • Disconnect ignition harness from the ignition coils.

Action

Check for a pin to pin short.

  • Measure the resistance between the CD voltage pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between the spark RETURN SIGNAL pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between each coil SIGNAL pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C Gas, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3E

Go to 4A

Guided Step 3E - Check the ICM.

Conditions

  • Refer to Procedure 019-105 in Section 19.

Action

Check the ICM for internal shorts or open circuits.

  • Refer to Procedure 019-105 in Section 19.

ICM to specification?
YES NO
No Repair

  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Verify that ignition coils and ignition circuit are good.

Conditions

  • Refer to Procedure 013-012 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Action

Check the ignition coils of the misfiring cylinders.

  • Using the Ignition Coil Test Kit, Part Number 4918343, observe the spark in the observation window.

Steady spark observed?
YES NO
No Repair

Replace the ignition coil. Refer to Procedure 013-012 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1482 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 23-Feb-2012


FAULT CODE 1643 - Engine Cylinder 1 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648. | Active fault codes?
 | STEP 1B. Check the knock sensor. | Knock sensor damage?
 | STEP 1C. Check for ignition problems. | Ignition system operating properly?
 | STEP 1D. Check the overhead adjustment. | Valve adjustment within specification?
 | STEP 1E. Check for in-cylinder damage. | Evidence of damage?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1643 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Use INSITE™ electronic service tool to read for active fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1B

Guided Step 1B - Check the knock sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensor 1.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation such as sensor loose on mounting, or mounted in wrong location
  • No washers used on installation.

Any knock sensor damage?
YES NO

Replace the sensor or correct the mounting. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for ignition problems.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance troubleshooting symptom tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

Repair or replace the damaged components.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-016 in Section 13.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-014 in Section 13. Refer to Procedure 013-016 in Section 13.

Go to 1D

Go to 2A

Guided Step 1D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Valve adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 1E

Go to 2A

Guided Step 1E - Check for in-cylinder damage.

Conditions

Turn keyswitch OFF.

Action

Check for the following possible cylinder damage:

  • Evidence of knock damage
  • Compression too low
  • Valve leakage
  • Spark plug damage such as metal flakes, molten aluminum, and missing spark plug ground electrodes
  • Fuel quality.

Evidence of damage?
YES NO

Replace the affected components. For C and L gas engine, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1643 is inactive.

Fault Code 1643 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Feb-2012


FAULT CODE 1644 - Engine Cylinder 2 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648. | Active fault codes?
 | STEP 1B. Check the knock sensor. | Knock sensor damage?
 | STEP 1C. Check for ignition problems. | Ignition system operating properly?
 | STEP 1D. Check the overhead adjustment. | Valve adjustment within specification?
 | STEP 1E. Check for in-cylinder damage. | Evidence of damage?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1644 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Use INSITE™ electronic service tool to read for active fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1B

Guided Step 1B - Check the knock sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensor 1.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation such as sensor loose on mounting, or mounted in wrong location
  • No washers used on installation.

Any knock sensor damage?
YES NO

Replace the sensor or correct the mounting. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for ignition problems.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance troubleshooting symptom tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

Repair or replace the damaged components.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-016 in Section 13.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-014 in Section 13. Refer to Procedure 013-016 in Section 13.

Go to 1D

Go to 2A

Guided Step 1D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Valve adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 1E

Go to 2A

Guided Step 1E - Check for in-cylinder damage.

Conditions

Turn keyswitch OFF.

Action

Check for the following possible cylinder damage:

  • Evidence of knock damage
  • Compression too low
  • Valve leakage
  • Spark plug damage such as metal flakes, molten aluminum, and missing spark plug ground electrodes
  • Fuel quality.

Evidence of damage?
YES NO

Replace the affected components. For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1644 is inactive.

Fault Code 1644 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Feb-2012


FAULT CODE 1645 - Engine Cylinder 3 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648. | Active fault codes?
 | STEP 1B. Check the knock sensor. | Knock sensor damage?
 | STEP 1C. Check for ignition problems. | Ignition system operating properly?
 | STEP 1D. Check the overhead adjustment. | Valve adjustment within specification?
 | STEP 1E. Check for in-cylinder damage. | Evidence of damage?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1645 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Use INSITE™ electronic service tool to read for active fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1B

Guided Step 1B - Check the knock sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensor 1.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation such as sensor loose on mounting, or mounted in wrong location
  • No washers used on installation.

Any knock sensor damage?
YES NO

Replace the sensor or correct the mounting. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for ignition problems.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance troubleshooting symptom tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

Repair or replace the damaged components.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-016 in Section 13.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-014 in Section 13. Refer to Procedure 013-016 in Section 13.

Go to 1D

Go to 2A

Guided Step 1D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Valve adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 1E

Go to 2A

Guided Step 1E - Check for in-cylinder damage.

Conditions

Turn keyswitch OFF.

Action

Check for the following possible cylinder damage:

  • Evidence of knock damage
  • Compression too low
  • Valve leakage
  • Spark plug damage such as metal flakes, molten aluminum, and missing spark plug ground electrodes
  • Fuel quality.

Evidence of damage?
YES NO

Replace the affected components. For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1645 is inactive.

Fault Code 1645 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Feb-2012


FAULT CODE 1646 - Engine Cylinder 4 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648. | Active fault codes?
 | STEP 1B. Check the knock sensor. | Knock sensor damage?
 | STEP 1C. Check for ignition problems. | Ignition system operating properly?
 | STEP 1D. Check the overhead adjustment. | Valve adjustment within specification?
 | STEP 1E. Check for in-cylinder damage. | Evidence of damage?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1646 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Use INSITE™ electronic service tool to read for active fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1B

Guided Step 1B - Check the knock sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensor 2.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation such as sensor loose on mounting, or mounted in wrong location
  • No washers used on installation.

Any knock sensor damage?
YES NO

Replace the sensor or correct the mounting. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for ignition problems.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance troubleshooting symptom tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

Repair or replace the damaged components.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-016 in Section 13.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-014 in Section 13. Refer to Procedure 013-016 in Section 13.

Go to 1D

Go to 2A

Guided Step 1D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Valve adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG PlusTroubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 1E

Go to 2A

Guided Step 1E - Check for in-cylinder damage.

Conditions

Turn keyswitch OFF.

Action

Check for the following possible cylinder damage:

  • Evidence of knock damage
  • Compression too low
  • Valve leakage
  • Spark plug damage such as metal flakes, molten aluminum, and missing spark plug ground electrodes
  • Fuel quality.

Evidence of damage?
YES NO

Replace the affected components. For C and L gas engine, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1646 is inactive.

Fault Code 1646 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Feb-2012


FAULT CODE 1647 - Engine Cylinder 5 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648. | Active fault codes?
 | STEP 1B. Check the knock sensor. | Knock sensor damage?
 | STEP 1C. Check for ignition problems. | Ignition system operating properly?
 | STEP 1D. Check the overhead adjustment. | Valve adjustment within specification?
 | STEP 1E. Check for in-cylinder damage. | Evidence of damage?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1647 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Use INSITE™ electronic service tool to read for active fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1B

Guided Step 1B - Check the knock sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensor 2.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation such as sensor loose on mounting, or mounted in wrong location
  • No washers used on installation.

Any knock sensor damage?
YES NO

Replace the sensor or correct the mounting. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for ignition problems.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance troubleshooting symptom tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

Repair or replace the damaged components.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-016 in Section 13.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-014 in Section 13. Refer to Procedure 013-016 in Section 13.

Go to 1D

Go to 2A

Guided Step 1D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Valve adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 1E

Go to 2A

Guided Step 1E - Check for in-cylinder damage.

Conditions

Turn keyswitch OFF.

Action

Check for the following possible cylinder damage:

  • Evidence of knock damage
  • Compression too low
  • Valve leakage
  • Spark plug damage such as metal flakes, molten aluminum, and missing spark plug ground electrodes
  • Fuel quality.

Evidence of damage?
YES NO

Replace the affected components. For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1647 is inactive.

Fault Code 1647 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Feb-2012


FAULT CODE 1648 - Engine Cylinder 6 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648. | Active fault codes?
 | STEP 1B. Check the knock sensor. | Knock sensor damage?
 | STEP 1C. Check for ignition problems. | Ignition system operating properly?
 | STEP 1D. Check the overhead adjustment. | Valve adjustment within specification?
 | STEP 1E. Check for in-cylinder damage. | Evidence of damage?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1646 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for existing fault codes other than Fault Code 1643, 1644, 1645, 1646, 1647 or 1648.

Use INSITE™ electronic service tool to read for active fault codes.

Active fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s)

Go to 1B

Guided Step 1B - Check the knock sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from knock sensor 2.

Action

Inspect the knock sensor for the following:

  • Damage to sensor face
  • Damage to mounting stud or bolt
  • Poor installation such as sensor loose on mounting, or mounted in wrong location
  • No washers used on installation.

Any knock sensor damage?
YES NO

Replace the sensor or correct the mounting. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for ignition problems.

Conditions

  • Turn keyswitch OFF.

Action

Check for an ignition-related problem.

  • Reference the Engine Performance troubleshooting symptom tree in Section TT.

Ignition system operating properly?
YES NO
No Repair

Repair or replace the damaged components.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-016 in Section 13.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 013-012 in Section 13. Refer to Procedure 013-014 in Section 13. Refer to Procedure 013-016 in Section 13.

Go to 1D

Go to 2A

Guided Step 1D - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Valve adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-004 in Section 3.
  • For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

Go to 1E

Go to 2A

Guided Step 1E - Check for in-cylinder damage.

Conditions

Turn keyswitch OFF.

Action

Check for the following possible cylinder damage:

  • Evidence of knock damage
  • Compression too low
  • Valve leakage
  • Spark plug damage such as metal flakes, molten aluminum, and missing spark plug ground electrodes
  • Fuel quality.

Evidence of damage?
YES NO

Replace the affected components. For C and L gas engines, reference the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. For B gas engines, reference the B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 1648 is inactive.

Fault Code 1648 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Feb-2012


FAULT CODE 1649 - Spark Voltage on Multiple Cylinders - Data Valid But Below Normal Operating Range

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the status of engine misfire. |
 | STEP 1A. Check for engine misfire. | Engine misfiring?
STEP 2. | Check the ignition coils. |
 | STEP 2A. Inspect the ignition coils and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plugs. | Visible damage or spark plug gap less than 0.30 mm [0.012 inch]?
STEP 3. | Check the ICM, ignition coils and ignition harness. |
 | STEP 3A. Inspect ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the ignition harness. |
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3E. Check the ignition coils. | More than two coils not firing?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1649 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check status of engine misfire.

Guided Step 1A - Check for engine misfires.

Conditions

  • Turn keyswitch OFF.

Action

Check for engine misfire.

  • Interview the operator to see if there is any complaint of misfire.
  • Verify that the engine performs as the operator indicates with test drive or dynamometer test.

Engine misfiring?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ignition coils.

Guided Step 2A - Inspect ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ignition coil.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the spark plugs.

Conditions

  • Turn keyswitch OFF.

Action

Check for spark plugs with too small a spark gap.

  • Inspect the spark plugs for any damage
  • Use a feeler gauge to measure the spark plug gap.

Visible damage or spark plug gap less than 0.30 mm [0.012 inch]?
YES NO

Replace all damaged spark plugs. Refer to Procedure 013-016 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM, ignition coils and ignition harness.

Guided Step 3A - Inspect the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ICM connector C1.

Action

Inspect the ignition harness and ICM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM, ignition coils, or ignition harness connector.

Repair or replace the harness, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit for each cylinder coil connector line.

  • Measure the resistance between the ignition harness ICM connector C2 coil SIGNAL pin and the ignition harness coil connector SIGNAL pin.
  • Measure the resistance between the ignition harness ICM connector C2 CD voltage pin and the ignition harness coil connector CD voltage pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit.

  • Measure the resistance between the ignition harness ICM connector spark RETURN SIGNAL pin and the ignition harness coil connector RETURN SIGNAL pins.

All spark return signal wires in the ignition harness are tied together. This way there will be continuity through each spark signal pin of each coil to the main spark return signal wire at the ignition harness connector C2. If one of the spark signal circuits is found to be open, then the ICM will think that the engine is misfiring when it is not.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3C

Go to 3A

Guided Step 3C - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the ignition harness connector C2 from the ICM
  • Disconnect the ignition harness from all coils.

Action

Check for a pin to ground short for each cylinder coil connector.

  • Measure the resistance between the CD voltage pin at the coil connector and engine block ground.
  • Measure the resistance between the coil SIGNAL pin at the coil connector and engine block ground.
  • Measure the resistance between the spark SIGNAL pin at the coil connector and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from the ignition coils.

Action

Check for a pin to pin short.

  • Measure the resistance between the CD voltage pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.
  • Measure the resistance between the spark RETURN SIGNAL pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.
  • Measure the resistance between each coil SIGNAL pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3E

Go to 4A

Guided Step 3E - Check the ignition coils.

Conditions

  • Refer to Procedure 013-012 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Action

Check the ignition coils of all cylinders.

  • Use the Ignition Coil Test Kit, Part Number 4918343, observe the spark in the observation window.

Coil must be tested in a vertical position or damage to the coil can result.

More than two coils not firing?

YES NO

  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

  • Replace the ignition coil. Refer to Procedure 013-012 in Section 13 in the Troubleshooting and Repair Manual C8.3G, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1649 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 1651 - Spark Voltage on Multiple Cylinders - Data Valid But Above Normal Operating Range

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the status of engine misfire. |
 | STEP 1A. Check for engine misfire. | Engine misfiring?
STEP 2. | Check the ignition coils. |
 | STEP 2A. Inspect the ignition coils and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plugs. | Visible damage or spark plug gap less than 0.30 mm [0.012 inch]?
STEP 3. | Check the ICM, ignition coils and ignition harness. |
 | STEP 3A. Inspect the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 3C. Check the ignition coils. | More than two coils not firing?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1651 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check status of engine misfire.

Guided Step 1A - Check for engine misfires.

Conditions

  • Turn keyswitch OFF.

Action

Check for engine misfire.

  • Interview the operator to see if there is any complaint of misfire.
  • Verify that the engine performs as the operator indicates with test drive or dynamometer test.

Engine misfiring?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ignition coils.

Guided Step 2A - Inspect ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ignition coil.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the spark plugs.

Conditions

  • Turn keyswitch OFF.

Action

Check for spark plugs with too small a spark gap.

  • Inspect the spark plugs for any damage
  • Use a feeler gauge to measure the spark plug gap.

Visible damage or spark plug gap less than 0.30 mm [0.012 inch]?
YES NO

Replace all damaged spark plugs. Refer to Procedure 013-016 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ICM, ignition coils and ignition harness.

Guided Step 3A - Inspect the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ICM connector C1.

Action

Inspect the ignition harness and ICM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ICM, ignition coils or ignition harness connector.

Repair or replace the harness, whichever has the damaged pins.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from the ignition coils.

Action

Check for a pin to pin short.

  • Measure the resistance between the CD voltage pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.
  • Measure the resistance between the spark RETURN SIGNAL pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.
  • Measure the resistance between each coil SIGNAL pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3C

Go to 4A

Guided Step 3C - Check the ignition coils.

Conditions

  • Refer to Procedure 013-012 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Action

Check the ignition coils of all cylinders.

  • Use the Ignition Coil Test Kit, Part Number 4918343, observe the spark in the observation window.

Coil must be tested in a vertical position or damage to the coil can result.

More than two coils not firing?

YES NO

  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

  • Replace the ignition coil. Refer to Procedure 013-012 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1651 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Feb-2012


FAULT CODE 1652 - Spark Voltage on Multiple Cylinders - Data Erratic, Intermittent or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1652 inactive?
STEP 2. | Check the ICM and ignition harness. |
 | STEP 2A. Inspect the ICM ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 2B-1. Check for an open circuit in the ignition harness. |
 | STEP 2C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a pin to pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 2E. Check for an inactive fault code. | Fault Code 1652 inactive?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1652 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1652 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ICM ignition harness.

Guided Step 2A - Inspect ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector C1 and connector C2 from the ICM.

Action

Inspect the ignition harness and ICM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ICM or ignition harness connectors.

Repair the damaged pins. Repair or replace the harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.
  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit for each cylinder coil connector line.

  • Measure the resistance between the ignition harness ICM connector C2 coil SIGNAL pin and the ignition harness coil connector SIGNAL pin.
  • Measure the resistance between the ignition harness ICM connector C2 CD voltage pin and the ignition harness coil connector CD voltage pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from all coils.

Action

Check for an open circuit.

  • Measure the resistance between the ignition harness ICM connector spark RETURN SIGNAL pin and the ignition harness coil connector RETURN SIGNAL pins.

All spark return signal wires in the ignition harness are tied together. This way there will be continuity through each spark signal pin of each coil to the main spark return signal wire at the ignition harness connector C2. If one of the spark signal circuits is found to be open, then the ICM will think that the engine is misfiring when it is not.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector C2 from the ICM.
  • Disconnect the ignition harness from all coils.

Action

Check for a pin to ground short for each cylinder coil connector.

  • Measure the resistance between the CD voltage pin at the coil connector and engine block ground.
  • Measure the resistance between the coil SIGNAL pin at the coil connector and engine block ground.
  • Measure the resistance between the spark SIGNAL pin at the coil connector and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin to pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ignition harness connector C2 from the ICM.
  • Disconnect ignition harness from the ignition coils.

Action

Check for a pin to pin short.

  • Measure the resistance between the CD voltage pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.
  • Measure the resistance between the spark RETURN SIGNAL pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.
  • Measure the resistance between each coil SIGNAL pin in the ignition harness ICM connector C2 and all other pins in the ignition harness connector C2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Replace the ignition harness. Refer to Procedure 013-037 in Section 13 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 2E

Go to 3A

Guided Step 2E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine and let idle.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1652 inactive?
YES NO

The removal and installation of the connectors corrected the failure.

  • Replace the ICM. Refer to Procedure 019-105 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1652 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Feb-2012


FAULT CODE 1919 - B and C Gas Plus - Humidity Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Read the fault codes. | Fault Code 1919 active?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.3 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1128 active and Fault Code 1919 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1919 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1919 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1919 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 and/or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 and/or 386.

Go to 2A

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1919 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-361 in Section 19.

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-218 in Section 19.

Refer to Procedure 019-356 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the humidity SUPPLY pin and the humidity RETURN pin at the humidity sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.3 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the humidity SUPPLY pin and the humidity SIGNAL pin at the humidity sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active and Fault Code 1919 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1919 active?
YES NO

A malfunctioning sensor has been detected.

Replace the humidity sensor.

Refer to Procedure 019-356 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM engine harness connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity SUPPLY pin and the engine harness humidity sensor connector SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity SIGNAL pin and the engine harness humidity sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 and 2 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and engine block ground

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1919 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1919 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 1919 - L Gas Plus - Humidity Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Read the fault codes. | Fault Code 1919 active?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.5 to 5.3 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1128 active and Fault Code 1919 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1919 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1919 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1919 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 and/or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 and/or 386.

Go to 2A

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1919 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-361 in Section 19.

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19

Refer to Procedure 019-218 in Section 19.

Refer to Procedure 019-356 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the humidity SUPPLY pin and the humidity RETURN pin at the humidity sensor connector of the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

4.5 to 5.3 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the humidity SUPPLY pin and the humidity SIGNAL pin at the humidity sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1128 active and Fault Code 1919 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1919 active?
YES NO

A malfunctioning sensor has been detected.

Replace the humidity sensor.

Refer to Procedure 019-356 in Section 19.

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM engine harness connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-043 in Section 19.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity SUPPLY pin and the engine harness humidity sensor connector SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM engine connector 1 humidity SIGNAL pin and the engine harness humidity sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the folllowing procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors 1 and 2 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 1.
  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and all other pins in the engine harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the humidity SIGNAL pin in the engine harness ECM engine connector 1 and engine block ground

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A pin to ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-204 in Section 19.

Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1919 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1919 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 2118 - Fuel Delivery Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pressure. |
 | STEP 1A. Read the fault codes. | Fault Code 2118 active?
 | STEP 1B. Check the primary fuel pressure. | Fuel pressure measurement within 5 percent?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2118 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel pressure.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Read the fault codes.

Fault Code 2118 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the primary fuel pressure.

Conditions

  • Turn keyswitch OFF.
  • Install a mechanical gauge.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 005-061 in Section 5.
  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 005-061 in Section 5.
  • Connect INSITE™ electronic service tool.

Action

Verify the primary fuel pressure.

  • Verify the primary fuel pressure measurement with a mechanical gauge against the primary fuel pressure measurement value displayed in INSITE™ electronic service tool.

Note: Fuel pressure is displayed in absolute in INSITE™ electric service tool. The Compucheck™ fitting located on the fuel housing is used to measure secondary fuel pressure out of the engine (low pressure) fuel regulator.

Fuel pressure measurement within 5 percent?
YES NO

The OEM fuel system is not supplying proper fuel pressure or flow. Troubleshoot the OEM fuel system. Refer to the OEM service manual for fuel supply troubleshooting.

A damaged primary fuel pressure sensor has been detected.

Replace the sensor. Refer to Procedure 019-188 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Verify that Fault Code 2118 is active.

Fault Code 2118 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts.

Last Modified: 27-Feb-2012


FAULT CODE 2119 - Fuel Delivery Pressure 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fuel tank pressure or level. | Fuel tank pressure or level low?
 | STEP 1B. Check the vehicle fueling history. | Low fuel pressure faults only after refueling?
 | STEP 1C. Check for an active fault code. | Fault Code 2119 active?
STEP 2. | Check the primary fuel pressure sensor. |
 | STEP 2A. Check the fuel system for leaks. | Fuel leaks?
 | STEP 2B. Verify the primary fuel pressure sensor reading. | Fuel pressure measurement within 5 percent?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2119 active
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the OEM gauge to check the pressure or level.

Fuel tank pressure or level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. Refer to the OEM service manual

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the vehicle fueling history.

Conditions

  • Turn keyswitch OFF.

Action

Check the history to see if the vehicle’s low fuel pressure complaints occur only after refueling.

  • Use the OEM gauge to check the pressure or level.

Low fuel pressure faults only after refueling?
YES NO

A fuel fill issue has been detected. Refer to the OEM service manual or fuel system supplier to review fuel fill procedures.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Operate the engine in the condition in which the fault occurred.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2119 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the primary fuel pressure sensor.

Guided Step 2A - Check the fuel system for leaks.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for leaks in the fuel system.

  • Use the combustible gas detector service tool to check the fuel lines, fuel connections, and fuel filters for leaks.
  • Note: Unlike natural gas, liquefied petroleum gas is heavier than air and will sink to the ground. It is best to check below the connector. Another sign of fuel leakage is frosting around the connection.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Repair or replace the leaking component.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Verify the primary fuel pressure sensor reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge.

Use the following procedure in the Troubleshooting and Repair Manual B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 005-061 in Section 5.

Use the following procedure in the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-061 in Section 5.

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the primary fuel pressure.

  • Verify the primary fuel pressure measurement with a mechanical gauge against the primary fuel pressure measurement value displayed in INSITE™ electronic service tool.

Fuel pressure is displayed in absolute in INSITE™. The Compuchek™ fitting located on the fuel housing is used to measure secondary fuel pressure out of the engine (low pressure) fuel regulator.

Fuel pressure measurement wthin 5 percent?
YES NO

The OEM fuel system is not supplying sufficient fuel pressure or flow. Troubleshoot the OEM fuel system. Refer to the OEM service manual

A damaged primary fuel pressure sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2119 is active.

Fault Code 2119 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Feb-2012


FAULT CODE 2184 - Fuel Control Valve Hysteresis

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 455 or 511 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2184 inactive?
STEP 2. | Check the fuel control valve and circuit. |
 | STEP 2A. Inspect the fuel control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel control valve. | 2 to 5 ohms?
 | STEP 2C. Check for a short to ground in the fuel control valve. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check fuel system. |
 | STEP 4A. Verify secondary fuel system. | Is pressure correct for the engine family?
 | STEP 4B. Check for a stuck open fuel control valve. | Secondary fuel pressure drop within 50 seconds of key ON?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2184 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 455 or 511 active?
YES | NO
No Repair | No Repair

Fault Code 455 or 511

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2184 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel control valve and circuit.

Guided Step 2A - Inspect the fuel control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect fuel control valve from the engine harness.

Action

Inspect the engine harness and fuel control valve connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connection.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-102 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel control valve output pin and the fuel control valve RETURN pin at the fuel control valve connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

2 to 5 ohms?
YES NO
No Repair

  • Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.
  • Use INSITE™ electronic service tool to reset the fuel tables.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short to ground in the fuel control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a fuel control valve output short to ground.

  • Measure the resistance between the fuel control valve SUPPLY pin and at the fuel control valve connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.
  • Use INSITE™ electronic service tool to reset the fuel tables.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for pin to ground short.

  • Measure the resistance between the fuel control valve output pin in the engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the fuel control valve output line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for pin to pin short.

  • Measure the resistance between the fuel control valve SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the fuel control valve SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the fuel control valve supply line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check fuel system.

Guided Step 4A - Check the secondary fuel inlet pressure.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Use INSITE™ electronic service tool to monitor the fuel pressure.
  • Secondary fuel pressures are different depending on engine platform. See below:

B Gas Plus - 414 kPa [60 psia]

B LPG Plus - 276 kPa [40 psia]

C Gas Plus - 517 kPa [75 psia]

All pressure sensors on the Gas Plus engines are absolute pressure sensors.

It might be necessary to perform a stall test to monitor dynamic secondary fuel pressure. If fuel pressure is not adequate, then the engine will surge under load possibly causing this fault to occur.

Reference the Engine Performance troubleshooting symptom tree in Section TT.

Is pressure correct for the engine family?
YES NO
No Repair

Reference the Engine Performance troubleshooting symptom tree in Section TT.

Go to 4B

Go to 5A

Guided Step 4B - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the secondary fuel pressure while the keyswitch is ON.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Secondary fuel pressure drop within 50 seconds of key ON?
YES NO

A defective fuel control valve has been detected.

Replace the fuel control valve. Refer o Refer to Procedure 019-102 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2184 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 2185 - Sensor Supply Voltage (4) Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2185 inactive?
STEP 2. | Check the ECM and sensor harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 2185 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the primary fuel pressure and exhaust back pressure sensors from the engine harness.
  • Disconnect all components connected to sensor supply number 4.

Action

Check for a pin to pin short circuit.

  • Measure the resistance between the sensor SUPPLY number 4 pin in engine harness ECM connector 1 to all other pins in engine connector 1.
  • Measure the resistance from the sensor SUPPLY number 4 pin in engine harness ECM connector 1 to all pins in engine connector 2.

See the circuit diagram or wiring harness for connector pin identification.

Use the following procedure for general resistance techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor SUPPLY number 4 wire has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2185 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Feb-2012


FAULT CODE 2186 - Sensor Supply Voltage (4) Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2186 inactive?
STEP 2. | Check the sensors and sensor supply circuit. |
 | STEP 2A. Inspect the primary fuel pressure sensor and connector pins connected to sensor supply number 4. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the exhaust back pressure sensor and connector pins connected to sensor supply number 4. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground. |
 | STEP 3C. Check for an inactive fault code. | Fault Code 2186 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2186 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2186 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and sensor supply circuits.

Guided Step 2A - Inspect the primary fuel pressure sensor and connector pins connected to sensor supply number 4.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary fuel pressure sensor from the engine harness.

Action

Inspect the primary fuel pressure sensor harness and engine sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

A defective sensor has been detected.

Replace the primary fuel pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 2B

Go to 4B

Guided Step 2B - Inspect the exhaust back pressure sensor and connector pins connected to sensor supply number 4.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.

Action

Inspect the exhaust back pressure sensor harness and engine sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust back pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

A defective sensor has been detected.

Replace the exhaust back pressure sensor. Refer to Procedure 019-347 in Section 19.

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the primary fuel pressure sensor and exhaust back pressure sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 4.

Action

Check for a pin to pin short.

  • Measure the resistance between the sensor SUPPLY number 4 pin in engine harness ECM connector 1 to all other pins in the engine harness connector 1.
  • Measure the resistance between the sensor SUPPLY number 4 pin in engine harness ECM connector 1 to all other pins in the engine connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the sensor SUPPLY number 4 wire has been detected in the engine harness.

Repair or replace the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the primary fuel pressure sensor and exhaust back pressure sensor from the engine harness.
  • Disconnect all components connected to sensor supply number 4.

Action

Check for a pin short to ground.

  • Measure the resistance between the sensor SUPPLY number 4 pin in engine harness ECM connector 1 and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the sensor SUPPLY number 4 wire has been detected in the engine harness.

Repair or replace the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2186 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that Fault Code is inactive.

Fault Code 2186 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Feb-2012


FAULT CODE 2187 - Exhaust Back Pressure - Data Valid But Above Normal Operational Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2187 active?
STEP 2. | Check the exhaust back pressure sensor. |
 | STEP 2A. Inspect the exhaust back pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor accuracy. | Exhaust back pressure (absolute) read atmospheric pressure?
 | STEP 2C. Inspect the back pressure sensing hardware for cracked fittings, plugging, or leaks. Verify back pressure measurement location. | Hardware failure or installation issue found?
 | STEP 2D. Check the exhaust back pressure. | Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
STEP 3. | Check for excessive oil consumption. |
 | STEP 3A. Inspect the closed crankcase ventilation system. | Excessive oil, plugging, wrong orientation, or oil carryover?
 | STEP 3B. Check for oil residue in the turbocharger compressor outlet plumbing. | Oil residue present?
 | STEP 3C. Check for oil in the charge-air cooler outlet. | Oil present?
 | STEP 3D. Check for oil residue in the turbocharger turbine outlet. | Oil residue present?
 | STEP 3E. Inspect the valve stem seals. | Damaged, cracked, wrong, or improperly installed valve stem seals?
STEP 4. | Check air to fuel ratio control. |
 | STEP 4A. Check the overhead set. | Valve lash out of specification?
 | STEP 4B. Check the gas flow measurement. | Excessive compressor oil carryover in the fuel system.
 | STEP 4C. Check the fuel mixer housing. | Fuel mixer incorrect or venturi sleeve not seated properly?
 | STEP 4D. Check the gas mass flow sensor and fuel control valve. | Steady-state gas mass flow compensation greater tthan 90 percent and gas mass flow deviation greater tthan 4.7 lt/hr [10 lb/hr]?
 | STEP 4E. Check for an exhaust system leak. | Exhaust leaks?
STEP 5. | Check combustion chamber sealing. |
 | STEP 5A. Check cylinder leak down. | Does cylinder pass leak down test?
STEP 6. | Check the exhaust back pressure. |
 | STEP 6A. Check the exhaust back pressure. | Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 2187 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2187 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2D

Guided Step 2 - Check the exhaust back pressure sensor.

Guided Step 2A - Inspect the exhaust back pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the exhaust back pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Us electronic contact cleaner, Part Number 3824510, to flush the dirt, debris, or moisture from the connector pins.

Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine harness. Refer to Procedure 019-202 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the sensor. Refer to Procedure 019-347.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Use INSITE™ electronic service tool to verify the sensor accuracy.

Note: Convert psia to in. Hg. by multiplying by 2.036.

Exhaust back pressure (absolute) read atmospheric pressure?
YES NO
No Repair

Verify the sensing tube is free of blockage and replace the sensor.

Refer to Procedure 019-347 in Section 19.

Go to 2C

Go to 2C

Guided Step 2C - Inspect the back pressure sensing hardware for cracked fittings, plugging, or leaks. Verify back pressure measurement location.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensing hardware and measurement location.

  • Inspect the back pressure sensing hardware for cracked fittings, plugging, or leaks. Verify the back pressure measurement location is correct.

Hardware failure or installation issue found?
YES NO

Repair or replace the malfunctioning components, or correct the exhaust back pressure measurement location.

 No Repair

Go to 2D

Go to 2D

Guided Step 2D - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust back pressure.

  • Measure the exhaust restriction.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 011-009 in Section 11.or Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 011-009 in Section 11.

Make sure the back pressure tube is free from blockage.

Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
YES NO
No Repair

Remove the catalyst and utilize piping to restrict to required back pressure.

Go to 7A

Go to 3A

Guided Step 3 - Check for excessive oil consumption.

Guided Step 3A - Inspect the closed crankcase ventilation system.

Conditions

  • Turn keyswitch OFF.

Action

Check the closed crankcase ventilation system.

  • Check the closed crankcase ventilation canister for excessive oil.
  • Inspect the drain line for plugging and proper orientation of the check valve.
  • Check for excessive oil carryover in the closed crankcase ventilation return line.

Excessive oil, plugging, wrong orientation, or oil carryover?
YES NO

Repair the closed crankcase ventilation system.

 No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check for oil residue in the turbocharger compressor outlet plumbing.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger outlet pipe.

Action

Check for oil residue.

  • Check for oil residue in the turbocharger compressor outlet plumbing.

Oil residue present?
YES NO

The turbocharger is the source of the oil. Replace the turbocharger.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 010-033 in Section 10.or Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3C

Go to 3C

Guided Step 3C - Check for oil in the charge-air cooler outlet.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pipe.

Action

Check the charge-air cooler.

  • Check for oil in the charge-air cooler outlet.

Oil present?
YES NO

Clean the charge-air cooler.

Remove and clean the intake piping.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 010-027 in Section 10. Use the following procedure in Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 010-027 in Section 10.

No Repair

Go to 3D

Go to 3D

Guided Step 3D - Check for oil residue in the turbocharger turbine outlet.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger turbine piping.

Action

Check the turbocharger turbine outlet.

  • Check for oil residue in the turbocharger turbine outlet.

Oil residue present?
YES NO

The turbocharger is the source of the oil. Replace the turbocharger.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 010-033 in Section 10. Use the following procedure in the Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.Refer to Procedure 010-033 in Section 10.

Replace the oxygen sensor.

Refer to Procedure 019-100 in Section 19..

Clean the exhaust system of any oil or residue.

 No Repair

Go to 3E

Go to 3E

Guided Step 3E - Inspect the valve stem seals.

Conditions

  • Turn keyswitch OFF.

Action

Remove the valve covers.

  • Inspect the valve stem seals.

Damaged, cracked, wrong, or improperly installed valve stem seals?
YES NO

Replace the valve stem seals. Clean the exhaust system of any oil or residue.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines in Bulletin 3666206. Refer to Procedure 002-004 in Section 2. or Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines in Bulletin 3666164. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check air to fuel ratio control.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.

Action

Remove the valve cover.

  • Check the overhead set. Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 003-004 in Section 3 or Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

Valve lash out of specification?
YES NO

Adjust the overhead.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 003-004 in Section 3. Use the following procedure in the Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 003-004 in Section 3.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Check the gas flow measurement.

Conditions

  • Turn keyswitch OFF.

Action

Check the gas flow measurement.

  • Remove the fuel system components downstream of the fuel filter and check for excessive compressor oil carryover in the fuel system.

Excessive compressor oil carryover in the fuel system?
YES NO

Replace the fuel system screen pack and the gas mass flow sensor.

Refer to Procedure 019-101 in Section 19..

Clean the fuel system of compressor oil contamination.

Be sure the fuel filter drain interval is in accordance with the maintenance schedule.

 No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the fuel mixer housing.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuel shutoff valve (or plug on B LPG Plus) is installed properly and check for debris on the screen.

B Gas Plus and B LPG Plus:

  • Verify the mixer set screws are in place and the mixer is oriented properly. Check for oil or debris on the gas mass flow sensor screen.

C Gas Plus and L Gas Plus

  • Verify the o-ring sealing, snap ring is installed, the mixer part number and orientation are correct, and the set screw is properly installed behind the gas mass flow sensor to hold the flow venturi in place.

Fuel mixer incorrect or venturi sleeve not seated properly?

YES NO

Replace or repair the fuel mixer.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-003 in Section 5. or Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 005-003 in Section 5.

No Repair

Go to 4D

Go to 4D

Guided Step 4D - Check the gas mass flow sensor and fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the gas mass flow sensor and fuel control valve.

Automatic Transmission:

  • Use INSITE™ electronic service tool to perform a Stall Test.

Manual Transmission:

  • Do a road test including operation at rated power.

Check for the following:

  • Steady-state gas mass flow compensation greater than 90 percent
  • Gas mass flow deviation greater than 4.7 lt/hr [10 lb/hr].

Steady-state gas mass flow compensation greater than 90 percent and gas mass flow deviation greater tthan 4.7 lt/hr [10 lb/hr]?
YES NO

Be sure voltage regulation is installed as appropriate.

or

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

 No Repair

Go to 4E

Go to 4E

Guided Step 4E - Check for an exhaust system leak.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for exhaust leaks.

  • Check for exhaust leaks at the turbocharger gasket, exhaust manifold gasket leaks, or leak upstream of the oxygen sensor in the exhaust stack.

Exhaust leaks?
YES NO

Repair or replace the leaking components.

Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206, or Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check combustion chamber sealing.

Guided Step 5A - Check cylinder leak down.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine compression.

  • Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206 or Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164.

Does cylinder pass leak down test?
YES NO
No Repair

Repair the engine as necessary.

Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206 or Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 014-012 in Section 14.

Go to 6A

Go to 6A

Guided Step 6 - Check the exhaust back pressure.

Guided Step 6A - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.
  • Remove the test piece installed in Step 2D.
  • Install the original catalyst.

Action

Check the exhaust back pressure.

  • Check the exhaust restriction. 011-009 Use the following procedure in the Troubleshooting and Repair Manual, C Gas, C Gas Plus and L Gas Plus Engines Bulletin 3666206. Refer to Procedure 011-009 in Section 11. Use the following procedure in Troubleshooting and Repair Manual, B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164. Refer to Procedure 011-009 in Section 11.
  • Make sure the back pressure tube is free from blockage.

Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
YES NO
No Repair

Inspect the oxidation catalyst and/or muffler, and replace according to the manufacturer's instructions.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2187 is inactive.

Fault Code 2187 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 13-May-2014


FAULT CODE 2188 - Heated Oxygen Sensor Circuit - Heater Shorted High

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 2188 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the heater supply voltage. | Supply voltage is greater than 12 VDC?
 | STEP 2C. Check the heated oxygen sensor heater. | Resistance is between 2 ohms and 10 ohms?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2188 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2188 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2188 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the heater supply voltage.

Conditions

  • Turn keyswitch ON.
  • Engine not operating.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Measure the heated oxygen sensor heated supply voltage.

  • Measure the heated oxygen sensor heater SUPPLY voltage from the engine harness connector to chassis ground.

See Shop Talk.

Supply voltage is greater than 12 VDC?
YES NO
No Repair

There is an open circuit or short circuit to ground in the heated oxygen sensor SUPPLY wire. Check the OEM voltage SUPPLY and heated oxygen sensor fuse. Repair or replace the heated oxygen heater line.

OEM troubleshooting and repair manual and the note in Shop Talk.

Go to 2C

Go to 4A

Guided Step 2C - Check the heated oxygen sensor heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the heated oxygen sensor heater.

  • Measure the resistance between the heated oxygen sensor heater positive and the heated oxygen sensor heater negative at the heated oxygen connector.

Resistance is between 2 ohms and 10 ohms?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the heated oxygen sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2188 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4B

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.

Action

Inspect the engine harness and ecm connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following foor general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the heated oxygen sensor heater negative pin on the heated oxygen sensor engine harness connector to the heated oxygen sensor heater negative pin on the ECM connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the heated oxygen heater negative pin in engine harness connector 1 to ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 2188 is inactive.

Fault Code 2188 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Feb-2012


FAULT CODE 2189 - Leaking Throttle Plate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine idle speed. |
 | STEP 1A. Check the engine idle speed using INSITE™ electronic service tool. | 700 to 900 rpm?
 | STEP 1B. Check for air leaks in the air intake system. | Air leaks?
 | STEP 1C. Check the throttle actuator. | Did actuator pass the test?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2189 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine idle speed.

Guided Step 1A - Check the engine idle speed using INSITE™.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the engine idle speed.

  • Use INSITE™ electronic service tool to read the engine idle speed.

700 to 900 rpm?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for air leaks in the air intake system.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks near all gasket surfaces between the throttle actuator and where the intake meets the block. Check all pipe plugs for leaks or missing components.

  • Start the engine and let idle
  • Listen for air leaks while engine is running.

Air leaks?
YES NO

Locate all damaged gaskets or parts and replace accordingly.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the throttle actuator

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform throttle actuator test.

  • Use INSITE™ electronic service tool to run throttle actuator test and confirm actuator is operational.

Did actuator pass test?
YES NO
No Repair

Replace the throttle actuator. Refer to Procedure 019-097 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 2189 is inactive.

Fault Code 2189 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Feb-2012


FAULT CODE 2191 - Mixer Inlet Pressure, Intake Manifold Pressure, and Exhaust Back Pressure Do Not Agree

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2191 active?
STEP 2. | Check the sensor pressure readings. |
 | STEP 2A. Check the pressure readings of the mixer inlet pressure sensor, intake manifold pressure sensor, and exhaust back pressure sensor. | Pressure for all three sensors is approximately 96.53 kPa [14 psia] or 723.90 mm Hg [28.5 in Hg] (atmospheric pressure)
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2191 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Read the fault codes.

Fault Code 2191 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the sensor pressure readings.

Guided Step 2A - Check the pressure readings of the mixer inlet pressure sensor, intake manifold pressure sensor, and exhaust back pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Do not start the engine.

Action

Check the pressure readings of the mixer inlet pressure sensor, intake manifold pressure sensor, and exhaust back pressure sensor.

  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to check the mixer inlet pressure, intake manifold pressure, and exhaust back pressure.

Pressure for all three sensors is approximately 96.53 kPa [14 psia] or 723.90 mm Hg [28.5 in Hg] (atmospheric pressure)?
YES NO
No Repair

One or more pressures do not meet specification. Troubleshoot appropriate sensor circuit.

  • Troubleshoot the mixer inlet pressure sensor circuit. Go to Fault Codes 122 and 123.
  • Troubleshoot the intake manifold pressure sensor circuit. Go to Fault Codes 354 and 355.
  • Troubleshoot the exhaust back pressure sensor circuit. Go to Fault Codes 591 and 592.

Go to 3A

Appropriate fault code(s)

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Verify that Fault Code 2191 is inactive.

Fault Code 2191 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Feb-2012


FAULT CODE 2192 - Heated Oxygen Sensor Circuit - Heater Shorted Low

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2192 active?
STEP 2. | Check the heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 2192 active?
 | STEP 2C. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage to engine harness. | 11 to 14 VDC?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3E. Check for an open circuit in the heated oxygen sensor. | 2.9 to 3.7 ohms at room temperature?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2192 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Read the fault codes.

Fault Code 2192 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2192 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit in the heated oxygen sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor form the engine harness.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.

Action

Check heated osygen sensor resistance.

  • Measure the resistance between the heated oxygen sensor heater SUPPLY pin and the heated oxygen sensor heater RETURN pin at the heated oxygen sensor connector.
  • Make sure to check the resistance at room temperature 23°C [73°F] ± 5 degrees.

2.9 to 3.7 ohms at room temperature?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the engine harness from the OEM harness at the 31-pin OEM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check the supply voltage to engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 31 pin OEM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the SUPPLY voltage to the heated oxygen heater SUPPLY pin in the 31-pin connector, OEM side.

11 to 14 VDC?
YES NO
No Repair

  • Repair or replace the OEM harness. Use the OEM troubleshooting and repair manual.

Make sure that the 10 Ampere fuse is not blown in the OEM harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the engine harness from the heated oxygen sensor.
  • Disconnect the engine harness from the OEM harness at the 31 pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance from the heated oxygen heater SUPPLY pin at the 31 pin OEM connector of the engine harness to the heated oxygen heater SUPPLY pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference SIGNAL pin in the engine harness ECM connector to the heated oxygen reference SIGNAL pin in the engine harness sensor connector.
  • Measure the resistance from the heated oxygen reference RETURN pin in the engine harness ECM connector to the heated oxygen reference RETURN pin in the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect engine harness connector 2 from the ECM
  • Disconnect the 31-pin OEM connector from the engine harness
  • Disconnect the engine harness from the heated oxygen sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the heated oxygen heater SUPPLY pin in the engine harness sensor connector to engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-203 in Section 19 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector 1 and connector 2 from the ECM
  • Disconnect the 31 pin and 23 pin connectors from the OEM harness
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor SUPPLY pin at the 31 pin OEM connector of the engine harness and all other pins in the 31 pin connector.
  • Measure the resistance between the heated oxygen sensor SUPPLY pin at the 31 pin OEM connector of the engine harness and all other pins in the 23 pin connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the heated oxygen sensor supply line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 2192 is inactive.

Fault Code 2192 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 27-Feb-2012


FAULT CODE 2199 - Engine Speed/Position Sensor Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2199 inactive?
STEP 2. | Check the crankshaft speed/position sensor and circuit. |
 | STEP 2A. Inspect the crankshaft speed/position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the crankshaft speed/position sensor. | Damaged sensor tip?
 | STEP 2D. Verify adequate crankshaft speed/position sensor air gap. | Distance is between 41.36 mm [1.36 in] and 42.65 mm [1.68 in]?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 2119 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3G. Check for an inactive fault code. | Fault Code 2199 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2199 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Fault Code 352 or 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2199 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankshaft speed/position sensor and circuit.

Guided Step 2A - Inspect the crankshaft speed/position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect crankshaft speed/position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the sensor or harness connection.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-365 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect crankshaft speed/position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the crankshaft speed/position SUPPLY pin and the crankshaft speed/position RETURN pin at the crankshaft speed/position sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for component pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Inspect the crankshaft speed/position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the crankshaft speed/position sensor from the engine.

Action

Inspect the crankshaft speed/position sensor for the following:

  • Damage sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

A defective sensor has been detected.

Replace the crankshaft speed/position sensor. Refer to Procedure 019-365 in Section 19.

Inspect the crankshaft tone wheel/gear teeth for damage or spinning. Sensor clearance is between 41.36 mm [1.36 in] and 42.65 mm [1.68 in].

Refer to Procedure 001-071 in Section 1 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Verify adequate crankshaft speed/position sensor air gap.

Conditions

  • Turn keyswitch OFF.
  • Remove crankshaft speed/position sensor from the engine.

Action

Verify adequate air gap.

  • Measure the distance between the sensor mounting surface and the edge of the tone wheel.

Distance is between 41.36 mm [1.36 in] and 42.65 mm [1.68 in]?
YES NO
No Repair

Inspect the crankshaft tone wheel/gear teeth for damage or spinning. Refer to Procedure 001-071 in Section 1 in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2199 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

 No Repair

Go to 4B

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector 1.
  • Disconnect the crankshaft speed/position sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the ECM connector 1 RETURN pin and the crankshaft speed/position sensor connector RETURN pin.
  • Measure the resistance between the ECM connector 1 SUPPLY pin and the crankshaft speed/position sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector 1 SIGNAL pin and the crankshaft speed/position sensor connector SIGNAL pin.

Shake and wiggle the harness to determine an intermittent connection.

Shake and wiggle the harness to determine an intermittent connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return current has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness and all other pins in the engine connector 1.
  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the crankshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the crankshaft speed/position sensor 5 volt SUPPLY pin in the engine harness connector 1 and all other pins in the ECM connector 2.

Refer the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a pin short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine harness.

Action

Check for pin to ground short.

  • Measure the resistance between the crankshaft speed/position SIGNAL pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2199 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the crankshaft speed/position sensor. Refer to Procedure 019-365 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2199 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-May-2012


FAULT CODE 2219 - Heated Oxygen Sensor Circuit - Failed In-Range High

Associated Procedures

Cautions and Warnings

WARNING

Wait for the engine to cool down before working on the heated oxygen sensor. Failure to do so could result in personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 752 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 2. | Check the engine harness and heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 3. | Check the fuel pressure. |
 | STEP 3A. Verify secondary fuel pressure. | Pressure correct for the engine family?
 | STEP 3B. Check for fuel leaks. | Combustible gas leak detected?
 | STEP 3C. Check for a stuck open fuel control valve. | Secondary fuel pressure drop within 50 seconds of keyswitch ON?
 | STEP 3D. Gas mass flow compensation is correct. | Gas flow compensation a positive 25 or higher?
STEP 4. | Check the intake and exhaust system |
 | STEP 4A. Check the intake and exhaust system for air leaks. | Air leaks?
 | STEP 4B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2219 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 active?
YES | NO
No Repair | No Repair

Fault Code 752

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness connector 2 and heated oxygen sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the ECM, engine harness or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and the engine harness heated oxygen sensor connector adjustment current pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and the engine harness heated oxygen sensor connector SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor RETURN pin and the engine harness heated oxygen sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open adjustment current, signal or return circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line or adjustment current line has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 3A

Guided Step 3 - Check the fuel pressure.

Guided Step 3A - Verify secondary fuel pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the secondary fuel pressure.

  • Use INSITE™ electronic service tool to monitor the fuel pressure.
  • Minimum secondary fuel pressures are different depending on engine platform. See values below:

B Gas Plus - 60 psia

B LPG Plus - 40 psia

C and L Gas Plus - 75 psia

  • All pressure sensors on Gas Plus engines are absolute pressure sensors.

Pressure correct for the engine family?
YES NO
No Repair

For more troubleshooting details on low fuel pressure issues, go to Fault Code 2119.

Go to 3B

Go to 3B

Guided Step 3B - Check for fuel leaks.

Conditions

  • Turn keyswitch ON.

Action

Check for fuel leaks.

  • Start or crank the engine.
  • Use a combustible gas detector, Part Number 3823984, to check for gas leaks at the fuel jumper line between the gas mass flow sensor and the fuel control valve.

Combustible gas leak detected?
YES NO

Close fuel shutoff valve and repair the gas leak immediately.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the secondary fuel pressure while the keyswitch is ON.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Secondary fuel pressure drop within 50 seconds of keyswitch ON?
YES NO

A malfunctioning fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Gas mass flow compensation is correct.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine at stall conditions.

Action

Monitor the gas flow compensation.

  • Use INSITE™ electronic service tool to monitor the gas mass flow compensation.

Oil contamination of the gas mass flow sensor will cause a low flow reading and over compensate for fuel flow. If the engine is running rich and Fault Code 2219 is active, the gas mass flow sensor must be inspected. Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, than there is a possibility that oil has contaminated the fuel system. The customer must check the gas compression station for oil carry over.

Gas flow compensation a positive 25 or higher?
YES NO

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for intake and exhaust systems.

Guided Step 4A - Check the intake and exhaust system for air leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the intake and exhaust system for air leaks.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-024 in Section 10.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-024 in Section 10.

Air leaks?
YES NO

Follow the troubleshooting steps in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 010-024 in Section 10.

Follow the troubleshooting steps in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 010-024 in Section 10.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Use INSITE™ electronic service tool to reset.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 10-Jan-2014


FAULT CODE 2221 - Heated Oxygen Sensor Circuit - Failed In-Range Low

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 752 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 2. | Check the engine harness and heated oxygen sensor. |
 | STEP 2A. Inspect the engine harness and heated oxygen sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for pin short to ground in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check the heated oxygen sensor heater supply voltage. | Voltage greater than 12 VDC?
 | STEP 2E. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 3. | Check the fuel control valve. |
 | STEP 3A. Check for a stuck open fuel control valve. | Secondary fuel pressure drop within 50 seconds of key on?
STEP 4. | Check the exhaust system. |
 | STEP 4A. Check for high exhaust back pressure. | Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
STEP 5. | Check oil consumption. |
 | STEP 5A. Check for excessive oil consumption. | Excessive oil consumption?
 | STEP 5B. Check for an inactive fault code. | Fault Code 2219 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2219 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for snesor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 752 active?
YES | NO
No Repair | No Repair

Fault Code 752

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the engine harness and heated oxygen sensor.

Guided Step 2A - Inspect the engine harness and heated oxygen sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Inspect the engine harness and heated oxygen sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A defective connection has been detected in the ECM, engine harness or heated oxygen sensor connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-204 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for pin short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin short to ground.

  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor adjustment current pin and engine block ground.
  • Measure the resistance between the engine harness ECM connector 2 heated oxygen sensor SIGNAL pin and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A pin short to ground in the adjustment current or signal circuit has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2
  • Measure the resistance between the heated oxygen sensor adjustment current pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 2.
  • Measure the resistance between the heated oxygen sensor SIGNAL pin in the engine harness ECM connector 2 and all other pins in the ECM connector 1.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the SIGNAL wire or adjustment current wire has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 6A

Guided Step 2D - Check the heated oxygen sensor heater supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the heated oxygen sensor from the engine harness.

Action

Check the voltage at the heated oxygen sensor connector at the engine harness.

  • Measure the voltage between the heated oxygen heater SUPPLY pin and the heated oxygen heater RETURN pin at the engine harness.

See the circuit diagram or wiring diagram for connector pin identification.

Voltage greater than 12 VDC?
YES NO
No Repair

An open circuit or shorted to ground has been detected on the heated oxygen sensor SUPPLY wiree in the engine harness. An open circuit in the heated oxygen sensor return line can also be a possible fail mode.

Check for a blown, corroded or wet fuse in the heated oxygen heater supply line.

Repair the damaged pins. Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 6A

Guided Step 2E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 3A

Guided Step 3 - Check the fuel control valve.

Guided Step 3A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the secondary fuel pressure while the keyswitch is on.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Secondary fuel pressure drop within 50 seconds of key on?
YES NO

A defective fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the exhaust systems.

Guided Step 4A - Check for high exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust system for higher than specified exhaust back pressure.

  • Check the exhaust back pressure by installing a pressure gauge into the exhaust system just past the turbocharger outlet.
  • Refer to Procedure 011-009 in Section 11 in the C8.3G, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 011-009 in Section 11 in the B5.9G, B5.9 LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

Exhaust back pressure within 61 to 127 mm-Hg [2.2 to 5.0 in-Hg]?
YES NO
No Repair

Refer to Procedure 011-009 in Section 11. in the C8.3G, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 011-009 in Section 11 in the B5.9G, B5.9 LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

Go to 5A

Go to 6A

Guided Step 5 - Check oil consumption.

Guided Step 5A - Check for excessive oil consumption.

Conditions

  • Turn keyswitch OFF.

Action

Check for excessive oil consumption.

  • Use the Lubricating Oil Consumption Excessive troubleshooting symptom tree in the C8.3G, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206 and in the B5.9G, B5.9 LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

Excessive oil consumption?
YES NO

  • Use the Lubricating Oil Consumption Excessive troubleshooting symptom tree in the C8.3G, C Gas Plus and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206 and in the B5.9G, B5.9 LPG, B Gas Plus and B LPG Plus Troubleshooting and Repair Manual, Bulletin 3666164.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2219 inactive?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in Section 19.

Use INSITE™ electronic service tool to reset.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2219 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Feb-2012


FAULT CODE 2227 - Intake Manifold Pressure Leak

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 2189 inactive?
STEP 2. | Check the engine idle speed. |
 | STEP 2A. Check the engine idle speed using INSITE™ electronic service tool. | Engine idle speed greater than 900 rpm?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Check for multiple fault codes.

Fault Code 2189 inactive?
YES NO

Troubleshoot Fault Code 2189 first.

 No Repair

Fault Code 2189

Go to 2A

Guided Step 2 - Check the engine idle speed.

Guided Step 2A - Check the engine idle speed using INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.

Action

Check the engine idle speed.

  • Use INSITE™ electronic service tool to read the engine idle speed.

Engine idle speed greater than 900 rpm?
YES NO

Check the throttle actuator for leakage and leaking intake manifold around sealing orifices.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Verify that Fault Code 2227 is inactive.

Fault Code 2227 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Feb-2012


FAULT CODE 2228 - Fuel Delivery Pressure (Absolute) High - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pressure. |
 | STEP 1A. Read the fault codes. | Fault Code 2228 active?
 | STEP 1B. Check the primary fuel pressure. | Fuel pressure mesurement within 5 percent?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2228 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel pressure.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2228 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the primary fuel pressure.

Conditions

  • Turn keyswitch OFF.
  • Install a mechanical gauge.
  • Use the following procedure in the Troubleshooting and Repair Manual B5.9G, B5.9LPG, B Gas Plus, and B LPG Plus Engines, Bulletin 3666164 Refer to Procedure 005-061 in Section 5.
  • Use the following procedure in the Troubleshooting and Repair Manual C Gas, C Gas Plus, and L Gas Plus Engines, Bulletin 3666206. Refer to Procedure 005-061 in Section 5.
  • Connect INSITE™ electronic service tool.

Action

Verify the primary fuel pressure.

  • Verify the primary fuel pressure measurement with a mechanical gauge against the primary fuel pressure measurement value displayed in INSITE™ electronic service tool.

NOTE: Fuel pressure is displayed in absolute in INSITE™ electronic service tool.

The Compucheck™ fitting located on the fuel housing is used to measure secondary fuel pressure out of the engine (low pressure) fuel regulator.

Fuel pressure measurement within 5 percent?
YES NO

The OEM fuel system is not supplying proper fuel pressure or flow. Troubleshoot the OEM fuel system. Refer to OEM service manual for fuel supply troubleshooting.

A damaged primary fuel pressure sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-188 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2228 is inactive.

Fault Code 2228 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 2B

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 02-Mar-2012


FAULT CODE 2229 - Heated Oxygen Sensor Circuit - Long Term Drift

Associated Procedures

Cautions and Warnings

WARNING

Do not touch the heated oxygen sensor until it has cooled. The heated oxygen sensor operates at high temperature and can cause personal injury.
CAUTION

Do not use any lubricant in the heated oxygen sensor connector. The sensor will not perform correctly with any grease in the connector.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 751 or 752 active?
STEP 2. | Check the fuel control valve. |
 | STEP 2A. Check for a stuck open fuel control valve. | Secondary fuel pressure drop within 50 seconds of key ON?
STEP 3. | Check oil consumption. |
 | STEP 3A. Check for excessive oil consumption. | Excessive oil consumption?
 | STEP 3B. Check the crankcase ventilation canister. | Crankcase ventilation canister plugged or restricted?
STEP 4. | Check for air contaminants. |
 | STEP 4A. Check for alternate fuel source or air contaminants. | Alternate fuel source or air contaminants?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault codes. | Fault Code 2229 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 751 or 752 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 751 or Fault Code 752.

Go to 2A

Guided Step 2 - Check the fuel control valve.

Guided Step 2A - Check for a stuck open fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor the secondary fuel pressure while the keyswitch is ON.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust. This will cause the heated oxygen sensor to read a lower than actual air oxygen value.

Secondary fuel pressure drop within 50 seconds of keyswitch ON?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve. Refer to Procedure 019-102 in Section 19.

Use INSITE™ electronic service tool to reset the fuel tables.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check oil consumption.

Guided Step 3A - Check for excessive oil consumption.

Conditions

  • Turn keyswitch OFF.

Action

Check oil consumption.

  • For the C8.3G, C Gas Plus, and L Gas Plus engines. Refer to the Lubricating Oil Consumption Excessive symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. For the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 engines. Refer to the Lubricating Oil Consumption Excessive symptom tree in Section TS of the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164.

Excessive oil consumption?
YES NO

For the C8.3G, C Gas Plus, and L Gas Plus engines,. Refer to the Lubricating Oil Consumption Excessive symptom tree in Section TS of the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. For the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 engines. Refer to the Lubricating Oil Consumption Excessive symptom tree in Section TS of the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the crankcase ventilation canister.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankcase ventilation canister for a plugged or restricted crankcase ventilation filter.

If the filter becomes plugged or restricted, oil can be drawn through the turbocharger, engine and back through the exhaust side of the turbocharger. This can also cause excessive build up of hydrocarbons on the heated oxygen sensor.

Crankcase ventilation canister plugged or restricted?
YES NO

Replace the crankcase ventilation canister filter.

  • Use the following procedure in the C8.3G, C Gas Plus, and L Gas Plus Troubleshooting and Repair Manual, Bulletin 3666206. Refer to Procedure 003-021 in Section 3.
  • Use the following procedure in the B5.9G, B5.9LPG, B Gas Plus, B LPG Plus, B Gas International, and G5.9 Troubleshooting and Repair Manual, Bulletin 3666164. Refer to Procedure 003-021 in Section 3.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for air contaminants.

Guided Step 4A - Check for alternate fuel source or air contaminants.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Interview the operator to see if an alternate fuel source or contaminant was identified while the engine was in motoring state.

Air contaminants, over time, can cause the oxygen sensor to misread oxygen content in the air. If this occurs, the fuel tables can become inaccurate and cause poor open loop performance.

Alternate fuel source or air contaminants?
YES NO

Reset the fueling tables. Use INSITE™ electronic service tool to reset the fuel tables.

The engine must not be operated in the presence of combustible vapors.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2229 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 28-Feb-2012


FAULT CODE 2319 - Exhaust Back Pressure Low Warning - Under Pressure

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust back pressure. |
 | STEP 1A. Check the exhaust back pressure with a mechanical gauge. | Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
STEP 2. | Verify the sensor accuracy. |
 | STEP 2A. Compare the INSITE™ electronic service tool exhaust back pressure measurement with the mechanical gauge measurement. | INSITE™ electronic service tool measurement the same as pressure measured with gauge?
 | STEP 2B. Inspect the exhaust back pressure sensor and engine harness connector pins. | Dirty or damaged pins?
STEP 3. | Check the exhaust back pressure tube. |
 | STEP 3A. Inspect the exhaust back pressure tube for blockage. | Any blockage in tube?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2319 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust back pressure.

Guided Step 1A - Check the exhaust back pressure with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Measure the exhaust back pressure with a mechanical gauge.

This test must be performed under stall test conditions.

Pressure between 61 to 127 mm Hg [2.4 to 5.0 in Hg]?
YES NO
No Repair

Exhaust back pressure not to specification. Contact the OEM regarding the exhaust system (pipe, muffler, catalytic converter).

Go to 2A

Go to 4A

Guided Step 2 - Verify the sensor accuracy.

Guided Step 2A - Compare the INSITE™ electronic service tool exhaust back pressure measurement with the mechanical gauge measurement.

Conditions

  • Turn keyswitch ON.

Action

Verify the exhaust back pressure measurement by comparing the INSITE™ electronic service tool reading to the gauge measurement.

  • Measure the exhaust back pressure and use INSITE™ electronic service tool to verify it is the same as the pressure reading measured with a mechanical gauge.

Is INSITE™ electronic service tool measurement the same as pressure measured with gauge?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the exhaust back pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the exhaust back pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the sensor. Refer to Procedure 019-347 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the exhaust back pressure tube.

Guided Step 3A - Inspect the exhaust back pressure tube for blockage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the exhaust b ack pressure tube for blockage.

Any blockages in tube?
YES NO

Tube obstructed. Clean or replace the tube.

Replace the sensor. Refer to Procedure 019-347 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Verify that Fault Code 2319 is inactive.

Fault Code 2319 inactive?
YES NO
No Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 28-Feb-2012


INDEX
85-fc111.htm

85-t05-111.htm

85-fc115.htm

85-fc115bcgp.htm

85-t05-115bcgp.htm

85-fc115lgp.htm

85-t05-115lgp.htm

85-fc118.htm

85-t05-118.htm

85-fc119.htm

85-t05-119.htm

85-fc121.htm

85-t05-121.htm

85-fc122.htm

85-fc122bcgp.htm

85-t05-122bcgp.htm

85-fc122lgp.htm

85-t05-122lgp.htm

85-fc123.htm

85-fc123bcgp.htm

85-t05-123bcgp.htm

85-fc123lgp.htm

85-t05-123lgp.htm

85-fc124.htm

85-fc124bcgp.htm

85-t05-124bcgp.htm

85-fc124lgp.htm

85-t05-124lgp.htm

85-fc131.htm

85-t05-131.htm

85-fc132.htm

85-t05-132.htm

85-fc133.htm

85-t05-133.htm

85-fc134.htm

85-t05-134.htm

85-fc135.htm

85-fc135bcgp.htm

85-t05-135bcgp.htm

85-fc135lgp.htm

85-t05-135lgp.htm

85-fc141.htm

85-fc141bcgp.htm

85-t05-141bcgp.htm

85-fc141lgp.htm

85-t05-141lgp.htm

85-fc142.htm

85-fc142bcgp.htm

85-t05-142bcgp.htm

85-fc142lgp.htm

85-t05-142lgp.htm

85-fc143.htm

85-fc143bcgp.htm

85-t05-143bcgp.htm

85-fc143lgp.htm

85-t05-143lgp.htm

85-fc144.htm

85-fc144bcgp.htm

85-t05-144bcgp.htm

85-fc144lgp.htm

85-t05-144lgp.htm

85-fc145.htm

85-fc145bcgp.htm

85-t05-145bcgp.htm

85-fc145lgp.htm

85-t05-145lgp.htm

85-fc146.htm

85-fc146bcgp.htm

85-t05-146bcgp.htm

85-fc146lgp.htm

85-t05-146lgp.htm

85-fc151.htm

85-fc151bcgp.htm

85-t05-151bcgp.htm

85-fc151lgp.htm

85-t05-151lgp.htm

85-fc153.htm

85-t05-153.htm

85-fc154.htm

85-t05-154.htm

85-fc155.htm

85-t05-155.htm

85-fc175.htm

85-t05-175.htm

85-fc176.htm

85-t05-176.htm

85-fc177.htm

85-t05-177.htm

85-fc178.htm

85-t05-178.htm

85-fc187.htm

85-t05-187.htm

85-fc198.htm

85-t05-198.htm

85-fc199.htm

85-t05-199.htm

85-fc212.htm

85-t05-212.htm

85-fc213.htm

85-t05-213.htm

85-fc214.htm

85-t05-214.htm

85-fc221.htm

85-t05-221.htm

85-fc222.htm

85-t05-222.htm

85-fc227.htm

85-fc227bcgp.htm

85-t05-227bcgp.htm

85-fc227lgp.htm

85-t05-227lgp.htm

85-fc228.htm

85-t05-228.htm

85-fc231.htm

85-t05-231.htm

85-fc232.htm

85-t05-232.htm

85-fc233.htm

85-t05-233.htm

85-fc234.htm

85-fc234bcgp.htm

85-t05-234bcgp.htm

85-fc234lgp.htm

85-t05-234lgp.htm

85-fc235.htm

85-fc235bcgp.htm

85-t05-235bcgp.htm

85-fc235lgp.htm

85-t05-235lgp.htm

85-fc238.htm

85-t05-238.htm

85-fc239.htm

85-t05-239.htm

85-fc241.htm

85-t05-241.htm

85-fc242.htm

85-t05-242.htm

85-fc249.htm

85-t05-249.htm

85-fc254.htm

85-fc254gp.htm

85-t05-254gp.htm

85-fc254blpg.htm

85-t05-254blpg.htm

85-fc255.htm

85-fc255gp.htm

85-t05-255gp.htm

85-fc255blpg.htm

85-t05-255blpg.htm

85-fc256.htm

85-t05-256.htm

85-fc263.htm

85-t05-263.htm

85-fc265.htm

85-t05-265.htm

85-fc336.htm

85-t05-336.htm

85-fc337.htm

85-t05-337.htm

85-fc343.htm

85-t05-343.htm

85-fc346.htm

85-t05-346.htm

85-fc352.htm

85-fc352bcgp.htm

85-t05-352bcgp.htm

85-fc352lgp.htm

85-t05-352lgp.htm

85-fc354.htm

85-t05-354.htm

85-fc355.htm

85-t05-355.htm

85-fc386.htm

85-fc386bcgp.htm

85-t05-386bcgp.htm

85-fc386lgp.htm

85-t05-386lgp.htm

85-fc387.htm

85-t05-387.htm

85-fc415.htm

85-fc415bcgp.htm

85-t05-415bcgp.htm

85-fc415lgp.htm

85-t05-415lgp.htm

85-fc421.htm

85-t05-421.htm

85-fc422.htm

85-fc422bcgp.htm

85-t05-422bcgp.htm

85-fc422lgp.htm

85-t05-422lgp.htm

85-fc431.htm

85-fc431sss.htm

85-t05-431sss.htm

85-fc431iss.htm

85-t05-431iss.htm

85-fc431niss.htm

85-t05-431niss.htm

85-fc432.htm

85-t05-432.htm

85-fc441.htm

85-t05-441.htm

85-fc442.htm

85-t05-442.htm

85-fc443.htm

85-t05-443.htm

85-fc449.htm

85-t05-449.htm

85-fc453.htm

85-fc453bcgp.htm

85-t05-453bcgp.htm

85-fc453lgp.htm

85-t05-453lgp.htm

85-fc454.htm

85-fc454bcgp.htm

85-t05-454bcgp.htm

85-fc454lcgp.htm

85-t05-454lcgp.htm

85-fc455.htm

85-t05-455.htm

85-fc458.htm

85-fc458bcgp.htm

85-t05-458bcgp.htm

85-fc458lgp.htm

85-t05-458lgp.htm

85-fc459.htm

85-fc459bcgp.htm

85-t05-459bcgp.htm

85-fc459lgp.htm

85-t05-459lgp.htm

85-fc461.htm

85-fc461bcgp.htm

85-t05-461bcgp.htm

85-fc461lgp.htm

85-t05-461lgp.htm

85-fc462.htm

85-fc462bcgp.htm

85-t05-462bcgp.htm

85-fc462lgp.htm

85-t05-462lgp.htm

85-fc465.htm

85-fc465bcgp.htm

85-t05-465bcgp.htm

85-fc465lgp.htm

85-t05-465lgp.htm

85-fc466.htm

85-fc466bcgp.htm

85-t05-466bcgp.htm

85-fc466lgp.htm

85-t05-466lgp.htm

85-fc482.htm

85-t05-482.htm

85-fc488.htm

85-t05-488.htm

85-fc511.htm

85-t05-511.htm

85-fc512.htm

85-fc512gp.htm

85-t05-512gp.htm

85-fc512bgi.htm

85-t05-512bgi.htm

85-fc513.htm

85-fc513gp.htm

85-t05-513gp.htm

85-fc513bgi.htm

85-t05-513bgi.htm

85-fc545.htm

85-fc545bcgp.htm

85-t05-545bcgp.htm

85-fc545lgp.htm

85-t05-545lgp.htm

85-fc546.htm

85-t05-546.htm

85-fc547.htm

85-t05-547.htm

85-fc551.htm

85-t05-551.htm

85-fc561.htm

85-t05-561.htm

85-fc562.htm

85-t05-562.htm

85-fc563.htm

85-t05-563.htm

85-fc564.htm

85-t05-564.htm

85-fc565.htm

85-t05-565.htm

85-fc566.htm

85-t05-566.htm

85-fc572.htm

85-t05-572.htm

85-fc584.htm

85-t05-584.htm

85-fc585.htm

85-t05-585.htm

85-fc591.htm

85-t05-591.htm

85-fc592.htm

85-t05-592.htm

85-fc613.htm

85-t05-613.htm

85-fc689.htm

85-t05-689.htm

85-fc751.htm

85-fc751bcgp.htm

85-t05-751bcgp.htm

85-fc751lgp.htm

85-t05-751lgp.htm

85-fc752.htm

85-fc752bcgp.htm

85-t05-752bcgp.htm

85-fc752lgp.htm

85-t05-752lgp.htm

85-fc753.htm

85-fc753bcgp.htm

85-t05-753bcgp.htm

85-fc753lgp.htm

85-t05-753lgp.htm

85-fc778.htm

85-t05-778.htm

85-fc1128.htm

85-fc1128bcgp.htm

85-t05-1128bcgp.htm

85-fc1128lgp.htm

85-t05-1128lgp.htm

85-fc1129.htm

85-fc1129bcgp.htm

85-t05-1129bcgp.htm

85-fc1129lgp.htm

85-t05-1129lgp.htm

85-fc1271.htm

85-t05-1271.htm

85-fc1482.htm

85-t05-1482.htm

85-fc1643.htm

85-t05-1643.htm

85-fc1644.htm

85-t05-1644.htm

85-fc1645.htm

85-t05-1645.htm

85-fc1646.htm

85-t05-1646.htm

85-fc1647.htm

85-t05-1647.htm

85-fc1648.htm

85-t05-1648.htm

85-fc1649.htm

85-t05-1649.htm

85-fc1651.htm

85-t05-1651.htm

85-fc1652.htm

85-t05-1652.htm

85-fc1919.htm

85-fc1919bcgp.htm

85-t05-1919bcgp.htm

85-fc1919lgp.htm

85-t05-1919lgp.htm

85-fc2118.htm

85-t05-2118.htm

85-fc2119.htm

85-t05-2119.htm

85-fc2184.htm

85-t05-2184.htm

85-fc2185.htm

85-t05-2185.htm

85-fc2186.htm

85-t05-2186.htm

85-fc2187.htm

85-t05-2187.htm

85-fc2188.htm

85-t05-2188.htm

85-fc2189.htm

85-t05-2189.htm

85-fc2191.htm

85-t05-2191.htm

85-fc2192.htm

85-t05-2192.htm

85-fc2199.htm

85-t05-2199.htm

85-fc2219.htm

85-t05-2219.htm

85-fc2221.htm

85-t05-2221.htm

85-fc2227.htm

85-t05-2227.htm

85-fc2228.htm

85-t05-2228.htm

85-fc2229.htm

85-t05-2229.htm

85-fc2319.htm

85-t05-2319.htm