Next Generation Cense CM2330, QSK19G/38G/60G, QSV81/91 - CM700/CM2358, QSK19G/38G/60G, QSV81/91 SSM558/CM2358

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module (CM700 or CM558) Microprocessor

FAULT CODE 111

Electronic Control Module (CM700 or CM558) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: None SRT: | Error internal to the CM700 or CM558. | No effect on engine performance.
CM700 or CM558

Circuit Description

The CM700 or CM558 is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal CM700 or CM558 problem.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 27-Oct-2011
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: SPN: 190 FMI: 10 LAMP: Warning SRT: | No engine speed signal detected from the main or backup speed sensors. | Engine may shut down.
Engine Speed Sensor Circuit – Single Turbocharger
Engine Speed Sensor Circuit – Multiple Turbocharger with Two-Piece Throttle
Engine Speed Sensor Circuit – Multiple Turbocharger with Integrated Throttle

Circuit Description

The Engine/Speed Position Sensor(s) monitor the engine position and the engine speed. They then pass this information to the ECM through the engine wiring harness. The engine speed sensor is a dual coil circuit that provides the engine speed signal to each engine control module through the engine wiring harness.

Component Location

The engine speed sensor is located on engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected no engine speed signal from the backup or main speed sensors.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses the reset button.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damage engine wiring harness.
  • Damaged or loose connectors.
  • Malfunctioning or damaged engine speed/position sensor.
Refer to Troubleshooting Fault Code t05-121.

Last Modified: 26-Apr-2022


Compressor Outlet Pressure High - Critical

FAULT CODE 1213

Compressor Outlet Pressure High - Critical

Printable Version Printable Version

Overview

Compressor Outlet Pressure High - Critical

CODE | REASON | EFFECT
Fault Code: 1213 PID: P102 SPN: 102 FMI: 0 LAMP: Shutdown SRT: | The compressor outlet pressure has exceeded the high critical threshold. | Engine will shut down.
Compressor Outlet Pressure Sensor Circuit

Circuit Description

The Compressor Outlet Pressure Sensor monitors the pressure of the air and fuel mixture as it exits the turbocharger compressor. This pressure is monitored by the CM558.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The compressor outlet pressure is the pressure of the air fuel mixture after as it has exited the turbocharger compressor and prior to entering the throttle. High pressures can be a result of air-to-fuel ratios that are too high.

Refer to Troubleshooting Fault Code t05-1213

Last Modified: 27-Oct-2011


Engine Speed Below Normal

FAULT CODE 1271

Engine Speed Below Normal

Printable Version Printable Version

Overview

Engine Speed Below Normal

CODE | REASON | EFFECT
Fault Code: 1271 PID: SPN: 190 FMI: 7 LAMP: Stop/Shutdown SRT: | The ECM has detected very low engine speed when the engine has been commanded to run at low idle or high idle. | Engine will shut down.
Engine Speed Sensor Circuit – Single Turbocharger
Engine Speed Sensor Circuit – Multiple Turbocharger with Two-Piece Throttle
Engine Speed Sensor Circuit – Multiple Turbocharger with Integrated Throttle

Circuit Description

The engine speed /position sensor is a dual coil circuit that provides the engine speed signal to each engine control module through the engine wiring harness.

Component Location

The engine speed/position sensor is located on engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected very low engine speed when the engine has been commanded to run at low idle or high idle.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connectors.
  • Malfunctioning or damaged engine speed/position sensor.
  • Malfunctioning or damaged camshaft position sensor.
  • Internal ECM failure.
Refer to Troubleshooting Fault Code t05-1271

Last Modified: 29-Apr-2022


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: 100 SPN: 100 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil pressure sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-135

Last Modified: 26-Apr-2022


Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 136

Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 136 PID: SPN: 1208 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the pre-filter oil pressure sensor signal circuit. | None on performance.
Pre-Filter Oil Pressure Sensor Circuit

Circuit Description

The pre-filter oil pressure sensor monitors the engine oil pressure before it enters the filter. The pre-filter oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The pre-filter oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The pre-filter oil pressure sensor is located on the lube oil filter covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the pre-filter oil pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged pre-filter oil pressure sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-136

Last Modified: 18-Mar-2022


Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level.

FAULT CODE 1362

Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1362 PID: 99 SPN: 99 FMI: 16 LAMP: Warning SRT: | Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level. The oil filter differential pressure, measured by the inlet and outlet oil filter pressure sensors, has exceeded the Warning threshold. | No effect on engine performance.
QSV81G / QSV91G Multiple Turbochargers with Two-Piece Twin Throttles and Generator Control Panel 1 (GCP 1) and PowerCommand™ Supervisor 3100 - Engine Oil Filter Differential Circuit
QSV81G / QSV91G Multiple Turbochargers with One-Piece Twin Throttles and Generator Control Panel 2 (GCP 2) and PowerCommand™ Supervisor 3100 - Engine Oil Filter Differential Circuit and QSV91G Multiple Turbochargers with One-Piece Twin Throttles and Generator Interface Box (GIB) and PowerCommand™ Controller 3300 - Engine Oil Filter Differential Circuit
QSV91G Single Turbochargers with One-Piece Twin Throttle and Generator Control Panel 2 (GCP 2) and PowerCommand™ Supervisor 3100 - Engine Oil Filter Differential Circuit and QSV91G Single Turbocharger with One-Piece Twin Throttles and Generator Interface Box (GIB) and PowerCommand™ Controller 3300 - Engine Oil Filter Differential Circuit

Circuit Description

This fault code utilizes data from two oil pressure sensors (oil filter inlet pressure sensor and oil filter outlet pressure sensor). The CM700 engine control module (ECM) provides a 5 volt supply to these oil pressure sensors on the sensor supply circuit. The CM700 also provides a ground on the sensors' return circuit. The engine oil inlet pressure sensor and oil filter outlet pressure sensor provides signals to the CM700 on the seperate oil pressure sensor signal circuits. These sensor signal voltages change, based on the pressure in the oil gallery before and after the oil filters. The CM700 monitors these signal voltages to calculate the oil filter differential pressure.

Component Location

QSV91-G and QSV91-G2 Multiple Turbocharger Engines:

The oil filter inlet pressure sensor is located on the left-bank of the engine at the flywheel end, and is mounted on the base of the oil filter housing.

The oil filter outlet pressure sensor is located on the left-bank of the engine at the flywheel end, and is mounted on the end cover of the oil cooler.

QSV91-G3 and QSV91-G5 Single Turbocharger Engines:

The oil filter inlet pressure sensor is located on the left-bank of the engine at the free end, and is mounted in-board on the engine end of the oil filter housing.

The oil filter outlet pressure sensor is located on the left-bank of the engine at the free end, and is mounted out-board on the end end of the oil filter housing, adjacent to the oil temperature sensor.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service documentation.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position

Conditions for Setting the Fault Codes

The ECM detects that the engine oil filter differential pressure is greater than 124 kPa [18 psig] for 3 seconds. The default settings for this fault code 124 kPa [18 psig] and 3 seconds, but the differential pressure and persistence time may have different settings for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 1362 will also show as ACTIVE by INSITE™ electronic service tool and on the OEM control panel human machine interface display.

Conditions for Clearing the Fault Code

To validate the repair.

  • Start the engine and let it operate for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the oil pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors, open and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 1362, check for multiple fault codes.

Possible causes of this fault code include:

  • Plugged oil filters.
  • Plugged oil filter head.
  • Open return circuit in the harness, connectors or sensor.
  • A signal circuit shorted to sensor supply or battery voltage.

Premature plugging of the oil filters must be investigated prior to changing the oil filters and restarting the engine, otherwise serious engine damage can occur.

Refer to Troubleshooting Fault Code t05-1362.

Last Modified: 22-Jul-2013


Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 137

Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 137 PID: SPN: 1208 FMI: 4 LAMP: Warning SRT: | Low signal voltage detected at the pre-filter oil pressure sensor signal circuit. | None on performance.
Pre-Filter Oil Pressure Sensor Circuit

Circuit Description

The pre-filter oil pressure sensor monitors the engine oil pressure before it enters the filter. The pre-filter oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The pre-filter oil pressure sensor has three circuits: 5-volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The pre-filter oil pressure sensor is located on the lube oil filter covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the pre-filter oil pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged pre-filter oil pressure sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-137

Last Modified: 18-Mar-2022


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 141 PID: 100 SPN: 100 FMI: 4 LAMP: Warning SRT: | Low signal voltage detected at the engine oil pressure sensor circuit. | None on performance.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil pressure sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-141

Last Modified: 26-Apr-2022


Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 142

Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 142 PID: 100 SPN: 100 FMI: 16 LAMP: Warning SRT: | Engine oil pressure is above the engine protection warning limit. | None on performance.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil pressure was greater than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil pressure sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-142

Last Modified: 26-Apr-2022


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 143 PID: 100 SPN: 100 FMI: 18 LAMP: Warning SRT: | Engine oil pressure is below the engine protection warning limit. | None on performance.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil pressure was less than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil pressure sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-143

Last Modified: 17-May-2022


Engine Coolant Temperature Sensor Circuit (High Temperature) — Shorted High

FAULT CODE 144

Engine Coolant Temperature Sensor Circuit (High Temperature) — Shorted High

Printable Version Printable Version

Overview

Engine Coolant Temperature Sensor Circuit (High Temperature) — Shorted High

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Warning SRT: | The Engine Coolant Temperature Sensor signal (High Temperature) is Shorted High. | No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit (High Temperature)

Circuit Description

The Engine Coolant Temperature Sensor (High Temperature) is used by the CM700 to monitor the temperature of the engine coolant.

If the voltage is high, the CM700 will log Fault Code 144. High voltage can be caused by open circuits in the signal or return wires, voltage shorts to the signal or return wires, or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-144

Last Modified: 27-Oct-2011


Generator AC Output Frequency - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 1448

Generator AC Output Frequency - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

Generator AC Output Frequency - Data Valid but Below Normal Operational Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 1448 PID: SPN: 2436 FMI: 1/1 LAMP: Red SRT: | Generator AC output frequency is low. | Generator set will shut down.
Generator Circuit

Circuit Description

The generator set produces electrical power. The generator set controller monitors the performance and operation of the generator set. The threshold for a low AC output frequency condition is that the engine speed has dropped below 90 percent of nominal for at least 10 seconds.

The generator set controller displays this fault code to tell the operator when the generator set AC output frequency is low.

Component Location

The alternator is mounted directly to the engine.

The location of generator set bus bar setup is site specific.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the generator set AC output frequency is low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The generator set will shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active fault

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Fault simulation enabled.
  • Incorrect parameter settings.
  • Generator set overload.
Refer to Troubleshooting Fault Code t05-1448

Last Modified: 11-Feb-2021


Engine Coolant Temperature Sensor Circuit (High Temperature) — Shorted Low

FAULT CODE 145

Engine Coolant Temperature Sensor Circuit (High Temperature) — Shorted Low

Printable Version Printable Version

Overview

Engine Coolant Temperature Sensor Circuit (High Temperature) — Shorted Low

CODE | REASON | EFFECT
Fault Code: 145 PID: 110 SPN: 110 FMI: 4 LAMP: Warning SRT: | High temperature Engine Coolant Temperature Sensor signal is shorted low. | No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The Engine Coolant Temperature Sensor is used by the CM700 to monitor the temperature of the engine coolant. The coolant temperature is used by the CM700 for the engine protection system.

If the voltage is low, the CM700 will log Fault Code 145. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded, failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Troubleshooting Fault Code t05-145

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 1457
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc1457st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc1457mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc1457mt

Last Modified: 21-Dec-2011


Generator Synchronizing to Electric Bus Failed - Condition Exists

FAULT CODE 1457 - Multiple Turbocharger with Integrated Throttle

Generator Synchronizing to Electric Bus Failed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1457 PID: SPN: 2529 FMI: 31 LAMP: Amber SRT: | Generator Synchronizing to Electric Bus Failed - Condition Exists. The generator set synchronization to the system electric bus has malfunctioned. | The generator set will continue to run, but the generator set will not close its breaker or pick-up the load.

Circuit Description

The generator set picks up electrical load from the system electric bus. For the generator set to connect to the bus (other than a dead bus), it must match, within a preset threshold, the voltage, frequency, and phase rotation of the bus. The generator set can not connect to the bus while voltage and frequency are outside the threshold, and the phase rotation between the generator set and the bus does not match; otherwise, serious damage can occur to the generator set.

The generator set control panel transmits certain generator set parameters to the parent engine control module (CM700) by way of a data link. The generator set control system will inform the operator that the generator set has not synchronized to the system electric bus by displaying a fault code on the generator set control panel. The engine CM700 module will also generate Fault Code 1457.

Component Location

For the location of the generator set circuit breakers, use the customer/facility/installation documentation.

Use the following procedure for the generator set component locations. Refer to Procedure 100-002 in Section E.

Shop Talk

The generator set control fault code is dependent on the model of the control panel installed. The fault code generated will be as follows:

  • Cummins® PowerCommand® Supervisor (PCS) 3100: Fault Code 224.
  • Cummins® PowerCommand® Controller (PCC) 3300: Fault Code 1457.

The fault codes must be cleared on both the generator set and engine control systems before the generator set can be restarted.

The alarm condition of this fault is configurable via the generator set controller front panel, or by connecting the Cummins® Power Generation electronic service tool - InPower™. The operator/service technician, can set this fault code to either '"WARNING", in which case the generator set will continue to run but not take load, or SHUTDOWN, in which case the generator set will shutdown. The factory default setting for this fault code is set as a WARNING.

Generator set related problems that can activate this fault code are:

  • Incorrect adjustment of bus or generator set voltage (control panel calibration)
  • Malfunctioning power transformer module
  • Generator set controller synchronizing permissive window parameters incorrectly set
  • Generator set control panel circuit board faults
  • Generator set harness faults.

Troubleshooting of the generator set control panel is outside the scope of this document. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand® Supervisor (PCS) 3100: Service Manual, Bulletin A034T570.
  • Cummins® PowerCommand® Controller (PCC) 3300: Service Manual, Bulletin 0900-0670.

The throttle plate commanded signal and the feedback signal can be monitored with the electronic service tool. If the difference between the commanded position and the feedback position signal is greater than the fault threshold, which is pre-set to 30 percent, then Fault Code 177 will be set.

The throttle assembly can be tested using the electronic service tool. To conduct this test, the engine rpm must be at zero. The throttle plate can be commanded to any position between 0 percent and 100 percent and the feedback signal compared with the commanded signal.

The most likely causes for this fault being activated are:

  • Mechanical seizure of the throttle shaft/bearings.
  • A fault with the throttle plate position feedback circuit.
Refer to Troubleshooting Fault Code t05-1457mt.

Last Modified: 24-Aug-2014


Generator Synchronizing to Electric Bus Failed - Condition Exists

FAULT CODE 1457 - Multiple Turbocharger with Two-Piece Throttle

Generator Synchronizing to Electric Bus Failed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1457 PID: SPN: 2529 FMI: 31 LAMP: Amber SRT: | Generator Synchronizing to Electric Bus Failed - Condition Exists. The generator set synchronization to the system electric bus has malfunctioned. | The generator set will continue to run, but the generator set will not close its breaker or pick-up load.

Circuit Description

The generator set picks up electrical load from the system electric bus. For the generator set to connect to the bus (other than a dead bus), it must match, within a preset threshold, the voltage, frequency, and phase rotation of the bus. The generator set can not connect to the bus while voltage and frequency are outside the threshold, and the phase rotation between the generator set and the bus does not match; otherwise, serious damage can occur to the generator set.

The generator set control panel transmits certain generator set parameters to the parent engine control module (CM700) by way of a data link. The generator set control system will inform the operator that the generator set has not synchronized to the system electric bus by displaying a fault code on the generator set control panel. The engine CM700 module will also generate Fault Code 1457.

Component Location

For the location of the generator set circuit breakers, use the customer/facility/installation documentation.

Use the following procedure for the generator set component locations. Refer to Procedure 100-002 in Section E.

Shop Talk

The generator set control fault code is dependent on the model of the control panel installed. The fault code generated will be as follows:

  • Cummins® PowerCommand® Supervisor (PCS) 3100: Fault Code 224.
  • Cummins® PowerCommand® Controller (PCC) 3300: Fault Code 1457.

The fault codes must be cleared on both the generator set and engine control systems before the generator set can be restarted.

The alarm condition of this fault is configurable via the generator set controller front panel, or by connecting the Cummins Power Generation electronic service tool - InPower™. The operator/service technician, can set this fault code to either WARNING, in which case the generator set will continue to run but not take load, or SHUTDOWN, in which case the generator set will shutdown. The factory default setting for this fault code is set as a WARNING.

Generator set related problems that can activate this fault code are:

  • Incorrect adjustment of bus or generator set voltage (control panel calibration).
  • Malfunctioning power transformer module.
  • Generator set controller synchronizing permissive window parameters incorrectly set.
  • Generator set control panel circuit board faults.
  • Generator set harness faults.

Troubleshooting of the generator set control panel is outside the scope of this document. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand® Supervisor (PCS) 3100: Service Manual, Bulletin A034T570.
  • Cummins® PowerCommand® Controller (PCC) 3300: Service Manual, Bulletin 0900-0670.

The throttle plate commanded signal and the feedback signal can be monitored with the electronic service tool. If the difference between the commanded position and the feedback position signal is greater than the fault threshold, which is pre-set to 30 percent, then Fault Code 177 will be set.

The throttle assembly can be tested using the electronic service tool. To conduct this test, the engine rpm must be at zero. The throttle plate can be commanded to any position between 0 percent and 100 percent and the feedback signal compared with the commanded signal.

The most likely causes for this fault being activated are:

  • Mechanical seizure of the throttle shaft/bearings
  • A fault with the throttle plate position feedback circuit.
Refer to Troubleshooting Fault Code t05-1457mttt.

Last Modified: 24-Aug-2014


Generator Synchronizing to Electric Bus Failed - Condition Exists

FAULT CODE 1457 - Single Turbocharger

Generator Synchronizing to Electric Bus Failed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1457 PID: SPN: 2529 FMI: 31 LAMP: Amber SRT: | Generator Synchronizing to Electric Bus Failed - Condition Exists. The generator set synchronization to the system electric bus has malfunctioned. | The generator set will continue to run, but the generator set will not close its breaker or pick-up the load.

Circuit Description

The generator set picks up electrical load from the system electric bus. For the generator set to connect to the bus (other than a dead bus), it must match, within a preset threshold, the voltage, frequency, and phase rotation of the bus. The generator set can not connect to the bus while voltage and frequency are outside the threshold, and the phase rotation between the generator set and the bus does not match; otherwise, serious damage can occur to the generator set.

The generator set control panel transmits certain generator set parameters to the parent engine control module (CM700) by way of a data link. The generator set control system will inform the operator that the generator set has not synchronized to the system electric bus by displaying a fault code on the generator set control panel. The engine CM700 module will also generate Fault Code 1457.

Component Location

For the location of the generator set circuit breakers, use the customer/facility/installation documentation.

Use the following procedure for the generator set component locations. Refer to Procedure 100-002 in Section E.

Shop Talk

The generator set control fault code is dependent on the model of the control panel installed. The fault code generated will be as follows:

  • Cummins® PowerCommand® Supervisor (PCS) 3100: Fault Code 224.
  • Cummins® PowerCommand® Controller (PCC) 3300: Fault Code 1457.

The fault codes must be cleared on both the generator set and engine control systems before the generator set can be restarted.

The alarm condition of this fault is configurable via the generator set controller front panel, or by connecting the Cummins Power Generation electronic service tool - InPower™. The operator/service technician, can set this fault code to either WARNING, in which case the generator set will continue to run but not take load, or SHUTDOWN, in which case the generator set will shutdown. The factory default setting for this fault code is set as a WARNING.

Generator set related problems that can activate this fault code are:

  • Incorrect adjustment of bus or generator set voltage (control panel calibration).
  • Malfunctioning power transformer module.
  • Generator set controller synchronizing permissive window parameters incorrectly set.
  • Generator set control panel circuit board faults.
  • Generator set harness faults.

Troubleshooting of the generator set control panel is outside the scope of this document. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand® Supervisor (PCS) 3100: Service Manual, Bulletin A034T570.
  • Cummins® PowerCommand® Controller (PCC) 3300: Service Manual, Bulletin 0900-0670.

The throttle plate commanded signal and the feedback signal can be monitored with the electronic service tool. If the difference between the commanded position and the feedback position signal is greater than the fault threshold, which is pre-set to 30 percent, then Fault Code 177 will be set.

The throttle assembly can be tested using the electronic service tool. To conduct this test, the engine rpm must be at zero. The throttle plate can be commanded to any position between 0 percent and 100 percent and the feedback signal compared with the commanded signal.

The most likely causes for this fault being activated are:

  • Mechanical seizure of the throttle shaft/bearings.
  • A fault with the throttle plate position feedback circuit.
Refer to Troubleshooting Fault Code t05-1457st.

Last Modified: 24-Aug-2014


Generator is absorbing Power from the Electric Bus - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1459

Generator is absorbing Power from the Electric Bus - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1459 PID: SPN: 2452 FMI: 1/1 LAMP: Red SRT: | The generator set is drawing power from the bus bar rather than producing power for the bus bar. | The generator set will shut down.
Generator Circuit

Circuit Description

Under normal operating conditions, the generator set connects to the bus bar. Generator set is producing power, and when it connects to the bus bar, power is added to the bus bar. When some events occur, a condition can occur when the generator set is no longer producing power for the bus bar, but rather is drawing power from the bus bar. This condition is called reverse kilowatt.

Component Location

Refer to the appropriate service manual for the location of the generator set circuit breaker and interface with the bus bar.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The generator set controller has detected reverse kilowatt.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Improper connection of load-sharing lines.
  • Incorrect frequency and voltage at the generator set.
  • Improper connection to the generator's current transformer.

Refer to Troubleshooting Fault Code t05-1459.

Last Modified: 24-Mar-2022


Engine Coolant Temperature (High Temperature) High - Warning

FAULT CODE 146

Engine Coolant Temperature (High Temperature) High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 1100 FMI: 16 LAMP: Warning SRT: | Engine Coolant Temperature (High Temperature) High - Warning. The engine coolant temperature (high temperature) has exceeded the high warning threshold. | No effect on engine performance.
Engine Coolant Temperature Sensor Circuit (High Temperature)

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant circuit of the engine. The CM700 engine control module (ECM) supplies 5 volts to the coolant temperature circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the engine ECMs for the engine protection system and emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

For single turbocharger, single throttle engines, the high temperature coolant circuit temperature sensor is mounted on the right bank side of the aftercooler located at the front of the engine.

For multiple turbocharger, twin throttle engines, the high temperature coolant circuit temperature sensor is mounted in the high temperature coolant steel pipe located at the front of the engine on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

  • The ECM detects that the high temperature coolant signal is greater than the warning threshold limit for 3 seconds. The default persistent time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.
  • The high temperature coolant signal Warning threshold is dependent on engine model, applications, and CM700 software versions.

Action Taken When the Fault Code is Active

  • The CM700 module illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 146 will also be shown as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.

Conditions for Clearing the Fault Code

  • To validate the repair. start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code indicates that the coolant temperature (high temperature coolant circuit) has exceeded the engine protection warning limit for high coolant temperature. Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314.

OEM supplied balance-of-plant equipment can also cause Fault Code 146 to be activated. This equipment must be confirmed as working correctly when troubleshooting this fault code. OEM equipment must be installed and operating to manufacturer's specification and must be suitable for the application. See equipment manufacturer service information.

OEM supplied equipment includes (but not limited to):

  • Radiators and associated pipework
  • Electrically driven radiator fans
  • Off-engine electrically driven coolant circulation pumps
  • Heat exchangers and associated pipework
  • Cooling system deaeration lines and chambers
  • Cooling system pressure vessels and associated pipework
  • Electrically driven coolant flow control valves and associated pipework.

Possible causes of this fault code include (but not limited to):

  • Engine operation at high altitude and applicable derate not applied
  • Engine operating at high humidity conditions and applicable derate not applied
  • Engine operation at high ambient temperatures and applicable derate not applied
  • Aftercooler core blocked
  • Cooling system undersized for application
  • Radiator core blocked
  • Incorrect thermostats installed for application
  • Electrically driven radiator fans not working correctly (stopped or fan speed too low)
  • Collapsed coolant pipes resulting in coolant flow restriction
  • Cogeneration system heat exchanger blocked
  • Temperature sensor malfunctioning in-range so Fault Codes 144 or 145 are not activated
  • Engine load too high (generator set controller fault or controller calibration error).
Refer to Troubleshooting Fault Code t05-146.

Last Modified: 17-Feb-2015


Incompatible Software Versions Determined Between Engine Controls ECM's

FAULT CODE 1474

Incompatible Software Versions Determined Between Engine Controls ECM's

Printable Version Printable Version

Overview

Incompatible Software Versions Determined Between Engine Controls ECM's

CODE | REASON | EFFECT
Fault Code: 1474 PID: P21 SPN: 35 FMI: 31 LAMP: Shutdown SRT: | The ECM's have detected incompatibly of software on one or more modules. | Engine will not be allowed to start.
Electronic Service Tool

Circuit Description

The CM700 and CM558 each require software, often called calibrations, to perform control functions and provide engine protection.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The Electronic Control Module (ECM) function and control can change with software versions. The electric service tool and ECM's perform automatic checks to ensure the CM700 and CM558 software versions are compatible. If the ECM automatic check identifies incompatible software, the Fault Code 1474 will be activated.

Refer to Troubleshooting Fault Code t05-1474

Last Modified: 27-Oct-2011


Fuel Pressure Sensor Circuit - Shorted High

FAULT CODE 1482

Fuel Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 1482 PID: FMI: 3 LAMP: Warning SRT: | High voltage detected on the Fuel Pressure Sensor signal circuit. | Possible reduced engine performance.
Fuel Pressure Sensor Circuit

Circuit Description

The Fuel Pressure Sensor monitors the gas pressure as it enters the fuel shutoff valve. The pressure in monitored by the CM700 module. High voltage will cause Fault Code 1482 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

The fuel pressure sensor is located on the left side of the engine within the gas control assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged fuel pressure sensor.
  • Malfunctioning or damaged wiring harness.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1482

Last Modified: 29-Apr-2022


Fuel Pressure Sensor Circuit - Shorted Low

FAULT CODE 1484

Fuel Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 1484 PID: FMI: 3 LAMP: Warning SRT: | Low voltage detected on the Fuel Pressure Sensor signal circuit. | Possible reduced engine performance.
Fuel Pressure Sensor Circuit

Circuit Description

The Fuel Pressure Sensor monitors the gas pressure as it enters the fuel shutoff valve. The pressure in monitored by the CM700 module. Low voltage will cause Fault Code 1484 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

The fuel pressure sensor is located on the left side of the engine within the gas control assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged fuel pressure sensor.
  • Malfunctioning or damaged wiring harness.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1484

Last Modified: 26-Apr-2022


Engine Coolant Temperature (High Temperature) High - Critical

FAULT CODE 151

Engine Coolant Temperature (High Temperature) High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Shutdown SRT: | Engine Coolant Temperature (High Temperature) High - Critical. The engine coolant temperature (high temperature) has exceeded the high critical threshold. | Engine will shut down.
Engine Coolant Temperature Sensor Circuit (High Temperature)

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant circuit of the engine. The CM700 engine control module (ECM) supplies 5 volts to the coolant temperature circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the engine ECMs for the engine protection system and emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

For single turbocharger, single throttle engines, the high temperature coolant circuit temperature sensor is mounted on the right bank side of the aftercooler located at the front of the engine.

For multiple turbocharger, twin throttle engines, the high temperature coolant circuit temperature sensor is mounted in the high temperature coolant steel pipe located at the front of the engine on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

  • The ECM detects that the high temperature coolant signal is greater than the critical threshold limit for 3 seconds. The default persistent time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.
  • The high temperature coolant signal critical threshold is dependent on engine model, applications, and CM700 software versions.

Action Taken When the Fault Code is Active

The CM700 module illuminates the red ALARM SHUTDOWN lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 151 will also be shown as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.

Conditions for Clearing the Fault Code

  • To validate the repair. start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM700 will turn off the red ALARM SHUTDOWN lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code indicates that the coolant temperature (high temperature coolant circuit) has exceeded the engine protection critical limit for high coolant temperature. Reference the Engine Coolant Temperature Above Normal troubleshooting tree in Section TS of the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314.

The OEM supplied balance-of-plant equipment can also cause Fault Code 151 to be activated. This equipment must be confirmed as working correctly when troubleshooting this fault code. OEM equipment must be installed and operating to manufacturer's specification and must be suitable for the application. See equipment manufacturer service information.

OEM supplied equipment includes (but not limited to):

  • Radiators and associated pipework
  • Electrically driven radiator fans
  • Off-engine electrically driven coolant circulation pumps
  • Heat exchangers and associated pipework
  • Cooling system deaeration lines and chambers
  • Cooling system pressure vessels and associated pipework
  • Electrically driven coolant flow control valves and associated pipework.

Possible causes of this fault code include (but not limited to):

  • Engine operation at high altitude and applicable derate not applied
  • Engine operating at high humidity conditions and applicable derate not being applied
  • Engine operation at high ambient temperatures and applicable derate not being applied
  • Aftercooler core blocked
  • Cooling system undersized for application
  • Radiator core blocked
  • Incorrect thermostats installed for application
  • Electrically driven radiator fans not working correctly (stopped or fan speed too low)
  • Collapsed coolant pipes resulting in coolant flow restriction
  • Cogeneration system heat exchanger blocked
  • Temperature sensor malfunctioned in-range so Fault Codes 144 or 145 are not activated
  • Engine load too high (generator set controller fault or controller calibration error).
Refer to Troubleshooting Fault Code t05-151.

Last Modified: 17-Feb-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage above normal, or shorted to high source

FAULT CODE 1521

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1521 PID: SPN: 1139 FMI: 3 LAMP: Stop/Shutdown SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.

Refer to Troubleshooting Fault Code t05-1521

Last Modified: 24-Mar-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage above normal, or shorted to high source

FAULT CODE 1522

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1522 PID: SPN: 1141 FMI: 3 LAMP: Stop / Shutdown SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1522

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage above normal, or shorted to high source

FAULT CODE 1523

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1523 PID: SPN: 1143 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1523

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage above normal, or shorted to high source

FAULT CODE 1524

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1524 PID: SPN: 1145 FMI: 3 LAMP: Stop / Shutdown SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1524

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage above normal, or shorted to high source

FAULT CODE 1525

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1525 PID: SPN: 1147 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1525

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage above normal, or shorted to high source

FAULT CODE 1526

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1526 PID: SPN: 1149 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1526

Last Modified: 24-Mar-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage above normal, or shorted to high source

FAULT CODE 1527

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: SPN: 1151 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors
Refer to Troubleshooting Fault Code t05-1527

Last Modified: 24-Mar-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 17 (A9) - Voltage above normal, or shorted to high source

FAULT CODE 1528

Exhaust Gas Temperature Sensor Circuit Cylinder 17 (A9) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1528 PID: SPN: 1153 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1528

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage above normal, or shorted to high source

FAULT CODE 1529

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1529 PID: SPN: 1138 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors
Refer to Troubleshooting Fault Code t05-1529

Last Modified: 05-Apr-2022


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 153 PID: 105 SPN: 105 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at intake manifold temperature sensor circuit. | Possible reduced engine performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistance sensor used by the Engine Control Module (ECM) to monitor the pressure and temperature in the intake manifold. The sensor has four circuits: supply, return and two signal circuits. The intake manifold pressure/temperature sensor temperature signal indicates the pressure/temperature in the intake manifold.

Component Location

The Intake manifold temperature sensor is located on each bank below the charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails. A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged intake manifold temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-153

Last Modified: 17-Mar-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage above normal, or shorted to high source

FAULT CODE 1531

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1531 PID: SPN: 1142 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1531

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage above normal, or shorted to high source

FAULT CODE 1532

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1532 PID: SPN: 1144 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1532

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage above normal, or shorted to high source

FAULT CODE 1533

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1533 PID: SPN: 1146 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1533

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage above normal, or shorted to high source

FAULT CODE 1534 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1534 PID: SPN: 1148 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1534

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage above normal, or shorted to high source

FAULT CODE 1535

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1535 PID: SPN: 1150 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1535

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage above normal, or shorted to high source

FAULT CODE 1536

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1536 PID: SPN: 1152 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1536.

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 18 (B9) - Voltage above normal, or shorted to high source

FAULT CODE 1527

Exhaust Gas Temperature Sensor Circuit Cylinder 18 (B9) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: SPN: 1154 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1537

Last Modified: 05-Apr-2022


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 154 PID: 105 SPN: 105 FMI: 4 LAMP: Warning SRT: | Low signal voltage detected at intake manifold temperature sensor circuit. | Possible reduced engine performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistance sensor used by the Engine Control Module (ECM) to monitor the pressure and temperature in the intake manifold. The sensor has four circuits: supply, return and two signal circuits. The intake manifold pressure/temperature sensor temperature signal indicates the pressure/temperature in the intake manifold.

Component Location

The Intake manifold temperature sensor is located on each bank below the charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged intake manifold temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-154

Last Modified: 17-Mar-2022


Engine Secondary Speed Sensor (Engine Camshaft Speed/Position Sensor) Lost - Condition Exists

FAULT CODE 1545

Engine Secondary Speed Sensor (Engine Camshaft Speed/Position Sensor) Lost - Condition Exists

Printable Version Printable Version

Overview

Engine Secondary Speed Sensor (Engine Camshaft Speed/Position Sensor) Lost - Condition Exists

CODE | REASON | EFFECT
Fault Code: 1545 PID: SPN: 723 FMI: 31 LAMP: Warning SRT: | The Engine Control Module (ECM) has detected a loss of signal from the camshaft position sensor circuit. | Possible reduced engine performance.
Camshaft Position Sensor

Circuit Description

The camshaft engine position sensor provides engine speed information to the engine control module (ECM). The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the camshaft.

Component Location

The engine camshaft position sensor is located on the side of the front gear cover housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the engine speed sensor signal.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged camshaft position sensor.
  • Damaged tone wheel.
  • Sensor air gap that is marginally too small or too large.
Refer to Troubleshooting Fault Code t05-1545

Last Modified: 22-Mar-2022


Engine Primary Speed Sensor (Engine Crankshaft Speed/Position Sensor) Lost - Condition Exists

FAULT CODE 1546

Engine Primary Speed Sensor (Engine Crankshaft Speed/Position Sensor) Lost - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1546 PID: 190 SPN: 190 FMI: 31 LAMP: Warning SRT: | The Engine Control Module (ECM) has detected a loss of signal from the engine speed/position sensor. | None on performance.
Camshaft Position Sensor

Circuit Description

The Engine/Speed Position Sensor(s) monitor the engine position and the engine speed. They then pass this information to the ECM through the engine wiring harness.

The engine speed sensor is a dual coil circuit that provides the engine speed signal to each engine control module through the engine wiring harness.

Component Location

The engine speed/position sensor is located on the side of the flywheel housing in the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or Damaged engine speed sensor.
  • Damaged tone wheel.
  • Sensor air gap that is marginally too small or too large.
Refer to Troubleshooting Fault Code 1546.

Last Modified: 18-Mar-2022


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 155 PID: 105 SPN: 105 FMI: 0 LAMP: Shutdown SRT: | Intake manifold temperature signal indicates intake manifold temperature above engine protection critical limit. | The engine will shut down.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold temperature sensor is a variable resistance sensor used by the Engine Control Module (ECM) to monitor the pressure and temperature in the intake manifold. The sensor has four circuits: supply, return and two signal circuits. The intake manifold pressure/temperature sensor temperature signal indicates the pressure/temperature in the intake manifold.

Component Location

The Intake manifold pressure sensor is located on each bank below the charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

The "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged intake manifold temperature sensor
  • Damaged or loose connectors
  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-155

Last Modified: 17-Mar-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage above normal, or shorted to high source

FAULT CODE 1618

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1618 PID: SPN: 1137 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1618

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage above normal, or shorted to high source

FAULT CODE 1619

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage above normal, or shorted to high source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1619 PID: SPN: 1140 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range high.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1619

Last Modified: 28-Mar-2022


Engine Throttle Control Actuator - Bad Intelligent Device or Component (QSV91G)

FAULT CODE 1737

Engine Throttle Control Actuator - Bad Intelligent Device or Component (QSV91G)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1737 PID: SPN: 3464 FMI: 12 LAMP: Red SRT: | The throttle control actuator has an internal failure. | Engine will shut down.
Single Turbocharger Throttle Control Actuator Circuit
Multiple Turbocharger with Two Piece Throttle Control Actuator Circuit
Multiple Turbocharger with Integrated Throttle Control Actuator Circuit

Circuit Description

The throttle assemblies are supplied with a fused 24-VDC supply from the original equipment manufacturer (OEM) control panel, each throttle having a dedicated supply. When the engine is not running, the power to the throttle assemblies is switched off by removing the run enable signal. When the engine receives a start command, the run enable switch is closed and power to the throttle assemblies is restored.

This fault code only applies to the QSV91G engine platforms fitted with two throttle assemblies.

Component Location

Both throttle control actuator assemblies are mounted on the front gear housing, directly below the charge-air cooler assembly located at the non‐drive end of the engine. The throttle control actuator 1 assembly is mounted on the left side of the front gear housing and the throttle control actuator 2 assembly is mounted on the right side of the front gear housing (when viewed from the flywheel end of the engine).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Throttle control actuator has reported to the Engine Control Module (ECM) that it has an internal failure.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning throttle control actuator.
Refer to Troubleshooting Fault Code 1737.

Last Modified: 25-Jan-2021


Engine Throttle Control Actuator - Condition Exists (QSV91G)

FAULT CODE 1739

Engine Throttle Control Actuator - Condition Exists (QSV91G)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1739 PID: SPN: 3464 FMI: 11/31 LAMP: Amber SRT: | The Throttle Control Actuator has an internal failure. | Possible reduced engine performance.
Single Turbocharger Throttle Control Actuator Circuit
Multiple Turbocharger with Two Piece Throttle Control Actuator Circuit
Multiple Turbocharger with Integrated Throttle Control Actuator Circuit

Circuit Description

The throttle assemblies are supplied with a fused 24-VDC supply from the original equipment manufacturer (OEM) control panel, each throttle having a dedicated supply. When the engine is not running, the power to the throttle assemblies is switched off by removing the Run Enable signal. When the engine receives a Start Command, the Run Enable switch is closed and power to the throttle assemblies is restored.

This fault code only applies to the QSV91G engine platforms fitted with two throttle assemblies.

Component Location

Both throttle control actuator assemblies are mounted on the front gear housing, directly below the charge-air cooler assembly located at the non‐drive end of the engine. The throttle control actuator 1 assembly is mounted on the left side of the front gear housing and the throttle control actuator 2 assembly is mounted on the right side of the front gear housing (when viewed from the flywheel end of the engine).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Throttle control actuator has reported to the Engine Control Module (ECM) that it has diagnosed an issue with the position demand signal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning throttle control actuator.
Refer to Troubleshooting Fault Code 1739.

Last Modified: 25-Jan-2021


FAULT CODE 1745

Printable Version Printable Version

Overview

Engine Throttle Control Actuator 2 - Data Erractic, Intermittent, or Incorrect - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2111 PID: SPN: 3645 FMI: 2 LAMP: Red SRT: | Engine Throttle Control Actuator 2 - Data Erractic, Intermittent, or Incorrect - Condition Exists. The data for throttle control actuator 2 being received over the CAN 2.0B data link is erratic, intermittent or not being received by the CM558 engine control module (ECM). | Engine will shutdown.
QSV91G Multiple Turbocharger with Two Integrated Throttle Assemblies

Circuit Description

NOTE: This fault code is only applies to the QSV91G engine platforms fitted with two throttle assemblies.

The throttle assemblies are supplied with a fused 24-VDC supply from the original equipment manufacturer (OEM) control panel, each throttle having a dedicated supply. When the engine is not running, the power to the throttle assemblies is switched off by removing the Run Enable signal. When the engine receives a Start Command, the Run Enable switch is closed and power to the throttle assemblies is restored.

The CM700 ECM monitors engine speed and when engine speed deviates (plus or minus) from the default engine speed within the CM700 calibration, the CM700 issues a Percent Torque Command Signal to both CM558 ECMs over the CAN 2.0B data link network. Based on this Percent Torque Command Signal, the CM558 modules will command their respective throttle assemblies , via the CAN2.0B data link network to either open or close so that the engine speed is maintained regardless of engine torque/load. The A-bank (left-bank) CM558 controls the A-bank throttle control actuator 1 assembly and the B-bank (right-bank) CM558 controls the B‐bank throttle control actuator 2 assembly. The throttle control actuators receive position command signals and transmit throttle position feedback signals over the same CAN 2.0B data link network. Each throttle control actuator has its own network device identification assigned.

The CAN jumper (installed between pins J and K on the throttle control actuator 2 C32 connector) activates a 120 ohm termination resistor that is located within the throttle assembly. Activating this internal CAN2.0B termination resistor removes the need to have a separate second termination resistor within the engine wiring harness (two CAN2.0B data link 120 ohm termination resistors are required).

Component Location

Both throttle control actuator assemblies are mounted on the front gear housing, directly below the charge-air cooler assembly located at the non‐drive end of the engine. The throttle control actuator 1 assembly is mounted on the left side of the front gear housing and the throttle control actuator 2 assembly is mounted on the right side of the front gear housing (when viewed from the flywheel end of the engine).

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

The run enable relay is located within the OEM control panel. Refer to the OEM service manual.

The CAN 2.0B data link network is located within the engine harnesses and OEM control panel wiring harness. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position and the engine is running. Throttle control actuator data is monitored on the CAN 2.0B data link network every 10 milliseconds.

Conditions for Setting the Fault Codes

The CM558 detects that the throttle control actuator 2 data has not been received/detected for more than 3 seconds. Three seconds is the default persistence time for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

-The CM700 illuminates the Red ALARM SHUTDOWN lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault code 1745 will also show as ACTIVE by INSITE™ electronic service tool and on the OEM control panel Human Machine Interface (HMI) display.

-The engine control system will issue a Critical Engine Stop command.

Conditions for Clearing the Fault Code

-To validate the repair, an alarm reset will need to be performed via the OEM control panel. The fault code will change to INACTIVE and the alarm SHUTDOWN lamp will be extinguished. Refer to the OEM service documentation.

-Start the engine and let it run for 1 minute at no load.

-The fault code status displayed by INSITE™ electronic service tool will remain at INACTIVE immediately after the diagnostics runs and passes.

-The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code could be activated by either an internal throttle control actuator fault or by a fault condition external to the throttle control actuator 2.

Possible causes of this fault code include:

  • Power supply + ve or ‐ ve wires open circuit or short to ground in the harness, connectors or throttle control actuator 2.
  • Poor connections (intermittent 'make and break' condition) in the power supply + ve or ‐ ve supply harness connectors.
  • CAN 2.0B data link network open circuit or short to ground in the harness, connectors, or throttle control actuator 2.
  • Poor connections (intermittent 'make or break' condition) in the CAN 2.0B data link network, connectors, or throttle control actuator 2.
  • Poor connections (intermittent 'make or break' condition) at the CAN 2.0B data link network 120 ohm termination resistor (located in the OEM generator interface box) or the CAN jumper link fitted between pins J and K on the throttle control actuator 2 C32 connector.
  • Run Enable supply connection wires, open circuit or short to ground in the harness, connectors, relay, or throttle control actuator 2.
Refer to Troubleshooting Fault Code t05-1745.

Last Modified: 02-Oct-2013


Engine Throttle Control Actuator 2 - Bad Intelligent Device or Component

FAULT CODE 1747

Engine Throttle Control Actuator 2 - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1747 PID: SPN: 3465 FMI: 12/12 LAMP: Red SRT: | The throttle control actuator has an internal failure. | Engine will shut down.
Single Turbocharger Throttle Control Actuator Circuit
Multiple Turbocharger with Two Piece Throttle Control Actuator Circuit
Multiple Turbocharger with Integrated Throttle Control Actuator Circuit

Circuit Description

The throttle assemblies are supplied with a fused 24-VDC supply from the original equipment manufacturer (OEM) control panel, each throttle having a dedicated supply. When the engine is not running, the power to the throttle assemblies is switched off by removing the run enable signal. When the engine receives a start command, the run enable switch is closed and power to the throttle assemblies is restored.

This fault code only applies to the QSV91G engine platforms fitted with two throttle assemblies.

Component Location

Both throttle control actuator assemblies are mounted on the front gear housing, directly below the charge-air cooler assembly located at the non‐drive end of the engine. The throttle control actuator 1 assembly is mounted on the left side of the front gear housing and the throttle control actuator 2 assembly is mounted on the right side of the front gear housing (when viewed from the flywheel end of the engine).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Throttle control actuator has reported to the Engine Control Module (ECM) that it has an internal failure.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning throttle control actuator.
Refer to Troubleshooting Fault Code 1747.

Last Modified: 01-Feb-2021


Engine Throttle Actuator 2 Control - Condition Exists

FAULT CODE 1749

Engine Throttle Actuator 2 Control - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1749 PID: SPN: 3465 FMI: 11/31 LAMP: Amber SRT: | The Throttle Control Actuator has an internal failure. | Possible reduced engine performance.
Single Turbocharger Throttle Control Actuator Circuit
Multiple Turbocharger with Two Piece Throttle Control Actuator Circuit
Multiple Turbocharger with Integrated Throttle Control Actuator Circuit

Circuit Description

The throttle assemblies are supplied with a fused 24-VDC supply from the original equipment manufacturer (OEM) control panel, each throttle having a dedicated supply. When the engine is not running, the power to the throttle assemblies is switched off by removing the Run Enable signal. When the engine receives a Start Command, the Run Enable switch is closed and power to the throttle assemblies is restored.

This fault code only applies to the QSV91G engine platforms fitted with two throttle assemblies.

Component Location

Both throttle control actuator assemblies are mounted on the front gear housing, directly below the charge-air cooler assembly located at the non‐drive end of the engine. The throttle control actuator 1 assembly is mounted on the left side of the front gear housing and the throttle control actuator 2 assembly is mounted on the right side of the front gear housing (when viewed from the flywheel end of the engine).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Throttle control actuator has reported to the Engine Control Module (ECM) that it has diagnosed an issue with the position demand signal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning throttle control actuator.
Refer to Troubleshooting Fault Code 1749.

Last Modified: 01-Feb-2021


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 175

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 175 PID: SPN: 3464 FMI: 3/3 LAMP: Red SRT: | High current detected on the engine throttle actuator signal circuit. | Engine will shut down.
Throttle Actuator Position Circuit - Single Turbocharger
Throttle Actuator Position Circuit - Multiple Turbocharger with Two-Piece Throttle
Throttle Actuator Position Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The engine control module (ECM) controls the engine throttle actuator. The ECM can open and close the throttle based on the operating conditions in order to regulate air flow to the engine.

Component Location

The engine throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle actuator signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Throttle actuator is malfunctioning.
  • A damaged engine throttle actuator.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-175

Last Modified: 22-Feb-2021


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 176

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 176 PID: SPN: 3464 FMI: 4/4 LAMP: Red SRT: | Low current detected on the engine throttle actuator signal circuit. | Possible reduced engine performance.
Throttle Actuator Position Circuit - Single Turbocharger
Throttle Actuator Position Circuit - Multiple Turbocharger with Two-Piece Throttle
Throttle Actuator Position Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The engine control module (ECM) controls the engine throttle actuator. The ECM can open and close the throttle based on the operating conditions in order to regulate air flow to the engine.

Component Location

The engine throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle actuator signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Throttle actuator is malfunctioning.
  • A damaged engine throttle actuator.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-176

Last Modified: 22-Feb-2021


Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

FAULT CODE 1791

Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

Printable Version Printable Version

Overview

Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

CODE | REASON | EFFECT
Fault Code: 1791 PID: SPN: 1204 FMI: 31 LAMP: Shut down SRT: | Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists. The calculated difference between the desired and actual engine speed is greater than the critical threshold for a set persistence time. | The engine will shut down.
Engine Speed and Speed Bias Circuit - QSV81/91G Multiple Turbochargers with Two-Piece Throttles using Generator Control Panel 1 (GCP1) and PowerCommand™ Supervisor (PCS) 3100 Control Panel
Engine Speed and Speed Bias Circuit - QSV91G Single and Multiple Turbochargers with Integrated Throttle using Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor (PCS) 3100 Control Panel
Engine Speed and Speed Bias Circuit - QSV91G Single and Multiple Turbochargers with Integrated Throttles using PowerCommand™ Control (PCC) 3300 Control Panel

Circuit Description

This feature provides diagnostics in order to prevent the engine from losing speed and/or power or failing to meet demand for indefinite periods of time.

When operating in Isolate Bus applications, the ECM monitors engine speed via the engine speed sensor mounted at the flywheel. The engine speed signal is monitored by the CM700 module.

When operating in Utility/Grid Parallel applications, the ECM monitors the speed bias demand signal. The engine speed sensor is mounted at the flywheel and its signal is monitored by the Generator Set Control Panel (PowerCommand™ Supervisor 3100 or PowerCommand™ Control 3300). The Generator Set Control Panel sends a speed bias command signal to the CM700 module so that the load demand is met (up to 100 percent of Generator Set rated output).

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If Fault Code 1791 is activated during load ramp up, the most probable causes are as follows:

  • Generator set control panel: Ramp load time incorrect (load being applied too quickly). The ramp load time has been changed to a lower value than the default value of 120 seconds.
  • Air/Fuel ratio too lean; this may also cause multiple cylinder misfires and multiple low cylinder exhaust temperatures.
  • Intake filters restriction.

Any fuel system-related faults, such as:

  • Fuel supply pressure too low
  • Fuel control valve-related fault
  • Throttle driver or actuator-related fault
  • Fuel system sensor faults (Fuel Inlet Pressure Sensor, Fuel Outlet Pressure Sensor, Gas Mass Flow Sensor, Intake Manifold Pressure Sensor, Intake Manifold Temperature Sensor, High Temperature Coolant Temperature Sensor, Generator Set kW Signal)

If Fault Code 1791 is activated when the engine is operating at a steady state condition, the most probable causes are as follows:

  • Air inlet temperature too high, resulting in loss of throttle margin.
  • Incorrect throttle valve adjustment.
  • Generator set control panel voltage/amps calibration incorrect, resulting in a mismatch between actual kW load and calculated kW load. This can result in the generator set running overload, but the control panel indicates 100 percent load.
  • Air/Fuel ratio too lean; this may also result in multiple cylinder misfires and low cylinder exhaust temperatures.
  • High low temperature (LT) coolant circuit temperature.
  • Turbocharger compressor bypass valve malfunctioned in the open position or not connected (QSK60G Single Turbocharger generator set only).
  • Turbocharger wear.

If Fault Code 1791 is activated, always check for multiple active or inactive fault codes and fully investigate before replacing the turbocharger(s).

Refer to Troubleshooting Fault Code t05-1791

Last Modified: 27-Oct-2011


Unexpected Thermal Event - Condition Exists

FAULT CODE 1794

Unexpected Thermal Event - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1794 PID: SPN: 520335 FMI: 31 LAMP: Shutdown SRT: | Unexpected Thermal Event - Condition Exists. An Unexpected Thermal Event Has Occurred. | Engine will shutdown.
Engine Control Module (ECM)

Circuit Description

Important Note: Comply with all site fire procedures, as well as national and local regulations. Evacuate the buildings and proceed to the designated fire assembly area.

If the source of the fire alarm activation was found to be local to the generator set, do not enter the engine room or container until it has been confirmed as safe to do so by local health and safety executive personnel and they have authorized entry.

The generator set must not be re-started until authorized by local health and safety executive personnel. This troubleshooting procedure must be followed and any identified issues rectified before attempting to re-start the generator set.

Note: This document does not override or replace any local legislation or regulations.

Most engine rooms or generator set containers will be equipped with some form of fire detection equipment in order to comply with local legislation. Typically, such fire detection equipment will be interfaced with the generator set controls, so that if the fire detection equipment is activated for any reason, any running generator sets will be brought to an immediate stop with a critical shutdown.

Engine auxiliaries, such as coolant and lube oil circulation pumps, will also be isolated.

The generator set control system may also be interfaced with any site fire alarm system and may be tripped as a result of the site fire alarm being activated.

Component Location

Reference the site specific installation schematics for the component location.

Shop Talk

Maintaining a running natural gas fueled generator set during a possible fire situation is undesirable; therefore, it is common to have the generator sets linked to site fire alarm systems so that any running generator sets will be brought to an immediate stop.

Once the cause of the fire alarm has been investigated and resolved, by suitably qualified and authorized personnel, the engine room/container fire protection system will need to be reset before Fault Code 1794 can be cleared and the generator set restarted.

Note: The fire detection system alarm reset procedure detailed in this procedure refers to the generator plant room or container local system. Any main site system reset procedure is outside of the scope of this document and must only be undertaken by local authorized personnel.

Refer to Troubleshooting Fault Code t05-1794.

Last Modified: 23-Sep-2014


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1837

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

CODE | REASON | EFFECT
Fault Code: 1837 PID: SPN: 723 FMI: 2 LAMP: Stop / Shutdown SRT: | The Engine Control Module (ECM) has detected the camshaft engine speed sensor signal is erratic. | Engine will shut down.
Camshaft Position Sensor

Circuit Description

The camshaft engine position sensor provides engine speed information to the engine control module (ECM). The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the camshaft.

Component Location

The engine camshaft position sensor is located on the side of the front gear cover housing in the lower left quadrant.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a lost or erratic camshaft engine speed sensor signal.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails. The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged camshaft position sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-1837

Last Modified: 22-Mar-2022


Fault Code Path Selection

FAULT CODE 187
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc187st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc187mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc187mt

Last Modified: 25-Feb-2004


Sensor Supply Circuit Number 2 — Shorted Low

FAULT CODE 187 - Multiple Turbocharger with Integrated Throttle

Sensor Supply Circuit Number 2 — Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 2 — Shorted Low

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4 LAMP: Warning SRT: | Sensor Supply Number 2 supply signal is shorted low. | Possible reduced engine performance or shutdown. Pressure sensor shorted low faults likely.
Sensor Supply Circuit Number 2

Circuit Description

Sensor Supply Circuit Number 2 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-187mt

Last Modified: 31-Oct-2011


Sensor Supply Circuit Number 2 — Shorted Low

FAULT CODE 187 - Multiple Turbocharger with a Two-piece Throttle

Sensor Supply Circuit Number 2 — Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 2 — Shorted Low

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4 LAMP: Warning SRT: | Sensor Supply Number 2 supply signal is shorted low. | Possible reduced engine performance or shutdown. Pressure sensor shorted low faults likely.
Sensor Supply Circuit Number 2

Circuit Description

Sensor Supply Circuit Number 2 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-187mttt

Last Modified: 31-Oct-2011


Sensor Supply Circuit Number 2 — Shorted Low

FAULT CODE 187 - Single Turbocharger

Sensor Supply Circuit Number 2 — Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 2 — Shorted Low

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4 LAMP: Warning SRT: | Sensor Supply Number 2 supply signal is shorted low. | Possible reduced engine performance or shutdown. Pressure sensor shorted low faults likely.
Sensor Supply Circuit Number 2

Circuit Description

Sensor Supply Circuit Number 2 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-187st

Last Modified: 31-Oct-2011


Engine Coolant Temperature Sensor Circuit (Low Temperature) - Shorted High

FAULT CODE 2111

Engine Coolant Temperature Sensor Circuit (Low Temperature) - Shorted High

Printable Version Printable Version

Overview

Engine Coolant Temperature Sensor Circuit (Low Temperature) - Shorted High

CODE | REASON | EFFECT
Fault Code: 2111 PID: SPN: 52 FMI: 3 LAMP: Warning SRT: | The Engine Coolant Temperature Sensor signal (Low Temperature) is shorted high. | No engine protection for the Engine Coolant Temperature (Low Temperature). Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit (Low Temperature)

Circuit Description

The Engine Coolant Temperature Sensor (Low Temperature) is used by the CM700 to monitor the temperature of the coolant in the low temperature coolant circuit.

If the voltage is high the CM700 will log Fault Code 2111. Voltage high can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Reference the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-2111

Last Modified: 31-Oct-2011


Engine Coolant Temperature Sensor Circuit (Low Temperature) - Shorted Low

FAULT CODE 2112

Engine Coolant Temperature Sensor Circuit (Low Temperature) - Shorted Low

Printable Version Printable Version

Overview

Engine Coolant Temperature Sensor Circuit (Low Temperature) - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2112 PID: SPN: 52 FMI: 4 LAMP: Warning SRT: | The Engine Coolant Temperature Sensor signal (Low Temperature) is shorted low. | No engine protection for the Engine Coolant Temperature (Low Temperature). Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit (Low Temperature)

Circuit Description

The Engine Coolant Temperature Sensor (Low Temperature) is used by the CM700 to monitor the temperature of the coolant in the low temperature coolant circuit.

If the voltage is low the CM700 will log Fault Code 2112. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded, failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Reference the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-2112

Last Modified: 31-Oct-2011


Engine Coolant Temperature (Low Temperature) High - Warning

FAULT CODE 2113

Engine Coolant Temperature (Low Temperature) High - Warning

Printable Version Printable Version

Overview

Engine Coolant Temperature (Low Temperature) High - Warning

CODE | REASON | EFFECT
Fault Code: 2113 PID: SPN: 52 FMI: 16 LAMP: Warning SRT: | The engine coolant temperature (low temperature) has exceeded the high warning threshold. | No effect on engine performance.
Engine Coolant Temperature Sensor Circuit (Low Temperature)

Circuit Description

The coolant temperature (low temperature) is used by the CM700 to monitor the temperature of the engine coolant. Coolant temperature is used by the CM700 for the engine protection system, timing, and fueling control.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine coolant temperature (low temperature) has exceeded the warning threshold.

Refer to Troubleshooting Fault Code t05-2113

Last Modified: 27-Oct-2011


Engine Coolant Temperature Number 2 (Low Temperature) High— Critical

FAULT CODE 2114

Engine Coolant Temperature Number 2 (Low Temperature) High— Critical

Printable Version Printable Version

Overview

Engine Coolant Temperature Number 2 (Low Temperature) High— Critical

CODE | REASON | EFFECT
Fault Code: 2114 PID: SPN: 52 FMI: 0 LAMP: Shutdown SRT: | The engine coolant temperature (low temperature) has exceeded the high critical threshold. | Engine will shut down.
Engine Coolant Temperature Number 2 (Low Temperature) High— Critical

Circuit Description

The coolant temperature (low temperature) is used by the CM700 to monitor the temperature of the engine coolant. Coolant temperature is used by the CM700 for the engine protection system, timing, and fueling control.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The engine coolant temperature (low temperature) has exceeded the critical threshold.

Refer to Troubleshooting Fault Code t05-2114

Last Modified: 27-Oct-2011


Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2115

Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2115 PID: SPN: 2981 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the coolant circuit pressure sensor circuit. | Possible reduced engine performance.
Low Temperature Coolant Pressure Sensor Circuit

Circuit Description

The low temperature coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The low temperature coolant pressure sensor is located in the coolant circuit piping connected to the aftercooler on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the low temperature coolant circuit pressure signal voltage was out of range High.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged low temperature coolant pressure sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2115

Last Modified: 18-Mar-2022


Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2116

Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 2116 PID: SPN: 2981 FMI: 4 LAMP: Warning SRT: | Low signal voltage detected at the coolant circuit pressure sensor circuit. | Possible reduced engine performance.
Low Temperature Coolant Pressure Sensor Circuit

Circuit Description

The low temperature coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The low temperature coolant pressure sensor is located in the coolant circuit piping connected to the aftercooler on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the low temperature coolant circuit pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged low temperature coolant pressure sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2116

Last Modified: 18-Mar-2022


Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2117

Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2117 PID: SPN: 2981 FMI: 18 LAMP: Warning SRT: | The coolant circuit pressure sensor is below the engine protection warning limit. | No effect on engine performance.
Low Temperature Coolant Pressure Sensor Circuit

Circuit Description

The low temperature coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The low temperature coolant pressure sensor is located in the coolant circuit piping connected to the aftercooler on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the low temperature coolant circuit pressure sensor was below the engine protection warning limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged low temperature coolant pressure sensor
  • Damaged or loose connectors
  • Low coolant level
  • Malfunctioning or damaged water pump.
Refer to Troubleshooting Fault Code t05-2117

Last Modified: 18-Mar-2022


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 212 PID: 175 SPN: 175 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the oil temperature sensor circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The controller monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. When the oil temperature is warm, the sensor resistance is low.

Component Location

The oil temperature sensor is located on the lubricating oil cooler housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil temperature sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-212

Last Modified: 26-Apr-2022


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2121

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2121 PID: SPN: 1137 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature. The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2121

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2122

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2122 PID: SPN: 1139 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2122

Last Modified: 24-Mar-2022


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2123

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2123 PID: SPN: 1141 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2123

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2124

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2124 PID: SPN: 1143 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2124

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2125

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2125 PID: SPN: 1145 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2125

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2126

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2126 PID: SPN: 1147 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2126

Last Modified: 24-Mar-2022


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2127

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2127 PID: SPN: 1149 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2127

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2128

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2128 PID: SPN: 1151 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2128

Last Modified: 24-Mar-2022


Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2129

Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2129 PID: SPN: 1153 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2129

Last Modified: 24-Mar-2022


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 213 PID: 175 SPN: 175 FMI: 4 LAMP: Warning SRT: | Low signal voltage detected at the oil temperature sensor circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The controller monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. When the oil temperature is warm, the sensor resistance is low.

Component Location

The oil temperature sensor is located on the lubricating oil cooler housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil temperature sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-213

Last Modified: 26-Apr-2022


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2131

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2131 PID: SPN: 1138 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2131

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2132

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2132 PID: SPN: 1140 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2132

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2133

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2133 PID: SPN: 1142 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2133

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2134

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2134 PID: SPN: 1144 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2134

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2135

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2135 PID: SPN: 1146 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2135

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2136

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2136 PID: SPN: 1148 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2136

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2137

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2137 PID: SPN: 1150 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2137

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2138

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2138 PID: SPN: 1152 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2138

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2139

Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2139 PID: SPN: 1154 FMI: 16 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2139

Last Modified: 05-Apr-2022


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 214 PID: 175 SPN: 175 FMI: 0 LAMP: Stop/Shutdown SRT: | The oil temperature has exceeded the critical limit. | The engine will shut down.
Engine Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The controller monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. When the oil temperature is warm, the sensor resistance is low.

Component Location

The oil temperature sensor is located on the lubricating oil cooler housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil temperature is above the critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil temperature sensor.
  • Damaged or loose connectors.
  • Malfunctioning or damaged lubricating oil cooler.
  • Internal engine damage.
Refer to Troubleshooting Fault Code t05-214

Last Modified: 26-Apr-2022


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2144

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 2144 PID: SPN: 1152 FMI: 0 LAMP: Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2144

Last Modified: 28-Mar-2022


Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2145

Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Above Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 2145 PID: SPN: 1154 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2145

Last Modified: 28-Mar-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 17 (A9) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2146

Exhaust Gas Temperature Sensor Circuit Cylinder 17 (A9) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 17 (A9) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 2146 PID: SPN: 1153 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2146

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 18 (B9) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2147

Exhaust Gas Temperature Sensor Circuit Cylinder 18 (B9) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 18 (B9) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 2147 PID: SPN: 1154 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2147

Last Modified: 06-Apr-2022


Engine Oil Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 215

Engine Oil Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Oil Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 215 PID: 175 SPN: 175 FMI: 1 LAMP: Stop/Shutdown SRT: | The oil temperature has dropped below the critical limit. | The engine will shut down.
Engine Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The controller monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. When the oil temperature is warm, the sensor resistance is low.

Component Location

The oil temperature sensor is located on the lubricating oil cooler housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil temperature is below the critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil temperature sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-215

Last Modified: 26-Apr-2022


Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2154

Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2154 PID: SPN: 3549 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the post-filter oil pressure sensor signal circuit. | No effect on engine performance.
Post-Filter Oil Pressure Sensor Circuit

Circuit Description

The post-filter oil pressure sensor monitors engine oil pressure as it exits the filter. post-filter oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The post-filter oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The post-filter oil pressure sensor is located on the lubricating oil cooler housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Post-Filter oil Pressure Sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged post-filter oil pressure sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2154

Last Modified: 18-Mar-2022


Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2155

Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 2155 PID: SPN: 3549 FMI: 4 LAMP: Warning SRT: | Low signal voltage detected at the post-filter oil pressure sensor signal circuit. | No effect on engine performance.
Post-Filter Oil Pressure Sensor Circuit

Circuit Description

The post-filter oil pressure sensor monitors engine oil pressure as it exits the filter. post-filter oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The post-filter oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The post-filter oil pressure sensor is located on the lubricating oil cooler housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Post-Filter oil pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged post-filter oil pressure sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2155

Last Modified: 17-Mar-2022


Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists

FAULT CODE 2191

Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2191 PID: 102 SPN: 102 FMI: 31 LAMP: Warning SRT: | Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists. The intake manifold pressure and compressor outlet pressure are mismatching. | Possible reduced engine performance.
Intake Manifold Pressure Sensor and Compressor Outlet Pressure Sensor Circuit - Multiple Turbochargers
Intake Manifold Pressure Sensor and Compressor Outlet Pressure Sensor Circuit - Single Turbocharger
Intake Manifold Absolute Pressure Sensor

Circuit Description

The turbocharger compressor outlet pressure sensor monitors the pressure of the air and fuel mixture after the turbocharger compressor outlet. The left-bank CM558 engine control module (ECM) provides a 5 volt supply to the compressor outlet pressure sensor on the sensor supply circuit. The left-bank CM558 also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the left-bank CM558 on the compressor outlet pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold before the throttle valve. The left-bank CM558 will detect a low signal voltage during operating conditions when the turbocharger outlet pressure is low. The left-bank CM558 will detect a high signal voltage during operating conditions when the turbocharger compressor outlet pressure is high.

The intake manifold pressure sensor monitors the absolute pressure of the air and fuel mixture in the intake manifold, immediately after the engine throttle valve. The left-bank CM558 ECM provides a 5 volt supply to the intake manifold absolute pressure sensor on the sensor supply circuit. The left-bank CM558 also provides a ground on the sensor return circuit. The intake manifold absolute pressure sensor provides a signal to the left-bank CM558 on the intake manifold absolute pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold after the throttle valve. The left-bank CM558 will detect a low signal voltage during operating conditions when the intake manifold pressure is low. The left-bank CM558 will detect a high signal voltage during operating conditions when the intake manifold pressure is high.

Component Location

The turbocharger compressor outlet pressure sensor is located in the free-end of the intake manifold, after the aftercooler and before the throttle valve.

The intake manifold absolute pressure sensor is mounted in the free-end of the intake manifold, after the throttle valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The pressure differential (delta P) between the turbocharger compressor outlet pressure sensor and the intake manifold pressure sensor has exceeded the pressure threshold for a period of 30 seconds and ignition timing retardation has reached the limit of adjustment.

Action Taken When the Fault Code is Active

The left-bank CM558 module illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 2191 will also be shown as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.

Conditions for Clearing the Fault Code

To validate the repair:

  • Start the engine and let it operate for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The left-bank CM558 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger compressor outlet pressure sensor is monitoring the boost pressure from the turbocharger(s) and the intake manifold pressure sensor is monitoring intake manifold pressure after the throttle plate.

The pressure differential (delta P) between the turbocharger compressor outlet pressure sensor and the intake manifold pressure sensor will vary according to the position of the throttle plate and as the throttle plate position increases, so the delta P decreases. This pressure differential is monitored by the left-bank CM558 module and is referred to as Throttle Margin.

If turbocharger boost pressure is low, then the ECM will command the throttle plate to open in order to try and maintain engine speed and load. At the same time, the engines ignition timing is retarded in order to try and recover turbocharger boost pressure. If turbocharger boost pressure remains low, the throttle plate position will again be increased and the ignition timing will be further retarded. Fault Code 2191 will be activated when the delta P threshold and limit of ignition timing retardation are reached. Due to the increased throttle plate position for a given load, throttle margin is lost and engine performance may be reduced as a result.

Throttle margin can be calculated using the following formula:

Turbocharger Compressor Outlet Pressure minus Intake Manifold Pressure divided by Turbocharger Compressor Outlet Pressure times 100 (%).

Throttle margin data can be interpreted as follows:
Throttle margin greater than 8% | Sufficient throttle margin for present operating conditions.
Throttle margin 6% to 8% | Approaching minimum throttle margin - schedule engine shut down to investigate.
Throttle margin less than 6% | Risk of instability and engine may be unlikely to maintain load - urgent investigation required. The engine may shutdown.

Throttle plate position can also give an indication of the engine's intake system condition and can be referenced to aid troubleshooting. For most applications, the throttle plate position should not exceed 60% at full/rated load.

Throttle position data can be interpreted as follows:
Throttle plate position less than 60% | Sufficient throttle valve margin for present operating conditions.
Throttle plate position 60% to 70% | Approaching minimum for stable governing - schedule shut down to investigate.
Throttle plate position greater than 70% | Unlikely to achieve or maintain load - urgent investigation required. The engine may shutdown.

Possible causes of this fault code include:

  • Engine operation at high altitude and applicable derate not applied
  • Engine operation at high ambient temperatures
  • Low temperature coolant circuit temperature too high
  • Incorrect exhaust emissions (air/fuel ratio too lean)
  • Turbocharger wear
  • Aftercooler core blocked
  • Engine air filters blocked
  • Exhaust back pressure too high
  • Engine room or container air inlet filters blocked
  • Compressor outlet pressure sensor malfunctioned, (sensor can fail in range so no fault code active)
  • Intake manifold pressure sensor malfunctioned (sensor can fail in range so no fault code active).

OEM supplied equipment can cause Fault Code 2191 to become active. OEM equipment must be installed and operating to manufacturer's specification. Refer to the OEM service manuals.

The intake manifold pressure sensor shares sensor return (-) wires with the intake manifold temperature sensor. Therefore, a fault in the sensor return (-) circuit will cause multiple fault codes to be active.

Before troubleshooting Fault Code 2191, check for multiple active fault codes.

Possible causes of this fault code include:

  • Malfunctioned compressor outlet pressure sensor
  • Malfunctioned intake manifold pressure sensor
  • Open circuit or short circuit (pin-to-pin or pin-to-ground) in the engine harness
  • High exhaust back pressure
  • Throttle plate misalignment.
Refer to Troubleshooting Fault Code t05-2191.

Last Modified: 05-Aug-2013


Engine Speed - Abnormal Rate of Change

FAULT CODE 2199

Engine Speed - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2199 PID: 190 SPN: 190 FMI: 10 LAMP: None SRT: | The Engine Control Module (ECM) has detected the crankshaft engine speed sensor signal is erratic. | Possible reduced engine performance.
Engine Speed Sensor Circuit – Single Turbocharger
Engine Speed Sensor Circuit – Multiple Turbocharger with Two-Piece Throttle
Engine Speed Sensor Circuit – Multiple Turbocharger with Integrated Throttle

Circuit Description

The Engine Speed Sensor monitors the engine speed by reading a pattern of holes drilled into the flywheel. There are two sensors mounted on the flywheel housing. Both coils of one sensor feed the ECM and the coils of the second sensor feed each of the ECM modules.

Component Location

The engine speed sensor is located on the side of the flywheel housing in the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a erratic or degraded signal from the engine speed sensor.

Action Taken When the Fault Code is Active

  • The generator set controller displays a fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged engine speed sensor.
  • Damaged tone wheel.
  • Sensor air gap that is marginally too small or too large.
Refer to Troubleshooting Fault Code t05-2199

Last Modified: 18-Apr-2022


Fuel Delivery Pressure High — Critical

FAULT CODE 2228

Fuel Delivery Pressure High — Critical

Printable Version Printable Version

Overview

Fuel Delivery Pressure High — Critical

CODE | REASON | EFFECT
Fault Code: 2228 PID: P135 SPN: 135 FMI: 0 LAMP: Shutdown SRT: | The fuel delivery pressure has exceeded the high critical threshold. | Engine will shut down.
Fuel Outlet Pressure Sensor Circuit

Circuit Description

The Fuel Outlet Pressure Sensor monitors the gas pressure as it exits the fuel control assembly. The pressure is monitored by the CM558 modules.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel outlet pressure is the gas pressure after the gas flow has been metered by the fuel control valve. This gas is introduced into the air box to mix with the intake air.

Refer to Troubleshooting Fault Code t05-2228

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 227
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc227st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc227mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc227mtit

Last Modified: 25-Feb-2004


Engine Coolant Level Shutdown

FAULT CODE 2279

Engine Coolant Level Shutdown

Printable Version Printable Version

Overview

Engine Coolant Level Shutdown

CODE | REASON | EFFECT
Fault Code: 2279 PID: FMI: 1 LAMP: Shutdown SRT: | Engine coolant level has been detected to be below a critical engine protection limit. | The engine will shut down.
Coolant Level Sensor Circuit - Single Turbocharger
Coolant Level Sensor Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine coolant level was below the critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged coolant Level sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2279

Last Modified: 18-Apr-2022


Sensor Supply Circuit Number 2 - Shorted High

FAULT CODE 227 - Multiple Turbocharger with Integrated Throttle

Sensor Supply Circuit Number 2 - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 2 - Shorted High

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 1080 FMI: 3 LAMP: Warning SRT: | Sensor supply number 2 supply signal is shorted high. | Possible reduced engine performance or shutdown. Pressure sensor shorted high faults likely.
Sensor Supply Circuit Number 2

Circuit Description

Sensor Supply Circuit Number 2 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires may cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-227mt

Last Modified: 31-Oct-2011


Sensor Supply Circuit Number 2 - Shorted High

FAULT CODE 227 - Multiple Turbocharger with a Two-piece Throttle

Sensor Supply Circuit Number 2 - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 2 - Shorted High

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 1080 FMI: 3 LAMP: Warning SRT: | Sensor supply number 2 supply signal is shorted high. | Possible reduced engine performance or shutdown. Pressure sensor shorted high faults likely.
Sensor Supply Circuit Number 2

Circuit Description

Sensor Supply Circuit Number 2 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires may cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 for the component location.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-227mttt

Last Modified: 31-Oct-2011


Sensor Supply Circuit Number 2 - Shorted High

FAULT CODE 227 - Single Turbocharger

Sensor Supply Circuit Number 2 - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 2 - Shorted High

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 1080 FMI: 3 LAMP: Warning SRT: | Sensor supply number 2 supply signal is shorted high. | Possible reduced engine performance or shutdown. Pressure sensor shorted high faults likely.
Sensor Supply Circuit Number 2

Circuit Description

Sensor Supply Circuit Number 2 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires may cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-227st

Last Modified: 31-Oct-2011


Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 228

Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 228 PID: 109 SPN: 109 FMI: 1 LAMP: Stop/Shutdown SRT: | The engine coolant pressure is below the engine protection critical limit. | The engine will shut down.
High Temperature Coolant Pressure Sensor Circuit

Circuit Description

The high temperature coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The high temperature coolant pressure sensor is located in the coolant circuit piping connected to the aftercooler on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure sensor signal voltage was below the critical limit.

Action Taken When the Fault Code is Active

  • The Engine Control Module (ECM) detected the coolant pressure sensor signal voltage was below the critical limit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged high temperature coolant pressure sensor.
  • Damaged or loose connectors.
  • Low coolant level.
  • Malfunctioning or damaged water pump.
Refer to Troubleshooting Fault Code t05-228

Last Modified: 26-Apr-2022


Engine Temperature Too Cold for High Idle Speed

FAULT CODE 2282

Engine Temperature Too Cold for High Idle Speed

Printable Version Printable Version

Overview

Engine Temperature Too Cold for High Idle Speed

CODE | REASON | EFFECT
Fault Code: 2282 PID: FMI: 31 LAMP: Warning SRT: | Engine too cold for rated speed - potential damage to engine can occur if run at rated speed until minimum operating temperature has been met. | ECM will prevent engine from reaching high idle until minimum operating temperature has been met.
ECM

Circuit Description

None

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The QSV81 and QSV91 engines have a protection feature that prevents the engine from running at high idle until the minimum temperature has been met. Once the minimum temperature has been met, the engine can be operated at high idle.

Refer to Troubleshooting Fault Code t05-2282

Last Modified: 27-Oct-2011


Waste Oil Reservoir Level - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2283

Waste Oil Reservoir Level - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

Waste Oil Reservoir Level - Data Valid But Above Normal Operating Range - Least Severe Level

CODE | REASON | EFFECT
Fault Code: 2283 PID: SPN: 3548 FMI: 15 LAMP: Warning SRT: | The waste oil reservoir tank level has been detected to be above the engine protection limit. | No effect on engine performance.
Waste Oil Reservoir Tank Level Sensor Circuit - Single Turbocharger
Waste Oil Reservoir Tank Level Sensor Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The waste oil reservoir tank level sensor monitors the fluid level within the waste oil tank and passes information to the ECM.

Component Location

The waste oil reservoir tank level sensor is located within the waste oil tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the waste oil reservoir level is above engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged waste oil reservoir tank level sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2283

Last Modified: 20-Apr-2022


Fault Code Path Selection

FAULT CODE 2288
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2288st
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc2288mt

Last Modified: 22-Oct-2004


Fuel Shutoff Valve Validation Module - Shorted High

FAULT CODE 2288 - Multiple Turbocharger with Integrated Throttle

Fuel Shutoff Valve Validation Module - Shorted High

Printable Version Printable Version

Overview

Fuel Shutoff Valve Validation Module - Shorted High

CODE | REASON | EFFECT
Fault Code: 2288 PID: FMI: 3 LAMP: Warning SRT: | High voltage detected on the Fuel Shutoff Valve Validation Module SIGNAL pin of the CM700. | Engine will not be able to start or fuel shutoff valve will not be tested.
Fuel Shutoff Valve Validation Module Circuit

Circuit Description

The Fuel Shutoff Valve Validation Module checks the integrity of the Fuel Shutoff Valve through an automatic testing sequence after a normal engine shutdown or following an emergency stop. The Fuel Shutoff Valve Validation Module pressurizes a chamber between the two closed valves on the Fuel Shutoff Valve. It the Fuel Shutoff Valve test is successful, a relay circuit will be completed allowing a contact to close for the CM700. Then the engine will be allowed to start.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-2288mt

Last Modified: 27-Oct-2011


Fuel Shutoff Valve Validation Module - Shorted High

FAULT CODE 2288 - Single Turbocharger

Fuel Shutoff Valve Validation Module - Shorted High

Printable Version Printable Version

Overview

Fuel Shutoff Valve Validation Module - Shorted High

CODE | REASON | EFFECT
Fault Code: 2288 PID: FMI: 3 LAMP: Warning SRT: | High voltage detected on the Fuel Shutoff Valve Validation Module SIGNAL pin of the CM700. | Engine will not be able to start or fuel shutoff valve will not be tested.
Fuel Shutoff Valve Validation Module Circuit

Circuit Description

The Fuel Shutoff Valve Validation Module checks the integrity of the Fuel Shutoff Valve through an automatic testing sequence after a normal engine shutdown or following an emergency stop. The Fuel Shutoff Valve Validation Module pressurizes a chamber between the two closed valves on the Fuel Shutoff Valve. It the Fuel Shutoff Valve test is successful, a relay circuit will be completed allowing a contact to close for the CM700. Then the engine will be allowed to start.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-2288st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 2289
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2289st
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc2289mt

Last Modified: 22-Oct-2004


Fuel Shutoff Valve Validation Module - Shorted Low

FAULT CODE 2289 - Multiple Turbocharger with Integrated Throttle

Fuel Shutoff Valve Validation Module - Shorted Low

Printable Version Printable Version

Overview

Fuel Shutoff Valve Validation Module - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2289 PID: FMI: 31 LAMP: Warning SRT: | Low voltage detected on the Fuel Shutoff Valve Validation Module SIGNAL pin of the CM700. | Engine will not be able to start or the Fuel Shutoff Valve will not be tested.
Fuel Shutoff Valve Validation Module Circuit

Circuit Description

The Fuel Shutoff Valve Validation Module checks the integrity of the fuel shutoff valve through an automatic testing sequence after a normal engine shutdown or following an emergency stop. The Fuel Shutoff Valve Validation Module pressurizes a chamber between the two closed valves on the Fuel Shutoff Valve. It the Fuel Shutoff Valve test is successful, a relay circuit will be completed allowing a contact to close for the CM700. Then the engine will be allowed to start.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-2289mt

Last Modified: 27-Oct-2011


Fuel Shutoff Valve Validation Module - Shorted Low

FAULT CODE 2289 - Single Turbocharger

Fuel Shutoff Valve Validation Module - Shorted Low

Printable Version Printable Version

Overview

Fuel Shutoff Valve Validation Module - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2289 PID: FMI: 31 LAMP: Warning SRT: | Low voltage detected on the Fuel Shutoff Valve Validation Module SIGNAL pin of the CM700. | Engine will not be able to start or the Fuel Shutoff Valve will not be tested.
Fuel Shutoff Valve Validation Module Circuit

Circuit Description

The Fuel Shutoff Valve Validation Module checks the integrity of the fuel shutoff valve through an automatic testing sequence after a normal engine shutdown or following an emergency stop. The Fuel Shutoff Valve Validation Module pressurizes a chamber between the two closed valves on the Fuel Shutoff Valve. It the Fuel Shutoff Valve test is successful, a relay circuit will be completed allowing a contact to close for the CM700. Then the engine will be allowed to start.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-2289st

Last Modified: 27-Oct-2011


Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 231

Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 231 PID: 109 SPN: 109 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the coolant pressure sensor circuit. | Possible reduced engine performance.
High Temperature Coolant Pressure Sensor Circuit

Circuit Description

The high temperature coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The high temperature coolant pressure sensor is located in the coolant circuit piping connected to the aftercooler on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged high temperature coolant pressure sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-231

Last Modified: 29-Apr-2022


Fault Code Path Selection

FAULT CODE 2311
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2311st
Is this engine equipped with a Multiple Turbochargers? | Go to 55-fc2311mt

Last Modified: 03-Apr-2012


Engine Electronic Fuel Control Valve 1 Circuit - Condition Exists

FAULT CODE 2311 - Multiple Turbcharger

Engine Electronic Fuel Control Valve 1 Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: N/A SPN: 633 FMI: 31 LAMP: Warning SRT: N/A | Engine Electronic Fuel Control Valve 1 Circuit - Condition Exists. An error has been detected in the left-bank electronic fuel control valve circuit. | The engine will continue to operate, but performance may be impaired.
QSV91G Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

FCV 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module. This FCV is located at the front of the engine (free-end).

FCV 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. For QSV91G single turbocharger engines, the FCV 2 is only fitted to low BTU fueled engines.

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 2311 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit. This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness, or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position, PWM percentage duty cycle, and VDC feedback signal specifications.

Troubleshooting Fuel Control Valve Operation
Actuator Commanded Position | PWD Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 89 | 4.6 to 4.8

NOTE: PWM percentage of duty cycle signals can only be measured with multimeters or other measuring devices that have a percentage of duty cycle function.

Refer to Troubleshooting Fault Code t05-2311.

Last Modified: 10-Feb-2012


Electronic Fuel Control Valve 1 Circuit - Condition Exists

FAULT CODE 2311 - Single Turbocharger

Electronic Fuel Control Valve 1 Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: N/A SPN: 633 FMI: 31 LAMP: Warning SRT: N/A | Electronic Fuel Control Valve 1 Circuit - Condition Exists. An error has been detected in the left-bank electronic fuel control valve circuit. | The engine will continue to operate but performance may be impaired.
QSV91G Single Turbocharger with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Single Turbocharger with PowerCommand™ Control 3300 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Single Turbocharger Low Btu Generator Sets with PowerCommand™ Control 3300 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

FCV 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module.

FCV 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. For QSV91G single turbocharger engines, the FCV 2 is only fitted to low BTU fueled engines.

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 2311 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness, or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position, PWM percent duty cycle and VDC feedback signal specifications.

Troubleshooting FCV Operation
Actuator Commanded Position | PWM Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 89 | 4.6 to 4.8

NOTE: PWM percent of duty cycle signals can only be measured with multimeters or other measuring devices that have a percent of duty cycle function.

Refer to Troubleshooting Fault Code t05-2311.

Last Modified: 10-Feb-2012


Fault Code Path Selection

FAULT CODE 2313
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2313st
Is this engine equipped with a Multiple Turbochargers? | Go to 55-fc2313mt

Last Modified: 03-Apr-2012


Engine Electronic Fuel Control Valve 2 Circuit - Condition Exists

FAULT CODE 2313 - Multiple Turbochargers

Engine Electronic Fuel Control Valve 2 Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2313 PID: N/A SPN: 1244 FMI: 31 LAMP: Warning SRT: N/A | Engine Electronic Fuel Control Valve 2 Circuit - Condition Exists. An error has been detected in the right-bank electron fuel control valve 2 circuit. | The engine will continue to operate, but performance may be impaired.
QSV91G Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

FCV 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module. This FCV is located at the front of the engine (free-end).

FCV 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. This FCV is located at the rear of the engine (flywheel end).

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 2313 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit. This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness, or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustment of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position, PWM percent duty cycle and VDC feedback signal specifications.

Troubleshooting FCV Operation
Actuator Commanded Position | PWM Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 89 | 4.6 to 4.8

NOTE: PWM percentage of duty cycle signals can only be measured with multimeters or other measuring devices that have a percent of duty cycle function.

Refer to Troubleshooting Fault Code t05-2313.

Last Modified: 10-Feb-2012


Engine Electronic Fuel Control Valve 2 Circuit - Condition Exists

FAULT CODE 2313 - Single Turbocharger

Engine Electronic Fuel Control Valve 2 Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2313 PID: SPN: 1244 FMI: 31 LAMP: warning SRT: | Engine Electronic Fuel Control Valve 2 Circuit - Condition Exists. Error on right-bank electronic Fuel Control Valve 2 circuit. | The engine will continue to run but performance may be impaired.
QSV91G Single Turbocharger Low BTU Generator Sets with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel Control Valve 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module.

Fuel Control Valve 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. For QSV91G single turbocharger engines, the Fuel Control Valve 2 is only fitted to low btu fueled engines.

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 2313 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

Possible causes of this fault code include:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn, or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCVor engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustments of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator position, commanded PWM percentage duty cycle, and voltage feedback signal specifications.

Actuator Commanded Position | Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

PWM percentage duty cycle signals can only be measured using a multimeter or other measuring device that has a percentage duty cycle function.

Refer to Troubleshooting Fault Code t05-2313st.

Last Modified: 30-Jan-2012


Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 232

Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 232 PID: 109 SPN: 109 FMI: 4 LAMP: Warning SRT: | Low signal voltage detected at the coolant pressure sensor circuit. | Possible reduced engine performance.
High Temperature Coolant Pressure Sensor Circuit

Circuit Description

The high temperature coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The high temperature coolant pressure sensor is located in the coolant circuit piping connected to the aftercooler on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged high temperature coolant pressure sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-232

Last Modified: 29-Apr-2022


Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 233

Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 233 PID: 109 SPN: 109 FMI: 18 LAMP: Warning SRT: | The engine coolant pressure is below the engine protection warning limit. | No effect on engine performance.
High Temperature Coolant Pressure Sensor Circuit

Circuit Description

The high temperature coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The high temperature coolant pressure sensor is located in the coolant circuit piping connected to the aftercooler on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine coolant pressure was below the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged high temperature coolant pressure sensor.
  • Damaged or loose connectors.
  • Low coolant level.
  • Malfunctioning or damaged water pump.
Refer to Troubleshooting Fault Code t05-233

Last Modified: 17-May-2022


Engine Overspeed

FAULT CODE 234

Engine Overspeed

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0 LAMP: Stop/Shutdown SRT: | Engine speed signal indicates engine speed above engine protection limit. | Engine will shut down.
Engine Speed Sensor Circuit – Single Turbocharger
Engine Speed Sensor Circuit – Multiple Turbocharger with Two-Piece Throttle
Engine Speed Sensor Circuit – Multiple Turbocharger with Integrated Throttle

Circuit Description

The Engine/Speed Position Sensor(s) monitor the engine position and the engine speed. They then pass this information to the ECM through the engine wiring harness. The engine speed sensor is a dual coil circuit that provides the engine speed signal to each engine control module through the engine wiring harness.

Component Location

The engine speed sensor is located on engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage.
  • Reverse powering (motoring) of the engine.
  • Damaged or loose connectors.
  • Malfunctioning or damaged engine speed sensor.
Refer to Troubleshooting Fault Code t05-234.

Last Modified: 17-May-2022


Fault Code Path Selection

FAULT CODE 2361
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2361st
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc2361mt

Last Modified: 22-Oct-2004


Fuel Shutoff Valve Validation - Test Failed

FAULT CODE 2361 - Multiple Turbocharger

Fuel Shutoff Valve Validation - Test Failed

Printable Version Printable Version

Overview

Fuel Shutoff Valve Validation - Test Failed

CODE | REASON | EFFECT
Fault Code: 2361 PID: SPN: 175 FMI: 31 LAMP: Warning SRT: | Fuel Shutoff Valve Validation Module has failed to test or the Fuel Shutoff Valve has failed to automatic test. | Engine will not be allowed to start.
Fuel Shutoff Valve Validation Module Circuit

Circuit Description

The Fuel Shutoff Valve Validation Module checks the integrity of the Fuel Shutoff Valve through an automatic testing sequence after a normal engine shutdown or following an emergency stop. The Fuel Shutoff Valve Validation Module pressurizes the chamber between the two closed valves of the Fuel Shutoff Valve. If the Fuel Shutoff Valve test is successful a relay will be completed allowing a contact to close for the CM700. The engine will then be allowed to start.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-2361mt

Last Modified: 23-Apr-2012


Fuel Shutoff Valve Validation - Test Failed

FAULT CODE 2361 - Single Turbocharger

Fuel Shutoff Valve Validation - Test Failed

Printable Version Printable Version

Overview

Fuel Shutoff Valve Validation - Test Failed

CODE | REASON | EFFECT
Fault Code: 2361 PID: SPN: 175 FMI: 31 LAMP: Warning SRT: | Fuel Shutoff Valve Validation Module has failed to test or the Fuel Shutoff Valve has failed to automatic test. | Engine will not be allowed to start.
Fuel Shutoff Valve Validation Module Circuit

Circuit Description

The Fuel Shutoff Valve Validation Module checks the integrity of the Fuel Shutoff Valve through an automatic testing sequence after a normal engine shutdown or following an emergency stop. The Fuel Shutoff Valve Validation Module pressurizes the chamber between the two closed valves of the Fuel Shutoff Valve. If the Fuel Shutoff Valve test is successful a relay will be completed allowing a contact to close for the CM700. The engine will then be allowed to start.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-2361st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 2364
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2364st
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc2364mt

Last Modified: 22-Oct-2004


Fuel Shutoff Valve Validation - Test Failed

FAULT CODE 2364 - Multiple Turbocharger with Integrated Throttle

Fuel Shutoff Valve Validation - Test Failed

Printable Version Printable Version

Overview

Fuel Shutoff Valve Validation - Test Failed

CODE | REASON | EFFECT
Fault Code: 2364 PID: SPN: 175 FMI: 31 LAMP: Shutdown SRT: | Fuel Shutoff Valve Validation Module has failed to test or the Fuel Shutoff Valve has failed to automatic test. | Engine will not be allowed to start.
Fuel Shutoff Valve Validation Module Circuit

Circuit Description

The Fuel Shutoff Valve Validation Module checks the integrity of the Fuel Shutoff Valve through an automatic testing sequence after a normal engine shutdown or following an emergency stop. The Fuel Shutoff Valve Validation Module pressurizes the chamber between the two closed valves of the Fuel Shutoff Valve. If the Fuel Shutoff Valve test is successful a relay will be completed allowing a contact to close for the CM700. The engine will then be allowed to start.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-2364mt

Last Modified: 27-Oct-2011


Fuel Shutoff Valve Validation - Test Failed

FAULT CODE 2364 - Single Turbocharger

Fuel Shutoff Valve Validation - Test Failed

Printable Version Printable Version

Overview

Fuel Shutoff Valve Validation - Test Failed

CODE | REASON | EFFECT
Fault Code: 2364 PID: SPN: 175 FMI: 31 LAMP: Shutdown SRT: | Fuel Shutoff Valve Validation Module has failed to test or the Fuel Shutoff Valve has failed to automatic test. | Engine will not be allowed to start.
Fuel Shutoff Valve Validation Module Circuit

Circuit Description

The Fuel Shutoff Valve Validation Module checks the integrity of the Fuel Shutoff Valve through an automatic testing sequence after a normal engine shutdown or following an emergency stop. The Fuel Shutoff Valve Validation Module pressurizes the chamber between the two closed valves of the Fuel Shutoff Valve. If the Fuel Shutoff Valve test is successful a relay will be completed allowing a contact to close for the CM700. The engine will then be allowed to start.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Refer to Troubleshooting Fault Code t05-2364st

Last Modified: 27-Oct-2011


Sensor Supply Circuit Number 3 - Shorted Low

FAULT CODE 238

Sensor Supply Circuit Number 3 - Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 3 - Shorted Low

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 620 FMI: 4 LAMP: Warning SRT: | Sensor supply number 3 supply signal is shorted low. | Possible reduced engine performance or shutdown. Gas Mass Flow Sensor shorted low fault likely.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

Sensor supply circuit number 3 from the CM558 module supplies the Gas Mass Flow Sensor with a positive (+) 14 VDC supply. A fault on either of these wires may cause multiple sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed sensor can cause multiple fault codes. A failed sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-238

Last Modified: 31-Oct-2011


Sensor Supply Circuit Number 3 - Shorted High

FAULT CODE 239

Sensor Supply Circuit Number 3 - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 3 - Shorted High

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 620 FMI: 4 LAMP: Warning SRT: | Sensor supply number 3 supply signal is shorted high. | Possible reduced engine performance or shutdown. Gas Mass Flow Sensor shorted high fault likely.
Sensor Supply Voltage Number 3 Circuit

Circuit Description

Sensor Supply Circuit Number 3 from the CM558 module supplies the Gas Mass Flow Sensor with a positive (+) 14 VDC supply. A fault on either of these wires may cause multiple sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed sensor can cause multiple fault codes. A failed sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-239

Last Modified: 31-Oct-2011


Fuel Outlet Pressure Sensor Circuit - Shorted High

FAULT CODE 2427

Fuel Outlet Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Outlet Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 2427 PID: SPN: FMI: 3 LAMP: Warning SRT: | High voltage detected on the Fuel Outlet Pressure Sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Fuel Outlet Pressure Sensor Circuit

Circuit Description

The Fuel Outlet Pressure Sensor monitors the gas pressure as it exits the fuel control assembly. The pressure is monitored by the CM558 modules. High voltage will cause Fault Code 2427 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel outlet pressure is the gas pressure after the gas flow has been metered by the fuel control valve. This gas is introduced into the air box to mix with the intake air.

Refer to Troubleshooting Fault Code t05-2427

Last Modified: 27-Oct-2011


Fuel Outlet Pressure Sensor Circuit - Shorted Low

FAULT CODE 2428

Fuel Outlet Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Outlet Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2428 PID: SPN: FMI: 4 LAMP: Warning SRT: | Low voltage detected on the Fuel Outlet Pressure Sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Fuel Outlet Pressure Sensor Circuit

Circuit Description

The Fuel Outlet Pressure Sensor monitors the gas pressure as it exits the fuel control assembly. The pressure is monitored by the CM558 modules. Low voltage will cause Fault Code 2428 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel outlet pressure is the gas pressure after the gas flow has been metered by the fuel control valve. This gas is introduced into the air box to mix with the intake air.

Refer to Troubleshooting Fault Code t05-2428

Last Modified: 27-Oct-2011


Engine Coolant Pressure (Low Temperature) Low — Critical

FAULT CODE 2429

Engine Coolant Pressure (Low Temperature) Low — Critical

Printable Version Printable Version

Overview

Engine Coolant Pressure (Low Temperature) Low - Critical

CODE | REASON | EFFECT
Fault Code: 2429 PID: FMI: 1 LAMP: Shutdown SRT: | The engine coolant pressure is below the engine protection critical limit. | The engine will shut down.
Low Temperature Coolant Pressure Sensor Circuit

Circuit Description

The low temperature coolant pressure sensor is a variable resistance sensor used by the ECM to monitor the coolant pressure. The coolant pressure sensor has three circuits: 5 volt supply, return and signal circuits. The signal circuit voltage indicates the coolant pressure in the engine cooling system.

Component Location

The low temperature coolant pressure sensor is located in the coolant circuit piping connected to the aftercooler on the right bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the low temperature coolant circuit pressure sensor was below the engine protection critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged low temperature coolant pressure sensor
  • Damaged or loose connectors
  • Low coolant level
  • Malfunctioning or damaged water pump.
Refer to Troubleshooting Fault Code t05-2429

Last Modified: 18-Mar-2022


Fault Code Path Selection

FAULT CODE 2442
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2442st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc2442mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc2442mt

Last Modified: 03-Mar-2004


Left Bank Capacitive Coil Driver Failed

FAULT CODE 2442 - Multiple Turbocharger with Integrated Throttle

Left Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Left Bank Capacitive Coil Driver Failed

CODE | REASON | EFFECT
Fault Code: 2442 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | The number of misfiring cylinders has exceeded the critical threshold. | The engine will shut down.
Left Bank Capacitive Coil Driver Failed

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil-on-plugs.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Be sure to verify that there is a 24 VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2442mt

Last Modified: 31-Oct-2011


Left Bank Capacitive Coil Driver Failed

FAULT CODE 2442 - Multiple Turbocharger with a Two-piece Throttle

Left Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Left Bank Capacitive Coil Driver Failed

CODE | REASON | EFFECT
Fault Code: 2442 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | The number of misfiring cylinders has exceeded the critical threshold. | The engine will shut down.
Left Bank Capacitive Coil Driver Failed

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil-on-plugs.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Be sure to verify that there is a 24 VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2442mttt

Last Modified: 31-Oct-2011


Left Bank Capacitive Coil Driver Failed

FAULT CODE 2442 - Single Turbocharger

Left Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Left Bank Capacitive Coil Driver Failed

CODE | REASON | EFFECT
Fault Code: 2442 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | The number of misfiring cylinders has exceeded the critical threshold. | The engine will shut down.
Left Bank Capacitive Coil Driver Failed

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil-on-plugs.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Be sure to verify that there is a 24 VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2442st

Last Modified: 31-Oct-2011


Fault Code Path Selection

FAULT CODE 2443
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2443st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc2443mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc2443mt

Last Modified: 03-Mar-2004


Right Bank Capacitive Coil Driver Failed

FAULT CODE 2443 - Multiple Turbocharger with Integrated Throttle

Right Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Right Bank Capacitive Coil Driver Failed

CODE | REASON | EFFECT
Fault Code: 2443 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | The number of misfiring cylinders has exceeded the critical threshold. | The engine will shut down.
Right Bank Capacitive Coil Driver Failed

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil-on-plugs.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Be sure to verify that there is a 24 VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2443mt

Last Modified: 31-Oct-2011


Right Bank Capacitive Coil Driver Failed

FAULT CODE 2443 - Multiple Turbocharger with a Two-piece Throttle

Right Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Right Bank Capacitive Coil Driver Failed

CODE | REASON | EFFECT
Fault Code: 2443 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | The number of misfiring cylinders has exceeded the critical threshold. | The engine will shut down.
Right Bank Capacitive Coil Driver Failed

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil-on-plugs.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Be sure to verify that there is a 24 VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2443mttt

Last Modified: 31-Oct-2011


Right Bank Capacitive Coil Driver Failed

FAULT CODE 2443 - Single Turbocharger

Right Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Right Bank Capacitive Coil Driver Failed

CODE | REASON | EFFECT
Fault Code: 2443 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | The number of misfiring cylinders has exceeded the critical threshold. | The engine will shut down.
Right Bank Capacitive Coil Driver Failed

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil-on-plugs.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Be sure to verify that there is a 24 VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2443st

Last Modified: 31-Oct-2011


Proprietary Data Link - Master Message Lost

FAULT CODE 2444

Proprietary Data Link - Master Message Lost

Printable Version Printable Version

Overview

Proprietary Data Link - Master Message Lost

CODE | REASON | EFFECT
Fault Code: 2444 PID: FMI: 2 LAMP: Stop SRT: | The ECM has detected erratic, intermittent, or incorrect data received over the proprietary datalink. | Engine will shut down.
Proprietary Data Link Circuit - Single Turbocharger
Proprietary Data Link Circuit - Multiple Turbocharger with Two-piece Throttle
Proprietary Data Link Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The proprietary datalink is a high speed datalink that carries critical engine operating data.

Component Location

The proprietary datalink is located in the engine wiring harness between the ECM and the datalink connectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected the proprietary datalink communication was lost.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
  • Damaged or loose connections.
Refer to Troubleshooting Fault Code t05-2444

Last Modified: 20-Apr-2022


Kilowatt Load High Error

FAULT CODE 2453

Kilowatt Load High Error

Printable Version Printable Version

Overview

Kilowatt Load High Error

CODE | REASON | EFFECT
Fault Code: 2453 PID: FMI: 16 LAMP: Warning SRT: | High current detected at the kilowatt load signal pin of the main harness CM700 connector. | Possible reduced engine performance.
Kilowatt Load Circuit

Circuit Description

The Kilowatt Load Sensor receives Alternating Current (AC) voltage and current signals from the main alternator, The sensor output is a 4 to 20 mA signal to the CM700.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Use caution when troubleshooting the Kilowatt Load Transducer. AC voltage is present.

The Kilowatt Load Sensor output needs to be calibrated with an Electronic Service Tool if the transducer is replaced.

Refer to Troubleshooting Fault Code t05-2453

Last Modified: 27-Oct-2011


Kilowatt Load Low Error

FAULT CODE 2454

Kilowatt Load Low Error

Printable Version Printable Version

Overview

Kilowatt Load Low Error

CODE | REASON | EFFECT
Fault Code: 2454 PID: FMI: 18 LAMP: Warning SRT: | Low current detected at the kilowatt load signal pin of the main harness CM700 connector. | Possible reduced engine performance.
Kilowatt Load Circuit

Circuit Description

The Kilowatt Load Sensor receives Alternating Current (AC) voltage and current signals from the main alternator, The sensor output is a 4 to 20 mA signal to the CM700.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Use caution when troubleshooting the Kilowatt Load Transducer. AC voltage is present.

The Kilowatt Load Sensor output needs to be calibrated with an Electronic Service Tool if the transducer is replaced.

Refer to Troubleshooting Fault Code t05-2454

Last Modified: 27-Oct-2011


Speed Bias - Low Error

FAULT CODE 2455

Speed Bias - Low Error

Printable Version Printable Version

Overview

Speed Bias - Low Error

CODE | REASON | EFFECT
Fault Code: 2455 PID: FMI: 5 LAMP: Warning SRT: | Low frequency detected on the speed bias pin of the CM700. | The engine will shutdown.
Speed Bias Circuit

Circuit Description

The speed bias input to the CM700 is a 5 VDC pulse-width modulated signal. An open in the speed bias signal or a short to ground will cause the Fault Code 2455.

Component Location

Not applicable.

Shop Talk

The pulse-width modulated signal that is sent to the CM700 from the Power Command Supervisor should always read a frequency of 3 kHz.

Refer to Troubleshooting Fault Code t05-2455

Last Modified: 27-Oct-2011


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2458

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2458 PID: SPN: 1138 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2458

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2459

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2459 PID: SPN: 1140 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2459

Last Modified: 24-Mar-2022


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2461

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2461 PID: SPN: 1142 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature. The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2461

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2462

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2462 PID: SPN: 1144 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature. The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2462

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2463

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2463 PID: SPN: 1146 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2463

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2464

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2464 PID: SPN: 1148 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2464

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2465

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2465 PID: SPN: 1150 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2465

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2466

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2466 PID: SPN: 1152 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2466

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2467

Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2467 PID: SPN: 1154 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2467

Last Modified: 24-Mar-2022


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2469

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2469 PID: SPN: 1137 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2469

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2471

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2471 PID: SPN: 1139 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2471

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2472

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2472 PID: SPN: 1141 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2472

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2473

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2473 PID: SPN: 1143 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2473

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2475

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2475 PID: SPN: 1145 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature. The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2475

Last Modified: 28-Mar-2022


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2476

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2476 PID: SPN: 1147 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature. The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2476

Last Modified: 28-Mar-2022


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2477

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2477 PID: SPN: 1149 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2477

Last Modified: 28-Mar-2022


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2478

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2478 PID: SPN: 1151 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2478

Last Modified: 28-Mar-2022


Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2479

Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2479 PID: SPN: 1153 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor has detected temperature below the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-2479

Last Modified: 28-Mar-2022


Start Block Condition

FAULT CODE 2482

Start Block Condition

Printable Version Printable Version

Overview

Start Block Condition

CODE | REASON | EFFECT
Fault Code: 2482 PID: SPN: FMI: 11 LAMP: Shutdown SRT: | A start attempt has been made while a start block condition was active. | The engine will not start.
Start Block Condition

Circuit Description

The starter motor is commanded to run by the CM700. If an attempt is made to start the engine while a start block condition is active, the engine will not start and the start block condition fault will be set.

In the above, relay K4 is commanded to close by the CM700. This sends 24 VDC to the starter solenoid to engage the starter.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Common start block conditions are having the barring gear engaged or attempting to start the engine too quickly after a keyswitch reset.

Refer to Troubleshooting Fault Code t05-2482

Last Modified: 27-Oct-2011


Continuous Starter Failure

FAULT CODE 2483

Continuous Starter Failure

Printable Version Printable Version

Overview

Continuous Starter Failure

CODE | REASON | EFFECT
Fault Code: 2483 PID: SPN: FMI: 7 LAMP: Shutdown SRT: | The starter motor has been commanded to run and is not running. | The engine will not start.
Continuous Starter Failure

Circuit Description

The starter motor is commanded to run by the CM700. If the CM700 commands the starter to run three times and does not see engine speed during any attempt, the Continuous Starter Failure fault is set.

In the circuit above, relay K4 is commanded to close by the CM700. This sends 24 VDC to the starter solenoid to engage the starter.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

A relay in the DC interface panel determines which pins in the starter connection are used for the start signal. The pins depend on whether or not an air starter or an electric starter is in use. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2483

Last Modified: 31-Oct-2011


Exhaust Gas Temperature Cylinder 1 (A1) - Abnormal Rate of Change

FAULT CODE 2484

Exhaust Gas Temperature Cylinder 1 (A1) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 1 (A1) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2484 PID: SPN: 1137 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2484

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 3 (A2) - Abnormal Rate of Change

FAULT CODE 2485

Exhaust Gas Temperature Cylinder 3 (A2) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 3 (A2) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2485 PID: SPN: 1139 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2485

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 5 (A3) - Abnormal Rate of Change

FAULT CODE 2486

Exhaust Gas Temperature Cylinder 5 (A3) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 5 (A3) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2486 PID: SPN: 1141 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2486

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 7 (A4) - Abnormal Rate of Change

FAULT CODE 2487

Exhaust Gas Temperature Cylinder 7 (A4) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 7 (A4) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2487 PID: SPN: 1143 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2487

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 9 (A5) - Abnormal Rate of Change

FAULT CODE 2488

Exhaust Gas Temperature Cylinder 9 (A5) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 9 (A5) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2488 PID: SPN: 1145 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2488

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 11 (A6) - Abnormal Rate of Change

FAULT CODE 2489

Exhaust Gas Temperature Cylinder 11 (A6) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 11 (A6) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2489 PID: SPN: 1147 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2489

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 13 (A7) - Abnormal Rate of Change

FAULT CODE 2491

Exhaust Gas Temperature Cylinder 13 (A7) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 13 (A7) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2491 PID: SPN: 1149 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2491

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 15 (A8) - Abnormal Rate of Change

FAULT CODE 2492

Exhaust Gas Temperature Cylinder 15 (A8) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 15 (A8) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2492 PID: SPN: 1151 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2492

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 17 (A9) - Abnormal Rate of Change

FAULT CODE 2493

Exhaust Gas Temperature Cylinder 17 (A9) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 17 (A9) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2493 PID: SPN: 1153 FMI: 10 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2493

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 2 (B1) - Abnormal Rate of Change

FAULT CODE 2494

Exhaust Gas Temperature Cylinder 2 (B1) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 2 (B1) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2494 PID: SPN: 1138 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2494

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 4 (B2) - Abnormal Rate of Change

FAULT CODE 2495

Exhaust Gas Temperature Cylinder 4 (B2) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 4 (B2) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2495 PID: SPN: 1140 FMI: 10 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2495

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 6 (B3) - Abnormal Rate of Change

FAULT CODE 2496

Exhaust Gas Temperature Cylinder 6 (B3) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 6 (B3) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2496 PID: SPN: 1142 FMI: 10 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2496

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 8 (B4) - Abnormal Rate of Change

FAULT CODE 2497

Exhaust Gas Temperature Cylinder 8 (B4) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 8 (B4) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2497 PID: SPN: 1144 FMI: 10 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2497

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 10 (B5) - Abnormal Rate of Change

FAULT CODE 2498

Exhaust Gas Temperature Cylinder 10 (B5) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 10 (B5) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2498 PID: SPN: 1146 FMI: 10 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2498

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 12 (B6) - Abnormal Rate of Change

FAULT CODE 2499

Exhaust Gas Temperature Cylinder 12 (B6) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 12 (B6) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2499 PID: SPN: 1148 FMI: 10 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2499

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 14 (B7) - Abnormal Rate of Change

FAULT CODE 2511

Exhaust Gas Temperature Cylinder 14 (B7) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 14 (B7) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2511 PID: SPN: 1150 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2511

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 16 (B8) - Abnormal Rate of Change

FAULT CODE 2512

Exhaust Gas Temperature Cylinder 16 (B8) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 16 (B8) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2512 PID: SPN: 1152 FMI: 10 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2512

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 18 (B9) - Abnormal Rate of Change

FAULT CODE 2513

Exhaust Gas Temperature Cylinder 18 (B9) - Abnormal Rate of Change

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 18 (B9) - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 2513 PID: SPN: 1154 FMI: 10 LAMP: Stop / Shutdown SRT: | The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2513

Last Modified: 04-Apr-2022


Compressor Outlet Pressure Sensor Circuit - Shorted High

FAULT CODE 2517

Compressor Outlet Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Compressor Outlet Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 2517 PID: SPN: FMI: 3 LAMP: Warning SRT: | High voltage detected on compressor outlet pressure sensor signal pin of the main harness A CM558 connector. | Possible reduced engine performance.
Compressor Outlet Pressure Sensor Circuit

Circuit Description

The Compressor Outlet Pressure Sensor monitors the pressure of the air and fuel mixture as it exits the turbocharger compressor. This pressure is monitored by the CM558. High voltage will cause Fault Code 2517 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The compressor outlet pressure is the pressure of the air fuel mixture after as it has exited the turbocharger compressor and prior to entering the throttle. High pressures can be a result of air-to-fuel ratios that are too high.

Refer to Troubleshooting Fault Code t05-2517

Last Modified: 27-Oct-2011


Compressor Outlet Pressure Sensor Circuit - Shorted Low

FAULT CODE 2518

Compressor Outlet Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Compressor Outlet Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2518 PID: SPN: FMI: 4 LAMP: Warning SRT: | Low voltage detected on compressor outlet pressure sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Compressor Outlet Pressure Sensor Circuit

Circuit Description

The Compressor Outlet Pressure Sensor monitors the pressure of the air and fuel mixture as it exits the turbocharger compressor. This pressure is monitored by the CM558. Low voltage will cause Fault Code 2518 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The compressor outlet pressure is the pressure of the air fuel mixture after as it has exited the turbocharger compressor and prior to entering the throttle. Low pressures can be a result of air-to-fuel ratios that are too low.

Refer to Troubleshooting Fault Code t05-2518

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 2519
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2519st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc2519mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc2519mt

Last Modified: 29-Mar-2004


Throttle Actuator Error

FAULT CODE 2519 - Multiple Turbocharger with Integrated Throttle

Throttle Actuator Error

Printable Version Printable Version

Overview

Throttle Actuator Error

CODE | REASON | EFFECT
Fault Code: 2519 PID: SPN: FMI: 7 LAMP: Shutdown SRT: | The Throttle Plate position feedback is not responding to commands from the ECM. The actuator or butterfly plate is stuck. | The engine will shutdown.
Throttle Plate Circuit

Circuit Description

The Throttle Actuator Circuit consists of the Throttle Driver and the CM558. The Throttle Driver receives a 4-20 mA commanded position signal from the CM558. The Position Feedback Signal from the throttle driver is also a 4-20 mA signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The Throttle Plate commanded signal and the feedback signal can be monitored using the electronic service tool. The Throttle Plate is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the Throttle Actuator fault will be set.

Always verify that the cable connections on the Throttle Driver are tight. There are two connections: the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-2519mt

Last Modified: 27-Oct-2011


Throttle Actuator Error

FAULT CODE 2519 - Multiple Turbocharger with Two-Piece Throttle

Throttle Actuator Error

Printable Version Printable Version

Overview

Throttle Actuator Error

CODE | REASON | EFFECT
Fault Code: 2519 PID: SPN: FMI: 7 LAMP: Shutdown SRT: | The Throttle Plate position feedback is not responding to commands from the ECM. The actuator or butterfly plate is stuck. | The engine will shutdown.
Throttle Plate Circuit

Circuit Description

The Throttle Actuator Circuit consists of the Throttle Driver and the CM558. The Throttle Driver receives a 4-20 mA commanded position signal from the CM558. The Position Feedback Signal from the throttle driver is also a 4-20 mA signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The Throttle Plate commanded signal and the feedback signal can be monitored using the electronic service tool. The Throttle Plate is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the Throttle Actuator fault will be set.

Always verify that the cable connections on the Throttle Driver are tight. There are three connections: the signal to the throttle actuator, the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-2519mttt

Last Modified: 27-Oct-2011


Throttle Actuator Error

FAULT CODE 2519 - Single Turbocharger

Throttle Actuator Error

Printable Version Printable Version

Overview

Throttle Actuator Error

CODE | REASON | EFFECT
Fault Code: 2519 PID: SPN: FMI: 7 LAMP: Shutdown SRT: | The Throttle Plate position feedback is not responding to commands from the ECM. The actuator or butterfly plate is stuck. | The engine will shutdown.
Throttle Plate Circuit

Circuit Description

The Throttle Actuator Circuit consists of the Throttle Driver and the CM558. The Throttle Driver receives a 4-20 mA commanded position signal from the CM558. The Position Feedback Signal from the throttle driver is also a 4-20 mA signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The Throttle Plate commanded signal and the feedback signal can be monitored using the electronic service tool. The Throttle Plate is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the Throttle Actuator fault will be set.

Always verify that the cable connections on the Throttle Driver are tight. There are two connections: the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-2519st

Last Modified: 27-Oct-2011


Bank Identification Error

FAULT CODE 2521

Bank Identification Error

Printable Version Printable Version

Overview

Bank Identification Error

CODE | REASON | EFFECT
Fault Code: 2521 PID: SPN: 1225 FMI: 11 LAMP: Shutdown SRT: | Incorrect bank identification detected by the CM558 at power up. | Engine will not start.
Left and Right CM558 Bank Identification Circuit

Circuit Description

Each CM558 reads the status of two pins to determine whether it is on the left bank or the right bank upon power up. A proper combination requires that one of these pins be shorted to CM558 Switch Return and the other left open. The short is permanently wired inside the wiring harness.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each CM558 must have a unique identification as established by the two bank identification pins upon start up. If both pins on either CM558 are shorted to CM558 Switch Return or open, a fault will occur. The two CM558s must not have the same pin shorted to CM558 Switch Return.

Refer to Troubleshooting Fault Code t05-2521

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 1

FAULT CODE 2522

Continuous Light Detonation (Knock) Detected in Cylinder Number 1

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 1

CODE | REASON | EFFECT
Fault Code: 2522 PID: SPN: FMI: 16 LAMP: Shutdown SRT: | Cylinder number 1 has exceeded the lower knock count threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an electronic service tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2522

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 2

FAULT CODE 2523

Continuous Light Detonation (Knock) Detected in Cylinder Number 2

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 2

CODE | REASON | EFFECT
Fault Code: 2523 PID: SPN: FMI: 16 LAMP: Shutdown SRT: | Cylinder number 2 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2523

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 3

FAULT CODE 2524

Continuous Light Detonation (Knock) Detected in Cylinder Number 3

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 3

CODE | REASON | EFFECT
Fault Code: 2524 PID: SPN: FMI: 16 LAMP: Shutdown SRT: | Cylinder number 3 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2524

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 4

FAULT CODE 2525

Continuous Light Detonation (Knock) Detected in Cylinder Number 4

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 4

CODE | REASON | EFFECT
Fault Code: 2525 PID: SPN: FMI: 16 LAMP: Shutdown SRT: | Cylinder number 4 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2525

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 5

FAULT CODE 2526

Continuous Light Detonation (Knock) Detected in Cylinder Number 5

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 5

CODE | REASON | EFFECT
Fault Code: 2526 PID: S090 SPN: 1356 FMI: 16 LAMP: Shutdown SRT: | Cylinder number 5 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2526

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 6

FAULT CODE 2527

Continuous Light Detonation (Knock) Detected in Cylinder Number 6

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 6

CODE | REASON | EFFECT
Fault Code: 2527 PID: S090 SPN: 1357 FMI: 16 LAMP: Shutdown SRT: | Cylinder number 6 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2527

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 7

FAULT CODE 2528

Continuous Light Detonation (Knock) Detected in Cylinder Number 7

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 7

CODE | REASON | EFFECT
Fault Code: 2528 PID: SPN: FMI: 16 LAMP: Shutdown SRT: | Cylinder number 7 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2528

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 8

FAULT CODE 2529

Continuous Light Detonation (Knock) Detected in Cylinder Number 8

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 8

CODE | REASON | EFFECT
Fault Code: 2529 PID: SPN: FMI: 16 LAMP: Shutdown SRT: | Cylinder number 8 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2529

Last Modified: 27-Oct-2011


Continuous Light Detonation (Knock) Detected in Cylinder Number 9

FAULT CODE 2531

Continuous Light Detonation (Knock) Detected in Cylinder Number 9

Printable Version Printable Version

Overview

Continuous Light Detonation (Knock) Detected in Cylinder Number 9

CODE | REASON | EFFECT
Fault Code: 2531 PID: SPN: FMI: 16 LAMP: Shutdown SRT: | Cylinder number 9 has exceeded the lower knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The Continuous Light Detonation (Knock) fault code is activated when light knocking occurs and can not be eliminated. The CM558 will retard the spark timing twice. If the timing retard does not eliminate the detonation (knock), the Continuous Light Detonation (Knock) fault will be set.

Refer to Troubleshooting Fault Code t05-2531

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 254
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc254st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc254mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc254mt

Last Modified: 30-Mar-2004


ECM Internal Air Temperature High — Critical

FAULT CODE 2544

ECM Internal Air Temperature High — Critical

Printable Version Printable Version

Overview

ECM Internal Air Temperature High — Critical

CODE | REASON | EFFECT
Fault Code: 2544 PID: FMI: 0 LAMP: SRT: | The ECM internal temperature has exceeded the high shutdown threshold. | The engine will shut down.
Electronic Control Module (ECM)

Circuit Description

The CM700 and CM558 each contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-2544

Last Modified: 27-Oct-2011


Proprietary Data Link - Slave Message Lost

FAULT CODE 2548

Proprietary Data Link - Slave Message Lost

Printable Version Printable Version

Overview

Proprietary Data Link - Slave Message Lost

CODE | REASON | EFFECT
Fault Code: 2548 PID: FMI: 2 LAMP: Stop/Shutdown SRT: | Data erratic, intermittent or incorrect data was received by the ECM from the other ECM over the proprietary data link. | Engine will shut down.
Proprietary Data Link Circuit - Single Turbocharger
Proprietary Data Link Circuit - Multiple Turbocharger with Two-piece Throttle
Proprietary Data Link Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The proprietary datalink is a high speed datalink that carries critical engine operating data.

Component Location

The proprietary datalink is located in the engine wiring harness between the ECM and the datalink connectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected erratic data received from one ECM to the other ECM over the proprietary data link.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
  • Damaged or loose connections.
Refer to Troubleshooting Fault Code t05-2548.

Last Modified: 20-Apr-2022


Fuel Shutoff Valve Circuit - Shorted Low

FAULT CODE 254 - Multiple Turbocharger with Integrated Throttle

Fuel Shutoff Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Shutoff Valve Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 254 PID: 17 SPN: 701 FMI: 4 LAMP: Shutdown SRT: | Low voltage detected at the signal return pin of the fuel shutoff valve. | The engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by both the CM700 and the left bank CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two 24 VDC supplies and one ground connection.

Refer to Troubleshooting Fault Code t05-254mt

Last Modified: 27-Oct-2011


Fuel Shutoff Valve Circuit - Shorted Low

FAULT CODE 254 - Multiple Turbocharger with Two-Piece Throttle

Fuel Shutoff Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Shutoff Valve Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 254 PID: 17 SPN: 701 FMI: 4 LAMP: Shutdown SRT: | Low voltage detected at the signal return pin of the fuel shutoff valve. | The engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by both the CM700 and the left bank CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two 24 VDC supplies and one ground connection. The logic of the vent valve is the opposite of the main fuel shutoff solenoids. When power is provided to open the solenoids, the vent valve is closed (if fitted).

Refer to Troubleshooting Fault Code t05-254mttt

Last Modified: 27-Oct-2011


Fuel Shutoff Valve Circuit - Shorted Low

FAULT CODE 254 - Single Turbocharger

Fuel Shutoff Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Shutoff Valve Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 254 PID: 17 SPN: 701 FMI: 4 LAMP: Shutdown SRT: | Low voltage detected at the signal return pin of the fuel shutoff valve. | The engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by both the CM700 and the left bank CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two 24 VDC supplies and one ground connection.

Refer to Troubleshooting Fault Code t05-254st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 255
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc255st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc255mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc255mt

Last Modified: 30-Mar-2004


Engine Oil Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2553

Engine Oil Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2553 PID: 98 SPN: 98 FMI: 18 LAMP: Warning SRT: | Engine Oil Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low engine oil level has been detected by the oil level sensor. | No effect on engine performance.
QSV81G / QSV91G Multiple Turbochargers with Generator Control Panel 1 and PowerCommand® Supervisor 3100
QSV81G / QSV91G Single and Multiple Turbochargers with Generator Control Panel 2 and PowerCommand® Supervisor 3100
QSV91G Single and Multiple Turbochargers with Generator Interface Box and PowerCommand® Control 3300
Discrete Murphy® Oil Sump Level Switch - Terminal Connections (All Models)

Circuit Description

The Discrete Murphy® Oil Sump Level Switch both monitors and maintains the oil level within the engine's sump. The engine oil level is monitored at all times while the 24 volt supply is switched ON.

The oil level switch is integral to the Murphy® Level Switch Assembly. If the oil level within the Murphy® Level Switch falls below a certain level, the control system will activate Fault Code 2553.

On Generator Sets fitted with Generator Control Panel 1 with PowerCommand® Supervisor 3100, the low oil sump level signal is monitored by the Programmable Logic Control.

On Generator Sets fitted with Generator Control Panel 2 with PowerCommand® Supervisor 3100 or Generator Interface Box with PowerCommand® Control 3300, the low oil sump level signal is monitored by the CM700 module.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

In order to maintain the correct engine oil level within the engine at all times, the Murphy® Oil Level Switch is connected to an engine lubricating oil day tank, usually located close to the generator set. The positioning of the Murphy® Oil Level Switch is critical to maintaining the correct oil level within the sump. This position has been pre-determined and is non-adjustable.

The oil level within the Murphy® Oil Level Switch can be monitored via an integral sight glass.

The Murphy® Oil Level Switch also incorporates an integral Test Switch, which can be used to test the switch alarm outputs to the Programmable Logic Control or CM700 module for the corresponding fault code activation.

Possible causes of this fault code include:

  • Engine lubricating oil day tank low oil levels (Fault Code 219 will be activated).
  • External engine oil leaks.
  • Internal engine oil leaks (oil leaking into the cooling system).
  • High engine oil consumption/power cylinder damage. Check for abnormally high blowby when the engine is loaded, as well as rapid filling of the engine dirty oil tank. Appropriate dirty oil tank level alarms will be activated.
Refer to Troubleshooting Fault Code t05-2553.

Last Modified: 24-Aug-2014


Fuel Shutoff Valve Circuit - Shorted High

FAULT CODE 255 - Multiple Turbocharger with Integrated Throttle

Fuel Shutoff Valve Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Shutoff Valve Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 255 PID: 26 SPN: 701 FMI: 3 LAMP: Shutdown SRT: | High voltage detected at the signal return pin of the fuel shutoff valve. | The engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by both the CM700 and the left bank CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two 24 VDC supplies and one ground connection.

Refer to Troubleshooting Fault Code t05-255mt

Last Modified: 27-Oct-2011


Fuel Shutoff Valve Circuit - Shorted High

FAULT CODE 255 - Multiple Turbocharger with Two-Piece Throttle

Fuel Shutoff Valve Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Shutoff Valve Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 255 PID: 26 SPN: 701 FMI: 3 LAMP: Shutdown SRT: | High voltage detected at the signal return pin of the fuel shutoff valve. | The engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by both the CM700 and the left bank CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two 24 VDC supplies and one ground connection. The logic of the vent valve is the opposite of the main fuel shutoff solenoids. When power is provided to open the solenoids, the vent valve is closed (if fitted).

Refer to Troubleshooting Fault Code t05-255mttt

Last Modified: 27-Oct-2011


Fuel Shutoff Valve Circuit - Shorted High

FAULT CODE 255 - Single Turbocharger

Fuel Shutoff Valve Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Shutoff Valve Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 255 PID: 26 SPN: 701 FMI: 3 LAMP: Shutdown SRT: | High voltage detected at the signal return pin of the fuel shutoff valve. | The engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is commanded by both the CM700 and the left bank CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two 24 VDC supplies and one ground connection.

Refer to Troubleshooting Fault Code t05-255st

Last Modified: 27-Oct-2011


Fuel Temperature High — Warning

FAULT CODE 261

Fuel Temperature High — Warning

Printable Version Printable Version

Overview

Fuel Temperature High — Warning

CODE | REASON | EFFECT
Fault Code: 261 PID: P174 SPN: 174 FMI: 16 LAMP: Warning SRT: | The fuel temperature has exceeded the high warning threshold. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor monitors the temperature of the fuel that is being supplied to the engine.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Verify that OEM installation guidelines have been followed for any fuel coolers that may be installed in the system. Often, no fuel conditioning is done.

Refer to Troubleshooting Fault Code t05-261

Last Modified: 27-Oct-2011


Fuel Temperature Sensor Circuit — Shorted High

FAULT CODE 263

Fuel Temperature Sensor Circuit — Shorted High

Printable Version Printable Version

Overview

Fuel Temperature Sensor Circuit — Shorted High

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3 LAMP: Warning SRT: | Engine Fuel Temperature Sensor signal is shorted high. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit

Circuit Description

The Fuel Temperature Sensor is used by the CM558 to monitor the temperature of the fuel entering the fuel control assembly. The Fuel Temperature Sensor is used by the CM558 for timing and fueling control.

If the voltage is high the CM558 will log Fault Code 263. Voltage high can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Reference the circuit diagram or wiring diagram to identify connectors and pins.

Refer to Troubleshooting Fault Code t05-263

Last Modified: 31-Oct-2011


Fuel Temperature Sensor Circuit - Shorted Low

FAULT CODE 265

Fuel Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Temperature Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4 LAMP: Warning SRT: | Engine Fuel Temperature Sensor signal is shorted low. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit

Circuit Description

The Fuel Temperature Sensor is used by the CM558 to monitor the temperature of the fuel entering the fuel control assembly. The fuel temperature is used by the CM558 for timing and fuel control.

If the voltage is low the CM558 will log Fault Code 265. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded, failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The resistance of the sensor varies with the temperature.

Reference the wiring diagram for details.

Refer to Troubleshooting Fault Code t05-265

Last Modified: 31-Oct-2011


Left Bank Capacitive Coil Driver Failed

FAULT CODE 2766

Left Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Engine Ignition Control Module #1 - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2766 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | Engine Ignition Control Module #1 - Condition Exists. The engine control module (ECM) has diagnosed that the ignition module on Bank A has malfunctioned. | The engine will shut down.
Left Bank Capacitive Coil Driver

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil-on-plugs.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Make sure to verify that there is a 24 VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2766.

Last Modified: 06-Jan-2016


Right Bank Capacitive Coil Driver Failed

FAULT CODE 2767

Right Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Engine Ignition Control Module #2 - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2767 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | Engine Ignition Control Module #2 - Condition Exists. The engine control module (ECM) has diagnosed that the ignition module on Bank B has malfunctioned. | The engine will shut down.
Left Bank Capacitive Coil Driver

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil-on-plugs.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Make sure to verify that there is a 24 VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Reference the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2766.

Last Modified: 06-Jan-2016


Fault Code Path Selection

FAULT CODE 277
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc277st
Is this engine equipped with a Multiple Turbochargers? | Go to 55-fc277mt

Last Modified: 03-Apr-2012


Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 277 - Multiple Turbochargers

Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: N/A SPN: 633 FMI: 7 LAMP: Warning SRT: N/A | Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment. The left-bank electronic fuel control valve is stuck or not responding. | The engine will continue to operate, but performance may be impaired.
QSV91G Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

FCV 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module. This FCV is located at the front of the engine (free-end).

FCV 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. This FCV is located at the rear of the engine (flywheel end).

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 277 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness, or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustment of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position, PWM percent duty cycle and VDC feedback signal specifications.

Troubleshooting FCV Operation
Actuator Commanded Position | PWM Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 89 | 4.6 to 4.8

NOTE: PWM percent of duty cycle signals can only be measured with multimeters or other measuring devices that have a percent of duty cycle function.

Refer to Troubleshooting Fault Code t05-277.

Last Modified: 10-Feb-2012


Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 277 - Single Turbocharger

Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: N/A SPN: 633 FMI: 7 LAMP: Warning SRT: N/A | Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment. The left-bank electronic fuel control valve is stuck or not responding. | The engine will continue to operate, but performance may be impaired.
QSV91G Single Turbocharger with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Single Turbocharger with PowerCommand™ Control 3300 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Single Turbocharger Low BTU Generator Sets with PowerCommand™ Control 3300 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

FCV 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module. This FCV is located at the front of the engine (free-end).

FCV 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. For QSV91G single turbocharger engines, the FCV 2 is only fitted to low BTU fueled engines.

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 277 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness, or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustment of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position, PWM percent duty cycle, and VDC feedback signal specifications.

Troubleshooting FCV Operation
Actuator Commanded Position | PWM Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 89 | 4.6 to 4.8

NOTE: PWM percentage of duty cycle signals can only be measured with multimeters or other measuring devices that have a percent of duty cycle function.

Refer to Troubleshooting Fault Code t05-277st.

Last Modified: 17-Feb-2012


Electronic Throttle Control Actuator - Data Erratic, Intermittent or Incorrect

FAULT CODE 2812

Electronic Throttle Control Actuator - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2812 PID: SPN: 3464 FMI: 2 LAMP: Stop/Shutdown SRT: | The data for throttle actuator being received over the data link is erratic. | Engine will shut down.
Throttle Actuator Position Circuit - Single Turbocharger
Throttle Actuator Position Circuit - Multiple Turbocharger with Two-Piece Throttle
Throttle Actuator Position Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The engine control module (ECM) controls the engine throttle actuator. The ECM can open and close the throttle based on the operating conditions in order to regulate air flow to the engine.

Component Location

Single Turbocharger: The engine throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Multiple Turbochargers: Both throttle actuator assemblies are mounted on the front gear housing, directly below the charge-air cooler assembly located at the non‐drive end of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine throttle actuator is erratic.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine control system will issue a Critical Engine Stop command.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged throttle actuator.
  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2812.

Last Modified: 16-May-2022


Fault Code Path Selection

FAULT CODE 2814
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc2814st
Is this engine equipped with a Multiple Turbochargers? | Go to 55-fc2814mt

Last Modified: 03-Apr-2012


Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

FAULT CODE 2814 - Multiple Turbochargers

Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2814 PID: SPN: 633 FMI: 11 LAMP: warning SRT: | Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known. An unidentified failure mode has occurred in the left-bank electronic fuel control valve (FCV). | The engine will continue to run, but performance may be impaired.
QSV91G Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The FCV position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel Control Valve 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module.

This FCV is located at the front of the engine (free-end). Fuel Control Valve 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. This FCV is located at the rear of the engine (flywheel end).

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 2184 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

Possible causes of this fault code include:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn, or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator position, commanded PWM percentage duty cycle, and voltage feedback signal specifications.

Actuator Commanded Position | Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

PWM percentage duty cycle signals can only be measured using a multimeter or other measuring device that has a percentage duty cycle function.

Refer to Troubleshooting Fault Code t05-2814mt.

Last Modified: 30-Jan-2012


Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

FAULT CODE 2814 - Single Turbocharger

Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2814 PID: SPN: 633 FMI: 11 LAMP: warning SRT: | Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known. An unidentified failure mode has occurred in the left-bank electronic fuel control valve. | The engine will continue to run but performance may be impaired.
QSV91G Single Turbocharger with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit
QSV91G Single Turbocharger with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit
QSV91G Single Turbocharger Low BTU Generator Sets with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel control valve 1 refers to the FCV controlled by the left-bank (a-bank) CM558 electronic control module. Fuel control valve 2 refers to the FCV controlled by the right-bank (b-bank) CM558 electronic control module. For QSV91G single turbocharger engines, the fuel control valve 2 is only fitted to low BTU fueled engines. If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 2184 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

Possible cause of this fault code include:

  • Electronic FCV high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn, or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position, PWM percentage duty cycle, and voltage feedback signal specifications.

Actuator Commanded Position | Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

PWM percentage duty cycle signals can only be measured using a multimeter or other measuring device that has a percentage duty cycle function.

Refer to Troubleshooting Fault Code t05-2814st.

Last Modified: 01-Feb-2012


Exhaust Gas Temperature Cylinder 1 (A1) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2837

Exhaust Gas Temperature Cylinder 1 (A1) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2837 PID: SPN: 1137 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2837

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 3 (A2) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2838

Exhaust Gas Temperature Cylinder 3 (A2) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2838 PID: SPN: 1139 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2838

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 5 (A3) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2839

Exhaust Gas Temperature Cylinder 5 (A3) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2839 PID: SPN: 1141 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2839

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 7 (A4) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2841

Exhaust Gas Temperature Cylinder 7 (A4) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2841 PID: SPN: 1143 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2841

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 9 (A5) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2842

Exhaust Gas Temperature Cylinder 9 (A5) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2842 PID: SPN: 1145 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2842

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 11 (A6) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2843

Exhaust Gas Temperature Cylinder 11 (A6) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2843 PID: SPN: 1147 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2843

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Cylinder 13 (A7) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2844

Exhaust Gas Temperature Cylinder 13 (A7) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2844 PID: SPN: 1149 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2844

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 15 (A8) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2845

Exhaust Gas Temperature Cylinder 15 (A8) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2845 PID: SPN: 1151 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2845

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 17 (A9) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2846

Exhaust Gas Temperature Cylinder 17 (A9) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2846 PID: SPN: 1153 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2846

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 2 (B1) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2847

Exhaust Gas Temperature Cylinder 2 (B1) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2847 PID: SPN: 1138 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2847

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 4 (B2) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2848

Exhaust Gas Temperature Cylinder 4 (B2) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2848 PID: SPN: 1140 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2848

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 6 (B3) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2849

Exhaust Gas Temperature Cylinder 6 (B3) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2849 PID: SPN: 1142 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2849

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 8 (B4) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2851

Exhaust Gas Temperature Cylinder 8 (B4) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2851 PID: SPN: 1144 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2851

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 10 (B5) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2852

Exhaust Gas Temperature Cylinder 10 (B5) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2852 PID: SPN: 1146 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2852

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 12 (B6) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2853

Exhaust Gas Temperature Cylinder 12 (B6) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2853 PID: SPN: 1148 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2853

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 14 (B7) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2854

Exhaust Gas Temperature Cylinder 14 (B7) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2854 PID: SPN: 1150 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2854

Last Modified: 04-Apr-2022


Exhaust Gas Temperature Cylinder 16 (B8) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2855

Exhaust Gas Temperature Cylinder 16 (B8) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2855 PID: SPN: 1152 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2855

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Cylinder 18 (B9) - Data Erratic, Intermittent or Incorrect

FAULT CODE 2856

Exhaust Gas Temperature Cylinder 18 (B9) - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2856 PID: SPN: 1154 FMI: 2 LAMP: Maintenance SRT: | The exhaust gas temperature signal is a intermittent and deviates from the other exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature is erratic and deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning or damaged fuel system
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2856

Last Modified: 06-Apr-2022


Engine Cylinder 1 (A1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3111

Engine Cylinder 1 (A1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 1 (A1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3111 PID: SPN: 1352 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3111

Last Modified: 18-Mar-2022


Engine Cylinder 2 (B1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3112

Engine Cylinder 2 (B1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 2 (B1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3112 PID: SPN: 1353 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle
Knock Sensor Circuit - Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3112

Last Modified: 18-Mar-2022


Engine Cylinder 3 (A2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3113

Engine Cylinder 3 (A2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 3 (A2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3113 PID: SPN: 1354 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3113

Last Modified: 18-Mar-2022


Engine Cylinder 4 (B2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3114

Engine Cylinder 4 (B2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 4 (B2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3114 PID: SPN: 1355 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle
Knock Sensor Circuit - Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3114

Last Modified: 18-Mar-2022


Engine Cylinder 5 (A3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3115

Engine Cylinder 5 (A3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 5 (A3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3115 PID: SPN: 1356 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3115

Last Modified: 18-Mar-2022


Engine Cylinder 6 (B3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3116

Engine Cylinder 6 (B3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 6 (B3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3116 PID: SPN: 1357 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle
Knock Sensor Circuit - Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3116

Last Modified: 18-Mar-2022


Engine Cylinder 7 (A4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3117

Engine Cylinder 7 (A4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 7 (A4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3117 PID: SPN: 1358 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3117

Last Modified: 18-Mar-2022


Engine Cylinder Number 8 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3118

Engine Cylinder Number 8 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3118 PID: SPN: 1359 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle
Knock Sensor Circuit - Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3118.

Last Modified: 18-Mar-2022


Engine Cylinder 9 (A5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3119

Engine Cylinder 9 (A5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 9 (A5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3119 PID: SPN: 1360 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3119

Last Modified: 18-Mar-2022


Engine Cylinder 10 (B5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3121

Engine Cylinder 10 (B5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 10 (B5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3121 PID: SPN: 1361 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle
Knock Sensor Circuit - Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3121

Last Modified: 18-Mar-2022


Engine Cylinder 11 (A6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3122

Engine Cylinder 11 (A6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 11 (A6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3122 PID: SPN: 1362 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3122

Last Modified: 18-Mar-2022


Engine Cylinder 12 (B6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3123

Engine Cylinder 12 (B6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 12 (B6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3123 PID: SPN: 1363 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle
Knock Sensor Circuit - Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3123

Last Modified: 18-Mar-2022


Engine Cylinder 13 (A7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3124

Engine Cylinder 13 (A7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 13 (A7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3124 PID: SPN: 1364 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3124

Last Modified: 18-Mar-2022


Engine Cylinder 14 (B7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3125

Engine Cylinder 14 (B7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 14 (B7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3125 PID: SPN: 1365 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle
Knock Sensor Circuit - Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3125

Last Modified: 18-Mar-2022


Engine Cylinder 15 (A8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3126

Engine Cylinder 15 (A8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 15 (A8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3126 PID: SPN: 1366 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3126

Last Modified: 18-Mar-2022


Engine Cylinder 16 (B8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3127

Engine Cylinder 16 (B8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 16 (B8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3127 PID: SPN: 1367 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3127

Last Modified: 18-Mar-2022


Engine Cylinder 17 (A9) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3128

Engine Cylinder 17 (A9) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 17 (A9) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3128 PID: SPN: 1368 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit – Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3128

Last Modified: 18-Mar-2022


Engine Cylinder 18 (B9) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3129

Engine Cylinder 18 (B9) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder 18 (B9) Knock Sensor Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3129 PID: SPN: 1369 FMI: 14 LAMP: Stop / Shutdown SRT: | Excessive mechanical vibration has been detected. | Engine will shut down.
Knock Sensor Circuit - Multiple Turbochargers with Two-Piece Throttle
Knock Sensor Circuit - Single Turbocharger
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle – Analog
Knock Sensor Circuit – Multiple Turbocharger with Integrated Throttle - Digital

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical limit.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged knock sensor
  • Damaged or loose connectors
  • Vibration resulting from loose engine parts / components
  • Worn or damaged power cylinder components.
Refer to Troubleshooting Fault Code t05-3129

Last Modified: 18-Mar-2022


Engine Control Module (CM700 or CM558) - Warning Software Error

FAULT CODE 346

Engine Control Module (CM700 or CM558) - Warning Software Error

Printable Version Printable Version

Overview

Engine Control Module (CM700 or CM558) - Warning Software Error

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12 LAMP: None SRT: | Error internal to the CM700 or CM558. | No effect on engine performance.
CM700 or CM558

Circuit Description

The CM700 or CM558 is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal CM700 or CM558 problem.

Refer to Troubleshooting Fault Code t05-346

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 3475
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc3475st
Is this engine equipped with a Multiple Turbochargers? | Go to 55-fc3475mt

Last Modified: 03-Apr-2012


Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3475 - Multiple Turbochargers

Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3475 PID: SPN: 1443 FMI: 3 LAMP: warning SRT: | Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. Error in the right-bank electronic fuel control valve (FCV) position sensor circuit. | The engine will continue to run, but performance may be impaired.
QSV91G Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The FCV position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel control valve 1 refers to the fuel control valve controlled by the left-bank (A-bank) CM558 electronic control module.

This FCV is located at the front of the engine (free-end). Fuel Control Valve 2 refers to the fuel control valve controlled by the right-bank (B-bank) CM558 electronic control module. This FCV is located at the rear of the engine (flywheel end).

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 3475 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

Possible causes of this fault code include:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn, or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short-to-ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electrical adjustments of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator position, commanded PWM percentage duty cycle, and voltage feedback signal specifications.

Actuator Commanded Position | Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 1.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

PWM percentage duty cycle signals can only be measured using a multimeter or other measuring device that has a percentage duty cycle function.

Refer to Troubleshooting Fault Code t05-3475mt.

Last Modified: 30-Jan-2012


Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3475 - Single Turbocharger

Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3475 PID: SPN: 1443 FMI: 3 LAMP: warning SRT: | Engine Electronic Fuel Control Valve 2 Position Sensor Circuit – Voltage Above Normal or Shorted to High Source. Error in the right-bank electronic fuel control valve (FCV) position sensor circuit. | The engine will continue to run, but performance may be impaired.
QSV91G Single Turbocharger Low BTU Generator Sets with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The FCV position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel Control Valve 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module.

This fuel control valve is located at the front of the engine (free-end). Fuel Control Valve 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. For QSV91G single turbocharger engines, the Fuel Control Valve 2 is only fitted to low BTU fueled engines.

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 3475 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

Possible causes of this fault code include:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn, or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short-to-ground
  • Intermittent circuit malfunctions.

Verify that all components are clean and free of corrosion before replacing components.

Mechanical or electronic adjustments of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator position, commanded PWM percentage duty cycle, and voltage feedback signal specifications.

Actuator Commanded Position | Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

PWM percentage duty cycle signals can only be measured using a multimeter or other measuring device that has a percentage duty cycle function.

Refer to Troubleshooting Fault Code t05-3475st.

Last Modified: 10-Feb-2012


Fault Code Path Selection

FAULT CODE 3476
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc3476st
Is this engine equipped with a Multiple Turbochargers? | Go to 55-fc3476mt

Last Modified: 03-Apr-2012


Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3476 - Multiple Turbochargers

Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3476 PID: SPN: 1443 FMI: 4 LAMP: Warning SRT: | The Engine Electronic Fuel Control Valve 2 Position Sensor Circuit – Voltage Below Normal or Shorted to Low Source. A fault has been detected in the right-bank electronic FCV position sensor circuit. | The engine will continue to run but performance may be impaired.
QSV91G Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated PWM signal and the feedback is a 0 to 5-VDC signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel Control Valve 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module. This FCV is located at the front of the engine (free-end).

Fuel Control Valve 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. This FCV is located at the rear of the engine (flywheel end).

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 3476 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustment of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position PWM percent duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | PWM Percent of Duty Cycle | 0 to 5 VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to 54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 94 | 4.6 to 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3476mt.

Last Modified: 30-Jan-2012


Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3476 - Single Turbocharger

Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3476 PID: SPN: 1443 FMI: 4 LAMP: Warning SRT: | Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. A fault has been detected in the right-bank electronic FCV position sensor circuit. | The engine will continue to run, but performance may be impaired.
QSV91G Single Turbocharger Low BTU Generator Sets with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel Control Valve 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module. This FCV is located at the front of the engine (free-end).

Fuel Control Valve 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. For QSV91G single turbocharger engines, the Fuel Control Valve 2 is only fitted to Low BTU fueled engines.

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 3476 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustment of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position, PWM percent duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | PWM Percent of Duty Cycle | 0 to 5 VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to 54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 94 | 4.6 to 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3476st.

Last Modified: 30-Jan-2012


Fault Code Path Selection

FAULT CODE 3477
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc3477st
Is this engine equipped with a Multiple Turbochargers? | Go to 55-fc3477mt

Last Modified: 03-Apr-2012


Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3477 - Multiple Turbochargers

Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3477 PID: SPN: 1244 FMI: 7 LAMP: Warning SRT: | Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Mechanical System Not Responding or Out of Adjustment. The right-bank electronic FCV is stuck or not responding. | The engine will continue to run but performance may be impaired.
QSV91G Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box - Engine Electronic Fuel Control Valve Circuit
QSV91G Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated signal and the feedback is a 0 to 5-VDC signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel Control Valve 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module. This FCV is located at the front of the engine (free-end).

Fuel Control Valve 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. This FCV is located at the rear of the engine (flywheel end).

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 3477 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustment of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator Commanded position PWM percent duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | PWM Percent of Duty Cycle | 0 to 5 VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to 54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 94 | 4.6 to 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3477mt.

Last Modified: 27-Jan-2012


Engine Electronic Fuel Control Valve 2 – Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3477 - Single Turbocharger

Engine Electronic Fuel Control Valve 2 – Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3477 PID: SPN: 1244 FMI: 7 LAMP: Warning SRT: | Engine Electronic Fuel Control Valve 2 - Mechanical System Not Responding or Out of Adjustment. The right-bank electronic fuel control valve is stuck or not responding. | The engine will continue to run, but performance may be impaired.
QSV91G Single Turbocharger Low BTU Generator Sets with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated signal and the feedback is a 0 to 5-VDC signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Fuel Control Valve 1 refers to the FCV controlled by the left-bank (A-bank) CM558 electronic control module. This FCV is located at the front of the engine (free-end).

Fuel Control Valve 2 refers to the FCV controlled by the right-bank (B-bank) CM558 electronic control module. For QSV91G single turbocharger engines, the Fuel Control Valve 2 is only fitted to low BTU fueled engines.

If an intermittent electrical circuit problem of the electronic FCV circuit exists, it is possible for Fault Code 3477 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short-to-ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustment of the electronic FCV is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator Commande position PWM percent duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | PWM Percent of Duty Cycle | 0 to 5 VDC Feedback Signal
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.9 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to 54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.1
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.3
100 | 89 to 94 | 4.6 to 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3477st.

Last Modified: 27-Jan-2012


Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

FAULT CODE 3489

Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3489 PID: SPN: 3470 FMI: 31 LAMP: Warning SRT: | Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists. The ECM has detected a difference between the actuator commanded position and the actuator feedback signal. | Possible reduced engine performance.
QSV91G Single Turbocharger Low BTU Engine with Generator Interface Box (GIB) and PowerCommand® Control 3300 - Engine Turbocharger Compressor Bypass Actuator Circuit

Circuit Description

The turbocharger compressor bypass actuator position circuit consists of the commanded position signal from the CM558 and the feedback signal that is received by the CM558 from the turbocharger compressor bypass valve. The CM558 monitors the commanded position and the feedback position signals to confirm that the compressor bypass valve has responded and is in the desired position. The commanded position signal is a + 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The turbocharger compressor bypass actuator commanded signal and the feedback signal can be monitored using the electronic service tool. The turbocharger compressor bypass valve is most likely to malfunction in either the closed or fully open position. Compare the feedback signal with the commanded position signal to make sure that the valve is moving freely and is in the desired position.

The following table provides actuator position commanded PWM percent duty cycle and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

If the difference between the commanded position and the feedback position signals is greater than the fault threshold, Fault Code 3489 will be activated.

Possible causes of this fault code include:

  • Short circuit in the commanded position or feedback signal circuits within the engine harness
  • Open circuit in the commanded position or feedback signal circuits within the engine harness.
Refer to Troubleshooting Fault Code t05-3489.

Last Modified: 10-Feb-2012


Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3491

Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3491 PID: 99 SPN: 99 FMI: 0 LAMP: Warning SRT: | Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Most Severe Level. The oil filter differential pressure, measured by the inlet and outlet oil filter pressure sensors, has exceeded the Critical threshold. | The engine will shutdown.
QSV81G / QSV91G Multiple Turbochargers with Two-Piece Twin Throttles and Generator Control Panel 1 (GCP 1) and PowerCommand™ Supervisor 3100 - Engine Oil Filter Differential Circuit
QSV81G / QSV91G Multiple Turbochargers with One-Piece Twin Throttles and Generator Control Panel 2 (GCP 2) and PowerCommand™ Supervisor 3100 - Engine Oil Filter Differential Circuit and QSV91G Multiple Turbochargers with One-Piece Twin Throttles and Generator Interface Box (GIB) and PowerCommand™ Controller 3300 - Engine Oil Filter Differential Circuit
QSV91G Single Turbochargers with One-Piece Twin Throttle and Generator Control Panel 2 (GCP 2) and PowerCommand™ Supervisor 3100 - Engine Oil Filter Differential Circuit and QSV91G Single Turbocharger with One-Piece Twin Throttles and Generator Interface Box (GIB) and PowerCommand™ Controller 3300 - Engine Oil Filter Differential Circuit

Circuit Description

This fault code utilizes data from two oil pressure sensors (oil filter inlet pressure sensor and oil filter outlet pressure sensor). The CM700 engine control module (ECM) provides a 5 volt supply to these oil pressure sensors on the sensor supply circuit. The CM700 also provides a ground on the sensors return circuit. The engine oil inlet pressure sensor and oil filter outlet pressure sensor provides signals to the CM700 on the seperate oil pressure sensor signal circuits. These sensor signal voltages change, based on the pressure in the oil gallery before and after the oil filters. The CM700 monitors these signal voltages to calculate the oil filter differential pressure.

Component Location

QSV91-G and QSV91-G2 Multiple Turbocharger Engines:

The oil filter inlet pressure sensor is located on the left-bank of the engine at the flywheel end, and is mounted on the base of the oil filter housing.The oil filter outlet pressure sensor is located on the left-bank of the engine at the flywheel end, and is mounted on the end cover of the oil cooler.

QSV91-G3 and QSV91-G5 Single Turbocharger Engines:

The oil filter inlet pressure sensor is located on the left-bank of the engine at the free end, and is mounted in-board on the engine end of the oil filter housing.The oil filter outlet pressure sensor is located on the left-bank of the engine at the free end, and is mounted out-board on the end end of the oil filter housing, adjacent to the oil temperature sensor.The CM700 is located within the OEM control panel.

Refer to the original equipment manufacturer (OEM) service documentation.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position

Conditions for Setting the Fault Codes

The ECM detects that the engine oil filter differential pressure is greater than 152 Kpa [22 psig] for 3 seconds. The default settings for this fault code are 152 Kpa [22 psig] and 3 seconds, but the differential pressure and persistence time may have different settings for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 3491 will also shown as ACTIVE by INSITE™ electronic service tool and on the OEM control panel human machine interface display.
  • The CM700 will initiate a Normal Engine Shutdown.

Conditions for Clearing the Fault Code

  • To validate the repair. start the engine and let it operate at rated speed for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the oil pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors, open and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 3491, check for multiple fault codes.

Possible causes of this fault code include:

  • Plugged oil filters.
  • Plugged oil filter head.
  • Open return circuit in the harness, connectors or sensor.
  • A signal circuit shorted to sensor supply or battery voltage.

Premature plugging of the oil filters must be investigated prior to changing the oil filters and restarting the engine, otherwise serious engine damage can occur.

Refer to Troubleshooting Fault Code t05-3491.

Last Modified: 22-Jul-2013


Sensor Supply Circuit Number 1 - Shorted Low

FAULT CODE 352

Sensor Supply Circuit Number 1 - Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 1 - Shorted Low

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 1079 FMI: 4 LAMP: Warning SRT: | Sensor supply number 1 supply signal is shorted high. | Possible reduced engine performance or shutdown.
Sensor Supply Circuit Number 1

Circuit Description

Sensor supply circuit number 1 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires may cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-352

Last Modified: 31-Oct-2011


Intake Manifold Pressure Sensor Circuit — Shorted High

FAULT CODE 354

Intake Manifold Pressure Sensor Circuit — Shorted High

Printable Version Printable Version

Overview

Intake Manifold Pressure Sensor Circuit — Shorted High

CODE | REASON | EFFECT
Fault Code: 354 PID: P106 SPN: 106 FMI: 3 LAMP: Shutdown SRT: | High voltage detected on the Intake Manifold Pressure Sensor signal pin of the main harness CM558 connector. | The engine will shutdown.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The Intake Manifold Pressure Sensor monitors the absolute pressure of the air-to-fuel mixture in the intake manifold. This pressure is monitored by the CM558. High voltage will cause Fault Code 354 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold pressure is required for engine control. The engine will shutdown if the sensor fails.

Refer to Troubleshooting Fault Code t05-354

Last Modified: 27-Oct-2011


Intake Manifold Pressure Sensor Circuit — Shorted Low

FAULT CODE 355

Intake Manifold Pressure Sensor Circuit — Shorted Low

Printable Version Printable Version

Overview

Intake Manifold Pressure Sensor Circuit — Shorted Low

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: 106 FMI: 4 LAMP: Shutdown SRT: | Low voltage detected on the Intake Manifold Pressure Sensor signal pin of the main harness CM558 connector. | The engine will shutdown.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The Intake Manifold Pressure Sensor monitors the absolute pressure of the air-to-fuel mixture in the intake manifold. This pressure is monitored by the CM558. Low voltage will cause Fault Code 355 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold pressure is required for engine control. The engine will shutdown if the sensor fails.

Refer to Troubleshooting Fault Code t05-355

Last Modified: 27-Oct-2011


Engine Failed to Start

FAULT CODE 359

Engine Failed to Start

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 359 PID: 124 SPN: 1664 FMI: 31 LAMP: Shutdown SRT: | Engine failed to start. The engine has not started after completing the starting cycle. | The engine will shutdown.
Engine Failed to Start.

Circuit Description

The starter is commanded to run by the CM700 module, which receives a command from the generator set control panel. If the engine performs a complete start cycle of cranking and purge attempts without the engine starting, the Failed to Start fault will be set.

Depending on the specific engine model, relays K3 or K4 is commanded to close by the CM700. The relay sends 24 VDC to the starter solenoid to engage the starter.

Component Location

The starter motor and starter solenoid is located on the left-bank at the flywheel end of the engine.

The CM700 module and asscoiated starter circuit relays are located in the generator control panels

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine control module (ECM) keyswitch is in the ON position and the engine begins a Start cycle.

Conditions for Setting the Fault Codes

The ECM monitors the engine start cycles and has detected that the engine has failed to start after completing the preset number of start attempts. The default number of start attempts is four, but this value may have a different setting for specific CM700 software versions and engine applications

Action Taken When the Fault Code is Active

The CM700 module illuminates the red ALARM SHUTDOWN lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault Code 359 will also be shown as ACTIVE by INSITE™ electronic service tool and on the OEM control panel display.

Conditions for Clearing the Fault Code

  • To validate the repair. perform and ECM keyswitch cycle, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM700 will turn off the red ALARM SHUTDOWN lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine has failed to start on completion of the preset number of start attempts. Reference the Engine Difficult to Start or Will Not Start troubleshooting symptom tree (t045) in Section TS of the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 402131.

A fault in the original equipment manufacturer (OEM) supplied balance-of-plant equipment can also cause the engine to Fail to Start and Fault Code 359 to be activated. This equipment must be inspected when troubleshooting this fault code. OEM equipment must be installed and operating to manufacturer's specification and must be suitable for the application. See equipment manufacturer service information guides, service manuals, and wiring diagrams.

OEM supplied equipment includes (but not limited to):

  • Gas pressure regulator
  • Gas system valve proving module
  • Gas supply double solenoid shutoff valve
  • Gas filter
  • Gas supply lines.

Possible causes of Fault Code 359 being activated includes (but not limited to):

  • Gas supply isolated (manual shutoff valve closed)
  • Double solenoid shutoff valve malfunction (valves not opening)
  • Blocked gas supply filter
  • Air leaks into gas supply line (usually associated with landfill gas supply systems).
Refer to Troubleshooting Fault Code t05-359.

Last Modified: 05-Feb-2015


Fault Code Path Selection

FAULT CODE 3594
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger with Integrated Throttle? | Go to 55-fc3594st
Is this engine equipped with a Multiple Turbocharger with Integrated Throttle? | Go to 55-fc3594mt

Last Modified: 03-Apr-2012


Engine Emissions Closed Loop Fueling (Limit) – Condition Exists

FAULT CODE 3594 - Multiple Turbochargers with Integrated Throttle

Engine Emissions Closed Loop Fueling (Limit) – Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3594 PID: SPN: 520485 FMI: 31 LAMP: Warning SRT: | Engine Emissions Closed Loop Fueling (Limit) - Condition Exists. The engine closed loop fueling control has reached the limit of adjustment within the calibration. | The engine will continue to run but performance may be impaired.
QSV91G with Multiple Turbochargers Generator Sets with Integrated Throttle, PowerCommand™ Supervisor 3100 Control and Generator Interface Box (GIB) - Fuel Control Circuit
QSV91G with Multiple Turbochargers Generator Sets with Integrated Throttle and PowerCommand™ Controller 3300 Control - Fuel Control Circuit

Circuit Description

Engine fueling control is managed by the left-bank CM558 module. The fueling map is part of the CM558 calibration and is specific to the engine rating, application and exhaust emissions specification. The range of adjustment or fueling compensation available within the fuel map is limited, but is designed to provide a wide-range of fueling compensation in response to varying inputs, including fuel quality (lower heating value kg/N.m³).

The CM558 controls the fueling based on a number of engine sensor inputs, which are:

Open and Closed-Loop Fueling

  • Engine speed (RPM)
  • Coolant temperature (high temperature circuit)
  • Intake manifold temperature(IMT)
  • Intake manifold pressure (IMP)
  • Fuel inlet pressure (FIP)
  • Fuel outlet pressure (FOP)
  • Gas mass flow (GMF)
  • Fuel control valve position % (FCV)

Closed-Loop Fueling

  • Torque-over-boost

Torque-over-boost is a method of calculating the engines actual air/fuel ratio (measured) for a given operating condition and the key inputs are generator kilowatts (KW = torque) and intake manifold pressure (boost).

From all of these inputs, the CM558 can calculate the "desired gas flow" (used for open-loop fueling) and the "desired air/fuel ratio" (used for closed-loop fueling). The CM558 then compares the "measured gas flow" and the "measured air/fuel ratio" and adjusts the FCV accordingly in order to make the necessary fueling adjustment required to maintain the specified exhaust emissions.

Engines will operate using open-loop fueling control at low intake manifold pressures and will switch to closed-loop fueling control when the pressure measured in the intake manifold exceeds 15psia.

In generator sets fitted with a generator interface box (GIB), the kilowatt load is taken directly from the generator set controller (PowerCommand™ Supervisor 3100 Control Panel or PowerCommand™ Controller 3300 Control Panel).

The CM700 module communicates any fueling related information to the left-bank CM558 module over the proprietary data link circuit.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Once the engines fueling has been adjusted and set, the CM558 will work to maintain the desired fueling to achieve the required exhaust emissions, while maintaining engine stability and response.

If the sensors used for fueling control and the fuel remain within specification (fuel lower heating value (LHV) ±4%), then the fueling and exhaust emissions will be maintained across a wide range of operating conditions. The fueling and emissions can begin to drift out-of-specification if one or more of the input sensors or the fuel quality begins to deviate outside of its specification. The CM558 module can, up to a limit, compensate for these deviations. However, if the sensor condition or fuel quality continues to deteriorate, then the CM558 module will eventually reach the limit of adjustment within the fuel map and engine performance will be compromised. When this limit of adjustment is reached, Fault Code 3594 will be activated.

Auxiliary equipment within the overall power plant system, such as selective catalyst reduction (SCR) systems, can also have an effect on engine fueling and will be needed to be considered when investigating Fault Code 3594 - for example, if the catalyst medium (bricks) within the SCR becomes blocked. The causes of SCR malfunction will need to be investigated using the relevant service literature supplied with the equipment.

Note: Fault finding of auxiliary equipment, such as selective catalyst reduction (SCR) systems are outside of the scope of this document.

The most likely cause for this fault is that one of the sensors used for fuel control has malfunctioned or has a poor connection. It should be remembered that sensors can malfunction ‘in-range’ which will not activate their respective fault codes. The generator set kilowatt load signal to the CM700 may also be inaccurate and will cause incorrect fueling. Fuel quality will also need to be considered and checked.

The following table, which can be used as an aid when checking the fuel control valve operation, provides actuator commanded position, pulse width modulation (PWM) percent duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 – 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

Note: Pulse width modulation (PWM) percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3594mt.

Last Modified: 12-Feb-2012


Engine Emissions Closed Loop Fueling (Limit) - Condition Exists

FAULT CODE 3594 - Single Turbocharger with Integrated Throttle

Engine Emissions Closed Loop Fueling (Limit) - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3594 PID: SPN: SPN FMI: 12 LAMP: Warning SRT: | Engine Emissions Closed Loop Fueling (Limit) - Condition Exists. The engine closed loop fueling control has reached the limit of adjustment within the calibration. | The engine will continue to run but performance may be impaired.
QSV91G with Single Turbocharger Generator Sets with Integrated Throttle, PowerCommand™ Supervisor 3100 Control and Generator Interface Box (GIB) - Fuel Control Circuit
QSV91G with Single Turbocharger Generator Sets with Integrated Throttle and PowerCommand™ Controller 3300 Control - Fuel Control Circuit
QSV91G Low Btu with Single Turbocharger Generator Sets with Integrated Throttle and PowerCommand™ Controller 3300 Control - Fuel Control Circuit

Circuit Description

Engine fueling control is managed by the left-bank CM558 module. The fueling map is part of the CM558 calibration and is specific to the engine rating, application and exhaust emissions specification. The range of adjustment or fueling compensation available within the fuel map is limited, but is designed to provide a wide-range of fueling compensation in response to varying inputs, including fuel quality (lower heating value kg/N.m³).

The CM558 controls the fueling based on a number of engine sensor inputs, which are:

Open and Closed-Loop fueling

  • Engine speed (RPM)
  • Coolant temperature (high temperature circuit)
  • Intake manifold temperature(IMT)
  • Intake manifold pressure (IMP)
  • Fuel inlet pressure (FIP)
  • Fuel outlet pressure (FOP)
  • Gas mass flow (GMF)
  • Fuel control valve (FCV) position percent

Closed-Loop Fueling

  • Torque-over-boost

Torque-over-boost is a method of calculating the engine's actual air/fuel ratio (measured) for a given operating condition and the key inputs are generator kilowatts (KW = torque) and intake manifold pressure (boost).

From all of these inputs, the CM558 can calculate the "desired gas fow" (used for open-loop) and the ‘desired air/fuel ratio’ (used for closed-loop). The CM558 then compares the ‘measured gas flow" and the ‘measured air/fuel ratio"a nd adjusts the FCV accordingly in order to make the necessary adjustment required to maintain the specified exhaust emissions.

Engines will operate using ‘open-loop’ fueling control at low intake manifold pressures and will switch to closed-loop fueling control when the pressure measured in the intake manifold exceeds 15psia.

In generator sets fitted with a generator interface box (GIB), the kilowatt load is taken directly from the generator set controller (PowerCommand™ Supervisor 3100 Control Panel or PowerCommand™ Controller 3300 Control Panel).

The CM700 module communicates any related information to the left-bank CM558 module over the proprietary data link circuit.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Once the engine's fueling has been adjusted and set, the CM558 will work to maintain the desired fueling to achieve the required exhaust emissions, while maintaining engine stability and response.

If the sensors used for fueling control and the fuel remain within specification (fuel lower heating value (LHV) ±4%), then the fueling and exhaust emissions will be maintained across a wide range of operating conditions. The fueling and emissions can begin to drift out-of-specification if one or more of the input sensors or the fuel quality begins to deviate outside of its specification. The CM558 module can, up to a limit, compensate for these deviations. However, if the sensor condition or fuel quality continues to deteriorate, then the CM558 module will eventually reach the limit of adjustment within the fuel map and engine performance will be compromised. When this limit of adjustment is reached, Fault Code 3594 will be activated.

Auxiliary equipment within the overall power plant system, such as selective catalyst reduction (SCR) systems, can also have an effect on engine fueling and will be need to be considered when investigating Fault Code 3594 - for example, if the catalyst medium (bricks) within the SCR becomes blocked. The causes of SCR malfunction will need to be investigated using the relevant service literature supplied with the equipment.

Note: Fault finding of auxiliary equipment, such as Selective Catalyst Reduction systems, are outside of the scope of this document.

The most likely cause for this fault is that one of the sensors used for fuel control has malfunctioned or has a poor connection. It should be remembered that sensors can fail ‘in-range’ which will not activate their respective fault codes. The generator set kilowatt load signal to the CM700 may also be inaccurate and will cause incorrect fueling. Fuel quality will also need to be considered and checked.

The following table, which can be used as an aid when checking the FCV operation, provides actuator commanded position pulse wdth modulation (PWM) duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 – 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

Note: PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3594st.

Last Modified: 19-Feb-2012


Fault Code Path Selection

FAULT CODE 3595
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger with Integrated Throttle? | Go to 55-fc3595st
Is this engine equipped with a Multiple Turbocharger with Integrated Throttle? | Go to 55-fc3595mt

Last Modified: 03-Apr-2012


Engine Emissions Closed Loop Fueling (Limit) - Root Cause Not Known

FAULT CODE 3595 - Multiple Turbochargers with Integrated Throttle

Engine Emissions Closed Loop Fueling (Limit) - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3595 PID: SPN: 520485 FMI: 11 LAMP: Shutdown SRT: | Engine Emissions Closed Loop Fueling (Limit) - Root Cause Not Known. The engine closed loop fueling control has reached the limit of adjustment within the calibration. | The engine will shut down.
QSV91G with Multiple Turbochargers Generator Sets with Integrated Throttle, PowerCommand™ Supervisor 3100 Control and Generator Interface Box (GIB) - Fuel Control Circuit
QSV91G with Multiple Turbochargers Generator Sets with Integrated Throttle and PowerCommand™ Controller 3300 Control - Fuel Control Circuit

Circuit Description

Engine fueling control is managed by the left-bank CM558 module. The fueling map is part of the CM558 calibration and is specific to the engine rating, application and exhaust emissions specification. The range of adjustment or fueling compensation available within the fuel map is limited, but is designed to provide a wide-range of fueling compensation in response to varying inputs, including fuel quality (lower heating value kg/N.m³).

The CM558 controls the fueling based on a number of engine sensor inputs, which are:

Open and Closed-Loop Fueling

  • Engine speed (RPM)
  • Coolant temperature (high temperature circuit)
  • Intake manifold temperature (IMT)
  • Intake manifold pressure (IMP)
  • Fuel inlet pressure (FIP)
  • Fuel outlet pressure (FOP)
  • Gas mass flow (GMF)
  • Fuel control valve (FCV) position percent

Closed-Loop Fueling

  • Torque-over-boost

Torque-over-boost is a method of calculating the engines actual air/fuel ratio (measured) for a given operating condition and the key inputs are generator kilowatts (KW = torque) and intake manifold pressure (boost).

From all of these inputs, the CM558 can calculate the "desired gas flow": (used for open-loop fueling) and the "desired air/fuel ratio" (used for closed-loop fueling). The CM558 then compares the "measured gas flow" and the "measured air/fuel ratio" and adjusts the fuel control valve accordingly in order to make the necessary fueling adjustment required to maintain the specified exhaust emissions.

Engines will operate using ‘open-loop’ fueling control at low intake manifold pressures and will switch to closed-loop fueling control when the pressure measured in the intake manifold exceeds 15 psia.

In generator sets fitted with a generator interface box (GIB), the kilowatt load is taken directly from the generator set controller (PowerCommand™ Supervisor 3100 Control Panel or PowerCommand™ Controller 3300 Control Panel).

The CM700 module communicates any fueling related information to the left-bank CM558 module over the proprietary data link circuit.

Component Location

Reference engine diagrams in Section E of this manual for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Once the engine's fueling has been adjusted and set, the CM558 will work to maintain the desired fueling to achieve the required exhaust emissions, while maintaining engine stability and response.

If the sensors used for fueling control and the fuel remain within specification (fuel lower heating value (LHV) ±4%), then the fueling and exhaust emissions will be maintained across a wide range of operating conditions. The fueling and emissions can begin to drift out-of-specification if one or more of the input sensors or the fuel quality begins to deviate outside of its specification. The CM558 module can, up to a limit, compensate for these deviations. However, if the sensor condition or fuel quality continues to deteriorate, then the CM558 module will eventually reach the limit of adjustment within the fuel map and engine performance will be compromised. When this limit of adjustment is reached, Fault Code 3595 will be activated.

Auxiliary equipment within the overall power plant system, such as selective catalyst reduction (SCR) systems, can also have an effect on engine fueling and will be needed to be considered when investigating Fault Code 3595 - for example, if the catalyst medium (bricks) within the SCR becomes blocked. The causes of SCR malfunction will need to be investigated using the relevant service literature supplied with the equipment.

Note: Fault finding of auxiliary equipment, such as selective catalyst reduction systems, are outside of the scope of this document.

The most likely cause for this fault is that one of the sensors used for fuel control has failed or has a poor connection. It should be remembered that sensors can fail ‘in-range’ which will not activate their respective fault codes. The generator set kilowatt load signal to the CM700 may also be inaccurate and will cause incorrect fueling. Fuel quality will also need to be considered and checked.

The following table, which can be used as an aid when checking the fuel control valve operation, provides actuator commanded position pulse width modulated (PWM) percent duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 - 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

Note: PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3595mt.

Last Modified: 19-Feb-2012


Engine Emissions Closed Loop Fueling (Limit) – Root Cause Unknown

FAULT CODE 3595 - Single Turbocharger with Integrated Throttle

Engine Emissions Closed Loop Fueling (Limit) – Root Cause Unknown

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3595 PID: S254 SPN: 520485 FMI: 11 LAMP: Shutdown SRT: | Engine Emissions Closed Loop Fueling (Limit) – Root Cause Unknown. The engine closed loop fueling control has reached the limit of adjustment within the calibration. | The engine will shut down.
QSV91G with Single Turbocharger Generator Sets with Integrated Throttle, PowerCommand™ Supervisor 3100 Control and Generator Interface Box (GIB) - Fuel Control Circuit
QSV91G with Single Turbocharger Generator Sets with Integrated Throttle and PowerCommand™ Controller 3300 Control - Fuel Control Circuit
QSV91G Low Btu with Single Turbocharger Generator Sets with Integrated Throttle and PowerCommand™ Controller 3300 Control - Fuel Control Circuit

Circuit Description

Engine fueling control is managed by the left-bank CM558 module. The fueling map is part of the CM558 calibration and is specific to the engine rating, application and exhaust emissions specification. The range of adjustment or fueling compensation available within the fuel map is limited, but is designed to provide a wide-range of fueling compensation in response to varying inputs, including fuel quality (lower heating value kg/N.m³).

The CM558 controls the fueling based on a number of engine sensor inputs, which are:

Open and Closed-Loop fueling

  • Engine speed (RPM)
  • Coolant temperature (high temperature circuit)
  • Intake manifold temperature (IMT)
  • Intake manifold pressure (IMP)
  • Fuel inlet pressure (FIP)
  • Fuel outlet pressure (FOP)
  • Gas mass flow (GMF)
  • Fuel control valve (FCV) position percent

Closed-Loop Fueling

  • Torque-over-boost

Torque-over-boost is a method of calculating the engine's actual air/fuel ratio (measured) for a given operating condition and the key inputs are generator kilowatts (KW = torque) and intake manifold pressure (boost).

From all of these inputs, the CM558 can calculate the "desired gas flow" (used for open-loop), and the "desired air/fuel ratio" (used for closed-loop). The CM558 then compares the "measured gas flow" and the "measured air/fuel ratio" and adjusts the fuel control valve accordingly in order to make the necessary fueling adjustment required to maintain the specified exhaust emissions.

Engines will operate using ‘open-loop’ control at low intake manifold pressures and will switch to closed-loop control when the pressure measured in the intake manifold exceeds 15 psia.

In generator sets fitted with a generator interface box (GIB), the kilowatt load is taken directly from the generator set controller (PowerCommand™ Supervisor 3100 Control Panel or PowerCommand™ Controller 3300 Control Panel).

The CM700 module communicates any related information to the left-bank CM558 module over the proprietary data link circuit.

Component Location

Reference the engine diagrams in Section E of this manual for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Once the engine has been adjusted and set, the CM558 will work to maintain the desired fueling to achieve the required exhaust emissions, while maintaining engine stability and response.

If the sensors used for control and the fuel remain within specification (fuel lower heating value (LHV) ±4%), then the exhaust emissions will be maintained across a wide range of operating conditions. The emissions can begin to drift out-of-specification if one or more of the input sensors or the fuel quality begins to deviate outside of its specification. The CM558 module can, up to a limit, compensate for these deviations. However, if the sensor condition or fuel quality continues to deteriorate, then the CM558 module will eventually reach the limit of adjustment within the fuel map and engine performance will be compromised. When this limit of adjustment is reached, Fault Code 3594 will be activated.

Auxiliary equipment within the overall power plant system, such as selective catalyst reduction (SCR) systems, can also have an effect on engine and will be needed to be considered when investigating Fault Code 3595 - for example, if the catalyst medium (bricks) within the SCR becomes blocked. The causes of SCR malfunction will need to be investigated using the relevant service literature supplied with the equipment.

Note: Fault finding of auxiliary equipment, such as selective catalyst reduction systems, are outside of the scope of this document.

The most likely cause for this fault is that one of the sensors used for fuel control has failed or has a poor connection. It should be remembered that sensors can fail ‘in-range’ which will not activate their respective fault codes. The generator set kilowatt load signal to the CM700 may also be inaccurate and will cause incorrect fueling. Fuel quality will also need to be considered and checked.

The following table, which can be used as an aid when checking the fuel control valve operation, provides actuator commanded position, pulse width modulated (PWM) percent duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 - 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

Note: PWM duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3595st.

Last Modified: 17-Feb-2012


Sensor Supply Circuit Number 1 - Shorted High

FAULT CODE 386

Sensor Supply Circuit Number 1 - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 1 - Shorted High

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 1079 FMI: 3 LAMP: Warning SRT: | Sensor supply number 1 supply signal is shorted high. | Possible reduced engine performance or shutdown.
Sensor Supply Circuit Number 1

Circuit Description

Sensor Supply Circuit Number 1 from the electronic control module (ECM) supplies multiple engine pressure sensors with a positive (+) 5 VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires may cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Reference the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A failed pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-386

Last Modified: 31-Oct-2011


Low Voltage Ride Through - Bad Intelligent Device or Component

FAULT CODE 3869

Low Voltage Ride Through - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3869 PID: SPN: 520527 FMI: 12 LAMP: Warning SRT: | Low Voltage Ride Through - Bad Intelligent Device or Component. Low voltage ride through detection in the generator set controller is in error or not available. | The engine will continue to run.
QSV91G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. Low voltage ride through (LVRT) related information is relayed from the PCC3300 to the CM700 module ECM over the J1939 data link.

Component Location

Reference Procedure 100-002 in Section E of this manual for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Low voltage ride through (LVRT) relates to grid code compliance and is mainly enforced within Europe, but low voltage ride through (LVRT) is expected to be adopted in some form by other countries. Within the European Union, low voltage ride through (LVRT) compliance will be mandatory from 2014.

Low voltage ride through (LVRT) applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500 ms (milliseconds), after which the generator set can be disconnected from the utility.

Note: Low voltage ride through (LVRT) system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For generator set control system troubleshooting guidance, refer to the appropriate Generator Set Controller Service Manual:

  • For Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670.
Refer to Troubleshooting Fault Code t05-3869.

Last Modified: 19-Feb-2012


Low Voltage Ride Through - Abnormal Update Rate

FAULT CODE 3871

Low Voltage Ride Through - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3871 PID: SPN: 520527 FMI: 9 LAMP: Warning SRT: | Low Voltage Ride Through - Abnormal Update Rate. Receiving low voltage ride through information over data link lost or intermittent. | The engine will continue to run.
QSV91G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

LVRT relates to grid code compliance and is mainly enforced within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500 ms (milliseconds), after which the generator set can be disconnected from the utility

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670.
Refer to Troubleshooting Fault Code t05-3871.

Last Modified: 30-Jan-2012


Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3872

Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3872 PID: SPN: 520527 FMI: 2 LAMP: Warning SRT: | Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect. Receiving low voltage ride through information over data link is erratic, intermittent, or incorrect. | The engine will continue to run.
QSV91G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

LVRT relates to grid code compliance and is mainly ienforced within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500 ms (milliseconds), after which the generator set can be disconnected from the utility.

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual, Bulletin 0900-0670.
Refer to Troubleshooting Fault Code t05-3872.

Last Modified: 30-Jan-2012


Low Voltage Ride Through - Abnormal Frequency, Pulse Width, or Period

FAULT CODE 3873

Low Voltage Ride Through - Abnormal Frequency, Pulse Width, or Period

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3873 PID: SPN: 520527 FMI: 8 LAMP: Warning SRT: | Low Voltage Ride Through - Abnormal Frequency, Pulse Width, or Period. Receiving low voltage ride through information over data link lost or intermittent. | The engine will stop.
QSV91G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

LVRT relates to grid code compliance and is mainly enforced within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500 ms (milliseconds), after which the generator set can be disconnected from the utility

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670.

Activation of this fault code could indicate that a high number of grid faults were/are present, which could occur in regions which have an unstable utility grid system.

Refer to Troubleshooting Fault Code t05-3873.

Last Modified: 30-Jan-2012


Low Voltage Ride Through - Root Cause Not Known

FAULT CODE 3874

Low Voltage Ride Through - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3874 PID: SPN: 520527 FMI: 11 LAMP: Warning SRT: | Low Voltage Ride Through - Root Cause Not Known. Receiving low voltage ride through information over data link lost or intermittent. | The engine will continue to run.
QSV91G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

LVRT relates to grid code compliance and is mainly enforced within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500 ms (milliseconds), after which the generator set can be disconnected from the utility

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670.

Activation of this fault code could indicate a fault in the generator set PCC3300 controller or an intermittent short in the generator set harness.

Refer to Troubleshooting Fault Code t05-3874.

Last Modified: 30-Jan-2012


Low Voltage Ride Through - Condition Exists

FAULT CODE 3875

Low Voltage Ride Through - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3875 PID: SPN: 520527 FMI: 31 LAMP: Warning SRT: | Low Voltage Ride Through - Condition Exists. Receiving low voltage ride through information over data link lost or intermittent. | The engine will continue to run.
QSV91G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

LVRT relates to grid code compliance and is mainly enforced within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500 ms (milliseconds), after which the generator set can be disconnected from the utility

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670.

Activation of this fault code indicates that a grid related fault has occurred, which the LVRT system has detected, and the generator set has remained connected to the grid.

Refer to Troubleshooting Fault Code t05-3875.

Last Modified: 30-Jan-2012


SAE J1587/J1922 Datalink - Data Erratic, Intermittent, or Incorrect

FAULT CODE 412

SAE J1587/J1922 Datalink - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

SAE J1587/J1922 Datalink - Data Erratic, Intermittent, or Incorrect

CODE | REASON | EFFECT
Fault Code: 412 PID: SPN: 608 FMI: 2 LAMP: None SRT: | The ECM has detected the J1587/1922 datalink is erratic, intermittent, or incorrect. | None on performance.
J1587 Data Link Circuit - Single Turbocharger
J1587 Data Link Circuit - Multiple Turbocharger with Two-piece Throttle
J1587 Data Link Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The J1587/1922 datalink is a public datalink that broadcasts engine operating data as well as fault codes.

Component Location

The J1587/1922 datalink is located in the engine wiring harness between the ECM and the datalink connectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected that the J1587/1992 datalink communication is erratic.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
  • Damaged or loose connector.
Refer to Troubleshooting Fault Code t05-412

Last Modified: 18-Apr-2022


SAE J1587/J1922 Datalink - Abnormal Update Rate

FAULT CODE 414

SAE J1587/J1922 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

SAE J1587/J1922 Datalink - Abnormal Update Rate

CODE | REASON | EFFECT
Fault Code: 414 PID: SPN: 608 FMI: 9 LAMP: None SRT: | An abnormal update rate was detected on the J1587/1922 datalink. | None on performance.
J1587 Data Link Circuit - Single Turbocharger
J1587 Data Link Circuit - Multiple Turbocharger with Two-piece Throttle
J1587 Data Link Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The J1587/1922 datalink is a public datalink that broadcasts engine operating data as well as fault codes.

Component Location

The J1587/1922 datalink is located in the engine wiring harness between the ECM and the datalink connectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected the J1587/1992 datalink communication is abnormal.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-414

Last Modified: 18-Apr-2022


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 415 PID: 100 SPN: 100 FMI: 1 LAMP: Stop/Shutdown SRT: | Engine oil pressure is above the critical limit. | The engine will shut down.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The engine oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil pressure was less than the critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil pressure sensor.
  • Damaged or loose connectors.
  • Incorrect oil level.
  • Low oil pressure.
Refer to Troubleshooting Fault Code t05-415

Last Modified: 29-Apr-2022


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 421 PID: 175 SPN: 175 FMI: 16 LAMP: Warning SRT: | The oil temperature has exceeded the engine protection warning limit. | No effect on engine performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The controller monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. When the oil temperature is warm, the sensor resistance is low.

Component Location

The oil temperature sensor is located on the lubricating oil cooler housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature is above engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged oil temperature sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-421

Last Modified: 17-May-2022


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

CODE | REASON | EFFECT
Fault Code: 426 PID: SPN: 639 FMI: 2 LAMP: None SRT: | The ECM has detected the J1939 datalink is erratic, intermittent, or incorrect. | None on performance.
J1939 Datalink Circuit - Multiple Turbocharger with a Two-piece Throttle

Circuit Description

The J1939 datalink is a public datalink that broadcasts engine operating data as well as fault codes.

Component Location

The J1939 datalink wiring and the J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected that the J1939 datalink communication is erratic.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:.

  • Malfunctioning or damaged J1939 datalink wiring harness.
  • Communication failure between J1939 devices.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-426

Last Modified: 12-Apr-2022


SAE J1939 Datalink - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

SAE J1939 Datalink - Abnormal Update Rate

CODE | REASON | EFFECT
Fault Code: 427 PID: SPN: 639 FMI: 9 LAMP: None SRT: | An abnormal update rate detected on the J1939 datalink. | No effect on engine performance.
J1939 Datalink Circuit - Multiple Turbocharger with Two-piece Throttle

Circuit Description

The J1939 datalink is a public datalink that broadcasts engine operating data as well as fault codes.

Component Location

The J1939 datalink wiring and the J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged J1939 datalink wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
Refer to Troubleshooting Fault Code t05-427

Last Modified: 12-Apr-2022


Fault Code Path Selection

FAULT CODE 441
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc441st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc441mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc441mt

Last Modified: 24-Sep-2004


Battery Supply Circuit - Low

FAULT CODE 441 - Multiple Turbocharger with Integrated Throttle

Battery Supply Circuit - Low

Printable Version Printable Version

Overview

Battery Supply Circuit - Low

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Warning SRT: | Low voltage has been detected on the battery supply. | ECM voltage supply approaching a level at which unpredictable operation will occur.
Battery Supply Circuit

Circuit Description

The 24 VDC battery circuit provides operating power to the CM700, CM558s, CENSE™ module and the Fuel Control Valve. This supply is provided by a 20A DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

This fault is usually caused by loose or corroded connections, a blown fuse or a tripped circuit breaker.

Refer to Troubleshooting Fault Code t05-441mt

Last Modified: 27-Oct-2011


Battery Supply Circuit - Low

FAULT CODE 441 - Multiple Turbocharger with a Two-piece Throttle

Battery Supply Circuit - Low

Printable Version Printable Version

Overview

Battery Supply Circuit - Low

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Warning SRT: | Low voltage has been detected on the battery supply. | ECM voltage supply approaching a level at which unpredictable operation will occur.
Battery Supply Circuit

Circuit Description

The 24 VDC battery circuit provides operating power to the CM700, CM558s, CENSE™ module and the Fuel Control Valve. This supply is provided by a 20A DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

This fault is usually caused by loose or corroded connections, a blown fuse or a tripped circuit breaker.

Refer to Troubleshooting Fault Code t05-441mttt

Last Modified: 27-Oct-2011


Battery Supply Circuit - Low

FAULT CODE 441 - Single Turbocharger

Battery Supply Circuit - Low

Printable Version Printable Version

Overview

Battery Supply Circuit - Low

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Warning SRT: | Low voltage has been detected on the battery supply. | ECM voltage supply approaching a level at which unpredictable operation will occur.
Battery Supply Circuit

Circuit Description

The 24 VDC battery circuit provides operating power to the CM700, CM558s, CENSE™ module and the Fuel Control Valve. This supply is provided by a 20A DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

This fault is usually caused by loose or corroded connections, a blown fuse or a tripped circuit breaker.

Refer to Troubleshooting Fault Code t05-441st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 442
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc442st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc442mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc442mt

Last Modified: 24-Sep-2004


Battery Supply Circuit - High

FAULT CODE 442 - Multiple Turbocharger with Integrated Throttle

Battery Supply Circuit - High

Printable Version Printable Version

Overview

Battery Supply Circuit - High

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Warning SRT: | High voltage has been detected on the battery. | ECM damage will occur.
Battery Supply Circuit

Circuit Description

The 24 VDC battery circuit provides operating power to the CM700, CM558s, CENSE™ module and the Fuel Control Valve. This supply is provided by a 20A DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-442mt

Last Modified: 27-Oct-2011


Battery Supply Circuit - High

FAULT CODE 442 - Multiple Turbocharger with a Two-piece Throttle

Battery Supply Circuit - High

Printable Version Printable Version

Overview

Battery Supply Circuit - High

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Warning SRT: | High voltage has been detected on the battery. | ECM damage will occur.
Battery Supply Circuit

Circuit Description

The 24 VDC battery circuit provides operating power to the CM700, CM558s, CENSE™ module and the Fuel Control Valve. This supply is provided by a 20A DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-442mttt

Last Modified: 27-Oct-2011


Battery Supply Circuit - High

FAULT CODE 442 - Single Turbocharger

Battery Supply Circuit - High

Printable Version Printable Version

Overview

Battery Supply Circuit - High

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Warning SRT: | High voltage has been detected on the battery. | ECM damage will occur.
Battery Supply Circuit

Circuit Description

The 24 VDC battery circuit provides operating power to the CM700, CM558s, CENSE™ module and the Fuel Control Valve. This supply is provided by a 20A DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-442st

Last Modified: 27-Oct-2011


Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 453

Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 453 PID: 149 SPN: 1241 FMI: 3 LAMP: Warning SRT: | High signal voltage detected at the gas mass flow sensor circuit. | Possible reduced engine performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The gas mass flow sensor is a variable voltage sensor used by the ECM to monitor the mass of the gas flowing to the engine. The gas mass flow sensor has four circuits: 5 volt supply, signal, and two return circuits. The signal circuit voltage indicates the gas mass flowing into the engine.

Component Location

The gas mass flow sensor is located in the gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the gas mass flow signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged gas mass flow sensor.
  • Malfunctioning engine wiring harness.
  • Damaged or loose connector.
Refer to Troubleshooting Fault Code t05-453

Last Modified: 12-Apr-2022


Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 454

Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 454 PID: 149 SPN: 1241 FMI: 4 LAMP: Warning SRT: | Low signal voltage detected at the gas mass flow sensor circuit. | Possible reduced engine performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The gas mass flow sensor is a variable voltage sensor used by the ECM to monitor the mass of the gas flowing to the engine. The gas mass flow sensor has four circuits: 5 volt supply, signal, and two return circuits. The signal circuit voltage indicates the gas mass flowing into the engine.

Component Location

The gas mass flow sensor is located in the gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the gas mass flow signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged gas mass flow sensor.
  • Malfunctioning engine wiring harness.
  • Damaged or loose connector.
Refer to Troubleshooting Fault Code t05-454

Last Modified: 26-Apr-2022


Fault Code Path Selection

FAULT CODE 455
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc455st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc455mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc455mt

Last Modified: 25-Feb-2004


Fuel Control Valve Circuit - Shorted High

FAULT CODE 455 - Multiple Turbocharger with Integrated Throttle

Fuel Control Valve Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Control Valve Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 455 PID: 18 SPN: 633 FMI: 3 LAMP: Shutdown SRT: | High voltage detected on the fuel control valve signal return pin of the main harness CM558 connector. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24 VDC pulse-width modulated signal. A short to battery voltage in the harness or at the fuel control valve connector will cause Fault Code 455 to be set.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 should always read an alternating 24 VDC and 0 VDC.

Refer to Troubleshooting Fault Code t05-455mt

Last Modified: 27-Oct-2011


Fuel Control Valve Circuit - Shorted High

FAULT CODE 455 - Multiple Turbocharger with a Two-piece Throttle

Fuel Control Valve Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Control Valve Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 455 PID: 18 SPN: 633 FMI: 3 LAMP: Shutdown SRT: | High voltage detected on the fuel control valve signal return pin of the main harness CM558 connector. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24 VDC pulse-width modulated signal. A short to battery voltage in the harness or at the fuel control valve connector will cause Fault Code 455 to be set.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 should always read an alternating 24 VDC and 0 VDC.

Refer to Troubleshooting Fault Code t05-455mttt

Last Modified: 27-Oct-2011


Fuel Control Valve Circuit - Shorted High

FAULT CODE 455 - Single Turbocharger

Fuel Control Valve Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Control Valve Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 455 PID: 18 SPN: 633 FMI: 3 LAMP: Shutdown SRT: | High voltage detected on the fuel control valve signal return pin of the main harness CM558 connector. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24 VDC pulse-width modulated signal. A short to battery voltage in the harness or at the fuel control valve connector will cause Fault Code 455 to be set.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 should always read an alternating 24 VDC and 0 VDC.

Refer to Troubleshooting Fault Code t05-455st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 458
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc458st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc458mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc458mt

Last Modified: 03-Mar-2004


Ignition Timing Signal Circuit - Shorted High

FAULT CODE 458 - Multiple Turbocharger with Integrated Throttle

Ignition Timing Signal Circuit - Shorted High

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 458 PID: S067 SPN: 726 FMI: 3 LAMP: Shutdown SRT: | The ignition timing signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | The engine will shut down.
Ignition Timing and Reference Signal Circuit

Circuit Description

The ignition timing signal is a 5 VDC signal. The CM558 drives the ignition timing signal to 0 VDC to create an ignition timing pulse for each cylinder.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the capacitive coil driver to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-458mt

Last Modified: 27-Oct-2011


Ignition Timing Signal Circuit - Shorted High

FAULT CODE 458 - Multiple Turbocharger with a Two-piece Throttle

Ignition Timing Signal Circuit - Shorted High

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 458 PID: S067 SPN: 726 FMI: 3 LAMP: Shutdown SRT: | The ignition timing signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | The engine will shut down.
Ignition Timing and Reference Signal Circuit

Circuit Description

The ignition timing signal is a 5 VDC signal. The CM558 drives the ignition timing signal to 0 VDC to create an ignition timing pulse for each cylinder.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the capacitive coil driver to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-458mttt

Last Modified: 27-Oct-2011


Ignition Timing Signal Circuit - Shorted High

FAULT CODE 458 - Single Turbocharger

Ignition Timing Signal Circuit - Shorted High

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 458 PID: S067 SPN: 726 FMI: 3 LAMP: Shutdown SRT: | The ignition timing signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | The engine will shut down.
Ignition Timing and Reference Signal Circuit

Circuit Description

The ignition timing signal is a 5 VDC signal. The CM558 drives the ignition timing signal to 0 VDC to create an ignition timing pulse for each cylinder.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the capacitive coil driver to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-458st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 459
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc459st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc459mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc459mt

Last Modified: 03-Mar-2004


Ignition Timing Signal Circuit - Shorted Low

FAULT CODE 459 - Multiple Turbocharger with Integrated Throttle

Ignition Timing Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 459 PID: S067 SPN: 726 FMI: 4 LAMP: Shutdown SRT: | The ignition timing signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | The engine will shut down.
Ignition Timing and Reference Signal Circuit

Circuit Description

The ignition timing signal is a 5 VDC signal. The CM558 drives the ignition timing signal to 0 VDC to create an ignition timing pulse for each cylinder.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the CCD to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-459mt

Last Modified: 27-Oct-2011


Ignition Timing Signal Circuit - Shorted Low

FAULT CODE 459 - Multiple Turbocharger with a Two-piece Throttle

Ignition Timing Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 459 PID: S067 SPN: 726 FMI: 4 LAMP: Shutdown SRT: | The ignition timing signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | The engine will shut down.
Ignition Timing and Reference Signal Circuit

Circuit Description

The ignition timing signal is a 5 VDC signal. The CM558 drives the ignition timing signal to 0 VDC to create an ignition timing pulse for each cylinder.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the CCD to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-459mttt

Last Modified: 27-Oct-2011


Ignition Timing Signal Circuit - Shorted Low

FAULT CODE 459 - Single Turbocharger

Ignition Timing Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 459 PID: S067 SPN: 726 FMI: 4 LAMP: Shutdown SRT: | The ignition timing signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | The engine will shut down.
Ignition Timing and Reference Signal Circuit

Circuit Description

The ignition timing signal is a 5 VDC signal. The CM558 drives the ignition timing signal to 0 VDC to create an ignition timing pulse for each cylinder.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the CCD to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-459st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 461
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc461st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc461mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc461mt

Last Modified: 03-Mar-2004


Ignition Reference Signal Circuit - Shorted High

FAULT CODE 461 - Multiple Turbocharger with Integrated Throttle

Ignition Reference Signal Circuit - Shorted High

Printable Version Printable Version

Overview

Ignition Reference Signal Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 461 PID: S066 SPN: 725 FMI: 3 LAMP: Shutdown SRT: | The ignition reference signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | Engine will shut down.
Ignition timing and Reference Signal Circuit

Circuit Description

The ignition reference signal is a 5 VDC signal. The CM558 drives the ignition reference signal to 0 VDC to create pulse to initiate the firing order.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Capacitive Coil Driver (CCD) to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-461mt

Last Modified: 27-Oct-2011


Ignition Reference Signal Circuit - Shorted High

FAULT CODE 461 - Multiple Turbocharger with a Two-piece Throttle

Ignition Reference Signal Circuit - Shorted High

Printable Version Printable Version

Overview

Ignition Reference Signal Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 461 PID: S066 SPN: 725 FMI: 3 LAMP: Shutdown SRT: | The ignition reference signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | Engine will shut down.
Ignition timing and Reference Signal Circuit

Circuit Description

The ignition reference signal is a 5 VDC signal. The CM558 drives the ignition reference signal to 0 VDC to create pulse to initiate the firing order.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Capacitive Coil Driver (CCD) to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-461mttt

Last Modified: 27-Oct-2011


Ignition Reference Signal Circuit - Shorted High

FAULT CODE 461 - Single Turbocharger

Ignition Reference Signal Circuit - Shorted High

Printable Version Printable Version

Overview

Ignition Reference Signal Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 461 PID: S066 SPN: 725 FMI: 3 LAMP: Shutdown SRT: | The ignition reference signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | Engine will shut down.
Ignition timing and Reference Signal Circuit

Circuit Description

The ignition reference signal is a 5 VDC signal. The CM558 drives the ignition reference signal to 0 VDC to create pulse to initiate the firing order.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Capacitive Coil Driver (CCD) to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-461st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 462
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc462st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc462mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc462mt

Last Modified: 03-Mar-2004


Ignition Reference Signal Circuit - Shorted Low

FAULT CODE 462 - Multiple Turbocharger with Integrated Throttle

Ignition Reference Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

Ignition Reference Signal Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 462 PID: S066 SPN: 725 FMI: 4 LAMP: Shutdown SRT: | The ignition reference signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | Engine will shut down.
Ignition timing and Reference Signal Circuit

Circuit Description

The ignition reference signal is a 5 VDC signal. The CM558 drives the ignition reference signal to 0 VDC to create pulse to initiate the firing order.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Capacitive Coil Driver (CCD) to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-462mt

Last Modified: 27-Oct-2011


Ignition Reference Signal Circuit - Shorted Low

FAULT CODE 462 - Multiple Turbocharger with a Two-piece Throttle

Ignition Reference Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

Ignition Reference Signal Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 462 PID: S066 SPN: 725 FMI: 4 LAMP: Shutdown SRT: | The ignition reference signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | Engine will shut down.
Ignition timing and Reference Signal Circuit

Circuit Description

The ignition reference signal is a 5 VDC signal. The CM558 drives the ignition reference signal to 0 VDC to create pulse to initiate the firing order.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Capacitive Coil Driver (CCD) to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-462mttt

Last Modified: 27-Oct-2011


Ignition Reference Signal Circuit - Shorted Low

FAULT CODE 462 - Single Turbocharger

Ignition Reference Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

Ignition Reference Signal Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 462 PID: S066 SPN: 725 FMI: 4 LAMP: Shutdown SRT: | The ignition reference signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | Engine will shut down.
Ignition timing and Reference Signal Circuit

Circuit Description

The ignition reference signal is a 5 VDC signal. The CM558 drives the ignition reference signal to 0 VDC to create pulse to initiate the firing order.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the Capacitive Coil Driver (CCD) to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-462st

Last Modified: 27-Oct-2011


Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P444 SPN: 444 FMI: 1/18 LAMP: Amber SRT: | Low voltage has been detected on the isolated battery supply. | Possible reduced engine performance.
Isolated Battery Power Supply Circuit - Single Turbocharger
Isolated Battery Power Supply Circuit - Multiple Turbocharger with Two-Piece Throttle
Isolated Battery Power Supply Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The isolated battery circuit provides operating power to the capacitive coil drivers. This supply is provided by a DC power supply, which is located at the customer's discretion.

Component Location

The location of the battery will vary with the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected the isolated battery voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting.
  • A weak or damaged battery.
  • Improperly connected batteries.
  • A damaged alternator causing low voltage
Refer to Troubleshooting Fault Code t05-477

Last Modified: 17-Feb-2021


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P444 SPN: 444 FMI: 0/16 LAMP: Amber SRT: | High voltage has been detected on the isolated battery supply. | Possible reduced engine performance.
Isolated Battery Power Supply Circuit - Single Turbocharger
Isolated Battery Power Supply Circuit - Multiple Turbocharger with Two-Piece Throttle
Isolated Battery Power Supply Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The isolated battery circuit provides operating power to the capacitive coil drivers. This supply is provided by a DC power supply, which is located at the customers discretion.

Component Location

The location of the battery will vary with the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected the isolated battery voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting.
  • A damaged alternator causing high voltage.
  • Improperly connected batteries.
  • A weak or damaged battery.
Refer to Troubleshooting Fault Code t05-478

Last Modified: 17-Feb-2021


Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 481

Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 481 PID: 99 SPN: 99 FMI: FMI: 16 LAMP: None SRT: | The engine oil filter restriction has exceeded the engine protection warning limit. | No effect on engine performance.
Post-filter Oil Pressure Sensor Circuit

Circuit Description

The post-filter oil pressure sensor monitors engine oil pressure as it exits the filter. post-filter oil pressure sensor is a variable resistance sensor used by the ECM to monitor the lubricating oil pressure. The post-filter oil pressure sensor has three circuits: 5 volt supply, return, and signal circuits. The signal circuit voltage indicates the engine oil pressure.

Component Location

The post-filter oil pressure sensor is located on the lubricating oil cooler housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the oil pressure was greater than the engine protection warning limit.

Action Taken When the Fault Code is Active

The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and let it run for 1 minute at no load.

The generator set controller will turn off the warning indicator immediately after the user presses reset.

The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged post-filter oil pressure sensor
  • Plugged oil filters
  • Plugged oil filter head
  • Excessive restriction or cold oil
  • Damaged or loose connector.
Refer to Troubleshooting Fault Code t05-481

Last Modified: 17-Mar-2022


Fuel Delivery Pressure Low - Warning

FAULT CODE 482

Fuel Delivery Pressure Low - Warning

Printable Version Printable Version

Overview

Fuel Delivery Pressure Low - Warning

CODE | REASON | EFFECT
Fault Code: 482 PID: P094 SPN: 094 FMI: 18 LAMP: Warning SRT: | The fuel delivery pressure has dropped below the low warning threshold. | Possible reduced engine performance.
Fuel Pressure Sensor Circuit

Circuit Description

The Fuel Delivery Pressure Sensor monitors the engine gas pressure before it enters the fuel control valve. This pressure is monitored by the left bank CM558. High voltage will cause Fault Code 546 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure is the regulated input gas pressure to the engine. It is typically regulated to approximately 150 mBar [2.2 psi].

Fuel delivery pressure will be 0 mBar [0 psi] while the engine is cranking during the purge cycle. Fuel delivery pressure will rise as soon as the fuel shutoff valve opens.

Refer to Troubleshooting Fault Code t05-482

Last Modified: 27-Oct-2011


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 488 PID: 105 SPN: 105 FMI: 16 LAMP: Warning SRT: | The Intake manifold temperature signal has exceeded engine protection warning limit. | Possible reduced engine performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The Intake Manifold Temperature Sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The Intake Manifold Temperature Sensor is used by the ECM for engine protection, timing, and fueling control.

Component Location

The Intake manifold temperature sensor is located on each bank below the charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged intake manifold temperature sensor.
  • Damaged or loose connectors.
  • Restricted air flow through the charge-air cooler.
  • Undersized charge-air cooler.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-488

Last Modified: 29-Apr-2022


Fault Code Path Selection

FAULT CODE 511
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc511st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc511mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc511mt

Last Modified: 25-Feb-2004


Fuel Control Valve Circuit - Shorted Low

FAULT CODE 511 - Multiple Turbocharger with Integrated Throttle

Fuel Control Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Control Valve Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 511 PID: 18 SPN: 633 FMI: 4 LAMP: Shutdown SRT: | Low voltage detected on the fuel control valve signal pin of the main harness CM558 connector. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24 VDC pulse-width modulated signal. An open circuit in the harness or at the fuel control valve connector will cause Fault Code 511 to be set.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 must always read an alternating 24 VDC and 0 VDC.

Refer to Troubleshooting Fault Code t05-511mt

Last Modified: 27-Oct-2011


Fuel Control Valve Circuit - Shorted Low

FAULT CODE 511 - Multiple Turbocharger with a Two-piece Throttle

Fuel Control Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Control Valve Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 511 PID: 18 SPN: 633 FMI: 4 LAMP: Shutdown SRT: | Low voltage detected on the fuel control valve signal pin of the main harness CM558 connector. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24 VDC pulse-width modulated signal. An open circuit in the harness or at the fuel control valve connector will cause Fault Code 511 to be set.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 must always read an alternating 24 VDC and 0 VDC.

Refer to Troubleshooting Fault Code t05-511mttt

Last Modified: 27-Oct-2011


Fuel Control Valve Circuit - Shorted Low

FAULT CODE 511 - Single Turbocharger

Fuel Control Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Control Valve Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 511 PID: 18 SPN: 633 FMI: 4 LAMP: Shutdown SRT: | Low voltage detected on the fuel control valve signal pin of the main harness CM558 connector. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The commanded position signal from the CM558 to the fuel control valve is a 24 VDC pulse-width modulated signal. An open circuit in the harness or at the fuel control valve connector will cause Fault Code 511 to be set.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The pulse-width modulated signal that is sent to the fuel control valve from the CM558 must always read an alternating 24 VDC and 0 VDC.

Refer to Troubleshooting Fault Code t05-511st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 512
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc512st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc512mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc512mt

Last Modified: 29-Mar-2004


Throttle Plate Position Circuit High Error

FAULT CODE 512 - Multiple Turbocharger with Integrated Throttle

Throttle Plate Position Circuit High Error

Printable Version Printable Version

Overview

Throttle Plate Position Circuit High Error

CODE | REASON | EFFECT
Fault Code: 512 PID: 51 SPN: 51 FMI: 3 LAMP: Warning SRT: | High current detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Plate Position Circuit

Circuit Description

The throttle plate position circuit consists of the ProAct™ throttle driver and the CM558. The ProAct™ throttle driver has internal circuitry that provides a 4 to 20 mA throttle position reference to the CM558.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the ProAct™ throttle driver are tight. There are two connections: the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-512mt

Last Modified: 27-Oct-2011


Throttle Plate Position Circuit High Error

FAULT CODE 512 - Multiple Turbocharger with Two-Piece Throttle

Throttle Plate Position Circuit High Error

Printable Version Printable Version

Overview

Throttle Plate Position Circuit High Error

CODE | REASON | EFFECT
Fault Code: 512 PID: 51 SPN: 51 FMI: 3 LAMP: Warning SRT: | High current detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Plate Position Circuit

Circuit Description

The throttle plate position circuit consists of the ProAct™ throttle driver and the CM558. The ProAct™ throttle driver has internal circuitry that provides a 4 to 20 mA throttle position reference to the CM558.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the ProAct™ throttle driver are tight. There are two connections: the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-512mttt

Last Modified: 27-Oct-2011


Throttle Plate Position Circuit High Error

FAULT CODE 512

Throttle Plate Position Circuit High Error

Printable Version Printable Version

Overview

Throttle Plate Position Circuit High Error

CODE | REASON | EFFECT
Fault Code: 512 - Single Turbocharger PID: 51 SPN: 51 FMI: 3 LAMP: Warning SRT: | High current detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Plate Position Circuit

Circuit Description

The throttle plate position circuit consists of the ProAct™ throttle driver and the CM558. The ProAct™ throttle driver has internal circuitry that provides a 4 to 20 mA throttle position reference to the CM558.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the ProAct™ throttle driver are tight. There are two connections: the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-512st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 513
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc513st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc513mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc513mt

Last Modified: 29-Mar-2004


Throttle Plate Position Circuit Low Error

FAULT CODE 513 - Multiple Turbocharger with Integrated Throttle

Throttle Plate Position Circuit Low Error

Printable Version Printable Version

Overview

Throttle Plate Position Circuit Low Error

CODE | REASON | EFFECT
Fault Code: 513 PID: 51 SPN: 51 FMI: 4 LAMP: Warning SRT: | Low current detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Plate Position Circuit

Circuit Description

The throttle plate position circuit consists of the Throttle Driver and the CM558. The Throttle Driver has internal circuitry that provides a 4 to 20 mA throttle position reference to the CM558.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the Throttle Driver are tight. There are three connections: the signal to the throttle actuator, the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-513mt

Last Modified: 27-Oct-2011


Throttle Plate Position Circuit Low Error

FAULT CODE 513 - Multiple Turbocharger with a Two-piece Throttle

Throttle Plate Position Circuit Low Error

Printable Version Printable Version

Overview

Throttle Plate Position Circuit Low Error

CODE | REASON | EFFECT
Fault Code: 513 PID: 51 SPN: 51 FMI: 4 LAMP: Warning SRT: | Low current detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Plate Position Circuit

Circuit Description

The throttle plate position circuit consists of the Throttle Driver and the CM558. The Throttle Driver has internal circuitry that provides a 4 to 20 mA throttle position reference to the CM558.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the Throttle Driver are tight. There are three connections: the signal to the throttle actuator, the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-513mttt

Last Modified: 27-Oct-2011


Throttle Plate Position Circuit Low Error

FAULT CODE 513 - Single Turbocharger

Throttle Plate Position Circuit Low Error

Printable Version Printable Version

Overview

Throttle Plate Position Circuit Low Error

CODE | REASON | EFFECT
Fault Code: 513 PID: 51 SPN: 51 FMI: 4 LAMP: Warning SRT: | Low current detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Plate Position Circuit

Circuit Description

The throttle plate position circuit consists of the Throttle Driver and the CM558. The Throttle Driver has internal circuitry that provides a 4 to 20 mA throttle position reference to the CM558.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the Throttle Driver are tight. There are three connections: the signal to the throttle actuator, the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-513st

Last Modified: 27-Oct-2011


Fault Code Path Selection

FAULT CODE 514
Fault Code Path Selection

Is this engine equipped with a Single Turbocharger? | Go to 55-fc514st
Is this engine equipped with a Multiple Turbocharger with a Two-piece Throttle? | Go to 55-fc514mttt
Is this engine equipped with a Multiple Turbocharger with a Integrated Throttle? | Go to 55-fc514mt

Last Modified: 25-Feb-2004


Fuel Control Valve - Mechanically Stuck

FAULT CODE 514 - Multiple Turbocharger with Integrated Throttle

Fuel Control Valve - Mechanically Stuck

Printable Version Printable Version

Overview

Fuel Control Valve - Mechanically Stuck

CODE | REASON | EFFECT
Fault Code: 514 PID: 18 SPN: 633 FMI: 7 LAMP: Shutdown SRT: | The fuel control valve position feedback is not responding to commands from the ECM. The valve is stuck. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The fuel control valve position circuit consists of the commanded position signal from the CM558 and feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve command position signal is supplied by the CM558. The position signal is a 24 VDC pulse-width modulated signal and the feedback is a 0 to 5 VDC signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel control valve commanded signal and the feedback signal can be monitored using the electronic service tool. The fuel control valve is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the fault for the mechanically stuck valve will be set.

Refer to Troubleshooting Fault Code t05-514mt

Last Modified: 27-Oct-2011


Fuel Control Valve - Mechanically Stuck

FAULT CODE 514 - Multiple Turbocharger with a Two-piece Throttle

Fuel Control Valve - Mechanically Stuck

Printable Version Printable Version

Overview

Fuel Control Valve - Mechanically Stuck

CODE | REASON | EFFECT
Fault Code: 514 PID: 18 SPN: 633 FMI: 7 LAMP: Shutdown SRT: | The fuel control valve position feedback is not responding to commands from the ECM. The valve is stuck. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The fuel control valve position circuit consists of the commanded position signal from the CM558 and feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve command position signal is supplied by the CM558. The position signal is a 24 VDC pulse-width modulated signal and the feedback is a 0 to 5 VDC signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel control valve commanded signal and the feedback signal can be monitored using the electronic service tool. The fuel control valve is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the fault for the mechanically stuck valve will be set.

Refer to Troubleshooting Fault Code t05-514mttt

Last Modified: 27-Oct-2011


Fuel Control Valve - Mechanically Stuck

FAULT CODE 514 - Single Turbocharger

Fuel Control Valve - Mechanically Stuck

Printable Version Printable Version

Overview

Fuel Control Valve - Mechanically Stuck

CODE | REASON | EFFECT
Fault Code: 514 PID: 18 SPN: 633 FMI: 7 LAMP: Shutdown SRT: | The fuel control valve position feedback is not responding to commands from the ECM. The valve is stuck. | The engine will shutdown.
Fuel Control Valve Circuit

Circuit Description

The fuel control valve position circuit consists of the commanded position signal from the CM558 and feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve command position signal is supplied by the CM558. The position signal is a 24 VDC pulse-width modulated signal and the feedback is a 0 to 5 VDC signal.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel control valve commanded signal and the feedback signal can be monitored using the electronic service tool. The fuel control valve is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to ensure that the valve is moving freely.

If the difference between the command position and the feedback position signal is larger than the fault threshold, the fault for the mechanically stuck valve will be set.

Refer to Troubleshooting Fault Code t05-514st

Last Modified: 27-Oct-2011


Fuel Delivery Pressure Sensor Circuit - Shorted High

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Delivery Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 546 PID: P094 SPN: 094 FMI: 3 LAMP: Warning SRT: | High voltage detected on the fuel delivery pressure sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The Fuel Delivery Pressure Sensor monitors the engine gas pressure before it enters the fuel control valve. This pressure is monitored by the left bank CM558. High voltage will cause Fault Code 546 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure is the regulated input gas pressure to the engine. It is typically regulated to approximately 150 mBar [2.2 psi].

Fuel delivery pressure will be 0 mBar [0 psi] while the engine is cranking during the purge cycle. Fuel delivery pressure will rise as soon as the fuel shutoff valve opens.

Refer to Troubleshooting Fault Code t05-546

Last Modified: 27-Oct-2011


Fuel Delivery Pressure Sensor Circuit - Shorted Low

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Delivery Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 547 PID: P094 SPN: 094 FMI: 4 LAMP: Warning SRT: | Low voltage detected on the fuel delivery pressure sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The Fuel Delivery Pressure Sensor monitors the engine gas pressure before it enters the fuel control valve. This pressure is monitored by the left bank CM558. High voltage will cause Fault Code 547 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel delivery pressure is the regulated input gas pressure to the engine. It is typically regulated to approximately 150 mBar [2.2 psi].

Fuel delivery pressure will be 0 mBar [0 psi] while the engine is cranking during the purge cycle. Fuel delivery pressure will rise as soon as the fuel shutoff valve opens.

Refer to Troubleshooting Fault Code t05-547

Last Modified: 27-Oct-2011


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 556 PID: 101 SPN: 94 FMI: 3 LAMP: Warning SRT: | The Engine Control Module has detected crankcase blowby pressure at the engine critical limit. | Engine will shut down.
Crankcase Blowby Pressure Sensor Circuit - Multiple Turbocharger with Two-Piece Throttle
Crankcase Blowby Pressure Sensor Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The crankcase blowby pressure sensor monitors the pressure in the crankcase as a result of combustion gas getting past the piston rings. This information is monitored by the CENSE™ module, which passes it on to the engine control mondule across the J1939 datalink.

Component Location

The crankcase blowby pressure sensor is located near the crankcase breather on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the crankcase blowby pressure is greater than the critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged crankcase blowby pressure sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
  • Restricted crankcase breather filter plugged.
  • Internal engine damage.
Refer to Troubleshooting Fault Code t05-556

Last Modified: 26-Apr-2022


Detonation (Knock) Detected in Cylinder Number 1

FAULT CODE 561

Detonation (Knock) Detected in Cylinder Number 1

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 1

CODE | REASON | EFFECT
Fault Code: 561 PID: S90 SPN: 1352 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 1 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-561

Last Modified: 27-Oct-2011


Detonation (Knock) Detected in Cylinder Number 2

FAULT CODE 562

Detonation (Knock) Detected in Cylinder Number 2

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 2

CODE | REASON | EFFECT
Fault Code: 562 PID: S91 SPN: 1353 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 2 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-562

Last Modified: 27-Oct-2011


Detonation (Knock) Detected in Cylinder Number 3

FAULT CODE 563

Detonation (Knock) Detected in Cylinder Number 3

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 3

CODE | REASON | EFFECT
Fault Code: 563 PID: S92 SPN: 1354 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 3 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-563

Last Modified: 27-Oct-2011


Detonation (Knock) Detected in Cylinder Number 4

FAULT CODE 564

Detonation (Knock) Detected in Cylinder Number 4

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 4

CODE | REASON | EFFECT
Fault Code: 564 PID: S93 SPN: 1355 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 4 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-564

Last Modified: 27-Oct-2011


Detonation (Knock) Detected in Cylinder Number 5

FAULT CODE 565

Detonation (Knock) Detected in Cylinder Number 5

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 5

CODE | REASON | EFFECT
Fault Code: 565 PID: S94 SPN: 1356 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 5 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-565

Last Modified: 27-Oct-2011


Detonation (Knock) Detected in Cylinder Number 6

FAULT CODE 566

Detonation (Knock) Detected in Cylinder Number 6

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 6

CODE | REASON | EFFECT
Fault Code: 566 PID: S95 SPN: 1357 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 6 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-566

Last Modified: 27-Oct-2011


Detonation (Knock) Detected in Cylinder Number 7

FAULT CODE 567

Detonation (Knock) Detected in Cylinder Number 7

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 7

CODE | REASON | EFFECT
Fault Code: 567 PID: S96 SPN: 1358 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 7 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-567

Last Modified: 27-Oct-2011


Detonation (Knock) Detected in Cylinder Number 8

FAULT CODE 568

Detonation (Knock) Detected in Cylinder Number 8

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 8

CODE | REASON | EFFECT
Fault Code: 568 PID: S097 SPN: 1359 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 8 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-568

Last Modified: 27-Oct-2011


Detonation (Knock) Detected in Cylinder Number 9

FAULT CODE 569

Detonation (Knock) Detected in Cylinder Number 9

Printable Version Printable Version

Overview

Detonation (Knock) Detected in Cylinder Number 9

CODE | REASON | EFFECT
Fault Code: 569 PID: S098 SPN: 1360 FMI: 0 LAMP: Shutdown SRT: | Cylinder number 9 has exceeded the knock threshold. | The engine will shutdown.
Detonation (Knock) Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock or detonation.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 on each bank monitors all the knock sensors for that bank. The knock sensor offset must be calibrated in each CM558 at initial startup, and if a sensor is removed or changed. The calibration can be done with an Electronic Service Tool.

The detonation (knock) fault is set when the knock sensor count exceeds a high, critical threshold. The engine will shut down immediately.

Refer to Troubleshooting Fault Code t05-569

Last Modified: 27-Oct-2011


Exhaust Back Pressure Sensor Circuit — Shorted High

FAULT CODE 591

Exhaust Back Pressure Sensor Circuit — Shorted High

Printable Version Printable Version

Overview

Exhaust Back Pressure Sensor Circuit — Shorted High

CODE | REASON | EFFECT
Fault Code: 591 PID: 100 SPN: 100 FMI: 3 LAMP: Warning SRT: | High voltage detected on the engine exhaust back pressure sensor signal pin of the Left Bank CM558. | Possible reduced engine performance.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The exhaust back pressure sensor monitors exhaust back pressure and passes information to the Left Bank CM558. The Left Bank CM558 monitors voltage on the exhaust back pressure signal pin and expects to see a voltage vary between 0.46 and 4.56 VDC during normal operation.

The Left Bank CM558 uses this input to determine the pressure of the exhaust gas, which affects the measured oxygen level and therefore the fueling of the engine.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust back pressure sensor tube is vulnerable to collection of condensation and sludge. Periodic maintenance of this tube must be performed. The sensor is located such that it is protected from extreme heat. Do not relocate this sensor from its on-engine position.

Refer to Troubleshooting Fault Code t05-591

Last Modified: 27-Oct-2011


Exhaust Back Pressure Sensor Circuit — Shorted Low

FAULT CODE 592

Exhaust Back Pressure Sensor Circuit — Shorted Low

Printable Version Printable Version

Overview

Exhaust Back Pressure Sensor Circuit — Shorted Low

CODE | REASON | EFFECT
Fault Code: 592 PID: 100 SPN: 100 FMI: 4 LAMP: Warning SRT: | Low voltage detected on the engine exhaust back pressure sensor signal pin of the main harness Left Bank CM558 connector. | Possible reduced engine performance.
Exhaust Back Pressure Sensor Circuit

Circuit Description

The exhaust back pressure sensor monitors exhaust back pressure and passes information to the Left Bank CM558. The Left Bank CM558 monitors voltage on the exhaust back pressure signal pin and expects to see a voltage vary between 0.46 and 4.56 VDC during normal operation.

The Left Bank CM558 uses this input to determine the pressure in the exhaust system, which affects the measured oxygen level and therefore the fueling of the engine.

Component Location

For the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust back pressure sensor tube is vulnerable to collection of condensation and sludge. Periodic maintenance of this tube must be performed. The sensor is located such that it is protected from extreme heat. Do not relocate this sensor from its on-engine position.

Refer to Troubleshooting Fault Code t05-592

Last Modified: 27-Oct-2011


Intake Restriction #2 High - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 619

Intake Restriction #2 High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 619 PID: P105 SPN: 1177 FMI: 16 LAMP: Warning SRT: | Intake Restriction #2 High - Data Valid But Above Normal Operating Range - Moderately Severe Level. The intake restriction has exceeded the high critical threshold. | Possible reduced engine performance.
CM700

Circuit Description

The intake restriction sensor is used by the CM700 to monitor the intake restriction across the air cleaner element.

Component Location

See the following for the component location. Refer to Procedure 100-002 in Section E.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the intake restriction is greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault.

Shop Talk

The intake restriction has exceeded the critical threshold.

Possible causes of this fault code include:

  • Dirty or damaged air cleaner element.
Refer to Troubleshooting Fault Code t05-619

Last Modified: 06-Oct-2016


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 641

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 641 PID: SPN: 1137 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-641

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 642

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 642 PID: SPN: 1139 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-642

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 643

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 643 PID: SPN: 1141 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit - Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-643

Last Modified: 07-Feb-2022


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 644

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 644 PID: SPN: 1143 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-644

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 645

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 645 PID: SPN: 1145 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-645

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 646

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 646 PID: SPN: 1147 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-646

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 647

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 647 PID: SPN: 1149 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-647

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 648

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 648 PID: SPN: 1151 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-648

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 651

Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 651 PID: SPN: 1153 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-651

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 652

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 652 PID: SPN: 1138 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-652

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 653

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 653 PID: SPN: 1140 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 datalink, a datalink or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-653

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 654

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 654 PID: SPN: 1142 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-654

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 655

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 655 PID: SPN: 1144 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-655

Last Modified: 03-Feb-2022


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 656

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 656 PID: SPN: 1146 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-656

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 657

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 657 PID: SPN: 1148 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-657

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 658

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 658 PID: SPN: 1150 FMI: 0 LAMP: Stop/Shutdown SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | The engine will shut down.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning or damaged exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code t05-658

Last Modified: 31-Jan-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 671

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 671 PID: SPN: 1137 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinder Circuit - Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-671

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 672

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 672 PID: SPN: 1139 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-672

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 673

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 673 PID: SPN: 1141 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-673

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 674

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 674 PID: SPN: 1143 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-674

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 675

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 675 PID: SPN: 1145 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-675

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 676

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 676 PID: SPN: 1147 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The "Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-676

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 677

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 677 PID: SPN: 1149 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-677

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 678

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 678 PID: SPN: 1151 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-678

Last Modified: 05-Apr-2022


ECM Internal Air Temperature - Shorted High

FAULT CODE 697

ECM Internal Air Temperature - Shorted High

Printable Version Printable Version

Overview

ECM Internal Air Temperature - Shorted High

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Warning SRT: | The internal signal for the ECM temperature is reading abnormally high voltage. | No effect on engine performance.
CM700

Circuit Description

The CM700 and CM558 each contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM Internal Air Temperature Sensor is inside of the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-697

Last Modified: 27-Oct-2011


ECM Internal Air Temperature - Shorted Low

FAULT CODE 698

ECM Internal Air Temperature - Shorted Low

Printable Version Printable Version

Overview

ECM Internal Air Temperature - Shorted Low

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Warning SRT: | The internal signal for the ECM temperature is reading abnormally low voltage. | No effect on engine performance.
CM700

Circuit Description

The CM700 and CM558 each contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM Internal Air Temperature Sensor is inside of the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-698

Last Modified: 27-Oct-2011


Extended Crankcase Blowby Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 719

Extended Crankcase Blowby Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Extended Crankcase Blowby Pressure Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 719 PID: 22 SPN: 22 FMI: 3 LAMP: Warning SRT: | High voltage detected on the crankcase blowby pressure sensor signal circuit. | Possible reduced engine performance.
Crankcase Blowby Pressure Sensor Circuit - Multiple Turbocharger with Two-Piece Throttle
Crankcase Blowby Pressure Sensor Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The crankcase blowby pressure sensor monitors the pressure in the crankcase as a result of combustion gas getting past the piston rings. This information is monitored by the CENSE™ module, which passes it on to the engine control mondule across the J1939 datalink.

Component Location

The crankcase blowby pressure sensor is located near the crankcase breather on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the crankcase blowby pressure sensor signal voltage is out or range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged crankcase blowby pressure sensor.
  • Damaged or loose connector.
Refer to Troubleshooting Fault Code t05-719

Last Modified: 18-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 721

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 721 PID: SPN: 1138 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-721

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 722

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 722 PID: SPN: 1140 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-722

Last Modified: 05-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 723

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 723 PID: SPN: 1142 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-723

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 724

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 724 PID: SPN: 1144 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-724

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 725

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 725 PID: SPN: 1146 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-725

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 726

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 726 PID: SPN: 1148 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-726

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 727

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 727 PID: SPN: 1150 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-727

Last Modified: 06-Apr-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 728

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 728 PID: SPN: 1152 FMI: 4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Cylinder Circuit – Multiple Turbocharger with Integrated Throttle
Exhaust Gas Temperature Cylinder Circuit – Single Turbocharger
Exhaust Gas Temperature Cylinders Circuit – Multiple Turbochargers with Two-Piece Throttle

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of misfiring within the cylinder.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness
  • Malfunctioning or damaged exhaust gas temperature sensor
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-728

Last Modified: 06-Apr-2022


Extended Crankcase Blowby Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 729

Extended Crankcase Blowby Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Extended Crankcase Blowby Pressure Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 729 PID: 22 SPN: 22 FMI: 4 LAMP: Warning SRT: | Low voltage detected on the crankcase blowby pressure sensor signal circuit. | Possible reduced engine performance.
Crankcase Blowby Pressure Sensor Circuit - Multiple Turbocharger with Two-Piece Throttle
Crankcase Blowby Pressure Sensor Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The crankcase blowby pressure sensor monitors the pressure in the crankcase as a result of combustion gas getting past the piston rings. This information is monitored by the CENSE™ module, which passes it on to the engine control module across the J1939 datalink.

Component Location

The crankcase blowby pressure sensor is located near the crankcase breather on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the crankcase blowby pressure sensor signal voltage is out or range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged crankcase blowby pressure sensor.
  • Damaged or loose connector.
Refer to Troubleshooting Fault Code t05-729

Last Modified: 18-Apr-2022


Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 751

Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect

CODE | REASON | EFFECT
Fault Code: 751 PID: 149 SPN: 1241 FMI: 2 LAMP: Warning SRT: | The gas mass flow sensor signal is reading an erratic value. | Possible reduced engine performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The gas mass flow sensor is a variable voltage sensor used by the ECM to monitor the mass of the gas flowing to the engine. The gas mass flow sensor has four circuits: 5 volt supply, signal, and two return circuits. The signal circuit voltage indicates the gas mass flowing into the engine.

Component Location

The gas mass flow sensor is located in the gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected data from gas mass flow sensor is erratic.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Improper fuel pressure or low fuel.
  • Malfunctioning or damaged fuel control valve
  • Malfunctioning or damaged gas mass flow sensor.
  • Damaged or loose connector.
Refer to Troubleshooting Fault Code t05-751

Last Modified: 26-Apr-2022


Engine Camshaft Speed/Position Sensor - Abnormal Rate of Change

FAULT CODE 753

Engine Camshaft Speed/Position Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 753 PID: SPN: 723 FMI: 10 LAMP: None SRT: | The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Camshaft Position Sensor Circuit

Circuit Description

The camshaft engine position sensor provides engine speed information to the engine control module (ECM). The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the camshaft.

Component Location

The engine camshaft position sensor is located on the side of the front gear cover housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft position sensor signal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The Reset All Faults command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Damaged or loose connectors.
  • Malfunctioning or damaged camshaft position sensor.
Refer to Troubleshooting Fault Code t05-753

Last Modified: 17-May-2022


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

Intake Manifold 1 Temperature - Abnormal Rate of Change

CODE | REASON | EFFECT
Fault Code: 783 PID: 105 SPN: 105 FMI: 10 LAMP: Stop/Shutdown SRT: | Possible damage to the intake valves has been detected. | The engine will shut down.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The Intake Manifold Temperature Sensor is used by the ECM to monitor the temperature of the air in the intake manifold after the aftercooler. The Intake Manifold Temperature Sensor is used by the ECM for engine protection, timing, and fueling control.

Component Location

The Intake manifold temperature sensor is located on each bank below the charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature reading was higher or lower than the other temperature sensors.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses reset.
  • The "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged intake manifold temperature sensor.
  • Valve damage or valve held open.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code 783.

Last Modified: 26-Apr-2022


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Using the electronic service tool, verify that the Fault Code 111 is inactive.

Fault Code 111 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Check the inactive counts of Fault Code 111.

  • Using the electronic service tool, read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Oct-2011


FAULT CODE 121 - Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSV81 and QSV91 CM700 | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV81 and QSV91 CM700 | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins?
 | STEP 1B. Inspect the engine speed sensor. | No damaged engine speed sensor?
 | STEP 1C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 1D. Check for an open circuit. | 1k to 2k ohms?
 | STEP 1E. Check for short circuit between coils. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2B. Check for an open circuit. | Less than 2k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 1B

3A

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.
OK NOT OK

No damaged engine speed sensor?

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine block ground.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin to the engine block ground.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

1k to 2k ohms?

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 1E

Go to 3A

Guided Step 1E - Check for short circuit between coils.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine speed sensor 2 SIGNAL pin.
  • Measure the resistance between the engine speed sensor 1 RETURN pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the engine harness to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the engine harness to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the engine harness.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the engine harness.
OK NOT OK

Less than 2k ohms?

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the engine harness.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the engine harness.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the engine harness.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Feb-2021


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
STEP 2. | Check the Oil Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 135 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 135 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Oil Pressure Sensor.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the Oil Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Oil Pressure Sensor (rifle).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Oil Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Oil Pressure Sensor (rifle). Refer to Procedure 019-066.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Oil Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Oil Pressure Sensor breakout cable between the sensor and the harness connector
  • Connect the electronic service tool.

Action

Check the Oil Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Oil Pressure Sensor (rifle).

Refer to Procedure 019-066.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Oil Pressure Sensor (rifle) and the CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Oil Pressure Sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Oil Pressure Sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the oil pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Oil Pressure Sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the oil pressure return pin on the engine harness connector to the oil pressure return pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Oil Pressure Sensor connector.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 141 will become active upon disconnecting the sensor.

Fault Code 135 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700
  • Disconnect the 50-pin B Deutsch connector from the CM700
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the oil rifle pressure signal pin on the CM700 to CM700 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 135 is inactive.

Fault Code 135 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
STEP 2. | Check the Oil Inlet Pressure Sensor (pre-filter). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 136 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 136 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Oil Inlet Pressure Sensor (pre-filter).

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the Oil Inlet Pressure Sensor (pre-filter).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the oil inlet pressure (pre-filter) sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Oil Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Oil Inlet Pressure Sensor (pre-filter). Refer to Procedure 019-066.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Oil Inlet Pressure Sensor (pre-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Oil Inlet Pressure Sensor (pre-filter) breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Oil Inlet Pressure Sensor (pre-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Oil Inlet Pressure Sensor (pre-filter). Refer to Procedure 019-066.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Oil Inlet Pressure Sensor (pre-filter) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Oil Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Oil Pressure Sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the oil pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Oil Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the oil pressure return pin on the engine harness connector to the oil pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure signal pin on the engine harness connector to the oil pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure supply pin on the engine harness connector to the oil pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the Oil Inlet Pressure Sensor (pre-filter) connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 137 will become active upon disconnecting the sensor.

Fault Code 136 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700.
  • Disconnect the 50-pin B Deutsch connector from the CM700.
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the oil inlet pressure signal pin on the CM700 to the CM700 sensor supply circuit number 2 pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 136 is inactive.

Fault Code 136 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 active?
STEP 2. | Check the Oil Inlet Pressure Sensor (pre-filter). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 137 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 137 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Oil Inlet Pressure Sensor (pre-filter).

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the Oil Inlet Pressure Sensor (pre-filter).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Oil Inlet Pressure Sensor (pre-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Oil Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Oil Inlet Pressure Sensor (pre-filter). Refer to Procedure 019-066.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Oil Inlet Pressure Sensor (pre-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Oil Inlet Pressure Sensor (pre-filter) breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Oil Inlet Pressure Sensor (pre-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Oil Inlet Pressure Sensor (pre-filter). Refer to Procedure 019-066.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Oil Inlet Pressure Sensor (pre-filter) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Oil Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Oil Pressure Sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the oil pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Oil Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the oil pressure return pin on the engine harness connector to the oil pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure signal pin on the engine harness connector to the oil pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure supply pin on the engine harness connector to the oil pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Oil Inlet Pressure Sensor (pre-filter) connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the oil inlet pressure (pre-filter) supply pin and the oil inlet pressure (pre-filter) signal pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 136 will become active upon installing the jumper.

Fault code 137 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700.
  • Disconnect the 50-pin B Deutsch connector from the CM700.
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the oil inlet pressure signal pin on the CM700 to the CM700 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 136 is inactive.

Fault Code 137 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 active?
STEP 2. | Check the Engine Oil Pressure Sensor (Rifle). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 141 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 141 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Engine Oil Pressure Sensor (Rifle).

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the Engine Oil Pressure Sensor (Rifle).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Oil Pressure Sensor (Rifle).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Oil Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Oil Pressure Sensor (Rifle). Refer to Procedure 019-066.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Engine Oil Pressure Sensor (Rifle) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Engine Oil Pressure Sensor (Rifle) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Engine Oil Pressure Sensor (Rifle).

Refer to Procedure 019-066.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Oil Pressure Sensor (Rifle) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Engine Oil Pressure Sensor (Rifle).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Engine Oil Pressure Sensor (Rifle).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the Engine Oil Pressure Sensor (Rifle) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Oil Pressure Sensor (Rifle) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Oil Pressure Sensor (Rifle) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Engine Oil Pressure Sensor (Rifle).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the Engine Oil Pressure Sensor (Rifle) return pin on the engine harness connector to the Engine Oil Pressure Sensor (Rifle) return pin on the engine harness sensor connector.
  • Measure the resistance from the Engine Oil Pressure Sensor (Rifle) signal pin on the engine harness connector to the Engine Oil Pressure Sensor (Rifle) signal pin on the engine harness sensor connector.
  • Measure the resistance from the Engine Oil Pressure Sensor (Rifle) supply pin on the engine harness connector to the Engine Oil Pressure Sensor (Rifle) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Engine Oil Pressure Sensor (Rifle) connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the Engine Oil Pressure Sensor (Rifle) supply pin and the Engine Oil Pressure Sensor (Rifle) signal pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 135 will become active upon installing the jumper.

Fault code 141 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700.
  • Disconnect the 50-pin B Deutsch connector from the CM700.
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the Engine Oil Pressure Sensor (Rifle) signal pin on the CM700 to the CM700 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 141 is inactive.

Fault Code 141 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 135 or 141 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 135 or 141 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Pressure High symptom tree in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 135 or 141 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 135 or 141 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Pressure Low symptom tree in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the Engine Coolant Temperature Sensor (High Temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 144 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 144 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Engine Coolant Temperature Sensor (High Temperature).

Other fault codes active?
YES | NO
No Repair | No Repair

Reference the appropriate fault codes

Go to 2A

Guided Step 2 - Check the Engine Coolant Temperature Sensor (High Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (High Temperature).

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Engine Coolant Temperature Sensor (High Temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Coolant Temperature Sensor (High Temperature). Refer to Procedure 019-019.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (High Temperature).

Action

Check the resistance of the Engine Coolant Temperature Sensor (High Temperature).

  • Measure the resistance between the Engine Coolant Temperature Sensor (High Temperature) signal pin and the Engine Coolant Temperature Sensor (High Temperature) return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Engine Coolant Temperature Sensor (High Temperature). Refer to Procedure 019-019.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (High Temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Engine Coolant Temperature Sensor (High Temperature) connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Engine Coolant Temperature Sensor (High Temperature). Refer to Procedure 019-019.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (High Temperature) and the CM700.

Action

Inspect the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (High Temperature).
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Engine Coolant Temperature Sensor (High Temperature) return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Coolant Temperature Sensor (High Temperature) signal pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect engine harness from Engine Coolant Temperature Sensor (High Temperature).
  • Disconnect engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires.

  • Measure the resistance from the Engine Coolant Temperature Sensor (High Temperature) signal pin in the engine harness connector to the engine block ground.
  • Measure the resistance from the Engine Coolant Temperature Sensor (High Temperature) return pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM700
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (High Temperature).

Action

Check for an open circuit.

  • Measure the resistance from the signal pin in the Engine Coolant Temperature Sensor (High Temperature) connector to the sensor signal pin in the CM700.
  • Measure the resistance from the return pin in the Engine Coolant Temperature Sensor (High Temperature) connector to the return pin in the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (High Temperature).
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the Engine Coolant Temperature Sensor (High Temperature) signal pin and the Engine Coolant Temperature Sensor (High Temperature) return pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Read the fault codes using the Electronic Service Tool.

Note: Fault Code 145 will become active upon disconnecting the sensor.

Fault Code 144 inactive?
YES NO
No Repair

Repair

Contact the Local Cummins Authorized Repair Facility.

Go to 5A

Repair complete.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify Fault Code 144 is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the Local Cummins Authorized Repair Facility if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the radiator pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the radiator pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the Engine Coolant Temperature Sensor (High Temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 145 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 145 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Engine Coolant Temperature Sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Reference the appropriate fault codes.

Go to 2A

Guided Step 2 - Check the Engine Coolant Temperature Sensor (High Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (High Temperature).

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Engine Coolant Temperature Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Coolant Temperature Sensor. Refer to Procedure 019-019.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (High Temperature).

Action

Check the resistance of the Engine Coolant Temperature Sensor (high temperature).

  • Measure the resistance between the coolant temperature signal pin and the coolant temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Engine Coolant Temperature Sensor (High Temperature). Refer to Procedure 019-019.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (High Temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Engine Coolant Temperature Sensor (High Temperature) connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Engine Coolant Temperature Sensor (High Temperature). Refer to Procedure 019-019.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (High Temperature) and the CM700.

Action

Inspect the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (High Temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the coolant temperature (High Temperature) return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the coolant temperature (High Temperature) signal pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect engine harness from Engine Coolant Temperature Sensor (High Temperature).
  • Disconnect engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires.

  • Measure the resistance from the coolant temperature (High Temperature) signal pin in the engine harness connector to the engine block ground.
  • Measure the resistance from the coolant temperature (High Temperature) return pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM700
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (High Temperature).

Action

Check for an open circuit.

  • Measure the resistance from the signal pin in the Engine Coolant Temperature Sensor (High Temperature) connector to the sensor signal pin in the CM700.
  • Measure the resistance from the return pin in the Engine Coolant Temperature Sensor (High Temperature) connector to the return pin in the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant sensor.
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 144 will become active upon disconnecting the sensor.

Fault Code 145 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify Fault Code 145 is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 146 - Engine Coolant Temperature (High Temperature) High - Warning

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active Fault Code 146. | Fault Code 146 active?
STEP 2. | Check the temperature sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Temperature differs more than 3°C [37°F] or 5°C [41°F]?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the engine temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the engine temperature sensor. | Between 600 ohms and 36k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 146 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 146.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the temperature sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool, to the reading from the temperature probe.

If no temperature measuring device is available, answer 'NO' to this step.

Temperature differs more than 3°C [37°F] or 5°C [41°F]?
YES NO

Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the coolant the temperature sensor.

Action

Inspect the coolant temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is missing or damaged.

Repair the engine harness. Refer to Procedure 019-202 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the resistance of the engine coolant temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin.

Between 600 ohms and 36k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 146 is inactive.

Fault Code 146 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 18-Feb-2015


FAULT CODE 151 - Engine Coolant Temperature (High Temperature) High - Critical

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active Fault Code 151. | Fault Code 151 active?
STEP 2. | Check the temperature sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Temperature differs more than 3°C or 5°C?
STEP 3. | Check the coolant temperature sensor. |
 | STEP 3A. Inspect the engine temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the engine temperature sensor. | Between 600 ohms to 36k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 151.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the temperature sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect a temperature gauge to the engine.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the sensor accuracy.

  • Compare the coolant temperature reading on INSITE™ electronic service tool, to the reading from the temperature probe.

If no temperature measuring device is available, answer 'NO' to this step.

Temperature differs more than 3°C or 5°C?
YES NO

Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the coolant temperature sensor.

Guided Step 3A - Inspect the coolant temperature sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the coolant the temperature sensor.

Action

Inspect the coolant temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is missing or damaged.

Repair the engine harness. Refer to Procedure 019-202 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the resistance of the engine coolant temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin.

Between 600 ohms and 36k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 151 is inactive.

Fault Code 151 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 05-Mar-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the Intake Manifold Temperature Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 153 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 153 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Read the fault codes using the electronic service tool
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Intake Manifold Temperature Sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Check the Intake Manifold Temperature Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Temperature Sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Intake Manifold Temperature Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 2B

Go to 5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check the resistance of the Intake Manifold Temperature Sensor.

  • Measure the resistance between the intake manifold temperature signal pin and the intake manifold temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Intake Manifold Temperature Sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the intake manifold temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the Intake Manifold Temperature Sensor connector to the sensor signal pin on the CM558.
  • Measure the resistance from the return pin on the Intake Manifold Temperature Sensor connector to the return signal pin on the CM558.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch is Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor
  • Connect the electronic service tool.

Action

Check for appropriate CM558 response.

  • Place a jumper wire between the intake manifold temperature signal pin and the intake manifold temperature return pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 154 will become active upon installing the jumper.

Fault Code 153 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify Fault Code 153 is inactive.

Fault Code 153 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active?
STEP 2. | Check the Intake Manifold Temperature Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 154 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 154 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Read the fault codes using the electronic service tool
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Intake Manifold Temperature Sensor.

Other fault codes are active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Check the Intake Manifold Temperature Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Temperature Sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broke pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Intake Manifold Temperature Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check the resistance of the Intake Manifold Temperature Sensor.

  • Measure the resistance between the intake manifold temperature signal pin and the intake manifold temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Intake Manifold Temperature Sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the intake manifold temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the Intake Manifold Temperature Sensor connector to the sensor signal pin on the CM558.
  • Measure the resistance from the return pin on the Intake Manifold Temperature Sensor connector to the return pin on the CM558.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 153 will become active upon disconnecting the sensor.

Fault Code 154 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 154 is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear any inactive fault codes.

  • Using the electronic service tool, clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 153 or 154 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 153 or 154 active?
YES NO
No Repair

Repair

Reference the Intake Manifold Temperature Above Specification symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477 or 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit for pin to pin. | More than 100k ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check the throttle driver commanded position signal current. | More than 20 mA?
 | STEP 4B. Check for the appropriate CM558 response. | Fault Code 175 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault code 175 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect electronic service tool.

Action

Read the fault codes.

  • Use electronic service tool to read the fault codes.

Fault Code 441, 442, 477 or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 (Throttle Driver) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the throttle driver power connection
  • Connect electronic service tool.

Action

Check the throttle driver supply voltage.

Use a multimeter to measure the throttle supply voltage.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver and the CM558.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit for pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Preform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check the throttle driver commanded position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the throttle driver commanded position connection
  • Connect electronic service tool.

Action

Check the throttle driver commanded position signal

  • Connect an ammeter in series with the commanded position signal wire
  • Use a jumper wire to connect the return connection.

More than 20 mA?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 5A

Guided Step 4B - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the throttle driver commanded position connector
  • Connect electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use electronic service tool to verify the fault codes.
  • Fault Code 176 will become active upon disconnecting the throttle driver commanded position connector.

Fault Code 175 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use electronic service tool to verify Fault Code 175 is inactive.

Fault Code 175 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect electronic service tool.

Action

Clear the inactive fault codes.

  • Use electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 19-Feb-2021


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477 or 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit for pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check the throttle driver commanded position signal current. | Less than 4 mA?
 | STEP 4B. Check for the appropriate CM558 response. | Fault Code 176 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault code 176 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect electronic service tool.

Action

Read the fault codes.

  • Use electronic service tool to read the fault codes.

Fault Code 441, 442, 477 or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 (Throttle Driver) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the throttle driver power connection
  • Connect electronic service tool.

Action

Check the throttle driver supply voltage.

Use a multimeter to measure the throttle supply voltage.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver and the CM558.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit for pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver commanded position connector.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver commanded position return pin on the engine harness connector to the throttle driver commanded position return pin on the throttle driver commanded position connector.
  • Measure the resistance from the throttle driver commanded position signal pin on the engine harness connector to the throttle driver commanded position signal pin on the throttle driver commanded position connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check the throttle driver commanded position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the throttle driver commanded position connection
  • Connect electronic service tool.

Action

Check the throttle driver commanded position signal.

  • Connect an ammeter in series with the commanded position signal wire.
  • Use a jumper wire to connect the return connection.

Less than 4 mA?
YES NO

Repair

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and engine running at rated speed and load
  • Connect electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use electronic service tool to verify the fault codes.

Fault Code 176 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use electronic service tool to verify Fault Code 176 is inactive.

Fault Code 176 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect electronic service tool.

Action

Clear the inactive fault codes.

  • Use electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 19-Feb-2021


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 187 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 187 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing Sensor Supply Circuit Number 2.

Fault Code 187 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code Procedure Refer to Procedure 019-362.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Reference the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share Sensor Supply Circuit Number 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Sensor Supply Circuit Number 2 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share Sensor Supply Circuit Number 2.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor supply pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Read the fault codes using the electronic service tool.

Fault Code 187 active?
YES NO

Repair

Contact the nearest authorized repair location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 187 is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using the electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the engine oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 212 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 212 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Read the fault codes using the electronic service tool
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine oil temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine oil temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2B

5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check the resistance of the engine oil temperature sensor.

  • Measure the resistance between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine oil temperature sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness from the engine oil temperature sensor and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness from the CM700.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine oil temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the engine oil temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine oil temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine oil temperature sensor connector to the sensor SIGNAL pin on the CM700.
  • Measure the resistance from the RETURN pin on the engine oil temperature sensor connector to the return SIGNAL pin on the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch is Stop mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Connect the electronic service tool.

Action

Check for appropriate CM700 response.

  • Place a jumper wire between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

NOTE: Fault Code 213 will become active upon installing the jumper.

Fault Code 212 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify Fault Code 212 is inactive.

Fault Code 212 is inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2022


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active?
STEP 2. | Check the engine oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 213 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 213 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Read the fault codes using the electronic service tool
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine oil temperature sensor.

Other fault codes are active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine oil temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check the resistance of the engine oil temperature sensor.

  • Measure the resistance between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine oil temperature sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine oil temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the engine oil temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine oil temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine oil temperature sensor connector to the sensor SIGNAL pin on the CM700.
  • Measure the resistance from the RETURN pin on the engine oil temperature sensor connector to the RETURN pin on the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

NOTE: Fault Code 212 will become active upon disconnecting the sensor.

Fault Code 213 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 213 is inactive.

Fault Code 213 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear any inactive fault codes.

  • Using the electronic service tool, clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-May-2022


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 212 or 213 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 212 or 213 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Temperature Above Specification symptom tree in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 212 or 213 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 212 or 213 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Temperature Below Specification symptom tree.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 227 is active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing Sensor Supply Circuit Number 2.

Fault Code 227 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code Procedure Refer to Procedure 019-362.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Reference the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share Sensor Supply Circuit Number 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Sensor Supply Circuit Number 2 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Read the fault codes using the electronic service tool.

Fault Code 227 is active?
YES NO

Repair

Contact the nearest authorized repair location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 227 is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using the electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 231 or 232 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 231 or 232 active?
YES NO
No Repair

Repair

Reference the Coolant Pressure is Low symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the Engine Coolant Pressure Sensor Circuit (High Temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault code 231 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault code 231 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 386

Go to 2A

Guided Step 2 - Check the Engine Coolant Pressure Sensor Circuit (High Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Pressure Sensor Circuit (High Temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-219.
  • Replace the Engine Coolant Pressure Sensor (High Temperature). Refer to Procedure 019-016.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Engine Coolant Pressure Sensor Circuit (High Temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the oil pressure sensor breakout cable between the sensor and the harness connector
  • Connect the electronic service tool.

Action

Check the Engine Coolant Pressure Sensor Circuit (High Temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Engine Coolant Pressure Sensor (High Temperature).

Refer to Procedure 019-016.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks to all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (High Temperature)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Engine Coolant Pressure Sensor (High Temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the Engine Coolant Pressure Sensor supply (High Temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Coolant Pressure Sensor return (High Temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Coolant Pressure Sensor signal (High Temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (High Temperature).

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Engine Coolant Pressure Sensor (High Temperature) return pin on the engine harness connector to the Engine Coolant Pressure Sensor (High Temperature) return pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Engine Coolant Pressure Sensor (High Temperature) connector.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 232 will become active upon disconnecting the sensor.

Fault code 231 is inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700.
  • Disconnect the 50-pin B Deutsch connector from the CM700.
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the Engine Coolant Pressure Sensor (High Temperature) signal pin on the CM700 to the CM700 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 231 is inactive.

Fault code 231 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the Engine Coolant Pressure Sensor Circuit (High Temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 232 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 232 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Engine Coolant Pressure Sensor Circuit (High Temperature).

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the Engine Coolant Pressure Sensor Circuit (High Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Pressure Sensor Circuit (High Temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Engine Coolant Pressure Sensor Circuit (High Temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Coolant Pressure Sensor (High Temperature). Refer to Procedure 019-016.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Engine Coolant Pressure Sensor Circuit (High Temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Engine Coolant Pressure Sensor Circuit (High Temperature) breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Engine Coolant Pressure Sensor Circuit (High Temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Engine Coolant Pressure Sensor (High Temperature). Refer to Procedure 019-016.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor Circuit (High Temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (High Temperature).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Engine Coolant Pressure Sensor Circuit (High Temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure supply (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure return (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure signal (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (High Temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine coolant pressure (high temperature) return pin on the engine harness connector to the engine coolant pressure (high temperature) return pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure (high temperature) signal pin on the engine harness connector to the engine coolant pressure (high temperature) signal pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure (high temperature) supply pin on the engine harness connector to the engine coolant pressure (high temperature) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Engine Coolant Pressure Sensor (High Temperature) connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the engine coolant pressure (high temperature) supply pin and the engine coolant pressure (high temperature) signal pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 231 will become active upon installing the jumper.

Fault code 232 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700.
  • Disconnect the 50-pin B Deutsch connector from the CM700.
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine coolant pressure (high temperature) signal pin on the CM700 to the CM700 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 232 is inactive.

Fault Code 232 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 234 - Engine Overspeed

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Module Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSV81 and QSV91 CM700 | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV81 and QSV91 CM700 | 4021315

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR Cummins® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed exceeds 125 percent of rated speed, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring down hill, if applcable?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with the recommended Cummins® electronic service tool, or equivalent. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1F. Test the equipment. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Engine motoring down hill, if applcable?
YES NO

Repair

Check for engine damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.
 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a uncommanded acceleration where the engine rapidly accelerated to or past 115 percent of rated rpm, followed by moderate deceleration to 115 percent of rated rpm.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with the electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.
  • Operate the engine.

Action

Check the engine rpm with the electronic service tool.

Compare the engine crankshaft speed/position sensor reading on the electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine crankshaft engine speed sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1D

Troubleshoot Fault Codes 689 and 1376.

Guided Step 1D - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the engine harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the damaged engine crankshaft speed/position sensor.

 No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for active Fault Code 234 when the engine is operating below rated rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1F

Go to 2A

Guided Step 1F - Test the equipment.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Test the equipment in a road test or if it stationary, operate under normal operating conditions, to determine if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Use the electronic service tool to verify the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-May-2022


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 238 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 3.

Fault Code 238 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code Procedure Refer to Procedure 019-362.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Reference the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 3.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 3 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 3.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor supply pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Read the fault codes using the electronic service tool.

Fault Code 238 active?
YES NO

Repair

Contact the nearest authorized repair location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 238 is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using the electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 239 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing Sensor Supply Circuit Number 3.

Fault Code 239 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code Procedure Refer to Procedure 019-362.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Reference the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share Sensor Supply Circuit Number 3.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Sensor Supply Circuit Number 3 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Read the fault codes using the electronic service tool.

Fault Code 239 active?
YES NO

Repair

Contact the nearest Cummins Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 239 is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using the electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the fuel shutoff valve and generator control harness connector pins. | Damaged pins?
 | STEP 2B. Check the valve supply voltage. | 24 VDC?
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 and CM700 response. |
 | STEP 4A. Check for the appropriate CM558 and CM700 response. | Fault Code 254 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 254 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the fuel shutoff valve and generator control harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness connector from the fuel shutoff valve.

Action

Inspect the valve and the generator control harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the generator control harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the generator control harness. Refer to Procedure 019-183.
  • Replace the fuel shutoff valve. Refer to Procedure 005-044 in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main generator control harness from the fuel shutoff valve
  • Connect the electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

Note: Ensure that the engine is not performing a purge cycle when making this measurement.

24 VDC?
YES NO
No Repair

Repair

Check the battery connections and the fuses in the harness. Reference the engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the fuel shutoff valve and the CM558 and CM700.

Action

Inspect the generator control harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Replace the generator control harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the generator control harness. Refer to Procedure 019-183.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the extension harness (if present)
  • Disconnect the generator control harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the generator control harness connector to all other pins in the generator control harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the generator control harness connector to all other pins in the generator control harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the generator control harness.

  • Replace the generator control harness. Refer to Procedure 019-183.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the extension harness (if present)
  • Disconnect the generator control harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the generator control harness connector to the fuel shutoff valve supply pin on the generator control harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the generator control harness connector to the fuel shutoff valve return pin on the generator control harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the generator control harness.

  • Replace the generator control harness. Refer to Procedure 019-183.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 and CM700 response.

Guided Step 4A - Check for the appropriate CM558 and CM700 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the fuel control valve actuator connector
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 and CM700 response.

  • Remove the fuel shutoff valve relays and crank the engine. Reference the engine wiring diagram for the appropriate circuit.
  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 255 will become active.

Fault Code 254 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 254 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the valve supply voltage. | 24 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 and CM700 response. |
 | STEP 4A. Check for the appropriate CM558 and CM700 response. | Fault Code 254 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 254 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the fuel shutoff valve. Refer to Procedure 005-044 in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect the electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

Note: Ensure that the engine is not performing a purge cycle when making this measurement.

24 VDC?
YES NO
No Repair

Repair

Check the battery connections and the fuses in the harness. Reference the engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558 and CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to the fuel shutoff valve return pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 and CM700 response.

Guided Step 4A - Check for the appropriate CM558 and CM700 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the fuel control valve actuator connector
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 and CM700 response.

  • Remove the fuel shutoff valve relays and crank the engine. Reference the engine wiring diagram for the appropriate circuit.
  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 255 will become active.

Fault Code 254 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 254 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 — female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and generator control harness connector pins. | Damaged pins?
 | STEP 2B. Check the valve supply voltage. | 24 VDC?
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 and CM700 response. |
 | STEP 4A. Check for the appropriate CM558 and CM700 response. | Fault Code 255 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 255 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for multiple fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and generator control harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the generator control harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the generator control harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the generator control harness. Refer to Procedure 019-183.
  • Replace the fuel shutoff valve. Refer to Procedure 005-044 in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect the electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

Note: Ensure that the engine is not performing a purge cycle when making this measurement.

24 VDC?
YES NO
No Repair

Repair

Check the battery connections and the fuses in the harness. Reference the engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the generator control harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the fuel shutoff valve and the CM558 and CM700.

Action

Inspect the generator control harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Replace the generator control harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the generator control harness. Refer to Procedure 019-183.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the extension harness (if present)
  • Disconnect the generator control harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the generator control harness connector to all other pins in the generator control harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the generator control harness connector to all other pins in the generator control harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the generator control harness.

  • Replace the generator control harness. Refer to Procedure 019-183.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the generator control harness from the extension harness (if present)
  • Disconnect the generator control harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the generator control harness connector to the fuel shutoff valve supply pin on the generator control harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the generator control harness connector to the fuel shutoff valve return pin on the generator control harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the generator control harness.

  • Replace the generator control harness. Refer to Procedure 019-183.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 and CM700 response.

Guided Step 4A - Check for the appropriate CM558 and CM700 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the fuel control valve actuator connector
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 and CM700 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine. Reference the engine wiring diagram for the appropriate circuit.
  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 254 will become active.

Fault Code 255 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 255 is inactive.

Fault Code 255 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 — female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the valve supply voltage. | 24 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 and CM700 response. |
 | STEP 4A. Check for the appropriate CM558 and CM700 response. | Fault Code 255 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 255 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the fuel shutoff valve. Refer to Procedure 005-044 in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect the electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

Note: Ensure that the engine is not performing a purge cycle when making this measurement.

24 VDC?
YES NO
No Repair

Repair

Check the battery connections and the fuses in the harness. Reference the engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558 and CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to the fuel shutoff valve return pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 and CM700 response.

Guided Step 4A - Check for the appropriate CM558 and CM700 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the fuel control valve actuator connector
  • Run/Stop/Auto switch in Run mode and engine cranking.

Action

Check for the appropriate CM558 and CM700 response.

  • Install a jumper to power the fuel shutoff valve relays and then crank the engine. Reference the engine wiring diagram for the appropriate circuit.
  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 254 will become active.

Fault Code 255 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 255 is inactive.

Fault Code 255 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 263 or 265 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 263 or 265 active?
YES NO
No Repair

Repair

Refer the OEM installation guidelines. Verify that any OEM fuel coolers are operating properly.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the Fuel Temperature Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 263 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 263 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Read the fault codes using the electronic service tool
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Fuel Temperature Sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Check the Fuel Temperature Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Fuel Temperature Sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Fuel Temperature Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Temperature Sensor. Refer to Procedure 019-119.
No Repair

Go to 2B

5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature signal pin and the fuel temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Fuel Temperature Sensor. Refer to Procedure 019-119.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Fuel Temperature Sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Fuel Temperature Sensor. Refer to Procedure 019-119.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the Fuel Temperature Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the fuel temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the fuel temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Fuel Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the Fuel Temperature Sensor connector to the sensor signal pin on the CM558.
  • Measure the resistance from the return pin on the Fuel Temperature Sensor connector to the return signal pin on the CM558.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch is Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor
  • Connect the electronic service tool.

Action

Check for appropriate CM558 response.

  • Place a jumper wire between the fuel temperature signal pin and the fuel temperature return pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 265 will become active upon installing the jumper.

Fault Code 263 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify Fault Code 263 is inactive.

Fault Code 263 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active?
STEP 2. | Check the Fuel Temperature Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 265 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 265 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Read the fault codes using the electronic service tool
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Fuel Temperature Sensor.

Other fault codes are active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Check the Fuel Temperature Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Fuel Temperature Sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broke pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Fuel Temperature Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Temperature Sensor. Refer to Procedure 019-119.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature signal pin and the fuel temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Fuel Temperature Sensor. Refer to Procedure 019-119.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Fuel Temperature Sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Fuel Temperature Sensor. Refer to Procedure 019-119.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the Fuel Temperature Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the fuel temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the fuel temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Fuel Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the Fuel Temperature Sensor connector to the sensor signal pin on the CM558.
  • Measure the resistance from the return pin on the Fuel Temperature Sensor connector to the return pin on the CM558.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Temperature Sensor
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 263 will become active upon disconnecting the sensor.

Fault Code 265 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 265 is inactive.

Fault Code 265 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear any inactive fault codes.

  • Using the electronic service tool, clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 277 - Multiple Turbochargers - Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 277 active or high inactive counts?
STEP 2. | Check the left-bank fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | Feedback signal voltage 0 to 5-VDC?
STEP 3. | Check the left-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Wiring harness and connector pins OK?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short-to-ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 277 and/or 2184, 2311, 2864, 2866 and 2867 become active?
STEP 4. | Check the left-bank ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector. | Percent duty cycle 10 to 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 277 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 277 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the left-bank fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the left-bank fuel control valve actuator.

Action

Inspect the left-bank actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the left-bank engine harness, the harness connector or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Measure the commanded signal percent duty cycle with a multimeter by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedack and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Feedback signal voltage 0 to 5-VDC?
YES NO
No Repair

Repair

Replace the left-bank fuel control valve:

  • Use the following procedure to replace the fuel control valve in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the left-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Inspect the left-bank engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the left-bank engine harness, the harness connector or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Reference the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check for an open circuit in the left-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

  • Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the left-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Reference the wiring diagram to identify shared sensors.

Action

Check the left-bank engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator Feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the left-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent left-bank engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector. Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 277 and/or 2184, 2311, 2864, 2866 and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness. Repair or replace the left-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the left-bank ECM.

Guided Step 4A - Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left-bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault has been detected with the left-bank CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact your local Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 277 is inacitve.

Fault Code 277 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 15-Mar-2012


FAULT CODE 277 - Single Turbocharger - Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 277 active or high inactive counts?
STEP 2. | Check the left-bank fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | Fuel control valve feedback signal voltage 0 to 5-VDC?
STEP 3. | Check the left-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Wiring harness and connector pins OK?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 277 and/or 2184, 2311, 2864, 2866 and 2867 become active?
STEP 4. | Check the left-bank ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector. | Percent duty cycle 10 to 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 277 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 277 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the left-bank fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the left-bank fuel control valve actuator.

Action

Inspect the left-bank actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the left-bank engine harness, the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 2B

Go to 5A

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Feedback signal voltage 0 to 5-VDC?
YES NO
No Repair

Repair

Replace the left-bank fuel control valve:

  • Use the following procedure to replace the fuel control valve in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the left-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Inspect the left-bank engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the left-bank engine harness, the harness connector, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • 9
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check for an open circuit in the left-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

  • Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the left-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.
  • Refer to the wiring diagram to identify shared sensors.

Action

Check the left-bank engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the left-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent left-bank engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 277 and/or 2184, 2311, 2864, 2866 and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness. Repair or replace the left-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the left-bank ECM.

Guided Step 4A - Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left-bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault has been detected with the left-bank CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 277 is inacitve.

Fault Code 277 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 15-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 346 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 346. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 346.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Check the inactive counts of Fault Code 346.

  • Use the electronic service tool to read the inactive counts of Fault Code 346.

Less than three counts?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 352 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 352 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 1.

Fault Code 352 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code Procedure Refer to Procedure 019-362.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Reference the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 1 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor supply pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from all sensors that share sensor supply circuit number 1
  • Energize the keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Read the fault codes using the electronic service tool.

Fault Code 352 active?
YES NO

Repair

Contact the nearest Local Cummins Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 352 is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using the electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the Intake Manifold Pressure Sensor . |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 354 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 354 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Intake Manifold Pressure Sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 386

Go to 2A

Guided Step 2 - Check the Intake Manifold Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Oil Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Intake Manifold Pressure Sensor. Refer to Procedure 019-061.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Intake Manifold Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Intake Manifold Pressure Sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Intake Manifold Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Intake Manifold Pressure Sensor. Refer to Procedure 019-061.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Intake Manifold Pressure Sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to the intake manifold pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to the intake manifold pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to the intake manifold pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the Intake Manifold Pressure Sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 137 will become active upon disconnecting the sensor.

Fault Code 354 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the intake manifold pressure signal pin on the CM558 to the CM558 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 354 is inactive.

Fault Code 354 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the Intake Manifold Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 355 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 355 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Intake Manifold Pressure Sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 352

Go to 2A

Guided Step 2 - Check the Intake Manifold Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Oil Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Intake Manifold Pressure Sensor. Refer to Procedure 019-061.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Intake Manifold Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Intake Manifold Pressure Sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Intake Manifold Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Intake Manifold Pressure Sensor. Refer to Procedure 019-061.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Intake Manifold Pressure Sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to the intake manifold pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to the intake manifold pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to the intake manifold pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the Intake Manifold Pressure Sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the intake manifold pressure supply pin and the intake pressure signal pin of the sensor connector.
  • Check for the appropriate CM558 response after thirty seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 354 will become active upon disconnecting the sensor.

Fault Code 355 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the intake manifold pressure signal pin on the CM558 to the CM558 sensor supply circuit number one return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 355 is inactive.

Fault Code 355 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 359 - Engine Failed to Start

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the engine control module (ECM) for other active fault codes. | Other fault codes active?
 | STEP 1B. Check the ECM for active Fault Code 359. | Active or inactive counts of Fault Code 359?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 359 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for other active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode.

Action

Use INSITE™ electronic service tool to check for other active fault codes.

Other fault codes active?
YES NO

Repair

Use the appropriate troubleshooting steps to troubleshoot the fault codes.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the ECM for active Fault Code 359.

Conditions

  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool to check for active Fault Code 359.

Active or inactive counts of Fault Code 359?
YES NO

Repair

Reference the Engine Difficult to Start or Will Not Start troubleshooting symptom tree (t045) in Section TS of the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 402131.4

No Repair

Go to 2A

Go to 2B

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and run for more than one minute.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.

Fault Code 359 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting step or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 05-Feb-2015


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 386 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing Sensor Supply Circuit Number 1.

Fault Code 386 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code Procedure Refer to Procedure 019-362.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Reference the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share Sensor Supply Circuit Number 1.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Sensor Supply Circuit Number 1 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Read the fault codes using the electronic service tool.

Fault Code 386 active?
YES NO

Repair

Contact the nearest authorized repair location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 386 is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using the electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


SAE J1587/J1922 Datalink - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Repair

Refer to Procedure 019-166, SAE J1587/1922 Datalink Circuit, in this manual for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2022


SAE J1587/J1922 Datalink - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Repair

Refer to Procedure 019-166, SAE J1587/1922 Datalink Circuit, in this manual for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2022


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 135 or 141 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 135 or 141 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Pressure Low symptom tree in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Repair

Refer to Procedure 019-165, SAE J1939 Datalink Circuit for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Repair

Refer to Procedure 019-165, SAE J1939 Datalink Circuit, in this manual for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824811 - male Deutsch test leadPart Number 3824812 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 VDC (24 VDC system)?
 | STEP 1C. Verify 120 VAC supplied to DC power supply. | 120 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 441 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Reference the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7 VDC (24 VDC system)?
YES NO
No Repair

Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120 VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120 VAC input to the DC power supply.

Measure the 120 VAC input to the DC power supply.

120 VDC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-197.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Battery Supply Circuit to see if any fuse is blown.

  • Reference the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

Pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

More than 100 ohms?
YES NO

Repair

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 441 is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824811 - male Deutsch test leadPart Number 3824812 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 VDC (24 VDC system)?
 | STEP 1C. Verify 120 VAC supplied to DC power supply. | 120 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 441 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Reference the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7 VDC (24 VDC system)?
YES NO
No Repair

Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120 VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120 VAC input to the DC power supply.

Measure the 120 VAC input to the DC power supply.

120 VDC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-197.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Battery Supply Circuit to see if any fuse is blown.

  • Reference the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

Pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

More than 100 ohms?
YES NO

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 441 is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test leadPart Number 3824811 - male Deutsch test leadPart Number 3824812 - female Deutsch test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 VDC (24 VDC system)?
 | STEP 1C. Verify 120 VAC supplied to DC power supply. | 120 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | Damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 442 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Reference the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7 VDC (24 VDC system)?
YES NO
No Repair

Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120 VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120 VAC input to the DC power supply.

Measure the 120 VDC input to the DC power supply.

120 VDC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-197.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Battery Supply Circuit to see if any fuse is blown.

  • Reference the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed).

Action

Inspect the wiring harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

Pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2E

Go to 3A

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823994 - female Deutsch test lead.
Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify the connectors and pins.

More than 100 ohms?
YES NO

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204, and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than one minute.

Action

Verify that the fault code are inactive.

  • Using the electronic service tool, verify that Fault Code 442 is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Merti-Pack test leadPart Number 3822917 - female Deutsch/AMP/Merti-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 239 active?
STEP 2. | Check the Gas Mass Flow Sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 8 to 15 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 453 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 453 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using an electronic service tool, read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 239

Go to 2A

Guided Step 2 - Check the Gas Mass Flow Sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Gas Mass Flow Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Gas Mass Flow Sensor, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Gas Mass Flow Sensor. Refer to Procedure 019-101.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Gas Mass Flow Sensor
  • Connect the electronic service tool.

Action

Check the Gas Mass Flow Sensor supply voltage.

  • Measure the sensor supply voltage.

8 to 15 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the CM558
  • Connect the electronic service tool.

Action

Check the Gas Mass Flow Sensor signal voltage.

  • Measure the signal voltage at the main harness CM558 connector with a multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Gas Mass Flow Sensor. Refer to Procedure 019-101.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Gas Mass Flow Sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform all these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Gas Mass Flow Sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Gas Mass Flow Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Gas Mass Flow Sensor supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Gas Mass Flow Sensor return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Gas Mass Flow Sensor signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Gas Mass Flow Sensor

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Gas Mass Flow Sensor return pin on the engine harness connector to the Gas Mass Flow Sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Gas Mass Flow Sensor.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 454 will become active upon disconnecting the sensor.

Fault Code 453 is inactive?
YES NO
No Repair

Repair

Contact the nearest Authorized Cummins Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 453 is inactive.

Fault Code 453 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Authorized Cummins Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service too, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Merti-Pack test leadPart Number 3822917 - female Deutsch/AMP/Merti-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 238 active?
STEP 2. | Check the Gas Mass Flow Sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 8 to 15 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 454 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 454 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using an electronic service tool, read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 238

Go to 2A

Guided Step 2 - Check the Gas Mass Flow Sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Gas Mass Flow Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Gas Mass Flow Sensor, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Gas Mass Flow Sensor. Refer to Procedure 019-101.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Gas Mass Flow Sensor
  • Connect the electronic service tool.

Action

Check the Gas Mass Flow Sensor supply voltage.

  • Measure the sensor supply voltage.

8 to 15 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the CM558
  • Connect the electronic service tool.

Action

Check the Gas Mass Flow Sensor signal voltage.

  • Measure the signal voltage at the main harness CM558 connector with a multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Gas Mass Flow Sensor. Refer to Procedure 019-101.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Gas Mass Flow Sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform all these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Gas Mass Flow Sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Gas Mass Flow Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Gas Mass Flow Sensor supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Gas Mass Flow Sensor return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Gas Mass Flow Sensor signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Gas Mass Flow Sensor

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Gas Mass Flow Sensor return pin on the engine harness connector to the Gas Mass Flow Sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Gas Mass Flow Sensor.

Action

Check for the appropriate CM558 response.

  • Place a jumper line between the Gas Mass Flow Sensor supply pin and the Gas Mass Flow Sensor signal pin on the sensor connector.
  • Check the appropriate CM558 response after thirty seconds.
  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 453 will become active upon installing the jumper.

Fault Code 454 is inactive?
YES NO
No Repair

Repair

Contact the nearest Authorized Cummins Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 454 is inactive.

Fault Code 454 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Authorized Cummins Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service too, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the CM700.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 — female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the Fuel Control Valve Actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the actuator supply voltage. | 24 VDC?
 | STEP 2C. Check the actuator signal Voltage. | 24 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 455 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 455 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.

Fault Codes 441, 442 or 477, 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Fuel Control Valve Actuator.

Guided Step 2A - Inspect the actuator and the harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Fuel Control Valve Actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins

Repair or replace the engine harness or the Fuel Control Valve Actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Control Valve Actuator. 006-049 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check actuator supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect the electronic service tool.

Action

Check the Fuel Control Valve Actuator supply voltage.

  • Measure the supply voltage with a multimeter.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Reference the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check actuator signal voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect the electronic service tool.

Action

Check the fuel control valve actuator signal voltage.

  • Measure the signal voltage with a multimeter. The pulse-width modulated signal should be alternating between positive (+) 24 VDC and 0 VDC.

24 VDC?
YES NO

Repair

Replace the Fuel Control Valve Actuator. 006-049 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Fuel Control Valve Actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform all these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Fuel Control Valve Actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Fuel Control Valve Actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Fuel Control Valve Actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Fuel Control Valve Actuator signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Fuel Control Valve Actuator

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the Fuel Control Valve Actuator supply pin on the engine harness connector to the Fuel Control Valve Actuator supply pin on the engine harness connector.
  • Measure the resistance from the Fuel Control Valve Actuator return pin on the engine harness connector to the Fuel Control Valve Actuator return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Fuel Control Valve Actuator connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 511 will become active upon disconnecting the actuator.

Fault Code 455 is inactive?
YES NO
No Repair

Repair

Contact the nearest Authorized Cummins Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 455 is inactive.

Fault Code 455 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Authorized Cummins Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service too, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead, Part Number 3823995 - male Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit on the capacitive coil driver connector. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the capacitive coil driver. |
 | STEP 3A. Check the ignition timing signal. | 5 VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 458 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 458 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the pins of the CM558 connectors and the capacitive coil driver connector for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-208 or Refer to Procedure 019-204.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit on the capacitive coil driver connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24 VDC supply pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24 VDC return pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the ignition timing signal pin to all other pins on the CM558 connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply, and power return lines.

  • Measure the resistance from the ignition timing signal pin on the capacitive coil driver wiring harness connector to the ignition timing signal pin on the CM558 connector.
  • Measure the resistance from the 24 VDC supply pin on the capacitive coil driver wiring harness connector to the 24 VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24 VDC return pin on the capacitive coil driver wiring harness connector to the 24 VDC return on the power supply.
  • Measure the resistance from the 24 VDC supply pin on the CM558 wiring harness connector to the 24 VDC supply on the power supply.
  • Measure the resistance from the 24 VDC return pin on the CM558 wiring harness connector to the 24 VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 3A

Go to 5A

Guided Step 3 - Check the capacitive coil driver.

Guided Step 3A - Check the ignition timing signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connectors from the right bank CM558.

Action

Check the voltage on the ignition timing signal pin of the CM558 main harness connector.

  • Install a jumper across the contacts of the capacitive coil driver power supply relay. Ensure that 24 VDC is applied to the circuit.
  • Use a multimeter to measure the ignition timing signal voltage.

5 VDC?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use the electronic service tool to verify the fault codes.

Fault Codes 458 inactive?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Verify the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 458 is inactive.

Fault Code 458 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead, Part Number 3823995 - male Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to pin short circuit on the capacitive coil driver connector. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the capacitive coil driver. |
 | STEP 3A. Check the ignition timing signal. | 5 VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 459 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 459 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the pins of the CM558 connectors and the capacitive coil driver connector for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-208 or Refer to Procedure 019-204.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the capacitive coil driver connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24 VDC supply pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24 VDC return pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the ignition timing signal pin to all other pins on the CM558 connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin on the capacitive coil driver wiring harness connector to engine block ground.
  • Measure the resistance from the 24 VDC supply pin on the capacitive coil driver harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply, and power return lines.

  • Measure the resistance from the ignition timing signal pin on the capacitive coil driver wiring harness connector to the ignition timing signal pin on the CM558 connector.
  • Measure the resistance from the 24 VDC supply pin on the capacitive coil driver wiring harness connector to the 24 VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24 VDC return pin on the capacitive coil driver wiring harness connector to the 24 VDC return on the power supply.
  • Measure the resistance from the 24 VDC supply pin on the CM558 wiring harness connector to the 24 VDC supply on the power supply.
  • Measure the resistance from the 24 VDC return pin on the CM558 wiring harness connector to the 24 VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 3A

Go to 5A

Guided Step 3 - Check the capacitive coil driver.

Guided Step 3A - Check the ignition timing signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connectors from the right bank CM558.

Action

Check the voltage on the ignition timing signal pin of the CM558 main harness connector.

Install a jumper across the contacts of the capacitive coil driver power supply relay. Ensure that 24 VDC is applied to the circuit.

  • Use a multimeter to measure the ignition timing signal voltage.

5 VDC?
YES NO
No Repair

Repair

Contact the nearest authorized Cummins repair location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use the electronic service tool to verify the fault codes.

Fault Codes 459 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized Cummins repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Verify the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 459 is inactive.

Fault Code 459 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement.Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin on the Capacitive Coil Driver connector. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | More than 100k ohms?
STEP 3. | Check the Capacitive Coil Driver. |
 | STEP 3A. Check the ignition reference signal. | 5 VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 459 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 459 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Capacitive Coil Driver
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the engine harnes and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Clean the connector and pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the Capacitive Coil Driver connector.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Capacitive Coil Driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition reference signal pin to all others on the Capacitive Coil Driver wiring harness connector.
  • Measure the resistance from the 24 VDC supply pin to all other pins on the Capacitive Coil Driver wiring harness connector.
  • Measure the resistance from the 24 VDC return pin to all other pins on the Capacitive Coil Driver wiring harness connector.
  • Measure the resistance from the ignition reference signal pin to all others on the CM558 connectors.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Capacitive Coil Driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply and power return lines.

  • Measure the resistance from the ignition reference signal pin on the capacitive coil driver wiring harness connector to the ignition reference signal pin on the CM558 connector.
  • Measure the resistance from the 24 VDC supply pin on the capacitive coil driver wiring harness connector to the 24 VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24 VDC return pin on the capacitive coil driver wiring harness connector to the 24 VDC return on the power supply.
  • Measure the resistance from the 24 VDC supply pin on the CM558 wiring harness connector to the 24 VDC supply on the power supply.
  • Measure the resistance from the 24 VDC return pin on the CM558 wiring harness connector to the 24 VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 5A

Guided Step 3 - Check the Capacitive Coil Driver.

Guided Step 3A - Check the ignition reference signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main harness connectors from the right bank CM558.

Action

Check the voltage on the ignition reference signal pin on the CM558main harness connector.

  • Install a jumper across the contacts of the Capacitive Coil Driver power supply relay. Ensure that 24 VDC is applied to the circuit.
  • Measure the ignition reference signal voltage using a multimeter.

5 VDC?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • All components connected
  • Electronic service tool connected.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Fault Code 461 inactive?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Electronic service tool connected.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify the fault code is inactive.

Fault Code 461 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Electronic service tool connected.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement.Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3823995 - male Weather-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin on the Capacitive Coil Driver connector. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the Capacitive Coil Driver. |
 | STEP 3A. Check the ignition reference signal. | 5 VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 462 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 462 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Capacitive Coil Driver
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the engine harnes and CM558 connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Clean the connector and pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the Capacitive Coil Driver connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Capacitive Coil Driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition reference signal pin to all others on the Capacitive Coil Driver wiring harness connector.
  • Measure the resistance from the 24 VDC supply pin to all other pins on the Capacitive Coil Driver wiring harness connector.
  • Measure the resistance from the 24 VDC return pin to all other pins on the Capacitive Coil Driver wiring harness connector.
  • Measure the resistance from the ignition reference signal pin to all others on the CM558 connectors.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Capacitive Coil Driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the ignition reference signal pin on the Capacitive Coil Driver wiring harness connector to engine block ground.
  • Measure the resistance from the 24 VDC supply pin the Capacitive Coil Driver wiring harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the Capacitive Coil Driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal power supply and power return lines.

  • Measure the resistance from the ignition reference signal pin on the Capacitive Coil Driver wiring harness connector to the Ignition Reference Signal pin on the CM558 connector.
  • Measure the resistance from the 24 VDC supply pin on the Capacitive Coil Driver wiring harness connector to the 24 VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24 VDC return pin on the Capacitive Coil Driver wiring harness connector to the 24 VDC return on the power supply.
  • Measure the resistance from the 24 VDC supply pin on the CM558 wiring harness connector to the 24 VDC supply on the power supply.
  • Measure the resistance from the 24 VDC return pin on the CM558 wiring harness connector to the 24 VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3A

Go to 5A

Guided Step 3 - Check the Capacitive Coil Driver.

Guided Step 3A - Check the ignition reference signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main harness connectors from the right bank CM558.

Action

Check the voltage on the ignition reference signal pin on the CM558 main harness connector.

  • Install a jumper across the contacts of the Capacitive Coil Driver power supply relay. Ensure that 24 VDC is applied to the circuit.
  • Measure the ignition reference signal voltage using a multimeter.

5 VDC?
YES NO
No Repair

Repair

Contact the nearest Authorized Cummins Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for a CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • All components connected
  • Electronic service tool connected.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Fault Code 462 inactive?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Electronic service tool connected.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify the fault code is inactive.

Fault Code 462 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Electronic service tool connected.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 31-Oct-2011


Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | +17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120 VAC supplied to DC power supply. | 120 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 477 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Refer to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

+17.3 to 34.7-VDC (24-VDC system)?
YES NO
No Repair

Repair

Repair or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120 VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Verify 120 VAC supplied to DC power supply.

Measure the 120 VAC input to the DC power supply.

120 VAC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Isolated Battery Supply Circuit to see if any fuse is blown.

  • Refer to the wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

More than 100k ohms?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 477 is inactive.

Fault Code 477 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-Feb-2021


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | +17.3 to 34.7 VDC (24 VDC system)?
 | STEP 1C. Verify 120 VAC supplied to DC power supply. | 120 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | Damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 478 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Refer to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

+17.3 to 34.7 VDC (24 VDC system)?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Verify 120 VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Verify 120 VAC supplied to DC power supply.

Measure the 120 VAC input to the DC power supply.

120 VAC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-197 (Ring Terminal) in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Isolated Battery Supply Circuit to see if any fuse is blown.

  • Refer to the wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed).

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

More than 100k ohms?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 478 is inactive.

Fault Code 478 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-Feb-2021


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 481 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | Fault Code 481 inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 481 active?
YES NO

Repair

Check the position of the oil filter selection handle (if installed). Change the oil filters. 007-002 in the Troubleshooting and Repair Manual QSV81G and QSV91G, Bulletin 4021314.

No Repair

Go to 24

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the CM700 board.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 546 or 547 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 546 or 547 inactive?
YES NO
No Repair

Repair

Reference the Engine Performance troubleshooting tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop position
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 153 and 154 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position.

Action

Check the ECM.

  • Use an electronic service tool to read the active fault codes.

Fault Codes 153 and 154 active?
YES NO
No Repair

Repair

Reference the Intake Manifold Air Temperature Above Specification symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop position
  • Connect all components
  • Connect the electronics service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the CM700.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 — female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the Fuel Control Valve Actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the actuator supply voltage. | 24 VDC?
 | STEP 2C. Check the actuator signal Voltage. | 24 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 511 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 511 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.

Fault Codes 441, 442 or 477, 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Fuel Control Valve Actuator.

Guided Step 2A - Inspect the actuator and the harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Fuel Control Valve Actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins

Repair or replace the engine harness or the Fuel Control Valve Actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Control Valve Actuator. Refer to Procedure 006-049 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check actuator supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect the electronic service tool.

Action

Check the Fuel Control Valve Actuator supply voltage.

  • Measure the supply voltage with a multimeter.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Reference the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check actuator signal voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect the electronic service tool.

Action

Check the fuel control valve actuator signal voltage.

  • Measure the signal voltage with a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24 VDC and 0 VDC.

24 VDC?
YES NO

Repair

Replace the Fuel Control Valve Actuator. Refer to Procedure 006-049 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Fuel Control Valve Actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform all these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Fuel Control Valve Actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Fuel Control Valve Actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Fuel Control Valve Actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Fuel Control Valve Actuator signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Fuel Control Valve Actuator

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the Fuel Control Valve Actuator supply pin on the engine harness connector to the Fuel Control Valve Actuator supply pin on the engine harness connector.
  • Measure the resistance from the Fuel Control Valve Actuator return pin on the engine harness connector to the Fuel Control Valve Actuator return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Fuel Control Valve Actuator connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the Fuel Control Valve Actuator supply pin and the Fuel Control Valve Actuator signal pin of the sensor connector.
  • Check for the appropriate CM558 response after thirty seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 455 will become active upon installing the actuator.

Fault Code 511 is inactive?
YES NO
No Repair

Repair

Contact the nearest Authorized Cummins Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 511 is inactive.

Fault Code 511 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Authorized Cummins Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service too, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the CM700.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 — female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the Fuel Control Valve Actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the actuator supply voltage. | 24 VDC?
 | STEP 2C. Check the actuator signal Voltage. | 24 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 511 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 511 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.

Fault Codes 441, 442 or 477, 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Fuel Control Valve Actuator.

Guided Step 2A - Inspect the actuator and the harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Fuel Control Valve Actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins

Repair or replace the engine harness or the Fuel Control Valve Actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Control Valve Actuator. Refer to Procedure 006-049 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check actuator supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect the electronic service tool.

Action

Check the Fuel Control Valve Actuator supply voltage.

  • Measure the supply voltage with a multimeter.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Reference the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check actuator signal voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect the electronic service tool.

Action

Check the fuel control valve actuator signal voltage.

  • Measure the signal voltage with a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24 VDC and 0 VDC.

24 VDC?
YES NO

Repair

Replace the Fuel Control Valve Actuator. Refer to Procedure 006-049 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Fuel Control Valve Actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform all these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Fuel Control Valve Actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Fuel Control Valve Actuator.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Fuel Control Valve Actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Fuel Control Valve Actuator signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Fuel Control Valve Actuator

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the Fuel Control Valve Actuator supply pin on the engine harness connector to the Fuel Control Valve Actuator supply pin on the engine harness connector.
  • Measure the resistance from the Fuel Control Valve Actuator return pin on the engine harness connector to the Fuel Control Valve Actuator return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Fuel Control Valve Actuator connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the Fuel Control Valve Actuator supply pin and the Fuel Control Valve Actuator signal pin of the sensor connector.
  • Check for the appropriate CM558 response after thirty seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 455 will become active upon installing the actuator.

Fault Code 511 is inactive?
YES NO
No Repair

Repair

Contact the nearest Authorized Cummins Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 511 is inactive.

Fault Code 511 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Authorized Cummins Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service too, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Electronic Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the ProAct™ driver. |
 | STEP 2A. Inspect the ProAct™ driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the ProAct™ supply voltage. | 24 VDC?
 | STEP 2C. Check the ProAct™ driver position signal circuit. | Less than 20 mA?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 512 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 512 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault codes 441, 442, 447, or 448 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the ProAct™ throttle driver.

Guided Step 2A - Inspect the ProAct™ driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the ProAct™ driver.

Action

Inspect the ProAct™ driver and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the ProAct™ driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Throttle Driver. Refer to Procedure 019-429
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the ProAct™ driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the ProAct™ driver power connection
  • Connect the electronic service tool.

Action

Check ProAct™ driver supply voltage.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Reference the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the ProAct™ driver position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the ProAct™ driver position feedback connection
  • Connect the electronic service tool.

Action

Check the ProAct™ driver position signal current.

  • Connect an ampmeter in series with the positive ProAct™ position feedback wire.
  • Use a jumper wire to connect the negative (-) connection.

Less than 20 mA?
YES NO
No Repair

Repair

  • Replace the Throttle Driver. Refer to Procedure 019-429

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the ProAct™ throttle driver and the CM558.

Action

Inspect the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the ProAct™ throttle driver
  • Disconnect the engine harness from all sensors that have a shared supply or return with the ProAct™ throttle driver.

Action

Inspect the engine harness connector pins for the following:

  • Measure the resistance from the ProAct™ throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the ProAct™ throttle driver position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for one minute
  • Disconnect the ProAct™ actuator position feedback connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 513 will become active upon disconnecting the ProAct™ driver position feedback connector.

Fault Code 512 is inactive?
YES NO
No Repair

Repair

Contact a Local Cummins Authorized Repair Facility.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 512 is inactive.

Fault Code 512 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Electronic Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 — male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 441, 442, 477 or 478 active?
STEP 2. | Check the Throttle Driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24 VDC?
 | STEP 2C. Check the throttle driver position signal circuit. | Less than 4 mA?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | More than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 513 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 513 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 441, 442, 477 or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Throttle Driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Throttle Driver. Refer to Procedure 019-429.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver power connection
  • Connect the electronic service tool.

Action

Check throttle driver supply voltage.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Reference the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the throttle driver position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver position feedback connection
  • Connect the electronic service tool.

Action

Check the throttle driver position signal current.

  • Connect an ammeter in series with the positive throttle position feedback wire.
  • Use a jumper wire to connect the negative (-) connection.

Less than 4 mA?
YES NO

Repair

  • Replace the Throttle Driver. Refer to Procedure 019-429.
No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the Throttle Driver and the CM558.

Action

Inspect the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Throttle Driver
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Throttle Driver.

Action

Inspect the engine harness connector pins for the following:

  • Measure the resistance from the Throttle Driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Throttle Driver position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Throttle Driver position feedback connector.

Action

Check for an open circuit in the signal and return wire.

  • Measure the resistance from the Throttle Driver return pin on the engine harness connector to the Throttle Driver return pin on the engine harness sensor connector.
  • Measure the resistance from the Throttle Driver position signal pin on the engine harness connector to the Throttle Driver position signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running at rated speed and load.
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 513 will become active upon disconnecting the throttle driver position feedback connector.

Fault Code 513 is inactive?
YES NO
No Repair

Repair

Contact a Local Cummins Authorized Repair Facility.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 513 is inactive.

Fault Code 513 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 455 or 511 active?
STEP 2. | Check the Fuel Control Valve Actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the actuator position signal voltage. | 24 VDC?
 | STEP 2C. Check the position feedback signal voltage. | 0 to 5 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 514 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 514 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 455 or 511 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Fuel Control Valve Actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Fuel Control Valve Actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Fuel Control Valve Actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Control Valve. Refer to Procedure 006-049 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the actuator position signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect the electronic service tool.

Action

Check the Fuel Control Valve Actuator position signal voltage.

  • Measure the signal voltage using a multimeter. The pulse-width modulated signal must be alternating between positive (+) 24 VDC and 0 VDC.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and fuses in the power supply wires to the CM558. Reference the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the position feedback signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main engine harness from the Fuel Control Valve Actuator
  • Connect the electronic service tool.

Action

Check the Fuel Control Valve Actuator position feedback signal voltage.

  • Measure the position feedback signal with a multimeter. The voltage signal must be alternating between 0 and 5 VDC.

0 to 5 VDC?
YES NO
No Repair

Repair

Replace the Fuel Control Valve Actuator.

Refer to Procedure 005-052 in the Troubleshooting and Repair Manual, QSV81G and QSV91G Engine Series, Bulletin 4021314.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Control Valve Actuator and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Fuel Control Valve Actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Fuel Control Valve Actuator.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the Fuel Control Valve Actuator position feedback pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Fuel Control Valve Actuator return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Fuel Control Valve Actuator position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Fuel Control Valve Actuator.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Fuel Control Valve Actuator position feedback pin on the engine harness connector to the Fuel Control Valve Actuator position feedback pin on the engine harness sensor connector.
  • Measure the resistance from the Fuel Control Valve Actuator return pin on the engine harness connector to the Fuel Control Valve Actuator return pin on the engine harness sensor connector.
  • Measure the resistance from the Fuel Control Valve Actuator position signal pin on the engine harness connector to the Fuel Control Valve Actuator position signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for one minute
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Fault Code 514 is inactive?
YES NO
No Repair

Repair

Contact a local Authorized Cummins Repair Facility.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 514 is inactive.

Fault Code 514 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Authorized Cummins Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable.Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the Fuel Delivery Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Any damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.53 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Any damaged pins?
 | STEP 3B. Check for short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 546 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 546 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Fuel Delivery Pressure Sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 386.

Go to 2A

Guided Step 1 - Check the Fuel Delivery Pressure Sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Fuel Delivery Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Any damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Fuel Delivery Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Repair the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Delivery Pressure Sensor. Refer to Procedure 019-188.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Fuel Delivery Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Fuel Delivery Pressure Sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Fuel Delivery Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Fuel Delivery Pressure Sensor. Refer to Procedure 019-188.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Fuel Delivery Pressure Sensor and the CM558.

Action

Inspect the wiring harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Any damaged pins?
YES NO

Repair

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the Fuel Delivery Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Fuel Delivery Pressure Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the Fuel Delivery Pressure Sensor.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Fuel Delivery Pressure Sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 547 will become active upon disconnecting the sensor.

Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check CM558 signal pin resistance.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM558.
  • Disconnect the 50-pin B Deutsch connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel delivery pressure signal pin on the CM558 to the CM558 supply circuit number one return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault codes is inactive.

Conditions

  • Connect all components.
  • Connect the electrical service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and idle for one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 546 is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact the nearest Cummins Authorized Repair Location, if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cable.Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the Fuel Delivery Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Any damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.53 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Any damaged pins?
 | STEP 3B. Check for short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 547 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 547 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Fuel Delivery Pressure Sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227.

Go to 2A

Guided Step 2 - Check the Fuel Delivery Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness connector from the Fuel Delivery Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Any damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Fuel Delivery Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Repair the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Delivery Pressure Sensor. Refer to Procedure 019-188.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Fuel Delivery Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Install the Fuel Delivery Pressure Sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Fuel Delivery Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Fuel Delivery Pressure Sensor. Refer to Procedure 019-188.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the Fuel Delivery Pressure Sensor and the CM558.

Action

Inspect the wiring harness and extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Any damaged pins?
YES NO

Repair

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the Fuel Delivery Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Fuel Delivery Pressure Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the engine harness from the extension harness
  • Disconnect the engine harness from the Fuel Delivery Pressure Sensor.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel delivery pressure supply pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure signal pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel delivery pressure return pin on the engine harness connector to the fuel delivery pressure supply pin on the engine harness sensor connector.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the Fuel Delivery Pressure Sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the Fuel Delivery Pressure Sensor supply pin and the Fuel Delivery Pressure Sensor signal pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 546 will become active upon installing the jumper wire.

Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check CM558 signal pin resistance.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Disconnect the main harness connectors from the CN558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel delivery pressure signal pin on the CM558 to the CM558 sensor supply circuit number one return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault codes is inactive.

Conditions

  • Connect all components
  • Connect the electrical service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run position and idle for one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 546 is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact the nearest Cummins Authorized Repair Location, if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting tree

Last Modified: 31-Oct-2011


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level (55-t05-556)

This procedure is not yet available at the time of publication.

Last Modified: 17-May-2022


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Repair

Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following breakout tool when taking a measurement:Part Number 3164752 - pressure sensor breakout cable

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 592 active?
STEP 2. | Check the exhaust back pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit form pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a Left Bank CM558 response |
 | STEP 4A. Check for an appropriate Left Bank CM558 response. | Fault Code 592 is inactive?
 | STEP 4B. Check the Left Bank CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive | Fault Code 591 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the exhaust back pressure sensor.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 239.

Go to 2A

Guided Step 2 - Check the Exhaust Back Pressure Sensor .

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness connector from the exhaust back pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the exhaust back pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the exhaust back pressure sensor. Refer to Procedure 019-347.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the exhaust back pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the exhaust back pressure sensor breakout cable between the sensor and the harness connector
  • Connect the electronic service tool.

Action

Check the exhaust back pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the exhaust back pressure sensor. Refer to Procedure 019-347.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the stop mode
  • Disconnect the engine harness from the exhaust back pressure sensor and the Left Bank CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the exhaust back pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the exhaust back pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the exhaust back pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the exhaust back pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the exhaust back pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the exhaust back pressure return pin on the engine harness connector to the exhaust back pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the exhaust back pressure signal pin on the engine harness connector to the exhaust back pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the exhaust back pressure supply pin on the engine harness connector to the exhaust back pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a Left Bank CM558 response.

Guided Step 4A - Check for an appropriate Left Bank CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust back pressure sensor connector.

Action

Check for the appropriate Left Bank CM558 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 592 will become active upon disconnecting the sensor.

Fault Code 592 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the Left Bank CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto pin in Stop mode
  • Disconnect the 50 pin A Deutsch connector from the Left Bank CM558.
  • Disconnect the 50 pin B Deutsch connector from the Left Bank CM558.

Action

Check the Left Bank CM558 signal pin resistance.

  • Measure the resistance from the exhaust back pressure signal pin on the Left Bank CM558 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 591 is inactive.

Fault Code 591 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto/switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following breakout tool when taking a measurement:Part Number 3164752 - pressure sensor breakout cable

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 238 active?
STEP 2. | Check the exhaust back pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit form pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a Left Bank CM558 response |
 | STEP 4A. Check for an appropriate Left Bank CM558 response. | Fault Code 592 is inactive?
 | STEP 4B. Check the Left Bank CM558 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive | Fault Code 592 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the exhaust back pressure sensor.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 238.

Go to 2A

Guided Step 2 - Check the Exhaust Back Pressure Sensor .

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness connector from the exhaust back pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the exhaust back pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the exhaust back pressure sensor. Refer to Procedure 019-347.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the exhaust back pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the exhaust back pressure sensor breakout cable between the sensor and the harness connector
  • Connect the electronic service tool.

Action

Check the exhaust back pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the exhaust back pressure sensor. Refer to Procedure 019-347.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the stop mode
  • Disconnect the engine harness from the exhaust back pressure sensor and the Left Bank CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the exhaust back pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the exhaust back pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the exhaust back pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the exhaust back pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the exhaust back pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the exhaust back pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the exhaust back pressure return pin on the engine harness connector to the exhaust back pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the exhaust back pressure signal pin on the engine harness connector to the exhaust back pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the exhaust back pressure supply pin on the engine harness connector to the exhaust back pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a Left Bank CM558 response.

Guided Step 4A - Check for an appropriate Left Bank CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust back pressure sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate Left Bank CM558 response.

  • Place a jumper wire between the exhaust back pressure sensor supply pin and the exhaust back pressure signal pin of the sensor connector.
  • Check the appropriate Left Bank CM558 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 591 will become active upon installing the jumper.

Fault Code 591 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the Left Bank CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto pin in Stop mode
  • Disconnect the 50 pin A Deutsch connector from the Left Bank CM558.
  • Disconnect the 50 pin B Deutsch connector from the Left Bank CM558.

Action

Check the Left Bank CM558 signal pin resistance.

  • Measure the resistance from the exhaust back pressure signal pin on the Left Bank CM558 to the Left Bank CM558 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 592 is inactive.

Fault Code 592 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto/switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 31-Oct-2011


Intake Restriction #2 High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81 and QSV91 CM700 | 4021314

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 619 active or more than one inactive count within the last 25 hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit..

Action

Check for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 619 active or more than one inactive count within the last 25 hours?
YES NO

Repair

Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 2A

No Repair

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Feb-2017


FAULT CODE 641 - Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1618 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overhead adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the the recommended Cummins® electronic tool or equivalent.
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the· the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1618 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • · Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 29-Sep-2021


FAULT CODE 642 - Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1521 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overhead adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1521 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 29-Sep-2021


FAULT CODE 643 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1522 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overhead adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1522 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete.

Escalate or call for assistance.

Last Modified: 29-Sep-2021


FAULT CODE 644 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1523 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1523 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 645 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1524 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1524 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 646 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1525 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1525 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 647 - Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1526 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1526 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 648 - Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1527 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1527 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 651 - Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1528 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1528 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 652 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1529 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overhead adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1529 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected. Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 653 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1619 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overhead adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1619 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 654 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1531 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1531 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 655 - Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1532 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1532 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19;

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 656 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1533 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overhead adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1533 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 657 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1534 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1534 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration

Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FC 658- Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV81G CM700/QSV91G CM700 | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV81G CM700/QSV91G CM700 | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV81G CM700/QSV91G CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1535 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. |
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Adjustments correct?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Code 1535 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Oct-2021


FAULT CODE 671 - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 671 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1618 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 671 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart.

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.· Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent..
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault code 1618 active?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1618

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 672 - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 672 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1521 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 672 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1521 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1521

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 673 - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 673 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1522 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 673 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes

Fault Code 1522 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1522

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 674 - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. |
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1523 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 674 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1523 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1523

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 675 - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 675 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1524 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault codes 675 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1524 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1524

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table .

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 676 - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 676 active?
STEP 2. | Exhaust gas temperature sensor and circuit check |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1525 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 676 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1525 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1525

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 677 - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 677 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response | Fault Code 1526 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 677 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1526 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1526

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 678 - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 678 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1527 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 678 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1527 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1527

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Repair

Contact your Local Cummins Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 698 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 698 active?
YES NO

Repair

Contact your Local Cummins Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Extended Crankcase Blowby Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead, Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 426 or 427 active?
STEP 2. | Check the Crankcase Blowby Pressure Sensor. |
 | STEP 2A. Inspect the sensor and the engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CENSE™ response. |
 | STEP 4A. Check for an appropriate CENSE™ response. | Fault Code 719 inactive?
 | STEP 4B. Check the CENSE™ signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 719 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.
  • Check for J1939 datalink Fault Codes 426 and 427.

Fault Codes 426 or 427 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 426 or 427

Go to 2A

Guided Step 2 - Check the Crankcase Blowby Pressure Sensor and circuit.

Guided Step 2A - Check the Crankcase Blowby Pressure Sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Crankcase Blowby Pressure Sensor

Action

Inspect the sensor and engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or the Crankcase Blowby Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Crankcase Blowby Pressure Sensor. Refer to Procedure 019-011.

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Crankcase Blowby Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Crankcase Blowby Pressure Sensor signal voltage.

Measure the signal voltage by installing the breakout cable's supply and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Crankcase Blowby Pressure Sensor. Refer to Procedure 019-011.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Crankcase Blowby Pressure Sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Crankcase Blowby Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Crankcase Blowby Pressure Sensor.

Action

Check for a short from pin to pin.

  • Measure the resistance from the crankcase blowby pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the crankcase blowby pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the crankcase blowby pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Crankcase Blowby Pressure Sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the crankcase blowby pressure return pin on the engine harness connector to the crankcase blowby pressure return pin on the engine harness sensor connector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Check for a CENSE™ response.

Guided Step 4A - Check for an appropriate CENSE™ response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Crankcase Blowby Pressure Sensor connector.

Action

Check for an appropriate CENSE™ response.

  • Using the electronic service tool, verify that fault codes.

Note: Fault Code 729 will become active upon disconnecting the sensor.

Fault Code 719 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CENSE™ signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CENSE™ module.

Action

Check the CENSE™ signal pin resistance.

  • Measure the resistance from the crankcase blowby pressure signal pin on the CENSE™ to the CENSE™ sensor supply return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine running for greater than one minute.

Action

Verify that fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 719 is inactive.

Fault Code 719 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2022


FAULT CODE 721 - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 721 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1529 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 721 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes

Fault Code 1529 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1529

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 722 - Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 722 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1619 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 722 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1619 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1619

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 723 - Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 723 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1531 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 723 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1531 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1531

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 10-Mar-2022


FAULT CODE 724 - Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 724 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1532 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 724 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1532 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1532

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 10-Mar-2022


FAULT CODE 725 - Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 725 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1533 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 725 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1533 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1533

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 10-Mar-2022


FAULT CODE 726 - Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 726 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1534 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 726 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1534 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1534

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 10-Mar-2022


FAULT CODE 727 - Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 727 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1535 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 727 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1535 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1535

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Mar-2022


FAULT CODE 728 - Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 728 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1536 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 728 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1536 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1536

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 10-Mar-2022


Extended Crankcase Blowby Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead, Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 426 or 427 active?
STEP 2. | Check the Crankcase Blowby Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CENSE™ response. |
 | STEP 4A. Check for the appropriate CENSE™ response. | Fault Code 729 inactive?
 | STEP 4B. Check the CENSE™ signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that Fault Code 729 is inactive. | Fault Code 729 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.
  • Check for J1939 datalink Fault Codes 426 and 427.

Fault Code 426 or 427 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 426 or 427

Go to 2A

Guided Step 2 - Check the Crankcase Blowby Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Crankcase Blowby Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the Crankcase Blowby Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Crankcase Blowby Pressure Sensor. Refer to Procedure 019-011.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Crankcase Blowby Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Crankcase Blowby Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Crankcase Blowby Pressure Sensor. Refer to Procedure 019-011.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Crankcase Blowby Pressure Sensor and the CENSE™ module.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the Crankcase Blowby Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Crankcase Blowby Pressure Sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Crankcase Blowby Pressure Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Crankcase Blowby Pressure Sensor supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Crankcase Blowby Pressure Sensor return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Crankcase Blowby Pressure Sensor signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Crankcase Blowby Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the Crankcase Blowby Pressure Sensor return pin on the engine harness connector to the Crankcase Blowby Pressure Sensor return pin on the engine harness sensor connector.
  • Measure the resistance from the Crankcase Blowby Pressure Sensor signal pin on the engine harness connector to the Crankcase Blowby Pressure Sensor signal pin on the engine harness sensor connector.
  • Measure the resistance from the Crankcase Blowby Pressure Sensor supply pin on the engine harness connector to the Crankcase Blowby Pressure Sensor supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CENSE™ response.

Guided Step 4A - Check for the appropriate CENSE™ response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Crankcase Blowby Pressure Sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate CENSE™ response.

  • Place a jumper wire between the Crankcase Blowby Pressure Sensor supply pin and the Crankcase Blowby Pressure Sensor signal pin of the sensor connector.
  • Check for the appropriate CENSE™ response after 30 seconds.
  • Use the electronic service tool to read the fault codes.

Note: Fault Code 719 will become active upon installing the jumper.

Fault Code 729 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CENSE™ signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connectors from the CENSE™ module.

Action

Check the CENSE™ signal pin resistance.

  • Measure the resistance from the crankcase blowby pressure signal pin on CENSE™ to the CENSE™ sensor supply return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that Fault Code 729 is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 729 is inactive.

Fault Code 729 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2022


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active Fault Codes. | Fault Codes 453 or 454 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active Fault Codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than one minute.

Action

Check the Electronic Control Module (ECM).

  • Using the electronic service tool, read the active fault codes.

Fault Codes 453 or 454 active?
YES NO
No Repair

Repair

Reference the fuel system symptoms in the Engine Performance Troubleshooting Tree in Section TT on this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault code.

Conditions

  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault code.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 753 active?
STEP 2. | Check the Camshaft Position Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Inspect the sensor for damage. | Damaged Camshaft Position Sensor?
 | STEP 2C. Check the resistance of the sensor. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2E. Check for short circuit between coils. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 2k ohms?
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 753 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Connect the electronic service tool.

Action

Using the electronic service tool, read the fault codes.

Fault Code 753 active?
YES NO
No Repair

Repair

Using the electronic service tool, clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check the Camshaft Position Sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Camshaft Position Sensor.

Action

Inspect the engine harness and Camshaft Position Sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Camshaft Position Sensor. Refer to Procedure 019-363.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Camshaft Position Sensor.

Action

Inspect the Camshaft Position Sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Damaged Camshaft Position Sensor?
YES NO

Repair

Repair or replace the Camshaft Position Sensor. Refer to Procedure 019-363.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Camshaft Position Sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the Camshaft Position Sensor signal positive (+) pin to the Camshaft Position Sensor return negative (-) pin in the Camshaft Position Sensor connector.
  • Measure the resistance from the Camshaft Position Sensor backup signal positive (+) pin to the Camshaft Position Sensor backup return negative (-) pin in the Camshaft Position Sensor connector.

Note: While testing the sensor, electrical leads must be gently flexed to check for damage or partially broken wires under the insulation.

Less than 2k ohms?
YES NO
No Repair

Repair

Repair or replace the Camshaft Position Sensor. Refer to Procedure 019-363.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Camshaft Position Sensor
  • Camshaft Position Sensor installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the signal pin in the Camshaft Position Sensor to the engine block ground.
  • Measure the resistance from the backup signal pin in the Camshaft Position Sensor to the engine block ground.

Note: While testing the sensor, electrical leads must be gently flexed to check for damage or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the Camshaft Position Sensor. Refer to Procedure 019-363.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit between coils.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Camshaft Position Sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the Camshaft Position Sensor signal pin of one coil and the Camshaft Position Sensor signal pin of the other coil.
  • Measure the resistance between the Camshaft Position Sensor return pin to the Camshaft Position Sensor return pin.

Note: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Camshaft Position Sensor. Refer to Procedure 019-363.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Moisture or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Connect the engine harness to the Camshaft Position Sensor.

Action

Check for an open circuit.

  • Measure the resistance from the Camshaft Position Sensor signal pin to the speed sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 2k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Disconnect the engine harness from the Camshaft Position Sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the Camshaft Position Sensor signal pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Disconnect the engine harness from the Camshaft Position Sensor.

Action

Check for a short circuit pin to pin.

  • Measure the resistance between the Camshaft Position Sensor signal pin and all other pins of the engine harness connector.
  • Measure the resistance between the Camshaft Position Sensor return pin and all other pins of the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Clear the fault codes.

  • Using the electronic service tool, verify that Fault Code 753 is inactive.

Fault Code 753 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked.

Go to 4B

Go to 2A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active Fault Code 783. | Fault Code 783 active?
 | STEP 1B. Check the ECM for any other active fault codes. | Other fault codes active?
STEP 2. | Inspect the intake manifold 1 temperature sensor. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor electrical connections. | Dirty or damaged pins?
 | STEP 2B. Verify intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Thermocouple reading agree with the intake manifold 1 temperature sensor reading on INSITE™ electronic service tool?
STEP 3. | Inspect the coil-on-plug assemblies. |
 | STEP 3A. Inspect the coil-on-plug assembly harness and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Inspect the coil-on-plug assemblies for cracks or other damage to the extension tube, coil extension spark plug boost, and o-rings. | Damage found?
STEP 4. | Inspect the spark plugs. |
 | STEP 4A. Inspect the spark plugs for damage to the electrode and porcelain, as well as for any signs of HT tracking down the plug porcelain to ground. | Damage found?
STEP 5. | Check the air/fuel ratio. |
 | STEP 5A. Check the air/fuel ratio is correct as per engine rating/specification. | Air/fuel ratio to specification?
STEP 6. | Inspect the intake air filters for excessive restriction. |
 | STEP 6A. Check the air filter restriction. | Restriction present?
STEP 7. | Inspect the air/fuel mixer for damage. |
 | STEP 7A. Inspect the air/fuel mixer for damage. | Damage found?
STEP 8. | Inspect the turbocharger for damage. |
 | STEP 8A. Inspect the turbocharger for damage. | Damaged or out of specification found?
STEP 9. | Inspect the charge-air system for damage. |
 | STEP 9A. Inspect the charge-air system for visible damage. | Damage found?
 | STEP 9B. Inspect the charge-air system for leaks. | Leak found?
STEP 10. | Inspect the throttle and throttle mounting flange. |
 | STEP 10A. Inspect the throttle driver and engine harness electrical connections. | Dirty or damaged pins?
 | STEP 10B. Inspect the throttle for damage. | Damage or misalignment found?
 | STEP 10C. Inspect the throttle mounting flange for leaking or cracks. | Leak or crack found?
 | STEP 10D. Inspect the throttle plate alignment. | Throttle plate misaligned?
 | STEP 10E. Check the throttle for free movement throughout the full range of movement. | Does the throttle drive through its full range with no throttle position feedback errors reported on INSITE™ electronic service tool?
STEP 11. | Check engine compression. |
 | STEP 11A. Check individual cylinder compression pressures. | Gross leakage detected?
STEP 12. | Check high temperature cooling system for leaks. |
 | STEP 12A. Check individual cylinders for signs of high temperature coolant leakage between the cylinder head and engine block. | High temperature coolant leakage detected?
STEP 13. | Clear the fault code. |
 | STEP 13A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 13B. Verify the fault code is inactive. | Fault Code 783 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault code 783.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 783 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM for any other active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for any other active fault codes

  • Use INSITE™ electronic service tool to read the fault codes.

Other fault codes active?
YES | NO
No Repair | No Repair

Refer to the appropriate fault code troubleshooting procedure within Section TF.

Go to 3A

Guided Step 2 - Inspect the intake manifold 1 temperature sensor.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the intake manifold 1 temperature sensor and the engine harness connectors and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the intake manifold 1 temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold 1 air temperature sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 13A

Go to 2B

Guided Step 2B - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a 3A thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold, except at the probe threads.
  • Compare the intake manifold 1 temperature sensor reading on the INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer Yes to this step.

Does the thermocouple reading agree with the intake manifold temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 13A

Guided Step 3 - Inspect the coil-on-plug assemblies.

Guided Step 3A - Inspect the coil-on-plug assembly harness and electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the-coil-on plug assembly connectors, the engine harness connectors, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the coil-on-plug assembly, whichever has the dirty or damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coil-on-plug. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 013-024 in Section 13.
No Repair

Go to 13A

Go to 3B

Guided Step 3B - Inspect the coil-on-plug assemblies for cracks or other damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the coil-on-plug assemblies for cracks or other damage.

  • Inspect the coil-on-plug. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 013-024 in Section 13.

Damage found?
YES NO

Repair

  • Replace the coil-on-plug. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 013-024 in Section 13.
No Repair

Go to 13A

Go to 4A

Guided Step 4 - Inspect the spark plugs.

Guided Step 4A - Inspect the spark plugs.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plugs for cracks or other damage.

  • Inspect the spark plugs. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 013-016 in Section 13.

Damage found?
YES NO

Repair

Replace the spark plugs as necessary.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 13A

Go to 5A

Guided Step 5 - Check the air/fuel ratio.

Guided Step 5A - Check the air/fuel ratio is correct as per engine rating/specification.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode, generator circuit breaker closed, and rated load applied.

Action

Verify that the air/fuel ratio is not too rich.

  • Use the air/fuel adjustment wizard to verify the engine is not operating too rich with INSITE™ electronic service tool.

Air/fuel ratio to specification?
YES NO

Repair

Correct the air/fuel ratio. Use INSITE™ electronic service tool.

 No Repair

Go to 13A

Go to 6A

Guided Step 6 - Inspect the intake air filters for excessive restriction.

Guided Step 6A - Check for air filter restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air filter restriction or damage that may cause excessive restriction.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 010-086 in Section 3.

Restriction present?
YES NO

Repair

Replace the air cleaner elements.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-014 in Section 10.
No Repair

Go to 13A

Go to 7A

Guided Step 7 - Inspect air/fuel mixer for damage.

Guided Step 7A - Inspect air/fuel mixer for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-003 in Section 5.

Damage found?
YES NO

Repair

Replace the air/fuel mixer.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-003 in Section 5.
No Repair

Go to 13A

Go to 8A

Guided Step 8 - Inspect the turbocharger for damage.

Guided Step 8A - Inspect the turbocharger for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the turbocharger radial bearing clearance, axial bearing clearance, and impeller for damage or out-of-specification condition.

  • Check the turbocharger axial clearance. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 010-038 in Section 8.
  • Check the turbocharger radial clearance. Use the following procedure in the Operation and Maintenance Manual QSK60G Generator CM700, Bulletin 4021313. Refer to Procedure 010-047 in Section 8.

Damage or out of specification found?
YES NO

Repair

Replace the turbocharger.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-033 in Section 10.
No Repair

Go to 13A

Go to 9A

Guided Step 9 - Inspect the charge-air system for damage.

Guided Step 9A - Inspect the charge-air system for visible damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for damage.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-024 in Section 10.
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-001 in Section 10.

Damage found?
YES NO

Repair

Repair or replace the damaged items.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-024 in Section 10.
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-136 in Section 10.
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-001 in Section 10.
No Repair

Go to 13A

Go to 9B

Guided Step 9B - Inspect the charge-air system for leaks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for leaks.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-024 in Section 10.
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-001 in Section 10.

Leak found?
YES NO

Repair

Repair or replace the damaged items.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-024 in Section 10.
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-136 in Section 10.
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-001 in Section 10.
No Repair

Go to 13A

Go to 10A

Guided Step 10 - Inspect the throttle and throttle mounting flange.

Guided Step 10A - Inspect the throttle driver and engine harness electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the throttle driver connectors, engine harness connectors, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the throttle driver assembly, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 13A

Go to 10B

Guided Step 10B - Inspect the throttle for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the throttle for damage, valve misalignment, and freedom of valve rotational movement.

  • Inspect the throttle for damage.

Damage or misalignment found?
YES NO

Repair

Repair or replace the throttle body assembly.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 13A

Go to 10C

Guided Step 10C - Inspect the throttle mounting flange for leaking or cracks.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the throttle mounting flange for leaking or cracks.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-024 in Section 10.

Leak or crack found?
YES NO

Repair

Repair or replace the throttle body assembly.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 13A

Go to 10D

Guided Step 10D - Inspect the throttle plate alignment.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the throttle plate alignment.

  • Check the throttle plate alignment within the air/fuel intake plenum. The throttle body must be centered within the plenum.

Throttle plate misaligned?
YES NO

Repair

  • Loosen the throttle plate mounting bolts and align the throttle plate on the throttle shaft so the throttle plate is centered within the air/fuel intake plenum.
No Repair

Go to 13A

Go to 10E

Guided Step 10E - Check the throttle plate for free movement throughout the full range of movement.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the throttle plate for free movement throughout the full range of movement.

  • Use INSITE™ electronic service tool to check the throttle plate for free movement throughout the full-range of movement.

Does the throttle drive through its full range with no throttle position feedback errors reported on INSITE™ electronic service tool?

YES NO

Repair

Repair or replace the throttle assembly.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 13A

Go to 11A

Guided Step 11 - Check engine compression.

Guided Step 11A - Check individual cylinder compression pressures.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check individual cylinder compression for gross leakage.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 014-012 in Section 14.

Gross leakage detected?
YES NO

Repair

Replace cylinder head gaskets as required. Check cylinder head retaining bolt length to specification and replace as required.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 014-012 in Section 14.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 13A

Go to 12A

Guided Step 12 - Check high temperature cooling system for leaks.

Guided Step 12A - Check individual cylinders for signs of high temperature coolant leakage between the cylinder head and engine block.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check individual cylinders for signs of high temperature coolant leakage between the cylinder head and engine block.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 002-004 in Section 14.

High temperature coolant leakage detected?
YES NO

Repair

Replace cylinder head gaskets as required. Check cylinder head retaining bolt length to specification and replace as required.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 002-004 in Section 2.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 13A

Go to 13A

Guided Step 13 - Clear the fault codes.

Guided Step 13A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine turn keyswitch. Use INSITE™ electronic service tool to verify the inactive fault codes are cleared.

Fault Code 783 cleared?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 13B

Appropriate troubleshooting steps

Guided Step 13B - Verify the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 783 is inactive.

Fault code inactive?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Last Modified: 25-Aug-2014


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2517 or 2518 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2517 or 2518 active?
YES NO
No Repair

Repair

Check the turbocharger. Refer to Procedure 010-033 in the QSV81G and QSV91G Troubleshooting and Repair Manual, Bulletin 4021413.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-Nov-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Reference the appropriate troubleshooting procedure. |

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Reference the appropriate troubleshooting procedure.

Conditions

None

Action

Reference the appropriate troubleshooting procedures.

  • Check the manual fuel shutoff valve has been completely opened.
  • Check the fuel shutoff valve for proper operation.
  • Check the engine air filters for restriction.
  • Check the fuel filter for contamination.
  • Check the throttle body assembly for proper operation.

Are engine fuel and air handling systems operating correctly?
YES NO

Repair

  • Allow the engine to warm up.

Repair

Refer to Procedure 005-044, Refer to Procedure 005-052,Refer to Procedure 006-063 and Refer to Procedure 010-031 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.

Reference the Coolant Temperature is Below Normal and Lubricating Oil Temperature Above Specification, troubleshooting symptom charts.

Repair complete.

Repair complete.

Last Modified: 01-Nov-2011


FAULT CODE 1362 - Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil and Filters | Refer to Procedure 007-002 | QSV81 and QSV91 CM700 | 4021314

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active or inactive fault codes. |
 | STEP 1A. Check for Fault Code 1362. | Active or inactive counts of Fault Code 1362?
 | STEP 1B. Check for multiple fault codes. | Active or inactive counts of Fault Codes 143, 415, 556, 1367, 1368, 1377, and 1378?
STEP 2. | Lubricating oil filters |
 | STEP 2A. Replace the lubricating oil filters. | Oil filters contaminated?
STEP 3. | Lubricating oil pressure sensors. |
 | STEP 3A. Check the pre-filter and post-filter lubricating oil pressure sensors. | Pressure sensor malfunctioning?
STEP 4. | Lubricating oil filter head |
 | STEP 4A. Check the lubricating oil filter head. | Lubricating oil filter head malfunctioning?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1362 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active or inactive fault codes.

Guided Step 1A - Check for Fault Code 1362.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1362?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for multiple fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Codes 143, 415, 556, 1367, 1368, 1377, and 1378?
YES NO

Repair

Troubleshoot any of the above fault codes. See relevant fault code tree in Section TF of this manual.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Lubricating oil filters

Guided Step 2A - Replace the lubricating oil filters.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Remove, inspect, and replace the lubricating oil filters.

  • Refer to Procedure 007-002 in the Associated Procedures Table.
  • Cut open the lubricating oil filters and identify any debris or oil contamination. Check the lubricating oil condition as per Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin 3810340.
  • Contact a Cummins® Authorized Repair Location.

Oil filters contaminated?
YES NO

Repair

NOTE: Replace the engine lubricating oil if the oil shows signs of contamination or the oil analysis results recommend that the lubricating oil should be replaced.

  • Refer to Procedure 007-002 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Lubiricating oil pressure sensors

Guided Step 3A - Check the pre-filter and post-filter lubricating oil pressure sensors.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the operation and range of pre-filter and post-filter lubricating oil pressure sensors.

Pressure sensor malfunctioning?
YES NO

Repair

Replace pressure sensor.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Lubricating oil filter head

Guided Step 4A - Check the lubricating oil filter head.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the lubricating oil filter head assembly.

Lubricating oil filter head malfunctioning?
YES NO

Repair

Repair or replace as required.

 No Repair

Go to 5A

5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for greater than 1 minute.

Action

Use INSITE™ electronic service tool to verify Fault Code 1362 is inactive.

Fault Code 1362 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 24-Aug-2014


Fault Code 1448 - Generator AC Output Frequency

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check Fault Simulation Feature. |
 | STEP 1A. Verify fault simulation is not enabled. | Fault simulation is not enabled.
STEP 2. | Check the engine engine control module (ECM). |
 | STEP 2A. Check for multiple fault codes. | No other fault codes active?
 | STEP 2B. Verify that the correct ECM calibration is loaded. | Correct calibration loaded?
 | STEP 2C. Verify that the initial setup of the generator set was installed correctly. | Initial setup is correct.
 | STEP 2D. Check for overload. | No overload conditions or faults.
STEP 3. | Check generator set controller. |
 | STEP 3A. Check underfrequency threshold. | Threshold is within proper limits.
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1448 inactive.
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.
 | STEP . |

Guided Step 1 - Check fault simulation feature.

Guided Step 1A - Verify the fault simulation in not enabled.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect recommended Cummins® electronic service tool.

Action

Verify the fault simulation is not enabled.

Fault simulation enabled?
YES NO

Repair

  • Connect the recommended Cummins® electronic service tool. If not available cycle power to the generator set controller.
  • Depress the emergency stop button and wait 30 seconds.
  • Disconnect the battery. (disconnect negative first)
  • Leave the generator set controller without power for 1 minute.

Reconnect the battery, enable the battery charger, pullout the E-stop button, and reset the Generator set controller.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the engine ECM.

Guided Step 2A - Check for multiple fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the recommended Cummins® electronic service tool.

Action

Check for multiple fault codes.

  • Use recommended Cummins® electronic service tool to read the fault codes.

No other fault codes active?
YES | NO
No Repair | No Repair

Refer to the appropriate troubleshooting tree.

Go to 2B

Guided Step 2B - Verify correct calibration is loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect recommended Cummins® electronic service tool.

Action

Read the software calibration.

  • Use recommended Cummins® electronic service tool to verify that the correct calibration has been loaded into the engine control module.

Correct calibration loaded?
YES NO
No Repair

Repair

Incorrect or no calibration loaded. Load correct calibration software. Reference electronic service tool user's manual.

Go to 1C

Go to 2A

Guided Step 2C - Verify that the initial setup of the generator set was installed correctly.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect recommended Cummins® electronic service tool.

Action

Read initial setup.

  • Use INSITE™ recommended Cummins® electronic service tool to verify the initial setup was installed correctly.

Initial setup is correct?
YES NO
No Repair

Repair

Correctly install initial setup. Reference the site documentation.

Go to 2D

Go to 3A

Guided Step 2D - Check for overload.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect recommended Cummins® electronic service tool.

Action

Check for overload.

  • Use the recommended Cummins® electronic service tool to verify the load is acceptable and within proper limits.

No overload conditions or faults?
YES NO
No Repair

Repair

Generator set is being overloaded. Correctly install initial setup and correct any overload. Reference the site documentation.

Go to 3A

Go to 3A
Go to
Go to

Guided Step 3 - Check the generator set controller.

Guided Step 3A - Check the underfrequency threshold.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in STOP position.
  • Check generator set controller settings.

Action

Check the underfrequency threshold.

  • To access the operator panel, go to setup > OEM Set-up> Over frequency Threshold and set the “Over frequency Threshold’ Parameter appropriately for the application.
  • Refer to the parameter section to see the default value for over frequency.

Over frequency threshold parameter setting is correct?
YES NO
No Repair

Repair

Reset to default value.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ recommended Cummins® electronic service tool to verify Fault Code 1448 is inactive.

Clear the fault code.

  • Press reset button on generator set controller.

Fault Code 1448 inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Go to 4B

Escalate or call for assistance

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect recommended Cummins® electronic service tool.

Action

Clear the inactive fault codes.

  • Use recommended Cummins® electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Refer to the appropriate troubleshooting tree
Go to
Go to

Last Modified: 09-Feb-2021


Fault Code 1457 - Generator Synchronizing to Electric Bus Failed - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for any active fault codes. | Fault Codes 121, 234, 175, 176, 177, 512, 513, 689, 1446, 1447, 1448, 1452, 1457, 1458, 1546, 1737, 1738, 1739, 1741, 1742, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1793, 1821, 2455, 2456, 2519, 2643, 2644, 2752, 2796, 2812, 2863, 3499, 3511, 3512, 3514, 3515, 3521, 3522, 3594 and 3595 active?
STEP 2. | Check the spark plugs. |
 | STEP 2A. Check the spark plug gaps. | Spark plug electrode gap to specification?
STEP 3. | Check the throttle assemblies. |
 | STEP 3A. Check the throttle assemblies commanded position signal and position feedback signal for excessive deviation. | Throttle assemblies commanded position signal and position feedback signal exceeds 30 percent?
 | STEP 3B. Check the throttle shafts for free movement. | Throttle shafts move freely?
 | STEP 3C. Check the throttle plates for misalignment. | Throttle plates misaligned?
STEP 4. | Check the exhaust emissions. |
 | STEP 4A. Check the exhaust emissions are set to specification. | Exhaust emissions to specification?
STEP 5. | Check the speed bias sensor. |
 | STEP 5A. Check the speed bias sensor adjustment. | Speed bias sensor adjustment correct?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 1457 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify that there are no active fault codes.

  • Use INSITE™ electronic service tool to read for any active fault codes.

Fault Codes 121, 234, 175, 176, 177, 512, 513, 689, 1446, 1447, 1448, 1452, 1457, 1458, 1546, 1737, 1738, 1739, 1741, 1742, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1793, 1821, 2455, 2456, 2519, 2643, 2644, 2752, 2796, 2812, 2863, 3499, 3511, 3512, 3514, 3515, 3521, 3522, 3594 and 3595 active?

YES NO

Repair

Follow the appropriate fault code troubleshooting steps or contact a Cummins® Authorized Repair Location.

Repair

Note: Use the following procedure if any fault codes are 'Inactive'. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plugs.

Guided Step 2A - Check the spark plug gaps.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plugs and measure the spark plug electrode gap on all spark plugs. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 013-016 in Section 13.

Spark plug electrode gap to specification?
YES NO
No Repair

Repair

Repair as necessary:

  • Adjust the spark plug electrode gaps.
  • Replace the spark plugs. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 013-016 in Section 13.

Go to 3A

Go to 6A

Guided Step 3 - Check the throttle assemblies.

Guided Step 3A - Check the throttle assemblies commanded position signal and position feedback signal for excessive deviation.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle assemblies for commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the throttle plates for free movement. Use the "Actuator Diagnostics Tests" within the "ECM Diagnostics Tests" feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Throttle assemblies commanded position signal and position feedback signal exceeds 30 percent?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check the throttle shafts for free movement.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle assembly.

Action

Mechanically check the throttle shafts for free movement. Carry out the following procedures:

  • Remove the throttle assemblies. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-052 in Section 5.
  • Mechanically rotate the shaft from the fully closed to fully open position
  • Check for smooth movement through the full range
  • Check for any tight spots during the rotation of the shaft
  • Check the throttle shaft bearings for excessive free-play
  • Repeat for second throttle assembly.
  • Contact a Cummins® Authorized Repair Location.

Throttle shafts move freely?

YES NO
No Repair

Repair

Repair as necessary:

  • Replace the bearings on both throttle shafts. . Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-225 in Section 5.
  • Replace the throttle assemblies. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-052 in Section 5.
  • Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 6A

Guided Step 3C -

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle plates for misalignment:

  • Replace the throttle assemblies. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-052 in Section 5.

Throttle plates misaligned?

YES NO
No Repair

Repair

Adjust the throttle plate settings:

  • Adjust the throttle plate setting on both throttle assemblies. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-052 in Section 5.

Go to 6A

Go to 4A

Guided Step 4 - Check the exhaust emissions.

Guided Step 4A - Check the exhaust emissions are set to specification.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine at the highest possible load with no knock - must be at a minimum 70 percent load.

Action

Check the exhaust emissions are to specification:

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, to check that the exhaust emissions are to the fuel rating specification for the engine.
  • For exhaust emission specifications, use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Adjust the exhaust emissions to specification.

  • Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer to adjust the "open and closed-loop" fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 6A

Guided Step 5 - Check the speed bias sensor.

Guided Step 5A - Check the speed bias sensor adjustment.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the speed bias sensor adjustment:

  • Check that the speed bias sensor air gap setting is correctly adjusted. Refer to Procedure 019-042 in Section 19.

Speed bias sensor adjustment correct?

YES NO
No Repair

Repair

Adjust the speed bias sensor air gap to specification

  • Refer to Procedure 019-042 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Verify that the fault code is inactive:

  • Use INSITE™ electronic service tool to verify that the Fault Code 1457 is inactive.

Fault Code 1457 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Jan-2012


Fault Code 1457 - Generator Synchronizing to Electric Bus Failed - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for any active fault codes. | Fault Codes 121, 234, 175, 176, 177, 512, 513, 689, 1446, 1447, 1448, 1452, 1457, 1458, 1546, 1737, 1738, 1739, 1741, 1742, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1793, 1821, 2455, 2456, 2519, 2643, 2644, 2752, 2796, 2812, 2863, 3499, 3511, 3512, 3514, 3515, 3521, 3522, 3594 and 3595 active?
STEP 2. | Check the spark plugs. |
 | STEP 2A. Check the spark plug gaps. | Spark plug electrode gap to specification?
STEP 3. | Check the throttle assemblies. |
 | STEP 3A. Check the throttle assemblies commanded position signal and position feedback signal for excessive deviation. | Throttle assemblies commanded position signal and position feedback signal exceeds 30 percent?
 | STEP 3B. Check the throttle shafts for free movement. | Throttle shafts move freely?
 | STEP 3C. Check the throttle plates for misalignment. | Throttle plates misaligned?
STEP 4. | Check the exhaust emissions. |
 | STEP 4A. Check the exhaust emissions are set to specification. | Exhaust emissions to specification?
STEP 5. | Check the speed bias sensor. |
 | STEP 5A. Check the speed bias sensor adjustment. | Speed bias sensor adjustment correct?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 1457 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify that there are no active fault codes.

  • Use INSITE™ electronic service tool to read for any active fault codes.

Fault Codes 121, 234, 175, 176, 177, 512, 513, 689, 1446, 1447, 1448, 1452, 1457, 1458, 1546, 1737, 1738, 1739, 1741, 1742, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1793, 1821, 2455, 2456, 2519, 2643, 2644, 2752, 2796, 2812, 2863, 3499, 3511, 3512, 3514, 3515, 3521, 3522, 3594 and 3595 active?

YES NO

Repair

Follow the appropriate fault code troubleshooting steps or contact a Cummins® Authorized Repair Location.

Repair

Note: Use the following procedure if any fault codes are 'Inactive'. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plugs.

Guided Step 2A - Check the spark plug gaps.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plugs and measure the spark plug electrode gap on all spark plugs. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 013-016 in Section 13.

Spark plug electrode gap to specification?
YES NO
No Repair

Repair

Repair as necessary:

  • Adjust the spark plug electrode gaps.
  • Replace the spark plugs. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 013-016 in Section 13.

Go to 3A

Go to 6A

Guided Step 3 - Check the throttle assemblies.

Guided Step 3A - Check the throttle assemblies commanded position signal and position feedback signal for excessive deviation.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle assemblies for commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the throttle plates for free movement. Use the "Actuator Diagnostics Tests" within the "ECM Diagnostics Tests" feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Throttle assemblies commanded position signal and position feedback signal exceeds 30 percent?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check the throttle shafts for free movement.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle assembly.

Action

Mechanically check the throttle shafts for free movement. Carry out the following procedures:

  • Remove the throttle assemblies. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-052 in Section 5.
  • Mechanically rotate the shaft from the fully closed to fully open position
  • Check for smooth movement through the full range
  • Check for any tight spots during the rotation of the shaft
  • Check the throttle shaft bearings for excessive free-play
  • Repeat for second throttle assembly.
  • Contact a Cummins® Authorized Repair Location.

Throttle shafts move freely?

YES NO
No Repair

Repair

Repair as necessary:

  • Replace the bearings on both throttle shafts. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-225 in Section 5.
  • Replace the throttle assemblies. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-052 in Section 5.
  • Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 6A

Guided Step 3C -

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle plates for misalignment:

  • Replace the throttle assemblies. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-052 in Section 5.

Throttle plates misaligned?

YES NO
No Repair

Repair

Adjust the throttle plate settings:

  • Adjust the throttle plate setting on both throttle assemblies. Use the following procedure in the QSV81 and QSV91 CM700 Troubleshooting and Repair Manual, Bulletin 4021315. Refer to Procedure 005-052 in Section 5.

Go to 6A

Go to 4A

Guided Step 4 - Check the exhaust emissions.

Guided Step 4A - Check the exhaust emissions are set to specification.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine at the highest possible load with no knock - must be at a minimum 70 percent load.

Action

Check the exhaust emissions are to specification:

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, to check that the exhaust emissions are to the fuel rating specification for the engine.
  • For exhaust emission specifications, use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Adjust the exhaust emissions to specification.

  • Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer to adjust the "open and closed-loop" fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 6A

Guided Step 5 - Check the speed bias sensor.

Guided Step 5A - Check the speed bias sensor adjustment.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the speed bias sensor adjustment:

  • Check that the speed bias sensor air gap setting is correctly adjusted. Refer to Procedure 019-042 in Section 19.

Speed bias sensor adjustment correct?

YES NO
No Repair

Repair

Adjust the speed bias sensor air gap to specification

  • Refer to Procedure 019-042 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Verify that the fault code is inactive:

  • Use INSITE™ electronic service tool to verify that the Fault Code 1457 is inactive.

Fault Code 1457 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Jan-2012


Fault Code 1457 - Generator Synchronizing to Electric Bus Failed - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for any active fault codes. | Fault Codes 121, 234, 175, 176, 177, 512, 513, 689, 1446, 1447, 1448, 1452, 1457, 1458, 1546, 1737, 1738, 1739, 1741, 1742, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1793, 1821, 2455, 2456, 2519, 2643, 2644, 2752, 2796, 2812, 2863, 3499, 3511, 3512, 3514, 3515, 3521, 3522, 3594 and 3595 active?
STEP 2. | Check the spark plugs. |
 | STEP 2A. Check the spark plug gaps. | Spark plug electrode gap to specification?
STEP 3. | Check the throttle assembly. |
 | STEP 3A. Check the throttle assembly commanded position signal and position feedback signal for excessive deviation. | Throttle assembly commanded position signal and position feedback signal exceeds 30 percent?
 | STEP 3B. Check the throttle shaft for free movement. | Throttle shaft moves freely?
 | STEP 3C. Check the throttle plate for misalignment. | Throttle plate misaligned?
STEP 4. | Check the exhaust emissions. |
 | STEP 4A. Check the exhaust emissions are set to specification. | Exhaust emissions to specification?
STEP 5. | Check the speed bias sensor. |
 | STEP 5A. Check the speed bias sensor adjustment. | Speed bias sensor adjustment correct?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 1457 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify that there are no active fault codes.

  • Use INSITE™ electronic service tool to read for any active fault codes.

Fault Codes 121, 234, 175, 176, 177, 512, 513, 689, 1446, 1447, 1448, 1452, 1457, 1458, 1546, 1737, 1738, 1739, 1741, 1742, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1793, 1821, 2455, 2456, 2519, 2643, 2644, 2752, 2796, 2812, 2863, 3499, 3511, 3512, 3514, 3515, 3521, 3522, 3594 and 3595 active?

YES NO

Repair

Follow the appropriate fault code troubleshooting steps or contact a Cummins® Authorized Repair Location.

Repair

Note: Use the following procedure if any fault codes are 'Inactive'. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plugs.

Guided Step 2A - Check the spark plug gaps.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plugs and measure the spark plug electrode gap on all spark plugs. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 013-016 in Section 13.

Spark plug electrode gap to specification?
YES NO
No Repair

Repair

Repair as necessary:

  • Adjust the spark plug electrode gaps.
  • Replace the spark plugs. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314.Refer to Procedure 013-016 in Section 13.

Go to 3A

Go to 6A

Guided Step 3 - Check the throttle assembly.

Guided Step 3A - Check the throttle assembly commanded position signal and position feedback signal for excessive deviation.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle assembly for commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the throttle plate for free movement. Use the "Actuator Diagnostics Tests" within the "ECM Diagnostics Tests" feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Throttle assembly commanded position signal and position feedback signal exceeds 30 percent?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check the throttle shaft for free movement.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle assembly.

Action

Mechanically check the throttle shaft for free movement. Carry out the following procedures:

  • Remove the throttle assembly. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.
  • Mechanically rotate the shaft from the fully closed to fully open position
  • Check for smooth movement through the full range
  • Check for any tight spots during the rotation of the shaft
  • Check the throttle shaft bearings for excessive free-play
  • Contact a Cummins® Authorized Repair Location.

Throttle shaft moves freely?

YES NO
No Repair

Repair

Repair as necessary:

  • Replace the throttle shaft bearings. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-225 in Section 5.
  • Replace the throttle assembly. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.
  • Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 6A

Guided Step 3C -

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle plate for misalignment:

  • Use INSITE™ electronic service tool to check the throttle plate setting. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.

Throttle plate misaligned?
YES NO

Repair

Adjust the throttle plate setting:

  • Use INSITE™ electronic service tool to adjust the throttle plate setting. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the exhaust emissions.

Guided Step 4A - Check the exhaust emissions are set to specification.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine at the highest possible load with no knock - must be at a minimum 70 percent load.

Action

Check the exhaust emissions are to specification:

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, to check that the exhaust emissions are to the fuel rating specification for the engine.
  • For exhaust emission specifications, use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313, Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Adjust the exhaust emissions to specification.

  • Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer to adjust the "open and closed-loop" fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 6A

Guided Step 5 - Check the speed bias sensor.

Guided Step 5A - Check the speed bias sensor adjustment.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the speed bias sensor adjustment:

  • Check that the speed bias sensor air gap setting is correctly adjusted. Refer to Procedure 019-042 in Section 19.

Speed bias sensor adjustment correct?

YES NO
No Repair

Repair

Adjust the speed bias sensor air gap to specification

  • Refer to Procedure 019-042 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Verify that the fault code is inactive:

  • Use INSITE™ electronic service tool to verify that the Fault Code 1457 is inactive.

Fault Code 1457 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 05-Jan-2012


FAULT CODE 1459 - Reverse Kilowatt

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module. |
 | STEP 1A. Verify that the correct calibration is loaded into the engine control module. | Correct calibration loaded
 | STEP 1B. Verify that the initial setup of the generator set was completed correctly. | Initial setup is correct
 | STEP 1C. Verify if there are any active or inactive counts of fuel system faults. | No active or inactive fuel system faults
 | STEP 1D. Verify if there are any active or inactive counts of air intake faults. | No active or inactive air intake faults
 | STEP 1E. Verify that the fault simulation feature for reverse kilowatt protection is not enabled. | Fault simulation is disabled
STEP 2. | Check the output leads. |
 | STEP 2A. Inspect the alternator and the output leads. | No damaged/corroded connections
 | STEP 2B. Check for a short circuit from post to post. | More than 100k ohms
STEP 3. | Check the current transformers. |
 | STEP 3A. Inspect the current transformers and current transformer connections. | No damaged pins
 | STEP 3B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 4. | Check the generator set control board. |
 | STEP 4A. Check the generator set control board 3 ohm resistors. | 3 ohm resistors are good
 | STEP 4B. Inspect the generator set control board and the generator set control wiring harness connector pins. | No damaged pins
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 4D. Check for an open circuit. | Less than 10 ohms
 | STEP 4E. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 5. | Check the generator set control board. |
 | STEP 5A. Check the generator set control board and the generator set control wiring harness connector pins. | No damaged pins
 | STEP 5B. Check for a short circuit to engine block ground. | More than 100k ohms
 | STEP 5C. Check for an open circuit. | Less than 10 ohms
 | STEP 5D. Check for a short circuit from pin to pin. | More than 100k ohms
STEP 6. | Check the generator system. |
 | STEP 6A. Verify that the transient responses for the generators in the system are similar. | Transient responses are similar
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 1459 inactive
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the engine control module.

Guided Step 1A - Verify that the correct calibration is loaded into the engine control module.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the software calibration.

  • Use the recommended Cummins® electronic service tool or equivalent to verify that the correct calibration has been loaded into the engine control module.
OK NOT OK

Correct calibration loaded

Incorrect calibration loaded. Load correct calibration software.

Go to 1B

Go to 7A

Guided Step 1B - Verify that the initial setup of the generator set was installed correctly.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read initial setup.

  • Use the recommended Cummins® electronic service tool or equivalent to verify that the initial setup was installed correctly.
OK NOT OK

Initial setup is correct

Correctly install initial setup. Reference the site documentation.

Go to 1C

Go to 7A

Guided Step 1C - Verify if there are any active or inactive counts of fuel system faults.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Verify if there are any fuel system faults.

  • Use the recommended Cummins® electronic service tool or equivalent to verify if there are any fuel system faults.
OK NOT OK

No active or inactive fuel system faults

Fuel system faults found. Reference the site documentation.

Go to 1D

Go to 7A

Guided Step 1D - Verify if there are any active or inactive counts of air intake faults.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Verify if there are any air intake faults.

  • Use the recommended Cummins® electronic service tool or equivalent to verify if there are any air intake faults.
OK NOT OK

No active or inactive air intake faults

Air intake faults found. Reference the site documentation.

Go to 1E

Go to 7A

Guided Step 1E - Verify that the fault simulation feature for reverse kilowatt protection is not enabled.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Verify that reverse kilowatt protection is not enabled.

  • Use the recommended Cummins® electronic service tool or equivalent to verify that the fault simulation feature for reverse kilowatt protection is not enabled.
OK NOT OK

Fault simulation is disabled

Reverse kilowatt protection is enabled. Reference the site installation documentation.

Go to 2A

Go to 7A

Guided Step 2 - Check the output leads.

Guided Step 2A - Inspect the alternator and the output leads.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the load cables from the alternator.

Action

Verify that reverse kilowatt protection is not enabled.

  • Corroded posts
  • Loose connections.
OK NOT OK

No damaged/corroded connections

Repair the damaged connections. Reference the site documentation.

Go to 2B

Go to 7A

Guided Step 2B - Check for a short circuit from post to post.

Conditions

  • Place the run/stop/auto switch in STOP position.

Action

Check for a short circuit from post to post.

  • Measure the resistance between each of the output leads.
OK NOT OK

More than 100k ohms

Repair or replace the alternator. Reference the site installation documentation.

Go to 3A

Go to 7A

Guided Step 3 - Check the current transformers.

Guided Step 3A - Inspect the current transformers and current transformer connections.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the damaged current transformer. Reference the site installation documentation.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the generator set control board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness engine control module connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the generator set control board.
  • Disconnect the AC harness from the current transformers.

Action

Check for an open circuit.

  • Measure the resistance of each current transformer pin on the AC harness engine control module connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

Less than 10 ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the generator set control board.
  • Disconnect the AC harness from the current transformers.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the current transformer pin on the AC harness connector to all other pins on the generator set control wiring harness connector.
  • Repeat previous step for all other current transformer pins.
OK NOT OK

More than 100k ohms

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-207 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the generator set control board.

Guided Step 4A - Check the generator set control board 3 ohm resistors.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the generator set control board.
  • Disconnect the generator set control wiring harness from the generator set control board 3 ohms resistor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.
OK NOT OK

3 ohm resistors are good

3 ohm resistor is damaged. Replace the generator set control board. Refer to Procedure 019-318 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Inspect the generator set control board and the generator set control wiring harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator set control board from the generator set control wiring harness.

Action

Inspect the generator set control board and the generator set control wiring harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator set control wiring harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control wiring harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set control board. Refer to Procedure 019-318 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator set control wiring harness from the engine control module.
  • Disconnect the generator set control wiring harness from the generator set control board.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each generator set control pin on the generator set control wiring harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator set control wiring harness.

  • Repair the generator set control wiring harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control wiring harness. Refer to Procedure 019-183 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator set control wiring harness from the engine control module.
  • Disconnect the generator set control wiring harness from the generator set control board.

Action

Check for an open circuit in the generator set control wiring harness.

  • Measure the resistance from each of the generator set control board pins on the generator set control wiring harness board connector to the aligned generator set control wiring harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator set control wiring harness.

  • Repair the generator set control wiring harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control wiring harness. Refer to Procedure 019-183 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator set control wiring harness from the engine control module.
  • Disconnect the generator set control wiring harness from the generator set control board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each generator set control pin on the generator set control wiring harness engine control module connector to all other pins on the generator set control wiring harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator set control wiring harness.

  • Repair the generator set control wiring harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control wiring harness. Refer to Procedure 019-183 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the generator set control board.

Guided Step 5A - Inspect the generator set control board and the generator set control wiring harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator set control board from the generator set control wiring harness.

Action

Inspect the generator set control board and the generator set control wiring harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the generator set control wiring harness.

  • Repair the generator set control wiring harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control wiring harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set control board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator set control wiring harness from the engine control module.
  • Disconnect the generator set control wiring harness from the generator set control board.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each generator set control pin on the generator set control wiring harness engine control module connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the generator set control wiring harness.

  • Repair the generator set control wiring harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control wiring harness. Refer to Procedure 019-183 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator set control wiring harness from the engine control module.
  • Disconnect the generator set control wiring harness from the generator set control board.

Action

Check for an open circuit in the generator set control wiring harness.

  • Measure the resistance from each of the generator set control board pins on the generator set control wiring harness board connector to the aligned generator set control wiring harness engine control module connector pin.
OK NOT OK

Less than 10 ohms

Repair or replace the generator set control wiring harness.

  • Repair the generator set control wiring harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control wiring harness. Refer to Procedure 019-183 in Section 19.

Go to 5D

Go to 7A

Guided Step 5D - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the generator set control wiring harness from the engine control module.
  • Disconnect the generator set control wiring harness from the generator set control board.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of each generator set control pin on the generator set control wiring harness engine control module connector to all other pins on the generator set control wiring harness engine control module connector.
OK NOT OK

More than 100k ohms

Repair or replace the generator set control wiring harness.

  • Repair the generator set control wiring harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator set control wiring harness. Refer to Procedure 019-183 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the generator system.

Guided Step 6A - Verify that the transient responses for the generators in the system are similar.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Verify that the transient responses are similar.

  • Use the recommended Cummins® electronic service tool or equivalent to verify that the transient responses for the generators in the system are similar.
OK NOT OK

Transient responses are similar

Transient responses are not similar. Reference the site installation documentation.

Go to 7A

Go to 7A

Guided Step 7A - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to verify Fault Code 1459 is inactive.
OK NOT OK

Fault Code 1459 inactive

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Go to 7B

Escalate or Call for assistance

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Clear the inactive fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to clear the inactive fault codes.
OK NOT OK

All fault codes cleared. Place the off/manual/auto switch in AUTO position.

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 25-Jan-2021


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Software Compatibility |
 | STEP 1A. Check for Software Compatibility | Is Fault Code 1474 Active?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for Software Compatibility

Guided Step 1A - Check for Software Compatibility

Conditions

  • Connect the electronic service tool
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the software version of each ECM.

Is Fault Code 1474 active?
YES NO

Repair

Use the electronic service tool to load compatible software into the ECM's.

 No Repair

Repair complete.

Repair complete.

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 352 active?
STEP 2. | Check the Fuel Pressure Sensor. |
 | STEP 2A. Inspect the sensor and generator control harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor SUPPLY voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor SIGNAL voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness |
 | STEP 3A. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. |
 | STEP 3C. Check for a open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for an appropriate CM700 response. | Fault Code 1482 inactive?
 | STEP 4B. Check the CM700 signal pin resistance. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 1482 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Fuel Pressure Sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 2A

Guided Step 2 - Check the Fuel Supply Pressure Sensor.

Guided Step 2A - Inspect the sensor and generator control harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the generator control harness from the Fuel Pressure Sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

  • Flush the dirt, debris, or moisture from the connector using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the generator control harness. Refer to Procedure 019-183.
  • Replace the Fuel Pressure Sensor. Refer to Procedure 019-188.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the pressure breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the fuel pressure sensor SUPPLY voltage.

  • Measure the SUPPLY voltage by the breakout cable's SUPPLY and RETURN connectors into the multimeter.

4.45 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor SIGNAL voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the pressure breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the fuel pressure sensor SIGNAL voltage.

  • Measure the SIGNAL voltage by the breakout cable's SIGNAL and RETURN connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Fuel Pressure Sensor. Refer to Procedure 019-188.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the generator control harness from the fuel pressure sensor and the DC box connector G.

Action

Inspect the Generator Control Harness and extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the generator control harness or the fuel pressure sensor, whichever has the damaged pin.

  • Flush the dirt, debris, or moisture from the connector using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Replace the generator control harness. Refer to Procedure 019-183. Replace the Fuel Pressure Sensor. Refer to Procedure 019-188.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the generator control harness from the extension harness (if present)
  • Disconnect the generator control harness from the fuel pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pressure SUPPLY pin on the generator control harness to all other pins in the generator control harness connector.
  • Measure the resistance from the fuel pressure RETURN pin on the generator control harness to all other pins in the generator control harness connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the generator control harness to all other pins in the generator control harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the generator control harness. Refer to Procedure 019-183

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the generator control harness from the extension harness (if present)
  • Disconnect the generator control harness from the fuel pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel pressure RETURN pin on the generator control harness to the fuel pressure RETURN pin on the generator control harness connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the engine harness connector to the fuel pressure SIGNAL pin on the generator control harness connector.
  • Measure the resistance from the fuel pressure SUPPLY pin on the generator control harness to the fuel pressure SUPPLY pin on the generator control harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10k ohms?
YES NO
No Repair

Repair

Replace the generator control harness. Refer to Procedure 019-183

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the fuel pressure sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 1482 will become active upon disconnecting the sensor.

Fault Code 1482 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 SIGNAL pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the harness connector A from the CM700.

Action

Check the CM700 SIGNAL pin resistance.

  • Measure the resistance from the fuel pressure SIGNAL pin on the CM700 to the CM700 SUPPLY circuit number one pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and engine running for greater than one minute.

Action

Verify that the fault codes are inactive.

  • Use the electronic service tool to verify that Fault Code 1482 is inactive.

Fault Code 1482 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 352 active?
STEP 2. | Check the Fuel Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor SUPPLY voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor SIGNAL voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness |
 | STEP 3A. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for an appropriate CM700 response. | Fault Code 1484 inactive?
 | STEP 4B. Check the CM700 signal pin resistance. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 1484 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Fuel Pressure Sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 2A

Guided Step 2 - Check the Fuel Outlet Pressure Sensor.

Guided Step 2A - Inspect the sensor and generator control harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the generator control harness from the Fuel Pressure Sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair or replace the generator control harness or the fuel pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the generator control harness. Refer to Procedure 019-183.
  • Replace the Fuel Pressure Sensor. Refer to Procedure 019-188.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the pressure breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the fuel pressure sensor SUPPLY voltage.

  • Measure the SUPPLY voltage by the breakout cable's SUPPLY and RETURN connectors into the multimeter.

4.45 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor SIGNAL voltage

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Install the pressure breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the fuel pressure sensor SIGNAL voltage.

  • Measure the SIGNAL voltage by the breakout cable's SIGNAL and RETURN connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Fuel Pressure Sensor. Refer to Procedure 019-188.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the generator control harness from the fuel pressure sensor and the CM700.

Action

Inspect the Generator Control Harness and extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the generator control harness or the fuel pressure sensor, whichever has the damaged pin.

  • Flush the dirt, debris, or moisture from the connector using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Replace the generator control harness. Refer to Procedure 019-183. Replace the Fuel Pressure Sensor. Refer to Procedure 019-188.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the generator control harness from the extension harness (if present)
  • Disconnect the generator control harness from the fuel pressure sensor
  • Disconnect the generator control harness from all sensors that have a shared SUPPLY or RETURN with the fuel pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel pressure SUPPLY pin on the generator control harness to all other pins in the generator control harness connector.
  • Measure the resistance from the fuel pressure RETURN pin on the generator control harness to all other pins in the generator control harness connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the generator control harness to all other pins in the generator control harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the generator control harness. Refer to Procedure 019-183

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the generator control harness from the extension harness (if present)
  • Disconnect the generator control harness from the fuel pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel pressure RETURN pin on the generator control harness to the fuel pressure RETURN pin on the generator control harness connector.
  • Measure the resistance from the fuel pressure SIGNAL pin on the engine harness connector to the fuel pressure SIGNAL pin on the generator control harness connector.
  • Measure the resistance from the fuel pressure SUPPLY pin on the generator control harness to the fuel pressure SUPPLY pin on the generator control harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10k ohms?
YES NO
No Repair

Repair

Replace the generator control harness. Refer to Procedure 019-183

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the fuel pressure sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 1484 will become active upon disconnecting the sensor.

Fault Code 1484 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 SIGNAL pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connectors from the CM700.

Action

Check the CM700 SIGNAL pin resistance.

  • Measure the resistance from the fuel pressure SIGNAL pin on the CM700 to the CM700 SUPPLY circuit number one pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and engine running for greater than one minute.

Action

Verify that the fault codes are inactive.

  • Use the electronic service tool to verify that Fault Code 1484 is inactive.

Fault Code 1484 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 1521 -Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1521 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 672 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1521 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 672 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 672.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check ECM Calibration Revision History.

Refer to ECM Calibration Revision History Database.

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


FAULT CODE 1522 - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1522 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 673 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1522 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 673 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 673

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


FAULT CODE 1523 - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1523 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 674 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1523 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 674 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 674

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History.

Refer to ECM Calibration Revision History Database.

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


FAULT CODE 1524 - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1524 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 675 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1524 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 675 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 675.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1525 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 676 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1525 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 676 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 676.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1526 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 677 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1526 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 677 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 677.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1527 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 678 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1527 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature
  • .Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 678 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 678.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 17 (A9) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1528 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 2146 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1528 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 2146 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 2146.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1529 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 721 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 1529 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 721 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 721.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1531 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 723 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault code.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 1531 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 723 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 723.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - . Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1532 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 724 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1532 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 724 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 724.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3B

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1533 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 725 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1533 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 725 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 725.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1534 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 726 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1534 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361·in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 726 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 726.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361·in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1535 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 727 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1535 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 727 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 727.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1536 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 728 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1536 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 728 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 728.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • · Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 18 (B9) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1537 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 2147 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1537 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 2147 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 2147.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 16-Feb-2022


FAULT CODE 1545 - Engine Secondary Speed Sensor (Engine Camshaft Speed/Position Sensor) Lost - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1545 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the engine speed sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine speed sensor 2 for damage. | Damaged sensor?
STEP 3. | Check the engine speed sensor 2 circuit. |
 | STEP 3A. Check the engine speed sensor 2 supply voltage and return circuit. | Between 4.75-VDC to 5.25-VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open engine speed sensor 2 signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the engine speed sensor 2 signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Check the fault code and verify the engine speed sensor 2 condition. |
 | STEP 3C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check for an open engine speed sensor 2 circuit in the engine wiring harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1545 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the engine speed sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor 2 from the engine harness.

Action

Inspect the engine harness and engine speed sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine speed sensor 2 for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor 2 from the engine harness.
  • Remove the engine speed sensor 2 from the gear housing. Refer to Procedure 019-042 in Section 19.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

Repair

A malfunctioning sensor or mechanical damage has been detected.

  • Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components. Refer to Procedure 019-042 in Section 019.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine speed sensor 2 circuit.

Guided Step 3A - Check the engine speed sensor 2 supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor 2 from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine speed sensor 2 supply voltage and return circuit.

  • Measure the sensor supply voltage between the engine speed sensor 2 +5 volt SUPPLY pin and the engine speed sensor 2 RETURN pin at the engine speed sensor 2 connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open engine speed sensor 2 signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor 2 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine speed sensor 2 SIGNAL pin at the engine speed sensor 2 engine harness connector to the engine harness ECM connector

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the engine speed sensor 2 signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine speed sensor 2 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine speed sensor 2 SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check the fault code and verify the engine speed sensor 2 condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1545 active?
YES NO

Repair

A malfunctioning engine speed sensor 2 has been detected.

Replace the engine speed sensor 2. Refer to Procedure 019-042 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open engine speed sensor 2 circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the engine speed sensor 2 supply voltage and return circuit.

  • Measure the sensor supply voltage between the engine speed sensor 2 +5 volt SUPPLY pin and the engine speed sensor 2 RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC to 5.25-VDC?
YES NO

Repair

An open circuit has been detected in the SUPPLY or RETURN wires.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Aug-2017


FAULT CODE 1546 - Engine Primary Speed Sensor (Engine Crankshaft Speed/Position Sensor) Lost - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315
Resistance Measurement Using a Multimeter | Refer to Procedure 019-360 | QSV91G | 4021315
OEM Wiring Harness | Refer to Procedure 019-071 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 1546 active?
STEP 2. | Crankshaft engine speed sensor circuit check. |
 | STEP 2A. Check the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2B. Crankshaft engine speed sensor resistance check. | 750 to 1500 ohms?
STEP 3. | Crankshaft engine speed sensor circuit check. |
 | STEP 3A. Crankshaft engine speed sensor open circuit check. | Greater than 10 ohms?
 | STEP 3B. Crankshaft engine speed sensor pin to ground check. | Resistance less than 100k ohms?
 | STEP 3C. Crankshaft engine speed pin to pin check. | Resistance less than 100k ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Operate the engine at normal load conditions.

  • Use the recommended Cummins® electronic service tool to read the active fault codes.

Fault Code 1546 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Crankshaft engine speed sensor component check.

Guided Step 2A - Check the crankshaft engine speed sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Metal debris on end of sensor.
  • Damage to end of sensor caused by contacting the flywheel.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of sensor.

Damaged crankshaft engine speed sensor?
YES NO

Repair

The crankshaft engine speed sensor is damaged.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Crankshaft engine speed sensor resistance check.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the pins and connectors. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the resistance of the sensor.

  • Measure the resistance of the crankshaft engine speed sesnor from the speed SIGNAL (+) pin to the speed RETURN (-) pin at the sensor connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in the Associated Procedures Table.

750 to 1500 ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Crankshaft engine speed sensor circuit check.

Guided Step 3A - Crankshaft engine speed sensor open circuit check.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the crankshaft engine speed sensor from the engine wiring harness.

Action

Inspect the pins and connectors. Refer to Procedure 019-361 in the Associated Procedures Table.

Check for an open circuit.

  • Measure the resistance between the crankshaft engine speed sensor SIGNAL pin at the crankshaft engine speed sensor engine wiring harness connector and the crankshaft engine speed sensor connector SIGNAL pin at the engine wiring harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 10 ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-071 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Crankshaft engine speed sensor pin to ground check.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance between the crankshaft engine speed sensor SIGNAL pin at the engine wiring harness ECM connector and ground.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Crankshaft engine speed sensor pin to pin check.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine wiring harness from the crankshaft engine speed sensor.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Measure the resistance between the crankshaft engine speed sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Aug-2021


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1618 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 671 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check the ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1618 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 671 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 671.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 Ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 16-Feb-2022


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1619 active?
STEP 2. | Exhaust gas temperature sensor circuit check. |
 | STEP 2A. Exhaust gas temperature sensor circuit response. | Fault Code 722 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor open circuit check. | Less than 10 ohms?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1619 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor circuit response.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Place a jumper wire between the appropriate exhaust gas temperature sensor SIGNAL pin and the appropriate exhaust gas temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 722 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the jumper wire in place: 722.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor open circuit check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connector from the ECM
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor RETURN pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the exhaust gas temperature sensor engine wiring harness connector and the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


FAULT CODE 1737 - Engine Throttle Control Actuator - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSV81G CM700/QSV91G CM700 | 4021314

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault code 1737. | Fault Code 1737 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Disable the fault code. |
 | STEP 2A. Verify that the fault code is inactive. | Fault Code 1737 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 1737.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1737 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

Replace the throttle control actuator. See QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Disable the fault code.

Guided Step 2A - Verify that the fault code is inactive.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1737 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Clear inactive fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or Call for assistance

Last Modified: 20-Jan-2021


FAULT CODE 1739 - Engine Throttle Control Actuator - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSV91G | 4021314

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault code 1739. | Fault Code 1739 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Disable the fault code. |
 | STEP 2A. Verify that the fault code is inactive. | Fault Code 1739 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 1739.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1739 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

Replace the throttle control actuator. See QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Disable the fault code.

Guided Step 2A - Verify that the fault code is inactive.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1739 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Clear inactive fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or Call for assistance

Last Modified: 01-Feb-2021


Fault Code 1745 - Engine Throttle Control Actuator 2 - Data Erractic, Intermittent, or Incorrect - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60G Generator CM700 | 4021396
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV81 and QSV91 | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV81 and QSV91 | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the engine control module (ECM) for active Fault Code 1745. | Fault Code 1745 active?
 | STEP 1B. Check for ECM for multiple active fault codes. | Fault Code 1744, 1746, 1747, 1748, 1749, 1751, 1752, 2643, 2644,2752, 3522 or 3865 active?
STEP 2. | Check the throttle control actuator 2 assembly. |
 | STEP 2A. Inspect the throttle control actuator 2 assembly C32 connector and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle control actuator 2 supply voltage. | Supply voltage 18-VDC - 27.6-VDC?
 | STEP 2C. Check the Run Enable circuit resistance with engine in STOP mode. | More than 10 ohms (open circuit)?
 | STEP 2D. Check the Run Enable circuit resistance with engine in START/RUN mode. | Less than 1 ohm?
STEP 3. | Check the CAN 2.0B data link circuit. |
 | STEP 3A. Check the CAN 2.0B data link circuit. | CAN 2.0B data link circuit is to specification?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 4C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 4D. Check for a open circuit. | Greater than 10 ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault codes 1745 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 1745.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to read for active Fault Code 1745.

Fault Code 1745 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-032 in the Associated Procedures Table.

Guided Step 1B - Check the ECM for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to read for multiple active fault codes.

Fault Code 1744, 1746, 1747, 1748, 1749, 1751, 1752, 2643, 2644, 2752, 3522 or 3865 active?
YES | NO
No Repair | No Repair

Refer to the appropriate fault code troubleshooting procedure within Section TF.

Go to 2A

Guided Step 2 - Check the throttle control acutator 2 assembly.

Guided Step 2A - Inspect the throttle control actuator 2 assembly C32 connector and engine harness connector pins.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the throttle control actuator 2 assembly.

Action

Inspect the throttle control actuator 2 assembly C32 connector and engine harness connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectorsand pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged connector or connector pins.

Repair or replace the engine harness, the harness connector, or connector pins.

Repair or replace the throttle control actuator 2 assembly.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing. Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the throttle assembly 2 (right-bank). Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle control actuator 2 supply voltage.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the throttle control actuator 2 assembly.

Action

Check the throttle control actuator 2 supply voltage.

  • Use a multimeter to measure the throttle driver supply voltage.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Supply voltage 18-VDC - 27.6-VDC?
YES NO
No Repair

Repair

Check the power supply connections and fuses in the original equipment manufacturer (OEM) generator interface panel. Refer to the wiring diagram to identify the appropriate circuit.

  • Repair or replace the connectors, fuses, or fuse holders within the OEM generator interface box. Refer to the OEM service manual.
  • Replace the 24-VDC power supply within the OEM generator interface box. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the Run enable circuit resistance with engine in STOP mode.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the throttle control actuator 2 assembly.

Action

Check the throttle control actuator 2 Run Enable circuit resistance.

  • Use a multimeter to measure the throttle control actuator 2 Run Enable circuit resistance.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms (open circuit)?
YES NO
No Repair

Repair

Check the Run Enable relay located in the OEM generator interface panel. Refer to the wiring diagram to identify the appropriate circuit.Refer to the OEM service manual.

  • Repair or replace the Run Enable relay located in the OEM generator interface box. Refer to the OEM service manual .

Go to 2D

Go to 5A

Guided Step 2D - Check the Run Enable circuit resistance with the engine in START/RUN mode.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Isolate the gas supply by closing the fuel supply manual isolating valve.
  • Disconnect the engine harness from the throttle control actuator 2 assembly.

Action

Check the throttle control actuator 2 Run Enable circuit resistance.

  • Use a multimeter to measure the throttle control actuator 2 Run Enable circuit resistance.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

NOTE: Performing this test will activate a number of alarms, which will need to be acknowledged and reset before moving on to the next step.

Less than 1 ohm?
YES NO
No Repair

Repair

Check the Run Enable relay located in the OEM generator interface panel . Refer to the wiring diagram to identify the appropriate circuit.Refer to the OEM service manual.

  • Repair or replace the Run Enable relay located in the OEM generator interface box. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the CAN 2.0B data link circuit.

Guided Step 3A - Measure the CAN 2.0B data link.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect connector A from the CM700 ECM.

Action

Check that the CAN 2.0B (proprietary) data link circuit is to specification.

  • Check the CAN2.0B (proprietary) data link circuit. Refer to the engine wiring diagram to identify connectors and pins.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

CAN 2.0B (proprietary) data link circuit to specification?
YES NO
No Repair

Repair

Repair the CAN2.0B (proprietary) data link circuit.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Assocated Procedures Table.
  • Repair the OEM generator interface panel wiring harness. Refer to the OEM service manual.
  • Replace the OEM generator interface panel wiring harness. Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energized keyswitch circuit.
  • Place run/stop/auto switch is STOP mode.
  • Isolate the 24-VDC power supply.
  • Disconnect the engine harness from the throttle control actuator assemblies 1 and 2, the CM558 left-bank and right-bank modules.
  • Disconnect the OEM generator interface box harness from the CM700 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnessconnectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector or pins?
YES NO

Repair

Repair the damaged connector or connector pins.

Repair or replace the engine harness, the harness connector or connector pins.

Repair or replace the throttle control actuator 2 assembly.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Install the appropriate connector seal if it is missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a pin-to pin short circuit.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the 24-VDC power supply.
  • Disconnect the engine harness from the throttle control actuator assemblies 1 and 2, the CM558 left-bank and right-bank modules.
  • Disconnect the OEM generator interface box harness from the CM700 module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the throttle control actuator 2 SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle control actuator 2 RETURN pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harnessconnectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-ground short circuit.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the 24-VDC power supply.
  • Disconnect the engine harness from the throttle control actuator assemblies 1 and 2, the CM558 left-bank and right-bank modules.
  • Disconnect the OEM generator interface box harness from the CM700 module.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance from the throttle control actuator 2 SIGNAL pin in the engine harness connector to the engine block ground.

Perform these checks on all interconnecting harnessconnectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Assocated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Disable the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1745 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Entergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-Oct-2013


Engine Throttle Control Actuator 2 – Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSV91G | 4021314

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault code 1747. | Fault Code 1747 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Disable the fault code. |
 | STEP 2A. Verify that the fault code is inactive. | Fault Code 1747 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 1747.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent..

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1747 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

Replace the throttle control actuator. See QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Disable the fault code.

Guided Step 2A - Verify that the fault code is inactive.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1747 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Clear inactive fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or Call for assistance

Last Modified: 25-Jan-2021


Engine Throttle Control Actuator 2 – Condition exists (QSV91G)

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSV91G | 4021314

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault code 1749. | Fault Code 1749 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Disable the fault code. |
 | STEP 2A. Verify that the fault code is inactive. | Fault Code 1749 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 1749.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1749 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

  • Replace the throttle control actuator. See QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 2A

Go to 2A

Guided Step 2 - Disable the fault code.

Guided Step 2A - Verify that the fault code is inactive.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1749 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Clear the inactive fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or Call for assistance

Last Modified: 25-Jan-2021


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 144, 145, 146, 153, 154, 155, 156, 157, 158, 177, 263, 265, 354, 355, 453, 454, 488, 512, 513, 691, 692, 751, 783, 1737, 1738, 1739, 1741, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1759, 1761, 1765, 1766, 1767, 1768, 1783, 1793, 1821, 1827, 1828, 1838, 1839, 1841, 1984, 2157, 2191, 2311, 2313,2427, 2428, 2455, 2456, 2457, 2517, 2518, 2569, 2643, 2644, 2752, 2812, 2866, 2867, 2876, 2877, 3384, 3391, 3475, 3476, 3499, 3511, 3512, 3514, 3521, 3522, 3594 and/or 3595 active?
STEP 2. | Check the air intake system. |
 | STEP 2A. Check the air intake system for restriction. | Air intake system restricted?
STEP 3. | Check the exhaust emissions. |
 | STEP 3A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 4. | Check the air inlet temperature. |
 | STEP 4A. Check the air inlet temperature. | Air inlet temperature high?
STEP 5. | Check the kilowatt load transducer (if installed). |
 | STEP 5A. Check the kilowatt load transducer reference signal. | Kilowatt load transducer-sensed kilowatt matches generator set controller kilowatts?
 | STEP 5B. Check the calibration of the generator set controller. | Generator set controller output voltage and amperes readings match the measured readings?
STEP 6. | Check the turbocharger(s). |
 | STEP 6A. Inspect the turbocharger(s). | Turbocharger(s) worn or damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 1791 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 146, 153, 154, 155, 156, 157, 158, 177, 263, 265, 354, 355, 453, 454, 488, 512, 513, 691, 692, 751, 783, 1737, 1738, 1739, 1741, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1759, 1761, 1765, 1766, 1767, 1768, 1783, 1793, 1821, 1827, 1828, 1838, 1839, 1841, 1984, 2157, 2191, 2311, 2313,2427, 2428, 2455, 2456, 2457, 2517, 2518, 2569, 2643, 2644, 2752, 2812, 2866, 2867, 2876, 2877, 3384, 3391, 3475, 3476, 3499, 3511, 3512, 3514, 3521, 3522, 3594 and/or 3595 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the air intake system.

Guided Step 2A - Check the air intake system for restriction.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the air intake system for restriction.

  • Air filters excessive restriction. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-086 in Section 3.
  • Air filters element damage. Use the following procedure in the QSK60G CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-014 in Section 10.
  • Air filters element damage. Use the following procedure in the QSK60G CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-031 in Section 10.

Air intake system restricted?
YES NO

Repair

A restriction has been detected in the air intake system.

  • Replace the air filter elements. Use the following procedure in the QSK60G CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-014 in Section 10.
  • Repair or replace the air intake piping as appropriate. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the exhaust emissions.

Guided Step 3A - Measure the exhaust emissions.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Connect an exhaust gas analyzer
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operating at the highest load possible with no knock - must be at a minimum 70 percent load.

Action

Measure the exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port to check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395 for exhaust emission specifications. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

  • Use INSITE™ electronic service tool and, referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 7A

Guided Step 4 - Check the air inlet temperature.

Guided Step 4A - Check the air inlet temperature.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the air inlet temperature.

  • Check the temperature of the air entering the engine against the specification limit for the engine. Use the following procedure in the QSK60G CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Air inlet temperature high?
YES NO

Repair

The temperature of the air entering the engine has been found to be too high. Inspect the following balance-of-plant systems and repair or replace as necessary:

  • Engine room ventilation fans operation.
  • Motorized engine room louvres operation.
  • Engine room air intake grilles for blockages, obstructions, etc.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the kilowatt load transducer (if installed).

Guided Step 5A - Check the kilowatt load transducer reference signal.

Conditions

Note: If the generator set is not equipped with a kilowatt load transducer, then proceed to Guided Step 5B.

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 7A

Guided Step 5B - Check the calibration of the generator set controller.

Conditions

Note: This guided step should only be followed for generator sets not equipped with a kilowatt load transducer.

  • Connect all components
  • Connect a power analyzer or digital multimeter
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode with load available

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 7A

Guided Step 6 - Check the turbocharger(s).

Guided Step 6A - Inspect the turbochargers.

Conditions

  • Keyswitch circuit de-energised
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the turbocharger(s).

Inspect the turbocharger(s) for the following:

  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395 to check for excessive axial clearance. Refer to Procedure 010-038 in Section 10.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395 to check for excessive radial clearance. Refer to Procedure 010-047 in Section 10.
  • Turbocharger turbine or compressor damage.
  • Contact a Cummins® Authorized Repair Location.

Turbocharger(s) worn or damaged?
YES NO

Repair

A fault has been detected with the turbocharger(s).

  • Replace the turbocharger(s) as necessary. Use the following procedure in the QSK60G CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-033 in Section 10.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine operating for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1791 is inactive.

Fault code 1791 inactive?
YES NO

Repair

  • Use INSITE™ electronic service tool and an exhaust gas analyzer to check the exhaust emissions against the specification for the engine and fine-tune as required. Contact a Cummins® Authorized Repair Location.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 1794 - Unexpected Thermal Event - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine room/container and generator set for any thermal damage. |
 | STEP 1A. Check the engine room/container and the generator set for any thermal damage. | Any engine room/container or generator set thermal damage located?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Active fault codes present?
STEP 3. | Clear the local generator room/container fire detection/alarm system. |
 | STEP 3A. Verify the fire alarm detection system is acknowledged. | Generator room/container fire detection/alarm system acknowledged?
 | STEP 3B. Reset the fire detection/alarm system. | Generator room/container fire detection/alarm system reset?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1794 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the engine room/container and generator set for any thermal damage.

Guided Step 1A - Check the engine room/container and generator set for any thermal damage.

Conditions

  • Keyswitch circuit energized
  • Place run/stop/auto switch in the OFF mode.

Action

When authorized as safe to proceed, check the engine room/container and generator set for any thermal damage. If the thermal event was local to the generator set, check for the following:

  • Engine fuel system leakage
  • Engine intake system/charge air leakage
  • Engine exhaust system leakage
  • Engine heaters for possible short circuit
  • Batteries and battery charger for possible short circuit or overload
  • Engine lubricating oil leakage onto hot surfaces
  • Engine coolant leakage onto hot surfaces
  • Alternator - possible winding short circuits and contaminants on windings
  • Alternator heaters possible short circuit or contact with contaminants
  • Switch gear possible short circuit
  • All wiring for possible short circuits
  • Ventilation fan motors for possible short circuits
  • Generator set panels (AC panel, DC panel, or Generator Interface Box) for possible short circuits
  • Local oil make-up tank system oil leakage onto hot surfaces
  • Contact a Cummins® Authorized Repair Location.

Any engine room/container or generator set thermal damage located?
YES NO

Repair

Rectify any engine room/container or generator set source of the thermal event and repair all resulting in damage. Use the appropriate repair procedures.

  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Active fault codes present?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Clear the local generator room/container fire detection/alarm system.

Guided Step 3A - Verify the fire detection/alarm system is acknowledged.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in STOP mode.

Action

Verify that the engine room/ container fire alarm detection system is acknowledged.

  • Acknowledge the fire alarm via the system panel. Reference the fire detection system manual.
  • Contact a Cummins® Authorized Repair Location.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Generator room/container fire detection/alarm system acknowledged?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Reset the fire detection system.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in STOP mode.

Action

Reset the engine room/container fire detection system.

  • Reset the fire detection system via the system panel. Reference the fire detection system manual.
  • Contact a Cummins® Authorized Repair Location.

Generator room/container fire detection/alarm system reset?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1794 is inactive.

Fault Code 1794 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 24-Sep-2014


FAULT CODE 1837 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1837 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the camshaft engine speed/position sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 2B. Check the camshaft speed/position sensor for damage. | Damaged camshaft engine speed/position sensor?
 | STEP 2C. Check the camshaft engine speed/position sensor resistance. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to ground in the camshaft engine speed/position sensor. | Greater than 100k ohms?
 | STEP 2E. Check the camshaft engine speed/position sensor for a short circuit between coils. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the engine control module (ECM) connector pins. | Dirty or damaged pins or connectors?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in RUN mode.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal load conditions.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1837 active or inactive with more than one count in the last 25 engine hours?
YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the camshaft engine speed/position sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.

Action

Inspect the engine harness and camshaft engine speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair

Repair or replace the damaged engine harness connector or camshaft engine speed/position sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness or connector. Refer to Procedure 019-043 in Section 19.
  • Replace the camshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the camshaft engine speed/position sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.
  • Remove the camshaft engine speed/position sensor.

Action

Inspect the camshaft engine speed/position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor. Refer to Procedure 019-042 in Section 19.

Damaged camshaft engine speed/position sensor?
YES NO

Repair

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-042 in Section 19.
No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the camshaft engine speed/position sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Use a multimeter to check the resistance of the sensor.

  • Measure the resistance from the camshaft engine speed/position sensor SIGNAL positive (+) pin to the engine speed/position sensor RETURN negative (-) pin in the engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position sensor backup SIGNAL positive (+) pin to the engine speed/position sensor backup RETURN negative (-) pin in the engine speed/position sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the camshaft engine speed/position sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor

Action

Use a multimeter to check for a short circuit to ground.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin on the sensor to the engine block ground.

See the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurment techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-042 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check the camshaft engine speed/position sensor for a short circuit between coils.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check the sensor for a short circuit between coils.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin of one coil to all other pins in the sensor connector.
  • Measure the resistance of the camshaft engine speed/position sensor RETURN (-) pin to all other pins at the sensor connector.

See the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the harness from both CM2358 modules.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Perform these checks on all interconnecting harness connectors in the circuit.

See the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connectors?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM2358 control modules.
  • Connect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the CM2358 left bank connector to the camshaft engine/position speed SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the CM2358 left bank connector to the camshaft engine speed/position RETURN (-) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the CM2358 right bank connector to the camshaft engine/position speed backup SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the CM2358 right bank connector to the camshaft engine speed/position backup RETURN (-) pin at the camshaft engine speed/position sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM2358 control modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the camshaft engine speed/position sensor SIGNAL (+) pin at the left bank CM2358 module to the engine block ground.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right bank CM2358 control module to the engine block ground.

See the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short to ground has been detected in the engine harness. Inspect the engine harness for a short to ground.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM2358 control modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left bank CM2358 connector to all other pins in the left bank CM2358 connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the left bank CM2358 connector to all other pins in the right bank CM2358 connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right bank CM2358 connector to all other pins in the right bank CM2358 connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the right bank CM2358 connector to all other pins in the right bank CM2358 connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Aug-2017


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Other fault codes active?
STEP 2. | Check the Engine Coolant Temperature Sensor (Low Temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2111 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2111 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Engine Coolant Temperature Sensor (Low Temperature).

Other fault codes active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Check the Engine Coolant Temperature Sensor (Low Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (Low Temperature).

Action

Inspect the harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Engine Coolant Temperature Sensor (Low Temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Coolant Temperature Sensor (Low Temperature). Refer to Procedure 019-019.

Go to 2B

5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature).

Action

Check the resistance of the Engine Coolant Temperature Sensor (Low Temperature).

  • Measure the resistance between the Engine Coolant Temperature signal (Low Temperature) pin and the Engine Coolant Temperature return (Low Temperature) pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Engine Coolant Temperature Sensor (Low Temperature). Refer to Procedure 019-019.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Engine Coolant Temperature Sensor (Low Temperature) connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Engine Coolant Temperature Sensor (Low Temperature). Refer to Procedure 019-019.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM700
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Engine Coolant Temperature Sensor return (Low Temperature) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Coolant Temperature Sensor signal (Low Temperature) pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the Engine Coolant Temperature Sensor signal (Low Temperature) pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the Engine Coolant Temperature Sensor return (Low Temperature) pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (Low Temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the Engine Coolant Temperature Sensor (Low Temperature) connector to the sensor signal pin on the CM700.
  • Measure the resistance from the return pin on the Engine Coolant Temperature Sensor (Low Temperature) connector to the return signal pin on the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch is Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature)
  • Connect the electronic service tool.

Action

Check for appropriate CM700 response.

  • Place a jumper wire between the Engine Coolant Temperature Sensor signal (Low Temperature) pin and the Engine Coolant Temperature Sensor return (Low Temperature) pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 2112 will become active upon installing the jumper.

Fault Code 2111 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify Fault Code 2111 is inactive.

Fault Code 2111 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Other fault codes are active?
STEP 2. | Check the Engine Coolant Temperature Sensor (Low Temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2112 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2112 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Engine Coolant Temperature Sensor (Low Temperature).

Other fault codes are active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Check the Engine Coolant Temperature Sensor (Low Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (Low Temperature).

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broke pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the Engine Coolant Temperature Sensor (Low Temperature) , whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Coolant Temperature Sensor (Low Temperature). Refer to Procedure 019-019.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature).

Action

Check the resistance of the Engine Coolant Temperature Sensor (Low Temperature).

  • Measure the resistance between the Engine Coolant Temperature Sensor signal (Low Temperature) pin and the Engine Coolant Temperature Sensor return (Low Temperature) pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Engine Coolant Temperature Sensor (Low Temperature). Refer to Procedure 019-019.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Engine Coolant Temperature Sensor (Low Temperature) connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Engine Coolant Temperature Sensor (Low Temperature). Refer to Procedure 019-019.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM700
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine coolant temperature return (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature signal (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the engine coolant temperature signal (low temperature) pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine coolant temperature return (low temperature) pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Temperature Sensor (Low Temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the Engine Coolant Temperature Sensor (Low Temperature) connector to the sensor signal pin on the CM700.
  • Measure the resistance from the return pin on the Engine Coolant Temperature Sensor (Low Temperature) connector to the return pin on the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Temperature Sensor (Low Temperature)
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2111 will become active upon disconnecting the sensor.

Fault Code 2112 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2112 is inactive.

Fault Code 2112 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear any inactive fault codes.

  • Using the electronic service tool, clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2111 or 2112 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2111 or 2112 active?
YES NO
No Repair

Repair

Reference the Coolant Temperature Above Normal - Low Temperature Circuit symptom tree in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2111 and 2112 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2111 and 2112 active?
YES NO
No Repair

Repair

Reference the Coolant Temperature Above Normal - Low Temperature Circuit symptom tree in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 386 active?
STEP 2. | Check the Engine Coolant Pressure Sensor (Low Temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2115 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2115 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Engine Coolant Pressure Sensor (Low Temperature).

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 386

Go to 2A

Guided Step 2 - Check the Engine Coolant Pressure Sensor (Low Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant pressure sensor (low temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the Engine Coolant Pressure Sensor (Low Temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Coolant Pressure Sensor (Low Temperature). Refer to Procedure 019-016.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Engine Coolant Pressure Sensor (Low Temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Engine Coolant Pressure Sensor (Low Temperature) breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Engine Coolant Pressure Sensor (Low Temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Engine Coolant Pressure Sensor (Low Temperature).

Refer to Procedure 019-016.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (Low Temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (Low Temperature)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Engine Coolant Pressure Sensor (Low Temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure supply (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure return (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure signal (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (low temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine coolant pressure return (low temperature) pin on the engine harness connector to the engine coolant pressure return (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure signal (low temperature) pin on the engine harness connector to the engine coolant pressure signal (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure supply (low temperature) pin on the engine harness connector to the engine coolant pressure supply (low temperature) pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the Engine Coolant Pressure Sensor (Low Temperature) connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2116 will become active upon disconnecting the sensor.

Fault Code 2115 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700.
  • Disconnect the 50-pin B Deutsch connector from the CM700.
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine coolant pressure signal (low temperature) pin on the CM700 to the CM700 sensor supply circuit number 1 pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2115 is inactive.

Fault Code 2115 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 352 active?
STEP 2. | Check the Engine Coolant Pressure Sensor (Low Temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2116 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2116 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Engine Coolant Pressure Sensor (Low Temperature).

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 352

Go to 2A

Guided Step 2 - Check the Engine Coolant Pressure Sensor (Low Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Pressure Sensor (Low Temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Engine Coolant Pressure Sensor (Low Temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Coolant Pressure Sensor (Low Temperature). Refer to Procedure 019-016.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Engine Coolant Pressure Sensor (Low Temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Engine Coolant Pressure Sensor (Low Temperature) breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Engine Coolant Pressure Sensor (Low Temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Engine Coolant Pressure Sensor (Low Temperature).

Refer to Procedure 019-016.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (Low Temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor (Low Temperature).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Engine Coolant Pressure Sensor (Low Temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the Engine Coolant Pressure Sensor supply (Low Temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Coolant Pressure Sensor return (Low Temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Coolant Pressure Sensor signal (Low Temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Engine Coolant Pressure Sensor return (Low Temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the Engine Coolant Pressure Sensor return (Low Temperature) pin on the engine harness connector to the Engine Coolant Pressure Sensor return (Low Temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the Engine Coolant Pressure Sensor signal (Low Temperature) pin on the engine harness connector to the Engine Coolant Pressure Sensor signal (Low Temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the Engine Coolant Pressure Sensor supply (Low Temperature) pin on the engine harness connector to the Engine Coolant Pressure supply (Low Temperature) pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Engine Coolant Pressure Sensor return (Low Temperature) connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the Engine Coolant Pressure Sensor return (Low Temperature) supply pin and the Engine Coolant Pressure Sensor return (Low Temperature) signal pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 2115 will become active upon installing the jumper.

Fault code 2116 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700.
  • Disconnect the 50-pin B Deutsch connector from the CM700.
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the Engine Coolant Pressure signal (Low Temperature) pin on the CM700 to the CM700 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2116 is inactive.

Fault Code 2116 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2115 or 2116 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2115 or 2116 active?
YES NO
No Repair

Repair

Reference the Coolant Pressure (Low Temperature) Below Normal symptom tree in the Troubleshooting and Repair Manual, QSV81G and QSV91G Series Engines, Bulletin 4021314.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1618 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1618 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1521 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1521 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting tree

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1522 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1522 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1523 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1523 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1524 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1524 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

.

 No Repair

Go to 5A

Go to 3A
Go to

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1525 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1525 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1526 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1526 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1527 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1527 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 17 (A9) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1528 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1528 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. efer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault code | Fault Codes 1529 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1529 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary.

Refer to Procedure 010-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1619 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1619 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance.

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1531 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1531 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1532 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1532 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 1533 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overhead adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1533 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1534 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3A. | Exhaust gas temperature sensor check. |
 | STEP 3B. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1534 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1535 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1535 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1536 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1536 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Above Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1537 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1537 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1536 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 11 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1535 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. efer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


Exhaust Gas Temperature Cylinder 18 (B9) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 1537 active?
STEP 2. | Intake air system check. |
 | STEP 2A. Intake air filter check. | Restricted air filter?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Overhead adjustments check. |
 | STEP 4A. Inspect overheard adjustments. | Overhead adjustments incorrect?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the recommended Cummins® electronic tool or equivalent to read the active fault codes.

Fault Codes 1537 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Disconnect the exhaust gas temperature sensor
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead components check.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-Feb-2022


FAULT CODE 2146 - Exhaust Gas Temperature Sensor Circuit Cylinder 17 (A9) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2146 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1528 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Code 2146 active?
YES | NO
No Repair | No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Place Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1528 active?

YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1528

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 10-Mar-2022


FAULT CODE 2147 - Exhaust Gas Temperature Sensor Circuit Cylinder 18 (B9) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2147 active?
STEP 2. | Exhaust gas temperature sensor and circuit check. |
 | STEP 2A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 2B. Exhaust gas temperature sensor circuit response. | Fault Code 1537 active?
STEP 3. | Engine wiring harness check. |
 | STEP 3A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 3B. Exhaust gas temperature sensor circuit pin to pin short. | Less than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Connect the recommended Cummins® electronic service tool or equivalent.

Fault Codes 2147 active?
YES NO

Repair

 No Repair

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Exhaust gas temperature sensor and circuit check.

Guided Step 2A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Exhaust gas temperature sensor circuit response.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1537 active?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1537

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Engine wiring harness check.

Guided Step 3A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 10-Mar-2022


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824776 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Engine Oil Pressure Sensor (Post-filter). |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check for a CENSE™ module response. |
 | STEP 3A. Check for the appropriate CENSE™ module response. | Fault Code 2154 is inactive?
 | STEP 3B. Check the CENSE™ module signal pin resistance. | Less than 100k ohm.
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify that fault code is inactive. | Fault Code 2154 is inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the Engine Oil Pressure Sensor (Post-filter).

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Oil Pressure Sensor (Post-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Oil Pressure Sensor. Refer to Procedure 019-066.
No Repair

Go to 5A

Go to 2B

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Engine Oil Pressure Sensor Circuit (Post-filter) breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Engine Oil Pressure Sensor Circuit (Post-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the harness connector
  • Connect the electronic service tool.

Action

Check the Engine Oil Pressure Sensor Circuit (Post-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Engine Oil Pressure Sensor. Refer to Procedure 019-066.

Go to 3A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Oil Pressure Sensor Circuit (Post-filter) and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Engine Oil Pressure Sensor Circuit (Post-filter)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Engine Oil Pressure Sensor Circuit (Post-filter).

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the Engine Oil Pressure Sensor Circuit (Post-filter) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Oil Pressure Sensor Circuit (Post-filter) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Oil Pressure Sensor Circuit (Post-filter) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Engine Oil Pressure Sensor Circuit (Post-filter).

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Engine Oil Pressure Sensor Circuit (Post-filter) return pin on the engine harness connector to the Engine Oil Pressure Sensor Circuit (Post-filter) return pin on the engine harness sensor connector.
  • Measure the resistance from the Engine Oil Pressure Sensor Circuit (Post-filter) signal pin on the engine harness connector to the Engine Oil Pressure Sensor Circuit (Post-filter) signal pin on the engine harness sensor connector.
  • Measure the resistance from the Engine Oil Pressure Sensor Circuit (Post-filter) supply pin on the engine harness connector to the Engine Oil Pressure Sensor Circuit (Post-filter) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 3 - Check for a CENSE™ module response.

Guided Step 3A - Check for an appropriate CENSE™ module response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Engine Oil Pressure Sensor Circuit (Post-filter) connector.

Action

Check for the appropriate CENSE™ module response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2155 will become active upon disconnecting the sensor.

Fault Code 2154 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 3B - Check the CENSE™ module signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connectors from the CENSE™ module.

Action

Check the CENSE™ module signal pin resistance.

  • Measure the resistance from the oil pressure signal pin on the CENSE™ module to CENSE™ module sensor supply circuit return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2154 is inactive.

Fault Code 2154 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824776 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Engine Oil Pressure Sensor (Post-filter). |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check for a CENSE™ module response. |
 | STEP 3A. Check for the appropriate CENSE™ module response. | Fault Code 2155 is inactive?
 | STEP 3B. Check the CENSE™ module signal pin resistance. | Less than 100k ohm.
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify that fault code is inactive. | Fault Code 2155 is inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the Engine Oil Pressure Sensor (Post-filter).

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Oil Pressure Sensor (Post-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Oil Pressure Sensor. Refer to Procedure 019-066.
No Repair

Go to 5A

Go to 2B

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Engine Oil Pressure Sensor (Post-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the harness connector
  • Connect the electronic service tool.

Action

Check the Engine Oil Pressure Sensor (Post-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Engine Oil Pressure Sensor. Refer to Procedure 019-066.

Go to 3A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Oil Pressure Sensor (Post-filter) and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Engine Oil Pressure Sensor (Post-filter)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor (post-filter).

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the Engine Oil Pressure Sensor (Post-filter) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Oil Pressure Sensor (Post-filter) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Engine Oil Pressure Sensor (Post-filter) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Engine Oil Pressure Sensor (Post-filter).

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Engine Oil Pressure Sensor (Post-filter) return pin on the engine harness connector to the Engine Oil Pressure Sensor (Post-filter) return pin on the engine harness sensor connector.
  • Measure the resistance from the Engine Oil Pressure Sensor (Post-filter) signal pin on the engine harness connector to the Engine Oil Pressure Sensor (Post-filter) signal pin on the engine harness sensor connector.
  • Measure the resistance from the Engine Oil Pressure Sensor (Post-filter) supply pin on the engine harness connector to the Engine Oil Pressure Sensor (Post-filter) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 3 - Check for a CENSE™ module response.

Guided Step 3A - Check for an appropriate CENSE™ module response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Engine Oil Pressure Sensor (Post-filter) connector.

Action

Check for the appropriate CENSE™ module response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2154 will become active upon disconnecting the sensor.

Fault Code 2155 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 3B - Check the CENSE™ module signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connectors from the CENSE™ module.

Action

Check the CENSE™ module signal pin resistance.

  • Measure the resistance from the oil pressure signal pin on the CENSE™ module to CENSE™ module sensor supply circuit return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2155 is inactive.

Fault Code 2155 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


FAULT CODE 2191 - Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3824773 - Kavlico™ pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2191 active?
 | STEP 1B. Check for multiple active/inactive active fault codes. | Fault Codes 153, 154, 155, 263, 265, 354, 355, 488, 546, 547, 783, 1737, 1739, 2427, 2428, 2517, 2518, 2568, 2569, 2799, and/or 2812 active/inactive?
STEP 2. | Inspect the air filters for excessive restriction |
 | STEP 2A. Check the engine air filter restriction. | Engine air filter restricted?
 | STEP 2B. Check the engine room or container air inlet filter restriction, if installed. | Engine room or container air inlet filter restricted?
STEP 3. | Check the exhaust emissions. |
 | STEP 3A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 4. | Inspect the turbocharger(s). |
 | STEP 4A. Inspect the turbocharger(s) for damage or excessive wear. | Turbocharger(s) damaged or out of specification?
STEP 5. | Check the exhaust restriction. |
 | STEP 5A. Check the exhaust back pressure. | Exhaust back pressure exceeds specification?
STEP 6. | Check the aftercooler. |
 | STEP 6A. Check the aftercooler for restriction. | Aftercooler core restricted or damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2191 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 2191.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2191 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 153, 154, 155, 263, 265, 354, 355, 488, 546, 547, 783, 1737, 1739, 2427, 2428, 2517, 2518, 2568, 2569, 2799, and/or 2812 active/inactive?

YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Reference the appropriate fault code troubleshooting procedure in Section TF.

Go to 2A

Guided Step 2 - Inspect the air filters for excessive restriction.

Guided Step 2A - Check the engine air filter restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the engine air filter restriction or damage that may cause excessive restriction.

  • Refer to Procedure 010-086 in Section 3.

Engine air filter restricted?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector

  • Refer to Procedure 010-014 in Section 6.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the engine room or container air inlet filter restriction, if installed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

NOTE: Only perform Guided Step 2B if engine room or container air inlet filters are installed. If they are not installed proceed to Guided Step 3A

Action

Check the engine room or container air inlet filter restriction or damage that may cause excessive restriction.

  • Refer to the original equipment manufacturer (OEM) service manuals for engine room or container air filter restriction specifications and inspection procedures.

Engine room or container air inlet filter restricted?
YES NO

Repair

Replace the engine room or container air cleaner elements.

  • Refer to the OEM service manuals for engine room or container air filter restriction specifications and inspection procedures.
 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the exhaust emissions.

Guided Step 3A - Measure the exhaust emissions.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode, generator circuit breaker closed and rated load applied.

Action

Check that the exhaust emissions are to specification.

  • Use an emissions analyser to verify that the engine exhaust emissions are not running too lean.
  • Measure the exhaust emissions. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 014-011 in Section 14.
  • Compare the measured exhaust emissions to the engines emissions specification. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 018-016 in Section V.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Correct the exhaust emissions.

  • Use INSITE™ electronic service tool to tune the exhaust emissions.

Go to 4A

Go to 7A

Guided Step 4 - Inspect the turbocharger(s).

Guided Step 4A - Inspect the turbocharger(s) for damage or excessive wear.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the turbocharger radial bearing clearance, axial bearing clearance and impeller for damage or out-of-specification condition.

  • Check the turbocharger axial clearance. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 010-038 in Section 8.
  • Check the turbocharger radial clearance. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 010-047 in Section 8.

Turbocharger(s) damaged or out of specification?
YES NO

Repair

Replace the turbocharger(s).

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-033 in Section 10.
No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the exhaust restriction.

Guided Step 5A - Check the exhaust back pressure.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode, generator circuit breaker closed and rated load applied.

Action

Check that the exhaust back pressure specification is not exceeded.

  • Measure the exhaust back pressure. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 011-009 in Section 11.

Exhaust back pressure exceeds specification?
YES NO

Repair

Inspect the exhaust system and associated components and remove restriction.

  • Refer to the OEM service manual.

Replace the exhaust system components causing the restriction.

  • Refer to the OEM service manual.
 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the aftercooler.

Guided Step 6A - Check the aftercooler for restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the aftercooler core is not restricted or damaged.

  • Inspect the aftercooler core. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-001 in Section 10.

Aftercooler core restricted or damaged?
YES NO
No Repair

Repair

Clean or replace the aftercooler core.

  • Clean or replace the aftercooler core. use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-001 in Section 10.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2191 is inactive.

Fault Code 2191 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 05-Aug-2013


Engine Speed - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2199 active?
STEP 2. | Check the Engine Speed Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Inspect the sensor for damage. | Damaged Engine Speed Sensor?
 | STEP 2C. Check the resistance of the sensor. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2E. Check for short circuit between coils. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 2k ohms?
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

Use the electronic service tool to read the active fault codes.

Fault Code 2199 active?
YES NO
No Repair

Repair

Using the electronic service tool, clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check the Engine Speed Sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Engine Speed Sensor.

Action

Inspect the engine harness and Camshaft Position Sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Engine Speed Sensor. Refer to Procedure 019-042.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the sensor for damage.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Engine Speed Sensor.

Action

Inspect the Engine Speed Sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by the engine gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Damaged Engine Speed Sensor?
YES NO

Repair

Repair or replace the Engine Speed Sensor. Refer to Procedure 019-042.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Engine Speed Sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance from the Engine Speed Sensor signal positive (+) pin to the Engine Speed Sensor return negative (-) pin in the Engine Speed Sensor connector.
  • Measure the resistance from the Engine Speed Sensor backup signal positive (+) pin to the Engine Speed Sensor backup return negative (-) pin in the Engine Speed Sensor connector.

Note: While testing the sensor, electrical leads must be gently flexed to check for damage or partially broken wires under the insulation.

Less than 2k ohms?
YES NO
No Repair

Repair

Repair or replace the Engine Speed Sensor. Refer to Procedure 019-042.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Engine Speed Sensor
  • Engine Speed Sensor installed.

Action

Check for a short circuit to ground.

  • Measure the resistance from the signal pin in the Engine Speed Sensor to the engine block ground.
  • Measure the resistance from the backup signal pin in the Engine Speed Sensor to the engine block ground.

Note: While testing the sensor, electrical leads must be gently flexed to check for damage or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the Engine Speed Sensor. Refer to Procedure 019-042.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit between coils.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Engine Speed Sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the Engine Speed Sensor signal pin of one coil and the Engine Speed Sensor signal pin of the other coil.
  • Measure the resistance between the Engine Speed Sensor return pin to the Engine Speed Sensor return pin.

Note: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Engine Speed Sensor. Refer to Procedure 019-042.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Moisture or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Connect the engine harness to the Engine Speed Sensor.

Action

Check for an open circuit.

  • Measure the resistance from the Engine Speed Sensor signal pin to the speed sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 2k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Disconnect the engine harness from the Engine Speed Sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the Engine Speed Sensor signal pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the control module
  • Disconnect the engine harness from the Engine Speed Sensor.

Action

Check for a short circuit pin to pin.

  • Measure the resistance between the Engine Speed Sensor signal pin and all other pins of the engine harness connector.
  • Measure the resistance between the Engine Speed Sensor return pin and all other pins of the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Clear the fault codes.

  • Using the electronic service tool, verify that Fault Code 2199 is inactive.

Fault Code 2199 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked.

Go to 4B

Go to 2A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2022


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2427 or 2428 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2427 or 2428 active?
YES NO
No Repair

Repair

Check the pressure regulator setting. Verify that OEM installation guidelines have been followed.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2011


Engine Coolant Level Shutdown

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the Low Temperature Coolant Tank level. |
 | STEP 1A. Check the low temperature tank level. | Is the fluid level in the Low Temperature Coolant Tank at the OEM's recommended level?
STEP 2. | Check the Engine Coolant Level Sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2279 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2279 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the Low Temperature Coolant Tank level.

Guided Step 1A - Check the Low Temperature Coolant Tank level.

Conditions

  • Run/Stop/Auto switch in the Stop position.

Action

Check the Low Temperature Coolat Tank level.

  • Reference the OEM service manual for coolant level requirements.

Is the fluid level in the Low Temperature Coolant Tank at the OEM's recommended level?
YES NO
No Repair

Repair

Fill the low temperature coolant tank to the OEM recommended level.

Go to 2A

Repair complete.

Guided Step 2 - Check the Engine Coolant Level Sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Low Temperature Coolant Level Sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins. Repair or replace the engine harness or the Low Temperature Coolant Level Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202.
  • Replace the harness. Reference the OEM installation instruction.
  • Replace the Low Temperature Coolant Level Sensor. Reference the OEM service manual.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Low Temperature Coolant Tank Level Sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Coolant Tank Level Sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the Low Temperature Coolant Level Sensor. Reference the OEM installation instruction.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Low Temperature Coolant Level Sensor and the CM700.

Action

Inspect the harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins. Repair or replace the harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the harness. Reference the OEM service manual for this procedure.
 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Low Temperature Coolant Level Sensor
  • Disconnect the harness connector from the CM700.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Low Temperature Coolant Level Sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Low Temperature Coolant Level Sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the harness. Reference the OEM service manual for this procedure.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Low Temperature Coolant Level Sensor
  • Disconnect the harness connector from the CM700.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires.

  • Measure the resistance from the Low Temperature Coolant Level Sensor SIGNAL pin in the harness connector to the engine block ground.
  • Measure the resistance from the Low Temperature Coolant Level Sensor RETURN pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the harness. Reference the OEM service manual for this procedure.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Low Temperature Coolant Level Sensor
  • Disconnect the harness connector from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin in the Low Temperature Coolant Level Sensor connector to the sensor SIGNAL pin in the CM700.
  • Measure the resistance from the RETURN pin in the Low Temperature Coolant Level Sensor connector to the sensor RETURN pin in the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the harness. Reference the OEM service manual for this procedure.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Low Temperature Coolant Level Sensor
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the Low Temperature Coolant Level Sensor SIGNAL pin and RETURN pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use the electronic service tool to read the fault codes.

Note: Fault Code 2279 will become active upon disconnecting the sensor.

Fault Code 2279 inactive?
YES NO
No Repair

Repair

Contact the Local Cummins Authorized Repair Facility.

Go to 5A

Repair complete.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify Fault Code 2279 is inactive.

Fault Code 2279 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the Local Cummins Authorized Repair Facility if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 20-Apr-2022


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault codes. |
 | STEP 1A. Reference the appropriate troubleshooting procedure. | Are engine heating systems operating correctly?

Guided Step 1 - Troubleshoot the fault codes.

Guided Step 1A - Reference the appropriate troubleshooting procedure.

Conditions

None

Action

Troubleshoot the fault codes.

  • Check coolant heater operation.
  • Check coolant circulating pump operation.
  • Check coolant heater switch operation and settings.
  • Check lubricating oil heater operation.
  • Check ambient air heaters operation and settings (if equipped).

Are engine heating systems operating correctly?
YES NO

Repair

Allow the engine to warm up.

Repair

Reference the appropriate troubleshooting chart.

Repair complete.

Repair complete.

Last Modified: 31-Oct-2011


Waste Oil Reservoir Level - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the Waste Oil Tank level. |
 | STEP 1A. Check the Waste Oil Tank level. | Is the fluid level in the Waste Oil Tank sight glass at the level of the sensor?
STEP 2. | Check the Waste Oil Tank Level Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2283 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2283 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the Waste Oil Tank level.

Guided Step 1A - Check the Waste Oil Tank level.

Conditions

  • Run/Stop/Auto switch in the Stop position.

Action

Check the Waste Oil Tank level.

  • Inspect the Waste Oil Tank level by observing the fluid level in the sight glass located on the side of the Waste Oil Tank.
  • Compare the location of the sensor with the fluid level in the sight glass.

Is the fluid level in the Waste Oil Tank sight glass at the level of the sensor?
YES NO

Repair

Drain the Waste Oil Tank.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Check the Waste Oil Tank Level Sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Waste Oil Tank Level Sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins. Repair or replace the engine harness or the Waste Oil Tank Level Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202.
  • Replace the harness. Refer to Procedure 019-043.
  • Replace the Waste Oil Tank Level Sensor. Reference the OEM Service Manual.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Waste Oil Tank Level Sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Waste Oil Tank Level Sensor to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the Waste Oil Tank Level Sensor. Reference the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Waste Oil Tank Level Sensor and the CM700.

Action

Inspect the harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Waste Oil Tank Level Sensor
  • Disconnect the harness connector from the CM700.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Waste Oil Tank Level Sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Waste Oil Tank Level Sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Waste Oil Tank Level Sensor
  • Disconnect the harness connector from the CM700.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires.

  • Measure the resistance from the Waste Oil Tank Level Sensor SIGNAL pin in the harness connector to the engine block ground.
  • Measure the resistance from the Waste Oil Tank Level Sensor RETURN pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the harness connector from the Waste Oil Tank Level Sensor
  • Disconnect the harness connector from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin in the Waste Oil Tank Level Sensor connector to the sensor SIGNAL pin in the CM700.
  • Measure the resistance from the RETURN pin in the Waste Oil Tank Level Sensor connector to the sensor RETURN pin in the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Waste Oil Tank Level Sensor
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the Waste Oil Tank Level Sensor SIGNAL pin and RETURN pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use the electronic service tool to read the fault codes.

Note: Fault Code 2283 will become active upon disconnecting the sensor.

Fault Code 2283 inactive?
YES NO
No Repair

Repair

Contact the Local Cummins Authorized Repair Facility.

Go to 5A

Repair complete.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify Fault Code 2283 is inactive.

Fault Code 2283 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the Local Cummins Authorized Repair Facility if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 20-Apr-2022


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2288 active?
STEP 2. | Check the Fuel Shutoff Valve Validation Module. |
 | STEP 2A. Inspect the Fuel Shutoff Valve Validation Module and Generator Control Harness connector pins. | Damaged pins?
 | STEP 2B. Check the Fuel Shutoff Valve Validation Module SUPPLY voltage. | +20 VDC to +25 VDC?
 | STEP 2C. Check the Fuel Shutoff Valve Validation Module SIGNAL voltage. | +20 VDC to +25 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2288 inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2288 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Fuel Supply Pressure Sensor.

Fault Code 2288 active?
YES | NO
No Repair | No Repair

Fault Code 2288

Go to 2A

Guided Step 2 - Check the Fuel Shutoff Valve Validation Module.

Guided Step 2A - Inspect the Fuel Shutoff Valve Validation Module and Generator Control Harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module.

Action

Inspect the Fuel Shutoff Valve Validation Module and harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair or replace the generator control harness or the Fuel Shutoff Valve Validation Module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electronic parts cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the Generator Control Harness. Refer to Procedure 019-183.
  • Replace the Fuel Shutoff Valve Validation Module. Refer to Procedure 005-230 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the Fuel Shutoff Valve Validation Module SUPPLY voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check the Fuel Shutoff Valve Validation Module SUPPLY voltage.

  • Measure the Fuel Shutoff Valve Validation Module SUPPLY voltage.

+20 VDC to +25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the Fuel Shutoff Valve Validation Module SIGNAL voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check the Fuel Shutoff Valve Validation Module SIGNAL voltage.

  • Measure the Fuel Shutoff Valve Validation Module sensor SIGNAL voltage.

+20 VDC to +25 VDC?
YES NO
No Repair

Repair

  • Replace the Fuel Shutoff Valve Validation Module. Refer to Procedure 005-230 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module and the DC Box connector G.

Action

Inspect the Generator Control Harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the Generator Control Harness or the Fuel Shutoff Valve Validation Module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electronic parts cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the Generator Control Harness. Refer to Procedure 019-183.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the extension harness (if present).
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Fuel Shutoff Valve Validation Module SUPPLY pin on the Generator Control Harness to all other pins in the Generator Control Harness connector.
  • Measure the resistance from the Fuel Shutoff Valve Validation Module RETURN pin on the Generator Control Harness to all other pins in the Generator Control Harness connector.
  • Measure the resistance from the Fuel Shutoff Valve Validation Module SIGNAL pin on the Generator Control Harness to all other pins in the Generator Control Harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Generator Control Harness. Refer to Procedure 019-183.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the extension harness (if present).
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel supply pressure RETURN pin on the Generator Control Harness connector to the Fuel Shutoff Valve Validation Module pressure RETURN pin on the Generator Control Harness connector.
  • Measure the resistance from the Fuel Shutoff Valve Validation Module SIGNAL pin on the engine harness connector to the Fuel Shutoff Valve Validation Module SIGNAL pin on the Generator Control Harness connector.
  • Measure the resistance from the Fuel Shutoff Valve Validation Module SUPPLY pin on the Generator Control Harness connector to the Fuel Shutoff Valve Validation Module pressure SUPPLY pin on the Generator Control Harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 10 ohms?
YES NO
No Repair

Repair

Replace the Generator Control Harness. Refer to Procedure 019-183.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Fuel Shutoff Valve Validation Module connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 2288 will become active upon disconnecting the sensor.

Fault Code 2288 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the harness connector A from the CM700.

Action

Check the CM700 SIGNAL pin resistance.

  • Measure the resistance from the Fuel Shutoff Valve Validation Module SIGNAL pin on the CM700 to the CM700 sensor SUPPLY circuit number one pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connected the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto in the Run mode and running for greater than one minute.

Action

Verify the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 2288 is inactive.

Fault Code 2288 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Connect all components
  • Connected the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2289 active?
STEP 2. | Check the Fuel Shutoff Valve Validation Module. |
 | STEP 2A. Inspect the Fuel Shutoff Valve Validation Module and Generator Control Harness connector pins. | Damaged pins?
 | STEP 2B. Check the Fuel Shutoff Valve Validation Module SUPPLY voltage. | +20 VDC to +25 VDC?
 | STEP 2C. Check the Fuel Shutoff Valve Validation Module SIGNAL voltage. | +20 VDC to +25 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2288 inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2289 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Fuel Shutoff Valve Validation Module.

Fault Code 2289 active?
YES | NO
No Repair | No Repair

Fault Code 2289

Go to 2A

Guided Step 2 - Check the Fuel Shutoff Valve Validation Module.

Guided Step 2A - Inspect the Fuel Shutoff Valve Validation Module and Generator Control Harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module.

Action

Inspect the Fuel Shutoff Valve Validation Module and harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair or replace the Generator Control Harness or the Fuel Shutoff Valve Validation Module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electronic parts cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the Generator Control Harness. Refer to Procedure 019-183.
  • Replace the Fuel Shutoff Valve Validation Module. Refer to Procedure 005-230 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the Fuel Shutoff Valve Validation Module SUPPLY voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check the Fuel Shutoff Valve Validation Module SUPPLY voltage.

  • Measure the Fuel Shutoff Valve Validation Module SUPPLY voltage.

+20 VDC to +25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the Fuel Shutoff Valve Validation Module SIGNAL voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check the Fuel Shutoff Valve Validation Module SIGNAL voltage.

  • Measure the Fuel Shutoff Valve Validation Module SIGNAL voltage.

+20 VDC to +25 VDC?
YES NO
No Repair

Repair

  • Replace the Fuel Shutoff Valve Validation Module. Refer to Procedure 005-230 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module and the CM700.

Action

Inspect the Generator Control Harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the Generator Control Harness or the Fuel Shutoff Valve Validation Module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector using electronic parts cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the Generator Control Harness. Refer to Procedure 019-183.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the extension harness (if present).
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module.
  • Disconnect the Generator Control Harness from all sensors that have a shared SUPPLY or RETURN with the Fuel Shutoff Valve Validation Module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Fuel Shutoff Valve Validation Module SUPPLY pin on the Generator Control Harness to all other pins in the Generator Control Harness connector.
  • Measure the resistance from the Fuel Shutoff Valve Validation Module RETURN pin on the Generator Control Harness to all other pins in the Generator Control Harness connector.
  • Measure the resistance from the Fuel Shutoff Valve Validation Module SIGNAL pin on the Generator Control Harness to all other pins in the Generator Control Harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Generator Control Harness. Refer to Procedure 019-183.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the extension harness (if present).
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel supply pressure RETURN pin on the Generator Control Harness connector to the Fuel Shutoff Valve Validation Module RETURN pin on the Generator Control Harness connector.
  • Measure the resistance from the Fuel Shutoff Valve Validation Module SIGNAL pin on the Generator Control Harness connector to the Fuel Shutoff Valve Validation Module SIGNAL pin on the Generator Control Harness connector.
  • Measure the resistance from the Fuel Shutoff Valve Validation Module SUPPLY pin on the Generator Control Harness connector to the Fuel Shutoff Valve Validation Module SUPPLY pin on the Generator Control Harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 10 ohms?
YES NO
No Repair

Repair

Replace the Generator Control Harness. Refer to Procedure 019-183.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Fuel Shutoff Valve Validation Module connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 2289 will become active upon disconnecting the sensor.

Fault Code 2289 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the harness connectors from the CM700.

Action

Check the CM700 SIGNAL pin resistance.

  • Measure the resistance from the Fuel supply pressure SIGNAL pin on the CM700 to the CM700 sensor SUPPLY circuit number one pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connected the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto in the Run mode and running for greater than one minute.

Action

Verify the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 2289 is inactive.

Fault Code 2289 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Connect all components
  • Connected the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 31-Oct-2011


FAULT CODE 2311 - Multiple Turbochargers - Engine Electronic Fuel Control Valve 1 Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the left-bank fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | Feedback signal voltage 0 to 5 VDC?
STEP 3. | Check the left-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Wiring harness and connector pins OK?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short-to-ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2311 and/or 2184, 2864, 2866 and 2867 become active?
STEP 4. | Check the left-bank ECM |
 | STEP 4A. Check the fuel control valve Commanded position percent pulse width modulation duty cycle signal at the CM558 connector. | Percent of duty cycle 10 to 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault code 2311 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2311 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the left-bank fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the left-bank fuel control valve actuator.

Action

Inspect the left-bank actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the left-bank engine harness, the harness connector or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN (–) pins. The feedback signal must be between 0 to 5 VDC.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Feedback signal voltage 0 to 5 VDC?
YES NO
No Repair

Repair

Replace the left-bank fuel control valve:

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the left-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Inspect the left-bank engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the left-bank engine harness, the harness connector, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check for an open circuit in the left-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 module connector of the engine harness.

Use the wiring diagram to identify connectors and pins.

  • Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the left-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.
  • Use the wiring diagram to identify shared sensors.

Action

Check the left-bank engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the appropriate wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the left-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent left-bank engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 2311 and/or 2184, 2864, 2866 and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness. Repair or replace the left-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the left-bank engine control module (ECM)

Guided Step 4A - Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left-bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the Commanded Signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percentage of duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault has been detected with the left-bank CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a local Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2311 is inacitve.

Fault Code 2311 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 24-Aug-2014


FAULT CODE 2311 - Single Turbocharger - Engine Electronic Fuel Control Valve 1 Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the left-bank fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | Feedback signal voltage 0 to 5 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Wiring harness and connector pins OK?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short-to-ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2311 and/or 2184, 2864, 2866 and 2867 become active?
STEP 4. | Check the left-bank ECM |
 | STEP 4A. Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector. | Percentage of duty cycle 10 to 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2311 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2311 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the left-bank fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the left-bank fuel control valve actuator.

Action

Inspect the left-bank actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the left-bank engine harness, the harness connector or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN (-) pins. The feedback signal must be between 0 to 5 VDC.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Feed back signal voltage 0 to 5 VDC?
YES NO
No Repair

Repair

Replace the left-bank fuel control valve:

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Inspect the left-bank engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the left-bank engine harness, the harness connector, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check for an open circuit in the left-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 module connector of the engine harness.

Use the wiring diagram to identify connectors and pins.

  • Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the left-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.
  • Reference the wiring diagram to identify shared sensors.

Action

Check the engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the appropriate wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the left-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent left-bank engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 2311 and/or 2184, 2864, 2866 and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness. Repair or replace the left-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the left-bank ECM.

Guided Step 4A - Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left-bank CM558 connector B.

  • Use the Actuator Test function within INSITE™ electronic service tool, drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percentage of duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault has been detected with the left-bank CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2311 is inacitve.

Fault Code 2311 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 24-Aug-2014


FAULT CODE 2313 - Multiple Turbochargers - Engine Electronic Fuel Control Valve 2 Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2313 active or high inactive counts?
STEP 2. | Check the right-bank fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | Feedback signal voltage 0 to 5-VDC?
STEP 3. | Check the right-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Wiring harness and connector pins OK?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short-to-ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2313 and/or 2314, 3475, 3476 and 3477 become active?
STEP 4. | Check the right-bank ECM |
 | STEP 4A. Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector. | Percent duty cycle 10 to 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2313 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2313 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the right-bank fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the right-bank fuel control valve actuator.

Action

Inspect the right-bank actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the right-bank engine harness, the harness connector or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, 4021314. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 1B

Repair complete

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN (-) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Feedback signal voltage 0 to 5-VDC?
YES NO
No Repair

Repair

Replace the right-bank fuel control valve:

  • Replace the fuel control valve. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, 4021314. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the right-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Inspect the right-bank engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the right-bank engine harness, the harness connector, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Check for an open circuit in the right-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

  • Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.
  • Refer to the wiring diagram to identify shared sensors.

Action

Check the right-bank engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent right-bank engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 2313 and/or 2314, 3475, 3476 and 3477 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness. Repair or replace the right-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the right-bank ECM.

Guided Step 4A - Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the right-bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault has been detected with the right-bank CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2313 is inacitve.

Fault code 2313 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 15-Mar-2012


FAULT CODE 2313 - Single Turbocharger - Engine Electronic Fuel Control Valve 2 Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 2313 active or high inactive counts?
STEP 2. | Check the right-bank fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator commanded position percentage pulse-width modulated (PWM) duty cycle signal. | Percent duty cycle between 10 and 94 percent?
 | STEP 2C. Check the actuator commanded positions feedback signal. | Between 0 and 5.0-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2313 and/or 2314, 3475, 3476, and 3477 become active?
STEP 4. | Check the right-bank ECM. |
 | STEP 4A. Check the fuel control valve (FCV) commanded position percent PWM duty cycle signal at the CM558 connector. | Percent duty cycle between 10 and 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive? | Fault Code 2313 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2313 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the right-bank FCV actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the right-bank FCV actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the appropriate circuit or wiring diagrams for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness, harness connector or FCV actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the FCV. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Repair

Troubleshoot any remaining active fault codes.

Go to 5A

Go to 2B

Guided Step 2B - Check the FCV actuator commanded signal percentage pulse-width modulated (PWM) duty cycle.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank actuator commanded signal percentage duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool, drive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage duty cycle by connecting the multimeter test probes between the FCV actuator position SIGNAL (+) and RETURN (-) pins at the FCV actuator connector. The signal percent duty cycle must be between 10 and 94, based on the FCV actuator position.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for the commanded position percent duty cycle specifications.

Percent duty cycle between 10 and 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and fuses. Reference the engine wiring diagram for the appropriate circuit.

Go to 2C

  • 3A

Guided Step 2C - Check the FCV feedback signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank FCV feedback signal voltage:

  • Use the actuator test function in INSITE™ electronic service tool to drive the FCV to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the FCV actuator positon feedback and RETURN (-) pins. The feedback signal must be between 0 and 5-VDC.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Between 0 and 5-VDC?
YES NO
No Repair

Repair

Replace the right-bank FCV. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

  • 3A

  • 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Connect the engine harness to the FCV actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the FCV actuator SIGNAL pin at the FCV connector and the FCV actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the FCV actuator RETURN pin at the FCV connector and the FCV actuator RETURN pin at the CM558 module connector of the engine harness.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator.

Action

Check the engine harness and FCV actuator resistance.

  • Measure the resistance from the FCV actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the FCV actuator FEEDBACK pin in the engine harness CM558 connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the harness connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in RUN mode at rated speed, no load
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent right-bank engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the FCV actuator connector.

Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is detected while the engine is operating, a warning or shutdown alarm corresponding fault code will be activated.

Fault Codes 2313 and/or 2314, 3475, 3476, and 3477 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the right-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the right-bank ECM.

Guided Step 4A - Check the FCV commanded position percent duty cycle signal at the CM558 connector.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percentage duty cycle at the right-bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool todrive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage duty cycle by connecting the multimeter test probes between the FCV actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the FCV actuator position.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for commanded position percentage duty cycle specifications.

Percent duty cycle between 10 and 94 percent?
YES NO
No Repair

Repair

A malfunction has been detected in the right-bank CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in the RUN mode and operate engine for mpre than 1 minute.

Action

Check the fault codes.

  • Using INSITE™ electronic service tool, verify that Fault Code 2313 is inactive.

Fault Code 2313 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Manually test the Fuel Shutoff Valve Validation Module. |
 | STEP 2A. Manually test the Fuel Shutoff Valve Validation Module. | Does the Amber lamp illuminate?
 | STEP 2B. Manually test the Fuel Shutoff Valve Validation Module. | Does the Red lamp illuminate?
STEP 3. | Manually test the Fuel Shutoff Valve Validation Module. |
 | STEP 3A. Check the Fuel Shutoff Valve Validation Module SUPPLY voltage. | +20 VDC to +25 VDC?
 | STEP 3B. Check the Manually test the Fuel Shutoff Valve Validation Module internal fuse. | Fuel Shutoff Valve Validation Module internal fuse OK?
 | STEP 3C. Inspect the Generator Control Harness connector pins. | Damaged pins?
STEP 4. | Manually test the Fuel Shutoff Valve Validation Module. |
 | STEP 4A. Check the Fuel Shutoff Valve Validation Module SIGNAL to the CM700. | +24 VDC at Pin 8 of Relay K7?
 | STEP 4B. Check Relay K7. | Continuity from SUPPLY to RETURN pins?
STEP 5. | Check the Fuel Shutoff Valve operation. |
 | STEP 5A. Check the Fuel Shutoff Valve operation. | Does gas flow from port P2 and Red lamp illuminate?
 | STEP 5B. Isolate the Fuel Shutoff Valve Validation Module from the Fuel Shutoff Valve. | Does gas flow from port P2 and Red lamp illuminate?
 | STEP 5C. Check the Fuel Shutoff Valve Validation Module pump. | Does air flow across ports on the back of the Fuel Shutoff Valve Validation Module?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool
  • Manual fuel valve open.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground or RETURN with the Fuel Shutoff Valve Validation Module.

Other fault codes active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code

Go to 2A

Guided Step 2 - Manually test the Fuel Shutoff Valve Validation Module.

Guided Step 2A - Manually test the Fuel Shutoff Valve Validation Module.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode
  • Connect all components
  • Manual fuel valve open.

Action

Manually test the Fuel Shutoff Valve Validation Module.

  • Press the Fuel Shutoff Valve Validation Module manual test button.

Does the Amber Lamp illuminate?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Manually test the Fuel Shutoff Valve Validation Module.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode
  • Connect all components
  • Manual fuel valve open.

Action

Manually test the Fuel Shutoff Valve Validation Module.

  • Press the Fuel Shutoff Valve Validation Module manual test button.

Does the Red Lamp illuminate?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3A

Guided Step 3 - Manually test the Fuel Shutoff Valve Validation Module.

Guided Step 3A - Check the Fuel Shutoff Valve Validation Module SUPPLY voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module
  • Manual fuel valve open.

Action

Check the Fuel Shutoff Valve Validation Module SUPPLY voltage.

  • Measure the voltage between the SUPPLY pin and the Fuel Shutoff Valve Validation Module RETURN pin.

+20 VDC to +25 VDC?
YES NO
No Repair

Repair

Check the Fuel Shutoff Valve Validation Module fuse in the DC box.

Go to 3C

Go to 3B

Guided Step 3B - Check the Fuel Shutoff Valve Validation Module internal fuse.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Manual fuel valve open.

Action

Check the Fuel Shutoff Valve Validation Module internal fuse.

  • Inspect the Fuel Shutoff Valve Validation Module internal fuse. Refer to Procedure 005-230 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engine, Bulletin 4021314.

Fuel Shutoff Valve Validation Module internal fuse OK?
YES NO
No Repair

Repair

Replace the Fuel Shutoff Valve Validation Module internal fuse. Refer to Procedure 005-230 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engine, Bulletin 4021314.

Go to 3C

Repair complete.

Guided Step 3C - Inspect the Generator Control Harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Generator Control Harness from the Fuel Shutoff Valve Validation Module
  • Manual fuel valve open.

Action

Inspect the Generator Control Harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Perform these checks on all interconnecting harness connectors in the circuit.

Damaged pins?
YES NO

Repair

Replace the Generator Control Harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the Generator Control Harness. Refer to Procedure 019-183.
No Repair

Repair complete.

Go to 4A

Guided Step 4 - Manually test the Fuel Shutoff Valve Validation Module.

Guided Step 4A - Check for a Fuel Shutoff Valve Validation Module SIGNAL to the CM700.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode
  • Connect all components
  • Manual fuel valve open.

Action

Check for a Fuel Shutoff Valve Validation Module SIGNAL to the CM700.

  • Check for a Fuel Shutoff Valve Validation Module SIGNAL to the CM700.

+24 VDC at pin 8 of Relay K7?
YES NO
No Repair

Repair

Check the K7 relay ground. Repair the ground to the K7 relay as necessary.

Go to 5A

Go to 4B

Guided Step 4B - Check the relay K7.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode
  • Connect all components
  • Manual fuel valve open.

Action

Check the relay K7.

  • Check for continuity from the SUPPLY and RETURN pins on relay K7.

Continuity from SUPPLY and RETURN pins?
YES NO
No Repair

Repair

Replace the K7 relay.

Go to 5A

Repair complete.

Guided Step 5 - Check the Fuel Shutoff Valve operation.

Guided Step 5A - Check the Fuel Shutoff Valve operation.

Conditions

  • Connect all components
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode
  • Manual fuel valve open.

Action

Verify that the fault code is inactive.

  • Remove the screw from validation port P2.
  • Manually test the Fuel Shutoff Valve Validation Module by pressing the manual test button.

Does gas flow from the port P2 and the Red Lamp illuminate?
YES NO

Repair

Replace the Fuel Shutoff Valve. Refer to Procedure 005-044 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engine, Bulletin 4021314.

No Repair

Repair complete.

Go to 5B

Guided Step 5B - Isolate the Fuel Shutoff Valve Validation Module from the Fuel Shutoff Valve.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode
  • Connect all components
  • Manual fuel valve open.

Action

Isolate the Fuel Shutoff Valve Validation Module from the Fuel Shutoff Valve.

  • Tighten screw P1 to the seat by turning it clockwise while counting the number of turns it take to seat the screw.
  • Remove the screw from port P2.
  • Manually test the Fuel Shutoff Valve Validation Module by pressing the manual test button.

Does gas flow from the port P2 and the Red Lamp illuminate?
YES NO

Repair

Replace the Fuel Shutoff Valve. Refer to Procedure 005-044 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engine, Bulletin 4021314.

Repair

Return screw in port P1 to its original position and install screw in port P2.

Repair complete.

Go to 5C

Guided Step 5C - Check the Fuel Shutoff Valve Validation Module pump.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode
  • Manual fuel valve open.

Action

Check the Fuel Shutoff Valve Validation Module pump.

  • Remove the Fuel Shutoff Valve Validation Module from the Fuel Shutoff Valve, but leave the wiring harness connected to the Fuel Shutoff Valve Validation Module. Refer to Procedure 005-230 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engine, Bulletin 4021314.
  • Manually test the Fuel Shutoff Valve Validation Module by pressing the manual test button.

Does air flow across ports on the back of the Fuel Shutoff Valve Validation Module?
YES NO

Repair

Replace the Fuel Shutoff Valve. Refer to Procedure 005-044 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engine, Bulletin 4021314.

Repair

Replace the Fuel Shutoff Valve Validation Module. Refer to Procedure 005-230 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engine, Bulletin 4021314.

Repair complete.

Repair complete.

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 227 active?
STEP 2. | Check the Fuel Outlet Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2427 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2427 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Fuel Outlet Pressure Sensor.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227.

Go to 2A

Guided Step 2 - Check the Fuel Outlet Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Fuel Outlet Pressure Sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the Fuel Outlet Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Outlet Pressure Sensor. Refer to Procedure 019-061.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Fuel Outlet Pressure Sensor supply voltage.

  • Measure the supply voltage by the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Fuel Outlet Pressure Sensor signal voltage.

  • Measure the signal voltage by the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

  • Replace the Fuel Outlet Pressure Sensor. Refer to Procedure 019-061.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Fuel Outlet Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the Fuel Outlet Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Fuel Outlet Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Fuel Outlet Pressure Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Fuel Outlet Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to fuel outlet pressure return pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to fuel outlet pressure signal pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to fuel outlet pressure supply pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Fuel Outlet Pressure Sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 2428 will become active upon disconnecting the sensor.

Fault Code 2427 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel outlet pressure signal pin on the CM558 to the CM558 sensor supply circuit number two pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 2427 is inactive.

Fault Code 2427 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 352 active?
STEP 2. | Check the Fuel Outlet Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2428 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2428 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Fuel Outlet Pressure Sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227.

Go to 2A

Guided Step 2 - Check the Fuel Outlet Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Fuel Outlet Pressure Sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Fuel Outlet Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Fuel Outlet Pressure Sensor. Refer to Procedure 019-061.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Fuel Outlet Pressure Sensor supply voltage.

  • Measure the supply voltage by the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect the electronic service tool.

Action

Check the Fuel Outlet Pressure Sensor signal voltage.

  • Measure the signal voltage by the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

  • Replace the Fuel Outlet Pressure Sensor. Refer to Procedure 019-061.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Fuel Outlet Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Fuel Outlet Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Fuel Outlet Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Fuel Outlet Pressure Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Fuel Outlet Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to fuel outlet pressure return pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to fuel outlet pressure signal pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to fuel outlet pressure supply pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Fuel Outlet Pressure Sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 2427 will become active upon disconnecting the sensor.

Fault Code 2428 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel outlet pressure signal pin on the CM558 to the CM558 sensor supply circuit number one pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 2428 is inactive.

Fault Code 2428 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2115 or 2116 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2115 or 2116 active?
YES NO
No Repair

Repair

Reference the Coolant Pressure Below Normal — Low Temperature Circuit symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Repair

Reference the Cylinder Power Low (Multiple Cylinders) troubleshooting tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Proprietary Data Link - Master Message Lost

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Repair

Refer to Procedure 019-417, Proprietary Datalink Circuit, in this manual for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2022


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 441, 442, 477, or 478 are active?
STEP 2. | Check the kilowatt load transducer. |
 | STEP 2A. Inspect the kilowatt load transducer for loose connections. | Loose connections?
 | STEP 2B. Check the kilowatt load transducer output. | More than 20 mA?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harnesses, terminal blocks, and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for an appropriate CM700 response | Fault Code 2453 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2453 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Keyswitch circuit energized.

Action

Check the ECM.

  • Use the Electronic Service Tool to read the active fault codes.

Fault Codes 441, 442, 477, or 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the kilowatt load transducer.

Guided Step 2A - Inspect the kilowatt load transducer for loose connections.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode.

Action

Inspect the terminal connections on the kilowatt load transducer.

Tighten any loose connections.

Loose connections?
YES NO

Repair

Tighten connections.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the kilowatt load transducer output.

Conditions

  • Keyswitch circuit de-energized.

Action

Check the Kilowatt Load Transducer output current.

Connect a ammeter in series with the positive (+) wire running between the transducer and the Generator Control Panel (GCP) terminal block.

More than 20 mA?
YES NO
No Repair

Repair

Repair or replace the Kilowatt Load Transducer. Refer to Procedure 019-425.

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the harnesses, terminal blocks, and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pin or terminals
  • Bent or broken pins
  • Pushed back or extended pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Perform terminal checks in the DC Interface Cabinet. Reference the circuit diagram or wiring diagram to identify connectors, pins and terminal locations.

Damaged pins?
YES NO

Repair

Repair the damaged pins and terminals.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Repair

Repair the wire.

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Kilowatt Load Transducer.

Action

Check for a short from pin to pin.

  • Measure the resistance from the kilowatt load return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the kilowatt load signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors, pins and terminal locations.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Kilowatt Load Transducer
  • Connect an Electronic Service Tool.

Action

Check for the appropriate CM700 response.

Using the electronic Service Tool, verify the fault codes.

NOTE: Fault Code 2454 will become active upon disconnecting the transducer.

Fault Code 2453 inactive?
YES NO
No Repair

Repair

Contact the Local Cummins Authorized Repair Facility.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify Fault Code 2453 is inactive.

Fault Code 2453 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 441, 442, 477, or 478 are active?
STEP 2. | Check the Kilowatt Load Transducer. |
 | STEP 2A. Inspect the Kilowatt Load Transducer for loose connections. | Loose connections?
 | STEP 2B. Check the kilowatt load transducer output. | Less than 4 mA?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harnesses, terminal blocks, and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | More than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for an appropriate CM700 response | Fault Code 2454 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2454 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Keyswitch circuit energized
  • Connect the Electronic Service Tool
  • Run/Stop/Auto switch in the Run mode and engine running for more than one minute.

Action

Check the ECM.

  • Use the Electronic Service Tool to read the active fault codes.

Fault Codes 441, 442, 477, or 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the kilowatt load transducer.

Guided Step 2A - Inspect the kilowatt load transducer for loose connections.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode.

Action

Inspect the terminal connections on the kilowatt load transducer.

Tighten any loose connections.

Loose connections?
YES NO

Repair

Tighten connections.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the kilowatt load transducer output.

Conditions

  • Keyswitch circuit de-energized.

Action

Check the Kilowatt Load Transducer output current.

Connect an ammeter in series with the positive (+) wire running between the transducer and the Generator Control Panel (GCP) terminal block.

More than 4 mA?
YES NO
No Repair

Repair

Repair or replace the Kilowatt Load Transducer. Refer to Procedure 019-425 in this manual.

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the harnesses, terminal blocks, and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the CM700.

Action

Inspect the engine harness and connector pins for the following:.

  • Corroded pin or terminals
  • Bent or broken pins
  • Pushed back or extended pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Perform terminal checks in the DC Interface Cabinet. Reference the circuit diagram or wiring diagram to identify connectors, pins and terminal locations.

Damaged pins?
YES NO

Repair

Repair the damaged pins and terminals.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Repair

Repair the wire.

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Kilowatt Load Transducer.

Action

Check for a short from pin to pin.

  • Measure the resistance from the kilowatt load return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the kilowatt load signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors, pins and terminal locations.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Kilowatt Load Transducer connector.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Kilowatt Load Transducer return pin on the engine harness connector to the Kilowatt Load Transducer return pin on the engine harness sensor connector.
  • Measure the resistance from the Kilowatt Load Transducer position signal pin on the engine harness connector to the Kilowatt Load Transducer signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Kilowatt Load Transducer
  • Connect an Electronic Service Tool.

Action

Check for the appropriate CM700 response.

Using the electronic Service Tool, verify the fault codes.

NOTE: Fault Code 2453 will become active upon disconnecting the transducer.

Fault Code 2454 inactive?
YES NO
No Repair

Repair

Contact the Local Cummins Authorized Repair Facility.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Use the electronic service tool to verify Fault Code 2454 is inactive.

Fault Code 2454 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the CM700.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - male Deutsch/AMP/Metri-Pack test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the wiring harness |
 | STEP 1A. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 1B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 1C. Check for an open circuit. | Less than 10 ohms?
STEP 2. | Check the Speed Bias Signal. |
 | STEP 2A. Inspect the speed bias termination. | Damaged pins?
 | STEP 2B. Check the speed bias signal at terminal strip E. | Between 2.5 kHz and 3.5 kHz?
 | STEP 2C. Check the speed bias signal at the CM700 connector. | Between 2.5 kHz and 3.5 kHz?
STEP 3. | Check for a CM700 response. |
 | STEP 3A. Check for the appropriate CM700 response. | Fault Code 2455 is inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 2455 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the wiring harness.

Guided Step 1A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the CM700 main connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform all these checks on all interconnecting harness connectors in the circuit. Refer to Procedure 100-002 for the component location.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt and debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 4A

Go to 1B

Guided Step 1B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the CM700 main connector.

Action

Check for a short circuit pin to pin.

  • Measure the resistance from the Speed Bias Signal pin on the CM700 harness connector to all other pins in the CM700 harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 4A

Guided Step 1C -

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the CM700 main connector.

Action

Check for an open circuit in the Speed Bias Signal wire.

  • Measure the resistance from the Speed Bias Signal pin on the harness connector to the Speed Bias Signal pin on terminal strip E.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2A

Go to 4A

Guided Step 2 - Check the Speed Bias Signal.

Guided Step 2A - Inspect the Speed Bias Signal terminations.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode.

Action

Inspect the terminations on treminal strip E.

  • Corroded contacts
  • Moisture
  • Missing or damaged terminations
  • Dirt or debris in or on the terminations.

Damaged terminations?
YES NO

Repair

Repair the damaged terminations.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the Speed Bias Signal at terminal strip E

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode.

Action

Check the Speed Bias Signal frequency.

  • Measure the Speed Bias Signal frequency with a multimeter.

Between 2.5 and 3.5 kHz
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 2C

Go to 4A

Guided Step 2C - Check the Speed Bias Signal at the CM700 main connector.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the CM700 main harness connector.

Action

Check the Speed Bias Signal frequency.

  • Measure the Speed Bias frequency with a multimeter.

Between 2.5 and 3.5 kHz
YES NO
No Repair

Repair

Repair or replace the wiring harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Check for damaged wires or terminations.

Go to 3A

Go to 4A

Guided Step 3 - Check for a CM700 response.

Guided Step 3A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

Fault Code 2455 is inactive?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2455 is inactive.

Fault Code 2455 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Facility if the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 31-Oct-2011


FAULT CODE 2458 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check Cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2767 active?
YES NO

Repair

Perform a search on the appropriate fault codes.

 No Repair

Go to 2A

Appropriate troubleshooting chart.

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the Spark Plug Gap.

Conditions

  • Place run/stop/auto switch in the OFF mode.

Action

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Ignition system check.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting wiring harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Proceed to next troubleshooting step.

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 28-Feb-2022


FAULT CODE 2459 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767 active?
STEP 2. | Cylinder 2 spark plug check. |
 | STEP 2A. Check spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Run/Stop/Auto switch in the Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2767 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Cylinder 2 spark plug check.

Guided Step 2B - Check the spark plug gap.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Ignition system check.

Guided Step 3A - Ignition coil check.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition wiring harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting wiring harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pin.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 28-Feb-2022


FAULT CODE 2461 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2B. Check spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 2457, 2767 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting tree

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2B - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in the OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in the Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage
  • .Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 28-Feb-2022


FAULT CODE 2462 - Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2767 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in the Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 7B - Disable the fault code

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code Inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 28-Feb-2022


FAULT CODE 2463 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
 | STEP 4B. Exhaust gas temperature sensor circuit response. | Fault Code 2458 inactive and Fault Code 2459 active?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2767 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in the OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.
 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in the Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in the Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 28-Feb-2022


FAULT CODE 2464 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in the STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2767 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in the STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 28-Feb-2022


FAULT CODE 2465 - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes 2457, 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2767 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition wiring harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in Stop mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Proceed to next troubleshooting step.

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2466 - Exhaust Gas Temperature Cylinder 16 (B8) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2767 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring as found necessary. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition wiring harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.
 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • · Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2467 - Exhaust Gas Temperature Cylinder 18 (B9) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767 active?
STEP 2. | Cylinder 2 Spark Plug Check. |
 | STEP 2A. Spark plug gap check. | Spark plug gap correct?
STEP 3. | Ignition system check. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition wiring harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition wiring harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2767 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring as found necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inpsect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inpsect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.
 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2469 - Exhaust Gas Temperature Cylinder 1 (A1) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Nmae | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 013-016 | QSV91G | 4021314
Engine Wiring Harness | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Cylinder 2 spark plug check. |
 | STEP 2A. Spark plug gap check. | Spark plug gap correct?
STEP 3. | Ignition system check. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition wiring harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition wiring harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Remove the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring, if necessary. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2471 - Exhaust Gas Temperature Cylinder 3 (A2) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Nmae | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the spark plug gap.

  • Replace the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2472 - Exhaust Gas Temperature Cylinder 5 (A3) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

  • Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2B - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Replace the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2473 - Exhaust Gas Temperature Cylinder 7 (A4) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Replace the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.
 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2475 - Exhaust Gas Temperature Cylinder 9 (A5) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

  • Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Replace the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.
 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

· Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes

Guided Step 7A - Check if an ECM calibration update is available

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2476 - Exhaust Gas Temperature Cylinder 11 (A6) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Replace the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2477 - Exhaust Gas Temperature Cylinder 13 (A7) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Replace the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit pin-to-pin.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a open circuit.

Conditions

  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2478 - Exhaust Gas Temperature Cylinder 15 (A8) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug gap.

Conditions

  • Place run/stop/auto switch in the OFF mode.

Action

  • Replace the spark plug and measure the spark plug gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Ignition coil check.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Check the ignition coil resistance. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit pin-to-pin.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a open circuit.

Conditions

  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


FAULT CODE 2479 - Exhaust Gas Temperature Cylinder 17 (A9) – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSV91G | 4021314
Coil-on-Plug | Refer to Procedure 013-024 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2766 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Ignition coil check. | Ignition coil OK?
 | STEP 3B. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Exhaust gas temperature sensor and circuit check. |
 | STEP 4A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 5. | Engine wiring harness check. |
 | STEP 5A. Exhaust gas temperature sensor pin to ground short. | Less than 100k ohms?
 | STEP 5B. Exhaust gas temperature sensor pin to pin short. | Less than 100k ohms?
STEP 6. | Check cylinder overhead set. |
 | STEP 6A. Overhead component damaged or out of adjustment. | Overhead set OK?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Fault Codes 2457, 2766 active?
YES NO
No Repair

Repair

Perform a search on the appropriate fault codes.

Go to 2A

Appropriate troubleshooting chart

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the Spark Plug Gap.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.

Action

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the Ignition System.

Guided Step 3A - Ignition coil check.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Inspect the ignition wiring harness and connector pins for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils Primary and Secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for an open circuit.

Conditions

  • RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Exhaust gas temperature sensor and circuit check.

Guided Step 4A - Exhaust gas temperature sensor resistance check.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected if the resistance is not within the following specification: 84 Ω - 480k Ω.

Repair or replace only the components that were found to be out of specification.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Engine wiring harness check.

Guided Step 5A - Exhaust gas temperature sensor pin to ground short.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Exhaust gas temperature sensor pin to pin short.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate exhaust gas temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder overhead set.

Guided Step 6A - Overhead component damaged or out of adjustment.

Conditions

  • RUN/STOP/AUTO switch in the STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 07-Mar-2022


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Repair

Reference the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2482 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2482 active?
YES NO
No Repair

Repair

Reference the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) symptom trees in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) symptom trees in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 227 active?
STEP 2. | Check the Compressor Outlet Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2517 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2517 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Compressor Outlet Pressure Sensor.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the Compressor Outlet Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Compressor Outlet Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Compressor Outlet Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Compressor Outlet Pressure Sensor. Refer to Procedure 019-061.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Compressor Outlet Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Compressor Outlet Pressure Sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Compressor Outlet Perssure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Compressor Outlet Pressure Sensor.

Refer to Procedure 019-061.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Compressor Outlet Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Compressor Outlet Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Compressor Outlet Pressure Sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the compressor outlet pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Compressor Outlet Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the compressor outlet pressure return pin on the engine harness connector to the compressor outlet pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure signal pin on the engine harness connector to the compressor outlet pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure supply pin on the engine harness connector to the compressor outlet pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the Compressor Outlet Pressure Sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2518 will become active upon disconnecting the sensor.

Fault Code 2517 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the compressor outlet pressure signal pin on the CM558 to the CM558 sensor supply circuit number two return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2517 is inactive.

Fault Code 2517 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 187 active?
STEP 2. | Check the Compressor Outlet Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2518 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2518 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Compressor Outlet Pressure Sensor.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the Compressor Outlet Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Compressor Outlet Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Compressor Outlet Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Compressor Outlet Pressure Sensor. Refer to Procedure 019-061.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Compressor Outlet Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the Compressor Outlet Pressure Sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Compressor Outlet Perssure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Compressor Outlet Pressure Sensor.

Refer to Procedure 019-061.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Compressor Outlet Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Compressor Outlet Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Compressor Outlet Pressure Sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the compressor outlet pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Compressor Outlet Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the compressor outlet pressure return pin on the engine harness connector to the compressor outlet pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure signal pin on the engine harness connector to the compressor outlet pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure supply pin on the engine harness connector to the compressor outlet pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the Compressor Outlet Pressure Sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2517 will become active upon disconnecting the sensor.

Fault Code 2518 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the compressor outlet pressure signal pin on the CM558 to the CM558 sensor supply circuit number two return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2518 is inactive.

Fault Code 2518 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 175, 176, 512, or 513 active?
STEP 2. | Check the Throttle Driver and Actuator. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the throttle driver position signal voltage. | 24 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 2519 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 2519 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 175, 176, 512, or 513 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Throttle Driver and Actuator.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the Throttle Driver and Actuator.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Throttle Driver and Actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Throttle Driver and Actuator. Refer to Procedure 006-049 in the Troubleshooting and Repair Manual QSV81G and QSV91G Series Engines, Bulletin 4021314, and Refer to Procedure 019-429 in this manual.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver position signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main engine harness from the Throttle Driver power connections
  • Connect the electronic service tool.

Action

Check the throttle driver supply voltage.

  • Measure the signal voltage using a multimeter.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and fuses in the power supply wires to the CM558. Reference the engine wiring diagram for the appropriate circuit.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Throttle Driver and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Throttle Driver.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the Throttle Driver supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Throttle Driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Throttle Driver position feedback pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Throttle Driver.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Throttle Driver supply pin on the engine harness connector to the Throttle Driver supply pin on the engine harness sensor connector.
  • Measure the resistance from the Throttle Driver return pin on the engine harness connector to the Throttle Driver return pin on the engine harness sensor connector.
  • Measure the resistance from the Throttle Driver position feedback pin on the engine harness connector to the Throttle Driver position feedback pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for one minute
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

Fault Code 2519 is inactive?
YES NO
No Repair

Repair

Contact a local Authorized Cummins Repair Facility.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 2519 is inactive.

Fault Code 2519 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Authorized Cummins Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the left bank CM558. | Fault Code 2521 is active?
 | STEP 1B. Check the right bank CM558. | Fault Code 2521 active?
STEP 2. | Check the left bank CM558 bank identification circuit. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify a short circuit between bank identification pin 1 and Left Bank CM558 Switch Return. | Less than 10 ohms?
 | STEP 2C. Verify an open circuit on bank identification pin 2. | Greater than 100k ohms?
STEP 3. | Check the right bank CM558 bank identification circuit. |
 | STEP 3A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify a short circuit between bank identification pin 2 and Right Bank CM558 Switch Return. | Less than 10 ohms?
 | STEP 3C. Verify an open circuit on bank identification pin 1. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify that the fault code is inactive. | Fault Code 2521 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the left bank CM558.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for bank identification error fault codes.

  • Using the electronic service tool read, the fault codes.

Fault Code 2521 is active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the right bank CM558.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Check for bank identification error fault codes.

  • Use the electronic service tool, read the fault codes.

Fault Code 2521 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 2 - Check the left bank CM558 bank identification circuit.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the left bank CM558.

Action

Inspect the harness connector and pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-204.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify a short circuit between bank identification pin 1 and Left Bank CM558 Switch Return.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the left bank CM558.

Action

Harness connector - pin to pin continuity check.

  • Measure the resistance between bank identification pin 1 and Left Bank CM558 Switch Return.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Add a short circuit between bank identification pin 1 and Left Bank CM558 Switch Return.
  • Repair the wiring harness. Refer to Procedure 019-204.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 2C

Go to 4A

Guided Step 2C - Verify an open circuit on bank identification pin 2.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the left bank CM558.

Action

Harness connector - pin to pin continuity check:

  • Measure the resistance between bank identification pin 2 and Left Bank CM558 Switch Return.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Restore an open circuit between bank identification pin 2 and Left Bank CM558 Switch Return.
  • Repair the wiring harness. Refer to Procedure 019-204.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 3 - Check the right bank CM558 bank identification circuit.

Guided Step 3A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the right bank CM558.

Action

Inspect the harness connector and pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO

Repair

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-204.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Verify a short circuit between bank identification pin 2 and Right Bank CM558 Switch Return.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the right bank CM558.

Action

Harness connector - pin to pin continuity check:

  • Measure the resistance between bank identification pin 2 and Right Bank CM558 Switch Return.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Add a short circuit between bank identification pin 2 and Right Bank CM558 Switch Return.
  • Repair the wiring harness. Refer to Procedure 019-204.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 3C

Go to 4A

Guided Step 3C - Verify an open circuit on bank identification pin 1.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the right bank CM558.

Action

Harness connector - pin to pin continuity check:

  • Measure the resistance between bank identification pin 1 and Right Bank CM558 Switch Return.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Restore an open circuit between bank identification pin 1 and Right Bank CM558 Switch Return.
  • Repair the wiring harness. Refer to Procedure 019-204.
  • Replace the wiring harness. Refer to Procedure 019-043.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Verify the fault code is inactive.

  • Use the electronic service tool, verify the fault code is inactive.

Fault Code 2521 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2442 or 2443 active?
YES NO
No Repair

Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2544 active?
YES NO

Repair

Allow the ECM to cool and then restart the engine. If the fault reoccurs, contact a local authorized service location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Oct-2011


Proprietary Data Link - Slave Message Lost

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Repair

Refer to Procedure 019-417, Proprietary Datalink Circuit, in this manual for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 20-Apr-2022


FAULT CODE 2553 - Engine Oil Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active Fault Code 2553. | Fault Code 2553 active?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 137, 143, 219, 415, 481, 555, 556, 1362, 1785, 1787, 1788, 1825 and/or 3491 active/inactive?
STEP 2. | Check the engine oil day tank. |
 | STEP 2A. Check the oil level within the engine oil day tank. | Engine oil day tank oil level low?
 | STEP 2B. Check for oil flow between the engine oil day tank and the Murphy® oil level switch. | Oil flow from engine oil day tank to the Murphy® oil level switch?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 2553 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active Fault Code 2553.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check for active Fault Code 2553.

  • Use INSITE™ electronic service tool to verify Fault Code 2553 is active.

Fault Code 2553 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the multiple active/inactive fault codes.

Fault Codes 137, 143, 219, 415, 481, 555, 556, 1362, 1785, 1787, 1788, 1825, and/or 3491 active/inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active/inactive fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine oil day tank.

Guided Step 2A - Check the oil level within the engine oil day tank.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check the oil level within the engine oil day tank.

  • Visually check the oil level in the engine oil day tank.

Engine oil day tank oil level low?
YES NO

Repair

Refill the engine oil day tank with engine oil of the correct specification.

  • Use the following procedure for lubricating oil recommendations and specifications in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-003 in Section V.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for oil flow between the engine oil day tank and the Murphy® oil level switch.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually check for oil flow between the engine oil day tank and the Murphy® oil level switch.

  • Temporarily disconnect the oil supply pipe from the engine oil day tank to the Murphy® oil level switch from the connection at the Murphy® oil level switch
  • Use a suitable container to catch the oil to check that there is a good flow of oil from the engine oil day tank.
  • Contact a Cummins® Authorized Repair Location.

Oil flow from engine oil day tank to the Murphy® oil level switch?
YES NO
No Repair

Repair

Poor or no oil flow has been detected between the engine oil day tank and the Murphy® oil level switch. Check for the following conditions:

  • Engine oil day tank to Murphy® oil level switch oil supply pipe - isolation valve fully open.
  • Engine oil day tank - no blockages at oil outlet, i.e. foreign matter, etc.
  • Engine oil day tank to Murphy® oil level switch oil supply pipe - no restrictions caused by routing or securing of flexible pipe work.
  • Engine oil day tank to Murphy® oil level switch oil supply pipe - no restrictions caused by internal blockages.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2553 is inactive.

Fault Code 2553 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Apr-2012


FAULT CODE 2766 - Engine Ignition Control Module #1 - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Repair

Reference the Cylinder Power Low (Multiple Cylinders) troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place Run/Stop/Auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-Jan-2016


FAULT CODE 2767 - Engine Ignition Control Module #2 - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Repair

Reference the Cylinder Power Low (Multiple Cylinders) troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place Run/Stop/Auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-Jan-2016


FAULT CODE 2812 - Engine Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Engine Wiring Harness | Refer to Procedure 019-043 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315
Multipurpose Relay | Refer to Procedure 019-642 | QSV91G | 4021315

Cautions and Warnings

CAUTION

There may be other generator set fault codes activated as a result of Fault Code 2812 being triggered. To avoid the possibility of damaging a new digital throttle assembly, all other active fault codes must be investigated and rectified before replacing the digital throttle assembly.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 441 or 442, 412, 414, 426, 427, active?
STEP 2. | Throttle body voltage check. |
 | STEP 2A. Throttle body voltage check. | Voltage within the following specification of battery voltage 1 VDC?
STEP 3. | Check the throttle actuator circuit. |
 | STEP 3A. Throttle body circuit check. | Resistance less than 10 ohms?
 | STEP 3B. Throttle body open circuit check. | Resistance greater than 10k ohms?
 | STEP 3C. Throttle body circuit pin to ground short. | Resistance greater than 100k ohms?
 | STEP 3D. Throttle body circuit pin to pin short. | Resistance greater than 100k ohms?
STEP 4. | Check the run enable relay. |
 | STEP 4A. Verify the relay fitted is correct. | 4 Pole 24V 10A DC relay?
 | STEP 4B. Inspect the wiring to the run enable relay base and pins and contactors. | Dirty or damaged pins/fixings/contactors?
 | STEP 4C. Verify the relay is energized. | Relay energized light illuminated.
 | STEP 4D. Check the contactor movement inside the relay casing. | Free contactor movement?
STEP 5. | Check engine control module (ECM) calibration code and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Energize the run/stop/auto switch.
  • Place run/stop/auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes or high counts of inactive fault codes.

  • Connect the recommended Cummins® electronic service tool or equivalent to read the active and inactive fault codes.

Fault Code 441 or 442, 412, 414, 426, 427, active?

YES NO
No Repair

Repair

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the throttle body voltage.

Guided Step 2A - Throttle body voltage check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the throttle body from the engine wiring harness.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the voltage between the throttle body SUPPLY pin and the throttle body RETURN pin at the throttle body engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within the following specification of battery voltage 1VDC?

YES | NO
No Repair | No Repair

Go to 3A

Go to 5A

Guided Step 3 - Check the throttle actuator circuit.

Guided Step 3A - Throttle body circuit check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the throttle body from the engine wiring harness.
  • Disconnect DC2 generator set wiring harness connector
  • Disconnect the battery supply and return terminals.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the throttle body SUPPLY pin at the throttle body engine wiring harness connector and the throttle body SUPPLY pin at the DC2 generator set wiring harness connector.
  • Measure the resistance between the throttle body RETURN pin at the throttle body engine wiring harness connector and the throttle body RETURN pin at the DC2 generator set wiring harness connector.
  • Measure the resistance between the throttle body SUPPLY pin at the DC2 engine wiring harness connector and the battery SUPPLY.
  • Measure the resistance between the throttle body RETURN pin at the DC2 engine wiring harness connector and the battery RETURN.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Resistance less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot the engine wiring harness, DC2 generator set wiring harness, and all interconnects.

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the DC2 generator set wiring harness.

Go to 3B

Go to 5A

Guided Step 3B - Throttle body open circuit check.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the throttle body from the engine wiring harness.
  • Disconnect DC2 generator set wiring harness connector.
  • Disconnect the Run Enable Relay on the generator set wiring harness connector.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the throttle body SIGNAL 1 pin at the throttle body engine wiring harness connector and the throttle body SIGNAL 1 pin at the Run Enable Relay on the generator set wiring harness.
  • Measure the resistance between the throttle body SIGNAL 2 pin at the throttle body engine wiring harness connector and the throttle body SIGNAL 2 pin at the Run Enable Relay on generator set wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Resistance greater than 10k ohms?

YES NO
No Repair

Repair

Troubleshoot the engine wiring harness, DC2 generator set wiring harness, and all interconnects.

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the DC2 generator set wiring harness.

Go to 3C

Go to 5A

Guided Step 3C - Throttle body circuit pin to ground short.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness from the throttle control actuator.
  • Disconnect DC2 connector at the engine wiring harness connection.
  • Disconnect Run Enable Relay connector at the engine wiring harness connection.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance from the throttle control actuator SIGNAL 1 (+) pin at the DC2 generator set wiring harness connector and ground.
  • Measure the resistance from the throttle control actuator SIGNAL 1 (+) pin at the DC2 generator set engine wiring harness connector and ground.
  • Measure the resistance from the throttle control actuator SIGNAL 2 (+) pin at the DC2 generator set wiring harness connector and ground.
  • Measure the resistance from the throttle control actuator SIGNAL 2 (+) pin at the DC2 generator set engine wiring harness connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Resistance greater than 100k ohms?

YES NO
No Repair

Repair

Troubleshoot the engine wiring harness, DC2 generator set wiring harness, and all interconnects.

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the DC2 generator set wiring harness.

Go to 3D

Go to 5A

Guided Step 3D - Throttle body circuit pin to pin short.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine wiring harness from the ECM.
  • Disconnect the engine wiring harness from the throttle control actuator.
  • Disconnect DC2 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC2 connector at the engine wiring harness connection.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance from the throttle control actuator SIGNAL 1 (+) pin at the DC2 generator set wiring harness connector and all other pins in the DC2 connector.
  • Measure the resistance from the throttle control actuator SIGNAL 1 (+) pin at the DC2 generator set engine wiring harness connector and all other pins in the DC2 connector.
  • Measure the resistance from the throttle control actuator SIGNAL 2 (+) pin at the DC2 generator set wiring harness connector and all other pins in the DC2 connector.
  • Measure the resistance from the throttle control actuator SIGNAL 2 (+) pin at the DC2 generator set engine wiring harness connector and all other pins in the DC2 connector.

Resistance greater than 100k ohms?

YES NO
No Repair

Repair

Troubleshoot the engine wiring harness, DC2 generator set wiring harness, and all interconnects.

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the DC2 generator set wiring harness.

Go to 4A

Go to 5A

Guided Step 4 - Check the run enable relay.

Guided Step 4A - Verify the relay is the correct rating for the run enable relay application.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

  • Visually inspect the Run Enable Relay.

Visually inspect the casing of the run enable relay location in the PCC3300 Generator Control Panel.

Verify the fitted relay is of the correct specification.

4 Pole 24V 10A DC relay?
YES NO
No Repair

Repair

Replace the Run Enable Relay. Refer to Procedure 019-642 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Inspect the wiring to the run enable relay base, pins and contactors.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.
  • Disconnect run enable relay from the Generator Control Panel.

Action

Visually Inspect the Run Enable Relay.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the wiring to the relay base.

  • Flush the dirt, debris, or moisture from the connector pins.
  • Replace the Run Enable Relay. Refer to Procedure 019-642 in the Associated Procedures Table.
 No Repair

Go to 4C

Go to 5A

Guided Step 4C - Verify the relay is energized.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.
  • Disconnect run enable relay from the Generator Control Panel.

Action

Remove the run enable relay from the PCC3300 Generator Control Panel and test it by applying 24V. If the green light illuminates on the relay itself, the relay is energized and should function correctly.

Relay energized light illuminated?
YES NO
No Repair

Repair

Replace the Run Enable Relay. Refer to Procedure 019-642 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check the contactor movement inside the relay casing.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.
  • Disconnect run enable relay from the Generator Control Panel.

Action

Remove the run enable relay from the PCC3300 Generator Control Panel to test. Apply 24V. Check throttle actuator contactor movement across pins inside the relay casing.

Free contactor movement?
YES NO
No Repair

Repair

Replace the Run Enable Relay. Refer to Procedure 019-642 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?

YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 17-May-2022


FAULT CODE 2814 - Multiple Turbochargers - Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 2814 active or high inactive counts?
STEP 2. | Check the left-bank fuel control valve (FCV) actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator commanded position percentage pulse-width modulated (PWM) duty cycle signal. | Percent duty cycle between 10 and 94 percent?
 | STEP 2C. Check the actuator commanded positions feedback signal. | Between 0 and 5.0-VDC?
STEP 3. | Check the left-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2814 and/or 2311, 2864, 2866, and 2867 become active?
STEP 4. | Check the left-bank ECM. |
 | STEP 4A. Check the FCV commanded position percentage PWM duty cycle signal at the CM558 connector. | Percent duty cycle between 10 and 94?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive? | Fault Code 2313 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2814 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the left-bank fuel control valve (FCV) actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the FCV actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the appropriate circuit or wiring diagrams for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness, harness connector, or FCV actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the FCV. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the FCV actuator commanded signal percentage pulse-width modulated (PWM) duty cycle.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank actuator commanded signal percentage duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage duty cycle by connecting the multimeter test probes between the FCV actuator position SIGNAL (+) and RETURN (-) pins at the FCV actuator connector. The signal percentage duty cycle must be between 10 and 94, based on the FCV actuator position.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for the commanded position percentage duty cycle specifications.

Percent duty cycle between 10 and 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and fuses. Reference the engine wiring diagram for the appropriate circuit.

Go to 2C

  • 3A

Guided Step 2C - Check the FCV feedback signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank FCV feedback signal voltage:

  • Use the actuator test function in INSITE™ electronic service tool to drive the FCV to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the FCV actuator positon feedback and RETURN (-) pins. The feedback signal must be between 0 and 5-VDC.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Between 0 and 5-VDC?
YES NO
No Repair

Repair

Replace the left-bank FCV. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

  • 3A

  • 5A

Guided Step 3 - Check the left-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Connect the engine harness to the FCV actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the FCV actuator SIGNAL pin at the FCV connector and the FCV actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the FCV actuator RETURN pin at the FCV connector and the FCV actuator RETURN pin at the CM558 module connector of the engine harness.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator.

Action

Check the engine harness and FCV actuator resistance.

  • Measure the resistance from the FCV actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the FCV actuator feedback pin in the engine harness CM558 connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the harness connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in RUN mode at rated speed, no load
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent left-bank engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the FCV actuator connector.

Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is detected while the engine is operating, a warning or shutdown alarm corresponding fault code will be activated.

Fault Codes 2814 and/or 2311, 2864, 2866, and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the left-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the left-bank ECM.

Guided Step 4A - Check the FCV commanded position percentage duty cycle signal at the CM558 connector.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percentage duty cycle at the right-bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool to drive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage duty cycle by connecting the multimeter test probes between the FCV actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percentage duty cycle must be between 10 and 94 percent, based on the FCV actuator position.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for commanded position percentage duty cycle specifications.

Percent duty cycle between 10 and 94 percent?
YES NO
No Repair

Repair

A malfunction has been detected in the right-bank CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in the RUN mode and operate engine for more than 1 minute.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2814 is inactive.

Fault Code 2814 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Mar-2012


FAULT CODE 2814 - Single Turbochargers - Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 2814 active or high inactive counts?
STEP 2. | Check the left-bank fuel control valve (FCV) actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator commanded position percentage pulse-width modulated (PWM) duty cycle signal. | Percent duty cycle between 10 and 94 percent?
 | STEP 2C. Check the actuator commanded positions feedback signal. | Between 0 and 5.0-VDC?
STEP 3. | Check the left-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2814 and/or 2311, 2864, 2866, and 2867 become active?
STEP 4. | Check the left-bank ECM. |
 | STEP 4A. Check the FCV commanded position percentage PWM duty cycle signal at the CM558 connector. | Percent duty cycle between 10 and 94?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive? | Fault Code 2313 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2814 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the left-bank fuel control valve (FCV) actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the FCV actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the appropriate circuit or wiring diagrams for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness, harness connector, or FCV actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the FCV. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the FCV actuator commanded signal percentage pulse-width modulated (PWM) duty cycle.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank actuator commanded signal percentage duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage duty cycle by connecting the multimeter test probes between the FCV actuator position SIGNAL (+) and RETURN (-) pins at the FCV actuator connector. The signal percentage duty cycle must be between 10 and 94, based on the FCV actuator position.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for the commanded position percentage duty cycle specifications.

Percent duty cycle between 10 and 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and fuses. Reference the engine wiring diagram for the appropriate circuit.

Go to 2C

  • 3A

Guided Step 2C - Check the FCV feedback signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the left-bank FCV feedback signal voltage:

  • Use the actuator test function in INSITE™ electronic service tool to drive the FCV to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the FCV actuator positon feedback and RETURN (-) pins. The feedback signal must be between 0 and 5-VDC.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Between 0 and 5-VDC?
YES NO
No Repair

Repair

Replace the left-bank FCV. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

  • 3A

  • 5A

Guided Step 3 - Check the left-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Connect the engine harness to the FCV actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the FCV actuator SIGNAL pin at the FCV connector and the FCV actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the FCV actuator RETURN pin at the FCV connector and the FCV actuator RETURN pin at the CM558 module connector of the engine harness.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator.

Action

Check the engine harness and FCV actuator resistance.

  • Measure the resistance from the FCV actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the FCV actuator FEEDBACK pin in the engine harness CM558 connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the harness connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode at rated speed, no load
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent left-bank engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the FCV actuator connector.

Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is detected while the engine is operating, a warning or shutdown alarm corresponding fault code will be activated.

Fault Codes 2814 and/or 2311, 2864, 2866, and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the left-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the left-bank ECM.

Guided Step 4A - Check the FCV commanded position percentage duty cycle signal at the CM558 connector.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percentage duty cycle at the right-bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool to drive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage duty cycle by connecting the multimeter test probes between the FCV actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percentage duty cycle must be between 10 and 94 percent, based on the FCV actuator position.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for commanded position percentage duty cycle specifications.

Percent duty cycle between 10 and 94 percent?
YES NO
No Repair

Repair

A malfunction has been detected in the right-bank CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the RUN mode and operate engine for more than 1 minute.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2814 is inactive.

Fault Code 2814 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-Mar-2012


FAULT CODE 2837 - Exhaust Gas Temperature Cylinder 1 (A1) – Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 641, 1618, 2121, 2469, 2484, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 641, 1618, 2121, 2469, 2484, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 06-Apr-2022


FAULT CODE 2838 - Exhaust Gas Temperature Cylinder 3 (A2) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 642, 1521, 2122, 2471, 2485, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 642, 1521, 2122, 2471, 2485, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component Damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 06-Apr-2022


FAULT CODE 2839 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 643, 1522, 2123, 2472, 2486, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 643, 1522, 2123, 2472, 2486, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 06-Apr-2022


FAULT CODE 2841 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 644, 1523, 2124, 2473, 2487, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 644, 1523, 2124, 2473, 2487, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. efer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 06-Apr-2022


FAULT CODE 2842 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 645, 1524, 2125, 2475, 2488, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 645, 1524, 2125, 2475, 2488, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2843 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 646, 1525, 2126, 2476, 2489, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 646, 1525, 2126, 2476, 2489, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2844 - Exhaust Gas Temperature Cylinder 13 (A7) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 647, 1526, 2127, 2477, 2491, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 647, 1526, 2127, 2477, 2491, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component Damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 05-Apr-2022


FAULT CODE 2845 - Exhaust Gas Temperature Cylinder 15 (A8) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 648, 1527, 2128, 2478, 2492, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 648, 1527, 2128, 2478, 2492, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2846 - Exhaust Gas Temperature Cylinder 17 (A9) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 651, 1528, 2129, 2479, 2493, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 651, 1528, 2129, 2479, 2493, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2847 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 652, 1529, 2131, 2458, 2494, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 652, 1529, 2131, 2458, 2494, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2848 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 653, 1619, 2132, 2459, 2495, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 653, 1619, 2132, 2459, 2495, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2849 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 654, 1531, 2133, 2461, 2496, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 654, 1531, 2133, 2461, 2496, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component Damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2851 - Exhaust Gas Temperature Cylinder 8 (B4) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 655, 1532, 2134, 2462, 2497, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 655, 1532, 2134, 2462, 2497, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2852 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 656, 1533, 2135, 2463, 2498, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 656, 1533, 2135, 2463, 2498, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2853 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 657, 1534, 2136, 2464, 2499, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 657, 1534, 2136, 2464, 2499, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 04-Apr-2022


FAULT CODE 2854 - Exhaust Gas Temperature Cylinder 14 (B7) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 658, 1535, 2137, 2465, 2511, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 658, 1535, 2137, 2465, 2511, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 06-Apr-2022


FAULT CODE 2855 - Exhaust Gas Temperature Cylinder 16 (B8) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 2144, 1536, 2138, 2466, 2512, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 2144, 1536, 2138, 2466, 2512, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 06-Apr-2022


FAULT CODE 2856 - Exhaust Gas Temperature Cylinder 18 (B9) - Data Erratic, Intermittent or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSV91G | 4021314
Air Intake Restriction | Refer to Procedure 010-031 | QSV91G | 4021314
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engien control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes Fault Codes 2145, 1537, 2139, 2467, 2513, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
STEP 2. | Intake air system check. |
 | STEP 2A. Restricted intake air filter. | Is the air intake restriction within specification?
 | STEP 2B. Leaks into the intake air system. | Air leaking into system?
STEP 3. | Exhaust gas temperature sensor check. |
 | STEP 3A. Exhaust gas temperature sensor resistance check. | Malfunctioning sensor?
STEP 4. | Check overhead components for damaged or out of adjustment. |
 | STEP 4A. Overhead components damaged or out of adjustment. | Adjustments correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list.

Check for active fault codes:

Fault Codes Fault Codes 2145, 1537, 2139, 2467, 2513, 153, 155, 277, 488, 2311, 2313, 2427, 2428, 2766, 3475, 3476, active?
YES NO

Repair

Perform a search on the appropriate fault codes.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake air system check.

Guided Step 2A - Restricted intake air filter check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Intake air filter plugged?
YES NO

Repair

Clean or change the air filter and intake piping as necessary. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Leaks into the intake air system.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Visually inspect the air intake system for leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the air compressor plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the EGR plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the intake plumbing for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.
  • Visually inspect the charge air cooler hoses for possible air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Leak found?
YES NO

Repair

Repair or replace the air intake component causing the air leak. Refer to Procedure 010-024 in the Associated Procedures Table.

Refer to OEM Service Manual.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Exhaust gas temperature sensor check.

Guided Step 3A - Exhaust gas temperature sensor resistance check.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.
  • Disconnect the exhaust gas temperature sensor.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning exhaust gas temperature sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Overhead components damaged or out of adjustment.

Guided Step 4A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Inspect and check the overhead valve lash settings and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjustments correct?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

Replace the damaged or worn overhead component. Refer to Procedure 003-004 in the Associated Procedures Table.

Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent.to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 06-Apr-2022


FAULT CODE 3111 - Engine Cylinder Number 1 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3111 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components
  • Run/Stop/Auto switch in Stop mode
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3111 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code Inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 21-Mar-2022


FAULT CODE 3112 - Engine Cylinder Number 2 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3112 and/or 3111, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3112 and/or 3111, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead .Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3113 - Engine Cylinder Number 3 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3113 and/or 3111, 3112, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3113 and/or 3111, 3112, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto in the STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3114 - Engine Cylinder Number 4 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3114 and/or 3111, 3112, 3113, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3114 and/or 3111, 3112, 3113, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews.Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3115 - Engine Cylinder 5 (A3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3116 - Engine Cylinder 6 (B3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3116 and/or 3111, 3112, 3113, 3114, 3115, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3116 and/or 3111, 3112, 3113, 3114, 3115, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

 No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place run/stop/auto switch in STOP mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3117 - Engine Cylinder 7 (A4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3117 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an Disable the fault code.ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3117 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket. Refer to procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure: 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure: 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3118 - Engine Cylinder Number 8 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3118 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3118 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure: 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure: 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3119 - Engine Cylinder 9 (A5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021315
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021315
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021315
Piston | Refer to Procedure 001-043 | QSV91G | 4021315
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021315
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021315
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021315
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021315
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021315
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021315
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021315
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3119 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3119 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3121, 3122, 3123, 3124, 3125, 3126, 3127,3128,3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • · Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3121 - Engine Cylinder 10 (B5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3121 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3121 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3122 - Engine Cylinder 11 (A6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3122 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3122 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3123 - Engine Cylinder 12 (B6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3123 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3123 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3124 - Engine Cylinder 13 (A7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3124 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3124 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3125, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 22-Mar-2022


FAULT CODE 3125 - Engine Cylinder 14 (B7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3125 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3126, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3125 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3126, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in theAssociated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place run/stop/auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 24-Mar-2022


FAULT CODE 3126 - Engine Cylinder 15 (A8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3126 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3127, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3126 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3127, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 24-Mar-2022


FAULT CODE 3127 - Engine Cylinder 16 (B8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3127 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3128, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3127 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3128, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Escalate or call for assistance

Last Modified: 24-Mar-2022


FAULT CODE 3128 - Engine Cylinder 17 (A9) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3128 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3129 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3128 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3129 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 24-Mar-2022


FAULT CODE 3129 - Engine Cylinder 18 (B9) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSV91G | 4021314
Cylinder Block | Refer to Procedure 001-026 | QSV91G | 4021314
Cylinder Liner | Refer to Procedure 001-028 | QSV91G | 4021314
Piston | Refer to Procedure 001-043 | QSV91G | 4021314
Piston cooling nozzle | Refer to Procedure 001-046 | QSV91G | 4021314
Piston Rings | Refer to Procedure 001-047 | QSV91G | 4021314
Cylinder Head | Refer to Procedure 002-004 | QSV91G | 4021314
Overhead Set | Refer to Procedure 003-004 | QSV91G | 4021314
Rocker Lever Assembly | Refer to Procedure 003-009 | QSV91G | 4021314
Rocker Lever Cover | Refer to Procedure 003-011 | QSV91G | 4021314
Aftercooler | Refer to Procedure 010-001 | QSV91G | 4021314
ECM Calibration Code | Refer to Procedure 019-032 | QSV91G | 4021315
Knock Sensor | Refer to Procedure 019-346 | QSV91G | 4021315

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3129 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128 active?
STEP 2. | Bracket capscrews check. |
 | STEP 2A. Check for loose bracket capscrews. | Torque meets specification?
 | STEP 2B. Knock sensor capscrew check. | Torque meets specification?
STEP 3. | Check cylinder overhead set. |
 | STEP 3A. Overhead component damaged or out of adjustment. | Overhead set OK?
STEP 4. | Power cylinder components check. |
 | STEP 4A. Worn or damaged power cylinder components. | Damaged or worn power cylinder components?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place Run/Stop/Auto switch in Stop mode.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Codes 3129 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128 active?

YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Bracket capscrews check.

Guided Step 2A - Check for loose bracket capscrews.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Check the torque on the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Torque meets specification?
YES NO
No Repair

Repair

Torque the aftercooler bracket capscrews. Refer to Procedure 010-001 in the Associated Procedures Table.

Torque the rocker lever housing capscrews. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Knock sensor capscrew check.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

Check the torque on knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

If the measured torque does not meet specification, then proceed to the Repair Section.

Torque meets specification?
YES NO
No Repair

Repair

Torque the knock sensor capscrews. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check cylinder overhead set.

Guided Step 3A - Overhead component damaged or out of adjustment.

Conditions

  • Place Run/Stop/Auto switch in Stop mode.

Action

  • Remove the rocker level cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect the rocker levers.
  • Visually inspect valve springs for damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Check the overhead valve lash setting and adjustment. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Remove and inspect the rocker lever shafts for damage. Refer to Procedure 003-009 in the Associated Procedures Table.

Overhead set OK?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the crossheads. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the rocker levers. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the valve springs. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Adjust the overhead. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Replace the rocker lever shafts. Refer to Procedure 003-009 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Power cylinder components check.

Guided Step 4A - Worn or damaged power cylinder components.

Conditions

  • Place Run/Stop/Auto switch in OFF mode.

Action

  • Piston damage. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Inspect the cylinder liners. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Inspect the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Inspect the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Connecting rod bearings excessive wear or damage. Refer Procedure 001-005 in the Associated Procedures Table.
  • Piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

Damaged or worn power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston. Refer to Procedure 001-043 in the Associated Procedures Table.
  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder block. Refer to Procedure 001-026 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the connecting rod bearings. Refer Procedure 001-005 in the Associated Procedures Table.
  • Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check ECM Calibration Revision History

Refer to ECM Calibration Revision History Database

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Disable and clear the fault code.
  • Operate the engine within the conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 24-Mar-2022


FAULT CODE 3475 - Multiple Turbochargers - Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3477 active or high inactive counts?
STEP 2. | Check the right-bank fuel control valve (FCV) actuator. |
 | STEP 2A. Check the FCV feedback signal voltage. | Between 0 and 5-VDC?
STEP 3. | Check the right-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 3475 and/or 2313, 2314, 3476 and 3477 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive? | Fault Code 3475 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3475 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the right-bank fuel control valve (FCV) actuator.

Guided Step 2A - Check the FCV actuator commanded signal percentage pulse-width modulated (PWM) duty cycle.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank actuator commanded signal percentage duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the FCV actuator position feedback and RETURN (-) pins. The feedback signal must be between 0 and 5-VDC.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for the commanded position percentage duty cycle specifications.

Use the following procedure for general mutlimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0 and 5-VDC?
YES NO
No Repair

Repair

Replace the right-bank FCV. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.

Go to 2C

  • 3A

Guided Step 3 - Check the right-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Connect the engine harness to the FCV actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the FCV actuator SIGNAL pin at the FCV connector and the FCV actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the FCV actuator RETURN pin at the FCV connector and the FCV actuator RETURN pin at the CM558 module connector of the engine harness.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator.

Action

Check the right-bank engine harness and FCV actuator resistance.

  • Measure the resistance from the FCV actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the FCV actuator FEEDBACK pin in the engine harness CM558 connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the harness connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in RUN mode at rated speed, no load
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent left-bank engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the FCV actuator connector.

Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is detected while the engine is operating, a warning or shutdown alarm corresponding fault code will be activated.

Fault Codes 3475 and/or 2313, 2314, 3476 and 3477 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the left-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in the RUN mode and operate engine for more than 1 minute.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 3475 is inactive.

Fault Code 3475 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 09-Feb-2012


FAULT CODE 3475 - Single Turbochargers - Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3477 active or high inactive counts?
STEP 2. | Check the right-bank fuel control valve (FCV) actuator. |
 | STEP 2A. Check the FCV feedback signal voltage. | Between 0 and 5-VDC?
STEP 3. | Check the right-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 3475 and/or 2313, 2314, 3476 and 3477 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive? | Fault Code 3475 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3475 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the right-bank fuel control valve (FCV) actuator.

Guided Step 2A - Check the FCV actuator commanded signal percentage pulse-width modulated (PWM) duty cycle.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank actuator commanded signal percentage duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the FCV actuator position feedback and RETURN (-) pins. The feedback signal must be between 0 and 5-VDC.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for the commanded position percent duty cycle specifications.

Use the following procedure for general mutlimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0 and 5-VDC?
YES NO
No Repair

Repair

Replace the right-bank FCV. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.

Go to 2C

  • 3A

Guided Step 3 - Check the right-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Connect the engine harness to the FCV actuator
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the FCV actuator SIGNAL pin at the FCV connector and the FCV actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the FCV actuator RETURN pin at the FCV connector and the FCV actuator RETURN pin at the CM558 module connector of the engine harness.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short-to-ground.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator.

Action

Check the right-bank engine harness and FCV actuator resistance.

  • Measure the resistance from the FCV actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the FCV actuator FEEDBACK pin in the engine harness CM558 connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness or the harness connector.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in RUN mode at rated speed, no load
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent left-bank engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the FCV actuator connector.

Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is detected while the engine is operating, a warning or shutdown alarm corresponding fault code will be activated.

Fault Codes 3475 and/or 2313, 2314, 3476 and 3477 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the left-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in RUN mode and engine running for greater than 1 minute.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 3475 is inactive.

Fault Code 3475 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 09-Feb-2012


FAULT CODE 3476 - Multiple Turbochargers - Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3476 active or high inactive counts?
STEP 2. | Check the right-bank fuel control valve actuator. |
 | STEP 2A. Check the actuator commanded position feedback signal. | 0 to 5-VDC?
STEP 3. | Check the right-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | More than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 3476 and/or 2313, 2314, 3475 and 3477 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3476 inactive?
 | STEP 4B. Clear the inactive. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3476 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the right-bank fuel control valve actuator.

Guided Step 2A - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feeback and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the right-bank fuel control valve:

  • Use the following procedure in the Troubleshooting and Repair Manual, Generator Set QSV81 and QSV91 CM700, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 3A

Appropriate troubleshooting chart

Guided Step 3 - Check the right-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Inspect the right-bank engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the right-bank engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the right-bank CM558 Module.

Action

Check for an open circuit in the right-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 Module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 Module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.

Action

Check the right-bank engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator FEEDBACK pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent right-bank engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a warning or shutdown alarm and corresponding fault code will be activated.

Fault Codes 3476 and/or 2313, 2314, 3475 and 3477 become active?
YES NO

Repair

Repair or replace the right-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in Run mode and operate engine for more than 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 3476 is inactive.

Action

Check for inactive fault codes.

  • Use INSITE electronic service tool to verify that Fault Code 3476 is inactive.

Fault code 3476 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 30-Jan-2012


FAULT CODE 3476 - Single Turbocharger - Engine Electronic Fuel Control Valve 2 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3476 active or high inactive counts?
STEP 2. | Check the right-bank fuel control valve actuator. |
 | STEP 2A. Check the actuator commanded position feedback signal. | 0 to 5-VDC?
STEP 3. | Check the right-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | More than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 3476 and/or 2313, 2314, 3475 and 3477 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3476 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3476 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Used the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the right-bank fuel control valve actuator.

Guided Step 2A - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool. Drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the right-bank fuel control valve:

  • Use the following procedure in the Troubleshooting and Repair Manual, Generator Set QSV81 and QSV91 CM700, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 3A

Appropriate troubleshooting chart

Guided Step 3 - Check the right-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Inspect the right-bank engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the right-bank engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the right-bank CM558 Module.

Action

Check for an open circuit in the right-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 Module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 Module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.

Action

Check the right-bank engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator Signal pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator Feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent right-bank engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 3476 and/or 2313, 2314, 3475 and 3477 become active?
YES NO

Repair

Repair or replace the right-bank engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in Run mode and operate engine for more than 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 3476 is inactive.

Action

Check for inactive fault codes.

  • Use INSITE electronic service tool to verify that Fault Code 3476 is inactive.

Fault Code 3476 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • PLace Run/Stop/Auto switch in STOP mode.

Action

Check for inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 30-Jan-2012


FAULT CODE 3477 - Multiple Turbochargers - Engine Electronic Fuel Control Valve 2 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3477 active or high inactive counts?
STEP 2. | Check the right-bank fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator commanded position percent pulse width modulation (PWM) duty cycle signal. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the actuator commanded position feedback signal. | 0 to 5-VDC?
STEP 3. | Check the right-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | More than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 3477 and/or 2313, 2314, 3475 and 3476 become active?
STEP 4. | Check the right-bank ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent PWM duty cycle signal at the CM558 connector | Percent duty cycle 10 to 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 3477 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3477 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the right-bank fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the right-bank fuel control valve actuator.

Action

Inspect the right-bank actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the right-bank engine harness, the harness connector or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure to replace the fuel control valve in the Troubleshooting and Repair Manual, QSV81 and QSV91 CM700 Generator Set, Bulletin 4021314. Refer to Procedure 006-049 in Sectio 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool. Drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Using a multimeter, measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the FCV actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve (FCV) actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit energized.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank fuel control valve feedback signal voltage:

  • Using the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a position between 0 and 100 percent.
  • Using a multimeter, measure the signal feedback voltage by connecting the multimeter test probes between the FCV actuator position feedback and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the right-bank fuel control valve.

  • Use the following procedure to replace the fuel control valve in the Troubleshooting and Repair Manual, QSV81 and QSV91 CM700 Generator Set, Bulletin 4021314. Refer to Procedure 006-049 in Sectio 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the right-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the right-bank CM558 Module.

Action

Inspect the right-bank engine harness and connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the right-bank engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Check for an open circuit in the right-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 Module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 Module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.

Action

Check the right-bank engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator Signal pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent right-bank engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 3477 and/or 2313, 2314, 3475 and 3476 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

  • Repair or replace the right-bank engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the right-bank ECM.

Guided Step 4 - Check the fuel control valve commanded position percent PWM duty cycle signal at the CM558 connector.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the right-bank CM558 connector B.

  • Using the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Using a multimeter, measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the FCV actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault has been detected with the right-bank CM558 module.

  • Replace the CM558 Module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 3477 is inactive.

Fault Code 3477 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 15-Mar-2012


FAULT CODE 3477 - Single Turbocharger - Engine Electronic Fuel Control Valve 2 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3477 active or high inactive counts?
STEP 2. | Check the right-bank fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator commanded position percent pulse width modulation (PWM) duty cycle signal. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the actuator commanded position feedback signal. | 0 to 5-VDC?
STEP 3. | Check the right-bank engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | More than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 3477 and/or 2313, 2314, 3475 and 3476 become active?
STEP 4. | Check the right-bank ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent PWM duty cycle signal at the CM558 connector | Percent duty cycle 10 to 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Is Fault Code 3477 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3477 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the right-bank fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the right-bank fuel control valve actuator.

Action

Inspect the right-bank actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the right-bank engine harness, the harness connector or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure to replace the fuel control valve in the Troubleshooting and Repair Manual, QSV81 and QSV91 CM700 Generator Set, Bulletin 4021314. Refer to Procedure 006-049 in Sectio 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank actuator commanded signal percent duty cycle.

  • Using the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Using a multimeter, measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the fuel control valve (FCV) actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the FCV actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the right-bank fuel control valve feedback signal voltage:

  • Using the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a position between 0 and 100 percent.
  • Using a multimeter, measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the right-bank fuel control valve.

  • Use the following procedure to replace the fuel control valve in the Troubleshooting and Repair Manual, QSV81 and QSV91 CM700 Generator Set, Bulletin 4021314. Refer to Procedure 006-049 in Sectio 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the right-bank engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the right-bank CM558 Module.

Action

Inspect the right-bank engine harness and connector pins for the following

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the right-bank engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the right-bank CM558 module.

Action

Check for an open circuit in the right-bank engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 Module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 Module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.

Action

Check the right-bank engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator signal pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the right-bank engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent right-bank engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 3477 and/or 2313, 2314, 3475 and 3476 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

  • Repair or replace the right-bank engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the right-bank ECM.

Guided Step 4 - Check the fuel control valve commanded position percent PWM duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the right-bank CM558 connector B.

  • Using the actuator test function within INSITE™ electronic service tool, drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Using a multimeter, measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the FCV actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent Duty Cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault has been detected with the right-bank CM558 module.

  • Replace the CM558 Module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Entergize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine running for more than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 3477 is inactive.

Fault Code 3477 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Entergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 15-Mar-2012


FAULT CODE 3489 - Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 1795, 1796, 1797, 1798, and/or 1799 active?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Check the turbocharger compressor bypass valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 2B. Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins. | Dirty or damaged connector pins?
 | STEP 2C. Check the actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 94 percent?
 | STEP 2D. Check the actuator position feedback signal voltage. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged connector pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check the CM558 module. |
 | STEP 4A. Check the actuator commanded signal percent duty cycle at the CM558 connector. | Percent duty cycle 10 to 91 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1799 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 1795, 1796, 1797, 1978, and/or 1799 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the turbocharger compressor bypass actuator.

Guided Step 2A - Check the turbocharger compressor bypass valve for free movement.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the turbocharger compressor bypass valve for free movement.

  • Use the Actuator Diagnostic Tests feature located within the ECM Diagnostic Test options within INSITE™ electronic service tool to test the valve for free movement throughout its full range (0 to 100 percent).
  • Compare the Commanded Position Signal and Feedback Position Signal values.
  • Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES NO
No Repair

Repair

A problem has been detected with the turbocharger compressor bypass valve or its control and feedback circuit.

Proceed to the next troubleshooting step.

Go to 5A

Go to 2B

Guided Step 2B - Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Inspect the turbocharger compressor bypass actuator connector, the engine harness connector, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector pins?
YES NO

Repair

A damaged connection has been detected in the turbocharger compressor actuator connector or harness connector.

Repair or replace the engine harness or the turbocharger compressor bypass actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger compressor bypass valve. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator commanded position SIGNAL (+) and RETURN (-) pins at the actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the actuator position.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for percent duty cycle specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Proceed to the next troubleshooting step.

Go to 5A

Go to 3A

Guided Step 2D - Check the actuator position feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the turbocharger compressor bypass actuator feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the turbocharger compressor bypass actuator position feedback and RETURN (-) pins. The feedback signal must be between 0 to 5-VDC.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Section 0 to 5-VDC?
YES NO
No Repair

Repair

A problem has been detected in the turbocharger compressor bypass control valve.

  • Replace the turbocharger compressor bypass valve. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector pins?
YES NO

Repair

  • Clean the connector pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to all other pins in the CM558 connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to all other pins in the CM558 connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit to engine block ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to engine block ground.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 module.

Guided Step 4A - Check the actuator commanded signal percent duty cycle at the CM558 module.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded position signal percent duty cycle at the CM558 connector.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator position SIGNAL (+) and RETURN (-) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the actuator position.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for percent duty cycle specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A problem has been detected within the CM558 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1799 is inactive.

Fault Code 1799 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Mar-2012


FAULT CODE 3491 - Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil and Filters | Refer to Procedure 007-002 | QSV81 and QSV91 CM700 | 4021314

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active or inactive fault code. | Active or inactive counts of Fault Code 3491?
 | STEP 1B. Check for multiple fault codes. | Active or inactive counts of Fault Codes 143, 415, 556, 1362, 1367, 1368, 1377, and 1378?
STEP 2. | Check the lubricating oil filters. |
 | STEP 2A. Inspect the lubricating oil filters. | Oil filters contaminated?
STEP 3. | Check the lubricating oil pressure sensors. |
 | STEP 3A. Check the pre-filter and post-filter oil pressure sensors. | Pressure sensor found malfunctioning?
STEP 4. | Check the lubricating oil filter head. |
 | STEP 4A. Check the lubricating oil filter head. | Lubricating oil filter head malfunctioning?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 3491 inactive?
 | STEP 5B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active or inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Code 3491?
YES NO

Repair

Proceed to next troubleshooting step.

 No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for multiple fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Codes 143, 415, 556, 1362, 1367, 1368, 1377, and 1378?
YES NO

Repair

Troubleshoot any the above fault codes.

  • See the relevant fault code troubleshooting procedure in Section TF.
 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the lubricating oil filters.

Guided Step 2A - Inspect the lubricating oil filters.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Remove, inspect, and replace the lubricating oil filters.

  • Loose connector
  • Remove and replace the lubricating oil filters. Refer to Procedure 007-002 in the Associated Procedures Table.

Cut open the lubricating oil filters and inspect for debris or oil contamination.

Check the lubricating oil condition as per Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin 3810340, or Contact a Cummins® Authorized Repair Location.

Oil filters contaminated?
YES NO

Repair

Replace the engine lubricating oil if the oil shows signs of contamination or the oil analysis results recommend that the lubricating oil should be replaced.

  • Replace the engine lubricating oil. Refer to Procedure 007-002 in the Associated Procedures Table.
No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the lubricating oil pressure sensors.

Guided Step 3A - Check the pre-filter and post-filter oil pressure sensors.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the pre-filter and post-filter oil pressure sensors.

  • Use INSITE™ electronic service tool to check the operation and range of the pre-filter and post-filter lubricating oil pressure sensors.

Pressure sensor found malfunctioning?
YES NO

Repair

Replace the appropriate pressure sensor.

Replace the malfunctioning pressure sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the lubricating oil filter head.

Guided Step 4A - Check the lubricating oil filter head.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the lubricating oil filter head assembly.

Lubricating oil filter head malfunctioning?
YES NO

Repair

Repair or replace the lubricating oil filter head.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 3491 is inactive.

Fault Code 3491inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 24-Aug-2014


FAULT CODE 3594 - Multiple Turbocharger with Integrated Throttle - Engine Emissions Closed Loop Fueling (Limit) - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 – male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 – female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 2892245 – diagnostic breakout cable kit and Part Number 3824892 – breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3595 active?
STEP 2. | Check the coolant temperature sensor (high temperature coolant circuit). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 625 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the intake manifold temperature and pressure sensors |
 | STEP 3A. Inspect the intake manifold temperature sensor, pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the intake manifold temperature sensor. | 625 ohms to 36k ohms?
 | STEP 3C. Check the intake manifold temperature sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 3D. Check the intake manifold temperature sensor signal voltage. | 0.46 to 4.50 VDC?
 | STEP 3E. Check for a short circuit. | More than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the fuel inlet and fuel outlet pressure sensors. |
 | STEP 4A. Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel inlet and fuel outlet pressure sensors supply voltage. | 4.75 to 5.25 VDC?
 | STEP 4C. Check the fuel inlet pressure sensor signal voltage. | 1.7 to 4.50 VDC?
 | STEP 4D. Check the fuel outlet pressure sensor signal voltage. |
 | STEP 4E. Check for a short circuit. | More than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the gas mass flow sensor - A-Bank |
 | STEP 5A. Inspect the gas mass flow sensor and engine harness connector pins on the A-Bank. | Dirty or damaged pins?
 | STEP 5B. Check the gas mass flow sensor supply voltage. | 8.0 to 15.0 VDC?
 | STEP 5C. Check the gas mass flow sensor signal voltage | 0.46 to 4.50-VDC?
 | STEP 5D. Check for a short circuit. | More than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the gas mass flow sensor - B-Bank |
 | STEP 6A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Check the sensor supply voltage. | Dirty or damaged pins?
 | STEP 6C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
 | STEP 6D. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 7. | Check the fuel control valve actuator - A-Bank. |
 | STEP 7A. Check the fuel control valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 7B. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 7C. Check the sensor signal voltage. | percent Duty Cycle 10 - 94 percent?
 | STEP 7D. Check the sensor signal voltage. | 0 to 5 VDC?
 | STEP 7E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 7F. Check for an open circuit. | Less than 10 ohms?
STEP 8. | Check the fuel control valve actuator - B- Bank. |
 | STEP 8A. Check the fuel control valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 8B. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 8C. Check the actuator commanded position percent pulse-width modulation duty cycle signal. | Percent duty cycle 10 - 94 percent?
 | STEP 8D. Check the actuator commanded position feedback signal. | 0 to 5 VDC?
 | STEP 8E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 8F. Check for an open circuit. | Less than 10 ohms?
STEP 9. | Check the kilowatt load transducer, if installed. |
 | STEP 9A. Check the kilowatt load transducer reference signal. | Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
 | STEP 9B. Check the generator set controller calibration. | Generator set controller voltage and ampere output calibration correct?
STEP 10. | Check the kilowatt load reference signal. |
 | STEP 10A. Check the quality of the natural gas supply. |
STEP 11. | Clear the fault codes. |
 | STEP 11A. Verify the fault code is inactive. | Is Fault Code 3594 inactive?
 | STEP 11B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3595 active?

YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference t048 in Section TS.

Go to 11A

Go to 2A

Guided Step 2 - Check the coolant temperature sensor (high temperature circuit).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the CM700 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Section 19.5

Go to 2B

Go to 11A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

625 ohms to 36k ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 11A

Guided Step 2C - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the CM700 connector A.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 11A

Guided Step 2D - Check for a open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the CM700 connector A.

Action

Check for an open circuit.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) SIGNAL pin in the CM700 connector A.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) RETURN pin in the CM700 connector A.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 3A

Go to 11A

Guided Step 3 - Check the intake manifold temperature and pressure sensors.

Guided Step 3A - Inspect the intake manifold temperature sensor, pressure sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the intake manifold temperature sensor harness connector.
  • Disconnect the intake manifold pressure sensor.
  • Disconnect the left-bank CM558 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 11A

Go to 3B

Guided Step 3B - Check the resistance of the intake manifold temperature sensor

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine intake manifold temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor:

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3C

Go to 11A

Guided Step 3C - Check the intake manifold temperature sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Check the intake manifold temperature sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

0.46 to 4.50 VDC?
YES | NO
No Repair | No Repair

Go to 3E

Go to 11A

Guided Step 3E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left-bank CM558 connector A.

Action

Check for a short circuit to engine block ground:

  • Measure the resistance from the SUPPLY pin of the intake manifold temperature sensor connector to the engine block ground.
  • Measure the resistance from the SIGNAL pin of the intake manifold temperature sensor connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 11A

Guided Step 3F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left-bank CM558 connector A.

Action

Check the intake manifold temperature and pressure sensor circuits for an open circuit:

  • Measure the resistance from the intake manifold temperature sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor SIGNAL pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold temperature sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor RETURN pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SUPPLY pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor RETURN pin in the left-bank CM558 connector A.

Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SIGNAL pin in the left-bank CM558 connector A.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 11A

Guided Step 4 - Check the fuel inlet and fuel outlet pressure sensors

Guided Step 4A - Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the fuel inlet pressure sensor harness connector.
  • Disconnect the fuel outlet pressure sensor connector.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the malfunctioning fuel inlet and fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 4B

Guided Step 4B - Check the fuel inlet and fuel outlet pressure sensors supply voltage

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

Check the fuel outlet pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 4C

Go to 4E

Guided Step 4C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

1.7 to 4.50 VDC?
YES NO
No Repair

Repair

Replace the fuel inlet pressure sensor.

  • Refer to Procedure 019-188 in Section 19.

Go to 4D

Go to 11A

Guided Step 4D - Check the fuel outlet pressure sensor signal voltage

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

0.50 to 4.50 VDC?
YES NO
No Repair

Repair

  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4E

Go to 11A

Guided Step 4E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 11A

Guided Step 4F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel inlet and fuel outlet pressure sensor circuits for an open circuit:

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor RETURN pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure SIGNAL pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SIGNAL pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor RETURN pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SIGNAL pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 11A

Guided Step 5 - Check the gas mass flow sensor - A-Bank

Guided Step 5A - Inspect the gas mass flow sensor and engine harness connector pins on the A-Bank.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the malfunctioning fuel inlet pressure or outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 5B

Guided Step 5B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor supply and return connector pins in the main engine harness.

8.0 to 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5D

Guided Step 5C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the left-bank CM558 connector B.

0.46 to 4.50 VDC?
YES NO
No Repair

Repair

Replace the gas mass flow sensor.

  • Refer to Procedure 019-101 in Section 19.

Go to 5D

Go to 11A

Guided Step 5D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5E

Go to 11A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit:

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the left-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 11A

Guided Step 6 - Check the gas mass flow sensor - A-Bank

Guided Step 6A - Inspect the gas mass flow sensor and engine harness connector pins on the B-Bank.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the malfunctioning fuel inlet or fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 6B

Guided Step 6B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor supply and return connector pins in the main engine harness.

8.0 to 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 6C

Go to 6D

Guided Step 6C - Check the gas mass flow sensor signal voltage

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the right-bank CM558 connector B.

0.46 to 4.50 VDC?
YES NO
No Repair

Repair

Replace the gas mass flow sensor.

  • Refer to Procedure 019-101 in Section 19.

Go to 6D

Go to 11A

Guided Step 6D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6E

Go to 11A

Guided Step 6E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit:

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the right-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the right-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the right-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 11A

Guided Step 7 - Check the fuel control valve - A-Bank

Guided Step 7A - Check the fuel control valve for free movement on the A-Bank.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement:

  • Use INSITE™ electronic service tool to perform the "Actuator Diagnostic Test" within the "ECM Diagnostic Tests" option and compare the actuator commanded position and position feedback signals . Contact a local Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-202 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the malfunctioning fuel inlet or fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 7C

Guided Step 7C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator to function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100Percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator Position SIGNAL (+) and RETURN (–) pins at the fuel control valve actuator breakout harness connectors. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 - 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram for the appropriate circuit.

Go to 7D

Go to 7E

Guided Step 7D - Check the fuel control valve feedback signal voltage

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and return (–) breakout harness connectors. The feedback signal must be between 0 to 5 VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the fuel control valve.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to

Go to

Guided Step 7E - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect all sensors that have a shared supply or return with the fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN (–) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position feedback pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7F

Go to 11A

Guided Step 7F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel control valve circuits for an open circuit.

  • Measure the resistance from the fuel control valve position actuator SIGNAL (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL (+) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position actuator RETURN (–) pin in the fuel control valve connector to the fuel control valve position actuator RETURN (–) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position feedback pin in the fuel control valve connector to the fuel control valve position feedback pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 8A

Go to 11A

Guided Step 8 - Check the fuel control valve - B-Bank

Guided Step 8A - Check the fuel control valve for free movement on the B-Bank.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.

Action

Check the fuel control valve for free movement:

  • Use INSITE™ electronic service tool to perform the "Actuator Diagnostic Test" within the "ECM Diagnostic Tests" option and compare the actuator commanded position and position feedback signals. Contact a local Cummins® Authorized Repair Location

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

9A and 9B as appropriate

Go to 8B

Guided Step 8B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the right-bank CM558 connector B.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the malfunctioning fuel inlet or fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 8C

Guided Step 8C - Check the actuator commanded signal percent duty cycle

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator Position SIGNAL (+) and RETURN (–) pins at the fuel control valve actuator breakout harness connectors. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 - 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram for the appropriate circuit.

Go to 8D

Go to 8E

Guided Step 8D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and return (–) breakout harness connectors. The feedback signal must be between 0 to 5 VDC.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Go to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5 VDC?
YES NO
No Repair

Repair

Replace the fuel control valve

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 8E

Go to 11A

Guided Step 8E - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect all sensors that have a shared supply or return with the fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN (–) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position feedback pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 8F

Go to 11A

Guided Step 8F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel control valve circuits for an open circuit:

  • Measure the resistance from the fuel control valve position actuator SIGNAL (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL (+) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position actuator RETURN (–) pin in the fuel control valve connector to the fuel control valve position actuator RETURN (–) pin in the right-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position feedback pin in the fuel control valve connector to the fuel control valve position feedback pin in the right-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 9A

Go to 11A

Guided Step 9 - Check the kilowatt load transducer. if installed.

Guided Step 9A - Check the kilowatt load transducer reference signal. (If the generator set is not installed with a kilowatt load transducer then proceed to Guided Step 9B.)

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a local Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 10A

Go to 11A

Guided Step 9B - Check the generator set controller calibration.

Conditions

This guided step should only be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1-L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a local Cummins® Authorized Repair Location.

Generator set controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

Go to 10A

Go to 11A

Guided Step 10 - Check the quality of the natural gas supply to the generator set.

Guided Step 10A - Check the quality of the natural gas supply

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

  • Check the quality of the natural gas supplied to the generator set meets or exceeds the minimum requirement for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 018-002 in Section V.
  • Contact a local Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

Contact a local Cummins® Authorized Repair Location.

Go to 11A

Go to 11A

Guided Step 11 - Clear the fault codes.

Guided Step 11A - Verify the fault code is inactive

Conditions

  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Verify fault code status.

  • Use INSITE™ electronic service tool to verify that Fault Code 3594 is inactive.

Fault code 3594 inactive?
YES NO

Repair

Use INSITE™ electronic service tool and an exhaust gas analyzer. Check the exhaust emissions against the specification for the engine and fine-tune as required. Contact a local Cummins® Authorized Repair Location.

Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual. Bulletin 4021313. Refer to Procedure 018-002 in Section V.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 11B

Go to 1A

Guided Step 11B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode and operate the engine for more than 1 minute.

Action

Verify fault code status.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO

Repair

Use INSITE™ electronic service tool and an exhaust gas analyzer to check the exhaust emissions against the specification for the engine and fine-tune as required. Contact a Cummins® Authorized Repair Location.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 018-002 in Section V.

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting step

Last Modified: 24-Aug-2014


FAULT CODE 3594 - Single Turbocharger with Integrated Throttle - Engine Emissions Closed Loop Fueling (Limit) - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 2892245 - diagnostic breakout cable kit and Part Number 3824892 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3595 active?
STEP 2. | Check the coolant temperature sensor (high temperature coolant circuit). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Wiring harness and connector pins OK?
 | STEP 2B. Check the resistance of the sensor. | 625 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the intake manifold temperature and pressure sensor. |
 | STEP 3A. Inspect the intake manifold temperature sensor, pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the intake manifold temperature sensor. | 625 ohms to 36k ohms?
 | STEP 3C. Check the intake manifold temperature sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 3D. Check the intake manifold temperature sensor signal voltage | 0.50 to 4.5 VDC?
 | STEP 3E. Check for a short circuit. | More than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the fuel inlet and fuel outlet pressure sensors. |
 | STEP 4A. Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel inlet and fuel outlet pressure sensors supply voltage. | 4.75 to 5.25 VDC?
 | STEP 4C. Check the fuel inlet pressure sensor signal voltage. | 1.7 to 4.5 VDC?
 | STEP 4D. Check the fuel outlet pressure sensor signal voltage. | 0.5 to 4.5 VDC?
 | STEP 4E. Check for a short circuit. | More than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the gas mass flow sensor - A-Bank |
 | STEP 5A. Inspect the gas mass flow sensor and engine harness connector pins on the A-Bank. | Dirty or damaged pins?
 | STEP 5B. Check the gas mass flow sensor supply voltage. | 8.0 to 15.0 VDC?
 | STEP 5C. Check the fuel inlet pressure sensor signal voltage. | 0.46 to 4.5 VDC?
 | STEP 5D. Check for a short circuit. | More than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the gas mass flow sensor - B-Bank (QSV91G Single Turbocharger Low British Thermal Unit (BTU) Fueled Engines only - All Other QSV91G Single Turbocharger Engines Proceed to Step 7A.) |
 | STEP 6A. Inspect the gas mass flow sensor and engine harness connector pins on the B-Bank. | Dirty or damaged pins?
 | STEP 6B. Check the gas mass flow sensor supply voltage. | 8.0 to 15.0 VDC?
 | STEP 6C. Check the gas mass flow sensor signal voltage. | 0.46 to 4.5 VDC?
 | STEP 6D. Check for a short circuit. | More than 100k ohms?
 | STEP 6E. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the fuel control valve - A-Bank. |
 | STEP 7A. Check the fuel control valve for free movement on the A - Bank. | Commanded position signal and feedback signal within 30 percent?
 | STEP 7B. Inspect the fuel control valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 7C. Check the actuator commanded signal percent duty cycle. | Percent duty cycle 10 - 94 percent?
 | STEP 7D. Check the fuel control valve feedback signal voltage. | 0 to 5 VDC?
 | STEP 7E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 7F. Check for an open circuit. | Less than 10 ohms?
STEP 8. | Check the fuel control valve - B-Bank (QSV91G single turbocharge low BTU fueled engines only - all other QSV91G single turbocharger engines proceed to Step 9A) |
 | STEP 8A. Check the fuel control valve for free movement on the B-Bank. | Commanded position signal and feedback signal within 30 percent?
 | STEP 8B. Inspect the fuel control valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 8C. Check the actuator commanded signal percent duty cycle. | Percent duty cycle 10 - 94 percent?
 | STEP 8D. Check the fuel control valve feedback signal voltage | 0 to 5 VDC?
 | STEP 8E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 8F. Check for an open circuit. | Less than 10 ohms?
STEP 9. | Check the kilowatt load transducer, if installed. (If the Generator Set is not equipped with a kilowatt load transducer, then proceed to Guided Step 9B.) |
 | STEP 9A. Check the kilowatt load transducer reference signal. (If the generator set is not equipped with a kilowatt load transducer then proceed to Guided Step 9B.) | Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
 | STEP 9B. Check the generator set controller calibration. (This guided step should only be followed for generator sets not equipped with a kilowatt load transducer.) | Generator set controller output voltage and ampere readings match the measured readings?
STEP 10. | Check the quality of the natural gas supply to the generator set. |
 | STEP 10A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 11. | Clear the fault codes. |
 | STEP 11A. Verify the fault code is inactive. | Is Fault Code 3594 inactive?
 | STEP 11B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3595 active?

YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference t048 in Section TS.

Go to 11A

Go to 2A

Guided Step 2 - Check the coolant temperature sensor (high temperature circuit).

Guided Step 2A - Inspect the sensor and engine harness connector pins:

Conditions

  • De-energize the keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the CM700 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 11A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor (high temperature).

  • Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 11A

Guided Step 2C - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the CM700 connector A.

Action

Check for a short circuit to engine ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 11A

Guided Step 2D - Check for a open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the CM700 connector A.

Action

Check for an open circuit.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) SIGNAL pin in the CM700 connector A.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) RETURN pin in the CM700 connector A.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 3A

Go to 11A

Guided Step 3 - Check the intake manifold temperature and pressure sensors.

Guided Step 3A - Inspect the intake manifold temperature sensor, pressure sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the intake manifold temperature sensor harness connector.
  • Disconnect the intake manifold pressure sensor.
  • Disconnect the left-bank CM558 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 11A

Go to 3B

Guided Step 3B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine intake manifold temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor:

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3C

Go to 11A

Guided Step 3C - Check the intake manifold temperature sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Check the intake manifold temperature sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

0.46 to 4.5 VDC?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor:

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3E

Go to 11A

Guided Step 3E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left-bank CM558 connector A.

Action

Check for a short circuit to engine block ground:

  • Measure the resistance from the SUPPLY pin of the intake manifold temperature sensor connector to the engine block ground.
  • Measure the resistance from the SIGNAL pin of the intake manifold temperature sensor connector to the engine block ground.

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 11A

Guided Step 3F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left-bank CM558 connector A.

Action

Check the intake manifold temperature and pressure sensor circuits for an open circuit:

  • Measure the resistance from the intake manifold temperature sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor SIGNAL pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold temperature sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor RETURN pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SUPPLY pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor RETURN pin in the left-bank CM558 connector A.

Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SIGNAL pin in the left-bank CM558 connector A.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 11A

Guided Step 4 - Check the fuel inlet and fuel outlet pressure sensors.

Guided Step 4A - Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the fuel inlet pressure sensor harness connector.
  • Disconnect the fuel outlet pressure sensor connector.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the malfunctioning fuel inlet or fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 4B

Guided Step 4B - Check the fuel inlet and fuel outlet pressure sensors supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

Check the fuel outlet pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 4C

Go to 4E

Guided Step 4C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

1.7 to 4.5 VDC?
YES NO
No Repair

Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4D

Go to 11A

Guided Step 4D - Check the fuel outlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

0.50 to 4.5 VDC?
YES NO
No Repair

Repair

  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4E

Go to 11A

Guided Step 4E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 11A

Guided Step 4F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel inlet and fuel outlet pressure sensor circuits for an open circuit:

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor RETURN pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure SIGNAL return pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SIGNAL pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor RETURN pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SIGNAL pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 11A

Guided Step 5 - Check the gas mass flow sensor - A-Bank

Guided Step 5A - Inspect the gas mass flow sensor and engine harness connector pins on the A-Bank.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the malfunctioning fuel inlet or fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 5B

Guided Step 5B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor supply and return connector pins in the main engine harness.

8.0 to 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5D

Guided Step 5C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the left-bank CM558 connector B.

0.46 to 4.5 VDC?
YES NO
No Repair

Repair

Replace the gas mass flow sensor:

  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to 5D

Go to 11A

Guided Step 5D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5E

Go to 11A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit:

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the left-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 11A

Guided Step 6 - Check the gas mass flow sensor - B-Bank (QSV91G Single Turbocharger Low British Thermal Unit (BTU) Fueled Engines Only - All Other QSV91G Single Turbocharger Engines Proceed to Step 7A.)

Guided Step 6A - Inspect the gas mass flow sensor and engine harness connector pins on the B-Bank.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the malfunctioning fuel inlet or fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 6B

Guided Step 6B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor supply and return connector pins in the main engine harness.

8.0 to 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 6C

Go to 6D

Guided Step 6C - Check the gas mass flow sensor signal voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the right-bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the right-bank CM558 connector B.

0.46 to 4.5 VDC?
YES NO
No Repair

Repair

  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to 6D

Go to 11A

Guided Step 6D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6E

Go to 11A

Guided Step 6E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit:

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the right-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the right-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the right-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 11A

Guided Step 7 - Check the fuel control valve - A-Bank

Guided Step 7A - Check the fuel control valve for free movement on the A-Bank.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement:

  • Use INSITE™ electronic service tool to perform the "Actuator Diagnostic Test" within the "ECM Diagnostic Tests" option and compare the actuator commanded position and position feedback signals. Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the malfunctioning fuel inlet or fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 7C

Guided Step 7C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator to function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator breakout harness connectors. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 - 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram for the appropriate circuit.

Go to 7D

Go to 7E

Guided Step 7D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and return (-) breakout harness connectors. The feedback signal must be between 0 to 5 VDC.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Go to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5 VDC?
YES NO
No Repair

Repair

Replace the fuel control valve.

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 7E

Go to 11A

Guided Step 7E - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect all sensors that have a shared supply or return with the fuel control valve
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN (-) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position feedback pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7F

Go to 11A

Guided Step 7F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel control valve circuits for an open circuit:

  • Measure the resistance from the fuel control valve position actuator SIGNAL (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL (+) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position actuator RETURN (-) pin in the fuel control valve connector to the fuel control valve position actuator RETURN (-) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position feedback pin in the fuel control valve connector to the fuel control valve position feedback pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 8A

Go to 11A

Guided Step 8 - Check the fuel control valve - B-Bank (QSV91G single turbocharger low BTU fueled engines only - all other QSV91G single turbocharger engines proceed to Step 9A)

Guided Step 8A - Check the fuel control valve for free movement on the B-Bank.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement:

  • Use INSITE™ electronic service tool to perform the "Actuator Diagnostic Test" within the "ECM Diagnostic Tests"option and compare the actuator commanded position and position feedback signals. Contact a local Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

9A and 9B as appropriate

Go to 8B

Guided Step 8B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the right-bank CM558 connector B.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-202 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the malfunctioning fuel inlet or fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 8C

Guided Step 8C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator breakout harness connectors. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 - 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram for the appropriate circuit.

Go to 8D

Go to 8E

Guided Step 8D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and return (-) breakout harness connectors. The feedback signal must be between 0 to 5 VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5 VDC?
YES NO
No Repair

Repair

Replace the fuel control valve:

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 8E

Go to 11A

Guided Step 8E - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect all sensors that have a shared supply or return with the fuel control valve.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN (-) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position feedback pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 8F

Go to 11A

Guided Step 8F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check the fuel control valve circuits for an open circuit:

  • Measure the resistance from the fuel control valve position actuator SIGNAL (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL (+) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position actuator RETURN (-) pin in the fuel control valve connector to the fuel control valve position actuator RETURN (-) pin in the right-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position feedback pin in the fuel control valve connector to the fuel control valve position feedback pin in the right-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 9A

Go to 11A

Guided Step 9 - Check the kilowatt load transducer, if fitted. (If the Generator Set is not equipped with a kilowatt load transducer, then proceed to Guided Step 9B.)

Guided Step 9A - Check the kilowatt load transducer reference signal. (If the generator set is not equipped with a kilowatt load transducer then proceed to Guided Step 9B.)

Conditions

  • Energize keyswitch circuit.
  • Connect all components.
  • Place run/stop/auto switch in the RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a local Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a local Cummins® Authorized Repair Location.

Go to 10A

Go to 11A

Guided Step 9B - Check the generator set controller calibration. (This guided step should only be followed for generator sets not equipped with a kilowatt load transducer.)

Conditions

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Check the generator set controller calibration.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1-L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a local Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

Go to 10A

Go to 11A

Guided Step 10 - Check the quality of the natural gas supply to the generator set.

Guided Step 10A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check if the quality of the natural gas supplied to the generator set meets or exceeds the minimum requirement for the generator set (methane number and fuel contaminants limits). Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 018-002 in Section V.
  • Contact a local Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

Contact a local Cummins® Authorized Repair Location.

Go to 11A

Go to 11A

Guided Step 11 - Clear the fault codes.

Guided Step 11A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify fault code status.

  • Use INSITE™ electronic service tool to verify that Fault Code 3594 is inactive.

Fault code 3594 inactive?
YES NO

Repair

Use INSITE™ electronic service tool and an exhaust gas analyzer. Check the exhaust emissions against the specification for the engine and fine-tune as required. Contact a local Cummins® Authorized Repair Location.

Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 018-002 in Section V.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 11B

Go to 1A

Guided Step 11B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode and engine operating for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify fault code status.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO

Repair

Use INSITE™ electronic service tool to clear the inactive fault codes.

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 25-Aug-2014


FAULT CODE 3595 - Multiple Turbocharger with Integrated Throttle - Engine Emissions Closed Loop Fueling (Limit) - Root Cause Unknown

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 2892245 - diagnostic breakout cable kit and Part Number 3824892 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3595 active?
STEP 2. | Check the coolant temperature sensor (high temperature coolant circuit). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 625 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the intake manifold temperature and pressure sensors. |
 | STEP 3A. Inspect the intake manifold temperature sensor, pressure sensor, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the intake manifold temperature sensor. | 625 ohms to 36k ohms?
 | STEP 3C. Check the intake manifold temperature sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 3D. Check the intake manifold temperature sensor signal voltage. | 0.50 to 4.5 VDC?
 | STEP 3E. Check for a short circuit. | More than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the fuel inlet and fuel outlet pressure sensors. |
 | STEP 4A. Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel inlet and fuel outlet pressure sensors supply voltage. | 4.75 to 5.25 VDC?
 | STEP 4C. Check the fuel inlet pressure sensor signal voltage. | 1.7 to 4.5 VDC?
 | STEP 4D. Check the fuel outlet pressure sensor signal voltage. | 0.5 to 4.5 VDC
 | STEP 4E. Check for a short circuit. | More than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the gas mass flow sensor - A-Bank |
 | STEP 5A. Inspect the gas mass flow sensor and engine harness connector pins on the A-Bank. | Dirty or damaged pins?
 | STEP 5B. Check the gas mass flow sensor supply voltage. | 8.0 to 15.0-VDC?
 | STEP 5C. Check the gas mass flow sensor signal voltage | 0.46 to 4.56 VDC?
 | STEP 5D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the gas mass flow sensor - B-Bank |
 | STEP 6A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Check the sensor supply voltage. | 8 to 15 VDC?
 | STEP 6C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
 | STEP 6D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 6E. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the fuel control valve actuator - A-Bank. |
 | STEP 7A. Check the fuel control valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 7B. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 7C. Check the actuator commanded position percent pulse-width modulated duty cycle signal. | Percent duty cycle 10 - 94 percent?
 | STEP 7D. Check the sensor signal voltage. | 0 to 5 VDC?
 | STEP 7E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 7F. Check for an open circuit. | Less than 10 ohms?
STEP 8. | Check the fuel control valve actuator - B- Bank. |
 | STEP 8A. Check the fuel control valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 8B. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 8C. Check the actuator commanded position percent pulse-width modulation duty cycle signal. | Percent duty cycle 10 - 94 percent?
 | STEP 8D. Check the actuator commanded position feedback signal. | 0 to 5 VDC?
 | STEP 8E. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 8F. Check for an open circuit. | Less than 10 ohms?
STEP 9. | Check the kilowatt load transducer (if installed). |
 | STEP 9A. Check the kilowatt load transducer reference signal. (If the generator set is not equipped with a kilowatt load transducer, then proceed to Guided Step 9B.) | Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
 | STEP 9B. Check the generator set controller calibration. This guided step should only be followed for generator sets not equipped with a kilowatt load transducer. | Generator set controller voltage and ampere output calibration correct?
STEP 10. | Check the quality of the natural gas supply to the generator set. |
 | STEP 10A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for the generaator set?
STEP 11. | Clear the fault codes. |
 | STEP 11A. Verify the fault code is inactive. | Is Fault Code 3595 inactive?
 | STEP 11B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3595 active?

YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference t048 in Section TS.

Go to 11A

Go to 2A

Guided Step 2 - Check the coolant temperature sensor (high temperature circuit).

Guided Step 2A - Inspect the sensor and engine harness connector pins:

Conditions

  • De-energize 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the CM700 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Section 19.5

Go to 2B

Go to 11A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Sectio 19.

Go to 2C

Go to 11A

Guided Step 2C - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the CM700 connector A.

Action

Check for a short circuit to engine ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine harness connector to all other pins in the engine harness connector
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 11A

Guided Step 2D - Check for a open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the CM700 connector A.

Action

Check for an open circuit.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) SIGNAL pin in the CM700 connector A.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) RETURN pin in the CM700 connector A.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 3A

Go to 11A

Guided Step 3 - Check the intake manifold temperature and pressure sensors.

Guided Step 3A - Inspect the intake manifold temperature sensor, pressure sensor, and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the intake manifold temperature sensor harness connector.
  • Disconnect the intake manifold pressure sensor.
  • Disconnect the left-bank CM558 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 11A

Go to 3B

Guided Step 3B - Check the resistance of the intake manifold temperature sensor

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine intake manifold temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor:

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3C

Go to 11A

Guided Step 3C - Check the intake manifold temperature sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s SUPPLY and RETURN test connectors.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Check the intake manifold temperature sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

0.46 to 4.5 VDC?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor:

  • Refer to Procedure 019-061 in Section 19.

Go to 3E

Go to 11A

Guided Step 3E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left-bank CM558 connector A.

Action

Check for a short circuit to engine block ground:

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 11A

Guided Step 3F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left-bank CM558 connector A.

Action

Check the intake manifold temperature and pressure sensor circuits for an open circuit:

  • Measure the resistance from the intake manifold temperature sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor SIGNAL pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold temperature sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor RETURN pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SUPPLY pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor RETURN pin in the left-bank CM558 connector A.

Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SIGNAL pin in the left-bank CM558 connector A.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 11A

Guided Step 4 - Check the fuel inlet and fuel outlet pressure sensors.

Guided Step 4A - Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the fuel inlet pressure sensor harness connector.
  • Disconnect the fuel outlet pressure sensor connector.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure temperature sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 4B

Guided Step 4B - Check the fuel inlet and fuel outlet pressure sensors supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

Check the fuel outlet pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4E

Guided Step 4C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

1.7 to 4.5 VDC?
YES NO
No Repair

Repair

Replace the fuel inlet pressure sensor:

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4D

Go to 11A

Guided Step 4D - Check the fuel outlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel outlet pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

0.50 to 4.5 VDC?
YES NO
No Repair

Repair

  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4E

Go to 11A

Guided Step 4E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 11A

Guided Step 4F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel inlet and fuel outlet pressure sensor circuits for an open circuit:

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor RETURN pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure SIGNAL pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SIGNAL pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor RETURN pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SIGNAL pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 11A

Guided Step 5 - Check the gas mass flow sensor - A-Bank

Guided Step 5A - Inspect the gas mass flow sensor and engine harness connector pins on the A-Bank.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-202 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure temperature sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 5B

Guided Step 5B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor SUPPLY and RETURN connector pins in the main engine harness.

8.0 to 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5D

Guided Step 5C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the left-bank CM558 connector B.

0.46 to 4.5 VDC?
YES NO

Repair

Repair

Replace the gas mass flow sensor:

  • Refer to Procedure 019-101 in Section 19.

Go to 5D

Go to 11A

Guided Step 5D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5E

Go to 11A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit:

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the left-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 11A

Guided Step 6 - Check the gas mass flow sensor - A-Bank

Guided Step 6A - Inspect the gas mass flow sensor and engine harness connector pins on the B-Bank.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 6B

Guided Step 6B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor SUPPLY and RETURN connector pins in the main engine harness.

8.0 to 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 6C

Go to 6D

Guided Step 6C - Check the gas mass flow sensor signal voltage

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the right-bank CM558 connector B.

0.46 to 4.5 VDC?
YES NO
No Repair

Repair

  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to 6D

Go to 11A

Guided Step 6D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6E

Go to 11A

Guided Step 6E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit:

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the right-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the right-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the right-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 11A

Guided Step 7 - Check the fuel control valve - A-Bank

Guided Step 7A - Check the fuel control valve for free movement on the A-Bank.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement:

  • Use INSITE™ electronic service tool to perform the "Actuator Diagnostic Test" within the "ECM Diagnostic Tests" option and compare the actuator commanded position and position feedback signals . Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor.
No Repair

Go to 11A

Go to 7C

Guided Step 7C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator terst function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve (FCV) actuator breakout harness connectors. The signal percent duty cycle must be between 10 to 94 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 - 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 7D

Go to 7E

Guided Step 7D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and return (-) breakout harness connectors. The feedback signal must be between 0 to 5 VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5 VDC?
YES NO
No Repair

Repair

Replace the fuel control valve:

  • Use the following procedure in the Troubleshooting and Repair Manual QSV81G and QSV91G CM700, Bulletin 4021315. Refer to Procedure 006-049 in Section 6.

Go to

Go to

Guided Step 7E - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect all sensors that have a shared supply or return with the fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve Commanded position actuator RETURN (-) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position feedback pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7F

Go to 11A

Guided Step 7F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel control valve circuits for an open circuit:

  • Measure the resistance from the fuel control valve position actuator SIGNAL (+) pin in the fuel control valve connector (FCV) to the fuel control valve position actuator SIGNAL (+) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position actuator RETURN (-) pin in the fuel control valve connector to the fuel control valve position actuator RETURN (-) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position feedback pin in the fuel control valve connector to the fuel control valve position feedback pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 8A

Go to 11A

Guided Step 8 - Check the fuel control valve - B-Bank

Guided Step 8A - Check the fuel control valve for free movement on the B-Bank.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement:

  • Use INSITE™ electronic service tool to perform the "Actuator Diagnostic Test" within the "ECM Diagnostic Tests" option and compare the actuator commanded position and position feedback signals. Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

9A and 9B as appropriate

Go to 8B

Guided Step 8B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve( FCV).
  • Disconnect the right-bank CM558 connector B.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 8C

Guided Step 8C - Check the actuator commanded signal percent duty cycle

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator Position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator breakout harness connectors. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve FCV actuator position.

Percent duty cycle 10 - 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 8D

Go to 8E

Guided Step 8D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and return (-) breakout harness connectors. The feedback signal must be between 0 to 5 VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5 VDC?
YES NO
No Repair

Repair

Replace the fuel control valve:

  • Use the following procedure in the Troubleshooting and Repair Manual QSV81G and QSV91G CM700, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 8E

Go to 11A

Guided Step 8E - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect all sensors that have a shared supply or return with the fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN (-) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position feedback pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 8F

Go to 11A

Guided Step 8F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel control valve circuits for an open circuit:

  • Measure the resistance from the fuel control valve position actuator SIGNAL (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL (+) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position actuator RETURN (-) pin in the fuel control valve connector to the fuel control valve position actuator RETURN (-) pin in the right-bank CM558 connector B.
  • Measure the resistance from the fuel control valve position feedback pin in the fuel control valve cFCV) connector to the fuel control valve position feedback pin in the right-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 9A

Go to 11A

Guided Step 9 - Check the kilowatt load transducer, if installed.

Guided Step 9A - Check the kilowatt load transducer reference signal. (If the generator set is not equipped with a kilowatt load transducer, then proceed to Guided Step 9B.)

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Compare kilowatt load transducer sensed kilowatts to generator set controller displayed kilowatts.

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/ load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 10A

Go to 11A

Guided Step 9B - Check the generator set controller calibration. This guided step should only be followed for generator sets not equipped with a kilowatt load transducer.

Conditions

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Check that the generator set controller readings for output voltage and amperes match those at the alternator output terminals.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1-L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

Contact a Cummins® Authorized Repair Location.

Go to 10A

Go to 11A

Guided Step 10 - Check the quality of the natural gas supply to the generator set.

Guided Step 10A - Check the quality of the natural gas supply

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supplied to the generator set meets or exceeds the minimum requirement.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds the minimum requirement for the generator set (methane number and fuel contaminants limits). Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 11A

Go to 11A

Guided Step 11 - Clear the fault codes.

Guided Step 11A - Verify the fault code is inactive

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for more than 1 minute.

Action

Verify fault code status.

  • Use INSITE™ electronic service tool to verify that Fault Code 3594 is inactive.

Fault code 3595 inactive?
YES NO

Repair

Use INSITE™ electronic service tool and an exhaust gas analyzer. Check the exhaust emissions against the specification for the engine, and fine-tune as required. Contact a Cummins® Authorized Repair Location.

Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 018-002 in Section V.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 11B

Go to 1A

Guided Step 11B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify fault code status.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO

Repair

Use INSITE™ electronic service tool and an exhaust gas analyzer to check the exhaust emissions against the specification for the engine and fine-tune as required. Contact a Cummins® Authorized Repair Location.

Refer to Procedure 018-002 in Section V.

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting step

Last Modified: 25-Aug-2014


FAULT CODE 3595 - Single Turbocharger with Integrated Throttle - Engine Emissions Closed Loop Fueling (Limit) - Root Cause Unknown

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 – male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 – female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 2892245 – diagnostic breakout cable kit and Part Number 3824892 – breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3595 active?
STEP 2. | Check the coolant temperature sensor (high temperature coolant circuit). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 625 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the intake manifold temperature and pressure sensor. |
 | STEP 3A. Inspect the intake manifold temperature sensor, pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the intake manifold temperature sensor. | 625 ohms to 36k ohms?
 | STEP 3C. Check the intake manifold temperature sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the intake manifold temperature sensor signal voltage | 0.50 to 4.50-VDC?
 | STEP 3E. Check for a short circuit. | More than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the fuel inlet and fuel outlet pressure sensors. |
 | STEP 4A. Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel inlet and fuel outlet pressure sensors supply voltage. | 4.75 to 5.25-VDC?
 | STEP 4C. Check the fuel inlet pressure sensor signal voltage. | 1.7 to 4.50-VDC?
 | STEP 4D. Check the fuel outlet pressure sensor signal voltage. | 0.5 to 4.5-VDC?
 | STEP 4E. Check for a short circuit. | More than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the gas mass flow sensor – A-Bank |
 | STEP 5A. Inspect the gas mass flow sensor and engine harness connector pins on the A-Bank. | Dirty or damaged pins?
 | STEP 5B. Check the gas mass flow sensor supply voltage. | 8.0 to 15.0-VDC?
 | STEP 5C. Check the gas mass flow sensor signal voltage | 0.50 to 4.50-VDC?
 | STEP 5D. Check for a short circuit. | More than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the gas mass flow sensor - B-Bank |
 | STEP 6A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Check the sensor supply voltage. | Dirty or damaged pins?
 | STEP 6C. Check the sensor signal voltage. | 0.50 to 4.56-VDC?
 | STEP 6D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 7. | Check the fuel control valve (FCV) actuator – A-Bank. |
 | STEP 7A. Check the fuel control valve (FCV) for free movement on the A - Bank. | Commanded position signal and feedback signal within 30 percent?
 | STEP 7B. Inspect the fuel control valve (FCV) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 7C. Check the actuator commanded position percent pulse-width modulated (PWM) duty cycle signal. | Percent duty cycle 10 - 94 percent?
 | STEP 7D. Check the fuel control valve (FCV) feedback signal voltage. | 0 to 5-VDC?
 | STEP 7E. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 7F. Check for an open circuit. | Less than 10 ohms?
STEP 8. | Check the fuel control valve (FCV) actuator – B- Bank. |
 | STEP 8A. Check the fuel control valve (FCV) for free movement on the B-Bank. | Commanded position signal and feedback signal within 30 percent?
 | STEP 8B. Inspect the fuel control valve (FCV) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 8C. Check the actuator commanded position percent pulse-width (PWM) modulated duty cycle signal. | Percent duty cycle 10 – 94 percent?
 | STEP 8D. Check the fuel control valve (FCV) feedback signal voltage | 0 to 5-VDC?
 | STEP 8E. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 8F. Check for an open circuit. | Less than 10 ohms?
STEP 9. | Check the kilowatt load transducer, if fitted. |
 | STEP 9A. Check the kilowatt load transducer reference signal. | Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
 | STEP 9B. Check the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 10. | Check the quality of the natural gas supply to the generator set. |
 | STEP 10A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 11. | Clear the fault codes. |
 | STEP 11A. Verify the fault code is inactive. | Is Fault Code 3595 inactive?
 | STEP 11B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3595 active?

YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference t048 in Section TS.

Go to 11A

Go to 2A

Guided Step 2 - Check the coolant temperature sensor (high temperature circuit).

Guided Step 2A - Inspect the sensor and engine harness connector pins:

Conditions

  • De-energize the keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the CM700 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Section 19.5

Go to 2B

Go to 11A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor (high temperature):

  • Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 11A

Guided Step 2C - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the CM700 connector A.

Action

Check for a short circuit to engine ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 11A

Guided Step 2D - Check for a open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the CM700 connector A.

Action

Check for an open circuit.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) SIGNAL pin in the CM700 connector A.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) RETURN pin in the CM700 connector A.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 11A

Guided Step 3 - Check the intake manifold temperature and pressure sensors.

Guided Step 3A - Inspect the intake manifold temperature sensor, pressure sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the intake manifold temperature sensor harness connector.
  • Disconnect the intake manifold pressure sensor.
  • Disconnect the left-bank CM558 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.9
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 11A

Go to 3B

Guided Step 3B - Check the resistance of the intake manifold temperature sensor

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine intake manifold temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor:

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3C

Go to 11A

Guided Step 3C - Check the intake manifold temperature sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Check the intake manifold temperature sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

0.46 to 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3E

Go to 11A

Guided Step 3E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left-bank CM558 connector A.

Action

Check for a short circuit to engine block ground:

  • Measure the resistance from the SUPPLY pin of the intake manifold temperature sensor connector to the engine block ground.
  • Measure the resistance from the SIGNAL pin of the intake manifold temperature sensor connector to the engine block ground.

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 11A

Guided Step 3F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left-bank CM558 connector A.

Action

Check the intake manifold temperature and pressure sensor circuits for an open circuit:

  • Measure the resistance from the intake manifold temperature sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor SIGNAL pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold temperature sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor RETURN pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SUPPLY pin in the left-bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor RETURN pin in the left-bank CM558 connector A.

Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SIGNAL pin in the left-bank CM558 connector A.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 11A

Guided Step 4 - Check the fuel inlet and fuel outlet pressure sensors.

Guided Step 4A - Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the fuel inlet pressure sensor harness connector.
  • Disconnect the fuel outlet pressure sensor connector.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the fuel inlet pressure temperature sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 4B

Guided Step 4B - Check the fuel inlet and fuel outlet pressure sensors supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

Check the fuel outlet pressure sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the breakout cable’s supply and return test connectors.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 4C

Go to 4E

Guided Step 4C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

1.7 to 4.50-VDC?
YES NO
No Repair

Repair

Replace the fuel inlet pressure sensor:

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4D

Go to 11A

Guided Step 4D - Check the fuel outlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the breakout cable’s signal and return test connectors.

0.50 to 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4E

Go to 11A

Guided Step 4E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 11A

Guided Step 4F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel inlet and fuel outlet pressure sensor circuits for an open circuit:

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor RETURN pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure SIGNAL return pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SIGNAL pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor RETURN pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SIGNAL pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 11A

Guided Step 5 - Check the gas mass flow sensor – A-Bank

Guided Step 5A - Inspect the gas mass flow sensor and engine harness connector pins on the A-Bank.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure temperature sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 5B

Guided Step 5B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor SUPPLY and RETURN connector pins in the main engine harness.

8.0 to 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5D

Guided Step 5C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the left-bank CM558 connector B.

0.46 to 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to 5D

Go to 11A

Guided Step 5D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5E

Go to 11A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit:

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the left-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the left-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 11A

Guided Step 6 - Check the gas mass flow sensor – B-Bank (Note: QSV91G Single Turbocharger Low BTU Fueled Engines Only – All Other QSV91G Single Turbocharger Engines Proceed to Step 7A.)

Guided Step 6A - Inspect the gas mass flow sensor and engine harness connector pins on the B-Bank.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the right-bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 6B

Guided Step 6B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage:

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor SUPPLY and RETURN connector pins in the main engine harness.

8.0 to 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 6C

Go to 6D

Guided Step 6C - Check the gas mass flow sensor signal voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the right-bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage:

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the right-bank CM558 connector B.

0.46 to 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to 6D

Go to 11A

Guided Step 6D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6E

Go to 11A

Guided Step 6E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit:

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the right-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the right-bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the right-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 11A

Guided Step 7 - Check the fuel control valve (FCV) - A-Bank

Guided Step 7A - Check the fuel control valve (FCV) for free movement on the A-Bank.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve (FCV) for free movement:

  • Use INSITE™ electronic service tool to perform the "Actuator Diagnostic Test" within the "ECM Diagnostic Tests" option and compare the actuator commanded position and position feedback signals. Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7B

Guided Step 7B - Inspect the fuel control valve (FCV) and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve (FCV).
  • Disconnect the left-bank CM558 connector B.

Action

Inspect the fuel control valve (FCV) and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 7C

Guided Step 7C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator to function within INSITE™ electronic service tool to drive the fuel control valve (FCV) to a position between 0 and 100 percenr.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve (FCV) actuator position SIGNAL (+) and RETURN (–) pins at the fuel control valve (FCV) actuator breakout harness connectors. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve (FCV) actuator position.

Percent duty cycle 10 – 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 7D

Go to 7E

Guided Step 7D - Check the fuel control valve (FCV) feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve (FCV) feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve (FCV) to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve (FCV) actuator position feedback and return (–) breakout harness connectors. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the fuel control valve (FCV):

  • Use the following procedure in the Troubleshooting and Repair Manual QSV81G and QSV91G CM700, Bulletin 4021315. Refer to Procedure 006-049 in Section 6.

Go to 7E

Go to 11A

Guided Step 7E - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve (FCV).
  • Disconnect all sensors that have a shared supply or return with the fuel control valve (FCV).
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel control valve (FCV) commanded position actuator SIGNAL (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve (FCV) commanded position actuator RETURN (–) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve (FCV) position feedback pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7F

Go to 11A

Guided Step 7F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve (FCV).
  • Disconnect the engine harness from the left-bank CM558 connector B.

Action

Check the fuel control valve (FCV) circuits for an open circuit:

  • Measure the resistance from the fuel control valve (FCV) position actuator SIGNAL (+) pin in the fuel control valve (FCV) connector to the fuel control valve (FCV) position actuator SIGNAL (+) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve (FCV) position actuator RETURN (–) pin in the fuel control valve (FCV) connector to the fuel control valve (FCV) position actuator RETURN (–) pin in the left-bank CM558 connector B.
  • Measure the resistance from the fuel control valve (FCV) position feedback pin in the fuel control valve (FCV) connector to the fuel control valve (FCV) position feedback pin in the left-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 8A

Go to 11A

Guided Step 8 - Check the fuel control valve (FCV) - B-Bank (Note: QSV91G single turbocharger low BTU fueled engines only – all other QSV91G single turbocharger engines proceed to Step 9A)

Guided Step 8A - Check the fuel control valve (FCV) for free movement on the B-Bank.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve (FCV) for free movement:

  • Use INSITE™ electronic service tool to perform the "Actuator Diagnostic Test" within the "ECM Diagnostic Tests"option and compare the actuator commanded position and position feedback signals. Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

9A and 9B as appropriate

Go to 8B

Guided Step 8B - Inspect the fuel control valve (FCV) and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve (FCV).
  • Disconnect the right-bank CM558 connector B.

Action

Inspect the fuel control valve (FCV) and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 11A

Go to 8C

Guided Step 8C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve (FCV) to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve (FCV) actuator position SIGNAL (+) and RETURN (–) pins at the fuel control valve (FCV) actuator breakout harness connectors. The signal percent duty cycle must be between 10 and 94 percent, based on the fuel control valve (FCV) actuator position.

Percent duty cycle 10 – 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 8D

Go to 8E

Guided Step 8D - Check the fuel control valve (FCV) feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve (FCV) feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve (FCV) to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve (FCV) actuator position feedback and return (–) breakout harness connectors. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the fuel control valve (FCV):

  • User the following procedure in the Troubleshooting and Repair Manual QSV81G and QSV91G CM700, Bulletin 4021314. Refer to Procedure 006-049 in Section 6.

Go to 8E

Go to 11A

Guided Step 8E - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve (FCV).
  • Disconnect all sensors that have a shared supply or return with the fuel control valve (FCV).
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel control valve (FCV) commanded position actuator SIGNAL (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve (FCV) commanded position actuator RETURN (–) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve (FCV) position feedback pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 8F

Go to 11A

Guided Step 8F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve (FCV).
  • Disconnect the engine harness from the right-bank CM558 connector B.

Action

Check the fuel control valve (FCV) circuits for an open circuit:

  • Measure the resistance from the fuel control valve (FCV) position actuator SIGNAL (+) pin in the fuel control valve (FCV) connector to the fuel control valve (FCV) position actuator SIGNAL (+) pin in the right-bank CM558 connector B.
  • Measure the resistance from the fuel control valve (FCV) position actuator RETURN (–) pin in the fuel control valve (FCV) connector to the fuel control valve (FCV) position actuator RETURN (–) pin in the right-bank CM558 connector B.
  • Measure the resistance from the fuel control valve (FCV) position feedback pin in the fuel control valve (FCV)) connector to the fuel control valve (FCV) position feedback pin in the right-bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 9A

Go to 11A

Guided Step 9 - Check the kilowatt load transducer, if fitted. (Note: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 9B.)

Guided Step 9A - Check the kilowatt load transducer reference signal. (NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 9B.)

Conditions

  • Energize keyswitch circuit.
  • Connect all components.
  • Place run/stop/auto switch in the RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a local Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a local Cummins® Authorized Repair Location.

Go to 10A

Go to 11A

Guided Step 9B - Check the generator set controller calibration. (NOTE: This guided step should only be followed for generator sets not fitted with a kilowatt load transducer.)

Conditions

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1-L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 10A

Go to 11A

Guided Step 10 - Check the quality of the natural gas supply to the generator set.

Guided Step 10A - Check the quality of the natural gas supply

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

  • Check if the quality of the natural gas supplied to the generator set meets or exceeds the minimum requirement for the generator set (methane number and fuel contaminants limits). Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 11A

Go to 11A

Guided Step 11 - Clear the fault codes.

Guided Step 11A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify fault code status.

  • Use INSITE™ electronic service tool to verify that Fault Code 3594 is inactive.

Fault Code 3595 inactive?
YES NO

Repair

Use INSITE™ electronic service tool and an exhaust gas analyzer. Check the exhaust emissions against the specification for the engine and fine-tune as required. Contact a Cummins® Authorized Repair Location.

Refer to Procedure 018-002 in Section V.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 11B

Go to 1A

Guided Step 11B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify fault code status.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO

Repair

Use INSITE™ electronic service tool to clear the inactive fault codes.

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 03-Apr-2012


FAULT CODE 3869 - Low Voltage Ride Through – Bad Intelligent Device or Component

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault code 3869 active or high inactive counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 3869 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for more than one minute.
  • Connect INSITE™ electronic service tool.

Action

Verify active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault code 3869 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps in the Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for more than one minute.
  • Connect INSITE™ electronic service tool.

Action

Verify an inactive fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 3869 is inactive.

Fault code 3869 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Go to 1A

Last Modified: 23-Feb-2012


FAULT CODE 3871 - Low Voltage Ride Through - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3871 and/or 426, 427, 781, and 3872 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3871 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3871 and/or 426, 427, 781, and 3872 active or high inactive counts?
YES NO

Repair

Proceed to next troubleshooting step.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference the Cummins Power Generation® generator set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the generator interface box. Reference the Cummins Power Generation® generator interface panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3871 is inactive.

Fault Code 3871 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 3871 inactive?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 31-Jan-2012


FAULT CODE 3872 - Low Voltage Ride Through - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3872 and/or 426, 427, 781, 3871, 3873, 3874, or 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3872 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3872 and/or 426, 427, 781, 3871, 3873, 3874 or 3875 active or high inactive counts?
YES NO

Repair

Proceed to next troubleshooting step.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference the Cummins Power Generation® generator set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the generator interface box. Reference the Cummins Power Generation® generator interface panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3872 is inactive.

Fault Code 3872 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 3872 inactive?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 30-Jan-2012


FAULT CODE 3873 - Low Voltage Ride Through - Abnormal Frequency, Pulse Width or Period

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3873 and/or 426, 427, 781, 3871, 3872, 3874, or 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3873 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3873 and/or 426, 427, 781, 3871, 3872, 3874, or 3875 active or high inactive counts?
YES NO

Repair

Proceed to next troubleshooting step.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference the Cummins Power Generation® generator set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the generator interface box. Reference the Cummins Power Generation® generator interface panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3873 is inactive.

Fault Code 3873 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 3873 inactive?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 31-Jan-2012


FAULT CODE 3874 - Low Voltage Ride Through - Root Cause Not Known

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3874 and/or 426, 427, 781, 3871, 3872, 3873, or 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3874 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3874 and/or 426, 427, 781, 3871, 3872, 3873, or 3875 active or high inactive counts?
YES NO

Repair

Proceed to next troubleshooting step.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference the Cummins Power Generation® generator set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the generator interface box. Reference the Cummins Power Generation® generator interface panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3874 is inactive.

Fault Code 3874 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 3874 inactive?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 30-Jan-2012


FAULT CODE 3875 - Low Voltage Ride Through - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3875 active or high inactive counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 3875 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3875 active or high inactive counts?
YES NO

Repair

Proceed to next troubleshooting step.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3875 is inactive.

Fault Code 3875 inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual, Bulletin 0900-0670.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 3875 inactive?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 31-Jan-2012


INDEX
55-fc111.htm

55-t05-111.htm

55-fc121.htm

55-t05-121.htm

55-fc135.htm

55-t05-135.htm

55-fc136.htm

55-t05-136.htm

55-fc137.htm

55-t05-137.htm

55-fc141.htm

55-t05-141.htm

55-fc142.htm

55-t05-142.htm

55-fc143.htm

55-t05-143.htm

55-fc144.htm

55-t05-144.htm

55-fc145.htm

55-t05-145.htm

55-fc146.htm

55-t05-146.htm

55-fc151.htm

55-t05-151.htm

55-fc153.htm

55-t05-153.htm

55-fc154.htm

55-t05-154.htm

55-fc155.htm

55-t05-155.htm

55-fc175.htm

55-t05-175.htm

55-fc176.htm

55-t05-176.htm

55-fc187.htm

55-fc187st.htm

55-t05-187st.htm

55-fc187mttt.htm

55-t05-187mttt.htm

55-fc187mt.htm

55-t05-187mt.htm

55-fc212.htm

55-t05-212.htm

55-fc213.htm

55-t05-213.htm

55-fc214.htm

55-t05-214.htm

55-fc215.htm

55-t05-215.htm

55-fc227.htm

55-fc227st.htm

55-t05-227st.htm

55-fc227mttt.htm

55-t05-227mttt.htm

55-fc227mt.htm

55-t05-227mt.htm

55-fc228.htm

55-t05-228.htm

55-fc231.htm

55-t05-231.htm

55-fc232.htm

55-t05-232.htm

55-fc233.htm

55-t05-233.htm

55-fc234.htm

55-t05-234.htm

55-fc238.htm

55-t05-238.htm

55-fc239.htm

55-t05-239.htm

55-fc254.htm

55-fc254st.htm

55-t05-254st.htm

55-fc254mttt.htm

55-t05-254mttt.htm

55-fc254mt.htm

55-t05-254mt.htm

55-fc255.htm

55-fc255st.htm

55-t05-255st.htm

55-fc255mttt.htm

55-t05-255mttt.htm

55-fc255mt.htm

55-t05-255mt.htm

55-fc261.htm

55-t05-261.htm

55-fc263.htm

55-t05-263.htm

55-fc265.htm

55-t05-265.htm

55-fc277.htm

55-fc277st.htm

55-t05-277st.htm

55-fc277mt.htm

55-t05-277mt.htm

55-fc346.htm

55-t05-346.htm

55-fc352.htm

55-t05-352.htm

55-fc354.htm

55-t05-354.htm

55-fc355.htm

55-t05-355.htm

55-fc359.htm

55-t05-359.htm

55-fc386.htm

55-t05-386.htm

55-fc412.htm

55-t05-412.htm

55-fc414.htm

55-t05-414.htm

55-fc415.htm

55-t05-415.htm

55-fc421.htm

55-t05-421.htm

55-fc426.htm

55-t05-426.htm

55-fc427.htm

55-t05-427.htm

55-fc441.htm

55-fc441st.htm

55-t05-441st.htm

55-fc441mttt.htm

55-t05-441mttt.htm

55-fc441mt.htm

55-t05-441mt.htm

55-fc442.htm

55-fc442st.htm

55-t05-442st.htm

55-fc442mttt.htm

55-t05-442mttt.htm

55-fc442mt.htm

55-t05-442mt.htm

55-fc453.htm

55-t05-453.htm

55-fc454.htm

55-t05-454.htm

55-fc455.htm

55-fc455st.htm

55-t05-455st.htm

55-fc455mttt.htm

55-t05-455mttt.htm

55-fc455mt.htm

55-t05-455mt.htm

55-fc458.htm

55-fc458st.htm

55-t05-458st.htm

55-fc458mttt.htm

55-t05-458mttt.htm

55-fc458mt.htm

55-t05-458mt.htm

55-fc459.htm

55-fc459st.htm

55-t05-459st.htm

55-fc459mttt.htm

55-t05-459mttt.htm

55-fc459mt.htm

55-t05-459mt.htm

55-fc461.htm

55-fc461st.htm

55-t05-461st.htm

55-fc461mttt.htm

55-t05-461mttt.htm

55-fc461mt.htm

55-t05-461mt.htm

55-fc462.htm

55-fc462st.htm

55-t05-462st.htm

55-fc462mttt.htm

55-t05-462mttt.htm

55-fc462mt.htm

55-t05-462mt.htm

55-fc477.htm

55-t05-477.htm

55-fc478.htm

55-t05-478.htm

55-fc481.htm

55-t05-481.htm

55-fc482.htm

55-t05-482.htm

55-fc488.htm

55-t05-488.htm

55-fc511.htm

55-fc511st.htm

55-t05-511st.htm

55-fc511mttt.htm

55-t05-511mttt.htm

55-fc511mt.htm

55-t05-511mt.htm

55-fc512.htm

55-fc512st.htm

55-t05-512st.htm

55-fc512mttt.htm

55-t05-512mttt.htm

55-fc512mt.htm

55-t05-512mt.htm

55-fc513.htm

55-fc513st.htm

55-t05-513st.htm

55-fc513mttt.htm

55-t05-513mttt.htm

55-fc513mt.htm

55-t05-513mt.htm

55-fc514.htm

55-fc514st.htm

55-t05-514st.htm

55-fc514mttt.htm

55-t05-514mttt.htm

55-fc514mt.htm

55-t05-514mt.htm

55-fc546.htm

55-t05-546.htm

55-fc547.htm

55-t05-547.htm

55-fc556.htm

55-t05-556.htm

55-fc561.htm

55-t05-561.htm

55-fc562.htm

55-t05-562.htm

55-fc563.htm

55-t05-563.htm

55-fc564.htm

55-t05-564.htm

55-fc565.htm

55-t05-565.htm

55-fc566.htm

55-t05-566.htm

55-fc567.htm

55-t05-567.htm

55-fc568.htm

55-t05-568.htm

55-fc569.htm

55-t05-569.htm

55-fc591.htm

55-t05-591.htm

55-fc592.htm

55-t05-592.htm

55-fc619.htm

55-t05-619.htm

55-fc641.htm

55-t05-641.htm

55-fc642.htm

55-t05-642.htm

55-fc643.htm

55-t05-643.htm

55-fc644.htm

55-t05-644.htm

55-fc645.htm

55-t05-645.htm

55-fc646.htm

55-t05-646.htm

55-fc647.htm

55-t05-647.htm

55-fc648.htm

55-t05-648.htm

55-fc651.htm

55-t05-651.htm

55-fc652.htm

55-t05-652.htm

55-fc653.htm

55-t05-653.htm

55-fc654.htm

55-t05-654.htm

55-fc655.htm

55-t05-655.htm

55-fc656.htm

55-t05-656.htm

55-fc657.htm

55-t05-657.htm

55-fc658.htm

55-t05-658.htm

55-fc671.htm

55-t05-671.htm

55-fc672.htm

55-t05-672.htm

55-fc673.htm

55-t05-673.htm

55-fc674.htm

55-t05-674.htm

55-fc675.htm

55-t05-675.htm

55-fc676.htm

55-t05-676.htm

55-fc677.htm

55-t05-677.htm

55-fc678.htm

55-t05-678.htm

55-fc697.htm

55-t05-697.htm

55-fc698.htm

55-t05-698.htm

55-fc719.htm

55-t05-719.htm

55-fc721.htm

55-t05-721.htm

55-fc722.htm

55-t05-722.htm

55-fc723.htm

55-t05-723.htm

55-fc724.htm

55-t05-724.htm

55-fc725.htm

55-t05-725.htm

55-fc726.htm

55-t05-726.htm

55-fc727.htm

55-t05-727.htm

55-fc728.htm

55-t05-728.htm

55-fc729.htm

55-t05-729.htm

55-fc751.htm

55-t05-751.htm

55-fc753.htm

55-t05-753.htm

55-fc783.htm

55-t05-783.htm

55-fc1213.htm

55-t05-1213.htm

55-fc1271.htm

55-t05-1271.htm

55-fc1362.htm

55-t05-1362.htm

55-fc1448.htm

55-t05-1448.htm

55-fc1457.htm

55-fc1457st.htm

55-t05-1457st.htm

55-fc1457mttt.htm

55-t05-1457mttt.htm

55-fc1457mt.htm

55-t05-1457mt.htm

55-fc1459.htm

55-t05-1459.htm

55-fc1474.htm

55-t05-1474.htm

55-fc1482.htm

55-t05-1482.htm

55-fc1484.htm

55-t05-1484.htm

55-fc1521.htm

55-t05-1521.htm

55-fc1522.htm

55-t05-1522.htm

55-fc1523.htm

55-t05-1523.htm

55-fc1524.htm

55-t05-1524.htm

55-fc1525.htm

55-t05-1525.htm

55-fc1526.htm

55-t05-1526.htm

55-fc1527.htm

55-t05-1527.htm

55-fc1528.htm

55-t05-1528.htm

55-fc1529.htm

55-t05-1529.htm

55-fc1531.htm

55-t05-1531.htm

55-fc1532.htm

55-t05-1532.htm

55-fc1533.htm

55-t05-1533.htm

55-fc1534.htm

55-t05-1534.htm

55-fc1535.htm

55-t05-1535.htm

55-fc1536.htm

55-t05-1536.htm

55-fc1537.htm

55-t05-1537.htm

55-fc1545.htm

55-t05-1545.htm

55-fc1546.htm

55-t05-1546.htm

55-fc1618.htm

55-t05-1618.htm

55-fc1619.htm

55-t05-1619.htm

55-fc1737.htm

55-t05-1737.htm

55-fc1739.htm

55-t05-1739.htm

55-fc1745.htm

55-t05-1745.htm

55-fc1747.htm

55-t05-1747.htm

55-fc1749.htm

55-t05-1749.htm

55-fc1791.htm

55-t05-1791.htm

55-fc1794.htm

55-t05-1794.htm

55-fc1837.htm

55-t05-1837.htm

55-fc2111.htm

55-t05-2111.htm

55-fc2112.htm

55-t05-2112.htm

55-fc2113.htm

55-t05-2113.htm

55-fc2114.htm

55-t05-2114.htm

55-fc2115.htm

55-t05-2115.htm

55-fc2116.htm

55-t05-2116.htm

55-fc2117.htm

55-t05-2117.htm

55-fc2121.htm

55-t05-2121.htm

55-fc2122.htm

55-t05-2122.htm

55-fc2123.htm

55-t05-2123.htm

55-fc2124.htm

55-t05-2124.htm

55-fc2125.htm

55-t05-2125.htm

55-fc2126.htm

55-t05-2126.htm

55-fc2127.htm

55-t05-2127.htm

55-fc2128.htm

55-t05-2128.htm

55-fc2129.htm

55-t05-2129.htm

55-fc2131.htm

55-t05-2131.htm

55-fc2132.htm

55-t05-2132.htm

55-fc2133.htm

55-t05-2133.htm

55-fc2134.htm

55-t05-2134.htm

55-fc2135.htm

55-t05-2135.htm

55-fc2136.htm

55-t05-2136.htm

55-fc2137.htm

55-t05-2137.htm

55-fc2138.htm

55-t05-2138.htm

55-fc2139.htm

55-t05-2139.htm

55-fc2144.htm

55-t05-2144.htm

55-fc2145.htm

55-t05-2145.htm

55-fc2146.htm

55-t05-2146.htm

55-fc2147.htm

55-t05-2147.htm

55-fc2154.htm

55-t05-2154.htm

55-fc2155.htm

55-t05-2155.htm

55-fc2191.htm

55-t05-2191.htm

55-fc2199.htm

55-t05-2199.htm

55-fc2228.htm

55-t05-2228.htm

55-fc2279.htm

55-t05-2279.htm

55-fc2282.htm

55-t05-2282.htm

55-fc2283.htm

55-t05-2283.htm

55-fc2288.htm

55-fc2288st.htm

55-t05-2288st.htm

55-fc2288mt.htm

55-t05-2288mt.htm

55-fc2289.htm

55-fc2289st.htm

55-t05-2289st.htm

55-fc2289mt.htm

55-t05-2289mt.htm

55-fc2311.htm

55-fc2311st.htm

55-t05-2311st.htm

55-fc2311mt.htm

55-t05-2311mt.htm

55-fc2313.htm

55-fc2313st.htm

55-t05-2313st.htm

55-fc2313mt.htm

55-t05-2313mt.htm

55-fc2361.htm

55-fc2361st.htm

55-t05-2361st.htm

55-fc2361mt.htm

55-t05-2361mt.htm

55-fc2364.htm

55-fc2364st.htm

55-t05-2364st.htm

55-fc2364mt.htm

55-t05-2364mt.htm

55-fc2427.htm

55-t05-2427.htm

55-fc2428.htm

55-t05-2428.htm

55-fc2429.htm

55-t05-2429.htm

55-fc2442.htm

55-fc2442st.htm

55-t05-2442st.htm

55-fc2442mttt.htm

55-t05-2442mttt.htm

55-fc2442mt.htm

55-t05-2442mt.htm

55-fc2443.htm

55-fc2443st.htm

55-t05-2443st.htm

55-fc2443mttt.htm

55-t05-2443mttt.htm

55-fc2443mt.htm

55-t05-2443mt.htm

55-fc2444.htm

55-t05-2444.htm

55-fc2453.htm

55-t05-2453.htm

55-fc2454.htm

55-t05-2454.htm

55-fc2455.htm

55-t05-2455.htm

55-fc2458.htm

55-t05-2458.htm

55-fc2459.htm

55-t05-2459.htm

55-fc2461.htm

55-t05-2461.htm

55-fc2462.htm

55-t05-2462.htm

55-fc2463.htm

55-t05-2463.htm

55-fc2464.htm

55-t05-2464.htm

55-fc2465.htm

55-t05-2465.htm

55-fc2466.htm

55-t05-2466.htm

55-fc2467.htm

55-t05-2467.htm

55-fc2469.htm

55-t05-2469.htm

55-fc2471.htm

55-t05-2471.htm

55-fc2472.htm

55-t05-2472.htm

55-fc2473.htm

55-t05-2473.htm

55-fc2475.htm

55-t05-2475.htm

55-fc2476.htm

55-t05-2476.htm

55-fc2477.htm

55-t05-2477.htm

55-fc2478.htm

55-t05-2478.htm

55-fc2479.htm

55-t05-2479.htm

55-fc2482.htm

55-t05-2482.htm

55-fc2483.htm

55-t05-2483.htm

55-fc2484.htm

55-t05-2484.htm

55-fc2485.htm

55-t05-2485.htm

55-fc2486.htm

55-t05-2486.htm

55-fc2487.htm

55-t05-2487.htm

55-fc2488.htm

55-t05-2488.htm

55-fc2489.htm

55-t05-2489.htm

55-fc2491.htm

55-t05-2491.htm

55-fc2492.htm

55-t05-2492.htm

55-fc2493.htm

55-t05-2493.htm

55-fc2494.htm

55-t05-2494.htm

55-fc2495.htm

55-t05-2495.htm

55-fc2496.htm

55-t05-2496.htm

55-fc2497.htm

55-t05-2497.htm

55-fc2498.htm

55-t05-2498.htm

55-fc2499.htm

55-t05-2499.htm

55-fc2511.htm

55-t05-2511.htm

55-fc2512.htm

55-t05-2512.htm

55-fc2513.htm

55-t05-2513.htm

55-fc2517.htm

55-t05-2517.htm

55-fc2518.htm

55-t05-2518.htm

55-fc2519.htm

55-fc2519st.htm

55-t05-2519st.htm

55-fc2519mttt.htm

55-t05-2519mttt.htm

55-fc2519mt.htm

55-t05-2519mt.htm

55-fc2521.htm

55-t05-2521.htm

55-fc2522.htm

55-t05-2522.htm

55-fc2523.htm

55-t05-2523.htm

55-fc2524.htm

55-t05-2524.htm

55-fc2525.htm

55-t05-2525.htm

55-fc2526.htm

55-t05-2526.htm

55-fc2527.htm

55-t05-2527.htm

55-fc2528.htm

55-t05-2528.htm

55-fc2529.htm

55-t05-2529.htm

55-fc2531.htm

55-t05-2531.htm

55-fc2544.htm

55-t05-2544.htm

55-fc2548.htm

55-t05-2548.htm

55-fc2553.htm

55-t05-2553.htm

55-fc2766.htm

55-t05-2766.htm

55-fc2767.htm

55-t05-2767.htm

55-fc2812.htm

55-t05-2812.htm

55-fc2814.htm

55-fc2814st.htm

55-t05-2814st.htm

55-fc2814mt.htm

55-t05-2814mt.htm

55-fc2837.htm

55-t05-2837.htm

55-fc2838.htm

55-t05-2838.htm

55-fc2839.htm

55-t05-2839.htm

55-fc2841.htm

55-t05-2841.htm

55-fc2842.htm

55-t05-2842.htm

55-fc2843.htm

55-t05-2843.htm

55-fc2844.htm

55-t05-2844.htm

55-fc2845.htm

55-t05-2845.htm

55-fc2846.htm

55-t05-2846.htm

55-fc2847.htm

55-t05-2847.htm

55-fc2848.htm

55-t05-2848.htm

55-fc2849.htm

55-t05-2849.htm

55-fc2851.htm

55-t05-2851.htm

55-fc2852.htm

55-t05-2852.htm

55-fc2853.htm

55-t05-2853.htm

55-fc2854.htm

55-t05-2854.htm

55-fc2855.htm

55-t05-2855.htm

55-fc2856.htm

55-t05-2856.htm

55-fc3111.htm

55-t05-3111.htm

55-fc3112.htm

55-t05-3112.htm

55-fc3113.htm

55-t05-3113.htm

55-fc3114.htm

55-t05-3114.htm

55-fc3115.htm

55-t05-3115.htm

55-fc3116.htm

55-t05-3116.htm

55-fc3117.htm

55-t05-3117.htm

55-fc3118.htm

55-t05-3118.htm

55-fc3119.htm

55-t05-3119.htm

55-fc3121.htm

55-t05-3121.htm

55-fc3122.htm

55-t05-3122.htm

55-fc3123.htm

55-t05-3123.htm

55-fc3124.htm

55-t05-3124.htm

55-fc3125.htm

55-t05-3125.htm

55-fc3126.htm

55-t05-3126.htm

55-fc3127.htm

55-t05-3127.htm

55-fc3128.htm

55-t05-3128.htm

55-fc3129.htm

55-t05-3129.htm

55-fc3475.htm

55-fc3475mt.htm

55-t05-3475mt.htm

55-fc3475st.htm

55-t05-3475st.htm

55-fc3476.htm

55-fc3476mt.htm

55-t05-3476mt.htm

55-fc3476st.htm

55-t05-3476st.htm

55-fc3477.htm

55-fc3477mt.htm

55-t05-3477mt.htm

55-fc3477st.htm

55-t05-3477st.htm

55-fc3489.htm

55-t05-3489.htm

55-fc3491.htm

55-t05-3491.htm

55-fc3594.htm

55-fc3594mt.htm

55-t05-3594mt.htm

55-fc3594st.htm

55-t05-3594st.htm

55-fc3595.htm

55-fc3595mt.htm

55-t05-3595mt.htm

55-fc3595st.htm

55-t05-3595st.htm

55-fc3869.htm

55-t05-3869.htm

55-fc3871.htm

55-t05-3871.htm

55-fc3872.htm

55-t05-3872.htm

55-fc3873.htm

55-t05-3873.htm

55-fc3874.htm

55-t05-3874.htm

55-fc3875.htm

55-t05-3875.htm