ISBe (4 and 6 Cylinder)

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Electronic Control Module (ECM) Microprocessor

FAULT CODE 111

Electronic Control Module (ECM) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Red SRT: | ECM internal hardware error. | Possible no effect or engine will possibly run rough or not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the left side of the engine block.

Shop Talk

This fault code can be caused only by an internal ECM problem. Field repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 26-Oct-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Injector Cylinder Number 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1139

Injector Cylinder Number 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1139 PID: S001 SPN: 651 FMI: 7 LAMP: Amber SRT: | Injector Cylinder Number 1 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder Number 1. | Possible misfire and excessive exhaust smoke. Eventual power and speed derate. Engine will shutdown if the Engine Protection Shutdown Feature is enabled (EPA/CARB Calibrations only).
Fuel Injector Circuit

Circuit Description

The Electronic Control Module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use Section E for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and notstart. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a failed injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1139

Last Modified: 26-Oct-2010


Injector Cylinder Number 2 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1141

Injector Cylinder Number 2 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1141 PID: S002 SPN: 652 FMI: 7 LAMP: Amber SRT: | Injector Cylinder Number 2 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder Number 2. | Possible misfire and excessive exhaust smoke. Eventual power and speed derate. Engine will shutdown if the Engine Protection Shutdown Feature is enabled (EPA/CARB Calibrations only).
Fuel Injector Circuit

Circuit Description

The Electrical Control Module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use Section E for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a failed injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1141

Last Modified: 26-Oct-2010


Injector Cylinder Number 3 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1142

Injector Cylinder Number 3 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1142 PID: S003 SPN: 653 FMI: 7 LAMP: Amber SRT: | Injector Cylinder Number 3 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder Number 3. | Possible misfire and excessive exhaust smoke. Eventual power and speed derate. Engine will shutdown if the Engine Protection Shutdown Feature is enabled (EPA/CARB Calibrations only).
Fuel Injector Circuit

Circuit Description

The Electronic Control Module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use Section E for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a failed injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1142

Last Modified: 26-Oct-2010


Injector Cylinder Number 4 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1143

Injector Cylinder Number 4 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1143 PID: S004 SPN: 654 FMI: 7 LAMP: Amber SRT: | Injector Cylinder Number 4 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder Number 4. | Possible misfire and excessive exhaust smoke. Eventual power and speed derate. Engine will shutdown if the Engine Protection Shutdown Feature is enabled (EPA/CARB Calibrations only).
Fuel Injector Circuit

Circuit Description

The Electronic Control Module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use Section E for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a failed injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1143

Last Modified: 26-Oct-2010


Injector Cylinder Number 5 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1144

Injector Cylinder Number 5 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1144 PID: S005 SPN: 655 FMI: 7 LAMP: Amber SRT: | Injector Cylinder Number 5 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder Number 5. | Possible misfire and excessive exhaust smoke. Eventual power and speed derate. Engine will shutdown if the Engine Protection Shutdown Feature is enabled (EPA/CARB Calibrations only).
Fuel Injector Circuit

Circuit Description

The Electronic Control Module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use Section E for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a failed injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1144

Last Modified: 26-Oct-2010


Injector Cylinder Number 6 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1145

Injector Cylinder Number 6 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1145 PID: S006 SPN: 656 FMI: 7 LAMP: Amber SRT: | Injector Cylinder Number 6 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder Number 6. | Possible misfire and excessive exhaust smoke. Eventual power and speed derate. Engine will shutdown if the Engine Protection Shutdown Feature is enabled (EPA/CARB Calibrations only).
Fuel Injector Circuit

Circuit Description

The Electronic Control Module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Use Section E for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a failed injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1145

Last Modified: 26-Oct-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the intake manifold pressure sensor signal pin. | Engine may derate to no-boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure/temperature sensor is located on the intake air manifold.

Shop Talk

  • Determine if engine is being fueled from an alternate fuel source.
  • Confirm that the correct intake manifold pressure/temperature sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air.
  • Inspect the intake manifold pressure/temperature sensor circuit for signs of tampering. Remove any extra wires from the circuit.
  • If Fault Codes 122 and 386 are active, then begin troubleshooting Fault Code 386 first.
Refer to Troubleshooting Fault Code t05-122

Last Modified: 26-Oct-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the intake manifold pressure signal pin. | Engine may derate to no-boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure/temperature sensor is located on the intake air manifold.

Shop Talk

  • Determine if engine is being fueled from an alternate fuel source.
  • Confirm that the correct intake manifold pressure/temperature sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air.
  • Inspect the intake manifold pressure/temperature sensor circuit for signs of tampering. Remove any extra wires from the circuit.
  • If Fault Code 123 and 352 are active, then begin troubleshooting Fault Code 352 first.
Refer to Troubleshooting Fault Code t05-123

Last Modified: 26-Oct-2010


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. See equipment manufacturer service information.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1239.

Last Modified: 12-Jun-2015


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: None SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2. When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. See equipment manufacturer service information.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the original equipment manufacturer harness or sensor
  • Malfunctioning accelerator pedal position sensor
  • Open circuit in the accelerator SIGNAL, SUPPLY, or RETURN wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code 1241.

Last Modified: 12-Jun-2015


Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: SPN: 091 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensors 1 and 2 are reading different values. | The engine will only idle.
Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position number 1 is twice as much as the signal voltage from accelerator position number 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. See equipment manufacturer service information.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.

Possible causes of the fault code include:

  • Damaged accelerator pedal position sensor 1 or damaged accelerator pedal position sensor 2
  • Accelerator pedal position sensor 1 or accelerator pedal position sensor 2 SIGNAL wires are shorted.
Refer to Troubleshooting Fault Code 1242.

Last Modified: 12-Jun-2015


Accelerator Position Sensor Circuit

FAULT CODE 131

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3 LAMP: Red SRT: | High voltage detected at accelerator position signal pin. | Engine idles when idle validation switch indicates idle and ramps up to a default speed when the idle validation switch indicates off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: Signal wire (pin 83), a +5-VDC supply wire (pin 55), and a return ground (pin 81).

Note: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensor checks look in good order, then replace the accelerator position sensor and the idle validation switch circuit wires between the accelerator pedal and the ECM with new wires. Run the wires through, or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from entering the operator area.

Note: The three wires in the accelerator position sensor circuit must be twisted together. The same applies for the three wires in the idle validation switch (IVS) circuit.

Note: If pin 83 (signal) and pin 81 (return) are reversed, accelerator position will only read 50 percent.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 26-Oct-2010


Accelerator Position Sensor Circuit

FAULT CODE 132

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4 LAMP: Red SRT: | Low voltage detected at accelerator position signal pin. | Engine idles when idle validation switch indicates idle and ramps up to a default speed when the idle validation switch indicates off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: Signal wire (pin 83), a +5-VDC supply wire (pin 55), and a return ground (pin 81).

Note: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensor checks look in good order, then replace the accelerator position sensor and the idle validation switch circuit wires between the accelerator pedal and the ECM with new wires. Run the wires through, or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from entering the operator area.

Note: The three wires in the accelerator position sensor circuit must be twisted together. The same applies for the three wires in the idle validation switch circuit.

Note: If pin 83 (signal) and pin 81 (return) are reversed, accelerator position will only read 50 percent.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 26-Oct-2010


Remote Accelerator Position - High

FAULT CODE 133

Remote Accelerator Position - High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 974 FMI: 3 LAMP: Red SRT: | High voltage detected at remote accelerator position signal pin. | Engine can possibly not respond to remote accelerator input.
Remote Accelerator Position Sensor Circuit

Circuit Description

The remote accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal location varies with each OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The accelerator position sensor is a potentiometer. The accelerator position sensor resistance specifications are:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, depressed = 200 to 1500 ohms.

The remote accelerator enable switch must be turned on for the remote accelerator to operate. Possible causes of this fault code include an open circuit in the return wire, short circuit to +5 VDC or +12 VDC, defective remote accelerator position sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-133

Last Modified: 26-Oct-2010


Remote Accelerator Position - Low

FAULT CODE 134

Remote Accelerator Position - Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 974 FMI: 4 LAMP: Red SRT: | Low voltage detected at remote accelerator position signal pin. | Engine can possibly not respond to remote accelerator input.
Remote Accelerator Position Sensor Circuit

Circuit Description

The remote accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal location varies with each OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The accelerator position sensor is a potentiometer. The accelerator position sensor resistance specifications are:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, depressed = 200 to 1500 ohms.

The remote accelerator enable switch must be turned on for the remote accelerator to operate. Possible causes of this fault code include an open circuit in the return wire, short circuit to +5 VDC or +12 VDC, defective remote accelerator position sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-134

Last Modified: 26-Oct-2010


Oil Pressure Sensor Circuit

FAULT CODE 135

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Yellow SRT: | High voltage detected at oil pressure signal pin. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located on the engine block, below the exhaust manifold, and near the oil filter housing.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure signal voltage going into the ECM.
  • Confirm that the correct oil pressure/temperature sensor part number is being used.
  • If Fault Codes 239 and 135 are active, then begin troubleshooting Fault Code 239 first.
Refer to Troubleshooting Fault Code t05-135

Last Modified: 26-Oct-2010


Fault Code Path Selection

FAULT CODE 141
Fault Code Path Selection

Do you have an Oil Pressure Sensor? | Go to 86-fc141sn
Do you have an Oil Pressure Switch? | Go to 86-fc141sw

Last Modified: 21-Sep-2005


Engine Control Module (ECM) Shutdown

FAULT CODE 1417

Engine Control Module (ECM) Shutdown

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1417 PID: S254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | Engine Control Module (ECM) Shutdown. Module will not shut down at key-off. | The ECM will cause battery drain if the engine has not operated for an extended period of time.
Engine Control Module (ECM) Shutdown

Circuit Description

The ECM requires direct battery supply voltage through the unswitched power supply and it also monitors the keyswitch power input. The ECM will begin its shutdown process when the keyswitch input is turned to the OFF position.

Component Location

The ECM is located on left side of the engine.

Refer to Troubleshooting Fault Code t05-1417

Last Modified: 25-Jul-2012


Oil Pressure Sensor Circuit

FAULT CODE 141

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at oil pressure signal pin. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located on the engine block, below the exhaust manifold and near the oil filter housing.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure signal voltage going into the ECM.
  • Confirm that the correct oil pressure/temperature sensor part number is being used.
  • If Fault Codes 141 and 238 are active, then begin troubleshooting Fault Code 238 first.
Refer to Troubleshooting Fault Code t05-141sn

Last Modified: 26-Oct-2010


Oil Pressure Switch Circuit

FAULT CODE 141

Oil Pressure Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: | Low voltage detected on pin 9 of the engine harness. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Switch Circuit

Circuit Description

The oil pressure switch is used by the electronic control module (ECM) to monitor the lubricating oil pressure.

Component Location

The oil pressure switch is located on the engine block, below and to the right of the ECM. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • The INSITE™ electronic service tool can be used to monitor the oil pressure signal voltage going into the ECM.
  • If an oil pressure switch is installed, the INSITE™ electronic service tool will read a constant value of 379 kPa [55 psi] ± 2 kPa [±0.3 psi] if the ECM is reading a signal from the oil pressure switch.
  • The switch is a single wire device which requires engine block ground for operation.
  • Engine Protection will activate, if enabled, if the lubricating oil pressure drops below 41 kPa [6 psi] with the engine running.
Refer to Troubleshooting Fault Code t05-141sw

Last Modified: 26-Oct-2010


Fault Code Path Selection

FAULT CODE 143
Fault Code Path Selection

Do you have an Oil Pressure Sensor? | Go to 86-fc143sn
Do you have an Oil Pressure Switch? | Go to 86-fc143sw

Last Modified: 21-Sep-2005


Oil Pressure - Engine Protection

FAULT CODE 143

Oil Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Yellow SRT: | Oil pressure signal indicates oil pressure below the low engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature enabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located on the engine block, below the exhaust manifold, and near the oil filter housing.

Shop Talk

  • Confirm that the oil pressure/temperature sensor supply voltage is between (+) 4.75 and 5.25 VDC at the sensor.
  • Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed under load, the oil pressure can drop below the engine protection limits.
Refer to Troubleshooting Fault Code t05-143sn

Last Modified: 26-Oct-2010


Oil Pressure - Engine Protection with an Oil Pressure Switch

FAULT CODE 143

Oil Pressure - Engine Protection with an Oil Pressure Switch

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1 LAMP: Yellow SRT: | Oil pressure signal indicates oil pressure below the low engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature enabled.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure switch is used by the electronic control module (ECM) to detect the presence of lubricating oil pressure.

Component Location

The oil pressure switch is located on the engine block, below and to the right of the ECM. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

  • Confirm that the oil pressure sensor supply voltage is between (+) 4.5 and 5.25 VDC at the sensor.
  • Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed under load, the oil pressure can drop below the engine protection limits.
  • Connect a manual gauge to monitor the actual oil pressure of the engine.
  • The fault will trigger if lubricating oil pressure drops below 41 kPa [6 psi] for 5 seconds while the engine is running.
Refer to Troubleshooting Fault Code t05-143sw

Last Modified: 26-Oct-2010


Coolant Temperature Sensor Circuit

FAULT CODE 144

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the coolant temperature signal pin. | Default value used for engine coolant temperature. No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the timing and fueling controls.

Component Location

The coolant temperature sensor is located to the front of the thermostat housing.

Shop Talk

The sensor reading will match the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 5k to 7k
25 | 77 | 1700 to 2500
50 | 122 | 700 to 1000
75 | 167 | 300 to 450
100 | 212 | 150 to 220
Refer to Troubleshooting Fault Code t05-144

Last Modified: 26-Oct-2010


Coolant Temperature Sensor Circuit

FAULT CODE 145

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the coolant temperature signal pin. | Default value used for engine coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for timing and fueling controls.

Component Location

The coolant temperature sensor is located to the front of the thermostat housing.

Shop Talk

The sensor reading will match the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 5k to 7k
25 | 77 | 1700 to 2500
50 | 122 | 700 to 1000
75 | 167 | 300 to 450
100 | 212 | 150 to 220
Refer to Troubleshooting Fault Code t05-145

Last Modified: 26-Oct-2010


Coolant Temperature - Engine Protection

FAULT CODE 146

Coolant Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0 LAMP: Yellow SRT: | Coolant temperature signal indicates coolant temperature has exceeded the minimum engine protection limit. | Power derate and possible engine shutdown if engine protection shutdown feature is enabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system and the timing and fueling controls.

Component Location

The coolant temperature sensor is located on top of the thermostat housing.

Shop Talk

Make sure the airflow through the radiator is not obstructed and the engine thermostat is operating correctly.

Refer to Troubleshooting Fault Code t05-146

Last Modified: 26-Oct-2010


Starter Lockout - Driver Pin Error

FAULT CODE 1478

Starter Lockout - Driver Pin Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1478 PID: FMI: 11/31 LAMP: Yellow SRT: | Error detected in starter lockout driver circuit. | Starter lockout feature will not work. The operator can activate the starter while the engine is operating.
Starter Lockout Circuit

Circuit Description

The starter lockout feature, when enabled, will prevent the starter motor from engaging when the engine is already running. This is intended to increase starter motor life. This feature can be enabled with the INSITE™ electronic service tool.

Component Location

The starter lockout relay is supplied by the OEM. It is probably near the starter motor relay.

Shop Talk

The starter lockout signal indicates that the engine is running. It is used to energize a relay that disconnects start voltage to the existing OEM starter relay, preventing the inadvertent engine cranking that could reduce starter motor life. This signal is used by the starter lockout feature when enabled.

Refer to Troubleshooting Fault Code t05-1478

Last Modified: 26-Oct-2010


Coolant Temperature - Engine Protection

FAULT CODE 151

Coolant Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Red SRT: | Engine coolant temperature signal indicates coolant temperature has exceeded the engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located on the top of the thermostat housing.

Shop Talk

Make sure the airflow through the radiator is not obstructed and the engine thermostat is operating correctly.

Refer to Troubleshooting Fault Code t05-151

Last Modified: 26-Oct-2010


Intake Manifold Temperature Sensor Circuit

FAULT CODE 153

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

Intake Manifold Temperature Sensor Circuit

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the intake manifold temperature signal pin. | Default value used for intake manifold temperature. No engine protection for intake manifold temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor is used by the electronic control module (ECM) to monitor the engine intake air temperature. The intake manifold temperature signal is used by the ECM for engine protection system, cold start aid, timing, and fueling control.

Component Location

The intake manifold pressure/temperature sensor is located in the intake air housing.

Shop Talk

If the sensor is functioning properly, compare the reading to the following table.

Sensor Temperature (°C) | Sensor Temperature [°F] | Resistance (ohms)
0 | 32 | 5k to 7k
25 | 77 | 1700 to 2500
50 | 122 | 700 to 1000
75 | 167 | 300 to 450
100 | 212 | 150 to 220
Refer to Troubleshooting Fault Code t05-153

Last Modified: 26-Oct-2010


Intake Manifold Temperature Sensor Circuit

FAULT CODE 154

Intake Manifold Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the intake manifold temperature signal pin. | Default value used for engine intake manifold temperature. No engine protection for intake manifold temperature.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor is used by the electronic control module (ECM) to monitor the engine intake air temperature. The intake manifold temperature signal is used by the ECM for cold start aid, timing, and fueling control.

Component Location

The intake manifold pressure/temperature sensor is located in the intake air housing.

Shop Talk

The sensor reading will match the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 5k to 7k
25 | 77 | 1700 to 2500
50 | 122 | 700 to 1000
75 | 167 | 300 to 450
100 | 212 | 150 to 220
Refer to Troubleshooting Fault Code t05-154

Last Modified: 26-Oct-2010


Intake Manifold Pressure/Temperature Sensor - Engine Protection Circuit

FAULT CODE 155

Intake Manifold Pressure/Temperature Sensor - Engine Protection Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Red SRT: | Intake manifold air temperature signal indicates the intake manifold air temperature is above the engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine intake air. The intake air temperature is used by the ECM for the engine protection system, cold start aids, and timing and fueling controls.

Component Location

The intake manifold pressure/temperature sensor is located in the intake air housing.

Shop Talk

  • Make sure the engine compartment temperature does not get too high (above 93.3°C [200°F]).
  • Make sure the intake manifold temperature sensor is not located near any extreme heat sources.
  • Possible causes:- Clogged, dirty, inadequate capacity air cleaner element - Intake restriction.
Refer to Troubleshooting Fault Code t05-155

Last Modified: 26-Oct-2010


Sensor Supply B - Low Voltage

FAULT CODE 187

Sensor Supply B - Low Voltage

Printable Version Printable Version

Overview

Sensor Supply B - Low Voltage

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4 LAMP: Yellow SRT: | Low voltage detected on the electronic control module (ECM) voltage supply line to fuel rail pressure sensor. | Possible low power.
Sensor Supply B - Low-Voltage Circuit

Circuit Description

The ECM supplies the fuel pressure sensor with +5 VDC. If the supply line to this sensor is damaged, the sensor will not work correctly.

Component Location

The fuel pressure sensor is located on the high-pressure common rail, which is above the intake manifold housing.

Shop Talk

Low voltage on the sensor +5-VDC supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a failed sensor, or a failed ECM power supply. If Fault Codes 187 and 452 are active, begin troubleshooting Fault Code 187 first.

Refer to Troubleshooting Fault Code t05-187

Last Modified: 26-Oct-2010


Engine Coolant Level - Engine Protection

FAULT CODE 197

Engine Coolant Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Yellow SRT: | Engine coolant level signal indicates coolant level has exceeded the engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM).

Component Location

The coolant level sensor is installed by the OEM. Use the OEM manual for sensor location.

Shop Talk

  • When the coolant level drops below a certain level, a power derate will be activated, which will decrease the power output by 50 percent over a 30-second period.
  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the four-way connector and the coolant level sensor for damage.
Refer to Troubleshooting Fault Code t05-197

Last Modified: 26-Oct-2010


Warning Lamp Circuit

FAULT CODE 198

Warning Lamp Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 198 PID: 122 SPN: 1661 FMI: 4 LAMP: Maintenance SRT: | Error detected in warning lamp circuit. Error could be an open circuit or a short circuit to the battery or ground on any lamp circuit. | Warning lamp will not operate correctly.
Warning Lamp Circuit

Circuit Description

The electronic control module (ECM) performs warning tests on most of its circuits and will activate a fault code if a problem is detected in one of the circuits. Certain fault codes will cause a warning lamp (yellow) to activate to signal the driver.

Component Location

The warning lamp is typically located in the truck cab on the dashboard panel.

Shop Talk

This fault typically indicates a short circuit to battery voltage. This fault can not be flashed out on the warning lamp. It can be read using INSITE™ or flashing the diagnostic code on the red lamp.

Refer to Troubleshooting Fault Code t05-198

Last Modified: 26-Oct-2010


Oil Temperature Sensor Circuit

FAULT CODE 212

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3 LAMP: Yellow SRT: | High voltage detected at oil temperature signal pin. | Default value used for oil temperature. No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The oil pressure/temperature sensor is located on the engine block below the exhaust manifold.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • Confirm that the correct oil pressure/temperature sensor part number is being used.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 5k to 7k
25 | 77 | 1700 to 2500
50 | 122 | 700 to 1000
75 | 167 | 300 to 450
100 | 212 | 150 to 220
Refer to Troubleshooting Fault Code t05-212

Last Modified: 26-Oct-2010


Oil Temperature Sensor Circuit

FAULT CODE 213

Oil Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at oil temperature signal pin. | Default value used for oil temperature. No engine protection for oil temperature.
Oil Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine oil. If the oil temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The oil pressure/temperature sensor is located on the engine lubricating oil cooler.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • Confirm that the correct oil pressure sensor part number is being used.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 5k to 7k
25 | 77 | 1700 to 2500
50 | 122 | 700 to 1000
75 | 167 | 300 to 450
100 | 212 | 150 to 220
Refer to Troubleshooting Fault Code t05-213

Last Modified: 26-Oct-2010


Accelerator Supply - High Voltage

FAULT CODE 2185

Accelerator Supply - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 620 FMI: 3 LAMP: Yellow SRT: | Accelerator supply above 5.5 VDC. | Accelerator default value used. Limp home accelerator will be used by electronic control module (ECM).
Accelerator Supply Circuit

Circuit Description

The accelerator pedal provides the driver's accelerator command to the electronic control module (ECM) through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The accelerator pedal location varies with each OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The accelerator position sensor is a potentiometer. The accelerator position sensor resistance specifications are:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, depressed = 200 to 1500 ohms.

Note: If the accelerator or accelerator position sensor is replaced, or after a calibration download is performed, cycle the accelerator pedal (turn keyswitch on) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Possible causes of this fault code include an open circuit in the return wire, short circuit to +5 VDC or +12 VDC, defective accelerator position sensor, or a failed ECM power supply.
Refer to Troubleshooting Fault Code t05-2185

Last Modified: 26-Oct-2010


Accelerator Supply - Low Voltage

FAULT CODE 2186

Accelerator Supply - Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 630 FMI: 4 LAMP: Yellow SRT: | Low voltage detected on the electronic control module (ECM) supply line to the accelerator. | Accelerator default value used. Limp home accelerator will be used by electronic control module (ECM).
Accelerator Supply Circuit

Circuit Description

The accelerator pedal provides the driver's accelerator command to the ECM through the OEM harness and the OEM interface harness. The ECM uses this signal to determine the fueling command.

Component Location

The accelerator pedal location varies with each OEM. Use the OEM troubleshooting and repair manual.

Shop Talk

The accelerator position sensor is a potentiometer. The accelerator position sensor resistance specifications are:

  • Between supply and return = 2000 to 3000 ohms
  • Between supply and signal: Released = 1500 to 3000 ohms, depressed = 200 to 1500 ohms.

NOTE: If the accelerator or accelerator position sensor is replaced, or after a calibration download is performed, cycle the accelerator pedal (turn keyswitch on) through its complete travel three times. This procedure calibrates the new accelerator with the ECM.

  • Low voltage on the accelerator +5 VDC supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and the return line, or a failed ECM power supply.
Refer to Troubleshooting Fault Code t05-2186

Last Modified: 26-Oct-2010


OEM Pressure - Engine Protection - Fueling Derate

FAULT CODE 2194

OEM Pressure - Engine Protection - Fueling Derate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2194 PID: P223 SPN: 1387 FMI: 11 LAMP: Yellow SRT: | OEM pressure signal indicates OEM pressure above or below the low engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
OEM Pressure Sensor Circuit

Circuit Description

The OEM pressure sensor is used by the electronic control module (ECM) to monitor OEM pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The OEM pressure value is used by the ECM for the engine protection system.

Component Location

This sensor is installed by the vehicle's OEM. Use the OEM troubleshooting and repair manual for location.

Shop Talk

Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed under load, the OEM pressure can drop below the engine protection limits.

Refer to Troubleshooting Fault Code t05-2194

Last Modified: 26-Oct-2010


OEM Temperature Sensor - Engine Protection - Fueling Derate Circuit

FAULT CODE 2197

OEM Temperature Sensor - Engine Protection - Fueling Derate Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2197 PID: P441 SPN: 441 FMI: 14 LAMP: None SRT: | OEM temperature out-of-range has been detected. Voltage signal at OEM temperature signal pin indicates OEM temperature is beyond OEM-specified threshold. | Calibration-dependent progressive power derate and engine shutdown with increasing time after alert.
OEM Temperature Sensor Circuit

Circuit Description

The OEM temperature is used by the electronic control module (ECM) to monitor the temperature of an OEM component or engine conditions. The OEM temperature sensor is used by the ECM for a protection system.

Component Location

This sensor is installed by the vehicle's OEM. Use the OEM troubleshooting and repair manual for location.

Shop Talk

Make sure the airflow through the radiator is not obstructed.

Refer to Troubleshooting Fault Code t05-2197

Last Modified: 26-Oct-2010


Ambient Air Pressure Sensor

FAULT CODE 221

Ambient Air Pressure Sensor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3 LAMP: Yellow SRT: | Ambient air pressure sensor (internal to the ECM) has had a failure. | Possible black smoke. Engine protection system can be affected. Altitude derate will not function.
Ambient Air Pressure Sensor Circuit

Circuit Description

The ambient air pressure sensor monitors atmospheric pressure and passes the information to the electronic control module (ECM) through the engine harness.

Component Location

The ambient air pressure sensor is internal to the ECM.

Shop Talk

Monitor the ambient air pressure reading with a service tool to confirm that the pressure reading matches the actual air pressure.

Refer to Troubleshooting Fault Code t05-221

Last Modified: 26-Oct-2010


Fuel Heater Circuit Error

FAULT CODE 2212

Fuel Heater Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2212 PID: S125 SPN: FMI: 4 LAMP: Yellow SRT: | Error detected in the fuel heater circuit. | Fuel heater can be ON or OFF all of the time or is damaged.
Fuel Heater Circuit

Circuit Description

The fuel heater improves starting in cold ambient conditions by heating the fuel to reduce its viscosity.

Component Location

The fuel heater is located on the fuel filter on the intake side of the engine.

Shop Talk

This fault could also indicate the fuel heater circuit is shorted to battery positive (+). This would command the fuel heater to be on full time. This will drain the batteries or burn out the fuel heater.

Refer to Troubleshooting Fault Code t05-2212

Last Modified: 26-Oct-2010


Fuel Rail Pressure Positive Deviation Error

FAULT CODE 2215

Fuel Rail Pressure Positive Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: P094 SPN: 94 FMI: 1/18 LAMP: Amber SRT: | Low fuel delivery pressure has been detected. | Possible stumble, low power, or engine may stall. No effect also possible.
Fuel Rail Pressure Circuit

Circuit Description

This fault indicates the fuel pressure in the fuel rail pressure is consistently lower than the electronic control module (ECM) is commanding. The electronic fuel control actuator controls how much fuel is delivered to the high-pressure pump. The ECM supplies an electronic current to the fuel control actuator. The electronic fuel control actuator is normally open and is only closed when maximum current is supplied. The high-pressure fuel is accumulated in the fuel rail. The fuel rail pressure sensor measures the fuel pressure and sends a signal to the ECM.

Component Location

The fuel system is located on the air intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the fuel delivery pressure was lower than normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Inspect the fuel system for external leaks. Check the low pressure fuel system for restriction and air. Check the rail pressure sensor. Check the engine harness. Check the rail pressure sensor supply voltage. Check the electronic fuel control actuator. Check for internal fuel leaks.

Refer to Troubleshooting Fault Code t05-2215

Last Modified: 08-Feb-2019


Fuel Rail Pressure Negative Deviation Error

FAULT CODE 2216

Fuel Rail Pressure Negative Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2216 PID: P094 SPN: 94 FMI: 1/18 LAMP: Yellow SRT: | Fuel Rail Pressure Negative Deviation Error. Fuel rail pressure signal indicates that fuel pressure is consistently higher than the commanded fuel pressure. | Possible power derate or no effect.
Fuel Rail Pressure Circuit

Circuit Description

This fault indicates that more fuel is commanded to maintain the fuel pressure in the fuel rail. The electronic fuel control actuator controls how much fuel is delivered to the high-pressure pump. The engine control module (ECM) supplies an electronic current to the fuel control actuator. The electronic fuel control actuator is normally open and is only closed when current is supplied. The high-pressure fuel is accumulated in the fuel rail. The fuel rail pressure sensor measures the fuel pressure and sends a signal to the ECM.

Component Location

The fuel system is located on the intake side of the engine.

Shop Talk

Inspect the electronic fuel control actuator and rail pressure sensor for tampering. High resistance in the rail pressure sensor circuit can cause the fault.

Refer to Troubleshooting Fault Code t05-2216

Last Modified: 23-Jul-2012


Engine Control Module (ECM) Software Error

FAULT CODE 2217

Engine Control Module (ECM) Software Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: S240 SPN: 628 FMI: 11/31 LAMP: Yellow SRT: | Engine Control Module (ECM) Software Error. ECM software error internal to the module. | Possible no effect or engine can run rough or not start.
Engine Control Module (ECM) Software Error

Circuit Description

The ECM is a computer that controls an engine's operation through its software calibration and electronic components. It requires direct battery supply voltage through the unswitched power supply and it also monitors the keyswitch power input. The ECM will begin its shutdown process when the keyswitch is turned to the OFF position.

Component Location

The ECM is located on the left side of the engine.

Refer to Troubleshooting Fault Code t05-2217

Last Modified: 23-Jul-2012


Sensor Supply B - High Voltage

FAULT CODE 227

Sensor Supply B - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 1080 FMI: 3 LAMP: Yellow SRT: | High voltage detected on the electronic control module (ECM) voltage supply line to fuel rail pressure. | Possible low power.
Fuel Rail Pressure Circuit

Circuit Description

The ECM supplies the sensor with +5 VDC. If the supply wire to this sensor is damaged, the sensor will not work correctly.

Component Location

The fuel pressure sensor is located on the high-pressure common rail, which is above the intake manifold housing.

Shop Talk

High voltage on the sensor +5-VDC supply line will be caused by a short to battery in the supply line. If Fault Codes 227 and 451 are active, then begin troubleshooting Fault Code 227 first.

Refer to Troubleshooting Fault Code t05-227

Last Modified: 26-Oct-2010


Engine Overspeed Circuit

FAULT CODE 234

Engine Overspeed Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0 LAMP: Red SRT: | Engine speed signal indicates engine speed has exceeded the overspeed limit. | Fuel to the injectors disabled until the engine speed falls below the overspeed limit.
Engine Overspeed Circuit

Circuit Description

The engine speed sensor provides engine speed information to the electronic control module (ECM). The sensor generates its signals by sensing the movement of target teeth cast into a tone wheel that is mounted to the crankshaft. The external tone wheel has 58 spaces and a solid section, which indicates that cylinder number 1 is at top dead center.

Component Location

The engine speed sensor is located behind the vibration damper near the crankshaft tone wheel.

Refer to Troubleshooting Fault Code t05-234

Last Modified: 26-Oct-2010


Coolant Level - Engine Protection

FAULT CODE 235

Coolant Level - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1 LAMP: Red SRT: | Engine coolant level signal indicates coolant level is low. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM).

Component Location

The coolant level sensor is installed by the OEM. Use the OEM manual for sensor location.

Shop Talk

  • When the coolant level drops below a certain level, a power derate will be activated, which will decrease the power output by 50 percent over a 30-second period.
  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly.
  • Inspect the wiring harness between the four-way connector and the coolant level sensor for damage.
Refer to Troubleshooting Fault Code t05-235

Last Modified: 26-Oct-2010


Sensor Supply C - Low Voltage

FAULT CODE 238

Sensor Supply C - Low Voltage

Printable Version Printable Version

Overview

Sensor Supply C - Low Voltage

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 620 FMI: 4 LAMP: Yellow SRT: | Low voltage detected on the electronic control module (ECM) voltage supply line to the oil pressure/temperature sensor. | Default value used for oil pressure/temperature sensor connected to this +5-VDC supply. No engine protection for oil pressure.
Oil Pressure/Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the ECM to monitor the lubricating oil pressure and temperature. The ECM monitors the voltage on the signal pins and converts this to pressure and temperature values.

Component Location

The oil pressure/temperature sensor is located on the engine block, below the exhaust manifold, near the oil filter housing.

Shop Talk

  • If Fault Codes 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure/temperature signal voltage going into the ECM.
  • Confirm that the correct oil pressure/temperature sensor part number is being used.
  • If Fault Codes 238 and 141 are active, begin troubleshooting Fault Code 238 first.
Refer to Troubleshooting Fault Code t05-238

Last Modified: 26-Oct-2010


Sensor Supply C - High Voltage

FAULT CODE 239

Sensor Supply C - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 620 FMI: 3 LAMP: Yellow SRT: | High voltage detected on the electronic control module (ECM) voltage supply line to the oil pressure/temperature sensor. | Default value for oil pressure/temperature connected to this +5-VDC supply. No engine protection for oil pressure.
Oil Pressure/Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The oil pressure/temperature sensor is located on the engine block, below the exhaust manifold, and near the oil filter housing.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure signal voltage going into the ECM.
  • Confirm that the correct oil pressure/temperature sensor part number is being used.
  • If Fault Codes 239 and 135 are active, then begin troubleshooting Fault Code 239 first.
Refer to Troubleshooting Fault Code t05-239

Last Modified: 26-Oct-2010


Vehicle Speed Sensor Circuit

FAULT CODE 241

Vehicle Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2 LAMP: Yellow SRT: | Vehicle speed signal has been lost. | Engine speed limited to maximum. Engine Speed without Vehicle Speed Sensor. Cruise control, gear-down protection, and road speed governor will not work. Trip information data that are based on mileage will be incorrect.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor (VSS) uses two separate coils of wire (some applications use a single-coil sensor) to count gear teeth as they pass in front of the sensor. One coil is used by the electronic control module (ECM) to sense vehicle speed. The other coil is sometimes used by the OEM to send a vehicle speed signal to the speedometer.

Component Location

The vehicle speed sensor is most commonly installed in the rear of the transmission.

Shop Talk

  • Disconnect the vehicle speed sensor connector that connects to the OEM speedometer, or trip recorder, and move the truck. If the fault goes inactive, there is probably electrical noise being fed into the vehicle speed sensor circuit from the OEM device.
  • Verify the vehicle speed sensor wires in the OEM harness are twisted pairs.
  • Check brake switch operation with INSITE™. Fault could be caused by rear-wheel lockup without brake indication to ECM.
  • Verify the speed sensor is installed properly and it's locking nut has not vibrated loose.
Refer to Troubleshooting Fault Code t05-241

Last Modified: 26-Oct-2010


Indicator Lamp Circuit Error

FAULT CODE 244

Indicator Lamp Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 244 PID: S238 SPN: 623 FMI: 4 LAMP: Yellow SRT: | Error detected on one or more of the lamp circuits. Error could be an open circuit or a short circuit to the battery or ground on any lamp except warning lamp. | Lamp will not come on during the key-on bulb test if an open circuit or short to battery exists. Lamp will stay on if shorted to ground.
Indicator Lamp Circuit Error

Circuit Description

The electronic control module (ECM) performs warning tests on most of its circuits and will activate a fault code if a problem is detected in one of its circuits. Certain fault codes will cause a lamp to activate to signal the driver.

Component Location

The indicator lamp is typically located in the truck cab on the dashboard panel.

Shop Talk

This fault typically indicates a short circuit to battery voltage. This fault can not be flashed out on the warning lamp. It can be read using INSITE™ or flashing the warning code on the yellow lamps. This fault code can be an error on any lamp (wait-to-start, stop, and maintenance lamps) except the warning lamp.

Refer to Troubleshooting Fault Code t05-244

Last Modified: 26-Oct-2010


Transmission ECU to ECM Communication - Abnormal Update Rate

FAULT CODE 2559

Transmission ECU to ECM Communication - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2559 PID: SPN: 1845 FMI: 4 LAMP: Amber SRT: | Transmission ECU to ECM Communication Lost - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected between the ECM and the transmission ECU. | None on performance.

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Component values and states from components such as sensors, accelerators, and switches can then be transmitted from the OEM VECU to the Cummins® ECM over the data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The data link wiring and the devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, a malfunctioning OEM VECU, or a malfunctioning Cummins® ECM. It may be necessary to contact the OEM for the proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-2559.

Last Modified: 03-Mar-2014


Fuel Temperature Sensor - Engine Protection Circuit

FAULT CODE 261

Fuel Temperature Sensor - Engine Protection Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: P174 SPN: 174 FMI: 0/16 LAMP: Yellow SRT: | High fuel temperature has been detected. Voltage signal at the fuel temperature signal pin indicates fuel temperature above 71°C [160°F]. | Calibration-dependent progressive power derate and engine shutdown with increasing time after alert.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the fuel supply. The fuel temperature is used by the ECM for the engine protection and fuel heater aids.

Component Location

The fuel temperature sensor is located on the fuel filter housing.

Shop Talk

Make sure the fuel tanks are adequately filled. The drained fuel heats the fuel in the tank; therefore, keep the fuel tanks at a full level when operating in hot conditions.

Refer to Troubleshooting Fault Code t05-261

Last Modified: 26-Oct-2010


Fuel Temperature Sensor Circuit

FAULT CODE 263

Fuel Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the fuel temperature signal pin. | Default value used for fuel temperature. Possible low power.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine fuel. If the fuel temperature becomes too high and engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The fuel temperature sensor is located on the fuel filter housing.

Shop Talk

If the sensor is functioning properly, compare the reading to the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 5k to 7k
25 | 77 | 1700 to 2500
50 | 122 | 700 to 1000
75 | 167 | 300 to 450
100 | 212 | 150 to 220
Refer to Troubleshooting Fault Code t05-263

Last Modified: 26-Oct-2010


Fuel Temperature Sensor Circuit

FAULT CODE 265

Fuel Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at fuel temperature signal pin. | Default value used for fuel temperature. Possible low power.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine fuel. If the fuel temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The fuel temperature sensor is located on the fuel filter housing.

Shop Talk

If the sensor is functioning properly, compare the reading to the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 5k to 7k
25 | 77 | 1700 to 2500
50 | 122 | 700 to 1000
75 | 167 | 300 to 450
100 | 212 | 150 to 220
Refer to Troubleshooting Fault Code t05-265

Last Modified: 26-Oct-2010


Fuel Temperature Sensor - Engine Protection Circuit

FAULT CODE 266

Fuel Temperature Sensor - Engine Protection Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 266 PID: P174 SPN: 174 FMI: 0 LAMP: Red SRT: | Fuel temperature signal indicates the fuel temperature has exceeded the engine protection limit. | Power derate and possible engine shutdown if engine protection shutdown feature is enabled.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine fuel. If the fuel temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The fuel temperature sensor is located on the fuel filter housing.

Shop Talk

Make sure the fuel tanks are adequately filled. The drained fuel heats the fuel in the tank; therefore, keep the fuel tanks at a full level when operating in hot conditions.

Refer to Troubleshooting Fault Code t05-266

Last Modified: 26-Oct-2010


Electronic Fuel Control Actuator Circuit - Short Circuit

FAULT CODE 271

Electronic Fuel Control Actuator Circuit - Short Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S151 SPN: 1347 FMI: 4 LAMP: Yellow SRT: | Electronic Fuel Control Actuator Circuit - Short Circuit. Short circuit detected on the electronic fuel control actuator circuit. | The engine has low power, dies, or will not start.
Electronic Fuel Control Actuator Circuit

Circuit Description

The electronic fuel control actuator controls how much fuel is delivered to the high-pressure pump. The electronic control module (ECM) supplies an electronic current to the fuel control actuator. The electronic fuel control actuator is normally open and is only closed when current is supplied.

Component Location

The electronic fuel control actuator is located on the intake side of the engine. The actuator is attached to the high-pressure pump, which is mounted on the rear gear housing.

Shop Talk

A short circuit of the electronic fuel control actuator can cause low power at rated conditions.

Refer to Troubleshooting Fault Code t05-271.

Last Modified: 10-Feb-2011


Electronic Fuel Control Actuator Circuit - Open Circuit

FAULT CODE 272

Electronic Fuel Control Actuator Circuit - Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3 LAMP: Yellow SRT: | Open circuit detected on the electronic fuel control actuator circuit. | Power derate to calibrated value.
Electronic Fuel Control Actuator Circuit

Circuit Description

The electronic fuel control actuator controls how much fuel is delivered to the high-pressure pump. The electronic control module (ECM) supplies an electronic current to the fuel control actuator. The electronic fuel control actuator is normally open and is only closed when current is supplied.

Component Location

The electronic fuel control actuator is located on the intake side of the engine. The actuator is attached to the high-pressure pump, which is mounted on the rear gear housing.

Shop Talk

  • A disconnected or improperly connected electronic fuel control actuator can cause this fault.
  • An open circuit of the electronic fuel control actuator can cause rough engine operation and low power.
Refer to Troubleshooting Fault Code t05-272

Last Modified: 26-Oct-2010


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9 LAMP: Yellow SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough, or did not receive it at all. | At least one multiplexed device will not operate properly.
J1939 Datalink Multiplexing Circuit

Circuit Description

Normally, switches, accelerators and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM power distribution center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code t05-285.

Last Modified: 16-Nov-2011


SAE J1939 Multiplexin Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexin Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13 LAMP: Yellow SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
J1939 Data Link Multiplexing Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine electronic control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or Transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The J1939 data link wiring and VECU location varies by OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM receives an invalid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM power distribution center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code t05-286.

Last Modified: 16-Nov-2011


OEM Temperature Sensor Circuit - High

FAULT CODE 293

OEM Temperature Sensor Circuit - High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 293 PID: P441 SPN: 441 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the OEM temperature sensor signal pin. | Default value used for the OEM temperature.
OEM Temperature Sensor Circuit

Circuit Description

The OEM temperature sensor is used by the electronic control module (ECM) to monitor the temperature of an OEM-specified component. If the OEM temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The sensor location is dependent on the OEM's application and installation. Use the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-293

Last Modified: 26-Oct-2010


OEM Temperature Sensor Circuit - Low

FAULT CODE 294

OEM Temperature Sensor Circuit - Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 294 PID: P441 SPN: 441 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the OEM temperature sensor signal pin. | Default value used for the OEM temperature.
OEM Temperature Sensor Circuit

Circuit Description

The OEM temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the OEM-specified component. If the OEM temperature becomes too high and the engine protection is enabled, a derate condition can be incurred, possibly leading to shutdown.

Component Location

The sensor location is dependent on the OEM's application and installation. Use the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-294

Last Modified: 26-Oct-2010


OEM Pressure - Engine Protection - Speed Derate

FAULT CODE 296

OEM Pressure - Engine Protection - Speed Derate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 296 PID: P223 SPN: 1387 FMI: 14 LAMP: Red SRT: | OEM pressure out-of-range has been detected. Voltage signal at the OEM pressure signal pin indicates OEM pressure beyond OEM-specified threshold. | Calibration-dependent progressive power derate and engine shutdown with increasing time after alert.
OEM Pressure Sensor Circuit

Circuit Description

The OEM pressure sensor is used by the electronic control module (ECM) to monitor the lubricating OEM pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The OEM pressure value is used by the ECM for the engine protection system.

Component Location

The sensor location is dependent on the OEM's application and installation. Use the OEM troubleshooting and repair manual.

Shop Talk

  • Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed under load, the OEM pressure can drop below the engine protection limits.
  • INSITE™ can be used to monitor the OEM pressure sensor signal voltage going into the ECM.
Refer to Troubleshooting Fault Code t05-296

Last Modified: 26-Oct-2010


OEM Pressure Sensor Circuit

FAULT CODE 297

OEM Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 297 PID: P223 SPN: 1387 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the OEM pressure sensor signal pin. | Default value used for the OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM pressure sensor is used by the electronic control module (ECM) to monitor the lubricating OEM pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The OEM pressure value is used by the ECM for the engine protection system.

Component Location

The sensor location is dependent on the OEM's application and installation. Use the OEM troubleshooting and repair manual.

Shop Talk

  • INSITE™ can be used to monitor the OEM pressure signal voltage going into the ECM.
Refer to Troubleshooting Fault Code t05-297

Last Modified: 26-Oct-2010


OEM Pressure Sensor Circuit - Low

FAULT CODE 298

OEM Pressure Sensor Circuit - Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 298 PID: P223 SPN: 1387 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the OEM pressure sensor signal pin. | Default value used for the OEM pressure.
OEM Pressure Sensor Circuit

Circuit Description

The OEM pressure sensor is used by the electronic control module (ECM) to monitor the lubricating OEM pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The OEM pressure value is used by the ECM for the engine protection system.

Component Location

The sensor location is dependent on the OEM's application and installation. Use the OEM troubleshooting and repair manual.

Shop Talk

  • INSITE™ can be used to monitor the OEM pressure signal voltage going into the ECM.
Refer to Troubleshooting Fault Code t05-298

Last Modified: 26-Oct-2010


Injector Bank 1 Circuit Error

FAULT CODE 311

Injector Bank 1 Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 PID: S001 SPN: 651 FMI: 6 LAMP: Yellow SRT: | Short circuit detected in injector bank 1 circuit. For a six-cylinder, engine bank 1 is cylinders 1, 3, and 5. For a four-cylinder, engine bank 1 is cylinders 1 and 3. | Low power as a result of cylinders not firing.
Injector Bank 1 Circuit Error

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a driver wire and a return wire. An electrical pulse is sent to the injector from the ECM on the driver wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injectors are located under the valve cover.

Shop Talk

  • Inspect the injector pigtail nuts and make sure no wires are shorting to ground against any hardware under the valve cover.
  • Inspect the injector pigtail nuts and make sure they are tightened to the proper torque value. Confirm that the pigtail nuts and solenoid post do not have damaged threads.
Refer to Troubleshooting Fault Code t05-311

Last Modified: 26-Oct-2010


Injector Bank 2 Circuit Error

FAULT CODE 321

Injector Bank 2 Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 PID: S004 SPN: 654 FMI: 6 LAMP: Yellow SRT: | Short circuit detected in injector bank 2 circuit. For a six-cylinder, engine bank 2 is cylinders 2, 4, and 6. For a four-cylinder, engine bank 2 is cylinders 2 and 4. | Low power as a result of cylinders not firing.
Injector Bank 2 Circuit Error

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a driver wire and a return wire. An electrical pulse is sent to the injector from the ECM on the driver wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injectors are located under the valve cover.

Shop Talk

  • Inspect the injector pigtail nuts and make sure no wires are shorting to ground against any hardware under the valve cover.
  • Inspect the injector pigtail nuts and make sure they are tightened to the proper torque value. Confirm that the pigtail nuts and solenoid post do not have damaged threads.
Refer to Troubleshooting Fault Code t05-321

Last Modified: 26-Oct-2010


Injector Circuit

FAULT CODE 322

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S001 SPN: 651 FMI: 5 LAMP: Yellow SRT: | No current detected at number 1 injector driver or return pin when the voltage supply at the harness is on or high resistance detected on injector number 1 circuit. | Possible misfire in cylinder 1. Engine will possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a driver wire and a return wire. An electrical pulse is sent to the injector from the ECM on the driver wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during fuel injection and metering.

Component Location

Located under the valve cover.

Shop Talk

  • Inspect the injector pigtail nuts and make sure no wires are shorting to ground against any hardware under the valve cover.
  • Inspect the injector pigtail nuts and make sure they are tightened to the proper torque value. Confirm that the pigtail nuts and solenoid post do not have damaged threads.
Refer to Troubleshooting Fault Code t05-322

Last Modified: 26-Oct-2010


Injector Circuit

FAULT CODE 323

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S005 SPN: 655 FMI: 5 LAMP: Yellow SRT: | No current detected at number 5 injector driver or return pin when the voltage supply at the harness is on or high resistance detected on injector number 5 circuit. | Possible misfire in cylinder 5. Engine will possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a driver wire and a return wire. An electrical pulse is sent to the injector from the ECM on the driver wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injector is located under the valve cover.

Shop Talk

  • Inspect the injector pigtail nuts and make sure no wires are shorting to ground against any hardware under the valve cover.
  • Inspect the injector pigtail nuts and make sure they are tightened to the proper torque value. Confirm that the pigtail nuts and solenoid post do not have damaged threads.
Refer to Troubleshooting Fault Code t05-323

Last Modified: 26-Oct-2010


Injector Circuit

FAULT CODE 324

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S003 SPN: 653 FMI: 5 LAMP: Yellow SRT: | No current detected at number 3 injector driver or return pin when the voltage supply at the harness is on or high resistance detected on injector number 3 circuit. | Possible misfire in cylinder 3. Engine will possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a driver wire and a return wire. An electrical pulse is sent to the injector from the ECM on the driver wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injector is located under the valve cover.

Shop Talk

  • Inspect the injector pigtail nuts and make sure no wires are shorting to ground against any hardware under the valve cover.
  • Inspect the injector pigtail nuts and make sure they are tightened to the proper torque value. Confirm that the pigtail nuts and solenoid post do not have damaged threads.
Refer to Troubleshooting Fault Code t05-324

Last Modified: 26-Oct-2010


Injector Circuit

FAULT CODE 325

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S006 SPN: 656 FMI: 5 LAMP: Yellow SRT: | No current detected at number 6 injector driver or return pin when the voltage supply at the harness is on or high resistance detected on injector number 6 circuit. | Possible misfire in cylinder 6. Engine will possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a driver wire and a return wire. An electrical pulse is sent to the injector from the ECM on the driver wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injector is located under the valve cover.

Shop Talk

  • Inspect the injector pigtail nuts and make sure no wires are shorting to ground against any hardware under the valve cover.
  • Inspect the injector pigtail nuts and make sure they are tightened to the proper torque value. Confirm that the pigtail nuts and solenoid post do not have damaged threads.
Refer to Troubleshooting Fault Code t05-325

Last Modified: 26-Oct-2010


High Pressure Common Rail (HPCR) Leakage Error

FAULT CODE 329

High Pressure Common Rail (HPCR) Leakage Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 329 PID: S233 SPN: 1077 FMI: 14 LAMP: Red SRT: | High Pressure Common Rail (HPCR) Leakage Error. Rail pressure can not be maintained at maximum pumping capacity. | Possible stumble, low power, or engine could possibly stall. No effect also possible.
High Pressure Common Rail (HPCR) Leakage Error

Circuit Description

This fault indicates the fuel pressure in the fuel rail pressure is consistently lower than the electronic control module (ECM) is commanding. The electronic fuel control actuator controls how much fuel is delivered to the high-pressure pump. The ECM supplies an electronic current to the fuel control actuator. The electronic fuel control actuator is normally open and is only closed when maximum current is supplied. The high-pressure fuel is accumulated in the fuel rail. The fuel rail pressure sensor measures the fuel pressure and sends a signal to the ECM.

Component Location

The fuel system is located on the air intake side of the engine.

Shop Talk

Inspect the fuel system for external leaks.

Check the low pressure fuel system for restriction and air.

Check the rail pressure sensor.

Check the engine harness.

Check the rail pressure sensor supply voltage.

Check the electronic fuel control actuator.

Check for internal fuel leaks.

Refer to Troubleshooting Fault Code t05-329

Last Modified: 26-Oct-2010


Injector Circuit

FAULT CODE 331

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S002 SPN: 652 FMI: 5 LAMP: Yellow SRT: | No current detected at number 2 injector driver or return pin when the voltage supply at the harness is on or high resistance detected on injector number 2 circuit. | Possible misfire in cylinder 2. Engine will possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a driver wire and a return wire. An electrical pulse is sent to the injector from the ECM on the driver wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injector is located under the valve cover.

Shop Talk

  • Inspect the injector pigtail nuts and make sure no wires are shorting to ground against any hardware under the valve cover.
  • Inspect the injector pigtail nuts and make sure they are tightened to the proper torque value. Confirm that the pigtail nuts and solenoid post do not have damaged threads.
Refer to Troubleshooting Fault Code t05-331

Last Modified: 26-Oct-2010


Injector Circuit

FAULT CODE 332

Injector Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S004 SPN: 654 FMI: 5 LAMP: Yellow SRT: | No current detected at number 4 injector driver or return pin when the voltage supply at the harness is on or high resistance detected on injector number 4 circuit. | Possible misfire in cylinder 4. Engine will possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves are actuated by the electronic control module (ECM) to control fuel metering and timing. Each injector solenoid is connected to the ECM by a driver wire and a return wire. An electrical pulse is sent to the injector from the ECM on the driver wire and returns to the ECM on the return wire after actuating the solenoid. Each solenoid valve is normally closed, and it is only opened by an electrical pulse from the ECM during fuel injection and metering.

Component Location

The injector is located under the valve cover.

Shop Talk

  • Inspect the injector pigtail nuts and make sure no wires are shorting to ground against any hardware under the valve cover.
  • Inspect the injector pigtail nuts and make sure they are tightened to the proper torque value. Confirm that the pigtail nuts and solenoid post do not have damaged threads.
Refer to Troubleshooting Fault Code t05-332

Last Modified: 26-Oct-2010


Electronic Control Module (ECM) Flash Memory

FAULT CODE 341

Electronic Control Module (ECM) Flash Memory

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 341 PID: S253 SPN: 630 FMI: 2 LAMP: Yellow SRT: | Memory in the ECM has been corrupted. | Possible no effect or engine will run rough or not start.
ECM Flash Memory

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is a single 30-amp fuse or two in-line 15-amp fuses in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the left side of the engine near the front of the engine. The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Use the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-341

Last Modified: 26-Oct-2010


Electronic Control Module (ECM)

FAULT CODE 343

Electronic Control Module (ECM)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | Internal ECM error. | Possibly none on performance or severe derate.
Electronic Control Module

Circuit Description

The ECM monitors both signal voltage output to the injectors and ECM input from the engine sensors.

Component Location

The ECM is bolted to the intake side of the cylinder block near the front of the engine.

Shop Talk

  • Loose engine or chassis ground connections can cause Fault Code 343 to be logged, as well as complaints of an intermittent stumble. Pay special attention to the negative (-) starter post connection.
  • Moisture in the ECM connectors can also cause the ECM to log Fault Code 343.
Refer to Troubleshooting Fault Code t05-343

Last Modified: 26-Oct-2010


Sensor Supply Circuit

FAULT CODE 352

Sensor Supply Circuit

Printable Version Printable Version

Overview

Sensor Supply Circuit

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 1079 FMI: 4 LAMP: Yellow SRT: | Low voltage detected on the electronic control module (ECM) supply line to intake manifold pressure/temperature, OEM pressure, and coolant level sensors, as well as the remote accelerator. | Default values used for sensors connected to this +5-VDC supply and possible default to idle speed. Low power can occur because fueling is derated to no-boost fueling. Also, possible loss of engine protection for the sensors.
Sensor Supply Circuit

Circuit Description

The ECM supplies each of these sensors with postive +5 VDC. If the supply line to any sensor is damaged, the sensor will not work correctly.

Component Location

The +5-VDC sensor supply circuit is located in both the engine harness and OEM harness.

Shop Talk

Low voltage on the sensor +5-VDC supply line can be caused by a short circuit to ground in a supply line, a short circuit between supply line and return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-352

Last Modified: 26-Oct-2010


Intake Air Heater Number 1 Circuit Error

FAULT CODE 381

Intake Air Heater Number 1 Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 381 PID: S237 SPN: 626 FMI: 11 LAMP: Yellow SRT: | Error detected in the cold start aid relay 1 enable circuit. | Intake air heater number 1 can be on or off all of the time or is damaged.
Intake Air Heater Number 1 Circuit Error

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The electronic control module (ECM) controls relays that switch power to the air heater. There are two heating coils in the heater that are individually controlled by the ECM.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the heater relays will vary with OEM.

Shop Talk

  • These faults could also indicate the intake air heater circuits are shorted to battery positive (+). This would command the grids to be on full time. This will drain the batteries, burn out grids, and/or destroy intake gaskets.
  • The intake air heater circuits will only activate when intake manifold temperature is below 19°C [66°F] when the keyswitch is in the ON position.
  • If the intake air heaters are not installed and Fault Code 381 or 382 is active, then use INSITE™ to disable this feature, “Intake Air Heater.”
Refer to Troubleshooting Fault Code t05-381

Last Modified: 26-Oct-2010


Intake Air Heater Number 2 Circuit Error

FAULT CODE 382

Intake Air Heater Number 2 Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 382 PID: S237 SPN: 626 FMI: 11 LAMP: Yellow SRT: | Error detected in the cold start aid relay 2 enable circuit. | Intake air heater number 2 can be on or off all of the time or is damaged.
Intake Air Heater Number 2 Circuit Error

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The ECM controls relays that switch power to the air heater. There are two heating coils in the heater that are individually controlled by the ECM.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the heater relays will vary with OEM.

Shop Talk

  • These faults could also indicate the intake air heater circuits are shorted to battery (+). This would command the grids to be on full time. This will drain the batteries, burn out grids, and/or destroy intake gaskets.
  • The intake air heater circuits will only activate when intake manifold temperature is below 19°C [66°F] when the keyswitch is in the ON position.
  • If the intake air heaters are not installed and Fault Code 381 or 382 is active, then use INSITE™ to disable this feature, “Intake Air Heater.”
Refer to Troubleshooting Fault Code t05-382

Last Modified: 26-Oct-2010


Sensor Supply A - High Voltage

FAULT CODE 386

Sensor Supply A - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 1079 FMI: 3 LAMP: Yellow SRT: | High voltage detected on the electronic control module (ECM) voltage supply wire to the intake manifold pressure, OEM pressure, coolant level, and remote accelerator sensors. | Default values used for sensors connected to the +5-VDC supply and possible default to idle speed. Lower power can occur because fueling defaulted to no-boost fueling. Also, possible loss of engine protection for the sensors.
Sensor Supply A - High Voltage

Circuit Description

The ECM supplies each of these sensors with positive +5 VDC. If the supply wire to any sensor is damaged, the sensor will not work correctly.

Component Location

There are four components involved in the sensor voltage supply: Intake manifold pressure/temperature, OEM pressure, coolant level, and remote accelerator sensors. See Section E for component location.

Shop Talk

High voltage on the sensor +5-VDC supply wire will be caused by a short circuit to battery of the supply wire or a short circuit between an actuator wire and the supply wire.

Refer to Troubleshooting Fault Code t05-386

Last Modified: 26-Oct-2010


Fan Clutch Circuit Error

FAULT CODE 389

Fan Clutch Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 389 PID: S033 SPN: 647 FMI: 11 LAMP: Yellow SRT: | Error detected in the fan clutch circuit. | The fan can be on or off all of the time or is damaged.
Fan Clutch Circuit

Circuit Description

The electronic control module (ECM) can control the cooling fan based on inputs from the coolant temperature sensor and intake manifold temperature sensor.

Component Location

The fan clutch is located on front of the engine.

Shop Talk

Some applications will also provide inputs to the ECM for auxiliary device cooling (e.g., air conditioner pressure, power steering, and transmission temperature) or a manual fan switch for fan control. Verify that the features and parameters are set correctly for fan control.

Refer to Troubleshooting Fault Code t05-389

Last Modified: 26-Oct-2010


Exhaust Brake Circuit Error

FAULT CODE 392

Exhaust Brake Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 392 PID: S029 SPN: 1073 FMI: 11 LAMP: Yellow SRT: | Error detected in the exhaust brake circuit. | Engine or exhaust brake driver 2 can not be activated.
Exhaust Brake Circuit Error

Circuit Description

The exhaust brake control feature is used for control of the exhaust brake, which slows engine speed during motoring conditions.

Component Location

The exhaust brake is located on the exhaust side of the engine (right side).

Refer to Troubleshooting Fault Code t05-392

Last Modified: 26-Oct-2010


J1708 Datalink Circuit

FAULT CODE 412

J1708 Datalink Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 SPN: 608 FMI: 2 LAMP: None SRT: | Communication between the electronic control module (ECM) and another device on the J1708 datalink has been lost. | None on performance. J1708 devices possibly will not operate.
J1708 Datalink Circuit

Circuit Description

Devices such as automatic braking system controllers, autoshift transmissions, vehicle ECM, automatic slip reduction systems, electronic displays, electronic information systems, electronic service tools, and VECUs can communicate with the ECM over the J1708 datalink. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the J1708 datalink. This datalink can also be available on the 89-pin OEM harness, pin 31 J1587 positive (+), and pin 30 J1587 negative (-).

Component Location

The J1708 datalink connector is located on the engine harness near the engine data plate on the intake side of the engine.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the J1708 datalink and then can no longer transmit on the datalink. Possible causes could be the following: Unplugging an electronic service tool before keying off the ECM, the J1708 datalink having an intermittent electrical problem, the ECM (or another J1708 device) tying up communications by an electrical problem, or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-412

Last Modified: 26-Oct-2010


Fault Code Path Selection

FAULT CODE 415
Fault Code Path Selection

Do you have an Oil Pressure Sensor? | Go to 86-fc415sn
Do you have an Oil Pressure Switch? | Go to 86-fc415sw

Last Modified: 21-Sep-2005


Oil Pressure - Engine Protection - Fueling Derate

FAULT CODE 415

Oil Pressure - Engine Protection - Fueling Derate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Red SRT: | Oil pressure signal indicates oil pressure below the very low engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature enabled.
Oil Pressure/Temperature Sensor Circuit

Circuit Description

The oil pressure/temperature sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure/temperature sensor is located on the engine block, between the fuel filter and fuel pump.

Shop Talk

  • Confirm that the oil pressure/temperature sensor supply voltage is between (+) 4.5 and 5.25 VDC at the sensor.
  • Verify, with the driver, the engine speed at which the fault occurs. If the engine is being operated at too low of a speed under load, the oil pressure can drop below the engine protection limits.
Refer to Troubleshooting Fault Code t05-415sn

Last Modified: 26-Oct-2010


Engine Oil Pressure Low - Critical

FAULT CODE 415

Engine Oil Pressure Low - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Red SRT: | Engine oil pressure low - critical. Engine oil pressure indicates oil pressure is below the low oil pressure engine protection limit. | Progressive power and speed derate with increasing time after alert. If the engine protection shutdown feature is enabled, engine will shut down 30 seconds after the red lamp starts flashing.
Oil Pressure/Temperature Sensor Circuit

Circuit Description

The engine oil pressure switch is used by the ECM to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the switch will open and cause Fault Code 415 to log.

Component Location

The oil pressure sensor is located on the intake side of the engine, on the block, below the fuel filter. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Incorrect oil level
  • Failed wiring harness
  • Failed oil pressure switch
  • Short circuit to ground
  • The fault will trigger if lubricating oil pressure drops below 41 kPa [6 psi] for 30 seconds. Engine Protection Shutdown will be activated after an additional 30 seconds if the feature is enabled in the ECM.
Refer to Troubleshooting Fault Code t05-415sw

Last Modified: 26-Oct-2010


Coolant Level Sensor Circuit

FAULT CODE 422

Coolant Level Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 422 PID: P111 SPN: 111 FMI: 2 LAMP: Yellow SRT: | Voltage detected simultaneously on both the coolant level high and low signal pins or no voltage detected on either pin. | No engine protection for coolant level.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor monitors the coolant level within the coolant system and passes information to the electronic control module (ECM) through the engine harness. Do not use a multimeter to check the coolant level sensor. If the radiator coolant level drops below a certain level, a progressive power derate with increasing time after alert will occur.

Component Location

The coolant level sensor is supplied by the vehicle's OEM and located in the radiator top tank or surge tank.

Shop Talk

  • If a shorting plug is used in the coolant level circuit, verify that it is wired correctly. Use the wiring diagram in Section E.
  • Inspect the wiring harness between the four-way connector and coolant level sensor for damage.
  • Make sure the coolant level sensor is located in the middle of the tank rather than off to one side where the coolant level can change when the vehicle makes a turn.
  • Make sure the correct ECM code is in the ECM. Calibrating the ECM with the incorrect DO option can cause Fault Code 422 to be active since some OEMs use a coolant level sensor that requires a special calibration.
Refer to Troubleshooting Fault Code t05-422

Last Modified: 26-Oct-2010


J1939 Datalink Communication

FAULT CODE 426

J1939 Datalink Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | Communication between the electronic control module (ECM) and another device on the J1939 datalink has been lost. | None on performance. J1939 devices possibly do not operate.
J1939 Datalink Circuit

Circuit Description

Devices such as automatic braking system controllers, autoshift transmissions, vehicle ECM, automatic slip reduction systems, electronic displays, electronic information systems, electronic service tools, and VECUs can communicate with the ECM over the J1939 datalink. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the J1939 datalink.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 datalink wiring and the J1939 devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the J1939 datalink and then can no longer transmit on the datalink. Possible causes could be the following: Unplugging an electronic service tool before keying off the ECM, the J1939 datalink having an intermittent electrical problem, or the ECM (or another J1939 device) tying up communications by an electrical problem or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-426

Last Modified: 26-Oct-2010


J1939 Datalink Communication

FAULT CODE 427

J1939 Datalink Communication

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9 LAMP: None SRT: | Communication between the electronic control module (ECM) and another device on the J1939 datalink is not fast enough. | None on performance. J1939 devices possibly do not operate.
J1939 Datalink Circuit

Circuit Description

Devices such as automatic braking system controllers, autoshift transmissions, vehicle ECM, automatic slip reduction systems, electronic displays, electronic information systems, electronic service tools, and VECUs can communicate with the ECM over the J1939 datalink. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the J1939 datalink.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 datalink wiring and the J1939 devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the J1939 datalink and then can no longer transmit on the datalink. Possible causes could be the following: Unplugging an electronic service tool before keying off the ECM, the J1939 datalink having an intermittent electrical problem, or the ECM (or another J1939 device) tying up communications by an electrical problem or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-427

Last Modified: 26-Oct-2010


Water-In-Fuel Sensor Circuit

FAULT CODE 429

Water-In-Fuel Sensor Circuit

Printable Version Printable Version

Overview

Water-In-Fuel Sensor Circuit

CODE | REASON | EFFECT
Fault Code: 429 PID: P97 SPN: 97 FMI: 4 LAMP: Yellow SRT: | Error detected in the water-in-fuel sensor. | No detection capability for water in fuel.
Water-In-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the OEM water separator. The water-in-fuel sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires: A return ground and a signal wire.

Component Location

The water-in-fuel sensor is installed in the OEM water separator and is supplied by the vehicle's OEM. Use the OEM manual for component location.

Shop Talk

The water-in-fuel sensor is not incorporated in the engine's fuel filter because it is a pressure-side filter. This water separator is supplied by the vehicle's OEM.

Refer to Troubleshooting Fault Code t05-429

Last Modified: 26-Oct-2010


Idle Validation Switch Circuit

FAULT CODE 431

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2 LAMP: Yellow SRT: | Idle validation signals indicate no voltage detected simultaneously on both idle and off-idle pins. | No effect on performance but loss of idle validation.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal manufacturers to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired idle validation switch.

A bad ground on pin A of the idle validation switch can also cause this fault.

Refer to Troubleshooting Fault Code t05-431

Last Modified: 26-Oct-2010


Accelerator Pedal Circuit

FAULT CODE 432

Accelerator Pedal Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13 LAMP: Red SRT: | Idle validation signal indicates the accelerator is at the idle position when the accelerator position signal indicates the accelerator is not at the idle position or idle validation signal indicates the accelerator is not at the idle position when the accelerator is at the idle position. | Engine possibly only idles.
Accelerator Pedal Circuit

Circuit Description

The accelerator pedal assembly relays the accelerator percentage requested by the operator to the electronic control module (ECM). Percent accelerator is used to determine fueling. The accelerator position sensor and the idle validation switch on the accelerator pedal are adjusted at the factory to provide the correct output signals.

Note: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

Confirm that the idle validation switch is properly calibrated. Use the manufacturer's procedures for adjustment information.

  • Make sure there are no external circuits hooked into the accelerator position sensor circuit and that there are no signs of tampering (stripped wires, cut loom, or additional connectors in the accelerator circuit) in the circuit.
  • If all the wiring and the sensor checks look good, replace the accelerator position sensor and the idle validation switch circuit wires, between the accelerator pedal and ECM, with new wires. Run the twisted pair of wires through or around the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal openings in the bulkhead around the connector and the wires to prevent toxic and noxious fumes from seeping into the operator area. Note: Check that the three accelerator position sensor circuit wires are twisted together. Check that the three idle validation switch circuit wires are twisted together.
  • The ECM and accelerator pedal assembly must be electrically calibrated to each other for proper engine response. The ECM and accelerator pedal assembly must be calibrated when an accelerator pedal is initially installed, replaced, when an ECM is replaced, when a new calibration is downloaded to the ECM, and when the accelerator pedal wiring is disconnected while the vehicle keyswitch is ON.
  • With keyswitch ON, gradually push the accelerator to the floor and release. Depress and release the accelerator pedal three times. This procedure will recalibrate the ECM and accelerator pedal.
  • Confirm with OEM that the accelerator is within OEM specifications for accelerator pedal sensor voltage or resistance at idle to off-idle transition.
  • Depressing the accelerator while starting the engine is not necessary nor advised. Additional fueling is not possible until the engine reaches idle, and in older versions of software, depressing the accelerator could cause Fault Code 432, in some situations.
Refer to Troubleshooting Fault Code t05-432

Last Modified: 26-Oct-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 433

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 433 PID: P102 SPN: 102 FMI: 2 LAMP: Yellow SRT: 00-093 | Intake manifold pressure signal indicates intake manifold pressure is high when other engine parameters indicate intake manifold pressure is low. | Engine can derate to no-boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure/temperature sensor is located on the air intake manifold.

Shop Talk

  • The ECM checks for this fault only at idle speed. If the intake manifold pressure shows too high of a value at this time, the ECM will log a fault code.
  • Run an automated cylinder performance test and/or single-cylinder cutout test to detect an injector problem causing the fault. Look for alternate fuel sources, such as oil-filled charge air coolers or blown seals in the turbocharger causing this fault.
Refer to Troubleshooting Fault Code t05-433

Last Modified: 26-Oct-2010


Unswitched Battery Supply Circuit

FAULT CODE 434

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 434 PID: S251 SPN: 627 FMI: 2 LAMP: Yellow SRT: | All data gathered by the ECM since the last key-on were not stored to permanent memory at the last key-off. | None on performance. Fault code table, trip information data, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is either one in-line 30-amp fuse or two in-line 15-amp fuses in the unswitched battery wires to protect the OEM harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Use the OEM manual.

Shop Talk

  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 434.
  • Inspect the intermittent keyswitch or fast keyswitch cycling.

Note: If a battery disconnect switch is turned off after the keyswitch is turned off, but before the ECM completely powers down (up to 20 seconds), this fault can register.

Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 434.

Corrupted voltage (short interruptions or spikes that can only be seen with a with a oscilloscope) on keyswitch line can cause this fault. If the voltage at pin 5 of the engine 36-pin connector is measured as negative with a oscilloscope at key-off, Fault Code 434 can be logged.

Refer to Troubleshooting Fault Code t05-434

Last Modified: 26-Oct-2010


Unswitched Battery Supply Circuit

FAULT CODE 441

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: S168 SPN: 168 FMI: 1/18 LAMP: Yellow SRT: | Voltage detected at electronic control module (ECM) power supply pins indicates low ECM supply voltage. | Engine can die or run rough.
Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is either one in-line 30-amp fuse or two in-line 15-amp fuses in the unswitched battery wires to protect the OEM harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the left side of the engine. The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Use the OEM manual.

Shop Talk

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441

Last Modified: 26-Oct-2010


Unswitched Battery Supply Circuit

FAULT CODE 442

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Yellow SRT: | Voltage detected at electronic control module (ECM) power supply pins indicates ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery input through the OEM harness. There is either one in-line 30-amp fuse or two in-line 15-amp fuses in the unswitched battery wire to protect the OEM harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

The ECM receives unswitched battery input through the OEM harness.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Use the OEM manual for battery location.

Shop Talk

Disconnect all aftermarket devices from the battery supply circuit. Make sure the proper-size fuses are being used (one 30-amp fuse or two 15-amp fuses, depending on the application).

Refer to Troubleshooting Fault Code t05-442

Last Modified: 26-Oct-2010


Fuel Pressure - High

FAULT CODE 449

Fuel Pressure - High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P094 SPN: 94 FMI: 0/16 LAMP: Yellow SRT: | Fuel rail pressure signal indicates fuel pressure has exceeded the maximum limit for the given engine rating. | Engine can shut down.
Electronic Fuel Control Actuator Circuit

Circuit Description

This fault indicates that the rail pressure sensor has detected a pressure higher than the system pressure. Current is provided to the electronic fuel control actuator, which allows fuel to be pressurized by the high-pressure pump. The high-pressure fuel is accumulated in the fuel rail. The fuel rail pressure sensor measures the fuel pressure and sends a signal to the electronic control module (ECM).

Component Location

The fuel system is located on the intake side of the engine.

Shop Talk

Fuel leaks can cause this fault. After troubleshooting this fault code, check for fuel leaks.

Refer to Troubleshooting Fault Code t05-449

Last Modified: 26-Oct-2010


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at rail fuel pressure sensor circuit. | Power and or speed derate.
Rail Fuel Pressure Sensor Circuit

Circuit Description

The rail fuel pressure sensor is used by the electronic control module (ECM) to monitor the fuel pressure in the fuel rail. The sensor gets +5 VDC from the ECM and is grounded by a RETURN pin. A third pin is the SIGNAL pin. The power and RETURN pins are shared with other devices on the engine.

Component Location

The rail fuel pressure sensor is installed in the fuel rail. Refer to Procedure 100-002

Shop Talk

This fault code will become active if there is an open circuit on any of the three pins (+5 volt supply, signal, or return) that connect the sensor or ECM to the wiring harness. This fault will also be active if the SIGNAL wire is shorted to a source of voltage. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Causes for this fault code include:

  • Voltage (+5 VDC or higher shorted to the SIGNAL wire)
  • Open circuit on the SIGNAL wire
  • Open circuit on the +5-VDC SUPPLY wire
  • Open circuit on the RETURN wire
  • Failed sensor
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-451

Last Modified: 26-Oct-2010


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the rail fuel pressure sensor circuit. | Power and or speed derate.
Rail Fuel Pressure Sensor Circuit

Circuit Description

The rail fuel pressure sensor is used by the electronic control module (ECM) to monitor the fuel pressure in the fuel rail. The sensor gets +5 VDC from the ECM and is grounded by a RETURN pin. A third pin is the SIGNAL pin. The POWER and RETURN pins are shared with other devices on the engine.

Component Location

The rail fuel pressure sensor is installed in the fuel rail. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code will become inactive any time the keyswitch is ON and the SIGNAL pin of the ECM is too low. This can be caused by a short circuit to ground on the +5-VDC SUPPLY or SIGNAL wire. This fault will also become active if a device that is powered by the common +5-VDC power supply is shorted to ground. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Causes for this fault code include:

  • Engine harness; the SUPPLY or SIGNAL wire is shorted to ground
  • Other components; any component connected to the common power supply is shorted to ground
  • Failed sensor
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-452

Last Modified: 26-Oct-2010


Intake Manifold Temperature Sensor - Engine Protection - Fueling Derate

FAULT CODE 488

Intake Manifold Temperature Sensor - Engine Protection - Fueling Derate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Yellow SRT: | Intake manifold temperature signal indicates the intake manifold air temperature is above the engine protection limit. | Power and/or speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold pressure/temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the engine intake air. The intake air temperature is used by the ECM for the engine protection system, cold start aids, and timing and fueling controls.

Component Location

The intake manifold pressure/temperature is located on the side of the intake manifold toward the rear of the cylinder head.

Shop Talk

  • Make sure the engine compartment temperature does not get too high (above 93°C [199°F]).
  • Make sure the intake manifold pressure/temperature is not located near any extreme heat sources.
  • Possible causes:- Clogged, dirty, inadequate-capacity air cleaner element.- Intake restriction.
Refer to Troubleshooting Fault Code t05-488

Last Modified: 26-Oct-2010


Idle Validation Switch Circuit

FAULT CODE 551

Idle Validation Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4 LAMP: Yellow SRT: | Idle validation signals on pins indicate no voltage detected on either pin. | Engine will possibly only idle.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal manufacturers to switch from on-idle to off-idle at the correct accelerator pedal position.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired idle validation switch. A bad ground on pin A (or pin 1) of the idle validation switch can also cause this fault.

Refer to Troubleshooting Fault Code t05-551

Last Modified: 26-Oct-2010


Alternator Circuit - High Voltage

FAULT CODE 596

Alternator Circuit - High Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: 167 SPN: 167 FMI: 0/16 LAMP: Yellow SRT: | High voltage detected at the alternator. | Fault code logged only.
Unswitched Battery Circuit

Circuit Description

The electronic control module (ECM) monitors the battery voltage (unswitched battery power) and logs a fault if the voltage is above or below a calibration-specific value.

Component Location

The alternator is located on the front of the engine and driven by the belt drive.

Shop Talk

  • The ECM monitors the battery voltage (unswitched battery power) and logs a fault if the voltage is above or below a calibration-specific value. If the alternator charging capability is adjustable, then it can be adjusted incorrectly (too low or too high). Use the alternator manufacturer's specifications.
  • Check the features and parameters to see if the correct battery system voltage is selected (12-VDC or 24-VDC systems). If this is incorrect, then it can trigger a fault code.
  • When the ECM detects this fault, the engine rpm will automatically rise above low idle and remain at the engine speed for up to a minute and then ramp back down to the low-idle setting. This is to increase the alternator speed, which can reset the alternator so that the system can begin to charge correctly.
Refer to Troubleshooting Fault Code t05-596

Last Modified: 26-Oct-2010


Alternator Circuit - Low Voltage

FAULT CODE 597

Alternator Circuit - Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: 167 SPN: 167 FMI: 1/18 LAMP: Yellow SRT: | Low voltage detected at the alternator. | Fault code logged only.
Unswitched Battery Circuit

Circuit Description

The electronic control module (ECM) monitors the battery voltage (unswitched battery power) and logs a fault if the voltage is above or below a calibration-specific value.

Component Location

The alternator is located on the front of the engine and driven by the belt drive.

Shop Talk

  • The ECM monitors the battery voltage (unswitched battery power) and logs a fault if the voltage is above or below a calibration-specific value. If the alternator charging capability is adjustable, then it can be adjusted incorrectly (too low or too high). Use the alternator manufacturer's specifications.
  • Check the features and parameters to see if the correct battery system voltage is selected (12-VDC or 24-VDC systems). If this is incorrect, then it can trigger a fault code.
  • When the ECM detects this fault, the engine rpm will automatically rise above low idle and remain at the engine speed for up to a minute and then ramp back down to the low-idle setting. This is to increase the alternator speed, which can reset the alternator so that the system can begin to charge correctly.
Refer to Troubleshooting Fault Code t05-597

Last Modified: 26-Oct-2010


Alternator Circuit - Very Low Voltage

FAULT CODE 598

Alternator Circuit - Very Low Voltage

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: 167 SPN: 167 FMI: 1 LAMP: Red SRT: | Very low voltage detected at the alternator. | Fault code logged only.
Unswitched Battery Circuit

Circuit Description

The electronic control module (ECM) monitors the battery voltage (unswitched battery power) and logs a fault if the voltage is above or below a calibration-specific value.

Component Location

The alternator is located on the front of the engine and driven by the belt drive.

Shop Talk

  • The ECM monitors the battery voltage (unswitched battery power) and logs a fault if the voltage is above or below a calibration-specific value. If the alternator charging capability is adjustable, then it can be adjusted incorrectly (too low or too high). Use the alternator manufacturer's specifications.
  • Check the features and parameters to see if the correct battery system voltage is selected (12-VDC or 24-VDC systems). If this is incorrect, then it can trigger a fault code.
  • When the ECM detects this fault, the engine rpm will automatically rise above low idle and remain at the engine speed for up to a minute and then ramp back down to the low-idle setting. This is to increase the alternator speed, which can reset the alternator so that the system can begin to charge correctly.
Refer to Troubleshooting Fault Code t05-598

Last Modified: 26-Oct-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2 LAMP: Yellow SRT: | No engine speed signal detected at the electronic control module (ECM) from the engine speed (crankshaft) sensor. | Engine can run rough. Possible poor starting capability.
Engine Speed (Crankshaft) Sensor Circuit

Circuit Description

The engine speed (crankshaft) sensor provides engine speed and position information to the electronic control module (ECM). The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

Use the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

Possible causes of this fault code include damaged engine speed (crankshaft) sensor, debris on top of sensor, open or short circuit, or power supply voltage failure.

Refer to Troubleshooting Fault Code t05-689

Last Modified: 28-Oct-2014


Engine Speed Signal Mismatch

FAULT CODE 731

Engine Speed Signal Mismatch

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7 LAMP: Yellow SRT: | The engine speed signals from the engine position (camshaft) sensor and the backup engine speed (crankshaft) sensor do not match. | Engine can run rough. Possible poor starting capability.
Engine Speed Sensor and Engine Position Sensor Circuits

Circuit Description

The crank sensor reports the engine speed and the cam sensor reports the engine position. These two engine rpms must be similar engine values.

Component Location

Use the engine diagrams in Section E for location of engine position sensor and engine speed sensor.

Shop Talk

This fault can occur when the engine speed from the engine position sensor (cam) and engine speed sensor (crank) differ by a specified rpm amount.

Refer to Troubleshooting Fault Code t05-731

Last Modified: 26-Oct-2010


Engine Position (Camshaft) Sensor Circuit

FAULT CODE 753 or 778

Engine Position (Camshaft) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 753 or 778 PID: S064 SPN: 723 FMI: 2 LAMP: Yellow SRT: | No engine speed signal detected at the electronic control module (ECM) from the backup engine speed engine position (camshaft) sensor. | Possible poor starting capability.
Engine Position (Camshaft) Sensor Circuit

Circuit Description

The engine position (camshaft) sensor provides engine position information to the electronic control module (ECM). The sensor generates the signal by sensing the movement of target teeth machined in the camshaft gear.

Component Location

Use the engine diagrams in Section E of this manual for the component location.

Shop Talk

Possible causes of this fault code include damaged engine position (camshaft) sensor, debris on tip of sensor, open or short circuit, or power supply voltage failure.

Fault Code 753: When checking the sensor air gap, inspect each cam gear notch for debris or failed cam gear. The ECM will trigger Fault Code 753 if it does not see the proper amount of pulses; four-cylinder engines have five notches on the cam gear and six-cylinder engines have seven notches.

Refer to Troubleshooting Fault Code t05-753

Last Modified: 26-Oct-2010


Analog Torque Circuit Error

FAULT CODE 768

Analog Torque Circuit Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 768 PID: S009 SPN: 923 FMI: 11 LAMP: Yellow SRT: | Error detected in the analog torque transmission interface circuit. | The engine/transmission interface will possibly not function properly.
Analog Torque Circuit

Circuit Description

The output device driver is a device used by the electronic control module (ECM) to control the transmission shift modulation signal.

Component Location

Use the OEM diagram for location of transmission shift modulator.

Shop Talk

Output device driver could be malfunctioning due to a failed engine harness, bad ground on transmission shift modulator connector, or a bad transmission shift modulator.

Refer to Troubleshooting Fault Code t05-768

Last Modified: 26-Oct-2010


Engine Position (Camshaft) Sensor Circuit

FAULT CODE 753 or 778

Engine Position (Camshaft) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 753 or 778 PID: S064 SPN: 723 FMI: 2 LAMP: Yellow SRT: | No engine speed signal detected at the electronic control module (ECM) from the backup engine speed engine position (camshaft) sensor. | Possible poor starting capability.
Engine Position (Camshaft) Sensor Circuit

Circuit Description

The engine position (camshaft) sensor provides engine position information to the electronic control module (ECM). The sensor generates the signal by sensing the movement of target teeth machined in the camshaft gear.

Component Location

Use the engine diagrams in Section E of this manual for the component location.

Shop Talk

Possible causes of this fault code include damaged engine position (camshaft) sensor, debris on tip of sensor, open or short circuit, or power supply voltage failure.

Fault Code 753: When checking the sensor air gap, inspect each cam gear notch for debris or failed cam gear. The ECM will trigger Fault Code 753 if it does not see the proper amount of pulses; four-cylinder engines have five notches on the cam gear and six-cylinder engines have seven notches.

Refer to Troubleshooting Fault Code t05-778

Last Modified: 26-Oct-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


NO TITLE

Information Fault Codes

NOTE: - Information Fault Codes have simple corrective actions and no fault code troubleshooting tree.
- After correcting the condition that caused the fault, let the engine warm up; then let the engine run for 1 minute to inactivate the fault code. Then, use the electronic service tool to clear the fault code.

CODE: 269
LAMP: Red
REASON: Engine rpm is detected when antitheft is active.
EFFECT: Engine possibly will not start.
ACTION: Enter antitheft protection password.
CODE: 291
LAMP: Red
REASON: Incorrect key used on the Immobilizer™ equipment to start the engine.
EFFECT: Engine will not start.
ACTION: The proper key must be used on the Immobilizer™ equipment to start the engine.
CODE: 292
LAMP: None
REASON: Coolant temperature has exceeded the Leyland/DAF specification.
EFFECT: Possible engine derate.
ACTION: Verify fluid level is within specification and OEM specification for coolant temperature.
CODE: 319
LAMP: Maintenance
REASON: Real-time clock lost power. Unswitched battery power to the electronic control module (ECM) has been interrupted.
EFFECT: None on performance. Data in the ECM possibly will not have accurate time and date information.
ACTION: Check real-time clock with electronic service tool or RoadRelay™ 4 and set if incorrect.
CODE: 418
LAMP: Maintenance
REASON: Water in fuel detected.
EFFECT: Fuel system damage possible.
ACTION: Drain water from fuel filter.
CODE: 2295
LAMP: None
REASON: ECM temperature out of specifications.
EFFECT: No effect on engine performance. The ECM can not be recalibrated above 75°C (167°F).
ACTION: Wait for the ECM to cool below 75°C (167°F) to recalibrate the ECM.

Last Modified: 01-Jul-2004


Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 5 inactive counts
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the ECM.

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1A - Check the ECM.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM.

  • Turn keyswitch OFF and wait 30 seconds.
  • Start the engine and idle for 1 minute.
OK NOT OK

Fault Code 111 inactive

Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 2A

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Read the inactive counts of Fault Code 111 using INSITE™.
OK NOT OK

Less than 5 inactive counts

Replace the ECM. Refer to Procedure 019-031.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 111 is inactive.
OK NOT OK

Fault Code 111 inactive

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-Oct-2010


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are inactive or not present?
STEP 2. | Check the intake manifold pressure/temperature sensor. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 122 active?
 | STEP 2C. Check the resistance of the intake manifold pressure/temperature sensor. | 10 ohms?
 | STEP 2D. Measure supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2E. Measure the signal voltage. | 0.10 to 0.25-VDC?
 | STEP 2F. Check the supply voltage at the engine harness sensor connector to the battery negative (-) post. | 4.75 to 5.25-VDC?
 | STEP 2G. Check the return resistance at the engine harness sensor connector to the battery negative (-) post. | Less than 10 ohms?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 122 or any other fault codes increase in count or go active?
 | STEP 3C. Read the fault codes. | Fault Code 122 active?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check the resistance from the ECM to the battery negative (-) post. | Less than 10 ohms?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the signal voltage from the ECM to the battery negative (-) post. | 0.10 to 0.25-VDC?
 | STEP 4B. Measure the supply voltage from the ECM. | 4.75 to 5.25-VDC?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are inactive or not present

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check the intake manifold pressure/temperature sensor.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the intake manifold pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active

Fault Code 122 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check the resistance of the intake manifold pressure/temperature sensor.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness connector.

Action

Check the resistance of the intake manifold pressure/temperature sensor.

  • Measure the resistance from pin 3 to pin 4 of the intake manifold pressure/temperature sensor.
OK NOT OK

10 to 10M ohms

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19..

Go to 2D

Go to 5A

Guided Step 2D - Measure the supply voltage.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the supply voltage.

  • Measure the supply voltage from pin 1 to pin 3 of the engine harness sensor connector.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 2E

Go to 2F

Guided Step 2E - Measure the signal voltage.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the signal voltage.

  • Measure the signal voltage from pin 4 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

0.10 to 0.25 VDC

Does not meet specifications.

Go to 3A

Go to 4A

Guided Step 2F - Check the supply voltage at the engine harness sensor connector to the battery negative (-) post.

Conditions

  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage at the engine harness sensor connector to the battery negative (-) post.

  • Measure the voltage from pin 3 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 2G

Go to 4B

Guided Step 2G - Check the return resistance at the engine harness sensor connector to the battery negative (-) post.

Conditions

  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the return resistance at the engine harness sensor connector to the battery negative (-) post.

  • Measure the resistance from pin 1 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

Less than 10 ohms

Go to 5A

Go to 3A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to monitor the fault codes while shaking the engine harness at the intake manifold pressure/temperature sensor and ECM connectors.
OK NOT OK

Fault Code 122 or any other fault codes increase in count or go active. Repair or replace the particular connector that allowed the fault to increase while shaking the engine harness because the connector has failed.

Fault Code 122 or any other fault codes did not increase in count or go active.

Go to 5B

Go to 5B

Guided Step 3C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 122 active

Fault Code 122 inactive.

Go to 3D

Go to 5B

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure the resistance from pin 21 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure the resistance from pin 28 of the engine harness 36-pin connector to pin 4 of the sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-214 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-216 in Section 19.
  • Replace the OEM harness.Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 3E

Guided Step 3E - Check the resistance from the ECM to the battery negative (-) post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check the resistance from the ECM to the battery negative (-) post.

  • Measure the resistance from pin 21 of the ECM port to the battery negative (-) post.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check signal voltage from the ECM to the battery negative (-) post.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check signal voltage from the ECM to the battery negative (-) post.

  • Measure the voltage from pin 28 of the ECM port to the battery negative (-) post.
OK NOT OK

0.10 to 0.25 VDC. Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 5A

Go to 5A

Guided Step 4B - Measure the supply voltage from the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage from pin 10 to pin 21 of the ECM port.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 3A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 122 is inactive.
OK NOT OK

Fault Code 122 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Apr-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are inactive or not present?
STEP 2. | Check the intake manifold pressure/temperature sensor. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 123 active?
 | STEP 2C. Check the resistance of the intake manifold pressure/temperature sensor. | 10 to 10M ohms?
 | STEP 2D. Measure the supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2E. Measure the signal voltage. | 0.10 to 0.25-VDC?
 | STEP 2F. Check the supply voltage at the engine harness sensor connector to the battery negative (-) post. | 4.75 to 5.25-VDC?
 | STEP 2G. Check return resistance at the engine harness sensor connector to the battery negative (-) post. | Less than 10 ohms?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 123 or any other fault codes increase in count or go active?
 | STEP 3C. Read the fault codes. | Fault Code 123 active
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check the resistance from the ECM to the battery negative (-) post. | Less than 10 ohms?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the signal voltage from the ECM to the battery negative (-) post. | 0.10 to 0.25-VDC?
 | STEP 4B. Measure the supply voltage from the ECM. | 4.75 to 5.25-VDC?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are inactive or not present

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check the intake manifold pressure/temperature sensor.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the intake manifold pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19. Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 active

Fault Code 123 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check the resistance of the intake manifold pressure/temperature sensor.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness connector.

Action

Check the resistance of the intake manifold pressure/temperature sensor.

  • Measure the resistance from pin 3 to pin 4 of the intake manifold pressure/temperature sensor.
OK NOT OK

10 to 10M ohms

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19..

Go to 2D

Go to 5A

Guided Step 2D - Measure the supply voltage.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the supply voltage.

  • Measure the supply voltage from pin 1 to pin 3 of the engine harness sensor connector.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 2E

Go to 2F

Guided Step 2E - Measure the signal voltage.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the signal voltage.

  • Measure the signal voltage from pin 4 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

0.10 to 0.25 VDC

Does not meet specifications.

Go to 3A

Go to 4A

Guided Step 2F - Check the supply voltage at the engine harness sensor connector to the battery negative (-) post.

Conditions

  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage at the engine harness sensor connector to the battery negative (-) post.

  • Measure the voltage from pin 3 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

4.75 to 5.25 VDC

Does not meet specifications.

Go to 2G

Go to 4B

Guided Step 2G - Check the return resistance at the engine harness sensor connector to the battery negative (-) post.

Conditions

  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the return resistance at the engine harness sensor connector to the battery negative (-) post.

  • Measure the resistance from pin 1 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

Less than 10 ohms

Go to 5A

Go to 3A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to monitor the fault codes while shaking the engine harness at the intake manifold pressure/temperature sensor and ECM connectors.
OK NOT OK

Fault Code 123 or any other fault codes increase in count or go active. Repair or replace the particular connector that allowed the fault to increase while shaking the engine harness because the connector has failed.

Fault Code 123 or any other fault codes did not increase in count or go active.

Go to 5B

Go to 5B

Guided Step 3C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 123 active

Fault Code 123 inactive.

Go to 3D

Go to 5B

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure the resistance from pin 21 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure the resistance from pin 28 of the engine harness 36-pin connector to pin 4 of the sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19. Refer to Procedure 019-214 in Section 19. Refer to Procedure 019-216 in Section 19.
  • Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 3E

Guided Step 3E - Check the resistance from the ECM to the battery negative (-) post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check the resistance from the ECM to the battery negative (-) post.

  • Measure the resistance from pin 21 of the ECM port to the battery negative (-) post.
OK NOT OK

Less than 10 ohms

Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the signal voltage from the ECM to the battery negative (-) post.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check the signal voltage from the ECM to the battery negative (-) post.

  • Measure the voltage from pin 28 of the ECM port to the battery negative (-) post.
OK NOT OK

0.10 to 0.25 VDC.

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 4B - Measure the supply voltage from the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage from pin 10 to pin 21 of the ECM port.
OK NOT OK

4.75 to 5.25 VDC.

Replace the ECM. Refer to Procedure 019-031 in Section 19..

Go to 3A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 123 is inactive.
OK NOT OK

Fault Code 123 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the inactive fault codes.
OK NOT OK

All faults codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-May-2012


FAULT CODE 153 - Intake Manifold Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164113 - Bosch® .6 socket test lead, Part Number 3823995 - Weather-Pack™ pin test lead and Part Number 3823996 - Weather-Pack™ socket test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Verify that the accelerator position sensor is connected. | Sensor connected?
 | STEP 1B. Inspect the OEM harness and accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 1C. Read the fault codes. | Fault Code 131 active?
 | STEP 1D. Check the accelerator position sensor resistance. | 2000 to 3000 ohms?
 | STEP 1E. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms. Depressed: 250 to 1500 ohms?
 | STEP 1F. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 131 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check for the ECM response. |
 | STEP 3A. Measure the voltage out of the ECM. | 4.75 to 5.25-VDC?
 | STEP 3B. Check for appropriate ECM response. | Fault Code 131 inactive and/or Fault code 132 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Verify that the accelerator position sensor is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the accelerator position sensor is connected.
OK NOT OK

Sensor connected?

Connect the accelerator position sensor.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the OEM harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the accelerator position sensor, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 131 active?

Repair complete.

Go to 1D

Go to 4B

Guided Step 1D - Check the accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the +5-VDC SUPPLY pin and the RETURN pin on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

2000 to 3000 ohms?

Replace the accelerator position sensor. Use the OEM troubleshooting and repair manual.

Go to 1E

Go to 4A

Guided Step 1E - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

  • Measure the resistance between the +5-VDC SUPPLY pin and SIGNAL pin on the sensor side of the accelerator position sensor.

Take the measurement when the pedal is depressed and released.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

Released: 1500 to 3000 ohms. Depressed: 250 to 1500 ohms?

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor. Use the OEM troubleshooting and repair manual.

Go to 1F

Go to 4A

Guided Step 1F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the +5-VDC SUPPLY pin on the sensor side of the accelerator position sensor to chassis ground.
  • Measure the resistance from the SIGNAL pin on the sensor side of the accelerator position sensor to chassis ground.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

Greater than 100k ohms?

Replace the accelerator position sensor. Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 131 active

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 55 of the OEM harness connector to pin C (pin A) on the harness side of the accelerator position sensor.
  • Measure the resistance from pin 81 of the OEM harness connector to pin A (pin C) on the harness side of the accelerator position sensor.
  • Measure the resistance from pin 83 of the OEM harness connector to pin B (pin B) on the harness side of the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch and letters shown in parentheses are for pedals with separate idle validation and accelerator sensors.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-214 in Section 19. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 55 to all other pins in the OEM harness connector.
  • Measure the resistance from pin 81 to all other pins in the OEM harness connector.
  • Measure the resistance from pin 83 to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for the ECM response.

Guided Step 3A - Measure the voltage out of the ECM.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage out of the ECM from pin 55 to pin 81.
OK NOT OK

4.75 to 5.25 VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness sensor connector from the accelerator position sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 131 inactive and/or Fault Code 132 active?

Fault Code 131 active?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 131 is inactive.
OK NOT OK

Fault Code 131 inactive

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tools to clear the fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-May-2012


FAULT CODE 131 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Verify that the accelerator position sensor is connected. | Sensor connected?
 | STEP 1B. Inspect the OEM harness and accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 1C. Read the fault codes. | Fault Code 132 active?
 | STEP 1D. Check the accelerator position sensor resistance. | 2000 to 3000 ohms?
 | STEP 1E. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms. Depressed: 250 to 1500 ohms?
 | STEP 1F. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 132 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short to engine block ground. | Greater than 100k ohms?
STEP 3. | Check for the ECM response. |
 | STEP 3A. Measure the voltage out of the ECM. | 4.75 to 5.25-VDC?
 | STEP 3B. Check for appropriate ECM response. | Fault Code 132 inactive and /or Fault Code 131 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Verify that the accelerator position sensor is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the accelerator position sensor is connected.
OK NOT OK

Sensor connected?

Connect the accelerator position sensor.

Go to 1B

Go to 4A

Guided Step 1B - Inspect the OEM harness and accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the OEM harness and accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the accelerator position sensor, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the accelerator position sensor. Refer to OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 132 active?

Repair complete.

Go to 1D

Go to 4B

Guided Step 1D - Check the accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the accelerator position sensor.

  • Measure the resistance between the +5-VDC SUPPLY pin and the RETURN pin on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

2000 to 3000 ohms?

Replace the accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1E

Go to 4A

Guided Step 1E - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

  • Measure the resistance between the +5-VDC SUPPLY pin and the SIGNAL pin on the sensor side of the accelerator position sensor.

Take the measurement when the pedal is depressed and released.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

Released: 1500 to 3000 ohms?

Depressed: 250 to 1500 ohms?

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1F

Go to 4A

Guided Step 1F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the +5-VDC SUPPLY pin on the sensor side of the accelerator position sensor to chassis ground.
  • Measure the resistance from the SIGNAL pin on the sensor side of the accelerator position sensor to chassis ground.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

Greater than 100k ohms?

Replace the accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 132 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 55 of the OEM harness connector to pin C (pin A) on the harness side of the accelerator position sensor.
  • Measure the resistance from pin 81 of the OEM harness connector to pin A (pin C) on the harness side of the accelerator position sensor.
  • Measure the resistance from pin 83 of the OEM harness connector to pin B (pin B) on the harness side of the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch, and letters shown in parentheses are for pedals with separate idle validation and accelerator sensors.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-214 in Section 19. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 55 to all other pins in the OEM harness connector.
  • Measure the resistance from pin 81 to all other pins in the OEM harness connector.
  • Measure the resistance from pin 83 to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 55 on the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 81 on the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 83 on the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for the ECM response.

Guided Step 3A - Measure the voltage out of the ECM.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage out of the ECM from pin 55 to pin 81.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3164113 as a jumper wire between pin 83 and pin 55 at the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 132 inactive and/or Fault Code 131 active?

Fault Code 132 active. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 132 is inactive.
OK NOT OK

Fault Code 132 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-Jun-2012


FAULT CODE 133 - Remote Accelerator Position - High

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.
CAUTION

For OEM-supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are inactive?
STEP 2. | Check the remote accelerator position sensor. |
 | STEP 2A. Verify that the remote accelerator position sensor is connected. | Sensor connected?
 | STEP 2B. Inspect the OEM harness and remote accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 2C. Read the fault codes. | Fault Code 133 active?
 | STEP 2D. Check the remote accelerator position sensor resistance. | 2000 to 3000 ohms?
 | STEP 2E. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms Depressed: 250 to 1500 ohms?
 | STEP 2F. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 133 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check for the ECM response. |
 | STEP 4A. Measure the voltage out of the ECM. | 4.75 to 5.25-VDC?
 | STEP 4B. Check for appropriate ECM response. | Fault Code 133 inactive and Fault Code 134 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 133 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the active fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 5A

Guided Step 2 - Check the remote accelerator position sensor.

Guided Step 2A - Verify that the remote accelerator position sensor is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the remote accelerator position sensor is connected.
OK NOT OK

Sensor connected?

Connect the remote accelerator position sensor.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the OEM harness and remote accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Inspect the OEM harness and remote accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the accelerator position sensor, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-214 in Section 19, Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the active fault codes.
OK NOT OK

Fault Code 133 active?

Repair complete.

Go to 2D

Go to 5B

Guided Step 2D - Check the remote accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Check for an open or short circuit between pins in the remote accelerator position sensor.

  • Measure the resistance between the +5-VDC SUPPLY pin and the RETURN pin on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

2000 to 3000 ohms?

Replace the remote accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

Guided Step 2E - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Check the resistance between sensor pins.

  • Measure the resistance between the +5-VDC supply pin and the signal pin on the sensor side of the accelerator position sensor.

Take the measurement when the pedal is depressed and released.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch a 6-pin repair connector, Part Number 3824910, for integrated sensor switch and the breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

Released: 1500 to 3000 ohms.

Depressed: 250 to 1500 ohms

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the remote accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2F

Go to 4A

Guided Step 2F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the +5-VDC SUPPLY pin on the sensor side of the accelerator position sensor to chassis ground.
  • Measure the resistance from the SIGNAL pin on the sensor side of the accelerator position sensor to chassis ground.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

Greater than 100k ohms?

Replace the remote accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 133 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 50 of the OEM harness connector to pin B on the harness side of the remote accelerator position sensor.
  • Measure the resistance from pin 68 of the OEM harness connector to pin A on the harness side of the remote accelerator position sensor.
  • Measure the resistance from pin 85 of the OEM harness connector to pin C on the harness side of the remote accelerator position sensor.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19, Refer to Procedure 019-202 in Section 19, Refer to Procedure 019-214 in Section 19, Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 50 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 68 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 85 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

Guided Step 4A - Measure the voltage out of the ECM.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage out of the ECM from pin 50 to pin 68.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 133 inactive Fault Code 134 active

Fault Code 133 active. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 133 is inactive.
OK NOT OK

Fault Code 133 inactive?

Return to troubleshooting steps, or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete?

Appropriate troubleshooting charts

Last Modified: 01-Jun-2012


FAULT CODE 134 - Remote Accelerator Position - Low

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, and Part Number 3164113 - Bosch® .6 socket test lead.
CAUTION

For OEM-supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the remote accelerator position sensor. |
 | STEP 2A. Verify that the remote accelerator position sensor is connected. | Sensor connected?
 | STEP 2B. Inspect the OEM harness and remote accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 2C. Read the fault codes. | Fault Code 134 active?
 | STEP 2D. Check the remote accelerator position sensor resistance. | 2000 to 3000 ohms?
 | STEP 2E. Check the resistance between sensor pins. | Released: 1500 to 3000 ohms? Depressed: 250 to 1500 ohms?
 | STEP 2F. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 134 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check for the ECM response. |
 | STEP 4A. Measure the voltage out of the ECM. | 4.75 to 5.25-VDC?
 | STEP 4B. Check for appropriate ECM response. | Fault Code 133 inactive and Fault Code 134 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 134 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 5A

Guided Step 2 - Check the remote accelerator position sensor.

Guided Step 2A - Verify that the remote accelerator position sensor is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the remote accelerator position sensor is connected.

Verify that the remote accelerator position sensor is connected.
OK NOT OK

Sensor connected?

Connect the remote accelerator position sensor.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the OEM harness and remote accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Inspect the OEM harness and remote accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the remote accelerator position sensor, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the remote accelerator position sensor. Refer to OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 134 active?

Repair complete.

Go to 2D

Go to 5B

Guided Step 2D - Check the remote accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Check for an open or short circuit between pins in the remote accelerator position sensor.

  • Measure the resistance between the +5-VDC SUPPLY pin and the RETURN pin on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

2000 to 3000 ohms?

Replace the remote accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2E

Go to 4A

Guided Step 2E - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Check the resistance between sensor pins.

  • Measure the resistance between the +5-VDC SUPPLY pin and the SIGNAL pin on the sensor side of the accelerator position sensor.

Take the measurement when the pedal is depressed and released.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

Released: 1500 to 3000 ohms?

Depressed: 250 to 1500 ohms?

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the remote accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2F

Go to 4A

Guided Step 2F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the +5-VDC SUPPLY pin on the sensor side of the accelerator position sensor to chassis ground.
  • Measure the resistance from the SIGNAL pin on the sensor side of the accelerator position sensor to chassis ground.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for idle validation switch; a 6-pin repair connector, Part Number 3824910, for integrated sensor switch; and a breakout cable, Part Number 3824892, for solid state integrated sensor switch if needed.

OK NOT OK

Greater than 100k ohms?

Replace the remote accelerator position sensor. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the remote accelerator position sensor.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 134 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 50 of the OEM harness connector to pin B on the harness side of the remote accelerator position sensor.
  • Measure the resistance from pin 68 of the OEM harness connector to pin A on the harness side of the remote accelerator position sensor.
  • Measure the resistance from pin 85 of the OEM harness connector to pin C on the harness side of the remote accelerator position sensor.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 inb Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the remote accelerator position sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 50 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 68 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 85 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

Guided Step 4A - Measure the voltage out of the ECM.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage out of the ECM from pin 50 to pin 68.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for appropriate ECM response.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install Part Number 3164113 as a jumper wire from pin 50 to 68 at the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 133 inactive?

Fault Code 134 active?

Fault Code 133 active. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 134 is inactive.
OK NOT OK

Fault Code 134 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 135 - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are inactive or not present?
STEP 2. | Check the oil pressure/temperature sensor. |
 | STEP 2A. Inspect the oil pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 135 active?
 | STEP 2C. Check the resistance of the oil pressure/temperature sensor. | 10 to 10M ohms?
 | STEP 2D. Measure the supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2E. Measure the signal voltage. | 0.10 to 0.25-VDC?
 | STEP 2F. Check the supply voltage at the engine harness sensor connector to the battery negative (-) post. | 4.75 to 5.25-VDC?
 | STEP 2G. Check the return resistance at the engine harness sensor connector to the battery negative (-) post. | Less than 10 ohms?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 135 or any other fault codes increase in count or go active?
 | STEP 3C. Read the fault codes. | Fault Code 135 active?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check the resistance from the ECM to the battery negative (-) post. | Less than 10 ohms?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the signal voltage from the ECM to the battery negative (-) post. | 0.10 to 0.25-VDC?
 | STEP 4B. Measure the supply voltage from the ECM. | 4.75 to 5.25-VDC?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are inactive or not present?

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check the oil pressure/temperature sensor.

Guided Step 2A - Inspect the oil pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the oil pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 active?

Fault Code 135 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check resistance of the oil pressure/temperature sensor.

Conditions

  • Disconnect the oil pressure/temperature sensor from the engine harness connector.

Action

Check the resistance of the oil pressure/temperature sensor.

  • Measure the resistance from pin 3 to pin 4 of the oil pressure/temperature sensor.
OK NOT OK

10 to 10M ohms?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Measure the supply voltage.

Conditions

  • Disconnect the oil pressure/temperature sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the supply voltage.

  • Measure the supply voltage from pin 1 to pin 3 of the engine harness sensor connector.
OK NOT OK

4.75 to 5.25-VDC?

Does not meet specifications.

Go to 2E

Go to 2F

Guided Step 2E - Measure the signal voltage.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the signal voltage.

  • Measure the signal voltage from pin 4 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

0.10 to 0.25-VDC?

Does not meet specifications.

Go to 3A

Go to 4A

Guided Step 2F - Check supply voltage at the engine harness sensor connector to the battery negative (-) post.

Conditions

  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage at the engine harness sensor connector to the battery negative (-) post.

  • Measure the voltage from pin 3 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

4.75 to 5.25-VDC?

Does not meet specifications.

Go to 2G

Go to 4B

Guided Step 2G - Check return resistance at the engine harness sensor connector to the battery negative (-) post.

Conditions

  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the return resistance at the engine harness sensor connector to the battery negative (-) post.

  • Measure resistance from pin 1 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

Less than 10 ohms?

Go to 5A

Go to 3A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Monitor the fault codes using INSITE™ electronic service tool while shaking the engine harness at the oil pressure/temperature sensor and ECM connectors.
OK NOT OK

Fault Code 135 or any other fault codes increase in count or go active. Repair or replace the particular connector that allowed the fault to increase while shaking the engine harness because the connector has failed.

Fault Code 135 or any other fault codes did not increase in count or go active.

Go to 5B

Go to 5B

Guided Step 3C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 135 active?

Fault Code 135 inactive.

Go to 3D

Go to 5B

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check for an open circuit.

  • Measure resistance from pin 9 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure resistance from pin 19 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure resistance from pin 33 of the engine harness 36-pin connector to pin 4 of the sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the OEM harness.Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 3E

Guided Step 3E - Check the resistance from the ECM to the battery negative (-) post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check the resistance from the ECM to the battery negative (-) post.

  • Measure the voltage from pin 19 at the ECM to the battery negative (-) post.
OK NOT OK

Less than 10 ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the signal voltage from the ECM to the battery negative (-) post.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check the signal voltage from the ECM to the battery negative (-) post.

  • Measure the voltage from pin 33 at the ECM to the battery negative (-) post.
OK NOT OK

0.10 to 0.25-VDC?

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 4B - Measure the supply voltage from the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage from pin 9 to pin 19 at the ECM.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 135 is inactive.
OK NOT OK

Fault Code 135 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 141 - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are inactive or not present?
STEP 2. | Check the oil pressure/temperature sensor. |
 | STEP 2A. Inspect the oil pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 141 active?
 | STEP 2C. Check the resistance of the oil pressure/temperature sensor. | 10 to 10M ohms?
 | STEP 2D. Measure the supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2E. Measure the signal voltage. | 0.10 to 0.25-VDC?
 | STEP 2F. Check the supply voltage at the engine harness sensor connector to the battery negative (-) post. | 4.75 to 5.25-VDC?
 | STEP 2G. Check the return resistance at the engine harness sensor connector to the battery negative (-) post. | Less than 10 ohms?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 141 or any other fault codes increase in count or go active?
 | STEP 3C. Read the fault codes. | Fault Code 141 active?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check resistance from the ECM to the battery (-) post. | Less than 10 ohms?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the signal voltage from the ECM to the battery negative (-) post. | 0.10 to 0.25-VDC?
 | STEP 4B. Measure the supply voltage from the ECM. | 4.75 to 5.25-VDC?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are inactive or not present?

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check the oil pressure/temperature sensor.

Guided Step 2A - Inspect the oil pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the oil pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 active?

Fault Code 141 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check resistance of the oil pressure/temperature sensor.

Conditions

  • Disconnect the oil pressure/temperature sensor from the engine harness connector.

Action

Check the resistance of the oil pressure/temperature sensor.

  • Measure the resistance from pin 3 to pin 4 of the oil pressure/temperature sensor.
OK NOT OK

10 to 10M ohms?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Measure the supply voltage.

Conditions

  • Disconnect the oil pressure/temperature sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the supply voltage.

  • Measure the supply voltage from pin 1 to pin 3 of the engine harness sensor connector.
OK NOT OK

4.75 to 5.25-VDC?

Does not meet specifications.

Go to 2E

Go to 2F

Guided Step 2E - Measure the signal voltage.

Conditions

  • Disconnect the oil pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the signal voltage.

  • Measure the signal voltage from pin 4 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

0.10 to 0.25-VDC?

Does not meet specifications.

Go to 3A

Go to 4A

Guided Step 2F - Check the supply voltage at the engine harness sensor connector to the battery negative (-) post.

Conditions

  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage at the engine harness sensor connector to the battery negative (-) post.

  • Measure the voltage from pin 3 of the engine harness sensor connector to the battery (-) post.
OK NOT OK

4.75 to 5.25-VDC?

Does not meet specifications.

Go to 2G

Go to 4B

Guided Step 2G - Check the return resistance at the engine harness sensor connector to the battery negative (-) post.

Conditions

  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check the return resistance at the engine harness sensor connector to the battery negative (-) post.

  • Measure the resistance from pin 1 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

Less than 10 ohms?

Go to 5A

Go to 3A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Monitor the fault codes using INSITE™ electronic service tool while shaking the engine harness at the oil pressure/temperature sensor and ECM connectors.
OK NOT OK

Fault Code 141 or any other fault codes increase in count or go active. Repair or replace the particular connector that allowed the fault to increase while shaking the engine harness because the connector has failed.

Fault Code 141 or any other fault codes did not increase in count or go active.

Go to 5B

Go to 5B

Guided Step 3C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 141 active?

Fault Code 141 inactive.

Go to 3D

Go to 5B

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check for an open circuit.

  • Measure resistance from pin 9 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure resistance from pin 19 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure resistance from pin 33 of the engine harness 36-pin connector to pin 4 of the sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 3E

Guided Step 3E - Check the resistance from the ECM to the battery negative (-) post.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check the resistance from the ECM to the battery negative (-) post.

  • Measure the voltage from pin 19 at the ECM to the battery negative (-) post.
OK NOT OK

Less than 10 ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the signal voltage from the ECM to the battery negative (-) post.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check the signal voltage from the ECM to the battery negative (-) post.

  • Measure the voltage from pin 33 at the ECM to the battery negative (-) post.
OK NOT OK

0.10 to 0.25-VDC?

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 4B - Measure the supply voltage from the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage from pin 9 to pin 19 at the ECM.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 141 is inactive.
OK NOT OK

Fault Code 141 inactive?

Return to troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 141 - Oil Pressure Switch Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - male ISBe (4 and 6 cylinder) amp test lead and Part Number 3164112 - male ISBe (4 and 6 cylinder) amp test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 352 and 386 inactive?
STEP 2. | Check the oil pressure switch. |
 | STEP 2A. Inspect the engine harness and oil pressure switch connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check the supply voltage at the oil pressure connector. | 4.75 to 5.25-VDC?
 | STEP 3E. Check the supply voltage at the ECM. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use the INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 352 and 386 inactive?

Possible sensor failure, a short circuit to ground in the sensor +5 VDC common SUPPLY, or a short circuit from pin to pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check the oil pressure switch.

Guided Step 2A - Inspect the oil pressure switch and the oil pressure switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.

Action

Inspect the oil pressure switch and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the oil pressure switch or the engine harness, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure switch.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure resistance from pin 9 of the engine harness connector to pin 2 of the oil pressure switch connector.
  • Measure resistance from pin 15 of the engine harness connector to pin 1 of the oil pressure switch connector.
OK NOT OK

Less than 10 ohms?

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pins 9 and 15 of the engine harness connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater then 100k ohms?

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the supply voltage at the oil pressure connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil pressure SIGNAL pin 2 at the switch connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.
OK NOT OK

4.75 to 5.25-VDC?

Go to 4A

Go to 3E

Guided Step 3E - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the supply voltage at the ECM.

  • Measure the voltage between the engine oil pressure SIGNAL pin 9 at the engine harness ECM connector port and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 141 is inactive.
  • Turn keyswitch to the OFF position.
OK NOT OK

Fault Code 141 inactive?

Return to troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 143 - Oil Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Check the oil fluid level. | Fluid filled to specification?
 | STEP 1B. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Check the oil fluid level.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil fluid level.

Check the oil fluid level.
OK NOT OK

Oil fluid filled to specifications

Oil fluid low. Fill to correct specifications.

Go to 1B

Go to 2A

Guided Step 1B - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ to vehicle datalink.
  • Start the engine, and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge.

If necessary, operate the engine at a higher rpm to clarify differences in the readings.
OK NOT OK

Sensor reading is correct?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 143 is inactive.

If the fault code occurred at a particular speed, operate the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 143 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2012


FAULT CODE 143 - Oil Pressure - Engine Protection With an Oil Pressure Switch

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the switch accuracy with a mechanical gauge. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 143 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the switch accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the switch accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect the INSITE™ electronic service tool to vehicle data link.

The switch will display 379.9 kPa [55.1 psi] in the INSITE™ electronic service tool if it detects actual oil pressure above 41 kPa [6 psi].

OK NOT OK

The switch is detecting pressure.

ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Fault Code 141 active?

Go to 2A

Fault Code 141

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 143 is inactive.

If the fault code occurred at a particular speed, operate the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 143 inactive?

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2012


FAULT CODE 144 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50° C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the engine harness and coolant temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 144 active?
 | STEP 2C. Check the resistance of the coolant temperature sensor. | 50 to 10k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 144 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 144 inactive and Fault Code 145 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine harness and coolant temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the engine harness and coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 144 active?

Fault Code 144 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the coolant temperature sensor.
OK NOT OK

50 to 10k ohms?

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 144 active?

Fault Code 144 inactive.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness 36-pin connector to pin 1 on the harness side of the coolant temperature sensor.
  • Measure the resistance from pin 36 of the engine harness 36-pin connector to pin 2 on the harness side of the coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 18 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 36 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 18 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 36 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the coolant temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 144 inactive and Fault Code 145 active?

Fault Code 144 active?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 144 is inactive.
OK NOT OK

Fault Code 144 inactive?

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 145 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50° C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the engine harness and coolant temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 145 active?
 | STEP 2C. Check the resistance of the coolant temperature sensor. | 50 to 10k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 145 inactive?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 145 inactive and Fault Code 144 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine harness and coolant temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the engine harness and the coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 active?

Fault Code 144 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the coolant temperature sensor.
OK NOT OK

50 to 10k ohms?

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 active?

Fault Code 145 inactive.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 18 of the engine harness 36-pin connector to pin 1 on the harness side of the coolant temperature sensor.
  • Measure the resistance from pin 36 of the engine harness 36-pin connector to pin 2 on the harness side of the coolant temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 18 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 36 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 18 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 36 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Short the SIGNAL pin 2 of the engine harness sensor connector to +5-VDC.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 145 inactive and Fault Code 144 active?

Fault Code 145 active.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 145 is inactive.
OK NOT OK

Fault Code 145 inactive?

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 146 - Coolant Temperature - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 146 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ to the vehicle data link.
  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer "OK" to this step.

OK NOT OK

Sensor reading is correct?

Use the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Sensor reading incorrect?

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 146 is inactive.
OK NOT OK

Fault Code 146 inactive?

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 151 - Coolant Temperature - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 151 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

If temperature measuring device is not available, answer “OK” to this step.

OK NOT OK

Sensor reading is correct?

Use the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Sensor reading incorrect?

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 151 is inactive.
OK NOT OK

Fault Code 151 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164110 - Bosch® 2.8 pin test lead (blade)Part Number 3164112 - Bosch® .6 pin test leadPart Number 3164111 - Bosch® 2.8 socket test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3164111 - Bosch® 2.8 socket test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164110 - Bosch® 2.8 pin test lead (blade)Part Number 3164112 - Bosch® .6 pin test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3164112 - Bosch® .6 pin test lead.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3164110 - Bosch® 2.8 pin test lead (blade)Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active
STEP 2. | Check the intake manifold pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and intake manifold pressure/temperature sensor connector pins. | No damaged pins
 | STEP 2B. Read the fault codes. | Fault Code 153 active
 | STEP 2C. Check the resistance of the intake manifold pressure/temperature sensor. | 50 to 10k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 3B. Read the fault codes. | Fault Code 153 active
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | More than 100k ohms
 | STEP 3E. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 153 inactive. Fault Code 154 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, and 386 are not active

Troubleshoot Fault Code 187, 227, 238, 239, 352, or 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the intake manifold pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and intake manifold pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the engine harness and intake manifold pressure/temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 Refer to Procedure 019-202 Refer to Procedure 019-205 Refer to Procedure 019-214.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 153 active

Fault Code 153 inactive

Go to 2C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3164111 - Bosch® 2.8 socket test lead.
Guided Step 2C - Check the resistance of the intake manifold pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check the resistance of the intake manifold pressure/temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the intake manifold pressure/temperature sensor.
OK NOT OK

50 to 10k ohms

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Gently pull on each wire to verify that it is locked in the connector and not a pushed back pin.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 153 active

Fault Code 153 inactive

Go to 3C

Go to 4B

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164110 - Bosch® 2.8 pin test lead (blade)Part Number 3164112 - Bosch® .6 pin test lead.
Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 of the 36-pin connector to pin 1 on the harness side of the intake manifold pressure/temperature sensor.
  • Measure the resistance from pin 29 of the 36-pin connector to pin 2 on the harness side of the intake manifold pressure/temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 Refer to Procedure 019-202 Refer to Procedure 019-205 Refer to Procedure 019-214 Refer to Procedure 019-216.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3164112 - Bosch® .6 pin test lead.
Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 21 of the 36-pin connector to engine block ground.
  • Measure the resistance from pin 29 of the 36-pin connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3E

Go to 4A

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3164110 - Bosch® 2.8 pin test lead (blade)Part Number 3164112 - Bosch® .6 pin test lead.
Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 21 of the 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 29 of the 36-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3F

Go to 4A

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Code 153 inactive. Fault Code 154 active

Fault Code 153 active. Replace the ECM. Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 153 is inactive.
OK NOT OK

Fault Code 153 inactive

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 26-Oct-2010


FAULT CODE 154 - Intake Manifold Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the intake manifold pressure/temperature sensor. |
 | STEP 2A. Inspect the engine harness and intake manifold pressure/temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 154 active?
 | STEP 2C. Check the resistance of the intake manifold pressure/temperature sensor. | 50 to 10k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | No damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 154 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 154 inactive and/or Fault Code 153 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the intake manifold pressure/temperature sensor.

Guided Step 2A - Inspect the engine harness and intake manifold pressure/temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the engine harness and the intake manifold pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19. Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 154 active?

Fault Code 154 inactive?

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the intake manifold pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check the resistance of the intake manifold pressure/temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the intake manifold pressure/temperature sensor.
OK NOT OK

50 to 10k ohms?

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 154 active?

Fault Code 154 inactive?

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 21 of the engine harness 36-pin connector to pin 1 on the harness side of the intake manifold pressure/temperature sensor.
  • Measure the resistance from pin 29 of the engine harness 36-pin connector to pin 2 on the harness side of the intake manifold pressure/temperature sensor connector.
OK NOT OK

Less than 10 ohms>

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19. Refer to Procedure 019-214 in Section 19. Refer to Procedure 019-216 in Section 19. .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 21 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 29 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 21 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 29 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Short the SIGNAL pin 2 of the engine harness sensor connector to +5-VDC.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 154 inactive and/or Fault Code 153 active?

Fault Code 154 active. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 154 is inactive.
OK NOT OK

Fault Code 154 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-May-2012


FAULT CODE 155 - Intake Manifold Pressure/Temperature Sensor - Engine Protection Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 155 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the intake manifold air temperature sensor.
  • Connect INSITE™ electronic service tool to the data link.
  • Run the engine and compare the intake manifold temperature sensor reading on INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer "OK" to this step.

Readings will possibly need to be checked while engine is operating at normal temperature conditions (82.2°C [180°F] coolant).
OK NOT OK

Sensor reading is correct?

Sensor reading incorrect. Replace intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Load and operate engine to typical operating temperature (82.2°C [180°F] coolant).
  • Verify Fault Code 155 is inactive and did not reoccur.
OK NOT OK

Fault Code 155 inactive and did not reoccur?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


FAULT CODE 187 - Sensor Supply B - Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rail pressure sensor. |
 | STEP 1A. Check the fuel rail pressure sensor supply voltage. | Fault Code 187 still active when sensor is removed. Less than 4.5-VDC.?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 187 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check the supply voltage from the ECM. | 4.75 to 5.25-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel rail pressure sensor.

Guided Step 1A - Check the fuel rail pressure sensor supply voltage.

Conditions

  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Turn keyswitch ON.

Action

Check the fuel rail pressure sensor supply voltage.

  • Measure the voltage from pin 3 to pin 1 on the engine harness fuel rail pressure sensor connector.
OK NOT OK

Less than 4.5-VDC?

Replace the rail pressure sensor if the supply voltage is 4.75 to 5.25 with sensor disconnected and the fault code is active with the sensor connected. Refer to Procedure 019-115 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness or connector, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187 active?

Fault Code 187 inactive?

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for an open circuit.

  • Measure resistance from pin 12 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure resistance from pin 20 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure resistance from pin 27 of the engine harness 36-pin connector to pin 2 of the sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19 .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 12 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 20 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 27 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground in the sensor SUPPLY wires.

  • Measure the resistance from pin 12 in the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 20 in the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 27 in the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the supply voltage from the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage from the ECM.

  • Measure the supply voltage out of the ECM from pin 20 to pin 12.
  • Measure the signal voltage out of the ECM from pin 20 to pin 27.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service too to verify Fault Code 187 is inactive.
OK NOT OK

Fault Code 187 inactive?

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 03-Jun-2012


FAULT CODE 197 - Engine Coolant Level - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50° C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 not active?
STEP 2. | Check for coolant level sensor. |
 | STEP 2A. Check vehicle for coolant level sensor. | Coolant level sensor present?
STEP 3. | Verify the coolant is low. |
 | STEP 3A. Check the coolant level. | Coolant level normal?
STEP 4. | Check coolant level sensor. |
 | STEP 4A. Verify fault is still active with engine running. | Fault Code 197 active?
 | STEP 4B. Inspect the coolant level sensor and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Read the fault codes. | Fault Code 197 active?
STEP 5. | Check for shorting plug. |
 | STEP 5A. Check for installed shorting plug. | Shorting plug installed?
STEP 6. | Check the OEM harness. |
 | STEP 6A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 6B. Read the fault codes. | Fault Code 197 active?
 | STEP 6C. Check for an open circuit. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 6E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 7. | Check the ECM response. |
 | STEP 7A. Check the ECM response high. | Fault Code 422 active and Fault Code 197 inactive?
 | STEP 7B. Check the ECM response low. | Fault Code 422 active and Fault Code 197 active?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 197 inactive?
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 not active?

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check for coolant level sensor.

Guided Step 2A - Check vehicle for coolant level sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check vehicle for coolant level sensor.
OK NOT OK

Coolant level sensor present?

Coolant level sensor not present.

Go to 3A

Go to 5A

Guided Step 3 - Verify that the coolant is low.

Guided Step 3A - Check the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check vehicle for coolant level sensor.

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level normal?

Add coolant to radiator

Make sure coolant has proper ratio of antifreeze and water.

Go to 4A

Go to 8A

Guided Step 4 - Check the coolant level sensor.

Guided Step 4A - Verify fault is still active with the engine running.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Verify fault code is still active.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 197 active?

Fault Code 197 inactive.

Go to 4B

Go to 8A

Guided Step 4B - Inspect the coolant level sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Inspect the coolant level sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 4C

Go to 8A

Guided Step 4C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 197 active?

Fault Code 197 inactive.

Go to 5A

Go to 8A

Guided Step 5 - Check for shorting plug.

Guided Step 5A - Check for installed shorting plug.

Conditions

  • Turn keyswitch OFF.

Action

Check for installed shorting plug.
OK NOT OK

Shorting plug installed

Install shorting plug. Refer to Procedure 019-324 in Section 19.

Go to 6A

Go to 8A

Guided Step 6 - Check the OEM harness.

Guided Step 6A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6B

Go to 8A

Guided Step 6B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 197 active?

Fault Code 197 inactive.

Go to 6C

Go to 8A

Guided Step 6C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 59 of the OEM harness connector to pin A of the OEM harness sensor connector.
  • Measure the resistance from pin 78 of the OEM harness connector to pin D of the OEM harness sensor connector.
  • Measure the resistance from pin 50 of the OEM harness connector to pin B of the OEM harness sensor connector.
  • Measure the resistance from pin 68 of the OEM harness connector to pin C of the OEM harness sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6D

Go to 8A

Guided Step 6D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 59 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 78 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 50 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 68 of the OEM harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6E

Go to 8A

Guided Step 6E - Check for a short circuit to engine block ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure resistance from pin 59 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 78 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 50 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 68 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the ECM response.

Guided Step 7A - Check the ECM response high.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check the ECM response high.

  • Install a jumper wire from pin C to pin D at the coolant level sensor connector.
OK NOT OK

Fault Code 422 active Fault Code 197 inactive?

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7B

Go to 8A

Guided Step 7B - Check the ECM response low.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check the ECM response low.

  • Install a jumper wire from pin A to pin C at the coolant level sensor connector.
OK NOT OK

Fault Code 422 active Fault Code 197 active?

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 197 is inactive.
OK NOT OK

Fault Code 197 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tools to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2015


FAULT CODE 198 - Warning Lamp Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the warning lamp. |
 | STEP 1A. Verify the warning lamp is connected to the OEM harness. | Warning lamp connected?
 | STEP 1B. Check supply voltage. | 9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 198 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Measure the voltage from the battery to the ECM. | 9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 198 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the warning lamp.

Guided Step 1A - Verify the warning lamp is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the warning lamp is connected to the OEM harness.
OK NOT OK

Warning lamp connected?

Connect the warning lamp if present. If warning lamp is not present, contact a Cummins Authorized Repair Location.

Go to 1B

Go to 3A

Guided Step 1B - Check the supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the warning lamp from the OEM harness.

Action

Check the warning lamp supply voltage.

  • Measure the supply voltage from pin 1 to pin 2 of the OEM harness warning lamp connector.
OK NOT OK

9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 198 active?

Fault Code 198 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the warning lamp.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 28 of the OEM harness ECM connector to pin 1 of the OEM harness warning lamp connector.
  • Measure the resistance from pin 64 of the OEM harness ECM connector to pin 2 of the OEM harness warning lamp connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the warning lamp.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 28 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 64 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the warning lamp from the OEM harness.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 28 of the OEM harness 89-pin connector to engine block ground.
  • Measure the resistance from pin 64 of the OEM harness 89-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Measure the voltage from the battery to the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Measure the voltage to the ECM.

  • Measure the voltage from pin 1 of the OEM harness connector to engine block ground.
  • Measure the voltage from pin 7 of the OEM harness connector to engine block ground.
  • Measure the voltage from pin 12 of the OEM harness connector to engine block ground.
  • Measure the voltage from pin 13 of the OEM harness connector to engine block ground.
OK NOT OK

9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 198 is inactive.
OK NOT OK

Fault Code 198 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2012


FAULT CODE 212 - Oil Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164111 - Bosch® 2.8 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the oil pressure/temperature sensor. |
 | STEP 2A. Inspect the oil pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 212 active?
 | STEP 2C. Check the resistance of the oil pressure/temperature sensor. | 50 to 10k ohms?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 212 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 212 inactive and Fault Code 213 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 212 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the oil pressure/temperature sensor.

Guided Step 2A - Inspect the oil pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the oil pressure/temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.
OK NOT OK

Fault Code 212 active?

Fault Code 212 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the oil pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check the resistance of the oil pressure/temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the oil pressure/temperature sensor.
OK NOT OK

50 to 10k ohms?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 active?

Fault Code 212 inactive.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness 36-pin connector to pin 1 on the harness side of the oil pressure/temperature sensor connector.
  • Measure the resistance from pin 35 of the engine harness 36-pin connector to pin 2 on the harness side of the oil pressure/temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19 .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 19 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 35 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 19 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 35 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness sensor connector from the oil pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 212 inactive and Fault Code 213 active?

Fault Code 212 active.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 212 is inactive.
OK NOT OK

Fault Code 212 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2012


FAULT CODE 213 - Oil Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the oil pressure/temperature sensor. |
 | STEP 2A. Inspect the oil pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 213 active?
 | STEP 2C. Check the resistance of the oil pressure/temperature sensor. | 50 to 10k ohms?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 213 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 213 inactive and Fault Code 212 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 213 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the oil pressure/temperature sensor.

Guided Step 2A - Inspect the oil pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Inspect the engine harness and the oil pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pinsFlush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the oil pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 213 active?

Fault Code 213 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the oil pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check the resistance of the oil pressure/temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the oil pressure/temperature sensor.
OK NOT OK

50 to 10k ohms?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19

Go to 3A

Go to 4A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 213 active?

Fault Code 213 inactive.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 of the engine harness 36-pin connector to pin 1 on the harness side of the oil pressure/temperature sensor.
  • Measure the resistance from pin 35 of the engine harness 36-pin connector to pin 2 on the harness side of the oil pressure/temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 19 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 35 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 19 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 35 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the oil pressure/temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Short the SIGNAL pin 2 of the engine harness sensor connector to +5-VDC.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 213 inactive and Fault Code 212 active?

Fault Code 213 active.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 213 is inactive.
OK NOT OK

Fault Code 213 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2012


FAULT CODE 221 - Ambient Air Pressure Sensor

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Any other fault codes active?
STEP 2. | Check ambient air pressure value. |
 | STEP 2A. Compare ambient air pressure value. | Less than 1 in Hg difference?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Any other fault codes active?

Troubleshoot any other fault codes first.

Go to 2A

Go to 3A

Guided Step 2 - Check ambient air pressure value.

Guided Step 2A - Compare ambient air pressure value.

Conditions

  • Monitor the ambient air pressure using INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Compare ambient air pressure value.

  • Compare value of the ambient air pressure reading in the electronic service tool to the value read from a mechanical gauge or a local barometer reading.
OK NOT OK

Less than 1 in Hg difference?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 221 is inactive.
OK NOT OK

Fault Code 221 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2012


FAULT CODE 227 - Sensor Supply B - High Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel rail pressure sensor. |
 | STEP 1A. Check the fuel rail pressure sensor supply voltage. | 4.75 to 5.25-VDC?
STEP 2. | Check the 36-pin engine harness and ECM. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pin?s
 | STEP 2B. Read the fault codes. | Fault Code 227 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check the supply voltage. | 4.75 to 5.25-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fuel rail pressure sensor.

Guided Step 1A - Check the fuel rail pressure sensor supply voltage.

Conditions

  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Turn keyswitch ON.

Action

Check the fuel rail pressure sensor supply voltage.

  • Measure the voltage from pin 3 to pin 1 on the engine harness fuel rail pressure sensor connector.
OK NOT OK

4.75 to 5.25-VDC?

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the 36-pin engine harness and ECM.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 227 active?

Fault Code 227 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for an open circuit.

  • Measure resistance from pin 12 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure resistance from pin 20 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure resistance from pin 27 of the engine harness 36-pin connector to pin 2 of the sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19 .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 12 in the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 20 in the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 27 in the engine harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground in the sensor supply lines.

  • Measure the resistance from pin 12 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 20 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 27 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the supply voltage from the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage from the ECM.

  • Measure the supply voltage out of the ECM from pin 12 to pin 20.
  • Measure the signal voltage out of the ECM from pin 20 to pin 27.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 227 is inactive.
OK NOT OK

Fault Code 227 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2012


FAULT CODE 234 - Engine Overspeed Circuit

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately to avoid engine damage.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for overspeed. |
 | STEP 1A. Check for proper operating conditions. | Not operating downhill?
 | STEP 1B. Check for an alternate fuel source. | No alternate fuel source?
 | STEP 1C. Check the rpm with INSITE™ service tool monitor mode. | Correct rpm reading?
 | STEP 1D. Inspect the vehicle speed sensor and OEM harness. | Dirty or damaged pins?
 | STEP 1E. Read the fault codes. | Fault Code 234 active?
 | STEP 1F. Check for vehicle speed sensor tampering. | No signs of tampering?
 | STEP 1G. Check for an active fault at low rpm. | Inactive fault at low rpm?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was operating downhill when the fault was logged.
OK NOT OK

Not operating downhill?

Check the engine for damage. Electronics are OK. Check the engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past overspeed limit without accelerator input to cause speed increase, followed by a sharp engine cutout.
  • Check the intake manifold for sources of flammable vapors, and check the turbocharger seals to verify there are no oil leaks.
OK NOT OK

No alternate fuel source?

Locate the alternate fuel source

  • Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, and so forth.
  • Inspect the base engine for damage due to the overspeed condition.

Go to 1C

Go to 2A

Guided Step 1C - Check the rpm with the INSITE™ service tool monitor mode.

Conditions

  • Run the engine.
  • Connect service tool to the vehicle datalink.

Action

Check the rpm with the monitor mode.

  • Monitor the engine using INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.
OK NOT OK

Correct rpm reading?

Inspect the engine speed sensor. Check the engine speed sensor as outlined for Fault Codes 689 and 778. Inspect the engine for damage due to the overspeed condition.

Go to 1D

Go to 2A

Guided Step 1D - Inspect the vehicle speed sensor and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the vehicle speed sensor and OEM harness sensor connector for the following:.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the vehicle speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. Use the OEM troubleshooting and repair manual.
  • Replace the vehicle speed sensor. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 234 active?

Fault Code 234 inactive.

Go to 1F

Go to 2B

Guided Step 1F - Check vehicle speed sensor for tampering.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check vehicle speed sensor for tampering.
OK NOT OK

No signs of tampering?

Contact vehicle owner before removing tampering device.

Go to 1G

Go to 2A

Guided Step 1G - Check for an active fault at low rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active fault code at low rpm.

Check for active Fault Code 234 when the engine is not running above 3500 rpm.

OK NOT OK

Inactive fault code at low rpm?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and operate in the condition that previously exhibited the overspeed condition.
  • Verify Fault Code 234 is inactive.
OK NOT OK

Fault Code 234 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2012


FAULT CODE 235 - Coolant Level - Engine Protection

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50° C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check for coolant level sensor. |
 | STEP 2A. Check vehicle for coolant level sensor. | Coolant level sensor present?
STEP 3. | Verify that the coolant is low. |
 | STEP 3A. Check the coolant level. | Coolant level normal?
STEP 4. | Check coolant level sensor. |
 | STEP 4A. Verify fault is still active with engine running. | Fault Code 197 active?
 | STEP 4B. Inspect the coolant level sensor and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Read the fault codes. | Fault Code 197 active?
STEP 5. | Check for shorting plug. |
 | STEP 5A. Check for installed shorting plug. | Shorting plug installed?
STEP 6. | Check the OEM harness. |
 | STEP 6A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 6B. Read the fault codes. | Fault Code 235 active?
 | STEP 6C. Check for an open circuit. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 6E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 7. | Check the ECM response. |
 | STEP 7A. Check the ECM response high. | Fault Code 422 active and Fault Code 235 inactive?
 | STEP 7B. Check the ECM response low. | Fault Code 422 active and Fault Code 235 active?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 235 inactive?
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check for coolant level sensor.

Guided Step 2A - Check vehicle for coolant level sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check vehicle for coolant sensor.
OK NOT OK

Coolant level sensor present?

Coolant level sensor not present.

Go to 3A

Go to 5A

Guided Step 3 - Verify that the coolant is low.

Guided Step 3A - Check the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check vehicle for coolant sensor.

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level normal?

Add coolant to the radiator.

Make sure coolant has proper mix of antifreeze and water.

Go to 4A

Go to 8A

Guided Step 4 - Check the coolant level sensor.

Guided Step 4A - Verify fault is still active with the engine running.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Verify fault code is still active.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 197 active?

Fault Code 197 inactive.

Go to 4B

Go to 8A

Guided Step 4B - Inspect the coolant level sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Inspect the coolant level sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the coolant level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 4C

Go to 8A

Guided Step 4C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 235 active?

Fault Code 235 inactive.

Go to 5A

Go to 8A

Guided Step 5 - Check for shorting plug.

Guided Step 5A - Check for installed shorting plug.

Conditions

  • Turn keyswitch OFF.

Action

Check for installed shorting plug.
OK NOT OK

Shorting plug installed?

Install shorting plug. Refer to Procedure 019-324 in Section 19.

Go to 6A

Go to 8A

Guided Step 6 - Check the OEM harness.

Guided Step 6A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6B

Go to 8A

Guided Step 6B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 235 active?

Fault Code 235 inactive.

Go to 6C

Go to 8B

Guided Step 6C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness sensor connector from the coolant level sensor connector.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 59 of the OEM harness connector to pin A of the OEM harness sensor connector.
  • Measure the resistance from pin 78 of the OEM harness connector to pin D of the OEM harness sensor connector.
  • Measure the resistance from pin 50 of the OEM harness connector to pin B of the OEM harness sensor connector.
  • Measure the resistance from pin 68 of the OEM harness connector to pin C of the OEM harness sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6D

Go to 8A

Guided Step 6D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 59 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 78 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 50 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 68 of the OEM harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6E

Go to 8A

Guided Step 6E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure resistance from pin 59 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 78 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 50 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 68 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the ECM response.

Guided Step 7A - Check the ECM response high.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check the ECM response high.

  • Install a jumper wire from pin C to pin D at the coolant level sensor connector.
OK NOT OK

Fault Code 422 active and Fault Code 235 inactive?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7B

Go to 8A

Guided Step 7B - Check the ECM response low.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Check the ECM response low.

  • Install a jumper wire from pin A to pin C at the coolant level sensor connector.
OK NOT OK

Fault Code 422 active and Fault Code 235 active.

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 235 is inactive.
OK NOT OK

Fault Code 235 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 04-Jun-2012


FAULT CODE 238 - Sensor Supply C - Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Measure the supply voltage to the sensor. |
 | STEP 1A. Measure the supply voltage at the oil pressure/temperature sensor connector. | Less than 4.5-VDC? Fault Code 238 still active when sensor is removed?
STEP 2. | Inspect the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 238 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check the supply voltage. | 4.75 to 5.25-VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Measure the supply voltage to the sensor.

Guided Step 1A - Measure the supply voltage at the oil pressure/temperature sensor connector.

Conditions

  • Disconnect the oil pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the supply voltage.

  • Measure the supply voltage from pin 1 to pin 3 of the engine harness sensor connector.
OK NOT OK

Less than 4.5-VDC?

Replace the oil pressure/temperature sensor if the supply voltage is 4.75 to 5.25 with the sensor disconnected and the fault code is active with the sensor connected. Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Inspect the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 238 active?

Fault Code 238 inactive

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the oil pressure/temperature sensor.

Action

Check for an open circuit.

  • Measure resistance from pin 9 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure resistance from pin 19 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure resistance from pin 33 of the engine harness 36-pin connector to pin 4 of the sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19 .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure/temperature sensor from the engine harness.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 9 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 19 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 33 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the oil pressure/temperature sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 9 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 33 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the supply voltage.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Check supply voltage from the ECM.

  • Measure the voltage from pin 9 to pin 19 at the ECM.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 238 is inactive.
OK NOT OK

Fault Code 238 inactive?

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tools to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Jun-2012


FAULT CODE 239 - Sensor Supply C - High Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Measure voltage from the sensor. |
 | STEP 1A. Measure voltage at the oil pressure/temperature sensor. | 4.75 to 5.25-VDC?
STEP 2. | Inspect the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 239 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check the supply voltage. | 4.75 to 5.25-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Measure voltage from the sensor.

Guided Step 1A - Measure voltage at the oil pressure/temperature sensor.

Conditions

  • Disconnect the oil pressure/temperature sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the supply voltage.

  • Measure the supply voltage from pin 1 to pin 3 of the engine harness sensor connector.
OK NOT OK

4.75 to 5.25-VDC?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Inspect the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 239 active?

Fault Code 239 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the oil pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure resistance from pin 9 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure resistance from pin 19 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure resistance from pin 33 of the engine harness 36-pin connector to pin 4 of the sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19 .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the oil pressure/temperature sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 9 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 19 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 33 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the oil pressure/temperature sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 9 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 19 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 33 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the supply voltage.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage from the ECM.

  • Measure the voltage from pin 9 to pin 19 at the ECM.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 239 is inactive.
OK NOT OK

Fault Code 239 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Jun-2012


FAULT CODE 241 - Vehicle Speed Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3823996 - Weather-Pack™ socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle speed sensor. |
 | STEP 1A. Inspect the OEM harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 241 active?
 | STEP 1C. Check for proper adjustment (if adjustable). | 1/2 to 3/4 turn out from gear for threaded type of sensor?
 | STEP 1D. Check for the correct sensor resistance. | 750 to 1500 ohms?
 | STEP 1E. Check for a short circuit to ground. | Greater than 10M ohms?
 | STEP 1F. Check for a short circuit between coils (if two coils exist). | Greater than 10M ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 241 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the OEM components. |
 | STEP 3A. Check for an external recording device. | No external device?
 | STEP 3B. Check for a transmission tailshaft gear slipping on the shaft. | Gear attached properly?
 | STEP 3C. Check for interference on the OEM harness. | Fault Code 241 inactive?
 | STEP 3C-1. Disable the fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the vehicle speed sensor.

Guided Step 1A - Inspect the OEM harness and vehicle speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and vehicle speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the vehicle speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the vehicle speed sensor. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Read the fault code.

  • Drive the vehicle. The vehicle speed must exceed 16 kph [10 mph].
OK NOT OK

Fault Code 241 active?

Fault Code 241 inactive.

Go to 1C

Go to 4B

Guided Step 1C - Check the vehicle speed sensor for the proper adjustment, if adjustable.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for the proper adjustment, if adjustable.
OK NOT OK

1/2 to 3/4 of a turn out from the gear

Adjust the vehicle speed sensor. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 1D

Go to 4A

Guided Step 1D - Check for the correct sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for the correct resistance.

  • Measure the resistance from pin B to pin A for each vehicle speed sensor connector on the sensor side.
OK NOT OK

750 to 1500 ohms?

Replace the vehicle speed sensor. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for a short circuit to ground.

  • Measure the resistance from pin A on the sensor side of one of the vehicle speed sensor connectors to engine block ground.
  • Measure the resistance from pin A on the sensor side of the other vehicle speed sensor connector to engine block ground.
OK NOT OK

Greater than 10M ohms?

Replace the vehicle speed sensor. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 1F

Go to 4A

Guided Step 1F - Check for a short circuit between coils, if two coils exist.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for a short circuit between coils.

  • Measure the resistance from pin A on the sensor side of one of the vehicle speed sensor connectors to pin A of the other connector.
OK NOT OK

Greater than 10M ohms?

Replace the vehicle speed sensor. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault code.

  • Drive the vehicle. The vehicle speed must exceed 16 kph [10 mph].
OK NOT OK

Fault Code 241 active?

Fault Code 241 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 56 of the OEM harness ECM connector to pin B of the harness side of the vehicle speed sensor connector.
  • Measure the resistance from pin 74 of the OEM harness ECM connector to pin A of the harness side of the vehicle speed sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 56 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 74 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check the harness for a short circuit to ground.

  • Measure the resistance from pin 56 of the OEM harness connector to engine block ground.
  • Measure the resistance from pin 74 of the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check OEM components.

Guided Step 3A - Check for an external recording device.

Conditions

  • Turn keyswitch OFF.

Action

Check for an external recording device or similar devices attached to the vehicle speed sensor circuit.
OK NOT OK

No external device?

Disconnect device from circuit

Go to 3B

Go to 4A

Guided Step 3B - Check for the transmission tailshaft gear slipping on its shaft.

Conditions

  • Turn keyswitch OFF.
  • Vehicle speed sensor removed.

Action

Check for the transmission tailshaft gear slipping on its shaft.

  • Check to make sure the transmission gear inside the sensor mounting is not slipping on the shaft. Do this by trying to spin the gear with a standard screwdriver.
OK NOT OK

Gear attached properly>

Repair transmission gear. Refer to the OEM troubleshooting and repair manual.

Go to 3C

Go to 4A

Guided Step 3C - Check for interference on the OEM harness.

Conditions

  • Connect all components.

Action

Check for interference on the OEM harness.

  • Install a pair of twisted jumper wires from the vehicle speed sensor to the ECM. Connect the wires from pin A on the harness side of the vehicle speed sensor connector to pin 74 on the OEM harness connector, and from pin B on the harness side of the vehicle speed sensor connector to pin 56 of the OEM harness connector.
  • Disconnect the speedometer connector at the vehicle speed sensor.
  • Drive the vehicle. The vehicle speed must exceed 10 mph.
OK NOT OK

Fault Code 241 inactive?

There is an interference on the OEM harness. Locate and remove the source of interference.

Replace the vehicle speed sensor. Refer to Procedure 019-090 in Section 19 or Refer to Procedure 019-091 in Section 19.

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Drive the vehicle. The vehicle speed must exceed 16 kph [10 mph].
  • Verify Fault Code 241 is inactive.
OK NOT OK

Fault Code 241 inactive?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Drive the vehicle. The vehicle speed must exceed 16 kph [10 mph].
OK NOT OK

Fault Code 241 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Jun-2012


FAULT CODE 244 - Indicator Lamp Circuit Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking measurements: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the indicator lamp. |
 | STEP 1A. Verify the indicator lamp is connected to the OEM harness. | Indicator lamp connected?
 | STEP 1B. Check supply voltage. | 9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 244 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100 ohms?
 | STEP 2F. Measure the voltage from the battery. | 9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 244 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the indicator lamp.

Guided Step 1A - Verify the indicator lamp is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the indicator lamp is connected to the OEM harness.
OK NOT OK

Indicator lamp connected?

Connect the indicator lamp to the OEM harness

Go to 1B

Go to 3A

Guided Step 1B - Check the supply voltage.

Conditions

  • Disconnect the indicator lamp from the OEM harness.
  • Turn keyswitch ON.

Action

Check the indicator lamp supply voltage.

  • Measure the supply voltage from pin 1 to pin 2 on the OEM harness side of the wait-to-start lamp.
  • Measure the supply voltage from pin 1 to pin 2 on the OEM harness side of the stop lamp.
  • Measure the supply voltage from pin 1 to pin 2 on the OEM harness side of the maintenance lamp.
OK NOT OK

9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?

Go to 2A

Go to 2A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the indicator lamp.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 244 active

Fault Code 244 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the stop lamp.
  • Disconnect the OEM harness from the wait-to-start lamp.
  • Disconnect the OEM harness from the maintenance lamp.

Action

Check for an open circuit.

  • Measure the resistance from pin 29 of the OEM harness 89-pin ECM connector to pin 2 of the wait-to-start lamp.
  • Measure the resistance from pin 47 of the OEM harness 89-pin ECM connector to pin 2 of the stop lamp.
  • Measure the resistance from pin 63 of the OEM harness 89-pin ECM connector to pin 2 of the maintenance lamp.
  • Measure the resistance from pin 8 of the OEM harness 89-pin ECM connector to pin 1 of the wait-to-start, stop, and maintenance lamps.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the indicator lamp.
  • Disconnect the OEM harness from the stop lamp.
  • Disconnect the OEM harness from the wait-to-start lamp.
  • Disconnect the OEM harness from the maintenance lamp.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 29 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 47 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 63 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the indicator lamp.
  • Disconnect the OEM harness from the stop lamp.
  • Disconnect the OEM harness from the wait-to-start lamp.
  • Disconnect the OEM harness from the maintenance lamp.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 29 to engine block ground.
  • Measure the resistance from pin 47 to engine block ground.
  • Measure the resistance from pin 63 to engine block ground.
OK NOT OK

More than 100k ohms

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Measure the voltage from the battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Measure the voltage to the ECM.

  • Measure the voltage from pin 1 of the OEM harness connector to engine block ground.
  • Measure the voltage from pin 7 of the OEM harness connector to engine block ground.
  • Measure the voltage from pin 12 of the OEM harness connector to engine block ground.
  • Measure the voltage from pin 13 of the OEM harness connector to engine block ground.
OK NOT OK

9 to 15 VDC for 12-VDC systems, 21 to 27 VDC for 24-VDC systems

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 244 is inactive.
OK NOT OK

Fault Code 244 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Jun-2012


FAULT CODE 261 - Fuel Temperature Sensor - Engine Protection Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 261 inactive and did not reoccur?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool to the data link.
  • Operate the engine and compare the fuel temperature sensor reading on INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer "OK" to this step.

Readings will possibly need to be checked while engine is operating at normal temperature conditions (82°C [180°F] coolant).
OK NOT OK

Sensor reading correct?

Sensor reading incorrect. Replace fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Load and operate engine to typical operating temperature (82°C [180°F] coolant).
  • Verify Fault Code 261 is inactive and did not reoccur.
OK NOT OK

Fault Code 261 inactive and did not reoccur?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2015


FAULT CODE 263 - Fuel Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164111 - Bosch® 2.8 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the fuel temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 263 active?
 | STEP 2C. Check the resistance of the fuel temperature sensor. | 50 to 10k ohms?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 263 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 263 inactive and Fault Code 265 active
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 263 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the fuel temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the fuel temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the fuel temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 263 active?

Fault Code 263 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the fuel temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the fuel temperature sensor.
OK NOT OK

50 to 10k ohms?

Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 263 active

Fault Code 263 inactive.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness 36-pin connector to pin 1 on the harness side of the fuel temperature sensor.
  • Measure the resistance from pin 34 of the engine harness 36-pin connector to pin 2 on the harness side of the fuel temperature sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 17 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 34 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms/

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 17 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 34 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness sensor from the fuel temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 263 inactive and Fault Code 265 active?

Fault Code 263 active.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 263 is inactive.
OK NOT OK

Fault Code 263 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Jun-2012


FAULT CODE 265 - Fuel Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the fuel temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 265 active?
 | STEP 2C. Check the resistance of the fuel temperature sensor. | 50 to 10k ohms?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 265 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 265 inactive and Fault Code 263 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 265 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the fuel temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Inspect the fuel temperature sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the fuel temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 265 active?

Fault Code 265 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check the resistance of the fuel temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance from pin 1 to pin 2 of the fuel temperature sensor.
OK NOT OK

50 to 10k ohms?

Replace the fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 265 active?

Fault Code 265 inactive.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 17 of the engine harness 36-pin connector to pin 1 on the harness side of the fuel temperature sensor.
  • Measure the resistance from pin 34 of the engine harness 36-pin connector to pin 2 on the harness side of the fuel temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 17 of the engine harness to engine block ground.
  • Measure the resistance from pin 34 of the engine harness to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel temperature sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 17 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 34 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the engine harness from the fuel temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Apply +5-VDC to signal pin 2 of the fuel temperature sensor connector.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 265 inactive and Fault Code 263 active?

Fault Code 265 active.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 265 is inactive.
OK NOT OK

Fault Code 265 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Jun-2012


FAULT CODE 266 - Fuel Temperature Sensor - Engine Protection Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 266 inactive and did not reoccur?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool to the data link.
  • Operate the engine and compare the fuel temperature sensor reading on INSITE™ monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer "OK" to this step.

Readings will possibly need to be checked while engine is operating at normal temperature conditions (82°C [180°F] coolant).
OK NOT OK

Sensor reading correct?

Sensor reading incorrect.

Replace fuel temperature sensor. Refer to Procedure 019-119 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Load and operate engine to typical operating temperature (82°C [180°F] coolant).
  • Verify Fault Code 266 is inactive and did not reoccur.
OK NOT OK

Fault Code 266 inactive and did not reoccur?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 07-Jun-2012


FAULT CODE 271 - Electronic Fuel Control Actuator Circuit - Short Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

Use the following test leads when taking a measurement to avoid pin and harness damage: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® 0.6 pin test lead and Part Number 3164111 - Bosch® 2.8 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control actuator. |
 | STEP 1A. Inspect the electronic fuel control actuator and engine harness connector for damaged pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 271 active?
 | STEP 1C. Check the coil resistance of the electronic fuel control actuator. | Resistance between 0.1 to 5 ohms?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 271 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 271 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the electronic fuel control actuator.

Guided Step 1A - Inspect the electronic fuel control actuator and engine harness connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Inspect the electronic fuel control actuator and engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the engine harness, or replace the electronic fuel control actuator, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness connectors.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-205 in Section 19.

Refer to Procedure 019-214 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 271 active?

Fault Code 271 inactive?

Go to 1C

Go to 3B

Guided Step 1C - Check the coil resistance of the electronic fuel control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check resistance of the electronic fuel control actuator.

  • Measure the resistance from pin-1 to pin-2 of the electronic fuel control actuator.
OK NOT OK

Resistance between 0.1 to 5 ohms?

Replace electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 2A

Go to 3A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Gently pull on each wire to verify that it is locked in the connector and not a pushed back pin.

OK NOT OK

Dirty or damaged pins?

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness connectors. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 271 inactive?

Fault Code 271 inactive?

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check for an open circuit.

  • Measure the resistance from pin-5 of the engine harness 36-pin connector to pin-2 of the engine harness electronic fuel control actuator connector.
  • Measure the resistance from pin-7 of the engine harness 36-pin connector to pin-1 of the engine harness electronic fuel control actuator connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness connectors.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-205 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-216 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check for short circuit from pin-to-pin.

  • Measure the resistance from pin-5 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin-7 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-5 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin-7 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 271 is inactive.
OK NOT OK

Fault Code 271 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 07-Jun-2012


FAULT CODE 272 - Electronic Fuel Control Actuator Circuit - Open Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® 0.6 pin test lead, and Part Number 3164111 - Bosch® 2.8 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control actuator. |
 | STEP 1A. Inspect the electronic fuel control actuator and engine harness connector for damaged pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 272 active?
 | STEP 1C. Check the coil resistance of the electronic fuel control actuator. | Resistance between 0.1 to 5 ohms?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 272 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 272 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the electronic fuel control actuator.

Guided Step 1A - Inspect the electronic fuel control actuator and engine harness connector for damaged pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Inspect the electronic fuel control actuator and engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the engine harness, or replace the electronic fuel control actuator, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-205 in Section 19.

Refer to Procedure 019-214 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 272 inactive?

Fault Code 272 inactive?

Go to 1C

Go to 3B

Guided Step 1C - Check the coil resistance of the electronic fuel control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check the resistance of the electronic fuel control actuator.

  • Measure the resistance from pin-1 to pin-2 of the electronic fuel control actuator.
OK NOT OK

Resistance between 0.1 to 5 ohms?

Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 2A

Go to 3A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Gently pull on each wire to verify that it is locked in the connector and not a pushed back pin.

OK NOT OK

Dirty or damaged pins?

Repair or replace the engine harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM.
  • Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 272 inactive?

Fault Code 272 inactive?

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check for an open circuit.

  • Measure the resistance from pin-5 of the engine harness 36-pin connector to pin-2 of the engine harness electronic fuel control actuator connector.
  • Measure the resistance from pin-7 of the engine harness 36-pin connector to pin-1 of the engine harness electronic fuel control actuator connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-205 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-216 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check for short circuit from pin-to-pin.

  • Measure the resistance from pin-5 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin-7 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-5 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin-7 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 272 is inactive.
OK NOT OK

Fault Code 272 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 07-Jun-2012


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine. ECM configuration | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 286 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 285 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between the INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.

If the status column indicates “Active” for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Note: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for specific multiplexing configuration information for several OEMs. If the OEM is not listed in the bulletin, it will be necessary to contact the OEM for specific multiplexing information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the sevice data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service data link cable or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for the general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the data link harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection and all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure and the wiring diagram general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Refer to the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the faut code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 285 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactivee fault code.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jul-2012


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 286 active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 286 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 286 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between the INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.

If the status column indicates “Active” for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Note: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for specific multiplexing configuration information for several OEMs. If the OEM is not listed in the bulletin, it will be necessary to contact the OEM for specific multiplexing information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service data link cable or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure the general resistance measurement techniques described in the following procedure and the wiring diagram. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the data link harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Refer to circuit diagram or wiring diagram for component pin inspection.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure and the wiring diagram general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection and all other pins in the OEM connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure and the wiring diagram general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Refer to the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 286 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault code.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jul-2012


FAULT CODE 293 - OEM Temperature Sensor Circuit - High

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the OEM temperature sensor. |
 | STEP 2A. Inspect the OEM harness and OEM temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 293 active?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 293 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 293 inactive and Fault Code 294 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 293 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM temperature sensor.

Guided Step 2A - Inspect the OEM harness and OEM temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the OEM temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM temperature sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 293 active?

Fault Code 293 inactive.

Go to 3A

Go to 4B

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 293 active?

Fault Code 293 inactive.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 32 of the OEM harness to pin A on the harness side of the OEM temperature sensor.
  • Measure the resistance from pin 88 of the OEM harness to pin B on the harness side of the OEM temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 32 of the OEM harness to engine block ground.
  • Measure the resistance from pin 88 of the OEM harness to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 32 of the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 88 of the OEM harness to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness from the OEM temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 293 inactive and Fault Code 294 active?

Fault Code 293 active. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 293 is inactive.
OK NOT OK

Fault Code 293 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 05-Jul-2012


FAULT CODE 294 - OEM Temperature Sensor Circuit - Low

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the OEM temperature sensor. |
 | STEP 2A. Inspect the OEM harness and OEM temperature sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 294 active?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 294 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check for the appropriate ECM response. | Fault Code 294 inactive and Fault Code 293 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 294 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 187, 227, 238, 239, 352, or 386 are not active

Troubleshoot Fault Code 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM temperature sensor.

Guided Step 2A - Inspect the OEM harness and OEM temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:Inspect the ?????? connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the OEM temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM temperature sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 294 active?

Fault Code 294 inactive.

Go to 3A

Go to 4B

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 294 active?

Fault Code 294 inactive.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 32 of the OEM harness to pin A on the harness side of the OEM temperature sensor connector.
  • Measure the resistance from pin 88 of the OEM harness to pin B on the harness side of the OEM temperature sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 32 of the OEM harness to engine block ground.
  • Measure the resistance from pin 88 of the OEM harness to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM temperature sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 32 of the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 88 of the OEM harness to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness sensor connector from the OEM temperature sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Short the signal pin B (or 2) to +5 VDC.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 294 inactive and Fault Code 293 active?

Fault Code 294 active. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 294 is inactive.
OK NOT OK

Fault Code 294 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 06-Jul-2012


FAULT CODE 296 - OEM Pressure - Engine Protection - Speed Derate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Check the fluid level. | Fluid filled to specification?
 | STEP 1B. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 296 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Check the fluid level.

Conditions

  • Turn keyswitch OFF.

Action

Check the fluid level.

Check the fluid level.
OK NOT OK

Fluid filled to specifications?

Fluid low. Fill to correct specifications.

Go to 1B

Go to 2A

Guided Step 1B - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical OEM pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to vehicle data link.
  • Start the engine and compare the OEM pressure reading on the service tool monitor screen to the reading on the mechanical OEM pressure gauge.

If necessary, rev the engine up to make it easier to see differences in the readings.
OK NOT OK

Sensor reading is correct?

Replace the OEM pressure sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 296 is inactive.

If the fault was at a particular speed, operate the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 296 inactive?

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 06-Jul-2012


FAULT CODE 297 - OEM Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the OEM pressure sensor. |
 | STEP 2A. Inspect the OEM pressure sensor and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 297 active?
 | STEP 2C. Check the OEM pressure sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Measure the voltage from the ECM. |
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 297 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 297 inactive and Fault Code 298 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 297 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check the OEM pressure sensor.

Guided Step 2A - Inspect the OEM pressure sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and the OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the OEM pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM pressure sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 active?

Fault Code 297 inactive.

Go to 2C

Go to 5B

Guided Step 2C - Check the OEM pressure sensor supply voltage.

Conditions

  • Disconnect the OEM harness from the OEM pressure sensor.
  • Turn keyswitch ON.

Action

Check the OEM pressure sensor supply voltage.

  • Measure the supply voltage from pin A to pin B of the OEM harness sensor connector.
OK NOT OK

4.75 to 5.25-VDC?

Does not meet specifications.

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage from pin 50 to pin 68 at the ECM.
OK NOT OK

4.75 to 5.25-VDC. Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 active

Fault Code 297 inactive.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 50 of the OEM harness connector to pin B of the OEM harness sensor connector.
  • Measure the resistance from pin 68 of the OEM harness connector to pin A of the OEM harness sensor connector.
  • Measure the resistance from pin 82 of the OEM harness connector to pin C of the OEM harness sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 50 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 68 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 82 of the OEM harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for a short circuit to ground.

  • Measure resistance from pin 50 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 68 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 82 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness from the OEM pressure sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 inactive and Fault Code 298 active?

Fault Code 297 active. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 297 is inactive.
OK NOT OK

Fault Code 297 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 06-Jul-2012


FAULT CODE 298 - OEM Pressure Sensor Circuit - Low

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® 2.8 socket test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 are not active?
STEP 2. | Check the OEM pressure sensor. |
 | STEP 2A. Inspect the OEM pressure sensor and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 298 active?
 | STEP 2C. Check the OEM pressure sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C-1. Measure the voltage from the ECM. |
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 298 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check for the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 297 inactive and Fault Code 298 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 298 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 are not active?

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check the OEM pressure sensor.

Guided Step 2A - Inspect the OEM pressure sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Inspect the engine harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the OEM pressure sensor, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM pressure sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check the OEM pressure sensor supply voltage.

Conditions

  • Disconnect the OEM harness from the OEM pressure sensor.
  • Turn keyswitch ON.

Action

Check the OEM pressure sensor supply voltage.

  • Measure the supply voltage from pin A to pin B of the OEM harness sensor connector.
OK NOT OK

4.75 to 5.25-VDC?

Does not meet specifications.

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Verify ECM output voltage.

  • Measure the voltage from pin 50 to pin 68 at the ECM.
OK NOT OK

4.75 to 5.25-VDC. Repair or replace the OEM harness. Refer to the OEM troubleshooting and repair manual.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 298 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 50 of the OEM harness connector to pin B of the OEM harness sensor connector.
  • Measure the resistance from pin 68 of the OEM harness connector to pin A of the OEM harness sensor connector.
  • Measure the resistance from pin 82 of the OEM harness connector to pin C of the OEM harness sensor connector.
OK NOT OK

Less than 10 ohms?

  • Repair or replace the OEM harness
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 50 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 68 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 82 of the OEM harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

  • Repair or replace the OEM harness
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.

Action

Check for a short circuit to ground.

  • Measure resistance from pin 50 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 68 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 82 of the OEM harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

  • Repair or replace the OEM harness
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19

Go to 4A

Go to 5A

Guided Step 4 - Check for the ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Disconnect the OEM harness from the OEM pressure sensor.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 297 inactive and Faultt Code 298 active?

Fault Code 298 active. Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 298 is inactive.
OK NOT OK

Fault Code 298 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 08-Jul-2012


FAULT CODE 311 - Injector Bank 1 Circuit Error

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164132 - Deutsch Number 12 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the pass-through connector. |
 | STEP 1A. Inspect the engine harness and pass-through connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 311 active?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the 16-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 311 active
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the resistance of the ECM. |
 | STEP 3A. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check the injector solenoid. |
 | STEP 4A. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 311 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the pass-through connector.

Guided Step 1A - Inspect the engine harness and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.

Action

Inspect the engine harness and pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-063 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 311 active?

Repair complete.

Go to 1C

Go to 5B

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the driver pin at the pass-through connector to engine block ground for each injector on the bank 1 side.
  • Measure the resistance from the return pin at the pass-through connector to engine block ground for each injector on the bank 1 side.
OK NOT OK

Greater than 100k ohms?

Go to 2A

Go to 4A

Guided Step 2 - Check the 16-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 311 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the driver pin at the engine harness 16-pin connector to all other pins in the connector for each injector on the bank 1 side.

Pins 4, 9, and 11 for six-cylinder engines and pins 9 and 11 for four-cylinder engines.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • For six-cylinder engines, measure the resistance from driver pins 4, 9, and 11 at the engine harness ECM connector to engine block ground.
  • For six-cylinder engines, measure the resistance from return pins 12, 13, and 16 at the engine harness ECM connector to engine block ground.
  • For four-cylinder engines, measure the resistance from driver pins 9 and 11 at the engine harness ECM connector to engine block ground.
  • For four-cylinder engines, measure the resistance from return pins 13 and 16 at the engine harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the resistance of the ECM.

Guided Step 3A - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Check for a short circuit to ground at the ECM.

  • For six-cylinder engines, measure the resistance from driver pins 4, 9, and 11 at the ECM to engine block ground.
  • For six-cylinder engines, measure the resistance from return pins 12, 13, and 16 at the ECM to engine block ground.
  • For four-cylinder engines, measure the resistance from driver pins 9, and 11 at the ECM to engine block ground.
  • For four-cylinder engines, measure the resistance from return pins 13, and 16 at the ECM to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check the injector solenoid.

Guided Step 4A - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.
  • Remove valve cover.
  • Disconnect the injector from the internal injector harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from each solenoid post to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Replace the failed injector. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 311 is inactive.
OK NOT OK

Fault Code 311 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 08-Jul-2012


FAULT CODE 321 - Injector Bank 2 Circuit Error

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164111 - Bosch® 2.8 socket test lead and Part Number 3164132 - Deutsch Number 12 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the pass-through connector. |
 | STEP 1A. Inspect the engine harness and pass-through connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 321 active?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the 16-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 321 active
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the resistance of the ECM. |
 | STEP 3A. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check the injector solenoid. |
 | STEP 4A. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 321 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the pass-through connector.

Guided Step 1A - Inspect the engine harness and pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.

Action

Inspect the engine harness and pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the pass-through connector. Refer to Procedure 019-063 in Section 19.

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 321 active?

Repair complete.

Go to 1C

Go to 5B

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the driver pin at the pass-through connector to engine block ground for each injector.
  • Measure the resistance from the return pin at the pass-through connector to engine block ground for each injector.
OK NOT OK

Greater than 100k ohms?

Go to 2A

Go to 4A

Guided Step 2 - Check the 16-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 321 active?

Repair complete.

Go to 2C

Go to 5B

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • For six-cylinder engines, measure the resistance from driver pins 3, 5, and 10 at the engine harness 16-pin connector to all other pins in the connector.
  • For four-cylinder engines, measure the resistance from driver pins 4 and 10 at the engine harness 16-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • For six-cylinder engines, measure the resistance from driver pins 3, 5, and 10 at the engine harness 16-pin connector to engine block ground.
  • For six-cylinder engines, measure the resistance from return pins 6, 14, and 15 at the engine harness 16-pin connector to engine block ground.
  • For four-cylinder engines, measure the resistance from driver pins 4 and 10 at the engine harness 16-pin connector to engine block ground.
  • For four-cylinder engines, measure the resistance from return pins 12 and 15 at the engine harness 16-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the resistance of the ECM.

Guided Step 3A - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Check for a short circuit to ground at the ECM.

  • For six-cylinder engines, measure the resistance from driver pins 3, 5, and 10 at the ECM to engine block ground.
  • For six-cylinder engines, measure the resistance from return pins 6, 14, and 15 at the ECM to engine block ground.
  • For four-cylinder engines, measure the resistance from driver pins 4 and 10 at the ECM to engine block ground.
  • For four-cylinder engines, measure the resistance from return pins 12 and 15 at the ECM to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the injector solenoid.

Guided Step 4A - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pass-through connector.
  • Remove valve cover.
  • Disconnect the injector from the internal injector harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from each solenoid post to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Replace the failed injector. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 321 is inactive.
OK NOT OK

Fault Code 321 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 08-Jul-2012


FAULT CODE 322 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164132 - Deutsch Number 12 socket test lead and Part Number 3164133 - Deutsch Number 12 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 322 active?
 | STEP 1C. Check the resistance of the internal injector circuit. | Less than 0.5 ohm?
STEP 2. | Check the 16-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 322 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the internal injector harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check the resistance of injector solenoid. | Less than 0.5 ohm?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 322 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the injector.

Guided Step 1A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector pass-through connector. Refer to Procedure 019-063 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 322 active?

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check the resistance of the internal injector circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check the resistance of the internal injector circuit.

  • Measure the resistance from pin 4 to pin 3 on the injector pass-through connector.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Go to 2A

Go to 3A

Guided Step 2 - Check the 16-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 322 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for an open circuit.

  • For 4 and six-cylinder engines, measure the resistance from pin 9 of the engine harness 16-pin connector to pin 4 on the external harness side of the engine harness 4-pin pass-through connector.
  • For 4 and six-cylinder engines, measure the resistance from pin 13 of the engine harness 16-pin connector to pin 3 on the external harness side of the injector harness 4-pin pass-through connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit from pin to pin.

  • For four-cylinder and six-cylinder engines, measure the resistance from pin 9 of the engine harness 16-pin connector to all other pins in the connector.
  • For four-cylinder and six-cylinder engines, measure the resistance from pin 13 of the engine harness 16-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit to ground.

  • For four-cylinder and six-cylinder engines, measure the resistance from pin 9 of the engine harness 16-pin connector to engine block ground.
  • For four-cylinder and six-cylinder engines, measure the resistance from pin 13 of the engine harness 16-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the internal injector harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 1 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 1 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to all other pins in the connector.
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to engine block ground.
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to engine block ground.

Make sure that the pigtail nuts do not contact the engine.

OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the injector from the internal injector harness.

Action

Check the resistance of injector solenoid.

  • Measure the resistance between the solenoid posts on injector number 1.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Replace the injector. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 322 is inactive.
OK NOT OK

Fault Code 322 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 08-Jul-2012


FAULT CODE 323 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164132 - Deutsch Number 12 socket test lead, and Part Number 3164133 - Deutsch Number 12 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 323 active?
 | STEP 1C. Check the resistance of the internal injector circuit. | Less than 0.5 ohm?
STEP 2. | Check the 16-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 323 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the internal engine harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check the resistance of injector solenoid. | Less than 0.5 ohm?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 323 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the injector.

Guided Step 1A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal engine harness at the 4-pin pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector pass-through connector. Refer to Procedure 019-063 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 323 active?

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check the resistance of the internal injector circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal engine harness at the 4-pin pass-through connector.

Action

Check the resistance of the internal injector circuit.

  • Measure the resistance from pin 4 to pin 3 on the injector pass-through connector.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Go to 2A

Go to 3A

Guided Step 2 - Check the 16-pin engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 323 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for an open circuit.

  • For six-cylinder engines, measure the resistance from pin 11 of the engine harness 16-pin connector to pin 4 on the external harness side of the engine harness 4-pin pass-through connector.
  • For six-cylinder engines, measure the resistance from pin 16 of the engine harness 16-pin connector to pin 3 on the external harness side of the engine harness 4-pin pass-through connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-215 in Section 19 .
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit from pin-to-pin.

  • For six-cylinder engines, measure the resistance from pin 11 of the engine harness 16-pin connector to all other pins in the connector.
  • For six-cylinder engines, measure the resistance from pin 16 of the engine harness 16-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit to ground.

  • For six-cylinder engines, measure the resistance from pin 11 of the engine harness 16-pin connector to engine block ground.
  • For six-cylinder engines, measure the resistance from pin 16 of the engine harness 16-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the internal engine harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 5 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 5 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms?

Replace the internal engine harness. Refer to Procedure 019-063 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to all other pins in the connector.
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the internal engine harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to engine block ground.
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to engine block ground.

Make sure that the pigtail nuts do not contact the engine.

OK NOT OK

Greater than 100k ohms?

Replace the internal engine harness. Refer to Procedure 019-063 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the injector from the internal injector harness.

Action

Check the resistance of injector solenoid.

  • Measure the resistance between the solenoid posts on injector number 5.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohms?

Replace the injector. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 323 is inactive.
OK NOT OK

Fault Code 323 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2015


FAULT CODE 324 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164132 - Deutsch Number 12 socket test lead and Part Number 3164133 - Deutsch Number 12 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 324 active?
 | STEP 1C. Check the resistance of the internal injector circuit. | Less than 0.5 ohm?
STEP 2. | Check the 16-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 324 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the internal injector harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check the resistance of the injector solenoid. | Less than 0.5 ohm?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 324 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the injector.

Guided Step 1A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector pass-through connector. Refer to Procedure 019-063 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 324 active

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check the resistance of the internal injector circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check resistance of the internal injector circuit.

  • Measure the resistance from pin 4 to pin 3 on the injector pass-through connector.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Go to 2A

Go to 3A

Guided Step 2 - Check the 16-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 324 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for an open circuit.

  • For 4 cylinder engines, measure the resistance from pin 11 of the engine harness 16-pin connector to pin 4 on the external harness side of the engine harness 4-pin pass-through connector.
  • For 4 cylinder engines, measure the resistance from pin 16 of the engine harness 16-pin connector to pin 3 on the external harness side of the engine harness 4-pin pass-through connector.
  • For 6 cylinder engines, measure the resistance from pin 4 of the engine harness 16-pin connector to pin 4 on the external harness side of the injector harness 4-pin pass-through connector.
  • For 6 cylinder engines, measure the resistance from pin 12 of the engine harness 16-pin connector to pin 3 on the external harness side of the engine harness 4-pin pass-through connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit from pin-to-pin.

  • For four-cylinder engines, measure the resistance from pin 11 of the engine harness 16-pin connector to all other pins in the connector.
  • For four-cylinder engines, measure the resistance from pin 16 of the engine harness 16-pin connector to all other pins in the connector.
  • For six-cylinder engines, measure the resistance from pin 4 of the engine harness 16-pin connector to all other pins in the connector.
  • For six-cylinder engines, measure the resistance from pin 12 of the engine harness 16-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit to ground.

  • For four-cylinder engines, measure the resistance from pin 11 of the engine harness 16-pin connector to engine block ground.
  • For four-cylinder engines, measure the resistance from pin 16 of the engine harness 16-pin connector to engine block ground.
  • For six-cylinder engines, measure the resistance from pin 4 of the engine harness 16-pin connector to engine block ground.
  • For six-cylinder engines, measure the resistance from pin 12 of the engine harness 16-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the internal injector harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 3 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 3 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to all other pins in the connector.
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 on the 4-pin pass-through connector to engine block ground.
  • Measure the resistance from pin 4 on the 4-pin pass-through connector to engine block ground.

Make sure that the pigtail nuts do not contact the engine.

OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the injector from the internal injector harness.

Action

Check the resistance of injector solenoid.

  • Measure the resistance between the solenoid posts on injector number 3.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Replace the injector. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 324 is inactive.
OK NOT OK

Fault Code 324 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2012


FAULT CODE 325 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - male Bosch® (blade) test lead, Part Number 3824810 - male Deutsch test leadPart Number 3164132 - Deutsch Number 12 socket test lead and Part Number 3164133 - Deutsch Number 12 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 325 active?
 | STEP 1C. Check the resistance of the internal injector circuit. | Less than 0.5 ohm?
STEP 2. | Check the 16-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 325 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the internal injector harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check the resistance of the injector solenoid. | Less than 0.5 ohm?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 325 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the injector.

Guided Step 1A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector pass-through connector. Refer to Procedure 019-063 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 325 active?

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check the resistance of the internal injector circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check the resistance of the internal injector circuit.

  • Measure the resistance from pin 1 to pin 2 on the injector pass-through connector.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Go to 2A

Go to 3A

Guided Step 2 - Check the 16-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 325 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for an open circuit.

  • For six-cylinder engines, measure the resistance from pin 10 of the engine harness 16-pin connector to pin 1 on the external harness side of the engine harness 4-pin pass-through connector.
  • For six-cylinder engines, measure the resistance from pin 15 of the engine harness 16-pin connector to pin 2 on the external harness side of the injector harness 4-pin pass-through connector.
OK NOT OK

Less than 10 ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit from pin to pin.

  • For six-cylinder engines, measure the resistance from pin 10 of the engine harness 16-pin connector to all other pins in the connector.
  • For six-cylinder engines, measure the resistance from pin 15 of the engine harness 16-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit to ground.

  • For six-cylinder engines, measure the resistance from pin 10 of the engine harness 16-pin connector to engine block ground.
  • For six-cylinder engines, measure the resistance from pin 15 of the engine harness 16-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the internal injector harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 6 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 6 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to all other pins in the connector.
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to engine block ground.
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to engine block ground.

Make sure that the pigtail nuts do not contact the engine.

OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the injector from the internal injector harness.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the solenoid posts on injector number 6.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Replace the injector. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 325 is inactive.
OK NOT OK

Fault Code 325 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jul-2012


FAULT CODE 329 - High Pressure Common Rail (HPCR) Leakage Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EFC Actuator Valve | Refer to Procedure 005-007 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
EFC Actuator Valve | Refer to Procedure 005-011 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Fuel Pump | Refer to Procedure 005-016 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Air in Fuel | Refer to Procedure 006-003 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Fuel Supply Lines | Refer to Procedure 006-024 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Injector | Refer to Procedure 006-026 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Engine Wiring Harness | Refer to Procedure 019-043 | ISB (4 Cylinder) and ISBe (4 and 6 Cylinder) Electronic Control System | 3666477
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB (4 Cylinder) and ISBe (4 and 6 Cylinder) Electronic Control System | 3666477

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch™ - 2.8 pin test lead (blade), Part Number 3164112 - Bosch™ - 6 pin test lead, and Part Number 3164113 - Bosch™ - 6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive faults codes. | Fault Codes 1139, 1141, 1142, 1143, 1144, or 1145 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the fuel lines. |
 | STEP 2A. Check all fuel lines for signs of leaking. | Any damages or leaking fuel supply lines found?
 | STEP 2B. Check for restriction in the low-pressure fuel lines. | Any restrictions in the low-pressure fuel supply lines found?
STEP 3. | Check the fuel filter. |
 | STEP 3A. Check for a plugged fuel filter. | Fuel filter plugged?
STEP 4. | Check for air in the system. |
 | STEP 4A. Check for air in the low-pressure system. | Air present in the low-pressure system?
STEP 5. | Check the fuel rail pressure sensor. |
 | STEP 5A. Inspect the fuel rail pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for signs of tampering on the fuel rail pressure sensor. | Tampering detected?
 | STEP 5C. Measure the voltage at the fuel rail pressure sensor connector. | 4.75 to 5.25 VDC?
 | STEP 5D. Verify the fuel rail pressure sensor accuracy. | Rail fuel pressure (measured) less than 30 bar [435 psi]?
STEP 6. | Check the ECM and engine harness. |
 | STEP 6A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 6B. Check for an open circuit. | Less than 10 ohms?
 | STEP 6C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6D. Check for an active fault code. | Fault Code 329 active or inactive with more than one count logged in the last 25 engine hours?
STEP 7. | Check the ECM response. |
 | STEP 7A. Measure voltage at the ECM. | 4.75 to 5.25 VDC?
STEP 8. | Check the high-pressure injection pump. |
 | STEP 8A. High-pressure injection pump flow test. | Fuel pump flow meets the specification?
STEP 9. | Check for an internal fuel leak. |
 | STEP 9A. Check for an internal high-pressure fuel leak. | Internal fuel leak?
 | STEP 9B. Check the fuel pressure relief valve for leakage. | Fuel leak from the pressure relief valve found?
 | STEP 9C. Place colored dye in the fuel. | Dye found?
STEP 10. | Clear the fault codes. Check ECM calibration and clear fault codes. |
 | STEP 10A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 10B. Clear the inactive fault codes. Disable the fault code. | Fault code inactive?

Guided Step 1 -

Guided Step 1A - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1139, 1141, 1142, 1143, 1144, or 1145 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the fuel supply lines.

Guided Step 2A - Check all fuel lines for signs of leaking.

Conditions

  • Turn keyswitch OFF.

Action

Check all fuel lines for signs of leaking.

  • Visually inspect all fuel system gasket locations for signs of leakage.
  • Visually inspect the engine fuel supply lines for signs of kinks, damage, or fuel leaks.

Refer to Procedure 006-024 in the Associated Procedures Table.

Any damages or leaking fuel supply lines found?
YES NO

Repair

Replace fuel lines.

  • Refer to Procedure 006-024 in the Associated Procedures Table.
 No Repair

Go to 10A

Go to 2B

Guided Step 2B - Check for restriction in the low-pressure fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Check for restriction in the low-pressure fuel lines.

  • Bent fuel lines
  • Twisted fuel lines
  • Pinched or squeezed fuel lines.

Any restrictions found in the low-pressure fuel supply lines?
YES NO

Repair

  • Refer to Procedure 006-024 in the Associated Procedures Table.
 No Repair

Go to 10A

Go to 3A

Guided Step 3 - Check the fuel filter.

Guided Step 3A - Check for a plugged fuel filter.

Conditions

  • Turn keyswitch OFF.

Action

Check for a plugged fuel filter.

  • Measure the pressure drop across the fuel filter. Refer to Procedure 005-011 in the Associated Procedures Table.

Fuel filter plugged?
YES NO

Repair

Refer to Procedure 005-011 in the Associated Procedures Table.

 No Repair

Go to 10A

Go to 4A

Guided Step 4 - Check for air in the system.

Guided Step 4A - Check for air in the low-pressure system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the low-pressure system.

  • Refer to Procedure 006-003 in the Associated Procedures Table.
  • Use the following procedure in the ISB (4 Cylinder) and ISBe (4 and 6 Cylinder) Electronic Control System Troubleshooting and Repair Manual, Bulletin 3666477. Refer to Procedure 019-032 in Section 19.
  • Start the engine and operate at high idle for 1 minute.

Air present in the low-pressure system?
YES NO

Repair

  • Refer to Procedure 006-003 in the Associated Procedures Table.
 No Repair

Go to 10A

Go to 5A

Guided Step 5 - Check the fuel rail pressure sensor.

Guided Step 5A - Inspect the fuel rail pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from fuel rail pressure sensor.

Action

Inspect the fuel rail pressure sensor and engine harness connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fuel rail pressure sensor engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 10A

Go to 5B

Guided Step 5B - Check for signs of tampering on the fuel rail pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from fuel rail pressure sensor.

Action

Check for signs of tampering on the fuel rail pressure sensor.

  • Broken, cut, or incorrect routing of the fuel rail pressure sensor wires.
  • Any device connected in series or parallel with the fuel rail pressure sensor.
  • Any other wires added to the fuel rail pressure sensor circuit.
  • Any evidence that tampering with the fuel rail pressure sensor has taken place.

Tampering detected?
YES NO

Repair

Repair or replace the engine harness, or replace the fuel rail pressure sensor. Repair or replace all tampered components.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.
 No Repair

Go to 10A

Go to 5C

Guided Step 5C - Measure the voltage at the fuel rail pressure sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from fuel rail pressure sensor.

Action

Measure the voltage at the fuel rail pressure sensor connector.

  • Measure the voltage from the fuel rail pressure sensor SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.
  • Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 5D

Go to 10A

Guided Step 5D - Verify the fuel rail pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Do not operate engine.
  • Connect INSITE™ electronic service tool.
  • INSITE™ electronic service tool monitor mode.

Action

Verify the fuel rail pressure sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the fuel rail pressure.

When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized.

Is the rail fuel pressure (measured) greater than 30 bar [435 psi]?
YES NO

Repair

A malfunctioning fuel rail pressure sensor has been detected.

Replace the fuel rail pressure sensor.

  • Refer to Procedure 019-115 in the Associated Procedures Table.
 No Repair

Go to 10A

Go to 6A

Guided Step 6 - Check the ECM and engine harness.

Guided Step 6A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from fuel rail pressure sensor.
  • Disconnect engine harness connector from ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Gently pull on each wire to verify that it is locked in the connector and not a pushed back pin.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 10A

Go to 6B

Guided Step 6B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Disconnect engine harness connector from ECM.

Action

Check for an open circuit.

  • Measure the resistance between the fuel rail pressure sensor SUPPLY pin in the engine harness ECM connector and the fuel rail pressure SUPPLY pin at the fuel rail pressure harness connector.
  • Measure the resistance between the fuel rail pressure sensor RETURN pin in the engine harness ECM connector and the fuel rail pressure RETURN pin at the fuel rail pressure harness connector.
  • Measure the resistance between the fuel rail pressure sensor SIGNAL pin in the engine harness ECM connector and the fuel rail pressure SIGNAL pin at the fuel rail pressure harness connector.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6D

Go to 10A

Guided Step 6C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Disconnect engine harness connector from ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the fuel rail pressure sensor SUPPLY pin at the engine harness connector and all other pins in the connector.
  • Measure the resistance between the fuel rail pressure sensor RETURN pin at the engine harness connector and all other pins in the connector.
  • Measure the resistance between the fuel rail pressure sensor SIGNAL pin at the engine harness connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 7A

Go to 10A

Guided Step 6D - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 329 active or inactive with more than one count logged in the last 25 engine hours?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 7A

Go to 10A

Guided Step 7 - Check the ECM response.

Guided Step 7A - Measure voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from ECM.
  • Turn keyswitch ON.

Action

Measure voltage at the ECM.

  • Measure the voltage from the fuel rail pressure SUPPLY pin to the fuel rail pressure RETURN pin at the engine harness connector on the ECM.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 8A

Go to 10A

Guided Step 8 - Check the high-pressure injection pump.

Guided Step 8A -

Conditions

  • Turn keyswitch ON.
  • Crank engine.

Action

Check the high-pressure injection pump.

  • Disconnect the high-pressure fuel line from the fuel rail of the high-pressure injection pump.
  • Connect a clear hose to the outlet of the high-pressure injection pump.
  • Run the clear hose into a suitable empty container.
  • Crank the engine for 30 seconds and measure fuel pump flow.

Fuel pump flow meets the specification?
YES NO

Repair

  • Replace the EFC actuator valve. Refer to Procedure 005-007 in the Associated Procedures Table.

Repair

  • Replace the high-pressure fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 9A

Go to 10A

Guided Step 9 - Check for an internal fuel leak.

Guided Step 9A - Check for an internal high pressure fuel leak.

Conditions

  • Turn keyswitch OFF.

Action

Check for an internal high pressure fuel leak.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Internal fuel leak?
YES NO
No Repair

Repair

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 9B

Go to 10A

Guided Step 9B - Check the fuel pressure relief valve for leakage.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel pressure relief valve for leakage.

  • Use Cummins® service tool, Fuel Pressure Gauge Adapter, Part Number 3164044.

It is possible for small amounts of air to be vented through this valve. This is considered acceptable and is not a reason for valve replacement.

Fuel leak from the pressure relief valve?
YES NO

Repair

  • Replace the fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.
 No Repair

Go to 10A

Go to 9C

Guided Step 9C - Place colored dye in the fuel.

Conditions

  • Place colored dye in fuel.
  • Turn keyswitch ON.
  • Start engine and run at high idle for 5 minutes.

Action

Place colored dye in the fuel.

  • Place colored dye, Part Number 3376891, in the fuel to determine if there is an internal leak in the cylinder head.
  • Start the engine and run at high idle for 5 minutes.
  • Check coolant and oil for traces of dye.

Colored dye found?
YES NO

Repair

Inspect the high-pressure connector and injector for source of leak. Replace the failed component.

Repair

Replace the electronic fuel control actuator.

  • Refer to Procedure 005-007 in the Associated Procedures Table.

Go to 10A

Go to 0A

Guided Step 10 - Check ECM calibration and clear fault codes.

Guided Step 10A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check if an ECM calibration update is available.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

  • Use the following procedure in the ISB (4 Cylinder) and ISBe (4 and 6 Cylinder) Electronic Control System Troubleshooting and Repair Manual, Bulletin 3666477. Refer to Procedure 019-032 in Section 19.

Go to 10B

Go to 10B

Guided Step 10B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 02-Jan-2017


FAULT CODE 331 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164132 - Deutsch Number 12 socket test lead and Part Number 3164133 - Deutsch Number 12 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the engine harness and injector pass-through connector pins. | Dirty ordamaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 331 active?
 | STEP 1C. Check the resistance of the internal injector circuit. | Less than 0.5 ohm?
STEP 2. | Check the 16-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 331 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the internal injector harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check the resistance of the injector solenoid. | Less than 0.5 ohm?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 331 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the injector.

Guided Step 1A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector pass-through connector. Refer to Procedure 019-063 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 331 active?

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check resistance of the internal injector circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check the resistance of the internal injector circuit.

  • Measure the resistance from pin 1 to pin 2 on the injector pass-through connector.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Go to 2A

Go to 3A

Guided Step 2 - Check the 16-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 331 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for an open circuit.

  • For four-cylinder engines, measure the resistance from pin 10 of the engine harness 16-pin connector to pin 1 on the external harness side of the engine harness 4-pin pass-through connector.
  • For four-cylinder engines, measure the resistance from pin 15 of the engine harness 16-pin connector to pin 2 on the external harness side of the injector harness 4-pin pass-through connector.
  • For six-cylinder engines, measure the resistance from pin 3 of the engine harness 16-pin connector to pin 1 on the external harness side of the engine harness 4-pin pass-through connector.
  • For six-cylinder engines, measure the resistance from pin 6 of the engine harness 16-pin connector to pin 2 on the external harness side of the injector harness 4-pin pass-through connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit from pin-to-pin.

  • For four-cylinder engines, measure the resistance from pin 10 of the engine harness 16-pin connector to all other pins in the connector.
  • For four-cylinder engines, measure the resistance from pin 15 of the engine harness 16-pin connector to all other pins in the connector.
  • For six-cylinder engines, measure the resistance from pin 3 of the engine harness 16-pin connector to all other pins in the connector.
  • For six-cylinder engines, measure the resistance from pin 6 of the engine harness 16-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit to ground.

  • For four-cylinder engines, measure the resistance from pin 10 of the engine harness 16-pin connector to engine block ground.
  • For four-cylinder engines, measure the resistance from pin 15 of the engine harness 16-pin connector to engine block ground.
  • For six-cylinder engines, measure the resistance from pin 3 of the engine harness 16-pin connector to engine block ground.
  • For six-cylinder engines, measure the resistance from pin 6 of the engine harness 16-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the internal injector harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 2 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 2 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to all other pins in the connector.
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to engine block ground.
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to engine block ground.

Make sure that the pigtail nuts do not contact the engine.

OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the injector from the internal injector harness.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the solenoid posts on injector number 2.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Replace the injector. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 331 is inactive.
OK NOT OK

Fault Code 331 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jul-2012


FAULT CODE 332 - Injector Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement :Part Number 3164132 - Deutsch Number 12 socket test lead, Part Number 3164110 - male Bosch® (blade) test lead and Part Number 3824810 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the injector. |
 | STEP 1A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 332 active?
 | STEP 1C. Check resistance of the internal injector circuit. | Less than 0.5 ohm?
STEP 2. | Check the 16-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 332 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the internal injector harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check the resistance of injector solenoid. | Less than 0.5 ohm?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 332 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the injector.

Guided Step 1A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Inspect the engine harness and injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the pass-through connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the injector pass-through connector. Refer to Procedure 019-063 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the active fault codes.
OK NOT OK

Fault Code 332 active?

Repair complete.

Go to 1C

Go to 4B

Guided Step 1C - Check resistance of the internal injector circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check resistance of the internal injector circuit.

  • Measure the resistance from pin 1 to pin 2 on the injector pass-through connector.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohm?

Go to 2A

Go to 3A

Guided Step 2 - Check the 16-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 332 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for an open circuit.

  • For six-cylinder engines, measure the resistance from pin 5 of the engine harness 16-pin connector to pin 1 on the external harness side of the engine harness 4-pin pass-through connector.
  • For six-cylinder engines, measure the resistance from pin 14 of the engine harness 16-pin connector to pin 2 on the external harness side of the injector harness 4-pin pass-through connector.
  • For four-cylinder engines, measure the resistance from pin 4 of the engine harness 16-pin connector to pin 1 on the external harness side of the engine harness 4-pin pass-through connector.
  • For four-cylinder engines, measure the resistance from pin 12 of the engine harness 16-pin connector to pin 2 on the external harness side of the injector harness 4-pin pass-through connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit from pin-to-pin.

  • For six-cylinder engines, measure the resistance from pin 5 of the engine harness 16-pin connector to all other pins in the connector.
  • For six-cylinder engines, measure the resistance from pin 14 of the engine harness 16-pin connector to all other pins in the connector.
  • For four-cylinder engines, measure the resistance from pin 4 of the engine harness 16-pin connector to all other pins in the connector.
  • For four-cylinder engines, measure the resistance from pin 12 of the engine harness 16-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 16-pin connector from the ECM.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.

Action

Check for a short circuit to ground.

  • For six-cylinder engines, measure the resistance from pin 5 of the engine harness 16-pin connector to engine block ground.
  • For six-cylinder engines, measure the resistance from pin 14 of the engine harness 16-pin connector to engine block ground.
  • For four-cylinder engines, measure the resistance from pin 4 of the engine harness 16-pin connector to engine block ground.
  • For four-cylinder engines, measure the resistance from pin 12 of the engine harness 16-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-215 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the internal injector harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 4 injector. (Resistance to one of these nuts must be within specification.)
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to each injector pigtail nut that connects to number 4 injector. (Resistance to one of these nuts must be within specification.)
OK NOT OK

Less than 10 ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to all other pins in the connector.
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the engine harness from the internal injector harness at the 4-pin pass-through connector.
  • Disconnect the injector from the internal injector harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 2 on the 4-pin pass-through connector to engine block ground.
  • Measure the resistance from pin 1 on the 4-pin pass-through connector to engine block ground.

Make sure that the pigtail nuts do not contact the engine.

OK NOT OK

Greater than 100k ohms?

Replace the internal injector harness. Refer to Procedure 019-063 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove valve cover.
  • Disconnect the injector from the internal injector harness.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the solenoid posts on injector number 4.

Subtract multimeter lead resistance to get true solenoid resistance.
OK NOT OK

Less than 0.5 ohms?

Replace the injector. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 332 is inactive.
OK NOT OK

Fault Code 332 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jul-2012


FAULT CODE 341 - Engine Control Module (ECM) Flash Memory

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the inactive counts of Fault Code 341. | Less than five inactive counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 341 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the inactive counts of Fault Code 341.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 341.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 341.
OK NOT OK

Less than five inactive counts?

Calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for at least 1 minute.
  • Verify that Fault Code 341 is inactive.
OK NOT OK

Fault Code 341 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jul-2012


FAULT CODE 343 - Engine Control Module (ECM)

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade).

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 689 and 778 inactive?
STEP 2. | Check for moisture in the ECM connectors. |
 | STEP 2A. Check for moisture in the ECM connectors. | Connectors dry?
STEP 3. | Check the power and ground connections. |
 | STEP 3A. Check all engine and chassis power and ground connections. | Clean and tight?
 | STEP 3B. Check all power resistances. | Less than 10 ohms?
 | STEP 3C. Check all ground resistances. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 689 and 778 inactive?

Go to Fault Codes 689 and 778.

Go to 2A

Fault Codes 689 and 778

Guided Step 2 - Check for moisture in the ECM connectors.

Guided Step 2A - Check for moisture in the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor harness connector from the ECM.

Action

Check for moisture in the ECM connectors.

  • Check for moisture in the ECM connectors.
OK NOT OK

All connectors dry?

Dry the connectors. Dry the connectors with electrical contact cleaner, Part Number 3824510.

Go to 3A

Go to 4A

Guided Step 3 - Check the power and ground connections.

Guided Step 3A - Check all engine and chassis power and ground connections.

Conditions

Turn keyswitch OFF.

Action

Check all engine and vehicle power and ground connections for the following:

  • Corrosion
  • Loose connections.
OK NOT OK

Clean and tight?

Repair damaged connections. Repair or replace the damaged connections.

Go to 3B

Go to 4A

Guided Step 3B - Check all power resistances.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the negative (-) battery cable from the battery.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check all power resistances.

  • Measure the resistance from pin 1 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 7 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 12 of the OEM harness connector to the positive (+) battery terminal connector.
  • Measure the resistance from pin 13 of the OEM harness connector to the positive (+) battery terminal connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check all ground resistances.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the negative (-) battery cable from the battery.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check all ground resistances.

  • Measure the resistance from pin 3 of the OEM harness connector to the negative (-) battery terminal connector.
  • Measure the resistance from pin 9 of the OEM harness connector to the negative (-) battery terminal connector.
  • Measure the resistance from pin 14 of the OEM harness connector to the negative (-) battery terminal connector.
  • Measure the resistance from pin 15 of the OEM harness connector to the negative (-) battery terminal connector.
OK NOT OK

Less than 10 ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 343 is inactive.
OK NOT OK

Fault Code 343 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jul-2012


FAULT CODE 352 - Sensor Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164113 - Bosch® .6 socket test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to reduce the possibility of pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensors. |
 | STEP 1A. Check the intake manifold pressure/temperature sensor. | Fault Code 352 still active when sensor is removed. Less than 4.5-VDC?
 | STEP 1B. Check the remote accelerator sensor. | Fault Code 352 still active when sensor is removed. Less than 4.5-VDC?
 | STEP 1C. Check the OEM pressure sensor. | Fault Code 352 still active when sensor is removed. Less than 4.5-VDC?
 | STEP 1D. Check the coolant level sensor. | Fault Code 352 still active when sensor is removed. Less than 4.5-VDC?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 352 active?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2E. Check the sensor supply voltage at the ECM. | 4.75 to 5.25-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 352 active?
 | STEP 3C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensors.

Guided Step 1A - Check the intake manifold pressure/temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness sensor connector.

Action

Check the intake manifold pressure/temperature sensor.

  • Measure the voltage from pin 1 to pin 3 at the engine harness sensor connector.
OK NOT OK

Less than 4.5-VDC?

Replace the intake manifold pressure/temperature sensor if the supply voltage is 4.75 to 5.25 with the sensor disconnected and the fault code is active with the sensor connected. Refer to Procedure 019-159.

Go to 1B

Go to 4A

Guided Step 1B - Check the remote accelerator sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the remote accelerator sensor from the OEM harness.

Action

Check the remote accelerator sensor.

  • Measure the supply voltage from pin A to pin B at the OEM harness sensor connector.
OK NOT OK

Less then 4.5-VDC?

Replace the remote accelerator sensor if the supply voltage is 4.75 to 5.25 with the sensor disconnected and the fault code is active with the sensor connected. Rerfer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the OEM pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check the OEM pressure sensor.

  • Measure the voltage from pin A to pin B at the OEM harness sensor connector.
OK NOT OK

Less then 4.5-VDC?

Replace the OEM Sensor if the supply voltage is 4.75 to 5.25 with the sensor disconnected and the fault code is active with the sensor connected. Use the OEM troubleshooting and repair manual.

Go to 1D

Go to 4A

Guided Step 1D - Check the coolant level sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant level sensor from the OEM harness.

Action

Check the coolant level sensor.

  • Measure the supply voltage from pin B to pin C at the OEM harness sensor connector.
OK NOT OK

Less than 4.5-VDC?

Replace the coolant level sensor if the supply voltage is 4.75 to 5.25 with the sensor disconnected and the fault code is active with the sensor connected. Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check the coolant level sensor.Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Gently pull on each wire to verify that it is locked in the connector and not a pushed back pin.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 352 active?

Fault Code 352 inactive?

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 of the engine harness connector to all the other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance from pin 10 of the engine harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 2E - Check the sensor supply voltage at the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Check for the sensor supply voltage.

  • Measure the voltage at the ECM from pin 10 to 21.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for the sensor supply voltage.Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Gently pull on each wire to verify that it is locked in the connector and not a pushed back pin.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 352 active?

Fault Code 352 inactive?

Go to 3C

Go to 4B

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the remote accelerator sensor from the OEM harness.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 68 of the OEM harness connector to all the other pins in the connector except pin 69.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the remote accelerator sensor from the OEM harness.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin 68 of the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 352 is inactive.
OK NOT OK

Fault Code 352 inactive?

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


FAULT CODE 381 - Intake Air Heater Number 1 Circuit Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check intake air heater number 1. |
 | STEP 1A. Verify intake air heater number 1 is connected. | Intake air heater number 1 connected?
 | STEP 1B. Read the fault codes. | Fault Code 381 active?
 | STEP 1C. Check the resistance of the intake air heater number 1. | Less than 1 ohm?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 381 active?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 381 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check intake air heater number 1.

Guided Step 1A - Verify intake air heater number 1 is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify intake air heater number 1 is connected to the OEM harness.
OK NOT OK

Intake air heater number 1 connected

Intake air heater number 1 not connected

  • Connect the intake air heater number 1.
  • If intake air heaters are not used on the engine, then disable the intake air heater feature using an electronic service tool.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 381 active

Fault Code 381 inactive.

Go to 1C

Go to 3B

Guided Step 1C - Check the resistance of the intake air heater number 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the intake air heater number 1.

Action

Check the resistance of the intake air heater number 1.

  • Measure the resistance from pin 1 to pin 2 at the intake air heater.
OK NOT OK

Less than 1 ohm

Replace the intake air heater. Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the intake air heater number 1.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 381 active?

Fault Code 381 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the intake air heater number 1.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 4 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 16 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the intake air heater number 1.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the OEM harness intake air heater connector to pin 16 of the OEM harness ECM connector.
  • Measure the resistance from pin 2 of the OEM harness intake air heater connector to pin 4 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19 or Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the intake air heater number 1.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 4 of the OEM harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 16 of the OEM harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 381 is inactive.
OK NOT OK

Fault Code 381 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2015


FAULT CODE 382 - Intake Air Heater Number 2 Circuit Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check intake air heater number 2. |
 | STEP 1A. Verify intake air heater number 2 is connected. | Intake air heater number 2 connected?
 | STEP 1B. Read the fault codes. | Fault Code 382 active?
 | STEP 1C. Check the resistance of the intake air heater number 2. | Less than 1 ohm?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 382 active?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 382 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check intake air heater number 2.

Guided Step 1A - Verify intake air heater number 2 is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify intake air heater number 2 is connected to the OEM harness.
OK NOT OK

Intake air heater number 2 connected?

Intake air heater number 2 not connected

  • Connect the intake air heater number 2.
  • If intake air heaters are not used on the engine, then disable the intake air heater feature using an electronic service tool.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 382 active?

Fault Code 382 inactive.

Go to 1C

Go to 3B

Guided Step 1C - Check the resistance of the intake air heater number 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the intake air heater number 2.

Action

Check the resistance of the intake air heater number 2.

  • Measure the resistance from pin 1 to pin 2 at the intake air heater.
OK NOT OK

Less than 1 ohm?

Replace the intake air heater. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the intake air heater number 2.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 382 active?

Fault Code 382 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the intake air heater number 2.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 4 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 17 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the intake air heater number 2.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the OEM harness intake air heater connector to pin 17 of the OEM harness ECM connector.
  • Measure the resistance from pin 2 of the OEM harness intake air heater connector to pin 4 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-197 in Section 19 or Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the intake air heater number 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 4 of the OEM harness ECM connector to all other pins.
  • Measure the resistance from pin 17 of the OEM harness ECM connector to all other pins.
OK NOT OK

More than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 382 is inactive.
OK NOT OK

Fault Code 382 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jul-2012


FAULT CODE 386 - Sensor Supply A - High Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the 36-pin engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 386 active?
 | STEP 1C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1D. Check for an open circuit. | Less than 10 ohms?
 | STEP 1E. Check the supply voltage. | 4.75 to 5.25-VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 386 active?
 | STEP 2C. Check for a short circuit to battery voltage. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit. | Less than 10 ohms?
 | STEP 2F. Check the supply voltage. | 4.75 to 5.25-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the 36-pin engine harness.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 386 active?

Fault Code 386 inactive.

Go to 1C

Go to 3B

Guided Step 1C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 10 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness 36-pin connector to pin 3 of the sensor harness connector.
  • Measure the resistance from pin 21 of the engine harness 36-pin connector to pin 1 of the sensor harness connector.
  • Measure the resistance from pin 28 of the engine harness 36-pin connector to pin 4 of the sensor harness connector.
  • Measure the resistance from pin 29 of the engine harness 36-pin connector to pin 2 of the sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check the supply voltage.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin 10 to pin 21 at the ECM.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM harness from the remote accelerator sensor.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 386 active?

Fault Code 386 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit to the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM harness from the remote accelerator sensor.

Action

Check for a short circuit to battery voltage.

  • Measure the resistance from pin 68 of the OEM harness connector to pins 1, 5, 7, 8, 12, 13, 28, and 39 of the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM harness from the remote accelerator sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 68 of the OEM harness connector to all other pins in the connector except pin 69.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the OEM pressure sensor.
  • Disconnect the OEM harness from the coolant level sensor.
  • Disconnect the OEM harness from the remote accelerator sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 68, 50, and 85 respectively of the OEM harness connector to pin A, B, and C of the remote accelerator sensor harness connector.
  • Measure the resistance from pin 68, 50, and 82 respectively of the OEM harness connector to pin A, B, and C of the OEM pressure sensor harness connector.
  • Measure the resistance from pin 59, 50, 68, and 78 respectively of the OEM harness connector to pin A, B, C, and D of the coolant level sensor harness connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the supply voltage.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage.

  • Measure the voltage from pin 68 of the 89-pin OEM connector to engine block ground.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Verify that Fault Code 386 is inactive.
OK NOT OK

Fault Code 386 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jul-2012


FAULT CODE 389 - Fan Clutch Circuit Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fan clutch. |
 | STEP 1A. Verify fan clutch is connected. | Fan clutch connected?
 | STEP 1B. Inspect the fan clutch and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 1C. Read the fault codes. | Fault Code 389 active?
 | STEP 1D. Check fan clutch according to OEM guidelines (if applicable). | OEM specification?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 389 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 389 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check fan clutch.

Guided Step 1A - Verify fan clutch is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify fan clutch is connected to the OEM harness.
OK NOT OK

Fan clutch connected?

Fan clutch not connected.

  • Connect fan clutch.
  • If the fan clutch is not present, contact an authorized Cummins® Authorized Repair Location.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the fan clutch and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan clutch.

Action

Inspect the fan clutch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or fan clutch, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3894510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-205 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-214 in Section 19
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19
  • Replace the fan clutch. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 389 active?

Fault Code 389 inactive.

Go to 1D

Go to 3B

Guided Step 1D - Check fan clutch according to OEM guideline, if applicable.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fan clutch.

Action

Check the fan clutch according to OEM guidelines, if applicable.

  • Refer to manufacturer's installation and operation specifications.
OK NOT OK

OEM specification?

Repair or replace fan clutch. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the fan clutch.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3894510
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Sect5ion 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 389 active?

Fault Code 389 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the fan clutch.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the OEM harness fan clutch connector to pin 5 of the OEM harness ECM connector.
  • Measure the resistance from pin 2 of the OEM harness fan clutch connector to pin 10 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19 .
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the fan clutch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 5 of the OEM harness ECM connector to all other pins.
  • Measure the resistance from pin 10 of the OEM harness ECM connector to all other pins.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the fan clutch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 5 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 10 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 389 is inactive.
OK NOT OK

Fault Codes 389 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jul-2012


FAULT CODE 392 - Exhaust Brake Circuit Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check exhaust brake. |
 | STEP 1A. Verify exhaust brake is connected. | Exhaust brake connected?
 | STEP 1B. Read the fault codes. | Fault Code 392 active?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 392 active?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2F. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 392 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check exhaust brake.

Guided Step 1A - Verify exhaust brake is connected.

Conditions

  • Turn keyswitch OFF.

Action

Verify exhaust brake is connected.
OK NOT OK

Exhaust brake connected?

Exhaust brake not connected

  • Connect the exhaust brake.
  • If exhaust brakes are not used on the engine, then disable the exhaust brake feature using an electronic service tool.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 392 active?

Fault Code 392 inactive.

Go to 2A

Go to 3B

Guided Step 2 - Check OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the exhaust brake.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 392 active?

Fault Code 392 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the exhaust brake.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the exhaust brake connector to engine block ground.
  • Measure the resistance from pin 2 of the exhaust brake connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the exhaust brake.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the OEM harness exhaust brake connector to pin 11 of the OEM harness ECM connector.
  • Measure the resistance from pin 2 of the OEM harness exhaust brake connector to pin 4 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the exhaust brake.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 4 of the OEM harness ECM connector to all other pins.
  • Measure the resistance from pin 11 of the OEM harness ECM connector to all other pins.
OK NOT OK

Greater than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute
  • Verify that Fault Code 392 is inactive.
OK NOT OK

Fault Code 392 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 11-Jul-2012


FAULT CODE 412 - J1708 Data Link Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3823995 - Weather-Pack pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check communication with the ECM. |
 | STEP 1A. Check communication with the ECM over the J1708 data link. | Communication established?
 | STEP 1B. Read the engine speed and fault codes. | Fault Code 412 inactive?
STEP 2. | Check the J1708 data link. |
 | STEP 2A. Inspect the electronic service tool and J1708 data link connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the connectors for any other devices connected to the J1708 data link. | Dirty or damaged pins?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 412 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check communication with the ECM. |
 | STEP 4A. Check communication with the ECM over the J1708 data link. | Communication established?
 | STEP 4B. Check for malfunctioning J1708 devices. | Communication established?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 412 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check communication with the ECM.

Guided Step 1A - Check communication with the ECM over the J1708 datalink.

Conditions

  • Connect the electronic service tool to the J1708 connector.
  • Turn keyswitch ON.

Action

Check communication with the ECM over the J1708 data link.

  • Use INSITE™ electronic service tool to read the engine speed.
OK NOT OK

Communication established?

Communication not established.

Go to 1B

Go to 2A

Guided Step 1B - Read the engine speed and fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the engine speed and fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the engine speed and fault codes.
OK NOT OK

Fault Code 412 inactive?

Fault Code 412 active.

Go to 5A

Go to 2A

Guided Step 2 - Check the J1708 data link.

Guided Step 2A - Inspect the electronic service tool and J1708 data link connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic service tool from the J1708 data link.

Action

Inspect INSITE™ electronic service tool and the J1708 data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the J1708 data link connector or the electronic service tool connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the J1708 data link connector. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the electronic service tool connector. Use the appropriate electronic service tool manual.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the connectors for any other devices connected to the J1708 data link.

Conditions

  • Turn keyswitch OFF.
  • Disconnect devices from the J1708 data link (electronic dashes, automatic slip reduction system, and the automatic braking system).

Action

Inspect the connectors for any other devices connected to the J1708 data link.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the VECU(s), 2-pin connector, or multiplexed devices, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the VECU(s). Refer to the OEM troubleshooting and repair manual.
  • Repair the 2-pin connector. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Repair or replace the multiplexed devices. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic service tool.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 412 active?

Fault Code 412 inactive.

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic service tool.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 13 of the engine harness connector to pin A of the engine harness electronic service tool connector.
  • Measure the resistance from pin 14 of the engine harness connector to pin B of the engine harness electronic service tool connector.

This data link can also be available on the 89-pin OEM harness. Refer to the wiring diagram.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19
  • Repair the engine harness. Refer to Procedure 019-205 in Section 19
  • Repair the engine harness. Refer to Procedure 019-214 in Section 19
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic service tool.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 13 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin 14 of the engine harness connector to all other pins in the connector.

This data link can also be available on the 89-pin OEM harness. Refer to the wiring diagram.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic service tool.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 13 of the engine harness connector to engine block ground.
  • Measure the resistance from pin 14 of the engine harness connector to engine block ground.

This data link can also be available on the 89-pin OEM harness. Refer to the wiring diagram.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check communication with the ECM.

Guided Step 4A - Check communication with the ECM over the J1708 data link.

Conditions

  • Connect INSITE™ electronic service tool to the J1708 connector.
  • Connect all components.
  • Turn keyswitch ON.

Action

Check communication with the ECM over the J1708 data link.

  • Use INSITE™ electronic service tool to read the engine speed.
OK NOT OK

Communication established?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for malfunctioning J1708 devices.

Conditions

  • Connect the electronic service tool to the J1708 connector.
  • Connect all components.
  • Turn keyswitch ON.

Action

Check for malfunctioning J1708 devices.

  • Use INSITE™ electronic service tool to check for malfunctioning J1708 devices.
  • Disconnect devices one by one to find the failed device.
OK NOT OK

Communication established

Replace the J1708 device. Refer to OEM troubleshooting and repair manual.

Go to 5B

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 412 is inactive.
OK NOT OK

Fault Code 412 inactive?

Return to troubleshooting steps or contact your nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jul-2012


FAULT CODE 415 - Oil Pressure - Engine Protection - Fueling Derate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Check the oil fluid level. | Oil fluid filled to specification?
 | STEP 1B. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Check the oil fluid level.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil fluid level.

Check the oil fluid level.
OK NOT OK

Oil fluid filled to specification?

Oil fluid low. Fill to correct specifications.

Go to 1B

Go to 2A

Guided Step 1B - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect INSITE™ to vehicle data link.
  • Start the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge.

If necessary, rev the engine up to make it easier to see differences in the readings.
OK NOT OK

Sensor reading is correct?

Replace the oil pressure/temperature sensor. Refer to Procedure 019-155 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 415 is inactive.

If the fault was at a particular speed, run the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 415 inactive?

Return to the troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Jul-2012


FAULT CODE 415 - Engine Oil Pressure Low - Critical

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - male ISBe (4 and 6 cylinder) amp test lead and Part Number 3164112 - male ISBe (4 and 6 cylinder) amp test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Check the engine harness and engine control module (ECM). |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the supply voltage at the oil pressure connector. | 4.75 to 5.25-VDC?
 | STEP 3C. Check the supply voltage at the ECM. | 4.75 to 5.25-VDC?
STEP 4. | Check the oil pressure switch. |
 | STEP 4A. Check the oil pressure switch. | Less than 10 ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use the INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Active or inactive counts of Fault Code 415?

Repair complete

Go to 2A

Go to 5A

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch OFF.
  • Connect mechanical oil pressure gauge.
  • Turn keyswitch ON.
  • Start engine.

Action

Check the engine oil pressure.

  • Refer to Procedure 007-052 in Section 7 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.
OK NOT OK

Oil pressure greater than 48 kPa [7 psi]?

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 3A

Go to T105

Guided Step 3 - Check the engine harness and ECM.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Clean the connector pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-360 in Section 19.

Go to 5A

Go to 3B

Guided Step 3B - Check the supply voltage at the oil pressure connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil pressure SIGNAL pin 2 at the switch connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.
OK NOT OK

4.75 to 5.25-VDC?

Go to 4A

Go to 3C

Guided Step 3C - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the supply voltage at the ECM.

  • Measure the voltage between the engine oil pressure SIGNAL pin 9 at the engine harness ECM connector port and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the oil pressure switch.

Guided Step 4A - Check the oil pressure switch.

Conditions

  • Disconnect the engine harness from the oil pressure switch.
  • Turn keyswitch ON.
  • Start engine.

Action

Check the resistance of the switch.

  • Measure the resistance between the engine oil pressure SIGNAL pin of the engine oil pressure switch and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the oil pressure switch.

.

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all the components.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Use the INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 415 inactive?

Return to the troubleshooting steps, or contact a local Cummins® Authorized Repair Location if all the steps have been completed and rechecked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Jul-2012


FAULT CODE 422 - Coolant Level Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164113 - Bosch® .6 socket test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 187, 227, 238, 239, 352, or 386 inactive?
STEP 2. | Check for coolant level sensor. |
 | STEP 2A. Check vehicle for coolant level sensor. | Coolant level sensor present?
STEP 3. | Verify that the coolant is low. |
 | STEP 3A. Check the coolant level. | Coolant level normal?
STEP 4. | Check coolant level sensor. |
 | STEP 4A. Verify fault is still active with engine running. | Fault Code 422 active?
 | STEP 4B. Inspect the coolant level sensor and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Read the fault codes. | Fault Code 422 active?
STEP 5. | Check for shorting plug. |
 | STEP 5A. Check for installed shorting plug. | Shorting plug installed?
STEP 6. | Check the OEM harness and ECM. |
 | STEP 6A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 6B. Read the fault codes. | Fault Code 422 active?
 | STEP 6C. Check for an open circuit. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 7. | Check the ECM response. |
 | STEP 7A. Check the ECM response high. | Fault Code 197 inactive and Fault Code 422 inactive?
 | STEP 7B. Check the ECM response low. | Fault Code 197 active and Fault Code 422 inactive
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 422 inactive?
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 187, 227, 238, 239, 352, or 386 inactive?

Troubleshoot Fault Codes 187, 227, 238, 239, 352, and 386 first.

Go to 2A

Go to the appropriate troubleshooting charts

Guided Step 2 - Check for coolant level sensor.

Guided Step 2A - Check vehicle for coolant level sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check vehicle for coolant sensor.

Check vehicle for coolant sensor.
OK NOT OK

Coolant level sensor present

Coolant level sensor not present. Install coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Verify that the coolant is low.

Guided Step 3A - Check the coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check vehicle for coolant sensor.

  • Remove the radiator cap and inspect coolant level.
OK NOT OK

Coolant level normal?

Add coolant to the radiator

Make sure coolant has proper mix of antifreeze to water.

Go to 4A

Go to 8A

Guided Step 4 - Inspect the OEM harness.

Guided Step 4A - Verify fault is still active with the engine running.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Verify fault code is still active.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 422 active?

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Fault Code 422 inactive.

Go to 4B

Go to 8B

Guided Step 4B - Inspect the coolant level sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the coolant level sensor.

Action

Inspect the OEM harness and the coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the coolant level sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Go to 4C

Go to 8A

Guided Step 4C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 422 active?

Fault Code 422 inactive.

Go to 5A

Go to 8B

Guided Step 5 - Check for shorting plug.

Guided Step 5A - Check for installed shorting plug.

Conditions

  • Turn keyswitch OFF.

Action

Check for installed shorting plug.

Check for installed shorting plug.
OK NOT OK

Shorting plug installed?

Install shorting plug. Refer to Procedure 019-324 in Section 19.

Go to 6A

Go to 8A

Guided Step 6 - Check the OEM harness and ECM.

Guided Step 6A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 6B

Go to 8A

Guided Step 6B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 422 active?

Fault Code 422 inactive.

Go to 6C

Go to 8B

Guided Step 6C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness sensor connector from the coolant level sensor connector.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance from pin 59 of the OEM harness connector to pin A of the OEM harness sensor connector.
  • Measure the resistance from pin 78 of the OEM harness connector to pin D of the OEM harness sensor connector.
  • Measure the resistance from pin 50 of the OEM harness connector to pin B of the OEM harness sensor connector.
  • Measure the resistance from pin 68 of the OEM harness connector to pin C of the OEM harness sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6D

Go to 8A

Guided Step 6D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness sensor connector from the coolant level sensor.

Action

Check for a short circuit from pin to pin.

  • Measure resistance from pin 59 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 78 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 50 of the OEM harness ECM connector to all other pins in the connector.
  • Measure resistance from pin 68 of the OEM harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6E

Go to 4B

Guided Step 6E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness sensor connector from the coolant level sensor.

Action

Check for a short circuit to engine block ground.

  • Measure resistance from pin 59 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 78 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 50 of the OEM harness ECM connector to engine block ground.
  • Measure resistance from pin 68 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the ECM response.

Guided Step 7A - Check the ECM response high.

Conditions

  • Disconnect the OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM response high.

  • Install a jumper wire from pin 68 to pin 78 at the ECM.
OK NOT OK

Fault Code 197 inactive and Fault Code 422 inactive?

Replace coolant level sensor. Refer to Procedure 019-017 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7B

Go to 8A

Guided Step 7B - Check the ECM response low.

Conditions

  • Disconnect the OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM response low.

  • Install a jumper wire from pin 68 to pin 59 at the ECM.
OK NOT OK

Fault Code 197 active and Fault Code 422 inactive?

Replace the coolant level sensor. Refer to Procedure 019-017 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 422 is inactive.
OK NOT OK

Fault Code 422 inactive?

Return to the troubleshooting steps or contact your nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jul-2012


FAULT CODE 426 - J1939 Datalink Communication

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164113 - Bosch® .6 socket test lead and Part Number 3823993 - Deutsch™ Number 16 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for proper multiplexing configuration. |
 | STEP 1A. Verify that the proper devices are set. | INSITE™ electronic service tool readout matches ECM settings for devices?
 | STEP 1B. Read the engine speed and fault codes. | Fault Code 426 inactive?
STEP 2. | Inspect the J1939 connector and OEM harness connectors. |
 | STEP 2A. Inspect the ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Inspect the connectors for any other device connected to the J1939 data link. | Dirty or damaged pins?
STEP 3. | Inspect the J1939 backbone harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check the resistance value in the J1939 harness. | 55 to 65 ohms?
 | STEP 3C. Check for a short circuit to power. | Less than 8.0-VDC?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check for malfunctioning J1939 devices. |
 | STEP 4A. Check communication with the ECM using the J1939 data link. | Established communication?
 | STEP 4B. Check for malfunctioning J1939 devices. | Proper communication between J1939 devices and ECM?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for proper multiplexing configuration.

Guided Step 1A - Verify that the proper devices are set.

Conditions

  • Connect INSITE™ electronic service tool to the J1939 connector using the INLINE™ II data link adapter.
  • Turn keyswitch ON.

Action

Check that the correct vehicle inputs are multiplexed over the J1939 data link.

  • Use INSITE™ electronic service tool to read the devices that are sending input information.
OK NOT OK

INSITE™ readout matches ECM settings for devices?

Configure the ECM to match the multiplexing devices

Go to 1B

Go to 5A

Guided Step 1B - Read the engine speed and fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the engine speed and fault codes.

  • Use INSITE™ electronic service tool to read the engine speed.
  • Check for any active fault codes.
OK NOT OK

Fault Code 426 inactive?

Fault Code 426 active.

Go to 5B

Go to 2A

Guided Step 2 - Inspect the J1939 connector and OEM harness connectors.

Guided Step 2A - Inspect the ECM connectors.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the multiplexed devices.

Action

Inspect the ECM, OEM harness, J1939 connector, and multiplexed devices for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the OEM harness, J1939, or multiplexed devices, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the J1939 data link. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the J1939 data link. Refer to Procedure 019-071 in Section 19.
  • Refer to the OEM troubleshooting and repair manual for specific multiplexed device.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the connectors on any other device connected to the J1939 data link.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VECU(s) from the J1939 backbone harness.
  • Disconnect the multiplexed devices from the VECU(s).

Action

Inspect the connectors on the VECU(s), 3-pin, and multiplexed devices connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the VECU(s), 3-pin connector, or multiplexed devices, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the VECU(s). Refer to the OEM troubleshooting and repair manual.
  • Repair the 3-pin connector. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the J1939 backbone harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 connector from the VECU(s).

Action

Check for an open circuit.

  • Measure resistance from pin 51 at the OEM harness connector to pin C at the data link connector.
  • Measure resistance from pin 52 at the OEM harness connector to pin B at the data link connector.
  • Measure resistance from pin 53 at the OEM harness connector to pin A at the data link connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair or replace the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the resistance value in the J1939 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the resistance value of the J1939 harness.

  • Measure from pin 53 in the OEM harness connector to pin 52 in the OEM harness connector.
OK NOT OK

55 to 65 ohms?

J1939 backbone termination resistors missing or damaged

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to power.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short to power.

  • Measure the voltage from pin 52 at the ECM to ground.
  • Measure the voltage from pin 53 at the ECM to ground.
OK NOT OK

Less than 8.0-VDC?

Repair or replace the OEM harness

  • Repair or replace the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 51 in the OEM harness connector to all other pins in the connector, except pins 52 and 53.
  • Measure the resistance from pin 52 in the OEM harness connector to all other pins in the connector, except pins 51 and 53.
  • Measure the resistance from pin 53 in the OEM harness connector to all other pins in the connector, except pins 51 and 52.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair or replace the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for short to ground.

  • Measure the resistance from pin 52 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 53 in the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair or replace the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for malfunctioning J1939 devices.

Guided Step 4A - Check communication with the ECM using the J1939 datalink.

Conditions

  • Connect INSITE™ electronic service tool to the J1939 connector using the INLINE™ II data link adapter.
  • Disconnect all J1939 devices from the J1939 data link.
  • Turn keyswitch ON.

Action

Check communication with the ECM using the J1939 data link.
OK NOT OK

Established communication?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for malfunctioning J1939 devices.

Conditions

  • Connect INSITE™ electronic service tool to the J1939 connector using the INLINE™II data link adapter.
  • Connect all J1939 devices to the data link.
  • Turn keyswitch ON.

Action

Check for malfunctioning J1939 devices.

  • Disconnect J1939 devices from the J1939 backbone one by one until communication can be established using INSITE™ electronic service tool.

Before disconnecting J1939 devices, remember to turn keyswitch OFF, so ECM will not register fault code; then turn keyswitch ON to establish communication with INSITE™ electronic service tool.

OK NOT OK

Proper communication between J1939 devices and ECM?

Replace malfunctioning J1939 device. Refer to OEM troubleshooting and repair manual for repair procedures.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 426 is inactive.
OK NOT OK

Fault Code 426 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jul-2012


FAULT CODE 427 - J1939 Data Link Communication

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164113 - Bosch® .6 socket test lead and Part Number 3823993 - Deutsch™ Number 16 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM for proper multiplexing configuration. |
 | STEP 1A. Verify that the proper devices are set. | INSITE™ electronic service tool readout matches ECM settings for devices?
 | STEP 1B. Read the engine speed and fault codes. | Fault Code 427 inactive?
STEP 2. | Inspect the J1939 connector and OEM harness connectors. |
 | STEP 2A. Inspect the ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Inspect the connectors for any other device connected to the J1939 data link. | Dirty or damaged pins?
STEP 3. | Inspect the J1939 harness. |
 | STEP 3A. Check for an open circuit. | Less than 10 ohms?
 | STEP 3B. Check the resistance value in the J1939 harness. | 55 to 65 ohms?
 | STEP 3C. Check for a short circuit to power. | Less than 8.0-VDC?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check J1939 devices. |
 | STEP 4A. Check communication with the ECM using the J1939 data link. | Established communication?
 | STEP 4B. Check for malfunctioning J1939 devices. | Proper communication between J1939 devices and ECM?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 427 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM for proper multiplexing configuration.

Guided Step 1A - Verify that the proper devices are set.

Conditions

  • Connect the electronic service tool to the J1939 connector using the INLINE™ II data link adapter.
  • Turn keyswitch ON.

Action

Check that the correct vehicle inputs are multiplexed over the J1939 data link.

  • Read the devices that are sending input information with INSITE™ electronic service tool.
OK NOT OK

INSITE™ readout matches ECM settings for devices?

Configure the ECM to match the multiplexing devices

Go to 1B

Go to 5A

Guided Step 1B - Read the engine speed and fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the engine speed and fault codes.

  • Use INSITE™ electronic service tool to read the engine speed.
  • Check for any active fault codes.
OK NOT OK

Fault Code 427 inactive?

Fault Code 427 active.

Go to 5B

Go to 2A

Guided Step 2 - Inspect the J1939 connector and OEM harness connectors.

Guided Step 2A - Inspect the ECM connectors.

Conditions

  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the multiplexed devices.

Action

Inspect the ECM, OEM harness, J1939 connector, and multiplexed devices for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the OEM harness, J1939, or multiplexed devices, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair the J1939 data link. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the J1939 datalink. Refer to Procedure 019-071 in Section 19.
  • Use the OEM troubleshooting and repair manual for specific multiplexed device.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the connectors on any other device connected to the J1939 data link.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VECU(s) from the J1939 backbone harness.
  • Disconnect the multiplexed devices from the VECU(s).

Action

Inspect the connectors on the VECU(s), 3-pin, and multiplexed devices' connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Repair or replace the VECU(s), 3-pin connector, or multiplexed devices, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the VECU(s). Refer to the OEM troubleshooting and repair manual.
  • Repair the 3-pin connector. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19, or Refer to Procedure 019-214 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the J1939 backbone harness.

Guided Step 3A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 connector from the VECU(s).

Action

Check for an open circuit.

  • Measure resistance from pin 51 at the OEM harness connector to pin C at the data link connector.
  • Measure resistance from pin 52 at the OEM harness connector to pin B at the data link connector.
  • Measure resistance from pin 53 at the OEM harness connector to pin A at the data link connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair or replace the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check the resistance value in the J1939 harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the resistance value of the J1939 harness.

  • Measure from pin 53 in the OEM harness connector to pin 52 in the OEM harness connector.
OK NOT OK

55 to 65 ohms?

J1939 backbone termination resistors missing or damaged

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to power.

Conditions

  • Disconnect the J1939 harness from the VECU(s).
  • Disconnect the OEM harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check for a short to power.

  • Measure the voltage from pin 52 at the ECM to ground.
  • Measure the voltage from pin 53 at the ECM to ground.
OK NOT OK

Less than 8.0-VDC?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 51 in the OEM harness connector to all other pins in the connector, except pins 52 and 53.
  • Measure the resistance from pin 52 in the OEM harness connector to all other pins in the connector, except pins 51 and 53.
  • Measure the resistance from pin 53 in the OEM harness connector to all other pins in the connector, except pins 51 and 52.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the J1939 harness from the VECU(s).

Action

Check for short to ground.

  • Measure the resistance from pin 52 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 53 in the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check J1939 devices.

Guided Step 4A - Check communication with the ECM using the J1939 data link.

Conditions

  • Connect INSITE™ electronic service tool to the J1939 connector using the INLINE™ II data link adapter.
  • Disconnect all J1939 devices from the J1939 data link.
  • Turn keyswitch ON.

Action

Check communication with ECM using INSITE™ over the J1939 data link.

Check communication with ECM using INSITE™ over the J1939 data link.
OK NOT OK

Established communication?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for malfunctioning J1939 devices.

Conditions

  • Connect INSITE™ electronic service tool to the J1939 connector using the INLINE™ II data link adapter.
  • Connect all J1939 devices to the data link.
  • Turn keyswitch ON.

Action

Check for malfunctioning J1939 devices.

  • Disconnect J1939 devices from the J1939 backbone one by one until communication can be established using INSITE™ electronic service tool.

Before disconnecting J1939 devices, remember to turn keyswitch OFF, so ECM will not register fault code; then turn keyswitch ON to establish communication with INSITE™ electronic service tool.

OK NOT OK

Proper communication between J1939 devices and ECM?

Replace malfunctioning J1939 device. Refer to the OEM troubleshooting and repair manual for repair procedures.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 427 is inactive.
OK NOT OK

Fault Code 427 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 16-Jul-2012


FAULT CODE 429 - Water-In-Fuel Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, Part Number 3164113 - Bosch® .6 socket test lead and Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the water-in-fuel sensor. |
 | STEP 1A. Inspect the water-in-fuel sensor and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 429 active?
 | STEP 1C. Check the resistance of the water-in-fuel sensor. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 429 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Read the fault codes. |
 | STEP 3A. Read the fault codes. | Fault Code 429 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 429 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the water-in-fuel sensor.

Guided Step 1A - Inspect the water-in-fuel sensor and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the water-in-fuel sensor.

Action

Inspect the WIF sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the water-in-fuel sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness.Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the water-in-fuel sensor. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 429 active?

Fault Code 429 inactive

Go to 1C

Go to 4B

Guided Step 1C - Check the resistance of the water-in-fuel sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the water-in-fuel sensor.

Action

Check the resistance in the water-in-fuel sensor.

  • Measure the resistance from pin A to pin B at the water-in-fuel sensor.
OK NOT OK

Greater than 100k ohms?

Replace the water-in-fuel sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the water-in-fuel sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 429 active

Fault Code 429 inactive

Go to 2C

4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the water in fuel sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 32 of the OEM harness to pin A of the OEM harness water-in-fuel sensor connector.
  • Measure the resistance from pin 87 of the OEM harness to pin B of the OEM harness water-in-fuel sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19, or Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the water-in-fuel sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 32 of the OEM harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 87 of the OEM harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the water-in-fuel sensor.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin A of the OEM harness water-in-fuel sensor connector to engine block ground.
  • Measure the resistance from pin B of the OEM harness water-in-fuel sensor connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness.Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Read the fault codes.

Guided Step 3A - Read the fault codes.

Conditions

  • Connect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the water-in-fuel sensor.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Disconnect the OEM harness from the water-in-fuel sensor.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 429 active?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that the Fault Code 429 is inactive.
OK NOT OK

Fault Code 429 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 17-Jul-2012


FAULT CODE 431 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death. Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® pin test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the idle validation switch is connected to the OEM harness and has lubricant. | Idle validation switch connected and has lubricant?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 active?
 | STEP 1C. Inspect the OEM harness and idle validation switch connector. | Dirty or damaged pins?
 | STEP 1D. Read the fault codes. | Fault Code 431 active?
 | STEP 1E. Check for an open circuit. | Less than 125 ohms?
 | STEP 1F. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 431 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check the ECM supply. | 4.75 to 5.25-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the idle validation switch is connected to the OEM harness and has lubricant.

Conditions

  • Turn keyswitch OFF.

Action

Verify the idle validation switch is connected to the OEM harness.
OK NOT OK

Idle validation switch connected and has lubricant?

Connect the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 active?

Pedal not calibrated. Fault Code 431 inactive.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the OEM harness and idle validation switch connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the engine harness and idle validation switch connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness or the idle validation switch, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 active?

Fault Code 431 inactive.

Go to 1E

Go to 3B

Guided Step 1E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for an open circuit in the idle validation switch.

  • Measure the resistance from pin A to pin B on the switch side of the idle validation switch connector with the accelerator pedal released.
  • Measure the resistance from pin C to pin A on the switch side of the idle validation switch connector with the accelerator pedal depressed.
OK NOT OK

Less than 125 ohms?

Replace the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 1F

Go to 3A

Guided Step 1F - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin-to-pin in the idle validation switch.

  • Measure the resistance from pin B to pin C on the switch side of the idle validation switch connector with the accelerator pedal released and depressed.
OK NOT OK

Greater than 100k ohms?

Replace the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 active?

Fault Code 431 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 on the harness side of the OEM harness connector to pin A on the harness side of the idle validation switch connector.
  • Measure the resistance from pin 72 on the harness side of the OEM harness connector to pin B on the harness side of the idle validation switch connector.
  • Measure the resistance from pin 73 on the harness side of the OEM harness connector to pin C on the harness side of the idle validation switch connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 19 of the OEM harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 72 of the OEM harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin 73 of the OEM harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to ground.

  • Measure the resistance from pin 19 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 72 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 73 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the ECM supply voltage.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM supply voltage.

  • Measure the voltage at the ECM from pin 19 to pin 55.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn keyswitch ON and completely depress and release the accelerator pedal four to five times.
  • Turn keyswitch OFF for 5 seconds.
  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 19-Jul-2012


FAULT CODE 432 - Accelerator Pedal Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check accelerator pedal. |
 | STEP 1A. Inspect the accelerator pedal and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 432 active?
 | STEP 1C. Calibrate the accelerator pedal. | Fault Code 432 active?
 | STEP 1D. Check the resistance of the accelerator position sensor. | Released: 1500 to 3000 ohms, Depressed: 250 to 1500 ohms?
 | STEP 1E. Check for an open circuit. | 2000 to 3000 ohms?
 | STEP 1F. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness, bulkhead connector, and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 432 active
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check the voltage supply. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 432 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check accelerator pedal.

Guided Step 1A - Inspect the accelerator pedal and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator from the OEM harness.

Action

Inspect the throttle pedal and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the accelerator pedal assembly, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the accelerator pedal assembly. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 432 active?

Fault Code 432 inactive.

Go to 1C

Go to 4B

Guided Step 1C - Calibrate the accelerator pedal.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 432 active?

Accelerator pedal not calibrated. Fault Code 432 inactive.

Go to 1D

Go to 4A

Guided Step 1D - Check the resistance of the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance of the accelerator position sensor.

  • Measure the resistance from pin B to pin C on the accelerator position sensor with the pedal in the released (idle) position.
  • Measure the resistance from pin B to pin C on the accelerator position sensor with the pedal in the depressed (full-fuel) position.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for an idle validation switch; a 6-pin repair connector, Part Number 3824910, for an integrated sensor switch; and a breakout cable, Part Number 3824892, for a solid state integrated sensor switch if needed.

OK NOT OK

Released: 1500 to 3000 ohms. Depressed: 250 to 1500 ohms. Released value must be at least 1000 ohms greater than depressed value?

Replace the accelerator pedal assembly. Refer to the OEM troubleshooting and repair manual.

Go to 1E

Go to 4A

Guided Step 1E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin A to pin C at the accelerator position sensor. (The pedal can be either released or depressed.)

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for an idle validation switch; a 6-pin repair connector, Part Number 3824910, for an integrated sensor switch; and a breakout cable, Part Number 3824892, for a solid state integrated sensor switch if needed.

OK NOT OK

2000 to 3000 ohms?

Replace the accelerator pedal assembly. Refer to the OEM troubleshooting and repair manual.

Go to 1F

Go to 4A

Guided Step 1F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin B at the accelerator position sensor to chassis ground.
  • Measure the resistance from pin C at the accelerator position sensor to chassis ground.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for an idle validation switch; a 6-pin repair connector, Part Number 3824910, for an integrated sensor switch; and a breakout cable, Part Number 3824892, for a solid state integrated sensor switch if needed.

OK NOT OK

Greater than 100k ohms?

Replace the accelerator pedal assembly. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness, bulkhead connector, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 432 active?

Fault Code 432 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 55 of the OEM harness connector to pin C on the OEM harness accelerator position sensor connector.
  • Measure the resistance from pin 81 of the OEM harness connector to pin A on the OEM harness accelerator position sensor connector.
  • Measure the resistance from pin 83 of the OEM harness connector to pin B on the OEM harness accelerator position sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 55 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 81 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin 83 in the OEM harness to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 55 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 81 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin 83 in the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the voltage supply.

Conditions

  • Connect the OEM harness connector to the ECM.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Turn keyswitch ON.

Action

Check the voltage supply at the ECM.

  • Measure the voltage from pin A to pin C at the OEM harness accelerator position sensor connector.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure twice.
  • Verify that Fault Code 432 is inactive.
OK NOT OK

Fault Code 432 inactive?

Fault Code 432 active.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 433 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure/temperature sensor. |
 | STEP 1A. Inspect the sensor circuit for tampering. | No tampering?
 | STEP 1B. Inspect the intake manifold pressure/temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1C. Read the fault codes. | Fault Code 433 active?
 | STEP 1D. Measure the supply voltage. | 4.75 to 5.25-VDC?
 | STEP 1D-1. Measure the voltage from the ECM. |
 | STEP 1E. Measure the signal voltage. | 0.10 to 0.25-VDC?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 433 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check for alternate fuel sources. | No alternate sources?
 | STEP 2G. Check for injectors out of specification. | Within specification?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 433 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the intake manifold pressure/temperature sensor.

Guided Step 1A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure/temperature sensor and engine harness for external wires or damaged harness braiding.
OK NOT OK

No tampering

Remove and record tampering. If tampering has occurred, repair the circuit, and record the tampering.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the intake manifold pressure/temperature sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the intake manifold pressure/temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 433 active?

Fault Code 433 inactive.

Go to 1D

Go to 3B

Guided Step 1D - Measure the supply voltage.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness connector.
  • Turn keyswitch ON.

Action

Measure the supply voltage.

  • Measure the supply voltage from pin 1 to pin 3 of the engine harness sensor connector.
OK NOT OK

4.75 to 5.25-VDC?

Does not meet specifications.

Go to 1E

Go to 1D-1

Guided Step 1D-1 - Measure the voltage from the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the ECM.

  • Measure the voltage from pin 10 to pin 21 at the ECM.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Measure the signal voltage.

Conditions

  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the signal voltage.

  • Measure the signal voltage from pin 4 of the engine harness sensor connector to the battery negative (-) post.
OK NOT OK

0.10 to 0.25-VDC?

Does not meet specifications.

Go to 2A

Go to 3A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Gently pull on each wire to verify that it is locked in the connector and not a pushed back pin.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 433 active

Fault Code 433 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect intake manifold pressure/temperature sensor from engine harness.

Action

Check for an open circuit.

  • Measure the resistance from pin 10 of the engine harness 36-pin connector to pin 3 of the sensor connector.
  • Measure the resistance from pin 21 of the engine harness 36-pin connector to pin 1 of the sensor connector.
  • Measure the resistance from pin 28 of the engine harness 36-pin connector to pin 4 of the sensor connector.
  • Measure the resistance from pin 29 of the engine harness 36-pin connector to pin 2 of the sensor connector.
OK NOT OK

Less than 10 ohms

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19. Refer to Procedure 019-202 in Section 19. Refer to Procedure 019-205 in Section 19. Refer to Procedure 019-214 in Section 19. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect intake manifold pressure/temperature sensor from engine harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 10 in the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 21 in the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 28 in the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 29 in the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the intake manifold pressure/temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 10 in the engine harness 36-pin connector to the engine block ground.
  • Measure the resistance from pin 28 in the engine harness 36-pin connector to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for alternate fuel sources.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for alternate fuel sources creating extra boost:

  • Ether bottles
  • Blown or leaking turbocharger seals
  • Charge air cooler filled with oil
  • Sources external to engine, vapors, etc.
OK NOT OK

No alternate sources?

Remove alternate fuel sources.

Go to 2G

Go to 3A

Guided Step 2G - Check for injectors out of specification.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for injectors for compliance with specification.

  • Run cylinder diagnostics with service tool.

Depending on symptoms, different test will be required. See guidelines for recommended diagnostic tests. If diagnostics are inconclusive, consider cylinders with higher exhaust temperatures, excessive smoke, or fuel knock.

OK NOT OK

Within specification?

Proceed with troubleshooting conclusions from injector diagnostic testing.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 433 is inactive.
OK NOT OK

Fault Code 433 inactive?

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-May-2012


FAULT CODE 434 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | No active or inactive injector fault codes?
STEP 2. | Check the battery. |
 | STEP 2A. Check the battery connections. | Connections are tight and corrosion free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least 12-VDC for (12-VDC systems) or 24-VDC for (24-VDC systems), Cranking: At least 6.2-VDC for (12-VDC systems) or 12-VDC for (24-VDC systems)?
STEP 3. | Check fuse. |
 | STEP 3A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 3B. Check for blown fuse. | Fuse not blown?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 434 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4F. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 4G. Check for a short circuit to ground. | Less than 10 ohms?
 | STEP 4G. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Dirty or damaged wires?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 434 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No active or inactive injector fault codes?

Troubleshoot the injector fault codes. Reference the appropriate injector fault code tree.

Go to 2A

Go to 5A

Guided Step 2 - Check the battery.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.
OK NOT OK

Connections are tight and corrosion free?

Tighten the loose connections, and clean the terminals. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place positive (+) probe of the multimeter on the positive (+) battery terminal, and touch negative (-) probe to the negative (-) battery terminal while trying to start engine.
OK NOT OK

Normal conditions: At least 12-VDC for (12-VDC systems) or 24-VDC for (24-VDC systems), Cranking: At least 6.2-VDC for (12-VDC systems) or 12-VDC for (24-VDC systems)?

Charge or replace the battery. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check fuse.

Guided Step 3A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-amp fuse is installed correctly.

  • Inspect the 30-amp fuse for correct installation.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse installed correctly?

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for blown fuse.

  • Inspect the 30-amp fuse to see if it is blown.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse not blown?

Replace fuse. Refer to Procedure 019-198 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 434 active?

Repair complete.

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery post to pins 1, 7, 12, and 13 of the OEM harness ECM connector.
  • Measure the resistance from the negative (-) battery post to pins 3, 9, 14, and 15 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to all the other pins in the connector, except pins 7, 12, and 13.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 12, and 13.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 13.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 12.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 of the OEM harness ECM connector to all the other pins in the connector, except pins 9, 14, and 15.
  • Measure the resistance from pin 9 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 14, and 15.
  • Measure the resistance from pin 14 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 15.
  • Measure the resistance from pin 15 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 14.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 9 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 14 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 15 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4H

Go to 5A

Guided Step 4H - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair or replace the damaged wires. Refer to the OEM troubleshooting and repair manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 434 is inactive.
OK NOT OK

Fault Code 434 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 20-Jul-2012


FAULT CODE 441 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | No active or inactive injector fault codes?
STEP 2. | Check the battery. |
 | STEP 2A. Check the battery connections. | Connections are tight and corrosion free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least 12-VDC for (12-VDC systems) or 24-VDC for (24-VDC systems), Cranking: At least 6.2-VDC for (12-VDC systems) or 12-VDC for (24-VDC systems)?
STEP 3. | Check fuse. |
 | STEP 3A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 3B. Check for blown fuse. | Fuse not blown?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 441 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4F. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 4G. Check for a short circuit to ground. | Less than 10 ohms?
 | STEP 4H. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Dirty or damaged wires?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No active or inactive injector fault codes?

Troubleshoot the injector fault codes. Reference the appropriate injector fault code tree.

Go to 2A

Go to 5A

Guided Step 2 - Check the battery.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.
OK NOT OK

Connections are tight and corrosion free?

Tighten the loose connections, and clean the terminals. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place positive (+) probe of the multimeter on the positive (+) battery terminal, and touch negative (-) probe to the negative (-) battery terminal while trying to start engine.
OK NOT OK

Normal conditions: At least 12-VDC for (12-VDC systems) or 24-VDC for (24-VDC systems), Cranking: At least 6.2-VDC for (12-VDC systems) or 12-VDC for (24-VDC systems)?

Charge or replace the battery. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check fuse.

Guided Step 3A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-amp fuse is installed correctly.

  • Inspect the 30-amp fuse for correct installation.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse installed correctly?

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for blown fuse.

  • Inspect the 30-amp fuse to see if it is blown.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse not blown?

Replace fuse. Refer to Procedure 019-198 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 441 active?

Repair complete.

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery post to pins 1, 7, 12, and 13 of the OEM harness ECM connector.
  • Measure the resistance from the negative (-) battery post to pins 3, 9, 14, and 15 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to all the other pins in the connector, except pins 7, 12, and 13.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 12, and 13.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 13.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 12.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery leads.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness ECM connector to all the other pins in the connector, except pins 9, 14, and 15.
  • Measure the resistance from pin 9 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 14, and 15.
  • Measure the resistance from pin 14 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 15.
  • Measure the resistance from pin 15 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 14.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4F

Go to 5A

Guided Step 4F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4G

Go to 5A

Guided Step 4G - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 3 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 9 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 14 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 15 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4H

Go to 5A

Guided Step 4H - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair or replace the damaged wires. Reference the OEM troubleshooting and repair manual.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 441 is inactive.
OK NOT OK

Fault Code 441 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 449 - Fuel Pressure - High

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 111 inactive?
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than 20-VDC for 12-VDC system. Less than 32-VDC for 24-VDC system?
 | STEP 2B. Check the battery ground. | Less than 10 ohms?
 | STEP 2C. Check the alternator. | Alternator operates properly?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 inactive?

Go to Fault Code 111.

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check the battery voltage.

  • Measure the battery voltage from pin 1 of the OEM harness ECM connector to engine block ground.
  • Measure the battery voltage from pin 7 of the OEM harness ECM connector to engine block ground.
  • Measure the battery voltage from pin 12 of the OEM harness ECM connector to engine block ground.
  • Measure the battery voltage from pin 13 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Less than 20-VDC for 12-VDC system. Less than 32-VDC for 24-VDC system?

Install the battery system correctly. Refer to the OEM troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check the battery resistance.

  • Measure the resistance from pin 3 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 9 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 14 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 15 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Less than 10 ohms?

Install the battery system correctly. Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 3A

Guided Step 2C - Check the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator for normal operation.
OK NOT OK

Alternator operates properly?

Repair or replace the alternator. Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 442 is inactive.
OK NOT OK

Fault Code 442 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 449 - Fuel Pressure - High

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® 0.6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the electronic fuel control actuator. |
 | STEP 1A. Check for a mechanically stuck electronic fuel control actuator. | Click heard?
 | STEP 1B. Check resistance of the electronic fuel control actuator. | Resistance between 0.1 to 5 ohms?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 449 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 449 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the electronic fuel control actuator.

Guided Step 1A - Check for a mechanically stuck electronic fuel control actuator.

Conditions

  • Turn keyswitch ON.

Action

Check for a mechanically stuck electronic fuel control actuator using a click test.

  • Turn the keyswitch ON for 5 seconds; then turn the keyswitch OFF. An audible click will be heard when the keyswitch is turned OFF.
OK NOT OK

Click heard?

Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 1B

Go to 3A

Guided Step 1B - Check the resistance of the electronic fuel control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the electronic fuel control actuator.

Action

Check the resistance of the electronic fuel control actuator.

  • Measure the resistance from pin-1 to pin-2 at the electronic fuel control actuator.
OK NOT OK

Resistance between 0.1 to 5 ohms?

Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 2A

Go to 3A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 449 active?

Fault Code 449 inactive?

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-5 of the engine harness ECM connector to pin 2 of the electronic fuel control actuator connector.
  • Measure the resistance from pin-7 of the engine harness ECM connector to pin 1 of the electronic fuel control actuator connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness connectors.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-205 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-216 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-5 of the engine harness ECM connector to all other pins in the connector.
  • Measure the resistance from pin-7 of the engine harness ECM connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-5 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin-7 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 449 is inactive.
OK NOT OK

Fault Code 449 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if any steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jul-2012


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch® test lead, Part Number 3164110 - female Bosch® test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and RETURN circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and RETURN circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 451 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187, 227, 238, 239, 352, or 386 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting procedure

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damaged
  • Connector shell broken.
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and RETURN circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 in Section 19..

Repair

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damaged
  • Connector shell broken.
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken.
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and RETURN circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 451 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-May-2012


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch® test lead, Part Number 3164110 - female Bosch® test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187, 227, 238, 239, 352, or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 is inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and RETURN circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and RETURN circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 452 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187, 227, 238, 239, 352, or 386 active?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken.
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19..

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and RETURN circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 VDC SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 in Section 19.

Repair

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken.
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and RETURN circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 VDC SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damaged
  • Connector shell broken.
  • Damaged locking tab connector.

For general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 452 inactive?
YES NO
No Repair

Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-May-2012


FAULT CODE 488 - Intake Manifold Temperature Sensor - Engine Protection - Fueling Derate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 488 inactive and did not reoccur?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the intake manifold pressure/temperature sensor.
  • Connect INSITE™ electronic service tool to the data link.
  • Run the engine and compare the intake manifold temperature reading on INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer "OK" to this step.

Readings will possibly need to be checked while engine is operating at normal temperature conditions 82°C [180°F] coolant).
OK NOT OK

Sensor reading is correct?

Sensor reading incorrect. Replace intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Load and operate engine to typical operating temperature 82°C (180°F coolant).
  • Verify Fault Code 488 is inactive and did not reoccur.
OK NOT OK

Fault Code 488 inactive and did not reoccur?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2015


FAULT CODE 551 - Idle Validation Switch Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the idle validation switch is connected to the OEM harness and has lubricant. | Idle validation switch connected and has lubricant?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 551 active?
 | STEP 1C. Inspect the OEM harness and the idle validation switch connector pins. | Dirty or damaged pins?
 | STEP 1D. Read the fault codes. | Fault Code 551 active?
 | STEP 1E. Check for an open circuit. | Less than 125 ohms?
 | STEP 1F. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 551 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check the ECM supply voltage. | 4.75 to 5.25-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the idle validation switch is connected to the OEM harness and has lubricant.

Conditions

  • Turn keyswitch OFF.

Action

Verify the idle validation switch is connected to the OEM harness.

Verify the idle validation switch is connected to the OEM harness.
OK NOT OK

Idle validation switch connected and has lubricant?

Connect the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 551 active?

Pedal not calibrated. Fault Code 551 inactive.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the OEM harness and idle validation switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the engine harness and idle validation switch connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or idle validation switch, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Repair or replace the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 551 active?

Repair complete.

Go to 1E

Go to 3B

Guided Step 1E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for an open circuit in the idle validation switch.

  • Measure the resistance from pin A to pin B on the switch side of the idle validation switch connector with the accelerator pedal released.
  • Measure the resistance from pin C to pin A on the switch side of the idle validation switch connector with the accelerator pedal depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for an idle validation switch; a 6-pin repair connector, Part Number 3824910, for an integrated sensor switch; and a breakout cable, Part Number 3824892, for a solid state integrated switch if needed.

OK NOT OK

Less than 125 ohms?

Replace the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 1F

Go to 3A

Guided Step 1F - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin to pin in the IVS.

  • Measure the resistance from pin B to pin C on the switch side of the idle validation switch connector with the accelerator pedal released and depressed.

Install a 3-pin repair connector, Part Number 3823255, into the accelerator position sensor for an idle validation switch; a 6-pin repair connector, Part Number 3824910, for an integrated sensor switch; and a breakout cable, Part Number 3824892, for a solid state integrated switch if needed.

OK NOT OK

Greater than 100k ohms?

Replace the idle validation switch. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 551 active?

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for an open circuit.

  • Measure the resistance from pin 19 on the harness side of the OEM harness connector to pin A on the harness side of the idle validation switch connector.
  • Measure the resistance from pin 72 on the harness side of the OEM harness connector to pin B on the harness side of the idle validation switch connector.
  • Measure the resistance from pin 73 on the harness side of the OEM harness connector to pin C on the harness side of the idle validation switch connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 19 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 72 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 73 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the idle validation switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 19 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 72 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 73 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the ECM supply voltage.

Conditions

  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Check the ECM supply voltage.

  • Measure the voltage at the ECM from pin 19 to pin 55.
OK NOT OK

4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn keyswitch ON and completely depress and release the accelerator pedal four to five times.
  • Turn keyswitch OFF for 5 seconds.
  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 551 is inactive.
OK NOT OK

Fault Code 551 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Jul-2012


FAULT CODE 596 - Alternator Circuit - High Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery equipment system. |
 | STEP 1A. Check the alternator cable connections. | No damaged connections?
 | STEP 1B. Check the battery cable connections. | Connections are tight and corrosion free?
 | STEP 1C. Check the battery voltage. | Normal conditions: At least 12-VDC for (12-VDC systems) or 24-VDC for (24-VDC systems); Cranking: At least 6.2-VDC for (12-VDC systems) or 12-VDC for (24-VDC systems)?
STEP 2. | Check fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for blown fuse. | Fuse not blown?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 596 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3G. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 596 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery equipment system.

Guided Step 1A - Check the alternator cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the alternator cable connections for the following:

  • Corroded ring terminal
  • Bent or broken terminal post
  • Loose or missing retaining nut.
OK NOT OK

No damaged connections?

Repair or replace damaged connections. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections for the following:

  • Loose terminal connections
  • Corroded terminal connections.
OK NOT OK

Connections are tight and corrosion free?

Tighten loose connections and clean terminals. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Touch the positive (+) probe of the multimeter to the positive (+) battery terminal, and the negative (-) probe to the negative (-) battery terminal while trying to start engine.
OK NOT OK

Normal conditions: At least 12-VDC for (12-VDC systems) or 24-VDC for (24-VDC systems); Cranking: At least 6.2-VDC for (12-VDC systems) or 12-VDC for (24-VDC systems)

Charge or replace the battery. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-amp fuse is installed correctly.

  • Inspect the 30-amp fuse for correct installation.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse installed correctly?

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for blown fuse.

  • Inspect the 30-amp fuse to see if it is blown.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse not blown?

Replace fuse. Refer to Procedure 019-198 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the harness and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 596 active?

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery post to pins 1, 7, 12, and 13 of the OEM harness ECM connector.
  • Measure the resistance from the negative (-) battery post to pins 3, 9, 14, and 15 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to all the other pins in the connector, except pins 7, 12, and 13.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 12, and 13.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 13.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 12.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 3 of the OEM harness ECM connector to all the other pins in the connector, except pins 9, 14, and 15.
  • Measure the resistance from pin 9 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 14, and 15.
  • Measure the resistance from pin 14 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 15.
  • Measure the resistance from pin 15 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 14.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair or replace the damaged wires. Refer to the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 596 is inactive.
OK NOT OK

Fault Code 596 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 689 - Engine Speed (Crankshaft) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery equipment system. |
 | STEP 1A. Check the alternator cable connections. | No damaged connections?
 | STEP 1B. Check the battery cable connections. | Connections are tight and corrosion free?
 | STEP 1C. Check the battery voltage. | Normal conditions: At least 12-VDC for (12-VDC systems) or 24-VDC for (24-VDC systems), Cranking: At least 6.2-VDC for (12-VDC systems) or 12-VDC for (24-VDC systems)?
STEP 2. | Check fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for blown fuse. | Fuse not blown?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 597 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3G. Check the add-on or the accessory wiring at positive (+) terminal of the battery. | Dirty or damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 597 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery equipment system.

Guided Step 1A - Check the alternator cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the alternator cable connections for the following:

  • Corroded ring terminal
  • Bent or broken terminal post
  • Loose or missing retaining nut.
OK NOT OK

Dirty or damaged connections?

Repair or replace damaged connections. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections for the following:

  • Loose terminal connections
  • Corroded terminal connections.
OK NOT OK

Connections are tight and corrosion free?

Tighten the loose connections, and clean the terminals. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Touch the positive (+) probe of the multimeter to the positive (+) battery terminal, and the negative (-) probe to the negative (-) battery terminal while trying to start engine.
OK NOT OK

Normal conditions: At least 12 VDC for (12-VDC systems) or 24 VDC for (24-VDC systems), Cranking: At least 6.2 VDC for (12-VDC systems) or 12 VDC for (24-VDC systems)?

Charge or replace the battery. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-amp fuse is installed correctly.

  • Inspect the 30-amp fuse for correct installation.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse installed correctly?

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for blown fuse.

  • Inspect the 30-amp fuse to see if it is blown.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse not blown?

Replace fuse. Refer to Procedure 019-198 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the harness and ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 597 active?

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery post to pins 1, 7, 12, and 13 of the OEM harness ECM connector.
  • Measure the resistance from the negative (-) battery post to pins 3, 9, 14, and 15 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to all the other pins in the connector, except pins 7, 12, and 13.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 12, and 13.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 13.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 12.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness ECM connector to all the other pins in the connector, except pins 9, 14, and 15.
  • Measure the resistance from pin 9 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 14, and 15.
  • Measure the resistance from pin 14 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 15.
  • Measure the resistance from pin 15 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 14.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check the add-on or accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

Dirty or damaged wires?

Repair or replace the damaged wires. Refer to the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 597 is inactive.
OK NOT OK

Fault Code 597 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 598 - Alternator Circuit - Very Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery equipment system. |
 | STEP 1A. Check the alternator cable connections. | Dirty or damaged connections?
 | STEP 1B. Check the battery cable connections. | Connections are tight and corrosion free?
 | STEP 1C. Check the battery voltage. | Normal conditions: At least 12 VDC for (12-VDC systems) or 24 VDC for (24-VDC systems), Cranking: At least 6.2 VDC for (12-VDC systems) or 12 VDC for (24-VDC systems)?
STEP 2. | Check fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for blown fuse. | Fuse not blown?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 598 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3F. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3G. Check the add-on or the accessory wiring at positive (+) terminal of the battery. | Dirty or damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 598 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery equipment system.

Guided Step 1A - Check the alternator cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the alternator cable connections for the following:

  • Corroded ring terminal
  • Bent or broken terminal post
  • Loose or missing retaining nut.
OK NOT OK

No damaged connections

Repair or replace damaged connections. Use the OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections for the following:

  • Loose terminal connections
  • Corroded terminal connections.
OK NOT OK

Connections are tight and corrosion free

Tighten loose connections and clean terminals. Use the OEM troubleshooting and repair manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Touch the positive (+) probe of the multimeter to the positive (+) battery terminal, and the negative (-) probe to the negative (-) battery terminal while trying to start engine.
OK NOT OK

Normal conditions: At least 12 VDC for (12-VDC systems) or 24 VDC for (24-VDC systems), Cranking: At least 6.2 VDC for (12-VDC systems) or 12 VDC for (24-VDC systems)

Charge or replace the battery. Use the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-amp fuse is installed correctly.

  • Inspect the 30-amp fuse for correct installation.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse installed correctly

Install the fuse correctly. Refer to Procedure 019-198.

Go to 2B

Go to 4A

Guided Step 2B - Check for blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for blown fuse.

  • Inspect the 30-amp fuse to see if it is blown.

In some applications, there can be two 15-amp fuses.
OK NOT OK

Fuse not blown

Replace fuse. Refer to Procedure 019-198.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217.
  • Replace the OEM harness. Refer to Procedure 019-071.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 598 active

Repair complete.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery post to pins 1, 7, 12, and 13 of the OEM harness ECM connector.
  • Measure the resistance from the negative (-) battery post to pins 3, 9, 14, and 15 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to all the other pins in the connector, except pins 7, 12, and 13.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 12, and 13.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 13.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to all the other pins in the connector, except pins 1, 7, and 12.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 3 of the OEM harness ECM connector to all the other pins in the connector, except pins 9, 14, and 15.
  • Measure the resistance from pin 9 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 14, and 15.
  • Measure the resistance from pin 14 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 15.
  • Measure the resistance from pin 15 of the OEM harness ECM connector to all the other pins in the connector, except pins 3, 9, and 14.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 3F

Go to 4A

Guided Step 3F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 7 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 12 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 13 of the OEM harness ECM connector to engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217.
  • Replace the OEM harness. Refer to Procedure 019-071.

Go to 3G

Go to 4A

Guided Step 3G - Check the add-on or accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.
OK NOT OK

No damaged wires

Repair or replace the damaged wires. Use the OEM troubleshooting and repair manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 598 is inactive.
OK NOT OK

Fault Code 598 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2015


FAULT CODE 689 - Engine Speed (Crankshaft) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed (crankshaft) sensor. |
 | STEP 1A. Inspect the engine speed (crankshaft) sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 689 active?
 | STEP 1C. Measure the resistance of the engine speed (crankshaft) sensor. | 650 to 1000 ohms?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 689 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the engine speed (crankshaft) sensor gap. |
 | STEP 3A. Check the engine speed (crankshaft) sensor gap. | 0.8 to 1.5 mm?
 | STEP 3B. Read the fault codes. | Fault Code 689 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine speed (crankshaft) sensor.

Guided Step 1A - Inspect the engine speed (crankshaft) sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine speed (crankshaft) sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine speed (crankshaft) sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed (crankshaft) sensor. Refer to Procedure 019-042 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 689 active?

Fault Code 689 inactive.

Go to 1C

Go to 4B

Guided Step 1C - Measure the resistance of the engine speed (crankshaft) sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed (crankshaft) sensor.

Action

Measure the resistance of the crankshaft engine speed sensor.

  • Measure the resistance from pin 1 to pin 2 at the engine speed (crankshaft) sensor.
OK NOT OK

650 to 1000 ohms?

Replace the engine speed (crankshaft) sensor. Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 689 active?

Fault Code 689 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine speed (crankshaft) sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 24 of the engine harness 36-pin connector to pin 1 of the engine harness engine speed (crankshaft) sensor connector.
  • Measure the resistance from pin 24 of the engine harness 36-pin connector to pin 3 of the engine harness engine speed (crankshaft) sensor connector.
  • Measure the resistance from pin 25 of the engine harness 36-pin connector to pin 2 of the engine harness engine speed (crankshaft) sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine speed (crankshaft) sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 24 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 25 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine speed (crankshaft) sensor.

Action

Check for an short circuit to ground.

  • Measure the resistance from pin 24 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 25 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine speed (crankshaft) sensor gap.

Guided Step 3A - Check the engine speed (crankshaft) sensor gap.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed (crankshaft) sensor.

Action

Check the engine speed (crankshaft) sensor gap.

Refer to Procedure 019-042 in Section 19.

OK NOT OK

0.8 to 1.5 mm?

Install the engine speed (crankshaft) sensor to the correct settings. Refer to Procedure 019-042 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 689 is inactive.
OK NOT OK

Fault Code 689 inactive?

Fault Code 689 active.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 689 is inactive.
OK NOT OK

Fault Code 689 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 731 - Engine Speed Signal Mismatch

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164111 - Bosch® 2.8 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine position (camshaft) and engine speed (crankshaft) sensors. |
 | STEP 1A. Inspect the sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 731 active?
 | STEP 1C. Measure the resistance of the engine position (camshaft) and engine speed (crankshaft) sensors. | 650 to 1000 ohms?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 731 active?
 | STEP 2C. Check for an open circuit in the camshaft sensor connector. | Less than 10 ohms?
 | STEP 2C-1. Check for an open circuit in the crankshaft sensor connector. |
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the engine position (camshaft) and engine speed (crankshaft) sensor gap. |
 | STEP 3A. Check the engine position (camshaft) sensor gap. | 0.8 to 1.5 mm?
 | STEP 3B. Check the engine speed (crankshaft) sensor gap. | 0.8 to 1.5 mm?
 | STEP 3C. Read the fault codes. | Fault Code 731 inactive?
 | STEP 3D. Check the camshaft gear to camshaft. | Alignment correct?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine position (camshaft) and engine speed (crankshaft) sensors.

Guided Step 1A - Inspect the sensors and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine position (camshaft) sensor.
  • Disconnect the engine harness connector from the engine speed (crankshaft) sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine position (camshaft) sensor or engine speed (crankshaft) sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position (camshaft) sensor. Refer to Procedure 019-038 in Section 19.
  • Replace the engine speed (crankshaft) sensor. Refer to Procedure 019-042 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 731 active?

Fault Code 731 inactive.

Go to 1C

Go to 4B

Guided Step 1C - Measure the resistance of the engine position (camshaft) and engine speed (crankshaft) sensors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position (camshaft) sensor.
  • Disconnect the engine harness connector from the engine speed (crankshaft) sensor.

Action

Measure the resistance of the engine position (camshaft) sensor and of the engine speed (crankshaft) sensor.

  • Measure the resistance from pin 1 to pin 2 at the engine position (camshaft) sensor.
  • Measure the resistance from pin 1 to pin 2 at the engine speed (crankshaft) sensor.
OK NOT OK

650 to 1000 ohms?

Replace the engine position (camshaft) or engine speed (crankshaft) sensor

  • Replace the engine position (camshaft) sensor. Refer to Procedure 019-038 in Section 19.
  • Replace the engine speed (crankshaft) sensor. Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 731 active?

Fault Code 731 inactive.

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit in the camshaft sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness connector from the engine position (camshaft) sensor.
  • Disconnect the engine harness connector from the engine speed (crankshaft) sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to pin 2 of the engine harness engine position (camshaft) sensor connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to pin 1 of the engine harness engine position (camshaft) sensor connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to pin 3 of the engine harness engine position (camshaft) sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C-1

Go to 4A

Guided Step 2C-1 - Check for an open circuit in the crankshaft sensor connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness connector from the engine position (camshaft) sensor.
  • Disconnect the engine harness connector from the engine speed (crankshaft) sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 24 of the engine harness connector to pin 1 of the engine harness engine speed (crankshaft) sensor connector.
  • Measure the resistance from pin 24 of the engine harness connector to pin 3 of the engine harness engine speed (crankshaft) sensor connector.
  • Measure the resistance from pin 25 of the engine harness connector to pin 2 of the engine harness engine speed (crankshaft) sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness connector from the engine position (camshaft) sensor.
  • Disconnect the engine harness connector from the engine speed (crankshaft) sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 24 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 25 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness connector from the engine position (camshaft) sensor.
  • Disconnect the engine harness connector from the engine speed (crankshaft) sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 24 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 25 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine position (camshaft) and engine speed (crankshaft) sensor gap.

Guided Step 3A - Check the engine position (camshaft) sensor gap.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check the camshaft engine position sensor gap.

  • Refer to Procedure 019-038 in Section 19.
OK NOT OK

0.8 to 1.5 mm?

Install the camshaft engine position sensor to the correct settings. Refer to Procedure 019-038 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the engine speed (crankshaft) sensor gap.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine speed (crankshaft) sensor.

Action

Check the crankshaft engine speed sensor gap.

  • Refer to Procedure 019-042 in Section 19.
OK NOT OK

0.8 to 1.5 mm?

Install the crankshaft engine speed sensor to the correct settings. Refer to Procedure 019-042 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 731 inactive?

Fault Code 731 active

Go to 4A

Go to 3D

Guided Step 3D - Check the camshaft gear to camshaft.

Conditions

  • Turn keyswitch OFF.

Action

Check the camshaft gear to camshaft.

  • Check the alignment of the camshaft gear to camshaft.
OK NOT OK

Alignment correct?

Refer to Procedure 001-008 and Refer to Procedure 001-012 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Align the camshaft gear to the camshaft.

Refer to Procedure 001-008 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 731 is inactive.
OK NOT OK

Fault Code 731 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 753 or 778 - Engine Position (Camshaft) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test leadPart Number 3164111 - Bosch® 2.8 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine position (camshaft) sensor. |
 | STEP 1A. Inspect the engine position (camshaft) sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 753 or 778 active?
 | STEP 1C. Measure the resistance of the engine position (camshaft) sensor. | 650 to 1000 ohms?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and engine position (camshaft) sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 753 or 778 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the engine position (camshaft) sensor gap. |
 | STEP 3A. Check the engine position (camshaft) sensor gap. | 0.8 to 1.5 mm?
 | STEP 3B. Read the fault codes. | Fault Code 753 or 778 inactive?
 | STEP 3C. Check the camshaft gear to crankshaft. | Alignment correct?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 753 and 778 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine position (camshaft) sensor.

Guided Step 1A - Inspect the engine position (camshaft) sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine position (camshaft) sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine position (camshaft) sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position (camshaft) sensor. Refer to Procedure 019-038 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 753 or 778 active?

Fault Codes 753 and 778 inactive.

Go to 1C

Go to 4B

Guided Step 1C - Measure the resistance of the engine position (camshaft) sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Measure the resistance of the camshaft engine position sensor.

  • Measure the resistance from pin 1 to pin 2 at the engine position (camshaft) sensor.
OK NOT OK

650 to 1000 ohms?

Replace the engine position (camshaft) sensor. Refer to Procedure 019-038 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 753 or 778 active?

Fault Codes 753 and 778 inactive

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to pin 2 of the engine harness engine position (camshaft) sensor connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to pin 1 of the engine harness engine position (camshaft) sensor connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to pin 3 of the engine harness engine position (camshaft) sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine position (camshaft) sensor gap.

Guided Step 3A - Check the engine position (camshaft) sensor gap.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check the camshaft engine position sensor gap.

  • Refer to Procedure 019-038 in Section 19.
OK NOT OK

0.8 to 1.5 mm?

Install the engine position (camshaft) sensor to the correct settings. Refer to Procedure 019-038 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 753 and 778 inactive?

Fault Code 753 or 778 active

Go to 4A

Go to 3C

Guided Step 3C - Check the camshaft gear to camshaft.

Conditions

  • Turn keyswitch OFF.

Action

Check the camshaft gear to camshaft.

  • Check the alignment of the camshaft gear to camshaft.
OK NOT OK

Alignment correct? Refer to Procedure 001-008 and Refer to Procedure 001-012 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Realign the camshaft gear to the camshaft. Refer to Procedure 001-008 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Codes 753 and 778 are inactive.
OK NOT OK

Fault Code 753 and 778 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 768 - Analog Torque Circuit Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) andPart Number 3164112 - Bosch® .6 pin test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check analog torque transmission interface. |
 | STEP 1A. Verify that the analog torque transmission interface is connected to the OEM harness. | Analog torque transmission interface connected?
 | STEP 1B. Inspect the analog torque transmission interface and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 1C. Read the fault codes. | Fault Code 768 active
 | STEP 1D. Check analog torque according to OEM guidelines, if applicable. | OEM specification?
STEP 2. | Check OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 768 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 768 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check analog torque transmission interface.

Guided Step 1A - Verify that the analog torque transmission interface is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the analog torque transmission interface is connected to the OEM harness.
OK NOT OK

Analog torque transmission interface connected?

Connect analog torque transmission interface. If the analog torque is not present, contact a Cummins Authorized Repair Location.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the analog torque transmission interface and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the analog torque transmission interface.

Action

Inspect the analog torque transmission interface and OEM harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the analog torque transmission interface, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 7684510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the analog torque transmission interface. Refer to the OEM troubleshooting and repair manual.

Go to 1C

Go to 3A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 768 active?

Fault Code 768 inactive.

Go to 1D

Go to 3B

Guided Step 1D - Check analog torque according to OEM guidelines, if applicable.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the analog torque transmission interface.

Action

Check the analog torque transmission interface according to OEM guidelines, if applicable, for the following:

  • Damaged pins
  • Open or short circuits
  • Excessive current draw (power transmission shift modulator directly from battery).

Perform this test in accordance with the OEM guidelines.
OK NOT OK

OEM specification?

Replace analog torque transmission interface. Refer the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the analog torque transmission interface.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 7684510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the OEM harness. Refer to the OEM troubleshooting and repair manual.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 768 active?

Fault Code 768 inactive.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the analog torque transmission interface.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the OEM harness analog torque transmission interface connector to pin 36 of the OEM harness ECM connector.
  • Measure the resistance from pin 2 of the OEM harness analog torque transmission interface connector to pin 2 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-202 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-214 in Section 19
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the analog torque transmission interface.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 2 of the OEM harness ECM connector to all other pins.
  • Measure the resistance from pin 36 of the OEM harness ECM connector to all other pins.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the analog torque transmission interface.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the OEM harness ECM connector to engine block ground.
  • Measure the resistance from pin 2 of the OEM harness ECM connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute
  • Verify that Fault Code 768 is inactive.
OK NOT OK

Fault Code 768 inactive?

Return to troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshooting any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 753 or 778 - Engine Position (Camshaft) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test leadPart Number 3164111 - Bosch® 2.8 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine position (camshaft) sensor. |
 | STEP 1A. Inspect the engine position (camshaft) sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 753 or 778 active?
 | STEP 1C. Measure the resistance of the engine position (camshaft) sensor. | 650 to 1000 ohms?
STEP 2. | Check the 36-pin engine harness. |
 | STEP 2A. Inspect the engine harness and engine position (camshaft) sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 753 or 778 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check the engine position (camshaft) sensor gap. |
 | STEP 3A. Check the engine position (camshaft) sensor gap. | 0.8 to 1.5 mm?
 | STEP 3B. Read the fault codes. | Fault Code 753 or 778 inactive?
 | STEP 3C. Check the camshaft gear to crankshaft. | Alignment correct?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Codes 753 and 778 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine position (camshaft) sensor.

Guided Step 1A - Inspect the engine position (camshaft) sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine position (camshaft) sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the engine position (camshaft) sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine position (camshaft) sensor. Refer to Procedure 019-038 in Section 19.

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 753 or 778 active?

Fault Codes 753 and 778 inactive.

Go to 1C

Go to 4B

Guided Step 1C - Measure the resistance of the engine position (camshaft) sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Measure the resistance of the camshaft engine position sensor.

  • Measure the resistance from pin 1 to pin 2 at the engine position (camshaft) sensor.
OK NOT OK

650 to 1000 ohms?

Replace the engine position (camshaft) sensor. Refer to Procedure 019-038 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the 36-pin engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 753 or 778 active?

Fault Codes 753 and 778 inactive

Go to 2C

Go to 4B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check for an open circuit.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to pin 2 of the engine harness engine position (camshaft) sensor connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to pin 1 of the engine harness engine position (camshaft) sensor connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to pin 3 of the engine harness engine position (camshaft) sensor connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19 Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to all other pins in the connector.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 23 of the engine harness 36-pin connector to engine block ground.
  • Measure the resistance from pin 30 of the engine harness 36-pin connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine position (camshaft) sensor gap.

Guided Step 3A - Check the engine position (camshaft) sensor gap.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine position (camshaft) sensor.

Action

Check the camshaft engine position sensor gap.

  • Refer to Procedure 019-038 in Section 19.
OK NOT OK

0.8 to 1.5 mm?

Install the engine position (camshaft) sensor to the correct settings. Refer to Procedure 019-038 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 753 and 778 inactive?

Fault Code 753 or 778 active

Go to 4A

Go to 3C

Guided Step 3C - Check the camshaft gear to camshaft.

Conditions

  • Turn keyswitch OFF.

Action

Check the camshaft gear to camshaft.

  • Check the alignment of the camshaft gear to camshaft.
OK NOT OK

Alignment correct? Refer to Procedure 001-008 and Refer to Procedure 001-012 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Realign the camshaft gear to the camshaft. Refer to Procedure 001-008 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Codes 753 and 778 are inactive.
OK NOT OK

Fault Code 753 and 778 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 1139 - Injector Cylinder Number 1 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1139. | Active or high inactive counts of Fault Code 1139, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock, and excessive exhaust smoke go away, and Fault Code 1139 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1139 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes reset?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1139.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Active or high inactive counts of Fault Code 1139, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

  • Use the fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector Number 1. Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.
  • Start the engine and idle for one minute.

Does the engine knock and excessive exhaust smoke go away and Fault Code 1139 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector.

Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

No Repair

Go to 2A-1

Refer to Engine Noise Excessive troubleshooting symptom tree in Section TS

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 003-018 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Action

Progressive engine damage is possible due to the failed injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 1139 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use INSITE™ to reset the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1141 - Injector Cylinder Number 2 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1141. | Active or high inactive counts of Fault Code 1141, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock, and excessive exhaust smoke, go away and Fault Code 1141 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1141 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Active or high inactive counts of Fault Code 1141, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

  • Use the fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector Number 2. Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.
  • Start the engine and idle for one minute.

Does the engine knock and excessive exhaust smoke go away and Fault Code 1141 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector.

Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

No Repair

Go to 2A-1

Refer to appropriate Engine Noise troubleshooting symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 003-018 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Action

Progressive engine damage is possible due to the failed injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 1141 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use INSITE™ to reset the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1142 - Injector Cylinder Number 3 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1142. | Active or high inactive counts of Fault Code 1142, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock, excessive exhaust smoke, go away and Fault Code 1142 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1142 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1142.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Active or high inactive counts of Fault Code 1142, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

  • Using the fuel system leak tester blocking tool, Part Number 3164325, block the fuel flow going to injector Number 3. Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.
  • Start the engine and idle for one minute.

Does the engine knock and excessive exhaust smoke go away and Fault Code 1142 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector.

Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

No Repair

Go to 2A-1

Refer to appropriate Engine Noise troubleshooting symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 003-018 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Action

Progressive engine damage is possible due to the failed injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 1142 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use INSITE™ to reset the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1143 - Injector Cylinder Number 4 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1143. | Active or high inactive counts of Fault Code 1143, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock, and excessive exhaust smoke go away and Fault Code 1143 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1143 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes reset?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Active or high inactive counts of Fault Code 1143, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

  • Use the fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector Number 4. Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.
  • Start the engine and idle for one minute.

Does the engine knock and excessive exhaust smoke go away and Fault Code 1143 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector.

Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

No Repair

Go to 2A-1

Refer to appropriate Engine Noise troubleshooting symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 003-018 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Action

Progressive engine damage is possible due to the failed injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 1143 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use INSITE™ to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1144 - Injector Cylinder Number 5 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1144. | Active or high inactive counts of Fault Code 1144, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Engine knock and excessive exhaust smoke goes away and Fault Code 1144 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1144 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes reset?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1144.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Active or high inactive counts of Fault Code 1144, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

  • Use the fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector Number 5. Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.
  • Start the engine and idle for one minute.

Engine knock and excessive exhaust smoke goes away and Fault Code 1144 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector.

Refer to Procedure 006-026 in Section 6 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

No Repair

Go to 2A-1

See appropriate Engine Noise troubleshooting symptom tree in Section TS

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 003-018 in Section 3 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Action

Progressive engine damage is possible due to the failed injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 1144 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use INSITE™ to reset the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps

Last Modified: 12-Jun-2015


FAULT CODE 1145 - Injector Cylinder Number 6 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1145. | Active or high inactive counts of Fault Code 1145, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock, and excessive exhaust smoke go away and Fault Code 1145 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1145 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes reset?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Active or high inactive counts of Fault Code 1145, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

  • Using the fuel system leak tester blocking tool, Part Number 3164325, block the fuel flow going to injector Number 6. Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.
  • Start the engine and idle for one minute.

Does the engine knock and excessive exhaust smoke go away and Fault Code 1145 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector.

Refer to Procedure 006-026 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

No Repair

Go to 2A-1

Refer to appropriate Engine Noise troubleshooting symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. Refer to Procedure 003-018 in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Action

Progressive engine damage is possible due to the failed injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 1145 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use INSITE™ to reset the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jul-2012


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
STEP 2. | Check the accelerator pedal position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troublehshoot Fault Code 2185.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and exhaust gas temperature 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

Repair

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location.

Replace the accelerator pedal or lever. See equipment manufacturer service information.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jun-2015


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1241 is active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 1241 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness.

  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position +5 VDC SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

Repair

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SUPPLY pin and the OEM harness accelerator pedal connector SUPPLY pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jun-2015


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor Number 1 and Number 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 131, 132, 1239, or 1241 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131, 132, 1239, or 1241 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 both active?
YES NO
No Repair

Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Go to the appropriate fault code troubleshooting tree.

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Repair

Low sensor supply voltage has been detected.

See Fault Code 132 troubleshooting tree.

Go to 2D

Go to Fault Code 132 troubleshooting tree.

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal position 2 sensor +5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Repair

Low sensor supply voltage has been detected.

See Fault Code 1241 troubleshooting tree.

Go to 2E

Go to Fault Code 1241 troubleshooting tree.

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Fully depress and release the accelerator pedal 3 times.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. See equipment manufacturer service information.

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jun-2015


FAULT CODE 1417 - Engine Control Module (ECM) Shutdown

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Calibrate the ECM. | Download successful?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1417 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Connect the electronic service tool.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to verify the correct calibration is loaded into the ECM.
OK NOT OK

Download successful?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 1417 is inactive.
OK NOT OK

Fault Code 1417 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 1478 - Starter Lockout - Driver Pin Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.
CAUTION

For original equipment manufacturer (OEM) supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | No other active fault codes?
STEP 2. | Check that the components are installed correctly. |
 | STEP 2A. Check that the components are installed and connected correctly. | Components are installed and connected correctly?
STEP 3. | Check the starter lockout relay. |
 | STEP 3A. Inspect the starter lockout relay and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 1478 active?
 | STEP 3C. Measure the voltage at the starter lockout relay. | 10 to 14 VDC for 12 VDC systems, 22 to 26 VDC for 24 VDC systems?
 | STEP 3D. Verify starter lockout relay is operating correctly. | Starter lockout relay operating correctly?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Inspect the OEM harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Read the fault codes. | Fault Code 1478 active?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1478 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

No other active fault codes?

Troubleshoot any other active fault codes first.

Go to 2A

Go to 5A

Guided Step 2 - Check that the components are installed correctly.

Guided Step 2A - Verify that the components are installed and connected correctly.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Verify that the components are installed and connected correctly.

  • Use the OEM manual for component location.

Use INSITE™ electronic service tool to verify the feature is disabled when there are no starter lockout relay components installed.

OK NOT OK

Components are installed and connected correctly?

Components are not installed and connected correctly. See the OEM troubleshooting and repair manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the starter lockout relay.

Guided Step 3A - Inspect the starter lockout relay and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Inspect the starter lockout relay and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the starter lockout relay, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-205 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the starter lockout relay. See OEM troubleshooting and repair manual.

Go to 3B

Go to 5A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 1478 active?

Repair complete.

Go to 3C

Go to 5B

Guided Step 3C - Measure the voltage at the starter lockout relay.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Measure the voltage at the starter lockout relay.

  • Measure the voltage at the starter lockout relay from pin 1 to pin 2 with the engine running.
OK NOT OK

10 to 14 VDC for 12 VDC systems, 22 to 26 VDC for 24 VDC systems?

Go to 3D

Go to 4A

Guided Step 3D - Verify starter lockout relay is operating correctly.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Verify starter lockout relay is operating correctly.

  • Relay does not allow power to the starter relay while engine is running.
OK NOT OK

Starter lockout relay operating correctly?

Replace starter lockout relay. See the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89 pin connector from the ECM.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 1478 active

Repair complete.

Go to 4C

Go to 5B

Guided Step 4C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Check for an open circuit.

  • Measure the resistance from pin 1 of the OEM harness connector to pin 1 of the OEM harness starter lockout relay connector.
  • Measure the resistance from pin 46 of the OEM harness connector to pin 2 of the OEM harness starter lockout relay connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 1 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 46 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the starter lockout relay.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 of the OEM harness connector to engine block ground.
  • Measure the resistance from pin 46 of the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 1478 is inactive.
OK NOT OK

Fault Code 1478 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jun-2015


FAULT CODE 2185 - Accelerator Supply - High Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator sensor. |
 | STEP 1A. Measure the voltage to the accelerator sensor. | Greater than 4.5-VDC?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 2185 active?
 | STEP 2C. Check for a short circuit to battery voltage. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check ECM. |
 | STEP 3A. Check ECM supply voltage. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator sensor.

Guided Step 1A - Measure the voltage to the accelerator sensor.

Conditions

  • Disconnect the accelerator from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage to the accelerator sensor.

  • Measure the voltage from pin C to pin A of the OEM accelerator sensor harness connector.
OK NOT OK

More than 4.5 VDC?

Replace the accelerator sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 2185 active?

Repair complete.

Go to 2C

Go to 4B

Guided Step 2C - Check for a short circuit to battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check for a short circuit to battery voltage.

  • Measure the resistance from pin 55 to pins 1, 5, 7, 8, 11, 12, 13, 16, 17, 18, 28, 36, 37, 46, and 49.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect accelerator pedal connector from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 55 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 81 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 83 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check ECM.

Guided Step 3A - Check ECM supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Check ECM supply voltage.

  • Measure the supply voltage at the ECM from pin 55 to pin 81.
OK NOT OK

4.75 to 5.25 VDC?

Replace the ECM. Refer to Procedure 019-031 in section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 2185 is inactive.
OK NOT OK

Fault Code 2185 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 2186 - Accelerator Supply - Low Voltage

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® .6 pin test lead, and Part Number 3164113 - Bosch® .6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator sensor. |
 | STEP 1A. Measure the voltage to the accelerator circuit. | Fault Code 2186 still active when sensor is removed. Less than 4.5-VDC?
STEP 2. | Check OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 2186 active
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2186 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the accelerator circuit.

Guided Step 1A - Measure the voltage to the accelerator sensor.

Conditions

  • Turn keyswitch ON.
  • Disconnect accelerator from OEM harness.

Action

Measure the voltage to the accelerator sensor.

  • Measure the voltage from pin C to pin A of the OEM accelerator sensor harness connector.
OK NOT OK

Less than 4.5 VDC?

Replace the accelerator sensor if the supply voltage is 4.75 to 5.25 with sensor disconnected and the fault code is active with the sensor connected. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 3A

Guided Step 2 - Check OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pinsFlush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 2186 active?

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the accelerator pedal.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin 55 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 81 of the OEM harness connector to all other pins in the connector.
  • Measure the resistance from pin 83 of the OEM harness connector to all other pins in the connector.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect accelerator pedal connector from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 55 of the OEM harness connector to engine block ground.
  • Measure the resistance from pin 81 of the OEM harness connector to engine block ground.
  • Measure the resistance from pin 83 of the OEM harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 2186 is inactive.
OK NOT OK

Fault Code 2186 inactive?

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Ue INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 2194 - OEM Pressure - Engine Protection - Fueling Derate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2194 inactive
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical OEM pressure gauge to the engine.
  • Connect INSITE™ to vehicle datalink.
  • Start the engine, and compare the OEM pressure reading on the service tool monitor screen to the reading on the mechanical OEM pressure gauge.

If necessary, rev the engine up to make it easier to see differences in the readings.
OK NOT OK

Sensor reading is correct?

Replace the OEM pressure sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify Fault Code 2194 is inactive.

If the fault was at a particular speed, run the engine at that speed to verify the problem has been corrected.
OK NOT OK

Fault Code 2194 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Erase the inactive fault code using INSITE™.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 2197 - OEM Temperature Sensor - Engine Protection - Fueling Derate Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correct?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2197 inactive and did not reoccur?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the OEM temperature sensor.
  • Connect INSITE™ to the data link.
  • Run the engine and compare the OEM temperature sensor reading on INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer "OK" to this step.

Readings will possibly need to be checked while engine is operating at normal temperature conditions (82°C [180°F coolant]).
OK NOT OK

Sensor reading correct?

Sensor reading incorrect. Replace OEM temperature sensor. Refer to the OEM troubleshooting and repair manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Load and operate engine to typical operating temperature (82°C [180°F] coolant).
  • Verify Fault Code 2197 is inactive and did not reoccur.
OK NOT OK

Fault Code 2197 inactive and did not reoccur?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 25-Jul-2012


FAULT CODE 2212 - Fuel Heater Circuit Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade) and Part Number 3164112 - Bosch® .6 pin test lead.
CAUTION

For OEM supplied connectors, refer to the OEM service manuals for connector and test lead information in order to avoid pin and harness damage.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fuel heater. |
 | STEP 1A. Inspect the fuel heater and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Read the fault codes. | Fault Code 2212 active?
 | STEP 1C. Check the resistance of the fuel heater. | Less than 2.5 ohms
 | STEP 1D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1E. Check supply voltage. | 9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 2212 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2212?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check fuel heater.

Guided Step 1A - Inspect the fuel heater and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fuel heater.

Action

Inspect the fuel heater and OEM harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the fuel heater, whichever has the damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the fuel heater. Refer to the OEM troubleshooting and repair manual.

Go to 1B

Go to 3A

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 2212 active?

Repair complete.

Go to 1C

Go to 3B

Guided Step 1C - Check the resistance of the fuel heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fuel heater.

Action

Check the resistance of the fuel heater.

  • Measure the resistance from pin 1 to pin 2 at the fuel heater connector.
OK NOT OK

Less than 2.5 ohms?

Replace the fuel heater. Refer to the OEM troubleshooting and repair manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the fuel heater.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 1 at the OEM harness fuel heater connector to engine block ground.
  • Measure the resistance from pin 2 at the OEM harness fuel heater connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the fuel heater.

Action

Check supply voltage.

  • Measure the resistance from pin 1 at the OEM harness fuel heater connector to engine block ground.
OK NOT OK

9 to 15-VDC for 12-VDC systems, 21 to 27-VDC for 24-VDC systems?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-201 in Section 19 Refer to Procedure 019-202 in Section 19 Refer to Procedure 019-214 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the fuel heater.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair damaged pins. Flush the dirt or debris from the connector pins. Repair or replace the OEM harness, or replace the ECM, whichever has damaged pins.

  • Flush the dirt or debris from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 2212 active?

Repair complete.

Go to 2C

Go to 3B

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the fuel heater.

Action

Check for an open circuit.

  • Measure the resistance from pin 2 of the OEM harness fuel heater connector to pin 2 of the OEM harness ECM connector.
  • Measure the resistance from pin 1 of the OEM harness fuel heater connector to pin 18 of the OEM harness ECM connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness 89-pin connector from the ECM.
  • Disconnect the OEM harness from the fuel heater.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 2 of the OEM harness ECM connector to all other pins.
  • Measure the resistance from pin 18 of the OEM harness ECM connector to all other pins.
OK NOT OK

Greater than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair or replace the OEM harness

  • Repair the OEM harness. Refer to Procedure 019-217 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 2212 is inactive.
OK NOT OK

Fault Code 2212 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 2215 - Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EFC Actuator Valve | Refer to Procedure 005-007 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Fuel Flow | Refer to Procedure 005-011 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Fuel Pump | Refer to Procedure 005-016 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Air in Fuel | Refer to Procedure 006-003 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Fuel Supply Lines | Refer to Procedure 006-024 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Injector | Refer to Procedure 006-026 | IISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Injector Supply Lines (High Pressure) | Refer to Procedure 006-051 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Fuel Connector (Head Mounted) | Refer to Procedure 006-052 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Engine Wiring Harness | Refer to Procedure 019-043 | ISB (4 Cylinder) and ISBe (4 and 6 Cylinder) | 3666477
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB (4 Cylinder) and ISBe (4 and 6 Cylinder) | 3666477

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM,) all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227, 329, 449 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the fuel lines. |
 | STEP 2A. Check all fuel lines for signs of leaking. | Signs of leaking fuel?
 | STEP 2B. Check for restriction in the low pressure fuel lines. | Restriction in the low pressure fuel line?
STEP 3. | Check the fuel filter. |
 | STEP 3A. Check for plugged fuel filter. | Fuel filter plugged?
 | STEP 4. Check for air in the low-pressure system. | Air in the system?
STEP 5. | Check the fuel rail pressure sensor. |
 | STEP 5A. Check for signs of tampering on the fuel rail pressure sensor. | Signs of tampering?
 | STEP 5B. Inspect the fuel rail pressure sensor and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 5C. Measure the voltage at the fuel rail pressure sensor connector. | Voltage between 4.75 to 5.25 VDC?
 | STEP 5D. Verify the fuel rail pressure sensor accuracy. |
STEP 6. | Check the 36-pin engine wiring harness. |
 | STEP 6A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 6B. Read the fault codes. |
 | STEP 6C. Check for an open circuit. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 7. | Check the ECM response. |
 | STEP 7A. Measure voltage at the ECM. | Voltage between 4.75 to 5.25 VDC?
STEP 8. | Check the high-pressure injection pump. |
 | STEP 8A. High-pressure injection pump flow test. | Fuel pump flow meets the specification?
STEP 9. | Check for an internal fuel leak. |
 | STEP 9A. Check the injector return flow. | Injector return flow within specifications?
 | STEP 9B. Check the high-pressure connector torque. | Injector high-pressure connector torque meets specifications?
 | STEP 9C. Check for individual leaking injectors. | Fuel injector return flow within specification with an injector capped off?
 | STEP 9D. Check the fuel pressure relief valve for a fuel leak. | Signs of fuel leakage?
STEP 10. | Check ECM calibration code and clear fault codes. |
 | STEP 10A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 10B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227, 329, 449 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel lines.

Guided Step 2A - Check all fuel lines for signs of leaking.

Conditions

  • Turn keyswitch OFF.

Action

Check all fuel lines for the following:

Signs of leaking fuel?
YES NO

Repair

Replace the fuel lines. Refer to Procedure 006-051 in Associated Procedures Table.

 No Repair

Go to 10a

Go to 2B

Guided Step 2B - Check for restriction in the low pressure fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Check the low pressure fuel lines for the following:

  • Bent fuel lines
  • Twisted fuel lines
  • Pinched or squeezed fuel lines.

Restriction in the low pressure fuel line?
YES NO

Repair

Replace the fuel lines. Refer to Procedure 006-024 in Associated Procedures Table.

 No Repair

Go to 10A

Go to 3A

Guided Step 3 - Check the fuel filter.

Guided Step 3A - Check for a plugged fuel filter.

Conditions

  • Turn keyswitch OFF.

Action

Check for a plugged fuel filter.

  • Measure the pressure drop across the fuel filter. Refer to Procedure 005-011 in Associated Procedures Table.

Fuel filter plugged?
YES NO

Repair

Replace the fuel filter. Refer to Procedure 006-015 in the Associated Procedures Table.

 No Repair

Go to 10A

Go to 4A

Guided Step 4 - Check for air in the system.

Guided Step 4A - Check for air in the low-pressure system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the low-pressure system.

  • Refer to Procedure 006-003 in the Associated Procedures Table.
  • Start the engine and operate at high idle for 1 minute.

Air in the system?
YES NO

Repair

Find and repair the air intrusion. Refer to Procedure 006-003 in the Associated Procedures Table.

No Repair

Go to 10A

Go to 5A

Guided Step 5 - Check the fuel rail pressure sensor.

Guided Step 5A - Check for signs of damage or improper wiring on the fuel rail pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel rail pressure sensor.

Action

Check for signs of damage or improper wiring on the fuel rail pressure sensor circuit.

  • Broken, cut, or incorrect routing of the fuel rail pressure sensor wires
  • Any device connected in series or parallel with the fuel rail pressure sensor
  • Any other wires added to the fuel rail pressure sensor circuit
  • Any evidence that tampering with the fuel rail pressure sensor has taken place.

Signs of damaged or improper wiring?
YES NO

Repair

Repair or replace damaged or improperly wired items.

  • Repair or replace the damaged connector(s) or the engine wiring harness. Refer to the following procedures:

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Associated Procedures Table.

 No Repair

Go to 10A

Go to 5B

Guided Step 5B - Inspect the fuel rail pressure sensor and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel rail pressure sensor.

Action

Inspect the fuel rail pressure sensor and engine wiring harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine wiring harness, or replace the fuel rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510
  • .Install the appropriate connector seal if it is damaged or missing. Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.
  • Repair or replace the damaged connector(s) or the engine wiring harness.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 10A

Go to 5C

Guided Step 5C - Measure the voltage at the fuel rail pressure sensor connector.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine wiring harness from the fuel rail pressure sensor.

Action

Measure the voltage at the fuel rail pressure sensor connector.

  • Measure the voltage from pin 1 to pin 3 at the engine wiring harness fuel rail pressure sensor connector.

Voltage between 4.75 to 5.25 VDC?
YES NO
No Repair

Repair

  • Repair or replace the damaged connector(s) or the engine wiring harness. Refer to the following procedures:

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5D

Go to 10A

Guided Step 5D - Verify the fuel rail pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Engine not operating.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool monitor.

Action

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to monitor the fuel rail pressure.

Rail fuel pressure (measured) less than 30 bar [435 psi]?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 6A

Go to 10A

Guided Step 6 - Check the 36 pin engine wiring harness.

Guided Step 6A - Inspect the engine wiring harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel rail pressure sensor.
  • Disconnect the engine wiring harness 36 pin connector from the ECM.

Action

Inspect the engine wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine wiring harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector(s) or the engine wiring harness. Refer to the following procedures:

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the engine wiring harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine wiring harness. Refer to 019-043 in the Associated Procedure Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedure Table.

Go to 10A

Go to 6B

Guided Step 6B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215 active?
YES | NO
No Repair | No Repair

Go to 6C

Go to 10B

Guided Step 6C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel rail pressure sensor.
  • Disconnect the engine wiring harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail pressure SUPPLY pin of the engine wiring harness 36-pin connector to the fuel rail pressure SUPPLY pin of the engine wiring harness fuel rail pressure sensor connector.
  • Measure the resistance from the fuel rail pressure RETURN pin of the engine wiring harness 36-pin connector to the fuel rail pressure RETURN pin of the engine wiring harness fuel rail pressure sensor connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin of the engine wiring harness 36-pin connector to the fuel rail pressure SIGNAL pin of the engine wiring harness fuel rail pressure sensor connector.Use the following procedure

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair or replace the damaged connector(s) or the engine wiring harness. Refer to the following procedures:

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6D

Go to 10A

Guided Step 6D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel rail pressure sensor.
  • Disconnect the engine wiring harness 36 pin connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel rail pressure SUPPLY pin of the engine wiring harness 36 pin connector to all other pins in the connector.
  • Measure the resistance from the fuel rail pressure RETURN pin of the engine wiring harness 36 pin connector to all other pins in the connector.
  • Measure the resistance from the fuel rail pressure SIGNAL pin of the engine wiring harness 36 pin connector to all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Repair or replace the damaged connector(s) or the engine wiring harness. Refer to the following procedures;

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 7A

Go to 10A

Guided Step 7 - Check the ECM response.

Guided Step 7A - Measure voltage at the ECM.

Conditions

  • Disconnect the engine wiring harness 36 pin connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage at the ECM.

  • Measure the voltage from the fuel rail pressure SUPPLY pin to the fuel rail pressure RETURN pin at the ECM.

Voltage between 4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedure Table.

Go to 8A

Go to 10A

Guided Step 8 - Check the high-pressure injection pump.

Guided Step 8A - High-pressure injection pump flow test.

Conditions

  • Turn keyswitch ON.
  • Engine cranking.

Action

Check the high-pressure injection pump fuel flow.

  • Refer to procedure 005-007 in Associated Procedures Table.

Fuel pump flow meets the specification?
YES NO

Repair

Replace the EFC actuator valve. Refer to Procedure 005-007 in Associated Procedures Table.

Repair

Replace the high-pressure fuel pump. Refer to Procedure 005-016 in Associated Procedures Table.

Go to 9A

Go to 10A

Guided Step 9 - Check for an internal fuel leak.

Guided Step 9A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the High-Pressure Injector Return Flow Test.

  • Refer to procedure 006-026 in the Associated Procedures Table.

Injector return flow within specifications?
YES | NO
No Repair | No Repair

Go to 10A

Go to 9B

Guided Step 9B - Check the high-pressure connector torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque.

  • Refer to Procedure 006-052 in the Associated Procedures Table.

Injector high-pressure connector torque meets specifications?
YES NO
No Repair

Repair

Inspect the injector high-pressure connector and replace, if necessary. Refer to Procedure 006-052 in the Associated Procedures Table.

Go to 9C

Go to 9A

Guided Step 9C - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the High-Pressure Injector Return Flow Isolation Test.

  • Refer to procedure 006-026 in the Associated Procedures Table.

Fuel injector return flow within specification with an injector capped off?
YES NO

Repair

Replace the injector of the cylinder that is contributing to the high return flow. Refer to Procedure 006-026 in Associated Procedures Table.

Repair

  • Replace the injector of the cylinder that is contributing to the high return flow. Refer to Procedure 006-026 in Associated Procedure Table.

Go to 9A

Go to 9D

Guided Step 9D - Check the fuel pressure relief valve for a fuel leak.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic tool.
  • Engine running.
  • Coolant temperature is greater than 80 C [176F].

Action

Perform the fuel pressure override test.

  • Refer to Procedure 006-061 in Associated Procedures Table.

Sign of fuel leakage?
YES NO

Repair

Replace the fuel pressure relief valve. Refer to Procedure 006-061 in Associated Procedures Table.

 No Repair

Go to 10A

Go to 10A

Guided Step 10 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 10B

Go to 10B

Guided Step 10B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 28-Feb-2019


FAULT CODE 2216 - Fuel Rail Pressure Negative Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - Bosch® 2.8 pin test lead (blade), Part Number 3164112 - Bosch® 0.6 pin test lead, Part Number 3164111 - Bosch® 2.8 socket test lead, and Part Number 3164113 - Bosch® 0.6 socket test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 271 and 272 inactive?
STEP 2. | Check fuel rail pressure sensor. |
 | STEP 2A. Check for signs of tampering on the fuel rail pressure sensor. | Signs of tampering?
 | STEP 2B. Inspect the fuel rail pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Read the fault codes. | Fault Code 2216 active?
 | STEP 2D. Measure the voltage at the fuel rail pressure sensor connector. | Voltage between 4.75 and 5.25-VDC?
 | STEP 2E. Verify the fuel rail pressure sensor. | At 600 rpm no load = 500, Bar at 800 rpm no load = 800 bar?
STEP 3. | Check the 36-pin engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 2216 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check the ECM supply. |
 | STEP 4A. Measure voltage at the ECM. | Voltage between 4.75 and 5.25-VDC?
STEP 5. | Check the electronic fuel control actuator. |
 | STEP 5A. Check for a mechanically stuck electronic fuel control actuator. | Click heard?
 | STEP 5B. Check the coil resistance of the fuel pump. | Resistance between 0.1 to 5 ohms?
 | STEP 5C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2216 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Codes 271 and 272 are inactive.
OK NOT OK

Fault Codes 271 and 272 inactive?

Troubleshoot Fault Codes 271 and 272 first.

Go to 2A

Go to 6A

Guided Step 2 - Check fuel rail pressure sensor.

Guided Step 2A - Check for signs of tampering on the fuel rail pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for signs of tampering on the fuel rail pressure sensor.

  • Broken, cut, or incorrect routing of the fuel rail pressure sensor wires
  • Any device connected in series or parallel with the fuel rail pressure sensor
  • Any other wires added to the fuel rail pressure sensor circuit
  • Any evidence that tampering with the fuel rail pressure sensor has taken place.
OK NOT OK

Signs of tampering?

Repair or replace the engine harness or replace the fuel rail pressure sensor, whichever item has been tampered.

  • Repair the engine harness connectors.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2B

Go to 6A

Guided Step 2B - Inspect the fuel rail pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Inspect the fuel rail pressure sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the engine harness, or replace the fuel rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness connectors.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 2216 active?

Fault Code 2216 inactive?

Go to 2D

Go to 5B

Guided Step 2D - Measure the voltage at the fuel rail pressure sensor connector.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Measure the voltage at the fuel rail pressure sensor connector.

  • Measure the voltage from pin-1 to pin-3 at the engine harness fuel rail pressure sensor connector.
OK NOT OK

Voltage between 4.75 and 5.25-VDC?

Repair or replace the engine harness.

  • Repair the engine harness connectors.

Refer to Procedure 019-201 in Section 19.

Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-214 in Section 19.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 6A

Guided Step 2E - Verify the fuel rail pressure sensor.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Start the engine and run at high idle.

Action

Check the output pressure of the fuel pump.

  • Use INSITE™ electronic service tool to monitor the fuel pressure and electronic fuel control actuator current. Compare values to specifications.
OK NOT OK

At 600 rpm no load = 500 bar, At 800 rpm no load = 800 bar?

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the 36-pin engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 6A

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 2216 active?

Fault Code 2216 inactive?

Go to 3C

Go to 5B

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-1 of the fuel rail pressure sensor connector to pin-20 of the engine harness 36-pin connector.
  • Measure the resistance from pin-2 of the fuel rail pressure sensor connector to pin-27 of the engine harness 36-pin connector.
  • Measure the resistance from pin-3 of the fuel rail pressure sensor connector to pin-12 of the engine harness 36-pin connector.
  • Measure the resistance from pin-1 of the electronic fuel control actuator to pin-7 of the engine harness 36-pin connector.
  • Measure the resistance from pin-2 of the electronic fuel control actuator to pin-5 of the engine harness 36-pin connector.
OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.
  • Disconnect the engine harness from the fuel rail pressure sensor.
  • Disconnect the engine harness 36-pin connector from the ECM.

Action

Check for a from pin-to-pin short circuit.

  • Measure the resistance from pin-5 of the engine harness 36-pin connector to all other pins in the connector, except pins-17, 18, 19, 20, 21, and 22.
  • Measure the resistance from pin-7 of the engine harness 36-pin connector to all other pins in the connector, except pins-17, 18, 19, 20, 21, and 22.
  • Measure the resistance from pin-12 of the engine harness 36-pin connector to all other pins in the connector, except pins-17, 18, 19, 20, 21, and 22.
  • Measure the resistance from pin-20 of the engine harness 36-pin connector to all other pins in the connector, except pins-17, 18, 19, 20, 21, and 22.
  • Measure the resistance from pin-27 of the engine harness 36-pin connector to all other pins in the connector, except pins-17, 18, 19, 20, 21, and 22.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness connectors. Refer to Procedure 019-216 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the fuel rail pressure sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-12 at the ECM to engine block ground.
  • Measure the resistance from pin-20 at the ECM to engine block ground.
  • Measure the resistance from pin-27 at the ECM to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the ECM supply.

Guided Step 4A - Measure the voltage at the ECM.

Conditions

  • Disconnect the engine harness 36-pin connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage at the ECM.

  • Measure the voltage from pin-12 to pin-20 at the ECM.
OK NOT OK

Voltage between 4.75 and 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the electronic fuel control actuator.

Guided Step 5A - Check for a mechanically stuck electronic fuel control actuator.

Conditions

  • Turn keyswitch ON.

Action

Check for a mechanically stuck electronic fuel control actuator using a click test.

  • Turn keyswitch ON for 5 seconds; then turn keyswitch OFF. An audible click will be heard when the keyswitch is turned OFF.
OK NOT OK

Click heard?

Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 5B

Go to 6A

Guided Step 5B - Check the coil resistance of the electronic fuel control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check the coil resistance of the electronic fuel control actuator.

  • Measure the resistance from pin-1 to pin-2 of the electronic fuel control actuator.
OK NOT OK

Resistance between 0.1 and 5 ohms?

Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness 36-pin connector from the ECM.
  • Disconnect the engine harness from the electronic fuel control actuator.

Action

Check for a short circuit to ground.

  • Measure the resistance of pin-1 on the electronic fuel control actuator to engine block ground.
  • Measure the resistance of pin-2 on the electronic fuel control actuator to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 2216 is inactive.
OK NOT OK

Fault Code 2216 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting charts.

Last Modified: 24-Jul-2012


FAULT CODE 2217 - Engine Control Module (ECM) Software Error

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Calibrate the ECM. | Download successful?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2217 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Calibrate the ECM.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to verify that the latest and correct calibration is loaded into the ECM.
OK NOT OK

Download successful?

Replace the ECM. Refer to Procedure 019-031in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the code.

  • Start the engine and idle for 1 minute.
  • Verify that Fault Code 2217 is inactive.
OK NOT OK

Fault Code 2217 inactive?

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 24-Jul-2012


FAULT CODE 2559 - Transmission ECU to ECM Communication - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 2559 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit ( VECU ) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration matches the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the service data link harness. | 50 to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM data link harness. | 50 to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 2559 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2559 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

NOTE: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration matches the OEM VECU multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the service data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the data link (+) wire and the data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service data link connector or harness connection to the data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the data link (+) wire and the data link (-) wire on the appropriate Cummins® ECM OEM connection to the data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the data link (+) wire and the data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the data link (+) and the data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2559 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Mar-2014


INDEX
86-ifctable.htm

86-fc111.htm

86-t05-111.htm

86-fc122.htm

86-t05-122.htm

86-fc123.htm

86-t05-123.htm

86-fc131.htm

86-t05-131.htm

86-fc132.htm

86-t05-132.htm

86-fc133.htm

86-t05-133.htm

86-fc134.htm

86-t05-134.htm

86-fc135.htm

86-t05-135.htm

86-fc141.htm

86-fc141sn.htm

86-t05-141sn.htm

86-fc141sw.htm

86-t05-141sw.htm

86-fc143.htm

86-fc143sn.htm

86-t05-143sn.htm

86-fc143sw.htm

86-t05-143sw.htm

86-fc144.htm

86-t05-144.htm

86-fc145.htm

86-t05-145.htm

86-fc146.htm

86-t05-146.htm

86-fc151.htm

86-t05-151.htm

86-fc153.htm

86-t05-153.htm

86-fc154.htm

86-t05-154.htm

86-fc155.htm

86-t05-155.htm

86-fc187.htm

86-t05-187.htm

86-fc197.htm

86-t05-197.htm

86-fc198.htm

86-t05-198.htm

86-fc212.htm

86-t05-212.htm

86-fc213.htm

86-t05-213.htm

86-fc221.htm

86-t05-221.htm

86-fc227.htm

86-t05-227.htm

86-fc234.htm

86-t05-234.htm

86-fc235.htm

86-t05-235.htm

86-fc238.htm

86-t05-238.htm

86-fc239.htm

86-t05-239.htm

86-fc241.htm

86-t05-241.htm

86-fc244.htm

86-t05-244.htm

86-fc261.htm

86-t05-261.htm

86-fc263.htm

86-t05-263.htm

86-fc265.htm

86-t05-265.htm

86-fc266.htm

86-t05-266.htm

86-fc271.htm

86-t05-271.htm

86-fc272.htm

86-t05-272.htm

86-fc285.htm

86-t05-285.htm

86-fc286.htm

86-t05-286.htm

86-fc293.htm

86-t05-293.htm

86-fc294.htm

86-t05-294.htm

86-fc296.htm

86-t05-296.htm

86-fc297.htm

86-t05-297.htm

86-fc298.htm

86-t05-298.htm

86-fc311.htm

86-t05-311.htm

86-fc321.htm

86-t05-321.htm

86-fc322.htm

86-t05-322.htm

86-fc323.htm

86-t05-323.htm

86-fc324.htm

86-t05-324.htm

86-fc325.htm

86-t05-325.htm

86-fc329.htm

86-t05-329.htm

86-fc331.htm

86-t05-331.htm

86-fc332.htm

86-t05-332.htm

86-fc341.htm

86-t05-341.htm

86-fc343.htm

86-t05-343.htm

86-fc352.htm

86-t05-352.htm

86-fc381.htm

86-t05-381.htm

86-fc382.htm

86-t05-382.htm

86-fc386.htm

86-t05-386.htm

86-fc389.htm

86-t05-389.htm

86-fc392.htm

86-t05-392.htm

86-fc412.htm

86-t05-412.htm

86-fc415.htm

86-fc415sn.htm

86-t05-415sn.htm

86-fc415sw.htm

86-t05-415sw.htm

86-fc422.htm

86-t05-422.htm

86-fc426.htm

86-t05-426.htm

86-fc427.htm

86-t05-427.htm

86-fc429.htm

86-t05-429.htm

86-fc431.htm

86-t05-431.htm

86-fc432.htm

86-t05-432.htm

86-fc433.htm

86-t05-433.htm

86-fc434.htm

86-t05-434.htm

86-fc441.htm

86-t05-441.htm

86-fc442.htm

86-t05-442.htm

86-fc449.htm

86-t05-449.htm

86-fc451.htm

86-t05-451.htm

86-fc452.htm

86-t05-452.htm

86-fc488.htm

86-t05-488.htm

86-fc551.htm

86-t05-551.htm

86-fc596.htm

86-t05-596.htm

86-fc597.htm

86-t05-597.htm

86-fc598.htm

86-t05-598.htm

86-fc689.htm

86-t05-689.htm

86-fc731.htm

86-t05-731.htm

86-fc753.htm

86-t05-753.htm

86-fc768.htm

86-t05-768.htm

86-fc778.htm

86-t05-778.htm

86-fc1139.htm

86-t05-1139.htm

86-fc1141.htm

86-t05-1141.htm

86-fc1142.htm

86-t05-1142.htm

86-fc1143.htm

86-t05-1143.htm

86-fc1144.htm

86-t05-1144.htm

86-fc1145.htm

86-t05-1145.htm

86-fc1239.htm

86-t05-1239.htm

86-fc1241.htm

86-t05-1241.htm

86-fc1242.htm

86-t05-1242.htm

86-fc1417.htm

86-t05-1417.htm

86-fc1478.htm

86-t05-1478.htm

86-fc2185.htm

86-t05-2185.htm

86-fc2186.htm

86-t05-2186.htm

86-fc2194.htm

86-t05-2194.htm

86-fc2197.htm

86-t05-2197.htm

86-fc2212.htm

86-t05-2212.htm

86-fc2215.htm

86-t05-2215.htm

86-fc2216.htm

86-t05-2216.htm

86-fc2217.htm

86-t05-2217.htm

86-fc2559.htm

86-t05-2559.htm