ISB Light Duty Fuel System ISB Engines

Last Modified: 30 October 2018

Copyright © 2018
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module (ECM) Microprocessor

FAULT CODE 111

Engine Control Module (ECM) Microprocessor

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12 LAMP: Yellow SRT: | ECM internal hardware error. | Possible no effect or engine may run rough or not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the left side of the engine block, behind the fuel filter.

Shop Talk

This fault code can be caused only by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111.

Last Modified: 09-Jan-2013
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Fault Code Path Selection

FAULT CODE 80-fc115
Fault Code Path Selection

Do you have a VP-30 fuel system? | Go to 80-fc115vp30
Do you have a VP-44 fuel system? | Go to 80-fc115vp44

Last Modified: 13-Jan-2014


Engine Speed Sensor (ESS) Circuit

FAULT CODE 115VP30

Engine Speed Sensor (ESS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Yellow SRT: | No engine speed signal detected at pin 17 of the engine harness. | Engine power derate. Possible white smoke.
Engine Speed Sensor (ESS) Circuit

Circuit Description

The engine speed sensor provides engine speed information to the engine control module (ECM). The sensor must be powered up by (+) 5 VDC to operate. The sensor generates its signals by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft. The tone wheel has 35 teeth and a gap where the 36th tooth would be placed. This missing tooth indicates cylinder 1 and 6 are at top dead center.

Component Location

The combination sensor is located in the back of the gear housing behind the injection pump on QSB engines with the Bosch™ VP30 fuel system.

Shop Talk

This fault code will also cause a fuel derate. This could be the cause of a low-power complaint. Also, this fault code can cause starting problems in cold weather.

QSB engines with the Bosch™ VP30 fuel system use only an engine speed sensor located in the gear housing below the injection pump that reads off a tone wheel bolted to the camshaft gear. This is a combination sensor that provides both speed and position.

Refer to Troubleshooting Fault Code 115vp30.

Last Modified: 28-Sep-2016


Engine Speed Sensor (ESS) Circuit

FAULT CODE 115VP44

Engine Speed Sensor (ESS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 190 FMI: 2 LAMP: Yellow SRT: | No engine speed signal detected at pin 17 of the engine harness. | Engine power derate. Possible white smoke.
Engine Speed Sensor (ESS) Circuit

Circuit Description

The engine speed sensor provides engine speed information to the engine control module (ECM). The sensor must be powered up by (+) 5 VDC to operate. The sensor generates its signals by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft. The tone wheel has 35 teeth and a gap where the 36th tooth would be placed. This missing tooth indicates cylinder 1 and 6 are at top dead center.

Component Location

The engine speed sensor is located on the intake side of the engine block, at crankshaft level, between cylinders 4 and 5 on ISB and QSB5.9 engine with the Bosch™ fuel system.

Shop Talk

This fault code will also cause a fuel derate. This could be the cause of a low-power complaint. Also, this fault code can cause starting problems in cold weather.

ISB and QSB engines with the fuel pump system use separate sensors for engine speed and position.

Refer to Troubleshooting Fault Code 115vp44.

Last Modified: 28-Sep-2016


Engine Position Sensor (EPS) Circuit

FAULT CODE 121

Engine Position Sensor (EPS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P0341 SPN: 190 FMI: 2 LAMP: None or MIL SRT: | No engine position signal detected at pin 9 of the engine harness. | No engine position backup for main speed/position sensor. Misfire monitor will not function.
Engine Position Sensor (EPS) Circuit

Circuit Description

The engine position sensor provides engine position information to the electronic control module (ECM). The engine position sensor senses the movement of a target dimple found on the back of the cam gear. The dimple position determines if cylinder No. 1 is at top dead center (TDC). The sensor is used for misfire detection and the automated cylinder performance test.

Component Location

The engine position sensor is located on the intake side of the gear housing, behind the VP44 fuel pump.

Refer to Troubleshooting Fault Code t05-121

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the boost pressure sensor signal pin-45 of the engine harness. | Engine will derate to no-boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located on the rear of the intake air manifold in the second port on the side of the head to the right of the fuel filter.

Shop Talk

  • Determine if engine is being overfueled.
  • Confirm that the correct intake manifold pressure sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air.
  • Check for high restriction in the intake air manifold due to a shutdown device in the manifold (if the vehicle is equipped with one). Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.
Refer to Troubleshooting Fault Code t05-122

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at the boost pressure sensor signal pin 45 of the engine harness. | Engine will derate to no-boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the sensor harness. If the intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located on the rear of the intake air manifold in the second port on the side of the head to the right of the fuel filter.

Shop Talk

  • Determine if engine is being overfueled.
  • Confirm that the correct intake manifold pressure sensor part number is being used.
  • Confirm that the correct turbocharger is being used.
  • If it is suspected that cold intake air is the cause of the high intake manifold pressure, test the engine with warm intake air.
  • Check for high restriction in the intake air manifold due to a shutdown device in the manifold (if the vehicle is equipped with one). Do not remove this device. If the engine is operated in a flammable atmosphere, the device is an essential safety feature.
Refer to Troubleshooting Fault Code t05-123

Last Modified: 29-Jul-2010


Intake Manifold Pressure - Engine Protection

FAULT CODE 124

Intake Manifold Pressure - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 SPN: P102 FMI: 0 LAMP: Service Engine Soon SRT: | Intake manifold pressure signal indicates intake manifold pressure has exceeded the maximum limit for the given engine rating. | Engine will derate to no boost fueling.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor is used by the electronic control module (ECM) to monitor the engine intake manifold pressure. The ECM monitors the voltage on the signal wire pin C and converts this to a pressure valve.

Component Location

The intake manifold pressure sensor is located on the rear of the intake air manifold in the second port on the side of the head to the right of the fuel filter.

Shop Talk

Possible causes:

  • Malfunctioning turbo wastegate
  • Wastegate tampering
  • Wrong turbo part.
Refer to Troubleshooting Fault Code t05-124

Last Modified: 29-Jul-2010


Accelerator Position Sensor Circuit

FAULT CODE 131

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 091 FMI: 3 or 4 LAMP: Yellow SRT: | High voltage detected at accelerator position signal pin 30 of the OEM harness. | Engine idles when idle validation switch indicates idle and ramps up to at a default set speed when the idle validation switch indicates off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: a +5-VDC supply wire (pin 29), a return ground (pin 19), and a signal wire (pin 30).

NOTE: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensor checks look in good order then replace the accelerator position sensor and the idle validation switch circuit wires between the accelerator pedal and the ECM with new wires. Run the wires through, or around, the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent toxic and noxious fumes from entering the operator area.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together. The same applies for the three wires in the idle validation switch circuit.

NOTE: If pin 19 (return) and pin 30 (signal) are reversed, throttle position will only read 50 percent.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 29-Jul-2010


Accelerator Position Sensor Circuit

FAULT CODE 132

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 091 FMI: 3 or 4 LAMP: Yellow SRT: | Low voltage detected at accelerator position SIGNAL pin 30 of the OEM harness. | Engine idles when idle validation switch indicates idle and ramps up to a default set speed when the idle validation switch indicates off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator position sensor is attached to the accelerator pedal. The accelerator position sensor sends a signal to the electronic control module (ECM) when the driver pushes on the accelerator pedal. The accelerator position circuit contains three wires: a +5-VDC SUPPLY wire (pin 29), a RETURN ground (pin 19), and a SIGNAL wire (pin 30).

NOTE: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor is located on the accelerator pedal.

Shop Talk

If all wiring and sensor checks look in good order, replace the accelerator position sensor and the idle validation switch circuit wires between the accelerator pedal and the ECM with new wires. Run the wires through, or around, the bulkhead without using the bulkhead connector. Test the truck with the test wires in place. If the fault goes away, replace the OEM harness. Seal the openings in the bulkhead around the connector and wires to prevent engine compartment fumes from entering the cab area.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together. The same applies for the three wires in the idle validation switch circuit.

NOTE: If pin 19 (RETURN) and pin 30 (SIGNAL) are reversed, throttle position will only read 50 percent.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 29-Jul-2010


Oil Pressure Sensor Circuit

FAULT CODE 135 (SN)

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Yellow SRT: | High voltage detected at oil pressure sensor signal pin 33 of the engine harness. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, below and to the right of the ECM.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure signal voltage going into the ECM.
Refer to Troubleshooting Fault Code t05-135

Last Modified: 29-Jul-2010


Fault Code Path Selection

FAULT CODE 141
Fault Code Path Selection

Do you have an Oil Pressure Sensor? | Go to 80-fc141sn
Do you have an Oil Pressure Switch? | Go to 80-fc141sw

Last Modified: 27-Jan-2004


Oil Pressure Sensor Circuit

FAULT CODE 141 (SN)

Oil Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at oil pressure sensor signal pin 33 of the engine harness. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value. The oil pressure value is used by the ECM for the engine protection system.

Component Location

The oil pressure sensor is located on the engine block, below and to the right of the ECM.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ electronic service tool can be used to monitor the oil pressure signal voltage going into the ECM.
Refer to Troubleshooting Fault Code t05-141

Last Modified: 29-Jul-2010


Oil Pressure Switch Circuit

FAULT CODE 141 (SW)

Oil Pressure Switch Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4 LAMP: Yellow SRT: | Low voltage detected on pin 47 of the engine harness. | Default value used for oil pressure. No engine protection for oil pressure.
Oil Pressure Switch Circuit

Circuit Description

The oil pressure switch is used by the electronic control module (ECM) to monitor the lubricating oil pressure.

Component Location

The oil pressure switch is located on the engine block, below and to the right of the ECM.

Shop Talk

  • If Fault Code 143 or 415 is not present, the problem is not related to the engine lubrication system.
  • INSITE™ can be used to monitor the oil pressure signal voltage going into the ECM.
  • If an oil pressure switch is installed, INSITE™ will read a constant value of 379 kPa [55 psi] ±2 kPa [±0.3 psi] if the ECM is reading a signal from the oil pressue switch.
  • The switch is a single wire device which requires engine block ground for operation.
  • Engine Protection will activate, if enabled, if the lubricating oil pressure drops below 41 kPa [6 psi] with the engine running.
Refer to Troubleshooting Fault Code t05-141

Last Modified: 29-Jul-2010


Coolant Temperature Sensor Circuit

FAULT CODE 144

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 or 4 LAMP: Yellow SRT: | High voltage detected at the coolant temperature signal pin 23 of the engine harness. | Default value used for engine coolant temperature.No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located to the front of the thermostat housing.

Shop Talk

The sensor reading will match to the following table if the sensor is functioning properly.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-144

Last Modified: 29-Jul-2010


Coolant Temperature - Engine Protection

FAULT CODE 146

Coolant Temperature - Engine Protection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0 LAMP: Yellow SRT: | Coolant temperature signal indicates coolant temperature has exceeded the minimum engine protection limit. | Power derate and possible engine shutdown if engine protection shutdown feature is enabled.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor (CTS) is used by the electronic control module (ECM) to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system and the timing and fueling control.

Component Location

The coolant temperature sensor is located on top of the thermostat housing.

Shop Talk

Make sure the airflow through the radiator is not obstructed.

Refer to Troubleshooting Fault Code t05-146

Last Modified: 29-Jul-2010


Intake Manifold Air Temperature Sensor Circuit

FAULT CODE 153

Intake Manifold Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 or 4 LAMP: Yellow SRT: | High voltage detected at intake manifold temperature signal pin 34 of the engine harness. | Default value used for intake manifold temperature. No engine protection for intake manifold temperature.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is used by the ECM to monitor the engine intake air temperature. The intake manifold air temperature signal is used by the ECM for engine protection system, cold start aid, timing, and fueling control.

Component Location

The intake manifold air temperature sensor is located on the side of the intake manifold at the rear of the head.

Shop Talk

If the sensor is functioning properly, compare the reading to the following table.

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-153

Last Modified: 29-Jul-2010


Intake Manifold Air Temperature Sensor Circuit

FAULT CODE 154

Intake Manifold Air Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 3 or 4 LAMP: Yellow SRT: | Low voltage detected at intake manifold temperature signal pin 34 of the engine harness. | Default value used for intake manifold temperature. No engine protection for intake manifold temperature.
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor is used by the engine control module (ECM) to monitor the engine intake air temperature. The intake manifold air temperature signal is used by the ECM for engine protection system, cold start aid, timing, and fueling control.

Component Location

The intake manifold air temperature sensor is located on the side of the intake manifold at the rear of the head.

Shop Talk

Temperature (°C) | Temperature [°F] | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 16-Jan-2013


Wait-to-Start Lamp Circuit

FAULT CODE 186

Wait-to-Start Lamp Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 186 PID: P0381 SPN: 675 FMI: 11 LAMP: Service Engine Soon SRT: | Error detected in the wait-to-start lamp circuit at pin 37 of the engine harness. | Wait-to-start lamp will be illuminated constantly or will not be illuminated at all.
Wait-to-Start Lamp Circuit

Circuit Description

The wait-to-start lamp is controlled by the engine ECM. It is used to indicate to the driver when the intake air heater has completed the pre-heat cycle and the engine can be started.

Component Location

The wait-to-start lamp is located in the vehicle dash.

Refer to Troubleshooting Fault Code t05-186

Last Modified: 29-Jul-2010


Vehicle Electronic Control Module

FAULT CODE 211

Vehicle Electronic Control Module

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 211 PID: P1693 SPN: 609 FMI: 12 LAMP: Service Engine Soon LAMP: None SRT: | Error detected within the vehicle ECM. | No effect on engine performance.
Vehicle Electronic Control Module

Circuit Description

The vehicle ECM communicates with the engine ECM and various vehicle components.

Component Location

Refer to the OEM manual for vehicle ECM location.

Refer to Troubleshooting Fault Code t05-211

Last Modified: 29-Jul-2010


Engine Overspeed Circuit

FAULT CODE 234

Engine Overspeed Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0 LAMP: Red SRT: | Engine speed signal indicates engine speed has exceeded the overspeed limit. | Fuel to the injectors disabled until the engine speed falls below the overspeed limit.
Engine Overspeed Circuit

Circuit Description

The engine speed sensor provides engine speed information to the electronic control module (ECM). The sensor must be powered up by +5 VDC to operate. The sensor generates its signals by sensing the movement of target teeth cast into a tone wheel that is mounted to the crankshaft. The tone wheel has 35 teeth and a gap where the 36th tooth would be placed. This missing tooth indicates that cylinder No. 1 (and No. 6) is at top dead center.

Component Location

The engine speed sensor is located on the intake side of the engine block, at crankshaft level, between cylinders No. 4 and No. 5.

Refer to Troubleshooting Fault Code t05-234

Last Modified: 06-Sep-2011


Transmission ECU to ECM Communication - Abnormal Update Rate

FAULT CODE 2559

Transmission ECU to ECM Communication - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2559 PID: SPN: 1845 FMI: 4 LAMP: Amber SRT: | Transmission ECU to ECM Communication Lost - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected between the ECM and the transmission ECU. | None on performance.

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Component values and states from components such as sensors, accelerators, and switches can then be transmitted from the OEM VECU to the Cummins® ECM over the data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins Inc. ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The data link wiring and the devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, a malfunctioning OEM VECU, or a malfunctioning Cummins® ECM. It may be necessary to contact the OEM for the proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-2559.

Last Modified: 09-Aug-2013


Pump High Fuel Temperature Error/Overheat Error

FAULT CODE 261

Pump High Fuel Temperature Error/Overheat Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: P0168 SPN: 174 FMI: 0 LAMP: Yellow SRT: | Fuel temperature signal indicates fuel temperature has exceeded the engine protection limit and/or pump protection limit. | Engine power derate.
Fuel Pump

Circuit Description

The fuel temperature sensor is located in the fuel pump. Fuel temperature information is passed to the engine control module (ECM) through the controller area network datalink.

Component Location

The fuel temperature sensor is located in the fuel pump.

Shop Talk

This fault code is typically set when the fuel pump controller communicates to the ECM that the fuel temperature measured in the fuel inlet to the pump (temperature sensor) exceeds the allowable threshold value (93°C [199°F]).

This signal does not set a final temperature defect in the controller and, in most cases, identifies a fuel overheat condition on the engine/vehicle.

Refer to Troubleshooting Fault Code t05-261.

Last Modified: 08-Jan-2013


Fuel Temperature Sensor Error

FAULT CODE 264

Fuel Temperature Sensor Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 264 PID: P0181 SPN: 174 FMI: 2 LAMP: Yellow SRT: | High or low voltage detected at the fuel temperature sensing circuit inside the fuel pump controller for 2 seconds. | Engine power derate.
Fuel Pump

Circuit Description

This fault indicates a final defect of the temperature sensor. The sensor's reading indicates an unrealistic value, or the temperature is outside of the signal range check thresholds, -45°C [-49°F] to 130°C [266°F].

Component Location

The circuit for this fault code is contained within the Bosch® fuel pump control module.

Shop Talk

The table below relates which actions are taken by the engine control module (ECM) or fuel pump control module when Fault Code 264 becomes active.

Fault Code | Action Taken By ECM or Fuel Pump Control Module
 | No Action | Fueling Derate | Disable Injection
264 |  | X |

When a defect occurs within the controller temperature sensing circuit, the controller defaults to a temperature value of 75°C [167°F]. If this is the temperature's reading indicated on the monitor screen and this reading does not vary with changes in the coolant temperature, then the is most likely malfunctioning.

NOTE: An active pump fault code can result in deactivation of the fuel lift pump by the ECM. Correct the active fault codes before replacing the fuel lift pump.

Refer to Troubleshooting Fault Code t05-264.

Last Modified: 08-Jan-2013


Fault Code Path Selection

FAULT CODE 278
Fault Code Path Selection

Do you have a Ford™ truck application? | Go to 80-fc278ford
Do you have an application other than a Ford™ truck? | Go to 80-fc278corp

Last Modified: 12-Aug-2010


Lift Pump Circuit

FAULT CODE 278 (Application for Trucks Other Than Ford™ )

Lift Pump Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 278 PID: P073 SPN: 1075 FMI: 11 LAMP: Yellow SRT: | Error detected in lift pump circuit at pin 11 of the engine harness. | The engine possibly loses power, dies, or is difficult to start.
Lift Pump Circuit

Circuit Description

The electronic control module (ECM) enables the lift pump by sending a signal directly to the lift pump. The ECM fast-duty cycles the lift pump ON and OFF during cranking, and it enables the pump once the engine has started.

Component Location

The lift pump is mounted to the engine block on the intake side, toward the rear of the engine.

Shop Talk

  • The lift pump is turned ON for approximately 5 seconds when the keyswitch is first turned ON. With the hood raised, it is possible to hear the lift pump running when the keyswitch is turned ON.
  • Loose battery connections can sometimes cause this fault code.
Refer to Troubleshooting Fault Code t05-278 (Application for Trucks Other Than Ford™).

Last Modified: 16-Feb-2011


Lift Pump Circuit

FAULT CODE 278 (Ford™ Truck Application)

Lift Pump Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 278 PID: P073 SPN: 1075 FMI: 11 LAMP: Yellow SRT: | Error detected in lift pump circuit at pin 11 of the engine harness. | The engine possibly loses power, dies, or is difficult to start.
Lift Pump Circuit

Circuit Description

The electronic control module (ECM) enables the lift pump by sending a signal directly to the lift pump. The ECM fast-duty cycles the lift pump ON and OFF during cranking, and it enables the pump once the engine has started.

Component Location

The lift pump is mounted to the engine block on the intake side, toward the rear of the engine.

Shop Talk

  • The lift pump is turned on for approximately 5 seconds when the keyswitch is first turned ON. With the hood raised, it is possible to hear the lift pump running when the keyswitch is turned ON.
  • Loose battery connections can sometimes cause this fault code.
Refer to Troubleshooting Fault Code 278 (Ford™ Truck Application).

Last Modified: 09-Aug-2010


Engine Speed Sensor Supply

FAULT CODE 283

Engine Speed Sensor Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 283 PID: P190 SPN: 190 FMI: 3 or 4 LAMP: Yellow SRT: | High voltage detected at main engine speed sensor voltage supply pin 8 of the engine harness. | The engine control module (ECM) will use the fuel pump speed signal as a backup. Possible white smoke, hard start, and power derate.
Engine Speed Sensor

Circuit Description

The engine speed sensor provides engine speed information to the ECM. The sensor must be powered up by +5 VDC to operate. The sensor generates its signals by sensing the movement of target teeth cast into a tone wheel that is mounted to the crankshaft. The tone wheel has 35 teeth and a gap where the 36th tooth would be placed. This missing tooth indicates that cylinder 1 and 6 are at top dead center.

Component Location

The engine speed sensor is located on the intake side of the engine block, at crankshaft level, between cylinders 4 and 5 on ISB and QSB5.9 engine with the Bosch fuel pump system.

The combination sensor is located in the back of the gear housing behind the injection pump on QSB engines with the Bosch VP30 fuel system.

Shop Talk

QSB engines with the Bosch VP30 fuel system use only an engine speed sensor located in the gear housing below the injection pump, that reads off a tone wheel bolted to the camshaft gear. This is a combination sensor that provides both speed and position. ISB and QSB engines with the Bosch fuel pump system use separate sensors for engine speed and position.

Refer to Troubleshooting Fault Code t05-283.

Last Modified: 09-Jan-2013


Engine Speed Sensor Supply

FAULT CODE 284

Engine Speed Sensor Supply

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 284 PID: P190 SPN: 190 FMI: 3 or 4 LAMP: Yellow SRT: | Low voltage detected at main engine speed sensor voltage supply pin 8 of the engine harness. | The ECM will use the Bosch fuel pump speed signal as a backup. Possible white smoke, hard start, and power derate.
Engine Speed Sensor

Circuit Description

The engine speed sensor provides engine speed information to the engine control module (ECM). The sensor must be powered up by +5 VDC to operate. The sensor generates its signals by sensing the movement of target teeth cast into a tone wheel that is mounted to the crankshaft. The tone wheel has 35 teeth and a gap where the 36th tooth would be placed. This missing tooth indicates that cylinder 1 and 6 are at top dead center.

Component Location

The engine speed sensor is located on the intake side of the engine block, at crankshaft level, between cylinders 4 and 5 on ISB and QSB5.9 engine with the Bosch fuelpump system.

The sensor is located in the back of the gear housing behind the injection pump on QSB engines with the Bosch VP30 fuel system.

Shop Talk

QSB engines with the Bosch VP30 fuel system use only an engine speed sensor located in the gear housing below the injection pump, that reads off a tone wheel bolted to the camshaft gear. This is a combination sensor that provides both speed and position. ISB and QSB engines with the Bosch fuelpump system use separate sensors for engine speed and position.

Refer to Troubleshooting Fault Code t05-284.

Last Modified: 09-Jan-2013


Datalink Circuit

FAULT CODE 291

Datalink Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 291 SPN: 609 FMI: 2 LAMP: Service Engine Soon SRT: | Datalink error detected between the vehicle ECM and the engine ECM. | No effect on performance.
Datalink Circuit

Circuit Description

This datalink is used to transmit vehicle and engine data between the vehicle ECM and the engine ECM.

Component Location

The datalink is located in the engine harness and the OEM harness.

Refer to Troubleshooting Fault Code t05-291

Last Modified: 29-Jul-2010


Coolant Temperature Sensor Circuit

FAULT CODE 334

Coolant Temperature Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 SPN: 110 FMI: 2 LAMP: Service Engine Soon SRT: | Coolant temperature signal indicates coolant temperature is not changing during engine operation. | Default value used for engine coolant temperature. No engine protection for coolant temperature.
Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is used by the ECM to monitor the temperature of the engine coolant. The coolant temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The coolant temperature sensor is located to the front of the thermostat housing.

Shop Talk

The sensor readings will match the following table if the sensor is functioning properly.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-334

Last Modified: 29-Jul-2010


Sensor Supply Circuit

FAULT CODE 352

Sensor Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 620 FMI: 4 or 3 LAMP: Yellow SRT: | Low voltage detected at +5-VDC supply, pin 10 of the engine harness. | Default value used for sensors connected to this +5-VDC supply. Engine will derate to no-boost fueling and loss of engine protection for oil pressure, intake manifold pressure, and coolant temperature.
Sensor Supply Circuit

Circuit Description

The engine position sensor (EPS), the intake manifold pressure sensor, and the oil pressure sensor are powered by the same +5-VDC source and the same return in the electronic control module (ECM). This supply is also used to operate the intake manifold temperature and coolant temperature sensors.

Component Location

The +5-VDC sensor supply circuit is located in the sensor harness. Refer to Procedure 100-002 (Engine Diagrams) in Section E for the sensor locations.

Shop Talk

These faults could also cause high-voltage or low-voltage faults on the coolant temperature and intake manifold temperature sensors.

Refer to Troubleshooting Fault Code t05-352

Last Modified: 29-Jul-2010


Fuel Valve High Current Error

FAULT CODE 362

Fuel Valve High Current Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 362 PID: P0253, S251 SPN: 1076 FMI: 4 LAMP: Yellow SRT: | Low voltage or no voltage detected at the fuel pump control valve, which indicates that the valve will not close for a shorter duration. | Engine can possibly shut down or operate poorly.
Fuel Pump Circuit

Circuit Description

This circuit is internal to the fuel pump control module. It controls the quantity of fuel being delivered to each cylinder.

Component Location

The fuel-metering valve is located inside the fuel pump in the middle of the delivery valve holders.

Shop Talk

This fault is set when the fuel-metering solenoid valve quick dissipation voltage is too low. Fault Code 362 can be triggered by power supply glitches or voltage spikes. Additionally, current or clamping voltage outside the set limits can trigger this fault code.

Refer to Troubleshooting Fault Code t05-362.

Last Modified: 17-Jan-2013


Fuel Pump Control Valve Feedback Error

FAULT CODE 363

Fuel Pump Control Valve Feedback Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 363 PID: P0251, S251 SPN: 1076 FMI: 7 LAMP: Yellow SRT: | Slow or no fuel control valve movement detected by the fuel pump as determined by the valve driver circuit inductive kickback pulse. | Engine power derate. Engine can die.
Fuel Pump Circuit

Circuit Description

This circuit is internal to the fuel pump and detects fuel solenoid movement.

Component Location

The fuel pump is located on the backside of the gear housing on the intake side of the engine.

Shop Talk

No current inflection recognized within the solenoid closing time. This fault is typically set when a fuel pump beginning of injection point error is recognized at engine speeds greater than 700 rpm and commanded fueling greater than 20 mm3 [0.787 in3] for 2 seconds at battery voltage (greater than 9-VDC). The fault code can be triggered by electrical noise or voltage feedback on ground loop. Jump-starting a vehicle with 24-VDC can cause this fault code to be set.

Refer to Troubleshooting Fault Code t05-363.

Last Modified: 17-Jan-2013


Engine Control Module (ECM) to Pump Communications Error

FAULT CODE 364

Engine Control Module (ECM) to Pump Communications Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 364 PID: P1689, S233 SPN: 1077 FMI: 9 LAMP: Yellow SRT: | No communications or invalid data transfer rate detected on datalink between the ECM and fuel pump control module at pins 4 and 13 of the engine harness. | Engine power derate, low power, two-speed engine operation.
Fuel Pump Circuit

Circuit Description

This circuit is used to communicate fueling, timing, and pump status messages between the ECM and pump controller. If this link is lost, the pump will operate in a backup mode based on the idle signal (pin 4).

Component Location

The datalink is located within the ECM and fuel pump control module.

Shop Talk

  • The datalink is used to communicate fueling and timing commands, as well as pump status messages. If the datalink is lost, the pump will operate in backup mode based on idle signal (pin 4 at fuel pump connector).
  • This fault code will be active if the fuel pump power supply is inadequate.
  • When troubleshooting for this fault, suspect that one or a combination of the following can be the cause: The ECM, fuel pump, or wiring harness/fuses/relay.
Refer to Troubleshooting Fault Code t05-364.

Last Modified: 17-Jan-2013


Fuel Pump Voltage Out of Range Error Low

FAULT CODE 365

Fuel Pump Voltage Out of Range Error Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 365 PID: S233 SPN: 1077 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at fuel pump controller supply voltage circuit. | Possible engine dying, operating rough, or no effect.
Fuel Pump Circuit

Circuit Description

Power is supplied to the through a relay. When the engine control module (ECM) switches the relay, power is supplied from the battery, through the relay, to the fuel pump.

Component Location

Internal to the pump.

Shop Talk

The fuel pump control module compares battery voltage to supply voltage while energizing the fuel metering solenoid. If this measured voltage drop is excessive, there is high resistance in the fuel pump power supply circuit.

Refer to Troubleshooting Fault Code t05-365.

Last Modified: 17-Jan-2013


Fuel Pump Voltage Measurement Error

FAULT CODE 366

Fuel Pump Voltage Measurement Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 366 PID: P1287 SPN: FMI: LAMP: Yellow SRT: | Fuel pump controller battery voltage measurement is outside the pump signal range check limits. | Possibly no effect. If battery voltage is less than 6-volt, the engine will die or operate rough.
Fuel Pump Circuit

Circuit Description

Battery voltage to the fuel pump is passed to the engine control module (ECM) through the controller area network datalink.

Component Location

The voltage measurement is located within the pump control module.

Shop Talk

This fault is set when the fuel pump control module registers a voltage value outside of its threshold limits (6.5 to 18-volt) for 0.5 second.

The fuel pump fully compensates for voltage fluctuations within its signal range check. Excessive voltage (more than 24-volt) will damage the pump controller.

Troubleshooting must focus on sources of high or low voltage or engine grounding.

Refer to Troubleshooting Fault Code t05-366.

Last Modified: 17-Jan-2013


Fuel Pump Speed/Position Sensor Signal Lost

FAULT CODE 367

Fuel Pump Speed/Position Sensor Signal Lost

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 367 PID: P0370 FMI: LAMP: None SRT: | Fuel pump speed/position signal is lost. | Fueling to injectors is disabled. Engine dies.
Fuel Pump Circuit

Circuit Description

This fault code indicates that the fuel pump speed/position signal is lost.

Component Location

The speed/position sensor is located in the fuel pump.

Shop Talk

The fuel pump determines its speed and position in relation to the engine by referencing an internal tone wheel gap-analog signals are converted to digital.

If the digital signal is not available or if the gap of the incremental angle sensor tone wheel is not recognized, the pump controller will set a fault code. Also, rapid speed changes, stalling, or inlet pressure under 21 kPa [3 psi] can cause this fault code to set.

Refer to Troubleshooting Fault Code t05-367.

Last Modified: 17-Jan-2013


Fuel Pump Can Not Reach Commanded Timing

FAULT CODE 368

Fuel Pump Can Not Reach Commanded Timing

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 368 PID: P0216, S254 SPN: 1078 FMI: 8 LAMP: Yellow SRT: | The fuel pump can not achieve the timing value being commanded by the engine control module (ECM) due to an internal pump problem. | Engine power derate. White smoke.
Fuel Pump Circuit

Circuit Description

The fuel pump uses an internal check to determine if the fuel injection pump can reach the commanded timing.

Component Location

The fuel pump circuit is internal to the fuel pump.

Shop Talk

The fuel pump uses pressure generated by an internal vane-type transfer pump and its timing solenoid to vary the fuel pump's timing according to the specified ECM commands. Possible causes can be classified into four groups:

  • Static timing - offset key, gear train issues
  • Low-pressure fuel supply issues - restriction issues, low supply pressure
  • Fuel pump return plumbing issues - high return restriction, overflow valve issues
  • Noise in the engine position pulse signal.
Refer to Troubleshooting Fault Code t05-368

Last Modified: 17-Jan-2013


Fuel Pump To Engine Synchronization Pulse Not Recognized

FAULT CODE 369

Fuel Pump To Engine Synchronization Pulse Not Recognized

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 369 PID: P1690 SPN: 1078 FMI: 2 LAMP: Yellow SRT: | Fuel pump controller does not detect engine position pulse at pin 7 of the engine harness ECM connector. | Engine power derate. Low power.
Engine Synchronization Error Circuit

Circuit Description

The engine control module (ECM) receives a signal from the engine speed/position sensor. This signal is then sent to the fuel pump to indicate where top dead center is for each cylinder.

Component Location

The engine speed/position sensor is located on the fuel-pump side of the block, behind the starter.

Shop Talk

The fuel pump controller monitors/processes 10- to 12-VDC square wave signals at pin 8 (engine harness pump end). The leading edge of this wave is the top dead center reference for the pump. The reference signal must occur within a defined window. If an engine pulse is not recognized within a window, the pump controller sets an error (bit 12). If a final error (bit 13) is set, Fault Code 369 is triggered after 10 seconds while the engine is operating. If Fault Code 368 occurs along with Fault Code 369, verify the engine static timing. Most occurrences of this fault are due to improper wiring by original equipment manufacturer (OEMs) or to grounding issues, loose/shorted wires, or electrical noise.

Refer to Troubleshooting Fault Code t05-369.

Last Modified: 17-Jan-2013


Idle Select High/Low

FAULT CODE 372

Idle Select High/Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 372 PID: P1283, S233 SPN: 1077 FMI: 11 LAMP: Yellow SRT: | The fuel pump controller detects continuous voltage at idle select pin 16 of the engine harness, or the pump controller detects an open circuit or short circuit to ground at idle select pin 16 of the engine harness. | Engine will operate at the lower limp home mode speed.
Fuel Pump Circuit

Circuit Description

This circuit is used for limp home acceleration if communication between the engine control module (ECM) and fuel pump is lost. The circuit allows for a two-stage acceleration where there are only two engine speeds available throughout the full range of accelerator travel.

Component Location

This circuit is internal to the fuel pump control module and the engine ECM.

Refer to Troubleshooting Fault Code t05-372.

Last Modified: 17-Jan-2013


Fuel Pump Fuel Shut Off Error

FAULT CODE 373

Fuel Pump Fuel Shut Off Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 373 PID: P232, S233 SPN: 1077 FMI: 3 LAMP: Yellow SRT: | High voltage detected at the fuelpump shut off SIGNAL pin 5 of the engine harness, pump connector end. | Fueling to injector disabled. Engine stops.
Fuel Pump Circuit

Circuit Description

This circuit provides a secondary fuel shutoff signal from the engine control module (ECM) to the fuel pump.

Component Location

The fuel pump is located on the back side of the gear housing.

Shop Talk

The fuel pump controller disables fuel injection if a greater-than-6-VDC signal is registered at pin 5 (pump connector end) for 1 second. This signal line is triggered if an engine protection limit is exceeded or if a pump controller defect is set.

Normal engine operation is as follows:

  • 0-VDC at pin 5 at keyswitch ON
  • 12-VDC at pin 5 at keyswitch OFF, until ECM powers down.

Check for a short circuit in the wiring harness, bad connectors, or high voltage at engine harness pin 5 on the pump end at keyswitch ON.

Refer to Troubleshooting Fault Code t05-373.

Last Modified: 17-Jan-2013


Fuel Pump Calibration Error

FAULT CODE 374

Fuel Pump Calibration Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 374 PID: P1688 FMI: LAMP: Yellow SRT: | Fuel pump controller has detected a calibration error, electrically erasable programmable read-only memory error, random-access memory problem, or an electrical or hardware problem in the fueling solenoid circuit. | Engine will not start or engine will run with some power loss.
Fuel Pump

Circuit Description

Fuel pump self-test is provided at power-up. In an ideal case, an active Fault Code 374 indicates a fuel pump defect and can trigger the engine light/malfunction indicator light at key on.

Component Location

The fuel pump is located on the backside of the gear housing. Refer to Procedure 100-002 in Section E for detailed component location.

Shop Talk

If Fault Code 374 becomes active while the engine is operating, it can possibly be due to a power glitch or to voltage spikes. Check the power supply circuit for loose or shorted wires and/or fuses. Inspect the power supply relay.

Refer to Troubleshooting Fault Code t05-374.

Last Modified: 08-Jan-2013


Engine Control Module (ECM) Fuel Calibration Corrupted

FAULT CODE 375

Engine Control Module (ECM) Fuel Calibration Corrupted

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 375 PID: P0602, S254 SPN: FMI: 2 LAMP: Yellow SRT: | The engine ECM is commanding a fueling or timing value that the fuel pump can not achieve. | Engine does not operate.
Engine Control Module

Circuit Description

The ECM contains the calibration-specific parameter to control the engine's performance and diagnostics. The fuel pump has its own calibration to interpret the ECM message and control the pump. If the fueling calibration in the ECM is altered or tampered with, this fault will be logged.

Component Location

The logic for the fault code is contained in the ECM circuitry.

Shop Talk

This fault code is meant to detect out-of-range values and protect the fuel pump from excessive duty cycles from illegal calibration tampering.

If this code is active or has high inactive counts, the fuel pump control module has detected an out-of-range value commanded by the ECM. Recalibrate the ECM.

Refer to Troubleshooting Fault Code t05-375.

Last Modified: 09-Jan-2013


Fuel Pump rpm and Fuel Error

FAULT CODE 376

Fuel Pump rpm and Fuel Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 376 PID: P1691 SPN: FMI: LAMP: None SRT: | The speed measured by the pump controller is different from the speed measured by the engine controller by more than a calibratable amount. The pump controller is commanding fuel while the engine controller is requesting no fuel delivery. | Engine will not operate.
Fuel Pump

Circuit Description

This diagnostic is meant to act as a speed and fueling rationality check between the engine control module (ECM) and the fuel pump control module.

Component Location

The logic for this fault code is contained in the ECM and the fuel pump control module.

Shop Talk

False alarms caused by speed transitions, such as sudden accelerations or engine stall checks, can trigger this fault code.

Refer to Troubleshooting Fault Code t05-376.

Last Modified: 08-Jan-2013


Fuel Pump Power Relay Stuck-On

FAULT CODE 377

Fuel Pump Power Relay Stuck-On

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 377 PID: S233 SPN: 1077 FMI: 7 LAMP: Yellow SRT: | Fuel pump controller is not powering down when keyswitch power is removed from the engine control module (ECM). | Equipment batteries can be drained low during long shutdown periods.
Fuel Pump Circuit

Circuit Description

This circuit is internal to the ECM. If the keyswitch is turned off and the ECM still detects messages being sent from the fuel pump, the ECM will log this fault.

Component Location

This circuit logic is internal to the ECM.

Shop Talk

  • Some older ISB engines use a different original equipment manufacturer (OEM) interface connector than illustrated.
  • Fault Code 377 can be caused by a stuck fuel pump relay. If voltage is detected at pin 7 of the fuel pump connector, with the keyswitch in the OFF position, check for a faulty fuel pump relay.
Refer to Troubleshooting Fault Code t05-377.

Last Modified: 17-Jan-2013


Intake Air Heater Relay Circuit

FAULT CODE 381

Intake Air Heater Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 381 PID: S237 SPN: 626 FMI: 11 LAMP: Yellow SRT: | Error detected in the cold start air relay 1 enable circuit at pin 41 of the original equipment OEM harness. | Intake air heater can not be energized by the ECM. Possible white smoke and/or hard starting in cold ambient conditions.
Intake Air Heater Relay Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The ECM controls relays that switch power to the air heater. There are two heating coils in the heater that are individually controlled by the ECM.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the heater relays will vary with the OEM.

Shop Talk

  • These faults could also indicate the intake air heater circuits are shorted to battery (+). This would command the grids to be on full time. This will drain the batteries, burn out grids, and/or destroy intake gaskets.
  • The intake air heater circuits will only activate when intake manifold temperature is below 19°C [66°F], when the keyswitch is in the ON position.
Refer to Troubleshooting Fault Code t05-381

Last Modified: 29-Jul-2010


Intake Air Heater Relay Circuit

FAULT CODE 382

Intake Air Heater Relay Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 382 PID: S237 SPN: 626 FMI: 11 LAMP: Yellow SRT: | Error detected in the cold start air relay 2 enable circuit at pin 31 of the OEM harness. | Intake air heater can not be energized by the electronic control module (ECM). Possible white smoke and/or hard starting in cold ambient conditions.
Intake Air Heater Relay Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The ECM controls relays that switch power to the air heater. There are two heating coils in the heater that are individually controlled by the ECM.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the heater relays will vary with the OEM.

Shop Talk

  • These faults could also indicate the intake air heater circuits are shorted to battery (+). This would command the grids to be on full time. This will drain the batteries, burn out grids, and/or destroy intake gaskets.
  • The intake air heater circuits will only activate when intake manifold temperature is below 19°C [66°F] when the keyswitch is in the ON position.
Refer to Troubleshooting Fault Code t05-382

Last Modified: 29-Jul-2010


Intake Air Heater Circuit

FAULT CODE 383

Intake Air Heater Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 383 SPN: 620 FMI: 3 LAMP: Service Engine Soon SRT: | The battery voltage monitor indicates the intake air heater is not functioning. | Possible white smoke and/or hard starting.
Intake Air Heater Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold temperature conditions. The ECM controls relays that switch power to the air heater. There are two heating coils in the heater that are individually controlled by the ECM.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold.

Refer to Troubleshooting Fault Code t05-383

Last Modified: 29-Jul-2010


Sensor Supply Circuit

FAULT CODE 386

Sensor Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 620 FMI: 4 or 3 LAMP: Yellow SRT: | High voltage detected at +5-VDC supply, pin 10 of the engine harness. | Default value used for sensors connected to this +5-VDC supply. Engine will derate to no-boost fueling and loss of engine protection for oil pressure, intake manifold pressure, and coolant temperature.
Sensor Supply Circuit

Circuit Description

The engine position sensor (EPS), the intake manifold pressure sensor, and the oil pressure sensor are powered by the same +5-VDC source and the same return in the electronic control module (ECM). This supply is also used to operate the intake manifold temperature and coolant temperature sensors.

Component Location

The +5-VDC sensor supply circuit is located in the sensor harness. See Section E of this manual for the sensor locations.

Shop Talk

These faults could also cause high- or low-voltage faults on the coolant temperature and intake manifold temperature sensors.

Refer to Troubleshooting Fault Code t05-386

Last Modified: 29-Jul-2010


Accelerator Position Sensor Circuit

FAULT CODE 387

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 387 PID: P091 or S232 SPN: 091 or 620 FMI: 3 or 1 LAMP: Yellow SRT: | High voltage detected at accelerator position sensor supply pin 29 of the original equipment manufacturer's (OEM) harness. | Engine idles when accelerator is not pressed and ramps up to a default set speed when off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator pedal assembly with accelerator position sensor relays the accelerator percentage requested by the operator to the electronic control module (ECM). Percent accelerator is used by the ECM to determine fueling. In order for the accelerator position sensor to function properly, it is necessary that a good +5-VDC supply voltage is available.

Component Location

The accelerator position sensor is located on the accelerator pedal inside the vehicle cab.

Refer to Troubleshooting Fault Code t05-387

Last Modified: 29-Jul-2010


Fuel Pump Relay Coil Supply Circuit

FAULT CODE 391

Fuel Pump Relay Coil Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 391 PID: S017 SPN: 632 FMI: 11 LAMP: Yellow SRT: | Short to ground detected in fuel pump power supply relay enable circuit at pin 43 of the engine harness. | Engine will not start; it dies.
Fuel Pump Relay Coil Supply Circuit

Circuit Description

The fuel pump relay is used to supply voltage to the fuel pump. The engine control module (ECM) can shut down the engine by cutting off the power to the fuel shutoff relay circuit.

Component Location

This component is supplied by the equipment manufacturer. Refer to the original equipment manufacturer (OEM) service manual for component location.

Shop Talk

  • Inspect the fuel pump relay circuit for external wires that are spliced in to power another device. Remove any extra wires that are found in the circuit.
  • If there is an external shutdown system on the vehicle that uses the fuel shutoff relay circuit for engine shutdown, make sure it has not failed and pulled down the voltage on the fuel shutoff circuit.
  • Inspect the engine block to chassis ground wire to make sure it is securely fastened to a clean, unpainted, dry surface.
  • Check the starter solenoid (+) terminal for a loose connector or accessory wiring with damaged insulation.
  • High resistance in the fuel pump power supply circuit can result in active Fault Code 364 and an engine that will not start. The troubleshooting steps for Fault Code 391 apply to other symptoms and fault codes that are voltage-dependent.
  • Fault Code 364 may be active in conjunction with this fault. Follow Fault Code 391tree first.
Refer to Troubleshooting Fault Code t05-391.

Last Modified: 18-Jan-2013


Water-In-Fuel Sensor Circuit

FAULT CODE 418

Water-In-Fuel Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 097 FMI: 0 LAMP: WIF SRT: | Water-in-fuel (WIF) signal indicates water in the fuel filter needs to be drained. | Excessive water in the fuel can lead to severe fuel system damage.
WIF Sensor Circuit

Circuit Description

The WIF sensor is attached to the fuel filter. The WIF sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter.

Component Location

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter, a malfunctioning Water-In-Fuel sensor is a likely cause.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

The WIF sensor is installed in the bottom or side of the fuel filter, which is located on the intake side of the cylinder head approximately midengine.

Refer to Troubleshooting Fault Code t05-418

Last Modified: 12-Oct-2011


Water-In-Fuel (WIF) Sensor Circuit

FAULT CODE 429

Water-In-Fuel (WIF) Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 097 FMI: 4 LAMP: Yellow SRT: | Low voltage detected at WIF signal pin 40 of the original equipment manufacturer (OEM) harness. | No water in fuel detection capability.
WIF Sensor Circuit

Circuit Description

The WIF sensor is attached to the fuel filter. The WIF sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The WIF circuit contain two wires: A return ground (pin 20), and a signal wire (pin 40).

Component Location

The water-in-fuel sensor is installed in the fuel filter and is located on the side of the head approximately midway on the engine.

Refer to Troubleshooting Fault Code t05-429

Last Modified: 29-Jul-2010


Idle Validation Switch (IVS) Circuit

FAULT CODE 431

Idle Validation Switch (IVS) Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: P091 SPN: 091 FMI: 2 or 4 LAMP: Yellow SRT: | Idle validation signals on pins 25 and 26 of the original equipment manufacturer's (OEM) harness indicate +5 VDC present at both pins 25 and 26. | No effect on performance but loss of idle validation.
Idle Validation Switch Circuit

Circuit Description

The idle validation switch (IVS) is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal manufacturers to switch from on-idle to off-idle at the correct accelerator pedal position.

NOTE: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with the equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Shop Talk

This fault code is usually caused by a loose connection, uncalibrated accelerator pedal, or miswired IVS.

A bad ground on pin A of the IVS can also cause this fault.

Refer to Troubleshooting Fault Code t05-431

Last Modified: 29-Jul-2010


Accelerator Pedal Circuit (ISS)

FAULT CODE 432

Accelerator Pedal Circuit (ISS)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: P091 SPN: 091 FMI: 13 LAMP: Yellow SRT: | No voltage detected at pin 26 of the original equipment manufacturer's (OEM) harness indicates the accelerator is at the idle position when the accelerator position signal at pin 30 of the OEM harness indicates the accelerator is not at the idle position, or idle validation signal at pin 26 of the OEM harness indicates the accelerator is not at the idle position when the accelerator position signal pin 30 of the OEM harness indicates the accelerator is at the idle position. | Engine will only idle.
Accelerator Pedal Circuit

Circuit Description

The accelerator pedal assembly relays the accelerator percentage requested by the operator to the electronic control module (ECM). Percent accelerator is used to determine fueling. The accelerator position sensor and the idle validation switch on the accelerator pedal are adjusted at the factory to provide the correct output signals.

NOTE: The connector pin letters shown for the accelerator pedal wiring in these troubleshooting steps are examples of representative sensors. The connector pin assignments can vary with the equipment manufacturer, but the base troubleshooting logic will still apply.

Component Location

The accelerator position sensor and the idle validation switch are located on the accelerator pedal in the cab.

Shop Talk

Confirm that the idle validation switch (IVS) is properly calibrated. Refer to the accelerator pedal manufacturer's instructions for adjustment information.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together. Depending on ground location, IVS will, perhaps, only have two wires.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 29-Jul-2010


Intake Manifold Pressure Sensor Circuit

FAULT CODE 433

Intake Manifold Pressure Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 433 PID: P102 FMI: 2 LAMP: Yellow SRT: | Boost pressure signal indicates boost pressure is high when other engine parameters (i.e., speed and load) indicate boost pressure should be low. | Possible overfueling during acceleration. Increase in black smoke.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If intake manifold pressure becomes too high, it will cause a derate condition.

Component Location

The intake manifold pressure sensor is located in the side of the intake manifold, just to the right of the fuel filter.

Shop Talk

The ECM checks for this fault only at idle speed. If the intake manifold pressure shows too high of a value at this time, the ECM will log a fault code.

Refer to Troubleshooting Fault Code t05-433

Last Modified: 29-Jul-2010


Unswitched Battery Supply Circuit

FAULT CODE 441

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1 LAMP: None SRT: | Voltage detected at electronic control module (ECM) power supply pins 38, 39, and 40 of the engine harness indicates ECM supply voltage fell below (+) 6 VDC. | Engine will die or run rough.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery input through the engine harness. There are three in-line 7.5-amp fuses and two 10-amp fuses in the unswitched battery wire of the actuator harness to protect the engine harness from overheating.

Component Location

The ECM is connected to the battery by the engine harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the equipment manufacturer. Refer to the equipment manufacturer's repair manual for the battery location.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter or other device. Check for possible weak batteries.

Refer to Troubleshooting Fault Code t05-441

Last Modified: 29-Jul-2010


Unswitched Battery Supply Circuit

FAULT CODE 442

Unswitched Battery Supply Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0 LAMP: Yellow SRT: | Voltage detected at electronic control module (ECM) power supply pins 38, 39, and 40 of the engine harness indicates ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The ECM receives unswitched battery input through the engine harness. There are two in-line 10-amp fuses and three 7.5-amp fuses in the unswitched battery wire to protect the engine harness from overheating. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is connected to the battery by the engine harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM manual for battery location.

Shop Talk

Disconnect all aftermarket devices from the battery supply circuit. Make sure the proper size fuses are being used (10-amp fuse or 7.5-amp fuse).

Refer to Troubleshooting Fault Code t05-442

Last Modified: 29-Jul-2010


Accelerator Position Sensor Circuit

FAULT CODE 443

Accelerator Position Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443 PID: P091 or S232 SPN: 091 or 620 FMI: 3 or 1 LAMP: Yellow SRT: | Low voltage detected at accelerator position sensor supply pin 29 of the OEM harness. | Engine idles when accelerator is not pressed and ramps up to a default set speed when off-idle.
Accelerator Position Sensor Circuit

Circuit Description

The accelerator pedal assembly with accelerator position sensor relays the accelerator percentage requested by the operator to the electronic control module (ECM). Percent accelerator is used by the ECM to determine fueling. In order for the accelerator position sensor to function properly, it is necessary that a good +5-VDC supply voltage is available.

Component Location

The accelerator position sensor is located on the accelerator pedal inside the vehicle cab.

Refer to Troubleshooting Fault Code t05-443

Last Modified: 29-Jul-2010


Fuel Pump Valve Feedback Error

FAULT CODE 517

Fuel Pump Valve Feedback Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 517 PID: P0252 SPN: FMI: LAMP: Yellow SRT: | A mechanically stuck fuel control valve has been detected by the fuel pump controller. | Engine will stop running.
Fuel Pump

Circuit Description

A mechanically stuck fuel control valve has been detected by the pump controller.

Component Location

The fuel pump is located on the backside of the gear housing.

Shop Talk

This fault is typically set when a fuel pump beginning of injection point error (bit 10) is recognized at engine speeds of more than 700 rpm and commanded fueling of more than 20 mm³ for two seconds at a battery voltage of 9 VDC.

In most instances, Fault Code 517 will occur in conjunction with Fault Code 363. The same diagnostic steps can be applied. The fault code can also be triggered by electrical noise, voltage feedback on ground loop, or high fuel return line restriction.

Refer to Troubleshooting Fault Code t05-517.

Last Modified: 08-Jan-2013


Auxiliary Commanded Dual Output Shutdown - Special Instructions

FAULT CODE 599

Auxiliary Commanded Dual Output Shutdown - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 599 PID: S025 SPN: 640 FMI: 14 LAMP: Red SRT: | Auxiliary Commanded Dual Output Shutdown - Special Instructions. The engine protection limit has been exceeded for the dual outputs calibrated limits. | Engine will shut down.
Dual-Output Driver A
QSB3.9-30,QSB4.5-30,and QSB5.9-30 - Auxiliary Commanded Dual Output Shutdown Circuit

Circuit Description

Dual outputs based on sensed parameters provide up to two independent switched outputs for original equipment manufacturer (OEM) use. The state of each switched output can be determined by different inputs to the engine control module (ECM) depending on the engine platform. The ECM can provide different outputs to OEM devices if any of the inputs are above or below calibrated thresholds. Each switched output is independent of the other with respect to control parameter input and threshold settings.

Component Location

The dual outputs features are OEM dependent. Use the following for a detailed component location view. See equipment manufacturer service information.

Shop Talk

This fault code is activated when one of the OEM defined inputs has exceeded a calibratible limit. The triggers for shutdown are OEM dependent.

Refer to Troubleshooting Fault Code t05-599.

Last Modified: 10-Jul-2015


Engine Misfire Detection

FAULT CODE 613

Engine Misfire Detection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 613 SPN: 1322 FMI: 1 LAMP: Service Engine Soon SRT: | An engine misfire has been detected in more than one cylinder. | Engine will misfire, run rough, stall or be hard to start.
No Graphic Available

Circuit Description

The ECM monitors the engine and detects when a cylinder is misfiring.

Component Location

N/A

Refer to Troubleshooting Fault Code t05-613

Last Modified: 29-Jul-2010


Engine Misfire Detection

FAULT CODE 621

Engine Misfire Detection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 621 PID: SPN: 1323 FMI: 1 LAMP: Service Engine Soon SRT: | An engine misfire has been detected in cylinder No. 1. | Engine will misfire and run rough.

Circuit Description

The ECM monitors the engine and detects when a cylinder is misfiring.

Component Location

N/A

Refer to Troubleshooting Fault Code t05-621

Last Modified: 29-Jul-2010


Engine Misfire Detection

FAULT CODE 622

Engine Misfire Detection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 622 PID: SPN: 1324 FMI: 1 LAMP: Service Engine Soon SRT: | An engine misfire has been detected in cylinder No. 2. | Engine will misfire and run rough.

Circuit Description

The ECM monitors the engine and detects when a cylinder is misfiring.

Component Location

N/A

Refer to Troubleshooting Fault Code t05-622

Last Modified: 29-Jul-2010


Engine Misfire Detection

FAULT CODE 623

Engine Misfire Detection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 623 PID: SPN: 1325 FMI: 1 LAMP: Service Engine Soon SRT: | An engine misfire has been detected in cylinder No. 3. | Engine will misfire and run rough.

Circuit Description

The ECM monitors the engine and detects when a cylinder is misfiring.

Component Location

N/A

Refer to Troubleshooting Fault Code t05-623

Last Modified: 29-Jul-2010


Engine Misfire Detection

FAULT CODE 624

Engine Misfire Detection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 624 PID: SPN: 1326 FMI: 1 LAMP: Service Engine Soon SRT: | An engine misfire has been detected in cylinder No. 4. | Engine will misfire and run rough.

Circuit Description

The ECM monitors the engine and detects when a cylinder is misfiring.

Component Location

N/A

Refer to Troubleshooting Fault Code t05-624

Last Modified: 29-Jul-2010


Engine Misfire Detection

FAULT CODE 625

Engine Misfire Detection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 625 PID: SPN: 1327 FMI: 1 LAMP: Service Engine Soon SRT: | An engine misfire has been detected in cylinder No. 5. | Engine will misfire and run rough.

Circuit Description

The ECM monitors the engine and detects when a cylinder is misfiring.

Component Location

N/A

Refer to Troubleshooting Fault Code t05-625

Last Modified: 29-Jul-2010


Engine Misfire Detection

FAULT CODE 626

Engine Misfire Detection

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 626 PID: SPN: 1328 FMI: 1 LAMP: Service Engine Soon SRT: | An engine misfire has been detected in cylinder No. 6. | Engine will misfire and run rough.

Circuit Description

The ECM monitors the engine and detects when a cylinder is misfiring.

Component Location

N/A

Refer to Troubleshooting Fault Code t05-626

Last Modified: 29-Jul-2010


Fault Codes 123, 141, and 352

FAULT CODE Multiple A

Fault Codes 123, 141, and 352

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: Multiple A PID: SPN: 102, 100, and 620 FMI: 4 LAMP: Service Engine Soon and Check Gauges SRT: | Low voltage detected in the internal electronic control module (ECM) supply line to the sensors. | Derate to no-air setting.

Sensor Supply Voltage Circuit

Circuit Description

The ECM supplies each sensor in the engine harness with +5 VDC. If the electrical wiring or voltage supply source to any sensor is damaged, the sensor will not work correctly.

Component Location

  • Intake Manifold Pressure Sensor
  • Oil Pressure Sensor
  • Engine Position Sensor.

Shop Talk

Low voltage on the sensor +5 VDC supply line will be caused by a short to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement:
Part No. 3822758 - male AMP/Metri-Pack test lead
Part No. 3822917 - female AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connector pins. | No damaged pins
 | STEP 1B. Check for a short circuit to ground in the sensor supply lines. | More than 100k ohms
 | STEP 1C. Check for a short circuit from pin to pin. | More than 100k ohms
 | STEP 1D. Check the ECM supply voltage. | 4.75 to 5.25 VDC
STEP 2. | Clear for failed sensors. |
 | STEP 2A. Check the intake manifold pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2B. Check the oil pressure sensor supply voltage. | 4.75 to 5.25 VDC
 | STEP 2C. Check the engine position sensor supply voltage. | 4.75 to 5.25 VDC
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Codes 123, 141, and 352 are inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Keyswitch in the “OFF” position.
  • Disconnect the engine harness from the ECM.

Action

  • bent or broken pins
  • pushed back or expanded pins
  • corroded pins
  • moisture in or on the connector
  • missing or damaged seals.
OK NOT OK

No damaged pins

Repair the damaged pins
Repair or replace the engine harness or the ECM, whichever has the damaged pins.
Repair the engine harness.

  • Refer to Procedure 019-250.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit to ground in the sensor supply lines.

Conditions

  • Keyswitch in the "OFF" position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

  • Measure the resistance from pin 10 of the engine harness connector to the engine block ground.
OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-250.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch in the "OFF" position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

  • Measure the resistance from pin 10 of the engine harness connector to all the other pins in the connector.
OK NOT OK

More than 100k ohms

Replace the engine harness
Refer to Procedure 019-043.

Go to 1D

Go to 3A

Guided Step 1D - Check the ECM supply voltage.

Conditions

  • Keyswitch in the “ON” position.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Connect the engine harness to the ECM.

Action

  • Measure the voltage from pin A on the harness side of the engine speed sensor to engine block ground.
  • Measure the voltage from pin A on the harness side of the oil pressure sensor to engine block ground.
  • Measure the voltage from pin A on the harness side of the intake manifold pressure sensor to engine block ground.
OK NOT OK

4.75 to 5.25 VDC

Replace the ECM
Refer to Procedure 019-031.

Go to 2A

Go to 3A

Guided Step 2 - Check for failed sensors.

Guided Step 2A - Check the intake manifold pressure sensor supply voltage.

Conditions

  • Keyswitch in the “ON” position.
  • Connect the intake manifold pressure sensor breakout cable, Part No. 3824775, between the intake manifold pressure sensor and the engine harness.

Action

  • Measure the voltage from pin A to pin B on the intake manifold pressure sensor circuit with the sensor connected and disconnected.

NOTE: Pressure sensor breakout cable kit, Part No. 3824773, is available to aid in troubleshooting.

OK NOT OK

4.75 to 5.25 VDC

Replace the intake manifold pressure sensor
Refer to Procedure 019-061.

Go to 2B

Go to 3A

Guided Step 2B - Check the oil pressure sensor supply voltage.

Conditions

  • Keyswitch in the “ON” position.
  • Connect the oil pressure sensor breakout cable, Part No. 3824775, between the oil pressure sensor and the engine harness.

Action

  • Measure the voltage from pin A to pin B on the oil pressure sensor circuit with the sensor connected and disconnected.

NOTE: Pressure sensor breakout cable kit, Part No. 3824773, is available to aid in troubleshooting.

OK NOT OK

4.75 to 5.25 VDC

Replace the oil pressure sensor
Refer to Procedure 019-066.

Go to 2C

Go to 3A

Guided Step 2C - Check the engine position sensor supply voltage.

Conditions

  • Keyswitch in the “ON” position.
  • Connect the engine position sensor breakout cable, Part No. 3824775, between the engine position sensor and the engine harness.

Action

  • Measure the voltage from pin A to pin B on the engine position sensor circuit with the sensor connected and disconnected.

NOTE: Pressure sensor breakout cable kit, Part No. 3824773, is available to aid in troubleshooting.

OK NOT OK

4.75 to 5.25 VDC

Replace the engine position sensor
Refer to Procedure 019-038.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

  • Start the engine and let idle for 1 minute.
  • Verify that Fault Codes 123, 141, and 352 inactive.
OK NOT OK

Fault Codes 123, 141, and 352 inactive

Return to the troubleshooting steps, or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Keyswitch in the “ON” position.

Action

  • Erase the inactive fault codes using INSITE™.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2003


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module (ECM) Microprocessor

Printable Version Printable Version

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 111 inactive.
 | STEP 1B. Check the inactive counts of Fault Code 111. | Fault is inactive and no performance-related complaints are associated with this fault.
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 111 inactive.
 | STEP 2B. Clear the inactive fault codes. | All faults cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 111 inactive

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault is inactive and no performance-related complaints are associated with this fault.

Replace the ECM

Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 111 inactive

Return to the troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jan-2013


FAULT CODE 115VP30 - Engine Speed Sensor (ESS) Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB and QSB | 3666194
Engine Control Module | Refer to Procedure 019-031 | ISB Light Duty | 3666288
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | ISB and QSB | 3666194
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | ISB Light Duty | 3666288
Engine Wiring Harness | Refer to Procedure 019-043 | ISB and QSB | 3666194
Engine Wiring Harness | Refer to Procedure 019-043 | ISB Light Duty | 3666288

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 283 or 284 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the engine speed sensor. |
 | STEP 3A. Inspect the engine speed sensor and engine harness connectors. | Dirty or damaged pins?
 | STEP 3B. Check engine speed sensor supply voltage. | Between 4.75 VDC and 5.25 VDC?
 | STEP 3C. Check for signal from the engine speed sensor. | Signal present?
 | STEP 3D. Inspect the nose of the sensor. | Damage found?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 283 or 284 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the engine speed sensor connector.

Action

Check for an open circuit in the +5 VDC SUPPLY wire and the SIGNAL wire.

  • Measure the resistance between the ECM connector SUPPLY pin and the engine speed sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector RETURN pin and the engine speed sensor connector RETURN pin.
  • Measure the resistance between the ECM connector SIGNAL pin and the engine speed sensor connector SIGNAL pin.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the engine speed sensor connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine speed sensor SUPPLY pin of the engine harness connector to the engine block ground.
  • Measure the resistance from the engine speed sensor RETURN pin of the engine harness connector to the engine block ground.
  • Measure the resistance from the engine speed sensor SIGNAL pin of the engine harness connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the engine speed sensor connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine speed sensor SUPPLY pin in the engine harness ECM connector to all other pins in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor RETURN pin in the engine harness ECM connector to all other pins in the engine harness ECM connector.
  • Measure the resistance from the engine speed sensor SIGNAL pin in the engine harness ECM connector to all other pins in the engine harness ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine speed sensor.

Guided Step 3A - Inspect the engine speed sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine speed sensor connector.
  • Connect the engine harness connector to the ECM connector.

Action

Inspect the engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check engine speed sensor supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the engine speed sensor connector.

Action

Check engine speed sensor supply voltage.

  • Measure the voltage between the engine speed sensor SUPPLY pin and the engine speed sensor RETURN pin at the engine speed sensor connector of the engine harness.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a signal from the engine speed sensor.

Conditions

  • Turn keyswitch ON.
  • Install breakout cable, Part Number 3824775, between the engine speed sensor and engine harness.

Action

Check for a signal from the engine speed sensor .

  • Measure the voltage between the engine speed sensor SIGNAL pin and the engine speed sensor RETURN pin on the breakout cable while barring the engine over. If the signal is present, the voltage will fluctuate between less than (+) 0.5 VDC and greater than (+) 4.5 VDC as the engine is barred over slowly.

Negative (-) lead of multimeter should be connected to the RETURN pin and the positive (+) lead to the SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Signal present?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Inspect the nose of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove sensor from engine. Refer to Procedure 019-042 in the Associated Procedures Table.

Action

Inspect the nose of the sensor for damage or debris.

  • Inspect for metal debris on the sensor tip.
  • Inspect for damage on the sensor caused by the crankshaft tone wheel gear.
  • Inspect for sensor swelling.
  • Check for a properly installed tone wheel.

Damage found?
YES NO

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verfiy all steps have been completed. If all steps have been completed follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 28-Sep-2016


FAULT CODE 115VP44 - Engine Speed Sensor (ESS) Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB and QSB | 3666194
Engine Control Module | Refer to Procedure 019-031 | ISB Light Duty | 3666288
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | ISB and QSB | 3666194
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | ISB Light Duty | 3666288
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | ISB and QSB | 3666194
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | ISB Light Duty | 3666288
Engine Wiring Harness | Refer to Procedure 019-043 | ISB and QSB | 3666194
Engine Wiring Harness | Refer to Procedure 019-043 | ISB Light Duty | 3666288

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 283 or 284 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the engine speed sensor. |
 | STEP 3A. Inspect the engine speed sensor and engine harness connectors. | Dirty or damaged pins?
 | STEP 3B. Check engine speed sensor supply voltage. | Between 4.75 VDC and 5.25 VDC?
 | STEP 3C. Check for signal from the engine speed sensor. | Signal present?
 | STEP 3D. Inspect the nose of the sensor. | Damage found?
STEP 4. | Check the engine position sensor. |
 | STEP 4A. Inspect the engine position sensor and engine harness connectors | Dirty or damaged pins?
 | STEP 4B. Check engine position sensor supply voltage. | Between 4.75 VDC and 5.25 VDC?
 | STEP 4C. Check for signal from the engine position sensor. | Signal present?
 | STEP 4D. Inspect the nose of the sensor. | Damage found?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 283 or 284 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the engine speed sensor connector.
  • Disconnect the engine harness connector from the engine position sensor connector.

Action

Check for an open circuit in the +5-VDC SUPPLY wire and the SIGNAL wire of the engine speed sensor.

  • Measure the resistance between the ECM connector SUPPLY pin and the engine speed sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector RETURN pin and the engine speed sensor connector RETURN pin.
  • Measure the resistance between the ECM connector SIGNAL pin and the engine speed sensor connector SIGNAL pin.

Check for an open circuit in the SUPPLY wire and SIGNAL wire of the engine position sensor.

  • Measure the resistance between the ECM connector SUPPLY pin and the engine position sensor connector SUPPLY pin.
  • Measure the resistance between the ECM connector RETURN pin and the engine position sensor connector RETURN pin.
  • Measure the resistance between the ECM connector SIGNAL pin and the engine position sensor connector SIGNAL pin.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the engine speed sensor connector.
  • Disconnect the engine harness connector from the engine position sensor connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine speed sensor SUPPLY pin of the engine harness connector to the engine block ground.
  • Measure the resistance from the engine speed sensor RETURN pin of the engine harness connector to the engine block ground.
  • Measure the resistance from the engine speed sensor SIGNAL pin of the engine harness connector to the engine block ground.
  • Measure the resistance from the engine position sensor SUPPLY pin of the engine harness connector to the engine block ground.
  • Measure the resistance from the engine position sensor SIGNAL pin of the engine harness connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine harness connector from the engine speed sensor connector.
  • Disconnect the engine harness connector from the engine position sensor connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure resistance from the engine speed sensor SUPPLY pin in the engine harness ECM connector to all other pins in the engine harness ECM connector.
  • Measure resistance from the engine speed sensor RETURN pin in the engine harness ECM connector to all other pins in the engine harness ECM connector.
  • Measure resistance from the engine speed sensor SIGNAL pin in the engine harness ECM connector to all other pins in the engine harness ECM connector.
  • Measure resistance from the engine position sensor SUPPLY pin in the engine harness ECM connector to all other pins in the engine harness ECM connector.
  • Measure resistance from the engine position sensor SIGNAL pin in the engine harness ECM connector to all other pins in the engine harness ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine speed sensor.

Guided Step 3A - Inspect the engine speed sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine speed sensor connector.
  • Connect the engine harness connector to the ECM connector.

Action

Inspect the engine speed sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Repair the AMP connector. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check engine speed sensor supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the engine speed sensor connector.

Action

Check engine speed sensor supply voltage.

  • Measure the voltage between the engine speed sensor SUPPLY pin and the engine speed sensor RETURN pin at the engine speed sensor connector of the engine harness.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a signal from the engine speed sensor.

Conditions

  • Turn keyswitch ON.
  • Install breakout cable, Part Number 3824775, between the engine speed sensor and the engine harness.

Action

Check for a signal from the engine speed sensor.

  • Measure the voltage between the engine speed sensor SIGNAL pin and the engine speed sensor RETURN pin on the breakout cable while barring the engine over. If the signal is present, the voltage will fluctuate between less than (+) 0.5 VDC and greater than (+) 4.5 VDC as the engine is barred over slowly.

Negative (-) lead of multimeter should be connected to the RETURN pin and the positive (+) lead to the SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Signal present?
YES NO
No Repair

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Inspect the nose of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove sensor from engine. Refer to Procedure 019-042 in the Associated Procedures Table.

Action

Inspect the nose of the sensor for damage or debris.

  • Inspect for metal debris on the sensor tip.
  • Inspect for damage on the sensor caused by the crankshaft tone wheel gear.
  • Inspect for sensor swelling.
  • Check for a properly installed tone wheel.

Damage found?
YES NO

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the engine position sensor.

Guided Step 4A - Inspect the engine position sensor and engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine position sensor connector.
  • Connect the engine harness connector to the ECM connector.

Action

Inspect the engine position sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check engine position sensor supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the engine position sensor connector.

Action

Check engine position sensor supply voltage.

  • Measure the voltage between the engine position sensor SUPPLY pin and the engine position sensor RETURN pin at the engine speed sensor connector of the engine harness.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a signal from the engine position sensor.

Conditions

  • Turn keyswitch ON.
  • Install breakout cable, Part Number 3824775, between the engine position sensor and engine harness.

Action

Check for a signal from the engine position sensor.

  • Measure the voltage between the engine position sensor SIGNAL pin and the engine speed sensor RETURN pin on the breakout cable while barring the engine over. If the signal is present, the voltage will fluctuate between less than (+) 0.5 VDC and greater than (+) 4.5 VDC as the engine is barred over slowly.

Negative (-) lead of multimeter should be connected to the RETURN pin and the positive (+) lead to the SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Signal present?
YES NO
No Repair

  • Replace the engine position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the nose of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove sensor from engine. Refer to Procedure 019-038 in the Associated Procedures Table.

Action

Inspect the nose of the sensor for damage or debris.

  • Inspect for metal debris on sensor tip.
  • Inspect for damage on the sensor caused by crankshaft tone wheel gear.
  • Inspect for sensor swelling.
  • Check for properly installed tone wheel.

Damage found?
YES NO

  • Replace the engine position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 28-Sep-2016


FAULT CODE 121 - Engine Position Sensor (EPS) Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and the ECM connectors. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the engine position sensor (EPS). |
 | STEP 2A. Inspect the EPS and engine harness connectors. | Dirty or damaged pins?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 121 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EPS.

Action

Check for an open circuit in the +5-VDC supply wire and the signal wire.

  • Measure the resistance from pin-10 of the engine harness connector to pin-A on the harness side of the EPS connector.
  • Measure the resistance from pin-9 of the engine harness connector to pin-C on the harness side of the EPS connector.
  • Measure the resistance from pin-11 of the engine harness connector to pin-B on the harness side of the EPS connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EPS.

Action

Check for a short circuit to ground in the +5-VDC supply wire and the signal wire.

  • Measure the resistance from pin-10 of the engine harness connector to engine block ground.
  • Measure the resistance from pin-9 of the engine harness connector to engine block ground.
  • Measure the resistance from pin-11 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EPS.

Action

Check for a short circuit from pin-to-pin in the +5-VDC supply wire and the signal wire.

  • Measure resistance from pin 10, 11 and 9 of the engine harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine position sensor (EPS).

Guided Step 2A - Inspect the EPS and the engine harness connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the EPS.
  • Connect the engine harness to the ECM.

Action

Inspect the EPS and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins

Repair the damaged pins. Repair or replace the engine harness or sensor, whichever, has the damaged pins

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the EPS. Refer to Procedure 019-038 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check EPS supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the EPS.

Action

Check EPS supply voltage.

  • Measure the voltage from pin-A to pin-B on the harness side of the EPS connector.
OK NOT OK

4.75 to 5.25-VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a signal from the EPS.

Conditions

  • Turn keyswitch ON.
  • Install breakout cable, Part Number 3824775, between the EPS and the engine harness.

Action

Check for a signal from the EPS.

  • Measure the voltage from pin-C to pin-B on the breakout cable while barring the engine over. If the signal is present, the voltage will change from above 4.75-VDC to less than 0.5-VDC when cylinder number 1 TDC mark passes the sensor. The engine may need to be rotated through two full revolutions before the top dead center (TDC) mark will pass the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Signal present

Replace the EPS. Refer to Procedure 019-038 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the nose of the sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove sensor from engine.

Action

Inspect the nose of the sensor for damage or debris.

  • Inspect for metal debris on sensor tip.
  • Inspect for damage on sensor caused by camshaft gear.
  • Inspect for sensor swelling.
OK NOT OK

No damage found

Replace the engine position sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.

Action

Disable the fault codes.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 121 inactive

Return to the troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting charts

Last Modified: 15-Mar-2012


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 141, 144, 145, 153, 154, and 352 inactive?
STEP 2. | Check for mechanical malfunction. |
 | STEP 2A. Make sure of proper turbocharger operation. | Positive intake manifold pressure from turbocharger and wastegate not stuck closed?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Inspect the sensor circuit for tampering. | No tampering?
 | STEP 3b. Inspect the intake manifold pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3c. Check the intake manifold pressure supply voltage. | (+) 4.5 to 5.25-VDC?
 | STEP 3d. Check the intake manifold pressure signal voltage. | (+) 0.44 to 0.56-VDC?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 135, 141, 144, 145, 153, 154, and 352 inactive?

Possible sensor malfunction.

Short circuit to ground in sensor +5-VDC common supply, or short circuit from pin-to-pin.

Go to 2A

Fault Code 352 or 386

Guided Step 2 - Check for mechanical malfunction.

Guided Step 2A - Make sure of proper turbocharger operation.

Conditions

  • Turn keyswitch OFF.

Action

Make sure of proper turbocharger operation.

  • Check for positive intake manifold pressure using a mechanical gauge.
OK NOT OK

Positive intake manifold pressure from turbocharger and wastegate not stuck closed

Low intake manifold pressure

Correct the base engine malfunction.

Reference the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.

Go to 3A

Go to 5A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure sensor and the engine harness for external wires or damaged harness braiding.
OK NOT OK

No tampering

Remove and record tampering.

If tampering has occurred, repair the circuit and record the tampering.

Go to 3B

Go to 5A

Guided Step 3B - Inspect the intake manifold pressure sensor and engine harness connector pins.

Conditions

  • Turn the keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the sensor connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins

Repair the damaged pins.

Repair or replace the intake manifold pressure sensor or the engine harness, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the intake manifold pressure supply voltage.

Conditions

  • Turn keyswitch ON.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure supply voltage.

  • Measure the voltage from pin-A to pin-B of the intake manifold pressure sensor circuit.
OK NOT OK

(+) 4.5 to 5.25-VDC

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the intake manifold pressure signal voltage.

Conditions

  • Turn keyswitch ON.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure signal voltage.

  • Measure the voltage from pin-B to pin-C of the intake manifold pressure sensor circuit.
OK NOT OK

(+) 0.44 to 0.56-VDC

Replace the intake manifold pressure sensor

Refer to Procedure 019-061 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-45 on the engine harness connector to pin-C on the harness side of the intake manifold pressure sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-45 on the harness side of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-45 on the harness side of the engine harness connector to all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, turn keyswitch ON, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 122 inactive

Return to troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Mar-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Cannon™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 135, 141, 144, 145, 153, 154, and 352 inactive?
STEP 2. | Check for mechanical malfunction. |
 | STEP 2A. Make sure of proper turbocharger operation. | Positive intake manifold pressure from turbocharger and wastegate not stuck closed?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Inspect the sensor circuit for tampering. | No tampering?
 | STEP 3B. Inspect the intake manifold pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the intake manifold pressure supply voltage. | (+) 4.5 to 5.25 VDC?
 | STEP 3D. Check the intake manifold pressure signal voltage. | (+) 0.44 to 0.56 VDC?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and the ECM connector pins. | No damaged pins?
 | STEP 4B. Check for an open circuit. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 135, 141, 144, 145, 153, 154, and 352 inactive?

Possible sensor malfunction.

Short circuit to ground in sensor +5 VDC common supply, or short circuit from pin-to-pin.

Go to 2A

Fault Code 352 or 386?

Guided Step 2 - Check for mechanical malfunction.

Guided Step 2A - Make sure of proper turbocharger operation.

Conditions

  • Turn keyswitch OFF.

Action

Make sure of proper turbocharger operation.

  • Check for positive intake manifold pressure using a mechanical gauge.
OK NOT OK

Positive intake manifold pressure from turbocharger and wastegate not stuck closed?

Low intake manifold pressure.

Correct the base engine malfunction.

Reference the Troubleshooting and Repair Manual, ISC Engines, Bulletin 3666245.

Go to 3A

Go to 5A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure sensor and the engine harness for external wires or damaged harness braiding.
OK NOT OK

No tampering?

Remove and record tampering.

If tampering has occurred, repair the circuit and record the tampering.

Go to 3B

Go to 5A

Guided Step 3B - Inspect the intake manifold pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the sensor connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the intake manifold pressure sensor or the engine harness, whichever, has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the intake manifold pressure supply voltage.

Conditions

  • Turn keyswitch ON.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure supply voltage.

  • Measure the voltage from pin-A to pin-B of the intake manifold pressure sensor circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.5 to 5.25 VDC?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the intake manifold pressure signal voltage.

Conditions

  • Turn keyswitch ON.
  • Connect the intake manifold pressure sensor breakout cable, Part Number 3824776, between the sensor and the engine harness.

Action

Check the intake manifold pressure signal voltage.

  • Measure the voltage from pin-B to pin-C of the intake manifold pressure sensor circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 0.44 to 0.56 VDC?

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the engine harness and the ECM connector pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-45 on the engine harness connector to pin-C on the harness side of the intake manifold pressure sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-45 on the harness side of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-45 on the harness side of the engine harness connector to all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 123 inactive?

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Jul-2015


FAULT CODE 124 - Intake Manifold Pressure - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct within 127 mm Hg [5 in Hg]
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 124 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical intake manifold pressure gauge to the engine.
  • Connect INSITE™ electronic service tool to the vehicle datalink.
  • Start the engine, and compare the intake manifold pressure reading on the service tool monitor screen to the reading on the mechanical intake manifold pressure gauge.

The engine speed must be increased to make it easier to read differences in readings.

OK NOT OK

Sensor reading is correct within 127 mm Hg [5 in Hg]?

Locate and repair the cause of high intake manifold pressure. Reference the Troubleshooting and Repair Manual, ISB Series Engines, Bulletin No. 3666193.

Sensor reading incorrect?

Go to 2A

Fault Codes 122 and 123

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and operate under loaded conditions.
  • Use INSITE™ electronic service tool to verify the Fault Code 124 is inactive.
OK NOT OK

Fault Code 124 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Mar-2012


FAULT CODE 131 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and the accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the accelerator position sensor resistance. | 2000 to 3000 ohms?
 | STEP 1C. Check the resistance between sensor pins. Measure when the pedal is depressed and released. | Released: 1500 to 3000 ohms? Depressed: 200 to 1500 ohms? Released resistance must be at least 1000 ohms more than depressed resistance.
 | STEP 1D. Check for a short circuit to ground in the sensor +5-VDC supply. | Greater than 100k ohms?
 | STEP 1E. Check for a short circuit to ground in the sensor signal wire. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the supply, signal, and return wires of the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit between the +5-VDC supply wire and any other wire in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit between the accelerator position signal wire and any other wire in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check the accelerator position supply voltage. | (+) 4.75 to 5.25-VDC?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 131 or 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the OEM harness and the accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the accelerator position sensor. Refer to OEM troubleshooting and repair manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the acclerator position sensor.

  • Measure the resistance from pin-C (pin-A) to pin-A (pin-C) on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector onto the accelerator position sensor. The pin letters shown above are for the integrated sensor switch (ISS) and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

2000 to 3000 ohms?

Replace the accelerator position sensor

Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Measure when the pedal is depressed and released.

  • Measure the resistance from pin-C (pin-A) to pin-B (pin-C) on the sensor side of the accelerator position sensor.

Install the 6-pin, Part Number 3824892, or the 3-pin repair connector, Part Number 3823255, repair connector into accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS) and the letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Released: 1500 to 3000 ohms?

Depressed: 250 to 1500 ohms?

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor.

Refer to the OEM service manual.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to ground in the sensor +5-VDC supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the sensor +5-VDC supply.

  • Measure the resistance from pin-C (pin-A) on the sensor side of the accelerator position sensor to engine block ground.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS) and the letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the accelerator position sensor

Refer to the OEM service manual.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit to ground in the sensor signal wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the signal wire.

  • Measure the resistance from pin-B on the sensor side of the accelerator position sensor to engine block ground.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS) and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the accelerator position sensor.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever, has damaged pins.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit in the supply, signal, and return wires of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit in the supply, signal, and return wires of the OEM harness.

  • Measure the resistance from pin-29 of the OEM harness connector to pin-C (pin-A) on the harness side of the accelerator position sensor.
  • Measure the resistance from pin-30 of the OEM harness connector to pin-B on the harness side of the accelerator position sensor.
  • Measure the resistance from pin-19 of the OEM harness connector to pin-A (pin-C) on the harness side of the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit between +5-VDC supply wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from the +5-VDC supply wire to any other wire in the OEM harness.

  • Measure the resistance from pin-29 to all other pins in the OEM harness connector.
OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit between accelerator position signal wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit between the accelerator position signal wire and any other signal in the OEM harness.

  • Measure the resistance from pin-30 to all other pins in OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the accelerator position supply voltage.

Conditions

  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check the accelerator position supply voltage.

  • Measure the voltage from pin-19 to pin-29 in the OEM port of the ECM.
OK NOT OK

(+) 4.75 to 5.25-VDC

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Turn the keyswitch ON.
  • Depress the accelerator pedal to full position.
  • Release the pedal.
  • Turn the keyswitch OFF.
  • Verify that Fault Code 131 or 132 is inactive.
OK NOT OK

Fault Code 131 or 132 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Mar-2012


FAULT CODE 132 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect the OEM harness and the accelerator position sensor connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the accelerator position sensor resistance. | 2000 to 3000 ohms?
 | STEP 1C. Check the resistance between sensor pins. Measure when the pedal is depressed and released. | Released: 1500 to 3000 ohms? Depressed: 200 to 1500 ohms? Released resistance must be at least 1000 ohms more than depressed resistance.
 | STEP 1D. Check for a short circuit to ground in the sensor +5-VDC supply. | Greater than 100k ohms?
 | STEP 1E. Check for a short circuit to ground in the sensor SIGNAL wire. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the SUPPLY, SIGNAL, and RETURN wires of the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit between the +5-VDC SUPPLY wire and any other wire in the OEM harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit between the accelerator position SIGNAL wire and any other wire in the OEM harness. | Geater than 100k ohms?
 | STEP 2E. Check for a short circuit between the +5-VDC SUPPLY and RETURN wires. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit to ground in the accelerator position sensor SIGNAL circuit. | Greater than 100k ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Check the accelerator position supply voltage. | (+) 4.75 to 5.25-VDC?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 131 or 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and the accelerator position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the OEM harness and the accelerator position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the OEM harness or sensor, whichever has the damaged pins.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the accelerator position sensor. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the accelerator position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for an open or short circuit between pins in the acclerator position sensor.

  • Measure the resistance from pin-C (pin-A) to pin-A (pin-C) on the sensor side of the accelerator position sensor when the accelerator pedal is released and when it is depressed.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector onto the accelerator position sensor. The pin letters shown above are for the integrated sensor switch (ISS) and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

OK NOT OK

2000 to 3000 ohms?

Replace the accelerator position sensor.

Refer to the OEM service manual.

Go to 1C

Go to 4A

Guided Step 1C - Check the resistance between sensor pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check the resistance between sensor pins.

Measure when the pedal is depressed and released.

  • Measure the resistance from pin-C (pin-A) to pin-B (pin-C) on the sensor side of the accelerator position sensor.

Install the 6-pin, Part Number 3824892, or the 3-pin repair connector, Part Number 3823255, repair connector into accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS) and the letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Released: 1500 to 3000 ohms?

Depressed: 250 to 1500 ohms?

Released resistance must be at least 1000 ohms more than depressed resistance.

Replace the accelerator position sensor.

Refer to the OEM service manual.

Go to 1D

Go to 4A

Guided Step 1D - Check for a short circuit to ground in the sensor +5-VDC supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the sensor +5-VDC supply.

  • Measure the resistance from pin-C (pin-A) on the sensor side of the accelerator position sensor to engine block ground.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS) and the letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the accelerator position sensor.

Refer to the OEM service manual.

Go to 1E

Go to 4A

Guided Step 1E - Check for a short circuit to ground in the sensor SIGNAL wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Check for a short circuit to ground in the SIGNAL wire.

  • Measure the resistance from pin-B (pin-B) on the sensor side of the accelerator position sensor to engine block ground.

Install the 6-pin, Part Number 3824892, or the 3-pin, Part Number 3823255, repair connector into the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS) and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the accelerator position sensor.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever has damaged pins.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit in the SUPPLY, SIGNAL, and RETURN wires of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit in the SUPPLY, SIGNAL, and RETURN wires of the OEM harness.

  • Measure the resistance from pin-29 of the OEM harness connector to pin-C (pin-A) on the harness side of the accelerator position sensor.
  • Measure the resistance from pin-30 of the OEM harness connector to pin-B (pin-B) on the harness side of the accelerator position sensor.
  • Measure the resistance from pin-19 of the OEM harness connector to pin-A (pin-C) on the harness side of the accelerator position sensor.

The pin letters shown above are for the integrated sensor switch (ISS), and letters shown in brackets are for pedals with separate idle validation and accelerator sensors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit between +5-VDC SUPPLY wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from the +5-VDC SUPPLY wire to any other wire in the OEM harness.

  • Measure the resistance from pin-29 to all other pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit between accelerator position SIGNAL wire and any other wire in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit between the accelerator position SIGNAL wire and any other signal in the OEM harness.

  • Measure the resistance from pin-30 to all other pins in OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit between the +5-VDC SUPPLY and RETURN wires.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit between the +5-VDC SUPPLY and RETURN wires.

  • Measure the resistance from pin-29 of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness

Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Check for a short circuit to ground of the accelerator position sensor signal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground of the accelerator position sensor SIGNAL circuit.

  • Measure the resistance from pin-30 of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the accelerator position supply voltage.

Conditions

  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check the accelerator position supply voltage.

  • Measure the voltage from pin-19 to pin-29 in the OEM port of the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC?

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Turn keyswitch ON.
  • Depress the accelerator pedal to full position.
  • Release the pedal.
  • Turn keyswitch OFF.
  • Use INSITE™ electronic service tool to verify the Fault Code 131 or 132 is inactive.
OK NOT OK

Fault Code 131 or 132 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Mar-2012


FAULT CODE 135 - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 352 and 386 inactive?
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the engine harness and oil pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the oil pressure sensor supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C. Check the oil pressure sensor signal voltage. | (+) 0.40 to 0.60-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 352 and 386 inactive?

Possible sensor malfunction, a short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 352 and 386 inactive?

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the engine harness and the oil pressure sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Inspect the oil pressure sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins

Repair or replace the oil pressure sensor or the engine harness, whichever, has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the oil pressure sensor supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the oil pressure sensor.
  • Install oil pressure sensor breakout cable, Part Number 3824775.

Action

Check the oil pressure sensor supply voltage.

  • Measure the voltage from pin-A to pin-B on the harness side of the oil pressure sensor connector.

Pressure sensor breakout cable kit, Part Number 3824775, of kit 3824773, is available to assist with this step.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC

Go to 2C

Go to 3A

Guided Step 2C - Check the oil pressure sensor signal voltage.

Conditions

  • Turn keyswitch ON.
  • Install oil pressure sensor breakout cable, Part Number 3824775.

Action

Check the oil pressure sensor signal voltage.

  • Measure the voltage from pin-C to pin-B of the breakout cable.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 0.40 to 0.60-VDC?

Replace the oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

Dirty or damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-33 of the engine harness connector to pin-C on the harness side of the oil pressure sensor connector.
  • Measure the resistance from pin-10 of the engine harness connector to pin-A on the harness side of the oil pressure sensor connector.
  • Measure the resistance from pin-19 of the engine harness connector to pin-B on the harness side of the oil pressure sensor connector.

OK NOT OK

Less than 10 ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-33 of the engine harness connector to engine block ground.
  • Measure the resistance from pin-10 of the engine harness connector to engine block ground.
  • Measure the resistance from pin-19 of the engine harness connector to engine block ground.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-33 of the engine harness connector to all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 135 is inactive and did not occur.
  • Turn keyswitch ON.
OK NOT OK

Fault Code 135 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Mar-2012


FAULT CODE 141 (SN) - Oil Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 352 and 386 inactive?
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the engine harness and oil pressure sensor connector pins. | No damaged pins?
 | STEP 2B. Check the oil pressure sensor supply voltage. | (+) 4.75 to 5.25-VDC?
 | STEP 2C. Check the oil pressure sensor signal voltage. | (+) 0.40 to 0.60-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect engine harness and ECM connector pins. | No damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 352 and 386 inactive?

Possible sensor malfunction, a short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the engine harness and the oil pressure sensor connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the oil pressure sensor or the engine harness, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the oil pressure sensor supply voltage.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the engine harness from the oil pressure sensor.
  • Install oil pressure sensor breakout cable, Part Number 3824775.

Action

Check the oil pressure sensor supply voltage.

  • Measure the voltage from pin A to pin B on the harness side of the oil pressure sensor connector.

Pressure sensor breakout cable kit, Part Number 3824775 of kit 3824773, is available to assist with this step.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC?

Go to 2C

Go to 3A

Guided Step 2C - Check the oil pressure sensor signal voltage.

Conditions

  • Turn keyswitch to the ON position; engine not running.
  • Install oil pressure sensor breakout cable, Part Number 3824775.

Action

Check the oil pressure sensor signal voltage.

  • Measure the voltage from pin-C to pin-B of the breakout cable.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 0.40 to 0.60-VDC?

Replace the oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-33 of the engine harness connector to pin-C on the harness side of the oil pressure sensor connector.
  • Measure the resistance from pin-10 of the engine harness connector to pin-A on the harness side of the oil pressure sensor connector.
  • Measure the resistance from pin-19 of the engine harness connector to pin-B on the harness side of the oil pressure sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-33 of the engine harness connector to engine block ground.
  • Measure the resistance from pin-10 of the engine harness connector to engine block ground.
  • Measure the resistance from pin-19 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19..

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-33 of the engine harness connector to all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Replace the ECM. Refer to Procedure 019-031.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 141 is inactive and did not reoccur.
  • Turn keyswitch ON.
OK NOT OK

Fault Code 141 inactive?

Return to the troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault code .
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 23-Apr-2012


FAULT CODE 141 (SW) - Oil Pressure Switch Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 352 and 386 inactive?
STEP 2. | Check the oil pressure switch. |
 | STEP 2A. Inspect the engine harness and oil pressure switch connector pins. | No damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect engine harness and ECM connector pins. | No damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

If multiple temperature or pressure fault codes exist, this procedure should not be followed.

OK NOT OK

Fault Codes 352 and 386 inactive?

Possible sensor malfunction, a short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin-to-pin.

Go to 2A

Fault Code 352

Guided Step 2 - Check the oil pressure switch.

Guided Step 2A - Inspect the engine harness and the oil pressure switch connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.

Action

Inspect the oil pressure switch and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the oil pressure switch or the engine harness, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the oil pressure switch. Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin 47 of the engine harness connector to the oil pressure switch connector.
OK NOT OK

Less than 10 ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the oil pressure switch.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin 47 of the engine harness connector to engine block ground.
OK NOT OK

More than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the oil pressure switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin 47 of the engine harness connector to all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Replace the oil pressure switch.

Refer to Procedure 019-066 in Section 19.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 141 is inactive and did not reoccur.
  • Turn keyswitch OFF.
OK NOT OK

Fault Code 141 inactive?

Return to the troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Jul-2015


FAULT CODE 144 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

WARNING

Wait until the coolant temperature is below 50° C [120°F] before removing the coolant system pressure cap or the coolant temperature sensor. Failure to do so can cause personal injury from heated coolant spray.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead and Part Number 3823256 - female Metri-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 352 and 386 are inactive
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Inspect the engine harness and coolant temperature sensor connector pins. | No damaged pins
 | STEP 2B. Check the resistance of the coolant temperature sensor. | 175 to 244k ohms
 | STEP 2C. Check for a short circuit to ground in coolant temperature sensor. | Greater than 100k ohms
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harness and the ECM connector. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Codes 352 and 386 inactive

Possible sensor failure, short circuit to ground in the sensor +5-VDC common supply, or a short circuit from pin to pin, or an open circuit in the sensor common ground.

Go to 2A

Refer to Fault Codes 352 and 386

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Inspect the engine harness and coolant temperature sensor connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or the coolant temperature sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.
  • Install the appropriate connector seal if damaged or missing.

Go to 2B

Go to 4A

Guided Step 2B - Check the resistance of the coolant temperature sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin-A to pin-B of the coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

175 to 244k ohms

Replace the coolant temperature sensor

Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the coolant temperature sensor.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-A of the coolant temperature sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the coolant temperature sensor

Refer to Procedure 019-019 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever, has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-19 of the engine harness to pin-A on the harness side of the coolant temperature sensor connector.
  • Measure the resistance from pin-23 of the engine harness to pin-B on the harness side of the coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-23 of the engine harness to engine block ground.
  • Measure the resistance from pin-19 of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin-23 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin-19 of the engine harness to all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 144 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2012


FAULT CODE 146 - Coolant Temperature - Engine Protection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading is correct
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 146 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch to the ON position.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the coolant temperature sensor.
  • Connect INSITE™ to the vehicle data link.
  • Compare the coolant temperature reading on the service tool monitor screen to the reading from the temperature probe.

If a temperature measuring device is not available, answer "OK" to this step.

OK NOT OK

Sensor reading is correct: Reference the Troubleshooting and Repair Manual, ISB and QSB5.9-44 Engines, Bulletin 3666193.

Sensor reading incorrect: Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 146 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2012


FAULT CODE 153 - Intake Manifold Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3823256 - female Metri-Pack™ test lead and Part Number 3822758 - male Deutsch™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 352 and 386 inactive
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect intake manifold temperature sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor resistance. | 175 to 244k ohms
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms
STEP 3. | Check engine harness. |
 | STEP 3A. Inspect harness and ECM connector. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Check for active fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 352 and 386 inactive

Possible sensor malfunction, a short circuit to ground in the sensor +5-VDC common supply, a short circuit from pin-to-pin, or an open circuit on the sensor common ground.

Go to 2A

Refer to Fault Code 352 or 386

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the intake manifold temperature sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the intake manifold temperature sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the intake manifold temperature sensor or the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Check the resistance of the intake manifold air temperature sensor.

  • Measure the resistance from pin-A to pin-B of the intake manifold air temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

175 ohms to 244k ohms

Replace the intake manifold temperature sensor

Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-A of the intake manifold temperature sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the intake manifold temperature sensor.

Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-19 of the engine harness to pin-A on the harness side of the intake manifold air temperature- sensor connector.
  • Measure the resistance from pin-34 of the engine harness to pin-B on the harness side of the intake manifold air temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to the ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-19 of the engine harness connector to engine block ground.
  • Measure the resistance from pin-34 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-19 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin-34 of the engine harness to all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 153 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All the faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Jul-2015


FAULT CODE 154 - Intake Manifold Air Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3823256 - female Metri-Pack™ test lead and Part Number 3822758 - male Deutsch-Pack™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 352 and 386 inactive
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect intake manifold temperature sensor and engine harness connector pins. | No damaged pins
 | STEP 2B. Check the sensor resistance. | 175 to 244k ohms
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms
STEP 3. | Check engine harness. |
 | STEP 3A. Inspect harness and ECM connector. | No damaged pins
 | STEP 3B. Check for an open circuit. | Less than 10 ohms
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive
 | STEP 4B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch to the ON position.

Action

Check for active fault codes.

  • Read the fault codes using INSITE™.
OK NOT OK

Fault Codes 352 and 386 inactive

Possible sensor malfunction, a short circuit to ground in the sensor +5-VDC common supply, a short circuit from pin-to-pin, or an open circuit on the sensor common ground.

Go to 2A

Refer to Fault Code 352 or 386

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the intake manifold temperature sensor and the engine harness connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Inspect the intake manifold temperature sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the intake manifold temperature sensor or the engine harness, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Check the resistance of the intake manifold air temperature sensor.

  • Measure the resistance from pin-A to pin-B of the intake manifold air temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

175 ohms to 244k ohms

Replace the intake manifold temperature sensor

Refer to Procedure 019-059 in Section 19..

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-A of the intake manifold temperature sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the intake manifold temperature sensor

Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-19 of the engine harness to pin-A on the harness side of the intake manifold air temperature sensor connector.
  • Measure the resistance from pin-34 of the engine harness to pin-B on the harness side of the intake manifold air temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to the ground.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-19 of the engine harness connector to engine block ground.
  • Measure the resistance from pin-34 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch to the OFF position.
  • Disconnect the engine harness from the intake manifold air temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from pin-19 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin-34 of the engine harness to all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 153 or 154 inactive

Return to the troubleshooting steps, or contact a Cummin®s Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All the faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Jul-2015


FAULT CODE 186 - Wait-to-Start Lamp Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Wait-to-Start lamp. |
 | STEP 1A. Inspect the Wait-to-Start lamp. | Lamp is not burned out
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for an open circuit. | Less than 10 ohms
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms
 | STEP 2E. Measure voltage at the ECM connector. | 11 to 13-VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 186 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the Wait-to-Start lamp.

Guided Step 1A - Inspect the Wait-to-Start lamp.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Wait-to-Start lamp.

Make sure the lamp is not burned out.

OK NOT OK

Lamp is not burned out

Lamp is burned out. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins. Repair or replace the engine harness or ECM, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 43-pin connector.

Action

Check for an open circuit.

  • Measure the resistance from pin-37 of the ECM connector to pin 10 of the of the 43-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 43-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-37 of the engine harness connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 43-pin connector.

Action

Check for a short circuit to ground.

  • Check for a short circuit from pin-37 to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Measure voltage at the ECM connector.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the OEM harness at the 43-pin connector.

Action

Measure voltage at the ECM connector.

  • Measure the voltage from pin-37 of the engine harness connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

11 to 13-VDC.

Repair or replace the OEM harness. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code:

  • Start the engine and let idle for one minute
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 186 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Key switch in the “ON” position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 05-Jun-2012


FAULT CODE 211 - Vehicle Electronic Control Module

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 211 inactive
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 211 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 211 inactive

Fault Code 211 is active.

Go to 2A

Refer to the OEM service manual.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 211 inactive

Fault Code 211 inactive

Go to 2B

Refer to the OEM service manual.

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 05-Jun-2012


FAULT CODE 234 - Engine Overspeed Circuit

Associated Procedures

Cautions and Warnings

WARNING

If flammable vapors are detected, shut down the engine, ventilate the area, and do not restart the engine until the source of the vapors is located and repaired.
CAUTION

If the engine speed stays above 3700 rpm, the engine must be shut off immediately.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for overspeed. |
 | STEP 1A. Check for proper operating conditions. | Not motoring downhill
 | STEP 1B. Check for an alternate fuel source. | No alternate fuel source
 | STEP 1C. Check the rpm with INSITE™ electronic service tool monitor mode. | Correct rpm reading
 | STEP 1D. Check for an active fault at low rpm. | Inactive fault at low rpm
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive
 | STEP 2B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Identify the reason for overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.
OK NOT OK

Not motoring downhill

Check the engine for damage

Electronics are OK. Check the engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past overspeed limit without accelerator input to cause speed increase, then followed by a sharp engine cutout.
  • Check the intake manifold for sources of flammable vapors, and check the turbocharger seals to verify there are no oil leaks.
OK NOT OK

No alternate fuel source

Locate the alternate fuel source

  • Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, and so forth.
  • Inspect the base engine for damage due to the overspeed condition.

Go to 1C

Go to 2A

Guided Step 1C - Check the rpm with the INSITE™ service tool monitor mode.

Conditions

  • Run the engine.
  • Connect service tool to the vehicle datalink.

Action

Check the rpm with the monitor mode.

  • Monitor the engine using INSITE™.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.
OK NOT OK

Correct rpm reading

Inspect the engine speed sensor

Check the engine speed sensor as outlined for Fault Code 115. Inspect the engine for damage due to the overspeed condition.

Go to 1D

Go to 2A

Guided Step 1D - Check for an active fault at low rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for an active fault code at low rpm.

  • Check for active Fault Code 234 when the engine is not running above 3700 rpm.
OK NOT OK

Inactive fault code at low rpm

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and operate in the condition that previously exhibited the overspeed condition.
  • Verify Fault Code 234 is inactive.
OK NOT OK

Fault Code 234 inactive

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 05-Jun-2012


FAULT CODE 261 - Pump High Fuel Temperature Error/Overheat Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 261 inactive?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy while operating the engine under typical conditions. | Sensor reading correct?
STEP 3. | Check for high fuel temperature causes. |
 | STEP 3A. Check for high fuel temperature causes. | No conditions exist for high fuel temperature?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 261 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 261 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 261 inactive?

Fault Code 261 active or inactive or other active fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy while operating the engine under typical conditions.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy with a thermocouple or similar temperature probe while operating the engine under typical conditions.

  • Place a thermocouple or similar temperature probe (thermometer kit, Part Number 3822666, can be used) in the outlet tap of the fuel filter head.
  • Connect INSITE™ electronic service tool to the engine data link.
  • Load and operate the engine to typical operating temperature (82°C [180°F]).
  • Compare the fuel temperature sensor's reading on the INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

Readings must vary no more than ± 4°C [± 25°F] between INSITE™ electronic service tool and the temperature probe when the engine is warm.

If a temperature measuring device is not available, answer “OK” to this step. Readings need to be checked while the engine is operating at the conditions at which the fault occurred.

OK NOT OK

Sensor reading correct?

  • Locate and repair the cause of high fuel temperature

Fault Code 261 is active

Go to 3A

Go to 4A

Guided Step 3 - Check for high fuel temperature causes.

Guided Step 3A - Check for high fuel temperature causes.

Conditions

  • Turn keyswitch OFF.

Action

Check for the following possible causes of high fuel temperature:

  • Wrong fuel type/grade
  • Fuel tank fuel level is low
  • High fuel supply or return restriction
  • Fuel tank installation not correct
  • Fuel lines not routed correctly
  • High ambient air temperature
  • Engine coolant not cooling engine (overheat condition exists).

Refer to the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193, or the original equipment manufacturer (OEM) troubleshooting and repair manual for the appropriate procedure(s).

OK NOT OK

No conditions exist for high fuel temperature?

Condition for high fuel temperature exists?

  • Remedy the cause of the high fuel temperature.

Refer to the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193, or the OEM troubleshooting and repair manual for the appropriate procedure(s).

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Load and operate engine to typical operating temperature (82°C [180°F] coolant).
  • Verify Fault Code 261 is inactive.
OK NOT OK

Fault Code 261 inactive?

Fault Code 261 active.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-Jan-2013


FAULT CODE 264 - Fuel Temperature Sensor Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 264 inactive?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy while operating the engine under typical conditions. | Temperature sensor's reading correct (greater than -45°C [-49°F] and less than 130°C [266°F]) Locate and repair the cause of high fuel temperature?
STEP 3. | Check for high fuel temperature causes. |
 | STEP 3A. Check for high fuel temperature causes. | No conditions exist for high fuel temperature?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 264 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 264 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 264 inactive?

Fault Code 264 inactive and other active fault codes present or Fault Code 264 active

Go to 2A

2A or applicable fault codes

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy while operating the engine under typical conditions.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy, with a thermocouple or similar temperature probe, while operating the engine under typical conditions.

  • Place a thermocouple or similar temperature probe (thermometer kit, Part Number 3822666, can be used) in the outlet tap of the fuel filter head.
  • Connect INSITE™ electronic service tool to the engine data link.
  • Load and operate the engine to typical operating temperature (82°C [180°F]).
  • Compare the fuel temperature sensor's reading on the INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

Readings must vary no more than ± 4°C [± 25°F] between INSITE™ and the temperature probe when the engine is warm.

If a temperature measuring device is not available, answer “OK” to this step. Readings need to be checked while the engine is operating at the conditions at which the fault occurred.

OK NOT OK

Temperature sensor's reading correct (greater than -45°C [-49°F] and less than 130°C [266°F]) Locate and repair the cause of high fuel temperature?

Refer to Section TS in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193, or the original equipment manufacturer (OEM) troubleshooting and repair manual.

Sensor reading defaults to 75°C [167°F].

Go to 3A

Go to 4A

Guided Step 3 - Check for high fuel temperature causes.

Guided Step 3A - Check for high fuel temperature causes.

Conditions

  • Turn keyswitch OFF.

Action

Check for the following possible causes of high fuel temperature:

  • Wrong fuel type/grade
  • Fuel tank fuel level is low
  • High fuel supply
  • Return fuel restriction
  • Fuel tank installation not correct
  • Fuel lines not routed correctly
  • High ambient air temperature
  • Engine coolant not cooling engine (overheat condition exists).

Refer to the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193, or the OEM troubleshooting and repair manual for the appropriate procedure(s).

OK NOT OK

No conditions exist for high fuel temperature?

Condition for high fuel temperature exists. Remedy the cause of the high fuel temperature

Refer to the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193, or the OEM troubleshooting and repair manual for the appropriate procedure(s).

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Load and operate engine to typical operating temperature (82°C [180°F] coolant).
  • Verify Fault Code 264 is inactive.
OK NOT OK

Fault Code 264 inactive?

Fault Code 264 active

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-Jan-2013


FAULT CODE 278 (Non-Ford Truck Applications) - Lift Pump Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead.
CAUTION

To avoid damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the lift pump. |
 | STEP 1A. Inspect the engine harness and lift pump connectors. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the lift pump. | 0.1 to 4.0 ohms (+) 12-VDC lift pump? 0.1 to 10.0 ohms (+) 24-VDC lift pump?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check engine harness. |
 | STEP 2A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2B-1. Check for an open circuit in original equipment manufacturer (OEM) harness. |
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Measure voltage at the lift pump. | 11 to 13-VDC for 12 VDC lift pump? 21 to 26-VDC for 24 VDC lift pump?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 278 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the lift pump.

Guided Step 1A - Inspect the engine harness and lift pump connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Inspect the engine harness and lift pump connectors for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or lift pump, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the lift pump. Use the following procedure in the ISB and QSB5.9-44 Troubleshooting and Repair Manual, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the resistance of the lift pump

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Check the resistance of the lift pump.

  • Measure the resistance of the multimeter leads. Make sure this value is subtracted from the lift pump resistance measurement to obtain the true pump resistance.
  • Measure the resistance from pin-1 to pin-2 of the lift pump harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.1 to 4.0 ohms (+) 12-VDC lift pump?

0.1 to 10.0 ohms (+) 24-VDC lift pump?
YES NO
No Repair

Replace the lift pump. Use the following procedure in the ISB and QSB5.9-44 Troubleshooting and Repair Manual, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Check for a short to ground in the lift pump.

  • Measure the resistance from pin-1 and pin-2 of the lift pump connector, pump side, to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the lift pump. Use the following procedure in the ISB and QSB5.9-44 Troubleshooting and Repair Manual, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.

Go to 2A

Go to 3A

Guided Step 2 - Check engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the lift pump connector from the engine harness.
  • Disconnect the OEM harness from the 16-pin connector.

Action

Check for an open circuit in the lift pump SUPPLY pin.

  • On the engine harness, measure the resistance from pin-2 of the lift pump connector to pin-15 of the 23-pin connector.
  • On the engine harness, measure the resistance from pin-1 of the lift pump connector to pin-11 of the 16-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an open circuit in OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 23-pin connector.
  • Disconnect the negative (-) battery terminal from the battery post.

Action

Check for an open circuit in the OEM harness.

  • Measure resistance from pin-W of the OEM 23-pin connector to the negative (-) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the OEM harness. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the lift pump.

Action

Check for a short circuit to ground.

  • Measure resistance from pin-11 of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the lift pump.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-11 of the engine harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Measure voltage at the lift pump.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool and perform Lift Pump Override Test.

Action

Measure voltage at the lift pump.

  • Measure the voltage from the terminals on the underside of the pump with the lift pump connected to the engine harness.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

11 to 13-VDC for 12-VDC lift pump?

21 to 26-VDC for 24-VDC lift pump?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all component.s
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify Fault Code 278 is inactive.

Fault Code 278 inactive?
YES NO
No Repair

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-Oct-2013


FAULT CODE 278 (Ford Truck Applications) - Lift Pump Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead.
CAUTION

To avoid damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the lift pump. |
 | STEP 1A. Inspect the engine harness and lift pump connectors. | Dirty or damaged pins?
 | STEP 1B. Check the resistance of the lift pump. | 0.1 to 4.0 ohms (+) 12-VDC lift pump? 0.1 to 10.0 ohms (+) 24-VDC lift pump?
 | STEP 1C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check engine harness. |
 | STEP 2A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2B-1. Check for an open circuit in original equipment manufacturer (OEM) harness. |
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Measure voltage at the lift pump. | 11 to 13-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 278 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the lift pump.

Guided Step 1A - Inspect the engine harness and lift pump connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Inspect the engine harness and lift pump connectors for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or lift pump, whichever has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the lift pump. Use the following procedure in the ISB and QSB5.9-44 Troubleshooting and Repair Manual, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the resistance of the lift pump

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Check the resistance of the lift pump.

  • Measure the resistance of the multimeter leads. Make sure this value is subtracted from the lift pump resistance measurement to obtain the true pump resistance.
  • Measure the resistance from pin-1 to pin-2 of the lift pump harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.1 to 4.0 ohms (+) 12-VDC lift pump?

0.1 to 10.0 ohms (+) 24-VDC lift pump?
YES NO
No Repair

Replace the lift pump. Use the following procedure in the ISB and QSB5.9-44 Troubleshooting and Repair Manual, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the lift pump.

Action

Check for a short-to-ground in the lift pump.

  • Measure the resistance from pins 1 and 2 of the lift pump connector, pump side, to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the lift pump. Use the following procedure in the ISB and QSB5.9-44 Troubleshooting and Repair Manual, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.

Go to 2A

Go to 3A

Guided Step 2 - Check engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connection
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM
  • Disconnect the lift pump connector from the engine harness
  • Disconnect the OEM harness from the 16-pin connector.

Action

Check for an open circuit in the lift pump SUPPLY pin.

  • Measure the resistance from pin-2 of the lift pump connector, harness side, and engine to pin-15 of the 16-pin connector.
  • Measure the resistance from pin-11 of the engine harness connector to pin-1 of the lift pump connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an open circuit in OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the 23-pin connector
  • Disconnect the negative (-) battery terminal from the battery post.

Action

Check for an open circuit in the OEM harness.

  • Measure resistance from pin-W of OEM 23-pin connector to negative (-) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace OEM harness. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the lift pump.

Action

Check for a short circuit to ground.

  • Measure resistance from pin 11 of the engine harness to engine block ground.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the lift pump.

Action

Check for short circuit from pin-to-pin.

  • Measure the resistance from pin-11 of the engine harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Measure voltage at the lift pump.

Conditions

  • Turn keyswitch to the ON position
  • Connect INSITE™ electronic service tool and perform lift pump override test.

Action

Measure voltage at the lift pump.

  • Measure the voltage from the terminals on the underside of the pump with the lift pump connected to the engine harness.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

11 to 13-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute
  • Use INSITE™ electronic service tool to verify Fault Code 278 is inactive.

Fault Code 278 inactive?
YES NO
No Repair

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components
  • Turn keyswitch to the ON position.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Dec-2013


FAULT CODE 283 - Engine Speed Sensor Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the sensor connector pins. | No damaged pins
 | STEP 1B. Check for an internal short circuit to ground. | Fault Code 283 still active
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check sensor supply voltage. | (+) 4.75 to 5.25-VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 283 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness connector from the engine speed sensor connector.

Action

Inspect the engine speed sensor connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the engine harness or the engine speed sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an internal short circuit to ground.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the engine speed sensor connector.

Action

Check for an internal short circuit to ground.
OK NOT OK

Fault Codes 283 still active

Replace the engine speed sensor

Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine speed/position sensor connector.

Action

Check for short circuit to ground.

  • Measure the resistance from pin-8 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine speed/position sensor connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-8 to all other pins on the harness side of the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check sensor supply voltage.

Conditions

  • Turn keyswitch to the ON position.
  • Disconnect the speed sensor connector.

Action

Check sensor supply voltage.

  • Measure voltage from pin-A on the harness side of the engine speed sensor connector to engine block ground.
OK NOT OK

(+) 4.75 to 5.25-VDC?

  • Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Verify that Fault Codes 283 and 284 are inactive.
OK NOT OK

Fault Codes 283 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jan-2013


FAULT CODE 284 - Engine Speed Sensor Supply

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the sensor connector pins. | No damaged pins
 | STEP 1B. Check for an internal short circuit to ground. | Fault Code 284 still active
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | No damaged pins
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check sensor supply voltage. | (+) 4.75 to 5.25-VDC
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Codes 284 inactive
 | STEP 3B. Clear the inactive fault codes. | All faults cleared

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the engine speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness connector from the engine speed sensor connector.

Action

Inspect the engine speed sensor connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the engine harness or the engine speed sensor, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for an internal short circuit to ground.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness connector from the engine speed sensor connector.

Action

Check for an internal short circuit to ground.
OK NOT OK

Fault Codes 283 still active?

Replace the engine speed sensor

Refer to Procedure 019-042 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine speed/position sensor connector.

Action

Check for short circuit to ground.

  • Measure the resistance from pin-8 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the engine speed/position sensor connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-8 to all other pins on the harness side of the engine harness connector.
OK NOT OK

Greater than 100k ohms?

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check sensor supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the speed sensor connector.

Action

Check sensor supply voltage.

  • Measure voltage from pin-A on the harness side of the engine speed sensor connector to engine block ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC?

  • Replace ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Verify that Fault Codes 283 and 284 are inactive.
OK NOT OK

Fault Codes 284 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jan-2013


FAULT CODE 291 - Data Link Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead.
CAUTION

To avoid damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle dash. |
 | STEP 1A. Check the vehicle dash for proper operation. | Engine speed displayed, but oil pressure and coolant temperature are not working correctly?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and 43-pin connector. | No damaged pins?
 | STEP 2B. Inspect the harness and ECM. | No damaged pins?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit in the data link circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 291 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the vehicle dash.

Guided Step 1A - Check the vehicle dash for proper operation.

Conditions

  • Turn keyswitch ON.

Action

Operate the vehicle.

  • Verify that the dash displays the proper engine speed, oil pressure, and coolant temperature.
OK NOT OK

Engine speed displayed correctly, but oil pressure and coolant temperature are not displayed properly?

No engine speed displayed, but oil pressure and coolant temperature are displayed properly?

Go to 2A

Refer to the OEM service manual.

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the harness and the 43-pin connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM harness at the 43-pin connector.

Action

Inspect the engine harness and OEM harness connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the engine harness or OEM harness, whichever, has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the OEM harness. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the harness and 43-pin connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 43-pin connector.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the engine harness or ECM, whichever, has damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 43-pin connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-41 of the engine harness connector to all other pins in the connector.
  • Measure the resistance from pin-40 of the engine harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 43-pin connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-41 of the engine harness to engine block ground.
  • Measure the resistance from pin-40 of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness at the 43-pin connector.

Action

Check for an open circuit in the data link circuit.

  • Measure the resistance from pin-41 of the engine harness to pin-13 of the 43-pin connector.
  • Measure the resistance from pin-40 of the engine harness to pin-17 of the 43-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Check OEM harness.

Refer to the OEM service manual.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.

Action

Disable the fault codes.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 291 inactive

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting charts

Last Modified: 11-Jun-2012


FAULT CODE 334 - Coolant Temperature Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number. 3823256 - female Metri-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the coolant temperature sensor. |
 | STEP 1A. Inspect the sensor circuit for tampering. | No tampering?
 | STEP 1B. Inspect the engine harness and the sensor connectors. | No damaged pins?
 | STEP 1C. Check resistance of the coolant temperature sensor. | 175 ohm to 244k ohms?
 | STEP 1D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | No damaged pins?
 | STEP 2B. Check for a open circuit from pin to pin. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 334 inactive?
 | STEP 3B. Clear the inactive fault code. | All faults cleared?

Guided Step 1 - Check the coolant temperature sensor.

Guided Step 1A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensor circuit for tampering.

  • Check the coolant temperature sensor and the engine harness for external wires or damaged harness braiding.
OK NOT OK

No tampering?

Remove and record tampering

If tampering has occurred, repair the circuit, and record the tampering.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the harness and sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Inspect the harness and the sensor connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the engine harness or sensor, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check resistance of coolant temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check the resistance of the coolant temperature sensor.

  • Measure the resistance from pin-A to pin-B of the coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

175 ohms to 244k ohms?

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-A of the coolant temperature sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or the ECM, whichever. has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-11 of the engine harness to pin-A on the harness side of the coolant temperature sensor connector.
  • Measure the resistance from pin-14 of the engine harness to pin-B on the harness side of the coolant temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-14 of the engine harness to engine block ground.
  • Measure the resistance from pin-11 of the engine harness to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coolant temperature sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-14 of the engine harness to all other pins in the engine harness.
  • Measure the resistance from pin-11 of the engine harness to all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 344 is inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Jun-2012


FAULT CODE 352 - Sensor Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensors. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
 | STEP 1B. Check the engine position sensor. | Fault Code 352 remains active?
 | STEP 1C. Check the intake manifold pressure sensor. | Fault Code 352 remains active?
 | STEP 1D. Check the oil pressure sensor. | Fault Code 352 remains active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins?
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 1D. Check sensor supply voltage. | (+) 4.75 to 5.25-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 352 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the sensors.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 386 active?

Fault Code 352 active?

Go to 2A

Go to 1B

Guided Step 1B - Check the engine position sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the engine position sensor from the engine harness.

Action

Check the engine position sensor.
OK NOT OK

Fault Code 352 remains active?

Replace the engine position sensor

Refer to Procedure 019-038 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check the intake manifold pressure sensor.
OK NOT OK

Fault Code 352 remains active?

Replace intake manifold sensor

Refer to Procedure 019-061 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check the oil pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check the oil pressure sensor.
OK NOT OK

Fault Code 352 remains active?

Replace oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Repair or replace the engine harness or ECM, or replace the ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance from pin-10 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-10 of the engine harness connector to all the other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Replace the engine harness

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check sensor supply voltage.

Conditions

  • Connect the engine harness to the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for sensor +5-VDC supply voltage.

  • Measure the voltage from pin-A on the harness side of the engine speed sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 352 is inactive.
OK NOT OK

Fault Code 352 inactive

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Jul-2015


FAULT CODE 362 - Fuel Valve High Current Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 362 inactive?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | 6.5 to 18 VDC (12-VDC system); 12 to 27 VDC (24 VDC System)?
STEP 3. | Perform a diagnostic check using the diagnostic tool. |
 | STEP 3A. Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump. | Engine starts and operates in idle mode?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness, fuel pump, and ECM connector pins for loose or expanded pins. | No damaged pins?
 | STEP 4B. Check the fuel pump supply resistance. | Less than 0.2 ohm?
 | STEP 4C. Check the fuel pump ground circuit resistance. | Less than 0.2 ohm?
 | STEP 4D. Inspect the fuses, relays, and harnesses. | No faulty fuses, relays, or harnesses?
STEP 5. | Check the fuel pump wiring. |
 | STEP 5A. Inspect the fuel pump fuel solenoid wire leads. | No loose or frayed wires?
STEP 6. | Check for sources of electrical noise. |
 | STEP 6A. Inspect the engine, ECM, and alternator ground connections. | No loose connections?
 | STEP 6B. Inspect the original equipment manufacturer (OEM) power distribution box fuses and wires. | No loose wires or shorted plugs?
 | STEP 6C. Inspect the alternator. | Fault Code 362 is still active?
 | STEP 6D. Check the lift pump resistance. | 0.1 to 2.0 ohms (12-VDC system); 0.1 to 4.0 ohms (24-VDC system)?
 | STEP 6E. Check the OEM wiring connections. | Fault code still active?
 | STEP 6F. Inspect the vehicle accessories. | No interference from accessories?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 362 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 362 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 362 inactive?

Fault Code 362 active or inactive and no other active fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check the voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

6.5 to 18 VDC (12-VDC system); 12 to 27 VDC (24 VDC System)?

Go to 3A

Go to 7A

Guided Step 3 - Perform a diagnostic check using the diagnostic tool.

Guided Step 3A - Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump.
OK NOT OK

Engine starts and operates in idle mode?

Engine does not start.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness, fuel pump, and ECM connector pins for loose or expanded pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.
  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Action

Inspect the engine harness, fuel pump, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-071 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check the fuel pump supply resistance.

Conditions

  • Disconnect the fuel pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel pump supply resistance.

  • Measure the resistance from pin 7 of the fuel pump harness connector to the positive (+) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

More than 0.2 ohm?

Inspect the relay and power supply fuses. Replace if necessary.

Go to 4C

Go to 4D

Guided Step 4C - Check the fuel pump ground circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump from the engine harness.
  • Disconnect the negative (-) battery terminal from the battery post.

Action

Check the fuel pump ground circuit resistance.

  • Measure the resistance from pin 6 of the harness connector to ground side, negative (-) battery ring terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-197 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Inspect the fuses, relays, and harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery cables.

Action

Inspect the fuses, relays, and harnesses.

  • Inspect for blown or corroded 10-amp fuses.
  • Inspect the power relay.
  • Inspect the OEM harness, battery terminals, and 23-pin OEM connector for source of resistance.
OK NOT OK

No faulty fuses, relays, or harnesses?

Replace the fuses, relays, or harnesses if necessary.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump wiring.

Guided Step 5A - Inspect the fuel pump fuel solenoid wire leads.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump fuel solenoid wire leads.
OK NOT OK

No loose or frayed wires?

Go to 6A

Go to 7A

Guided Step 6 - Check for sources of electrical noise.

Guided Step 6A - Inspect the engine, ECM, and alternator ground connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine, ECM, and alternator ground connections.

  • Disconnect and clean any loose connections found.

When checking ground connections, use a dedicated ground strap. A measurement of 2 to 3 ohms must exist between engine block to chassis frame, engine block to battery negative post, and chassis frame to battery negative post.

OK NOT OK

No loose connections?

Clean and tighten all loose connections.

Go to 6B

Go to 7A

Guided Step 6B - Inspect the OEM power distribution box fuses and wires.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses and wires in the OEM distribution box.
OK NOT OK

No loose wires or shorted plugs?

Repair damaged or loose wiring and replace shorted plugs.

Go to 6C

Go to 7A

Guided Step 6C - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator.

  • Check to make sure that the alternator voltage is to specification. (See the OEM service manual for voltage specification.)
  • Disconnect the alternator output (remove the drive belt), and check for a fault code occurrence.
OK NOT OK

Fault Code 362 is still active?

Fault Code 362 went inactive?

Replace the alternator.

Use the following procedure in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193. Refer to Procedure 013-001 in Section 13.

Go to 6D

Go to 7A

Guided Step 6D - Check the lift pump resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump engine harness connector from the lift pump.

Action

Check the lift pump resistance.

  • Measure the resistance from pin-1 to pin-2 of the lift pump connector.
OK NOT OK

0.1 to 2.0 ohms (12-VDC system); 0.1 to 4.0 ohms (24-VDC system)?

Replace the lift pump

Go to 6E

Go to 7A

Guided Step 6E - Check the OEM wiring connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM A harness connector from the ECM.
  • Disconnect the 23-pin OEM pass-through connector.
  • Run a wire from the keyswitch input line (pin-A of the 23-pin OEM connector, engine harness side) directly to the battery positive (+) post.
  • Turn keyswitch ON.

Action

Check the keyswitch input wire.
OK NOT OK

Fault code still active

Fault code clears.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 6F

Go to 7A

Guided Step 6F - Inspect the vehicle accessories.

Conditions

  • Turn keyswitch OFF.

Action

Check any accessories in the vehicle for electrical noise interference.
OK NOT OK

No interference from accessories?

Correct electrical interference.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and road-test for 30 minutes.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Code 362 inactive?

Fault Code 362 active?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7B

Go to 7B

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-Jan-2013


FAULT CODE 363 - Fuel Pump Control Valve Feedback Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM) all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 363 inactive?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | 6.5 to 18-VDC (12-VDC system); 12 to 27-VDC (24-VDC System)?
STEP 3. | Perform a diagnostic check using the diagnostic tool. |
 | STEP 3A. Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump. | Engine starts and operates in idle mode?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness, fuel pump, and ECM connector pins for loose or expanded pins. | No damaged pins?
 | STEP 4B. Check the fuel pump supply resistance. | Less than 0.2 ohm?
 | STEP 4C. Check the fuel pump ground circuit resistance. | Less than 0.2 ohm?
 | STEP 4D. Inspect the fuses, relays, and harnesses. | No faulty fuses, relays, or harnesses?
STEP 5. | Check the fuel pump wiring. |
 | STEP 5A. Inspect the fuel pump fuel solenoid wire leads. | No loose or frayed wires?
STEP 6. | Check for sources of electrical noise. |
 | STEP 6A. Inspect the engine, ECM, and alternator ground connections. | No loose connections?
 | STEP 6B. Inspect the original equipment manufacturer (OEM) power distribution box fuses and wires. | No loose wires or shorted plugs?
 | STEP 6C. Inspect the alternator. | No fault code occurrence?
 | STEP 6D. Check the lift pump resistance. | 0.1 to 2.0 ohms (12-VDC system); 0.1 to 4.0 ohms (24-VDC system)?
 | STEP 6E. Check the OEM wiring connections. | Fault code still active?
 | STEP 6D. Inspect the vehicle accessories. | No interference from accessories?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 363 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 363 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 363 inactive?

Fault Code 363 active or inactive, and no other active fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check the voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

6.5 to 18-VDC (12-VDC system); 12 to 27-VDC (24-VDC System)?

Go to 3A

Go to 7A

Guided Step 3 - Perform a diagnostic check using the diagnostic tool.

Guided Step 3A - Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump.

  • Use diagnostic tool to perform a diagnostic check.
OK NOT OK

Engine starts and operates in idle mode?

Engine does not start.

Make sure air has been vented from the system. Use the following procedure in the ISB and QSB5.9-44 Troubleshooting and Repair Manual, Bulletin 3666193.Refer to Procedure 006-003 in Section 6.

Pre-authorization is required to replace injection pump, if the pump is under warranty.

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness, fuel pump, and ECM connector pins for loose or expanded pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Action

Inspect the engine harness, fuel pump, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check the fuel pump supply resistance.

Conditions

  • Disconnect the fuel pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel pump supply resistance.

  • Measure the resistance from pin-7 of the fuel pump harness connector to the positive (+) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

More than 0.2 ohm?

Inspect the relay and power supply fuses, and replace if necessary.

Go to 4C

Go to 4D

Guided Step 4C - Check the fuel pump ground circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump from the engine harness.
  • Disconnect the negative (-) battery terminal from the battery post.

Action

Check the fuel pump ground circuit resistance.

  • Measure the resistance from pin 6 of the fuel pump harness connector to ground side, negative (-) battery ring terminal.
  • Make certain that the terminal is disconnected from the battery post.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-197 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Inspect the fuses, relays, and harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery cables.

Action

Inspect the fuses, relays, and harnesses.

  • Inspect for blown or corroded 10 ampere fuses.
  • Inspect the power relay.
  • Inspect the OEM harness, battery terminals, and 23-pin OEM connector for source of resistance.
OK NOT OK

No faulty fuses, relays, or harnesses?

Replace the fuses, relays, or harnesses if necessary.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump wiring.

Guided Step 5A - Inspect the fuel pump fuel solenoid wire leads.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump fuel solenoid wire leads.
OK NOT OK

No loose or frayed wires?

Repair damaged or loose wires.

Go to 6A

Go to 7A

Guided Step 6 - Check for sources of electrical noise.

Guided Step 6A - Inspect the engine, ECM, and alternator ground connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine, ECM, and alternator ground connections.

  • Disconnect and clean any loose connections found.

When checking ground connections, use a dedicated ground strap. A measurement of 2 to 3 ohms must exist between engine block to chassis frame, engine block to battery negative post, and chassis frame to battery negative post.

OK NOT OK

No loose connections?

Clean and tighten all loose connections.

Go to 6B

Go to 7A

Guided Step 6B - Inspect the OEM power distribution box fuses and wires.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses and wires in the OEM distribution box.
OK NOT OK

No loose wires or shorted plugs?

Repair damaged or loose wiring, and replace shorted plugs.

Go to 6C

Go to 7A

Guided Step 6C - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator.

  • Check to make sure that the alternator voltage is to specification. (Reference the OEM manual for voltage specification.)
  • Disconnect the alternator output (remove the drive belt), and check for a fault code occurrence.
OK NOT OK

No fault code occurrence?

Charge or replace alternator.

Use the following procedure in the Troubleshooting and Repair Manual, ISB and QSB5.9-44 engines, Bulletin 3666193. Refer to Procedure 013-001 in Section 13.

Go to 6D

Go to 7A

Guided Step 6D - Check the lift pump resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump engine harness from the lift pump.

Action

Check the lift pump resistance.

  • Measure the resistance from pin-1 to pin-2 of the lift pump connector.
OK NOT OK

0.1 to 2.0 ohms (12-VDC system); 0.1 to 4.0 ohms (24-VDC system)?

Replace the lift pump

Use the following procedure in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.

Go to 6E

Go to 7A

Guided Step 6E - Check the OEM wiring connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM A harness connector from the ECM.
  • Disconnect the 23-pin pass-through connector.
  • Run a wire from the keyswitch input line (pin-A of the 23-pin OEM connector, engine harness side) directly to the battery positive (+) post.
  • Turn keyswitch ON.

Action

Check the keyswitch input line.
OK NOT OK

Fault code still active?

Fault code clears

Repair or replace the OEM harness.

Go to 6F

Go to 7A

Guided Step 6F - Inspect the vehicle accessories.

Conditions

  • Turn keyswitch OFF.

Action

Check any accessories in the vehicle for electrical noise interference.
OK NOT OK

No interference from accessories?

Correct electrical interference.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and road-test for 30 minutes.
  • Verify Fault Code 363 is inactive.
OK NOT OK

Fault Code 363 inactive?

Fault Code 363 active

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Jul-2015


FAULT CODE 364 - Fuel Pump Control Module CAN Datalink - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 364 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the fuel pump battery voltage. | Voltage is within +/- 1 volt DC of battery voltage?
 | STEP 2B. Check the fuel pump battery voltage. | Voltage is within +/- 1 volt DC of battery voltage?
STEP 3. | Check the fuel pump. |
 | STEP 3A. Check the fuel pump operation. | Engine starts and operates in idle mode?
STEP 4. | Check the fuel pump datalink. |
 | STEP 4A. Check the fuel pump datalink for open circuit. | Resistance is less than 10 ohms?
 | STEP 4B. Check the fuel pump datalink for short to ground. | Resistance is greater than 100k ohms?
 | STEP 4C. Check the fuel pump datalink pin-to-pin short. | Resistance is greater than 100k ohms?
STEP 5. | Check the fuel lift pump. |
 | STEP 5A. Disconnect the lift pump. | Fault code 364 goes inactive?
STEP 6. | Check the charging system alternator. |
 | STEP 6A. Inspect the charging system alternator. | Fault code is inactive with the charging system alternator disconnected?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 364 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the voltage supply.

Guided Step 2A - Check the fuel pump battery voltage.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connector for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the voltage from the SUPPLY pin of the fuel pump harness connector to the RETURN pin of the fuel pump harness connector.
  • Check the voltage at key ON, while cranking the engine.

6.5 to 18-VDC (12-VDC System)

12 to 27-VDC (24-VDC System)

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage is within +/- 1 volt DC of battery voltage?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the fuel pump battery voltage.

Conditions

  • Disconnect the fuel pump relay from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage from the POWER SHUTOFF RETURN pin of the fuel pump relay connector to the SUPPLY pin of the fuel pump relay connector

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage is within +/- 1 volt DC of battery voltage?
YES NO

A malfunctioning relay or engine harness has been detected.

For a malfunctioning engine harness, repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

For a malfunctioning relay. See equipment manufacturer service information.

A malfunctioning fuel pump supply, ground circuit, or fuse has been detected.

Repair or replace the malfunctioning component.

Go to 2A

Go to 7A

Guided Step 3 - Check the fuel pump.

Guided Step 3A - Check the fuel pump operation.

Conditions

  • Turn keyswitch ON.

Action

  • Inspect the pins and connector for damage. Refer to Procedure 019-361 in Section 19.
  • Use the following procedure for installation and testing. Refer to Procedure 005-014 in Section 5.
  • Make sure air has been vented from the system before using the diagnostic tool.
  • If replacing the fuel pump injection pump, perform a lift pump volume test at the fuel filter outlet for 25 seconds by bumping the starter. If the volume is greater than 1.33 liters [45 oz], the low pressure fuel system is operating correctly.

Engine starts and operates in idle mode?
YES NO
No Repair

Make sure air has been vented from the system.

A malfunctioning fuel pump has been detected.

Replace the fuel pump. Refer to Procedure 005-014 in Section 5.

Go to 4A

Go to 7A

Guided Step 4 - Check the fuel pump datalink.

Guided Step 4A - Check the fuel pump datalink for open circuit.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the ECM.

Action

Check for open circuit in the fuel pump datalink circuit

  • Measure the resistance from the DATALINK (+) pin of the fuel pump harness connector to the DATALINK (+) pin of the ECM harness connector.
  • Measure the resistance from the DATALINK (-) pin of the fuel pump harness connector to the DATALINK (-) pin of the ECM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance is less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

For a malfunctioning engine harness, repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 7A

Guided Step 4B - Check the fuel pump datalink for short to ground.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the ECM

Action

Check for short circuit to ground in the fuel pump datalink circuit.

  • Measure the resistance from the DATALINK (+) pin of the fuel pump harness connector to the engine block ground.
  • Measure the resistance from the DATALINK (-) pin of the fuel pump harness connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance is greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

For a malfunctioning engine harness, repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check the fuel pump datalink pin-to-pin short.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the ECM.

Action

Check for short circuit from pin-to-pin the fuel pump datalink circuit

  • Measure the resistance from the DATALINK (+) pin of the fuel pump harness connector to all other pins in the connector.
  • Measure the resistance from the DATALINK (-) pin of the fuel pump harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance is greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

For a malfunctioning engine harness, repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel lift pump.

Guided Step 5A - Disconnect the lift pump.

Conditions

  • Turn keyswitch OFF.

Action

  • Unplug the fuel lift pump and start the engine to see if fault code goes inactive.

NOTE: Fault Code 278 may also become active. No additional action will be needed for this fault code.

Fault code 364 goes inactive?
YES NO

A malfunctioning fuel lift pump has been detected.

Replace the fuel lift pump. Refer to Procedure 005-045 in Section 5.

No Repair

Go to 6A

Go to 7A

Guided Step 6 - Check the charging system alternator.

Guided Step 6A - Inspect the charging system alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the charging system alternator.

  • Check to make sure that the charging system alternator voltage is to specification. (The OEM manual has voltage specifications.)
  • Disconnect the charging system alternator output (remove the drive belt), and check if the fault code goes inactive with the charging system alternator disconnected.

The charging system alternator belt may also drive the water pump. If so, then do not run the engine for more than a few minutes.

Fault code is inactive with the charging system alternator disconnected?
YES NO

A malfunctioning charging system has been detected.

Repair or replace the charging system and associated wiring.

A malfunctioning high pressure fuel pump has been detected.

Replace the high pressure fuel pump assembly. Refer to Procedure 005-014 in Section 5.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 24-May-2017


FAULT CODE 365 - Fuel Pump Voltage Out of Range Error Low

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check engine harness. |
 | STEP 1A. Inspect the engine harness, fuel pump, and ECM connectors. | No damaged pins?
 | STEP 1B. Check fuel pump supply resistance. | Less than 0.2 ohm?
 | STEP 1C. Check for an open circuit in fuel pump controller ground circuit. | Less than 0.2 ohm?
STEP 2. | Check equipment voltage supply. |
 | STEP 2A. Check the battery voltage. | Normal conditions: At least (+) 12-VDC (for 12-VDC System); At least (+) 24-VDC (for 24-VDC System); During Cranking: At Least (+) 8-VDC (for 12-VDC System); At least (+) 12-VDC (for 24- VDC System)
 | STEP 2B. Check alternator output. | Refer to the original equipment manufacturer (OEM) service manual?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 365 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check engine harness.

Guided Step 1A - Inspect the engine harness, fuel pump, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Inspect the engine harness, fuel pump, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness, ECM, or fuel pump, whichever, has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Use the following procedure to replace the fuel pump in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.

Go to 1B

Go to 3A

Guided Step 1B - Check fuel pump supply resistance.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the fuel pump.

Action

Check the fuel pump supply resistance.

  • Measure the resistance from pin-7 of the fuel pump connector, harness side, to the positive (+) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

Greater than 0.2 ohm; find and correct harness resistance.

Go to 1C

Refer to Fault Code 391

Guided Step 1C - Check for an open circuit in fuel pump controller ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect engine harness from the fuel pump control module.

Action

Check for an open circuit in fuel pump controller ground circuit.

  • Measure the resistance from pin-6 on the harness side of the fuel pump control module to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

Greater than 0.2 ohm; find and correct harness resistance.

Go to 2A

Refer to Fault Code 391

Guided Step 2 - Check equipment voltage supply.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Normal conditions: At least (+) 12-VDC (for 12-VDC System); At least (+) 24-VDC (for 24-VDC System)

During cranking: At least (+) 8-VDC (for 12-VDC System); At least (+) 12-VDC (for 24-VDC System)?

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check alternator output.

Conditions

  • Start and idle engine.

Action

Measure voltage output.

  • Reference the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Refer to the alternator manufacturer diagnostic instructions?

Repair or replace alternator.

Use the following procedure in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193. Refer to Procedure 013-001 in Section 13.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify Fault Code 365 is inactive.
OK NOT OK

Fault Code 365 inactive?

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All the faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jan-2013


FAULT CODE 366 - Fuel Pump Voltage Measurement Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 366 inactive?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | 6.5 to 18-VDC (12-volt system); 8 to 18-VDC (during cranking); (12 to 27-volt system)?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay. | No damaged pins or blown fuses?
STEP 4. | Check the harness electrical circuits. |
 | STEP 4A. Check the fuel pump supply resistance. | Less than 0.2 ohm?
 | STEP 4B. Check the fuel pump ground circuit resistance. | Less than 0.2 ohm?
STEP 5. | Check the ground connections. |
 | STEP 5A. Inspect the engine, ECM, and alternator ground connections. | No loose connections?
 | STEP 5B. Inspect the original equipment manufacturer (OEM) power distribution box fuses and wires. | No loose wires or shorted plugs?
STEP 6. | Check the alternator. |
 | STEP 6A. Inspect the alternator. | No fault code occurrence?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 366 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 366 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 366 inactive?

Fault Code 366 active or inactive and no other active fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check the voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

6.5 to 18-VDC (12-volt system); 8 to 18-VDC (during cranking) (12 to 27-volt system)

Charge or replace battery.

Go to 3A

Go to 7A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the battery cables.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Action

Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins or blown fuses?

Repair the damaged pins.

Replace any blown fuses. Repair or replace the engine harness, fuel pump, or ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the blown fuses. Refer to Procedure 019-198 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the harness electrical circuits.

Guided Step 4A - Check the fuel pump supply resistance.

Conditions

  • Disconnect the fuel pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel pump supply resistance.

  • Measure the resistance from pin-7 of the fuel pump harness connector to the positive (+) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

Greater than 0.2 ohm.

Inspect the relay and power supply fuses, and replace if necessary.

Go to 4B

Go to 7A

Guided Step 4B - Check the fuel pump ground circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the negative (-) battery terminal from the battery post.

Action

Check the fuel pump ground circuit resistance.

  • Measure the resistance from pin-6 of the fuel pump harness connector to ground side, negative (-) battery ring terminal.
  • Make certain that the terminal is disconnected from the battery post.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the ground connections.

Guided Step 5A - Inspect the engine, ECM, and alternator ground connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine, ECM, and alternator ground connections for loose connections.

  • Disconnect and clean any loose connections found.

When checking ground connections, use a dedicated ground strap. A measurement of 2 to 3 ohms must exist between engine block to chassis frame, engine block to battery negative post, and chassis frame to battery negative post.

OK NOT OK

No loose connections?

Clean and tighten all loose connections.

Go to 5B

Go to 7A

Guided Step 5B - Inspect the OEM power distribution box fuses and wires.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses and wires in the OEM distribution box.
OK NOT OK

No loose wires or shorted plugs?

Repair damaged or loose wiring, and replace shorted plugs.

Go to 6A

Go to 7A

Guided Step 6 - Check the alternator.

Guided Step 6A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator.

  • Check to make sure that the alternator voltage is to specification. (Refer to the OEM service manual for voltage specification.)
  • Disconnect the alternator output (remove the drive belt), and check for a fault code occurrence.
OK NOT OK

No fault code occurrence?

Charge or replace the alternator.

Use the following procedure in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193. Refer to Procedure 013-001 in Section 13.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and road-test for 30 minutes.
  • Verify Fault Code 366 is inactive.
OK NOT OK

Fault Code 366 inactive?

Fault Code 366 active.

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Jul-2015


FAULT CODE 367 - Fuel Pump Speed/Position Sensor Signal Lost

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if fault code is active at engine start-up. | Fault Code 367 inactive?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | 6.5 to 18-VDC (12 Volt System), 12 to 27-VDC (24 Volt System)?
STEP 3. | Check the connector pins |
 | STEP 3A. Check the connector pins. | Check the connector pins?
STEP 4. | Perform a diagnostic check using the diagnostic tool. |
 | STEP 4A. Install the fuel pump diagnostic tool to check the operation of the fuel pump. | Engine starts and operates in idle mode?
STEP 5. | Perform low pressure system checks. |
 | STEP 5A. Install the gauges and record findings. | Restriction less than 152 mm-Hg [6 in-Hg], fuel pressure at fuel filter inlet less than 34 kPa [5 psi], no air found in fuel, fuel in bucket is greater than 1.33 liter [45 oz]?
 | STEP 5B. Check the lift pump supply voltage. | Battery voltage ± 2-VDC?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 367 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read active fault codes.

If Fault Code 367 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 367 inactive?

Fault Code 367 active or inactive and no other active fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin 7 of the fuel pump harness connector using pin 6 as the ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

6.5 to 18-VDC (12 Volt System), 12 to 27-VDC (24 Volt System)?

Check supply and ground circuits.

Go to 3A

Go to 6A

Guided Step 3 - Check the connector pins.

Guided Step 3A - Check the connector pins

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch OFF.

Action

Inspect the connector pins.

Use inspection gauge, Part Number 3164980 or equivalent, to inspect the connector pins.
OK NOT OK

Tool can not be inserted into any terminal.

Tool can be inserted into pin(s). Replace the damaged terminals.

Refer to Procedure 019-210 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Perform a diagnostic check using the diagnostic tool.

Guided Step 4A - Install the fuel pump diagnostic tool to check the operation of the fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump.

  • Use the following procedure for installation and testing procedures. Refer to Procedure 005-014 in Section 5.
  • Make sure air has been vented from the system before using the diagnostic tool.
  • If replacing the injection pump, perform a lift pump volume test at the fuel filter outlet for 25 seconds by bumping the starter. If the volume is greater than 1.33 liter [45 fl-oz], the low pressure fuel system is operating correctly.
OK NOT OK

Engine starts and operates in idle mode?

Engine does not start.

Make sure air has been vented from the system. Pre-authorization is required to replace the injection pump, if pump is under warranty.

Go to 5A

Go to 6A

Guided Step 5 - Perform low pressure system checks.

Guided Step 5A - Install gauges and record findings.

Conditions

  • Turn keyswitch ON.

Action

Install restriction gauge at the lift pump inlet.

Install pressure gauge at the fuel filter inlet. Use the Troubleshooting and Repair Manual, ISB and QSB5.9 Engines, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.

Install a clear line at the fuel filter outlet and run into a bucket.

With gauges and the clear line in place, bump the starter and leave the keyswitch on. The lift pump will run for 25 to 30 seconds. While the lift pump is running, record the following:

  • Inlet restriction
  • Fuel pressure at fuel filter inlet
  • Air in fuel content.

If all of the above checks are okay, measure the amount of fuel in the bucket.
OK NOT OK

Restriction less than 152 mm-Hg [6 in-Hg]?

Fuel pressure at fuel filter inlet less than 34 kPa [5 psi].

No air found in fuel.

Fuel in bucket is greater than 1.33 liters [45 fl-oz].

Inlet restriction greater than 152 mm Hg [6 in Hg]. Find source of excessive restriction between the lift pump inlet and fuel tank.

Fuel pressure at fuel filter inlet is greater than 34 kPa [5 psi]. Fuel filter is restricted. Replace the filter and check again.

Air in fuel detected. Find the source of air between the lift pump inlet and fuel tank.

Fuel in bucket is less than 1.33 liters [45 fl-oz].

Go to 6A

Go to 5B

Guided Step 5B - Check the lift pump supply voltage.

Conditions

  • Disconnect the lift pump from the engine harness
  • Turn keyswitch ON.

Action

Check the lift pump voltage supply.

  • Disconnect the lift pump from the engine harness, after bumping the starter, use a multimeter to measure the voltage at pin-1 (engine harness, lift pump connector).
  • Lift pump will run for only 25 to 30 seconds after bumping the starter.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Battery voltage ± 2-VDC?

Replace the lift pump. Use the Troubleshooting and Repair Manual, ISB and QSB5.9 Engines, Bulletin 3666193.Refer to Procedure 005-045 in Section 5.

Inspect the voltage supply circuit.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and road-test for 30 minutes.
  • Use INSITE™ electronic service tool to verify fault code 367 is inactive.
OK NOT OK

Fault Code 367 inactive?

Fault Code 367 active.

Return to the troubleshooting steps or contact a Cummins® Authorized Service Location if all steps have been completed and checked again.

Pre-authorization is required to replace the injection pump if the pump is under warranty.

Repair complete

Go to 1A

Last Modified: 08-Jan-2013


FAULT CODE 368 - Fuel Pump Can Not Reach Commanded Timing

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 368 inactive?
STEP 2. | Perform low pressure system checks. |
 | STEP 2A. Install the gauges and record inlet restriction findings. | Restriction less than 152 mm-Hg [6 in-Hg]?
 | STEP 2B. Install the gauges and record fuel pressure findings. | Fuel pressure at fuel filter inlet less than 34 kPa [5 psi]?
 | STEP 2C. Install the gauges and record air in fuel findings. | No air found in fuel?
 | STEP 2D. Install the gauges and record fuel displacement findings. | Fuel in bucket is greater than 1.33 liters [1.4 qt]?
 | STEP 2E. Check the lift pump supply voltage. | Battery voltage ± 2-VDC?
STEP 3. | Verify the inlet restriction and check for air in the fuel when loaded. |
 | STEP 3A. Verify the inlet restriction with the engine loaded. | Restriction less than 152 mm-Hg [6 in-Hg]?
 | STEP 3B. Verify there is no air in the fuel system with the engine loaded. | No air found in the fuel?
 | STEP 3C. Verify the fuel pressure at the fuel filter outlet with the engine loaded. | Fuel pressure greater than 14 kPa [2 psi]?
STEP 4. | Remove and inspect the overflow valve. |
 | STEP 4A. Remove and inspect the overflow valve. | Overflow valve clean?
STEP 5. | Measure the drain line restriction. |
 | STEP 5A. Install a pressure gauge in the drain line. | Pressure less than 69 kPa [10 psi]?
STEP 6. | Check the fuel pump static timing. |
 | STEP 6A. Check the fuel pump gear. | Pump gear correctly engaged with camshaft gear and key undamaged?
 | STEP 6B. Check the fuel pump gear key in use. | Key is correct and installed correctly?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 368 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read active fault codes.

If Fault Code 368 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 368 inactive?

Fault Code 368 active and no other active fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Perform low pressure system checks.

Guided Step 2A - Record findings for inlet restriction.

Conditions

  • Turn keyswitch OFF.

Action

Install a restriction gauge at the lift pump inlet.

Install a pressure gauge at the fuel filter inlet.

Use the following procedure in the Troubleshooting and Repair Manual, ISB and QSB5.9 Engines, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.

Install a clear line at the fuel filter outlet and run the line into a bucket.

With gauges and the clear line in place, bump the starter and leave the keyswitch ON. The lift pump will run for 25 to 30 seconds. While the lift pump is running, record the inlet restriction.

Steps 2A through 2D can be observed and recorded with a single bump of the starter.
OK NOT OK

Restriction less than 152 mm-Hg [6 in-Hg]?

Inlet restriction greater than 152 mm-Hg [6 in-Hg].

Find source of excessive restriction between the lift pump inlet and fuel tank.

Fix the source of excessive restriction.

Go to 2B

Go to 7A

Guided Step 2B - Install the gauges and record fuel pressure findings.

Conditions

  • Turn keyswitch OFF.

Action

With gauges and the clear line in place (as in Step 2A), bump the starter and leave the keyswitch ON.

The lift pump will run for 25 to 30 seconds. While the lift pump is running, record the fuel pressure at the fuel filter inlet.
OK NOT OK

Fuel pressure at fuel filter inlet less than 34 kPa [5 psi]?

Fuel pressure at fuel filter inlet is greater than 34 kPa [5 psi].

Fuel filter is restricted.

Replace the filter and check again.

Go to 2C

Go to 7A

Guided Step 2C - Install the gauges and record air in fuel findings.

Conditions

  • Turn keyswitch OFF.

Action

With gauges and the clear line in place (as in Step 2A), bump the starter and leave the keyswitch ON.

The lift pump will run for 25 to 30 seconds. While the lift pump is running, record if air is found in the fuel system.
OK NOT OK

No air found in the fuel?

Air in fuel detected.

Find the source of air between the lift pump inlet and fuel tank.

Go to 2D

Go to 7A

Guided Step 2D - Install the gauges and record fuel displacement findings.

Conditions

  • Turn keyswitch OFF.

Action

With gauges and the clear line in place (as in Step 2A), bump the starter and leave the keyswitch ON.

The lift pump will run for 25 to 30 seconds. While the lift pump is running, record the amount of fuel in the bucket after the lift pump has stopped running.

OK NOT OK

Fuel in bucket is greater than 1.33 liters [1.4 qt]?

Fuel in bucket is less than 1.33 liter [1.4 qt]

Go to 3A

Go to 2E

Guided Step 2E - Check the lift pump supply voltage.

Conditions

  • Disconnect the lift pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the lift pump voltage supply.

  • Disconnect the lift pump from the engine harness, after bumping the starter, use a multimeter to measure the voltage at pin-1 (engine harness, lift pump connector).
  • Lift pump will run for only 25 to 30 seconds after bumping the starter.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Battery voltage ± 2-VDC?

Use the following procedure to replace the lift pump in the Troubleshooting and Repair Manual, ISB and QSB5.9 Engines, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.

Inspect the voltage supply circuit.

Go to 7A

Go to 7A

Guided Step 3 - Verify the inlet restriction and check for air in the fuel when loaded.

Guided Step 3A - Verify the inlet restriction with the engine loaded.

Conditions

  • Turn keyswitch OFF.

Action

Install a restriction gauge at the lift pump inlet.

Install the clear line between the fuel filter outlet and fuel pump.

Use the following procedure to install a pressure gauge at the fuel filter outlet in the Troubleshooting and Repair Manual, ISB and QSB5.9 Engines, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.

With the gauges and the clear line in place, start the engine and put it under a load. Monitor and record the inlet restriction when Fault Code 368 is active.

Steps 3A through 3C can be observed and recorded with a single bump of the starter.
OK NOT OK

Inlet restriction less than 152 mm-Hg [6 in-Hg]?

Inlet restriction greater than 152 mm-Hg [6 in-Hg].

Find source of excessive restriction between the lift pump inlet and fuel tank.

Fix the source of excessive restriction.

Go to 3B

Go to 7A

Guided Step 3B - Verify there is no air in the fuel system with the engine loaded.

Conditions

  • Turn keyswitch OFF.

Action

With the gauges and the clear line in place (as in Step 3A) start the engine and put it under load.

Monitor the clear line to see if there is any air in the fuel system when Fault Code 368 is active.
OK NOT OK

No air found in the fuel?

Air in fuel detected.

Find the source of air between the lift pump inlet and the fuel tank.

Go to 3C

Go to 7A

Guided Step 3C - Verify the fuel pressure at the fuel filter outlet with the engine loaded.

Conditions

  • Turn keyswitch OFF.

Action

With the gauges and the clear line in place (as in Step 3A), start the engine and put it under load.

Monitor and record the fuel pressure at the fuel filter outlet when Fault Code 368 is active.
OK NOT OK

Fuel pressure greater than 14 kPa [2 psi]?

Fuel pressure less than 14 kPa [2 psi]

Go to 6A

Go to 4A

Guided Step 4 - Remove and inspect the overflow valve.

Guided Step 4A - Remove and inspect the overflow valve.

Conditions

  • Turn keyswitch OFF.

Action

Remove and inspect the overflow valve.

Use the following procedure in the Troubleshooting and Repair Manual, ISB and QSB5.9 Engines, Bulletin 3666193. Refer to Procedure 006-044 in Section 6.

OK NOT OK

Overflow valve clean?

Clean or replace overflow valve.

Go to 5A

Go to 7A

Guided Step 5 - Measure the drain line restriction.

Guided Step 5A - Install pressure gauge in the drain line.

Conditions

  • Turn keyswitch OFF.

Action

Install pressure gauge in the drain line.

Use the following procedure in the Troubleshooting and Repair Manual, ISB and QSB5.9 Engines, Bulletin 3666193. Refer to Procedure 006-012 in Section 6.

Operate the engine at high idle.
OK NOT OK

Pressure less than 69 kPa [10 psi]?

Pressure greater than 69 kPa [10 psi].

Find the source of restriction in the drain line.

Check for bends or kinks.

Go to 6A

Go to 7A

Guided Step 6 - Check the fuel pump static timing.

Guided Step 6A - Check the fuel pump gear.

Conditions

  • Turn keyswitch OFF.

Action

Review the vehicle claim history.

  • Before proceeding with Step 6, review the vehicle claim history. If the vehicle has accumulated over several thousand miles without any engine problems, service checks, or pump replacement, before developing Fault Code 368, then proceed to Step 7.

Check the fuel pump gear.

  • Use the following procedure to verify the timing marks on the gear train are aligned with the engine at top dead center (TDC) in the Troubleshooting and Repair Manual, ISB and QSB5.9 Engines, Bulletin 3666193. Refer to Procedure 005-037 in Section 5.
  • Verify the gear key is properly aligned in the center of the keyway and is not damaged.
OK NOT OK

Pump gear correctly engaged with camshaft gear and key undamaged?

Pump gear incorrectly engaged with camshaft gear or key damaged.

Correct engagement or replace damaged key.

Go to 6B

Go to 7A

Guided Step 6B - Check the fuel pump gear key in use.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel pump gear key in use.

  • Verify the key number inscribed on the key matches the number inscribed on the fuel pump data plate.
  • Verify the key is installed with the arrow facing the pump.
OK NOT OK

Key is correct and installed correctly?

Key is incorrect or installed incorrectly.

Install correct key or install key correctly.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and road-test for 30 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 368 is inactive.
OK NOT OK

Fault Code 368 inactive?

Fault Code 368 active.

Replace fuel pump. If the fuel pump is still under warranty and pre-authorization is required contact RAPIDSERVE™ for authorization.

Go to 7B

Go to 7B

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-Jan-2013


FAULT CODE 369 - Fuel Pump To Engine Synchronization Pulse Not Recognized

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if fault code is active at engine start-up. | Fault Code 369 inactive?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | 8 to 18-VDC during cranking?
STEP 3. | Check the fuel pump connector pins |
 | STEP 3A. Check the fuel pump connector pins. | Tool can not be inserted into any terminal?
STEP 4. | Check the pump controller circuit. |
 | STEP 4A. Check pump controller circuit resistance. | 5k to 7k ohms?
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the engine harness, fuel pump, and ECM connector pins, fuses, and relay. | No damaged pins or blown fuses?
STEP 6. | Check the engine synchronization signal circuit. |
 | STEP 6A. Check for an open circuit. | Less than 10 ohms?
 | STEP 6B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 6C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 7. | Check the engine speed sensor. |
 | STEP 7A. Inspect the sensor for a loose or intermittent connection. | No loose connections?
 | STEP 7B. Check for a signal from the engine speed sensor. | Signal present?
STEP 8. | Check for sources of electrical noise. |
 | STEP 8A. Inspect the engine, battery, and chassis ground connections. | No loose connections?
 | STEP 8B. Inspect the original equipment manufacturer (OEM) power distribution box fuses and wires. | No loose wires or shorted plugs?
 | STEP 8C. Disable the alternator by removing the belt. | Fault code is still active or goes active when running?
 | STEP 8D. Disconnect the lift pump. |
 | STEP 8E. Inspect the vehicle accessories. | No interference from accessories?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Disable the fault code. | Fault Code 369 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 369 is inactive, but other fault codes are active, troubleshoot the active fault codes. If Fault Code 115 has logged, troubleshoot it first.

OK NOT OK

Fault Code 369 inactive?

Fault Code 369 active or inactive and no other active fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check the voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector using pin-6 as ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

8 to 18-VDC during cranking

Check fuel pump supply and ground circuits.

Go to 3A

Go to 9A

Guided Step 3 - Check the fuel pump connector pins.

Guided Step 3A - Check the fuel pump connector pins.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch OFF.

Action

Check the fuel pump connector pins using inspection tool, Part Number 3164980 or equivalent.
OK NOT OK

Tool can not be inserted into any terminal?

Tool can be inserted into pin(s). Replace the damaged terminals.

Go to 4A

Go to 9A

Guided Step 4 - Check the pump controller circuit.

Guided Step 4A - Check the pump controller circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check the pump controller circuit resistance.

  • Measure the resistance from pin-7 to pin 8 of the fuel pump controller.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

5k to 7k ohms?

Replace the fuel pump injection pump.

Pre-authorization is required to replace the fuel pump injection pump, if pump is under warranty.

Go to 5A

Go to 9A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the battery cables.
  • Flush and clean the connector pins using electrical contact cleaner, Part Number 3824510.

Action

Inspect the engine harness and fuel pump and ECM connector pins, and fuses, and relay for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

No damaged pins or blown fuses?

Repair the damaged pins.

Replace any blown fuses. Repair or replace the engine harness, fuel pump, or ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace blown fuses. Refer to Procedure 019-198 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the engine synchronization signal circuit.

Guided Step 6A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from pin-8 of the fuel pump harness connector to pin-7 of the ECM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-185 or Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6B

Go to 9A

Guided Step 6B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-8 of the fuel pump harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-185 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6C

Go to 9A

Guided Step 6C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-8 of the fuel pump harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-185 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the engine speed sensor.

Guided Step 7A - Inspect the sensor for a loose or intermittent connection.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the sensor for loose or intermittent connection.

  • Remove and inspect the sensor. Refer to Procedure 019-042 in Section 19.
OK NOT OK

No loose connections?

Replace the engine speed sensor.

Refer to Procedure 019-042 in Section 19.

Go to 7B

Go to 9A

Guided Step 7B - Check for a signal from the engine speed sensor.

Conditions

  • Install breakout cable, Part Number 3824775 or equivalent, between the engine speed sensor and the engine harness.
  • Turn keyswitch ON.

Action

Check for a signal from the engine speed sensor.

The negative (-) multimeter lead should be connected to pin-B and the positive (+) lead to pin-C.

  • Measure the voltage from pin-C to pin-B of the breakout cable while barring the engine over. If the signal is present, the voltage will fluctuate between less than 0.5-VDC and greater than 4.5-VDC as the engine is slowly barred over.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Signal present?

Replace the engine speed sensor.

Refer to Procedure 019-042 in Section 19.

Go to 8A

Go to 9A

Guided Step 8 - Check for sources of electrical noise.

Guided Step 8A - Inspect the engine, battery, and chassis ground connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine, battery, and chassis ground connections.

  • Check the engine, battery, and chassis ground connections for loose connectors.
OK NOT OK

No loose connections?

Clean, tighten, and/or repair all loose connectors.

Go to 8B

Go to 9A

Guided Step 8B - Inspect the OEM power distribution box fuses and wires.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses and wires in the OEM distribution box.
OK NOT OK

No loose wires or shorted plugs?

Repair damaged or loose wiring and replace shorted plugs.

Go to 8C

Go to 9A

Guided Step 8C - Disable the alternator by removing the belt.

Conditions

  • Turn keyswitch OFF.

Action

Remove the alternator belt and run the engine to see if Fault Code 369 returns.
OK NOT OK

Fault code is still active or goes active when running?

Fault code did not return or went inactive. Inspect charging system and associated wiring.

Go to 8D

Go to 9A

Guided Step 8D - Disconnect the lift pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump engine harness connectors from the lift pump.

Action

Unplug the fuel lift pump and start engine to see if Fault Code 369 goes inactive.
OK NOT OK

Fault code is still active or goes active when running?

Fault code goes inactive or does not return with engine operating.

Use the following procedure to replace the fuel lift pump in the Troubleshooting and Repair Manual, ISB and QSB5.9-44, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.

Go to 8E

Go to 9A

Guided Step 8E - Inspect the vehicle accessories.

Conditions

  • Turn keyswitch OFF.

Action

Check all accessories in the vehicle for electrical noise interference.

The ECM and fuel pump power supply circuits should be uninterrupted and directly from battery.
OK NOT OK

No interference from accessories?

Correct electrical interference.

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test for 30 minutes.
  • Verify Fault Code 369 is inactive.
OK NOT OK

Fault Code 369 inactive?

Fault Code 369 active.

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Pre-authorization is required to replace the fuel pump injection pump if pump is under warranty.

Repair complete

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes clear?

All fault codes clear?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jan-2013


FAULT CODE 372 - Idle Select High/Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if fault code is active at engine start-up. | Fault Code 372 inactive, multiple active Fault Codes 431, 432, 443, and/or 551?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | Battery voltage +/- 2.0-VDC (during cranking)?
 | STEP 2B. Check the idle speed select circuit. | 5k to 7k ohms [0.05 to 0.07 bar]?
STEP 3. | Perform a diagnostic check, use the fuel pump diagnostic tool. |
 | STEP 3A. Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump. | Engine starts and operates in idle mode?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay. | No damaged pins or blown fuses?
STEP 5. | Check the harness electrical circuits. |
 | STEP 5A. Check for an open circuit. | Less than 10 ohms?
 | STEP 5B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 372 inactive?.
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 372 inactive, multiple active Fault Codes 431, 432, 443, and/or 551?

Fault Code 372 active.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Battery voltage +/- 2.0-VDC (during cranking)?

Check the battery.

Reference the ISB Engine Operation and Maintenance Manual, Bulletin 3666170.

Go to 2B

Go to 6A

Guided Step 2B - Check the idle speed select circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Check the idle speed select circuit.

  • Measure the resistance from pin-4 to pin-7 of the fuel pump.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

5k to 7k ohms [0.05 to 0.07 bar]?

Pre-authorization is required to replace the fuel pump injection pump if the pump is under warranty.

Go to 3A

Go to 6A

Guided Step 3 - Perform a diagnostic check, use the fuel pump diagnostic tool.

Guided Step 3A - Install the fuel pump diagnostic tool, Part Number 3163834 or equivalent, to check the operation of the fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump.

  • Install the fuel pump diagnostic tool, Part Number 3163834 or equivalent, to check the operation of the fuel pump.
OK NOT OK

Engine starts and operates in idle mode?

Engine does not start.

Make sure that air has been vented from the system. Pre-authorization is required to replace the fuel pump injection pump if the pump is under warranty.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins or blown fuses?

Repair the damaged pins.

Replace any blown fuses. Repair or replace the engine harness, or replace the fuel pump or ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace blown fuses. Refer to Procedure 019-198 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-210 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure to replace the fuel lift pump in the Troubleshooting and Repair Manual,ISB and QSB5.9-44 Engines, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the harness electrical circuits.

Guided Step 5A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for an open circuit.

  • Measure the resistance from pin-4 of the fuel pump harness connector to pin-16 of the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-210 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5B

Go to 6A

Guided Step 5B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-16 of the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-16 of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Depress the accelerator pedal to idle the vehicle at 1000 rpm.
  • Depress the accelerator pedal to idle the vehicle at 1000 rpm.
  • Verify that Fault Code 372 is inactive.
OK NOT OK

Fault Code 372 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jan-2013


FAULT CODE 373 - Fuel Pump Fuel Shut Off Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if fault code is active at engine start-up. | Fault Code 373 inactive, multiple active Fault Codes 146, 151, 488, 155, 143, 415, 235, and/or 234?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | 6.5 to 18.0-VDC (12-VDC system); 8.0 to 18.0-VDC (during cranking)?
STEP 3. | Perform a diagnostic check using the fuel pump diagnostic tool. |
 | STEP 3A. Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump. | Engine starts and runs in idle mode?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay. | No damaged pins or blown fuses?
STEP 5. | Check the harness electrical circuits. |
 | STEP 5A. Check for an open circuit. | Less than 10 ohms?
 | STEP 5B. Check for a short circuit from pin to pin at the ECM harness connector. | Greater than 100k ohms?
 | STEP 5C. Check for a short circuit from pin-to-pin at the fuel pump harness connector. | Greater than 100k ohms?
STEP 6. | Check the ECM. |
 | STEP 6A. Recalibrate the ECM with updated code. | ECM calibrated with updated code. Fault Code 364 goes inactive?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 373 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If the engine is in a shutdown state and a fault code is present, this indicates that an engine protection limit has been exceeded (Fault Code 146, 151, 488, 155, 143, 415, 235, or 234), troubleshoot this fault code first.

OK NOT OK

Fault Code 373 inactive, multiple active Fault Codes 146, 151, 488, 155, 143, 415, 235, and/or 234?

Fault Code 373 active or inactive and no other fault codes are present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

6.5 to 18.0-VDC (12-VDC system); 8.0 to 18.0-VDC (during cranking)?

Check the battery.

Reference the Operation and Maintenance Manual, ISB Engines, Bulletin 3666170.

Go to 3A

Go to 7A

Guided Step 3 - Perform a diagnostic check using the fuel pump diagnostic tool.

Guided Step 3A - Install the fuel pump diagnostic tool, Part Number 3163834 or equivalent, to check the operation of the fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Install the fuel pump diagnostic tool, Part Number 3163834 or equivalent, to check the operation of the fuel pump.

Perform a diagnostic check using the fuel pump diagnostic tool.
OK NOT OK

Engine starts and operates in idle mode?

Engine does not start.

  • Use the following procedure to replace the fuel pump in the ISB and QSB5.9-44 Engines Troubleshooting and Repair Manual, Bulletin 3666193. Refer to Procedure 005-014 in Section 5..

Go to 4A

Go to 7A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Inspect the engine harness, fuel pump, ECM connector pins, fuses, and relay for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins or blown fuses?

Repair the damaged pins.

Replace any blown fuses. Repair or replace the engine harness, or replace the fuel pump or ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace blown fuses. Refer to Procedure 019-198 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure to replace the fuel pump in the ISB and QSB5.9-44 Engines Troubleshooting and Repair Manual, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the harness electrical circuits.

Guided Step 5A - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-6 of the engine harness ECM connector to pin 5 of the fuel pump harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Check for a short circuit from pin-to-pin at the ECM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin at the engine harness ECM connector.

  • Measure the resistance from pin-6 of the engine harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check for a short circuit from pin-to-pin at the fuel pump harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin at the fuel pump harness connector.

  • Measure the resistance from pin-5 of the fuel pump harness connector to all other pins in the connector, except pin-6.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-209 or Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the ECM.

Guided Step 6A - Recalibrate the ECM with updated code.

Conditions

  • Turn keyswitch OFF.

Action

Recalibrate the ECM with updated calibration code.

  • Refer to Procedure 019-032 in Section 19.

If a test ECM is available, hook it up to the vehicle and perform a road test. If fault does not reoccur with the test ECM, replace the ECM.

OK NOT OK

ECM calibrated with updated code.

Fault Code 364 goes inactive.

Fault Code 373 still active.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road-test for 30 minutes.
  • Verify Fault Code 373 is inactive.
OK NOT OK

Fault Code 373 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jan-2013


FAULT CODE 374 - Fuel Pump Calibration Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 374 inactive?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | 8 to 18-VDC during cranking?
STEP 3. | Check the connector pins |
 | STEP 3A. Check the connector pins | Tool can not be inserted into any terminal?
STEP 4. | Perform a diagnostic check using the diagnostic tool. |
 | STEP 4A. Install the fuel pump diagnostic tool to check the operation of the fuel pump. | Engine starts and operates in idle mode?
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the engine harness and fuel pump and ECM connector pins and the fuses and relay. | No damaged pins or blown fuses?
STEP 6. | Check the harness electrical circuits. |
 | STEP 6A. Check the fuel pump supply resistance. | Less than 2.0 ohms?
 | STEP 6B. Check the fuel pump ground circuit resistance. | Less than 0.2 ohms?
 | STEP 6C. Check the load carrying capabilities of the power and ground circuit. | Headlight illuminates?
STEP 7. | Check for sources of electrical noise. |
 | STEP 7A. Inspect the engine, battery, and chassis ground connections. | No loose connections?
 | STEP 7B. Inspect the original equipment manufacturer (OEM) power distribution box fuses and wires. | No loose wires or shorted plugs?
 | STEP 7C. Disable the alternator by removing the belt. | Fault Code is still active or goes active when running?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 374 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 374 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 374 inactive?

Fault Code 374 active or inactive and no other fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check the voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector using pin-6 as ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

8 to 18-VDC during cranking?

Check the harness electrical circuits.

Go to 3A

Go to 6A

Guided Step 3 - Check the connector pins

Guided Step 3A - Check the connector pins

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch OFF.

Action

Check the connector pins using inspection tool, Part Number 3164980.

Refer to Procedure 019-214 in Section 19.

OK NOT OK

Tool can not be inserted into any terminal.

Tool can be inserted into pin(s).

Refer to Procedure 019-214 in Section 19.

Go to 4A

Go to 8A

Guided Step 4 - Perform a diagnostic check using the diagnostic tool.

Guided Step 4A - Install the fuel pump diagnostic tool to check the operation of the fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Install the fuel pump diagnostic tool, Part Number, 3163834, to check the operation of the fuel pump.

  • Use the following procedure in Service Manual, B3.9, B4.5RGT, and B5.9 Series Engines, Bulletin 3666087. Refer to Procedure 005-014 in Section 5.

Make sure that air has been vented from the system before using the diagnostic tool.

If replacing the injection pump, perform a lift pump volume test at the fuel filter outlet for twenty-five seconds by bumping the starter. If volume is greater than 1.33 liter [45 oz], the low pressure fuel system is operating correctly.

OK NOT OK

Engine starts and operates in idle mode?

Engine does not start.

Pre-authorization is required to replace the injection pump, if pump is under warranty.

Use the following procedure for installation, testing, and replacing the fuel injection pump in Service Manual, B3.9, B4.5RGT, and B5.9 Series Engines, Bulletin 3666087. Refer to Procedure 005-014 in Section 5.

Make sure that air has been vented from the system.

Go to 5A

Go to 8A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Inspect the engine harness and fuel pump, and the ECM connector pins, fuses, and relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the battery cables.
  • Flush and clean the connector pins using electrical contact cleaner, Part Number 3824510.

Action

Inspect the engine harness and fuel pump and the ECM connector pins, fuses, and relay for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

No damaged pins or blown fuses?

Repair the damaged pins?

Replace any blown fuses. Repair or replace the engine harness, fuel pump or ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the blown fuses. Refer to Procedure 019-198 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-209 and Refer to Procedure or 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6C

Go to 8A

Guided Step 6 - Check the harness electrical circuits.

Guided Step 6A - Check the fuel pump supply resistance.

Conditions

  • Disconnect the fuel pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel pump supply resistance.

  • Measure the resistance from pin-7 of the fuel pump harness connector to the positive (+) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 2.0 ohms?

Greater than 2.0 ohms.

Inspect the relay and power supply fuses, and replace if necessary.

Go to 6B

Go to 8A

Guided Step 6B - Check the fuel pump ground circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.
  • Disconnect the engine harness from the ECM.
  • Disconnect the ECM battery return connector.

Action

Check the fuel pump ground circuit resistance.

  • Measure the resistance from pin-6 of the fuel pump harness connector to ground side, negative (-) battery ring terminal.
  • Make certain that the terminal is disconnected from the battery post.
OK NOT OK

Less than 0.2 ohms?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-209 and Refer to Procedure or 019-197 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6C

Go to 8A

Guided Step 6C - Check the load carrying capabilities of the power and ground circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump.

Action

Connect a 12-VDC headlight to pin-6 and pin-7 of the connector and check illumination with the keyswitch on and during cranking. Headlight must draw 10 to 12 amps minimum.

OK NOT OK

Headlight illuminates?

Headlight does not illuminate

Check battery connections.

Check fuses and relay.

Perform illumination test on OEM powers and grounds at 23-pin OEM connector.

Go to 7A

Go to 8A

Guided Step 7 - Check for sources of electrical noise.

Guided Step 7A - Inspect the engine, battery, and chassis ground connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine, battery, and chassis ground connections.

  • Check the engine, battery and chassis ground connections for loose connectors.
OK NOT OK

No loose connections?

Clean and tighten and repair all loose connectors.

Go to 7B

Go to 8A

Guided Step 7B - Inspect the OEM power distribution box fuses and wires.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses and wires in the OEM distribution box.
OK NOT OK

No loose wires or shorted plugs?

Repair damaged or loose wiring and replace shorted plugs?

Go to 7C

Go to 8A

Guided Step 7C - Disable the alternator by removing the belt.

Conditions

  • Turn keyswitch OFF.

Action

Remove the alternator belt and run engine to see if Fault Code 374 returns.
OK NOT OK

Fault code is still active or goes active when running?

Fault code did not return or went inactive.

Inspect the charging system and associated wiring.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test for 30 minutes.
  • Verify Fault Code 374 is inactive.
OK NOT OK

Fault Code 374 inactive?

Fault Code 374 active

Return to the troubleshooting steps, or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Pre-authorization is required to replace the injection pump, if pump is under warranty.

Use the following procedure for installation, testing, and replacing the fuel injection pump in Service Manual, B3.9, B4.5RGT, and B5.9 Series Engines, Bulletin 3666087. Refer to Procedure 005-014 in Section 5.

Make sure that air has been vented from the system.

Repair complete

Go to 1A

Last Modified: 08-Jan-2013


FAULT CODE 375 - Engine Control Module (ECM) Fuel Calibration Corrupted

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 375 inactive?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low voltage during cranking. | 6.5 to 18-VDC (12-VDC system); 8 to 18-VDC (during cranking)?
STEP 3. | Perform a diagnostic check using the fuel pump diagnostic tool. |
 | STEP 3A. Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump. | Engine starts and operates in idle mode?
STEP 4. | Check the engine harness and fuel pump. |
 | STEP 4A. Inspect the engine harness and fuel pump solenoid leads for tampering. | No signs of tampering?
STEP 5. | Calibrate the ECM. |
 | STEP 5A. Calibrate the ECM with updated code. | ECM recalibrated with updated code, Fault Code 375 goes inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 375 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 375 inactive?

Fault Code 375 active or inactive and no other fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check the voltage supply.

Guided Step 2A - Check the battery voltage supply for low voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

6.5 to 18-VDC (12-VDC system); 8 to 18-VDC (during cranking)?

Go to 3A

Go to 6A

Guided Step 3 - Perform a diagnostic check using the fuel pump diagnostic tool.

Guided Step 3A - Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Install the fuel pump diagnostic tool, Part Number 3163834, to check the operation of the fuel pump.

  • Contact a Cummins® Authorized Repair Locaton.
  • Make certain that the air has been vented from the system before using the diagnostic tool.
OK NOT OK

Engine starts and operates in idle mode?

Engine does not start.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness and fuel pump.

Guided Step 4A - Inspect the engine harness and fuel pump solenoid leads for tampering.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Inspect the engine harness and fuel pump solenoid leads for tampering.

  • Make certain that no aftermarket performance upgrade kits have been installed on the vehicle.
OK NOT OK

No signs of tampering?

Correct the problem.

Go to 5A

Go to 6A

Guided Step 5 - Calibrate the ECM.

Guided Step 5A - Calibrate the ECM with updated code.

Conditions

  • Turn keyswitch OFF.

Action

Calibrate the ECM with updated calibration code.

  • Reference the INSITE™ manual for the appropriate procedure.
OK NOT OK

ECM recalibrated with updated code, Fault Code 375 goes inactive. Calibrations available on the latest ESDN calibration CD-ROM.

Fault Code 375 still active?

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Verify Fault Code 375 is inactive.
OK NOT OK

Fault Code 375 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jan-2013


FAULT CODE 376 - Fuel Pump rpm and Fuel Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if the fault code is active at engine start-up. | Fault Code 376 inactive?
STEP 2. | Recalibrate the ECM. |
 | STEP 2A. Recalibrate the ECM with updated code. | ECM recalibrated with updated code Fault Code 376 goes inactive?
STEP 3. | Check the fuel lines. |
 | STEP 3A. Check for air in the fuel lines. | No air in fuel lines?
STEP 4. | Check the vehicle rpm. |
 | STEP 4A. Compare a tachometer rpm reading with the engine-speed-sensor-calculated rpm reading and the fuel-pump-calculated rpm reading. | Tachometer rpm reading equal to engine-speed-sensor-calculated reading, and tachometer reading equal to or less than a 50-rpm difference from fuel-pump-calculated reading at steady-state conditions?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 376 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if the fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if the fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 376 is inactive, but other fault codes are active, troubleshoot the active fault codes.
OK NOT OK

Fault Code 376 inactive?

Fault Code 376 active or inactive and no other fault codes present.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Recalibrate the ECM.

Guided Step 2A - Recalibrate the ECM with updated code.

Conditions

  • Turn keyswitch OFF.

Action

Calibrate the ECM with updated calibration code.

  • Reference the INSITE™ manual for the appropriate procedure.
OK NOT OK

ECM recalibrated with updated code Fault Code 376 goes inactive.

Calibrations available on the latest ESDN calibration CD-ROM.

Fault Code 376 still active?

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel lines.

Guided Step 3A - Check for air in the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the fuel lines.

  • Use the following procedure to open all fuel lines, and prime the engine to eliminate the air from the fuel system in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193. Refer to Procedure 006-003 in Section 6.
OK NOT OK

No air in fuel lines?

Go to 4A

Go to 5A

Guided Step 4 - Check the vehicle rpm.

Guided Step 4A - Compare a tachometer rpm reading with the engine-speed-sensor-calculated rpm reading and the fuel-pump-calculated rpm reading.

Conditions

  • Turn keyswitch ON.

Action

Compare rpm readings from different sources as follows:

  • Measure the vehicle's rpm at the vibration damper or fan pulley with a handheld tachometer or similar rpm measurement device.
  • Compare the vehicle rpm reading measured by the tachometer with the rpm reading from the fuel pump and the rpm reading from the engine speed sensor (as shown on the INSITE™ monitor screen).
OK NOT OK

Tachometer rpm reading equal to engine-speed-sensor-calculated reading, and tachometer reading equal to or less than a 50-rpm difference from fuel-pump-calculated reading at steady-state conditions?

Tachometer rpm reading not equal to engine-speed-sensor-calculated reading, or tachometer reading is more than 50 rpm different from fuel-pump-calculated reading at steady-state conditions

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and road-test for 30 minutes.
  • Verify Fault Code 376 is inactive.
OK NOT OK

Fault Code 376 inactive?

Fault Code 376 active.

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-Jan-2013


FAULT CODE 377 - Fuel Pump Power Relay Stuck-On

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness, fuel pump, and ECM connectors. |
 | STEP 1A. Inspect the engine harness, fuel pump, and ECM connectors. | No damaged pins?
 | STEP 1B. Check for a short circuit from pin to pin in the fuel pump power shutoff circuit. | Greater than 100k ohms?
 | STEP 1C. Check for a short circuit to an external voltage source. | Less than 1.0-VDC?
STEP 2. | Check relay. |
 | STEP 2A. Check for stuck relay. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 377 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the engine harness, fuel pump, and ECM connectors.

Guided Step 1A - Inspect the engine harness, fuel pump, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the fuel pump relay connector from the engine harness.

Action

Inspect the engine harness, fuel pump, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair or replace the damaged pins.

  • Repair the engine harness. and Refer to Procedure 019-250.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the ECM. Refer to Procedure 019-031.
  • Use the following procedure to replace the fuel pump in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.

Go to 1B

Go to 3A

Guided Step 1B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-43 to pin-16, pin-6, pin-11, pin-5, pin-38, pin-39, pin-40, pin-31, and pin-42.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to an external voltage source.

Conditions

  • Disconnect fuel pump relay from the engine harness.
  • Connect ECM to the engine harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to an external voltage source in the fuel pump voltage supply circuit.

  • Measure the voltage from pin-A of the fuel pump relay connector, harness side, to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Less than 1.0-VDC?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check relay.

Guided Step 2A - Check for stuck relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump relay from the engine harness.

Action

Check for stuck “ON” relay.

  • Measure resistance between pin-30 and post 87 of the fuel pump relay.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Use the following procedure to replace the fuel pump in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193. Refer to Procedure 005-014 in Section 5.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let idle for 1 minute
  • Verify that Fault Code 377 is inactive
OK NOT OK

Fault Code 377 inactive?

Return to troubleshooting steps, or a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jan-2013


FAULT CODE 381 - Intake Air Heater Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check OEM harness. |
 | STEP 1A. Inspect the OEM harness, intake air heater relay, and ECM connectors. | No damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
 | STEP 1C. Check for an open circuit in the relay and relay ground. | Refer to the OEM troubleshooting and repair manual for specification?
 | STEP 1D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1F. Check for a short circuit to battery. | Less than (+) 1.0-VDC?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Codes 381 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check OEM harness.

Guided Step 1A - Inspect the OEM harness, intake air heater relay, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intake air heater relay.

Action

Inspect the OEM harness, intake air heater relay, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair damaged pins.

Repair or replace the OEM harness, ECM, or intake air heater relay, whichever. has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-250 and Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the intake air heater relay. Reference the Troubleshooting and Repair Manual ISB Engines, Bulletin 3666193.

Go to 1B

Go to 2A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the intake air heater relay connector.

Action

Check for an open circuit in the relay enable circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness connector to the harness side of the heater relay connector.
  • Refer to the following to determine the correct pins to check for each fault: OEM harness connector pin-41 to heater relay 1 (pin-A).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for an open circuit in the relay and relay ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the intake air heater relay connector.

Action

Check for an open circuit in the relay and relay ground.

  • Measure the resistance of the relay and its ground on the pull-in-coil-side of the relay.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Refer to the OEM service manual.

Replace relay or ground circuit.

Refer to the OEM service manual.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the intake air heater relay connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the intake air heater relay circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness connector to engine block ground.
  • Refer to the following to determine the correct pins to check for each fault: OEM harness connector pin-41.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the intake air heater relay connector from the OEM harness.

Action

Check for a short circuit from pin-to-pin in the intake air heater relay circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness to all other pins in the OEM harness connector.
  • Refer to the following to determine the correct pins to check for each fault: OEM harness connector pin-41.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Check for a short circuit to battery.

Conditions

  • Disconnect the OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery.

  • Measure the voltage from pin-31 and 41 in the OEM harness to the block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Less than 1.0 (+)-VDC

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute
  • Verify that Fault Codes 381 are inactive.
OK NOT OK

Fault Codes 381 inactive?

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jul-2012


FAULT CODE 382 - Intake Air Heater Relay Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check OEM harness. |
 | STEP 1A. Inspect the OEM harness, intake air heater relay, and ECM connectors. | No damaged pins?
 | STEP 1B. Check for an open circuit. | Less than 10 ohms?
 | STEP 1C. Check for an open circuit in the relay and relay ground. | Refer to the OEM service manual?
 | STEP 1D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 1F. Check for a short circuit to battery. | Less than (+) 1.0-VDC?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Codes 382 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check OEM harness.

Guided Step 1A - Inspect the OEM harness, intake air heater relay, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intake air heater relay.

Action

Inspect the OEM harness, intake air heater relay, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair damaged pins.

Repair or replace the OEM harness, ECM, or intake air heater relay, whichever, has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-250 and Refer to Procedure 019-204 in Section 19..
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Replace the intake air heater relay. Reference the Troubleshooting and Repair Manual ISB Engines, Bulletin 3666193.

Go to 1B

Go to 2A

Guided Step 1B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the intake air heater relay connector.

Action

Check for an open circuit in the relay enable circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness connector to the harness side of the heater relay connector.
  • Refer to the following to determine the correct pins to check for each fault: OEM harness connector pin-31 to heater relay 2 (pin-C).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for an open circuit in the relay and relay ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the intake air heater relay connector.

Action

Check for an open circuit in the relay and relay ground.

  • Measure the resistance of the relay and its ground on the pull-in-coil-side of the relay.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Refer to the OEM service manual?

Replace relay or ground circuit.

Refer to the OEM service manual.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the intake air heater relay connector.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the intake air heater relay circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness connector to engine block ground.
  • Refer to the following to determine the correct pins to check for each fault: OEM harness connector pin-31.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the intake air heater relay connector from the OEM harness.

Action

Check for a short circuit from pin-to-pin in the intake air heater relay circuit.

  • Measure the resistance from the intake air heater relay pin in the OEM harness to all other pins in the OEM harness connector.
  • Refer to the following to determine the correct pins to check for each fault: OEM harness connector pin-31.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 1F

Go to 2A

Guided Step 1F - Check for a short circuit to battery.

Conditions

  • Disconnect OEM harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to battery.

  • Measure the voltage from pins-31 and pin-41 in the OEM harness to the block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Less than 1.0 (+)-VDC

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute
  • Verify that Fault Code 382 are inactive.
OK NOT OK

Fault Codes 382 inactive?

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear all inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jul-2012


FAULT CODE 383 - Intake Air Heater Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check grid heater relay. |
 | STEP 1A. Check grid heater relay switch circuit. | No errors detected during test?
 | STEP 1B. Measure voltage of each grid heater coil. | 11 to 13-VDC?
STEP 2. | Check the grid heater coils. |
 | STEP 2A. Measure resistance of each grid heater coil. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 383 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check grid heater relay.

Guided Step 1A - Check grid heater relay switch circuit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform Grid Heater Override Test.

  • Use INSITE™ electronic service tool to run the Grid Heater Override Test.
OK NOT OK

No errors detected during test?

Errors detected during test

Go to 3A

Go to 1B

Guided Step 1B - Measure voltage of each grid heater circuit.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™.

Action

Measure voltage to each grid heater coil.

  • Use INSITE electronic service tool to perform Grid Heater Override Test.
  • Measure voltage from grid heater coils to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

11 to 13-VDC?

Repair or replace the damaged OEM wiring.

Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Check the grid heater coils.

Guided Step 2A - Measure the resistance of each grid heater coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit at each grid heater coil.

Measure the resistance from pin-A to pin-B, and from pin-C to pin-D.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the damaged OEM wiring.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify that Fault Code 383 is inactive.
OK NOT OK

Fault Code 383 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-Jul-2012


FAULT CODE 386 - Sensor Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensors. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
 | STEP 1B. Check the engine position sensor. | Fault Code 352 remains active?
 | STEP 1C. Check the intake manifold pressure sensor. | Fault Code 352 remains active?
 | STEP 1D. Check the oil pressure sensor. | Fault Code 352 remains active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connectors. | No damaged pins?
 | STEP 2B. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 1D. Check sensor supply voltage. | (+) 4.75 to 5.25 VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the sensors.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 386 active?

Fault Code 352 active?

Go to 2A

Go to 1B

Guided Step 1B - Check the engine position sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the engine position sensor from the engine harness.

Action

Check the engine position sensor.
OK NOT OK

Fault Code 352 remains active?

Replace the engine position sensor.

Refer to Procedure 019-038 in Section 19.

Go to 1C

Go to 3A

Guided Step 1C - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check the intake manifold pressure sensor.
OK NOT OK

Fault Code 352 remains active?

Replace intake manifold sensor.

Refer to Procedure 019-061 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check the oil pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check the oil pressure sensor.
OK NOT OK

Fault Code 352 remains active?

Replace oil pressure sensor.

Refer to Procedure 019-066 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance from pin-10 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Repair or replace the engine harness

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-10 of the engine harness connector to all the other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

More than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check sensor supply voltage.

Conditions

  • Connect the engine harness to the ECM.
  • Disconnect the engine position sensor from the engine harness.
  • Disconnect the oil pressure sensor from the engine harness.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check for sensor +5-VDC supply voltage.

  • Measure the voltage from pin-A on the harness side of the engine speed sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.
OK NOT OK

Fault Codes 386 inactive?

Return to troubleshooting steps, or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Jul-2015


FAULT CODE 387 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822917 - female AMP™/Metri-Pack™/Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect OEM harness and sensor connectors. | No damaged pins?
 | STEP 1B. Check for active fault codes. | Fault Code 387 remains active?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connectors. | No damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to a voltage source. | Less than (+) 1.0-VDC?
STEP 3. | Check the ECM voltage. |
 | STEP 3A. Measure the sensor supply voltage from the ECM. | (+) 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 387 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the sensor connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Replace the damaged pins.

Repair or replace the OEM harness or the accelerator position sensor, whichever has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the accelerator position sensor. Refer to the OEM service manual.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 387 remains active?

Replace the accelerator pedal assembly or the accelerator position sensor.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-250 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-29 of the OEM harness connector to pin-C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin-19 of the OEM harness connector to pin-A on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin-30 of the OEM harness connector to pin-B on the harness side of the accelerator position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to a chassis ground.

  • Measure the resistance from pin-29 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin-19 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin-30 in the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-29 to all other pins in the OEM harness connector.
  • Measure the resistance from pin-19 to all other pins in the OEM harness connector.
  • Measure the resistance from pin-30 to all other pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the ECM.
  • Connect the OEM harness to the accelerator position sensor.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage from pin-29 in the OEM harness connector to engine block ground.
  • Measure the voltage from pin-19 in the OEM harness connector to engine block ground.
  • Measure the voltage from pin-30 in the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Less than 1.0-VDC?

Replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM voltage.

Guided Step 3A - Measure the sensor supply voltage from the ECM

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the ECM.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin-29 to pin 19 on the ECM OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Depress and release the accelerator pedal several times to be sure the ECM is getting an accelerator signal.
  • Verify Fault Code 387 inactive.
OK NOT OK

Fault Code 387 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 15-Jul-2015


FAULT CODE 391 - Fuel Pump Relay Coil Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connectors. | No damaged pins?
 | STEP 1B. Check the battery voltage. | Normal: (+) 12-VDC in a (+) 12-Volt system; Cranking: (+) 8-VDC in a (+) 12-Volt system
 | STEP 1C. Check for an open circuit in the fuel shutoff circuit. | Less than 10 ohms?
 | STEP 1D. Check for an open circuit in the relay ground circuit. | Less than 10 ohms?
 | STEP 1E. Check for an open circuit in the ground circuit. | Less than 10 ohms?
 | STEP 1F. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1G. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 1H. Check the fuel shutoff voltage from the ECM. | (+) 11-VDC?
STEP 2. | Check original equipment manufacturer's (OEM) harness. |
 | STEP 2A. Check the pump power supply circuit. | No damaged pins?
 | STEP 2B. Measure the pump ground resistance. | Less than 0.2 ohms?
STEP 3. | Clear the fault codes |
 | STEP 3A. Disable the fault code. | Fault Code 391 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check engine harness.

Guided Step 1A - Inspect the engine harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damage connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair the engine harness.Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) to the negative (-) post.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Normal: (+) 12-VDC in a (+) 12-volt system; Cranking: (+) 8-VDC in a (+) 12-volt system?

Replace the battery.

Go to 1C

Go to 3A

Guided Step 1C - Check for an open circuit in the fuel shutoff circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect engine harness from OEM fuel shutoff circuit.

Action

Check for open circuit in the fuel shutoff circuit.

  • Measure resistance from pin-43 of the engine harness connector to pin-C on the harness side of the fuel shutoff relay connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit in the relay ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect engine harness from OEM fuel shutoff circuit.

Action

Check for open circuit in the relay ground circuit.

  • Measure the resistance from pin-H of the 23-pin OEM connector to pin-D on the harness side of the fuel shutoff relay connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 1E

Go to 3A

Guided Step 1E - Check for an open circuit in the relay ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the engine harness ground circuit.

  • Measure the resistance from pin-H of the 23-pin OEM harness to battery return.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness or battery return connector.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the battery return connector. Refer to Procedure 019-199 in Section 19.

Go to 1F

Go to 3A

Guided Step 1F - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect engine harness from OEM fuel shutoff circuit.

Action

Check for short circuit to ground.

  • Measure the resistance from pin-43 of the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 1G

Go to 3A

Guided Step 1G - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect engine harness from OEM fuel shutoff circuit (disconnect the fuel pump relay).

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-43 of the engine harness to all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 1H

Go to 3A

Guided Step 1H - Check for signal voltage from the ECM.

Conditions

  • Turn keyswitch ON.
  • Disconnect the fuel pump relay from the engine harness.

Action

Check for signal voltage from the ECM.

  • Check the supply voltage from pin-C of the fuel pump relay connector, harness side, to the engine block ground.

This will cause Fault Code 364 to register an additional count.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Greater than (+) 11-VDC?

Check ECM power supply.

Go to 2A

Refer to the OEM service manual.

Guided Step 2 - Check the +12-VDC pump power supply and ground circuit.

Guided Step 2A - Check the pump power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump power relay.

Action

Check the fuel pump power relay and the engine harness for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damage connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

No damaged pins?

Repair the damage pins.

  • Repair or replace the fuel pump relay. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the resistance of the fuel pump ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump connector.
  • Disconnect the negative (-) battery terminal from the negative (-) post.

Action

Check the reistance of the fuel pump ground circuit.

  • Measure the resistance from pin-6 at the fuel pump connector, harness side, to the negative (-) battery ground terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohms?

Replace or repair the section of ground circuit causing high resistance.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Verify Fault Code 391 is inactive.
OK NOT OK

Fault Code 391 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 09-Jan-2013


FAULT CODE 418 - Water-In-Fuel Sensor Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel filter. |
 | STEP 1A. Drain the water from the fuel filter. | Fault Code 418 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 418 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fuel filter.

Guided Step 1A - Drain the water from the fuel filter.

Conditions

  • Turn keyswitch ON.

Action

Drain the water from the fuel filter.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 418 inactive?

Drain water from the fuel filter. Use the following procedure in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193. Refer to Procedure 006-015 in Section 6.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the Fault Code 418 is inactive.
OK NOT OK

Fault Code 418 inactive?

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Jul-2012


FAULT CODE 429 - Water-In-Fuel (WIF) Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor supply fault code. |
 | STEP 1A. Read fault codes. | Fault Code 444 inactive?
STEP 2. | Check OEM harness. |
 | STEP 2A. Inspect the OEM harness, WIF sensor, and ECM connectors. | No damaged pins?
 | STEP 2B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check sensor supply voltage. | (+) 4.75 to 5.25-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 429 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for sensor supply fault code.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.

Action

Temperature

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 385 or 444 inactive?

Fault Code 385 or 444 active?

Go to 2A

Reference Fault Code 385 or 444.

Guided Step 2 - Check OEM harness.

Guided Step 2A - Inspect the OEM harness, WIF sensor, and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the WIF sensor.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness, WIF sensor, and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the ECM, WIF sensor, or OEM harness, whichever has the damaged pins.

  • Repair OEM harness. Refer to Procedure 019-250 and Refer to Procedure 019-202 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure to replace WIF sensor in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193. Refer to Procedure 006-015 in Section 6.
  • Repair or replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the WIF sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-40 of the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the WIF sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-40 to all other pins on the harness side of the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check sensor supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the WIF sensor.
  • Connect the OEM harness to the ECM.

Action

Check sensor supply voltage.

  • Measure the voltage from pin-B on the harness side of the WIF sensor connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC?

Use the following procedure to replace WIF sensor in the Troubleshooting and Repair Manual, ISB Engines, Bulletin 3666193. Refer to Procedure 006-015 in Section 6

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify that the Fault Code 429 is inactive.
OK NOT OK

Fault Code 429 inactive?

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Jul-2012


FAULT CODE 431 - Idle Validation Switch (IVS) Circuit

Associated Procedures

Cautions and Warnings

WARNING

Set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP®/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3822917 - female AMP™/Metri-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator pedal. |
 | STEP 1A. Verify the IVS is connected to the OEM harness. | IVS connected?
 | STEP 1B. Calibrate the accelerator pedal. | Fault Code 431 inactive?
 | STEP 1C. Inspect the engine harness and the IVS connector. | No damaged pins?
 | STEP 1D. Check for an open circuit. | Less than 10 ohms?
 | STEP 1E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connectors. | No damaged pins?
 | STEP 2B. Check the ECM supply. | (+) 4.75 to 5.25-VDC?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the accelerator pedal.

Guided Step 1A - Verify the IVS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the IVS is connected to the OEM harness.
OK NOT OK

IVS connected?

Connect the IVS.

Connect the OEM harness to the IVS. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Calibrate the accelerator pedal.

Conditions

  • Turn keyswitch ON.

Action

Calibrate the accelerator pedal.

  • Depress the accelerator pedal to the full-fuel position.
  • Release the accelerator pedal.
  • Repeat this procedure two more times.
OK NOT OK

Fault Code 431 active?

Pedal not calibrated.

Fault Code 431 inactive.

Go to 1C

Go to 3A

Guided Step 1C - Inspect the OEM harness and the IVS connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the IVS.

Action

Inspect the OEM harness and the IVS connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the IVS or OEM harness, whichever, has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the IVS. Refer to the OEM service manual.
  • Install the appropriate connector seal if it is damaged or missing. Refer to the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the IVS.

Action

Check for an open circuit in the IVS.

  • Measure the resistance from pin-B to pin-A on the switch side of the IVS connector with the accelerator pedal released.
  • Measure the resistance from pin-C to pin-A on the switch side of the IVS connector with the accelerator pedal depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the IVS.

Refer to the OEM service manual.

Go to 1E

Go to 3A

Guided Step 1E - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the IVS.

Action

Check for a short circuit from pin-to-pin in the IVS.

  • Measure the resistance from pin-B to pin-C on the switch side of the IVS connector with the accelerator pedal released and depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the IVS.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the IVS.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever, has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-250 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the ECM supply.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the ECM.

Action

Check the ECM supply.

  • Measure the voltage from pin-29 of the OEM harness of the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the IVS.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pins-25 and pin-26 of the OEM harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the IVS.

Action

Check for an open circuit.

  • Measure the resistance from pin-26 on the harness side of the OEM harness connector to pin B on the harness side of the IVS connector.
  • Measure the resistance from pin-25 on the harness side of the OEM harness connector to pin C on the harness side of the IVS connector.
  • Measure the resistance from pin-A on the harness side of the IVS connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness to the IVS.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistance from pin-25 on the harness side of the OEM connector to engine block ground.
  • Measure the resistance from pin-26 on the harness side of the OEM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position and completely depress and release the accelerator pedal four to five times.
  • Turn the keyswitch to the OFF position for 5 seconds.
  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 431 is inactive.
OK NOT OK

Fault Code 431 inactive

Return to troubleshooting steps, or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Jul-2012


FAULT CODE 432 - Accelerator Pedal Circuit (ISS)

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault status. |
 | STEP 1A. Perform the fault code disable procedure. | Fault Code 432 still active?
 | STEP 1B. Check for idle validation fault codes. | Fault Code 431 inactive?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and the ECM connectors. | No damaged pins?
 | STEP 2B. Check the resistance. | 1500 to 3000 ohms (released); 250 to 1500 ohms (depressed)?
 | STEP 2B-1. Check the resistance of the accelerator position sensor. |
 | STEP 2B-2. Check the resistance in the OEM harness. |
 | STEP 2C. Check for an open circuit. | 2000 to 3000 ohms?
 | STEP 2C-1. Check for an open circuit of the accelerator position sensor supply and return circuit. |
 | STEP 2C-2. Check for an open circuit in the OEM harness. |
 | STEP 2D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D-1. Check for a short circuit to ground in the accelerator position sensor. |
 | STEP 2D-2. Check for a short circuit to ground in the OEM harness. |
 | STEP 2E. Check for a short circuit from pin-to-pin in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 432 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault status.

Guided Step 1A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch ON.
  • Connect all components.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal to the full-fuel position, and release it completely three times.
  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 432 still active?

Replace the accelerator pedal assembly.

Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Check for idle validation fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect all components.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 431 inactive?

Fault Codes inactive?

Go to 2A

Reference Fault Code 431.

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever, has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-250 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance.

  • Measure the resistance from pin-29 to pin-30 of the OEM harness connector with the accelerator pedal in the released (idle) position.
  • Repeat the measurement with the accelerator pedal in the depressed (full-fuel) position. Resistance with the pedal released must be at least 1000 ohms greater than when it is depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

1500 to 3000 ohms (released); 250 to 1500 ohms (depressed)?

Released value must be at least 1000 ohms greater than depressed value.

Repair the circuit.

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Check the resistance of the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance of the throttle position sensor.

  • Measure the resistance from pin-C to pin-B on the sensor side of the accelerator position sensor connector with the accelerator pedal in the released (idle) position.
  • Repeat the above measurement with the accelerator pedal in the depressed (full-fuel) position. Resistance when the pedal is released must be at least 1000 ohms greater than when it is depressed.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

1500 to 3000 ohms (released); 250 to 1500 ohms (depressed)?

Released value at least 1000 ohms greater than depressed value

Replace the accelerator pedal assembly.

Refer to the OEM service manual.

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check the resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance in the OEM harness.

  • Measure the resistance from pin-29 of the OEM harness connector to pin-C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin-30 of the OEM harness connector to pin-B on the harness side of the accelerator position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-29 to pin 19 of the OEM harness connector (the accelerator pedal can be either released or depressed).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

2000 to 3000 ohms?

Repair the circuit.

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for an open circuit of the accelerator position sensor supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit of the throttle position sensor supply and return circuit.

  • Measure the resistance from pin-C to pin-A on the sensor side of the accelerator position sensor connector (the accelerator pedal can be either released or depressed).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

2000 to 3000 ohms?

Replace the accelerator pedal assembly.

Refer to the OEM service manual.

Go to 2C-2

Go to 3A

Guided Step 2C-2 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check the resistance in the OEM harness from the ECM.

  • Measure the resistance from pin-29 of the OEM harness connector to pin-C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin-19 of the OEM harness connector to pin-A on the harness side of the accelerator position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the accelerator position sensor.
  • Disconnect the OEM harness from ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-29 in the OEM harness to the engine block ground.
  • Measure the resistance from pin-30 in the OEM harness to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair the circuit.

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check for a short circuit to ground in the accelerator position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the throttle position sensor.

  • Measure the resistance from pin-B on the sensor side of the accelerator position sensor connector to the engine block ground.
  • Measure the resistance from pin-C on the sensor side of the accelerator position sensor connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the accelerator pedal assembly.

Refer to the OEM service manual.

Go to 2D-2

Go to 3A

Guided Step 2D-2 - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance from pin-29 of the OEM harness to the engine block ground.
  • Measure the resistance from pin-30 of the OEM harness to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for short circuit from pin-to-pin in the OEM harness.

  • Measure the resistance from pin-29 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin-30 in the OEM harness to all other pins in the connector.
  • Measure the resistance from pin-19 in the OEM harness to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Depress the accelerator pedal to the full-fuel position, and release it completely three times.
  • Start the engine, and let idle for 1 minute.
  • Drive the vehicle.
  • Verify Fault Code 432 is inactive.
OK NOT OK

Fault Code 432 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Jul-2012


FAULT CODE 433 - Intake Manifold Pressure Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold pressure sensor. |
 | STEP 1A. Inspect the sensor circuit for tampering. | No tampering?
 | STEP 1B. Inspect the engine harness and the sensor connectors. | No damaged pins?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the harness and the ECM connectors. | No damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the return line. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 433 inactive?
 | STEP 3B. Clear the inactive fault code. | All faults cleared?

Guided Step 1 - Check the intake manifold pressure sensor.

Guided Step 1A - Inspect the sensor circuit for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the sensor circuit for tampering.

  • Check the intake manifold pressure sensor and the engine harness for external wires or damaged harness braiding.
OK NOT OK

No tampering?

Remove and record tampering.

If tampering has occurred, repair the circuit, and record the tampering.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the engine harness and the sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Inspect the harness and the sensor connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

No damaged pins?

A damaged connection has been detected in the sensor connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the damaged pins

  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the harness and the ECM connectors for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

OK NOT OK

No damaged pins?

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the ECM, whichever, has the damaged pins.

Repair or replace the engine harness or ECM, whichever, has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-250 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short from pin-to-pin.

  • Measure the resistance from pin-45 in the engine harness connector to all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-45 in the engine harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the RETURN wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from pin-19 of the engine harness connector to pin-B of the intake manifold pressure sensor connector on the harness side.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

Replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 433 is inactive.
OK NOT OK

Fault Code 433 inactive?

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault code.
OK NOT OK

All faults cleared.

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Jul-2012


FAULT CODE 441 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male AMP™/Cannon™ Metri-Pack™/Deutsch™ test lead and Part Number 3822917 - female AMP™/Cannon™ Metri-Pack™/Deutsch™ test lead
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | No damaged connections?
 | STEP 1B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC ((+) 12 volt system) At least (+) 24-VDC ((+) 24 volt system) During cranking: At least (+) 6.2-VDC((+) 12 volt system) At least (+) 12-VDC((+) 24 volt system)?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the fuse connections. | Fuses installed correctly?
 | STEP 2B. Check the fuse. | Fuses not blown?
 | STEP 2C. Inspect the 23-pin power connector. | No damaged pins or loose connections?
 | STEP 2D. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2E. Check for an add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable connections for the following:

  • Corrosion
  • Loose connection.
OK NOT OK

No damaged connections?

Repair the damaged connections.

Tighten the battery connections, and clean the battery terminals. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Normal conditions:

  • At least (+) 12-VDC ((+) 12 volt system)
  • At least (+) 24-VDC ((+) 24 volt system)

During cranking:

  • At least (+) 6.2-VDC ((+) 12 volt system)
  • At least (+) 12-VDC ((+) 24 volt system)

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the fuse connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 7.5-amp fuses and 10 amp-fuse from the engine harness.

Action

Check if the three 7.5-amp fuses and the 10-amp fuse are installed correctly.
OK NOT OK

Fuses installed correctly?

Install fuses correctly.

Install fuses correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuse.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the 7.5-amp fuses and 10-amp fuse from the engine harness.

Action

Check if the three 7.5-amp fuses and the 10-amp fuse are blown.
OK NOT OK

Fuses not blown?

Replace the fuses.

019-198.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the 23-pin power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the battery at the 23-pin Deutsch™ connector.

Action

Inspect the 23-pin connectors on both the battery side and the harness side for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins or loose connections?

Repair or replace the 23-pin connector. Refer to Procedure 019-223 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the battery supply at the 23-pin Deutsch™ connector.

Action

Check for an open circuit in the battery supply and return circuits.

  • Measure the resistance from pin-B, pin-C, pin-D, pin-M, and pin-S to the positive (+) terminal of the battery.
  • Measure the resistance from pin-E, pin-F, pin-H, pin-P, and pin-W the negative (-) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Repair or replace the harness.

Refer to the OEM service manual.

Go to 2E

Go to 4A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine the wire(s) for damaged insulation or installation error that can cause SUPPLY wire to be shorted to the engine block ground.
OK NOT OK

No damaged wires?

Repair the damaged wiring. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check for short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the 23-pin Deutsch™ connector.

Action

Check for a short circuit.

  • Measure the resistance from pin-38 to all other pins in the engine harness.
  • Measure the resistance from pin-39 to all other pins in the engine harness.
  • Measure the resistance from pin-40 to all other pins in the engine harness.
  • Measure the resistance from pin-20 to all other pins in the engine harness.
  • Measure the resistance from pin-28 to all other pins in the engine harness.
  • Measure the resistance from pin-29 to all other pins in the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect engine harness from the 23-pin Deutsch™ connector.

Action

Check for an open circuit.

  • Measure the resistance, on the engine harness side, from pin-38 of the ECM connector to pin-D of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin-39 of the ECM connector to pin-B of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin-40 of the ECM connector to pin-C of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin-20 of the ECM connector to pin-E of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin-28 of the ECM connector to pin-F of the 23-pin connector.
  • Measure the resistance, on the engine harness side, from pin-29 of the ECM connector to pin-H of the 23-pin connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM.
  • Disconnect engine harness from the 23-pin Deutsch™ connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from pin-38 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin-39 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin-40 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin-20 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin-28 of the ECM connector on the engine harness to chassis ground.
  • Measure the resistance from pin-29 of the ECM connector on the engine harness to chassis ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault Code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify that Fault Code 441 is inactive.
OK NOT OK

Fault Code 441 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive Fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 11-Jul-2012


FAULT CODE 442 - Unswitched Battery Supply Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™/Deutsch™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check the battery voltage. | Less than (+) 32-VDC?
 | STEP 1B. Check the battery ground. | Less than 10 ohms?
 | STEP 1C. Check the alternator. | Alternator functioning normally?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 442 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the engine harness from the battery at the positive (+) 23-pin Deutsch™ connector.

Action

Check the battery voltage.

  • Measure the battery voltage from pin-B of the 23-pin OEM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Less than (+) 32-VDC?

Install the battery system correctly. Refer to the OEM service manual.

Go to 1B

Go to 2A

Guided Step 1B - Check the battery ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the engine harness from the battery at 23-pin Deutsch™ connector.

Action

Check the battery ground.

  • Measure the resistance from pin-E of the 23-pin OEM connector to ground.
  • Measure the resistance from pin-F of the 23-pin OEM connector to ground.
  • Measure the resistance from pin-H of the 23-pin OEM connector to ground.
  • Measure the resistance from pin-P of the 23-pin OEM connector to ground.
  • Measure the resistance from pin-W of the 23-pin OEM connector to ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator for normal operation.
OK NOT OK

Alternator functioning normally?

Repair or replace the alternator.

Refer to the OEM service manual.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Verify Fault Code 442 is inactive.
OK NOT OK

Fault Code 442 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Jul-2012


FAULT CODE 443 - Accelerator Position Sensor Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822917 - female AMP™/Metri-Pack™/Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the accelerator position sensor. |
 | STEP 1A. Inspect OEM harness and sensor connectors. | No damaged pins?
 | STEP 1B. Check for active fault codes. | Fault Code 443 remains active?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and ECM connectors. | No damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to a voltage source. | Less than (+) 1.0-VDC?
STEP 3. | Check the ECM voltage. |
 | STEP 3A. Measure the sensor supply voltage from the ECM. | (+) 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 443 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the accelerator position sensor.

Guided Step 1A - Inspect the OEM harness and sensor connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Inspect the harness and the sensor connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Replace the damaged pins.

Repair or replace the OEM harness or the accelerator position sensor, whichever, has damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the accelerator position sensor. Refer to the equipment manufacturer's troubleshooting and repair manual.
  • Install the appropriate connector seal if it is damaged or missing.

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the accelerator position sensor.

Action

Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 443 remains active?

Replace the accelerator pedal assembly or the accelerator position sensor.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness and the ECM connectors.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the OEM harness or ECM, whichever has the damaged pins.

  • Repair the OEM harness. Refer to Procedure 019-250 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from pin-29 of the OEM harness connector to pin-C on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin-19 of the OEM harness connector to pin-A on the harness side of the accelerator position sensor connector.
  • Measure the resistance from pin-30 of the OEM harness connector to pin-B on the harness side of the accelerator position sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 10 ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to a chassis ground.

  • Measure the resistance from pin-29 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin-19 in the OEM harness connector to engine block ground.
  • Measure the resistance from pin-30 in the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the accelerator position sensor.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from pin-29 to all other pins in the OEM harness connector.
  • Measure the resistance from pin-19 to all other pins in the OEM harness connector.
  • Measure the resistance from pin-30 to all other pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the ECM.
  • Connect the OEM harness to the accelerator position sensor.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage from pin-29 in the OEM harness connector to engine block ground.
  • Measure the voltage from pin-19 in the OEM harness connector to engine block ground.
  • Measure the voltage from pin-30 in the OEM harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Less than 1.0-VDC?

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM voltage.

Guided Step 3A - Measure the sensor supply voltage from the ECM

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness from the ECM.

Action

Measure the voltage out of the ECM.

  • Measure the voltage from pin-29 to pin-19 on the ECM OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

(+) 4.75 to 5.25-VDC?

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine, and let idle for 1 minute.
  • Depress and release the accelerator pedal several times to be sure the ECM is getting an accelerator signal.
  • Fault Code 443 inactive?
OK NOT OK

Fault Code 443 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 12-Jul-2012


FAULT CODE 517 - Fuel Pump Valve Feedback Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check to see if fault code is active at engine start-up. | Fault Code 517 inactive? Multiple active fault codes?
STEP 2. | Check the voltage supply. |
 | STEP 2A. Check the battery voltage supply for low or high voltage during cranking. | 6.5 to 18-VDC (12 volt system); 8 to 18-VDC (during cranking)?
STEP 3. | Check the fuel drain restriction. |
 | STEP 3A. Check the fuel drain line restriction. | No kinks, tie strap constrictions, or brackets pressing on lines. Specification less than 69 kPa [10 psi]?
STEP 4. | Perform a diagnostic check using the diagnostic tool. |
 | STEP 4A. Install the fuel pump diagnostic tool, Part Number 3163834, or equivalent, to check the operation of the fuel pump. | Engine starts and operates in idle mode?
STEP 5. | Check the engine harness. |
 | STEP 5A. Inspect the engine harness, fuel pump, and engine control module (ECM) connector pins. | No damaged pins?
 | STEP 5B. Check the fuel pump supply resistance. | Less than 0.2 ohm?
 | STEP 5C. Check the fuel pump ground circuit resistance. | Less than 0.2 ohm?
STEP 6. | Check the fuel pump wiring. |
 | STEP 6A. Inspect the fuel pump solenoid wire leads. | No loose or frayed wires?
STEP 7. | Check for sources of electrical noise. |
 | STEP 7A. Inspect the engine, ECM, and alternator ground connections. | No loose connections?
 | STEP 7B. Inspect the original equipment manufacturer (OEM) power distribution box fuses and wires. | No loose wires or shorted plugs?
 | STEP 7C. Inspect the alternator. | No fault code occurrence?
 | STEP 7D. Check the lift pump resistance. | 0.1 to 2.0 ohms (12 volt system); 0.1 to 4.0 ohms (24 volt system)?
 | STEP 7E. Check the OEM wiring connections. | Battery voltage?
 | STEP 7F. Inspect the vehicle accessories. | No interference from accessories?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 517 inactive?
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check to see if fault code is active at engine start-up.

Conditions

  • Turn keyswitch ON.

Action

Check to see if fault code is active at engine start-up.

  • Use INSITE™ electronic service tool to read the fault codes.
OK NOT OK

Fault Code 517 inactive Multiple active fault codes?

Fault Code 517 active.

Applicable fault code(s)

Go to 2A

Guided Step 2 - Check voltage supply.

Guided Step 2A - Check the battery voltage supply for low or high voltage during cranking.

Conditions

  • Disconnect the engine harness from the fuel pump.
  • Turn keyswitch ON.

Action

Measure the supply voltage to the fuel pump while cranking the engine.

  • Measure the supply voltage from pin-7 of the fuel pump harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

6.5 to 18-VDC (12 volt system); 8 to 18-VDC (during cranking)

Go to 3A

Go to 8A

Guided Step 3 - Check the fuel drain restriction.

Guided Step 3A - Check the fuel drain line restriction.

Conditions

  • Install gage on the return fitting at the rear of the head.
  • Turn keyswitch ON.

Action

Check the fuel drain line from the fitting at the rear of the head.

  • Use the following procedure to inspect the fuel drain line for restrictions such as kinks, tie strap constrictions, or brackets pressing on lines in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193. Refer to Procedure 006-012 in Section 6.
OK NOT OK

No kinks, tie strap constrictions, or brackets pressing on linesLess than 69 kPa [10 psi]?

Greater than 69 kPa [10 psi]?

Use the following procedure to repair or replace the restricted line in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193. Refer to Procedure 006-012 in Section 6.

Go to 4A

Go to 8A

Guided Step 4 - Perform a diagnostic check using the diagnostic tool.

Guided Step 4A - Install the fuel pump diagnostic tool, Part Number 3163834, or equivalent, to check the operation of the fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Install the fuel pump diagnostic tool, Part Number 3163834, or equivalent, to check the operation of the fuel pump.

  • Use the following procedure for the installation and testing procedures. Refer to Procedure 005-014 in Section 5.

Make sure air has been vented from the system before using the diagnostic tool.

If replacing the injection pump, perform a lift pump volume test at the fuel filter outlet for twenty-five seconds by bumping the starter. If volume is greater than 1.33 liter [45 oz], the low pressure fuel system is operating correctly.

OK NOT OK

Engine starts and operates in idle mode?

Engine does not start.

Replace injection pump.

Pre-authorization is required to replace the injection pump if pump is under warranty.

Go to 5A

Go to 8A

Guided Step 5 - Check the engine harness.

Guided Step 5A - Inspect the engine harness, fuel pump, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the fuel pump.
  • Flush and clean the connector pins using electrical contact cleaner, Part Number 3824510.

Action

Inspect the engine harness, fuel pump, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-185 or Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5B

Go to 8A

Guided Step 5B - Check the fuel pump supply resistance.

Conditions

  • Disconnect the fuel pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the fuel pump supply resistance.

  • Measure the resistance from pin-7 of the fuel pump harness connector to the positive (+) battery terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

Greater than 0.2 ohm.

Inspect the relay and power supply fuses and replace if necessary.

Go to 5C

Go to 8A

Guided Step 5C - Check the fuel pump ground circuit resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect fuel pump from the engine harness.
  • Disconnect the negative (-) battery terminal from the battery post.

Action

Check the fuel pump ground circuit resistance.

  • Measure the resistance from pin-6 of the fuel pump harness connector to ground side, negative (-) battery ring terminal.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Less than 0.2 ohm?

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-185 or Refer to Procedure 019-197 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 8A

Guided Step 6 - Check the fuel pump wiring.

Guided Step 6A - Inspect the fuel pump solenoid wire leads.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump solenoid wire leads.
OK NOT OK

No loose or frayed wires?

Go to 7A

Go to 8A

Guided Step 7 - Check for sources of electrical noise.

Guided Step 7A - Inspect the engine, ECM, and alternator ground connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine, ECM, and alternator ground connections.

  • Disconnect and clean any loose connections found.

When checking ground connections, use a dedicated ground strap. A measurement of 2 to 3 ohms should exist between engine block to chassis frame, engine block to battery negative post, and chassis frame to battery negative post.

OK NOT OK

No loose connections?

Clean and tighten all loose connections.

Go to 7B

Go to 8A

Guided Step 7B - Inspect the OEM power distribution box fuses and wires.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuses and wires in the OEM distribution box.
OK NOT OK

No loose wires or shorted plugs?

Repair damaged or loose wiring and replace shorted plugs.

Go to 7C

Go to 8A

Guided Step 7C - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator.

  • Check to make sure the alternator voltage is to specification. Refer to the OEM service manual for voltage specification.
  • Disconnect the alternator output (remove the drive belt) and check for a fault code occurrence.
OK NOT OK

No fault code occurrence?

Charge or replace alternator.

Use the following procedure in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193. Refer to Procedure 013-001 in Section 13.

Go to 7D

Go to 8A

Guided Step 7D - Check the lift pump resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump engine harness connector from the lift pump.

Action

Check the lift pump resistance.

  • Measure the resistance from pin-1 to pin-2 of the lift pump connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

0.1 to 2.0 ohms (12 volt system); 0.1 to 4.0 ohms (24 volt system)

Replace the lift pump.

Use the following procedure in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193. Refer to Procedure 005-045 in Section 5.

Go to 7E

Go to 8A

Guided Step 7E - Check the OEM wiring connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM A harness connector from the ECM.
  • Disconnect the 23-pin OEM pass-through connector.
  • Run a wire from the keyswitch input line (pin-A of the 23-pin OEM connector, engine harness side) directly to the battery positive (+) post.
  • Turn keyswitch ON.

Action

Check the keyswitch input line.

  • Measure the voltage from pin-5 of the ECM A harness connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

OK NOT OK

Battery voltage?

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 7F

Go to 8A

Guided Step 7F - Inspect the vehicle accessories.

Conditions

  • Turn keyswitch OFF.

Action

Check any accessories in the vehicle for electrical noise interference.
OK NOT OK

No interference from accessories?

Correct electrical interference.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and road test for 30 minutes.
  • Verify Fault Code 517 is inactive.
OK NOT OK

Fault Code 517 inactive?

Fault Code 517 active?

Return to the troubleshooting steps, or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-Jan-2013


FAULT CODE 599 - Auxiliary Commanded Dual Output Shutdown - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 599. | Active or inactive counts of Fault Code 599?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 599.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 599?
YES NO

The engine protection limit for the original equipment manufacturer (OEM) supplied auxiliary device has been exceeded. See equipment manufacturer service information.

No Repair

See equipment manufacturer service information.

Repair complete.

Last Modified: 10-Jul-2015


FAULT CODE 613 - Engine Misfire Detection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify engine misfire. |
 | STEP 1A. Perform cylinder performance test. | Fault Code 613 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 613 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify engine misfire.

Guided Step 1A - Perform cylinder performance test.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Refer to the appropriate INSITE™ User's Manual.
OK NOT OK

Fault Code 613 inactive?

Reference the appropriate symptom tree in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify that Fault Code 613 is inactive.
OK NOT OK

Fault Code 613 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jul-2012


FAULT CODE 621 - Engine Misfire Detection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify engine misfire. |
 | STEP 1A. Perform cylinder performance test. | Fault Code 621 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 621 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify engine misfire.

Guided Step 1A - Perform cylinder performance test.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Refer to the appropriate INSITE™ user's manual.
OK NOT OK

Fault Code 621 inactive?

Reference the appropriate symptom tree in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify that Fault Code 621 is inactive.
OK NOT OK

Fault Code 621 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jul-2012


FAULT CODE 622 - Engine Misfire Detection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify engine misfire. |
 | STEP 1A. Perform cylinder performance test. | Fault Code 622 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 622 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify engine misfire.

Guided Step 1A - Perform cylinder performance test.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Refer to the appropriate INSITE™ user's manual.
OK NOT OK

Fault Code 622 inactive?

Reference the appropriate symptom tree in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify that Fault Code 622 is inactive.
OK NOT OK

Fault Code 622 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jul-2012


FAULT CODE 623 - Engine Misfire Detection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify engine misfire. |
 | STEP 1A. Perform cylinder performance test. | Fault Code 623 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 623 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify engine misfire.

Guided Step 1A - Perform cylinder performance test.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Refer to the appropriate INSITE™ user's manual.
OK NOT OK

Fault Code 623 inactive?

Reference the appropriate symptom tree in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify that Fault Code 623 is inactive.
OK NOT OK

Fault Code 623 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jul-2012


FAULT CODE 624 - Engine Misfire Detection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify engine misfire. |
 | STEP 1A. Perform cylinder performance test. | Fault Code 624 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 624 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify engine misfire.

Guided Step 1A - Perform cylinder performance test.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Refer to the appropriate INSITE™ user's manual
OK NOT OK

Fault Code 624 inactive?

Reference the appropriate symptom tree in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify that Fault Code 624 is inactive.
OK NOT OK

Fault Code 624 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jul-2012


FAULT CODE 625 - Engine Misfire Detection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify engine misfire. |
 | STEP 1A. Perform cylinder performance test. | Fault Code 625 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 625 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify engine misfire.

Guided Step 1A - Perform cylinder performance test.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Refer to the appropriate INSITE™ user's manual.
OK NOT OK

Fault Code 625 inactive?

Reference the appropriate symptom tree in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify that Fault Code 625 is inactive.
OK NOT OK

Fault Code 625 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jul-2012


FAULT CODE 626 - Engine Misfire Detection

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify engine misfire. |
 | STEP 1A. Perform cylinder performance test. | Fault Code 626 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 626 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Verify engine misfire.

Guided Step 1A - Perform cylinder performance test.

Conditions

  • Turn keyswitch ON.

Action

Perform cylinder performance test.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Refer to the appropriate INSITE™ user's manual.
OK NOT OK

Fault Code 626 inactive

Reference the appropriate symptom tree in the Troubleshooting and Repair Manual, ISB Engine, Bulletin 3666193.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Verify that Fault Code 626 is inactive.
OK NOT OK

Fault Code 626 inactive?

Return to the troubleshooting steps, or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All faults cleared?

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jul-2012


FAULT CODE 2559 - Transmission ECU to ECM Communication - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 2559 active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration matches the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the service data link harness. | 50 to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM data link harness. | 50 to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 2559 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with the INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

–

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2559 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

NOTE: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration matches the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the service data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the data link (+) wire and the data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the data link (+) wire and the data link (-) wire on the appropriate Cummins® ECM OEM connection to the data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the data link (+) wire and the data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the data link (+) and the data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2559 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Aug-2013


INDEX
80-fcmfc.htm

80-fc111.htm

80-t05-111.htm

80-fc115.htm

80-fc115vp30.htm

80-t05-115vp30.htm

80-fc115vp44.htm

80-t05-115vp44.htm

80-fc121.htm

80-t05-121.htm

80-fc122.htm

80-t05-122.htm

80-fc123.htm

80-t05-123.htm

80-fc124.htm

80-t05-124.htm

80-fc131.htm

80-t05-131.htm

80-fc132.htm

80-t05-132.htm

80-fc135.htm

80-t05-135.htm

80-fc141.htm

80-fc141sn.htm

80-t05-141sn.htm

80-fc141sw.htm

80-t05-141sw.htm

80-fc144.htm

80-t05-144.htm

80-fc146.htm

80-t05-146.htm

80-fc153.htm

80-t05-153.htm

80-fc154.htm

80-t05-154.htm

80-fc186.htm

80-t05-186.htm

80-fc211.htm

80-t05-211.htm

80-fc234.htm

80-t05-234.htm

80-fc261.htm

80-t05-261.htm

80-fc264.htm

80-t05-264.htm

80-fc278.htm

80-fc278ford.htm

80-t05-278ford.htm

80-fc278corp.htm

80-t05-278corp.htm

80-fc283.htm

80-t05-283.htm

80-fc284.htm

80-t05-284.htm

80-fc291.htm

80-t05-291.htm

80-fc334.htm

80-t05-334.htm

80-fc352.htm

80-t05-352.htm

80-fc362.htm

80-t05-362.htm

80-fc363.htm

80-t05-363.htm

80-fc364.htm

80-t05-364.htm

80-fc365.htm

80-t05-365.htm

80-fc366.htm

80-t05-366.htm

80-fc367.htm

80-t05-367.htm

80-fc368.htm

80-t05-368.htm

80-fc369.htm

80-t05-369.htm

80-fc372.htm

80-t05-372.htm

80-fc373.htm

80-t05-373.htm

80-fc374.htm

80-t05-374.htm

80-fc375.htm

80-t05-375.htm

80-fc376.htm

80-t05-376.htm

80-fc377.htm

80-t05-377.htm

80-fc381.htm

80-t05-381.htm

80-fc382.htm

80-t05-382.htm

80-fc383.htm

80-t05-383.htm

80-fc386.htm

80-t05-386.htm

80-fc387.htm

80-t05-387.htm

80-fc391.htm

80-t05-391.htm

80-fc418.htm

80-t05-418.htm

80-fc429.htm

80-t05-429.htm

80-fc431.htm

80-t05-431.htm

80-fc432.htm

80-t05-432.htm

80-fc433.htm

80-t05-433.htm

80-fc441.htm

80-t05-441.htm

80-fc442.htm

80-t05-442.htm

80-fc443.htm

80-t05-443.htm

80-fc517.htm

80-t05-517.htm

80-fc599.htm

80-t05-599.htm

80-fc613.htm

80-t05-613.htm

80-fc621.htm

80-t05-621.htm

80-fc622.htm

80-t05-622.htm

80-fc623.htm

80-t05-623.htm

80-fc624.htm

80-t05-624.htm

80-fc625.htm

80-t05-625.htm

80-fc626.htm

80-t05-626.htm

80-fc2559.htm

80-t05-2559.htm